untitled

SQL*Codes, explaining the Oracle
error codes and messages

Companion file to SQL*XL

www.oraxcel.com


untitled

SQL*XL provides an easy to use bridge between Excel and Oracle databases. SQL*XL adds a new menu item to Excel so Oracle access appears to be native. Through comprehensive dialogs you have interaction with the database.

From Oracle...
SQL is taken from a dialog box, spreadsheet or file. The data is put in the spreadsheet where you want it.

To Oracle...
A full spreadsheet full of data can be inserted with one click. When constraints are violated you are prompted with the full Oracle error message. Transaction control lets you rollback or commit the changes.

Update Oracle...
Once data is fetched into Excel, SQL*XL allows you to edit it in the spreadsheet. When you are done, the changes can be updated in Oracle with one mouse click. Optionally SQL*XL will asks you to confirm each individual change.

More information available on the webiste: www.oraxcel.com

Oraxcel homepage: www.oraxcel.com
Oraxcel info: info@oraxcel.com


DBA-00073

DBA-00073warning: name created with compilation errors

Cause:The package, package body, procedure, or function could not be created because there were code errors.

Action:Enter the SHOW ERRORS command and correct the listed compilation errors.


DBA-00100

DBA-00100invalid SPOOL filename

Cause:When using the SPOOL command, the name of a file that already existswas specified.

Action:Specify a valid name for a file that does not currently exist.


DBA-00101

DBA-00101extraneous text at end of command

Cause:There were unrecognized commands or other text on the command line.

Action:Check the syntax of the command and issue the command again.


DBA-00102

DBA-00102missing LOG keyword

Cause:The LOG keyword was missing from the ARCHIVE LOG command.

Action:Check the syntax of the command and issue the command again.


DBA-00103

DBA-00103illegal ARCHIVE LOG option

Cause:An option specified was not LIST, STOP, START, NEXT, ALL, a number, or a filename in the ARCHIVE LOG command.

Action:Check the syntax of the command and issue the command again.


DBA-00104

DBA-00104illegal RECOVER option

Cause:An option specified was not DATABASE, MANUAL, UNTIL, TABLESPACE, or DATAFILE in the RECOVER command.

Action:Check the syntax of the command and issue the command again.


DBA-00105

DBA-00105invalid INSTANCE name

Cause:An invalid SQL*Net CONNECT string was specified for the instance name.

Action:Refer to the SQL*Net documentation for a complete description of SQL*Net CONNECT strings.


DBA-00106

DBA-00106invalid ECHO switch

Cause:An invalid option for the SET ECHO command was specified.

Action:Use either ON or OFF as an option for the SET ECHO command.


DBA-00107

DBA-00107invalid TERMOUT switch

Cause:An invalid option for the SET TERMOUT command was specified.

Action:Use either ON or OFF as an option for the SET TERMOUT command.


DBA-00108

DBA-00108invalid TIMING switch

Cause:An invalid option for the SET TIMING command was specified.

Action:Use either ON or OFF as an option for the SET TIMING command.


DBA-00109

DBA-00109invalid CYCLE value

Cause:An invalid value for the SET CYCLE command was specified.

Action:The SET CYCLE command must use an integer between 1 and 3600.


DBA-00110

DBA-00110illegal SET option

Cause:An invalid option for the SET command was specified.

Action:Check the syntax of the SET command in Oracle7 Server Utilities and issue the command again.


DBA-00111

DBA-00111illegal SHOW option

Cause:An invalid option for the SHOW command was specified.

Action:Check the syntax of the SHOW command in Oracle7 Server Utilities and issue the command again.


DBA-00113

DBA-00113invalid PFILE name

Cause:The specified PFILE name is not recognized.

Action:Specify a legal PFILE name.


DBA-00114

DBA-00114invalid database name

Cause:The specified database name is not recognized.

Action:Specify a legal database name.


DBA-00115

DBA-00115unexpected end of command

Cause:An option was specified without any arguments. For example:

SQLDBA> STARTUP OPEN PFILE

Action:Check the syntax of the command and enter the command again with the appropriate arguments for options that require values.


DBA-00116

DBA-00116illegal SHUTDOWN option

Cause:An option was specified that was not NORMAL, IMMEDIATE, or ABORT for the SHUTDOWN command.

Action:Check the syntax of the command and issue the command again.


DBA-00117

DBA-00117invalid tablespace name

Cause:The specified tablespace name was not recognized.

Action:Specify a legal tablespace name.


DBA-00118

DBA-00118invalid process identifier or invalid statistics class

Cause:Something other than a number for a process identifier, or an invalid class was specified after the MONITOR STATISTICS command.

Action:Specify only numbers as process identifiers or specify a valid class for the MONITOR STATISTICS command.


DBA-00119

DBA-00119illegal STARTUP option

Cause:An option was specified that was not DBA, PFILE, EXCLUSIVE, SHARED, MOUNT, OPEN, RECOVER, or NOMOUNT for the STARTUP command.

Action:Check the syntax of the command and issue the command again.


DBA-00120

DBA-00120invalid STOPONERROR switch

Cause:An invalid option was specified for the SET STOPONERROR command.

Action:Use either ON or OFF as an option for the SET STOPONERROR command.


DBA-00121

DBA-00121illegal MONITOR option

Cause:An illegal option was specified for the MONITOR command.

Action:Check the syntax of the MONITOR command in Oracle7 Server Utilities and issue the command again.


DBA-00122

DBA-00122invalid SET numeric parameter

Cause:A character or an invalid value was specified when a number was expected as a value for a SET command option.

Action:Check the syntax of the command, use an appropriate number for the option, and enter the command again.


DBA-00123

DBA-00123invalid tablespace name list

Cause:An invalid string was specified as one of the values in the list of tablespaces in the ARCHIVE LOG command. For example, '"' is an invalid string.

Action:Check the syntax of the command, use valid tablespace names for all names in the list, and enter the command again.


DBA-00124

DBA-00124invalid ARCHIVE destination

Cause:The specified ARCHIVE destination was not recognized.

Action:Specify a legal ARCHIVE destination.


DBA-00125

DBA-00125integer value overflow

Cause:A numeric value was specified that was too large.

Action:Use a smaller number.


DBA-00126

DBA-00126invalid VERIFY switch

Cause:The VERIFY switch was not recognized.

Action:Specify a legal VERIFY switch.


DBA-00127

DBA-00127invalid combination of STARTUP options

Cause:The specified options of the STARTUP command cannot be used simultaneously. For example, the following command is not valid:

SQLDBA> STARTUP MOUNT OPEN testdb

Action:Check the syntax of the STARTUP command in Oracle7 Server Utilities for options that can be used together.


DBA-00128

DBA-00128invalid DEBUG switch

Cause:The DEBUG switch was not recognized.

Action:Specify a legal DEBUG switch.


DBA-00129

DBA-00129value out of range (1 - num)

Cause:The specified value was out of range. The valid range is given by theerror message.

Action:Use a number within the range specified by this error.


DBA-00131

DBA-00131invalid ARCHIVE TO device

Cause:The specified ARCHIVE TO device was not recognized.

Action:Specify a legal ARCHIVE TO device.


DBA-00132

DBA-00132null hostname/password specified

Cause:hostname/password was not specified.

Action:Specify the correct hostname/password.


DBA-00133

DBA-00133invalid datafile list

Cause:An invalid string was entered as one of the values in the list of datafiles in the ARCHIVE LOG command. For example, '"' is an invalid string.

Action:Check the syntax of the command, use valid datafile names for all names in the list, and enter the command again.


DBA-00134

DBA-00134invalid AUTORECOVERY switch

Cause:An invalid option was specified for the SET AUTORECOVERY command.

Action:Use either ON or OFF as options for the SET AUTORECOVERY command.


DBA-00136

DBA-00136bad variable specification

Cause:A variable was incorrectly specified using the VARIABLE command.

Action:Check the syntax of the command and issue the command again.


DBA-00137

DBA-00137syntax error in PL/SQL Block

Cause:The PL/SQL block contains a syntax error.

Action:Correct the syntax error.


DBA-00139

DBA-00139invalid ALTER DATABASE option

Cause:The specified ALTER DATABASE option was not recognized.

Action:Specify a legal option.


DBA-00140

DBA-00140invalid COMPATIBILITY switch

Cause:The specified COMPATIBILITY switch was not recognized.

Action:Specify a legal COMPATIBILITY switch.


DBA-00141

DBA-00141invalid RETRIES value

Cause:The specified RETRIES value was not recognized.

Action:Specify a legal RETRIES value.


DBA-00142

DBA-00142cannot recognize object type, owner or name

Cause:The specified object type, owner, or name was not recognized.

Action:Specify a legal object type, owner or name.


DBA-00143

DBA-00143variable has not been defined

Cause:The specified variable was not recognized.

Action:Specify an existing variable.


DBA-00144

DBA-00144invalid object type for DESCRIBE

Cause:The specified object type was not TABLE, VIEW, or PROCEDURE.

Action:Check that the object is a table, view, or procedure. If so, check that you specified the correct name and try again. If not, you cannot DESCRIBEthe object.


DBA-00145

DBA-00145invalid object name for DESCRIBE

Cause:The specified table, view, stored procedure or function was not recognized.

Action:Check spelling and specify an existing table, view, stored procedure,or function.


DBA-00146

DBA-00146invalid HISTORY value

Cause:The specified HISTORY value was not recognized.

Action:Specify a legal HISTORY value.


DBA-00147

DBA-00147invalid LINES value

Cause:The specified LINES value was not recognized.

Action:Specify a legal LINES value.


DBA-00148

DBA-00148invalid TERM switch (use either PAGE or NOPAGE)

Cause:The specified value was not recognized.

Action:Specify a legal value.


DBA-00149

DBA-00149invalid SERVEROUTPUT switch

Cause:The specified value was not recognized.

Action:Specify a legal value.


DBA-00150

DBA-00150invalid FLAGGER switch

Cause:The specified value was not recognized.

Action:Specify a legal value.


DBA-00301

DBA-00301cannot SET INSTANCE while connected to a database

Cause:SET INSTANCE was used while currently connected to a database.

Action:To change the current instance, DISCONNECT from the database before using SET INSTANCE.


DBA-00302

DBA-00302not connected to a database

Cause:The requested operation required being connected to the database.

Action:CONNECT to the database using a valid username and password before retrying the operation.


DBA-00304

DBA-00304input file I/O error num - input aborted

Cause:A command file used as input to SQL*DBA is corrupt or invalid.

Action:Check the file before retrying the operation.


DBA-00305

DBA-00305command size exceeds internal buffer size num

Cause:The size of the SQL statement exceeds SQL*DBA's buffer size.

Action:Shorten the SQL statement by removing extra blanks or by using intermediate statements or views, if necessary.


DBA-00306

DBA-00306monitor cycle interval time out of range (1 - num)

Cause:An invalid number was specified for the cycle interval.

Action:Enter a number between 1 and 3600 for the cycle interval. The numberindicates seconds.


DBA-00307

DBA-00307cannot open spool file name

Cause:SQL*DBA tried to open a spool file after the SPOOL filename was specified, but could not open the file. Possible causes are not enough disk space or inadequate privileges to create a file.

Action:Determine why SQL*DBA could not create a new file and retry.


DBA-00308

DBA-00308no spool file opened

Cause:SPOOL OFF was entered when not currently spooling.

Action:To capture session output, use the SPOOL command to open a file, enter the required commands, and close the file with SPOOL OFF.


DBA-00309

DBA-00309cannot close spool file name

Cause:SPOOL OFF could not close the currently open spool file.

Action:Check for an operating system reason that the spool file could not be closed.


DBA-00310

DBA-00310cannot open parameter file name

Cause:SQL*DBA cannot locate or open the file specified by the PFILE option, because either the file does not exist or SQL*DBA has insufficient privileges to openthe file.

Action:Check that the file exists in a location expected by SQL*DBA and canbe opened.


DBA-00314

DBA-00314unable to attach to default host

Cause:The default host has not been set up correctly.

Action:Use the SET INSTANCE command with a valid host specification to set up a default host.


DBA-00315

DBA-00315cannot open command file name

Cause:SQL*DBA cannot locate the specified command file.

Action:Check the file's name and SQL*DBA's access to it before retrying.


DBA-00316

DBA-00316cannot start up while connected to a database

Cause:An attempt was made to start up an instance while connected to a database.

Action:To start up an instance, first DISCONNECT from the current database.


DBA-00318

DBA-00318SQL*DBA command line error num

Cause:A syntax or typing error was made while entering a SQL*DBA command line.

Action:Check the syntax and try again.


DBA-00319

DBA-00319cannot locate sqldba configuration file name

Cause:SQL*DBA cannot open the file specified by the ORA_SQLDBAINIT variable, because either the file does not exist or SQL*DBA has insufficient privilege to open the file.

Action:Check that the specified file exists and can be opened.


DBA-00320

DBA-00320cannot open sqldba configuration file name

Cause:File mentioned cannot be opened.

Action:Check that the specified file exists and can be opened.


DBA-00321

DBA-00321instance name too long

Cause:An instance name was specified that may be valid, but is too long(exceeds 64 characters).

Action:Check the name of the desired instance and try again.


DBA-00322

DBA-00322total size of command line parameters exceeds buffer size

Cause:Too many command-line arguments were specified to fit in theSQL*DBA buffer.

Action:Specify the arguments over several command lines.


DBA-00325

DBA-00325pfile too large

Cause:The file specified using PFILE is too large (exceeds 8K).

Action:Reduce the size of the parameter file before specifying it again using PFILE.


DBA-00327

DBA-00327command not available in this mode

Cause:A command was specified that is not available in this mode.

Action:Switch to a mode where the command is allowed.


DBA-00328

DBA-00328insufficient privilege for this display

Cause:An attempt was made to display a MONITOR display without sufficient privileges for the underlying V$ tables.

Action:Contact the database administrator to obtain the required privileges.


DBA-00329

DBA-00329insufficient privilege for SHOW SGA

Cause:An attempt was made to use SHOW SGA without sufficient privileges.

Action:Contact the database administrator to obtain the required privileges.


DBA-00330

DBA-00330logsource name too long

Cause:The specified name may be valid, but is too long (exceeds 127 characters).

Action:Use a shorter name. For example, relocate the file so that its path nameis shorter.


DBA-00331

DBA-00331cannot allocate enough memory for SQL buffer

Cause:There is not enough memory for the current SQL buffer.

Action:Use the SET command to reduce MAXDATA. Re-invoke MONITOR FILEIO.


DBA-00336

DBA-00336insufficient privilege for SHOW PARAMETERS

Cause:An attempt was made to use SHOW PARAMETERS withoutsufficient privileges.

Action:Contact the database administrator to obtain the required privileges.


DBA-00337

DBA-00337missing instance name

Cause:The instance name was not specified in the CONNECT statement.

Action:Issue the CONNECT statement again, using the proper instance name.


DBA-00341

DBA-00341name is an undefined bind variable

Cause:The SQL statement refers to an undefined bind variable.

Action:Use the VARIABLE statement to define the bind variable and re-executethe query.


DBA-00342

DBA-00342unable to complete internal login

Cause:Some database error occurred that prevented a successful CONNECT INTERNAL. For example, a SHUTDOWN ABORT command was issued. This message is usually followed by another message that indicates the problem.

Action:Ensure that the instance is started correctly before trying to CONNECT INTERNAL. You may need to use the STARTUP FORCE command.


DBA-00343

DBA-00343no such parameter

Cause:SHOW PARAMETER was given a parameter name that does not exist.

Action:Use a different argument to SHOW PARAMETER.


DBA-00344

DBA-00344no items for the requested operation currently exist

Cause:A mandatory list element in a dialog contained zero (0) elements.

Action:No action required.


DBA-00345

DBA-00345no user sessions exist

Cause:An attempt was made to see if users were connected, but no userswere connected.

Action:No action required.


DBA-00346

DBA-00346no unresolved in-doubt transactions exist

Cause:There were no in-doubt transactions to resolve.

Action:No action required.


DBA-00347

DBA-00347no offline tablespaces exist

Cause:There were no offline tablespaces to bring online.

Action:No action required.


DBA-00348

DBA-00348no online tablespaces exist

Cause:There were no tablespaces to take offline. You cannot take the SYSTEM tablespace offline.

Action:No action required.


DBA-00349

DBA-00349no available rollback segments exist

Cause:There were no offline rollback segments to drop.

Action:No action required.


DBA-00350

DBA-00350no offline rollback segments exist

Cause:There were no offline or partly available rollback segments to bring online.

Action:No action required.


DBA-00351

DBA-00351no online rollback segments exist

Cause:There were no online rollback segments to take offline.

Action:No action required.


DBA-00352

DBA-00352no online tablespaces exist for backup

Cause:There were no online tablespaces to backup.

Action:No action required.


DBA-00353

DBA-00353no online tablespaces being backed up exist

Cause:An attempt was made to end an online tablespace backup, but no tables are being backed up.

Action:No action required.


DBA-00354

DBA-00354no offline tablespaces exist

Cause:There were no offline tablespaces to recover.

Action:No action required.


DBA-00355

DBA-00355no offline datafiles exist

Cause:There were no offline datafiles to recover.

Action:No action required.


DBA-00356

DBA-00356no users exist

Cause:There were no named users to alter or drop.

Action:No action required.


DBA-00357

DBA-00357no roles exist

Cause:There were no roles to alter or drop.

Action:No action required.


DBA-00358

DBA-00358no users or roles exist

Cause:There were no users or roles to grant privileges and roles to or to revoke privileges and roles from.

Action:Create some users before granting roles or privileges.


DBA-00359

DBA-00359monitor already active

Cause:An instantiation of this monitor was already active.

Action:Cycle through the monitor windows until the monitor becomes visible.


DBA-00360

DBA-00360object to be described does not exist

Cause:The object in a DESCRIBE FUNCTION / PROCEDURE / PACKAGE statement did not exist.

Action:Check that the object name and owner are correct and that the object exists.


DBA-00361

DBA-00361error during describe

Cause:An unexpected error occurred during describe.

Action:Check the following error and correct the problem.


DBA-00362

DBA-00362object name is a package; use DESCRIBE name.<procedure>

Cause:The named object was a package. DESCRIBE does not currently describe an entire package specification.

Action:Specify an entire package.


DBA-00363

DBA-00363procedure or function name not found in the package

Cause:The named package did not contain the procedure of the function specified.

Action:Specify a procedure or function within the package.


DBA-00364

DBA-00364object name is a remote object, cannot further describe

Cause:The specified object name contained a database link or was a synonymthat resolved to a name with a database link. Such objects cannot currentlybe described.

Action:Specify a local object.


DBA-00365

DBA-00365object name is invalid, it may not be described

Cause:The object must have been successfully compiled.

Action:Fix any errors in the object and recompile.


DBA-00366

DBA-00366name name is malformed, it must be of form [[a.]b.]c@dblink

Cause:The name may have at most three parts and a dblink.

Action:Use a well formed object name.


DBA-00371

DBA-00371cannot open/locate input help file, name

Cause:The Help Key was pressed or an item was chosen from the Help Menu, and the help file was not in the expected location.

Action:Put the help file in the location specified.


DBA-00372

DBA-00372cannot open/locate input index file, name

Cause:The Help Key was pressed or an item was chosen from the Help Menu, and the help file was not in the expected location.

Action:Put the index help file in the location specified.


DBA-00373

DBA-00373cannot allocate memory of size num from toolkit

Cause:The Help Key was pressed or an item was chosen from the Help Menu, and SQL*DBA ran out of memory.

Action:Exit SQL*DBA, restart, and try again.


DBA-00374

DBA-00374could not set file position in name directly

Cause:The Help Key was pressed or an item was chosen from the Help Menu.

Action:Alternate chosen ¾ no action required.


DBA-00375

DBA-00375unexpected end of file, name

Cause:The Help Key was pressed or an item was chosen from the Help Menu, but the help file specified was not installed.

Action:Exit SQL*DBA and install the correct help file.


DBA-00376

DBA-00376mandatory field has to be filled in before navigation is possible

Cause:An attempt was made to navigate to the next/previous item without filling a required field.

Action:Fill in current field before proceeding to another field.


DBA-00377

DBA-00377mandatory list item has to be selected before navigation is possible

Cause:An attempt was made to navigate to the next/previous item without filling a required field.

Action:Select a list item before proceeding to another field.


DBA-00378

DBA-00378an item has to be selected before help can be sought for it

Cause:An attempt was made to obtain help before selecting an item.

Action:Select an item first and re-execute.


DBA-00379

DBA-00379variable(s) not defined

Cause:The SHOW VAR[IABLES] [var-name] command could not find any variables. Either no variables are defined or you specified a non-existent variable.

Action:Check the spelling of the variables that were entered or, if no variables were entered, define the necessary variables.


DBA-00380

DBA-00380procedural option required for this statement

Cause:The attempted statement requires the procedural option.

Action:Refrain from using this statement or contact an Oracle sales representative to purchase the procedural option.


DBA-00381

DBA-00381error in the SERVER OUTPUT option

Cause:Most likely the package DBMS_OUTPUT was not installed.

Action:Install the package DBMS_OUTPUT and check the accompanying messages for more information.


DBA-00382

DBA-00382value name is not a recognizable filename for name

Cause:The value for the SQL*DBA initialization variable, which points to the initialization file, is not a recognizable filename.

Action:Specify a valid filename or do not define the variable so that no initialization file is run.


DBA-00383

DBA-00383filename name pointed to by name could not be opened

Cause:The filename pointed to by the SQL*DBA initialization variable could notbe opened.

Action:Specify an available file or do not define the variable so that no initialization file is run.


DBA-00384

DBA-00384could not open SQL*DBA resource file, name

Cause:The file mentioned could not be opened.

Action:Make the file mentioned available for use by SQL*DBA.


DBA-00385

DBA-00385could not locate SQL*DBA resource file, name

Cause:The file mentioned could not be located.

Action:Check that the file exists before rerunning SQL*DBA.


DBA-00386

DBA-00386could not open toolkit resource file, name

Cause:The file mentioned could not be opened.

Action:Make the file mentioned available for use by SQL*DBA.


DBA-00387

DBA-00387could not locate toolkit resource file, name

Cause:The file mentioned could not be located.

Action:Check that the file exists before rerunning SQL*DBA.


DBA-00388

DBA-00388cannot start SQL*DBA in screen mode; check if values are legal

Cause:A variable was not properly set.

Action:Check the values listed by SQL*DBA to see if they are correct.


DBA-00389

DBA-00389toolkit resource file name is defined to name

Cause:File mentioned could not be located.

Action:Check that the file specified exists and can be accessed.


DBA-00390

DBA-00390terminal type name is defined by name

Cause:Terminal type specified by may not be valid.

Action:Check that the terminal specification is correct.


DBA-00391

DBA-00391value name is defined to name; legal values: name or name

Cause:SQL*DBA mode has been incorrectly defined.

Action:Define the value of the variable to one of the legal values.


DBA-00392

DBA-00392this field requires a numeric value

Cause:An attempt was made to navigate to the next/previous item with a non-numeric value in a field requiring a numeric value.

Action:Enter a numeric value in the field and repeat the operation.


LCC-00111

LCC-00111value not in legal range range

Cause:The value of the parameter was outside the valid range.

Action:Check the valid range and retry using a new value.


LCC-00113

LCC-00113integer conversion error or negative integer num

Cause:A non-integer or negative integer was assigned to an integer parameter.

Action:Retry using a valid integer value.


LCC-00114

LCC-00114illegal boolean response character

Cause:A value other than TRUE or FALSE was specified.

Action:Enter a boolean value, either TRUE or FALSE.


LCC-00122

LCC-00122unrecognized keyword name

Cause:An invalid or misspelled keyword was specified.

Action:Re-enter the line.


LCC-00128

LCC-00128invalid positional parameter value num

Cause:An invalid positional parameter value was specified.

Action:Correct the value.


LCC-00161

LCC-00161Oracle error (possible syntax error) parameter name

Cause:A parameter was specified incorrectly, possibly with a syntax error.

Action:Correct the error as described in the accompanying message.


LCC-00201

LCC-00201could not open specified filename name

Cause:The specified file did not exist.

Action:Check the name of the file or create a file by that name before retrying.


LCC-00203

LCC-00203missing keyword name

Cause:A keyword is expected but none was found.

Action:Add a parameter keyword followed by an equal sign and a parameter value.


LCC-00204

LCC-00204left parenthesis and no parameter specified name

Cause:A parameter list was started but no parameter was specified.

Action:Add an appropriate list of values and close the parameter list.


LCC-00205

LCC-00205unbalanced parentheses character

Cause:An odd number of parentheses was found, indicating that one is missing or one is extra.

Action:Retry the statement using the correct number of parentheses.


LCC-00206

LCC-00206positional parameter entered after keyword name

Cause:An equal sign was missing.

Action:Retry the parameter specification using an equal sign between the parameter name and the value.


LCC-00207

LCC-00207nested parentheses encountered character

Cause:More than one set of parentheses was used. Only one set of parenthesesis permitted.

Action:Remove the nested parentheses and retry.


LCC-00208

LCC-00208unexpected keyword in value list name

Cause:A keyword was found instead of a value.

Action:Insert an appropriate value for the keyword.


LCC-00209

LCC-00209missing value for keyword at end of string str

Cause:A keyword was specified with no value.

Action:Specify a valid value for the keyword.


LCC-00210

LCC-00210illegal assignment operator symbol

Cause:An attempt was made to use a symbol other than an equal sign to assign a value to a parameter.

Action:Retry using an equal sign following the parameter name.


LCC-00211

LCC-00211unexpected delimiter symbol

Cause:An invalid delimiter was found between values.

Action:A comma or a space is a valid delimiter.


LCC-00212

LCC-00212runaway quoted string str

Cause:The parameter value was quoted on the left side but not on the right.

Action:Balance the quotation marks.


LCC-00215

LCC-00215parameter files nested too deep num

Cause:Too many parameter files were nested. The maximum number of files that may be nested is three.

Action:Reduce the number of nested parameter files.


LCC-00217

LCC-00217failure while processing file parameter

Cause:An error occurred while processing a file parameter.

Action:Other messages will follow with additional information.


LCC-00218

LCC-00218error in file name

Cause:An error occurred in the particular file.

Action:Other messages will follow with additional information.


EXP-00001

EXP-00001data field truncation - column length=num, buffer size=num fetched=num

Cause:Export could not fit a column in the data buffer.

Action:Record the given size parameters and the accompanying messages and report this as an Export internal error to customer support. (Part of the table has been exported. Export will continue with the next table.)


EXP-00002

EXP-00002error in writing to export file

Cause:Export could not write to the export file, probably because of a device error. This message is usually followed by a device message from theoperating system.

Action:Take appropriate action to restore the device.


EXP-00003

EXP-00003no storage definition found for segment (name, num)

Cause:Export could not find the storage definitions for a cluster, index, or table.

Action:Record the accompanying messages and report this as an Export internal error to customer support.


EXP-00004

EXP-00004invalid username or password

Cause:An invalid username or password was specified.

Action:Retry with a valid username and password.


EXP-00005

EXP-00005all allowable logon attempts failed

Cause:Attempts were repeatedly made to log on with an invalid usernameor password.

Action:Shut down the utility, then restart and retry with a valid usernameand password.


EXP-00006

EXP-00006internal inconsistency error

Cause:Export's data structure was corrupted.

Action:Record the accompanying messages and report this as an Export internal error to customer support.


EXP-00007

EXP-00007dictionary shows no columns for name.name

Cause:Export failed to gather column information from the data dictionary. The table may have been dropped.

Action:Retry the export and, if this error recurs, report it as an Export internal error to customer support.


EXP-00008

EXP-00008Oracle error num encountered

Cause:Export encountered the referenced Oracle error.

Action:Look up the Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


EXP-00009

EXP-00009no privilege to export name's table name

Cause:An attempt was made to export another user's table. Only a database administrator can export another user's tables.

Action:Ask your database administrator to do the export.


EXP-00010

EXP-00010name is not a valid username

Cause:An invalid username was specified.

Action:Shut down the utility, then restart and retry with a valid username.


EXP-00011

EXP-00011name.name does not exist

Cause:Export could not find the specified table.

Action:Retry with the correct table name.


EXP-00012

EXP-00012num is not a valid export mode

Cause:An invalid export mode was specified.

Action:Retry with a valid export mode.


EXP-00013

EXP-00013respond with either "Y", "N", RETURN or "." to quit

Cause:An invalid response was entered.

Action:Enter any of the responses shown in the message.


EXP-00014

EXP-00014error on row num of table name

Cause:Export encountered an Oracle error while fetching rows.

Action:Look up the accompanying Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


EXP-00015

EXP-00015error on row num of table name, column name, datatype num

Cause:Export encountered an error while fetching or writing the column. An accompanying message gives more information.

Action:Correct the error and try again.


EXP-00016

EXP-00016Oracle error encountered while reading default auditing options

Cause:Export encountered an Oracle error while reading the default auditing options (those for updates, deletes, and so on).

Action:Look up the accompanying Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


EXP-00018

EXP-00018datatype (num) for column name, table name.name is not supported

Cause:Export does not support the referenced datatype.

Action:Retry with an acceptable datatype (CHAR, NUMBER, DATE, LONG, or RAW).


EXP-00019

EXP-00019failed to process parameters, type "EXP HELP=Y" for help

Cause:Invalid command-line parameters were specified.

Action:Check the online help screen for the set of valid parameters, then retry.


EXP-00020

EXP-00020failed to allocate memory of size num

Cause:Export failed to allocate the necessary memory.

Action:Decrease the export buffer size so that less memory is required, or increase the runtime memory size for Export.


EXP-00021

EXP-00021can only perform incremental export in Full Database mode

Cause:USER or TABLE mode was specified when doing an incremental export.

Action:Specify FULL database mode (FULL=Y) and retry.


EXP-00022

EXP-00022must be SYS or SYSTEM to do incremental export

Cause:The privileges needed to do an incremental export do not exist. Only users SYS and SYSTEM can do incremental exports.

Action:Ask the database administrator to do the incremental export.


EXP-00023

EXP-00023must be a DBA to do Full Database export

Cause:The privileges needed to do a FULL database export do not exist. Only a database administrator can do a FULL database export.

Action:Ask the database administrator to do the FULL database export.


EXP-00024

EXP-00024export views not installed, please notify your DBA

Cause:The necessary Export views were not installed.

Action:Ask the database administrator to install the required Export views.


EXP-00025

EXP-00025dictionary shows no column for constraint name.num

Cause:Export failed to gather column information about the referenced constraint from the data dictionary. The constraint may have been altered.

Action:Retry the export and, if this error recurs, report it as an Export internal error to customer support.


EXP-00026

EXP-00026only one parameter (TABLES, OWNER, or FULL) can be specified

Cause:Conflicting export modes were specified.

Action:Specify only one parameter and retry.


EXP-00027

EXP-00027failed to calculate Oracle block size

Cause:Export failed to calculate the Oracle block size.

Action:Report this as an Export internal error to customer support.


EXP-00028

EXP-00028failed to open name for write

Cause:Export failed to open the export file for writing. This message is usually followed by device messages from the operating system.

Action:Take appropriate action to restore the device.


EXP-00029

EXP-00029incremental export mode and consistent mode are not compatible

Cause:Both consistent and incremental exports were specified.

Action:None. Consistent mode is turned off.


EXP-00030

EXP-00030unexpected End-Of-File encountered while reading input

Cause:Encountered an End-Of-File while reading the user input.

Action:If input to export is being redirected, check the file for errors.


EXP-00031

EXP-00031arraysize not in valid range. Using arraysize=num

Cause:The arraysize value specified is not in the valid range.

Action:None.


EXP-00032

EXP-00032non-DBAs may not export other users

Cause:Only database administrators can export to other users. A non-database administrator attempted to specify owner=user where exporter is not the user.

Action:Request that this operation be performed by the database administrator.


EXP-00033

EXP-00033could not find environment character set

Cause:The environment character set is missing or incorrectly specified.

Action:Ensure that the environment character set is correctly specified and is present.


EXP-00034

EXP-00034error on rowid: file# num block# num slot# num

Cause:Identifies the rowid on which an error occurred.

Action:This is an information message. No action is required.


EXP-00035

EXP-00035cannot specify Rows=N and Compress=Y

Cause:Compress applies only to rows of data, so to request compress you must also request rows.

Action:Remove the compress parameter or specify Rows=Y.


EXP-00037

EXP-00037Export views not compatible with database version

Cause:The Export utility is at a higher version than the database version and is thereby incompatible.

Action:Use the same version of Export utility as the database.


EXP-00038

EXP-00038bad Hash cluster id in CLU$

Cause:The function id in clu$ is not a legal number. CLU$ has become corrupted.

Action:Contact Oracle Worldwide Support.


EXP-00039

EXP-00039unknown value for procedural option

Cause:The V$OPTION table should correctly indicate which options are installed on your system. It would appear that there is no row for the procedural option. V$OPTION is corrupted.

Action:Contact Oracle Worldwide Support.


EXP-00040

EXP-00040dump file and log file must be different

Cause:The dump file and log file cannot be the same file.

Action:Specify different file names for the dump file and the log file, then retry the operation.


EXP-00041

EXP-00041export done in server's name, different from user's name character set name

Cause:The specified NLS_LANG/NLS_NCHAR parameter is incompatible with the value specified for the server in PROPS$.

Action:Change the client's value for NLS_LANG/NLS_NCHAR to server's value and retry the operation.


EXP-00042

EXP-00042missing NLS_CHARACTERSET/NLS_NCHAR_CHARACTERSET in PROPS$

Cause:A value for NLS_CHARACTERSET/NLS_NCHAR_CHARACTERSET was not entered in the PROPS$ table.

Action:This is an internal error. Contact Oracle Worldwide Support.


EXP-00043

EXP-00043invalid data dictionary information in the row where column name is name in table name

Cause:The export utility retrieved invalid data from the data dictionary.

Action:Contact Oracle Worldwide Support.


EXP-00044

EXP-00044must be a DBA to do Tablespace Point-in-time Recovery export

Cause:The user does not have privileges to do Tablespace Point-in-time Recovery export.

Action:Have the database administrator do Tablespace Point-in-time Recovery export for you.


EXP-00045

EXP-00045cannot export SYSTEM Tablespace for Point-in-time Recovery

Cause:SYSTEM tablespace cannot be part of recovery set.

Action:Contact Oracle Worldwide Support.


EXP-00046

EXP-00046tablespace named name does not exist

Cause:The specified tablespace does not exist in dictionary.

Action:Contact Oracle Worldwide Support.


EXP-00047

EXP-00047missing tablespace name(s) in Point-in-time Recovery set

Cause:Tablespace name(s) were not supplied for Point-in-time Recovery.

Action:Enter tablespace name(s) with Point-in-time Recovery option set.


EXP-00048

EXP-00048tablespace point-in-time Recover option not set

Cause:The tablespace option was not used in Point-in-time Recovery.

Action:Use the tablespace option only with the Point-in-time Recovery Option set.


EXP-00049

EXP-00049name option is not compatible with Point-in-time Recovery Export

Cause:An option was specified that cannot be used in Point-in-time Recovery Export.

Action:Consult the Oracle Server Utility Guide for the correct list of options.


EXP-00050

EXP-00050cannot perform Partition Export name on non-partitioned table name

Cause:The table specified in this Partition Export is not a partitioned table.

Action:Use Table mode, or specify a non-partitioned table.


EXP-00051

EXP-00051name - given partition name is not part of name table

Cause:The specified partition name is not in the specified table.

Action:Check if the correct table or partition name was specified.


EXP-00052

EXP-00052error on row num of partition name

Cause:Export encountered the referenced Oracle error while fetching rows.

Action:Look up the Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


EXP-00053

EXP-00053error on row num of partition name column name, datatype name

Cause:Export encountered the referenced Oracle error while fetching or writing the column.

Action:Look up the Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


EXP-00054

EXP-00054no storage definition found for partitioned object (name)

Cause:Could not find the storage definitions for partitioned table/index.

Action:Record the error messages that follow and report this to Oracle Worldwide Support as an Export internal error.


EXP-00055

EXP-00055name.name is marked not exportable

Cause:An object was marked as non-exportable in the NOEXP$ table.

Action:Consult your database administrator.


EXP-00057

EXP-00057failure to initialize parameter manager

Cause:The parameter manager failed in initialization.

Action:Record the messages that follow and report this to Oracle Worldwide Support as an Export internal bug.


EXP-00058

EXP-00058password Verify Function for name profile does not exist

Cause:Cannot find the function for the profile.

Action:Check if the profile was created properly.


EXP-00059

EXP-00059error converting an object type's identifier to characters

Cause:An invalid length of an object type identifier prevented its conversion.

Action:Contact Oracle Worldwide Support.


EXP-00060

EXP-00060an object type had multiple TYPE BODYs

Cause:More than one TYPE BODY was found for an object type.

Action:Try dropping the TYPE BODY; if that is not successful, contact Oracle Worldwide Support.


EXP-00061

EXP-00061unable to find the outer table name of a nested table

Cause:While exporting a bitmap index or post-able action on an inner nested table, the name of the outer table could not be located, using the NTAB$ table.

Action:Verify the table is properly defined.


EXP-00062

EXP-00062invalid source statements for an object type

Cause:TYPE was not found in the statements in SOURCE$ for an Object Type.

Action:Contact Oracle Worldwide Support.


EXP-00063

EXP-00063error in changing language handle

Cause:Unable to change language handle.

Action:Contact Oracle Worldwide Support.


EXP-00064

EXP-00064name is an inner nested table and cannot be exported.

Cause:An attempt was made to export an inner nested table without its parent table.

Action:Export the parent of the inner nested table.


EXP-00065

EXP-00065error writing LOB to the dump file.

Cause:The current LOB could not be written to the dump file.

Action:Identify the cause of the write failure and fix it.


EXP-00066

EXP-00066object table name is missing its object identifier index

Cause:All object tables must have an object identifier index, but the specified table was missing an index on its object identifier column.

Action:Recreate the type table and retry the operation.


EXP-00067

EXP-00067direct path cannot export name which contains object or LOB data.

Cause:Direct path export cannot export tables that contain LOBs, files, or object datatypes.

Action:Use conventional path export to export tables containing these datatypes.


EXP-00068

EXP-00068view has too many dependent views

Cause:An attempt was made to export a view with more than 200 dependent views.

Action:Contact Oracle Worldwide Support.


FRM-10000

FRM-10000: Validation error on item.

Cause:You tried to apply an invalid item definition.

Action:Change the item's property settings to make the item definition valid.


FRM-10001

FRM-10001: Internal Error: TOS.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10002

FRM-10002: Unable to save the current module.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10003

FRM-10003: Unable to retrieve the module from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10004

FRM-10004: Unique and valid value must be entered.

Cause:You entered an invalid value.

Action:Change the value to a valid value.


FRM-10005

FRM-10005: Value is required.

Cause:You attempted to exit the field without first entering a value.

Action:Enter a value.


FRM-10006

FRM-10006: Internal error.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10007

FRM-10007: Unable to access the table.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10008

FRM-10008: Unable to create the table.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10009

FRM-10009: Unable to find the object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10010

FRM-10010: Internal error: unable to insert an object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10011

FRM-10011: Internal error: unable to delete an object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10012

FRM-10012: Internal error: no memory.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10013

FRM-10013: Duplicate object is found.

Cause:Internal system error occurred when trying to save a module to the database.

Action:Contact your DBA or an Oracle support representative.


FRM-10014

FRM-10014: Module by this name already exists.

Cause:Internal system error occurred when trying to save a module to the database.

Action:Contact your DBA or an Oracle support representative.


FRM-10015

FRM-10015: Duplicate reference information is found.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10016

FRM-10016: Internal error: unable to close the object store.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10017

FRM-10017: Internal error: unable to rollback.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10018

FRM-10018: Internal error: unable to commit the changes.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10019

FRM-10019: Internal error: unable to open the object store.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10020

FRM-10020: Module exists.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10021

FRM-10021: Unable to find the module.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10022

FRM-10022: Internal error: unable to reference an object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10023

FRM-10023: Internal error: unable to retrieve objects from the object store.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10024

FRM-10024: Unable to save the column mapping object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10025

FRM-10025: Unable to retrieve the column mapping object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10032

FRM-10032: Unable to save the VGS object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10033

FRM-10033: Unable to retrieve the VGS object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10034

FRM-10034: Valid module name must be entered.

Cause:Internal system error occurred when trying to open a module from the database.

Action:Contact your DBA or an Oracle support representative.


FRM-10035

FRM-10035: Module does not exist.

Cause:The module name you specified does not exist.

Action:Check the module name or try another name.


FRM-10036

FRM-10036: Unable to save the relations.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10037

FRM-10037: Unable to retrieve the relations.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10038

FRM-10038: Cannot delete. Object is locked.

Cause:You tried to delete an object -- such as an item or a canvas -- that is locked by an active Layout Editor. An object is locked when it has been modified in the Layout Editor.

Action:Release the lock on the object.


FRM-10039

FRM-10039: Unable to start up the Form Builder.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10040

FRM-10040: Cannot revert a new module.

Cause:You chose File->Revert for a module that has not been saved. Since the module has not been saved, there is no version to revert to.

Action:Close the module without saving, then open a new module.


FRM-10041

FRM-10041: Operation not valid without database connection.

Cause:You tried to perform a design operation that requires the Form Builder to be connected to the database.

Action:Logon and connect to the database.


FRM-10042

FRM-10042: Not a Form Builder file.

Cause:You tried to open a file that is not a valid Form Builder design module.

Action:Open a form (.FMB), menu (.MMB), or library (.PLL) module.


FRM-10043

FRM-10043: Cannot open file.

Cause:You tried to open a file that is not a valid Form Builder design module file.

Action:Open a form (.FMB), menu (.MMB), or library (.PLL) module.


FRM-10044

FRM-10044: Cannot create file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10045

FRM-10045: Cannot connect to database.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10046

FRM-10046: Unable to delete VGS object.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10047

FRM-10047: Import only allowed to a multi-line text item.

Cause:You tried to import text to a single line text field or another control type. (Text can be imported only to a multi-line text item.)

Action:None.


FRM-10048

FRM-10048: Export is only allowed from a multi-line text item.

Cause:You tried to export text from a single-line text field or another control type. (Text can only be exported from a multi-line text field.)

Action:None.


FRM-10049

FRM-10049: Operation is only allowed from a multi-line text item.

Cause:You tried to invoke the default operation that can only be invoked from a multi-line text field.

Action:None.


FRM-10050

FRM-10050: Valid value must be entered.

Cause:You specified an invalid value or left a required field blank.

Action:Specify a valid value.


FRM-10051

FRM-10051: Error occurred while importing text.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10052

FRM-10052: Error occurred while exporting text.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10053

FRM-10053: No printer available.

Cause:The printer you specified is busy or not connected.

Action:Check the printer connections, or try again later.


FRM-10054

FRM-10054: Cannot attach PL/SQL library %s. This library attachment will be lost if the module is saved.

Cause:The library you specified is locked by other users, or the library name is invalid.

Action:Check the library name and try again later.


FRM-10056

FRM-10056: Incorrect module type stored in the file.

Cause:The file is not the correct module type for the operation you are trying to perform.

Action:None.


FRM-10057

FRM-10057: Cannot perform this operation on a module you do not own.

Cause:You tried to perform an operation -- such as revoking access privileges -- on a module in the database of which you are not the owner.

Action:None.


FRM-10058

FRM-10058: Object to be copied/referenced was not found.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10059

FRM-10059: Changes were not saved to the PL/SQL library before building.

Cause:You tried to compile the library before saving your changes.

Action:Save your changes, then compile the library.


FRM-10060

FRM-10060: Database connection required for retrieving referenced objects.

Cause:You tried to reference an object when Form Builder was not connected to the database. Only objects in modules that are stored in the database can be referenced.

Action:Logon and connect to the database.


FRM-10061

FRM-10061: Cannot script/parse PL/SQL library file

Cause:You attempted to parse or script a library file.

Action:Do not attempt to parse or script a library file.


FRM-10062

FRM-10062: Modal window must be dismissed before exiting.

Cause:The system did not get your response to a modal window.

Action:Reply to the modal window before you quit.


FRM-10063

FRM-10063: Cannot find help file, or help file is damaged.

Cause:Form Builder cannot locate or load the help file.

Action:Check your environment and check the path to the help file. If necessary, contact your DBA.


FRM-10064

FRM-10064: Unable to load the object from the resource file.

Cause:There is a bad resource file, a memory problem, or some other resource problem.

Action:Check your development environment.


FRM-10065

FRM-10065: Failed to initialize development environment (DE).

Cause:The development environment did not initialize, possibly because the system could not find resources.

Action:Check your development environment.


FRM-10066

FRM-10066: Failed to create a module.

Cause:The system could not find the necessary resources.

Action:Check your development environment.


FRM-10067

FRM-10067: Unable to lock module.

Cause:The module currently is opened by other users.

Action:Wait until the module is free, or have the user of the module quit.


FRM-10069

FRM-10069: Cannot detach the current working PL/SQL library module.

Cause:You tried to detach a working library.

Action:Do not detach a working library.


FRM-10070

FRM-10070: Unable to load the attached library information of the current PL/SQL library.

Cause:You tried to load a Forms 4.0 library module, but Forms was unable to load the module.

Action:Make sure the library can be loaded using Forms 4.0. If so, contact your DBA or an Oracle support representative.


FRM-10071

FRM-10071: Internal error: cannot open resource file %s.

Cause:Resource file cannot be found.

Action:Reinstall Form Builder or call an Oracle support representative.


FRM-10072

FRM-10072: Internal error: cannot open menu definition %s

Cause:Resource definitions for menu cannot be found.

Action:Reinstall Form Builder or call an Oracle support representative.


FRM-10074

FRM-10074: Unable to build a PL/SQL library script file.

Cause:Error in reading a library file.

Action:Fix the errors detected during the scripting process.


FRM-10075

FRM-10075: Unable to build a PL/SQL library from a script file.

Cause:Unable to convert an ASCII library file to library format.

Action:Fix the errors detected during the conversion process.


FRM-10076

FRM-10076: Value as entered will be truncated to fit in space allocated.

Cause:You entered a string that is too long to fit into the field.

Action:Reduce the length of the string.


FRM-10077

FRM-10077: Unable to extract translatable strings into NX file.

Cause:An internal error occurred while translating strings from NX file.

Action:Contact an Oracle support representative.


FRM-10078

FRM-10078: Unable to merge translated strings from NX file.

Cause:An internal error occurred while translating strings from NX file.

Action:Contact an Oracle support representative.


FRM-10080

FRM-10080: Source control services are not installed on this machine.

Cause:The source control component of Form Builder is not installed on your machine

Action:Contact your DBA or an Oracle support representative.


FRM-10081

FRM-10081: Cannot retrieve %s in '%s' module.

Cause:Internal error that appears during the loading process.

Action:Contact an Oracle support representative.


FRM-10082

FRM-10082: Cannot save %s.

Cause:Internal error that appears during the loading process.

Action:Contact an Oracle support representative.


FRM-10083

FRM-10083: Cannot find/open '%s' module for referenced objects.

Cause:The file containing the form module cannot be found, or the user ID for logging on to the database is incorrect.

Action:Make sure the file containing the form module is in your local directory, or under the search path FORMS50_PATH. Also, make sure you are logging on to the database with the correct user id.


FRM-10084

FRM-10084: Module appears to be an older version of Form Builder file.

Cause:The module you are referencing is not in the latest Form Builder format.

Action:Load the reference file and save it in the latest Form Builder format.


FRM-10085

FRM-10085: Cannot read in module information.

Cause:The file you tried to open is not an Form Builder file, or the file is corrupted.

Action:Contact an Oracle support representative.


FRM-10086

FRM-10086: The file is already open.

Cause:You are trying to open a file that is already open.

Action:None.


FRM-10087

FRM-10087: Libraries cannot be compiled.

Cause:You cannot compile libraries.

Action:None.


FRM-10088

FRM-10088: Libraries cannot be run.

Cause:You cannot run libraries.

Action:None.


FRM-10089

FRM-10089: Menus cannot be run from the Form Builder.

Cause:You clicked the Run button with a menu module selected.

Action:Select a form module before clicking the Run button.


FRM-10090

FRM-10090: Cannot save module to database.

Cause:Internal error.

Action:Contact an Oracle support representative.


FRM-10091

FRM-10091: Unable to create a script/parse file.

Cause:Internal error. Errors occurred during the conversion process.

Action:Contact an Oracle support representative.


FRM-10092

FRM-10092: Unable to convert an old module to current format:

Cause:Internal error occurs when converting Oracle Forms 4.0 structures to Forms 4.5 structures.

Action:Contact an Oracle support representative.


FRM-10093

FRM-10093: No PL/SQL source code.

Cause:You created a trigger that does not contain PL/SQL source code.

Action:Add PL/SQL source code to your trigger, or delete the trigger.


FRM-10094

FRM-10094: Could not compile the Formula.

Cause:Forms was unable to compile the PL/SQL expression specified in the Formula property.

Action:Check the PL/SQL expression for syntax errors and recompile.


FRM-10095

FRM-10095: Assertion failed in %s, at %s:%d.

Cause:An internal inconsistency was detected.

Action:Contact an Oracle support representative, and proceed with caution.


FRM-10096

FRM-10096: Cannot load Cue Card file.

Cause:Form Builder could not load the Cue Card file. It is missing or corrupt.

Action:Reinstall Form Builder or contact an Oracle support representative.


FRM-10097

FRM-10097: Cannot load Quick Tour file.

Cause:Forms could not load the Quick Tour file. It is missing or corrupt.

Action:Reinstall Form Builder or contact an Oracle support representative.


FRM-10098

FRM-10098: Cannot place entire module in Object Library.

Cause:You tried to place an entire Form Builder module into an Object Library.

Action:You can place only individual objects into an Object Library.


FRM-10099

FRM-10099: Cannot SmartClass object. An object with this name exists already.

Cause:You tried to SmartClass an object which would have conflicted with another object of the same name.

Action:Rename the existing object.


FRM-10100

FRM-10100: File name must be entered.

Cause:You tried to perform an operation that requires a valid file name to be specified.

Action:Specify a valid file name.


FRM-10101

FRM-10101: Cannot build module.

Cause:The module was not created due to generated errors.

Action:Contact your DBA or an Oracle support representative.


FRM-10150

FRM-10150: Error occurred while trying to save the preferences.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10200

FRM-10200: Illegal function in this context.

Cause:You pressed a key that is not valid in this context.

Action:Press [Show Keys] to view a list of valid function keys.


FRM-10201

FRM-10201: No parameters needed.

Cause:You pressed [Enter Application Parameters] or [Enter Menu Parameters], but none are required in this context.

Action:No action required.


FRM-10202

FRM-10202: Menus are nested too deeply.

Cause:You tried to select an item that would nest menus more than 10 deep.

Action:Press [Main Menu] to return to the main menu, then navigate to the menu of your choice.


FRM-10203

FRM-10203: Selected item is not in this menu.

Cause:In a full-screen menu, you entered a number that exceeds the maximum number of menu items.

Action:Choose an item that is on this menu.


FRM-10204

FRM-10204: No command defined for the selected background item.

Cause:You pressed [Background Menu n], where n was greater than the maximum number on the background menu.

Action:No action required. Press [Show Background Menu] to see the valid background menu items.


FRM-10205

FRM-10205: Menu %s not found.

Cause:In the choice field of a full-screen menu, you entered a menu name that does not exist in this application or is not found in the library.

Action:No action is required if the menu does not exist in the application. If it does, recompile the library.


FRM-10206

FRM-10206: Dynamic memory exhausted.

Cause:Form Builder has run out of memory.

Action:Contact your DBA.


FRM-10207

FRM-10207: No background menu present.

Cause:You pressed [Show Background Menu], but no background menu exists.

Action:No action required.


FRM-10208

FRM-10208: Parameter %s not found.

Cause:A menu item referenced an undefined parameter.

Action:Contact your DBA.


FRM-10209

FRM-10209: No next menu from background in this context.

Cause:The application attempted to navigate to a named menu from the background menu.

Action:No action required.


FRM-10210

FRM-10210: Response required.

Cause:You did not enter a required parameter, or you left the choice field blank in a full-screen menu.

Action:Make an entry.


FRM-10211

FRM-10211: Field must be filled completely.

Cause:You partially entered a parameter that must be entered completely.

Action:Enter enough data to completely fill the field.


FRM-10212

FRM-10212: Login failed for this username and password.

Cause:You specified an illegal username and password.

Action:Check the username and password and try again.


FRM-10213

FRM-10213: Login procedure terminated.

Cause:You failed to logon to ORACLE three times in a row.

Action:No action required. If you are a valid user, check your user name and password.


FRM-10214

FRM-10214: No authorization to run any application.

Cause:You are not a valid user of any module in Form Builder.

Action:No action required. If you think that you should be a valid user, ask your DBA to grant you access to the module you wish to run.


FRM-10215

FRM-10215: No help available.

Cause:You pressed [Help], but none is available for this item.

Action:No action required.


FRM-10216

FRM-10216: Failed to spawn a command to the operating system.

Cause:The operating system could not spawn a sub-process.

Action:Refer to the error message that the operating system issued.


FRM-10217

FRM-10217: No authorization for any item in selected menu.

Cause:You tried to move to a menu that has no items you can access.

Action:Check the menu name you entered and try again.


FRM-10218

FRM-10218: Error for menu %s.

Cause:Form Builder could not read the library information for this menu, or an invalid menu name was specified.

Action:Recompile the library or correct the menu name.


FRM-10219

FRM-10219: Item number is invalid.

Cause:In a full-screen menu, you entered an invalid number in the choice field.

Action:Check the item number and re-enter it.


FRM-10220

FRM-10220: No detailed help available for this item.

Cause:You pressed [Help], but none is available for this menu item.

Action:No action required.


FRM-10221

FRM-10221: Cannot read file %s.

Cause:Either file privileges are set incorrectly, or the library you tried to open is invalid.

Action:Recompile the application library and try again.


FRM-10222

FRM-10222: Menu %s was created by an old version of Forms Compiler.

Cause:You are using a newer version of Form Builder than the one that created this menu module.

Action:Recompile the menu module and re-execute the command.


FRM-10224

FRM-10224: Application bind variable module does not exist.

Cause:The bind variable information could not be located in the library. This may be due to an invalid library file.

Action:Recompile the application library and try again. If this is unsuccessful, contact your DBA.


FRM-10225

FRM-10225: Could not read parameter data.

Cause:The application library is invalid.

Action:Recompile the application library and try again. If this is unsuccessful, contact your DBA.


FRM-10226

FRM-10226: Could not read bind variable data.

Cause:The application library is invalid.

Action:Recompile the application library and try again. If this is unsuccessful, contact your DBA.


FRM-10227

FRM-10227: Too many menu parameters.

Cause:The application contains more menu parameters than can be used on your operating system.

Action:Revise and recompile the application, or contact your DBA.


FRM-10228

FRM-10228: Could not read help text.

Cause:The application library is invalid.

Action:Recompile the application library and try again. If this is unsuccessful, contact your DBA.


FRM-10229

FRM-10229: Could not close file %s.

Cause:Operating system error or internal error.

Action:Contact your DBA.


FRM-10230

FRM-10230: Application procedure module does not exist.

Cause:The procedure information could not be located in the library. This may be due to an invalid library file.

Action:Recompile the application library and try again. If this is unsuccessful, contact your DBA.


FRM-10231

FRM-10231: Could not read procedure data.

Cause:The application library is invalid.

Action:Recompile the application library and try again. If this is unsuccessful, contact your DBA.


FRM-10233

FRM-10233: Navigational procedures/macros not valid in current menu style.

Cause:You tried to use the full-screen, navigational packaged procedures, or macros in the pull-down or menu bar display style.

Action:Notify your DBA.


FRM-10234

FRM-10234: Semicolon missing in macro statement.

Cause:The command line specified for this item has a syntax error.

Action:Notify your DBA.


FRM-10235

FRM-10235: Macro %s not found.

Cause:The menu designer specified an undefined macro to be executed.

Action:Notify your DBA.


FRM-10236

FRM-10236: No procedure/macro specified.

Cause:The menu designer has specified a blank command.

Action:Notify your DBA.


FRM-10237

FRM-10237: Argument(s) not allowed for this procedure/macro.

Cause:The menu designer specified an argument to a command that does not take arguments.

Action:Notify your DBA.


FRM-10238

FRM-10238: Error executing %s. Check argument(s).

Cause:The menu designer specified an argument to a command that does not take arguments.

Action:Notify your DBA.


FRM-10239

FRM-10239: Cannot read form by that name.

Cause:Form Builder tried to read a form that does not exist in the current directory.

Action:Notify your DBA.


FRM-10240

FRM-10240: Form name not specified.

Cause:Forms Runtime command did not give the name of a form to execute.

Action:Notify your DBA.


FRM-10241

FRM-10241: Illegal operation when Form Builder is active.

Cause:The menu designer specified a built-in or macro that cannot be used when Form Builder calls Forms Runtime.

Action:Notify your DBA.


FRM-10242

FRM-10242: Cannot call linked-in Forms from Form Builder.

Cause:The menu designer specified a call to linked-in Forms from within Form Builder.

Action:Notify your DBA.


FRM-10243

FRM-10243: Error occurred during invocation of Form Builder.

Cause:A call to Forms Runtime failed.

Action:Notify your DBA.


FRM-10244

FRM-10244: Application %s does not exist.

Cause:The application name you specified does not exist in the database, or you do not have access privileges to it.

Action:Check the application name and try again, or contact your DBA.


FRM-10245

FRM-10245: Already on first item.

Cause:You pressed [Previous Item] from the first item in the parameter form.

Action:No action required. You cannot go to an item prior to the first item in a parameter form.


FRM-10246

FRM-10246: Error executing packaged procedure - inactive form.

Cause:The menu designer specified a built-in that cannot be executed in the current context.

Action:Notify your DBA.


FRM-10247

FRM-10247: No active items in root menu of application.

Cause:You tried to open an application but its root menu has no items that you can access. The root menu is either the application's main menu or another menu specified when Form Builder called Forms Designer.

Action:Notify your DBA.


FRM-10248

FRM-10248: No direct menu selection allowed when using a root menu.

Cause:The root menu is not the module's main menu, because Form Builder specified another root menu when calling Forms Designer.

Action:No action required. You can only use direct menu selection when the module's main menu is the root menu.


FRM-10249

FRM-10249: No authorization to run application %s.

Cause:You are not a valid user of the application you tried to run.

Action:No action required. If you think you should be a valid user, ask your DBA to grant you access privileges to the application.


FRM-10250

FRM-10250: Error initializing Forms Runtime application.

Cause:You did not name the module properly.

Action:Check the module name and enter it correctly.


FRM-10251

FRM-10251: Unsupported command type 4 switch used (-e,-i,-r,-w).

Cause:This menu option attempted to run a form, but specified a command line argument for Forms Runtime which is invalid when running a form from a menu.

Action:Notify your DBA.


FRM-10252

FRM-10252: Unknown command type 4 switch used.

Cause:This menu option attempted to run a form, but specified an unknown command line argument for Forms Runtime.

Action:Notify your DBA.


FRM-10253

FRM-10253: File name must be entered.

Cause:You have not entered a name (or you have deleted a name) for the file.

Action:You must enter a file name.


FRM-10254

FRM-10254: Cannot open file for screen shot.

Cause:The operating system could not open a file (e.g. permission problems, lack of disk space).

Action:Resolve the operating system condition that caused the error.


FRM-10255

FRM-10255: Error occurred during printing of screen shot.

Cause:The operating system had trouble with a file.

Action:Resolve the operating system condition that caused the error.


FRM-10256

FRM-10256: User is not authorized to run Form Builder Menu.

Cause:You are not enrolled in Form Builder. You do not have SELECT permission on the Form Builder base tables.

Action:Notify your DBA.


FRM-10257

FRM-10257: User is not authorized to select specified option.

Cause:You tried to select a menu item to which you do not have access.

Action:Choose another item or notify your DBA.


FRM-10258

FRM-10258: Specified menu is already active.

Cause:You tried to navigate to the current menu.

Action:No action required.


FRM-10259

FRM-10259: Invalid null argument to packaged procedure or function.

Cause:You did not specify an argument to a built-in, or the argument is invalid.

Action:Check the online Help for the proper built-in syntax.


FRM-10260

FRM-10260: No active items in selected menu.

Cause:You do not have access privileges for any items in this menu.

Action:Contact your DBA for access privileges if you think you should have access to the items on this menu.


FRM-10261

FRM-10261: Menu %s was created by a new version of Forms Compiler.

Cause:You are using an old version of Forms Runtime with a new version of Forms Compiler.

Action:Upgrade to new version of Forms Runtime.


FRM-10262

FRM-10262: Cannot put radio items, check boxes, or separators in menu bar.

Cause:You attempted to put radio items, check boxes, or separators in menu bar.

Action:Put these items in a submenu.


FRM-10263

FRM-10263: Cannot find icon file for iconic menu item.

Cause:No directory name for this icon.

Action:Contact the person who created the menu application.


FRM-10264

FRM-10264: Specified menu item does not exist.

Cause:You specified a menu item that does not exist in the form.

Action:Try retyping the name or choose another item name.


FRM-10265

FRM-10265: Library was created by an old version of Forms Compiler.

Cause:Form Builder cannot use library.

Action:Recompile the library with current version of Forms Compiler.


FRM-10266

FRM-10266: Library was created by a new version of Forms Compiler.

Cause:Form Builder cannot use library.

Action:Recompile the library with current version of Forms Compiler.


FRM-10267

FRM-10267: Help type magic menu item must be placed on top-level menu.

Cause:You placed a help magic menu item on a submenu.

Action:Move the help magic menu item to the top-level menu (main menu).


FRM-10268

FRM-10268: Error: Program unit %s in library %s is uncompiled.

Cause:You called an uncompiled program unit from a library.

Action:Follow the PL/SQL program error.


FRM-10269

FRM-10269: Warning! Program unit %s in library %s is uncompiled.

Cause:In debug Forms Runtime, you called an uncompiled program unit in a library.

Action:This is just a warning. Forms Runtime will attempt to compile and run the program unit.


FRM-10270

FRM-10270: Cannot attach library %s while opening menu %s.

Cause:The specified library file is attached to the given menu, but cannot be located in the search path for PL/SQL libraries.

Action:Make sure the library file can be located before attempting to run with the specified menu again. For example, have it in the working directory.


FRM-10275

FRM-10275: Destination module already exists.

Cause:You tried to rename a module in the database to a name that duplicates an existing module.

Action:Specify a unique name for the module.


FRM-10325

FRM-10325: Invalid module type.

Cause:Incorrect file extension specified.

Action:Use the correct extension (.FMX, .MMX or .LIB).


FRM-10327

FRM-10327: Only module owner can modify module access.

Cause:You attempted to grant or revoke access to a module of which you are not the owner.

Action:No action required. To modify access to the module, contact your DBA or the owner of the module.


FRM-10328

FRM-10328: Unable to modify access to this module.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10329

FRM-10329: User name must be entered.

Cause:Form Builder expects the name of a valid user.

Action:Enter the name of a valid user.


FRM-10350

FRM-10350: User does not have privileges to perform this operation.

Cause:You tried to perform an operation for which you do not have access privileges.

Action:If you wish to execute the operation, contact your DBA for access privileges.


FRM-10400

FRM-10400: Unable to open Report Builder.

Cause:Form Builder was unable to launch Report Builder.

Action:Start Report Builder as a separate process.


FRM-10401

FRM-10401: Can't open file %s for output.

Cause:The operating system had trouble opening a file (e.g. permission problems, lack of disk space).

Action:Resolve the operating system condition that caused the error.


FRM-10402

FRM-10402: No such application present.

Cause:The requested application could not be found in order to be documented.

Action:Make sure that the correct application name is specified.


FRM-10409

FRM-10409: Cannot close file.

Cause:Operating system error or internal error.

Action:Contact your DBA.


FRM-10411

FRM-10411: Unable to allocate dynamic memory for descriptor area.


FRM-10412

FRM-10412: Non-supported ORACLE datatype selected.


FRM-10600

FRM-10600: Mismatch between source module/object type and target module type.

Cause:The object you tried to copy or reference is not valid for the active module. For example, you cannot copy a block to a menu module.

Action:Make sure the object you tried to copy or reference is valid for the active target module.


FRM-10601

FRM-10601: Invalid parent for the target object.

Cause:Parent object name does not exist.

Action:Check the parent object name and try again.


FRM-10602

FRM-10602: Target by that name already exists.

Cause:The name you specified for the target object duplicates the name of another object of that same class.

Action:Change the target name to a name that is unique within the scope of that object.


FRM-10603

FRM-10603: Copy/reference to and from a PL/SQL library is not supported.

Cause:You tried to copy or reference a PL/SQL program unit -- such as a user-named procedure or function -- from a library module.

Action:None.


FRM-10604

FRM-10604: Cannot copy/reference the ROOT_WINDOW.

Cause:You attempted an editing operation upon a root window.

Action:None.


FRM-10605

FRM-10605: Valid module name required.

Cause:You did not enter a module name in the dialog.

Action:Enter a module name before accepting or canceling the dialog.


FRM-10606

FRM-10606: Valid data block name required..

Cause:You did not enter a data block name in the dialog.

Action:Enter a data block name before accepting or canceling the dialog.


FRM-10607

FRM-10607: Valid item name required.

Cause:You did not enter a valid item name in the dialog.

Action:Enter an item name before accepting or canceling the dialog.


FRM-10608

FRM-10608: Object type is invalid (internal error).

Cause:An internal Oracle error occurred.

Action:Contact your DBA.


FRM-10609

FRM-10609: Valid menu name required.

Cause:You did not enter a valid menu name in the dialog.

Action:Enter a menu name before accepting or canceling the dialog.


FRM-10625

FRM-10625: Input focus must be in text item.

Cause:You attempted an operation without the required input focus.

Action:Use keyboard of mouse navigation to place input focus in the the text item.


FRM-10650

FRM-10650: Input focus must be in text item.

Cause:You attempted an operation without the required input focus.

Action:Use keyboard of mouse navigation to place input focus in the the text item.


FRM-10700

FRM-10700: Replacement object does not exist in destination module.

Cause:The name you specified in the Copy Object Options dialog cannot be found in the destination module for the appropriate object type.

Action:Click a Select button in the dialog to view a list of appropriate object types in the destination module.


FRM-10725

FRM-10725: Failed to load the wizard from the resource file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-10750

FRM-10750: Table name required.

Cause:You must enter a table name before leaving this page of the wizard.

Action:Enter a table name, or click Browse to find a table in the database.


FRM-10751

FRM-10751: At least one database column must be selected.

Cause:At least one column must appear in the Database Items list of the field picker in order to leave this page of the wizard.

Action:Move one or more columns from the Available Columns list to the Database Items list of the field picker.


FRM-10752

FRM-10752: Wizard can modify only one data block at a time.

Cause:You have invoked the Data Block Wizard when two or more data blocks are selected in the Object Navigator. The wizard may only modify one data block at a time.

Action:Ensure that only one data block is selected in the Object Navigator before invoking the Data Block Wizard.


FRM-10753

FRM-10753: Invalid join condition to master data block %s.

Cause:While loading a data block in order to modify it, the Data Block Wizard has found an invalid join condition to the given master data block.

Action:Locate the relevant relation object of the given master data block and correct the join condition before invoking the Data Block Wizard again.


FRM-10754

FRM-10754: More than one join to master data block %s.

Cause:While loading a data block in order to modify it, the Data Block Wizard has found that the data block is joined more than once to the given master data block. This is an internal error that should not normally be encountered.

Action:Do one of the following:

1. Make sure that only one relation object links the master data block to the detail data block.

2. Contact your DBA or an Oracle support representative.


FRM-10755

FRM-10755: No join condition to master data block %s.

Cause:A join condition to the given master data block must exist before you can leave this page of the wizard.

Action:Use the Detail Item and Master Item poplists to setup a join condition to the given master data block.


FRM-10756

FRM-10756: Error retrieving constraints for table %s.

Cause:An internal error occured as the Data Block Wizard attempted to retreive constraints for the given table.

Action:Contact your DBA or an Oracle support representative.


FRM-10757

FRM-10757: No master data blocks are available.

Cause:No data blocks are available with which to define a master-detail relationship.

Action:If the Auto-join data blocks checkbox is:

1. Checked, then the only potential master data blocks are those that are based on tables referenced by a foreign key on the current block's base table.

2. Unchecked, then all data blocks in the form are potential master data blocks, but you must enter the join condition manually.


FRM-10758

FRM-10758: No item based on join column %s in this detail data block.

Cause:The Data Block Wizard is attempting to use foreign key constraint information to automatically setup the join condition between the current data block and the selected master data block. However, one of the columns included in the foreign key constraint does not appear as an item in the current data block.

Action:Return to the Table page of the wizard and ensure that all the columns needed to link the current data block to the required master data block appear in the Database Items list of the field picker.


FRM-10759

FRM-10759: No item based on join column %s in master data block %s.

Cause:The Data Block Wizard is attempting to use foreign key constraint information to automatically setup the join condition between the current data block and the selected master data block. However, one of the columns included in the foreign key constraint does not appear as an item in the selected master data block.

Action:Leave the wizard and ensure that the items needed to link the current data block to the required master block appear as items of the required master data block.


FRM-10760

FRM-10760: Error encountered while describing stored procedure.

Cause:Internal Oracle error.

Action:Contact your DBA or an Oracle support representative.


FRM-10761

FRM-10761: Wizard can only modify data blocks based on a single table or a set of procedures.

Cause:While loading a data block in order to modify it, the Data Block Wizard found a combination of data block properties not supported by the wizard.

Action:Ensure that the data block is either based on one of the following:

1. A single table (with Query Data Source Type and DML Data Target Type properties both set to Table, and identical Query Data Source Name and DML Target Name properties).

2. A set of stored procedures (with Query Data Source Type and DML Data Target Type properties both set to Procedure).


FRM-10762

FRM-10762: Procedure name required.

Cause:You must enter a procedure name to leave this page of the wizard.

Action:Enter a procedure name.


FRM-10763

FRM-10763: Argument of type TABLE or REFCURSOR must be IN OUT.

Cause:An argument of type TABLE or REFCURSOR (for a procedure used to query data for the data block) must have a mode of IN OUT.

Action:Do one of the following:

1. Select an alternative procedure to query data for your data block.

2. Exit the Data Block Wizard, change the argument mode to IN OUT, then re-invoke the wizard.


FRM-10764

FRM-10764: No argument of type TABLE or REFCURSOR.

Cause:A procedure used to query data for a data block must have one argument of type TABLE or REFCURSOR.

Action:Do one of the following:

1. Select an alternative procedure to query data for your data block.

2. Exit the Data Block Wizard, add an argument of type TABLE or REFCURSOR to the procedure, then re-invoke the wizard.


FRM-10765

FRM-10765: Only one argument of type TABLE or REFCURSOR permitted.

Cause:A procedure used to query data for a data block can have only one argument of type TABLE or REFCURSOR.

Action:Do one of the following:

1. Select an alternative procedure to query data for your data block.

2. Exit the Data Block Wizard, ensure that the procedure has only one argument of type TABLE or REFCURSOR, then re-invoke the wizard.


FRM-10766

FRM-10766: Arguments of type RECORD not permitted.

Cause:Arguments of type RECORD are not permitted in procedures that query, insert, update, delete or lock data for your data block.

Action:Do one of the following:

1. Select an alternative procedure to query, insert, update, delete or lock data for your data block.

2. Exit the Data Block Wizard, ensure that the procedure has no arguments of type RECORD, then re-invoke the wizard.


FRM-10767

FRM-10767: Please select at least one result set column.

Cause:At least one result set column must appear in the Database Items list of the field picker before you can leave this page of the wizard.

Action:Move one or more result set columns from the Available Columns list to the Database Items list of the field picker.


FRM-10768

FRM-10768: Argument of type TABLE must be IN or IN OUT.

Cause:A TABLE argument of a procedure used to insert, update, delete or lock data for the data block must have a mode of IN or IN OUT.

Action:Do one of the following:

1. Select an alternative procedure to insert, update, delete or lock data for your data block.

2. Exit the Data Block Wizard, correct the argument mode to IN or IN OUT, then re-invoke the wizard.


FRM-10769

FRM-10769: No argument of type TABLE.

Cause:A procedure used to insert, update, delete or lock data for a data block must have one argument of type TABLE.

Action:Do one of the following:

1. Select an alternative procedure to insert, update, delete or lock data for your data block.

2. Exit the Data Block Wizard, add an argument of type TABLE to the procedure, then re-invoke the wizard.


FRM-10770

FRM-10770: Only one argument of type TABLE permitted.

Cause:A procedure used to insert, update, delete or lock data for a data block must only have one argument of type TABLE.

Action:Do one of the following:

1. Select an alternative procedure to insert, update, delete or lock data for your data block.

2. Exit the Data Block Wizard, ensure that the procedure has only one argument of type TABLE, then re-invoke the wizard.


FRM-10771

FRM-10771: Arguments of type REFCURSOR not permitted.

Cause:A procedure used to insert, update, delete or lock data for a data block must not have arguments of type REFCURSOR.

Action:Do one of the following:

1. Select an alternative procedure to insert, update, delete or lock data for your data block.

2. Exit the Data Block Wizard, ensure that the procedure has no arguments of type REFCURSOR, then re-invoke the wizard.


FRM-10772

FRM-10772: Use of a function is not permitted.

Cause:A function has been specified to query, insert, update, delete or lock data for your data block. Only procedures may be used for this purpose.

Action:Do one of the following:

1. Select a procedure to query, insert, update, delete or lock data for your data block.

2. Exit the Data Block Wizard, convert the function to a procedure, then re-invoke the wizard.


FRM-10800

FRM-10800: Please select at least one displayed item.

Cause:At least one item must appear in the Displayed Items list of the field picker before you can leave this page of the wizard.

Action:Move one or more items from the Available Items list to the Displayed Items list of the field picker.


FRM-10801

FRM-10801: No data blocks in the current form to lay out.

Cause:You cannot invoke the Layout Wizard because there are no data blocks to lay out.

Action:Ensure that at least one data block exists in the form before invoking the Layout Wizard.


FRM-10802

FRM-10802: Wizard can modify only one frame at a time.

Cause:You have invoked the Layout Wizard while multiple frames are selected in the Layout Editor. The wizard can modify only one frame at a time.

Action:Ensure that only one frame is selected in the Layout Editor before invoking the Layout Wizard.


FRM-10803

FRM-10803: One or more items have a negative width or height.

Cause:One or more of the items in the table has a negative width or height.

Action:Ensure that no items in the table have a negative width or height.


FRM-10804

FRM-10804: Distance between records must be 0 or higher.

Cause:You have entered a negative value for distance between records.

Action:Correct distance between records to either 0 or a positive value.


FRM-10805

FRM-10805: Records displayed must be greater than 0.

Cause:You have entered a value less than 1 for records displayed.

Action:Correct records displayed to a value greater than 0.


FRM-10850

FRM-10850: Frame %s can only display %d records.

Cause:The given frame cannot display the requested number of records.

Action:No action is necessary. The frame will display the given maximum number of records. If you wish to display more records in the frame, use the Property Palette to set the Allow Expansion property of the frame to Yes.


FRM-10851

FRM-10851: Not enough horizontal space in frame %s to start layout.

Cause:The given frame doesn't have enough horizontal space to even start the layout of its associated data block.

Action:Increase the width of the frame so that more horizontal space is available.


FRM-10852

FRM-10852: Not enough vertical space in frame %s to start layout.

Cause:

Action:Increase the height of the frame so that more vertical space is available, or use the Property Palette to set the Allow Expansion property of the frame to Yes.


FRM-10853

FRM-10853: Horizontal overflow in frame %s.

Cause:The layout has horizontally overflowed the boundaries of the frame and the frame is not permitted to expand.

Action:Increase the width of the frame so that more horizontal space is available, or use the Property Palette to set the Allow Expansion property of the frame to Yes.


FRM-10855

FRM-10855: Not enough horizontal space in frame %s for object %s.

Cause:The given object is too wide to fit within the width of the frame.

Action:


FRM-11001

FRM-11001: Invalid character cell width.

Cause:The Character Cell Width is set to 0 or a negative number.

Action:Set the Character Cell Width to a whole number greater than 0.


FRM-11002

FRM-11002: Invalid character cell height.

Cause:The Character Cell Height field is set to 0 or a negative number.

Action:Set the Character Cell Height field to a whole number greater than 0.


FRM-11004

FRM-11004: Form module with this name already exists.

Cause:You attempted to rename a module using a name already in use.

Action:Choose another name with which to rename the module.


FRM-11005

FRM-11005: Unable to store the current form module.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11006

FRM-11006: Unable to retrieve the current form.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11007

FRM-11007: Invalid form name.

Cause:You have entered an invalid name for the form module.

Action:Enter a form module name composed only of valid characters: letters, numbers, underscores, and the # symbol (no dashes, periods, or @).


FRM-11008

FRM-11008: Data block does not exist.

Cause:Referenced block does not exist.

Action:Check the block name and try again.


FRM-11009

FRM-11009: Failed to load in the color palette %s.

Cause:You probably were working with an editable color palette and starting a new form or opening a form.

Action:Change to a sharable color mode; restart Form Builder.


FRM-11010

FRM-11010: Failed to save the color palette %s.

Cause:You probably were working with an editable color palette and starting a new form or opening a form.

Action:Change to a sharable color mode; restart Form Builder.


FRM-11100

FRM-11100: Master data block does not exist.

Cause:The block you specified in the Master Block field is not defined in the active form module.

Action:Enter the name of a valid master block. Use the LOV to display a list of all potential master blocks.


FRM-11101

FRM-11101: Error while parsing join condition.

Cause:Invalid value in the Join Condition property.

Action:Enter a valid join condition to define the relationship between the master block specified in the Master Block property and the detail block you are defining.


FRM-11102

FRM-11102: Error while generating the constraints.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11103

FRM-11103: Error while creating the default data block.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11104

FRM-11104: Valid data block and table names must be entered.

Cause:You entered an invalid block name or table name.

Action:Enter a a valid block name and a valid table name.


FRM-11105

FRM-11105: Error occurred while generating a list of master data blocks.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11106

FRM-11106: No master data blocks available.

Cause:You tried to invoke a list of potential master blocks for the current detail block you are defining, but no such block exists in the active form. A potential master block is a block whose base table has a foreign key relationship to the base table of the current block.

Action:None.


FRM-11107

FRM-11107: Number of records displayed must be between 1 and 100.

Cause:The number of records to be displayed is between 1 and 100.

Action:Enter a value between 1 and 100 in the Displayed field of the block property sheet.


FRM-11108

FRM-11108: Data block name cannot be SYSTEM, GLOBAL or PARAMETER.

Cause:The block name specified is a PL/SQL reserved word.

Action:Specify another name and try again.


FRM-11109

FRM-11109: Cannot fit the data block on the specified canvas.

Cause:The canvas you specified in the Canvas property is not large enough to display all of the text items you are trying to create (using the default layout).

Action:Increase the dimensions of the canvas. (If the specified canvas does not exist, you must first create it.) To change dimensions, either set the Width and Height properties in the Properties window, or re-size the canvas in the Layout Editor.


FRM-11110

FRM-11110: Retrieved columns do not match specified table.

Cause:You may have changed table names after a retrieve of columns.

Action:Retrieve the columns again.


FRM-11111

FRM-11111: Master data block name must be entered.

Cause:You may have specified a join condition without a master block.

Action:Specify a master block.


FRM-11112

FRM-11112: Enter a base table name before choosing columns.

Cause:You are trying to select columns before specifying a base table.

Action:Specify a base table name before choosing columns.


FRM-11200

FRM-11200: Valid data block name must be entered and be unique within the form.

Cause:The Block Name property is blank or specifies the name of another block.

Action:Enter a name for the block that is unique among all blocks in the active form.


FRM-11201

FRM-11201: Number of records displayed must be a whole number > 0 and not more than the number of records buffered.

Cause:The Records Displayed property is blank. Or, the Records Displayed property contains a number greater than the Records Buffered property.

Action:Set the Records Displayed property to a number that is greater than zero, but that is less than or equal to the number of records buffered.


FRM-11203

FRM-11203: Data block with Records Buffered, Primary Key or Column Security must have a base table.

Cause:You may not have identified a base table.

Action:Identify a base table.


FRM-11204

FRM-11204: Data block with this name already exists.

Cause:There is already a block in the active form with the name specified by the Block Name property.

Action:Enter a name for the block that is unique among all blocks in the active form.


FRM-11205

FRM-11205: Unable to store the current data block.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11206

FRM-11206: Unable to retrieve the data blocks.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11207

FRM-11207: Data block does not exist.

Cause:You may have supplied the wrong name.

Action:Supply the correct name of a valid block.


FRM-11208

FRM-11208: Unable to get the copied/referenced data block %s.

Cause:The specified block does not exist in the database.

Action:Check the block name and try again.


FRM-11210

FRM-11210: Records fetched must be a whole number > 0 and < 65536, or null.

Cause:You may have tried to fetch a number of records that are out of range.

Action:Try to fetch using a valid number.


FRM-11211

FRM-11211: Number of rows buffered must be a whole number > 0 and < 65536.

Cause:You entered an invalid value.

Action:Enter a positive integer.


FRM-11300

FRM-11300: Valid item name must be entered and be unique within the data block.

Cause:The Name property is blank or specifies the name of another item.

Action:Enter a name for the item that is unique among all items in the same block.


FRM-11301

FRM-11301: Sequence number must be > 0 and < 65536.

Cause:The Sequence ID field is blank or specifies a number greater than zero and less than 65536.

Action:In the Sequence ID field, enter a valid number.


FRM-11302

FRM-11302: Data block name must be entered and exist in the form.

Cause:The Block Name field is blank or specifies the name of another block.

Action:Enter a name for the block that is unique among all blocks in the active form.


FRM-11303

FRM-11303: Canvas name can be null, otherwise it must exist in the form.

Cause:The Canvas property specifies a non-existent canvas.

Action:Leave the Canvas property blank (to make the current item a NULL-canvas item) or enter the name of an existing canvas.


FRM-11304

FRM-11304: Valid X coordinate is required.

Cause:The X Position property is blank or specifies a negative number.

Action:Enter a non-negative number in the X Position property to specify the position of the item's upper left corner on the canvas.


FRM-11305

FRM-11305: Valid Y coordinate is required.

Cause:The Y Position property is blank or specifies a negative number.

Action:Enter a non-negative number in the Y Position property to specify the position of the item's upper left corner on the canvas.


FRM-11306

FRM-11306: Valid width coordinate is required.

Cause:The View Width property is blank or specifies a negative number.

Action:Enter a non-negative number in the Width field to specify the width of the item in the current form coordinate units.


FRM-11307

FRM-11307: Valid height coordinate is required.

Cause:The View Height property field is blank or specifies a negative number.

Action:Enter a non-negative number in the Height field to specify the height of item in the current form coordinate units.


FRM-11310

FRM-11310: Invalid maximum length for the current item/data type.

Cause:You entered an invalid maximum length for an item.

Action:If the current item type is:

1. An image item, set the Maximum Length property to 1024 or greater.

2. Not an image item, set the Maximum Length property to 1 or greater.


FRM-11311

FRM-11311: Item's data block must be based on a database table.

Cause:You tried to invoke an LOV on the Name property for a control block item.

Action:No action required.


FRM-11312

FRM-11312: Item name already exists in the current data block.

Cause:The name you have specified is already in use.

Action:Enter a unique item name.


FRM-11313

FRM-11313: Unable to store the current items.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11314

FRM-11314: Unable to retrieve the items from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11316

FRM-11316: Editor name can be null, else it must exist in the form.

Cause:The editor specified in the Editor property is not defined in the active form.

Action:Do one of the following:

1. If you do not want to assign a custom editor to the item, leave the Editor Name property blank.

2. Enter the name of an existing editor.


FRM-11317

FRM-11317: LOV name can be null, else it must exist in the form.

Cause:The List of Values specified in the LOV property is not defined in the active form.

Action:Do one of the following:

1. If you do not want to attach an LOV to the text item, leave the LOV property blank.

2. Enter the name of an existing LOV.


FRM-11318

FRM-11318: Multi-line attribute cannot be set for this data type.

Cause:You tried to set the Multi-line property to True when the Data Type property is set to CHAR, ALPHA, or LONG. This is not allowed.

Action:Set the Multi-line property to False or change the Data Type property to CHAR, ALPHA, or LONG.


FRM-11319

FRM-11319: Query length must be 0 or >= the maximum length and < 65536 (depending upon the data type).

Cause:The Query Length property setting is invalid.

Action:Enter a valid length in the Query Length property. If not 0, it must be equal to or greater than the Maximum Length property value.


FRM-11320

FRM-11320: Valid initial value must be entered.

Cause:You attempted to enter an invalid global or parameter.

Action:Enter a valid value.


FRM-11321

FRM-11321: Valid range value must be entered.

Cause:The values in the Range Low Value and Range High Value properties are incompatible with the data type of the text item.

Action:Change the low and high range values to be compatible with the data type or change the Data Type property to be compatible with the range values.


FRM-11322

FRM-11322: Other value is invalid.

Cause:The other value specified for a radio group or list item is invalid.

Action:Other value must be one of the following:

1. Item, parameter, sequence, or global reference.

2. Equal to the value of one of the buttons or lists.

3. Equal to the name of one of the buttons or lists.

4. NULL.


FRM-11323

FRM-11323: Initial value is invalid.

Cause:The initial value specified for a radio group, list item, or check box is invalid.

Action:Initial value must be one of the following:

1. Item, parameter, sequence, or global reference.

2. Equal to the "checked" value (check box only.)

3. Equal to the "unchecked" value (check box only).

4. Equal to the "checked" or "unchecked" value - case insensitive (check box only).

5. NULL.


FRM-11324

FRM-11324: Value is invalid.

Cause:The value you entered is out of the legal range.

Action:Enter a legal value.


FRM-11325

FRM-11325: Invalid horizontal spacing between columns.

Cause:You entered an invalid value.

Action:Enter a positive number.


FRM-11326

FRM-11326: Invalid column display width.

Cause:You entered an invalid value.

Action:Enter a positive number.


FRM-11327

FRM-11327: Unable to get the copied/referenced item %s in data block %s.

Cause:You specified an item that does not exist in the specified block.

Action:Check the block and item names, and try again.


FRM-11328

FRM-11328: Initial Value is invalid; correct format is %s.

Cause:Value is not compatible with data type.

Action:Make the value compatible with the data type.


FRM-11329

FRM-11329: Other Value is invalid; correct format is %s.

Cause:Value is not compatible with data type.

Action:Make the value compatible with the data type.


FRM-11330

FRM-11330: Value is invalid; correct format is %s.

Cause:Value is not compatible with data type.

Action:Make the value compatible with the data type.


FRM-11331

FRM-11331: High range value must be greater than low range value.

Cause:Low range value is greater than high range value.

Action:Make sure high range value is greater than low range value.


FRM-11400

FRM-11400: PL/SQL with this name already exists.

Cause:You may have created two code segments with the same name.

Action:Rename a code segment.


FRM-11401

FRM-11401: Unable to store the current PL/SQL.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11402

FRM-11402: Unable to retrieve the PL/SQL.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11403

FRM-11403: Unable to initialize the PL/SQL context.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11404

FRM-11404: Unable to load the procedures.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11405

FRM-11405: Unable to load the program unit browser from the resource file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11406

FRM-11406: Unable to show the program unit browser.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11407

FRM-11407: Unable to load the PL/SQL editor.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11408

FRM-11408: Unable to get the copied/referenced PL/SQL %s.

Cause:The specified PL/SQL does not exist in the database.

Action:Check the PL/SQL name, and try again.


FRM-11409

FRM-11409: Program unit %s is already shown in another window.

Cause:You can only view a program unit from one PL/SQL editor window.

Action:View the program unit from another window.


FRM-11410

FRM-11410: Menu item %s is already shown in another window.

Cause:You can only view a menu item from one PL/SQL editor window.

Action:View the menu item from another window.


FRM-11411

FRM-11411: Menu %s is already shown in another window.

Cause:You can only view menu startup code from one PL/SQL Editor window.

Action:View the menu startup code from another window.


FRM-11412

FRM-11412: PL/SQL code for %s is too large to be stored.

Cause:The program unit is too large to store in a single memory allocation.

Action:Reduce the size of the PL/SQL code by encapsulating the code and making several program units.


FRM-11413

FRM-11413: PL/SQL code for %s is too large to be decoded. %s needs to be broken up into smaller program units.

Cause:The program unit is too large to decode in a single memory allocation. You may loose the incremental compilation feature.

Action:Divide the program unit into several smaller program units so that you can decode each program unit in a single memory allocation.


FRM-11500

FRM-11500: Data block with this name does not exist in the form.

Cause:You tried to attach a trigger to a block that is not defined in the active form module.

Action:Enter a valid block name in the Object field.


FRM-11501

FRM-11501: Item with this name does not exist in the data block.

Cause:You tried to attach a trigger to an item that is not defined in the block.

Action:Enter a valid item name in the Object field.


FRM-11502

FRM-11502: Built-in trigger with this name does not exist.

Cause:The trigger name specified in the Name field is not a valid built-in trigger.

Action:Check the syntax of the trigger name and make sure it corresponds to one of the predefined trigger names. Use the List of Values for this field to display a list of Form Builder triggers.


FRM-11503

FRM-11503: Trigger that is not a key-trigger cannot be shown with Show-Keys.

Cause:You set the Show Keys option to True on the Properties window.

Action:Change the trigger name or delete the descriptor.


FRM-11504

FRM-11504: Trigger with this name already exists.

Cause:You tried to define a trigger with the same name at the same definition level; that is, a trigger with the same scope as an existing trigger. This is not allowed.

Action:Either change the scope of the trigger or its name.


FRM-11506

FRM-11506: Unable to store the current triggers.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11507

FRM-11507: Unable to retrieve the triggers from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11508

FRM-11508: Built-in trigger invalid at this definition level.

Cause:You tried to define a trigger at an invalid definition level (form-, block-, or item-). Certain triggers are valid only at specific definition levels.

Action:Change the Object field to specify a valid definition level. For more information, refer to help on trigger definition level .


FRM-11509

FRM-11509: Valid trigger name must be entered.

Cause:The Trigger Type property is set to User-Named but the Type field is either blank or contains an invalid trigger name.

Action:In the Type field, enter a valid user-named trigger name. The name must adhere to Oracle naming conventions and must be unique among triggers in the form, including built-in triggers.


FRM-11510

FRM-11510: Unable to get the copied/referenced trigger %s in form %s.

Cause:The specified trigger does not exist in the specified form.

Action:Check the trigger and form names, and try again.


FRM-11511

FRM-11511: Unable to get the copied/referenced trigger %s in data block %s.

Cause:The specified trigger does not exist in the specified block.

Action:Check the trigger and block names, and try again.


FRM-11512

FRM-11512: Unable to get the copied/referenced trigger %s in item %s of data block %s.

Cause:The specified trigger does not exist in the item on the specified block.

Action:Check the trigger, item, and block names, and try again.


FRM-11513

FRM-11513: Trigger %s is already shown in another window.

Cause:You can only view a trigger from one PL/SQL editor window.

Action:View the trigger from another window.


FRM-11600

FRM-11600: Unable to store the current V2 triggers.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11601

FRM-11601: Unable to retrieve the V2 triggers from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11602

FRM-11602: Text for step must be entered.

Cause:You tried to create a V2-style trigger but left the Trigger Step Text field blank.

Action:Enter the desired trigger text in the Trigger Step Text field.


FRM-11603

FRM-11603: Sequence number must be at least 1 and less than 65536.

Cause:You attempted to enter a negative or non-integer number.

Action:Enter a non-negative, non-zero, whole number sequence.


FRM-11700

FRM-11700: Valid alert name must be entered and be unique within the form.

Cause:The Name field is blank.

Action:Enter a unique name for the alert.


FRM-11701

FRM-11701: Alert with this name already exists.

Cause:There is already an alert with the same name defined in the active form.

Action:Enter a unique name for the alert.


FRM-11702

FRM-11702: Unable to store the current alert objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11703

FRM-11703: Unable to retrieve the alert objects from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11704

FRM-11704: At least one button label must be supplied.

Cause:All of the Button properties (Button 1, Button 2, Button 3) are blank.

Action:Enter a label for at least one of the buttons.


FRM-11705

FRM-11705: Default button must have a label.

Cause:The Label property is blank for the button that is the Default button.

Action:Enter a label for the default button (Button 1, Button 2, or Button 3).


FRM-11706

FRM-11706: Unable to get the copied/referenced alert %s.

Cause:The specified alert does not exist in the database.

Action:Check the alert name, and try again.


FRM-11800

FRM-11800: Valid editor name must be entered and be unique within the form.

Cause:The editor Name property is blank.

Action:Enter a unique name for the editor.


FRM-11801

FRM-11801: Editor with this name already exists.

Cause:There is already an editor with the same name defined in the active form.

Action:Enter a unique name for the editor.


FRM-11802

FRM-11802: Unable to store the current editor objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11803

FRM-11803: Unable to retrieve the editor objects from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11804

FRM-11804: Unable to get the copied/referenced editor %s.

Cause:The specified editor does not exist in the database.

Action:Check the editor name, and try again.


FRM-11900

FRM-11900: List Of Values with this name already exists.

Cause:The name specified for the LOV duplicates the name of an existing LOV defined in the same form.

Action:Enter a valid name that is unique among LOVs in the active form.


FRM-11901

FRM-11901: Error occurred while trying to create the LOV.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11902

FRM-11902: Unable to store the current LOV objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11903

FRM-11903: Unable to retrieve the LOV objects from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-11905

FRM-11905: Item referenced in select statement does not exist.

Cause:You are trying to select an item that does not exist.

Action:Check the table and fix the select statement.


FRM-11906

FRM-11906: Valid LOV name must be entered and be unique within the form.

Cause:The Name field is blank.

Action:Enter a valid name that is unique among LOVs in the active form.


FRM-11907

FRM-11907: Record group must exist within the form.

Cause:The record group specified in the Record Group Type property does not exist in the active form.

Action:Enter the name of an existing record group, or create a new record group.


FRM-11908

FRM-11908: Item name must be valid and exist in the form.

Cause:The Return Item property contains an invalid value.

Action:Enter a valid value in the Return Item property. Valid values include the name of an item in the active form, the name of a global variable, or the name of a form parameter. Do not preface the object name with a colon or enclose it in quotes.


FRM-11909

FRM-11909: Valid column display width required.

Cause:The Display Width property of one or more columns in the LOV is blank or contains an invalid number.

Action:Change the Display Width value for each LOV column to be either 0 (for a hidden column) or a non-negative number.


FRM-11910

FRM-11910: Unable to get the copied/referenced LOV %s.

Cause:The specified LOV does not exist in the database.

Action:Check the LOV name, and try again.


FRM-12000

FRM-12000: Record group with this name already exists.

Cause:The name specified for the record group duplicates the name of an existing record group defined in the same form.

Action:Enter a valid name that is unique among record groups in the active form.


FRM-12001

FRM-12001: Cannot create the record group (check your query).

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12002

FRM-12002: Unable to store the current record group objects.

Cause:Form Builder cannot understand the Y coordinate you want for your window.

Action:Supply a positive number.


FRM-12003

FRM-12003: Unable to retrieve the record group objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12005

FRM-12005: Unable to get the copied/referenced record group %s.

Cause:The specified record group does not exist in the database.

Action:Check the record group name, and try again.


FRM-12006

FRM-12006: Valid record group name must be entered and be unique within the form.

Cause:Form Builder could not understand your record group name.

Action:Enter a unique name.


FRM-12100

FRM-12100: Valid canvas name must be entered and be unique within the form.

Cause:The Name field is blank.

Action:Enter a valid name that is unique among canvas objects in the active form.


FRM-12101

FRM-12101: Window name must be entered and window must exist in the form.

Cause:The Window property is either left blank or specifies a window that is not defined in the active form.

Action:Every canvas-view must be assigned to a window. Enter the name of an existing window in the Window property.


FRM-12102

FRM-12102: Value entered is not a valid coordinate.

Cause:You did not enter a valid value for width and height.

Action:Enter a valid X coordinate for canvas-view width, and a Y coordinate for canvas-view height.


FRM-12103

FRM-12103: Canvas with this name already exists.

Cause:The name specified for the canvas duplicates the name of an existing canvas defined in the same form.

Action:Enter a valid name that is unique among canvas objects in the active form.


FRM-12104

FRM-12104: Unable to store the current canvas objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12105

FRM-12105: Unable to retrieve the canvas objects from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12106

FRM-12106: Sequence number must be at least 1 and less than 65536.

Cause:The canvas-view Sequence (Seq) field is invalid.

Action:Enter a valid sequence number. Note that although the Sequence property is required for all canvas objects, it takes effect only when you assign more than one canvas to the same window.


FRM-12107

FRM-12107: Unable to get the copied/referenced canvas %s.

Cause:The specified canvas-view does not exist in the database.

Action:Check the canvas-view name, and try again.


FRM-12200

FRM-12200: Valid window name must be entered, unique within the form, and not ROOT_WINDOW.

Cause:The Name field is blank.

Action:Enter a valid window name that is unique among windows defined in the active form. The name ROOT_WINDOW is not a valid window name.


FRM-12201

FRM-12201: Valid X coordinate required.

Cause:Form Builder cannot understand the X coordinate you want for your window.

Action:Supply a positive number.


FRM-12202

FRM-12202: Valid Y coordinate is required.

Cause:Form Builder cannot understand the Y coordinate you want for your window.

Action:Supply a positive number.


FRM-12203

FRM-12203: Valid width coordinate is required.

Cause:Invalid width coordinate entered.

Action:Enter a positive width coordinate.


FRM-12204

FRM-12204: Valid height coordinate is required.

Cause:Invalid height coordinate entered.

Action:Enter a positive height coordinate.


FRM-12205

FRM-12205: Content view name can be null, otherwise it must exist in the form.

Cause:The View property is not defined in the active form.

Action:Leave the View property blank or enter the name of an existing view.


FRM-12211

FRM-12211: Window with this name already exists.

Cause:The name specified for the window duplicates the name of an existing window defined in the same form.

Action:Enter a valid name that is unique among windows in the active form.


FRM-12212

FRM-12212: Unable to store the current window objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12213

FRM-12213: Unable to retrieve the window objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12214

FRM-12214: Unable to get the copied/referenced window %s.

Cause:The specified window does not exist in the database.

Action:Check the window name, and try again.


FRM-12300

FRM-12300: Unable to store the current visual attribute objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12301

FRM-12301: Unable to retrieve the visual attributes.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12302

FRM-12302: Valid visual attribute name must be entered and unique within the module.

Cause:The Name property is blank.

Action:Enter a valid visual attribute name that is unique among visual attributes defined in the active module.


FRM-12303

FRM-12303: Visual attribute by this name does not exist.

Cause:You tried to assign an undefined visual attribute to an object.

Action:Enter the name of a visual attribute that is defined in the active module.


FRM-12304

FRM-12304: Visual attribute by this name already exists.

Cause:The name specified for the visual attribute duplicates the name of an existing visual attribute defined in the same form.

Action:Enter a valid name that is unique among visual attributes in the active form.


FRM-12305

FRM-12305: Color by this name does not exist.

Cause:The Foreground Color or Background Color property is invalid.

Action:Enter a valid color name in the Foreground Color or Background Color property, or leave the properties blank.


FRM-12306

FRM-12306: Pattern by this name does not exist.

Cause:The Fill Pattern property is invalid.

Action:Enter a valid pattern name in the Fill Pattern property, or leave the property blank.


FRM-12307

FRM-12307: Valid font size must be entered (1-100).

Cause:The Font Size field is invalid.

Action:Enter a valid font size or leave the field blank.


FRM-12308

FRM-12308: Unable to get the copied/referenced visual attribute %s.

Cause:The specified visual attribute does not exist in the database.

Action:Check the visual attribute name, and try again.


FRM-12400

FRM-12400: Menu module by this name already exists.

Cause:You entered a menu module name that already exists.

Action:Enter a valid name that is unique among menu modules.


FRM-12401

FRM-12401: Unable to store the menu module.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12402

FRM-12402: Unable to retrieve the menu module from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12403

FRM-12403: Invalid module name.

Cause:The name specified for the menu module is invalid.

Action:Enter a name for the module that follows standard Oracle naming conventions.


FRM-12500

FRM-12500: Valid menu name must be entered and be unique within the menu.

Cause:You attempted to exit the menu Name field without entering a name.

Action:Enter a menu name.


FRM-12501

FRM-12501: Unable to store the current menus.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12502

FRM-12502: Unable to retrieve the menus.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12503

FRM-12503: Invalid menu name.

Cause:The name specified for the menu is invalid.

Action:Enter a valid menu name in the Name field. Menu names are internal handles that are not displayed at runtime.


FRM-12504

FRM-12504: Unable to get the copied/referenced menu %s.

Cause:The specified menu does not exist in the database.

Action:Check the menu name, and try again.


FRM-12600

FRM-12600: Menu Item with this name already exists.

Cause:You tried to enter a menu item name that already exists.

Action:Enter a unique and valid name for the menu item.


FRM-12601

FRM-12601: Unable to store the current menu items.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12602

FRM-12602: Unable to retrieve the menu items from the file.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12603

FRM-12603: Valid radio group name must be entered.

Cause:One or more menu item in the menu module has the Type property set to Radio but its radio group property is invalid.

Action:Each radio menu item must be assigned to a radio group. To assign a radio item to a group, select the item in the appropriate menu column, set the Type selector to Type, then enter the name of the desired radio group property. The radio group name must adhere to Oracle naming conventions and must be unique. Radio group names are internal handles that are not displayed at runtime.


FRM-12604

FRM-12604: Valid accelerator key must be entered.

Cause:You entered an invalid accelerator key name in the Accelerator property.

Action:Enter a valid accelerator key name. Valid accelerator keys are ACCELERATOR-1 through ACCELERATOR-10.


FRM-12605

FRM-12605: Valid menu name must be entered.

Cause:You did not give a valid name for your menu.

Action:Supply a valid name.


FRM-12606

FRM-12606: Unable to get the copied/referenced menu item %s in menu %s.

Cause:The specified menu item does not exist in the specified menu.

Action:Check the menu and menu item names, and try again.


FRM-12607

FRM-12607: Invalid command type for this magic menu item.

Cause:The current combination of command type and magic item type is incompatible.

Action:Select a command type that is compatible with the current magic menu item type.


FRM-12700

FRM-12700: Parameter with this name already exists.

Cause:The name specified for the parameter duplicates the name of an existing parameter defined in the same module.

Action:Enter a valid name that is unique among parameters in the active module.


FRM-12701

FRM-12701: Unable to store the current menu parameters.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12702

FRM-12702: Unable to retrieve the menu parameters.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12703

FRM-12703: A 2 character name must be entered and be unique within the menu.

Cause:The menu parameter name is invalid.

Action:Enter a 2-character alphanumeric name for the parameter in the Name field.


FRM-12704

FRM-12704: Value must be at least 1 and less than 65536.

Cause:The parameter Length is invalid.

Action:Enter a valid value in the Length field.


FRM-12705

FRM-12705: Unable to get the copied/referenced menu parameter %s.

Cause:The specified menu parameter does not exist in the database.

Action:Check the menu parameter name, and try again.


FRM-12800

FRM-12800: Role with this name already exists.

Cause:The name specified for the role duplicates an existing role in the database.

Action:Enter a unique role name.


FRM-12801

FRM-12801: Unable to store the current menu role objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12802

FRM-12802: Unable to retrieve the menu role objects.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12803

FRM-12803: Valid role name must be entered and be unique within the list.

Cause:The role Name field is blank.

Action:Enter a valid role name in the Name field.


FRM-12900

FRM-12900: Parameter with this name already exists.

Cause:The name specified for the parameter duplicates that of an existing parameter within the current module.

Action:Enter a unique and valid name for the parameter.


FRM-12901

FRM-12901: Unable to store the current form parameters.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12902

FRM-12902: Unable to retrieve the form parameters.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-12903

FRM-12903: Valid parameter name is required and be unique within the form.

Cause:The Name field is blank.

Action:Enter a valid name for the parameter in the Name field. Form parameter names must follow Oracle naming conventions.


FRM-12904

FRM-12904: Numeric value between 1 and 2000 must be entered.

Cause:The parameter length is invalid.

Action:Enter a valid length in the Length field.


FRM-12905

FRM-12905: Initial value must match data type and be of the proper length.

Cause:The initial value is incompatible with the data type or length of the parameter.

Action:Change the Initial Value, Data Type, or Maximum Length settings.


FRM-12906

FRM-12906: Unable to get the copied/referenced form parameter %s.

Cause:The specified form parameter does not exist in the database.

Action:Check the form parameter name, and try again.


FRM-13000

FRM-13000: A fatal error has occurred.

Cause:An internal error has occurred in the Layout Editor.

Action:Contact your DBA or an Oracle support representative.


FRM-13001

FRM-13001: Unable to accept this canvas.

Cause:An internal error has occurred in the Layout Editor.

Action:Contact your DBA or an Oracle support representative.


FRM-13002

FRM-13002: Stacked and Tab canvases must be created within content canvases.

Cause:An internal error has occurred in the Layout Editor.

Action:Contact your DBA or an Oracle support representative.


FRM-13003

FRM-13003: Unimplemented observer event; close and reopen layout editor.

Cause:An internal error has occurred in the Layout Editor.

Action:Contact your DBA or an Oracle support representative.


FRM-13005

FRM-13005: Dropping objects of this type in the layout editor is not supported.

Cause:An internal error has occurred in the Layout Editor.

Action:Contact your DBA or an Oracle support representative.


FRM-13007

FRM-13007: Unable to create an object's view in the layout editor.

Cause:Forms could not display an object in layout editor.

Action:You may be low on resources; try closing other windows or restarting Forms.


FRM-13504

FRM-13504: There are no stacked canvases for this canvas.

Cause:You selected a view of a stacked view when no stacked views were created.

Action:Define a stacked view before selecting this option.


FRM-15000

FRM-15000: Duplicate relation name.

Cause:There already exists a relation with the same name.

Action:Change the name of the relation.


FRM-15001

FRM-15001: Relation name must be entered and must be unique within the data block.

Cause:There already exists a relation with the same name in the selected block.

Action:Use a unique name for the relation.


FRM-15002

FRM-15002: Master data block is required and must exist in the form.

Cause:You tried to enter a master or detail block name that is invalid.

Action:Type in a valid block name or select a valid block name from the list.


FRM-15003

FRM-15003: Detail data block is required and must exist in the form.

Cause:You tried to enter a master or detail block name that is invalid.

Action:Type in a valid block name or select a valid block name from the list.


FRM-15004

FRM-15004: Error while parsing join condition.

Cause:The join condition is incorrect.

Action:Enter a valid join condition in the multi-line field provided. The join condition defines the relationship between the master block specified in the Master field and the detail block specified in the Detail field.


FRM-15005

FRM-15005: Join condition cannot be null.

Cause:The join condition is undefined.

Action:Enter a valid join condition in the multi-line field provided. The join condition defines the relationship between the master block specified in the Master field and the detail block specified in the Detail field.


FRM-15006

FRM-15006: Master and detail data blocks cannot be the same.

Cause:The master block and detail block are the same.

Action:Specify a different master or detail block.


FRM-15007

FRM-15007: Master-Detail relationship already exists for given data blocks.

Cause:You attempted to create a relation between two blocks that already have a master-detail relationship.

Action:Verify the name of the detail block and retry.


FRM-15008

FRM-15008: Triggers describing master-detail relationships have been modified.

Cause:The triggers describing master-detail relationships between the two data blocks have been manually modified in a way that prevents the code being automatically updated.

Action:Delete and recreate the relation object.


FRM-15009

FRM-15009: Master data block must not be referenced.

Cause:You cannot add new relations to a reference block.

Action:Do not attempt to add a new relation to a reference block.


FRM-15100

FRM-15100: All objects selected must be of the same type.

Cause:You attempted to perform an operation requiring that all objects selected in the Object Navigator be of the same type.

Action:Perform the operation separately for each group of objects that are the the same type.


FRM-15101

FRM-15101: Cannot copy %s because its parent is subclassed.

Cause:You attempted to perform an operation on an object that is owned by a referenced object.

Action:You can only perform the operation on the object's parent or on the object that is the source of the reference. You can find the module that the source object is in by viewing the reference information in the Properties window.


FRM-15102

FRM-15102: Property class inherits from itself.

Cause:You tried to assign a property class to itself. In other words, you are trying to make the parent property class the same as the property class you are editing.

Action:Assign another property class to the object.


FRM-15103

FRM-15103: Can't delete %s because its parent is subclassed.

Cause:You tried to delete an object which is owned by a subclassed object. Forms does not allow you to remove any of a subclassed object's descendant objects."

Action:Since you cannot delete the object, consider disabling the object by modifying the appropriate property in the Properties Palette.


FRM-15104

FRM-15104: Can't move %s because its parent is subclassed.

Cause:You tried to move (reorder) an object which is owned by a subclassed object.

Action:Consider reordering in the source of the owning object. You can find the module that the source object is in by viewing the subclass information in the Properties window.


FRM-15107

FRM-15107: Cannot create a reference.

Cause:You tried to create a referenced object and the system does not have sufficient information to create the reference.

Action:Make sure that the source of the referencing has been saved to either the file system or the database. A new form that has not be saved cannot be the source of a reference.


FRM-15108

FRM-15108: Cannot create an object before an inherited object.

Cause:You tried to add or delete subobjects from a referenced object.

Action:If you need to change a referenced object's structure, you must perform the operation at the source of the reference. You can find the source of the reference by viewing the reference information in the Properties window for that object.


FRM-15109

FRM-15109: Source module must be saved before subclassing.

Cause:You tried to reference a source module that has not been saved.

Action:Save the source module and reestablish the reference.


FRM-15110

FRM-15110: Can't delete %s because it belongs to a subclassed object group.

Cause:You tried to delete an object which belongs to a subclassed object group.

Action:If you don't want all the objects in the subclassed object group, then you might consider either subclassing the desired objects individually, or creating an object group which contains only the desired objects.


FRM-15111

FRM-15111: Can't create an item because the module has no blocks.

Cause:You tried to create an item in a form which contains no blocks.

Action:Switch back to Ownership View and create a new block.


FRM-15200

FRM-15200: There are cycles in this module.

Cause:There is a cycle of submenu references in the module.

Action:Find and fix the cycles before generating. Use Expand All to help find cycles.


FRM-15201

FRM-15201: Cannot expand because a cycle would be created.

Cause:The selected item refers to a menu that is also an ancestor of that item.

Action:Fix the cycle before expanding.


FRM-15202

FRM-15202: There are references to non-existent submenus in this module.

Cause:The module contains items that refer to submenus that do not exist.

Action:Fix the non-existent references before generating.


FRM-15203

FRM-15203: Cannot expand because submenu does not exist.

Cause:There is a cycle of submenu references in the module.

Action:Find and fix the cycles before generating. Use Expand All to help find cycles.


FRM-15204

FRM-15204: Cannot drag menus and menu items at the same time.

Cause:You tried to drag a multiple selection that contains menus and menu items.

Action:Drag menus one at a time.


FRM-15205

FRM-15205: Cannot drag more than one menu at once.

Cause:You tried to drag a multiple selection of menus.

Action:Drag menus one at a time.


FRM-15206

FRM-15206: Cannot modify referenced menu or menu item.

Cause:Referenced objects cannot be modified.

Action:If you need to change a referenced object's structure, you must perform the operation at the source of the reference. You can find the source of the reference by viewing the reference information in the Properties window for that object.


FRM-15207

FRM-15207: Parent item requires type change before submenu is attached.(Code may be lost.)

Cause:The parent item is a type that cannot have a submenu.

Action:Change the parent type before attaching the submenu.


FRM-15208

FRM-15208: Unable to start the Menu Editor.

Cause:Forms was unable to start up the Menu Editor due to an internal error.

Action:Contact your DBA or an Oracle support representative.


FRM-15400

FRM-15400: Unable to load the Chart Wizard.

Cause:Either an internal error occurred, or Oracle Graphics was not properly installed.

Action:Make sure Oracle Graphics is properly installed.


FRM-15401

FRM-15401: Unable to load the specified Graphics Designer (OGD) file.

Cause:The OGD filen specified in the Filename property of the chart item could not be found.

Action:Make sure the specified OGD file exists in the specified location.


FRM-15402

FRM-15402: Unable to run the Chart Wizard.

Cause:Either an internal error occurred, or Oracle Graphics was not properly installed.

Action:Contact your DBA or an Oracle support representative.


FRM-15403

FRM-15403: Unable to display the Chart Item.

Cause:Forms could not obtain a VGS display list from the Graphics Designer (OGD) file.

Action:Make sure the specified file is a valid OGD file, or try recreating the OGD file.


FRM-15404

FRM-15404: Unable to set attributes in the Graphics Designer (OGD) file.

Cause:Forms could not apply the attributes from the Chart Wizard to the OGD file.

Action:Make sure the specified file is a valid OGD file, or try recreating the OGD file.


FRM-15405

FRM-15405: Unable to create a new Graphics Designer (OGD) file.

Cause:Either an internal error occurred, or you do not have permission to create a file in the specified location.

Action:Make sure you are allowed to create files in the specified location, and that Oracle Graphics is properly installed.


FRM-15501

FRM-15501: This is not a referenced object.

Cause:You tried to edit the reference information for a non-referenced object.

Action:There is no reference information for this object. Do not try to edit the reference information.


FRM-15502

FRM-15502: This built-in trigger name is not valid at this level.

Cause:You tried to create an invalid trigger for an object type.

Action:Make sure you define the trigger for the appropriate level.


FRM-15503

FRM-15503: This is a referenced subobject.

Cause:You tried to edit the reference information for a subobject of a referenced object.

Action:If you need to change a referenced object's structure, you must perform the operation at the source of the reference. You can find the source of the reference by viewing the reference information in the Properties window for that object.


FRM-15504

FRM-15504: Cannot retrieve list of VBX control names.

Cause:Unable to locate list of VBX control names.

Action:Reinstall VBX control files.


FRM-15505

FRM-15505: Cannot retrieve list of VBX control properties.

Cause:Unable to locate list of VBX control properties.

Action:Reinstall VBX control files.


FRM-15506

FRM-15506: Cannot retrieve list of OLE classes.

Cause:Cannot communicate with the registration database.

Action:Reinstall OLE servers.


FRM-15507

FRM-15507: This selection would create a circular reference.choose another object.

Cause:You are trying to assign a property class A to property class B, but property class A is defined as inheriting from property class B.

Action:Do not attempt to make a circular reference.


FRM-17000

FRM-17000: Data type is not valid for this object type.

Cause:You selected a data type that is not valid for the type of object.

Action:Select another data type.


FRM-17001

FRM-17001: Items displayed must not be greater than records displayed in data block.

Cause:You tried to set the Items Displayed property of an item to a number larger than the Records displayed property in the block.

Action:Make sure the Records displayed property is greater than or equal to the Items displayed property.


FRM-17002

FRM-17002: There is no tenant for this control.

Cause:You tried to edit a property which requires the control to be populated with a tenant.

Action:From the layout editor, insert a tenant into the control using the Insert Object command.


FRM-17003

FRM-17003: The control must be visible in the layout editor to view this property.

Cause:You tried to edit a property which requires the control to be visible in the layout edtior.

Action:Open the layout editor for the canvas to which this control is assigned.


FRM-17004

FRM-17004: There is no help available for this control.

Cause:Forms could not locate a help file for this control.

Action:Make sure the control is properly installed, or reinstall the control.


FRM-17005

FRM-17005: Cannot determine the name of the control's class.

Cause:Forms could not open the help file because the control's class name is not available.

Action:Make sure the control is properly installed, or reinstall the control.


FRM-18100

FRM-18100: Failed to compile the library.

Cause:Generation of the library was unsuccessfull

Action:Verify that all of the program units have been compiled successfully.


FRM-18101

FRM-18101: Failed to start up the Information Navigator.

Cause:The Information Navigator failed to start up.

Action:Verify that the Information Navigator has been installed correctly.


FRM-18102

FRM-18102: Failed to initialize the error dialog.

Cause:Forms could not create the default error dialog.

Action:Check your development environment.


FRM-18103

FRM-18103: Failed to initialize the Development Environment.

Cause:Forms could not start the Development Environment.

Action:Check your development environment.


FRM-18104

FRM-18104: Failed to start the Object Navigator.

Cause:Forms could not start the Object Navigator.

Action:Check your development environment.


FRM-18105

FRM-18105: Failed to start the Help System.

Cause:Forms could not start the Help System.

Action:Check your development environment.


FRM-18106

FRM-18106: Failed to create the Layout Editor context.

Cause:Forms could not create the layout editor context.

Action:Check your development environment.


FRM-18107

FRM-18107: Failed to create a DE context for the module.

Cause:Forms could not create the DE context for the module.

Action:Check your development environment.


FRM-18108

FRM-18108: Failed to load the following objects.

Cause:Forms could not load the foreign references specified.

Action:Verify that all the referenced forms and object libraries are present.


FRM-21011

FRM-21011: PL/SQL unhandled exception %s.


FRM-30004

FRM-30004: Module name must be specified.

Cause:Module name was not supplied, or the module name you supplied cannot be used.

Action:Enter a valid module name.


FRM-30009

FRM-30009: No blocks were entered.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30012

FRM-30012: Block must have at least one item.

Cause:You did not enter any items in the block.

Action:Enter items in the block or recreate the block.


FRM-30013

FRM-30013: No such item %s in block %s.

Cause:You referenced an item that does not exist in the current block.

Action:Check the name of the item, and do one of the following:

1. Remove the reference to the item.

2. Correct the name of the item.


FRM-30014

FRM-30014: No such block %s.

Cause:You referenced a block that does not exist in the current form.

Action:Check the name of the block, and do one of the following:

1. Remove the reference to the block.

2. Correct the name of the block.


FRM-30015

FRM-30015: Ambiguous item name %s.

Cause:You entered an item name that exists in more than one block.

Action:To make the item name unique, specify the block name. Use the block_name.item_name format (e.g., EMP.SALARY).


FRM-30016

FRM-30016: No such item %s.

Cause:You referenced an item that does not exist in the current form.

Action:Check the name of the item, and do one of the following:

1. Remove the reference to the item.

2. Correct the name of the item.


FRM-30018

FRM-30018: Internal error: Unable to allocate memory.

Cause:You may be out of memory, or there may be a memory corruption.

Action:Contact your DBA.


FRM-30020

FRM-30020: Internal error: Unable to allocate VGS context.

Cause:An error occurred while trying to allocate VGS context for the layout editor.

Action:Contact your Oracle support representative.


FRM-30021

FRM-30021: Internal error: Unable to build VGS boilerplate information.

Cause:Internal error caused by corrupted boilerplate data.

Action:Contact your Oracle support representative.


FRM-30028

FRM-30028: WHERE clause too long.

Cause:The SQL statement that you entered as part of a V2 trigger is too long.

Action:Shorten the statement (maximum length = 4096 characters).


FRM-30029

FRM-30029: Cannot find window %s.

Cause:The window is set to an invalid parent window.

Action:Set the window to a valid parent window.


FRM-30032

FRM-30032: Number of records displayed must be between 1 and 255.

Cause:The number of records displayed is not in the valid range. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30033

FRM-30033: Records buffered must exceed records displayed.

Cause:The number of records buffered was not greater than the number of records displayed. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30040

FRM-30040: Not a valid item type.

Cause:You entered an invalid item type. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30041

FRM-30041: Position of item places it off of canvas.

Cause:You specified invalid Y coordinates for the item.

Action:Specify coordinates within a canvas.


FRM-30042

FRM-30042: Length of item must be between 1 and 133.

Cause:The item length you entered was not in the valid range. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30043

FRM-30043: Length of item must be between 1 and 255.

Cause:The item length you entered was not in the valid range. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30044

FRM-30044: Display length must be between 1 and 133 but not more than length.

Cause:The item length you entered was not in the valid range. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30045

FRM-30045: Query length of item must be 0 (default) or greater than actual length.

Cause:You entered an invalid query length. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30046

FRM-30046: Internal error: unable to adjust pointer.

Cause:An internal compilation error occurred.

Action:Contact your Oracle support representative.


FRM-30047

FRM-30047: Cannot resolve item reference %s.

Cause:The item referenced does not exist.

Action:Change the reference or create the item.


FRM-30048

FRM-30048: Unable to find record group %s.

Cause:The record group specified within the LOV object is invalid.

Action:Check the record group name or ID specified.


FRM-30049

FRM-30049: Unable to build column mapping.

Cause:Reference to record group columns within the LOV object cannot be found.

Action:Check the column names specified within the LOV object.


FRM-30051

FRM-30051: Internal error: unable to prepare heaps for output.

Cause:An internal compilation error occurred.

Action:Contact your Oracle support representative.


FRM-30052

FRM-30052: Named visual attribute %s does not exist.

Cause:You assigned an undefined visual attribute name to an object.

Action:Check the visual attribute name and try again.


FRM-30053

FRM-30053: Cannot create unnamed visual attribute.

Cause:Caused by an internal error, or memory allocation error.

Action:Contact your DBA or an Oracle support representative.


FRM-30054

FRM-30054: Cannot find canvas %s.

Cause:You specified an invalid canvas name or ID specified.

Action:Check the canvas name or ID and try again.


FRM-30056

FRM-30056: Warning! Prompt for item %s.%s was truncated.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30057

FRM-30057: Maximum record length for record group exceeded.

Cause:You specified too many columns.

Action:Do not add additional columns to this record group.


FRM-30058

FRM-30058: Invalid name for a record group column %s.

Cause:You specified an invalid column name.

Action:Check the column name and try again.


FRM-30059

FRM-30059: Duplicate column name %s.

Cause:You specified a column name that already exits

Action:Specify a unique column name.


FRM-30060

FRM-30060: Unable to create column descriptor %s.

Cause:Internal error, or memory allocation error.

Action:Contact your DBA or an Oracle support representative.


FRM-30061

FRM-30061: Unable to remove INTO clause from statement %s.

Cause:Bind variable substitution error: a SELECT statement within an LOV or record group is incorrect.

Action:Check the syntax of the SELECT statement, and add the INTO clause.


FRM-30062

FRM-30062: Unable to perform bind variable substitution for statement %s.

Cause:Referenced bind variable does not exist.

Action:Create the variable, or correct the reference.


FRM-30063

FRM-30063: Unable to open cursor for parse of record group query %s.

Cause:You may have lost connection with the database.

Action:Check the database connection, or contact your DBA.


FRM-30064

FRM-30064: Unable to parse statement %s.

Cause:A syntax error occurred in the SELECT statement within an LOV or record group.

Action:Check the statement, and add the FROM clause.


FRM-30065

FRM-30065: Column type %d not supported.

Cause:The specified column type was not CHAR, NUMBER, or DATE.

Action:Change the column type to one supported by Form Builder.


FRM-30069

FRM-30069: Not a valid trigger name.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30081

FRM-30081: SQL statement is too long.

Cause:You entered an SQL statement (as part of a V2 trigger) that exceeds the maximum allowable length.

Action:Shorten the statement to 4096 characters or less.


FRM-30082

FRM-30082: Non-SELECT statements not allowed in non-commit triggers.

Cause:The trigger contains a SQL statement other than a SELECT statement.

Action:Move the statement to a trigger where the non-SELECT SQL statement is valid.


FRM-30083

FRM-30083: Unable to find editor %s.

Cause:The editor name referenced does not exist.

Action:Create the editor, or delete the reference.


FRM-30084

FRM-30084: Unable to find LOV %s.

Cause:The referenced LOV name does not exist.

Action:Specify another LOV name, or delete the reference.


FRM-30085

FRM-30085: Unable to adjust form for output.

Cause:Caused by an internal error, or memory allocation error.

Action:Contact your DBA or an Oracle support representative.


FRM-30087

FRM-30087: Unable to create form file %s.

Cause:You lack privileges in the specified directory, or you do not have the disk space required.

Action:Contact your DBA to make sure you have the access privileges you need.


FRM-30089

FRM-30089: Cannot find property class %s

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30091

FRM-30091: Too many trigger steps.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30092

FRM-30092: Too many ranges.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30093

FRM-30093: Too many triggers.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30094

FRM-30094: Too many item pointers.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30096

FRM-30096: Could not create form output file %s.

Cause:An operating system error prevented Form Builder from creating an output file.

Action:Contact your DBA or an Oracle support representative.


FRM-30100

FRM-30100: Block must have at least one primary key item.

Cause:A block with either UPDATEABLE_PRIMARY_KEY or NON_UPDATEABLE_PRIMARY_KEY must have at least one item marked as being part of the primary key.

Action:Mark one of the items as being part of the primary key and re-compile.


FRM-30101

FRM-30101: Too many strings.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30102

FRM-30102: Could not write all of the output file.

Cause:An operating system error prevented Form Builder from creating an output file.

Action:Contact your DBA or an Oracle support representative.


FRM-30109

FRM-30109: Item %s.%s is right-adjusted and scrolled.

Cause:An item can be either a scrolled item or a right-adjusted item, but not both.

Action:Define the item either as scrolled or right-adjusted.


FRM-30110

FRM-30110: You must enter Y, *Y, **Y, N, *N, or **N.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30112

FRM-30112: Warning! %s resolves to item in block PARAMETER.

Cause:You pointed to a field, not a parameter.

Action:Be sure this is what you intended.


FRM-30113

FRM-30113: Block must have non-query-only database item.

Cause:A block that allows updating and inserting must have at least one item derived from the database.

Action:Create a derived item in the block.


FRM-30118

FRM-30118: Could not create warning message file %s.

Cause:An operating system error prevented Form Builder from creating the warning file.

Action:Contact your DBA or an Oracle support representative.


FRM-30119

FRM-30119: Errors and warnings written to file %s.

Cause:Compilation error.

Action: Check the errors and warnings in the specified file.


FRM-30120

FRM-30120: Version 1 macro %s not supported.

Cause:You used an Forms version 1.0 macro (#MACRO, #MACROIF, or #KEY) that is not supported by later versions of Form Builder.

Action:Replace the macro with the appropriate later version equivalent.


FRM-30121

FRM-30121: Error in the INTO clause, or missing FROM clause.

Cause:A V2-style trigger contains an improper SQL statement.

Action:Correct the SQL statement.


FRM-30122

FRM-30122: Invalid line number.

Cause:An invalid Y position was given for an item. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30123

FRM-30123: Invalid column number.

Cause:An invalid X position was given for an item. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30124

FRM-30124: Too many procedures.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30125

FRM-30125: Too much library-unit memory.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30129

FRM-30129: Compilation error on procedure specification for procedure %s.

Cause:You tried to compile a procedure that contains an invalid specification.

Action:Correct the specification.


FRM-30130

FRM-30130: Code given for trigger %s is not an anonymous block.

Cause:You entered trigger text that was not an anonymous block.

Action:Rewrite the trigger to make it an anonymous block.


FRM-30131

FRM-30131: Invalid parameter reference in trigger %s.

Cause:You entered trigger text that references parameters.

Action:Remove the parameter references from the trigger. HINT: to use parameters, write a form-level procedure.


FRM-30132

FRM-30132: Code given for trigger %s is not executable.

Cause:You entered trigger text that is not executable.

Action:Rewrite the trigger.


FRM-30133

FRM-30133: Compilation error on trigger %s.

Cause:You entered invalid trigger text.

Action:View compilation errors on the error screen.


FRM-30134

FRM-30134: Mismatched procedure and unit names for procedure %s.

Cause:The procedure name does not match the name defined in the procedure text.

Action:Change the names to match each other.


FRM-30135

FRM-30135: Code given for procedure %s is not a named unit.

Cause:You entered an anonymous block when you should have entered a form-level procedure.

Action:Rewrite the form-level procedure.


FRM-30136

FRM-30136: Code given for procedure %s is not executable.

Cause:You entered non-executable code for the specified form-level procedure.

Action:Rewrite the form-level procedure.


FRM-30137

FRM-30137: Compilation error on procedure %s.

Cause:You entered an incorrect form-level procedure.

Action:See the error screen for the compilation errors.


FRM-30145

FRM-30145: Too many bind variables.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30148

FRM-30148: Too much buffer memory.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30149

FRM-30149: Too many LOVs.

Cause:Internal ORACLE error.

Action:Contact your DBA or an Oracle support representative.


FRM-30150

FRM-30150: Error in LOV text for item %s.%s.

Cause:You specified an invalid SQL statement in the LOV.

Action:Rewrite the SQL statement.


FRM-30152

FRM-30152: Unable to connect to database.

Cause:Internal system error.

Action:Contact your DBA or an Oracle support representative.


FRM-30156

FRM-30156: Could not close form output file %s.

Cause:An operating system error prevented Form Builder from closing an output file.

Action:Contact your DBA or an Oracle support representative.


FRM-30157

FRM-30157: LONG item length must be between 1 and 65534.

Cause:Length of the LONG item was not in the valid range. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30158

FRM-30158: Display length must be between 0 and 133.

Cause:Display length was not in the valid range. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30159

FRM-30159: No text in trigger statement.

Cause:An empty trigger step was found. The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-30169

FRM-30169: Username and password are required.

Cause:You have not specified your username and password in order to connect to the database.

Action:Specify your username and password.


FRM-30170

FRM-30170: Alert must contain at least one button - %s.

Cause:The alert contains no buttons.

Action:Create at least one button for the alert.


FRM-30172

FRM-30172: No such item.

Cause:You specified an item that does not exist within the referenced record group.

Action:Correct the reference.


FRM-30173

FRM-30173: Module contains no canvases.

Cause:You attempted to compile a form module that does not contain a canvas.

Action:Define at least one canvas for the form module.


FRM-30174

FRM-30174: Checked and Unchecked check box values must be distinct.

Cause:The check box has equal values for the Checked and Unchecked states.

Action:Check the values and try again.


FRM-30179

FRM-30179: Cannot find block %s

Cause:The block name you specified does not exist.

Action:Check the block name and try again.


FRM-30180

FRM-30180: No radio buttons in the radio group.

Cause:A radio group was defined without radio buttons.

Action:Define at least one radio button for the radio group.


FRM-30182

FRM-30182: Image item length must be at least 1024..

Cause:The maximum lenght of the image must exceed 1024.

Action:Increase the size of your image to the maximum length.


FRM-30184

FRM-30184: Other Value not found.

Cause:The Other Value defined does not match one of the valid values or label strings.

Action:Define a valid Other Value.


FRM-30185

FRM-30185: Record group %s contains more than one column of type LONG.

Cause:A record group can contain only one LONG column.

Action:Do one of the following:

1. Remove all but one of the LONG columns in the record group.

2. Change the types of all but one of the LONG columns in the record group.


FRM-30187

FRM-30187: Size of CHAR column in record group must be between 1 and 2000.

Cause:The size of a character column in the record group was incorrectly specified

Action:Make sure the sizes of the character columns in the record group are between 1 and 2000


FRM-30188

FRM-30188: No initial value given, and other values are not allowed (item %s.%s).

Cause:No initial value given for item.

Action:Provide an initial value for item.


FRM-30190

FRM-30190: No list items defined for T-List.

Cause:You defined an empty T-list.

Action:Define items in the T-List.


FRM-30191

FRM-30191: No list items defined for required poplist.

Cause:You defined an empty poplist.

Action:Define items in the poplist.


FRM-30193

FRM-30193: Format mask not allowed on JDATE item %s.%s.

Cause:Format masks are valid only for NUMBER, DATE, TIME, and DATETIME items.

Action:Remove the format mask from the JDATE item.


FRM-30195

FRM-30195: Format mask not allowed on EDATE item %s.%s.

Cause:Format masks are valid only for NUMBER, DATE, TIME, and DATETIME items.

Action:Remove the format mask from the EDATE item.


FRM-30196

FRM-30196: Too many user-named triggers.

Cause:You have defined more user-named triggers than Forms can allocate memory for.

Action:Define fewer user-named triggers.


FRM-30197

FRM-30197: Unable to add row to record group.

Cause:You must create the record group and add columns before attempting to add rows.

Action:Make sure the record group you are specifying exists.


FRM-30199

FRM-30199: Transactional triggers do not exist for this block

Cause:You referenced a transactional trigger, but none exist for this module.

Action:Create the trigger, or delete the reference.


FRM-30201

FRM-30201: Error occurred during form upgrade.

Cause:An error occurred during an SQL*Forms 3.0 to Forms 4.5 conversion.

Action:Check accompanying error messages (if any), or contact your DBA or an Oracle support representative.


FRM-30203

FRM-30203: No items on block %s.

Cause:You attempted to compile a form module that contains a block with no items.

Action:Define some items for the block.


FRM-30204

FRM-30204: Total data length of the items in this block is too large.

Cause:The field length of the item exceeds the limit.

Action:Reduce the item field length.


FRM-30205

FRM-30205: Cannot resolve parameter reference %s.

Cause:The referenced parameter could not be found.

Action:Declare the parameter, or remove the reference.


FRM-30207

FRM-30207: Mouse Navigate must be Yes for combo box item %s.%s

Cause:The Mouse Navigate property must be set to Yes for a combo box.

Action:Set the property value to Yes.


FRM-30209

FRM-30209: Module contains no windows.

Cause:A form module must have at least one window defined.

Action:Define a window for the form module.


FRM-30213

FRM-30213: High range value must be greater than low range value.

Cause:The high range value is greater than the low range value for text items.

Action:Define a high range value that is greater than the low range value.


FRM-30305

FRM-30305: Cannot open library file %s.

Cause:The VBX control properties have changed.

Action:Redefine the VBX properties.


FRM-30306

FRM-30306: Unable to save the library %s.

Cause:The VBX control properties have changed.

Action:Redefine the VBX properties.


FRM-30307

FRM-30307: Unable to load procedures from the library.

Cause:The VBX control properties have changed.

Action:Redefine the VBX properties.


FRM-30308

FRM-30308: Unable to allocate memory.

Cause:The VBX control properties have changed.

Action:Redefine the VBX properties.


FRM-30309

FRM-30309: No PL/SQL code in the library.

Cause:The VBX control properties have changed.

Action:Redefine the VBX properties.


FRM-30311

FRM-30311: Cannot attach libraries.

Cause:The VBX control properties have changed.

Action:Redefine the VBX properties.


FRM-30312

FRM-30312: Failed to compile the library.

Cause:The VBX control properties have changed.

Action:Redefine the VBX properties.


FRM-30351

FRM-30351: No list elements defined for list item.

Cause:A combo list must contain list elements.

Action:Define items for a combo list.


FRM-30352

FRM-30352: Invalid mirror item name %s for item %s.%s.

Cause:An invalid mirror item name was defined for the item.

Action:Use a valid mirror item name.


FRM-30353

FRM-30353: No VBX control file specified for VBX item.

Cause:No VBX control file is specified.

Action:Specify a VBX control file in the Form Builder.


FRM-30354

FRM-30354: No VBX control name specified for VBX item.

Cause:No VBX control name is specified.

Action:Specify a VBX control name in the Form Builder.


FRM-30355

FRM-30355: Too many mirror items specified for item %s.

Cause:The number of mirror items exceeds the maximum of 100.

Action:Make sure you do not exceed the maximum number of mirror items.


FRM-30356

FRM-30356: Too many records displayed for this item.

Cause:The number of records displayed for the item exceeds the number of records displayed for the block.

Action:Reduce the number of displayed records for the item.


FRM-30357

FRM-30357: Item specifies itself as its mirror item.

Cause:You set an item's Mirror Item property to the item itself.

Action:Specify another valid item for the mirror item property.


FRM-30358

FRM-30358: Item's mirror item %s also specifies a mirror item.

Cause:You set an item's Mirror Item property to an item that also specifies a mirror item.

Action:Specify an item that is not a mirror item.


FRM-30359

FRM-30359: Item specifies non-existent canvas %s.

Cause:You specified a canvas that does not exist.

Action:Specify a valid canvas.


FRM-30360

FRM-30360: Alert does not contain the specified default button.

Cause:You specified a default button that is not part of the alert definition.

Action:Specify a label for the default button or specify a valid default button.


FRM-30361

FRM-30361: Invalid initial value for check box.

Cause:You specified an initial value for a check box item that does not match the values of the Checked or Unchecked states.

Action:Specify a valid initial value.


FRM-30362

FRM-30362: Initial value does not match available list elements.

Cause:You specified a value that does not match a value on the available list of elements.

Action:Specify a valid value.


FRM-30363

FRM-30363: Initial value matches none of the radio buttons.

Cause:You specified a value that is not associated with a radio button in a radio group.

Action:Specify a value associated with a radio button in the radio group.


FRM-30364

FRM-30364: Other value matches none of the radio buttons.

Cause:You specified a value that is not the name of a radio button or a value associated with a radio button from a radio group.

Action:Specify a name of a radio button in the radio group or a value associated with a radio button from the radio group.


FRM-30367

FRM-30367: OLE item cannot specify a mirror item.

Cause:You used an OLE item to specify a mirror item.

Action:You cannot mirror OLE items. Use another item to specify a mirror item.


FRM-30368

FRM-30368: Item specifies a tab page %s that does not exist.

Cause:You specified an invalid tab page name.

Action:Make sure the tab page name exists on the tab canvas for this item.


FRM-30369

FRM-30369: Popup menu item specifies non-existent submenu %s.

Cause:You specified an invalid submenu name.

Action:Check the submenu name and try again.


FRM-30370

FRM-30370: Popup menu must have at least one item.

Cause:The popup menu has no items in it.

Action:Add at least one menu item to the popup menu.


FRM-30373

FRM-30373: Invalid command type specified for popup menu item.

Cause:You selected a command type that is not valid for popup menu items.

Action:Select a command type that is valid for popup menu items.


FRM-30374

FRM-30374: Invalid item type for popup menu item.

Cause:You selected an invalid item type for a popup menu item.

Action:Select a valid item type.


FRM-30375

FRM-30375: Datatype for non-Min/Max summary item must be Number.

Cause:A summary item with a summary function of Count, Sum, Avg, Variance, or Stdev has a datatype other than Number.

Action:Remove the summary item or change its datatype to Number.


FRM-30376

FRM-30376: Datatype for Min/Max summary item must match summarized item.

Cause:A summary item with a summary function of Min or Max has a datatype that does not match the datatype of the summarized item.

Action:Remove the summary item or change its datatype to match the datatype of the summarized item.


FRM-30377

FRM-30377: Summary item must reside in single-record block or in same block as summarized item.

Cause:A summary item resides in a different block from the summarized item, and the summary item's block does not have its Single Record property set to Yes.

Action:Move the summary item to the block that contains the summarized item, or to a block with the Single Record property set to Yes.


FRM-30378

FRM-30378: Summarized item must not be summary item and must not reside in single-record block.

Cause:A summary item specifies one of the following as its summarized item:

1. Another summary item.

2. An item in a block with the Single Record property set to Yes.

Action:Remove the summary item, or change it to summarize a non-summary item in a block with the Single Record property set to No.


FRM-30380

FRM-30380: There is a circular chain of dependent calculated items:

Cause:There is a circular chain of calculated items, such that the value of each item in the chain depends on the value of the next item in the chain.

The items in the chain are listed below the error message.

Action:Remove an item in the chain, or change an item in the chain so that it does not depend on any other item in the chain.

For a formula item, you must ensure that neither the formula nor any function or procedure that it calls refers to any item in the chain.

For a summary item, you must ensure that the item it summarizes is not in the chain.


FRM-30390

FRM-30390: Warning: Hint property ignored for calculated item %s.%s.

Cause:The Hint property was specified for a calculated item. It will be ignored.

Action:No action required.


FRM-30391

FRM-30391: Warning: Copy Value from Item property ignored for calculated item %s.%s.

Cause:The Copy Value from Item property was specified for a calculated item. It will be ignored.

Action:No action required.


FRM-30392

FRM-30392: Warning: Initial Value ignored for calculated item %s.%s.

Cause:The Initial Value property was specified for a calculated item. It will be ignored.

Action:No action required.


FRM-30393

FRM-30393: Warning: Range High Value ignored for calculated item %s.%s.

Cause:The Range High Value property was specified for a calculated item. It will be ignored.

Action:No action required.


FRM-30394

FRM-30394: Warning: 'Range Low Value' ignored for calculated item %s.%s.

Cause:The 'Range Low Value' property was specified for a calculated item. It will be ignored.

Action:No action required.


FRM-30395

FRM-30395: Other Values required for calculated item.

Cause:The Mapping of Other Values property was not specified for a calculated item that is a check box, list item, or radio group.

Action:Set the Mapping of Other Values property for the item.


FRM-30396

FRM-30396: Summary Function required for summary item.

Cause:The Summary Function property was specified as None for a summary item.

Action:Set the Summary Function property to a value other than None.


FRM-30397

FRM-30397: Warning: Summary Function ignored for non-summary item %s.%s.

Cause:The Summary Function property was specified for an item which is not a summary item. It will be ignored.

Action:No action is necessary. To prevent the warning in the future, set the Summary Function property to None.


FRM-30398

FRM-30398: Summarized Block Name and Summarized Item Name properties are required for summary items.

Cause:The Summarized Block Name and Summarized Item Name properties were not set for a summary item.

Action:Specify values for the properties.


FRM-30399

FRM-30399: Warning: Summarized Item Name ignored for non-summary item %s.%s.

Cause:The Summarized Block Name or Summarized Item Name property was specified for an item which is not a summary item. It will be ignored.

Action:No action required.


FRM-30400

FRM-30400: Formula required for formula item.

Cause:The Formula property was not specified for a formula item.

Action:Specify the Formula property.


FRM-30401

FRM-30401: Warning: Formula ignored for non-formula item %s.%s.

Cause:The Formula property was specified for an item which is not a formula item. It will be ignored.

Action:No action is necessary. To prevent the warning in the future, clear the Formula property.


FRM-30402

FRM-30402: Calculated item cannot be an LOV return item.

Cause:A calculated item is specified as a return item in the column mapping for an LOV.

Action:Remove the return item, or specify an item that is not a calculated item.


FRM-30403

FRM-30403: Calculated item cannot specify a mirror item, or be specified as a mirror item.

Cause:A calculated item specifies a Mirror Item, or is specified as a Mirror Item by some other item in the block.

Action:Remove the Mirror Item property. To make two calculated items effectively mirror each other, make one a formula item whose formula is simply ':' followed by the name of the other calculated item.


FRM-30404

FRM-30404: Summarized item's Item Type must not be Button, Chart, Image, Sound, or OLE Container.

Cause:A summary item specifies a summarized item which is a Button, Chart, Image, Sound, or OLE Container. Such an item has no associated data value and thus cannot be summarized.

Action:Remove the summary item, or change its summarized item to be an item which has an associated data value.


FRM-30405

FRM-30405: Datatype for Sum/Avg/Variance/Stddev summarized item must be Number.

Cause:A summary item whose summary function is Sum, Avg, Variance, or Stdev specifies a summarized item with a datatype other than Number.

Action:Remove the summary item or change its summarized item to have a datatype of Number.


FRM-30406

FRM-30406: Block with array DML must have required primary key items.

Cause:The data block's DML Array Size property value is greater than 1, but no data block items have the Primary Key property set to Yes.

Action:Do one of the following:

1. Specify a primary key for the data block by setting the Primary Key property value to Yes for one or more items.

2. Set the data block's DML Array Size property to 1.


FRM-30407

FRM-30407: Block must have at least one database item.

Cause:The form module contains a data block with no database items.

Action:Define at least one database item for the data block.


FRM-30408

FRM-30408: Invalid value.

Cause:The value entered for the specified datatype is invalid.

Action:Correct one or more of the following:

1. The datatype of the argument corresponding to the given value in the procedure argument list of the specified procedure.

2. The value of the argument in the procedure argument list of the specified procedure.


FRM-30409

FRM-30409: Delete Record Behavior for the relation is invalid.

Cause:The Delete Record Behavior of the relation is incompatible with its detail data block.

Action:Modify one of the following:

1. The Delete Record Behavior of the relation.

2. The DML Data Target Type/Query Data Source Type of the detail data block. (If the Delete Record Behavior of the relation is Cascading, then the DML Data Target Type of the detail data block must be Table. If the Delete Record Behavior of the relation is Isolated, then the Query Data Source Type of the detail data block must be Table.)


FRM-30410

FRM-30410: Warning: Single Record property ignored for non-control block %s.

Cause:A block specifies the 'Single Record' property as 'Yes', but it also specifies a Query Data Source or a DML Data Target.

Action:No action is necessary. To prevent the warning in the future, set the 'Single Record' property to 'No'.


FRM-30411

FRM-30411: A memory allocation failed. Re-compile the form, specifying compile_all=yes.

Cause:A memory allocation failed while calculated item dependency information was being computed.

Action:Do one of the following. Compile the form module:

1. 'Stand-alone' (not from within Form Builder), specifying that all PL/SQL code is to be compiled.

2. On a machine with more memory.

3. On a machine running fewer concurrent jobs.


FRM-30413

FRM-30413: Relation has no detail block.

Cause:A master-detail relation specifies no detail block.

Action:Specify a detail block.


FRM-30414

FRM-30414: Relation's detail block does not exist.

Cause:A master-detail relation specifies a non-existant detail block.

Action:Specify a detail block that exists.


FRM-30415

FRM-30415: Relation's detail block is a control block.

Cause:A master-detail relation specifies a detail block that's a control block.

Action:Specify a detail block that's a database block.


FRM-30416

FRM-30416: Relation's master block is a control block.

Cause:A master-detail relation specifies a master block that's a control block.

Action:Specify a master block that's a database block.


FRM-30417

FRM-30417: Relation's detail block is the same as its master block.

Cause:A master-detail relation specifies a detail block that's the same block as the master block.

Action:Specify distinct master and detail blocks.


FRM-30418

FRM-30418: Block contains too many items (more than %d) for Windows 3.1.

Cause:The number of items in this block exceeds the maximum allowable per block.

Action:Use fewer items in the block, or divide the items into two or more separate blocks.


FRM-30419

FRM-30419: Block scrollbar specifies a tab page %s that does not exist.

Cause:A scrollbar is assigned to a tab page which does not exist in the form.

Action:Check the tab page name and make sure it exists in the owning canvas for this scrollbar.


FRM-30420

FRM-30420: Cannot compile QUERY-PROCEDURE trigger.

Cause:Query procedure columns and/or Query procedure arguments are not declared properly.

Action:Correct the Query procedure column definitions and/or Query procedure argument definitions.


FRM-30421

FRM-30421: Cannot compile INSERT-PROCEDURE trigger.

Cause:Insert procedure columns and/or Insert procedure arguments are not declared properly.

Action:Correct the Insert procedure column definitions and/or Insert procedure argument definitions.


FRM-30422

FRM-30422: Cannot compile UPDATE-PROCEDURE trigger.

Cause:Update procedure columns and/or Update procedure arguments are not declared properly.

Action:Correct the Update procedure column definitions and/or Update procedure argument definitions.


FRM-30423

FRM-30423: Cannot compile DELETE-PROCEDURE trigger.

Cause:Delete procedure columns and/or Delete procedure arguments are not declared properly.

Action:Correct the Delete procedure column definitions and/or Delete procedure argument definitions.


FRM-30424

FRM-30424: Cannot compile LOCK-PROCEDURE trigger.

Cause:Lock procedure columns and/or Lock procedure arguments are not declared properly.

Action:Correct the Lock procedure column definitions and/or Lock procedure argument definitions.


FRM-30425

FRM-30425: Summarized database item must reside in a block with Query All Records or Precompute Summaries set to Yes.

Cause:A summary item specifies a summarized item which is a database item in a database block whose Query All Records and Precompute Summaries properties are both set to No.

Action:Remove the summary item or set the Precompute Summaries or Query All Records properties to Yes for the summarized item's block.


FRM-30426

FRM-30426: Summarized control item must reside in a control block, or in a block with Query All Records set to Yes.

Cause:A summary item specifies a summarized item which is a control item in a database block whose Query All Records property is set to No.

Action:Remove the summary item or set the Precompute Summaries property to No and the Query All Records property to Yes for the summarized item's block.


FRM-30427

FRM-30427: Summarized control item cannot reside in a block with Precompute Summaries set to Yes.

Cause:A summary item specifies a summarized control item which is in a block with the Precompute Summaries property set to Yes.

Action:Remove the summary item or set the Precompute Summaries property to No and the Query All Records property to Yes for the summarized item's block.


FRM-30428

FRM-30428: Min/Max summarized item cannot reside in a block with Precompute Summaries set to Yes.

Cause:A summary item with a summary function of Min or Max specifies a summarized item in a block with the Precompute Summaries property set to Yes.

Action:Remove the summary item or set the Precompute Summaries property to No and the Query All Records property to Yes for the summarized item's block.


FRM-30429

FRM-30429: Block with Precompute Summaries must specify Query Data Source Type as Table or FROM clause query.

Cause:A block has its Precompute Summaries property set to Yes, but its Query Data Source Type is set to Procedure or Transactional Triggers.

Action:Set Precompute Summaries to No. If the block contains any summarized items, set Query All Records to Yes.


FRM-30430

FRM-30430: Warning: block %s specifies Precompute Summaries but form's Isolation Mode is not Serializable.

Cause:A block specifies Precompute Summaries as Yes, but the form does not specify Isolation Mode as Serializable.

Action:No action is necessary. However, read consistency cannot be guaranteed. It is possible that actions by other users can occur between the time that summaries are precomputed and the time at which the query is initiated to populate the block. Such actions may cause the summary item values not to match the block's contents.


FRM-30431

FRM-30431: Warning: Duplicate column name %s in block %s.

Cause:One of the following:

There are multiple items with the same database column name.

The column name of one item matches the item name of an item that does not have a column name.

Action:Make sure that the database column names for items are unique.


FRM-30432

FRM-30432: Definition for procedure is not complete.

Cause:Either the columns or the arguments for the procedure are not specified.

Action:Enter both the columns and the arguments in the procedure definition.


FRM-30433

FRM-30433: Query procedure should have only one argument of type REFCURSOR/TABLE and its mode should be IN OUT.

Cause:The query procedure definition has either:

1. No argument of type TABLE/REFCURSOR.

2. Multiple arguments of type TABLE/REFCURSOR.

3. An argument of type TABLE/REFCURSOR with a mode that is not defined as IN OUT.

Action:Define the arguments as follows:

1. Define one and only one argument of type TABLE or REFCURSOR.

2. Declare the mode for the TABLE/REFCURSOR argument as IN OUT.


FRM-30434

FRM-30434: The table argument in the procedure definition should have a type name.

Cause:The type name for the TABLE argument in the given procedure is not entered.

Action:Enter the type name for the TABLE argument in the given procedure.


FRM-30435

FRM-30435: DML procedures should have only one argument of type TABLE and its mode should be IN or IN OUT.

Cause:DML (Insert, Update, Delete, Lock) procedure defintion has either:

1. No argument of type TABLE.

2. Multiple arguments of type TABLE.

3. An argument of type TABLE with a mode defined as OUT.

Action:Define the arguments as follows:

1. Define one and only one argument of type TABLE.

2. Declare the mode for the TABLE argument as IN or IN OUT.


FRM-30436

FRM-30436: Parent window not specified for canvas.

Cause:The canvas does not have a window specified to contain it. Default results are as follows:

1. In Forms 4.0, the canvas is attached to the ROOT_WINDOW.

2. In a Forms 4.5 application, the ROOT_WINDOW may not exist, so the canvas is automatically attached to the first window in the Object Navigator hierarchy.

3. In 5.0, it is possible to reference forms and override properties like Window Name. Thus, you always should set the Window Name property for the canvas.

Action:Set the Window Name property for the canvas.


FRM-31601

FRM-31601: Options -e, -g, -m, -p, and -r are mutually exclusive.

Cause:You specified more than one of these options.

Action:These options are mutually exclusive; do not use them in combination.


FRM-31602

FRM-31602: No module name specified.

Cause:You did not specify a module name.

Action:Specify a module name.


FRM-31603

FRM-31603: No username to grant/revoke.

Cause:You tried to grant Form Builder access to a user, or revoke access, but you did not specify the user.

Action:Re-execute the command and specify the username.


FRM-31605

FRM-31605: Module %s unknown.

Cause:You tried to access a module that does not exist in the database.

Action:Make sure the module name is correct and try again.


FRM-31606

FRM-31606: Could not open file %s.

Cause:Either file privileges are set incorrectly, or the library you attempted to open is invalid.

Action:Recompile the module library and try again.


FRM-31616

FRM-31616: Warning! No items defined for menu %s.

Cause:You are generating a module that has a menu which contains no items.

Action:No action required.


FRM-31627

FRM-31627: Circular reference detected in menu module.

Cause:The menu module you tried to compile contains circular references (instances where a menu item calls a menu that is above it in the hierarchy).

Action:Isolate and resolve the circular reference(s).


FRM-31628

FRM-31628: Item references an undefined menu.

Cause:The item references a submenu that is not part of the module.

Action:Define a submenu as part of the module or make the item reference a submenu that is part of the module.


FRM-31629

FRM-31629: Build errors written to file %s.

Cause:Compilation error.

Action:Refer to errors and warnings in the specified file.


FRM-31631

FRM-31631: Could not close file %s.

Cause:An operating system error prevented Form Builder from closing an output file.

Action:Contact your DBA or an Oracle support representative.


FRM-31633

FRM-31633: Main menu %s not found in module.

Cause:The menu name specified does not exist in this module.

Action:Make sure a menu with this name exists.


FRM-31634

FRM-31634: Error writing file %s.

Cause:You lack privileges in the specified directory, or you do not have the disk space required.

Action:Contact your DBA to make sure you have the access privileges you need.


FRM-31635

FRM-31635: No menu in specified file.

Cause:The file was loaded, but no menu module was found in the file.

Action:Make sure the file is a MMB file.


FRM-31637

FRM-31637: Error performing upgrade. Upgrade aborted.

Cause:SQL error deleted while performing menu upgrade.

Action:Make sure you are running as SYSTEM, and both Oracle Forms 4.5 and the menu tables are correctly installed.


FRM-31639

FRM-31639: No modules to upgrade.

Cause:No module was specified that does not already exist in Oracle Forms 4.5 tables.

Action:Make sure that no menu module with this name already exists in Oracle Forms 4.5.


FRM-31640

FRM-31640: Submenu name not specified.

Cause:A menu item of type menu has no menu specified.

Action:Specify a submenu for the menu item.


FRM-31641

FRM-31641: Radio group items must have radio group name specified.

Cause:Menu item was defined as type radio button, but no radio group was specified.

Action:Specify a radio group name.


FRM-31643

FRM-31643: Menu %s does not exist.

Cause:The menu item was defined as type menu, but the menu it refers to does not exist.

Action:Create a menu with this name.


FRM-31645

FRM-31645: Only one instance of each magic menu type per module is allowed.

Cause:You used more than one instance of a specific magic menu type.

Action:Delete all but one instance of each magic menu type.


FRM-31646

FRM-31646: Magic menu item %s has invalid command type.

Cause:You selected a command type that is not valid for the specific magic menu item.

Action:Select a command type that is compatible with the current magic menu item type.


FRM-31649

FRM-31649: Label for menu item %s is too long.

Cause:You specified a menu item label which has more than the maximum allowable number of characters.

Action:Shorten the menu item label.


FRM-31650

FRM-31650: Name of menu item %s is too long.

Cause:You specified a menu item name which has more than the maximum allowable number of characters.

Action:Shorten the menu item name.


FRM-32009

FRM-32009: Premature end of file at line %05d.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32010

FRM-32010: Input file sequence error at line %05d.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32011

FRM-32011: File doesn't contain valid Run Form source.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32035

FRM-32035: Illegal field type (%s) in %s.%s.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32036

FRM-32036: Warning! Prompt above line 1 for %s.%s.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32037

FRM-32037: Warning! Prompt doesn't fit beside field %s.%s.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32041

FRM-32041: Expected: %s: %s

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32042

FRM-32042: Error (line %05d): expected Yes/No answer, received %s.

Cause:You entered something other than Yes or No.

Action:Answer either Yes or No.


FRM-32051

FRM-32051: Illegal command in form text at line %05d.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.

Cause:The error commonly occurs when the .INP file is edited.

Action:Contact your DBA if the .INP file was not edited.


FRM-32079

FRM-32079: Invalid initial value for given datatype.

Cause:You specified an invalid initial value for the given datatype.

Action:Specify a valid initial value for the given datatype.


FRM-32080

FRM-32080: Invalid range value for given datatype.

Cause:You specified an invalid range value for the given datatype.

Action:Specify a valid range value for the given datatype.


FRM-32081

FRM-32081: Invalid default parameter value for given datatype.

Cause:You specified an invalid default parameter value for the given datatype.

Action:Specify a valid default parameter value for the given datatype.


FRM-32082

FRM-32082: Invalid value for given item type.

Cause:You tried to specify a value for the initial value property or other values property that exceeds the value of the maximum length property.

Action:Specify a value that does not exceed the value of the maximum length property.


FRM-32083

FRM-32083: Value length is too long for maximum length of item.

Cause:You specified an value length that is longer than the maximum length of the item.

Action:Specify a shorter value.


FRM-32084

FRM-32084: Type of item is not compatible with mirror item %s.

Cause:You specified an item that is an incompatible mirror item property.

Action:Specify a valid mirror item property.


FRM-32085

FRM-32085: Strip_Source requires output filename.

Cause:You failed to specify an output file name when generating a library from the command line.

Action:Specify an output file name.


FRM-32086

FRM-32086: Bind Variable :%s parse failed at <%s>.

Cause:The bind variable could not be parsed due to an invalid format.

Action:Change to a valid format.


FRM-32087

FRM-32087: Bind Variable :%s binds to more than one object.

Cause:The bind variable is ambiguous since it binds to more than one object.

Action:Make sure the bind variable binds to one object only.


FRM-40007

FRM-40007: Invalid user identifier or password. Re-enter.

Cause:You entered an incorrect ORACLE username or password.

Action:Retype your username and password properly.

Level:>25

Type:Error


FRM-40010

FRM-40010: Cannot read form %s.

Cause:One of the following:

1. You entered a nonexistent form name.

2. You typed an incomplete path.

3. You do not have the proper privileges to run the form.

4. You do not have a compiled copy of the form.

Action:Retype the form name correctly, provide the proper path name, compile the form, or contact the DBA.

Level:5

Type:Error


FRM-40011

FRM-40011: Form was created by an old version of Form Builder.

Cause:The .FMB file was created with an old and incompatible version of Forms Compiler.

Action:Recompile the form or relink Generate.

Level:>25

Type:Error


FRM-40012

FRM-40012: Form was created by a new version of Form Builder.

Cause:The .FMB file was created by a new and incompatible version of Forms Compiler.

Action:Recompile the form.

Level:>25

Type:Error


FRM-40013

FRM-40013: Program Error: error occurred while reading form.

Cause:An internal error occurred while Form Builder was trying to read the .FMB file.

Action:Recompile the form.

Level:>25

Type:Error


FRM-40014

FRM-40014: Not enough memory to load the form.

Cause:Internal error. Your computer does not have enough memory to run the form.

Action:The designer might be able to modify the form so that it will run. If that is not feasible, your installation must make more memory available, either by modifying the operating system parameters or by adding more memory to the computer.

Level:>25

Type:Error


FRM-40015

FRM-40015: Unexpected end of file reading form.

Cause:The form was fragmented or incomplete.

Action:Recompile the form.

Level:>25

Type:Error


FRM-40019

FRM-40019: Unknown screen number to display.

Cause:An internal error occurred.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40020

FRM-40020: Page %d too small for this form.

Cause:Application design error. An item is positioned off the page.

Action:Ensure that all items that are associated with the given page fit completely on that page. You can reposition the items or resize the page.

Level:>25

Type:Error


FRM-40021

FRM-40021: Item in form file is too large.

Cause:An internal error occurred while Form Builder was reading the form.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40023

FRM-40023: Error creating record manager context.

Cause:Form Builder could not initialize its internal record manager.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40024

FRM-40024: Out of memory.

Cause:Internal error. Your computer does not have enough memory to run the form.

Action:The designer might be able to modify the form so that it will run. If that is not feasible, your installation must make more memory available, either by modifying the operating system parameters or by adding more memory to the computer.

Level:>25

Type:Error


FRM-40025

FRM-40025: Cannot suppress screen output without file input.

Cause:You tried to run a form on the command line using incompatible preferences. The output_file preference works only in conjunction with the keyin preference.

Action:Retype the command to include both the output_file and keyin preferences.

Level:>25

Type:Error


FRM-40026

FRM-40026: Error opening key script file.

Cause:Form Builder cannot open the file you specified with the keyin preference.

Action:Make sure the file exists and the file protections are set properly. Or create a file with the keyin preference.

Level:>25

Type:Error


FRM-40027

FRM-40027: Error opening display spool file.

Cause:Operating system error. Form Builder cannot open a file specified with the output_file preference because there is insufficient disk space or because you have specified an incorrect filename.

Action:Contact your DBA or system administrator.

Level:>25

Type:Error


FRM-40028

FRM-40028: Error opening message file %s%s%s.MSB.

Cause:Form Builder cannot find the message file.

Action:Make sure the message file exists and the appropriate path is set.

Level:>25

Type:Error


FRM-40029

FRM-40029: Already logged on. Must logout before changing connections.

Cause:The Login() built-in was issued while already logged on.

Action:Use the Logout() built-in first.

Level:>25

Type:Error


FRM-40030

FRM-40030: File %s is not a Forms 4.0 file.

Cause:The file specified on the command line was not a valid Form Builder file.

Action:Re-enter Forms Runtime startup command with the name of a valid file.

Level:No level

Type:Startup message


FRM-40032

FRM-40032: Internal Error: file %s contains an improper chunk size.

Cause:Internal error. File was compiled incorrectly or is corrupted.

Action:Recompile your file.

Level:No level

Type:Startup message


FRM-40033

FRM-40033: Internal Error: file %s contains a bad chunk table.

Cause:Internal error. File was compiled incorrectly or is corrupted.

Action:Recompile your file.

Level:No level

Type:Startup message


FRM-40034

FRM-40034: Cannot attach the library file.

Cause:Form Builder was unable to find the specified library file.

Action:Exit Forms Runtime and try again.

Level:>25 (this message cannot be suppressed)

Type:Error


FRM-40035

FRM-40035: Error creating per-block record manager context.

Cause:Form Builder could not initialize its internal record manager.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40036

FRM-40036: Library was created by a new version of Form Builder.

Cause:Form Builder unable to use library.

Action:Recompile the library with current version of Form Builder.

Level:>25

Type:Error


FRM-40037

FRM-40037: Library was created by an old version of Form Builder.

Cause:Form Builder unable to use library.

Action:Recompile the library with current version of Form Builder.

Level:>25

Type:Error


FRM-40038

FRM-40038: Could not find %s VBX control for item %s in block %s.

Cause:Application design error. A VBX control specified in the .FMB file cannot be found at runtime.

Action:Make sure the VBX control file can be found in the location as specified in the Form Builder.

Level:>25

Type:Error


FRM-40039

FRM-40039: Cannot attach library %s while opening form %s.

Cause:The given library is attached to the form but cannot be located in the search path for PL/SQL libraries.

Action:Make sure that the given library can be found and that it has read permissions set.

Level:99

Type:Error


FRM-40100

FRM-40100: At first record.

Cause:You pressed [Previous Record] when the cursor was at the first record.

Action:No action is necessary.

Level:5

Type:Error


FRM-40101

FRM-40101: Cannot position to a key item. None are navigable.

Cause:You pressed [Next Primary Key Item], but there are no enterable primary key items in this block.

Action:Use [Next Item] for navigation rather than [Next Primary Key Item].

Level:10

Type:Error


FRM-40102

FRM-40102: Record must be entered or deleted first.

Cause:You pressed [Next Record] or [Down] in a context where it is meaningless. Either:

1. The last record in a block is the current record.

2. The block is empty.

3. You are in a new record in the middle of the block created by pressing [Insert Record].

Action:No action is necessary.

Level:5

Type:Error


FRM-40103

FRM-40103: Cannot position to a key item. None are queryable.

Cause:You tried to use [Next Primary Key Item], but none of the primary key items in the block allow you to enter query criteria.

Action:No action is necessary.

Level:10

Type:Error


FRM-40104

FRM-40104: No such block: %s.

Cause:Runtime error. A GO_BLOCK statement references a nonexistent block.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40105

FRM-40105: Unable to resolve reference to item %s.

Cause:Runtime error. A GO_ITEM statement references a nonexistent item.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40106

FRM-40106: No navigable items in destination block.

Cause:Runtime error. A GO_BLOCK statement references a block with no enterable items.

Action:Remove the statement or make at least one item in the block enterable.

Level:>25

Type:Error


FRM-40107

FRM-40107: Cannot navigate to non-displayed item %s.

Cause:Runtime error. A GO_ITEM statement references a non-displayed item.

Action:Remove the statement or turn on the Displayed property for the indicated item.

Level:>25

Type:Error


FRM-40108

FRM-40108: No such form: %s.

Cause:You attempted to get/set properties of a nonexistent or unloaded form.

Action:Use a valid form name.

Level:>25

Type:Error


FRM-40109

FRM-40109: Cannot navigate out of current block in enter-query mode.

Cause:You attempted to navigate out of the current block during enter-query mode.

Action:No action is necessary. You cannot navigate out of the current block or record during enter-query mode.

Level:99

Type:Error


FRM-40110

FRM-40110: At first block.

Cause:You attempted [Previous Block] when at the first block.

Action:None. Consider an alternative method of navigation.

Level:5

Type:Error


FRM-40111

FRM-40111: At last block.

Cause:You attempted [Next Block] when at the last block.

Action:None. Consider an alternative method of navigation.

Level:5

Type:Error


FRM-40200

FRM-40200: Field is protected against update.

Cause:You tried to update a field that does not allow updates.

Action:No action is necessary. You cannot update this field in this form.

Level:15

Type:Error


FRM-40201

FRM-40201: Field is full. Can't insert character.

Cause:Form Builder is in insert mode, and the current field is full.

Action:Delete a character to make room for the new character or press [Insert/Replace] to activate replace mode.

Level:10

Type:Error


FRM-40202

FRM-40202: Field must be entered.

Cause:You have not entered a value (or you have deleted a value) in a field that requires data input.

Action:You must enter a value in this field.

Level:15

Type:Error


FRM-40203

FRM-40203: Field must be entered completely.

Cause:You have not entered a complete value (or you have deleted part of a value) in a field that has a fixed length requirement.

Action:Enter a complete value (one that extends to the end of the field).

Level:15

Type:Error


FRM-40204

FRM-40204: Cursor is at beginning of field value.

Cause:You tried to delete a character before the first character position of the field.

Action:Use [Delete Character] to delete the character that the cursor is on.

Level:10

Type:Error


FRM-40205

FRM-40205: Cursor is beyond the current field value.

Cause:On a block mode terminal, you positioned the cursor out of a field.

Action:Move the cursor into the field and try the entry again.

Level:15

Type:Error


FRM-40206

FRM-40206: Previous character is currently hidden.

Cause:You tried to delete a character that is off the screen.

Action:Scroll the character you want to delete into view using the arrow keys or [Scroll Left] and [Scroll Right].

Level:10

Type:Error


FRM-40207

FRM-40207: Must be in range %.30s to %.30s.

Cause:You entered a value not in the valid item range.

Action:Enter a value in the range shown.

Level:15

Type:Error


FRM-40208

FRM-40208: Form running in query-only mode. Cannot change database fields.

Cause:You entered a value on a query-only form.

Action:Do not enter values on this form. You can execute queries and view data, but you cannot alter existing data or enter new data.

Level:15

Type:Error


FRM-40209

FRM-40209: Field must be of form %s.

Cause:The value that you entered did not match the format mask on the field.

Action:Retry with a field value that matches the format mask.

Level:>25

Type:Error


FRM-40210

FRM-40210: Search string not found.

Cause:Search string does not exist in the module.

Action:Check your search string to make sure it is accurate or try another search string.

Level:99

Type:Informative


FRM-40211

FRM-40211: Warning! Newlines may be stripped from this field.

Cause:You attempted to assign data with newlines to a single-line text field.

Action:Assign to a multi-line text field if you need the newlines.

Level:5

Type:Informative


FRM-40212

FRM-40212: Invalid value for field %s.

Cause:Caused by one of the following:

1. The value is not of the proper data type.

2. The value does not match any of the list of acceptable values.

3. For a text field, the value does not match the specified range.

Action:Retry with another value.

Level:>20

Type:Message


FRM-40213

FRM-40213: Cannot Copy_Region/Cut_Region; region not selected.

Cause:Region not selected.

Action:Select a region and try again.

Level:99

Type:Error


FRM-40214

FRM-40214: Cannot open the clipboard for the copy/cut.

Cause:Clipboard unavailable.

Action:Platform specific.

Level:99

Type:Error


FRM-40215

FRM-40215: Cannot write to the clipboard.

Cause:Clipboard unavailable.

Action:Platform specific.

Level:99

Type:Error


FRM-40216

FRM-40216: Cannot open the clipboard for the paste.

Cause:Clipboard unavailable.

Action:Platform specific.

Level:99

Type:Error


FRM-40217

FRM-40217: Cannot get the data size from the clipboard.

Cause:Invalid data.

Action:Platform specific.

Level:99

Type:Error


FRM-40218

FRM-40218: Cannot read from the clipboard.

Cause:Invalid data.

Action:Platform specific.

Level:99

Type:Error


FRM-40219

FRM-40219: Cannot format the data read from the clipboard.

Cause:Invalid data.

Action:Platform specific.

Level:99

Type:Error


FRM-40220

FRM-40220: Cannot paste from the clipboard; value too long.

Cause:Invalid data.

Action:Platform specific.

Level:99

Type:Error


FRM-40221

FRM-40221: Cannot Paste_Region; region not selected.

Cause:Paste_Region was invoked while no portion of the image item was selected.

Action:Select a region of the image item prior to calling Paste_Region.


FRM-40301

FRM-40301: Query caused no records to be retrieved. Re-enter.

Cause:No records matched the query criteria. Still in Enter Query mode.

Action:Either adjust the query criteria or press [Exit/Cancel] to leave Enter Query mode.

Level:>25

Type:Informative


FRM-40302

FRM-40302: Cannot enter a query. No fields are queryable.

Cause:You pressed [Enter Query] while the cursor was in a block with no queryable fields.

Action:No action is necessary.

Level:15

Type:Error


FRM-40303

FRM-40303: No base table fields in the block.

Cause:One of the blocks in the current module has no base table fields.

Action:No action is necessary.

Level:5

Type:Informative


FRM-40350

FRM-40350: Query caused no records to be retrieved.

Cause:The current query fetched no records from the table. The table is empty, or it contains no records that meet the query's search criteria.

Action:No action is necessary.

Level:5

Type:Informative


FRM-40352

FRM-40352: Last record of query retrieved.

Cause:You pressed [Down], [Next Record], [Next Set of Records], or [Scroll Down] after all records had been retrieved.

Action:No action is necessary.

Level:5

Type:Informative


FRM-40353

FRM-40353: Query cancelled.

Cause:You pressed [Exit/Cancel] in Enter Query mode, or you pressed CTRL-C (or its equivalent) while Form Builder was fetching rows from the database.

Action:No action is necessary.

Level:The message level is 5 when the message is invoked by CTRL-C.

Type:Informative


FRM-40355

FRM-40355: Query will retrieve 1 record.

Cause:You pressed [Count Query Hits]. If you now press [Execute Query], the number of records will be retrieved.

Action:No action is necessary.

Level:25

Type:Informative


FRM-40356

FRM-40356: Invalid number in example record. Query not issued.

Cause:In Enter Query mode, you entered an invalid number in the example record.

Action:Correct the entry and retry the query.

Level:>25

Type:Error


FRM-40357

FRM-40357: Invalid string in example record. Query not issued.

Cause:In query mode, you entered an invalid ALPHA or CHAR value in the example record.

Action:Correct the entry and retry the query.

Level:>25

Type:Error


FRM-40358

FRM-40358: Invalid date in example record. Query not issued.

Cause:In Enter Query mode, you entered an invalid DATE in the example record.

Action:Correct the entry and retry the query.

Level:>25

Type:Error


FRM-40359

FRM-40359: Invalid date or time in example record. Query not issued.

Cause:In Enter Query mode, you entered an invalid JDATE, EDATE, or TIME value in the example record.

Action:Correct the entry and retry the query.

Level:>25

Type:Error


FRM-40360

FRM-40360: Cannot query records here.

Cause:You attempted to query a block that does not allow queries.

Action:Do not attempt to query this block.

Level:>25

Type:Error


FRM-40361

FRM-40361: Query operation not support for TIME data type.

Cause:You made a query with a % "like" operator in a time field, which is not supported.

Action:Try to restate your query without a time data type.

Level:>25

Type:Error


FRM-40364

FRM-40364: The data type of item '%s' does not match the corresponding column in the stored procedure.

Cause:The data type of the item is different from the data type of the corresponding column in the stored procedure.

Action:Make the data type of the item in the block and the column in the stored procedure the same.

Level:20

Type:Error


FRM-40400

FRM-40400: Transaction complete: %d records applied and saved.

Cause:Save complete.

Action:No action is necessary.

Level:5

Type:Informative


FRM-40401

FRM-40401: No changes to save.

Cause:No records were added or modified since the last apply or save.

Action:No action is necessary.

Level:5

Type:Error


FRM-40402

FRM-40402: Save cancelled.

Cause:You pressed CTRL-C (or the equivalent) while waiting for a lock.

Action:No action is necessary.

Level:10

Type:Informative


FRM-40403

FRM-40403: A calling form has unapplied changes. Save not allowed.

Cause:A calling form has unapplied changes.

Action:Apply the changes or return to the calling form and retry the save.

Level:15

Type:Error


FRM-40404

FRM-40404: Database apply complete: %d records applied.

Cause:Apply complete.

Action:No action is necessary.

Level:5

Type:Informative


FRM-40405

FRM-40405: No changes to apply.

Cause:No records were added or modified since the last apply or save.

Action:No action is necessary.

Level:5

Type:Error


FRM-40406

FRM-40406: Transaction complete: %d records applied; all records saved.

Cause:You finished an apply that recorded your changes and saved previously applied changes.

Action:No action is necessary.

Level:5

Type:Informative


FRM-40407

FRM-40407: Transaction complete: applied records saved.

Cause:You finished a save that saved previously applied changes.

Action:No action is necessary.

Level:5

Type:Informative


FRM-40501

FRM-40501: ORACLE error: unable to reserve record for update or delete.

Cause:A fatal error occurred while trying to select the record for update.

Action:Pressing [Display Error] provides more information, if it is available. You can also try to update or delete this record later. If necessary, contact your DBA.

Level:>25

Type:Error


FRM-40502

FRM-40502: ORACLE error: unable to read list of values.

Cause:A fatal error occurred while trying to read a list of values.

Action:Contact your DBA or an Oracle support representative.

Level:>25

Type:Error


FRM-40504

FRM-40504: ORACLE error: unable to execute a %s trigger.

Cause:A fatal error occurred while trying to execute a trigger.

Action:Contact your DBA or an Oracle support representative.

Level:>25

Type:Error


FRM-40505

FRM-40505: ORACLE error: unable to perform query.

Cause:Processing error encountered. The table associated with the current block of the form might not exist, or your username might not have authority to perform the specified action on the table.

Action:Pressing [Display Error] provides more information, if it is available. You can also try to update or delete this record later. If necessary, contact your DBA.

Level:>25

Type:Error


FRM-40506

FRM-40506: ORACLE error: unable to check for record uniqueness.

Cause:Processing error encountered while checking a record's primary key items for uniqueness. The table associated with the current block of the form does not exist, or you do not have authority to access the table.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40507

FRM-40507: ORACLE error: unable to fetch next query record.

Cause:A fatal error occurred while trying to fetch the next query record.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40508

FRM-40508: ORACLE error: unable to INSERT record.

Cause:A fatal error occurred while trying to insert a record. The table associated with the current block of the form might not exist, your username might not have authority to perform the specified action on the table, or some other reason might have caused the fatal error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40509

FRM-40509: ORACLE error: unable to UPDATE record.

Cause:A fatal error occurred while trying to update a record. The table associated with the current block of the form might not exist, your username might not have authority to perform the specified action on the table, or some other reason might have caused the fatal error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40510

FRM-40510: ORACLE error: unable to DELETE record.

Cause:A fatal error occurred while trying to delete a record. The table associated with the current block of the form might not exist, your username might not have authority to perform the specified action on the table, or some other reason might have caused the fatal error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40511

FRM-40511: ORACLE error occurred while executing a %s trigger.

Cause:A fatal error occurred while trying to execute a trigger. The table associated with the current block of the form might not exist, your username might not have authority to perform the specified action on the table, or some other reason might have caused the fatal error.

Action:Contact your DBA

Level:>25

Type:Error


FRM-40512

FRM-40512: ORACLE error: unable to issue SAVEPOINT command.

Cause:While attempting to call a new form or to commit, the issued SAVEPOINT command failed. This generally means that the module has run out of savepoints.

Action:Press [Display Error] to display the specific ORACLE error. You might be able to increase the maximum number of savepoints in the INIT.ORA file.

Level:>25

Type:Error


FRM-40513

FRM-40513: ORACLE error: unable to get date/time from database.

Cause:An error occurred while trying to resolve a database date/time initial value.

Action:Connect if you have not already done so. Verify database status.

Level:10

Type:Error


FRM-40514

FRM-40514: Operation requires a database connection.

Cause:You tried to perform an database operation without connecting to the database.

Action:Connect to the database and retry.

Level:20

Type:Error


FRM-40515

FRM-40515: ORACLE error: unable to open cursor.

Cause:You reached the limit in the number of cursors you can open.

Action:Check the number of cursors you have open.

Level:99

Type:Error


FRM-40600

FRM-40600: Record has already been inserted.

Cause:You attempted to insert or update a record, but uniqueness is enforced on the block's primary key items. The record, as inserted or updated, is not unique.

Action:Change the values in one or more primary key fields of the current record, making them unique. If the requirement of unique primary key fields creates difficulties, consider eliminating the constraint.

Level:>25

Type:Error


FRM-40603

FRM-40603: Records no longer reserved for update. Re-query to make changes.

Cause:You committed your modifications in a block where you had previously entered an ENTER_QUERY or EXECUTE_QUERY packaged procedure with the FOR_UPDATE parameter. This action released all locks on the records in this block.

Action:If you want to modify the block, you will need to re-query.

Level:>25

Type:Error


FRM-40652

FRM-40652: Cannot lock table in shared update mode.

Cause:Caused by one of the following:

1. You do not have access to this table.

2. Form Builder cannot lock the table in shared update mode.

Action:Contact your DBA.

Level:15

Type:Error


FRM-40653

FRM-40653: Record not reserved for update or delete. Try again later.

Cause:You pressed CTRL-C (or the equivalent) to cancel. The operation that was attempting to update or delete the record was terminated.

Action:No action is necessary.

Level:20

Type:Informative


FRM-40654

FRM-40654: Record has been updated by another user. Re-query to see change.

Cause:Another user has updated this record since you performed a query and has changed at least one field in the record. Your actions have not changed the record in memory.

Action:You can update or delete this record now only if another user has restored the field values back to the way they were when you performed the query. Otherwise, you must re-query to fetch and display the new record into the form before you can update or delete it.

Level:20

Type:Error


FRM-40655

FRM-40655: SQL error forced rollback: clear form and re-enter transaction.

Cause:A deadlock or some other error has caused the current transaction to fail. Your changes were rolled back.

Action:Clear the form (or exit and re-enter the form) and re-enter the transaction. You might have to modify the form's design to prevent the error from recurring.

Level:>25

Type:Error


FRM-40656

FRM-40656: Update cannot be made due to prior rollback. Clear the record.

Cause:This record was already updated, but when you attempted to commit your changes, a serious error prevented this update or any further update or delete from being performed. The error might have occurred due to one of the following reasons:

1. A deadlock forced the loss of row locks.

2. The record had a database cluster key, and the previous attempt to update the record in the database was rolled back due to an error somewhere else in the form.

Action:You must clear this record before you can commit any other transactions in the form.

Level:25

Type:Error


FRM-40657

FRM-40657: Record changed or deleted by another user.

Cause:Another user has deleted the record since the query was executed.

Action:You can clear this record from your screen, but you cannot update or delete it since it no longer exists in the database.

Level:20

Type:Informative


FRM-40659

FRM-40659: Last row of query retrieved. Re-query to see remaining records.

Cause:A FOR_UPDATE query has been closed by executing a commit. Because the query was open prior to the commit, there may be more records to retrieve.

Action:Re-query to see remaining records.

Level:5

Type:Message


FRM-40700

FRM-40700: No such trigger: %s.

Cause:Application design error. The form attempted to execute a trigger that doesn't exist, causing a fatal error.

Action:Correct the reference to the trigger.

Level:20

Type:Error


FRM-40702

FRM-40702: Cannot call form with changes to save

Cause:You attempted to call another form with unsaved changes in the current form and savepoint mode off.

Action:Commit/post changes and then retry.

Level:15

Type:Error


FRM-40703

FRM-40703: Fetched field cannot be changed in query mode.

Cause:You attempted to modify a fetched item in query mode.

Action:None required.

Level:20

Type:Error


FRM-40704

FRM-40704: Illegal SQL statement in query-only mode

Cause:Application design error. The form tried to execute a function that is illegal in a query-only form.

Action:You might need to redesign the form.

Level:20

Type:Error


FRM-40705

FRM-40705: Illegal SQL statement in non-commit-time trigger.

Cause:Application design error. The current trigger contains a SQL statement that is illegal for the trigger type.

Action:Rewrite the trigger text or use a different type of trigger.

Level:20

Type:Error


FRM-40714

FRM-40714: Function illegal in this context.

Cause:Application design error. The current trigger contains an illegal function code.

Action:Rewrite the trigger text or use a different type of trigger.

Level:20

Type:Error


FRM-40720

FRM-40720: No statements found in list of statements.

Cause:Application design error. A step in a V2 trigger uses incorrect syntax.

Action:Correct the trigger step text.

Level:>25

Type:Error


FRM-40721

FRM-40721: Missing function code in trigger.

Cause:Application design error. A step in a V2 trigger uses incorrect syntax.

Action:Correct the trigger step text.

Level:>25

Type:Error


FRM-40722

FRM-40722: Unrecognized function name.

Cause:Application design error. A trigger references a nonexistent function code.

Action:Correct the reference.

Level:>25

Type:Error


FRM-40723

FRM-40723: Missing argument for function code.

Cause:Application design error. An argument is missing in an ERASE, EXECUTE_TRIGGER, GO_BLOCK, GO_ITEM, GO_RECORD, or NEW_FORM statement.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40724

FRM-40724: Missing selector in CASE statement.

Cause:Application design error. The selector portion is missing in a CASE statement.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40725

FRM-40725: Missing keyword in CASE statement.

Cause:Application design error. A keyword is missing in a CASE statement.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40726

FRM-40726: Missing choice in CASE statement.

Cause:Application design error. A choice is not specified in a CASE statement.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40727

FRM-40727: Illegal keyword in CASE statement.

Cause:Application design error. A CASE statement contains a mistyped keyword.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40728

FRM-40728: Unrecognized or extra arguments to function.

Cause:Application design error. A function specifies extra arguments.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40729

FRM-40729: Missing semicolon at end of statement.

Cause:Application design error. A semicolon is missing at the end of a function code.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40730

FRM-40730: Invalid message suppress level--unchanged from %d.

Cause:Application design error. A trigger attempted to set the system message level to an invalid number.

Action:Reset the SYSTEM.MESSAGE_LEVEL system variable to a valid number.

Level:>25

Type:Error


FRM-40731

FRM-40731: INTO keyword missing.

Cause:Application design error. A COPY statement is missing the INTO clause.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40732

FRM-40732: Target of GOTO does not exist in this macro.

Cause:Application design error. The label referenced in PL/SQL does not exist.

Action:Correct the statement.


FRM-40733

FRM-40733: PL/SQL built-in %s failed.

Cause:A fatal error occurred in Form Builder or in PL/SQL during trigger execution.

Action:Notify the DBA.

Level:>25

Type:Error


FRM-40734

FRM-40734: Internal Error: PL/SQL error occurred.

Cause:A fatal error occurred in PL/SQL during trigger execution.

Action:Notify the DBA.

Level:>25

Type:Error


FRM-40735

FRM-40735: %s trigger raised unhandled exception %s.

Cause:Application design error. The current trigger raised an exception (other than FORM_TRIGGER_FAILURE), but it did not handle the exception.

Action:Rewrite the trigger text to handle the exception.

Level:>25

Type:Error


FRM-40736

FRM-40736: Cannot initialize PL/SQL.

Cause:An internal error occurred while initializing PL/SQL.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40737

FRM-40737: Illegal restricted procedure %s in %s trigger.

Cause:Application design error. A trigger tried to execute a restricted packaged procedure.

Action:Remove the packaged procedure from the trigger text.

Level:>25

Type:Error


FRM-40738

FRM-40738: Argument %d to builtin %s cannot be null.

Cause:Application design error. No arguments were provided to the built-in.

Action:Refer to the online Help for the correct usage of this built-in.

Level:99

Type:Error


FRM-40739

FRM-40739: Full rollback not allowed in post-only form.

Cause:Application design error. A trigger tried to issue a CLEAR_FORM packaged procedure with the FULL_ROLLBACK parameter in a post-only, called form.

Action:Remove the FULL_ROLLBACK parameter or ensure that the calling form does not have unposted changes when the call occurs.

Level:>25

Type:Error


FRM-40740

FRM-40740: Procedure %s only allowed in an on-%s trigger.

Cause:Application design error. A non-transactional trigger attempted to invoke a built-in procedure that is restricted to a given trigger.

Action:Refer to the online Help for the correct usage of this procedure.

Level:>25

Type:Error


FRM-40741

FRM-40741: Unable to locate record %d on block %s.

Cause:You attempted to get or set record properties for an invalid record number for the given block.

Action:Verify your Get/Set record property parameters.

Level:20

Type:Error


FRM-40742

FRM-40742: Illegal status conversion on record %d: %s to %s.

Cause:Application design error. A call to SET_RECORD_PROPERTY attempted an illegal conversion between record statuses.

Action:Refer to SET_RECORD_PROPERTY in online Help for correct transitions.

Level:>25

Type:Error


FRM-40743

FRM-40743: This operation with no base table requires the %s trigger.

Cause:Application design error. Attempted a database operation (query, insert, update, etc.) on a non-base table block without the appropriate transactional trigger.

Action:Refer to online Help for the appropriate transactional trigger and then create the correct trigger.

Level:20

Type:Error


FRM-40744

FRM-40744: Truncation of input value will occur if editor accepted.

Cause:The editor's buffer is too small to accept the input.

Action:Change editors or enlarge the buffer.

Level:15

Type:Error


FRM-40745

FRM-40745: Output value of built-in %s was truncated.

Cause:Output variable is too small.

Action:Increase the size of the PL/SQL output variable.

Level:15

Type:Error


FRM-40746

FRM-40746: Cannot call built-in %s from startup debugger window.

Cause:Built-in is not accessible from the startup debugger window.

Action:Refer to the Form Builder Developer's Guide for a list of built-ins that are not accessible from the startup debugger window.

Level:99

Type:Informative


FRM-40747

FRM-40747: Cannot call built-in %s from a debug trigger.

Cause:Built-in is not accessible from the debug trigger.

Action:Refer to the Form Builder Developer's Guide for a list of built-ins that are accessible from a debug trigger .

Level:99

Type:Informative


FRM-40748

FRM-40748: Trigger %s terminated by reset command.

Cause:You issued the reset command or you pressed the reset button in the debugger.

Action:If you want to navigate downward, go to the call stack.

Level:99

Type:Informative


FRM-40749

FRM-40749: Invalid record status specified for record %d.

Cause:Application design error. An attempt was made to set the STATUS property of a record to an invalid value.

Action:The record's STATUS property should be set to NEW_STATUS, QUERY_STATUS, INSERT_STATUS, or CHANGED_STATUS.

Level:99

Type:Error


FRM-40750

FRM-40750: Record %d: Can't set status to QUERY or CHANGED in a control block.

Cause:Application design error. An attempt was made to set the STATUS property of a record in a control block to QUERY_STATUS or CHANGED_STATUS.

Action:The record's STATUS property should be set to NEW_STATUS or INSERT_STATUS.

Level:99

Type:Error


FRM-40800

FRM-40800: User exit %s does not exist.

Cause:The form tried to invoke a user exit that does not exist. This could be caused by one of the following:

1. You are using the wrong version of Forms Runtime.

2. There could be an error in the form.

Action:If you are using the wrong version of Forms Runtime, determine which version contains the user exit, and use that version to run the form. If there is an error in the form, the designer should correct the call to the user exit.

Level:20

Type:Error


FRM-40804

FRM-40804: Not enough arguments to COPY command.

Cause:Application design error. A COPY statement does not specify a source or destination.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40805

FRM-40805: Not enough arguments to ERASE command.

Cause:Application design error. An ERASE statement does not specify a variable.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40807

FRM-40807: No command string specified for HOST command.

Cause:Application design error. A HOST statement does not specify a command string.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40808

FRM-40808: Cannot execute HOST command. Error code = %s.

Cause:Cannot execute a HOST statement because of an operating system error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40809

FRM-40809: HOST command had error code = %s.

Cause:The operating system command resulted in the above error code.

Action:Verify that you entered the command properly.

Level:>25

Type:Error


FRM-40811

FRM-40811: Shell command had error.

Cause:The operating system command resulted in the above error code.

Action:Verify that you entered the command properly.

Level:>25

Type:Error


FRM-40814

FRM-40814: Illegal function code in this context.

Cause:Application design error. The NOFAIL keyword is specified for a function code that does not accept that keyword.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40815

FRM-40815: Variable GLOBAL.%s does not exist.

Cause:Application design error. A trigger references a global variable that does not exist.

Action:Create the global variable or remove the reference.

Level:>25

Type:Error


FRM-40816

FRM-40816: Could not allocate memory for new symbol.

Cause:Internal error. Out of memory while accessing a new global variable.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40817

FRM-40817: Could not allocate memory for new value.

Cause:Internal error. Out of memory while accessing a new global variable.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40818

FRM-40818: System variable name not defined.

Cause:You have tried to access a system variable that does not exist.

Action:Check the system variable name.

Level:99

Type:Error


FRM-40819

FRM-40819: System variable is not modifiable.

Cause:You have tried to modify a system variable.

Action:You cannot modify system variables.

Level:99

Type:Error


FRM-40820

FRM-40820: Not enough memory to evaluate system variable.

Cause:Internal error. Out of memory while accessing a system variable.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40822

FRM-40822: Not enough arguments to SET function.

Cause:Application design error. A SET function code does not specify enough arguments.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40823

FRM-40823: Extra argument to SET function.

Cause:Application design error. A SET function code specifies too many arguments.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40824

FRM-40824: Not enough arguments to PAGE function.

Cause:Application design error. A HIDEPAGE or a SHOWPAGE function code does not specify enough arguments.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40825

FRM-40825: Not enough arguments to VIEW function.

Cause:Application design error. A MOVEVIEW, ANCHORVIEW, or RESIZEVIEW function code does not specify enough arguments.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40826

FRM-40826: Invalid number of arguments to CALL function.

Cause:Application design error. A CALL or CALLQRY function code does not specify enough arguments.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40827

FRM-40827: Not enough arguments to GOREC function.

Cause:Application design error. A GOREC function code does not specify enough arguments.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40828

FRM-40828: CALL or CALLQRY with invalid variable reference.

Cause:Application design error. A CALL or CALLQRY function code contains an invalid variable reference.

Action:Correct the statement.

Level:>25

Type:Error


FRM-40829

FRM-40829: Not enough arguments to EDITFIELD function.

Cause:Application design error. An EDITFIELD function code does not specify enough arguments.

Action:Correct the statement.

Level:No message suppression level.

Type:Error


FRM-40830

FRM-40830: Not enough arguments to DISPLAYPAGE function.

Cause:Application design error. A DISPLAYPAGE function code does not specify enough arguments.

Action:Correct the statement.

Level:No message suppression level.

Type:Error


FRM-40831

FRM-40831: Truncation occurred: value too long for field %s.

Cause:Application design error. A trigger, query, or user exit read a value into an item that is not long enough to hold the entire value. The item truncated the value.

Action:Increase the target item's item length to avoid truncation.

Level:15

Type:Error


FRM-40900

FRM-40900: Unable to allocate record buffer. Clear form to continue.

Cause:Failed attempt to allocate memory for a fetched or new record. The remaining records that are queried are temporarily buffered on disk. This is an indication that no more temporary files can be written to the disk.

Action:Clear form and then attempt to continue. You may have to exit the form and then re-open. Also, make sure there is enough disk space and that you have write privileges to the disk drive and directory.

Level:>25

Type:Error


FRM-40901

FRM-40901: Note: not enough memory to remember all or part of this query.

Cause:Internal error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40902

FRM-40902: SQL statement too large.

Cause:Application design error. The form's design includes a SQL command that is more than 2048 characters long.

Action:Shorten the SQL command.

Level:>25

Type:Error


FRM-40903

FRM-40903: Cannot create output file.

Cause:You pressed [Print Screen], but screen contents could not be written to a file because of one of the following:

1. You have entered an illegal file name.

2. The operating system does not give you authority to create files.

3. The necessary disk or directory space is not available.

Action:Check the file name you have entered and correct it if necessary. If you need additional help, contact your DBA.

Level:>25

Type:Error


FRM-40904

FRM-40904: Program error: unknown operation to be performed on record.

Cause:Internal error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40905

FRM-40905: Unable to buffer more records on disk.

Cause:Internal error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40906

FRM-40906: FATAL ERROR: cannot write a buffered record to disk.

Cause:Failure while trying to write a buffered record to the disk.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40907

FRM-40907: FATAL ERROR: cannot read a buffered record from disk.

Cause:Failure while trying to read a buffered record from the disk.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40908

FRM-40908: RAM Internal Error: %s

Cause:An internal error occurred within the form's internal record manager. Possible causes include:

1. Unable to open the disk buffer file.

2. Read or write error to the disk buffer file.

3. Out of memory.

Action:Contact your DBA.

Level:>20

Type:Error


FRM-40909

FRM-40909: Internal Error: unknown error %d.

Cause:Internal error. Attempted to issue an unknown error message.

Action:Contact an Oracle support representative.

Level:>25

Type:Error


FRM-40910

FRM-40910: Internal Error: while executing PL/SQL trigger or procedure.

Cause:An internal error occurred during PL/SQL trigger or procedure as a result of a generation error or file corruption.

Action:Recompile your form. Contact an Oracle support representative.

Level:>25

Type:Error


FRM-40911

FRM-40911: Record not created due to sequence number generation error.

Cause:Internal error. Either the sequence number object does not exist, or the designer does not have privileges for the sequence number object, or some other fatal database error occurred.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40912

FRM-40912: WHEN-NEW-RECORD trigger failed. Record not created.

Cause:A runtime error occurred in a When-New-Record trigger that caused the trigger to fail. No new record was created.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-40913

FRM-40913: List of Values maximum exceeded. Some values are not displayed.

Cause:Application design error. Unable to return all the records in the current list of values; the number exceeds the maximum limit.

Action:Specify no more than 32,767 records to be returned in a list of values.

Level:>25

Type:Error


FRM-40914

FRM-40914: Memory allocation error: unable to complete transaction.

Cause:Internal error.

Action:Contact your DBA or an Oracle support representative.

Level:>25

Type:Error


FRM-40915

FRM-40915: Memory allocation error: unable to execute trigger %s.

Cause:Internal error.

Action:Contact your DBA or an Oracle support representative.

Level:>25

Type:Error


FRM-40916

FRM-40916: Memory allocation error: unable to execute query.

Cause:Internal error.

Action:Contact your DBA or an Oracle support representative.

Level:>25

Type:Error


FRM-40917

FRM-40917: Memory allocation error: unable to lock record.

Cause:Internal error.

Action:Contact your DBA or an Oracle support representative.

Level:>25

Type:Error


FRM-40918

FRM-40918: Internal error: unable to initialize Toolkit.

Cause:Something in your environment or application has prevented Form Builder from initializing the Oracle Toolkit.

Action:Make certain that Form Builder has been installed properly, your environment contains all of the necessary resource files, and all system dependent guidelines have been followed.

Level:>25

Type:Error


FRM-40919

FRM-40919: Internal SQL statement execution error: %d.

Cause:Error in the SQL statement Form Builder has tried to execute.

Action:Check the last SQL statement.

Level:25

Type:Error


FRM-40920

FRM-40920: Unable to create view: low on system resources.

Cause:Something in your environment or application has prevented view creation.

Action:Contact your DBA or an Oracle support representative.

Level:99

Type:Error


FRM-40921

FRM-40921: Could not create item: %s.

Cause:Something in your environment or application has prevented item creation.

Action:Contact your DBA or an Oracle support representative.

Level:99

Type:Error


FRM-40922

FRM-40922: An OLE error occurred: 0x%x.

Cause:A built-in called an OLE or OLE-related function which failed.

Action:You need to lookup the error number in an OLE manual for further details.

Level:99

Type:Error


FRM-40923

FRM-40923: OLE is not supported on this platform.

Cause:A built-in that required OLE support was called, and your platform does not support OLE.

Action:Don't call OLE-related built-ins on platforms that don't support OLE.

Level:99

Type:Error


FRM-40924

FRM-40924: Invalid argument index specified.

Cause:An attempt was made to retrieve a value from the OLE-argument stack whose index was out of bounds for the size of the current OLE-argument stack

Action:Argument indices range from 1 to the number specified in the last call to FORMS_OLE.InitArgs()

Level:99

Type:Error


FRM-40925

FRM-40925: No space initialized in OleArg for argument.

Cause:An attempt was made to store too many arguments into the initialized OLE-argument stack.

Action:Make sure you specify enough space in your call to FORMS_OLE.InitArgs().

Level:99

Type:Error


FRM-40926

FRM-40926: OLE Object is NULL.

Cause:You cannot operate on a NULL OLE object.

Action:Do not attempt to call FORMS_OLE built-ins with NULL OLE-objects.

Level:99

Type:Error


FRM-40927

FRM-40927: Variant is not an array.

Cause:An attempt was made to access a variant as if it contained an array, and it did not.

Action:You can call FORMS_OLE.Get_Dims() to ensure that you have a variant with an array. For arrays, the return value for the function is greater than or equal to 1.

Level:99

Type:Error


FRM-40928

FRM-40928: Too many array indices specified.

Cause:An attempt was made to access a variant that holds an array, but too many array indices were specified.

Action:You must use the correct number of array indices, the same number as returned by FORMS_OLE.GET_Dims().

Level:99

Type:Error


FRM-40929

FRM-40929: Too few array indices specified.

Cause:An attempt was made to access a variant that holds an array, but too few array indices were specified.

Action:You must use the correct number of array indices, the same number as returned by FORMS_OLE.GET_Dims().

Level:99

Type:Error


FRM-40930

FRM-40930: Array index was non-numeric.

Cause:An attempt was made to access a variant that holds an array, but the supplied array indices were non-numeric and not either ROW or COLUMN.

Action:The only valid array indices are numbers, which should be separated by columns. If you're fetching into a table from a variant, ROW and COLUMN can be used as placeholders for the row and column iterators during table construction.

Level:99

Type:Error


FRM-40931

FRM-40931: Cannot populate table because datatype is unsupported.

Cause:An attempt to populate a table failed because one of its columns used an unsupported datatype.

Action:Restrict your column types to integers, numbers, strings, and dates.

Level:99

Type:Error


FRM-40932

FRM-40932: Cannot populate variant because table's datatype is unsupported.

Cause:An attempt to populate a variant failed because one of the source table's columns used an unsupported datatype.

Action:Restrict your column types to integers, numbers, strings, and dates.

Level:99

Type:Error


FRM-40933

FRM-40933: Cannot populate table because datatype is incorrect.

Cause:An attempt to populate a table failed because the block's datatype did not match the table's datatype.

Action:The table datatype must match the datatypes of the block's columns that are being retrieved.

Level:99

Type:Error


FRM-40934

FRM-40934: Cannot populate table because records are out of bounds.

Cause:An attempt to populate a table failed because an illegal start or end record was specified.

Action:start_rec and end_rec parameters must fall between 1 and the number of retrievable records. end_rec may also be ALL_RECORDS.

Level:99

Type:Error


FRM-41000

FRM-41000: This function is not currently available.

Cause:You pressed an undefined function key.

Action:Press [Show Keys] to determine which function key you should have pressed.

Level:5

Type:Error


FRM-41001

FRM-41001: This function is not allowed on this device.

Cause:You tried to execute the Insert/Replace function.

Action:No action is necessary.

Level:5

Type:Error


FRM-41002

FRM-41002: Please make a valid selection.

Cause:You entered an invalid selection number on the block menu; that block does not exist in this form.

Action:Select an existing block.

Level:10

Type:Error


FRM-41003

FRM-41003: This function cannot be performed here.

Cause:You tried to perform a function that references a table, but current block does not correspond to any table.

Action:No action is necessary. You cannot perform the requested function on this block.

Level:10

Type:Error


FRM-41004

FRM-41004: This function is not allowed in this mode.

Cause:You pressed a function key that does not work in this mode.

Action:No action is necessary.

Level:10

Type:Error


FRM-41005

FRM-41005: Internal Error: function key not implemented.

Cause:You pressed a disabled function key.

Action:No action is necessary. You cannot use the function key in the current context unless the form's definition is modified.

Level:>25

Type:Error


FRM-41006

FRM-41006: Cannot find Forms Runtime command.

Cause:You pressed a function key that has not been defined for your keyboard map.

Level:>25

Type:Error


FRM-41007

FRM-41007: Cursor not in a valid item. Function key was ignored.

Cause:You were not in a valid item when you pressed the function key.

Action:Position the cursor inside the item and press the function key again.

Level:10

Type:Error


FRM-41008

FRM-41008: Undefined function key. Press %s for list of valid keys.

Cause:You pressed an undefined function key.

Action:Press [Show Keys] to determine which function key you should have pressed.

Level:>25

Type:Error


FRM-41009

FRM-41009: Function key not allowed. Press %s for list of valid keys.

Cause:You pressed a function key that is not allowed in this environment.

Action:Press [Show Keys] to determine which function key you should have pressed.

Level:>25

Type:Error


FRM-41010

FRM-41010: Cannot set attribute of the current item.

Cause:Application design error. A SET_ITEM statement tried to turn off the Input Allowed property for the current item.

Action:Eliminate the statement or rewrite the trigger.

Level:>25

Type:Error


FRM-41011

FRM-41011: Undefined attribute.

Cause:Application design error. A DISPLAY_ITEM or DISPLAY_PAGE statement tried to set an undefined attribute, or a SET_ITEM_PROPERTY statement tried to set an undefined property.

Action:Correct the statement.

Level:>25

Type:Error


FRM-41012

FRM-41012: Undefined item or variable reference.

Cause:Application design error. A NAME_IN statement tried to reference a nonexistent item or variable.

Action:Correct the statement.

Level:>25

Type:Error


FRM-41013

FRM-41013: Undefined attribute specified for item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure specifies an undefined parameter.

Action:Correct the statement.

Level:>25

Type:Error


FRM-41014

FRM-41014: Cannot set attribute of null canvas item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to change some property of a NULL canvas item.

Action:Move the item to a non-0 page.

Level:>25

Type:Error


FRM-41015

FRM-41015: Cannot set ENTERABLE attribute of the current item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to change the Input Allowed property of the current item.

Action:Correct the statement.

Level:>25

Type:Error


FRM-41016

FRM-41016: Cannot set DISPLAYED attribute of the current item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to change the Displayed property of the current item.

Action:Correct the statement.

Level:>25

Type:Error


FRM-41017

FRM-41017: Cannot set UPDATE ALLOWED attribute of non-enabled item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to turn on the Update Allowed property of a non-enterable item.

Action:To turn on the Update Allowed property of an item you must also turn on the Input Allowed property of the item.

Level:>25

Type:Error


FRM-41018

FRM-41018: Cannot set UPDATE_NULL attribute of non-enabled item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to turn on the Update if Null property of a non-enterable item.

Action:To turn on the Update if Null property of an item you must also turn on the Input Allowed property of the item.

Level:>25

Type:Error


FRM-41019

FRM-41019: Cannot set REQUIRED attribute of non-enabled item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to turn on the Required property of a non-enterable item.

Action:To turn on the Required property of an item you must also turn on the Input Allowed property of the item.

Level:>25

Type:Error


FRM-41020

FRM-41020: Cannot set ENTERABLE attribute of non-displayed item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to turn on the Input Allowed property of a non-displayed item.

Action:To turn on the Input Allowed property of an item you must also turn on the Displayed property of the item.

Level:>25

Type:Error


FRM-41021

FRM-41021: Cannot set QUERYABLE attribute of non-displayed item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to turn on the Query Allowed property of a non-displayed item.

Action:To turn on the Query Allowed property of an item you must also turn on the Displayed property of the item.

Level:>25

Type:Error


FRM-41022

FRM-41022: Cannot set REQUIRED attribute of non-updateable item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to turn on the Required property of a non-updateable item.

Action:To turn on the Required property of an item you must also turn on either the Update Allowed property or the Update if Null property of the item.

Level:>25

Type:Error


FRM-41023

FRM-41023: Cannot set UPDATE ALLOWED attribute of secure item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to change the Update Allowed property of a database item which the user does not have permission to update.

Action:Either correct the SET_ITEM statement or grant update permission on the column to the user.

Level:>25

Type:Error


FRM-41024

FRM-41024: Cannot set UPDATE_NULL attribute of secure item %s.%s.

Cause:Application design error. A SET_ITEM packaged procedure tried to change the Update if Null property of a database item which the user does not have permission to update.

Action:Either correct the SET_ITEM statement or grant update permission on the column to the user.

Level:>25

Type:Error


FRM-41025

FRM-41025: Page number %d does not exist.

Cause:Application design error. Attempted an operation on a non-existent page.

Action:Check arguments to page related built-ins.

Level:>25

Type:Error


FRM-41026

FRM-41026: Field does not understand operation.

Cause:You attempted to perform an operation that is invalid for the given item type.

Action:Do not attempt to perform the operation on an item to which the operation cannot be applied.


FRM-41027

FRM-41027: Primary key must be defined for this block.

Cause:You attempted to set Key_Mode or primary key option on for a block with no primary key items.

Action:Specify one or more primary key items on the block.

Level:>25

Type:Error


FRM-41028

FRM-41028: Invalid property.

Cause:You passed an invalid property constant to a Get or Set property built-in.

Action:Verify arguments.

Level:>25

Type:Error


FRM-41029

FRM-41029: Invalid parameter.

Cause:You attempted to set a form, block, item, or record property to an invalid value.

Action:Verify arguments to SET_FORM_PROPERTY, SET_BLOCK_PROPERTY, SET_ITEM_PROPERTY, or SET_RECORD_PROPERTY.

Level:>25

Type:Error


FRM-41030

FRM-41030: Cannot reset ITEM_LENGTH of item %s.%s.

Cause:Application design error. Attempted to change the length of a fixed length item.

Action:Statically declare the item to be of the maximum necessary length or change item type.

Level:>25

Type:Error


FRM-41031

FRM-41031: Cannot reset ITEM_LENGTH greater than the allocated buffer.

Cause:Application design error. Tried to reset ITEM_LENGTH greater than the allocated buffer.

Action:Increase item length in the form definition.

Level:>25

Type:Error


FRM-41032

FRM-41032: Cannot set ENABLED attribute of current item %s.%s.

Cause:A call to SET_ITEM_PROPERTY attempted to set the Enabled attribute of the current item.

Action:Either correct the call to SET_ITEM_PROPERTY or navigate to another item before setting the Enabled attribute.

Level:>25

Type:Error


FRM-41033

FRM-41033: Cannot set ENABLED attribute of non-displayed item %s.%s.

Cause:A call to SET_ITEM_PROPERTY attempted to set the Enabled attribute of a non-displayed item.

Action:First navigate to the item, then set the Enabled attribute with a call to SET_ITEM_PROPERTY.

Level:>25

Type:Error


FRM-41034

FRM-41034: Cannot set NAVIGABLE attribute of non-displayed item %s.%s.

Cause:A call to SET_ITEM_PROPERTY attempted to set the Navigable attribute of a non-displayed item.

Action:First navigate to the item, then set the Navigable attribute with a call to SET_ITEM_PROPERTY.

Level:>25

Type:Error


FRM-41035

FRM-41035: Cannot set NAVIGABLE attribute of non-enabled item %s.%s.

Cause:A call to SET_ITEM_PROPERTY attempted to set the Navigable attribute of a non-enabled item.

Action:First set the Enabled attribute of the item with a call to SET_ITEM_PROPERTY. Then set the Navigable property of the item with another call to SET_ITEM_PROPERTY.

Level:99

Type:Error


FRM-41036

FRM-41036: Cannot modify a checkbox that does not allow querying.

Cause:You attempted to modify a check box that does not allow querying.

Action:First set the Query Allowed property to True, then the end user may shift and click the check box to enable or disable the item.

Level:99

Type:Error


FRM-41037

FRM-41037: Cannot modify a radio group that does not allow querying.

Cause:You attempted to modify a radio group that does not allow querying.

Action:First set the Enabled property to True with a call to SET_RADIO_BUTTON_PROPERTY.

Level:>25

Type:Error


FRM-41038

FRM-41038: Item %s is not a checkbox.

Cause:A call to CHECKBOX_CHECKED was made to an item which was not a check box.

Action:Correct the call to CHECKBOX_CHECKED.

Level:>25

Type:Error


FRM-41039

FRM-41039: Invalid Alert ID %d.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_ALERT will be performed.

Level:>25

Type:Error


FRM-41040

FRM-41040: Cannot find radio button: %s.

Cause:An invalid ID or name was passed to a built-in subprogram.

Action:Check the name or ID that you entered and try again.

Level:>25

Type:Error


FRM-41041

FRM-41041: Cannot find form module: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_FORM will be performed.

Level:>25

Type:Error


FRM-41042

FRM-41042: No such property for Set_Item_Property.

Cause:You attempted to set an invalid item property.

Action:Check the documentation for setting item properties and try again.

Level:>25

Type:Error


FRM-41043

FRM-41043: Cannot find timer: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_TIMER will be performed.

Level:>25

Type:Error


FRM-41044

FRM-41044: Error deleting timer %s

Cause:An error occurred while executing a DELETE_TIMER built-in.

Action:Verify that your timer has been created correctly.

Level:>25

Type:Error


FRM-41045

FRM-41045: Cannot find item: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_ALERT will be performed.

Level:>25

Type:Error


FRM-41046

FRM-41046: Invalid parameter used for Set_Item_Property.

Cause:An invalid parameter was passed to SET_ITEM_PROPERTY.

Action:Verify the valid parameters for SET_ITEM_PROPERTY and try again.

Level:>25

Type:Error


FRM-41047

FRM-41047: Cannot navigate out of current block in enter-query mode.

Cause:An illegal attempt to navigate out of the current block when in Enter Query mode.

Action:Perform operation before entering query mode.

Level:>25

Type:Error


FRM-41048

FRM-41048: Procedure %s is not valid in a %s trigger.

Cause:The indicated procedure is not valid when called from the indicated trigger. The procedure may be a restricted procedure, which cannot be called from any trigger that fires during navigation.

Action:Correct the invalid trigger.

Level:20

Type:Error


FRM-41049

FRM-41049: You cannot delete this record.

Cause:You attempted to delete a record on a block that does not allow deletes.

Action:Do not attempt to delete records in this block until you have set the Delete Allowed block property to True.

Level:>20

Type:Error


FRM-41050

FRM-41050: You cannot update this record.

Cause:You attempted to update a record on a block that does not allow updates.

Action:Do not attempt to update records in this block until you have set the Update Allowed block property to True.

Level:20

Type:Error


FRM-41051

FRM-41051: You cannot create records here.

Cause:You attempted to create records on a block that does not allow inserts.

Action:Do not attempt to create and insert new records into this block until you have set the Insert Allowed block property to True.

Level:20

Type:Error


FRM-41052

FRM-41052: Cannot find Window: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_WINDOW will be performed.

Level:20

Type:Error


FRM-41053

FRM-41053: Cannot find Canvas: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_CANVAS will be performed.

Level:20

Type:Error


FRM-41055

FRM-41055: No such property for Set_Record_Property.

Cause:You attempted to set a non-existent record property.

Action:Verify call to SET_RECORD_PROPERTY for valid property.

Level:20

Type:Error


FRM-41056

FRM-41056: Cannot find Block: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_BLOCK will be performed.

Level:>25

Type:Error


FRM-41057

FRM-41057: No such property for Set_View_Property.

Cause:You attempted to set a non-existent view property.

Action:Verify call to SET_VIEW_PROPERTY for valid property.

Level:20

Type:Error


FRM-41058

FRM-41058: No such property for Get_Item_Property.

Cause:You attempted to get a non-existent item property.

Action:Verify call to GET_ITEM_PROPERTY for valid property.

Level:20

Type:Error


FRM-41059

FRM-41059: No such property for Set_Canvas_Property.

Cause:You attempted to set a non-existent canvas property.

Action:Verify call to SET_CANVAS_PROPERTY for valid property.

Level:20

Type:Error


FRM-41060

FRM-41060: Cannot disable Primary Key property of only key item.

Cause:You attempted to turn off the Primary Key property on the last primary key item on a block with either the Primary Key property or with key mode of the primary key.

Action:Disable the block properties first.

Level:20

Type:Error


FRM-41061

FRM-41061: No such property for Get_Window_Property.

Cause:You attempted to get a non-existent window property.

Action:Verify call to GET_WINDOW_PROPERTY for valid property.

Level:99

Type:Error


FRM-41062

FRM-41062: Cannot find Editor: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_EDITOR will be performed.

Level:20

Type:Error


FRM-41063

FRM-41063: Cannot create Editor.

Cause:Not enough memory available for Forms Runtime.

Action:Try calling SHOW_EDITOR again after closing some of your windows.

Level:20

Type:Error


FRM-41064

FRM-41064: Cannot create Timer %s: illegal identifier name.

Cause:Illegal identifier name.

Action:Check legal syntax for naming timers.

Level:99

Type:Error


FRM-41065

FRM-41065: Cannot find Menu: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_MENU will be performed.

Level:20

Type:Error


FRM-41066

FRM-41066: No such property for Get_Form_Property.

Cause:You attempted to get a non-existent form property.

Action:Verify call to GET_FORM_PROPERTY for valid property.

Level:20

Type:Error


FRM-41067

FRM-41067: Cannot find Menu Item: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_MENU_ITEM will be performed.

Level:20

Type:Error


FRM-41068

FRM-41068: Error in Set_Menu_Item_Property.

Cause:Invalid call to SET_MENU_ITEM_PROPERTY.

Action:Verify valid parameters and try again.

Level:20

Type:Error


FRM-41069

FRM-41069: Error in Get_Menu_Item_Property.

Cause:Invalid call to GET_MENU_ITEM_PROPERTY.

Action:Verify valid parameters and try again.

Level:20

Type:Error


FRM-41070

FRM-41070: Unknown property for Set_Menu_Item_Property.

Cause:You attempted to set a non-existent menu item property.

Action:Verify call to SET_MENU_ITEM_PROPERTY for valid property.

Level:20

Type:Error


FRM-41071

FRM-41071: Unknown property for Get_Menu_Item_Property.

Cause:You attempted to get a non-existent menu item property.

Action:Verify call to GET_MENU_ITEM_PROPERTY for valid property.

Level:20

Type:Error


FRM-41072

FRM-41072: Cannot create Group %s

Cause:Caused by one of the following

1. Duplicate column names in SQL statement.

2. Invalid record group name.

3. Query is invalid.

Action:Check the group name and/or correct the SQL statement.

Level:20

Type:Error


FRM-41073

FRM-41073: Cannot find Group: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_GROUP will be performed.

Level:20

Type:Error


FRM-41074

FRM-41074: Cannot find Group or Column: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_GROUP or FIND_COLUMN will be performed.

Level:20

Type:Error


FRM-41075

FRM-41075: Error deleting Group.

Cause:The record group name or ID specified in the call to DELETE_GROUP is invalid, or the record group was not dynamically created.

Action:Check the record group name or ID, and make sure that the specified record group was dynamically created.

Level:20

Type:Error


FRM-41076

FRM-41076: Error populating Group.

Cause:Query failed due to an invalid column or table name, or the query and group column structure do not match.

Action:Check the SQL SELECT statement in your call to POPULATE_GROUP_WITH_QUERY.

Level:20

Type:Error


FRM-41077

FRM-41077: Error deleting Group Row(s).

Cause:DELETE_GROUP_ROW cannot be used to delete records from a static record group, or you specified an invalid row number.

Action:Correct the call to DELETE_GROUP_ROW.

Level:20

Type:Error


FRM-41078

FRM-41078: Error resetting Group selection.

Cause:Record group name or ID specified is invalid.

Action:Check the record group name or ID and try again.

Level:20

Type:Error


FRM-41079

FRM-41079: Error adding Group column.

Cause:Caused by one of the following:

1. You cannot add columns to a group that already has rows.

2. The width of CHAR_COLUMN-typed columns cannot be less than the width of the corresponding database column.

3. You entered the name of a nonexistent or invalid record group.

4. You entered the name of a nonexistent or invalid column.

5. You entered a column type other than CHAR, NUMBER, or DATE.

Action:You can only add columns to a group after it is created with a call to CREATE_GROUP. If the group already has rows, delete the rows with DELETE_GROUP_ROW, then add the column.

Level:20

Type:Error


FRM-41080

FRM-41080: Error adding Group row.

Cause:Caused by one of the following:

1. You attempted to add rows to a group that is nonexistent or has no columns.

2. You entered the name of a nonexistent record group.

3. You provided a row number that is out of range or invalid.

Action:Create the group and add columns first. Check the call to ADD_GROUP_ROW to make sure that the record group name and row number are valid.

Level:20

Type:Error


FRM-41081

FRM-41081: Cannot move Item: invalid position.

Cause:You attempted to move the item to an invalid position on the canvas.

Action:Make sure the coordinates you chose in your call to SET_ITEM_PROPERTY are valid.

Level:99

Type:Error


FRM-41082

FRM-41082: Cannot resize item: position of item places it off of canvas.

Cause:The height and/or width you specified in your call to SET_ITEM_PROPERTY is invalid, or the height and/or width you specified causes the item to extend off of the canvas.

Action:Correct the call to SET_ITEM_PROPERTY.

Level:99

Type:Error


FRM-41083

FRM-41083: No such property for Set_Form_Property

Cause:You attempted to set a nonexistent form property.

Action:Verify call to SET_FORM_PROPERTY for valid property.

Level:20

Type:Error


FRM-41084

FRM-41084: Error getting Group Cell.

Cause:Invalid call to GET_GROUP_CHAR_CELL, GET_GROUP_DATE_CELL, OR GET_GROUP_NUMBER_CELL.

Action:Make sure the column type is of CHAR, DATE, or NUMBER, respectively. Check the validity of the row number and column name specified.

Level:20

Type:Error


FRM-41085

FRM-41085: Error getting Group Row count.

Cause:Invalid call to GET_GROUP_ROW_COUNT.

Action:Check the record group name and try again.

Level:20

Type:Error


FRM-41086

FRM-41086: Error getting Group selection count.

Cause:You specified an invalid record group name. Invalid call to GET_GROUP_SELECTION_COUNT.

Action:Correct the call to GET_GROUP_SELECTION.

Level:20

Type:Error


FRM-41087

FRM-41087: Error getting Group selection.

Cause:You specified an invalid record group name or selection number. Invalid call to GET_GROUP_SELECTION.

Action:Correct the call to GET_GROUP_SELECTION.

Level:20

Type:Error


FRM-41088

FRM-41088: Cannot set Group selection.

Cause:You specified an invalid record group name, ID, or row number.

Action:Correct the call to SET_GROUP_SELECTION.

Level:20

Type:Error


FRM-41089

FRM-41089: Cannot move View: invalid position.

Cause:The x, y pair specified in the call to SET_VIEW_PROPERTY is invalid.

Action:Correct the call to SET_VIEW_PROPERTY by making sure that the position specified by your coordinates is on the canvas.

Level:99

Type:Error


FRM-41090

FRM-41090: Invalid item type for go_item: %s.

Cause:You cannot navigate to the item.

Action:Check to make sure the item is a navigable item.

Level:20

Type:Error


FRM-41091

FRM-41091: Cannot find LOV: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_LOV will be performed.

Level:20

Type:Error


FRM-41092

FRM-41092: No records in block %s.

Cause:You attempted to place a value into an item on a block that has no records.

Action:Put records in the block first.

Level:20

Type:Error


FRM-41093

FRM-41093: Error setting item attribute: %s.

Cause:You specified Lock Record and the item was not a text item, or you specify Case Insensitive Query and the data type was not ALPHA or CHAR.

Action:In the case of Lock Record, make sure that the item is a text item. When specifying Case Insensitive Query, make sure that the data type is ALPHA or CHAR.

Level:20

Type:Error


FRM-41094

FRM-41094: No such property for Get_View_Property.

Cause:You attempted to get a non-existent view property.

Action:Verify call to GET_VIEW_PROPERTY for valid property.

Level:99

Type:Error


FRM-41095

FRM-41095: No such property for Get_Canvas_Property.

Cause:You attempted to get a non-existent canvas property.

Action:Verify call to GET_CANVAS_PROPERTY for valid property.

Level:99

Type:Error


FRM-41096

FRM-41096: Cannot resize View: invalid size.

Cause:The x, y coordinates place the view off the canvas.

Action:Choose another x, y pair.

Level:99

Type:Error


FRM-41097

FRM-41097: Cannot resize Canvas: invalid size.

Cause:The x, y coordinates place the view off the window.

Action:Choose another x, y pair.

Level:99

Type:Error


FRM-41098

FRM-41098: Cannot modify Display Position of a content view.

Cause:The display position property applies to a stacked canvas-view only.

Action:Correct the call to SET_VIEW_PROPERTY.

Level:99

Type:Error


FRM-41099

FRM-41099: Cannot modify Size of a content view.

Cause:The size of a content view is dependent on window size. Only stacked view sizes may be modified using SET_VIEW_PROPERTY.

Action:Correct the call to SET_VIEW_PROPERTY.

Level:99

Type:Error


FRM-41100

FRM-41100: Cannot find relation %s.

Cause:You attempted to get, set, or find using an invalid relation.

Action:Check call to built-in for correct arguments.

Level:>25

Type:Error


FRM-41101

FRM-41101: No such property for Get_Relation_Property.

Cause:You attempted to get a non-existent relation property.

Action:Verify call to GET_RELATION_PROPERTY for valid property.

Level:99

Type:Error


FRM-41102

FRM-41102: No such property for Set_Relation_Property.

Cause:You attempted to set a non-existent relation property.

Action:Verify call to SET_RELATION_PROPERTY for valid property.

Level:99

Type:Error


FRM-41103

FRM-41103: No such property value for Set_Relation_Property.

Cause:Application design error. Improper relation property value passed to SET_RELATION_PROPERTY built-in.

Action:Correct call to SET_RELATION_PROPERTY built-in and retry.

Level:99

Type:Error


FRM-41105

FRM-41105: You cannot query records without a saved parent record.

Cause:You attempted to query detail records without first creating a master record.

Action:Create a master record, and then query the detail records.


FRM-41106

FRM-41106: You cannot create records without a parent record.

Cause:You attempted to create new detail records without first creating a master record.

Action:Create a master record, and then add the detail records.


FRM-41107

FRM-41107: Master delete option for the relation is invalid.

Cause:An invalid query data source type or an invalid DML data target type is specified for the detail block.

Action:Verify that the detail block's query data source and the DML data targets are of type table.

Level:20

Type:Error


FRM-41200

FRM-41200: Integration error: invalid product.

Cause:Invalid product name specified in RUN_PRODUCT.

Action:Check the RUN_PRODUCT parameters and try again.

Level:99

Type:Error


FRM-41201

FRM-41201: Integration error: communication mode must be SYNCHRONOUS or ASYNCHRONOUS.

Cause:Invalid communication mode specified in RUN_PRODUCT.

Action:Check the RUN_PRODUCT parameters and try again.

Level:20

Type:Error


FRM-41202

FRM-41202: Integration error: parameter list %s has no parameters.

Cause:Parameter list has no arguments.

Action:Check the specified parameter list for parameters.

Level:20

Type:Error


FRM-41203

FRM-41203: Integration error: invalid parameter list ID.

Cause:An invalid parameter list ID was passed.

Action:Check the parameter list ID name and try again.

Level:20

Type:Error


FRM-41204

FRM-41204: Integration error: memory allocation error.

Cause:An internal error occurred.

Action:Contact customer support.

Level:20

Type:Error


FRM-41205

FRM-41205: Integration error: %s not a Chart Item

Cause:The variable type specified for display is not of type Chart Item.

Action:Specify a Chart Item for the display parameter.

Level:20

Type:Error


FRM-41206

FRM-41206: Integration error: ambiguous item %s.

Cause:Invalid item name; may be a duplicate.

Action:Specify the item name with the block name.item name format.

Level:20

Type:Error


FRM-41207

FRM-41207: Integration error: could not find item %s.

Cause:The item name specified does not exist.

Action:Check the name for accuracy and try again with the format block name.item name.

Level:20

Type:Error


FRM-41208

FRM-41208: Integration error: execution mode must be BATCH or RUNTIME.

Cause:Invalid execution mode specified in RUN_PRODUCT.

Action:Specify either BATCH or RUNTIME for the execmode parameter.

Level:20

Type:Error


FRM-41209

FRM-41209: Integration error: document location must be FILESYSTEM or DB.

Cause:Invalid document location specified in RUN_PRODUCT.

Action:Specify either FILESYSTEM or DB for the location parameter.

Level:20

Type:Error


FRM-41210

FRM-41210: Integration error: Null Chart Item

Cause:A null is specified for the chart item display.

Action:Check the display item of the RUN_PRODUCT built-in and confirm that it is not null.

Level:20

Type:Error


FRM-41211

FRM-41211: Integration error: SSL failure running another product.

Cause:There is a problem detected when launching another product.

Action:Check the RUN_PRODUCT built-in.

Level:99

Type:Error


FRM-41212

FRM-41212: Integration error: invalid communication mode for data exchange

Cause:User specified an asynchronous RUN_PRODUCT.

Action:Change to a synchronous RUN_PRODUCT communication mode.

Level:20

Type:Error


FRM-41213

FRM-41213: Unable to connect to the Report server %s.

Cause:There is a problem connecting to the specified Report server.

Action:Check the Report server and make sure it is up and running.

Level:20

Type:Error


FRM-41214

FRM-41214: Unable to run report.

Cause:The report server was unable to run the specified report.

Action:Check the Report server and make sure it is up and running.

Level:20

Type:Error


FRM-41215

FRM-41215: Invalid server name or jobid.

Cause:There is a problem decoding the return value from the built-in run_report.

Action:The return value from the built-in run_report should not be modified before being passed to another report built-in.

Level:20

Type:Error


FRM-41216

FRM-41216: Unable to cancel job.

Cause:There is a problem cancelling a report job.

Action:Check the Report server and make sure that the specified job exists.

Level:20

Type:Error


FRM-41217

FRM-41217: Unable to get report job status.

Cause:There is a problem getting report status for a given report job.

Action:Check the Report server and make sure that the specified job exists.

Level:20

Type:Error


FRM-41218

FRM-41218: Unable to copy report output.

Cause:There is a problem copying report output for a given report job.

Action:Check the Report server and make sure that the specified output file exists.

Level:20

Type:Error


FRM-41219

FRM-41219: Cannot find report: invalid ID.

Cause:The user has specified an invalid report object name.

Action:Check the form and make sure that the report object exists.

Level:20

Type:Error


FRM-41300

FRM-41300: Invalid parameter used for Set_Radio_Button_Property.

Cause:You specified a parameter that does not exist.

Action:Check the list of legal parameters.

Level:99

Type:Error


FRM-41301

FRM-41301: Invalid parameter used for Set_View_Property.

Cause:You specified a parameter that does not exist.

Action:Check the list of legal parameters.

Level:99

Type:Error


FRM-41302

FRM-41302: Invalid parameter used for Set_Canvas_Property.

Cause:You specified a parameter that does not exist.

Action:Check the list of legal parameters.

Level:99

Type:Error


FRM-41303

FRM-41303: No such property for Set_Window_Property.

Cause:You specified a property that does not exist.

Action:Check the list of legal properties.

Level:99

Type:Error


FRM-41304

FRM-41304: No such property for Set_Block_Property.

Cause:You specified a property that does not exist.

Action:Check the list of legal properties.

Level:99

Type:Error


FRM-41305

FRM-41305: No such property for Get_Block_Property.

Cause:You specified a property that does not exist.

Action:Check the list of legal properties.

Level:99

Type:Error


FRM-41306

FRM-41306: Invalid parameter used for Set_Window_Property.

Cause:You specified a parameter that is not valid.

Action:Check the list of valid parameters.

Level:99

Type:Error


FRM-41307

FRM-41307: Invalid parameter used for Set_Block_Property.

Cause:You specified a parameter that is not valid.

Action:Check the list of valid parameters.

Level:99

Type:Error


FRM-41308

FRM-41308: Error unsetting Group selection.

Cause:You tried to deselect a record or a subset of records that was not selected or is not in the record group.

Action:Check the records that are expected in the group.

Level:20

Type:Error


FRM-41309

FRM-41309: No such property for Get_Radio_Button_Property.

Cause:You specified a property that is invalid.

Action:Check the list of valid properties.

Level:99

Type:Error


FRM-41310

FRM-41310: No such property for Set_Radio_Button_Property.

Cause:You specified a property that is invalid.

Action:Check the list of valid properties.

Level:99

Type:Error


FRM-41311

FRM-41311: Invalid argument or argument ordering for %s.

Cause:You supplied an incorrect argument list.

Action:Check the list of valid arguments.

Level:99

Type:Error


FRM-41312

FRM-41312: Must have at least one writable item in block.

Cause:A block with the INSERT_ALLOWED or UPDATE_ALLOWED property set to True must have at least one writable item. You attempted to make the only remaining base table item in the block not writable by setting either the DERIVED_COLUMN or QUERY_ONLY property to True.

Action:Set INSERT_ALLOWED or UPDATE_ALLOWED to False for the block, rather than setting DERIVED_COLUMN or QUERY_ALLOWED to False for each item.

Level:10

Type:Informative


FRM-41313

FRM-41313: No such property for Set_Alert_Property.

Cause:An invalid property has been specified for SET_ALERT_PROPERTY.

Action:Enter a valid alert property.

Level:99

Type:Error


FRM-41314

FRM-41314: Cannot set Insert Allowed property of current item %s.%s

Cause:You attempted to set the Insert Allowed property for a non-displayed item.

Action:The Insert Allowed property is only valid on displayed items. Make sure the item is displayed.

Level:99

Type:Error


FRM-41315

FRM-41315: Cannot set Insert Allowed property of non-displayed item %s.%s

Cause:You tried to set Insert Allowed property for a non-displayed item.

Action:The Insert Allowed property is only valid on displayed items. Make sure the item is displayed.

Level:99

Type:Error


FRM-41316

FRM-41316: Cannot set Insert Allowed property of disabled item %s.%s

Cause:You tried to set Insert Allowed property for a disabled item.

Action:The Insert Allowed property is only valid on enabled items. Make sure the item is enabled.

Level:99

Type:Error


FRM-41317

FRM-41317: Item is not a radio button %s

Cause:You tried to use a radio button built-in with an item that is not a radio button.

Action:Make sure the item is a radio button.

Level:99

Type:Error


FRM-41318

FRM-41318: Item %s is not a VBX item.

Cause:You tried to use a VBX built-in with an item that is not a VBX item.

Action:Make sure the item is a VBX item.

Level:5

Type:Informative


FRM-41319

FRM-41319: Invalid property %s specified for VBX item %s.

Cause:You tried to get or set an invalid property for the specified VBX item.

Action:Make sure the property is valid for the specified VBX item.

Level:99

Type:Error


FRM-41320

FRM-41320: Unable to get property %s for VBX item %s.

Cause:Could not get the valid property for the VBX item.

Action:Check the list of legal properties.

Level:99

Type:Error


FRM-41321

FRM-41321: Unable to set property %s for VBX item %s.

Cause:Could not set the valid property for the VBX item.

Action:Check the list of legal properties.

Level:99

Type:Error


FRM-41322

FRM-41322: Invalid event %s for VBX item %s.

Cause:You tried to get or set an invalid event for the specified VBX item.

Action:Make sure the event is valid for the specified VBX item.

Level:99

Type:Error


FRM-41323

FRM-41323: Too many parameters for event %s for VBX item %s.

Cause:You specified too many parameters for the event name for the VBX item.

Action:Make sure there is a valid number of parameters for the event.

Level:99

Type:Error


FRM-41324

FRM-41324: Too few parameters for event %s for VBX item %s.

Cause:You specified too few parameters for the event name for the VBX item.

Action:Make sure there is a valid number of parameters for the event.

Level:99

Type:Error


FRM-41325

FRM-41325: VBX event parameter must be a string.

Cause:The VBX event parameter is not a string.

Action:Make sure the VBX event parameter is a string.

Level:99

Type:Error


FRM-41326

FRM-41326: Failed to deliver event %s to VBX item %s.

Cause:The VBX event failed.

Action:Make sure the event is valid for the specified VBX item.

Level:99

Type:Error


FRM-41327

FRM-41327: Failed to get default property for VBX item %s.

Cause:The VBX.GET_VALUE_PROPERTY built-in failed.

Action:Make sure an initial value is assigned to the VB Control Value property.

Level:99

Type:Error


FRM-41328

FRM-41328: Failed to set default property for VBX item %s.

Cause:The VBX.SET_VALUE_PROPERTY built-in failed.

Action:Make sure you are setting a valid value property.

Level:99

Type:Error


FRM-41329

FRM-41329: Item %s is not a List item.

Cause:You tried to add a list element to an item that is not a list.

Action:Make sure the item is a List item.

Level:99

Type:Error


FRM-41330

FRM-41330: Could not insert list element into %s.

Cause:You tried to insert an other values element when the block contained either queried or changed records.

Action:For more information, refer to help for restrictions on ADD_LIST_ELEMENT .

Level:99

Type:Error


FRM-41331

FRM-41331: Could not delete element from %s.

Cause:Caused by one of the following:

You tried to delete the other values element when the block contained either queried or changed records.

You tried to delete an element from a list that does not contain an other values element when the block contained either queried or changed records.

Action:For more information, refer to help for restrictions on CLEAR_LIST and DELETE_LIST_ELEMENT .

Level:99

Type:Error


FRM-41332

FRM-41332: List element index out of range.

Cause:Not enough memory.

Action:Contact your DBA.

Level:99

Type:Error


FRM-41333

FRM-41333: Cannot convert list element value.

Cause:Could not resolve list element value to a string.

Action:Make sure list element is a string.

Level:99

Type:Error


FRM-41334

FRM-41334: Invalid record group for list population.

Cause:You tried to populate a list from a record group that does not exist.

Action:Make sure the record group exists.

Level:99

Type:Error


FRM-41335

FRM-41335: Populate_List: invalid column type for column 1.

Cause:You tried to populate a list from a record group that does not exist.

Action:Make sure the record group exists.

Level:99

Type:Error


FRM-41336

FRM-41336: Populate_List: invalid column type for column 2.

Cause:The record group does not have a column of the same type.

Action:Make sure record group has a column of the same type.

Level:99

Type:Error


FRM-41337

FRM-41337: Cannot populate the list from record group.

Cause:The record group is invalid or the list item does not satisfy the requirements for deleting and adding elements.

Action:Make sure the record group is valid. For more information about deleting and adding list elements, refer to help for restrictions on DELETE_LIST_ELEMENT and ADD_LIST_ELEMENT .

Level:99

Type:Error


FRM-41338

FRM-41338: Cannot retrieve the list into record group.

Cause:The record group is invalid.

Action:Make sure the record group is valid.

Level:99

Type:Error


FRM-41339

FRM-41339: Cannot clear the list.

Cause:Not enough memory.

Action:Contact your DBA.

Level:99

Type:Error


FRM-41340

FRM-41340: No such property for Set_Application_Property.

Cause:You specified an invalid property.

Action:Specify a valid property

Level:99

Type:Error


FRM-41341

FRM-41341: Invalid cursor shape %s specified.

Cause:There is a predefined set of cursor types, and an invalid cursor type was specified.

Action:Specify a valid cursor type.

Level:99

Type:Error


FRM-41342

FRM-41342: Invalid parameter %s specified for VBX event %s.

Cause:You specified an invalid parameter for a VBX event.

Action:Check the parameter type.

Level:99

Type:Error


FRM-41343

FRM-41343: Item %s is not an OLE object.

Cause:Invalid item passed to OLE built-in.

Action:Specify a valid OLE item.

Level:99

Type:Error


FRM-41344

FRM-41344: OLE object not defined for %s in the current record.

Cause:An empty OLE container is defined.

Action:Define an OLE object to reside in the OLE container.

Level:20

Type:Error


FRM-41345

FRM-41345: Cannot find the verb %s for this server.

Cause:You specified an invalid OLE verb.

Action:Specify a valid OLE verb.

Level:99

Type:Error


FRM-41346

FRM-41346: Cannot determine the verb count for OLE object %s.

Cause:Could not communicate with OLE server.

Action:Re-install the OLE server.

Level:99

Type:Error


FRM-41347

FRM-41347: Invalid verb index for OLE object %s.

Cause:You provided an index that is greater than the verb count.

Action:Check the index value.

Level:99

Type:Error


FRM-41348

FRM-41348: OLE server error: %s.

Cause:OLE server detects an error.

Action:Try to resolve the error based on the message from the OLE server.

Level:99

Type:Error


FRM-41349

FRM-41349: OLE object %s cannot execute verb; verb id %d

Cause:OLE object does not recognize the verb.

Action:Try to execute another verb.

Level:99

Type:Error


FRM-41350

FRM-41350: OLE object is currently not displayed.

Cause:You tried to close a server that is not running.

Action:Ask if the server is active in a record that is not currently active.

Level:99

Type:Error


FRM-41351

FRM-41351: Cannot navigate out of current form.

Cause:You cannot navigate to an inactive form.

Action:Check to make sure the form you are navigating to is active.

Level:99

Type:Error


FRM-41352

FRM-41352: Failed to create a new session.

Cause:You attempted to open a new form with a new session.

Action:Check the database server.

Level:99

Type:Error


FRM-41353

FRM-41353: Cannot start another call form.

Cause:You went to a peer form and performed a call form.

Action:Make sure you are not at a peer form when calling the form.

Level:99

Type:Error


FRM-41354

FRM-41354: Cannot close form %s.

Cause:Unsuccessful attempt to close a form.

Action:Make sure the form is open.

Level:99

Type:Error


FRM-41355

FRM-41355: Cannot navigate to form %s.

Cause:You cannot navigate to an inactive form.

Action:Check to make sure you are navigating to an active form.

Level:99

Type:Error


FRM-41356

FRM-41356: Invalid method %s for VBX item %s.

Cause:You specified an invalid method name for the VBX item.

Action:Specify a valid method name for the VBX item.

Level:99

Type:Error


FRM-41357

FRM-41357: Incorrect number of arguments to method %s for VBX item %s.

Cause:You specified an incorrect number of arguments to the method for the VBX item.

Action:Make sure the number of arguments is what the VBX item expects.

Level:99

Type:Error


FRM-41358

FRM-41358: Method %s failed for VBX item %s.

Cause:You specified an invalid method name for the VBX item.

Action:Specify a valid method name for the VBX item.

Level:5

Type:Informative


FRM-41359

FRM-41359: The Open_Form session feature is not enabled. Cannot create new session.

Cause:You do not have the multiple sessioning feature enabled on the database.

Action:The Open_Form session feature is only available for use against a database with multiple sessioning enabled.

Level:99

Type:Error


FRM-41360

FRM-41360: Invalid value used in Set_Window_Property for window %s.

Cause:You are using an invalid value when attempting to set a window property.

Action:Specify a valid window property value.

Level:99

Type:Error


FRM-41361

FRM-41361: Cannot navigate out of current form in Enter-Query mode.

Cause:You are in Enter-Query mode and trying to navigate to another form when using Open Form.

Action:Exit Enter-Query mode and try again.

Level:10

Type:Error


FRM-41362

FRM-41362: No such property for Set_Alert_Button_Property.

Cause:You specified an invalid property for Set_Alert_Button_Property.

Action:Specify a valid property for Set_Alert_Button_Property.

Level:99

Type:Error


FRM-41363

FRM-41363: No such property for Set_LOV_Column_Property.

Cause:You specified an invalid property for Set_LOV_Column_Property.

Action:Specify a valid property for Set_LOV_Column_Property.

Level:99

Type:Error


FRM-41364

FRM-41364: Invalid column number specified for LOV %s.

Cause:You specified an invalid column number for the LOV.

Action:Specify a valid column number for the LOV.

Level:99

Type:Error


FRM-41365

FRM-41365: No such property for Set_TabPage_Property.

Cause:You specified an invalid property for Set_TabPage_Property.

Action:Specify a valid property for Set_TabPage_Property.

Level:99

Type:Error


FRM-41366

FRM-41366: No such property for Get_TabPage_Property.

Cause:You specified an invalid property parameter.

Action:Check the list of valid properties.

Level:99

Type:Error


FRM-41367

FRM-41367: Cannot find TabPage: invalid ID.

Cause:An invalid ID was passed to a built-in subprogram.

Action:Verify that a proper call to FIND_TABPAGE will be performed.

Level:99

Type:Error


FRM-41368

FRM-41368: Invalid parameter used for Set_TabPage_Property.

Cause:You specified a parameter that is not valid.

Action:Check the list of valid parameters.

Level:99

Type:Error


FRM-41369

FRM-41369: Cannot insert a second record into a single-record block.

Cause:You (or the application) have attempted to insert a second record into a block whose SINGLE_RECORD property is TRUE.

Action:Don't attempt to insert a record into such a block.

Level:99

Type:Error


FRM-41370

FRM-41370: Cannot modify calculated item %s.%s.

Cause:Application design error. The application attempted to assign a value to a calculated item.

Action:If the calculated item is a formula item, then its formula determines its value at all times. It may be appropriate to modify the formula. Or it may be appropriate to change the calculated item to a non-calculated control item whose value is set in various triggers.

Level:99

Type:Error


FRM-41371

FRM-41371: Cannot programmatically set INSERT_ALLOWED property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY or SET_ITEM_INSTANCE_PROPERTY built-in attempted to set a calculated item's INSERT_ALLOWED property to TRUE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41372

FRM-41372: Cannot programmatically set ITEM_IS_VALID property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY built-in attempted to set a calculated item's ITEM_IS_VALID property to FALSE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41373

FRM-41373: Cannot programmatically set LOCK_RECORD property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY built-in attempted to set a calculated item's LOCK_RECORD property to TRUE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41374

FRM-41374: Cannot programmatically set PRIMARY_KEY property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY built-in attempted to set a calculated item's PRIMARY_KEY property to TRUE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41375

FRM-41375: Cannot programmatically set QUERYABLE property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY built-in attempted to set a calculated item's QUERYABLE property to TRUE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41376

FRM-41376: Cannot programmatically set REQUIRED property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY or SET_ITEM_INSTANCE_PROPERTY built-in attempted to set a calculated item's REQUIRED property to TRUE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41377

FRM-41377: Cannot programmatically set UPDATEABLE property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY or SET_ITEM_INSTANCE_PROPERTY built-in attempted to set a calculated item's UPDATEABLE property to TRUE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41378

FRM-41378: Cannot programmatically set UPDATE_NULL property of calculated item %s.%s.

Cause:Application design error. A SET_ITEM_PROPERTY built-in attempted to set a calculated item's UPDATE_NULL property to TRUE.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41379

FRM-41379: Cannot recalculate non-formula item %s.%s.

Cause:Application design error. A RECALCULATE built-in specified an item which is not a formula item.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41380

FRM-41380: Cannot set the blocks query data source.

Cause:The user attempt to change the block's data source dynamically has failed.

Action:Check the form and make sure that the specified block is not a control block and the block status is new.

Level:20

Type:Error


FRM-41381

FRM-41381: Cannot set the blocks DML data target source.

Cause:The user attempt to change the block's DML data target dynamically has failed.

Action:Check the form and make sure that the specified block is not a control block and the block status is new.

Level:20

Type:Error


FRM-41382

FRM-41382: No such property for Get_Item_Instance_Property.

Cause:Application design error. A GET_ITEM_INSTANCE_PROPERTY built-in specified an invalid property.

Action:The property must be changed to BORDER_BEVEL, INSERT_ALLOWED, NAVIGABLE, REQUIRED, UPDATEABLE, or VISUAL_ATTRIBUTE, or else the call to the built-in must be removed.

Level:99

Type:Error


FRM-41383

FRM-41383: No such property for Set_Item_Instance_Property.

Cause:Application design error. A SET_ITEM_INSTANCE_PROPERTY built-in specified an invalid property.

Action:The property must be changed to BORDER_BEVEL, INSERT_ALLOWED, NAVIGABLE, REQUIRED, UPDATEABLE, or VISUAL_ATTRIBUTE, or else the call to the built-in must be removed.

Level:99

Type:Error


FRM-41384

FRM-41384: Invalid parameter used for Set_Item_Instance_Property.

Cause:Application design error. A SET_ITEM_INSTANCE_PROPERTY built-in specified an invalid value for a property.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-41385

FRM-41385: Maximum number of queried records exceeded.

Cause:The user specified maximum number of records for a given block is reached.

Action:Check the forms block and form level properties.

Level:99

Type:Informative


FRM-41386

FRM-41386: Cannot set VISIBLE attribute of tab page containing current item.

Cause:You tried to set the Visible property for the tab page which contains the current item.

Action:The Visible property is only valid for tab pages which don't contain the current item.

Navigate to an item on a different tab page or different canvas first.

Level:99

Type:Error


FRM-41387

FRM-41387: Cannot set VISIBLE attribute of last enterable tab page.

Cause:You tried to set the Visible property for the only enterable tab page on the canvas.

Action:Make sure there is at least one other enterable tab page on the canvas before trying to set the Visible property.

Level:99

Type:Error


FRM-41388

FRM-41388: Cannot set ENABLED attribute of tab page containing current item.

Cause:You tried to set the Enabled property for the tab page which contains the current item.

Action:The property is only valid for tab pages which don't contain the current item.

Navigate to an item on a different tab page or different canvas first.

Level:99

Type:Error


FRM-41389

FRM-41389: Cannot set ENABLED attribute of last enterable tab page.

Cause:You tried to set the Enabled property for the only enterable tab page on the canvas.

Action:Make sure there is at least one other enterable tab page on the canvas before trying to set the Enabled property.

Level:99

Type:Error


FRM-41800

FRM-41800: List of Values not available for this field.

Cause:You pressed [List], but the form does not provide a list of values for this field.

Action:No action is necessary.

Level:10

Type:Informative


FRM-41801

FRM-41801: Last value retrieved.

Cause:You pressed [List] and then pressed [Next Item] after the last value in the list was displayed.

Action:Enter an item value or press [List] again to display the list of possible values.

Level:10

Type:Informative


FRM-41802

FRM-41802: Duplicate record function allowed on new records only.

Cause:You pressed [Duplicate Record], but the current record is the one that has been fetched from the database.

Action:No action is necessary. You can use [Duplicate Record] only when creating a new record.

Level:10

Type:Error


FRM-41803

FRM-41803: No previous record to copy value from.

Cause:You pressed [Duplicate Item] or [Duplicate Record], but the current record is the first record in the block.

Action:No action is necessary. [Duplicate Item] and [Duplicate Record] are meaningless in this context.

Level:10

Type:Error


FRM-41804

FRM-41804: Variable was not entered: %.30s.

Cause:Your response to the Query Where alert contained a placeholder not used in any of the query items.

Action:Correct the placeholder in your response, or define it in one of the query items. Then re-execute the query.

Level:>25

Type:Error


FRM-41805

FRM-41805: Ambiguous item name: %s.

Cause:Application design error. Ambiguous item name.

Action:

Level:>25

Type:Error


FRM-41806

FRM-41806: Too many variables used.

Cause:You used more than 25 substitution variables in your query.

Action:Reduce the number of substitution variables and re-query.

Level:>25

Type:Error


FRM-41809

FRM-41809: Error initializing Menu.

Cause:You tried to use the menu component from within Form Builder, and an internal error occurred.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-41810

FRM-41810: Error creating menu.

Cause:You tried to use the menu component from within Form Builder, and an internal error occurred.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-41811

FRM-41811: Error removing menu.

Cause:You tried to use Menus from within Form Builder, and an internal Menu error occurred.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-41812

FRM-41812: Error resetting Menu.

Cause:You tried to use the menu component from within Form Builder, and an internal error occurred.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-41813

FRM-41813: Form exited by debug mode.

Cause:You selected the Exit Oracle Forms Runtime option on the Break Processing menu.

Action:No action is necessary.

Level:>25

Type:Working


FRM-41814

FRM-41814: Invalid page position.

Cause:Application design error. A trigger tried to move or resize a view to a page that would cause all or part of the view to display off of the screen.

Action:Correct the statement.

Level:>25

Type:Error


FRM-41815

FRM-41815: No such property for Get_LOV_Property.

Cause:You attempted to get a nonexistent LOV property.

Action:Verify the valid LOV properties and try again.

Level:>25

Type:Error


FRM-41816

FRM-41816: Attempt to create existing timer: %s.

Cause:Attempted to create a timer that already exists.

Action:Delete or alter the existing timer before re-creating a new one.

Level:>25

Type:Error


FRM-41817

FRM-41817: No such timer: %s.

Cause:You attempted to alter or delete a non-existent timer.

Action:Check the built-in for proper arguments.

Level:>25

Type:Error


FRM-41818

FRM-41818: Toolkit failed to create timer %s :may be out of memory.

Cause:An internal error occurred while attempting to create a timer, possibly as a result of memory constraints.

Action:Check and adjust memory quotas as necessary.

Level:>25

Type:Error


FRM-41819

FRM-41819: Timers are not supported on this platform.

Cause:Illegal attempt to create a timer on a platform where timers are not supported.

Action:None. A timer option is unavailable on your platform.

Level:>25

Type:Error


FRM-41820

FRM-41820: Toolkit failed to delete timer: %s.

Cause:Internal error caused by timer failure.

Action:Contact customer support.

Level:>25

Type:Error


FRM-41821

FRM-41821: Timer name too long: %s...

Cause:You attempted to create a timer with a name longer than 30 bytes.

Action:Retry with a shorter name.

Level:>25

Type:Error


FRM-41822

FRM-41822: Timer name may not be null string.

Cause:You attempted to create a timer with a null name.

Action:Retry with a non-null name.

Level:>25

Type:Error


FRM-41823

FRM-41823: Illegal timer interval for timer %s.

Cause:You attempted to create a timer with an interval less than 1 millisecond.

Action:Recreate your timer with an interval of at least 1 millisecond.

Level:>25

Type:Error


FRM-41824

FRM-41824: Date/time operation failed for %s.

Cause:An internal error occurred while attempting to resolve a date/time initial value for an item.

Action:Contact customer support.

Level:10

Type:Error


FRM-41826

FRM-41826: Cannot replace group; columns don't match LOV.

Cause:Cannot replace the list of values' current record group with a record group that is incompatible with the LOV column structure.

Action:Do not attempt to assign this record group to this LOV.

Level:>25

Type:Error


FRM-41827

FRM-41827: Group does not exist.

Cause:The group name or ID specified is invalid.

Action:Check the name or ID entered and try again.

Level:>25

Type:Error


FRM-41828

FRM-41828: LOV does not exist.

Cause:LOV name or ID specified is invalid.

Action:Check the name or ID entered and try again.

Level:>25

Type:Error


FRM-41829

FRM-41829: Record not created.

Cause:Application design error. The record failed to get its initial value.

Action:Contact the application designer.

Level:>25

Type:Error


FRM-41830

FRM-41830: List of Values contains no entries.

Cause:The record group underlying the LOV contains no records.

Action:Check to be sure that any criteria used to reduce a long list LOV did not eliminate all matches.

Level:>5

Type:Error


FRM-41832

FRM-41832: Error: program unit %s in library %s is uncompiled.

Cause:You called an uncompiled program unit from a library.

Action:Follow the PL/SQL program error.

Level:99

Type:Error


FRM-41833

FRM-41833: Warning! Program unit %s in library %s is uncompiled.

Cause:You called an uncompiled program unit in a library when debug mode was specified.

Action:This is just a warning. Forms Runtime will attempt to compile and run the program unit.

Level:99

Type:Informative


FRM-41834

FRM-41834: Error: Unable to create PECS class %s.

Cause:Unable to create the PECS data file.

Action:Check the PECS appendix for the location of the PECS data files. Check to be sure you have the appropriate privileges on this file, and that the path environment variable is set to a valid path.

Level:99

Type:Informative


FRM-41835

FRM-41835: Canvas %s is not a tab canvas.

Cause:You tried to perform a tab canvas specific operation on a canvas which is not a tab canvas.

Action:Make sure the canvas specified is a tab canvas.

Level:99

Type:Error


FRM-41836

FRM-41836: No tab page %s in canvas %s.

Cause:You tried to perform an operation on a tab page which does not exist in the specified canvas.

Action:Make sure you specify a tab page which exists in the specified tab canvas.

Level:99

Type:Error


FRM-41837

FRM-41837: Error raising tab page %s.

Cause:The specified tab page could not be brought to the top (made the current page of the tab canvas).

Action:Make sure the specified page is enabled, and not hidden.

Level:99

Type:Error


FRM-41838

FRM-41838: Unable to open temporary record buffer file %s.

Cause:Unable to open file used as temporary record buffer.

Action:Verify that the file system or directory in which the file resides exists and that you have permissions to read and write to it.

Level:99

Type:Error


FRM-41839

FRM-41839: Disk I/O error on temporary record buffer file %s

Cause:An I/O error occurred on attempting to read or write a record to the temporary record buffer file.

Action:Verify that the file system or directory in which the file resides exists, and that you have permissions to read and write to it, and that it contains sufficient space.

Level:99

Type:Error


FRM-41840

FRM-41840: Insufficient main memory for record buffers

Cause:Unable to allocate memory for a record being created in a block.

Action:Try restarting application when fewer programs are running concurrently, or on a machine with more memory. The design may need to be changed so that one or more blocks have smaller values for the Records Buffered property.

Level:99

Type:Error


FRM-41841

FRM-41841: Use the debugger-enabled executable if specifying DEBUG=YES.

Cause:You tried to use the debugger from an executable which doesn't include it.

Action:Run the other executable (name will vary with operating system), which includes the debugger.

Level:99

Type:Error


FRM-41900

FRM-41900: Run aborted by fatal error.

Cause:Fatal error caused form to abort.

Action:Contact your DBA.

Level:20

Type:Error


FRM-41901

FRM-41901: Error: %d cursors were not closed.

Cause:Internal error.

Action:Contact your DBA.

Level:>25

Type:Error


FRM-41902

FRM-41902: Total cursors used %d.

Cause:This message appears when you run a form with the Statistics preference set to True.

Action:No action is necessary.

Level:>25

Type:Informative


FRM-41903

FRM-41903: Run aborted by end of input file.

Cause:Internal error.

Action:Contact an Oracle support representative.

Level:>25

Type:Error


FRM-42015

FRM-42015: Must specify key file in non-interactive mode.

Cause:You tried to run the form in non-interactive mode without specifying the name of a key input file at form startup.

Action:Specify the name of the key file.

Level:>25

Type:Error


FRM-42016

FRM-42016: Read and write files may not have the same name.

Cause:You attempted to specify the same name for a read and a write file.

Action:Specify different names for the two files.

Level:>25

Type:Error


FRM-42017

FRM-42017: Module name must be specified.

Cause:You did not specify a module name.

Action:Specify a module name.

Level:>25

Type:Error


FRM-42100

FRM-42100: No errors encountered recently.

Cause:You pressed [Display Error], but no error has occurred recently.

Action:No action is necessary.

Level:5

Type:Informative


FRM-42400

FRM-42400: Performing event trigger %s.

Cause:This message is displayed during a trigger when debug mode is specified.

Action:No action is necessary.

Level:>25

Type:Informative


FRM-42401

FRM-42401: Performing program trigger %s.

Cause:This message is displayed during a trigger when debug mode is specified.

Action:No action is necessary.

Level:>25

Type:Informative


FRM-42423

FRM-42423: Cannot execute trigger %s: no compiled state

Cause:This message is displayed when running a form in debug mode, if the compiled state of a trigger has been destroyed. This can happen if you apply a change to the trigger text and that change results in compilation errors.

Action:You can recompile the trigger in the debugger or exit the form and start it up again.

Level:99

Type:Error


FRM-47000

FRM-47000: Cannot create Parameter List %s : internal error.

Cause:Internal error.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47001

FRM-47001: Cannot create Parameter List %s : list with this name exists.

Cause:The name you specified for the parameter list is already in use.

Action:Specify another name for the parameter list.

Level:99

Type:Error


FRM-47002

FRM-47002: Cannot create Parameter List : name must not be null.

Cause:The parameter list name cannot be null.

Action:Specify a name for the parameter list.


FRM-47003

FRM-47003: Cannot delete Parameter List : internal error.

Cause:Internal error.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47004

FRM-47004: Cannot delete Parameter List : invalid ID.

Cause:Attempted to pass an invalid parameter list ID.

Action:Check the list ID name and try again.

Level:99

Type:Error


FRM-47005

FRM-47005: Cannot validate parameter %s : internal error.

Cause:Internal error.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47006

FRM-47006: Cannot create Parameter List '%s' : illegal identifier name.

Cause:Illegal identifier name.

Action:Check valid syntax for the identifier.

Level:99

Type:Error


FRM-47007

FRM-47007: Cannot get parameter %s attributes from Parameter List : invalid list ID.

Cause:Specified an invalid parameter list ID.

Action:Check the parameter list ID name and try again.

Level:99

Type:Error


FRM-47008

FRM-47008: Cannot add parameter %s to Parameter List %s : internal error.

Cause:An internal error occurred.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47009

FRM-47009: Cannot add parameter %s to Parameter List : invalid list ID.

Cause:You specified an invalid parameter list ID.

Action:Check the parameter list ID name and try again.

Level:99

Type:Error


FRM-47010

FRM-47010: Cannot add parameter to Parameter List %s : null key specified.

Cause:No name specified for the parameter.

Action:Specify a parameter name <key> in your call to ADD_PARAMETER.

Level:99

Type:Error


FRM-47011

FRM-47011: Cannot add parameter %s to Parameter List %s : incorrect type specified.

Cause:You specified an invalid parameter type.

Action:Specify either TEXT_PARAMETER or DATA_PARAMETER.

Level:99

Type:Error


FRM-47012

FRM-47012: Cannot add parameter %s to Parameter List %s : group %s does not exist.

Cause:Record group name does not exist.

Action:Check the record group name and try again.

Level:99

Type:Error


FRM-47013

FRM-47013: Cannot add parameter %s to Parameter List %s : parameter with this name exists.

Cause:Parameter with this name already exists.

Action:Specify another name for the parameter.

Level:99

Type:Error


FRM-47014

FRM-47014: Cannot delete parameter %s from Parameter List %s : internal error.

Cause:Internal error.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47015

FRM-47015: Cannot delete parameter %s from Parameter List : invalid list ID.

Cause:Specified an invalid parameter list ID.

Action:Check the list ID name and try again.

Level:99

Type:Error


FRM-47016

FRM-47016: Cannot delete parameter from Parameter List %s : null key specified.

Cause:You did not specify a name for the parameter.

Action:Correct the call to DELETE_PARAMETER by supplying a parameter name.

Level:99

Type:Error


FRM-47017

FRM-47017: Cannot delete parameter %s from Parameter List %s : no such named parameter exists.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a parameter name that does not exist.

Action:Check the parameter name and try again.

Level:99

Type:Error


FRM-47018

FRM-47018: Cannot set parameter %s attributes in Parameter List %s : internal error.

Cause:Internal error: you specified an invalid parameter list ID.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47019

FRM-47019: Cannot set parameter %s attributes in Parameter List : invalid list ID.

Cause:You specified an invalid parameter list ID.

Action:Check the parameter list ID name and try again.

Level:99

Type:Error


FRM-47020

FRM-47020: Cannot set parameter %s attributes in Parameter List %s : no such named parameter exists.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a parameter name that does not exist.

Action:Check the parameter name and try again.

Level:99

Type:Error


FRM-47021

FRM-47021: No such parameter named %s exists in Parameter List %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a parameter name that does not exist.

Action:Check the name and try again.

Level:99

Type:Error


FRM-47022

FRM-47022: Cannot create Parameter List %s : name is a reserved word.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a name that is a reserved word.

Action:Specify another name for the parameter list.

Level:99

Type:Error


FRM-47024

FRM-47024: Parameter %s type does not match definition in form %s.

Cause:You specified a parameter type that does not match the definition in the form.

Action:Specify a parameter type that matches the definition in the form.

Level:99

Type:Error


FRM-47025

FRM-47025: Cannot get parameter %s attributes from Parameter List %s : internal error.

Cause:Internal error: you specified an invalid parameter list ID.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47026

FRM-47026: Cannot get parameter %s attributes from Parameter List %s : no such named parameter exists.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a parameter name does not exist.

Action:Check the name and try again.

Level:99

Type:Error


FRM-47027

FRM-47027: Cannot add parameter %s to Parameter List %s : invalid key specified .

Cause:You specified an invalid parameter list ID.

Action:Check the name and try again.

Level:99

Type:Error


FRM-47028

FRM-47028: Cannot set parameter %s attribute in Parameter List %s : group %s does not exist.

Cause:You specified an invalid parameter list ID.

Action:Check the name and try again.

Level:99

Type:Error


FRM-47029

FRM-47029: Invalid parameter list ID in form %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a parameter name does not exist.

Action:Check the ID and try again.

Level:99

Type:Error


FRM-47030

FRM-47030: Value of parameter %s is too long for definition in form %s.

Cause:You specified a parameter that is too long.

Action:Specify a parameter that is valid.

Level:99

Type:Error


FRM-47031

FRM-47031: Cannot set value of parameter %s in DEFAULT parameter list: invalid value specified.

Cause:Application design error. A built-in (such as SET_PARAMETER_ATTR) is attempting to set the value of a parameter which was defined when the form was designed, but the value specified is not legal for the parameter's datatype.

Action:The call to the built-in must be modified or removed.

Level:99

Type:Error


FRM-47032

FRM-47032: Cannot set value of parameter %s in DEFAULT parameter list: internal error.

Cause:An internal error while attempting to set the value of a parameter.

Action:Contact an Oracle support representative.

Level:99

Type:Error


FRM-47033

FRM-47033: Cannot set value of read-only bind variable %s.

Cause:Application design error. The application attempted to assign a value to a bind variable which cannot be programmtically modified.

Action:The assignment must be removed.

Level:99

Type:Error


FRM-47100

FRM-47100: Cannot read image file %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. Form Builder was unable to find or open the file.

3. The data in the file is not in the specified format.

Action:Check the file name and file format and try again.

Level:99

Type:Error


FRM-47101

FRM-47101: Cannot write image file %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. Form Builder was unable to find or open the file.

3. The data in the file is not in the specified format.

Action:Check the file name, and make sure you have write privileges.

Level:99

Type:Error


FRM-47102

FRM-47102: Cannot perform %s operation on images %s and %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. This operation cannot be performed on color images.

Action:Check to see that both images are black and white.

Level:99

Type:Error


FRM-47103

FRM-47103: Cannot zoom image %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. Internal multimedia error caused by trying to scale a null image or invalid image data.

Action:Check the image name that you want to zoom and try again.

Level:99

Type:Error


FRM-47104

FRM-47104: Invalid image type %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. Data in the file name specified does not match the data type specified.

Action:Check the file name and try again.

Level:99

Type:Error


FRM-47105

FRM-47105: No image name specified.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You did not supply a name to the built-in call.

Action:Refer to the documentation for the proper syntax for the built-in in question.

Level:99

Type:Error


FRM-47106

FRM-47106: No image type specified.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You did not specify an image type when calling READ_IMAGE_FILE or WRITE_IMAGE_FILE.

Action:Supply an image type as an argument in your call to READ_IMAGE_FILE or WRITE_IMAGE_FILE.

Level:99

Type:Error


FRM-47107

FRM-47107: Invalid scaling factor %d for Image_Zoom.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified an invalid scaling factor.

Action:Correct the call to IMAGE_ZOOM.

Level:20

Type:Error


FRM-47108

FRM-47108: Item %s is not an image item.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You attempted to perform an image operation on an item that is not an image item.

Action:Check the item name and try again.

Level:99

Type:Error


FRM-47109

FRM-47109: Cannot locate image file %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a file that cannot be found or does not exist.

Action:Verify that the file exists and the pathname is correct.

Level:20

Type:Error


FRM-47110

FRM-47110: No region was selected for Image_Zoom: %s

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You tried to zoom an image without selecting an image region.

Action:Select an image region.

Level:20

Type:Error


FRM-47111

FRM-47111: Cannot copy value to item: %s

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You tried to use the COPY built-in on an image item.

Action:You cannot use the COPY built-in on an image item.

Level:20

Type:Error


FRM-47200

FRM-47200: Item %s is not a sound item.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You attempted to perform a sound operation on an item that is not a sound item.

Action:Check the item name and try again.

Level:99

Type:Error


FRM-47201

FRM-47201: Cannot play sound %s.

Cause:Unable to play the sound in the requested sound item. The sound output device may be busy.

Action:Stop other programs directing output to the sound device and try again.

Level:99

Type:Error


FRM-47202

FRM-47202: No sound file name specified.

Cause:You did not supply a file name to the built-in call.

Action:Refer to the documentation for the proper syntax for the built-in in question.

Level:99

Type:Error


FRM-47203

FRM-47203: Cannot locate sound file %s.

Cause:Form Builder was unable to find the file specified in READ_SOUND_FILE.

Action:Check the file name and try again.

Level:99

Type:Error


FRM-47204

FRM-47204: Cannot read sound file %s.

Cause:Form Builder was unable to read the sound file, typically because the file type specified did not match the file contents.

Action:Verify the contents of the sound file.

Level:99

Type:Error


FRM-47205

FRM-47205: No sound type specified.

Cause:You did not specify a sound type when calling WRITE_SOUND_FILE.

Action:Supply a sound type as an argument in your call to WRITE_SOUND_FILE.

Level:99

Type:Error


FRM-47206

FRM-47206: Cannot write sound file %s.

Cause:Form Builder was unable to create the sound file. The sound data may have been corrupted.

Action:Contact your Oracle support representative.

Level:99

Type:Error


FRM-47207

FRM-47207: In this release, Play_Sound can only be run against the current item.

Cause:PLAY_SOUND was invoked against other than the current item.

Action:Place the input focus in the sound item before calling PLAY_SOUND.

Level:99

Type:Error


FRM-47208

FRM-47208: Cannot create an empty sound file. (%s)

Cause:WRITE_SOUND_FILE was invoked against a sound item containing no sound data.

Action:Load sound data into the sound item before calling WRITE_SOUND_FILE.

Level:99

Type:Error


FRM-50001

FRM-50001: Acceptable characters are a-z, A-Z, and space.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an unacceptable character into the item.

Action:Enter a character from a-z, A-Z, or a space.

Level:15

Type:Error


FRM-50002

FRM-50002: Month must be between 1 and 12.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid month value in a date field.

Action:Enter a month value from 1 (for January) to 12 (for December).

Level:15

Type:Error


FRM-50003

FRM-50003: Year must be 00-99 or 1000-4712.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid year.

Action:Enter a valid year. The year may be a number between 0 and 99 (representing the years 1900 to 1999) or between 1000 and 4712.

Level:15

Type:Error


FRM-50006

FRM-50006: Legal characters are 0-9 + and -.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an unacceptable character in a number item.

Action:Enter a valid number. A valid number has digits 0 through 9. A number may be preceded by a plus (+) or minus (-) sign. If the message allows it, a number may contain one decimal point at any location, except before the sign.

Level:15

Type:Error


FRM-50007

FRM-50007: Too many digits after decimal point.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered a number with 3 or more decimal digits after the decimal point in an item with the MONEY or RMONEY data type.

Action:Re-enter a valid number.

Level:15

Type:Error


FRM-50009

FRM-50009: Too many decimal points.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered a number that contains two or more decimal points, or you have entered a number that contains a decimal point in an item that requires a whole (non-decimal) number.

Action:Enter a number with no more than one decimal point. If you have used only one decimal, remove the decimal and the decimal part of the number.

Level:15

Type:Error


FRM-50010

FRM-50010: Money format is [+-]9999999.99

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid value in a MONEY or RMONEY item.

Action:Enter a valid value. This value should have zero or dollar digits, followed by a decimal and two cents digits. The entire number can be preceded by a plus (+) or a minus (-) sign.

Level:15

Type:Error


FRM-50011

FRM-50011: Not a valid month name.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid month name in a date field.

Action:Enter a valid month name. Form Builder recognizes the first three characters of a month name. For example, JAN stands for January, JUN for June.

Level:15

Type:Error


FRM-50012

FRM-50012: Date format is %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid date.

Action:Re-enter the date in the requested format. In the format shown above, July 7, 1989 would be 07-JUL-89.

Level:15

Type:Error


FRM-50013

FRM-50013: Plus or minus must be in first position.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered the plus or minus sign in the wrong position.

Action:Retype with the plus or minus sign in the first position.

Level:15

Type:Error


FRM-50014

FRM-50014: Bad exponent.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an exponent in an item that does not accept exponents.

Action:Enter a value without an exponent.

Level:15

Type:Error


FRM-50016

FRM-50016: Legal characters are 0-9 - + E .

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an unacceptable character in a number item.

Action:Enter a valid number. A valid number has digits 0 through 9. A number may be preceded by a plus (+) or minus (-) sign. If the message allows it, a number may contain one decimal point at any location, except before the sign. You can use an E to specify scientific notation.

Level:15

Type:Error


FRM-50017

FRM-50017: Hour must be between 0 and 23.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid hour.

Action:Enter a valid hour. Form Builder records time on a 24-hour basis.

Level:15

Type:Error


FRM-50018

FRM-50018: Minutes must be between 00 and 59.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid minute value.

Action:Enter a valid minute value.

Level:15

Type:Error


FRM-50019

FRM-50019: Seconds must be between 00 and 59.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid value.

Action:Enter a value between 00 and 59.

Level:15

Type:Error


FRM-50021

FRM-50021: Date format is %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid date or an incorrectly formatted date.

Action:Re-enter the date in the requested format. In the format shown above, July 20, 1986, would be 07/20/86.

Level:15

Type:Error


FRM-50022

FRM-50022: Time format is %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid time format.

Action:Re-enter the time in the requested format. For example, 3:00 p.m. is 15:00:00 (or 15:00).

Level:15

Type:Error


FRM-50023

FRM-50023: Date format is %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid date.

Action:Re-enter the date in the requested format. In the format shown above, July 20, 1986, would be 20/07/86.

Level:15

Type:Error


FRM-50024

FRM-50024: Space are allowed in leading positions only.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered spaces intermixed with data.

Action:Re-enter data with no spaces intermixed.

Level:15

Type:Error


FRM-50025

FRM-50025: Datetime format is %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid date.

Action:Re-enter the date and time in the requested format. In the format shown above, 3:00 p.m. on April 13, 1994, would be 13-APR-1994 15:00:00.

Level:15

Type:Error


FRM-50026

FRM-50026: Date format is %s.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You entered an invalid date.

Action:Re-enter the date in the requested format. In the format shown above, April 13, 1989, would be 13-APR-1989.

Level:15

Type:Error


FRM-50027

FRM-50027: Invalid format mask for given datatype.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. The format mask you assigned to a text item is incompatible with the data type of the text item.

Action:Assign a new format mask to the text item. For more information, refer to help on item format masks .

Level:15

Type:Error


FRM-50028

FRM-50028: Format mask not allowed for this datatype.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. The data types LONG, IMAGE, and GRAPHICS do not support a format mask.

Action:Do not try to create a format mask for data types LONG, IMAGE, or GRAPHICS.

Level:15

Type:Error


FRM-50029

FRM-50029: Too many digits preceding decimal point for scientific notation.

Cause:Caused by one of the following:

1. You specified an invalid parameter list ID.

2. You specified a number using scientific notation, but used more than one digit preceding the decimal point.

Action:Re-enter the number using scientific notation.

Level:15

Type:Error


FRM-90925

FRM-90925: Too many arguments on command line.

Cause:Too many arguments were specified on the command line.

Action:Retype your commands and try again.


FRM-90926

FRM-90926: Duplicate parameter on command line.

Cause:Two identical parameters were typed on the command line.

Action:Correct the command you typed and try again.


FRM-90927

FRM-90927: Unknown parameter on command line.

Cause:You specified an unknown parameter on the command line.

Action:Check the command line and edit as necessary.


FRM-90928

FRM-90928: Positional parameter after key on command line.

Cause:The parameters are not in the proper order on the command line, there is a missing parameter, or a missing '=' sign .

Action:Correct the command line as necessary and try again.


FRM-90929

FRM-90929: Invalid value for parameter on command line.

Cause:You specified an invalid parameter value on the command line.

Action:Check the command line and edit as necessary.


FRM-90930

FRM-90930: Invalid file parameter on command line.

Cause:You specified an invalid file parameter on the command line.

Action:Check the command line and edit as necessary.


FRM-90931

FRM-90931: Error processing command line.

Cause:Internal error.

Action:Contact your Oracle support representative.


FRM-90932

FRM-90932: Invalid list value on command line.

Cause:List value specified is invalid.

Action:Specify the correct value and try again.


FRM-90933

FRM-90933: Illegal list value on command line.

Cause:Illegal list value specified on the command line.

Action:Check the command line and try again.


FRM-91010

FRM-91010: Module_Access parameter must be FILE or DATABASE.

Cause:The parameter specified for Module_Access was not FILE or DATABASE.

Action:Specify FILE or DATABASE for the Module_Access parameter.


FRM-91017

FRM-91017: Module_Type parameter must be FORM, MENU or LIBRARY.

Cause:The parameter specified for Module_Type was not FORM, MENU or LIBRARY.

Action:Specify FORM, MENU or LIBRARY for the Module_Type parameter.


FRM-91100

FRM-91100: Internal Error: unable to create Common context.

Cause:Internal error.

Action:Contact your Oracle support representative.


FRM-91101

FRM-91101: Internal Error: unable to create Foundation context.

Cause:Internal error.

Action:Contact your Oracle support representative.


FRM-91102

FRM-91102: Internal Error: unable to tokenize command line.

Cause:Internal error.

Action:Contact your Oracle support representative.


FRM-91103

FRM-91103: Internal Error: out of memory.

Cause:Internal error.

Action:Contact your DBA or an Oracle support representative.


FRM-91108

FRM-91108: Internal Error: unable to initialize PL/SQL.

Cause:Internal error.

Action:Contact your Oracle support representative.


FRM-91109

FRM-91109: Internal Error: application startup failure.

Cause:Unable to start window system.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91110

FRM-91110: Internal Error: cannot find file name: %s.

Cause:Unable to find resource files.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91111

FRM-91111: Internal Error: window system startup failure.

Cause:You are in character mode and trying to run Form Builder on a window system.

Action:Run the correct executable.

Level:15

Type:Error


FRM-91112

FRM-91112: Internal Error: resource manager startup failure.

Cause:Unable to find resource files.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91113

FRM-91113: Internal Error: cannot get default resource file name.

Cause:Unable to find resource files.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91115

FRM-91115: Internal Error: bind table failure.

Cause:Unable to find key mappings.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91116

FRM-91116: Internal Error: Oracle*Image startup failure.

Cause:Unable to find resource files.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91117

FRM-91117: Internal Error: font metric initialization failure.

Cause:Unable to find resource files.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91118

FRM-91118: Internal Error: root window initialization failure.

Cause:Unable to find root window.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91119

FRM-91119: Internal Error: Oracle*VGS startup failure.

Cause:Unable to start VGS context.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91120

FRM-91120: Internal Error: Unable to load NLS character set.

Cause:Unable to load the specified NLS character set.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91121

FRM-91121: Internal Error: Unable to start up cue card viewer.

Cause:Unable to start the Cue Card Viewer.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91122

FRM-91122: Internal Error: Unable to create string context.

Cause:Unable to start the String Context.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91123

FRM-91123: Internal Error: Unable to start up quark manager.

Cause:Unable to start the Quark Manager.

Action:Contact an Oracle support representative.

Level:15

Type:Error


FRM-91124

FRM-91124: Warning: %s specified for ORAFORMS_DECIMAL_PREFIX. Should be 0 (zero) or ' ' (the empty string).

Cause:An invalid value was specified for the environment variable ORAFORMS_DECIMAL_PREFIX.

Action:Do one of the following:

1. Specify ORAFORMS_DECIMAL_PREFIX as 0 to force a zero before a leading decimal point in any number displayed without a format mask in the application.

2. Specify ORAFORMS_DECIMAL_PREFIX as ' ' (the empty string).

3. Do not specify a variable value.


FRM-91500

FRM-91500: Unable to start/complete the build.

Cause:Unable to find resource files.

Action:Contact your Oracle support representative.


IMP-00000

IMP-00000import terminated unsuccessfully

Cause:Import encountered an Oracle error.

Action:Look up the accompanying Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


IMP-00001

IMP-00001respond with either "Y", "N", "RETURN" or "." to quit

Cause:An invalid response was entered.

Action:Enter any of the responses shown in the message.


IMP-00002

IMP-00002failed to open name for read

Cause:Import failed to open the export file for reading. This message is usually followed by a device message from the operating system.

Action:Take appropriate action to restore the device.


IMP-00003

IMP-00003Oracle message code num encountered

Cause:Import encountered the referenced Oracle error.

Action:Look up the Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


IMP-00004

IMP-00004invalid username or password

Cause:An invalid username or password was specified.

Action:Retry with a valid username and password.


IMP-00005

IMP-00005all allowable logon attempts failed

Cause:An attempt was repeatedly made to log on with an invalid usernameor password.

Action:Retry with valid username and password.


IMP-00006

IMP-00006failed to allocate memory of size num

Cause:Import failed to allocate the necessary memory.

Action:Decrease the import buffer size so that less memory is required, or increase the runtime memory size for Import.


IMP-00007

IMP-00007must be a DBA to import objects to another user's account

Cause:The privileges needed to import into another user's account do not exist. Only a database administrator can import into another user's account.

Action:Ask the database administrator to do the import.


IMP-00008

IMP-00008unrecognized statement in the export file: str

Cause:Import did not recognize a statement in the export file. Either the export file was corrupted, or an Import internal error has occurred.

Action:If the export file was corrupted, retry with a new export file. Otherwise, report this as an Import internal error to customer support.


IMP-00009

IMP-00009abnormal end of export file

Cause:The export file is probably from an aborted Export session.

Action:If so, retry the export and import. Otherwise, report this as an Import bug and submit the export file that caused this error to customer support.


IMP-00010

IMP-00010not a valid export file, header failed verification

Cause:Either the file was not generated by Export or it was corrupted.

Action:If the file was indeed generated by Export, report this an Import bug and submit the export file to customer support.


IMP-00011

IMP-00011formatted table data not currently supported

Cause:You tried to import an export file that contains formatted table data. Import only supports export files containing binary table data.

Action:Retry using an export file that contains only binary table data.


IMP-00012

IMP-00012invalid export mode num in header

Cause:The Export mode specified in the export file header is invalid.

Action:Check the export file to see if it was corrupted. If it was not, report this as an Import bug and submit the export file to customer support.


IMP-00013

IMP-00013only a DBA can import a file exported by another DBA

Cause:The privileges needed to Import an export file generated by a database administrator do not exist. Only a database administrator can import such files.

Action:Ask the database administrator to do the import.


IMP-00014

IMP-00014insufficient Oracle privileges to do import

Cause:The privileges needed to do an import do not exist. A minimum of CONNECT privilege is required to do an import.

Action:Ask the database administrator to grant the necessary privileges.


IMP-00015

IMP-00015following statement failed because the object already exists: str

Cause:Import failed to create an object because it already exists.

Action:Specify IGNORE=Y to ignore such errors and import rows even when tables are not created because they already exist.


IMP-00016

IMP-00016required character set conversion (type num to num) not supported

Cause:Import could not convert the character format of the export file into the native character format.

Action:Change the user character set by setting the NLS_LANG environment variable to match the character set of the export file.


IMP-00017

IMP-00017following statement failed with Oracle message num: str

Cause:Import failed to execute the statement from the export file because of anOracle error.

Action:Look up the accompanying Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


IMP-00018

IMP-00018partial import of previous table complete: num rows imported

Cause:A table was only partially imported because of an Oracle error.

Action:Look up the accompanying Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


IMP-00019

IMP-00019row rejected due to Oracle message code num

Cause:Import encountered the referenced Oracle error while trying to import a row.

Action:Look up the accompanying Oracle message and take appropriate action. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


IMP-00020

IMP-00020long column too large for column buffer size num

Cause:The column buffer is too small. This usually occurs when importingLONG data.

Action:Increase the insert buffer size 10,000 bytes at a time (for example) up to 66,000 or greater. Use this step-by-step approach because a buffer size that is too large may cause a similar problem.


IMP-00021

IMP-00021operating system error - error code (dec num, hex 0xnum)

Cause:An operating system error has occurred.

Action:Look up the referenced message in your operating system-specific Oracle documentation and take appropriate action.


IMP-00022

IMP-00022failed to process parameters, type "IMP HELP=Y" for help

Cause:Invalid command-line parameters were specified.

Action:Check the online help screen for the set of valid parameters, then retry.


IMP-00023

IMP-00023import views not installed, please notify your DBA

Cause:The necessary Import views were not installed.

Action:Ask your database administrator to install the required Import views.


IMP-00024

IMP-00024full import mode, cannot specify FROMUSER or TABLES parameter

Cause:Parameters were specified that conflict with the import specification FULL=Y.

Action:Retry, making sure not to specify FULL=Y.


IMP-00025

IMP-00025for DBA export files, FROMUSER must be specified with TOUSER

Cause:When importing a database administrator export file, you specified the TOUSER parameter but not the FROMUSER parameter.

Action:Specify the FROMUSER parameter so that Import knows which user's objects to import.


IMP-00027

IMP-00027failed to roll back partial import of previous table

Cause:Import encountered an Oracle error while trying to roll back a partial import.

Action:Look up the accompanying Oracle message and take appropriate action. Then, log on to Oracle and check that the partial import was not committed.

(To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


IMP-00028

IMP-00028partial import of previous table rolled back: num rows rolled back

Cause:Import encountered an Oracle error while trying to import a table.

Action:Look up the accompanying Oracle message and take appropriate action. Then, if necessary, re-import the table.

(To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


IMP-00029

IMP-00029cannot qualify table name by owner name.name, use FROMUSER parameter

Cause:A table name was qualified with the name of its owner, as shown in the following example. This is not allowed.

IMP SYSTEM/MANAGER TABLES=(SCOTT.EMP,SCOTT.DEPT)

Action:Use the FROMUSER parameter to specify the table's owner, as shown in the following example:

IMP SYSTEM/MANAGER FROM USER=SCOTT TABLES=(EMP,DEPT)


IMP-00030

IMP-00030failed to create file name for write

Cause:Import was unable to create the specified file with write enabled.

Action:Check the file name and file system for the source of the error.


IMP-00032

IMP-00032SQL statement exceeded buffer length

Cause:The buffer was too small for the SQL statement being read.

Action:Rerun with a larger buffer. This can also be an indication of a corruption in the import datafile


IMP-00033

IMP-00033warning: Table name not found in export file

Cause:A table name was specified that does not exist in export file.

Action:Correct the table specification.


IMP-00034

IMP-00034warning: FROMUSER name not found in export file

Cause:The user specified a FROMUSER name that does not exist in export file.

Action:Correct the FROMUSER specification.


IMP-00035

IMP-00035warning: TOUSER name not found in export file

Cause:The user specified a TOUSER name that does not exist in export file.

Action:Correct the TOUSER specification.


IMP-00036

IMP-00036could not find environment character set

Cause:An environment character set was specified that was not recognized by the Import utility.

Action:Ensure that the spelling of the character set specified in the command line parameter CHARSET or the environment variable NLS_LANG is correct.


IMP-00037

IMP-00037character set marker unknown

Cause:The export file is corrupted.

Action:Try to obtain an uncorrupted version of the export file.


IMP-00038

IMP-00038could not find environment character set handle

Cause:An environment character set handle was specified that was not recognized by the Import utility.

Action:Ensure that the spelling of the environment character set handle is correct.


IMP-00039

IMP-00039no space for owner name in create string

Cause:The string is corrupted.

Action:Try to obtain an uncorrupted version of the export file.


IMP-00040

IMP-00040warning: Statement not executed due to invalid session label

Cause:An ALTER SESSION SET LABEL statement in the export file failed because it specified an invalid label. This caused all subsequent CREATE statements until the next valid ALTER SESSION SET LABEL statement to fail. These failed CREATE statements also generate this warning.

Action:If the invalid label on the ALTER SESSION SET LABEL statement should be valid, define the label within the operating system and re-execute the import. It would be desirable to have an invalid label be valid if an export file is being imported from a Trusted Oracle7 database on a different operating system (one that supports different labels).

If the invalid label must remain invalid, replace it with a valid label in the export file and re-execute the import.


IMP-00041

IMP-00041warning: object created with compilation warnings

Cause:The object in the SQL statement following this error was created with compilation errors. If this error occurred for a view, it is possible that the base table of the view was missing.

Action:This is a warning. The object may have to be recompiled before being used.


IMP-00042

IMP-00042CHARSET used, but the export file has specific character set

Cause:The user requested that a specific character set be used to process an export file that has a specific embedded character set ID. The ID in the export file is accurate and should be used.

Action:Remove the CHARSET keyword from the command line.


IMP-00043

IMP-00043export file character set inconsistent

Cause:The character set of the export file and the environment character set (or the character set specified with the CHARSET keyword) are inconsistent. One character set is ASCII-based while the other is EBCDIC based.

Action:Specify the correct character set with the CHARSET keyword.


IMP-00044

IMP-00044unable to allocate enough memory for statement

Cause:Import was unable to allocate sufficient memory to read in the specified statement and execute it.

Action:Increase the allocation for database buffers, restart the instance, and reexecute the Import command.


IMP-00045

IMP-00045unexpected character found on line num in mapfile

Cause:There was a syntax error while processing the mapfile. This message is generated only for Trusted Oracle7.

Action:Examine the specified line and correct the error.


IMP-00046

IMP-00046must specify MLS_MAPFILE with MLS_LISTLABELS

Cause:A map file for output of the list labels option was not specified. This message is generated only for Trusted Oracle7.

Action:Specify a map file using the MLS_MAPFILE option.


IMP-00047

IMP-00047label string larger than 255 characters found at line num in mapfile

Cause:A label string was specified in your mapfile that was too large. This message is generated only for Trusted Oracle7.

Action:Shorten label string to less than 255 characters.


IMP-00048

IMP-00048the MLS_LISTLABELS option cannot be used with this export file

Cause:An attempt was made to list the labels on an export file earlier than Release 7.1. This message is generated only for Trusted Oracle7.

Action:Only use the MLS_LISTLABELS option for a Release 7.1 or later export file.


IMP-00049

IMP-00049unknown language specified in CHARSET

Cause:An unknown language was listed in the CHARSET option. This message is generated only for Trusted Oracle7.

Action:Use a known character set.


IMP-00055

IMP-00055warning: partition name.name not found in export file

Cause:A partition name was specified that does not exist in export file.

Action:Check to make sure the partition name belongs to the table.


IMP-00056

IMP-00056warning: Table name given is not a partitioned table

Cause:The specified table is not a partitioned table.

Action:Retry the operation using a partitioned table.


IMP-00057

IMP-00057warning: Dump file may not contain data of all partitions of this table

Cause:The dump file used for this Table Import might not contain all of the data belonging to the exported table.

Action:Check to see if the export was done as intended, or try performing a Partition Import.


IMP-00059

IMP-00059failure to initialize parameter manager

Cause:Parameter manager failed in initialization.

Action:Report this to Oracle Worldwide Support as an Import internal bug.


IMP-00060

IMP-00060warning: Skipping table name.name because object type name.name does not exist or has different identifier

Cause:An object type needed by the table, either does not exist on the target system or, if it does exist, it has a different object identifier.

Action:Create the object type on the target system with a valid identifier.


IMP-00061

IMP-00061warning: Object type name.name already exists with a different identifier

Cause:An object type cannot be created because it already exists on the target system, but with a different identifier.

Action:Drop the object type from the target system and retry the operation.


IMP-00062

IMP-00062warning: The identifier on the dump file for object type name.name is invalid

Cause:The character string representing the object type's identifier could not be converted to an object identifier.

Action:Internal error.


IMP-00063

IMP-00063warning: Skipping table name.name because object type name.name cannot be created or has different identifier

Cause:An error occurred creating an object type that is used by the table.

Action:Examine the import log to determine why the object type could not be created. If the object type already existed, with a different object identifier, then drop the object type and retry the import.


IMP-00064

IMP-00064definition of LOB was truncated by export

Cause:While producing the dump file, Export was unable to write the entire contents of a LOB. Import is therefore unable to reconstruct the contents of the LOB. The remainder of the import of the current table will be skipped.

Action:Delete the offending row in the exported database and retry the export.


IMP-00065

IMP-00065import is unable to recreate LOBs within objects.

Cause:An error occurred recreating a LOB within an imported object.

Action:Report this to Oracle Worldwide Support as an Import internal error.


IMP-00066

IMP-00066missing NLS_CHARACTERSET in props$

Cause:No value for NLS_CHARACTERSET in props$.

Action:Report this to Oracle Worldwide Support as an Import internal error.


IMP-00067

IMP-00067could not convert the server character set's handle

Cause:This is an internal error.

Action:Report this to Oracle Worldwide Support as an Import internal error.


IMP-00068

IMP-00068could not find environment national character set

Cause:An environment national character set was specified that was not recognized by the Import utility.

Action:Ensure that the spelling of the national character set specified in the environment variable NLS_NCHAR is correct.


IMP-00069

IMP-00069could not convert to environment national character set's handle

Cause:This is an internal error.

Action:Report this to Oracle Worldwide Support as an Import internal error.


IMP-00070

IMP-00070LOB definitions in dump file are inconsistent with database

Cause:The number of LOBs per row in the dump file is different than the number of LOBs per row in the table being populated.

Action:Modify the table being imported so that it matches the attribute layout of the table that was exported.


IMP-00071

IMP-00071object identifier of imported table mismatches object identifier of existing table

Cause:An attempt was made to import data into a table that was recreated under a different object identifier than the object identifier used for the exported object table. Under this situation, REF's to this table that are contained within the dump file will also be invalid.

Action:Drop the offending object table prior to import.


IMP-00072

IMP-00072warning: the object table's object identifier is invalid

Cause:The character string representing the table's object identifier could not be converted to an internal object identifier.

Action:Report this to Oracle Worldwide Support as an Import internal error.


IMP-00073

IMP-00073FILE locator name.name is truncated to name.name

Cause:The conversion of the specified directory and name strings for a file attribute or column from the export server's character set into the import server's character set exceeded the maximum string lengths allowed within FILE descriptors. The strings will be truncated to the maximum supported lengths.

Action:Rename the directory aliases and external filenames to match the truncated names in the specified FILE column or attribute.


IMP-00074

IMP-00074the constraints flagged by ALL_CONSTRAINTS.BAD will break in 2000 A.D

Cause:Constraints exist in the database that specify date values without fully specifying the year. These constraints could break in the year 2000 A.D.

Action:Query ALL_CONSTRAINTS and correct those constraints marked as bad.


IMP-00075

IMP-00075warning: the nested table may contain partial rows or duplicate rows

Cause:An error occurred inserting data into an outer or inner nested table. If the error occurred in the outer table, rows are still inserted into the inner tables. If the error occurred in an inner table, data is still inserted into the outer table and other inner tables. This can result in duplicate inner table rows or partial logical rows.

Action:Examine the data in the tables. Delete the incorrect rows or drop the entire table and perform the import again.


IMP-00076

IMP-00076missing NLS_NCHAR_CHARACTERSET in props$

Cause:No value for NLS_NCHAR_CHARACTERSET in props$.

Action:Contact Worldwide support.


IMP-00077

IMP-00077could not convert to server national character set's handle

Cause:Internal error.

Action:Contact Worldwide support.


IMP-00078

IMP-00078cannot translate FILE locator to name.name in server character set

Cause:(1) The current export dump file was generated using Beta-2 of Oracle8.0 AND (2) there was a File that appeared as an attribute of an ADT within a table's column AND (3) the character set of the export server's database was different than the character set of the import server's database AND (4) when the filename or the aliasname of the File increased in size when it was translated to the character set of the import server.

When all of these conditions are true, translation of the strings could yield corruption of the data in the column. Rather than proceeding with the translation, import will leave the character strings in the File in the old character set.

Action:After import completes, rename the directory aliases and external filenames to match the real names used for the target database.


IMP-00079

IMP-00079warning: national character set data in this table may be incorrect

Cause:Due to a problem in 8.0.2 Export, national character data in NCHAR and NVARCHAR2 columns was incorrectly assumed to be in the export server's database character set and was converted to the export client's database character set. This conversion would only be correct if the export server's database character set was the same as the export server's national character set and the export client's database character set was the same as the export client's national character set. All other combinations would likely be incorrect. This export dump file was generated by 8.0.2 Export and the export client and server character sets did not fit that criteria.

Action:Examine the national character data. If incorrect, update the data with correct data.


IMP-00080

IMP-00080error during character conversion of long column or long command

Cause:During piecewise character conversion of the data in a long column or of a long command, a fatal conversion error occurred. Either character truncation occurred or an invalid character set handle was used.

Action:Retry the import with a different character set.


MGR-00101

MGR-00101extraneous text at end of command

Cause:There were unrecognized commands or other text on the command line.

Action:Issue the command without the extraneous text.


MGR-00102

MGR-00102missing LOG keyword

Cause:The LOG keyword was missing from the ARCHIVE LOG command.

Action:Correct the syntax of the command, then issue the command again.


MGR-00103

MGR-00103illegal ARCHIVE LOG option

Cause:An option specified was not LIST, STOP, START, NEXT, ALL, a number, or a filename in the ARCHIVE LOG command.

Action:Correct the syntax of the command, then issue the command again.


MGR-00104

MGR-00104illegal RECOVER option

Cause:You specified an invalid option. Valid options for the RECOVER command are DATABASE, MANUAL, UNTIL, TABLESPACE, or DATAFILE.

Action:Correct the syntax of the command, then issue the command again.


MGR-00105

MGR-00105invalid INSTANCE name

Cause:An invalid SQL*Net service name was specified for the instance name.

Action:Refer to your Oracle platform-specific documentation for a complete description of specifying SQL*Net service names.


MGR-00106

MGR-00106invalid ECHO switch

Cause:An invalid option for the SET ECHO command was specified.

Action:Use either ON or OFF as an option for the SET ECHO command.


MGR-00107

MGR-00107invalid TERMOUT switch

Cause:An invalid option for the SET TERMOUT command was specified.

Action:Use either ON or OFF as an option for the SET TERMOUT command.


MGR-00108

MGR-00108invalid TIMING switch

Cause:An invalid option for the SET TIMING command was specified.

Action:Use either ON or OFF as an option for the SET TIMING command.


MGR-00109

MGR-00109invalid CYCLE value

Cause:An invalid value for the SET CYCLE command was specified.

Action:The SET CYCLE command requires a value between 15 seconds and 99:99 (min:sec), inclusive.


MGR-00110

MGR-00110illegal SET option

Cause:An invalid option for the SET command was specified.

Action:Correct the syntax of the SET command and issue the command again. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00111

MGR-00111illegal SHOW option

Cause:An invalid option for the SHOW command was specified.

Action:Correct the syntax of the SHOW command and issue the command again. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00113

MGR-00113invalid PFILE name

Cause:Server Manager does not recognize the file specified by the PFILE option.

Action:Specify a legal parameter file.


MGR-00114

MGR-00114invalid database name

Cause:The specified database name is not recognized.

Action:Specify a legal database name.


MGR-00115

MGR-00115unexpected end of command

Cause:An option was specified without any arguments.

Action:Correct the syntax of the command and enter the command again with the appropriate arguments for options that require values.


MGR-00116

MGR-00116illegal SHUTDOWN option

Cause:An option was specified that was not NORMAL, IMMEDIATE, or ABORT for the SHUTDOWN command.

Action:Correct the syntax of the command, then issue the command again.


MGR-00117

MGR-00117invalid tablespace name

Cause:The specified tablespace name was not recognized.

Action:Specify a legal tablespace name.


MGR-00118

MGR-00118invalid process identifier or statistics class

Cause:Something other than a number for a process identifier, or an invalid class was specified after the MONITOR STATISTICS command.

Action:Specify only numbers as process identifiers, or specify a valid class for the MONITOR STATISTICS command.


MGR-00119

MGR-00119illegal STARTUP option

Cause:An option was specified that was not DBA, PFILE, EXCLUSIVE, SHARED, MOUNT, OPEN, RECOVER, or NOMOUNT for the STARTUP command.

Action:Correct the syntax of the command, then issue the command again.


MGR-00120

MGR-00120invalid STOPONERROR switch

Cause:An invalid option was specified for the SET STOPONERROR command.

Action:Use either ON or OFF as an option for the SET STOPONERROR command.


MGR-00121

MGR-00121illegal MONITOR option

Cause:An illegal option was specified for the MONITOR command.

Action:Correct the syntax of the MONITOR command in the Oracle Server Manager User's Guide and issue the command again.


MGR-00122

MGR-00122invalid SET numeric parameter

Cause:A character or an invalid value was specified when a number was expected as a value for a SET command option.

Action:Correct the syntax of the command, use an appropriate number for the option and issue the command again.


MGR-00123

MGR-00123invalid tablespace name list

Cause:An invalid string was specified as one of the values in the list of tablespaces in the ARCHIVE LOG command. For example, an empty string is an invalid string.

Action:Correct the syntax of the command, use valid tablespace names for all names in the list, then enter the command again.


MGR-00124

MGR-00124invalid ARCHIVE destination

Cause:The specified ARCHIVE destination was not recognized.

Action:Specify a legal ARCHIVE destination. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00125

MGR-00125integer value overflow

Cause:A numeric value was specified that was too large.

Action:Use a smaller number.


MGR-00127

MGR-00127invalid combination of STARTUP options

Cause:The specified options of the STARTUP command cannot be used simultaneously.

Action:Correct the syntax of the STARTUP command and issue the command again. See the Oracle Server Manager User's Guide for options that can be used with STARTUP.


MGR-00128

MGR-00128invalid DEBUG switch

Cause:The DEBUG switch was not recognized.

Action:Specify a legal DEBUG switch. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00129

MGR-00129value out of range (1 - num)

Cause:The specified value was out of range. The valid range is given by the error message.

Action:Use a number within the range specified by this error.


MGR-00131

MGR-00131invalid ARCHIVE TO device

Cause:The specified ARCHIVE TO device was not recognized.

Action:Specify a legal ARCHIVE TO device. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00132

MGR-00132null hostname/password specified

Cause:"hostname/password" was not specified.

Action:Specify the correct "hostname/password".


MGR-00133

MGR-00133invalid datafile list

Cause:An invalid string was entered as one of the values in the list of datafiles in the ARCHIVE LOG command. For example, an empty string is an invalid string.

Action:Correct the syntax of the command, use valid datafile names for all names in the list, then enter the command again.


MGR-00134

MGR-00134invalid AUTORECOVERY switch

Cause:An invalid option was specified for the SET AUTORECOVERY command.

Action:Use either ON or OFF as options for the SET AUTORECOVERY command.


MGR-00136

MGR-00136bad variable specification

Cause:A variable was incorrectly specified using the VARIABLE command.

Action:Correct the syntax of the command, then issue the command again.


MGR-00137

MGR-00137syntax error in PL/SQL Block

Cause:The PL/SQL block contains a syntax error.

Action:Correct the syntax error.


MGR-00139

MGR-00139invalid ALTER DATABASE option

Cause:The specified ALTER DATABASE option was not recognized.

Action:Specify a legal option. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00140

MGR-00140invalid COMPATIBILITY switch

Cause:The specified COMPATIBILITY switch was not recognized.

Action:Specify a legal COMPATIBILITY switch. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00141

MGR-00141invalid RETRIES value

Cause:The specified RETRIES value was not recognized.

Action:Specify a legal RETRIES value. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00142

MGR-00142cannot recognize object type, owner, or name

Cause:The specified object type, owner, or name was not recognized.

Action:Specify a legal object type, owner, or name.


MGR-00143

MGR-00143variable "name" has not been defined

Cause:The specified variable was not recognized.

Action:Specify an existing variable. You can use the PRINT command to display currently defined variables.


MGR-00144

MGR-00144invalid object type for DESCRIBE

Cause:The specified object type was not TABLE, VIEW, or PROCEDURE.

Action:Check that the object is a table, view, or procedure. If so, check that you specified the correct name and try again. If not, you cannot DESCRIBE the object.


MGR-00145

MGR-00145invalid object name for DESCRIBE

Cause:The specified table, view, stored procedure, or function was not recognized.

Action:Check your spelling and be sure to specify an existing table, view, stored procedure, or function.


MGR-00146

MGR-00146invalid HISTORY value

Cause:The specified HISTORY value was not recognized.

Action:Specify a legal HISTORY value. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00147

MGR-00147invalid LINES value

Cause:The specified LINES value was not recognized.

Action:Specify a legal LINES value. See the Oracle Server Manager User's Guide for the correct syntax.


MGR-00300

MGR-00300internal error code, argument: [num]

Cause:You have encountered an internal error in Server Manager.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-00302

MGR-00302not connected to a database

Cause:You must be connected to the database for the requested operation.

Action:Connect to the database using a valid username and password before retrying the operation.


MGR-00304

MGR-00304input file I/O error [num]; input aborted

Cause:A command file used as input to Server Manager is corrupted or invalid.

Action:Check the file before trying the operation again.


MGR-00305

MGR-00305command size exceeds internal buffer size (num)

Cause:The SQL statement size exceeds Server Manager's buffer size.

Action:Shorten the SQL statement by removing extra blanks or by converting intermediate statements to views.


MGR-00306

MGR-00306monitor cycle interval time out of range (1 - num)

Cause:You entered an invalid number for the cycle interval.

Action:Enter a value between 15 seconds and 99:99 (min:sec), inclusive, for the cycle interval.


MGR-00307

MGR-00307cannot open spool file "name"

Cause:Server Manager tried to open a spool file after you entered SPOOL <filename>, but could not open the file. Possible causes are a lack of disk space or inadequate privileges to create a file.

Action:Determine why Server Manager could not create a new file and try the operation again.


MGR-00308

MGR-00308no spool file opened

Cause:You entered SPOOL OFF, but you were not spooling at the time, so there was no file to close.

Action:If you wish to capture session output, first use the SPOOL command to open a file, then enter your commands before closing the file with SPOOL OFF.


MGR-00309

MGR-00309cannot close spool file "name"

Cause:SPOOL OFF could not close the currently open spool file.

Action:Check for operating system circumstances that are preventing the file from being closed.


MGR-00310

MGR-00310cannot open parameter file "name"

Cause:Server Manager cannot locate or open the file specified by the PFILE option, either because the file does not exist or because Server Manager has insufficient privileges to open the file.

Action:Make sure the file exists in a location expected by Server Manager and can be opened.


MGR-00311

MGR-00311data exceeds internal buffer size

Cause:The results returned by a SQL query exceed the size of Server Manager's internal buffer.

Action:Use the SET command to increase MAXDATA or decrease ARRAYSIZE.


MGR-00312

MGR-00312invalid pid range num num

Cause:You entered an invalid range. Ranges must be specified using the lower number first. Note: If a valid range includes any currently active process identification numbers, the range will be accepted.

Action:Enter a valid range.


MGR-00313

MGR-00313no active processes to monitor

Cause:You specified process identification numbers that do not correspond to any currently active processes.

Action:Try again by entering process identification numbers that you know to be currently active.


MGR-00314

MGR-00314unable to attach to default host

Cause:The default host has not been set up correctly.

Action:Use the SET INSTANCE command with a valid host specification to set up a default host.


MGR-00315

MGR-00315cannot open command file "name"

Cause:Server Manager cannot locate the specified command file.

Action:Verify the file's name and Server Manager's access to it before retrying.


MGR-00318

MGR-00318Server Manager command line error [num]

Cause:You made a syntax or typing error while entering a Server Manager command.

Action:Correct the syntax and try again.


MGR-00321

MGR-00321instance name too long

Cause:You specified an instance name that may or may not be valid, but is too long (exceeds 127 characters).

Action:Verify the name of the desired instance and try again.


MGR-00322

MGR-00322total size of command line parameters exceeds buffer size

Cause:You entered too many command line arguments and the size of the Server Manager buffer was exceeded.

Action:Reduce the number of command line arguments.


MGR-00323

MGR-00323invalid date specification; use DD-MON-YY:HH:MM:SS

Cause:You entered an improper date specification in the RECOVER DATABASE command.

Action:Use a valid date specification. For example: 24-DEC-1988:12:33:26.


MGR-00324

MGR-00324maximum number of tablespaces (num) exceeded; last num ignored

Cause:You specified too many tablespace names in the RECOVER TABLESPACE command. You may only specify up to 16 tablespace names.

Action:Reduce the number of table spaces. If you want to recover more than 16 tablespaces, use the RECOVER command multiple times.


MGR-00325

MGR-00325read error on parameter file "filename"

Cause:The file you specified using the PFILE option of the STARTUP command is too large (exceeds 8K), the file contains a line that is too long, or another file system error occurred.

Action:Reduce the size of the parameter file before specifying it again or shorten extremely long lines in the file.


MGR-00326

MGR-00326currently no statistics belong to the specified class

Cause:At this time no statistics exist in the class you specified.

Action:None.


MGR-00327

MGR-00327command not available in this mode

Cause:You have specified a command that is not available in this mode.

Action:Do not specify the command in the current mode.


MGR-00328

MGR-00328insufficient privileges for this display

Cause:You do not have sufficient privileges to view the monitor you requested.

Action:Contact your database administrator to obtain the required privileges.


MGR-00329

MGR-00329insufficient privileges for SHOW SGA

Cause:You attempted to use SHOW SGA without sufficient privileges.

Action:Contact your database administrator to obtain the required privileges.


MGR-00330

MGR-00330logsource name too long

Cause:You specified a logsource name that may or may not be valid, but is too long (exceeds 127 characters).

Action:Verify the logsource name and try again.


MGR-00336

MGR-00336insufficient privileges for SHOW PARAMETERS

Cause:You attempted to use SHOW PARAMETERS without sufficient privileges.

Action:Contact your database administrator to obtain the required privileges.


MGR-00337

MGR-00337missing instance name

Cause:Instance name or service name not specified in the CONNECT statement.

Action:Use CONNECT username/password@instance.


MGR-00340

MGR-00340display size exceeded; extra lines truncated

Cause:The monitor display retrieved too many lines.

Action:Increase the granularity of your selection.


MGR-00341

MGR-00341the bind variable name is undefined

Cause:The SQL statement refers to an undefined bind variable.

Action:Use the VARIABLE command to define the bind variable and execute the query again.


MGR-00342

MGR-00342unable to complete internal login

Cause:An attempt was made to complete an internal connection to a database. This connection attempt has failed as a result of the indicated database error.

Action:Correct the database error and try again.


MGR-00343

MGR-00343no such parameter

Cause:SHOW PARAMETER was given a parameter name that does not exist.

Action:Use a different argument with SHOW PARAMETER.


MGR-00360

MGR-00360object to be described does not exist

Cause:The object in a DESCRIBE FUNCTION/PROCEDURE/PACKAGE statement does not exist.

Action:Check that the object name and owner are correct and that the object exists.


MGR-00361

MGR-00361no privilege to describe this object

Cause:You do not have sufficient privileges to describe the object.

Action:The object owner must grant privileges on the object.


MGR-00362

MGR-00362text too long for DESCRIBE

Cause:The object's text is too long for the DESCRIBE command.

Action:The object cannot be used with the DESCRIBE command.


MGR-00363

MGR-00363logic error in DESCRIBE

Cause:You have encountered an internal error in Server Manager.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-00364

MGR-00364out of space for identifier in DESCRIBE

Cause:You have encountered an internal error in Server Manager.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-00365

MGR-00365DESCRIBE PACKAGE BODY is not supported

Cause:Only a package's specification can be described. The keyword BODY cannot be used with DESCRIBE PACKAGE.

Action:Remove the BODY keyword.


MGR-01501

MGR-01501Server Manager has run out of memory

Cause:Server Manager was unable to obtain the memory it required.

Action:Close some windows or exit and restart Server Manager.


MGR-01503

MGR-01503an invalid argument was sent to a function

Cause:An internal Server Manager function was called incorrectly.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-01505

MGR-01505user requested cancel

Cause:You canceled out of the middle of a process.

Action:None.


MGR-01506

MGR-01506unknown error

Cause:Unknown.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-01507

MGR-01507unable to open file "filename"

Cause:Server Manager was unable to open an existing file or create a new one.

Action:Check that the file exists and Server Manager can locate the file. Or make sure there is enough free disk space and you have sufficient privileges to create a file.


MGR-01508

MGR-01508unable to close the current file

Cause:Server Manager was unable to close a file.

Action:Check for operating system circumstances that are preventing the file from being closed.


MGR-01509

MGR-01509unexpected EOF encountered

Cause:Server Manager encountered an unexpected End-Of-File marker.

Action:Examine the script(s) to determine the problem.


MGR-01523

MGR-01523invalid monitor name: name

Cause:The entered monitor name is not a valid monitor type.

Action:Enter a different monitor name.


MGR-02001

MGR-02001unable to destroy a timer

Cause:You have encountered an internal error in Server Manager.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02002

MGR-02002unable to create a timer

Cause:You have encountered an internal error in Server Manager.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02003

MGR-02003unable to load a window from a resource file

Cause:A resource file is missing or corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02004

MGR-02004unable to find a needed resource: masplash.tif

Cause:A resource file is missing or corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02011

MGR-02011a control is missing from a resource

Cause:A resource file is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02016

MGR-02016an error occurred while loading a window from the resource file

Cause:A resource file is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02017

MGR-02017unable to get subview

Cause:A resource file is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02019

MGR-02019an error occurred while accessing help

Cause:An error occurred in Oracle Help.

Action:Examine subsequent messages.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Most messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02042

MGR-02042unable to open resource file: name

Cause:The multimedia resource file (mmmwm.res) may be missing or corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02046

MGR-02046unable to get a resource

Cause:The multimedia resource file (mmmwm.res) may be missing or corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02047

MGR-02047unable to load window system resources

Cause:The multimedia resource file (mmmwm.res) may be missing or corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02051

MGR-02051an error occurred while initializing Multimedia

Cause:The multimedia resource file (mmmwm.res) may be missing or corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02056

MGR-02056unable to load the splash screen from the resource file

Cause:A resource file is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02057

MGR-02057unable to find a necessary resource file

Cause:A resource file is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02059

MGR-02059unable to open .msb file for product name, facility name

Cause:The message file for the specified product and facility cannot be found.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.

Most messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02073

MGR-02073an error occurred while connecting to a database

Cause:An error occurred while connecting to a database.

Action:Examine subsequent messages.


MGR-02076

MGR-02076an error occurred while disconnecting from a database

Cause:An error occurred while disconnecting from a database.

Action:Examine subsequent messages.


MGR-02083

MGR-02083unable to load the Connect dialog box

Cause:A resource file is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Most messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Most messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02134

MGR-02134tab "name" failed; maybe catsvrmg.sql not run or not a DBA

Cause:Either Server Manager was not installed fully, or you do not have access to this information.

Action:Run the CATSVRMG.SQL script as SYS, if necessary. Then connect as a user with the DBA role as a default role.


MGR-02135

MGR-02135tab "name" failed; maybe insufficient privileges

Cause:Either Server Manager was not installed fully, or you do not have access to this information.

Action:Run the CATSVRMG.SQL script as SYS, if necessary. Then connect as a user with the DBA role as a default role.


MGR-02136

MGR-02136tab "name" failed, maybe utlxplan.sql not run

Cause:The table sys.plan_table does not exist.

Action:Run the script UTLXPLAN.SQL as SYS.


MGR-02137

MGR-02137tab "name" failed, maybe catrepad.sql not run or not a DBA

Cause:Either Server Manager was not installed fully, or you do not have access to this information.

Action:Run the catrepad.sql script as SYS, if necessary. Then connect as a user with the DBA role as a default role.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Most messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02150

MGR-02150an unrecognized database version was encountered

Cause:You have tried to administer a database version that Server Manager does not support.

Action:Consider upgrading your database.


MGR-02151

MGR-02151a specification for action string could not be found

Cause:A resource file is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-02156

MGR-02156Server Manager could not perform action string

Cause:Either Server Manager was not installed fully, or you do not have access to this information.

Action:Run the CATSVRMG.SQL script as SYS, if necessary. Then connect as a user with the DBA role as a default role.


MGR-02157

MGR-02157action string failed; maybe catsvrmg.sql not run or not a DBA

Cause:Either Server Manager was not installed fully, or you do not have access to this information.

Action:Run the CATSVRMG.SQL script as SYS, if necessary. Then connect as a user with the DBA role as a default role.


MGR-02158

MGR-02158action string failed; maybe insufficient privileges

Cause:Either Server Manager was not installed fully, or you do not have access to this information.

Action:Run the CATSVRMG.SQL script as SYS, if necessary. Then connect as a user with the DBA role as a default role.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

Most messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03006

MGR-03006the monitor_name could not enable its child views

Cause:A monitor resource is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03007

MGR-03007the monitor_name could not disable its child views

Cause:A monitor resource is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03008

MGR-03008the monitor_name could not be resized

Cause:The monitor was not able to be resized.

Action:Examine subsequent messages. A Toolkit error should follow this message.


MGR-03009

MGR-03009the monitor_name could not sort on the selected column

Cause:A monitor resource is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03010

MGR-03010the monitor_name cannot set its Cycle radio button

Cause:A monitor resource is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03011

MGR-03011the monitor_name cannot set its Sample on Demand radio button

Cause:A monitor resource is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03012

MGR-03012the monitor_name cannot reset a button

Cause:A monitor resource is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03013

MGR-03013the monitor_name cannot complete the filter operation

Cause:Text in the Filter field is invalid.

Action:Enter valid text in the Filter field.


MGR-03016

MGR-03016a monitor_name is closing because its SQL command failed

Cause:Connection to the database has been lost during the execution of a SQL command.

Action:Verify that the database is still running and that the network is functioning properly. Attempt to reconnect.


MGR-03017

MGR-03017a monitor_name is closing because its Interval pop-up menu failed

Cause:An error was generated when the Interval pop-up menu was used.

Action:Examine subsequent messages.


MGR-03018

MGR-03018the monitor_name is in an unknown state and could not be removed

Cause:The monitor failed to shut down properly.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03019

MGR-03019the monitor_name was not found

Cause:A monitor resource is corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03020

MGR-03020the following title was too long: "name"

Cause:You attempted to create a monitor with a connection name longer than 80 characters.

Action:Shorten your SQL*Net service names.


MGR-03021

MGR-03021a monitor_name is closing because of an error finishing a SQL command

Cause:The monitor lost connection with the database while a SQL command was running.

Action:Verify that the database is still running and that the network is functioning properly. Attempt to reconnect. A more specific error message will follow, probably indicating that the connection state has changed.


MGR-03022

MGR-03022select a monitor from the scrolling list and click OK

Cause:A resource file is missing or corrupted.

Action:Check your Oracle platform-specific documentation to make sure Server Manager is installed correctly. Reinstall if necessary. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03023

MGR-03023monitor selection failed

Cause:An error occurred during the selection of a monitor.

Action:Examine subsequent messages.


MGR-03024

MGR-03024interval must be at least 15 seconds

Cause:User entered an interval less than 15 seconds.

Action:Enter a valid interval of 15 seconds or more.


MGR-03025

MGR-03025numeric filter fields must contain numeric values

Cause:User entered a non-numeric value for a numeric filter field.

Action:Enter a valid number in the filter field and click filter again.


MGR-03050

MGR-03050a monitor_name is closing because of an error in parse/bind/define

Cause:An error was encountered when attempting to parse, bind, or define a SQL statement for the monitor.

Action:Verify that the database is still running and that the network is functioning properly. Attempt to reconnect. A more specific error message will follow, probably indicating that the connection state has changed.


MGR-03051

MGR-03051an error occurred while executing a monitor query

Cause:An error occurred when the monitor was interacting with the SQL engine.

Action:Verify that the database is still running and that the network is functioning properly. Attempt to reconnect. A more specific error message will follow, probably indicating that the connection state has changed.


MGR-03052

MGR-03052the query for the monitor_name failed to execute

Cause:An error occurred when the monitor was interacting with the SQL engine.

Action:Verify that the database is still running and that the network is functioning properly. Attempt to reconnect. A more specific error message will follow, probably indicating that the connection state has changed.


MGR-03053

MGR-03053an error occurred after completing a monitor query

Cause:The state of the monitor connection has changed as a result of actions taken outside of the monitor subsystem.

Action:Verify that the database is still running and that the network is functioning properly. Attempt to reconnect. A more specific error message will follow, probably indicating that the connection state has changed.


MGR-03054

MGR-03054one or more monitors are closing due to a connection problem

Cause:The state of the monitor connection has changed as a result of actions taken outside of the monitor subsystem.

Action:Verify that the database is still running and that the network is functioning properly. Attempt to reconnect. A more specific error message will follow, probably indicating that the connection state has changed.


MGR-03500

MGR-03500encountered an unterminated quote

Cause:The last command contained an open quote without a matching close quote.

Action:Correct the quoting and issue the command again.


MGR-03501

MGR-03501unable to process so many nested scripts

Cause:You have attempted to run a script that in turn tries to run too many nested levels of scripts.

Action:Restructure your scripts so the nesting depth decreases.


MGR-03502

MGR-03502the @@ operator is only allowed within SQL scripts

Cause:You attempted to use the @@ operator from the interactive mode.

Action:The @@ operator is only allowed from within a script. In the interactive mode, use the @ operator to run a SQL script.


MGR-03503

MGR-03503could not resolve the symbols in "filename"

Cause:The filename you provided for the parameter file contained undefined symbols.

Action:Check the text of the parameter filename you provided.


MGR-03504

MGR-03504CYCLE is no longer a valid global property

Cause:You attempted to set the CYCLE property.

Action:Set the interval in the monitor(s) you are running.


MGR-03506

MGR-03506expected a number (num-999999), not "string"

Cause:You attempted to set a property (NUMWIDTH, CHARWIDTH, and so on) to a non-numeric value or a number outside of the legal range.

Action:Use a value within the specified range.


MGR-03509

MGR-03509corrupted internal Oracle number representation

Cause:You attempted to use a bind variable that appears to have been corrupted.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03510

MGR-03510corrupted bind variable type [type]

Cause:You attempted to use a bind variable that appears to have been corrupted.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03511

MGR-03511the HOST command is not supported in graphical mode

Cause:You tried to use the HOST command from within a SQL Worksheet.

Action:Scripts that make use of the HOST command must be run from Server Manager line mode.


MGR-03512

MGR-03512spool file "name" is already open

Cause:You attempted to open a second spool file.

Action:Use SPOOL OFF to close the existing spool file.


MGR-03514

MGR-03514unable to start the database

Cause:The cause is listed in subsequent error messages.

Action:Examine the subsequent errors.


MGR-03515

MGR-03515invalid SERVEROUTPUT switch

Cause:You attempted to set SERVEROUTPUT to something other than ON or OFF.

Action:Use ON or OFF as arguments with SET SERVEROUTPUT.


MGR-03523

MGR-03523no parameter for SHOW ERRORS and no object has been compiled

Cause:You issued a SHOW ERRORS command, but have yet to compile a PL/SQL object.

Action:You can find error information for a specific object by selecting from the ALL_ERRORS view where NAME = <object>.


MGR-03524

MGR-03524unable to shutdown the database

Cause:You attempted to shut down the database without sufficient privileges.

Action:Enable the privileges required for shutdown.


MGR-03525

MGR-03525expected SYSDBA or SYSOPER, not "string"

Cause:You attempted to use the CONNECT AS syntax and specified something other than SYSDBA or SYSOPER.

Action:Correct the syntax and issue the command again. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-03534

MGR-03534invalid AUTOPRINT switch

Cause:You attempted to set AUTOPRINT to something other than ON or OFF

Action:Use ON or OFF as arguments with SET AUTOPRINT.


MGR-03536

MGR-03536variable type REFCURSOR not available

Cause:You tried to declare a REFCURSOR variable against a version of server manager which does not support this variable type.

Action:The version of Server Manager you are running against does not support the REFCURSOR feature. It was most likely compiled against a pre-7.2 database.

Messages in this range indicate that a SQL Worksheet command failed to execute properly. Other messages will follow the SQL Worksheet command messages. Examine the subsequent messages to determine the proper action.


MGR-04017

MGR-04017the attempted font change did not succeed

Cause:This action is not available to you.

Action:Do not change the font.


MGR-04022

MGR-04022the Write Selection menu item was chosen without a text selection

Cause:You chose Write Selection from the Worksheet menu without having any text selected in the input or output panes of a SQL Worksheet.

Action:Attempt the command with text selected.


MGR-04024

MGR-04024unable to open specified file: "name"

Cause:A specified file could not be opened.

Action:The file is either invalid or in an unexpected format. Verify the filename and replace the file with a usable file, if necessary.


MGR-04025

MGR-04025the Get File option of the Recover dialog box failed

Cause:You specified a filename which was invalid.

Action:Specify a valid filename.


MGR-04026

MGR-04026the Apply Recovery Archives dialog box failed

Cause:An error occurred in the operation of the Worksheet's Apply Recovery Archives dialog box.

Action:Examine subsequent messages.


MGR-04027

MGR-04027the database is not available

Cause:The Oracle database is not accessible from your system.

Action:Verify that the database is available and that you have the ability to connect to the database from the current location.


MGR-04501

MGR-04501monitors are not available from the line mode Server Manager

Cause:You attempted the MONITOR command from Server Manager line mode.

Action:Start Server Manager in graphical mode to run monitors.


MGR-04544

MGR-04544invalid parameter format

Cause:You gave an invalid command line argument.

Action:Start Line mode with the correct arguments. These should be of the format command="command". Note that the command should be in quotes.


MGR-04545

MGR-04545too many parameters

Cause:You gave too many parameters on the command line, or your command line parameters may have been parsed separately.

Action:Pass in only the supported number of arguments. Make sure they are of the format command="command". Note that the command should be in quotes.


MGR-04546

MGR-04546invalid connect string

Cause:Your connect string contained invalid information.

Action:Check the syntax of your connect string. It should be "[username] [/password] [@instance path]".


MGR-04547

MGR-04547duplicate password

Cause:Your connect string contained either a null password or multiple password strings.

Action:Make sure your connect string only gives a single password. It should be of the form "/password".


MGR-04548

MGR-04548null username/password not valid with connection name

Cause:A connect string with a null username/password and a non-null connection name is invalid.

Action:You must explicitly specify a null username/password using the "/" designator when giving a connection name in the user string. For example: "/@t:lorax:E".


MGR-04549

MGR-04549null or invalid connection name

Cause:Your connect string contained either a null or invalid host string.

Action:Check the syntax of your connect string.


MGR-05500

MGR-05500out of unique ids for asynchronous connections

Cause:You have too many outstanding asynchronous connections.

Action:Close some less important windows or restart Server Manager.


MGR-05501

MGR-05501user string overflow

Cause:You have tried to connect using a username that is greater than 30 characters in length.

Action:Specify a shorter username.


MGR-05502

MGR-05502password string overflow

Cause:You have tried to connect using a password that is greater than 30 characters in length.

Action:Specify a shorter password.


MGR-05503

MGR-05503host string overflow

Cause:You have tried to connect using a hostname that is greater than 80 characters in length.

Action:Use a shorter service name.


MGR-05504

MGR-05504cannot connect to an Oracle version_num instance

Cause:You have attempted to connect to an old version of Oracle.

Action:Server Manager can only run against Version 7 or later. You can upgrade the instance, or use the SQL*DBA included with your release of Oracle.


MGR-05505

MGR-05505cannot perform a CONNECT usr/pswd AS name to an ORACLE 7.0 instance

Cause:You tried to connect to a version 7.0 database AS SYSDBA or AS SYSOPER.

Action:In Version 7.0 you must CONNECT INTERNAL [/password].


MGR-05506

MGR-05506unable to release an allocated connection

Cause:You attempted to close a window which could not be closed.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-05507

MGR-05507the list of connections has been corrupted

Cause:You have encountered an internal error in Server Manager.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.

Most messages in this range indicate that you have encountered an internal error. Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-06512

MGR-06512Oracle Toolkit II has run out of memory

Cause:There is not enough memory.

Action:Free up or add memory.


MGR-06513

MGR-06513Oracle Toolkit II's client has run out of memory

Cause:There is not enough memory.

Action:Free up or add memory.


MGR-06518

MGR-06518Oracle Toolkit II's connection to the window system was refused

Cause:The windowing system (usually X Windows) denied permission to connect.

Action:On X Windows, set the DISPLAY to a server that will allow connections.

Most messages in this range indicate that you have encountered an internal error. For these messages, call Customer Support with the circumstances and complete set of messages leading to the error.

For other messages in this range, specific actions can be taken. These messages are listed below:


MGR-06602

MGR-06602the Oracle Help book is in a format not recognized by object store

Cause:The Oracle Help book has not been installed properly or is corrupted.

Action:Reinstall the help book(s) or the entire product.


MGR-06603

MGR-06603Oracle Help has run out of memory

Cause:There is not enough memory.

Action:Free up or add memory.


MGR-06606

MGR-06606Oracle Help could not find a help target

Cause:The program tried to access an Oracle Help target not contained in the help book(s).

Action:Reinstall the help book(s) or the entire product. If this does not solve the problem, contact Customer Support with the circumstances and complete set of messages leading to the error.


MGR-06607

MGR-06607Oracle Help could not find the specified word

Cause:The find operation could not locate the specified word.

Action:The word does not exist in the Help document. Try another word.


MGR-06608

MGR-06608Oracle Help could not link to external document

Cause:External document is either damaged, non-existent, or is not an Oracle Book document.

Action:Replace the document or link to a valid document.


MGR-06610

MGR-06610the document is not an Oracle Help document

Cause:The Oracle Help book has not been installed properly or has become corrupted.

Action:Reinstall the help book(s) or the entire product.


MGR-06611

MGR-06611the document is newer than Oracle Help

Cause:The Oracle Help book has not been installed properly or has become corrupted.

Action:Reinstall the help book(s) or the entire product. If this does not solve the problem, contact Customer Support with the circumstances and complete set of messages leading to the error


MGR-06614

MGR-06614Oracle Help encountered an invalid link

Cause:The program tried to follow an Oracle Help link not contained in the help book(s).

Action:Reinstall the help book(s) or the entire product. If this does not solve the problem, contact Customer Support with the circumstances and complete set of messages leading to the error.


MGR-06618

MGR-06618the string begins with a percent sign

Cause:An entered string begins with a percent sign.

Action:Remove the percent sign from the beginning of the string.


MGR-07368

MGR-07368the Username field must contain a valid Oracle username

Cause:The text you entered in the Username field is not a valid Oracle username.

Action:Check to make sure the value entered conforms to the guidelines for Oracle usernames given in Chapter 2 of the Oracle8 Server SQL Reference.


MGR-07369

MGR-07369the Password field must contain a password string

Cause:You selected Password in the Create/Alter User property sheet, but did not specify a password.

Action:Select another password option or assign a password to the user.


MGR-07401

MGR-07401the Composite Limit field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07402

MGR-07402the Private SGA field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07403

MGR-07403the Reads per Call field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07404

MGR-07404the Reads per Session field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07405

MGR-07405the Idle Time field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07406

MGR-07406the Connect Time field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07407

MGR-07407the CPU per Call field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07408

MGR-07408the CPU per Session field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07409

MGR-07409the Sessions per User field must contain a valid number

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-07410

MGR-07410the Profile Name field must contain a valid Oracle identifier

Cause:The value entered in the Profile Name field is not an Oracle identifier.

Action:Check to make sure the value entered conforms to the guidelines for Oracle identifiers given in Chapter 2 of the Oracle8 Server SQL Reference.


MGR-07537

MGR-07537the System Change Number field must contain a positive number

Cause:The value you have entered in the field is not a valid SCN.

Action:In general, you should allow Oracle to determine the SCN, so try committing the transaction without specifying an SCN


MGR-07539

MGR-07539the Group Number field must contain a valid number

Cause:The value in the field is not a number.

Action:The group number must be a positive number that is not the number of an existing group. When the dialog box appears, Server Manager initializes this field to be one greater than the greatest log file group number.


MGR-07540

MGR-07540the New File Size field must contain a valid number

Cause:The value in this field is not a number.

Action:Provide a valid positive number.


MGR-07541

MGR-07541at least one file must be specified

Cause:You have not specified the name of at least one file.

Action:Use the New button to bring up the file specification dialog box from which you can select a file.


MGR-07542

MGR-07542the Filename field must contain a valid filename

Cause:The field is empty or contains an invalid file.

Action:Provide a valid filename.


MGR-07543

MGR-07543you must select a log file group in which to place the log file

Cause:You have not selected the group into which this log file will be placed.

Action:Choose one of the provided groups.


MGR-07544

MGR-07544the To field must contain a valid filename

Cause:The field is empty or contains an invalid file.

Action:Provide a valid filename.


MGR-07547

MGR-07547the Name field must contain a valid Oracle identifier

Cause:The Name field is empty or contains a value that is not a valid Oracle identifier.

Action:Check to make sure the value entered conforms to the guidelines for Oracle identifiers given in Chapter 2 of the Oracle8 Server SQL Reference.


MGR-07548

MGR-07548you must specify at least one datafile

Cause:There are no entries in the list of datafiles.

Action:Use the New button to bring up a dialog box that will allow you to specify a datafile.


MGR-07549

MGR-07549the Initial Extent field must be empty or contain a valid number

Cause:The value is not a positive number.

Action:Specify a positive number or leave the field empty.


MGR-07550

MGR-07550the Next Extent field must be empty or contain a valid number

Cause:The value is not a positive number.

Action:Specify a positive number or leave the field empty.


MGR-07551

MGR-07551the Minimum Extents field must be empty or contain a valid number

Cause:The value is not a positive number.

Action:Specify a positive number or leave the field empty.


MGR-07552

MGR-07552the Maximum Extents field must be empty or contain a valid number

Cause:The value is not a positive number.

Action:Specify a positive number or leave the field empty.


MGR-07553

MGR-07553the Percentage Increase field must be empty or contain a valid number

Cause:The value is not a positive number.

Action:Specify a positive number or leave the field empty.


MGR-07555

MGR-07555unable to find tablespace information for "name"

Cause:Server Manager was unable to find the default storage settings for the chosen tablespace.

Action:Refresh the Tablespaces object list and try to alter the tablespace again. If the problem persists, call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-07556

MGR-07556the Rollback Segment field must contain a valid Oracle identifier

Cause:The Rollback Segment field is empty or contains a value that is not a valid Oracle identifier.

Action:Check to make sure the value entered conforms to the guidelines for Oracle identifiers given in Chapter 2 of the Oracle8 Server SQL Reference.


MGR-07557

MGR-07557the Optimal field must be empty or contain a valid number

Cause:The value is not a positive number.

Action:Specify a positive number or leave the field empty.


MGR-08049

MGR-08049the Role Name field must contain a valid Oracle identifier

Cause:The text you entered in the Role Name field is not a valid Oracle identifier.

Action:Check to make sure the value entered conforms to the guidelines for Oracle usernames given in Chapter 2 of the Oracle8 Server SQL Reference.


MGR-08050

MGR-08050with Password selected, a password must be specified

Cause:You selected Password in the Create/Alter Role property sheet, but did not specify a password.

Action:Select another password option or assign a password to the role.


MGR-08051

MGR-08051a user or role must be specified

Cause:No user or role was specified in the Grant/Revoke Role dialog box.

Action:Select a user or role from the scrolling list.


MGR-08052

MGR-08052with the Role privilege type selected, a role must be chosen

Cause:With the Role privilege type selected, you clicked the OK button in the Add Privilege to Role dialog box before selecting a role from the Defined Roles scrolling list.

Action:Select a role from the Defined Roles scrolling list or click the Cancel button to exit the dialog box.


MGR-08053

MGR-08053with the System privilege type selected, a privilege must be chosen

Cause:With the System Privileges privilege type selected, you clicked the OK button in the Add Privilege to Role dialog box before selecting a system privilege from the System Privileges scrolling list.

Action:Select a privilege from the System Privileges scrolling list or click the Cancel button to exit the dialog box.


MGR-08054

MGR-08054with the Object privilege type selected, an object must be specified

Cause:With the Object privilege type selected, you clicked the OK button in the Add Privilege to Role dialog box before entering an object in the Object Name field.

Action:Enter an object into the Object Name field or click the Cancel button to exit the dialog box.


MGR-08055

MGR-08055a schema must be chosen

Cause:You clicked the OK button in the Find Schema Object dialog box without selecting a schema from the Schema scrolling list.

Action:Select a schema from the Schema scrolling list or click the Cancel button to exit the dialog box.


MGR-08056

MGR-08056an object must be chosen

Cause:You clicked the OK button in the Find Schema Object dialog box without selecting an object from the Object scrolling list.

Action:Select an object from the Object scrolling list or click the Cancel button to exit the dialog box.


MGR-08504

MGR-08504the tablespace "name" is not offline so this datafile cannot be renamed

Cause:You tried to rename a datafile in an online tablespace.

Action:Take the corresponding tablespace offline and then rename the datafile.


MGR-08505

MGR-08505the tablespace "name" is invalid so this datafile cannot be renamed

Cause:You tried to rename a datafile in an invalid tablespace.

Action:Repair the tablespace to make it valid and then rename the datafile.


MGR-08507

MGR-08507the Quota Size field must contain a valid number

Cause:A negative number or a non-numeric character was entered in the Quota Size field of the Add/Edit Quota dialog box.

Action:Enter a valid quota size.


MGR-08510

MGR-08510a user must be specified

Cause:No user was specified in the Users scrolling list of the Assign Profile dialog box.

Action:Specify a user.


MGR-08515

MGR-08515this datafile has already been added to the database and cannot be removed

Cause:You tried to remove from a tablespace a datafile which belongs to a tablespace.

Action:None. A previously added datafile cannot be removed.


MGR-08517

MGR-08517the Object Name field does not contain a valid schema object

Cause:You entered a schema object that does not follow proper naming or quoting conventions.

Action:Enter a valid schema object name.


MGR-08524

MGR-08524a privilege or role must be specified

Cause:A Privilege or Role was not specified in the Remove Privilege from User/Role dialog box.

Action:Select a privilege or role from the list before clicking the Remove button.

Most messages in this range indicate that you have encountered an internal error. Call Customer Support with the circumstances and complete set of messages leading to the error.

For other messages in this range, specific actions can be taken. These messages are listed below:


MGR-09501

MGR-09501help is not available for the active window

Cause:The active window does not have a help target. This is probably because it is a system window rather than a Server Manager window.

Action:None. Refer to your documentation for the information about which you were looking for help.


MGR-09502

MGR-09502Oracle Help returned an error

Cause:Unknown.

Action:A second message will include the Oracle Help error. This number should be looked up in the Oracle Help documentation.


MGR-09506

MGR-09506Oracle Help was not able to respond to the user request

Cause:Multiple causes; to be clarified by additional error messages.

Action:Examine subsequent messages.


MGR-09507

MGR-09507Oracle Help text was not found

Cause:The Oracle Help book, mahelp.obd, is not properly installed or slfindfile() cannot find it.

Action:Reinstall Oracle Book or verify the response of slfindfile() for your platform.


MGR-09508

MGR-09508the text for target "string" was not found

Cause:The context string in the maht (help table) did not have a corresponding string in the mahelp.obd book.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error. The file mahelp.obd or the maht will need to be modified.


MGR-11401

MGR-11401input error, unable to read input line

Cause:An error in reading from the input source occurred. This is most likely because the input line is too long.

Action:Try breaking the input line into multiple lines of no more than 1024 bytes per line.


MGR-11402

MGR-11402error while writing output to a file

Cause:An error in writing to the output file occurred. This is most likely because the output line is too long.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-11403

MGR-11403error while writing output

Cause:An error in writing to the output source (generally stdout) occurred. This is most likely because the output line is too long.

Action:If this occurred in Server Manager Line Mode, try executing the query in the Server Manager Worksheet.


MGR-11404

MGR-11404error formatting output

Cause:An error occurred during the CORE sprintf routine.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-11500

MGR-11500you must quiesce the replicated schema before performing the operation

Cause:You attempted to alter a master repschema that has not been quiesced.

Action:First Suspend Master Activity on the replicated schema, then try again.


MGR-11502

MGR-11502the current operation is only valid for master definition sites

Cause:You attempted to use an operation that is only valid for master definition sites.

Action:Perform operation on a master definition site.


MGR-11505

MGR-11505the Remote Master field must contain a valid remote database

Cause:The operation needs a list of one or more remote masters on which to operate.

Action:Specify a list of masters in the Server Manager dialog using multi-select.


MGR-11506

MGR-11506the DDL Text field must contain a valid DDL statement

Cause:The operation needs a DDL statement.

Action:Enter a DDL statement in the Server Manager dialog.


MGR-11517

MGR-11517the selected Destination Database has no transactions queued for remote execution

Cause:You attempted an operation on a Destination Database which has no transactions queued for remote execution.

Action:Retry this operation when there are transactions queued for remote execution.


MGR-11519

MGR-11519the Transaction Count field must contain a positive integer

Cause:The number entered in the indicated field is not valid.

Action:Check to make sure there are no extraneous alphabetic or punctuation characters in the field. Make sure the value entered is within the range of valid values.


MGR-11523

MGR-11523the deferred call arguments could not be extracted

Cause:An error occurred while trying to extract and store the arguments for a call in a deferred transaction.

Action:Call Customer Support with the circumstances and complete set of messages leading to the error.


MGR-11525

MGR-11525the local database is not a master site

Cause:An operation originating from a remote database or locally assumes that the local database is a master site for replication.

Action:No action can be taken in this case.


MGR-11528

MGR-11528all objects in the chosen schema are already replicated

Cause:All the objects in the chosen schema are replicated.

Action:Choose a different schema or add some more objects to this schema.


MGR-11530

MGR-11530you must select at least one Remote Master from the list

Cause:The operation needs a list of one or more remote masters on which to operate.

Action:Specify a list of masters in the Server Manager dialog using multi-select.


MGR-11531

MGR-11531cannot generate replication support for name. Table has no PRIMARY KEY.

Cause:Replication will not work for tables without a PRIMARY KEY.

Action:Recreate table with a PRIMARY KEY or call procedure DBMS_REPCAT.SET_COLUMNS after CREATE_MASTER_REPOBJECT but before GENERATE_REPLICATION_SUPPORT.


MGR-11532

MGR-11532you must select at least one Master Database from the list

Cause:The operation needs a list of one or more remote masters on which to operate.

Action:Specify a list of masters in the Server Manager dialog using multi-select.


MGR-11533

MGR-11533cannot execute package SYS.DBMS_DEFER_PRINT. Maybe CATREPAD.SQL not run or no EXECUTE privilege

Cause:Server manager cannot execute DBMS_DEFER_PRINT.

Action:Make sure CATREPAD.SQL has been run and the current user has execute privileges on DBMS_DEFER_PRINT.


MGR-11534

MGR-11534cannot display call arguments for a remote procedure from a snapshot site

Cause:Cannot get the call arguments for remote procedure.

Action:No action is available from a snapshot site.


MOD-00009

MOD-00009unable to open input file name

Cause:SQL*Module is not able to open the input file that was specified with the INAME option. This error can result from any of the following:

The file does not exist.

The file exists, but in a directory not on the path specified.

You do not have the permissions or access rights required to read the file.

Action:Check that the appropriate permission to read the file has been granted. Check that the name and directory hierarchy have been specified correctly. Rerun the compiler.


MOD-00010

MOD-00010unable to open listing file name

Cause:SQL*Module is not able to create the listing output file. This usually happens when write permissions do not exist on the current directory or on the directory specified for the LNAME option. It can also happen if the name or directory path is not legal or a directory on the path does not exist.

Action:Check the permissions on the specified path and file, or on the current directory if the LNAME option is not used.


MOD-00011

MOD-00011unable to open output file name

Cause:SQL*Module is not able to create an output file, such as the specification file or the output code file. This usually happens when write permissions on the current directory or on the directory specified for the ONAME or SNAME options do not exist. It can also happen if the name or directory path is not legal or a directory on the path does not exist.

Action:Check the permissions on the specified path and file, or on the current directory if the ONAME or SNAME options are not used.


MOD-00012

MOD-00012encountered the symbol name when expecting one of the following...

Cause:This is caused by a syntax error in the Module Language file. For example, if the SQL statement

SELECT ename INTO :name FORM emp WHERE ...

is in a module procedure, the following message appears:

MOD-S-00012, Encountered the symbol FORM where expecting one of the following:

,:INDICATOR FROM

This message is not triggered by semantic errors.

Action:Correct the syntax error, then recompile.


MOD-00015

MOD-00015Oracle Error: ora-nnnnn

Cause:This message results from an internal error: an invalid value for the mode of a bind variable.

Action:Contact customer support.


MOD-00016

MOD-00016out of space - unable to allocate num bytes

Cause:SQL*Module could not allocate enough memory to run or to perform some required action.

Action:Try killing some non-essential processes, then rerunning SQL*Module. On some operating systems, there may be a quota for the amount of memory the processes can allocate. See the system administrator. If necessary, increase memory for the machine.


MOD-00017

MOD-00017unable to connect to Oracle with conn_str:username/password. Oracle error number ora-nnnnn

Cause:The database connection or the username or the password that was specified was not correct. This message can result from an incorrect command-line specification or an incorrect specification of the username and/or password in the module AUTHORIZATION clause.

Action:Look up the error number for more specific information on the failure, correct the identifiers, then rerun SQL*Module. (To find information on the error number, click the Help Topics button in this window, click the Index tab, then type the error number, including its three-letter prefix with the hyphen.)


MOD-00027

MOD-00027no input file name specified

Cause:The STORE_PACKAGE=YES option was entered, but an input file using the INAME option was not specified.

Action:Use INAME on the command line.


MOD-00036

MOD-00036internal programming exception

Cause:An internal error occurred.

Action:Contact customer support.


MOD-00038

MOD-00038module name required when output language is Ada

Cause:A MODULE clause was not specified in the module source file, or a name for the module was not provided.

Action:Specify the module name in the module file.


MOD-00039

MOD-00039unable to open specifications file name

Cause:SQL*Module is not able to create the specifications (header) output file. This usually happens when write permissions on the current directory or on the directory specified for the SNAME option do not exist. It can also happen if the name or directory path is not legal, a directory on the path does not exist, or the disk or file system is full.

Action:Check the permissions on the specified path and file or on the current directory if the SNAME options are not used. Check that the disk or file system is not full.


MOD-00041

MOD-00041ANSI violation at line num, column colnam: text

Cause:FIPS=YES was specified, and part of the module code was not compliant with the ANSI SQL92 Entry Level standard.

Action:Specify FIPS=NO (the default) or correct the code.


MOD-00042

MOD-00042cursor name is multiply declared

Cause:The cursor named in the message was declared more than once in themodule file.

Action:Check that each cursor names (not just in the module file, but in the entire application) is unique.


MOD-00043

MOD-00043procedure name is multiply declared

Cause:A procedure named X was declared more than once in the module file.

Action:Check that each procedure name (not just in the module file, but in the entire application) is unique.


MOD-00044

MOD-00044parameter param in procedure name is multiply declared

Cause:In the procedure named in the message, a parameter was declared with a name that duplicates another parameter's name.

Action:Check that each parameter name in a procedure is unique.


MOD-00046

MOD-00046cursor name has not been declared

Cause:In the module file, an OPEN, FETCH, or CLOSE was attempted on a cursor that had not yet been declared.

Action:Insert an appropriate cursor declaration in the module file. Remember that cursors must be declared in the file before they are acted upon.


MOD-00047

MOD-00047an open statement already exists for cursor name

Cause:More than one procedure in this module contains an OPEN command on the named cursor.

Action:Remove one of the OPEN commands, as there is no need for redundancy.


MOD-00048

MOD-00048cursor name was never opened

Cause:No OPEN command exists in the module for the cursor named in this message.

Action:Add an OPEN command or remove the cursor if it is not needed.


MOD-00049

MOD-00049unable to initialize PL/SQL

Cause:This message usually results when SQL*Module cannot connect to the database, using the username and password mentioned either in the module's AUTHORIZATION clause or on the command line with the USERID option.

Action:If connection is made using SQL*Net, check that a listener process is running and that the service name specified in the AUTHORIZATION clause or on the command line is in the tnsnames.ora file. If the connect parameters are correct and this problem persists, contact customer support.


MOD-00050

MOD-00050formal parameter param is not used in procedure

Cause:A formal parameter was declared in a procedure, but never used.

Action:Remove the parameter declaration or use it in the procedure.


MOD-00054

MOD-00054name is not a valid cursor reference

Cause:An attempt was made to OPEN a cursor that had not been declared.

Action:Declare the cursor or remove the erroneous reference to it.


MOD-00059

MOD-00059INTO variable var was not listed as a formal parameter

Cause:The target of an INTO clause in a SELECT statement is not a parameter ofthe procedure

Action:Declare the parameter using the correct datatype in the procedure'sparameter list.


MOD-00060

MOD-00060PL/SQL error in compiling package specification

Cause:A semantic error occurred in the PL/SQL parse phase when running SQL*Module.

Action:Check that all database objects are valid. To get more information, rerun SQL*Module with OUTPUT=PACKAGE, and check the output PL/SQL code specification file (it has a .pks extension). See the PL/SQL User's Guide and Reference for more information.


MOD-00061

MOD-00061PL/SQL error in compiling package body

Cause:A semantic error occurred in the PL/SQL parse phase when running SQL*Module.

Action:Check that all database objects are valid. To get more information, rerun SQL*Module with OUTPUT=PACKAGE, and check the output PL/SQL code file (it has a .pkb extension). See the PL/SQL User's Guide and Reference for more information.


MOD-00062

MOD-00062host variable for indicator is not recognized

Cause:A host variable that was used as an indicator variable was not declared.

Action:Declare the host variable or, if possible, remove the indicator variable from the SQL statement.


MOD-00063

MOD-00063procedure name, parameter param: illegal interface type type

Cause:When attempting to generate an interface procedures (stubs) file, the WITH INTERFACE PROCEDURE clause in the referenced stored package or stored procedure contained a parameter having an illegal datatype.

Action:Correct the datatype. Datatypes in a WITH INTERFACE clause must be SQL datatypes, not PL/SQL datatypes.


MOD-00064

MOD-00064procedure name: extra parameter param in interface

Cause:An unused parameter was declared in the WITH INTERFACE clause of a stored package or a stored procedure.

Action:Correct the WITH INTERFACE clause in the package.


MOD-00066

MOD-00066unable to load package name from database

Cause:The package name that was specified using the PNAME option is not correct, or SQL*Module could not access the database schema required.

Action:Check that the specified package exists and has a valid status. Check the STATUS column of the USER_OBJECTS table for that schema to check that the package is valid.


MOD-00067

MOD-00067package name is required but not specified

Cause:The options and values RPC_GENERATE=YES and STORE_PACKAGE=YES were specified, but a package name using the PNAME option was not specified.

Action:Add the PNAME option.


MOD-00068

MOD-00068could not find or open system configuration file

Cause:This is a warning message. SQL*Module is not able to find the system configuration file or is not able to open the file. The location of the system configuration file is system specific. See your operating system-specific documentation for the location on your system.

Action:Check that the file exists and that read permission or the appropriate access rights are set for it. The file must exist to avoid this warning message; however, it can be empty.


MOD-00069

MOD-00069Oracle error N while attempting to store package

Cause:SQL*Module's attempt to store the package in the database failed.

Action:Look up the error number in this manual and correct the problem.


MOD-00070

MOD-00070procedure name interface is missing declaration for indvar

Cause:An indicator variable was specified in the WITH INTERFACE clause, but the associated main variable was not declared there.

Action:Modify the WITH INTERFACE clause. Either remove the indicator variable or declare a host variable for it.


MOD-00072

MOD-00072PNAME option is specified but not meaningful

Cause:The PNAME option was used when there was no need for it. The PNAME option is only required when you specify RPC_GENERATE, STORE_PACKAGE, or both.

Action:Correct the command line.


MOD-00073

MOD-00073INAME option is specified but not meaningful

Cause:The INAME option was used when it was not required. For example, INAME is not required when RPC_GENERATE=YES and the PNAME option are specified.

Action:Do not use the INAME option.


MOD-00074

MOD-00074ONAME option is specified but not meaningful

Cause:The ONAME option was used when it was not required. For example, the ONAME option is not required when RPC_GENERATE=NO, and STORE_PACKAGE=YES, or the OUTPUT values list does not contain theCODE value.

Action:Do not use the ONAME option.

#


MOD-00075

MOD-00075error at line N. PLS-N: text

Cause:A semantic error occurred in the PL/SQL parse phase when running SQL*Module.

Action:Check that all database objects are valid. To get more information, rerun SQL*Module with OUTPUT=PACKAGE, and check the output PL/SQL code file (it has a .pkb extension). See the PL/SQL User's Guide and Reference for more information


MOD-00076

MOD-00076ANSI violation at line N. PLS-N: text

Cause:FIPS=YES was specified and part of the module code is not compliant with the ANSI SQL92 Entry Level standard.

Action:Specify FIPS=NO (the default) or correct the code.


MOD-00077

MOD-00077mandatory parameter SQLCODE or SQLSTATE is missing

Cause:Include a status parameter ¾ SQLCODE, SQLSTATE, or both ¾ in every parameter definition.

Action:Include SQLCODE or SQLSTATE.


MOD-00078

MOD-00078must specify a user if generating stubs from stored package

Cause:Because no USERID was specified, SQL*Module cannot connect to the server to create stubs (an interface procedures file) from the stored package.

Action:Specify the service name (if not connecting to the default database), and the username and password. Do this either on the command line or in a configuration file.


MOD-00079

MOD-00079SQLCHECK must be SEMANTICS when RPC_GENERATE=yes

Cause:SQLCHECK=SYNTAX (or SQLCHECK=NONE) cannot be specified when creating a stubs file.

Action:Remove the SQLCHECK=SYNTAX or SQLCHECK=NONE specification from the command line or the configuration file.


MOD-00080

MOD-00080error extracting stored package source.

Cause:OUTPUT=PACKAGE was requested on the command line or in a configuration file, and a package of the name specified does not exist in the schema or is marked as INVALID.

Action:Check that the named package exists and is valid.


MOD-00081

MOD-00081failed assertion

Cause:Some part of the input to SQL*Module caused an error or warning condition. This message always follows a specific error or warning message.

Action:No action required for this message. Correct the previous errors.


MOD-00086

MOD-00086error: couldn't install username. Aborted...

Cause:The server rejected a username.

Action:If the username is valid, contact customer support.


MOD-00088

MOD-00088feature not implemented yet

Cause:SQL*Module encountered a SQL statement that it can compile, but that uses a feature not yet implemented.

Action:Contact Oracle Languages Product Management.


MOD-00093

MOD-00093SNAME option is specified but not meaningful

Cause:The SNAME option was used when it was not required. For example, no SNAME option is required if the values list of the OUTPUT option does not include the value SPECIFICATION.

Action:Do not use the SNAME option.


MOD-00094

MOD-00094extension in PNAME option is specified but not meaningful

Cause:A filename extension was included in the value of a PNAME option. Packages are database objects, not files.

Action:Remove the extension.


MOD-00095

MOD-00095Datatype "X" is not valid for the host language

Cause:A datatype was used that is not supported for the host language. For example, NUMERIC is not a supported datatype for Ada and C.

Action:Refer to the Programmer's Guide to the Oracle Precompilers for a list of the datatypes supported in each host language.


MOD-00096

MOD-00096LNAME option is specified but not meaningful

Cause:The OUTPUT option list does not contain the value LIST.

Action:Add LIST to the list of values of the OUTPUT option.


MOD-00097

MOD-00097WITH INTERFACE must be specified for this host language

Cause:A PL/SQL package or function specification did not have a WITH INTERFACE clause. Currently, MODADA requires the WITH INTERFACE clause to be present in order to create calls to a PL/SQL function or package.

Action:Rewrite PL/SQL package or function specification to include a WITH INTERFACE clause. Alternatively, write a PL/SQL package or function specification which has a WITH INTERFACE clause and have it call the original PL/SQL package.


MOD-00098

MOD-00098WITH INTERFACE may only be defaulted when bind=late

Cause:A Command line option, "bind=early" was specified while creating calls to a PL/SQL package or function without a WITH INTERFACE clause.

Action:Change the command line option to "bind=late", or include a WITH INTERFACE clause in the PL/SQL specification (see error 97 action).


MOD-00099

MOD-00099type name is invalid when storing a module (store=yes)

Cause:The module contained a type for which there is currently no equivalentPL/SQL type; it may not be stored in the database.

Action:Set the command line option to STORE=NO or move the procedurescontaining the offending type to another module and compile that modulewith STORE=NO.


ORA-00001

ORA-00001unique constraint table.column violated

Cause:An update or insert statement attempted to insert a duplicate key.

Action:Either remove the unique restriction or do not insert the key.

For Trusted Oracle7 configured in DBMS MAC mode, you may see this message if a duplicate entry exists at a different level.


ORA-00017

ORA-00017session requested to set trace event

Cause:The current session was requested to set a trace event by another session.

Action:This is used internally; no action required.


ORA-00018

ORA-00018maximum number of sessions exceeded

Cause:An operation requested a resource that was unavailable. The maximum number of sessions is specified by the initialization parameter SESSIONS. When this maximum is reached, no more requests are processed.

Action:Try the operation again in a few minutes. If this message occurs often, shut down Oracle, increase the SESSIONS parameter in the initialization parameter file, and restart Oracle.


ORA-00019

ORA-00019maximum number of session licenses exceeded

Cause:All licenses are in use.

Action:Call customer support before increasing the number of session licenses.


ORA-00020

ORA-00020maximum number of processes num exceeded

Cause:An operation requested a resource that was unavailable. The maximum number of processes is specified by the initialization parameter PROCESSES. When this maximum is reached, no more requests are processed.

Action:Try the operation again in a few minutes. If this message occurs often, shut down Oracle, increase the PROCESSES parameter in the initialization parameter file, and restart Oracle.


ORA-00021

ORA-00021session attached to some other process; cannot switch session

Cause:The user session is currently being used by someone else.

Action:Do not execute calls in a user session concurrently.


ORA-00022

ORA-00022invalid session id; access denied

Cause:Either the session specified does not exist or the caller does not have the privilege to access it.

Action:Specify a valid session ID. This requires ownership of the session id or the CHANGE_USER privilege.


ORA-00023

ORA-00023session references process' private memory; cannot detach session

Cause:An attempt was made to detach the current session, which contains references to the process' private memory.

Action:A session may contain references to process memory (PGA) if it has an open network connection, a very large context area, or operating system privileges. To allow the detach, it may be necessary to close the session's database links and/or cursors. Detaching a session with operating system privileges is always disallowed.


ORA-00024

ORA-00024logins from more than one process not allowed in single-process mode

Cause:An attempt was made to log in more than once from different processes after ORACLE had been started in single-process mode.

Action:When ORACLE is running in single-process mode, log off from the previous process before trying to log in from another one.


ORA-00025

ORA-00025failed to allocate num

Cause:An allocation failed because ORACLE ran out of memory.

Action:Restart ORACLE with a larger SGA heap.


ORA-00026

ORA-00026missing or invalid session id

Cause:The session ID string specified in the ALTER SYSTEM KILL SESSION command was invalid, or no string was specified.

Action:Attempt the command again with a valid session ID.


ORA-00027

ORA-00027cannot kill current session

Cause:An attempt was made to kill the current session with the ALTER SYSTEM KILL SESSION command.

Action:If it is necessary to kill the current session, do so from another session.


ORA-00028

ORA-00028session has been killed

Cause:A privileged user killed the session and it is no longer logged in to the database.

Action:Contact the database administrator; the administrator may be attempting to perform an operation that requires users to be logged out. When the database administrator announces that the database is again available, log in again and resume work.


ORA-00029

ORA-00029session is not a user session

Cause:The session specified in the ALTER SYSTEM KILL SESSION command was not a user's session ID. For example, the session may be recursively started.

Action:Enter the command again with a valid session ID.


ORA-00030

ORA-00030session does not exist

Cause:The session ID specified in the ALTER SYSTEM KILL SESSION command does not exist. The user may have logged out since the command was issued.

Action:No user action is required.


ORA-00050

ORA-00050O/S message occurred while obtain an enqueue. See O/S message.

Cause:Could not obtain the operating system resources necessary for an ORACLE enqueue. This most often occurs when the user resource quota on the operating system is too low.

Action:Look up the operating system message in the system documentation and perform the needed action.


ORA-00032

ORA-00032invalid session migration password

Cause:The session migration password specified in a session creation call was invalid (probably too long).

Action:Retry with a valid password, less than 30 characters.


ORA-00033

ORA-00033current session has empty migration password

Cause:An attempt was made to detach or clone the current session, and it has an empty migration password. This is not allowed.

Action:Create the session with a non-empty migration password.


ORA-00034

ORA-00034cannot COMMIT or ROLLBACK in current PL/SQL session

Cause:An attempt was made to ROLLBACK from a PL/SQL object (procedure, function, package) in a session where COMMIT and ROLLBACK are disabled by an ALTER SESSION DISABLE COMMIT IN PROCEDURE statement.

Action:Enable COMMITs from PL/SQL in this session or do not attempt a COMMIT or ROLLBACK when disabled.


ORA-00035

ORA-00035LICENSE_MAX_USERS cannot be less than current number of users

Cause:Specified value for LICENSE_MAX_USERS is less than current numberof users.

Action:Check the license limit and drop extra users or purchase more licenses.


ORA-00036

ORA-00036Maximum number of recursive SQL levels num exceeded

Cause:An attempt was made to go more than the specified number of recursive SQL levels.

Action:Remove the recursive SQL, possibly a recursive trigger.


ORA-00050

ORA-00050O/S error occurred while obtaining an enqueue. See O/S error

Cause:Could not obtain the operating system resources necessary for an Oracle enqueue. This most often occurs when the user resource quota on the operating system is too low.

Action:Look up the operating system error in the operating-system-specific Oracle documentation and perform the needed action.


ORA-00051

ORA-00051time-out occurred while waiting for resource

Cause:This message is usually caused by an instance that has terminated abnormally.

Action:Check for any non-recovered instances; then restart them.


ORA-00052

ORA-00052maximum number of enqueue resources (num) exceeded

Cause:An operation requested a resource that was unavailable. The maximum number of enqueue resources is specified by the initialization parameter ENQUEUE_RESOURCES. When this maximum is reached, no more requests are processed.

Action:Try the operation again in a few minutes. If this message occurs often, shut down ORACLE, increase the ENQUEUE_RESOURCES parameter in the initialization parameter file, and restart ORACLE.


ORA-00053

ORA-00053maximum number of enqueues exceeded

Cause:An operation requested a resource that was unavailable and the enqueue list for the resource had reached its maximum length. If a request is made for a resource that is unavailable, the request is enqueued to wait for the resource. The number of requests that may be queued for a given resource is specified by the initialization parameter ENQUEUE_RESOURCES. When this maximum is reached, no more requests may be added to the enqueue list.

Action:Try the operation again in a few minutes. If this message occurs often, shut down ORACLE, increase the ENQUEUE_RESOURCES parameter in the initialization parameter file, and restart ORACLE.


ORA-00054

ORA-00054resource busy and acquire with NOWAIT specified

Cause:The NOWAIT keyword forced a return to the command prompt since a resource was unavailable for a LOCK TABLE or SELECT FOR UPDATE command.

Action:Either, try the command after a few minutes, or, to wait for the resource, enter the command without the NOWAIT keyword.


ORA-00055

ORA-00055maximum number of DML locks exceeded

Cause:An operation requested a resource that was unavailable. The maximum number of DML locks is specified by the DML_LOCKS parameter in the initialization parameter file. When this maximum is reached, no more requests are processed.

Action:Try the operation again in a few minutes. If this message occurs often, shut down ORACLE, increase the DML_LOCKS parameter in the initialization parameter file, and restart ORACLE.


ORA-00056

ORA-00056DDL lock on object 'str.name' already held in an incompatible mode

Cause:The attempted lock is incompatible with the DDL lock already held on the object. This usually occurs when attempting to drop a table that has parse locks.

Action:Before attempting to drop a table, make sure it has no parse locks. Wait a few minutes before retrying the operation.


ORA-00057

ORA-00057maximum number of DDL locks exceeded

Cause:System has run out of DDL locks.

Action:Increase DDL lock parameter and warm start.


ORA-00058

ORA-00058DB_BLOCK_SIZE must be num to mount this database (not num)

Cause:The DB_BLOCK_SIZE parameter value in the initialization parameter file used to start a database does not match the value used when that database was created.

Potential reasons for this mismatch are:

1) mounting the wrong database

2) using the wrong initialization parameter file

3) the DB_BLOCK_SIZE value was changed.

Action:For one of the above causes, either:

1) mount the correct database

2) use the correct initialization parameter file

3) correct the DB_BLOCK_SIZE parameter value


ORA-00059

ORA-00059maximum number of DB_FILES exceeded

Cause:An unavailable resource was requested. The maximum number of data files is specified by the DB_FILES parameter in the initialization parameter file. When this maximum is reached, no more requests are processed.

Action:Try again when the resource is freed. If this message occurs often, ORACLE must be shut down and restarted after increasing the DB_FILES parameter in the initialization parameter file. If the DB_FILES parameter cannot be changed because it is already set to the MAXDATAFILES parameter value (set at database creation), you must create a new control file.


ORA-00060

ORA-00060deadlock detected while waiting for resource

Cause:The active session and another session are each waiting for a resource locked by the other. This condition is known as a deadlock. In order to resolve the deadlock, one or more statements were rolled back so the other session could continue work.

Action:Either:

1) issue a ROLLBACK statement and re-execute all statements since the last commit

2) wait until the lock is released (possibly a few minutes) and re-execute the rolled back statements


ORA-00061

ORA-00061another instance has a different DML_LOCKS setting

Cause:The shared instance being started is using DML locks and the running instances are not, or vice versa.

Action:Either:

1) to not use DML_LOCKS, for all instances set DML_LOCKS to zero

2) to use DML_LOCKS, for all instances set DML_LOCKS to a positive integer


ORA-00063

ORA-00063LOG_FILES initialization parameter exceeded

Cause:LOG_FILES initialization parameter was exceeded.

Action:Increase the LOG_FILES parameter in the initialization parameter file and restart ORACLE. If this parameter cannot be increased because it would exceed the MAXLOGFILES set at database creation, you must create a new control file first.


ORA-00063

ORA-00063LOG_FILES initialization parameter exceeded

Cause:The value of the LOG_FILES initialization parameter was exceeded.

Action:Increase the value of LOG_FILES and warm start Oracle. The value needs to be as large as the highest number log that currently exists rather than just the count of the logs that exist. If this parameter cannot be increased because it would exceed the MAXLOGFILES set at database creation, you must create a new control file first.


ORA-00064

ORA-00064object is too large to allocate on this O/S ('num, num')

Cause:The initialization parameter DB_BLOCK_SIZE is set to a value that calls for more contiguous space than can be allocated on the operating system being used.


ORA-00065

ORA-00065initialization of FIXED_DATE failed

Cause:An attempt was made to enter a fixed date string that was not in the proper format.

Action:Enter the date string using the format YYYY-MM-DD:HH24:MI:SS.


ORA-00066

ORA-00066LOG_FILES is var buts needs to be var to be compatible

Cause:The maximum number of redo log files supported by this instance is not the same as for the other instances. All instances must be able to open all the files any instance can open.

Action:Ensure LOG_FILES initialization parameter is same for all instances.


ORA-00067

ORA-00067invalid value var for parameter var, must be at least var

Cause:The value for the initialization parameter is invalid.

Action:Choose a value as indicated by the message. Change the value of the LOG_FILES parameter to be compatible


ORA-00068

ORA-00068invalid value var for parameter var, must be between var and var

Cause:The value for the initialization parameter is invalid.

Action:Choose a value as indicated by the message.

________________________________________


ORA-00097

ORA-00097use of Oracle SQL feature not in SQL92 compliance level

Cause:You tried to use an Oracle SQL feature that is not compliant with the SQL92 standard.

Action:Do not use the feature or use the ALTER SESSION SET FLAGGER command to set the appropriate level of SQL92 compliance.


ORA-00070

ORA-00070command name is not valid

Cause:An invalid debugger command was specified.

Action:Type HELP to see the list of available commands.


ORA-00071

ORA-00071process number must be between 1 and num

Cause:An invalid process number was specified.

Action:Specify a valid process number.


ORA-00072

ORA-00072process \

Cause:An invalid process was specified.

Action:Specify a valid process.


ORA-00073

ORA-00073command name takes between num1 and num2 argument(s)

Cause:An incorrect number of arguments was specified.

Action:Specify the correct number of arguments. Type HELP to see the list of commands and their syntax.


ORA-00074

ORA-00074no process has been specified

Cause:No debug process has been specified.

Action:Specify a valid process.


ORA-00075

ORA-00075process \

Cause:The specified process was not logged on to the current instance.

Action:Specify a valid process.


ORA-00076

ORA-00076dump name not found

Cause:An attempt was made to invoke a dump which doesn't exist.

Action:Type DUMPLIST to see the list of available dumps.


ORA-00077

ORA-00077dump name is not valid

CauseAn attempt was made to invoke an invalid dump.

Action:Try another dump.


ORA-00079

ORA-00079variable var not found

Cause:An attempt was made to dump a variable which doesn't exist.

Action:Use a valid variable name.


ORA-00080

ORA-00080invalid global area specified by level num

Cause:An attempt was made to dump an invalid global area.

Action:Use level 1 for the PGA, 2 for the SGA, and 3 for the UGA. Use <extra + level> to dump global are a as well as <extra> bytes for every pointer; <extra> must be a multiple of 4.


ORA-00081

ORA-00081address range [num1, num2) is not readable

Cause:An attempt was made to read/write an invalid memory address range.

Action:Try another address or length.


ORA-00082

ORA-00082memory size of num is not in valid set of [1], [2], [4]num1num2num3num4num5

Cause:An invalid length was specified for the POKE command.

Action:Use a valid length (either 1, 2, 4, or possibly 8).


ORA-00083

ORA-00083warning: possibly corrupt SGA mapped

Cause:Even though there may be SGA corruptions, the SGA was mapped.

Action:Use the "dumpsga" command to dump the SGA.


ORA-00084

ORA-00084global area must be PGA, SGA, or UGA

Cause:An attempt was made to dump an invalid global area.

Action:Specify either PGA, SGA, or UGA.


ORA-00085

ORA-00085current call does not exist

Cause:An invalid attempt was made to dump the current call heap.

Action:Wait until the process starts a call.


ORA-00086

ORA-00086user call does not exist

Cause:An invalid attempt was made to dump the user call heap.

Action:Wait until the process starts a call.


ORA-00099

ORA-00099timed out while waiting for resource, potential PDML deadlock

Cause:The resource needed by the transaction was busy. The PDML transaction could not acquire the resource within the specified amount of time. This indicates potential deadlock involving this PDML transaction and other transactions currently running in the system.

Action:Increase the value of the PARALLEL_TRANSACTION_RESOURCE_TIMEOUT parameter, then retry the operation.


ORA-00100

ORA-00100idle public server terminating

Cause:There are too many idle shared servers waiting on the common dispatcher request queue.

Action:No action required.


ORA-00101

ORA-00101invalid specification for initialization parameter MTS_DISPATCHERS

Cause:The syntax for the MTS_DISPATCHERS parameter is incorrect.

Action:Enter the MTS_DISPATCHERS parameter into the initialization parameter file with the correct syntax, and then shut down and restart the instance.


ORA-00102

ORA-00102network protocol ('str') cannot be used by the dispatchers

Cause:The network specified in MTS_DISPATCHERS initialization parameter does not have the functionality required by the dispatchers.

Action:Refer to the installation or user's guide for network protocols supported by the dispatchers.


ORA-00103

ORA-00103invalid network protocol; reserved for use by dispatchers

Cause:The network specified in SQL*Net CONNECT string is reserved for use by the dispatchers.

Action:Specify other network protocols in the CONNECT string.


ORA-00104

ORA-00104deadlock detected; all public servers blocked waiting for resource

Cause:This message occurs when a client locks a resource, and then the maximum number of shared servers are taken by other clients who are requesting a locked resource. The original client would then be unable to get a shared server, and thus be unable to release the lock on the resource.

Action:The system automatically starts up new servers to break the deadlock until the number of servers reaches the value specified in MTS_MAX_SERVERS. If the maximum number of servers is reached, and if this problem occurs frequently, increase the limit for the initialization parameter MTS_SERVERS or MTS_MAX_SERVERS so that more shared servers are started up as the system restarts.


ORA-00105

ORA-00105dispatching mechanism not configured to support network protocol

Cause:The ALTER SYSTEM SET MTS_DISPATCHERS command was used to alter a set of dispatchers for a network protocol that is not specified in the initialization parameter file.

Action:Either:

1..include the network protocol in the MTS_DISPATCHERS initialization parameter and restart the system

2..use the ALTER SYSTEM SET MTS_DISPATCHERS command with a network protocol that exists in the initialization parameter file


ORA-00106

ORA-00106cannot startup/shutdown database when connected to a dispatcher

Cause:An attempt was made to start up or shut down an instance while connected to a shared server process via a dispatcher.

Action:Reconnect to the database using a dedicated server.


ORA-00107

ORA-00107failed to connect to network listener process

Cause:Usually caused by the fact that the network listener process has not been started.

Action:Check for the following:

·The network configuration file is not set up correctly.

·The client side address is not specified correctly.

·The listener initialization parameter file is not set up correctly.


ORA-00108

ORA-00108failed to set up dispatcher to accept connection asynchronously

Cause:The network protocol used by the dispatcher does not support asynchronous operations.

Action:Contact Worldwide Customer Support.


ORA-00110

ORA-00110missing value for initialization parameter MTS_LISTENER_ADDRESS

Cause:There is no value for the MTS_LISTENER_ADDRESS initialization parameter.

Action:Specify one or more valid SQL*Net Version 2 addresses for the listener process.


ORA-00111

ORA-00111Warning: maximum number of servers is only num; adding num servers

Cause:An attempt was made to start more shared server processes than the number allowed by the initialization parameter MTS_MAX_SERVERS. The actual number of shared servers started is specified in the message.

Action:If more shared server processes are required, increase the initialization parameter MTS_MAX_SERVERS; then restart the instance.


ORA-00112

ORA-00112only created up to num (maximum specified) dispatchers

Cause:An attempt was made to start up more dispatchers than the maximum number specified by the initialization parameter MTS_MAX_DISPATCHERS.

Action:If more dispatchers are required, increase MTS_MAX_DISPATCHERS, restart the instance, and add dispatchers using the ALTER SYSTEM MTS_DISPATCHERS command.


ORA-00113

ORA-00113protocol name string is too long

Cause:A protocol name specified in the MTS_DISPATCHERS initialization parameter is too long.

Action:Use a valid protocol name for the MTS_DISPATCHERS initialization parameter.


ORA-00114

ORA-00114missing value for initialization parameter MTS_SERVICE

Cause:There is no value for the MTS_SERVICE initialization parameter, nor for the DB_NAME parameter.

Action:Add an MTS_SERVICE or DB_NAME definition to the initialization parameter file. By default, MTS_SERVICE is the value of DB_NAME unless MTS_SERVICE is explicitly specified.


ORA-00115

ORA-00115connection refused; dispatcher connection table is full

Cause:A connection request was refused by a dispatcher because the dispatcher cannot support any more connections.

Action:Connect to a different dispatcher, or use a dedicated server.


ORA-00116

ORA-00116MTS_SERVICE name is too long

Cause:The service name specified in the MTS_SERVICE initialization parameter is too long.

Action:Use a shorter name for the MTS_SERVICE value (maximum is 255 characters).


ORA-00117

ORA-00117value out of range for the MTS_SERVERS system parameter

Cause:The value of the MTS_SERVERS parameter is incorrect.

Action:The MTS_SERVERS parameter must be from 0 to MTS_MAX_SERVERS.


(Untitled)

00150-00159: Oracle*XA


ORA-00119

ORA-00119invalid specification for system parameter MTS_LISTENER_ADDRESS

Cause:The syntax for the MTS_LISTENER_ADDRESS is incorrect.

Action:Refer to the Oracle7 Server Administrator's Guide for the correct syntax.


ORA-00120

ORA-00120dispatching mechanism not enabled or installed

Cause:Either the dispatcher is not enabled or the ORACLE executable image is not installed with the dispatching mechanism.

Action:Refer to the ORACLE7 Server Administrator's Guide and the installation or user's guide for procedures for starting and configuring the dispatcher processes.

________________________________________


ORA-00121

ORA-00121MTS_SERVERS specified without MTS_DISPATCHERS

Cause:A definition for MTS_SERVERS was specified in the INIT.ORA file, but no definition for MTS_DISPATCHERS was specified. If no value is specified for MTS_DISPATCHERS, shared servers will not be used.

Action:Add a definition for MTS_DISPATCHERS in the INIT.ORA file. If you do not intend to use shared servers, remove the MTS_SERVERS definition.


ORA-00122

ORA-00122cannot initialize network configuration

Cause:Oracle could not initialize SQL*Net Version 2.

Action:See accompanying messages.


ORA-00123

ORA-00123idle public server terminating

Cause:Too many idle servers were waiting on the common queue.

Action:This is used internally, no action required.


ORA-00124

ORA-00124MTS_DISPATCHERS specified without MTS_MAX_SERVERS

Cause:A definition for MTS_DISPATCHERS was specified in the INIT.ORA file, but MTS_MAX_SERVERS was specified as zero.

Action:Specify MTS_MAX_SERVERS to be greater than zero.


ORA-00150

ORA-00150duplicate transaction ID

Cause:Attempted to start a new transaction with an ID already in use by an existing transaction.

Action:Check your application.


ORA-00151

ORA-00151invalid transaction ID

Cause:The specified transaction ID does not correspond to an existing valid transaction.

Action:Check your application.


ORA-00152

ORA-00152current session does not match requested session

Cause:The current session is not the same as the session that was passed into a UPIXADO() call.

Action:Check your application.

________________________________________


ORA-00153

ORA-00153internal error in XA library

Cause:The XA library could not access thread-specific pointers.

Action:Contact customer support.


ORA-00154

ORA-00154protocol error in transaction monitor

Cause:The transaction monitor returned TMJOIN on an AX_REG call but the transaction was locally suspended.

Action:Contact the transaction monitor customer support.


ORA-00155

ORA-00155cannot perform work outside of global transaction

Cause:The application tried to perform some work on an Oracle 7.3 server outside of a global transaction.

Action:Check if the application is connected to an Oracle 7.3 server. The Transaction monitor must not return a NULL XID on an AX_REG call when the resource manager is Oracle 7.3.


ORA-00161

ORA-00161transaction branch length num is illegal (maximum allowed num

Cause:An external transaction branch id with a length either too large or 0 was passed in.

Action:Report the problem to your external transaction coordinator vendor.


ORA-00162

ORA-00162external dbid length num is greater than maximum num

Cause:An external data base name with too large a length field was passed in.

Action:Report the problem to your external transaction coordinator vendor.


ORA-00163

ORA-00163internal database name length num is greater than maximum num

Cause:An internal data base name with too large a length field was passed in.

Action:Report the problem to your external transaction coordinator vendor.


ORA-00200

ORA-00200cannot create control file 'name'

Cause:The control file cannot be created, usually because of insufficient disk storage or file name conflicts.

Action:Ensure that there is sufficient disk space and there are no conflicts in file names; then try to create the control file again.


ORA-00201

ORA-00201control file version num incompatible with ORACLE version num

Cause:The control file was created by incompatible software.

Action:Either restart with a compatible software release or use CREATE CONTROLFILE to create a new control file that is compatible with this release.


ORA-00202

ORA-00202control file: 'name'

Cause:This message reports the name of the file involved in other messages.

Action:See the associated messages for a description of the problem.


ORA-00203

ORA-00203using the wrong control files

Cause:The mount ID in the control file is not the same as the mount ID in the control file used by the first instance to mount this database. The control files are for the same database but they are not the same files. The most likely cause is one instance is using a backup of the control file. If you want to use a backed up control file, you can recover using the USING BACKUP CONTROLFILE option.

Action:Check that all instances are using the correct version of the control file.


ORA-00204

ORA-00204message in reading control file 'name' (block num, # blocks num)

Cause:A disk read-failure occurred while attempting to read the specified control file. The block location of the failure is given.

Action:Make sure the disk is online. If it is not, bring it online; then shut down and restart ORACLE. If the disk is online, then look for operating system reasons for ORACLE's inability to read the disk or control file. Refer to the ORACLE7 Server Database Administrator's Guide for information about recovering from the loss of a control file.


ORA-00205

ORA-00205message in identifying control file 'name'

Cause:The system could not find a control file of the specified name and size.

Action:Either:

1) Ensure the proper control file name is referenced in the CONTROL_FILES initialization parameter in the initialization parameter file and try again.

2) When using mirrored control files (that is, more than one control file is referenced in the initialization parameter file), remove the control file name listed in the message from the initialization parameter file, and restart the instance. If the message does not recur, remove the problem control file from the initialization parameter file and create another copy of the control file using a new file name in the initialization parameter file.


ORA-00206

ORA-00206message in writing control file 'name' (block num, # blocks num)

Cause:A disk write-failure occurred while attempting to write to the specified control file. The block location of the failure is given.

Action:Make sure the disk is online. If it is not, bring it online; then shut down and restart ORACLE. If the disk is online, then look for operating system reasons for ORACLE's inability to write to the disk or control file. Refer to the ORACLE7 Server Administrator's Guide for information on recovering from the loss of a control file.


ORA-00207

ORA-00207control files are not for the same database

Cause:The database ID in the control file is not the same as the database ID in the control file used by the first instance to mount this database. The most likely cause is either that one of the mounts used the wrong control file, or there are two databases with the same name.

Action:Check that the control file is for the correct database and not an old version. When using multiplexed control files (that is, more than one control file is referenced in the initialization parameter file), remove the control file name listed in the message from the initialization parameter file, and restart the instance. If the message does not recur, remove the problem control file from the initialization parameter file and create another copy of the c


ORA-00208

ORA-00208number of control file names exceeds limit of num

Cause:An attempt was made to use more control files than ORACLE supports. The limit is given in the message.

Action:Shut down ORACLE, reduce the number of control file names specified in the CONTROL_FILES parameter in the initialization parameter file, and restart ORACLE. Delete unused files.


ORA-00209

ORA-00209block size num exceeds limit of num bytes

Cause:A block size larger than that allowed by the operating system was specified.

Action:Reduce the block size to the amount specified in the message; then try again.


ORA-00210

ORA-00210cannot open control file 'name'

Cause:The system was unable to open a control file.

Action:Make sure the control file exists, that the storage device is online, and that the file is not locked by some other program; then try again. Also, check to see that the operating system limit on the number of open files per process has not been exceeded.

When using multiplexed control files (that is, more than one control file is referenced in the initialization parameter file), remove the parameter from the initialization parameter file referencing the control file name indicated in the message and restart the instance. If the message does not recur, remove the problem control file from the initialization parameter file and create another copy of the control file using a new file name in the initialization parameter file.


ORA-00211

ORA-00211control file 'name' does not match previous control files

Cause:The specified control file is from another database.

Action:Locate and specify the correct control file for this database, then retry the operation. When using multiplexed control files (that is, more than one control file is referenced in the initialization parameter file), remove the control file name listed in the message from the initialization parameter file, and restart the instance. If the message does not recur, remove the problem control file from the initialization parameter file and create another copy


ORA-00212

ORA-00212block size num below minimum required size of num bytes

Cause:The specified block size is too small; additional space is needed for system overhead.

Action:Specify a larger block size; then retry the operation.


ORA-00213

ORA-00213cannot reuse control file 'name'; old file size num, num required

Cause:To reuse a control file, it must be the same size as the previous one used.

Action:In the CREATE DATABASE statement, do not specify REUSE.


ORA-00214

ORA-00214control file 'name' version num inconsistent with file 'name' version num

Cause:An inconsistent set of control files, data files, and redo log files was used.

Action:Use a consistent set of control files, data files, and redo log files. That is, all the files must be for the same database and from the same time period.


ORA-00215

ORA-00215must be at least one control file

Cause:No control file was specified, or the control file specified does not exist.

Action:Specify at least one valid control file; then retry the operation.


ORA-00216

ORA-00216unable to determine physical block size for control file 'name'

Cause:An error occurred while determining the physical block size of the specified control file.

Action:Check the accompanying message stack for more detailed information.


ORA-00217

ORA-00217control file 'name' physical block size num inconsistent with num

Cause:The physical block size of the operating system is inconsistent with the block size of the control file.

Action:The system will not operate with invalid control files. Either restore a valid control file or re-create the database. When using multiplexed control files (that is, more than one control file is referenced in the initialization parameter file), remove the control file name listed in the message from the initialization parameter file, and restart the instance. If the message does not recur, remove the problem control file from the initialization paramete


ORA-00218

ORA-00218control file 'name' was created with physical size num now is num

Cause:The control file size specified in the file's header differs from the physical block size of the control file. This usually means that the control file has been corrupted.

Action:Recover the control file as described in the ORACLE7 Server Administrator's Guide.


ORA-00219

ORA-00219required control file size num larger than maximum num

Cause:The CREATE DATABASE statement specified a combination of initialization parameters that results in the control file exceeding the internal maximum size.

Action:You must re-create the database. In the CREATE DATABASE statement use lower for clauses such as MAXDATAFILES and MAXLOGFILES as described in the ORACLE7 Server Administrator's Guide.


ORA-00220

ORA-00220control file 'name' not mounted by first instance

Cause:The specified control file has a different mount ID than the other control files that are being mounted. This means that the first instance to mount the database did not use this control file.

Action:Find and use the correct control file.


ORA-00221

ORA-00221error on write to control file

Cause:An error occurred when writing to one or more of the control files.

Action:More descriptive messages will follow this message.


ORA-00222

ORA-00222control file may not be queried using dispatcher

Cause:Attempted to use client process connected to dispatcher. This is not allowed for queries to control file fixed tables due to the memory requirements.

Action:Connect directly to the instance, then execute the query.


ORA-00223

ORA-00223conversion data file is invalid or incorrect version

Cause:A Version 6 to ORACLE7 conversion data file contains invalid data or was created with an old version of the migration utility.

Action:Regenerate the conversion file with the correct version of the migration utility, or use the correct file for converting the database.


ORA-00224

ORA-00224the specified file is not a control file

Cause:The file specified in the initialization parameter file is not a control file.

Action:Edit the initialization parameter file and specify the correct control file name.

________________________________________


ORA-00225

ORA-00225expected size num of controlfile name differs from actual size num

Cause:The expected size of the control file as stored in its header was different than the actual operating system file size of the control file. This usually indicates that the control file was corrupted.

Action:Restore a good copy of the control file. For more information about control files and recovery, see the index entries on "control files," "control files, backing up," "control files, recovery and" in Oracle8 Server Concepts.


ORA-00226

ORA-00226operation disallowed while alternate controlfile open

Cause:The attempted operation cannot be executed at this time because this process has an alternate controlfile open for fixed table access.

Action:Retry the operation after calling cfileUseCurrent.


ORA-00227

ORA-00227corrupt block detected in controlfile: (block num, # blocks num)

Cause:A block header corruption or checksum error was detected on reading the controlfile.

Action:Use the CREATE CONTROLFILE or RECOVER DATABASE USING BACKUP CONTROLFILE command.


ORA-00229

ORA-00229operation disallowed: already hold snapshot controlfile enqueue

Cause:The attempted operation cannot be executed at this time because this process currently holds the snapshot controlfile enqueue.

Action:Retry the operation after calling cfileUseCurrent to release the snapshot controlfile enqueue.


ORA-00230

ORA-00230operation disallowed: snapshot controlfile enqueue unavailable

Cause:The attempted operation cannot be executed at this time because another process currently holds the snapshot controlfile enqueue.

Action:Retry the operation after the concurrent operation that is holding the snapshot controlfile enqueue terminates.


ORA-00231

ORA-00231snapshot controlfile has not been named

Cause:During an invocation of cfileMakeAndUseSnapshot or cfileUseSnapshot it was detected that no filename for the snapshot controlfile had previously been specified.

Action:First specify a name for the snapshot controlfile by calling cfileSetSnapshotName.


ORA-00232

ORA-00232snapshot controlfile is nonexistent, corrupt, or unreadable

Cause:The snapshot controlfile was found to be nonexistent, corrupt, or unreadable during an invocation of cfileUseSnapshot.

Action:Call cfileMakeAndUseSnapshot again (or for the first time).


ORA-00233

ORA-00233copy controlfile is corrupt or unreadable

Cause:The specified copy controlfile was found to be corrupt or unreadable during an invocation of cfileUseCopy.

Action:Before retrying cfileUseCopy, use the ALTER DATABASE BACKUP CONTROLFILE command, specifying the same filename as specified to cfileUseCopy.


ORA-00234

ORA-00234error in identifying or opening snapshot or copy controlfile

Cause:A snapshot or copy controlfile of the specified name could not be found or opened during an invocation of cfileUseSnapshot, cfileMakeAndUseSnapshot, or cfileUseCopy.

Action:Recreate the snapshot or copy controlfile using cfileMakeAndUseSnapshot or ALTER DATABASE BACKUP CONTROLFILE, respectively.


ORA-00235

ORA-00235controlfile fixed table inconsistent due to concurrent update

Cause:Concurrent controlfile update activity caused a query on a controlfile fixed table to read inconsistent information.

Action:Retry the operation.


ORA-00236

ORA-00236snapshot operation disallowed: mounted controlfile is a backup

Cause:An attempt was made to invoke cfileSetSnapshotName, cfileMakeAndUseSnapshot, or cfileUseSnapshot when the currently mounted controlfile is a backup controlfile.

Action:Mount a current controlfile and retry the operation.


ORA-00251

ORA-00251LOG_ARCHIVE_DUPLEX_DEST must be different from LOG_ARCHIVE_DEST

Cause: The destination pointed by the LOG_ARCHIVE_DUPLEX_DEST initialization parameter is the same as the destination pointed by LOG_ARCHIVE_DEST.

Action: Specify a different destination for either LOG_ARCHIVE_DUPLEX_DEST or LOG_ARCHIVE_DEST.


ORA-00250

ORA-00250archiver not started

Cause:An attempt was made to stop automatic archiving, but the archiver process was not running.

Action:None.


ORA-00251

ORA-00251archiving/media recovery requires OS DBA or OPER privileges

Cause:An attempt was made to perform archiving or media recovery without having the required operating system DBA or OPER privileges.

Action:Ask the database administrator to perform the operation or grant the necessary privileges.


ORA-00252

ORA-00252log 'name' of thread num is empty, cannot archive

Cause:The specified redo log has not been used since it was introduced to the database. It is also possible that the instance died during a log switch, and the log was left empty.

Action:Empty logs do not need to be archived. Do not attempt to archive the redo log file.


ORA-00253

ORA-00253limit of num exceeded by length num of archive string 'name'

Cause:The specified archive string is too long; the limit is given in the message.

Action:Use a shorter string, making sure not to exceed the given limit; then try again.


ORA-00254

ORA-00254message in archive control string 'str'

Cause:The specified archive string does not refer to a valid destination.

Action:Make sure the archive string refers to a valid, online device; then retry the operation.


ORA-00255

ORA-00255message archiving log 'name' of thread num, sequence # num

Cause:An message occurred during archiving.

Action:Check the accompanying message stack for more detailed information.


ORA-00256

ORA-00256message occurred in translating archive text string 'str'

Cause:An message occurred while translating the archive control string.

Action:Check the accompanying message stack for more detailed information.


ORA-00257

ORA-00257archiver is stuck. Connect internal only, until freed.

Cause:The ARCH process received an message while trying to archive a redo log file. If the problem is not resolved soon, the database will stop executing transactions. The most likely cause of this message is that the destination device is out of space to store the redo log file.

Action:Check the archiver trace file for a detailed description of the problem. Also, verify that the device specified in the initialization parameter ARCHIVE_LOG_DEST is set up properly for archiving.


ORA-00258

ORA-00258manual archiving in NOARCHIVELOG mode must identify log

Cause:An attempt was made to manually archive a redo log file without specifying the sequence number, group number, or file name while the database is in NOARCHIVELOG mode.

Action:The name, group number, or thread and sequence number of redo log files must be specified when manually archiving redo log files when the database is in NOARCHIVELOG mode.


ORA-00259

ORA-00259log name of open thread num is the current log, cannot archive

Cause:An attempt was made to archive the current log of an open thread. This is not allowed because the redo log file may still be in use for generation of redo entries.

Action:Force a log switch in the instance where the thread is open. If no instances are open, open the database so instance recovery can recover the thread.


ORA-00260

ORA-00260cannot find online log sequence num for thread num

Cause:The log sequence number specified in the ARCHIVE statement does not match any of the online logs for the specified thread. This log might have been reused for another sequence number; it might have been dropped; the sequence number may be greater than the current log sequence number; or the thread may not have any logs.

Action:Check the ARCHIVE statement; then specify a valid log sequence number.


ORA-00261

ORA-00261log name of thread num is being archived, cannot archive

Cause:The log sequence number specified in the ARCHIVE statement is currently being archived.

Action:Check all operating archive processes; then specify a valid log sequence number.


ORA-00262

ORA-00262current log name of closed thread num cannot switch for archiving

Cause:The redo log file cannot be archived because it is the current log of a closed thread. It is not possible to switch redo log files so that another log is current. All other redo log files for this thread must be archived and cannot be reused.

Action:Archive the other redo log files in this thread first.


ORA-00263

ORA-00263there are no logs that need archiving for thread num

Cause:An attempt was made to manually archive the unarchived logs in this thread, but no logs need archiving.

Action:No user action is required.


ORA-00264

ORA-00264no recovery required

Cause:An attempt was made to perform media recovery on files which do not need any type of recovery.

Action:Do not attempt to perform media recovery on the selected files. Check to see that the file names were entered properly; if not, issue the command again with the proper file names.


ORA-00265

ORA-00265instance recovery required, cannot set ARCHIVELOG mode

Cause:The database either crashed or was shut down with the ABORT option. Media recovery cannot be enabled because the online logs may not be sufficient to recover the data files.

Action:Open the database and then issue the SHUTDOWN command with the NORMAL or IMMEDIATE options.


ORA-00266

ORA-00266name of archived logfile needed

Cause:During media recovery, the name of an archived redo log file was requested, but no name was entered.

Action:Mount the correct redo log file and enter its name when it is requested.


ORA-00267

ORA-00267name of archived logfile not needed

Cause:During media recovery, the name of an archived redo log file was entered, but no name was requested.

Action:Continue media recovery, but do not enter a new log name.


ORA-00268

ORA-00268specified logfile does not exist name

Cause:The given redo log file does not exist.

Action:Check the spelling and capitalization of the file name and resubmit the command.


ORA-00269

ORA-00269specified logfile is part of thread num not num

Cause:The given redo log file is not part of the given thread

Action:Check to make sure the thread of the redo log file matches the thread on the command line, if not use a redo log file from the appropriate thread. Resubmit the command after correcting the error.


ORA-00271

ORA-00271there are no logs that need archiving

Cause:An attempt was made to manually archive the unarchived redo log files, but there are no files that need to be archived.

Action:No user action is required.


ORA-00271

ORA-00271there are no logs that need archiving

Cause:An attempt was made to archive the unarchived redo log files manually, but there are no files that need to be archived.

Action:No action required.


ORA-00272

ORA-00272error writing archive log

Cause:An I/O error occurred while archiving a redo log file.

Action:Make sure the output device is still available, and correct any device errors that may have occurred. Also, make certain that sufficient space for archiving is available on the output device.


ORA-00273

ORA-00273media recovery of direct load data that was not logged

Cause:A media recovery session encountered a table that was loaded by the direct loader without logging any redo information. Some or all of the blocks in this table are now marked as corrupt.

Action:The table must be dropped or truncated so that the corrupted blocks can be reused. If a more recent backup of the file is available, try to recover this file to eliminate this error.


ORA-00274

ORA-00274illegal recovery option str

Cause:An illegal option was specified for a recovery command.

Action:Check the syntax of the command and resubmit the command using the correct syntax.


ORA-00275

ORA-00275media recovery has already been started

Cause:An attempt was made to start a second media recovery operation in the same session.

Action:Complete or cancel the first media recovery session, or start another session to perform media recovery.


ORA-00276

ORA-00276CHANGE keyword specified but no change given

Cause:The CHANGE keyword was specified on the command line, but no change number was given.

Action:Resubmit the command using a valid change number after the CHANGE keyword.


ORA-00277

ORA-00277Illegal option to the UNTIL recovery flag str

Cause:Only CANCEL, CHANGE and TIME can be used with the UNTIL keyword.

Action:Correct the syntax.


ORA-00278

ORA-00278logfile 'name' no longer needed for this recovery

Cause:The specified redo log file is no longer needed for the current recovery.

Action:No action required. The archived redo log file may be removed from its current location to conserve disk space, if needed. However, the redo log file may still be required for another recovery session in the future.


ORA-00279

ORA-00279change num generated at name needed for thread num

Cause:The requested log is required to proceed with recovery.

Action:Please supply the requested log in the command, or cancel recovery.


ORA-00280

ORA-00280change num for thread num is in sequence #num

Cause:This message helps to locate the redo log file with the specified change number requested by other messages.

Action:Use the information provided in this message to supply the required archived redo log files for other errors.


ORA-00281

ORA-00281media recovery may not be performed using dispatcher

Cause:An attempt was made to use a dispatcher process for media recovery. Memory requirements disallow this recovery method.

Action:Connect to the instance via a dedicated server process to perform media recovery.


ORA-00282

ORA-00282UPI var %s call not supported, use ALTER DATABASE RECOVER

Cause:The given UPI call is no longer supported.

Action:All recovery operations are made through parsing and executing the "ALTER DATABASE RECOVER..." commands. Refer to the ORACLE7 Server Administrator's Guide for the proper recovery procedures.


ORA-00283

ORA-00283recovery session canceled due to errors.

Cause:An error during recovery was determined to be fatal enough to end the current recovery session.

Action:More specific messages will accompany this message. Refer to the other messages for the appropriate action.


ORA-00284

ORA-00284recovery session still in progress.

Cause:An message during recovery was determined to be minor enough to allow the current recovery session to continue.

Action:More specific messages will accompany this message. Refer to other messages for the appropriate action.


ORA-00285

ORA-00285TIME not given as a string constant

Cause:UNTIL TIME was not followed by a string constant for the time.

Action:Enter the time enclosed in single quotes.


ORA-00286

ORA-00286no members available, or no member contains valid data

Cause:None of the members of a redo log file group are available, or the available members do not contain complete data.

Action:If a member is temporarily offline, attempt to make it available. Make certain that the correct file names are being used, especially if the redo log file is being accessed from a remote location.


ORA-00287

ORA-00287specified change number num not found in thread num

Cause:The given change number does not appear in any of the online redo logs for the given thread.

Action:Check the statement to make certain a valid change number is given. Perhaps try to use the NEXT option for archiving logs.


ORA-00288

ORA-00288to continue recovery type ALTER DATABASE RECOVER CONTINUE

Cause:During media recovery, redo information from a new log is not required but the continuation command is necessary to do a checkpoint and report messages.

Action:Type ALTER DATABASE RECOVER CONTINUE and recovery will resume.


ORA-00289

ORA-00289suggestion : str

Cause:This message reports the next redo log file name that is needed, according to the initialization parameters LOG_ARCHIVE_DEST and LOG_ARCHIVE_FORMAT. This message assumes that LOG_ARCHIVE_DEST and LOG_ARCHIVE_FORMAT are the same now as when the required redo log file was archived.

Action:Consider using this file name for the next log needed for recovery.


ORA-00290

ORA-00290operating system archiving message occurred. See message below

Cause:While attempting to archive to a redo log file, the server encountered and unexpected operating system message.

Action:Correct the operating system message (given in the messages) and retry the operation.

________________________________________


ORA-00291

ORA-00291numeric value required for PARALLEL option

Cause:A recovery command was specified incorrectly. The PARALLEL option must be followed by a numeric argument that specifies the degree of parallelism.

Action:Re-enter the command with a numeric argument specifying the degree of parallelism desired.


ORA-00292

ORA-00292parallel recovery feature not installed

Cause:A parallel recovery was requested when the parallel recovery option is not installed.

Action:Delete the PARALLEL clause from the RECOVER command. Also, delete the RECOVERY_PARALLELISM parameter in the initialization file.


ORA-00293

ORA-00293control file out of sync with redo log

Cause:The redo log and control file are out of sync because a non-current control file was specified when the instance was started.

Action:Retry the Recover command using the current control file or retry the Recover command using the USING BACKUP CONTROL FILE clause.


ORA-00294

ORA-00294invalid archivelog format specifier name

Cause:An invalid format specifier was found in the LOG_ARCHIVE_FORMAT initialization parameter. The only characters permitted following the % symbol are s, S, t, and T.

Action:Correct the initialization file and re-start the instance.


ORA-00295

ORA-00295datafile number num is invalid, must be between 1 and num

Cause:An invalid file number was specified.

Action:Specify a correct datafile number and retry the operation.


ORA-00300

ORA-00300illegal redo log block size num specified -exceeds limit of num

Cause:The specified block size of the redo log file is greater than the maximum block size for the operating system.


ORA-00301

ORA-00301message in adding logfile 'name' - file cannot be created

Cause:The creation of the redo log file failed.

Action:Make sure there is enough storage space on the device, that the name of the file is valid, and that the device is online; then try again.

Also, it is possible REUSE was specified on the command line and a file of the incorrect size exists. Either do not specify REUSE or use a file of the correct size.


ORA-00302

ORA-00302limit of num logs exceeded

Cause:The maximum number of redo log files has been exceeded. There is a limit, set at database creation, on the number of redo log files (typically 16).

Action:None required.


ORA-00304

ORA-00304requested INSTANCE_NUMBER is busy

Cause:An instance tried to start by using a value of the initialization parameter INSTANCE_NUMBER that is already in use.

Action:Specify another value for INSTANCE_NUMBER in the initialization parameter file or wait for recovery to finish for that instance number; then restart the instance.


ORA-00305

ORA-00305log name of thread num inconsistent; belongs to another database

Cause:The database ID in the redo log file does not match the database ID in the control file. This redo log file is not from the current database.

Action:Specify the correct redo log file; then retry the operation.


ORA-00306

ORA-00306limit of num log writer instances in this database

Cause:Starting this instance would exceed the maximum number of instances allowed for this database. This message occurs only when attempting to start another instance in parallel server mode.

Action:It is not possible to start more than the given number of instances. The maximum is the lower of the operating system-specific maximum or the MAXINSTANCES option specified in the CREATE DATABASE statement.


ORA-00307

ORA-00307requested INSTANCE_NUMBER out of range, maximum is num

Cause:The initialization parameter INSTANCE_NUMBER specified a number that was out of range.

Action:Change INSTANCE_NUMBER to a valid range and restart the instance. The minimum value is one and the maximum value is the lower of the operating system-specific maximum or the MAXINSTANCES option specified in the CREATE DATABASE statement.


ORA-00308

ORA-00308cannot open archived log 'name'

Cause:The system cannot access a required archived redo log file.

Action:Make certain that the offline log exists, the storage device is online and the archived file is in the correct location; then attempt to continue recovery or restart the recovery session.


ORA-00309

ORA-00309log belongs to wrong database

Cause:The system cannot access the archived redo log because it belongs to another database.

Action:Specify the correct redo log file; then retry the operation.


ORA-00311

ORA-00311cannot read header from archived log

Cause:An message occurred when attempting to read the file header from the archived redo log file.

Action:Other messages will accompany this message. See the associated messages for the appropriate action to take.


ORA-00311

ORA-00311cannot read header from archived log

Cause:An error occurred when attempting to read the file header from the archived redo log file.

Action:Other messages will accompany this message. See the associated messages for the appropriate action to take.


ORA-00312

ORA-00312online log name thread num: 'str'

Cause:This message reports the file name for details of another message.

Action:Other messages will accompany this message. See the associated messages for the appropriate action to take.


ORA-00313

ORA-00313open failed for members of log group var of thread var

Cause:The online log cannot be opened. The file may not be in the expected location.

Action:Specify the correct redo log file, or make log available, if necessary. Also, see the following messages, if any.


ORA-00314

ORA-00314log name of thread num, expected sequence # num does not match num

Cause:The online log is out of sequence, probably because it is corrupted or an old version.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00315

ORA-00315log name of thread num, wrong thread # num in header

Cause:The online redo log file is corrupted or is an old version.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00316

ORA-00316log name of thread num, type str in header is not redo log file

Cause:The online redo log file is corrupted or is an old version.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00317

ORA-00317file type str in header is not logfile

Cause:This is not an archived redo log file.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00318

ORA-00318log name of thread num, expected file size num does not match num

Cause:The file size indicated in the control file did not match the file size contained in the redo log file.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00319

ORA-00319log name of thread num has incorrect log reset status

Cause:An online redo log file has log reset data that is different from the log reset data listed in the control file. The redo log file is probably an incorrectly restored backup.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00320

ORA-00320cannot read file header from log name of thread num

Cause:The system is unable to read the redo log file header because the file is not available or the file is corrupted.

Action:Specify the correct redo log file; then retry the operation.


ORA-00321

ORA-00321log name of thread num, cannot update logfile header

Cause:The system cannot write to the redo log file.

Action:Restore access to the redo log file; then retry the operation.


ORA-00322

ORA-00322log name of thread num is not current copy

Cause:An online redo log file appears to be an incorrectly restored backup, according to a check of the redo log file header.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00323

ORA-00323current log of thread num not usable and all others need archiving

Cause:An attempt to open a thread failed because it is necessary to switch to another online log, but all the other online redo logs need to be archived before they can be used.

Action:Archive the online redo logs for the thread; then retry the operation.


ORA-00324

ORA-00324logfile 'name' translated name 'name' too long, num characters exceeds num limit

Cause:The translated name for a redo log file is too long.

Action:Re-specify a redo log file name that on translation is shorter.


ORA-00325

ORA-00325archived log for thread num, wrong thread # num in header

Cause:The archived redo log file is corrupted or it belongs to another thread. This redo log file cannot be used.

Action:Find and use correct archived redo log file; then retry the operation.


ORA-00326

ORA-00326log begins at change num, need earlier change num

Cause:The archived redo log file supplied for recovery was generated after the redo log file that is needed. Cannot use the log for applying redo information at this time.

Action:Find and install the correct archived redo log file; then retry the operation.


ORA-00327

ORA-00327log name of thread num, physical size num less than needed num

Cause:A redo log file has shrunk in size. This is usually caused by a computer operator's mistake or an operating system message.

Action:Restore the redo log file from backup. If the database was shut down cleanly, no further action should be required; otherwise, manual recovery may be necessary.


ORA-00328

ORA-00328archived log ends at change num, need later change num

Cause:The archived redo log file supplied for recovery was generated before the log that is needed. Cannot use the log for applying redo information at this time.

Action:Find and install the correct archived redo log file; then retry the operation.


ORA-00329

ORA-00329archived log begins at change num, need change num

Cause:The archived redo log file supplied for recovery is not the correct log. An earlier redo log file is needed.

Action:Find and install the correct archived redo log file; then retry the operation.


ORA-00330

ORA-00330archived log ends at change num, need change num

Cause:The archived redo log file supplied for recovery is not the correct log. A later redo log file is needed.

Action:Find and install the correct archived redo log file; then retry the operation.


ORA-00331

ORA-00331log version num incompatible with ORACLE version num

Cause:The log was created under an older (incompatible) version of ORACLE, or an attempt was made to use the wrong log.

Action:Specify the correct redo log file, or recover the database with the old software; then shut down and restart ORACLE with the new software.


ORA-00332

ORA-00332archived log is too small - may be incompletely archived

Cause:The log occupies less space than is allocated to it. This may result from a shutdown abort while the archiver was writing it.

Action:Get a complete version of the file (either the online version or one that was successfully archived) and use that for recovery.


ORA-00333

ORA-00333redo log read message block num count num

Cause:An message occurred while reading the redo log file. Other messages will accompany this message and will give the name of the file.

Action:Restore access to the file, or get another copy of the file.


ORA-00334

ORA-00334archived log: 'name'

Cause:This message reports the file name involved with other message messages.

Action:See the associated messages for a description of the problem.


ORA-00335

ORA-00335online log name: No log with this number, log does not exist

Cause:This message reports the file name involved with other messages.

Action:See the associated messages for a description of the problem.


ORA-00336

ORA-00336logfile size num blocks is less than minimum num blocks

Cause:The redo log file size specified in the CREATE DATABASE statement is too small.

Action:Increase the redo log file size; then re-execute the statement.


ORA-00337

ORA-00337logfile 'name' does not exist and no size specified

Cause:The system could not add a redo log file because it could not find an existing file or a size for creating the file.

Action:Specify a size for the redo log file; then retry the operation.


ORA-00338

ORA-00338log name of thread num is more recent than control file

Cause:The control file change sequence number in the redo log file is greater than the number in the control file. This implies that the wrong control file is being used. Note that repeatedly causing this error to happen by reopening the database may cause the error to stop happening without correcting the problem. Every attempt to open the database advances the control file change sequence number.

Action:Use the correct control file or perform recovery using a backup of the control file.


ORA-00339

ORA-00339archived log does not contain any redo

Cause:The archived log being applied is not the correct log. The log being applied is possibly a copy of a log or was an online log being prepared to be used as the current log.

Action:Restore the correct redo log file.


ORA-00340

ORA-00340I/O error processing online log name of thread num

Cause:An I/O error occurred on the named online redo log file, probably because the file was not accessible, or because it was corrupted.

Action:Restore access to the file, or restore the file from a backup.


ORA-00341

ORA-00341log name of thread num, wrong log # num in header

Cause:The internal information in an online redo log file does not match the control file information.

Action:Refer to the ORACLE7 Server Administrator's Guide for recovery procedures.


ORA-00342

ORA-00342archived log was created before last RESETLOGS

Cause:During recovery, a log was supplied that was created before the last ALTER DATABASE OPEN RESETLOGS command. There should be another redo log file that was created since that time that contains the correct redo information.

Action:Find and supply the correct redo log file for recovery.


ORA-00343

ORA-00343too many errors, log member closed

Cause:The maximum number of errors on this log member has been exceeded. Other messages will accompany this message.

Action:Correct the underlying problems mentioned in the other messages.


ORA-00344

ORA-00344unable to re-create log 'name' at the end of incomplete recovery

Cause:At the end of manual recovery, all logs need reformatting. This message indicates that a log I/O failure occurred, probably because the file was not accessible or a device failed.

Action:Check the accompanying messages; then make the file accessible, or restore the device.


ORA-00345

ORA-00345redo log write error block num count num

Cause:An I/O error has occurred while writing the log, probably because the file was not accessible or a device failed.

Action:Make the file accessible or restore the device; then restart the system. If the log is lost, apply media or incomplete recovery.


ORA-00346

ORA-00346log member marked as STALE

Cause:A redo log file member is no longer complete. Other messages will accompany this message.

Action:Correct the underlying problem mentioned in the other messages.


ORA-00347

ORA-00347log name of thread num expected block size num does not match num

Cause:During online recovery, the block size specified in the control file did not match the block size indicated in the redo log file.

Action:Restore the correct redo log file from a backup, or reset the online redo log files.


ORA-00348

ORA-00348single-process redo failure. Must abort instance

Cause:A failure occurred during a single-process redo log operation. This error does not occur during normal multi-process operations.

Action:Shut down and restart the database.


ORA-00349

ORA-00349failure obtaining block size for 'name'

Cause:The operating system was unable to determine the block size for the named file.

Action:Check the accompanying messages; then restore the device or specify another file.


ORA-00350

ORA-00350log name of thread num needs to be archived - can not drop

Cause:An attempt was made to drop an online redo log file that has not been archived, and media recovery has been enabled.

Action:Archive the redo log file or disable media recovery.


ORA-00351

ORA-00351recover-to time invalid

Cause:The time specified in a RECOVER DATABASE ... UNTIL is after January 1, 1988.

Action:Specify a time after January 1, 1988.


ORA-00352

ORA-00352all logs for thread num need to be archived - can not enable

Cause:An attempt was made to enable a thread when all of the online redo log files in the thread need to be archived, and media recovery has been enabled. There is no online redo log file that can be made the new current log for the thread.

Action:Archive a redo log file for the thread.


ORA-00353

ORA-00353log corruption near block num time stamp str

Cause:Some type of redo log file corruption has been discovered. This message describes the location of the corruption. Other messages will accompany this message and describe the type of corruption.

Action:Perform recovery with a good version of the redo log file, or perform time-based recovery up to the indicated time.


ORA-00354

ORA-00354corrupt redo log block header

Cause:The block header on the block in the redo log file is not valid. The block number and time-stamp are given in an accompanying message.

Action:Perform recovery with a good version of the redo log file, or perform cancel-based recovery up to but not including the corrupted redo log file.


ORA-00355

ORA-00355change numbers out of order

Cause:A change number found in the redo log file is lower than a previously encountered change number. The redo log file is corrupted in some way. The corruption may be at the earlier change number or at this one. The block number and time-stamp are given in an accompanying message.

Action:Perform recovery with a good version of the redo log file, or perform time-based recovery up to the indicated time.


ORA-00356

ORA-00356inconsistent lengths in change description

Cause:A change record in the redo log file contains lengths that do not add up to a consistent value. The redo log file is corrupted in some way.

Action:Perform recovery with a good version of the redo log file or perform time-based recovery up to the indicated time.


ORA-00357

ORA-00357too many members specified for logfile, the maximum is num

Cause:An attempt was made to add a redo log group or add a redo log group member that would result in a set of online redo logs with too many members. The maximum number of members is set when the database is created.

Action:Use fewer redo log group members.


ORA-00358

ORA-00358Too many file members specified, the maximum is num

Cause:A CREATE or ALTER statement specified too many members in the file list.

Action:Specify a number of files that is within the given limit.


ORA-00359

ORA-00359Logfile group num does not exist

Cause:An attempt to add or drop a redo log group member specified a redo log file group number that does not exist.

Action:Check the configuration of the redo log files and issue the command again with a valid group number.


ORA-00360

ORA-00360 name is not a logfile member

Cause:An invalid file name was given to drop a redo log group member. Either the file is not a part of the database, or it is a data file.

Action:Supply a valid member name and issue the command again.


ORA-00361

ORA-00361 name is the last logfile member for group num

Cause:An attempt was made to remove the last member of a redo log group.

Action:If desired, delete the entire log by using the DROP LOGFILE command.


ORA-00362

ORA-00362member is required to form a valid logfile in group name

Cause:A request to drop a redo log group member was denied because it would remove data required to form a complete online redo log group.

Action:If desired, delete the entire log (after archiving, if required) using the DROP LOGFILE command.


ORA-00363

ORA-00363log is not the archived version

Cause:The log given for recovery is a backup of the online version from the time it was the current log. The archived version of the log would not be marked as the end of the thread. This message can also be caused by failing to list the current log of an enabled thread in a CREATE CONTROLFILE command.

Action:Find the archived version of the log and supply its name. If this is media recovery immediately following a CREATE CONTROLFILE, be sure the current log for this thread was included.


ORA-00364

ORA-00364can not write header to new log member

Cause:An I/O message occurred when attempting to write the header to a redo log group member that is being added to an existing group.

Action:See accompanying messages. Fix the problem or use another file.


ORA-00365

ORA-00365the specified log is not the correct next log

Cause:The specified log failed to pass checks to ensure it corresponds to the log that was generated against a cold backup image of the database.

Action:Find the log that was generated by this copy of the database and give that filename to recover.


ORA-00366

ORA-00366log name of thread name, checksum error in the file header

Cause:The file header for the redo log contains a checksum that does not match the value calculated from the file header as read from disk. This means the file header is corrupted.

Action:Find and install correct version of log or reset logs.


ORA-00367

ORA-00367checksum error in log file header

Cause:The file header for the redo log contains a checksum that does not match the value calculated from the file header as read from disk. This means the file header is corrupted.

Action:Find the correct file and try again.


ORA-00368

ORA-00368checksum error in redo log block

Cause:The redo block indicated by the accompanying error, is not valid. It has a checksum that does not match the block contents.

Action:Do recovery with a good version of the log or do time based recovery up to the indicated time. If this happens when archiving, archiving of the problem log can be skipped by clearing the log with the UNARCHIVED option. This must be followed by a backup of every datafile to insure recoverability of the database.


ORA-00369

ORA-00369current log of thread num not useable and other log being cleared

Cause:Attempt to open thread failed because it is necessary to switch redo generation to another online log, but all the other logs are being cleared or need to be archived before they can be used.

Action:If the ALTER DATABASE CLEAR log file command is still active then wait for it to complete. Otherwise, re-enter the CLEAR command. If there are other online logs for the thread that are not being cleared, then archive the logs.


ORA-00371

ORA-00371no free buffer handles available

Cause:The value of the initialization parameter DB_HANDLES is too small.

Action:Shut down the instance, increase the value of DB_HANDLES in the initialization parameter file, and then restart the instance. Under normal circumstances, let DB_HANDLES take its default value by omitting the parameter from the initialization parameter file.


ORA-00372

ORA-00372file name can not be modified at this time

Cause:An attempt was made to access a file being taken offline, or the database may be in the process of closing.

Action:Access the file after it is taken offline. Attempts will either succeed because the data file is back online, or fail with an message describing which file is offline. Repeat until successful.


ORA-00373

ORA-00373online log version ver incompatible with ORACLE version ver

Cause:The online log was written by incompatible version of ORACLE can occur when the redo log file was created by either a newer or older version of ORACLE.

Action:Recover the database with the compatible software, shut it down cleanly; then restart with current software.


ORA-00374

ORA-00374parameter DB_BLOCK_SIZE = num invalid, valid range [num..num]

Cause:An invalid value has been used for the DB_BLOCK_SIZE initialization parameter.

Action:Adjust the parameter and restart the instance.


ORA-00375

ORA-00375unable to get default DB_BLOCK_SIZE

Cause:The system was unable to determine the default DB_BLOCK_SIZE.

Action:See the corresponding operating system specific message. As a work-around, specify the block size with the parameter DB_BLOCK_SIZE in the initialization parameter file.


ORA-00376

ORA-00376file name can not be read at this time

Cause:An attempt was made to read from a file that is not readable. The most likely cause is that the file is offline.

Action:Check the state of the file. Bring the file online, if necessary.

________________________________________


ORA-00377

ORA-00377frequent backups of file name causing write operation to stall

Cause:Backups are occurring too frequently on this file. Each time a new backup is started for a file, any writes which have been previously issued (but not completed) have to be re-issued. If hot backups are started very, very frequently, it is possible that some writes will be re-issued repeatedly and never complete.

Action:Increase the interval between begin hot-backup commands for this file.


ORA-00378

ORA-00378buffer pools cannot be created as specified

Cause:Either the number of buffers or the number of LRU latches is too small to satisfy the specified buffer pool configuration.

Action:Either increase the number of buffers and/or number of LRU latches or configure smaller buffer pools.


ORA-00390

ORA-00390log name of thread num is being cleared, cannot become current log

Cause:An attempt to switch to a new online log for the redo thread failed because no reusable log could be found. This log is being cleared and will be useable when the clearing completes. The command that began the clearing may have terminated without completing the clearing.

Action:If the clear command is still executing, then wait for its completion. If it terminated, then re-enter the clear command or drop the log.


ORA-00391

ORA-00391all threads must switch to new log format at the same time

Cause:An attempt to switch the current log of a single thread is not allowed because the compatibility requirements force a new log format version number.When changing log formats, all threads must switch to the new format at the same time.

Action:Open the database to cause the coordinated log switch. If that is not possible, then return to the same software version and compatibility setting last used to open the database.


ORA-00392

ORA-00392log name of thread num is being cleared, operation not allowed

Cause:An operation encountered this online log in the middle of being cleared. The command that began the clearing may have terminated without completing the clearing.

Action:If the clear command is still executing, then wait for its completion. If it terminated, then re-enter the clear command or drop the log.


ORA-00393

ORA-00393log name of thread num is needed for recovery of offline datafiles

Cause:Log cannot be cleared because the redo in it is needed to recover offline datafiles. It has not been archived so there is no other copy available. If the log is cleared, the tablespaces containing the files will have to be dropped.

Action:Archive the log, then repeat the clear command. If archiving is not possible and dropping the tablespaces is acceptable, then add the clause UNRECOVERABLE DATAFILE at the end of the clear command.


ORA-00394

ORA-00394online log reused while attempting to archive it

Cause:An attempt was made to reuse an online log file that is being archived.

Action:The online logfile has been overwritten; it cannot be archived.


ORA-00400

ORA-00400invalid release value val for parameter val

Cause:The release level given for the specified initialization parameter is invalid.

Action:Correct the parameter value in the initialization parameter file and retry.


ORA-00401

ORA-00401the value for parameter "param" is not supported by this release

Cause:The value specified cannot be supported by this release of the software.

Action:Choose an appropriate value, or remove the initialization parameter value to use the default value.


ORA-00403

ORA-00403 str (str) is not the same as other instances (str)

Cause:The recovery compatibility initialization parameters for this instance are different than other instances.

Action:Change the initialization parameters of the current instance to match other instances already running.


ORA-00403

ORA-00403str str is not the same as other instances str

Cause:The recovery compatible, or recovery not compatible, initialization parameters were changed for another running instance.

Action:Change the initialization parameters of the current instance to match other instances already running.


ORA-00404

ORA-00404Conversion data file not found: name

Cause:The file used for converting the database from ORACLE Version 6 to ORACLE7 could not be found.

Action:Verify that the conversion process has been started on this database and that the data file name is accessible.


ORA-00405

ORA-00405compatibility type \name\

Cause:Reporting a type associated with another message.

Action:See accompanying message.

________________________________________


ORA-00406

ORA-00406COMPATIBLE parameter needs to be num or greater

Cause:The specification for the initialization parameter COMPATIBLE is too low to allow the requested operation.

Action:Shut down and specify a higher COMPATIBLE value, then restart.


ORA-00407

ORA-00407rolling upgrade from release num.num to num.num is not allowed

Cause:Another instance has the database mounted and that instance is for a different release of Oracle than you are using.

Action:Shut down and start up all instances with the new release of Oracle.


ORA-00408

ORA-00408parameter name is set to TRUE

Cause:Reporting the parameter that resulted in the compatibility error.

Action:Shutdown and startup with a higher compatibility setting.


ORA-00436

ORA-00436ORACLE is not licensed. Contact ORACLE Corporation for assistance

Cause:This installed ORACLE software is not licensed to run on this CPU. This can also occur if ORACLE software has been installed incorrectly (for example, with the wrong licensing codes).

Action:Make sure ORACLE is installed correctly; then contact Worldwide Customer Support.


ORA-00437

ORA-00437ORACLE feature is not licensed. Contact Oracle Corporation for assistance

Cause:This installed ORACLE feature is not licensed to run on this CPU. This can also occur if ORACLE software has been installed incorrectly (for example, with the wrong licensing codes).

Action:Make sure ORACLE is installed correctly; then contact Worldwide Customer Support.

________________________________________


ORA-00444

ORA-00444background process 'name' failed while starting

Cause:This message is usually caused by a faulty or non-existent background process image.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages, or obtain a proper background process image, then retry the operation.


ORA-00445

ORA-00445background process 'name' did not start

Cause:The specified process did not start.

Action:Check and, if necessary, correct problems indicated by one or more of the following:

1) the size of the SGA, referring to the operating system specific installation and user's guide for the initialization parameters

2) accompanying messages

3) the background trace file

4) the executable image is not in the right location with the correct protections


ORA-00446

ORA-00446background process started when not expected

Cause:A background process started after ORACLE was already running.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages. If no user on site started the process, report the message to Worldwide Customer Support.


ORA-00447

ORA-00447fatal message in background process

Cause:One of the background processes died unexpectedly.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.


ORA-00448

ORA-00448normal completion of background process

Cause:One of the background processes completed normally as requested by the user.

Action:If you are solving a problem, check for other messages and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart ORACLE.


ORA-00449

ORA-00449background process 'name' unexpectedly terminated with message num

Cause:A foreground process needing service from a background process has discovered the background process died.

Action:Refer to the message code given in the message and the trace file for the foreground and the background processes.


ORA-00470

ORA-00470LGWR process terminated with message

Cause:The Log Writer process terminated abnormally.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.


ORA-00471

ORA-00471DBWR process terminated with message

Cause:The Database Writer process terminated abnormally.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.


ORA-00472

ORA-00472PMON process terminated with message

Cause:The Process Monitor process terminated abnormally.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.


ORA-00473

ORA-00473ARCH process terminated with message

Cause:The Archiver process terminated abnormally.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.


ORA-00474

ORA-00474SMON process terminated with message

Cause:The System Monitor process terminated abnormally.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.


ORA-00475

ORA-00475TRWR process terminated with message.

Cause:The system tracing process died.

Action:Warm start the instance.


ORA-00476

ORA-00476RECO process terminated with message

Cause:The distributed transaction (two-phase commit) recovery process died.

Action:Warm start the instance.


ORA-00477

ORA-00477SNP* process terminated with an error

Cause:A snapshot refresh process died.

Action:Restart the instance.


ORA-00480

ORA-00480LCK* process terminated with message

Cause:One Lock process terminated abnormally.

Action:Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.


ORA-00481

ORA-00481SMON process posting itself

Cause:This is an internal message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00482

ORA-00482LMD* process terminated with error

Cause:A lock manager daemon process terminated.

Action:Warm start instance.


ORA-00483

ORA-00483during shutdown a process abnormally terminated

Cause:One of the background processes did not exit normally when the instance shut down.

Action:Use the SHUTDOWN ABORT command. Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages; then restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

________________________________________


ORA-00568

ORA-00568maximum number of interrupt handlers exceeded

Cause:The number of registered interrupt handling routines for when the break key is entered exceeds the maximum allowed.

Action:Reduce the number of registered interrupt handlers.

________________________________________


ORA-00600

ORA-00600internal message code, arguments: [num], [?], [?], [?], [?], [?]

Cause:This is a catch-all internal message for ORACLE program exceptions. It indicates that a process has met a low-level, unexpected condition.

Various causes of this message include:

·time-outs

·file corruption

·failed data checks in memory

·hardware, memory, or I/O messages

·incorrectly restored files

The first argument is the internal message number; other arguments are various numbers, names, and character strings. (See section "Reporting a Problem to Worldwide Customer Support" on page 1-12 for more information.) The numbers may change meanings between different versions of the ORACLE Server.

Action:Report this error to Worldwide Customer Support after gathering the following information:

·events that led up to the error

·the operations that were attempted that led to the error

·the conditions of the operating system and database at the time of the error

·any unusual circumstances that occurred prior to receiving the ORA-00600 message.

·contents of any trace files generated by the error

·the relevant portions of the Alert file

NOTE: The cause of this error may manifest itself as different errors at different times. Be aware of the history of errors that occurred prior to this internal error.


ORA-00601

ORA-00601cleanup lock conflict

Cause:The Process Monitor process encountered a lock conflict while trying to recover processes. This is an internal message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00602

ORA-00602internal programming exception

Cause:An internal programming exception has occurred.

Action:Report this error as a program bug to Worldwide Customer Support.


ORA-00603

ORA-00603ORACLE Server session terminated by fatal error

Cause:An ORACLE Server session is in an unrecoverable state.

Action:Login to ORACLE again so a new server session will be created automatically. Examine the session trace file for more information.


ORA-00604

ORA-00604error occurred at recursive SQL level num

Cause:An error occurred while processing a recursive SQL statement (a statement applying to internal dictionary tables).

Action:If the situation described in the next message on the stack can be corrected, do so; otherwise, contact Worldwide Customer Support.


ORA-00606

ORA-00606internal error code

Cause:A call to deferred UPI functions was made in non-deferred mode.

Action:Contact Worldwide Customer Support.

________________________________________


ORA-00701

ORA-00701object necessary for warm starting database cannot be altered

Cause:An attempt was made to alter or drop a table, cluster, or index defined in the control file's bootstrap segment and needed to warm start the database.

Action:Correct the spelling of the object name, or remove it from the ALTER or DROP statement.


ORA-00702

ORA-00702bootstrap version version inconsistent with version version

Cause:The version of the bootstrap data in a file is incompatible with the current version of the software.

Action:Restore a version of the software that is compatible with the data files.


ORA-00703

ORA-00703maximum number of dictionary cache instance locks exceeded

Cause:An operation requested a resource that was unavailable. The maximum number of dictionary cache instance locks is specified by the ROW_CACHE_INSTANCE_LOCKS parameter in the initialization parameter file. When this maximum is reached, no more requests are processed.

Action:Try the operation again in a few minutes. If this error occurs often, contact Worldwide Customer Support.


ORA-00704

ORA-00704bootstrap process failure

Cause:An error occurred when processing bootstrap data. Refer to the accompanying messages for more information about the cause of the problem.

Action:Correct the problems mentioned in the other messages. If problem persists, contact Worldwide Customer Support.

________________________________________


ORA-00816

ORA-00816message translation failed

Cause:There is an internal error where a routine was unable to translate a message code.

Action:Notify Worldwide Customer Support.

________________________________________


ORA-00900

ORA-00900invalid SQL statement

Cause:The statement entered is not recognized as a valid SQL statement.

Action:Correct the syntax.


ORA-00901

ORA-00901invalid CREATE command

Cause:The CREATE command was not followed by a valid CREATE option.

Action:Correct the syntax.


ORA-00902

ORA-00902invalid datatype

Cause:The datatype entered in the CREATE or ALTER TABLE statement is not valid.

Action:Correct the syntax.


ORA-00903

ORA-00903invalid table name

Cause:A table or cluster name is invalid or does not exist. This message is also issued if an invalid cluster name or no cluster name is specified in an ALTER CLUSTER or DROP CLUSTER statement.

Action:Check spelling. A valid table name or cluster name must begin with a letter and may contain only alphanumeric characters and the special characters $, _, and #. The name must be less than or equal to 30 characters long and cannot be a reserved word.


ORA-00904

ORA-00904invalid column name

Cause:The column name entered is either missing or invalid.

Action:Enter a valid column name. A valid column name must begin with a letter, be less than or equal to 30 characters, and consist of only alphanumeric characters and the special characters $, _, and #. If it contains other characters it must be enclosed in double quotes. It may not be a reserved word.


ORA-00905

ORA-00905missing keyword

Cause:A required keyword is missing.

Action:Correct the syntax.


ORA-00906

ORA-00906missing left parenthesis

Cause:A required left parenthesis has been omitted. Certain commands (such as CREATE TABLE, CREATE CLUSTER, and INSERT) require a list of items enclosed in parentheses. Parentheses are also required around subqueries used in WHERE clauses and UPDATE table SET column = (SELECT ...) statements.

Action:Check the command syntax, insert a left parenthesis where required; then re-execute the statement.


ORA-00907

ORA-00907missing right parenthesis

Cause:A left parenthesis has been entered without a closing right parenthesis, or extra information was contained in the parentheses. All parentheses must be entered in pairs.

Action:Correct the syntax.


ORA-00908

ORA-00908missing NULL keyword

Cause:Either:

1) In a CREATE TABLE or ALTER TABLE statement, NOT was entered to specify that no null values are allowed in that column but the keyword NULL was omitted.

2) In the IS [NOT] NULL logical operator, the keyword NULL was not found. For example, the following statement generates the message:

SELECT * FROM EMP WHERE DEPTNO IS NOT;

The keyword NULL must follow the keywords IS NOT.

Action:Correct the syntax.


ORA-00909

ORA-00909invalid number of arguments

Cause:An ORACLE function was referenced with an incorrect number of arguments. All ORACLE functions, except for SYSDATE, require at least one argument.

Action:Check the syntax of the function and enter the required number of arguments.


ORA-00910

ORA-00910specified length too long for its datatype

Cause:No size was specified for a character field or the size was invalid. A maximum length must be specified for each character column. The maximum value for this length varies for each character datatype, such as CHAR or VARCHAR2.

Action:Enter a maximum length for the field.


ORA-00911

ORA-00911invalid character

Cause:Special characters are valid only in certain places. If special characters other than $, _, and # are used in a name and the name is not enclosed in double quotes ("), this message will be issued.

Action:Remove the invalid character from the statement, or enclose the object name in double quotes.


ORA-00913

ORA-00913too many values

Cause:The SQL statement requires two sets of values equal in number. This error occurs when the second set contains more items than the first set. For example, the subquery in a WHERE or HAVING clause may return too many columns, or a VALUES or SELECT clause may return more columns than are listed in the INSERT.

Action:Check the number of items in each set and change the SQL statement to make them equal.


ORA-00914

ORA-00914missing ADD keyword

Cause:The keyword ADD does not precede one of the following:

·the keyword LOGFILE in an ALTER DATABASE statement

·a column element or table constraint in an ALTER TABLE statement

·the keyword DATAFILE in an ALTER TABLESPACE statement

Action:Specify the keyword ADD in the ALTER statement.


ORA-00915

ORA-00915network access of dictionary table not currently allowed

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00917

ORA-00917missing comma

Cause:A required comma has been omitted from a list of columns or values in an INSERT statement, or a list of the form ((C,D),(E,F), ...).

Action:Correct the syntax.


ORA-00918

ORA-00918column ambiguously defined

Cause:A column name used in a join exists in more than one table, and is thus referenced ambiguously. In a join, any column name that occurs in more than one of the tables must be prefixed by its table name when referenced. The column should be referenced as TABLE.COLUMN or TABLE_ALIAS.COLUMN. For example, if tables EMP and DEPT are being joined and both contain the column DEPTNO; then all references to DEPTNO should be prefixed with the table name, as in EMP.D

Action:Prefix references to column names that exist in multiple tables with either the table name or a table alias, and a period (.), as in the examples above.


ORA-00919

ORA-00919invalid function

Cause:An entry was formatted like a function call but not recognizable as an ORACLE function.

Action:Check for valid syntax and ensure a valid function is used.


ORA-00920

ORA-00920invalid relational operator

Cause:A search condition was entered with an invalid or missing relational operator.

Action:Include a valid relational operator such as =, !=, ^=, <>, >, <, >=, <=, ALL, ANY, [NOT] BETWEEN, EXISTS, [NOT] IN, IS [NOT] NULL, or [NOT] LIKE in the condition.


ORA-00921

ORA-00921unexpected end of SQL command

Cause:The SQL command was not complete. Part of a valid command was entered, but at least one major component was omitted.

Action:Check the command syntax; then enter all the required components.


ORA-00922

ORA-00922missing or invalid option

Cause:An invalid option was specified in defining a column or storage clause. The valid option in specifying a column is NOT NULL to specify that the column cannot contain any NULL values. Only constraints may follow the datatype. Specifying a maximum length on a DATE or LONG datatype also causes this error.

Action:Check syntax and spelling. Remove the erroneous option or length specification from the column or storage specification.


ORA-00923

ORA-00923FROM keyword not found where expected

Cause:In a SELECT or REVOKE statement the keyword FROM is either missing, misplaced, or misspelled. The keyword FROM must follow the last selected item in a SELECT statement, or the privileges in a REVOKE statement.

Action:Insert the keyword FROM where appropriate. The SELECT list itself may also be in error. If quotes were used in an alias, make sure double quotes enclose the alias. Also, check to see if a reserved word was used as an alias.


ORA-00924

ORA-00924missing BY keyword

Cause:The keyword BY was omitted in a GROUP BY, ORDER BY, or CONNECT BY clause. In a GRANT statement, the keyword IDENTIFIED must also be followed by the keyword BY.

Action:Check the syntax, insert the keyword BY where required, and then re-execute the statement.


ORA-00925

ORA-00925missing INTO keyword

Cause:An INSERT statement has been entered without the keyword INTO.

Action:Check the syntax, insert the keyword INTO where required, and then re-execute the statement.


ORA-00926

ORA-00926missing VALUES keyword

Cause:An INSERT statement has been entered without the keyword VALUES or SELECT. Either a VALUES clause or a SELECT subquery must follow the INSERT INTO clause.

Action:Enter either a VALUES clause or a subquery after the INSERT INTO clause.


ORA-00927

ORA-00927missing equal sign

Cause:An equal sign has been omitted in one of the following places:

·in the SET clause of an UPDATE statement

·following "!" in a search condition to signify not equal

Action:Check the syntax, insert the equal sign where required, then re-execute the statement.


ORA-00928

ORA-00928missing SELECT keyword

Cause:A SELECT subquery must be included in a CREATE VIEW statement.

Action:Insert the required SELECT clause after the CREATE VIEW clause, and then re-execute the statement.


ORA-00929

ORA-00929missing period

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00930

ORA-00930missing asterisk

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00931

ORA-00931missing identifier

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00932

ORA-00932inconsistent datatypes

Cause:Either:

·An attempt was made to perform an operation on incompatible datatypes. For example, adding a character field to a date field (dates may only be added to numeric fields), or concatenating a character field with a long field.

·An attempt was made to perform an operation on a database object (such as a table or view) that is not intended for normal use. For example, system tables cannot be modified by a user. Note that on rare occasions this error occurs because a misspelled object name matched a restricted object's name.

·An attempt was made to use an undocumented view.

Action:If the cause is:

·different datatypes; then use consistent datatypes. For example, convert the character field to a numeric field using the TO_NUMBER function before adding it to the date field. Functions may not be used with long fields.

·an object not intended for normal use; then do not access the restricted object.


ORA-00933

ORA-00933SQL command not properly ended

Cause:The SQL statement ends with an inappropriate clause. For example, an ORDER BY clause may have been included in a CREATE VIEW or INSERT statement. ORDER BY may not be used to create an ordered view or to insert in a certain order. Also, an improper SQL ending occurs if IN clause is used with only one argument (IN(X), for example). An IN clause must have two or more arguments.

Action:Correct the syntax by removing the inappropriate clauses. It may be possible to duplicate the removed clause with another SQL statement. For example, to order the rows of a view, do so when querying the view and not when creating it. This error can also occur in SQL*Forms applications if a continuation line is indented. Check for indented lines and delete these spaces.


ORA-00934

ORA-00934group function is not allowed here

Cause:One of the group functions (such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE) was used in a WHERE or GROUP BY clause.

Action:Remove the group function from the WHERE or GROUP BY clause.

The desired result may possibly be achieved by including the function in a subquery or HAVING clause.


ORA-00935

ORA-00935group function is nested too deeply

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00936

ORA-00936missing expression

Cause:A required part of a clause or expression has been omitted. For example, a SELECT statement may have been entered without a list of columns or expressions, or with an incomplete expression. This message is also issued in cases where a reserved word is misused, as in SELECT TABLE.

Action:Check the statement syntax and enter the missing component.


ORA-00937

ORA-00937not a single-group group function

Cause:A SELECT list cannot include both a group function (such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE) and an individual column expression, unless the individual column expression is included in a GROUP BY clause.

Action:Drop either the group function or the individual column expression from the SELECT list, or add a GROUP BY clause that includes all individual column expressions listed.


ORA-00938

ORA-00938not enough arguments for function

Cause:The function was referenced with too few arguments.

Action:Check the function syntax and supply the required number of arguments.


ORA-00939

ORA-00939too many arguments for function

Cause:The function was referenced with too many arguments.

Action:Check the function syntax and specify only the required number of arguments.


ORA-00940

ORA-00940invalid ALTER command

Cause:An invalid ALTER option was specified.

Action:Correct the syntax.


ORA-00941

ORA-00941missing cluster name

Cause:The cluster name was either missing or invalid.

Action:Specify a valid cluster name. A valid cluster name must start with a letter, be less than or equal to 30 characters, and contain only alphanumeric characters or the special characters $, _, and #. It may not be a reserved word. The name must be specified immediately following the keywords CREATE CLUSTER.


ORA-00942

ORA-00942table or view does not exist

Cause:The table or view entered does not exist, or a synonym was used although not allowed here, or a view was referenced where a table is required. Existing user tables and views can be listed by querying the data dictionary. Certain privileges may be required to access the table. If an application returned this message, the table the application tried to access does not exist in the database, or the application does not have access to them.

For Trusted ORACLE configured in DBMS MAC mode, you may get this message if you attempt to access an object that you do not dominate.

Action:Check, the spelling of the table or view name, that a view is not specified where a table is required, and that an existing table or view name exists. Contact the database administrator if the table needs to be created or if user or application privileges are required to access the table.

Also, if attempting to access a table or view in another schema, make certain the correct schema is referenced and that access to the object is granted.

For Trusted ORACLE in DMBS MAC mode, if the cause is an object existing at a higher label, alter your current label to dominate the creation label of the object; then re-issue the command.


ORA-00943

ORA-00943cluster does not exist

Cause:The current user owns no cluster by the specified name.

For Trusted ORACLE configured in DBMS MAC mode, you may get this message if you attempt to access an object that you do not dominate.

Action:Specify a valid cluster name following the keyword CLUSTER, then re-execute the statement.

For Trusted ORACLE in DMBS MAC mode, if the cause is an object existing at a higher label, alter your current label to dominate the creation label of the object; then re-issue the command.


ORA-00944

ORA-00944insufficient number of clustered columns

Cause:An attempt was made to create a table with fewer cluster columns than were specified in the CREATE CLUSTER statement. The CLUSTER clause of an CREATE TABLE statement must specify all cluster columns that were defined when the cluster was created.

Action:Specify all cluster columns in the CREATE TABLE statement, then re-execute it.


ORA-00945

ORA-00945specified clustered column does not exist

Cause:A column specified in the cluster clause of a CREATE TABLE statement is not a column in this table.

For Trusted ORACLE configured in DBMS MAC mode, you may get this message if you attempt to access an object that you do not dominate.

Action:Re-execute the statement, using the names of columns defined for the table.

For Trusted ORACLE in DMBS MAC mode, if the cause is an object existing at a higher label, alter your current label to dominate the creation label of the object; then re-issue the command.


ORA-00946

ORA-00946missing TO keyword

Cause:A GRANT statement was specified without the keyword TO, or an invalid form of the GRANT command was entered.

Action:Check the syntax for the GRANT command, insert the keyword TO where required, and re-execute the statement.


ORA-00947

ORA-00947not enough values

Cause:This error occurs when SQL statement requires two sets of values equal in number, but the second set contains fewer items than the first set. This can occur in a WHERE or HAVING clause in which a nested SELECT returns too few columns as in:

WHERE (A,B) IN (SELECT C FROM ...)

Another common cause of this error is in an INSERT statement in which the VALUES or SELECT clause does not contain enough values needed for the INSERT as in:

INSERT INTO EMP(EMPNO,ENAME) VALUES('JONES')

Action:Check the number of items in each set and change the SQL statement to make them equal.


ORA-00949

ORA-00949illegal reference to remote database

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-00949

ORA-00949illegal reference to remote database

Cause:This is an internal error message not usually issued.

Action:Contact customer support.


ORA-00950

ORA-00950invalid DROP option

Cause:A DROP command was not followed by a valid DROP option such as CLUSTER, DATABASE LINK, INDEX, ROLLBACK SEGMENT, SEQUENCE, SYNONYM, TABLE, TABLESPACE, or VIEW.

Action:Check the command syntax, specify a valid DROP option, and then re-execute the statement.


ORA-00951

ORA-00951cluster not empty

Cause:A DROP CLUSTER statement specified a cluster that is not empty. A cluster may not be dropped if it contains any tables, unless the optional INCLUDING TABLES clause is specified. Tables may also be removed from a cluster by using the DROP TABLE command.

Action:Either specify the INCLUDING TABLES clause in the DROP CLUSTER statement, or remove all tables from the cluster with the DROP TABLE command before issuing the DROP CLUSTER command.


ORA-00952

ORA-00952missing GROUP keyword

Cause:Groups are not currently implemented.

Action:No user action is required.


ORA-00953

ORA-00953invalid index name

Cause:In a CREATE INDEX, DROP INDEX, or VALIDATE INDEX statement, the index name was missing or invalid.

Action:Specify a valid index name after the keyword INDEX. To drop or validate an existing index, check the name by querying the data dictionary. To create a new index, check the syntax before retrying.


ORA-00954

ORA-00954missing IDENTIFIED keyword

Cause:A GRANT CONNECT statement was issued without the keyword IDENTIFIED.

Action:Check the syntax and insert the keyword IDENTIFIED after the last username. The format is:

@MONOX = GRANT CONNECT TO user-list IDENTIFIED BY password-list;


ORA-00955

ORA-00955 name is already used by an existing object

Cause:An attempt was made to create a database object (such as a table, view, cluster, index, or synonym) that already exists. A user's database objects must have distinct names.

Action:Enter a unique name for the database object, or modify or drop the existing object so it can be reused.


ORA-00956

ORA-00956missing or invalid auditing option

Cause:An AUDIT or NOAUDIT command was not followed by a valid option or the keyword ALL. For example, when AUDITing tables an option such as ALTER, AUDIT, COMMENT, DELETE, GRANT, INDEX, INSERT, LOCK, RENAME, SELECT, or UPDATE must be specified.

Action:Correct the syntax.


ORA-00957

ORA-00957duplicate column name

Cause:A column name was specified twice in a CREATE or INSERT statement. Column names must be unique within a table, view, or cluster.

Action:In a CREATE statement, change one of the column names to a new, unique column name. In an INSERT statement, remove one of the duplicate names.


ORA-00958

ORA-00958missing CHECK keyword

Cause:The keyword CHECK should follow the keyword WITH in the WITH OPTION clause of the CREATE VIEW statement.

Action:Check the statement syntax, insert the keyword CHECK where required; then re-execute the statement.


ORA-00959

ORA-00959tablespace 'name' does not exist

Cause:A statement specified the name of a tablespace that does not exist.

For Trusted ORACLE configured in DBMS MAC mode, you may get this message if you attempt to access an object that you do not dominate.

Action:Enter the name of an existing tablespace. For a list of tablespace names, query the data dictionary. If a tablespace is dropped and re-created with the same name, use ALTER USER to reset the default or temporary tablespace name, since the new tablespace is not the same as the dropped tablespace even though they have the same name.

For Trusted ORACLE in DMBS MAC mode, if the cause is an object existing at a higher label, alter your current label to dominate the creation label of the object; then re-issue the command.


ORA-00960

ORA-00960ambiguous column naming in select list

Cause:A column name in the order-by list matches more than one select list column.

Action:Remove the duplicate column naming in the select list.


ORA-00962

ORA-00962too many group-by or order-by expressions

Cause:The group-by or order-by column list contains more than 255 expressions.

Action:Use no more than 255 expressions in the group-by or order-by list.


ORA-00964

ORA-00964table name not in FROM list

Cause:A table specified in a query's SELECT list is not named in the FROM-clause list.

Action:Check spelling of the table names, make sure each table name in the SELECT list matches a table name in the FROM list, and then re-execute the statement.


ORA-00965

ORA-00965column aliases not allowed for '*'

Cause:An alias was used with the return-all-columns function (*) in the SELECT list. For example:

SELECT * COL_ALIAS FROM EMP;

Action:Either specify individual columns or do not specify an alias with a "*".


ORA-00966

ORA-00966missing TABLE keyword

Cause:A LOCK statement was specified and the keyword TABLE was missing, misspelled, or misplaced. A LOCK statement must begin with LOCK TABLE tablename.

Action:Check syntax, spelling, and use the keyword TABLE where required.


ORA-00967

ORA-00967missing WHERE keyword

Cause:The keyword WHERE in a SELECT statement was missing, misspelled, or misplaced.

Action:Correct the syntax of the SQL statement; then re-execute it.


ORA-00968

ORA-00968missing INDEX keyword

Cause:The keyword INDEX in a CREATE UNIQUE INDEX or VALIDATE INDEX statement was missing, misspelled, or misplaced.

Action:Check the statement syntax; then re-execute the statement.


ORA-00969

ORA-00969missing ON keyword

Cause:The keyword ON in a GRANT, REVOKE, or CREATE INDEX statement was missing, misspelled, or misplaced.

Action:Check syntax, spelling, and use the keyword ON where required.


ORA-00970

ORA-00970missing WITH keyword

Cause:The keyword START was specified without the keyword WITH. Both keywords are necessary if a START WITH clause is desired in a tree-structured query.

Action:Change the keyword START to the keywords START WITH; then re-execute the statement.


ORA-00971

ORA-00971missing SET keyword

Cause:The keyword SET in an UPDATE statement is missing, misspelled, or misplaced.

Action:Check syntax, spelling, and use the keyword SET after the name of the table to be updated.


ORA-00972

ORA-00972identifier is too long

Cause:The name of a schema object exceeds 30 characters. (Schema objects are tables, clusters, views, indexes, synonyms, tablespaces, and usernames.)

Action:Shorten the name to 30 characters or less.


ORA-00974

ORA-00974invalid PCTFREE value (percentage)

Cause:The percentage of free space specified in a CREATE INDEX statement is not between 0 and 100. A PCTFREE value of 0 means the entire block is available. The value 100 is not useful because it means that no data may be inserted. The default is 10.

Action:Specify a PCTFREE value between 0 and 100; then re-execute the statement.


ORA-00975

ORA-00975date + date not allowed

Cause:An attempt was made to add two date fields together. Dates may only be added to numeric fields, not to other dates.

Action:Use the ORACLE function TO_NUMBER to convert one of the date fields to a numeric field before adding it to the other date field.


ORA-00976

ORA-00976LEVEL, PRIOR, or ROWNUM not allowed here

Cause:The use of the PRIOR clause, the pseudo-column LEVEL, or ROWNUM is incorrect in this context.

Action:Check the syntax for the SQL statement; then remove or relocate the keyword PRIOR, LEVEL, or ROWNUM.


ORA-00977

ORA-00977duplicate auditing option

Cause:An AUDIT or NOAUDIT statement specified the same option more than once.

Action:Either specify ALL without other auditing options, or remove the duplicate auditing specifications.


ORA-00978

ORA-00978nested group function without GROUP BY

Cause:A group function (such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE) was used within another group function (as in MAX(COUNT(*))) without a corresponding GROUP BY clause.

Action:Either add a GROUP BY clause, or remove the extra level of nesting.


ORA-00979

ORA-00979not a GROUP BY expression

Cause:The GROUP BY clause does not contain all the expressions in the SELECT clause. SELECT expressions that are not included in a group function (such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE) must be listed in the GROUP BY clause.

Action:Include in the GROUP BY clause all SELECT expressions that are not group function arguments.


ORA-00980

ORA-00980synonym translation is no longer valid

Cause:The synonym used is based on a table, view, or synonym that no longer exists.

Action:Replace the synonym with the name of the object it references, or re-create the synonym so that it refers to a valid table, view, or synonym.


ORA-00981

ORA-00981cannot mix table and system auditing options

Cause:Both table-wide and system-wide options were specified within a single AUDIT statement.

Action:Check the AUDIT command syntax; then re-execute one or more AUDIT statements.


ORA-00982

ORA-00982missing plus sign

Cause:A left parenthesis appeared in a join condition, but a plus sign (+) did not follow. A left parenthesis in a join condition usually signals an outer-join specification and so, a plus sign is expected to follow. To specify an outer join on a column in a join operation, follow the column reference in the join condition with a plus sign (+) enclosed in parentheses.

Action:Correct the SQL syntax and re-execute the statement.


ORA-00984

ORA-00984column not allowed here

Cause:A column name was used in an expression where it is not permitted, such as in the VALUES clause of an INSERT statement.

Action:Check the syntax of the statement and use column names only where appropriate.


ORA-00985

ORA-00985invalid program name

Cause:Probably a syntax error.

Action:Correct syntax.


ORA-00986

ORA-00986missing or invalid group names(s)

Cause:Probably a syntax error.

Action:Correct syntax.


ORA-00987

ORA-00987missing or invalid username(s)

Cause:No username was specified in a GRANT statement or one of the specified usernames is invalid. Valid usernames must be specified following the keyword TO in a GRANT statement to define a user. A username must begin with a letter; consist only of alphanumeric characters and the special characters $, _, and #, and be less than or equal to 30 characters. If it contains other characters it must be enclosed in double quotes. It may not be a reserved word. Action:Specify a valid username (or list of usernames) following the keyword TO in the GRANT statement.


ORA-00988

ORA-00988missing or invalid password(s)

Cause:More usernames than passwords were specified in a GRANT statement. A valid password must be specified for each username listed in the GRANT statement.

Action:Enter a valid password for each username.


ORA-00989

ORA-00989too many passwords for usernames given

Cause:More passwords than usernames were specified in a GRANT statement. Only one password may be entered for each username listed in the GRANT statement.

Action:Enter an equal number of usernames and passwords.


ORA-00990

ORA-00990missing or invalid privilege

Cause:No privileges were specified in a GRANT privilege statement, or one of the specified privileges is invalid.

Action:Enter one or more valid privileges such as SELECT, INSERT, DELETE, UPDATE, ALTER, INDEX, REFERENCES, or ALL. More than one privilege may be granted by entering the privileges in a list separated by commas (,) or by specifying the keyword ALL to grant all privileges.


ORA-00991

ORA-00991invalid format for GRANT command

Cause:An invalid form of the GRANT command was entered. There are two forms of the GRANT command. The first form is used to grant a user database access privileges. The second form is used to grant a user object privileges.

Action:Check the command syntax and re-execute the statement.


ORA-00992

ORA-00992invalid format for REVOKE command

Cause:An invalid form of the REVOKE command was entered. There are two forms of the REVOKE command. The first form is used to revoke a user's database access privileges. The second form is used to revoke a user's object privileges.

Action:Check the command syntax and retry the statement.


ORA-00993

ORA-00993missing GRANT keyword

Cause:The keyword WITH was specified at the end of a GRANT statement without the keyword GRANT. In order to grant privileges to a user and also the permission to grant those privileges to another user, the keywords WITH GRANT OPTION must be specified at the end of the GRANT statement.

Action:Change the keyword WITH to the keywords WITH GRANT OPTION, then re-execute the statement.


ORA-00994

ORA-00994missing OPTION keyword

Cause:The keywords WITH GRANT were specified at the end of a GRANT statement without the keyword OPTION.

Action:Change the keywords WITH GRANT to the keywords WITH GRANT OPTION; then re-execute the statement.


ORA-00995

ORA-00995missing or invalid synonym identifier

Cause:In a CREATE or DROP SYNONYM statement, the synonym name was either missing or invalid.

Action:Check syntax and spelling. A valid synonym name must be specified immediately following the keyword SYNONYM in both statements. Valid synonym names must begin with a letter, consist of alphanumeric characters and the special characters $, _, and #, and be less than or equal to 30 characters. They may not be reserved words.


ORA-00996

ORA-00996the concatenate operator is ||, not |

Cause:A single bar (|) was interpreted as an attempt to specify concatenation but the concatenation operator is a double bar (||).

Action:Enter a double bar (||) for concatenation or remove single bar (|) if concatenation was not intended.


ORA-00997

ORA-00997illegal use of LONG datatype

Cause:A value of datatype LONG was used in a function or in a DISTINCT, WHERE, CONNECT BY, GROUP BY, or ORDER BY clause. A LONG value can only be used in a SELECT clause.

Action:Remove the LONG value from the function or clause.


ORA-00998

ORA-00998must name this expression with a column alias

Cause:An expression or function was used in a CREATE VIEW statement, but no corresponding column name was specified. When expressions or functions are used in a view, all column names for the view must be explicitly specified in the CREATE VIEW statement.

Action:Enter a column name for each column in the view in parentheses after the view name.


ORA-00999

ORA-00999invalid view name

Cause:In a CREATE VIEW statement, the view name was missing or invalid.

Action:Enter a valid view name following CREATE VIEW. Valid view names must begin with a letter, consist of only alphanumeric characters and the special characters $, _, and #, be less than or equal to 30 characters, and may not be reserved words. If the view name contains other characters it must be enclosed in double quotes.


ORA-01000

ORA-01000maximum open cursors exceeded

Cause:A host language program attempted to open too many cursors. The maximum number of cursors per user is determined by the initialization parameter OPEN_CURSORS.

Action:Modify the program to use fewer cursors. If this error occurs often, shut down ORACLE, increase the value of OPEN_CURSORS, and then restart ORACLE.


ORA-01001

ORA-01001invalid cursor

Cause:Either a host language program call specified an invalid cursor, or the values of the AREASIZE and MAXOPENCURSORS options in the precompiler command were too small. All cursors must be opened (using the OOPEN call) before being referenced in any of the following calls: SQL, DESCRIBE, NAME, DEFINE, BIND, EXEC, FETCH, and CLOSE. The Logon Data Area (LDA) must be defined by using OLON or OLOGON. If the LDA is not defined, this message is issued for the following calls: OPEN, COM, CON, ROL, and LOGOFF.

Action:Check the erroneous call statement. Specify a correct LDA area or open the cursor as required. If there is no problem with the cursor, it may be necessary to increase the AREASIZE and MAXOPENCURSORS options before precompiling.


ORA-01002

ORA-01002fetch out of sequence

Cause:In a host language program, a FETCH call was issued out of sequence. A successful parse-and-execute call must be issued before a fetch. This can occur if an attempt was made to FETCH from an active set after all records have been fetched. This may be caused by fetching from a SELECT FOR UPDATE cursor after a commit. A PL/SQL cursor loop implicitly does fetches and may also cause this error.

Action:Parse and execute a SQL statement before attempting to fetch the data.


ORA-01003

ORA-01003no statement parsed

Cause:A host language program call referenced a cursor with no associated parsed SQL statement. A SQL call (for example, OSQL3) must be used to pass a SQL statement to ORACLE and to associate the statement with an open cursor. A cursor must already have an associated SQL statement if referenced in any of the following calls: DESCRIBE, NAME, DEFINE, BIND, EXECUTE, and FETCH.

Action:Do the SQL call (for example, OSQL) to pass the required SQL statement before referencing the cursor.


ORA-01004

ORA-01004default username feature not supported; logon denied

Cause:An attempt was made to use automatic logon on a system not supporting this feature.

Action:Specify the complete username and password to log on to ORACLE.


ORA-01005

ORA-01005null password given; logon denied

Cause:An invalid password was given when logging on.

Action:Provide a valid password.


ORA-01006

ORA-01006bind variable does not exist

Cause:A program issued a BIND call for a variable not listed in the associated SQL statement. Only those variables prefixed by either a colon (:) or ampersand (&) in the SQL statement may be referenced in a BIND call (OBIND or OBINDN). This error may also be caused by a mismatch between a Precompiler program and the related library (SQLLIB).

Action:Modify the BIND call to reference one of the substitute variables specified in the associated SQL statement.


ORA-01007

ORA-01007variable not in select list

Cause:A reference was made to a variable not listed in the SELECT clause. In OCI, this can occur if the number passed for the position parameter is less than 1 or greater than the number of variables in the SELECT clause in any of the following calls: DESCRIBE, NAME, or DEFINE. In SQL*Forms or SQL*Report, specifying more variables in an INTO clause than in the SELECT clause also causes this error.

Action:In OCI, specify a position number between 1 and the number of variables in the SELECT clause. In SQL*Forms or SQL*Report, specify an equal number of variables in the SELECT and INTO clauses.


ORA-01008

ORA-01008not all variables bound

Cause:A SQL statement containing substitution variables was executed without all variables bound. All substitution variables must have a substituted value before the SQL statement is executed.

Action:In OCI, use an OBIND or OBINDN call to substitute the required values.


ORA-01009

ORA-01009missing mandatory parameter

Cause:A host language program call did not pass all required parameters. The syntax and parameter description for each call is given in the Programmer's Guide to the ORACLE Precompilers.

Action:Check the syntax for the call and enter all required parameters.


ORA-01010

ORA-01010invalid OCI operation

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01011

ORA-01011Cannot use ORACLE7 compatibility mode with an ORACLE Version 6 server

Cause:An attempt was made to use ORACLE7 compatibility mode when accessing ORACLE Version 6.

Action:Do not use ORACLE7 compatibility mode when accessing ORACLE Version 6.


ORA-01012

ORA-01012not logged on

Cause:A host language program issued an ORACLE call (other than OLON or OLOGON) without being logged on to ORACLE. This can occur when a user process attempts to access the database after the instance it is connected to terminates, forcing the process to disconnect.

Action:Log on to ORACLE (by calling OLON or OLOGON) before issuing any ORACLE calls. When the instance has been restarted, retry the action.


ORA-01013

ORA-01013user requested cancel of current operation

Cause:The user interrupted an ORACLE operation by entering CTRL-C (ControlC) or another canceling operation. This forces the current operation to end. This is an informational message only.

Action:Continue with the next operation.


ORA-01014

ORA-01014ORACLE shutdown in progress

Cause:A user tried to log on to ORACLE while an instance shutdown was in progress. ORACLE logons are disabled while ORACLE is being shut down.

Action:Wait until ORACLE is brought back up before attempting to log on.


ORA-01015

ORA-01015logon called recursively

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01016

ORA-01016This function can be called only after a fetch

Cause:The cursor is in an invalid state.

Action:Ensure the appropriate OCI/UPI function is called after the fetch and prior to the offending function.


ORA-01017

ORA-01017invalid username/password; logon denied

Cause:An invalid username or password was entered in an attempt to log on to ORACLE. The username and password must be the same as was specified in a GRANT CONNECT statement. If the username and password are entered together, the format is: username/password.

When Trusted ORACLE is configured in OS MAC mode, this error may occur if attempting to query a table/view in a secondary database when the username was not created or granted the CREATE SESSION privilege in the secondary database.

When Trusted ORACLE is configured in DBMS MAC mode, this error may occur if granted the CREATE SESSION system privilege at a higher label than that attempted at login.

Action:Enter a valid username/password combination in the correct format.

For Trusted ORACLE users, if the cause of this error is that the username was either not created or not granted the CREATE SESSION system privilege in a secondary database, ask the database administrator to authorize the username to access the secondary database. Alternatively, if the cause of this error is that the username is granted the CREATE SESSION system privilege at a higher label than that of the attempted login, either login at that higher label or ask the database administrator to re-grant the privilege at the appropriate label.


ORA-01018

ORA-01018column does not have a LONG datatype

Cause:An attempt was made to fetch data using the LONG fetch option, but the specified column was not LONG.

Action:Re-execute the fetch without the LONG fetch option, or create the table with a LONG column.


ORA-01019

ORA-01019unable to allocate memory in the user side

Cause:The user side memory allocator returned an error.

Action:Increase the process' heap size or switch to the old set of calls.


ORA-01020

ORA-01020unknown context state

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01021

ORA-01021invalid context size specified

Cause:An invalid value was entered for the initial context area size. The initialization parameter CONTEXT_AREA specifies the context area size which, must be between 1024 and 131,072 bytes.

Action:Specify an initial context area size between 1024 and 131,072 bytes.


ORA-01022

ORA-01022database operation not supported in this configuration

Cause:The attempted database operation does not conform to the user programming interface (UPI) for the two communicating Oracle servers.

This problem occurs when you use a 7.0.13 server and try to use PL/SQL or remote procedure calls on a 7.0.12 server.

Action:You may need to upgrade one or more of your Oracle servers or relink your user-side application with new libraries.


ORA-01023

ORA-01023cursor context not found (Invalid cursor number)

Cause:The cursor number is not a valid open cursor.

Action:Make sure that the cursor is open.


ORA-01024

ORA-01024invalid datatype in OCI call

Cause:An OCI program call specified an invalid datatype. In OCI calls, ORACLE datatypes are specified as numbers between 1 and 7. Datatypes are described in the Programmer's Guide to ORACLE Precompilers.

Action:Check the datatype description and enter the correct number for the datatype.


ORA-01025

ORA-01025UPI parameter out of range

Cause:An integer parameter to a UPI function is out of range. This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01026

ORA-01026multiple buffers of size > 2000 in the bind list

Cause:There is more than one long buffer in the bind list.

Action:Change the buffer size to be less than 255 for the bind variable bound to a normal column.


ORA-01027

ORA-01027bind variables not allowed for data definition operations

Cause:An attempt was made to use a bind variable in a SQL data definition statement. For example, a CREATE TABLE AS SELECT statement in which the SELECT's WHERE clause refers to a variable.

Action:Remove the bind variable; then re-execute the SQL statement.


ORA-01030

ORA-01030SELECT ... INTO variable does not exist

Cause:The SELECT ... INTO specified in the bind call does not correspond to a variable in the SQL statement.

Action:If it is not possible to correct the statement, call Worldwide Customer Support.


ORA-01031

ORA-01031insufficient privileges

Cause:An attempt was made to change the current username or password without the appropriate privilege. This error also occurs if attempting to UPDATE a table with only SELECT privileges, if attempting to CONNECT INTERNAL, or attempting to install a database without the necessary operating system privileges.

When Trusted ORACLE is configured in DBMS MAC, this error may occur if the user was granted the necessary privilege at a higher label than the current login.

Action:Ask the database administrator to perform the operation or grant the required privileges.

For Trusted ORACLE users getting this error although granted the appropriate privilege at a higher label, ask the database administrator to re-grant the privilege at the appropriate label.


ORA-01032

ORA-01032no such userid

Cause:This is an internal error message related to Export/Import.

Action:Contact Worldwide Customer Support.


ORA-01033

ORA-01033ORACLE startup or shutdown in progress

Cause:An attempt was made to log on while ORACLE is being started up or shut down.

Action:Wait a few minutes; then retry the operation.


ORA-01034

ORA-01034ORACLE not available

Cause:ORACLE was not started up. Possible causes are:

·The SGA requires more space than was allocated for it.

·The operating system variable pointing to the instance is improperly defined.

Action:Refer to accompanying messages for possible causes and correct the problem mentioned in the other messages. Retry after ORACLE has been initialized. If ORACLE has been initialized, verify that ORACLE was linked correctly. Also, refer to the installation or user's guide for additional information about this error.


ORA-01035

ORA-01035ORACLE only available to users with RESTRICTED SESSION privilege

Cause:Logins are disallowed because an instance started in restricted mode. Only users with the RESTRICTED SESSION system privilege can log on.

Action:Request that ORACLE be restarted without the restricted option, or obtain the RESTRICTED SESSION system privilege.


ORA-01036

ORA-01036illegal variable name/number

Cause:Unable to find bind context on user side.

Action:Make sure that the variable being bound is in the SQL statement.


ORA-01037

ORA-01037cannot allocate sort work area cursor; too many cursors

Cause:The maximum number of cursors for the program has been exceeded.

Action:Retry the operation using fewer open cursors.


ORA-01038

ORA-01038cannot write data file version ver with ORACLE Version ver

Cause:An attempt was made to write data file headers in an old format. The new format can not be used until after the database has been verified as being compatible with this software version.

Action:Open the database to advance to the new file formats, then repeat the operation. If the operation is required before the database can be opened; then use the previous software release to do the operation.


ORA-01039

ORA-01039insufficient privileges on underlying objects of the view

Cause:An attempt was made to use explain plan on another user's view without the necessary privileges on the underlying objects of the view.

Action:Obtain the necessary privileges or do not perform the offending operation.


ORA-01040

ORA-01040invalid character in password; logon denied

Cause:There are multibyte characters in the password or some characters in the password are not in the US7ASCII range.

Action:Resubmit password with valid characters.


ORA-01041

ORA-01041internal error. HOSTDEF extension does not exist

Cause:The pointer to the HSTDEF extension in HSTDEF is null.

Action:Report as a bug to Worldwide Customer Support.


ORA-01042

ORA-01042detaching a session with open cursors not allowed

Cause:An attempt was made to detach a session that has open cursors.

Action:Close all the cursors before detaching the session.


ORA-01043

ORA-01043user side memory corruption [num], [num], [num], [num]

Cause:The application code corrupted some of the user memory.

Action:Make certain that the application code is not overwriting memory. Contact Worldwide Customer Support.


ORA-01044

ORA-01044size num of buffer bound to variable name exceeds maximum num

Cause:An attempt was made to bind a buffer whose total size would exceed the maximum size allowed. The total array size for arrays is calculated as (element_size) * (number of elements)

Action:Reduce the buffer size.


ORA-01045

ORA-01045user name lacks CREATE SESSION privilege; logon denied

Cause:An attempt was made to connect to a userid that does not have create session privilege.

Action:If required, GRANT the user the CREATE SESSION privilege.


ORA-01046

ORA-01046cannot acquire space to extend context area

Cause:ORACLE could not extend the current area any further because the operating system would not supply any more space. A system-specific message should appear following this message.

Action:Close some cursors and try again, or check operating system quotas to allow use of more virtual memory.


ORA-01047

ORA-01047the above error occurred in schema=name, package=name, procedure=name

Cause:This message is displayed after a previous message to provide more specific information.

Action:See the cause and action for the previous message.


ORA-01048

ORA-01048couldn't find the specified procedure in the given context

Cause:The user of the procedure specified a deferred RPC that does not exist.

Action:Ensure that the procedure was specified correctly and that the replication process can locate the procedure.


ORA-01049

ORA-01049bind by name is not supported in streamed RPC

Cause:This error occurs when a newer server version requests from an older server version an operation that is not supported.

Action:You may need to upgrade one or more of your Oracle servers or relink your user application with new libraries.


ORA-01050

ORA-01050cannot acquire space to open context area

Cause:ORACLE could not open a new context area because the operating system would not supply any more space. A system-specific message should appear following this message.

Action:Close some cursors and try again, or check operating system quotas to allow use of more virtual memory.


ORA-01051

ORA-01051deferred RPC buffer format invalid

Cause:The deferred RPC data in SYS.DEF$_CALL is corrupted.

Action:Contact customer support.


ORA-01053

ORA-01053user storage address cannot be read

Cause:A bind variable or other user area could not be read by ORACLE.

Action:Check that binds are done correctly on valid user buffers, then retry the operation.


ORA-01054

ORA-01054user storage address cannot be written

Cause:A define (FETCH ... INTO or SELECT ... INTO) variable or other user area could not be written to by ORACLE.

Action:Check that INTO variables and indicators are correctly specified; then retry the operation.


ORA-01057

ORA-01057invalid or ambiguous block.field reference in user exit

Cause:The reference to a block.field identifier in a user exit is incorrect or ambiguous, probably because it is misspelled or incomplete.

Action:Check syntax and identifier spelling; then correct the reference.


ORA-01058

ORA-01058internal New Upi interface error

Cause:An attempt was made to delete a non-existent HSTDEF extension.

Action:Contact customer support.


ORA-01059

ORA-01059parse expected before a bind or execute

Cause:The client application attempted to bind a variable or execute a cursor opened in a PL/SQL block before the statement was parsed.

Action:Ensure the statement is parsed before a bind or execute.


ORA-01060

ORA-01060array binds or executes not allowed

Cause:The client application attempted to bind an array of cursors or attempted to repeatedly execute against a PL/SQL block with a bind variable of type cursor.

Action:Bind a single cursor or execute the PL/SQL block one.


ORA-01061

ORA-01061cannot start up a V8 server using a V7 client application

Cause:You are using an Oracle client application linked with version 7 (or lower) libraries and you attempted to start up a V8 (or higher) server.

Action:Use a client application linked with V8 (or higher) libraries.


ORA-01070

ORA-01070Using an old version of Oracle for the server

Cause:An attempt was made to run an older, obsolete ORACLE7 Server.

Action:Upgrade the server.


ORA-01071

ORA-01071cannot perform operation without starting up ORACLE

Cause:An attempt was made to perform an operation before ORACLE was started.

Action:Start up ORACLE; then retry the operation.


ORA-01072

ORA-01072cannot stop ORACLE; ORACLE not running

Cause:An attempt was made to stop ORACLE, but ORACLE was not running.

Action:No user action is required.


ORA-01073

ORA-01073fatal connection error: unrecognized call type

Cause:An illegal internal operation was attempted. This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01074

ORA-01074cannot shut down ORACLE; inside a logon session - log off first

Cause:An attempt was made to shut down ORACLE inside a logon session.

Action:Log off before shutting down ORACLE.


ORA-01075

ORA-01075currently logged on

Cause:An attempt was made to log on while already logged on.

Action:No user action is required.


ORA-01076

ORA-01076multiple logons per process not yet supported

Cause:ORACLE does not support multiple logons per process.

Action:No user action is required.


ORA-01077

ORA-01077background process initialization failure

Cause:A failure occurred during initialization of the background processes.

Action:Refer to the diagnostic information in the accompanying message stack or in the trace file, and take appropriate action.


ORA-01078

ORA-01078failure in processing initialization parameters

Cause:A failure occurred during processing of the initialization parameters during system startup.

Action:Refer to the diagnostic information in the accompanying message stack, and take appropriate action.


ORA-01079

ORA-01079ORACLE database was not properly created, operation aborted

Cause:There was an error when the database or control file was created.

Action:Check the message signaled when the database was first created or when the control file was re-created. Take appropriate actions to re-create the database or a new control file.


ORA-01080

ORA-01080error in shutting down ORACLE

Cause:A failure occurred during system shutdown.

Action:Refer to the diagnostic information in the accompanying message stack, and take appropriate action.


ORA-01081

ORA-01081cannot start already-running ORACLE - shut it down first

Cause:An attempt was made to start ORACLE while it was already running.

Action:Shut down ORACLE first, if you want to restart it.


ORA-01082

ORA-01082ROW_LOCKING = ALWAYS requires the transaction processing option

Cause:ROW_LOCKING = ALWAYS is specified in INIT.ORA file. This feature is not supported by ORACLE without the transaction processing option.

Action:Remove ROW_LOCKING = ALWAYS from the INIT.ORA file or set it to DEFAULT or INTENT.


ORA-01083

ORA-01083value of parameter var is inconsistent with that of other servers

Cause:The value of the given initialization parameter is required to be the same for all servers in the parallel configuration.

Action:Change the value in the initialization parameter file to match that of the other control files.


ORA-01084

ORA-01084invalid argument in OCI call

Cause:The failing OCI call contains an argument with an invalid value.

Action:Use valid argument values. For more information, see the Programmer's Guide to the Oracle Call Interface and the appropriate programming language supplement.


ORA-01085

ORA-01085preceding errors in deferred RPC to name.name.name

Cause:Errors were encountered when the named procedure was executed as a deferred, remote procedure call.

Action:Correct the cause of the preceding errors.


ORA-01086

ORA-01086savepoint 'name' never established

Cause:An attempt was made to roll back to a savepoint that was never established.

Action:No user action is required.


ORA-01087

ORA-01087cannot start up ORACLE - currently logged on

Cause:An attempt was made to start up ORACLE by a user who is currently logged on.

Action:Log off; then issue the STARTUP command.


ORA-01088

ORA-01088cannot shut down ORACLE while active processes exist

Cause:Users are still logged on to the instance.

Action:Either wait for all users to log off or issue the SHUTDOWN IMMEDIATE command to force the users off the system. Alternatively, issue the SHUTDOWN ABORT command to shut down the database without waiting for users to be forced off.


ORA-01089

ORA-01089immediate shutdown in progress - no operations are permitted

Cause:The SHUTDOWN IMMEDIATE command was used to shut down a running ORACLE instance, terminating any active operations.

Action:Wait for the instance to be restarted, or contact the database administrator.


ORA-01090

ORA-01090shutdown in progress - connection is not permitted

Cause:The SHUTDOWN command was used to shut down a running ORACLE instance, disallowing any connects to ORACLE.

Action:Wait for the instance to restart, or contact the database administrator.


ORA-01091

ORA-01091failure during startup force

Cause:Unable to destroy the old SGA.

Action:Manually remove the old SGA (see the installation or user's guide for instructions); then re-issue the STARTUP command.


ORA-01092

ORA-01092ORACLE instance terminated. Disconnection forced.

Cause:The instance connected to was terminated abnormally probably due to a SHUTDOWN ABORT. The current process was forced to disconnect from the instance.

Action:Contact the database administrator to determine when the instance is restarted. Attempt to reconnect after the instance is running again.


ORA-01093

ORA-01093ALTER DATABASE CLOSE only permitted with no sessions connected

Cause:There is at lease one more session (other than the current one) logged in to the instance. ALTER DATABASE CLOSE is not permitted when other sessions are active.

Action:Find the other sessions and disconnect them. Then resubmit the ALTER DATABASE CLOSE command. Also, issue the SHUTDOWN IMMEDIATE command to force users off the system. Or, issue the SHUTDOWN ABORT command to shut down the database without waiting for users to be forced off.


ORA-01094

ORA-01094ALTER DATABASE CLOSE in progress. Connections not permitted

Cause:An attempt was made to connect while the database is being closed with the ALTER DATABASE CLOSE command.

Action:Attempt to connect again when the database is open. Contact the database administrator to find out when the database will be open.


ORA-01095

ORA-01095DML statement processed zero rows

Cause:A DML cursor from the OTEX() call processed 0 rows when executed.

Action:Caller can either do a rollback or ignore the message and execute the rest of the cursors in the cursor array.


ORA-01096

ORA-01096program version (num) incompatible with instance (num)

Cause:The program was linked with a different version of the server than the instance it is attempting to connect to.

Action:Re-link the program against the same version of ORACLE as the instance, or restart (startup force) the database using the program's version of the SERVER.


ORA-01097

ORA-01097cannot shutdown while in a transaction -commit or rollback

Cause:An attempt was made to shut down the database while a transaction was in progress.

Action:Either commit or rollback the current transaction and then attempt to shut down the database.


ORA-01098

ORA-01098program interface error during LONG insert

Cause:The application program interface could not insert or update a LONG column because of an internal error when a TTCGETV call fails. For example, a network read error or one of the parameters passed to the call is invalid.

Action:Retry the insert or update.


ORA-01099

ORA-01099cannot mount database in SHARED mode if started in single process mode

Cause:An attempt was made to mount a database in parallel mode with the initialization parameter SINGLE_PROCESS set to TRUE.

Action:Either mount the database in EXCLUSIVE mode or set the initialization parameter SINGLE_PROCESS to FALSE before starting the instance in parallel (shared) mode.

________________________________________


ORA-01100

ORA-01100database already mounted

Cause:An attempt was made to mount a database with the name of a currently mounted database.

Action:No user action is required.


ORA-01101

ORA-01101database being created currently mounted by some other instance

Cause:An attempt was made to create a database with the name of a currently mounted database.

Action:Either change the database name or shut down the other instance.


ORA-01102

ORA-01102cannot mount database in exclusive mode

Cause:An instance tried to mount the database in exclusive mode, but some other instance has already mounted the database in exclusive or parallel mode.

Action:Either mount the database in parallel mode or shut down all other instances before mounting the database in exclusive mode.


ORA-01103

ORA-01103database name 'name' in control file is not 'name'

Cause:The database name used does not match that in the control file.

Action:Ensure the correct control file and database name are used.


ORA-01104

ORA-01104number of control files (num) does not equal num

Cause:The number of control files used by this instance disagrees with the number of control files in an existing instance that is accessing the same database.

Action:Make sure all control files are listed in the initialization parameter CONTROL_FILES, then retry the operation.


ORA-01106

ORA-01106database must be closed before dismounting

Cause:An attempt was made to dismount a database before it was closed.

Action:Close the database, then retry the operation.


ORA-01107

ORA-01107database must be mounted for media recovery

Cause:An attempt to perform media recovery was made but the database is not mounted.

Action:Mount the database, then retry the operation.


ORA-01108

ORA-01108media recovery active on file name

Cause:Media recovery is actively being applied to the given file. The file cannot be used for normal database access or crash recovery.

Action:Wait for media recovery to complete, or cancel the media recovery session.


ORA-01109

ORA-01109database not open

Cause:An attempt was made to perform an operation on an unopened database.

Action:Open the database, then retry the operation.


ORA-01110

ORA-01110data file name: 'str'

Cause:This message reports the file name involved with other messages.

Action:See the associated messages for a description of the problem.


ORA-01111

ORA-01111name for data file name is unknown - rename to correct file

Cause:The data file was missing from a CREATE CONTROLFILE command or backup control file recovery was done with a control file that was saved before the file was created.

Action:Rename the missing file to the name of the real file.


ORA-01112

ORA-01112media recovery not started

Cause:An attempt was made to continue media recovery, but media recovery had not been started.

Action:No user action is required.


ORA-01113

ORA-01113file name needs media recovery

Cause:An attempt was made to open a data file that is in need of media recovery.

Action:First apply media recovery to the data file identified in the message, then retry the operation.


ORA-01114

ORA-01114IO message writing block to file name (block # num)

Cause:The device on which the file resides is probably offline.

Action:Restore access to the device, then retry the operation.


ORA-01115

ORA-01115IO message reading block from file name (block # num)

Cause:The device on which the file resides is probably offline.

Action:Restore access to the device, then retry the operation.


ORA-01116

ORA-01116message in opening data file name

Cause:Usually the file is not accessible.

Action:Make sure the data file is in the expected location and can be accessed properly, then retry the operation.


ORA-01117

ORA-01117adding file 'name' with illegal block size num, limit is num

Cause:An attempt was made to add a data file with a block size that is greater than the maximum block size allowed.

Action:Retry the operation with a smaller block size.


ORA-01118

ORA-01118cannot add any more data files: limit of num exceeded

Cause:An attempt to add a data file failed because the limit for such files had already been reached.

Action:If more database space is required, export the database and re-create it with a higher limit for data files (and perhaps increased file size).


ORA-01119

ORA-01119message in creating data file 'name'

Cause:Insufficient space on device.

Action:Decrease the size of the requested file, or allocate a file on another device with more available space. If a file size was not specified in the statement, then specify a file size smaller than the available space on the device.


ORA-01120

ORA-01120cannot remove online data file name; database is open or mounted parallel

Cause:An attempt to remove an online data file failed because the file was not closed, or was opened in parallel mode. This message can occur when trying to drop a tablespace. A tablespace cannot be dropped while users are accessing its data, index, rollback, or temporary segments, or while the database is mounted in parallel mode.

Action:Shut down ORACLE and mount the database in exclusive mode to drop a tablespace. To prevent users from opening the tablespace, take it offline, or put the instance in restricted access mode.


ORA-01121

ORA-01121cannot rename data file name - file is in use or recovery

Cause:An attempt to rename an online data file failed because the file was not closed or was being recovered. Either the file is online and the data file is open to some instance, or another process is currently performing media recovery on the file.

Action:Close the file, or shut down ORACLE and mount the database in exclusive mode. End all recovery sessions. To prevent users from opening the file, take its tablespace off line, or put the instance into restricted mode.


ORA-01122

ORA-01122data file name - failed verification check

Cause:The information in the data file is inconsistent with information from the control file. This could be because the control file is from a time earlier than the data files, or the data file size does not match the size specified in the control file, or the data file is corrupted.

Action:Make certain that the data files and control files are the correct files for this database, then retry the operation.


ORA-01123

ORA-01123cannot start online backup; media recovery not enabled

Cause:An attempt to start backup of an online tablespace failed because archiving was not enabled.

Action:Enable archiving and retry the operation.


ORA-01124

ORA-01124cannot recover online file 'name' - must be offline to recover

Cause:An attempt was made to recover an online file.

Action:Take the file offline before recovery.


ORA-01125

ORA-01125cannot disable media recovery - file name has online backup set

Cause:An attempt to disable media recovery encountered an online recovery still in progress.

Action:Wait for the recovery to finish before retrying the operation.


ORA-01126

ORA-01126database must be mounted exclusive and not open for this operation

Cause:An operation failed because the database was not mounted in exclusive mode.

Action:Shut down ORACLE and mount the database in exclusive mode.


ORA-01127

ORA-01127database name 'name' exceeds size limit of num characters

Cause:The specified database name is too long.

Action:Shorten the database name to eight characters or fewer, then retry the operation.


ORA-01128

ORA-01128cannot start online backup - file name is offline

Cause:A file to be backed up in the online backup is offline.

Action:Either:

1) Bring the file online for the online backup.

2) Do an offline backup.


ORA-01129

ORA-01129user's default tablespace does not exist

Cause:A user's default or temporary tablespace was dropped.

Action:Re-create the tablespace that was dropped, or change the user's default or temporary tablespace.


ORA-01130

ORA-01130data file version num incompatible with ORACLE Version num

Cause:The named data file was created under an incompatible version of ORACLE, or the file is invalid or nonexistent.

Action:Shut down and restart the correct version of ORACLE, or check the references to the data file and make sure it exists.


ORA-01131

ORA-01131DB_FILES files initialization parameter value num exceeds limit of num

Cause:The specified value of the initialization parameter DB_FILES is too large.

Action:Reduce the value of the DB_FILES parameter and retry the operation.


ORA-01132

ORA-01132length of data file name 'name' exceeds limit of num characters

Cause:The specified data file name is too long.

Action:Shorten the file name and retry the operation.


ORA-01133

ORA-01133length of logfile name 'name' exceeds limit of num characters

Cause:The specified redo log file name is too long.

Action:Shorten the file name and retry the operation.


ORA-01134

ORA-01134database mounted exclusive by another instance

Cause:An attempt to access a database failed because it is mounted in exclusive mode by another instance.

Action:Either shut down the other instance, or wait for the other instance to either close the database or mount it in parallel mode, before retrying the operation.


ORA-01135

ORA-01135file name accessed for DML/query is offline

Cause:A query failed because it referenced a data file that belongs to an offline tablespace. An offline tablespace must be brought online to access its data.

Action:Wait until the tablespace is brought online before executing the query.


ORA-01136

ORA-01136specified size of file num (num blocks) is less than original size of num blocks

Cause:An attempt was made to specify a size in the AS clause of the ALTER DATABASE CREATE DATA FILE command that is smaller than the size needed.

Action:Issue the statement again using the correct size for the file.


ORA-01137

ORA-01137data file name is still in the middle of going offline

Cause:It was not possible to get the lock for a file that is offline when attempting to bring it online. The most likely cause is that the lock is still held by the instance that is took it offline.

Action:Wait for the other instance to release the lock on the file.


ORA-01138

ORA-01138database must either be open in this instance or not at all

Cause:The requested operation cannot be done when the database is mounted but not open by this instance, and another instance has the database open.

Action:Execute the operation in the open instance, open the database in the current instance, or close the database in the other instances.


ORA-01139

ORA-01139RESET LOGS option only valid after an incomplete database recovery

Cause:The RESET LOGS option was specified in an ALTER DATABASE OPEN statement, but there has been no incomplete recovery session.

Action:Re-execute the statement without specifying RESET LOGS.


ORA-01140

ORA-01140cannot end online backup - all files are offline

Cause:All the files were offline when attempting to end an online backup.

Action:None. Online backup does not need to be ended for this tablespace.


ORA-01141

ORA-01141message renaming data file name - new file 'name' not found

Cause:An attempt to change a data file's name in the control file failed because no file was found with the new name.

Action:Make sure that the data file has been properly renamed by the operating system, then retry the operation.


ORA-01142

ORA-01142cannot end online backup - none of the files are in backup

Cause:None of the files were found to be in the online backup when attempting to end the online backup.

Action:None. Online backup does not need to be ended for this tablespace.


ORA-01143

ORA-01143cannot disable media recovery - file name is offline

Cause:An attempt to disable media recovery found a file that needs media recovery, thus media recovery cannot be disabled.

Action:Recover the offending file or drop the tablespace to which it belongs, then retry the operation.


ORA-01145

ORA-01145offline immediate disallowed unless media recovery enabled

Cause:ALTER TABLESPACE ... OFFLINE IMMEDIATE or ALTER DATABASE DATA FILE ... OFFLINE is only allowed if database is in ARCHIVEREDO LOG mode.

Action:Take the tablespace offline normally or do a shutdown abort before attempting the required operation. It is worthwhile reconsidering the backup strategy for the database. The attempted operations can be done if ARCHIVEREDO LOG mode is enabled.


ORA-01145

ORA-01145offline immediate disallowed unless media recovery enabled

Cause:ALTER TABLESPACE ... OFFLINE IMMEDIATE or ALTER DATABASE DATAFILE ... OFFLINE is only allowed if database is in ARCHIVEREDOLOG mode.

Action:Take the tablespace offline as usual or do a shutdown abort before attempting the required operation. It is worthwhile reconsidering the backup strategy for the database. The attempted operations can be done if ARCHIVEREDO LOG mode is enabled.


ORA-01146

ORA-01146cannot start online backup - file name is already in backup

Cause:An attempt was made to start an online backup, but an online backup was already started for one of the data files.

Action:End the first backup before beginning another.


ORA-01147

ORA-01147SYSTEM tablespace file name is offline

Cause:A file belonging to the SYSTEM tablespace has been marked offline by the database administrator. The database cannot be started until all SYSTEM tablespace files are online and can be opened.

Action:Bring the file online.


ORA-01148

ORA-01148database must be mounted exclusive for this operation

Cause:Database was not mounted exclusive.

Action:Mount the database in exclusive mode and retry the operation.


ORA-01149

ORA-01149cannot shutdown - file name has online backup set

Cause:A normal shutdown was attempted while online backup is in progress.

Action:End the online backup and then shut down.


ORA-01150

ORA-01150cannot offline tablespace - file name has online backup set

Cause:Tablespace cannot be taken offline when online backup is running.

Action:End the online backup and then take the tablespace offline.


ORA-01151

ORA-01151use media recovery to recovery block, restore backup if needed

Cause:Crash recovery or instance recovery could not apply a change to a block because it was not the next change. This can happen if the block was corrupted and then repaired during recovery. This message is usually accompanied by ORA-01172.

Action:There is additional information for ORA-01172. Perform a RECOVER DATA FILE for the file containing the block. If this does not resolve the problem then restore the file from a backup and recover it again.


ORA-01152

ORA-01152file name was not restored from a sufficiently old backup

Cause:An incomplete recovery session was started, but an insufficient number of redo logs were applied to make the database consistent; this file is still in the future of the last redo log applied. The most likely cause of this message is forgetting to restore the file from backup before doing incomplete recovery.

Note: This message cannot always be caught.

Action:Apply additional redo log files until the database is consistent or restore the data files from an older backup and repeat recovery.


ORA-01153

ORA-01153an incompatible media recovery is active

Cause:An attempt was made to start an incompatible media recovery or open and reset the redo log files during media recovery. Media recovery sessions are incompatible if they attempt to recover the same data file. Incomplete media recovery or OPEN RESETLOGS is incompatible with any media recovery.

Action:Wait for the completion of, or cancel, the other media recovery session.


ORA-01154

ORA-01154database busy. Open, Close, mount, and dismount not allowed now

Cause:Some operation is in progress that expects the state of the instance to remain open or mounted.

Action:Wait for the operation to complete and try again. If attempting a normal database shutdown, try SHUTDOWN ABORT.


ORA-01155

ORA-01155the database is being opened, closed, mounted, or dismounted

Cause:The attempted operation will not succeed while the instance is in one of the states mentioned in the message.

Action:Wait for the open, close, mount, or dismount to complete and try again. If attempting a normal database shutdown, try SHUTDOWN ABORT.


ORA-01156

ORA-01156recovery in progress may need access to files

Cause:Either media or instance recovery is in progress. The recovery may need access to the files that the attempted operation tried to use.

Action:Wait for the recovery to complete and try again.


ORA-01157

ORA-01157cannot identify data file name - file not found

Cause:The background process was not able to find one of the data files. The database will prohibit access to this file but other files will be unaffected. However, the first instance to open the database will need to access all online data files. Accompanying messages from the operating system will describe why the file was not found.

Action:Make the file available to database. Then either open the database or do ALTER SYSTEM CHECK DATA FILES.


ORA-01158

ORA-01158database name already mounted

Cause:Another instance has a database by this name mounted.

Action:Find and shut down the instance that has this database mounted before issuing the CREATE CONTROLFILE statement.


ORA-01159

ORA-01159file name is not from same database as previous files

Cause:Not all of the files specified in the CREATE CONTROLFILE statement are from the same database.

Action:Check the list of files specified in the CREATE CONTROLFILE statement and remove files that are not part of the same database.


ORA-01160

ORA-01160file name is not a str it is of type str

Cause:The file in the DATA FILE or LOGFILE section of the CREATE CONTROLFILE statement is not of the type listed in the command line.

Action:Check the file and determine its type. Enter the command again using the correct type for the file.


ORA-01161

ORA-01161database name name in file header does not match given name of name

Cause:The database name given at the command line does not match the database name found in the file header. The database name specified at the command line is incorrect.

Action:Enter the command again with the correct name for the database.


ORA-01162

ORA-01162block size num in file header does not match DB_BLOCK_SIZE (num)

Cause:CREATE CONTROLFILE discovered that the block size for this file is incompatible with the initialization parameter DB_BLOCK_SIZE used to allocate cache buffers. If this is not the first file then there are a mixture of block sizes, or the file is corrupt.

Action:If this is the first file in the command then correct DB_BLOCK_SIZE to match the file and restart the instance. If not the first file find the correct version of the file.


ORA-01163

ORA-01163file size in header num (bytes) does not match SIZE num (bytes)

Cause:File size specified at CREATE CONTROLFILE does not match the size stored in the header. Most likely the specification is wrong.

Action:Restore the file from a backup and issue the statement again.


ORA-01164

ORA-01164MAXLOGFILES may not exceed num

Cause:The value for MAXLOGFILES specified on the command line is greater than num.

Action:Resubmit the command with a value of MAXLOGFILES that is num or less.


ORA-01165

ORA-01165MAXDATAFILES may not exceed num

Cause:The value for MAXDATAFILES specified on the command line is greater than num.

Action:Resubmit the command with a value of MAXDATAFILES that is num or less.


ORA-01166

ORA-01166file number num is larger than num (num)

Cause:In the CREATE CONTROLFILE statement, the file mentioned has a file number that is larger than that specified in MAXDATAFILES or MAXLOGFILES, or the file number is larger than the maximums specified in the initialization parameter, DB_FILES.

Action:Increase the values of MAXLOGFILES, MAXDATAFILES, or the parameter DB_FILES.


ORA-01167

ORA-01167two files are the same file/group number or the same file

Cause:There is an overlap of file numbers in the files specified on the command line or the same file is specified twice. If they are not the exact same file then one is likely to be a backup of the other. If they are two members of the same redo log they must be specified together in a group file spec.

Action:Confirm that the file mentioned is not a repeat of a file already mentioned in the command. If they are different files then omit the earlier backup. If they are members of the same redo log, insure they are in the same group file specification.


ORA-01168

ORA-01168physical block size num does not match size num of other members

Cause:The file is located on a device with a different physical block size than the other members in the group.

Action:Use a physical device with matching block size.


ORA-01169

ORA-01169DATA FILE number 1 not found. Must be present

Cause:Data file number 1 was not specified in a CREATE CONTROLFILE statement.

Action:Locate data file number 1 and resubmit the CREATE CONTROLFILE statement, making certain to include data file 1 on the command line.


ORA-01170

ORA-01170file not found 'name'

Cause:A file specified in the CREATE CONTROLFILE statement was not found. All data files (and all redo log files, if NORESETLOGS was used) must be accessible by the process that issues the CREATE CONTROLFILE statement.

Action:Check the statement for a typing mistake in the file name, and check for the existence of all files. Then issue the statement again after correcting the file names.


ORA-01171

ORA-01171data file string is going offline due to message advancing checkpoint

Cause:The checkpoint in the file header could not be advanced. See accompanying messages for the reason. The data file will be taken offline the same as for a write message of a data block.

Action:See accompanying messages for details. Restore access to the file, do media recovery, and bring it back online.


ORA-01172

ORA-01172recovery of thread num stuck at block num of file name

Cause:Crash recovery or instance recovery could not apply a change to a block because it was not the next change. This can happen if the block was corrupted and then repaired during recovery.

Action:Perform a RECOVER DATA FILE for the file containing the block. If this does not resolve the problem then restore the file from a backup and recover it again.


ORA-01173

ORA-01173data dictionary indicates missing data file from system tablespace

Cause:Either:

1) The database is recovered to a point in time in the future of the control file.

2) A data file from the system tablespace is omitted from the issued CREATE CONTROLFILE statement.

Action:Either:

1) Recover the database from a more recent control file.

2) Re-create the control file, ensuring all data files are included for the system tablespace in the command line.


ORA-01174

ORA-01174DB_FILES is num but needs to be num to be compatible

Cause:The maximum number of data files supported by this instance is not the same as for the other instances. All instances must be able to open all the files any instance can open.

Action:Change the value of the DB_FILES initialization parameter to be compatible.


ORA-01175

ORA-01175data dictionary has more than the num files allowed by the instance

Cause:The data dictionary has more files than the instance can support.

Action:Increase the value of the initialization parameter DB_FILES, then shut down and restart the instance.


ORA-01176

ORA-01176data dictionary has more than the num files allowed by the controlfile

Cause:After a CREATE CONTROLFILE statement, the data dictionary has more data files than supported by the control file.

Action:Re-create the controlfile with a larger value for MAXDATA FILES.


ORA-01178

ORA-01178file name created before last CREATE CONTROLFILE, cannot re-create

Cause:An attempt was made to use the ALTER DATABASE CREATE DATA FILE to re-create a data file that existed at the last CREATE CONTROLFILE command. The information needed to re-create the file was lost with the control file that existed when the file was added to the database.

Action:Find a backup of the file, and recover it. Perform incomplete recovery to the time before the file was originally created.


ORA-01178

ORA-01178file name created before last CREATE CONTROLFILE, cannot be recreated

Cause:An attempt was made to use the ALTER DATABASE CREATE datafile to re-create a datafile that existed at the last CREATE CONTROLFILE command. The information needed to re-create the file was lost with the control file that existed when the file was added to the database.

Action:Find a backup of the file and recover it. Perform incomplete recovery to the time before the file was originally created.


ORA-01179

ORA-01179file name does not exist

Cause:During data file recovery, a file was listed that was not part of the database.

Action:Recheck the file name. Remember to use double quotes at the SQL*DBA command line and remember that the file name is translated in the environment of SQL*DBA.


ORA-01180

ORA-01180can not create data file 1

Cause:Data file 1 cannot be created with the ALTERDATABASECREATEDATA FILE command.

Action:Either recover the file from a backup, or re-create the database.


ORA-01181

ORA-01181file name created before last RESETLOGS, cannot re-create

Cause:An attempt was made to use the ALTER DATABASE CREATE DATA FILE command to re-create a data file that existed before the last time the database was opened using the RESETLOGS option.

Action:Find a backup of the file and recover the backup file. Perform incomplete recovery to a time before the file was originally created.


ORA-01182

ORA-01182cannot create data file name - file is in use or recovery

Cause:An attempt was made to use the ALTER DATABASE CREATE DATA FILE command to re-create a data file that is currently online in an open instance or is currently being recovered.

Action:Close the database to all instances or end all recovery sessions, then take the file offline and retry the operation.


ORA-01183

ORA-01183cannot mount database in parallel mode

Cause:The database is mounted in exclusive mode by another instance. It is not possible to mount a database in parallel mode if it is mounted in exclusive mode by another instance.

Action:Shut down the other instance and try again.


ORA-01184

ORA-01184logfile group num already exists

Cause:An ALTER DATABASE ADD LOGFILE command specified a log number for the new redo log which is already in use.

Action:Specify a different redo log file number, or let the database choose an unused value.


ORA-01185

ORA-01185logfile group number num is invalid

Cause:An ALTER DATABASE ADD LOGFILE command specified a redo log number for the new redo log which is too large.

Action:Specify a valid redo log file number.


ORA-01186

ORA-01186verification tests failed on file name

Cause:The data file did not pass the checks to ensure it is part of the database. See the accompanying messages for the reason the verification did not succeed.

Action:Make the correct file available to database. Then either open the database or do ALTER DATABASE CHECK.


ORA-01187

ORA-01187can not read from file name because it failed verification tests

Cause:The data file did not pass the checks to insure it is part of the database. Reading the file is not allowed until it is verified.

Action:Make the correct file available to database. Then either open the database or do ALTER DATABASE CHECK.


ORA-01188

ORA-01188block size num in header does not match physical block size

Cause:A redo log file member given to CREATE CONTROLFILE is on a physical device that has a different block size than the device originally used to create the redo log.

Action:Move the file to a device with the correct block size or use the RESETLOGS option to CREATE CONTROLFILE.


ORA-01189

ORA-01189file is from a different RESETLOGS than previous files

Cause:In a CREATE CONTROLFILE command either this file or all previous files were backups from before the last RESETLOGS. This may also occur if this is a file that is offline and has been offline since before the last RESETLOGS.

Action:If the file was taken offline normal before the last RESETLOGS, and is still offline, omit it from the CREATE CONTROLFILE command. Rename and online the file after the database is open. Otherwise find the version of the mentioned file consist ant with the rest of the data files and resubmit the command.


ORA-01190

ORA-01190control file or data file name is from before the last RESETLOGS

Cause:An attempting was made to perform media recovery when the redo log reset information in a data file does not match the control file. Either the data file or the control file must be a backup that was made before the most recent ALTER DATABASE OPEN RESETLOGS.

Action:Restore the file from a more recent backup.


ORA-01191

ORA-01191file name is already offline - cannot do a normal offline

Cause:An attempt was made to take a tablespace offline normally, but the file named in the message is already offline.

Action:Bring the data file online first, or use the IMMEDIATE option when taking the tablespace offline.


ORA-01192

ORA-01192must have at least one enabled thread

Cause:At least two redo log files from at least one thread must be specified in the CREATE CONTROLFILE command line.

Action:Find the missing redo log files and resubmit the command with the newly found redo log files included in the command line.


ORA-01193

ORA-01193file name is not the same file seen at start of recovery

Cause:An attempt was made to perform media recovery on a file, but a different copy of the file now exists since the last media recovery. Perhaps an invalid backup of the file was resorted.

Action:Find the correct version of the file, then retry media recovery.


ORA-01194

ORA-01194file name needs more recovery to be consistent

Cause:An incomplete recovery session was started, but an insufficient number of redo logs were applied to make the file consistent. The named file was not closed cleanly when it was last opened by the database. The most likely cause of this message is forgetting to restore the file from a backup before doing incomplete recovery.

Action:The file must be recovered to a time when it was not being updated. Either apply more redo logs until the file is consistent, or restore the file from an older backup and repeat recovery.


ORA-01195

ORA-01195online backup of file name needs more recovery to be consistent

Cause:An incomplete recovery session was started, but an insufficient number of redo logs were applied to make the file consistent. The reported file is an online backup which must be recovered to the time the backup ended.

Action:Either apply more redo logs until the file is consistent, or restore the file from an older backup and repeat recovery.


ORA-01196

ORA-01196file name is inconsistent due to a failed media recovery session

Cause:A media recovery session failed while the named file was being recovered. The file is in an inconsistent state and no more recovery was successfully completed on this file.

Action:Either apply more redo logs until the file is consistent, or restore the file from a backup again and repeat recovery.


ORA-01197

ORA-01197thread num only contains one log

Cause:During a CREATE CONTROLFILE statement, all threads represented in the redo logs must be represented by at least two redo logs; a "last redo log" and a second redo log. The named thread does not contain two redo logs.

Action:Either find more redo logs from the named thread, or remove all references to redo logs from that thread, then resubmit the command.


ORA-01198

ORA-01198must specify size for file 'name' if RESETLOGS

Cause:File sizes must be given for all redo log files if doing a CREATE CONTROLFILE with the RESETLOGS option.

Action:Resubmit the command with the appropriate redo log file size.


ORA-01199

ORA-01199file name is not in online backup mode

Cause:Attempting to end an online backup for a file that is not in online backup.

Action:Do not enter command since it is not needed.


ORA-01200

ORA-01200actual file size of num is smaller than correct size of num blocks

Cause:The size of the file, as returned by the operating system, is smaller than the size of the file as indicated in the file header and the control file. Somehow the file has been truncated.

Action:Restore a good copy of the data file from a backup and perform recovery as needed.


ORA-01201

ORA-01201file size num in header does not match size num in control file

Cause:The file sizes in the control file and in the file header do not match. One of the files is probably corrupted.

Action:Replace the corrupted file with a good copy and perform recovery as needed.


ORA-01202

ORA-01202wrong incarnation of this file - wrong creation time

Cause:The creation time in the file header is not the same as the creation time in the control file. This is probably a copy of a file that was dropped.

Action:Restore a current copy of the data file and perform recovery as needed.


ORA-01203

ORA-01203wrong incarnation of this file - wrong creation SCN

Cause:The creation change number in the file header is not the same as the creation change number in the control file. This is probably a copy of a file that was dropped.

Action:Restore a current copy of the data file and perform recovery as needed.


ORA-01204

ORA-01204wrong file - file number is num rather than num

Cause:The file number in the file header is not correct. This is probably a restored backup of the wrong file, but from the same database.

Action:Restore a copy of the correct data file and perform recovery as needed.


ORA-01205

ORA-01205not a data file - type number in header is num

Cause:The file type in the header is not correct for a data file. This is probably a redo log file or control file.

Action:Restore a copy of the correct data file and perform recovery as needed.


ORA-01206

ORA-01206file is not part of this database - wrong database id

Cause:The database ID in the file header does not match the database ID in the control file. The file may be from a different database, or it may not be a data file at all. If the database was rebuilt, this may be a file from before the rebuild.

Action:Restore a copy of the correct data file and perform recovery as needed.


ORA-01207

ORA-01207file is more recent than control file - old control file

Cause:The control file change sequence number in the data file is greater than the number in the control file. This implies that the wrong control file is being used.

Note: If this message occurs repeatedly (by opening the database many times), the message may stop occurring without the problem being corrected. Every attempt to open the database will advance the control file change sequence number until it is great enough.

Action:Use the current control file or perform cancel-based recovery to make the control file current. Be sure to follow all restrictions on performing a cancel-based recovery.


ORA-01208

ORA-01208data file is an old version - not accessing current version

Cause:The checkpoint in the file header is less recent than in the control file. If opening a database that is already open by another instance, or if another instance just caused this file to be placed online, then the database is probably looking at a different version of the file. Otherwise, a backup of the file was probably restored while the file was still in use.

Action:Make correct file available to database. Then either open the database or do ALTER DATABASE CHECK.


ORA-01209

ORA-01209data file is from before the last RESETLOGS

Cause:The reset redo log data in the file header does not match the control file. If the database is closed or the file is offline this is an old backup that was taken before the last ALTER DATABASE OPEN RESETLOGS command. If opening a database that is already open by another instance, or if another instance just onlined this file, then we are probably looking at a different version of the file. Otherwise a backup of the file was probably restored while the file was in use.

Action:Make the correct file available to the database. Then either open the database or issue an ALTER DATABASE CHECK statement.


ORA-01210

ORA-01210data file header is media corrupt

Cause:The file header block is internally inconsistent. The beginning of the block has a header with a checksum and other data for insuring the consistency of the block. It is possible that the last disk write did not operate correctly. The most likely problem is that this is not a data file for any database.

Action:Make the correct file available to the database. Refer to any trace file generated after this message for more information. If the trace file indicates that the checksum is wrong, restore the file from a backup and perform media recovery.


ORA-01211

ORA-01211Version 6 data file is not from conversion to ORACLE7

Cause:The file is not a copy of the file last used under Version6. When converting a database from Version 6 to ORACLE7, the conversion utility must be run the last time the database is opened under Version6. Only the data files that were current when the conversion was done may be accessed by ORACLE7. This data file is either a backup taken from before the conversion, or the database was opened by Version6 after the conversion.

Action:Have the operating system make the correct data file available to the database, or repeat the Version 6 to ORACLE7 conversion.


ORA-01212

ORA-01212MAXLOGMEMBERS may not exceed num

Cause:The value specified for MAXLOGMEMBERS is too large.

Action:Resubmit the command with a smaller value for MAXLOGMEMBERS.


ORA-01214

ORA-01214MAXLOGHISTORY may not exceed num

Cause:The value specified for MAXLOGHISTORY is too large.

Action:Resubmit the command with a smaller value for MAXLOGHISTORY.


ORA-01214

ORA-01214MAXLOGHISTORY may not exceed num

Cause:The value specified for MAXLOGHISTORY is too large.

Action:Retry the command with a smaller value for MAXLOGHISTORY.


ORA-01215

ORA-01215enabled thread num is missing after CREATE CONTROLFILE

Cause:A CREATE CONTROLFILE command did not list all of the enabled threads for the database.

Action:Issue the CREATE CONTROLFILE command again and include all of the enabled threads.


ORA-01216

ORA-01216thread num is expected to be disabled after CREATE CONTROLFILE

Cause:A thread specified in the CREATE CONTROLFILE command was enabled, but the data files indicate that the thread should be disabled. This is probably due to the fact that the redo log files supplied to the CREATE CONTROLFILE command are from a time before the thread was disabled.

Action:This thread is not required for the operation of the database. Resubmit the command without specifying the thread. If desired, the thread can be re-created after the database has been opened.


ORA-01217

ORA-01217logfile member belongs to a different redo log file group

Cause:A member of a redo log file group specified in the CREATE CONTROLFILE command is not part of the same group as the previous members.

Action:Group together the correct members of the redo log file group for the CREATE CONTROLFILE command.


ORA-01218

ORA-01218logfile member is not from the same point-in-time

Cause:A member of a redo log file group specified in the CREATE CONTROLFILE command is from a different pint in time from the previous members. One of the members specified may be an older (possibly a backup copy) version of the redo log.

Action:Find the correct version of the redo log, or leave it out of the CREATE CONTROLFILE command.


ORA-01219

ORA-01219database not open: queries allowed on fixed tables/views only

Cause:A query was issued against an object not recognized as a fixed table or fixed view before the database was opened.

Action:Rephrase the query to include only fixed objects, or open the database.


ORA-01220

ORA-01220file based sort illegal before database is open

Cause:A query issued against a fixed table or view required a temporary segment for sorting before the database was open. Only in-memory sorts are supported before the database is open.

Action:Rephrase the query to avoid a large sort, increase the SORT_AREA_SIZE parameter in the initialization parameter file to enable the sort to done in memory.


ORA-01221

ORA-01221data file name is not the same file to a background process

Cause:When the database writer opens the data file, it is accessing a different physical file than the foreground doing the recovery. The time-stamp set in the file header by the foreground was not found by the background. It may be that the background process could not read the file at all.

Action:Look in the DBWR trace file for the message it received when attempting to read the file header. Reconfigure the operating system as needed to have the file name successfully access the same file when opened by a background process.


ORA-01222

ORA-01222MAXINSTANCES of num requires MAXLOGFILES be at least num, not num

Cause:Attempting to create database or control file that does not have room for at least two redo logs per thread of redo. A thread of redo must have two online redo logs in order to be enabled. It does not make sense to allow more redo threads than can be supported by the logs.

Action:Either reduce the MAXINSTANCES argument or increase MAXLOGFILES.


ORA-01223

ORA-01223RESETLOGS must be specified to set a new database nam

Cause:The SET database name option was specified to CREATE CONTROLFILE, but RESETLOGS was not specified. The database name can only be changed when opening the database with RESETLOGS.

Action:Either add the RESETLOGS option or drop the SET option to CREATE CONTROLFILE.


ORA-01224

ORA-01224group number in header name does not match GROUP name

Cause:Group number specified at CREATE CONTROLFILE does not match the group number stored in the header. Most likely the specification is wrong.

Action:Omit the GROUP option or give the correct one.


ORA-01225

ORA-01225thread number num is greater than MAXINSTANCES num

Cause:The redo log is for a thread greater than the MAXINSTANCES arguments.

Action:Increase the value for MAXINSTANCES and resubmit the command.


ORA-01226

ORA-01226file header of redo log member is inconsistent with other member

Cause:The redo log file member in the accompanying message is for the same group as the previous members, but other fields in the header are different. Either a file header is corrupted, or some file is a member of a deleted redo log.

Action:The correct redo log member or omit this member from the command.


ORA-01227

ORA-01227log name is inconsistent with other log

Cause:The redo log file in the accompanying message is inconsistent with the contents of other redo logs given in the CREATE CONTROLFILE command. Either a file header is corrupted, or some file is an old copy rather than the current version. The problem may not be with the redo log listed since all that can be detected is that there is an inconsistency. All redo log files listed in the command must be the current versions of the online redo logs.

Action:Find the correct online redo logs or use the RESETLOGS option.


ORA-01228

ORA-01228SET DATABASE option required to install seed database

Cause:The SET DATABASE option was not included in the CREATE CONTROLFILE command when installing a seed database. The database does not have a database id because it is intended to be installed at multiple sites, and each site needs to be a different database with its own database ID. Both the SET DATABASE and RESETLOGS options must be specified to create the control file for this database.

Action:command with the SET DATABASE and RESETLOGS options.


ORA-01229

ORA-01229data file name is inconsistent with logs

Cause:The data file in the accompanying message is inconsistent with the contents of the redo logs given in the CREATE CONTROLFILE command. The most likely cause is that one or more of the online redo logs was missing from the command. It is also possible that one or more of the redo logs is an old copy rather than the current version. All online redo log files must be listed in the command and must be the current versions of the online redo logs.

Action:the correct online redo logs or use the RESETLOGS option.

________________________________________


ORA-01230

ORA-01230cannot make read only - file name is offline

Cause:An attempt to make a tablespace read-only encountered an offline file.

Action:Bring the file online and retry the operation.


ORA-01231

ORA-01231cannot make read write - file name is offline

Cause:An attempt to make a tablespace read-write encountered an offline file.

Action:Bring the file online and retry the operation.


ORA-01232

ORA-01232cannot start online backup - file name is read only

Cause:An attempt to start an online backup encountered a read-only file.

Action:Read-only files do not need to be set into online backup mode. Start the backup without using the BEGIN BACKUP command.


ORA-01233

ORA-01233file name is read only - cannot recover using backup control file

Cause:An attempt to do media recovery using a backup control file encountered a read-only file. Typically, read-only files do not need to be recovered. However, if the recovery is using a backup control file, all online files must be recovered.

Action:Take the read-only file offline and bring the tablespace online only after opening the database. Ensure that the backup control file was in use when the currently read-only file was read-write. If such a control file is unavailable, you may be able to re-create it using the CREATE CONTROLFILE command.


ORA-01234

ORA-01234cannot end backup of file name - file is in use or recovery

Cause:Attempted to end an online backup of file when the file is busy. Some operation such as recovery or rename may be active, or there may still be some instance that has the database open with this file online.

Action:If there is an instance with the database open then the backup can be ended by using the ALTER TABLESPACE command. Otherwise wait for the completion of the other operation.


ORA-01235

ORA-01235END BACKUP failed for name file(s) and succeeded for name

Cause:One or more of the files in an end backup command failed. Some other files given in the same command may have succeeded.

Action:See the accompanying error messages for the reason the backups could not be ended. Any files not listed in the error messages were successful.


ORA-01236

ORA-01236error name occurred during initialization of file header access

Cause:The indicated error occurred while doing initialization processing of file headers.

Action:The error indicated should be corrected. An attempt is made to recover from this error by using a slower access algorithm.


ORA-01237

ORA-01237cannot extend datafile name

Cause:An operating system error occurred during the resize.

Action:Fix the cause of the operating system error and retry the command.


ORA-01239

ORA-01239database must be in ARCHIVELOG mode to use external cache

Cause:An online file used an external cache, but the database was in NOARCHIVELOG mode. Since an external cache may require media recovery this cannot be allowed.

Action:Change the database to be in ARCHIVELOG mode or do not use an external cache.

For more information about ARCHIVELOG, see the index entry on "ARCHIVELOG" in Oracle8 Server SQL Reference.


ORA-01240

ORA-01240too many datafiles to add in one command

Cause:The command specified adding more datafiles than can be done in one command. It is necessary to fit all the file names into one log entry, but that would make the entry too large.

Action:If this is a CREATE TABLESPACE command, create with fewer files then add the other files later. If this is an ADD DATAFILE command, break it up into multiple commands.

For more information about CREATE TABLESPACE and ADD DATAFILE, see the index entries on "CREATE TABLESPACE" and on "ADD DATAFILE clause, of ALTER TABLESPACE command" in Oracle8 Server SQL Reference.


ORA-01241

ORA-01241an external cache has died

Cause:The external cache may have been restarted.

Action:Take the file mentioned in the error stack offline, perform media recovery, bring the file online, and retry the attempted operation. You can also restart all instances to make sure they access all datafiles through consistent external caches.

For more information about external caches and the media recovery of datafiles, see the index entries on "caches" and on "datafiles, backups, media recovery and" in Oracle8 Server Concepts.


ORA-01242

ORA-01242data file suffered media failure: database in NOARCHIVELOG

Cause:The database is in NOARCHIVELOG mode and a database file was detected as inaccessible due to media failure.

Action:Restore accessibility to the file mentioned in the error stack and restart the instance.

For more information about media failure, see the index entry on "media failure" in the Oracle8 Server Administrator's Guide. For more information on NOARCHIVELOG, see the index entry on "NOARCHIVELOG" in Oracle8 Server SQL Reference.


ORA-01243

ORA-01243system tablespace file suffered media failure

Cause:A system tablespace file was detected as inaccessible due to media failure.

Action:Restore accessibility to the file mentioned in the error stack and restart the instance.

For more information about media failure, see the index entry on "media failure" in the Oracle8 Server Administrator's Guide. For more information on tablespaces, see the index entry on "tablespaces" in Oracle8 Server SQL Reference.


ORA-01244

ORA-01244unnamed datafile(s) added to controlfile by media recovery

Cause:Media recovery with a backup controlfile or a controlfile that was rebuilt encountered the creation of a datafile that was not in the controlfile. An entry has been added to the controlfile for the new datafiles, but with the file name UNNAMEDnum, where num is the file number. Attached errors describe the file names that were originally used to create the files.

Action:Rename the files to valid file names and resume recovery. If necessary, the command ALTER DATABASE CREATE DATAFILE may be used to create a file suitable for recovery and do the rename. If the file is not going to be recovered, then take it offline with the DROP option.

For more information about datafiles and media recovery, see the index entry on "recovery, media, datafile" in Oracle8 Server Concepts and the index entry on "ALTER DATABASE command" in Oracle8 Server SQL Reference.


ORA-01245

ORA-01245offline file name will be lost if RESETLOGS is done

Cause:An attempt was done to do an OPEN RESETLOGS with a file that will be lost because it is offline. The file was not taken offline with the DROP option.

Action:Either bring the file online and recover it, or take it offline with the DROP option.

For more information about bringing a file online and recovering the file, see the index entry on "redo log files, online, recovery use of" in Oracle8 Server Concepts.


ORA-01246

ORA-01246recovering files through TSPITR of tablespace name

Cause:The files named in the accompanying errors are backups that were made before a tablespace point in time recovery of this tablespace. They cannot be recovered to a time after the point in time recovery.

Action:Restore more recent backups and recover them.


ORA-01247

ORA-01247database recovery through TSPITR of tablespace name

Cause:Recovery of the whole database encountered redo indicating there was a point in time recovery of the tablespace. The new version of the files in the tablespace should be included in the recovery, but that was not done.

Action:If the tablespace should not be recovered, take its file offline for drop. If it should be recovered, take its file offline for drop. If it should be recovered, then restore or rename as needed and restart the recovery.


ORA-01248

ORA-01248file name was created in the future of incomplete recovery

Cause:Attempting to do a RESETLOGS open with a file entry in the controlfile that was created by switchToCopy, and the file was originally created after the UNTIL time of the incomplete recovery. The file number may be in use for a different file which would be lost if the RESETLOGS was allowed.

Action:If more recovery is desired then apply redo until the creation time of the file is reached. If the file is not wanted and the same file number is not in use at the stop time of the recovery, then the file can be taken offline with the FOR DROP option. Otherwise a different controlfile is needed to allow the RESETLOGS. Another backup can be restored and recovered, or a controlfile can be created via CREATE CONTROLFILE.


ORA-01249

ORA-01247archiving not allowed in a clone database

Cause:Attempting to archive an online redo log or enable archiving for a clone database.

Action:Do not attempt to archive from a clone. The archive log destination could easily be the same as the primary database destroying its archived logs. If archiving is needed then recreate database as not a clone.


ORA-01250

ORA-01246error name occurred during termination of file header access

Cause:The indicated error occurred while terminating the processing of file headers. The error was other than a WRITE error.

Action:The indicated error should be corrected.


ORA-01400

ORA-01400primary key or mandatory (NOT NULL) column is missing or NULL during insert

Cause:When inserting or updating rows, a value for a column defined as NOT NULL was not specified.

Action:Specify a value for each NOT NULL column or modify the table definition to allow null values in columns now defined as NOT NULL.


ORA-01401

ORA-01401inserted value too large for column

Cause:The value entered is larger than the maximum width defined for the column.

Action:Enter a value smaller than the column width, or use the MODIFY option with ALTER TABLE to expand the column width.


ORA-01402

ORA-01402view WITH CHECK OPTION where-clause violation

Cause:An INSERT or UPDATE statement was attempted on a view created with the CHECK OPTION. This would have resulted in the creation of a row that would not satisfy the view's WHERE clause.

Action:Examine the view's WHERE clause in the dictionary table VIEWS. If the current view does not have the CHECK OPTION, then its FROM clause must reference a second view that is defined using the CHECK OPTION. The second view's WHERE clause must also be satisfied by any INSERT or UPDATE statements. To insert the row, it may be necessary to insert it into the underlying table rather than through the view.


ORA-01403

ORA-01403no data found

Cause:In a host language program, all records have been fetched. The return code from the fetch was +4 indicating that all records have been returned from the SQL query.

Action:Terminate processing for the SELECT statement.


ORA-01404

ORA-01404ALTER COLUMN will make a concatenated index too large

Cause:Increasing the length of a column would cause the combined length of the columns specified in a previous CREATE INDEX statement to exceed the maximum index length (255). The total index length is computed as the sum of the width of all indexed columns plus the number of indexed columns. Date fields are calculated as a length of 7, character fields are calculated at their defined width, and numeric fields are length 22.

Action:The only way to alter the column is to drop the affected index. The index cannot be re-created if to do so would exceed the maximum index width.


ORA-01405

ORA-01405fetched column value is NULL

Cause:In an OCI program, a FETCH operation returned a NULL column value. The column buffer in the program remained unchanged and the cursor return code was +2.

Action:Include program processing for this condition. This is only a warning.


ORA-01406

ORA-01406fetched column value was truncated

Cause:In a host language program, a FETCH operation was forced to truncate a character string. The program buffer area for this column was not large enough to contain the entire string. The cursor return code from the fetch was +3.

Action:Increase the column buffer area to hold the largest column value, or perform other appropriate processing.


ORA-01407

ORA-01407cannot update mandatory (NOT NULL) column to NULL

Cause:An attempt was made to update data in a NOT NULL column to a null value.

Action:Specify a value for the column or modify the table definition to accept null values in that column.


ORA-01408

ORA-01408such column list already indexed

Cause:A CREATE INDEX statement specified a column that is already indexed. A single column may be indexed only once. Additional indexes may be created on the column if it is used as a portion of a concatenated index (that is, if the index consists of multiple columns).

Action:Do not attempt to re-index the column as it is unnecessary. To create a concatenated key, specify one or more additional columns in the CREATE INDEX statement.


ORA-01409

ORA-01409NOSORT option may not be used; rows are not in ascending order

Cause:Creation of index with NOSORT option when rows were not ascending. For non-unique indexes the ROWID is considered part of the index key. Therefore, if you create an index NOSORT and two of the rows in the table have the same key and are stored in ascending order, but get split across two extents where the data block address (dba) of the first block in the second extent is less than the data block address of the last block in the first extent, then the create index NOSORT may fail.

Action:Create the index without the NOSORT option, or ensure table is stored in one extent.


ORA-01410

ORA-01410invalid ROWID

Cause:A ROWID was entered incorrectly. ROWIDs must be entered as formatted hexadecimal strings using only numbers and the characters A through F. A typical ROWID format is '0001.000001F8.0006'.

Action:Check the format, then enter the ROWID using the correct format.


ORA-01411

ORA-01411cannot store the length of column in the indicator

Cause:ORACLE tried to fetch a column more than 64K long and couldn't store the length of the column in the given indicator size of 2 bytes.

Action:Use the new bind type with callbacks to fetch the long column.


ORA-01412

ORA-01412zero length not allowed for this datatype

Cause:The length for data type 97 is 0.

Action:Specify the correct length for the datatype.


ORA-01413

ORA-01413illegal value in packed decimal number buffer

Cause:The user buffer bound by the user as packed decimal number contained an illegal value.

Action:Use a legal value.


ORA-01415

ORA-01415outer-join (+) may not be applied to the label pseudo column

Cause:The user specified an outer-join (+) following a reference to the label pseudo column.

Action:Work around the problem by defining a view on the table and perform an outer join on the view column corresponding to a label.


ORA-01415

ORA-01415outer-join (+) may not be applied to the label pseudo-column

Cause:The user specified an outer-join (+) following a reference to the label pseudo-column.

Action:Work around the problem by defining a view on the table and perform an outer join on the view column corresponding to a label.


ORA-01416

ORA-01416two tables cannot be outer-joined to each other

Cause:Two tables in a join operation specified an outer join with respect to each other. If an outer join is specified on one of the tables in a join condition, it may not be specified on the other table.

Action:Remove the outer join specification (+) from one of the tables, then retry the operation.


ORA-01417

ORA-01417a table may be outer joined to at most one other table

Cause:A table in a join operation specified an outer join to more than one other table. A table may specify an outer join to only one other table.

Action:Specify only one outer join (+) to this table, then retry the operation.


ORA-01418

ORA-01418specified index does not exist

Cause:An ALTER INDEX, DROP INDEX, or VALIDATE INDEX statement specified the name of an index that does not exist. Only existing indexes can be altered, dropped, or validated. Existing indexes may be listed by querying the data dictionary.

Action:Specify the name of an existing index in the ALTER INDEX, DROP INDEX, or VALIDATE INDEX statement.


ORA-01419

ORA-01419datdts: illegal format code

Cause:During a date-to-character conversion, the internal representation of the conversion format was invalid. This is an internal message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01420

ORA-01420datstd: illegal format code

Cause:During a character-to-date conversion, the internal representation of the conversion format was invalid. This is an internal message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01421

ORA-01421datrnd/dattrn: illegal precision specifier

Cause:During a date truncate or round operation, the internal representation of the date precision was invalid. This is an internal message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01422

ORA-01422exact fetch returns more than requested number of rows

Cause:More rows were returned from an exact fetch than specified.

Action:Rewrite the query to return fewer rows or specify more rows in the exact fetch.


ORA-01423

ORA-01423message encountered while checking for extra rows in exact fetch

Cause:An message was encountered during the execution of an exact fetch. This message will be followed by more descriptive messages.

Action:Take the appropriate action for the messages that follow.


ORA-01424

ORA-01424missing or illegal character following the escape character

Cause:The character following the escape character in LIKE pattern is missing or not one of the escape characters '%' or '_'.

Action:Remove the escape character or specify the missing character.


ORA-01425

ORA-01425escape character must be character string of length 1

Cause:Given escape character for LIKE is not a character string of length 1.

Action:Change it to a character string of length 1.


ORA-01426

ORA-01426numeric overflow

Cause:Evaluation of a value expression has caused an overflow, or possibly, an underflow.

Action:Rewrite the expression as a series of expressions with few operands than the 'overloaded' expression.


ORA-01427

ORA-01427single-row query returns more than one row

Cause:The outer query must use one of the keywords ANY, ALL, IN, or NOT IN to specify values to compare, because the subquery returned more than one row.

Action:Use ANY, ALL, IN, or NOT IN to specify which values to compare, or reword the query so only one row is retrieved.


ORA-01428

ORA-01428argument num is out of range

Cause:An illegal value for a mathematical function argument was specified. For example:

SELECT SQRT(-1) "Square Root" FROM DUAL;

Action:Refer to Chapter 4 of the ORACLE7 Server SQL Language Reference Manual for valid input and ranges of the mathematical functions.


ORA-01429

ORA-01429a date in binary format has an out of range value

Cause:The date, in binary format, for an external type DATE was out of range for one or more of the seven possible bytes.

Action:Select values for each of the seven bytes that conform to the required date specification or use the TO_DATE function with character data.


ORA-01430

ORA-01430column being added already exists in table

Cause:An ALTER TABLE ADD statement specified the name of a column that is already in the table. All column names must be unique within a table.

Action:Specify a unique name for the new column, then re-execute the statement.


ORA-01431

ORA-01431internal inconsistency in GRANT command

Cause:An internal message occurred while attempting to execute a GRANT statement.

Action:Contact Worldwide Customer Support.


ORA-01432

ORA-01432public synonym to be dropped does not exist

Cause:The synonym specified in DROP PUBLIC SYNONYM is not a valid public synonym. It may be a private synonym.

Action:Correct the synonym name, or use DROP SYNONYM if the synonym is not public.


ORA-01433

ORA-01433synonym to be created is already defined

Cause:A CREATE SYNONYM statement specified a synonym name that is the same as an existing synonym, table, view, or cluster. Synonyms may not have the same name as any other synonym, table, view, or cluster available to the user creating the synonym.

Action:Specify a unique name for the synonym, then re-execute the statement.


ORA-01434

ORA-01434private synonym to be dropped does not exist

Cause:A DROP SYNONYM statement specified a synonym that does not exist. Existing synonym names may be listed by querying the data dictionary.

Action:Specify the name of an existing synonym in the DROP SYNONYM statement.


ORA-01435

ORA-01435user does not exist

Cause:This message is caused by any reference to a nonexistent user. For example, it occurs if a SELECT, GRANT, or REVOKE statement specifies a username that does not exist. Only a GRANT CONNECT statement may specify a new username. All other GRANT and REVOKE statements must specify existing usernames. If specified in a SELECT statement, usernames must already exist.

Action:Specify only existing usernames in the SELECT, GRANT, or REVOKE statement, or ask the database administrator to define the new username.


ORA-01436

ORA-01436CONNECT BY loop in user data

Cause:The condition specified in a CONNECT BY clause caused a loop in the query, where the next record to be selected is a descendent of itself. When this happens, there can be no end to the query.

Action:Check the CONNECT BY clause and remove the circular reference.


ORA-01437

ORA-01437cannot have join with CONNECT BY

Cause:A join operation was specified with a CONNECT BY clause. If a CONNECT BY clause is used in a SELECT statement for a tree-structured query, only one table may be referenced in the query.

Action:Remove either the CONNECT BY clause or the join operation from the SQL statement.


ORA-01438

ORA-01438value larger than specified precision allows for this column

Cause:When inserting or updating records, a value was entered that exceeds the column width.

Action:Enter a smaller value, or use the MODIFY option to increase the column width.


ORA-01439

ORA-01439column to be modified must be empty to change datatype

Cause:An ALTER TABLE MODIFY statement attempted to change the datatype of a column containing data. In order to alter a column's datatype, the column must only contain NULL values.

Action:To alter the datatype, first set all values in the column to NULL.


ORA-01440

ORA-01440column to be modified must be empty to decrease precision or scale

Cause:An ALTER TABLE MODIFY statement attempted to decrease the scale or precision of a numeric column containing data. In order to decrease either of these values, the column must contain only NULL values. An attempt to increase the scale without also increasing the precision will also cause this message.

Action:Set all values in the column to NULL before decreasing the numeric precision or scale. If attempting to increase the scale, increase the precision in accordance with the scale, or set all values in the column to NULL first.


ORA-01441

ORA-01441column to be modified must be empty to decrease column length

Cause:An ALTER TABLE MODIFY statement attempted to decrease the size of a character field containing data. In order to decrease the maximum size of a character column, the column must contain only NULL values.

Action:Set all values in column to NULL before decreasing the maximum size.


ORA-01442

ORA-01442column to be modified to NOT NULL is already NOT NULL

Cause:An ALTER TABLE MODIFY statement attempted to change a column specification unnecessarily, from NOT NULL to NOT NULL.

Action:No user action is required.


ORA-01443

ORA-01443internal inconsistency; illegal datatype in resultant view column

Cause:An internal message occurred in referencing a view.

Action:Contact Worldwide Customer Support.


ORA-01444

ORA-01444internal inconsistency; internal datatype maps to invalid external type

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01445

ORA-01445cannot select ROWID from view of more than one table

Cause:A SELECT statement attempted to select ROWIDs from a view derived from a join operation. Because the rows selected in the view do not correspond to underlying physical records, no ROWIDs can be returned.

Action:Remove ROWID from the view selection clause, then re-execute the statement.


ORA-01446

ORA-01446cannot select ROWID from view with DISTINCT, GROUP BY, etc.

Cause:A SELECT statement attempted to select ROWIDs from a view containing columns derived from functions or expressions. Because the rows selected in the view do not correspond to underlying physical records, no ROWIDs can be returned.

Action:Remove ROWID from the view selection clause, then re-execute the statement.


ORA-01447

ORA-01447ALTER TABLE does not operate on clustered columns

Cause:An ALTER TABLE MODIFY statement specified a column that is used to cluster the table. Clustered columns may not be altered.

Action:To alter the column, first re-create the table in non-clustered form. The column's size can be increased at the same time.


ORA-01448

ORA-01448index must be dropped before changing to desired type

Cause:An ALTER TABLE MODIFY statement attempted to change an indexed character column to a LONG column. Columns with the datatype LONG may not be indexed and hence the index must be dropped before the modification.

Action:Drop all indexes referencing the column before changing its datatype to LONG.


ORA-01449

ORA-01449column contains NULL values; cannot alter to NOT NULL

Cause:An ALTER TABLE MODIFY statement attempted to change the definition of a column containing NULL values to NOT NULL. The column may not currently contain any NULL values if it is to be altered to NOT NULL.

Action:Set all NULL values in the column to values other than NULL before ALTERING the column to NOT NULL.


ORA-01450

ORA-01450maximum key length exceeded

Cause:The combined length of all the columns specified in a CREATE INDEX statement exceeds the maximum index length. The maximum index length varies by operating system. The total index length is computed as the sum of the width of all indexed columns plus the number of indexed columns. Date fields have a length of 7, character fields have their defined length, and numeric fields have a length of 22.

Action:Select columns to be indexed so the total index length does not exceed the maximum index length for the operating system.


ORA-01451

ORA-01451column to be modified to NULL cannot be modified to NULL

Cause:The column may already allow NULL values, the NOT NULL constraint is part of a primary key or check constraint. Or, an ALTER TABLE MODIFY statement attempted to change a column specification unnecessarily, from NULL to NULL.

Action:If a primary key or check constraint is enforcing the NOT NULL constraint, then drop that constraint.


ORA-01452

ORA-01452cannot CREATE UNIQUE INDEX; duplicate keys found

Cause:A CREATE UNIQUE INDEX statement specified one or more columns that currently contain duplicate values. All values in the indexed columns must be unique, by row, to create a UNIQUE INDEX.

Action:If the entries need not be unique, remove the keyword UNIQUE from the CREATE INDEX statement, then re-execute the statement. If the entries must be unique, as in a primary key, then remove duplicate values before creating the UNIQUE index.


ORA-01453

ORA-01453SET TRANSACTION must be first statement of transaction

Cause:A transaction was not processed properly because the SET TRANSACTION statement was not the first statement.

Action:Commit or roll back the current transaction, before using the statement SET TRANSACTION.


ORA-01454

ORA-01454cannot convert column into numeric datatype

Cause:A non-numeric value could not be converted into a number value.

Action:Check the value to make sure it contains only numbers, a sign, a decimal point, and the character "E" or "e", then retry the operation.


ORA-01455

ORA-01455converting column overflows integer datatype

Cause:The converted form of the specified expression was too large for the specified datatype.

Action:Define a larger datatype, or correct the data.


ORA-01456

ORA-01456may not perform insert/delete/update operation inside a READ ONLY transaction

Cause:A non-DDL INSERT/DELETE/UPDATE or SELECT FOR UPDATE operation was attempted.

Action:Commit or roll back the current transaction, then retry the operation.


ORA-01457

ORA-01457converting column overflows decimal datatype

Cause:The converted form of the specified expression was too large for the specified type. The problem also occurs in COBOL programs when using COMP-3 in the picture clause, which is acceptable to the Pro*COBOL Precompiler and to COBOL but results in this error.

Action:Define a larger datatype, or correct the data.


ORA-01458

ORA-01458invalid length inside variable character string

Cause:An attempt was made to bind or define a variable character string with a buffer length less than the two byte minimum requirement.

Action:Increase the buffer size or use a different type.


ORA-01459

ORA-01459invalid length for variable character string

Cause:The buffer length was less than the minimum required (two bytes) or greater than its length at bind time minus two bytes.

Action:None. Buffer length is set correctly by ORACLE at fetch time.


ORA-01460

ORA-01460unimplemented or unreasonable conversion requested

Cause:The requested format conversion is not supported.

Action:Remove the requested conversion from the SQL statement. Check the syntax for the TO_CHAR, TO_DATE, and TO_NUMBER functions to see which conversions are supported.


ORA-01461

ORA-01461can bind a LONG value only for insert into a LONG column

Cause:An attempt was made to insert a value from a LONG datatype into another datatype. This is not allowed.

Action:Do not try to insert LONG datatypes into other types of columns.


ORA-01462

ORA-01462cannot insert string literals longer than 2000 characters

Cause:The longest literal supported by ORACLE consists of 2000 characters.

Action:Reduce the number of characters in the literal to 2000 characters or fewer, or use the VARCHAR2 or LONG datatype to insert strings exceeding 2000 characters.


ORA-01463

ORA-01463cannot modify column datatype with current constraints

Cause:An attempt was made to modify the datatype of column which has referential constraints; or has check constraints which only allows changing the datatype from CHAR to VARCHAR or vise versa.

Action:Remove the constraint(s) or do not perform the offending operation.


ORA-01464

ORA-01464circular grant (granting to grant ancestor) of table or view

Cause:The user in the TO clause of the GRANT statement has already been GRANTed privileges on this table.

Action:Do not GRANT privileges on a table to the user who originally GRANTed privileges on that table. The statement in error is probably unnecessary.


ORA-01465

ORA-01465invalid hex number

Cause:In an UPDATE statement following a SELECT FOR UPDATE, part of the ROWID contains invalid characters. ROWID must be expressed in the proper and expected format for ROWID, and within quotes.

Action:Enter the ROWID just as it was returned in the SELECT FOR UPDATE.


ORA-01466

ORA-01466unable to read data -- object definition has changed

Cause:This is a time-based read consistency error for a database object (such as a table or index). Either:

·the query was parsed and executed with a snapshot older than the time the object was changed

·the creation time-stamp of the object is greater than the current system time. This happens, for example, when the system time is set to a time earlier than the creation time of the object.

Action:If the cause is:

·an old snapshot, then commit or rollback the transaction and resume work.

·a creation time-stamp in the future, then:

·ensure the system time is correctly set

·if the object creation time-stamp is still greater than the system time, then export the object's data, drop the object, re-create the object (so it has a new creation time-stamp), import the object's data, and resume work.


ORA-01467

ORA-01467sort key too long

Cause:A DISTINCT, GROUP BY, ORDER BY, or SET operation requires a sort key longer than that supported by ORACLE. Either too many columns or too many group functions were specified in the SELECT statement.

Action:Reduce the number of columns or group functions involved in the operation.


ORA-01468

ORA-01468a predicate may reference only one outer-joined table

Cause:A predicate in the WHERE clause has two columns from different tables with "(+)".

Action:Change the WHERE clause so that each predicate has a maximum of one outer-join table.


ORA-01469

ORA-01469PRIOR can only be followed by a column name

Cause:An invalid column name was specified after the PRIOR keyword.

Action:Check syntax, spelling, use a valid column name and try again.


ORA-01470

ORA-01470in-list iteration does not support mixed operators

Cause:Constants of different types are specified in an in-list.

Action:Use constants of same type for in-lists.


ORA-01471

ORA-01471cannot create a synonym with the same name as object

Cause:An attempt was made to create a private synonym with the same name as the object to which it refers. This error typically occurs when a user attempts to create a private synonym with the same name as an object that he/she owns.

Action:Choose a different synonym name, or create the synonym under a different username.


ORA-01473

ORA-01473cannot have subqueries in CONNECT BY clause

Cause:Subqueries cannot be used in a CONNECT BY clause.

Action:Remove the subquery, or move it to the WHERE clause.


ORA-01473

ORA-01473cannot have subqueries in CONNECT BY clause

Cause:Subqueries cannot be used in a CONNECT BY clause.

Action:Remove the subquery or move it to the WHERE clause.


ORA-01474

ORA-01474cannot have START WITH or PRIOR without CONNECT BY

Cause:START WITH and PRIOR are meaningful only in connection with CONNECT BY.

Action:Check the syntax for the SQL statement and add a CONNECT BY clause if necessary.


ORA-01475

ORA-01475must reparse cursor to change bind variable datatype

Cause:After executing a statement, an attempt was made to rebind a bind variable with a datatype different from that of the original bind.

Action:Reparse the cursor before rebinding with a different datatype.


ORA-01476

ORA-01476divisor is equal to zero

Cause:An expression attempted to divide by zero.

Action:Correct the expression, then retry the operation.


ORA-01477

ORA-01477user data area descriptor is too large

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01478

ORA-01478array bind may not include any LONG columns

Cause:An attempt was made to use array bind on a column whose maximum size is greater than 2000 bytes. This is not permitted.

Action:Do not use array bind for a LONG column. Use an ordinary bind instead.


ORA-01479

ORA-01479last character in the buffer is not Null

Cause:A bind variable of type 97 does not contain null at the last position.

Action:Make the last character a null.


ORA-01480

ORA-01480trailing null missing from STR bind value

Cause:A bind variable specified as type SQLT_STR is not terminated with an ASCII null (0) character.

Action:Check maximum lengths and contents of string bind variables.


ORA-01481

ORA-01481invalid number format model

Cause:An invalid format parameter was used with the TO_CHAR or TO_NUMBER function.

Action:Correct the syntax, then retry the operation.


ORA-01482

ORA-01482unsupported character set

Cause:The second or third parameter to the CONVERT function is not a supported character set.

Action:Use one of the supported character sets.


ORA-01483

ORA-01483invalid length for DATE or NUMBER bind variable

Cause:A bind variable of type DATE or NUMBER is too long.

Action:Check the installation or user's guide for the maximum allowable length.


ORA-01484

ORA-01484arrays can only be bound to PL/SQL statements

Cause:You tried to bind an array to a non-PL/SQL statement.


ORA-01485

ORA-01485compile bind length different from execute bind length

Cause:You bound a buffer of type DTYVCS (VARCHAR with the two byte length in front) and at execute time the length in the first two bytes is more than the maximum buffer length (given in the bind call). The number of elements in the array and the current number of elements in the array cannot be more than the maximum size of the array.


ORA-01486

ORA-01486size of array element is too large

Cause:You tried to bind a data value which was either too large for the datatype (for example, NUMBER) or was greater than 2000 bytes (for example, VARCHAR or LONG).


ORA-01487

ORA-01487packed decimal number too large for supplied buffer

Cause:A conversion request cannot be performed because the buffer is too small to hold the result.

Action:Increase the size of the buffer.


ORA-01488

ORA-01488invalid nibble or byte in the input data

Cause:A conversion request cannot be performed because a digit was invalid.

Action:Fix the number and retry.


ORA-01489

ORA-01489result of string concatenation is too long

Cause:The result of a string concatenation was larger than the maximum length of a string (2000 characters).

Action:Reduce the size of one or both of the strings to be concatenated. Make certain the total length of the concatenation result is less than 2000 characters.

________________________________________


ORA-01490

ORA-01490invalid ANALYZE command

Cause:The syntax of the ANALYZE command was incorrect.

Action:Check the syntax and enter the command using the correct syntax.


ORA-01491

ORA-01491CASCADE option not valid

Cause:The CASCADE option should be used only for tables or clusters.

Action:Do not use the CASCADE option in this manner. Check the syntax of the statement and then retry.


ORA-01492

ORA-01492LIST option not valid

Cause:The LIST option can only be used for tables or clusters.


ORA-01493

ORA-01493invalid SAMPLE size specified

Cause:The specified SAMPLE size is out of range

Action:Specify a value within the proper range.


ORA-01494

ORA-01494invalid SIZE specified

Cause:The specified histogram SIZE value was out of range.

Action:Specify a value within the proper range.


ORA-01495

ORA-01495specified chain row table not found

Cause:The specified table either does not exist or the user does not have the proper privileges to access it.

Action:Specify an existing table, or obtain the privileges to access the desired table.


ORA-01496

ORA-01496specified chain row table form incorrect

Cause:The specified table does not have the proper field definitions.

Action:Check the spelling of the table name, and specify the correct table to use.


ORA-01497

ORA-01497unable to initialize statistics scan - see trace file.

Cause:The first block checked in the object from the ANALYZE ... STATISTICS command was found to be corrupted.

Action:Check the trace file for more descriptive messages about the problem. Correct these messages. The name of the trace file is operating system specific (for example, ORAxxxx.TRC) and it is found in the directory specified by the initialization parameter USER_DUMP_DEST. If USER_DUMP_DEST is not set, trace files are not created. It may be necessary to re-create the object.


ORA-01498

ORA-01498block Check Failure - see trace file

Cause:An message occurred while checking a block with the ANALYZE command.

Action:Check the trace file for more descriptive messages about the problem. Correct these messages. The name of the trace file is operating system specific (for example, ORAxxxx.TRC) and it is found in the directory specified by the initialization parameter USER_DUMP_DEST. If USER_DUMP_DEST is not set, trace files are not created. It may be necessary to re-create the object.


ORA-01499

ORA-01499table/Index Cross Reference Failure - see trace file

Cause:An message occurred when validating an index or a table using the ANALYZE command. One or more entries does not point to the appropriate cross reference.

Action:Check the trace file for more descriptive messages about the problem. Correct these messages. The name of the trace file is operating system specific (for example, ORAxxxx.TRC) and it is found in the directory specified by the initialization parameter USER_DUMP_DEST. If USER_DUMP_DEST is not set, trace files are not created. It may be necessary to re-create the object.


ORA-01500

ORA-01500failure in getting date/time

Cause:In executing a CREATE DATABASE or ALTER TABLESPACE statement, there was a failure in getting the date and time.

Action:Contact Worldwide Customer Support.


ORA-01501

ORA-01501CREATE DATABASE failed

Cause:An error occurred while executing the CREATE DATABASE statement.

Action:Refer to the diagnostic information in the accompanying message stack.


ORA-01502

ORA-01502index 'str.name' is in direct load state

Cause:The specified index had been marked invalid by a direct load.

Action:Drop the specified index.


ORA-01503

ORA-01503CREATE CONTROLFILE failed

Cause:An error occurred during CREATE CONTROLFILE.

Action:See accompanying messages.


ORA-01504

ORA-01504database name name does not match parameter DB_NAME str

Cause:The name in a CREATE DATABASE or START UP command does not match the name gi

Cause:ven in the initialization parameter DB_NAME.

Action:Determine which name is correct, then resubmit the command after correcting the name in the appropriate place.


ORA-01505

ORA-01505error in adding logfiles

Cause:In executing a CREATE DATABASE or ALTER DATABASE statement, an error occurred when adding new redo log files. The user issuing the command must CONNECT INTERNAL. The database must be mounted but closed in order to add redo log files.

Action:Check the accompanying message stack for detailed information and ensure that the session is connected as INTERNAL with the database mounted but closed.


ORA-01506

ORA-01506missing or illegal database name

Cause:No database name was specified in the ALTER DATABASE statement, nor was the initialization parameter DB_NAME specified.

Action:The database name must be given either in the ALTER DATABASE statement or as the value for the initialization parameter DB_NAME. Note that the SQL*DBA command START UP issues an ALTER DATABASE statement using the database name (if any) specified as part of START UP.


ORA-01507

ORA-01507database not mounted

Cause:An ALTER DATABASE statement specified the name of a database to alter, but no database is currently mounted.

Action:If issuing an ALTER DATABASE command via the SQL*DBA START UP command, specify the MOUNT option. If directly issuing an ALTER DATABASE DISMOUNT command, do nothing. Otherwise, re-issue the ALTER DATABASE command specifying the MOUNT option.


ORA-01508

ORA-01508cannot create database; error in file 'name' at line num

Cause:A CREATE DATABASE statement was unable to process the named file, because an error occurred at the given line number.

Action:Check the offending line in the specified file, correct the error, then re-execute the CREATE DATABASE statement. If the error is in an Oracle-supplied file, contact Worldwide Customer Support.


ORA-01509

ORA-01509specified name 'name' does not match actual 'name'

Cause:The database name specified in an ALTER DATABASE statement does not match the name of the currently mounted database.

Action:Correct the database name spelling or DISMOUNT the mounted database.


ORA-01510

ORA-01510error in deleting logfiles

Cause:In executing an ALTER DATABASE statement, an error occurred while dropping redo log files.

Action:Check the accompanying message stack for detailed information.


ORA-01511

ORA-01511error in renaming log/data files

Cause:In executing an ALTER DATABASE statement, an error occurred while renaming log or data files.

Action:Check the accompanying message stack for detailed information.


ORA-01512

ORA-01512error renaming logfile 'name' - new file 'name' not found

Cause:An attempt to change a redo log file's name in the control file failed because no file was found with the new name.

Action:Make sure that the redo log file has been properly renamed by the operating system and retry.


ORA-01513

ORA-01513invalid current time returned by operating system

Cause:The operating system returned a time that was not between the years 1988 and 2121.

Action:Correct the time kept by the operating system.


ORA-01514

ORA-01514error in log specification; no such log

Cause:A redo log file name, or list of member names, did not correspond to an existing redo log file.

Action:Specify the name of an existing redo log file, check the spelling and capitalization of the names, and then re-execute the statement.


ORA-01516

ORA-01516nonexistent log/data file 'name'

Cause:An ALTER DATABASE statement is attempting to rename a log file or a data file that is not known to the database control file.

Action:Specify the name of an existing redo log file, then re-execute the statement.


ORA-01516

ORA-01516nonexistent log/datafile name

Cause:An ALTER DATABASE statement is attempting to rename a log file or a datafile that is not known to the database control file.

Action:Specify the name of an existing redo log file, then re-execute the statement.


ORA-01517

ORA-01517log member: 'str'

Cause:This message indicates the file name involved with other messages.

Action:See the associated messages.


ORA-01518

ORA-01518CREATE DATABASE must specify more than one logfile

Cause:Only one redo log file was specified in the CREATE DATABASE statement.

Action:Specify at least two redo log files, then re-execute the statement.


ORA-01519

ORA-01519error while processing file 'name' near line num

Cause:A CREATE DATABASE statement encountered a problem while processing the named file, probably because of a system installation error.

Action:Try the system installation procedure again, or contact Worldwide Customer Support.


ORA-01520

ORA-01520number of data files to add (num) exceeds limit of num

Cause:A CREATE TABLESPACE statement specifies more files than are permitted for this database.

Action:Use fewer files. To exceed the limit, re-create the database with a larger value of MAXDATAFILES.


ORA-01521

ORA-01521error in adding data files

Cause:During a CREATE or ALTER TABLESPACE, an error was detected while adding data files.

Action:Check the accompanying message stack for detailed information.


ORA-01522

ORA-01522file 'name' to be renamed does not exist

Cause:During an ALTER TABLESPACE RENAME, a file to be renamed was not found in the database control file.

Action:Specify the correct file name, then re-execute the statement.


ORA-01523

ORA-01523cannot rename data file to 'name' - file already part of database

Cause:During an ALTER DATABASE RENAME or ALTER TABLESPACE RENAME, the new name of a file is already present in the control file.

Action:Rename the file to a name not already being used as part of the database.


ORA-01524

ORA-01524cannot create data file as 'name' - file already part of database

Cause:During an ALTER DATABASE CREATE DATAFILE, the new name of a file is already present in the control file.

Action:Use a name that is not already used in the database.


ORA-01525

ORA-01525error in renaming data files

Cause:An error occurred when renaming files as part of ALTER TABLESPACE.

Action:Check the accompanying message stack for detailed information. (All files were renamed except those mentioned in the message stack.)


ORA-01526

ORA-01526error in opening file 'name'

Cause:A CREATE DATABASE was not able to open the file identified in the message. This is probably due to a system installation error.

Action:Try the system installation procedure again, or contact Worldwide Customer Support.


ORA-01527

ORA-01527error while reading file

Cause:A CREATE DATABASE statement was not able to read the specified file, probably because of a system installation error.

Action:Try the system installation procedure again, or contact Worldwide Customer Support.


ORA-01528

ORA-01528EOF while processing SQL statement

Cause:A CREATE DATABASE statement unexpectedly encountered an end-of-file marker while reading the specified file, probably because of a system installation error.

Action:Try the system installation procedure again, or contact Worldwide Customer Support.


ORA-01529

ORA-01529error closing file 'name'

Cause:A CREATE DATABASE was not able to close the file identified in the message.

Action:Try the system installation procedure again, or contact Worldwide Customer Support.


ORA-01530

ORA-01530a database already mounted by the instance

Cause:During an ALTER DATABASE MOUNT, an attempt was made to mount a database by an instance for which there is already a mounted database.

Action:To mount the database, shut down the instance, then start up the instance and try the operation again.


ORA-01531

ORA-01531a database already open by the instance

Cause:During an ALTER DATABASE, an attempt was made to open a database by an instance for which there is already an open database.

Action:To open a new database, shut down the instance, then start up the instance and try the operation again.


ORA-01532

ORA-01532cannot create database; instance being started elsewhere

Cause:During a CREATE DATABASE, another user appears to be simultaneously starting the instance.

Action:Retry the operation. If the error recurs, contact Worldwide Customer Support.


ORA-01533

ORA-01533cannot rename file 'name'; file does not belong to tablespace

Cause:During an ALTER TABLESPACE RENAME, a file to be renamed was not found in the named tablespace.

Action:Check syntax and spelling, and correctly specify the file name and tablespace name.


ORA-01534

ORA-01534rollback segment 'name' doesn't exist

Cause:During an ALTER or DROP ROLLBACK SEGMENT, the specified rollback segment name was not found.

Action:Correct syntax and spelling, and correctly specify the rollback segment name, or specify a different rollback segment.


ORA-01535

ORA-01535rollback segment 'name' already exists

Cause:The specified rollback segment already exists.

Action:Correct syntax and spelling, and correctly specify the rollback segment name, or specify a different rollback segment.

ORA-e01536space quota exceeded for tablespace 'name'

Cause:The space quota in the tablespace is already used up and the operation attempted the creation of a new extent in the tablespace.

Action:Either:

1) Drop unnecessary objects in the tablespace to reclaim space.

2) Ask the database administrator to increase the tablespace quota.


ORA-01536

ORA-01536space quota exceeded for tablespace "name"

Cause:The space quota in the tablespace is already used up and the operation attempted the creation of a new extent in the tablespace.

Action:Either

·_Drop unnecessary objects in the tablespace to reclaim space.

·_Ask the database administrator to increase the tablespace quota.


ORA-01537

ORA-01537cannot add data file 'name' - file already part of database

Cause:During a CREATE or ALTER TABLESPACE, a file being added is already part of the database.

Action:Correct spelling of the data file name, or use a different file.


ORA-01538

ORA-01538failed to acquire any rollback segment

Cause:An instance failed to acquire the SYSTEM rollback segment, or an instance failed to acquire one rollback segment in addition to the SYSTEM rollback segment during start up in parallel mode.

Action:Make sure the SYSTEM rollback segment is available. Before starting an instance in parallel mode, either create one more public rollback segment or specify an available private rollback segment in the initialization parameter ROLLBACK_SEGMENTS.


ORA-01539

ORA-01539tablespace 'name' is not online

Cause:An attempt was made to bring a tablespace offline normally, but it is not online.

Action:Check the status of the tablespace, use IMMEDIATE or TEMPORARY options to force all files offline. Also, the database must be in ARCHIVELOG mode.


ORA-01540

ORA-01540tablespace 'name' is not offline

Cause:A tablespace could not be brought online because it is not offline.

Action:Check the status of the tablespace, then retry the operation.


ORA-01541

ORA-01541system tablespace cannot be brought offline; shut down if necessary

Cause:An attempt was made to bring tablespace SYSTEM offline.

Action:Do not attempt to take the tablespace SYSTEM offline, because it must always be online. Shut down if necessary to do a recovery.


ORA-01542

ORA-01542tablespace 'name' is offline, cannot allocate space in it

Cause:An attempt was made to allocate space in an offline tablespace.

Action:Bring the tablespace online or create the object in another tablespace.


ORA-01543

ORA-01543tablespace 'name' already exists

Cause:An attempt was made to create a tablespace that already exists.

When Trusted ORACLE is configured in DBMS MAC mode, it is possible to get this error if you attempt to create a tablespace using a name that was previously used by another tablespace. In DBMS MAC mode, it is not possible to reuse tablespace names, even if the old tablespace has been dropped.

Action:Use a different name for the new tablespace.


ORA-01544

ORA-01544cannot drop system rollback segment

Cause:An attempt was made to drop the rollback segment SYSTEM.

Action:No user action is required.


ORA-01545

ORA-01545rollback segment #'name' was not available

Cause:Either:

1) A non-existent rollback segment was specified.

2) An instance tried to acquire a rollback segment that is in use or offline.

3) An attempt was made to drop a rollback segment that contains active transactions.

Action:Either:

1) Check spelling and specify a valid rollback segment name. If the name of the rollback segment to be changed is unknown, reopen the database and query the data dictionary for the names of existing rollback segments.

2) To start up an instance that tried to acquire this rollback segment, specify another rollback segment in the initialization parameter ROLLBACK_SEGMENTS or bring the tablespace containing the rollback segment online.

3) To drop a rollback segment that is in use, shut down the instance using it; or if it needs recovery, find out the errors that are preventing the rolling back of the transactions, and take appropriate actions.


ORA-01546

ORA-01546tablespace contains active rollback segment 'name'

Cause:An attempt was made to bring offline a tablespace that contains active rollback segments.

Action:Make sure there are no active rollback segments in the tablespace to be brought offline, then retry the operation.


ORA-01547

ORA-01547failed to allocate extent of size num in tablespace 'name'

Cause:The tablespace does not have enough free space to allocate the requested extent of num ORACLE blocks. Either:

1) Too many temporary segments are in the tablespace, or the temporary segments are too large.

2) Current extents are not big enough because of disk fragmentation.

Action:Either:

1) Create another tablespace for temporary segments.

2) For fragmentation, decrease the PCTINCREASE initialization parameter value because it is too high. If there is still not enough room in the tablespace, use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated, or create the object in another tablespace if this happens during a CREATE statement.


ORA-01548

ORA-01548active rollback segment 'name' found, terminate dropping tablespace

Cause:An attempt was made to drop a tablespace that contains active rollback segments.

Action:Shut down instances that use the active rollback segments in the tablespace and then drop the tablespace.


ORA-01549

ORA-01549tablespace not empty, use INCLUDING CONTENTS option

Cause:An attempt was made to drop a non-empty tablespace.

Action:To drop all the objects in the tablespace, use the INCLUDING CONTENTS option with DROP TABLESPACE.


ORA-01550

ORA-01550cannot drop system tablespace

Cause:An attempt was made to drop the tablespace SYSTEM.

Action:No user action is required.


ORA-01551

ORA-01551extended rollback segment, pinned blocks released

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01552

ORA-01552cannot use system rollback segment for non-system tablespace 'name'

Cause:An attempt was made to use the SYSTEM rollback segment for operations involving a non-system tablespace.

Action:Create one or more private or public rollback segments, shut down the database, then start up again. It may be necessary to modify the initialization parameter ROLLBACK_SEGMENTS to acquire one of the new private rollback segments. Before creating a rollback segment outside the SYSTEM tablespace, it is necessary to first create and activate a non-system rollback segment in the SYSTEM tablespace. To activate a rollback segment, shut down the database, modify the initialization parameter file, and restart.


ORA-01553

ORA-01553MAXEXTENTS must be no smaller than the num extents currently allocated

Cause:The number of extents allocated is greater than the MAXEXTENTS specified.

Action:Specify a larger MAXEXTENTS value.


ORA-01554

ORA-01554out of transaction slots in transaction tables

Cause:There were too many concurrent transactions.

Action:Shut down ORACLE, modify initialization parameters TRANSACTIONS and ROLLBACK_SEGMENTS, then restart ORACLE. The TRANSACTIONS parameter must be high enough to handle any possible rollbacks.


ORA-01555

ORA-01555snapshot too old (rollback segment too small)

Cause:Rollback records needed by a reader for consistent read were overwritten by other writers.

When Trusted ORACLE is configured in OS MAC mode, it is possible to get this error if the interval between checkpoints in a secondary database is too small, causing necessary rollback records to be overwritten.

Action:To prevent the recurrence of this error, specify larger rollback segments.

For Trusted ORACLE users, if the cause of this error is that the necessary rollback records in an OS MAC secondary database were overwritten, decrease the value of the LOG_CHECKPOINT_TIMEOUT initialization parameter so that checkpoints are taken more frequently.


ORA-01556

ORA-01556MINEXTENTS for rollback segment must be greater than 1

Cause:A MINEXTENTS of less than 2 was specified for rollback segment.

Action:Specify a larger MINEXTENTS.


ORA-01557

ORA-01557rollback segment extents must be at least 3 blocks

Cause:An extent of less than three blocks was specified for the rollback segment.

Action:Specify extents of at least three blocks, then retry the operation.


ORA-01558

ORA-01558out of transaction ID's in rollback segment num

Cause:All the available transaction IDs have been used.

Action:Shut down the instance, restart it using another rollback segment, then drop the rollback segment that has no more transaction IDs.


ORA-01559

ORA-01559MAXEXTENTS for rollback segment must be greater than 1

Cause:An invalid value for MAXEXTENTS was specified; the value must be greater than 1.

Action:Specify a MAXEXTENTS value of at least 2 and try again.


ORA-01560

ORA-01560global hash table size mismatch for GC_name (num != num)

Cause:This message is only relevant for systems running the Parallel Server and occurs at instance start up. The value of the GC_name initialization parameter does not match that of an instance already mounted.

Action:Ensure correct initialization parameter files are being used. If necessary, modify the GC_name parameter in the offending initialization files, then shut down and restart those instances with corrected initialization parameter files.


ORA-01561

ORA-01561failed to remove all objects in the tablespace specified

Cause:A user failed to remove all objects when dropping a tablespace.

Action:Repeat DROP TABLESPACE until all objects have been dropped.


ORA-01562

ORA-01562failed to extend rollback segment (ID = num)

Cause:A failure occurred while trying to extend the rollback segment. The problem is usually lack of space in the database to extend the rollback segment.

Action:This is usually followed by another message stating the cause of the failure. Shut down and take appropriate action for the error that caused the failure. If no other messages follow this message, the cause is probably lack of space in the database.


ORA-01563

ORA-01563rollback segment is PUBLIC, need to use the keyword PUBLIC

Cause:The keyword PUBLIC was not used to identify a public rollback segment.

Action:Use the keyword PUBLIC when identifying a public rollback segment.


ORA-01564

ORA-01564rollback segment is not PUBLIC

Cause:The identified rollback segment is not public.

Action:Do not use the keyword PUBLIC when identifying a private rollback segment.


ORA-01565

ORA-01565message in identifying file 'name'

Cause:An message occurred while trying to identify a file.

Action:Check the accompanying message stack for detailed information.


ORA-01566

ORA-01566file specified more than once in DROP LOGFILE

Cause:For an ALTER DATABASE, the list of files for the DROP LOGFILE option contains at least one duplicate.

Action:Remove the duplicate file specification, then re-execute the statement.


ORA-01567

ORA-01567dropping log name would leave less than two logfiles in thread num

Cause:Dropping all the files specified would leave fewer than the required two redo log files.

Action:Either drop fewer logs or disable the thread before deleting the logs.


ORA-01568

ORA-01568cannot set space quota on PUBLIC

Cause:An attempt was made to set a space quota for PUBLIC on a tablespace.

Action:To grant system-wide or tablespace-wide space privileges to all users, use the statement:

GRANT UNLIMITED TABLESPACE [ON tablespace] TO PUBLIC;


ORA-01569

ORA-01569data file too small for system dictionary tables

Cause:The data file specified during creation of the database is too small to hold the system dictionary tables.

Action:Re-create the database specifying a larger file or more files.


ORA-01570

ORA-01570MINEXTENTS must be no larger than the num extents currently allocated

Cause:The number of extents already allocated is smaller than the MINEXTENTS specified in the command.

Action:Enter the command again specifying the number of extents given in the message as the value for MINEXTENTS.


ORA-01571

ORA-01571redo version ver incompatible with ORACLE Version ver

Cause:This software version can not read the current redo logs, and either crash recovery is required or there are offline database files that need media recovery. If a file name is listed then it needs media recovery.

Action:Shut down and start up using the compatible software. Do any required media recovery, and open the database. Shut down and then start up using current software.


ORA-01572

ORA-01572global hash table size num for rollback segments is too small for rollback segment ID num

Cause:An operation requested a resource that was unavailable. On a Parallel Server system, the maximum number of system-wide rollback segments is specified by the GC_ROLLBACK_SEGMENTS parameter. When this maximum is reached, no more requests are processed.

Action:Either use fewer rollback segments, or increase the initialization parameter GC_ROLLBACK_SEGMENTS to a number greater than rollback segment ID num in every initialization parameter file of the Parallel Server. This change will not take effect until ORACLE is shut down and restarted.


ORA-01573

ORA-01573shutting down instance, no further change allowed

Cause:A process attempted to make changes while the database was being shut down.

Action:No user action is required.


ORA-01574

ORA-01574maximum number of concurrent transactions exceeded

Cause:An operation requested a resource that was unavailable. The maximum number of concurrent transactions is specified by the TRANSACTIONS initialization parameter. When this maximum is reached, no more requests are processed.

Action:Try the request again later, or increase the TRANSACTIONS parameter in the initialization parameter file. This change will not take effect until ORACLE is shut down and restarted.


ORA-01575

ORA-01575time-out waiting for space management resource

Cause:The system timed out before it could acquire the necessary resources to do space management.

Action:Wait a few minutes, then retry the operation.


ORA-01576

ORA-01576instance locking protocol version num incompatible with ORACLE Version num

Cause:The version of ORACLE is incompatible with the given locking protocol version.

Action:Upgrade the version of ORACLE used to start up instances so that they use a compatible locking protocol.


ORA-01577

ORA-01577cannot add logfile 'name' - file already part of database

Cause:While executing a CREATE or ALTER DATABASE statement, a file being added was found to already exist on the database.

Action:Check syntax and spelling, specify a valid file name, and try again.


ORA-01578

ORA-01578ORACLE data block corrupted (file # num, block # num)

Cause:The given data block was corrupted, probably as a result of program errors.

Action:Try to restore the segment containing the given data block. This may involve dropping the segment and re-creating it. If there is a trace file, report the messages recorded in it to Worldwide Customer Support.


ORA-01579

ORA-01579write message occurred during recovery

Cause:A write message occurred during media recovery.

Action:Check the trace file for the type of the write message, then take appropriate action.


ORA-01580

ORA-01580message creating control backup file 'name'

Cause:An operating system message occurred while attempting to create the referenced control file for backup.

Action:Check the accompanying message stack for detailed information, then take appropriate action.


ORA-01581

ORA-01581attempt to use rollback segment name new extent name which isbeing allocated

Cause:Undo generated to extend a rollback segment run out of current undo block space and is attempting to write into the new extent, which has not been completely allocated.

Action:The rollback segment extending itself will be rollbacked by the system. No more extension will be possible until the next extent is freed up by the rolling back or committing of other transactions.


ORA-01582

ORA-01582unable to open control file for backup

Cause:An operating system error occurred while attempting to open a control file for backup.

Action:Check the accompanying message stack for detailed information, then take appropriate action.


ORA-01583

ORA-01583unable to get block size of control file to be backed up

Cause:An operating system error occurred while attempting to get the block size of a control file for backup.

Action:Check the accompanying message stack for detailed information, then take appropriate action.


ORA-01584

ORA-01584unable to get file size of control file to be backed up

Cause:An operating system error occurred while attempting to get the file size of a control file for backup.

Action:Check the accompanying message stack for detailed information, then take appropriate action.


ORA-01585

ORA-01585error identifying backup file 'name'

Cause:An operating system error occurred when attempting to identify the referenced control file for backup.

Action:Check the accompanying message stack for detailed information, then take appropriate action.


ORA-01586

ORA-01586unable to open destination file 'name' for backup

Cause:An operating system error occurred while attempting to open a control file for backup.

Action:Check the accompanying message stack for detailed information, then take appropriate action.


ORA-01587

ORA-01587error during control file backup file copy

Cause:An operating system error occurred while attempting to copy a control file for backup.

Action:Check the accompanying message stack for detailed information, then take appropriate action.


ORA-01588

ORA-01588must use RESETLOGS option for database open

Cause:An earlier attempt to open the database with the RESETLOGS option did not complete, or recovery was done with a control file backup.

Action:Retry the operation making sure to specify the RESETLOGS option.


ORA-01589

ORA-01589must use RESETLOGS or NORESETLOGS option for database open

Cause:Either cancel-based or time-based recovery has been performed. After these types of recovery, it is necessary to specify either the RESETLOGS or NORESETLOGS option to open the database.

Action:Specify the appropriate option.


ORA-01590

ORA-01590number of segment free list (num) exceeds maximum of num

Cause:The value of the storage clause FREELIST GROUPS is greater than the maximum allowed for the block size.

Action:Specify a number for FREELIST GROUPS less than or equal to the maximum when creating the table or index. The block size specified in the initialization parameter DB_BLOCK_SIZE cannot be changed after the database is created.


ORA-01591

ORA-01591lock held by in-doubt distributed transaction num

Cause:An attempt was made to access a resource locked by a dead two-phase commit transaction that is in prepared state.

Action:Match the transaction number in the message with the GLOBAL_TRAN_ID column of the DBA_2PC_PENDING table to determine the database link and the state of the transaction. Attempt to repair network connections to the coordinator and commit point, if necessary. If timely repair is not possible, contact the database administrator at the commit point (if known) to resolve the pending transaction.


ORA-01592

ORA-01592message converting Version 6 rollback segment 'num' to ORACLE7 form

Cause:ORACLE encountered an message while converting a Version6 rollback segment into the format used by ORACLE7.

Action:Investigate the accompanying internal error message. The Version6 database may not have shut down cleanly. It may be necessary to reload the Version6 database from backup and shut it down ensuring it shuts down cleanly.


ORA-01593

ORA-01593rollback segment optimal size (num blocks) is smaller than initial size (num blocks)

Cause:The specified OPTIMAL size is smaller than the cumulative size of the initial extents during create rollback segment.

Action:Specify a larger OPTIMAL size.


ORA-01594

ORA-01594attempt to wrap into rollback segment name extent num which is being freed

Cause:Undo generated to free a rollback segment extent is attempting to write into the same extent due to small extents and/or too many extents to free.

Action:The rollback segment shrinking will be rolled back by the system, increase the optimal size of the rollback segment.


ORA-01595

ORA-01595error freeing extent num of rollback segment name

Cause:An error occurred while freeing inactive rollback segment extents.

Action:Check the trace file and check for prior messages.


ORA-01596

ORA-01596fail to coalesce extents because sort area size is too small

Cause:There are too many entries of free extents to sort it in the in-memory sort area.

Action:Increase the sort area size or reduce the fragmentation in the tablespace by doing a full export followed by an import.


ORA-01597

ORA-01597cannot alter system rollback segment online or offline

Cause:An attempt was made to online or offline the SYSTEM rollback segment.

Action:None.


ORA-01598

ORA-01598rollback segment 'name' is not online

Cause:The rollback segment was taken offline either manually or by SMON.

Action:Check the status of the rollback segment in DBA_ROLLBACK_SEGS.


ORA-01599

ORA-01599failed to acquire rollback segment (name), cache space is full (currently has (num) entries)

Cause:The amount of allocated space is not enough.

Action:Take the rollback segment offline.


ORA-01600

ORA-01600at most one "str" in clause "str" of GC_FILES_TO_LOCKS

Cause:The initialization parameter GC_FILES_TO_LOCKS was not specified properly.

Action:Refer to the proper specifications of the GC_FILES_TO_LOCKS parameter, and specify it correctly in the initialization parameter file. If other instances are currently accessing the database, use the value that they are using.


ORA-01601

ORA-01601illegal bucket size in clause "str" of GC_FILES_TO_LOCKS

Cause:The number of locks specified in a clause of the initialization parameter GC_FILES_TO_LOCKS is not a positive integer.

Action:Correct the value of the GC_FILES_TO_LOCKS parameter before starting the instance. If other instances are currently accessing the database, use the value that they are using.


ORA-01602

ORA-01602more locks in GC_FILES_TO_LOCKS than reserved in GC_DB_LOCKS

Cause:The total number of PCM locks specified to all database files in the initialization parameter GC_FILES_TO_LOCKS is greater than the number specified in GC_DB_BLOCKS.

Action:Correct the value of either the GC_FILES_TO_LOCKS parameter or the GC_DB_LOCKS parameter before starting the instance. If other instances are currently accessing the database, use the values that they are using.


ORA-01604

ORA-01604illegal file number range in clause "str" of GC_FILES_TO_LOCKS

Cause:The range of file numbers specified in a clause of the initialization parameter GC_FILES_TO_LOCKS is invalid. The first file number must be smaller than the second file number, and a hyphen must separate the numbers. All numbers in the range must be valid file numbers.

Action:Correct the value of the GC_FILES_TO_LOCKS parameter before starting the instance. If other instances are currently accessing the database, use the value that they are using.


ORA-01604

ORA-01604illegal file number range in clause str of GC_FILES_TO_LOCKS

Cause:The range of file numbers specified in a clause of the initialization parameter GC_FILES_TO_LOCKS is invalid. The first file number must be smaller than the second file number, and a hyphen must separate the numbers. All numbers in the range must be valid file numbers.

Action:Correct the value of the GC_FILES_TO_LOCKS parameter before starting the instance. If other instances are currently accessing the database, use the value that they are using.


ORA-01605

ORA-01605missing file numbers in clause "str" of GC_FILES_TO_LOCKS

Cause:The initialization parameter GC_FILES_TO_LOCKS is specified incorrectly; each clause should have one or more file numbers, or ranges of file numbers (as listen in V$DBFILE), separated by commas. Use the following syntax:

GC_FILES_TO_LOCKS = "{filenum[-filenum] [,filenum[-filenum]]...= num_of_locks[EACH]}[:]..."

Spaces are not allowed within the double quotation marks.

Action:Correct the value of the GC_FILES_TO_LOCKS parameter before starting the instance. If other instances are currently accessing the database, use the value that they are using.


ORA-01606

ORA-01606GC_FILES_TO_LOCKS not identical to that of another mounted instance

Cause:The initialization parameter GC_FILES_TO_LOCKS is not the same as another instance mounted in parallel mode. This parameter must be the same as that for all shared instances.

Action:Modify the parameter to be compatible with the other instances, then shut down and restart the instance.


ORA-01607

ORA-01607GC_LCK_PROCS (num) is not the same as other instances (num)

Cause:The initialization parameter GC_LCK_PROCS is not the same in other instances that have the database open.

Action:Modify the parameter to be compatible with the other instances, then shut down and restart the instance.


ORA-01608

ORA-01608cannot bring rollback segment "name" online, its status is (status)

Cause:The rollback segment may have been brought online previously by the database administrator, or could have been left online after a process crashed. The above status can be one of the following: INVALID, IN USE, AVAILABLE, OFFLINE, NEEDS RECOVERY.

Action:Check the status of the rollback segment in the view DBA_ROLLBACK_SEGS. Take the segment offline, if necessary.


ORA-01609

ORA-01609log name is the current log for thread num - cannot drop members

Cause:A member of the current redo log for the given thread cannot be dropped.

Action:If the thread is opened, request a log switch by the instance that is using the thread. If the thread is not open, disable the thread.


ORA-01610

ORA-01610recovery using the BACKUP CONTROLFILE option must be done

Cause:Either an earlier database recovery session specified BACKUP CONTROLFILE or the control file was re-created with the RESETLOGS option. Only BACKUP CONTROLFILE recovery is allowed, and it must be followed by resetting the online redo log files when the database is next opened.

Action:Perform recovery using the BACKUP CONTROLFILE option.


ORA-01611

ORA-01611thread number num is invalid - must be between 1 and num

Cause:A thread number in a command is greater than the number of threads supported by the control file.

Action:Use a thread number that is valid.


ORA-01612

ORA-01612thread num is already enabled

Cause:An attempt was made to enable a thread that is already enabled.

Action:No action is required, or enable another thread, if desired.


ORA-01613

ORA-01613thread num only has num logs - at least 2 logs required to enable

Cause:The thread cannot be enabled because it has less than two online redo log files associated with it.

Action:Add logs to the thread or pick another thread to enable.


ORA-01614

ORA-01614thread num is busy - cannot enable

Cause:The mount enqueue for the thread could not be acquired when attempting to enable the thread. This probably means that another process has already started enabling this thread.

Action:Wait and try again, or find another thread to enable.


ORA-01615

ORA-01615thread num is mounted - cannot disable

Cause:Some instance, possibly this one, has allocated the thread for use. The thread may not be disabled while in use.

Action:To disable this thread, cleanly shut down the instance using it.


ORA-01616

ORA-01616thread num is open - cannot disable

Cause:The thread is not closed. The last instance to use the thread crashed and left the thread open. A thread cannot be disabled until it is closed. The thread is still needed for crash or instance recovery.

Action:If the database is open, instance recovery should close the thread soon; wait a few minutes until instance recovery frees the thread. Otherwise, open the database; crash recovery will close the thread.


ORA-01617

ORA-01617 num is not a valid thread number - cannot mount

Cause:The initialization parameter THREAD is not between 1 and the maximum number of threads allowed when the database was created.

Action:Shut down the instance, change the initialization parameter to a valid value, then restart the instance.


ORA-01618

ORA-01618thread num is not enabled - cannot mount

Cause:The initialization parameter THREAD requests a thread that is not enabled. A thread must be enabled before it can be mounted.

Action:Shut down the instance, change the initialization parameter to an enabled thread number, then restart the instance. If the database is open in another instance, then the thread may be enabled.


ORA-01619

ORA-01619thread num is mounted by another instance

Cause:The initialization parameter THREAD requests a thread that has been mounted by another instance. Only one instance may use each thread.

Action:Shut down the instance, change the initialization parameter to an unused thread, then restart the instance.


ORA-01620

ORA-01620no public threads are available for mounting

Cause:The initialization parameter THREAD is zero, its default value. There are no available threads which have been publicly enabled.

Action:Shut down the instance, change the initialization parameter to a thread which is privately enabled and not mounted, then restart the instance. If the database is open in another instance, then a thread may be publicly enabled.


ORA-01621

ORA-01621cannot rename member of current log if database is open

Cause:This is a rename command for a member of the current log for an open thread. If the database is open anywhere, the log may be in use, so the rename cannot be done.

Action:Wait until the log is not current, or mount the database exclusively.


ORA-01622

ORA-01622thread number must be specified - default not specific

Cause:The thread was not specified when adding a log, and the currently mounted thread was chosen by default at. Since the current thread was not specified explicitly the user cannot know to which thread the log will be added.

Action:Explicitly specify the thread number either in the initialization parameter THREAD, or in the ADD LOGFILE command.


ORA-01623

ORA-01623log num is current log for thread num -cannot drop

Cause:A thread's current log cannot be dropped even if the thread is closed. A disabled thread usually does not have a current log, but a half completed disable may need to be disabled again.

Action:If the database is not open, disable the thread. If the database is open and an instance has the thread open, then switch logs in the instance with the thread open.


ORA-01624

ORA-01624log name needed for crash recovery of thread num - cannot drop

Cause:A log can not be dropped until the thread's checkpoint has advanced out of the log.

Action:If the database is not open, open it. Crash recovery will advance the checkpoint. If the database is open, force a global checkpoint.


ORA-01625

ORA-01625rollback segment name does not belong to this instance

Cause:An attempt was made to take a rollback segment offline that does not belong to this instance.

Action:Only take rollback segments offline that belong to the current instance. To take the rollback segment offline, connect to the instance containing it.


ORA-01626

ORA-01626rollback segment number num cannot handle more transactions

Cause:There are too many transactions in this segment.

Action:Choose a different rollback segment, or reduce the number of concurrent transactions.


ORA-01627

ORA-01627rollback segment number num is not online

Cause:This rollback may have been taken offline by the database administrator, or cleaned up by SMON.

Action:Check the status of the rollback segment in DBA_ROLLBACK_SEGMENTS to make sure the rollback segment is actually online.


ORA-01628

ORA-01628max # of extents (num) reached for rollback segment num

Cause:An attempt was made to extend a rollback segment that already has reached its maximum size.

Action:If possible, increase the value of either the MAXEXTENTS or PCTINCREASE initialization parameters.


ORA-01629

ORA-01629max # of extents (num) reached saving undo for tablespace name

Cause:The maximum amount of space allowed for saving undo entries has been reached for an offline tablespace.

Action:Check the storage parameters for the SYSTEM tablespace. The tablespace named needs to be brought online so that the undo information can be applied.


ORA-01630

ORA-01630max # of extents (num) reached in temp segment in tablespace name

Cause:The maximum amount of space allowed for saving undo entries has been reached for a temporary segment in the named tablespace.

Action:If possible, increase the value of either the MAXEXTENTS or PCTINCREASE initialization parameters.


ORA-01631

ORA-01631max # of extents (num) reached in table name

Cause:The maximum amount of space allowed for saving undo entries has been reached for the named table.

Action:If possible, increase the value of either the MAXEXTENTS or PCTINCREASE initialization parameters.


ORA-01632

ORA-01632max # of extents (num) reached in index name

Cause:The maximum amount of space allowed for saving undo entries has been reached for the named index.

Action:If possible, increase the value of either the MAXEXTENTS or PCTINCREASE initialization parameters.


ORA-01633

ORA-01633Parallel Server option needed for this operation

Cause:The system is not configured to use the Parallel Server option, so the feature is not available.

Action:Contact Oracle Corporation to obtain the Parallel Server option.


ORA-01634

ORA-01634rollback segment number 'string' is about to go offline

Cause:The rollback segment specified was marked to go offline by DBA.

Action:Bring the rollback segment online before continuing.


ORA-01635

ORA-01635rollback segment #num specified not available

Cause:Either:

1) You tried to acquire an offline rollback segment during start up.

2) You tried to drop a rollback segment that contains active transactions.

Action:For the above, do either:

1) Bring the tablespace containing the rollback segment online or do not specify the rollback segment in initialization parameter file.

2) If the rollback segment is in use, shut down the instance using rollback segment, else if the rollback segment needs recovery, find out the errors that are holding back the rolling back of the transactions and take appropriate actions.


ORA-01636

ORA-01636rollback segment "name" is already online

Cause:A rollback segment can only be used by one instance and an instance is trying to bring a rollback segment online that is already in use.

Action:Check that the values set in the initialization parameter file for parameters ROLLBACK_SEGMENTS, ROLLBACK_SEGMENT_INITIAL, and ROLLBACK_SEGMENT_COUNT are correctly set for the instance incurring the problem. Also check that the instance is using the correct initialization parameter file. (Make sure you are not confused about the difference between private and public rollback segments.) See the ORACLE7 Parallel Server Administrator's Guide for more information about using rollback segments in parallel mode.


ORA-01638

ORA-01638 init parameter does not allow ORACLE Version ver to mount parallel

Cause:The recovery compatible initialization parameter is set too low to allow this software version to do a parallel mount.

Action:Either use an earlier software release or advance the RECOVERY_COMPATIBLE parameter. If this happens when no RECOVERY_COMPATIBLE parameter has been specified then set it to the current software release.


ORA-01638

ORA-01638parameter name does not allow Oracle Version num to mount parallel

Cause:The recovery compatible initialization parameter is set too low to allow this software version to do a parallel mount.

Action:Either use an earlier software release or advance the RECOVERY_COMPATIBLE parameter. If this happens when no RECOVERY_COMPATIBLE parameter has been specified, then set it to the current software release.


ORA-01639

ORA-01639database cannot be mounted parallel with no lock processes

Cause:The value of GC_LCK_PROCS is 0, and the database is being mounted in parallel mode.

Action:Change GC_LCK_PROCS to a value between 1 and 10, or leave it undefined to use the default.

________________________________________


ORA-01640

ORA-01640cannot make tablespace read-only with active transactions

Cause:An attempt to make a tablespace read-only encountered active transactions in the database. All transactions must be committed or rolled back to ensure consistency. This includes any transactions that are in doubt.

Action:Put the database in restricted mode to prevent any new transactions from being started and commit and/or rollback all active transactions, resolving all in-doubt transactions.


ORA-01641

ORA-01641datafiles cannot be added to read-only tablespace name

Cause:An attempt was made to add datafiles to a read-only tablespace.

Action:Make the tablespace read-write before attempting to add datafiles.


ORA-01642

ORA-01642begin backup not needed for read-only tablespace name

Cause:An attempt was made to use the BEGIN BACKUP or END BACKUP statement for a tablespace that has been made read-only.

Action:Start the backup without using the BEGIN BACKUP or END BACKUP statement. Read-only files cannot be modified and therefore will be consistent.


ORA-01643

ORA-01643system tablespace cannot be made read-only

Cause:An attempt was made to make the system tablespace read-only. The system tablespace must be read-write for database operations.

Action:Do not attempt this operation.


ORA-01644

ORA-01644tablespace name is already read-only

Cause:An attempt was made to make read-only a tablespace that is already read-only.

Action:This operation is unnecessary.


ORA-01645

ORA-01645previous attempt to make read-write is half complete

Cause:A failure while making a tablespace read-write occurred leaving the tablespace read-only, however the checkpoint was advanced. The tablespace will not be usable after a RESETLOGS if it's files are offline.

Action:Attempt to make the tablespace read-write again.


ORA-01646

ORA-01646tablespace name is not read-only - cannot make read-write

Cause:An attempt was made to make read-write a tablespace that is already read-write.

Action:This operation is unnecessary.


ORA-01647

ORA-01647tablespace "name" is read-only, cannot allocate space in it

Cause:An attempt was made to allocate space in a read-only tablespace, which isnot possible.

Action:Create the object in a read-write tablespace.


ORA-01648

ORA-01648log name is the current log of disabled thread name

Cause:An attempt to enable the thread failed after it was half completed. This log was left as the current log even though the thread is still disabled. Because a log switch cannot be done until the thread is enabled, the log cannot be cleared or archived.

Action:Complete the thread enable by issuing the enable command again.


ORA-01649

ORA-01649operation not allowed with a backup control file

Cause:An attempt was made to perform a command that does not make sense when the control file is a restored backup.

Action:Wait until after the database has been opened and try again.


ORA-01650

ORA-01650unable to extend rollback segment name by num in tablespace name

Cause:Failed to allocate extent for the rollback segment in tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.


ORA-01651

ORA-01651unable to extend save undo segment by num in tablespace name

Cause:Failed to allocate extent for saving undo entries for the specifiedoffline tablespace.

Action:Check the storage parameters for the system tablespace. The tablespace must be brought back online so the undo can be applied.


ORA-01652

ORA-01652unable to extend temp segment by num in tablespace name

Cause:Failed to allocate extent for temp segment in tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace or create the object in another tablespace.


ORA-01653

ORA-01653unable to extend table name.name by num in tablespace name

Cause:Failed to allocate extent for table segment in tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.


ORA-01654

ORA-01654unable to extend index name.name by num for tablespace name

Cause:Failed to allocate extent for index segment in tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.


ORA-01655

ORA-01655unable to extend cluster name.name by num for tablespace name

Cause:Failed to allocate extent for cluster segment in tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.


ORA-01656

ORA-01656max num extents num reached in cluster name.name

Cause:A cluster tried to extend past the value specified for MAXEXTENTS.

Action:If MAXEXTENTS is less than the system maximum, specify a higher value. Otherwise, you must recreate with larger INITIAL, NEXT, orPCTINCREASE parameters.


ORA-01657

ORA-01657invalid SHRINK option value

Cause:The specified value must be an integer.

Action:Choose an appropriate integer value.


ORA-01658

ORA-01658unable to create INITIAL extent for segment in tablespace name

Cause:Failed to find sufficient contiguous space to allocate INITIAL extent for segment being created.

Action:Use ALTER TABLESPACE ADD DATAFILE to add additional space to the tablespace or retry with a smaller value for INITIAL.


ORA-01659

ORA-01659unable to allocate MINEXTENTS beyond size in tablespace name

Cause:Failed to find sufficient contiguous space to allocate MINEXTENTS for the segment being created.

Action:Use ALTER TABLESPACE ADD DATAFILE to add additional space to the tablespace or retry with smaller value for MINEXTENTS, NEXT,or PCTINCREASE.


ORA-01660

ORA-01660tablespace name is already permanent

Cause:An attempt was made to make a tablespace permanent that was already permanent.

Action:Leave tablespace permanent.

For more information about ALTER TABLESPACE, see the index entry on "ALTER TABLESPACE" in Oracle8 Server SQL Reference.


ORA-01661

ORA-01661tablespace name is already temporary

Cause:An attempt was made to make a tablespace temporary that was already temporary.

Action:Leave tablespace permanent. For more information about ALTER TABLESPACE, see the index entry on "ALTER TABLESPACE" in Oracle8 Server SQL Reference.


ORA-01662

ORA-01662tablespace name is non-empty and cannot be made temporary

Cause:An attempt was made to convert a non-empty tablespace to a temporary tablespace.

Action:Drop all the objects in the tablespace.

For more information about ALTER TABLESPACE and DROP TABLESPACE, see the index entries on "ALTER TABLESPACE" and on "DROP TABLESPACE" in Oracle8 Server SQL Reference


ORA-01663

ORA-01663the contents of tablespace name is constantly changing

Cause:The contents of the tablespace always changed between PERMANENT and TEMPORARY

Action:Decide what the tablespace contents should be and stay with it.

For more information about ALTER TABLESPACE, see the index entry on "ALTER TABLESPACE" in Oracle8 Server SQL Reference.


ORA-01664

ORA-01664transaction which has expanded the Sort Segment has aborted

Cause:Internal Error.

Action:Contact Oracle Support.


ORA-01665

ORA-01665controlfile is not a standby controlfile

Cause:An attempt was made to mount, recover, or activate a standby database without a standby controlfile.

Action:Create a standby controlfile before attempting to use the database as a standby database.

For more information about control files and the manipulation of control files, see the index entry on "control files" in Oracle8 Server Concepts and the index entry on "control files, in CREATE DATABASE" in Oracle8 Server SQL Reference.


ORA-01666

ORA-01666controlfile is for a standby database

Cause:An attempt was made to mount, recover, or open a standby database without the appropriate command option to designate a standby database.

Action:Use the standby option or appropriate commands, or mount with the primary controlfile.

For more information about control files and the manipulation of control files, see the index entry on "control files" in Oracle8 Server Concepts and the index entry on "control files, in CREATE DATABASE" in Oracle8 Server SQL Reference.


ORA-01667

ORA-01667redo log is incompatible with standby database

Cause:Recovery of a standby database encountered redo in primary database that did not support the standby database option

Action:Change the compatible initialization parameter for the primary database to be 7.3.0 or greater, open the primary database, and rebuild the standby database.

For more information about parameter files and database startles, see the index entry on "parameter files" in Oracle8 Server Concepts.


ORA-01668

ORA-01668standby database requires DROP option for offline of datafile

Cause:An attempt was made to take a datafile offline in a standby database without specifying the DROP option. Files that were offline in a standby database were not recovered, and were likely to be unusable if the standby was activated. Note that specifying DROP does not prevent bringing the file online later.

Action:Specify the DROP option or leave the file online.

For more information about the DROP clause or other DROP commands, see the index entry on "DROP" in Oracle8 Server SQL Reference.


ORA-01669

ORA-01669standby database control file not consistent

Cause:An attempt was made to activate a standby database with a control file that was not recovered to the same point as the datafiles. Most likely the control file was just copied in primary database and was not used for recovery.

Action:Recover the standby database until all the files are consistent.

For more information about database recovery, see the index entry on "recovery, database, overview of" in Oracle8 Server Concepts.


ORA-01670

ORA-01670new datafile name needed for standby database recovery

Cause:Standby database recovery noticed that a file was added to the primary database but was not available on the standby.

Action:Either copy the file in primary database or do an ALTER DATABASE CREATE DATAFILE command on the standby to create a file to recover.

For more information about ALTER DATABASE CREATE DATAFILE, see the index entries on "ALTER DATABASE" and on "CREATE DATAFILE clause, of ALTER DATABASE command" in Oracle8 Server SQL Reference.


ORA-01671

ORA-01671controlfile is a backup, cannot make a standby controlfile

Cause:The currently mounted control file was a backup control file and attempted to create a control file for a standby database.

Action:Complete any needed recovery and open the database with the RESETLOGS option.

For more information about the RESETLOGS option, see the index entry on "RESETLOGS option, of ALTER DATABASE command" and on "RESETLOGS option, of CREATE CONTROLFILE command" in Oracle8 Server SQL Reference.


ORA-01672

ORA-01672controlfile may be missing files or have extra ones

Cause:An attempt was made to create a standby control file, but the controlfile was either recently created by using CREATE CONTROLFILE or an incomplete recovery was done. Therefore, the datafiles in the controlfile and the ones in the data dictionary may not match.

Action:Open the database and retry the operation.

For more information about CREATE CONTROLFILE, see the index entry on "CONTROLFILE" in Oracle8 Server SQL Reference.


ORA-01673

ORA-01673datafile name has not been identified

Cause:The datafile was not in the control file after an incomplete recovery or CREATE CONTROLFILE. Since information from its header was needed for standby database recovery, a standby controlfile cannot be created.

Action:Find the file and bring it online. If desired, it may be taken offline again. If you intend to drop this file, then taking it offline with the DROP option will avoid this error.

For more information about CREATE CONTROLFILE and DROP, see the index entries on "CREATE CONTROLFILE" and on "DROP" in Oracle8 Server SQL Reference.


ORA-01674

ORA-01674datafile name is an old incarnation rather than current file

Cause:Recovery encountered redo that indicates this file was dropped in database, and another file was added using the same file number. This implies that a CREATE CONTROLFILE command was given the old file which was dropped rather than the latest file.

Action:Rebuild the controlfile using CREATE CONTROLFILE, and give the correct file.

For more information about CREATE CONTROLFILE and DROP, see the index entries on "CREATE CONTROLFILE" and on "DROP" in Oracle8 Server SQL Reference.


ORA-01675

ORA-01675attempting a secondary mount of a standby database

Cause:An attempt was made to mount a standby database as a secondary.

Action:The standby database is already mounted. Do a dismount first before attempting to mount the standby database.

For more information about dismounting and mounting, see the index entries on "database, dismounting" and on "database, mounting" in Oracle8 Server Concepts and on "mounting, databases" in Oracle8 Server SQL Reference.


ORA-01676

ORA-01676standby file name convert of num exceeds maximum length of num

Cause:When the given file name was converted to the name used for the standby database, the converted name was bigger than the maximum allowed file name.

Action:Change the initialization parameter DB_FILE_STANDBY_NAME_CONVERT or LOG_FILE_STANDBY_NAME_CONVERT to convert to a valid file name.

For more information about the DB_FILES and LOG_FILES initialization parameters, see the index entries on "DB_FILES" and on "LOG_FILES" in Oracle8 Server SQL Reference.


ORA-01677

ORA-01677standby file name convert parameters differ from other instance

Cause:The DB_FILE_STANDBY_NAME_CONVERT or LOG_FILE_STANDBY_NAME_CONVERT initialization parameters were not the same as in other instances that already have the database mounted.

Action:Change initialization parameters DB_FILE_STANDBY_NAME_CONVERT and LOG_FILE_STANDBY_NAME_CONVERT to match other instances.

For more information about the DB_FILES and LOG_FILES initialization parameters, see the index entries on "DB_FILES" and on "LOG_FILES" in Oracle8 Server SQL Reference.


ORA-01678

ORA-01678parameter name must be two strings, a pattern and a replacement

Cause:The specialized initialization parameter did not have 2 strings for its value. The first string is a pattern to be found in file names. The second string is used to replace the pattern when found in file names.

Action:Specify two strings for the parameter, or omit the parameter.


ORA-01679

ORA-01679database must be mounted EXCLUSIVE and not open to activate

Cause:An attempt to activate a standby database was made when the database was not mounted EXCLUSIVE or was already open.

Action:Mount the database EXCLUSIVE and retry the ACTIVATE command.

For more information about the EXCLUSIVE option, see the index entry on "EXCLUSIVE option" in Oracle8 Server SQL Reference.


ORA-01680

ORA-01680gc_db_locks cannot be zero if gc_files_to_locks is used

Cause:Setting gc_db_locks to zero makes data blocks in all files releasable, so specifying gc_files_to_locks is redundant.

Action:Remove either gc_db_locks or gc_files_to_locks.

For more information about the GC_DB_LOCKS parameter and the GC_FILES_TO_LOCKS parameter, see the index entries on "GC_DB_LOCKS parameter" and "GC_FILES_TO_LOCKS parameter" in Oracle8 Server SQL Reference.


ORA-01681

ORA-01681max # extents num reached in LOB segment in tablespace name

Cause:A LOB segment tried to extend past the maximum number of extents.

Action:If the value of MAXEXTENTS for the tablespace is less than the system maximum, increase the parameter's value. Otherwise, increase the value of PCTINCREASE for the tablespace.


ORA-01683

ORA-01683unable to extend index name.name partition name by num in tablespace name

Cause:An extent for an index segment was not allocated in the tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the indicated tablespace.


ORA-01684

ORA-01684max # extents num reached in table name.name partition name

Cause:An attempt was made to extend past the maximum number of extents.

Action:If the value of MAXEXTENTS is less than the system maximum, increase the parameter's value. Otherwise, recreate the table with larger INITIAL, NEXT, or PCTINCREASE parameters.


ORA-01685

ORA-01685max # extents num reached in index name.name partition name

Cause:An attempt was made to extend an index past the maximum number of extents.

Action:If the value of MAXEXTENTS is less than the system maximum, increase the parameter's value. Otherwise, recreate the index with larger INITIAL, NEXT, or PCTINCREASE parameters.


ORA-01686

ORA-01686max # files num reached for the tablespace name

Cause:The number of files for a given tablespace has reached its maximum value.

Action:Resize existing files in the tablespace, or partition the objects among multiple tablespaces, or move some objects to a different tablespace.


ORA-01687

ORA-01687specified logging attribute for tablespace name is same as the existing

Cause:An attempt was made to change the tablespace default logging attribute (LOGGING or NOLOGGING) to be the same as the existing logging attribute.

Action:Change the specified logging attribute.


ORA-01688

ORA-01688unable to extend table name.name partition name by num in tablespace name

Cause:An extent could not be allocated for a table segment in tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.


ORA-01689

ORA-01689syntax error in clause name of name

Cause:There was a syntax error in the specification of an initialization parameter.

Action:Fix the syntax error and restart the instance.


ORA-01690

ORA-01690GC_ROLLBACK_LOCKS not identical to that of another mounted instance

Cause:The value of the parameter GC_ROLLBACK_LOCKS was different on different instances.

Action:Modify the initialization parameter GC_ROLLBACK_LOCKS and restart the instance.


ORA-01691

ORA-01691unable to extend LOB segment name.name by num in tablespace name

Cause:An extent could not be allocated for a LOB segment in the specified tablespace.

Action:Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.


ORA-01692

ORA-01692unable to extend LOB segment name.name partition name by num in tablespace name

Cause:An extent could not be allocated for a LOB segment in the specified tablespace.

Action:Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the specified tablespace.


ORA-01693

ORA-01693max # extents num reached in LOB segment name.name

Cause:A LOB segment tried to extend past the value of MAXEXTENTS.

Action:If the value of MAXEXTENTS is less than the system maximum, increase the value of the parameter. Otherwise, recreate the LOB segment with larger INITIAL, NEXT, or PCTINCREASE parameters.


ORA-01694

ORA-01694max # extents num reached in LOB segment name.name partition name

Cause:A LOB segment tried to extend past the value of MAXEXTENTS.

Action:If the value of MAXEXTENTS is less than the system maximum, increase the value of the parameter. Otherwise, recreate the LOB segment with larger INITIAL, NEXT, or PCTINCREASE parameters.


ORA-01695

ORA-01695error converting rollback segment name to version 8.0.2

Cause:Version 8.0.1 database may not have shutdown cleanly.

Action:May have to reload the 8.0.1 database and shutdown cleanly.


ORA-01696

ORA-01696controlfile is not a clone controlfile

Cause:Attempting to mount, a database as a clone when it is already mounted by another instance not as a clone or attempting to use a current controlfile for a clone.

Action:Mount without the clone option or use a backup controlfile and shutdown the other instances before mounting as a clone.


ORA-01697

ORA-01697controlfile is for a clone database

Cause:An attempt was made to mount a clone database without the appropriate command option to designate a clone database.

Action:Use the clone option or appropriate commands, or mount with the primary controlfile.


ORA-01698

ORA-01698a clone database may only have SYSTEM rollback segment online

Cause:An attempt was made to online a rollback segment in a clone database.

Action:Do not use this command.


ORA-01699

ORA-01699tablespace 'name' is being imported for point in time recovery

Cause:An attempt was made to online a tablespace or begin another point in time import while a point in time import is already in progress.

Action:Wait until the import completes.


ORA-01700

ORA-01700duplicate username in list

Cause:A username was listed twice in a GRANT or REVOKE statement. Usernames must be unique and may only be specified once in a GRANT or REVOKE statement.

Action:Remove the duplicate username, then re-execute the statement.


ORA-01701

ORA-01701a cluster is not appropriate here

Cause:The name of a cluster was specified in a statement in which clusters are not permitted.

Action:Enter a valid CLUSTER statement or change the cluster name to the name of a valid object for the statement (such as table, view, index, or synonym).


ORA-01702

ORA-01702a view is not appropriate here

Cause:The name of a view was specified in a statement in which views are not permitted.

Action:Enter the name of a valid object for the statement (such as table, cluster, synonym, or index).


ORA-01703

ORA-01703missing SYNONYM keyword

Cause:The keyword SYNONYM is required in this context.

Action:Check the statement syntax, then insert the keyword SYNONYM.


ORA-01704

ORA-01704string literal too long

Cause:A quoted string specified as a constant was too long.

Action:Quoted strings may not contain more than 2000 characters.


ORA-01705

ORA-01705an outer join cannot be specified on a correlation column

Cause:A correlation column (that is, a column in a subquery from a table referenced in the outer query's FROM clause) was followed by an outer-join indicator (+). This is not allowed.

Action:Reword or reform the query. Refer to the syntax for subqueries. The outer-join indicator may only follow columns in the same query block in which their table is included in the FROM clause.


ORA-01706

ORA-01706user function result value was too large

Cause:The user-written SQL function has generated a result that is larger than the maximum defined in the function table.

Action:Change the maximum in the function table, or correct the user-written function.


ORA-01707

ORA-01707missing LIST keyword

Cause:The keyword LIST is required in this context (for example, when using the ARCHIVE LOG statement to display the set of redo log files).

Action:Check the statement syntax and insert the keyword LIST where required, then re-execute the statement.


ORA-01708

ORA-01708ACCESS or SESSION expected

Cause:An AUDIT or NOAUDIT statement contained the keyword BY followed by something other than ACCESS or SESSION.

Action:Check the statement syntax and make sure to follow the keyword BY with ACCESS or SESSION.


ORA-01709

ORA-01709program does not exist

Cause:This feature is not currently implemented.

Action:No user action is required.


ORA-01710

ORA-01710missing OF keyword

Cause:The keyword OF was not specified in a SELECT FOR UPDATE statement.

Action:Check and correct the statement syntax. To specify SELECT FOR UPDATE, add the following clause to the end of the SELECT statement:

FOR UPDATE OF column-list


ORA-01711

ORA-01711duplicate privilege listed

Cause:A privilege was listed twice in a GRANT or REVOKE statement. A privilege may only be specified once in these statements.

Action:Remove the duplicate privilege from the list, then re-execute the statement.


ORA-01712

ORA-01712cannot grant a privilege grantor does not have

Cause:The grantor could not grant a privilege to another user because the grantor does not have the privilege. A grantor can only grant privileges that the grantor has or is authorized to grant.

Action:Either:

1) Specify only authorized privileges in the GRANT statement.

2) Ask the database administrator to grant the user the required privileges.

3) Ask the database administrator for the required privileges and then grant the other user the privileges.


ORA-01713

ORA-01713GRANT OPTION does not exist for that privilege

Cause:A GRANT statement specified a privilege that the granting user has but is not authorized to grant to other users. When the user was granted the privilege, the user was not given the GRANT OPTION needed to grant those privileges to others.

Action:Change the GRANT statement to specify only authorized privileges, or ask the user who granted the privileges to grant the GRANT OPTION also.


ORA-01714

ORA-01714error in execution of user function

Cause:The user-written SQL function indicated that an error occurred during its execution. The meaning of the message is function-dependent.

Action:Ensure proper usage of the function or correct the function.


ORA-01715

ORA-01715UNIQUE may not be used with a cluster index

Cause:An attempt was made to create a cluster index with the UNIQUE attribute. This is not permitted.

Action:Remove the keyword UNIQUE from the CREATE INDEX statement, then re-execute the statement.


ORA-01716

ORA-01716NOSORT may not be used with a cluster index

Cause:An attempt was made to create a cluster index using the NOSORT option. This is not permitted.

Action:Check the statement syntax and remove the keyword NOSORT from the CREATE INDEX statement, then re-execute the statement.


ORA-01717

ORA-01717seccta: invalid access mode token passed

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01718

ORA-01718BY ACCESS | SESSION clause not allowed for NOAUDIT

Cause:A BY ACCESS or BY SESSION clause was used in a NOAUDIT statement. BY ACCESS and BY SESSION are valid clauses in AUDIT statements, but are not permitted in NOAUDIT statements.

Action:Remove the BY ACCESS or BY SESSION clause from the NOAUDIT statement.


ORA-01719

ORA-01719outer join operator (+) not allowed in operand of OR or IN

Cause:An outer join appears in an OR clause.

Action:If A and B are predicates, to get the effect of (A(+) OR B), try using the following:

(SELECT WHERE (A+ AND NOT B)) UNION ALL (SELECT WHERE (B));


ORA-01720

ORA-01720grant option does not exist for 'str'

Cause:A grant was being performed on a view and the grant option was not present for an underlying object.

Action:Obtain the grant option on all underlying objects of the view.


ORA-01721

ORA-01721USERENV (COMMITSCN) invoked more than once in a transaction

Cause:The USERENV function can be used only once in a transaction.

Action:Rewrite the transaction to use USERENV (COMMITSCN) only once.


ORA-01722

ORA-01722invalid number

Cause:The attempted conversion of a character string to a number failed because the character string was not a valid numeric literal. Only numeric fields or character fields containing numeric data may be used in arithmetic functions or expressions. Only numeric fields may be added to or subtracted from dates.

Action:Check the character strings in the function or expression; make sure they contain only numbers, a sign, a decimal point, and the character "E" or "e", then retry the operation.


ORA-01723

ORA-01723zero-length columns are not allowed

Cause:During CREATE TABLE, a zero-length column was specified (CHAR(0), for example).

Action:Correct the column declaration so that length is at least 1 and try the operation again.


ORA-01724

ORA-01724floating point precision is out of range (1 to 126)

Cause:Floating point precision is too small or large.

Action:Correct and retry.


ORA-01725

ORA-01725USERENV (COMMITSCN) not allowed here

Cause:The function USERENV (COMMITSCN) is allowed only as a top-level expression in the VALUES clause of an INSERT statement and on the right side of an assignment in an UPDATE statement.

Action:Correct the use of this function.


ORA-01726

ORA-01726a table is not appropriate here

Cause:A table name was used in a statement in which tables are not permitted.

Action:Enter a valid table statement or use the current statement on the appropriate object.


ORA-01727

ORA-01727numeric precision specifier is out of range (1 to 38)

Cause:The precision specified for a number column in a CREATE/ALTER TABLE or CREATE CLUSTER statement must be a digit between 1 and 38. If no precision is specified, a default precision of 22 digits is used.

Action:Specify numeric precision between 1 and 38, then re-execute the statement.


ORA-01728

ORA-01728numeric scale specifier is out of range (-84 to 127)

Cause:The scale specified for a numeric field in a CREATE/ALTER TABLE or CREATE CLUSTER statement is not in the valid range. It should be between -84 and 127.

Action:Specify a numeric scale between -84 and 127. If a number is not specified, the default scale of the column is 0 decimal places.


ORA-01729

ORA-01729database link name expected

Cause:A database link name does not follow the "@" in a reference to a table in a remote database.

Action:Correct the reference, then retry the operation. The correct syntax for denoting a table in a remote database follows:

username.table_name@ database_name

Spaces before and after the at-sign are optional.


ORA-01730

ORA-01730invalid number of column names specified

Cause:The number of column names specified in a CREATE VIEW statement did not correspond to the number of columns listed in the SELECT clause. If column names are specified in a CREATE VIEW statement, exactly one name must be specified for each column or expression in the SELECT clause.

Action:Specify one view column name for each column in the SELECT clause.


ORA-01731

ORA-01731circular view definition encountered

Cause:Through a series of CREATE and DROP VIEW statements, a view became defined in terms of itself. For example, VIEW1 might include a column from VIEW2 that is defined as a column in VIEW1. View definitions may be seen by querying the data dictionary.

Action:Check the view definitions and remove any circular references, then re-execute the statements.


ORA-01732

ORA-01732data manipulation operation not legal on this view

Cause:An attempt was made to use an UPDATE, INSERT, or DELETE statement on a view that contains expressions or functions, or was derived from more than one table. If a join operation was used to create the view or the view contains virtual columns derived from functions or expressions, then the view may only be queried.

Action:UPDATE, INSERT, or DELETE rows in the base tables instead, and restrict the operations on the view to queries.


ORA-01733

ORA-01733virtual column not allowed here

Cause:An attempt was made to use an INSERT, UPDATE, or DELETE statement on an expression in a view.

Action:INSERT, UPDATE, or DELETE data in the base tables instead of the view.


ORA-01734

ORA-01734illegal parameters - EXTENT MIN higher than EXTENT MAX

Cause:The value of the lower parameter EXTENT MIN was higher than the value of the upper parameter EXTENT MAX.

Action:Select a value for EXTENT MIN that is smaller than EXTENT MAX.


ORA-01735

ORA-01735invalid ALTER TABLE option

Cause:An invalid option was specified in an ALTER TABLE statement.

Action:Check the statement syntax and specify a valid option and then re-execute the statement.


ORA-01736

ORA-01736[NOT] SUCCESSFUL expected

Cause:An AUDIT or NOAUDIT statement contained WHENEVER followed by something other than SUCCESSFUL or NOT SUCCESSFUL.

Action:Correct the WHENEVER clause, then re-execute the statement.


ORA-01737

ORA-01737valid modes: [ROW] SHARE, [[SHARE] ROW] EXCLUSIVE, SHARE UPDATE

Cause:The lock mode entered was not recognized.

Action:Enter one of the following: SHARE, ROW SHARE, EXCLUSIVE, ROW EXCLUSIVE, SHARE ROW EXCLUSIVE, or SHARE UPDATE.


ORA-01738

ORA-01738missing IN keyword

Cause:In a LOCK TABLE statement, the keyword IN was missing.

Action:Place the keyword IN and lock mode directly after the table name in the LOCK TABLE statement, then re-execute the statement.


ORA-01739

ORA-01739missing MODE keyword

Cause:In a LOCK TABLE statement, the keyword MODE was missing. The keyword MODE must directly follow the specified lock mode.

Action:Check the statement syntax and insert the keyword MODE where required, then re-execute the statement.


ORA-01740

ORA-01740missing double quote in identifier

Cause:An initial double quote (") was found without a closing quote. If an identifier contains a blank or special characters other than $, #, or _, it must be enclosed in double quotes.

Action:Add a closing double quote (") to the end of the identifier.


ORA-01741

ORA-01741illegal zero-length identifier

Cause:An attempt was made to use two double quotes ("") as an identifier. An identifier must be at least one character long.

Action:Insert at least one character between the double quotes in the identifier. If a blank identifier is required, specify a blank space between the double quotes (" ").


ORA-01742

ORA-01742comment not terminated properly

Cause:The indicated comment or hint beginning with a /* token is not terminated with a closing */ token.

Action:Check that the comment or hint is terminated properly.


ORA-01743

ORA-01743internal inconsistency; illegal user function index

Cause:This is not currently implemented.

Action:No user action is required.


ORA-01744

ORA-01744inappropriate INTO

Cause:The INTO clause may not be used in a subquery.

Action:Check the syntax and place the INTO clause in the top-level query, then re-execute the statement.


ORA-01745

ORA-01745invalid host/bind variable name

Cause:A colon in a bind variable or INTO specification was followed by an inappropriate name (perhaps a reserved word).

Action:Change the variable name, then retry the operation.


ORA-01746

ORA-01746indicator variable not permitted here

Cause:An indicator variable is not permitted in this context.

Action:Remove the indicator variable, then retry the operation.


ORA-01747

ORA-01747invalid user.table.column, table.column or columns specification

Cause:A column name was specified improperly in the current SQL statement.

Action:Check the statement's syntax and especially references to column names, then re-execute the statement.


ORA-01748

ORA-01748only simple column names allowed here

Cause:This SQL statement does not allow a qualified column name, such as username.table.column or table.column.

Action:Remove the qualifications from the column, then retry the operation.


ORA-01749

ORA-01749may not GRANT/REVOKE privileges to/from self

Cause:Grantor is not allowed to grant or revoke object or system privileges to self.

Action:Issue the GRANT or REVOKE of system privileges from another database administrator account.


ORA-01750

ORA-01750UPDATE/REFERENCES may only be revoked from the whole table, not by column

Cause:Although it is possible to GRANT update privileges on a column-by-column basis, it is only possible to REVOKE them for an entire table.

Action:Do not identify specific columns. To revoke update privileges for certain columns, use REVOKE for the entire table, then GRANT the user privileges for specific columns.


ORA-01751

ORA-01751invalid dump undo option

Cause:An invalid option was specified in the ALTER SYSTEM DUMP UNDO command.

Action:Check the syntax for spelling errors or invalid option names and reenter the command.

For more information about ALTER SYSTEM, see the index entry on "ALTER SYSTEM" in Oracle8 Server SQL Reference.


ORA-01752

ORA-01752cannot delete from view without exactly one key-preserved table

Cause:The deleted table either had no key-preserved tables, had more than one key-preserved table, or the key-preserved table was an unmerged view or a table from a read-only view.

Action:Redefine the view or delete it from the underlying base tables.

For more information about join views, see the index entries under "views" in Oracle8 Server SQL Reference, the index entry under "views" in the Oracle8 Server Application Developer's Guide, and the index entry on "updatable join views" in Oracle8 Server Concepts.


ORA-01753

ORA-01753column definition incompatible with clustered column definition

Cause:When adding a table to a cluster, the definition of the column in the table was inconsistent with the definition of the column in the cluster.

Action:The table cannot be added to the cluster until all cluster column definitions are consistent.


ORA-01754

ORA-01754a table may contain only one column of type LONG

Cause:Only one column per table may be defined with datatype LONG.

Action:Remove the LONG datatype from all but one column, then retry the operation.


ORA-01755

ORA-01755must specify an extent number or block number

Cause:An extent number or block number was not specified.

Action:Specify the proper extent number or block number.

For more information about selecting the proper extent number or block number, see the index entries on "ALLOCATE EXTENT clause, of ALTER TABLE command" and on "block size" in Oracle8 Server SQL Reference.


ORA-01756

ORA-01756quoted string not properly terminated

Cause:A quoted string must be terminated with a single quote mark (').

Action:Insert the closing quote, then re-execute the statement.


ORA-01757

ORA-01757must specify an object number

Cause:An object number was not specified.

Action:Specify the proper object number.

For more information specifying the proper object number, see the index entry on "object naming" in Oracle8 Server SQL Reference.


ORA-01758

ORA-01758table must be empty to add mandatory (NOT NULL) column

Cause:It is not possible to define a new column as NOT NULL if rows already exist in the table being modified.

Action:Re-issue the statement without the NOT NULL specification.


ORA-01759

ORA-01759user function is incorrectly defined

Cause:A user function has been improperly defined.

Action:Contact Worldwide Customer Support.


ORA-01760

ORA-01760illegal argument for function

Cause:The argument or arguments specified for the function are not valid in this context.

Action:Check the definition of the function and correct the arguments.


ORA-01761

ORA-01761DML operation does not map to a unique table in the join

Cause:The primary table is the base table against which the update, insert or delete operation is ultimately performed. If the operation is a delete, either there is no primary table in the join or there is more than one primary table. If the operation is an update or an insert, the specified columns map to more than one base table.

Action:Modify the join specification so that the situations described above do not occur.


ORA-01762

ORA-01762vopdrv: view query block not in FROM

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-01763

ORA-01763update or delete involves outer joined table

Cause:If the operation is a delete, the table being deleted from is outer-joined to some other table. If the operation is an update, either the table being updated is outer-joined to some other table, or a table that is reachable from the primary table is being outer-joined to a table not reachable from the primary table.

Action:Modify the join specification so that the situations described above do not occur.


ORA-01764

ORA-01764new update value of join is not guaranteed to be unique

Cause:A row of a join query table is being updated using a row of a table that is not guaranteed to have only one value for the row being updated.

Action:Modify the join specification, so that the situation described above does not occur.


ORA-01765

ORA-01765specifying table's owner name is not allowed

Cause:A table or view name was specified with a period (.) or identified with an invalid prefix.

Action:Verify that the object is identified correctly, and if necessary remove the period from the name.


ORA-01766

ORA-01766dictionary table not allowed in this context

Cause:The name of a data dictionary object was used outside the FROM clause of a SELECT statement. The only operation allowed on a data dictionary object is to SELECT from it.

Action:Restrict operations on data dictionary objects to queries.


ORA-01767

ORA-01767UPDATE ... SET expression must be a subquery

Cause:An attempt was made to use a single expression without a subquery to update a list of columns.

Action:Check the syntax for using subqueries to update data and add the necessary subquery.


ORA-01768

ORA-01768number string too long

Cause:A number entered exceeds the limit of 255 characters (including digits, sign, decimal point, and exponent).

Action:Shorten the number string, perhaps by expressing it in scientific notation (for example, 1.85E9 instead of 1,850,000,000).


ORA-01769

ORA-01769duplicate CLUSTER option specifications

Cause:During a CREATE of a clustered table, an attempt was made to specify more than one CLUSTER option.

Action:Remove the extra CLUSTER option, then re-execute the statement.


ORA-01770

ORA-01770CLUSTER option not allowed in CREATE CLUSTER command

Cause:An attempt was made to use the CLUSTER option within a CREATE CLUSTER statement.

Action:Remove the CLUSTER clause and try again.


ORA-01771

ORA-01771illegal option for a clustered table

Cause:CLUSTER option conflicts with MAXTRANS option.

Action:Choose one option and re-execute the statement.


ORA-01772

ORA-01772must specify a value for LEVEL

Cause:A value for LEVEL was not specified.

Action:Specify a proper value for LEVEL and reissue the command.

For more information specifying a proper value for LEVEL, see the index entries on "LEVEL pseudocolumn" and on "LEVEL pseudocolumn, in SELECT command" in Oracle8 Server SQL Reference.


ORA-01773

ORA-01773may not specify column datatypes in this CREATE TABLE

Cause:Column datatypes were specified in a SELECT statement used to directly create and load a table.

Action:Remove column datatypes. The datatypes of the SELECT list expressions are automatically used as the column datatypes.


ORA-01774

ORA-01774dump undo option specified more than once

Cause:The same option was specified more than once in the ALTER SYSTEM DUMP UNDO command.

Action:Check the syntax, remove the redundant specification of the option, and reissue the command.

For more information about ALTER SYSTEM, see the index entry on "ALTER SYSTEM" in Oracle8 Server SQL Reference.


ORA-01775

ORA-01775looping chain of synonyms

Cause:Through a series of CREATE synonym statements, a synonym was defined in terms of itself. For example, the following definitions are circular:

CREATE SYNONYM s1 for s2

CREATE SYNONYM s2 for s3

CREATE SYNONYM s3 for s1

Action:Change one synonym definition so that it applies to a base table or view, then retry the operation.


ORA-01776

ORA-01776cannot modify more than one base table through a join view

Cause:Columns belonging to more than one underlying table were either inserted into or updated.

Action:Phrase the statement as two or more separate statements.

For more information about join views, see the index entries under "views" in Oracle8 Server SQL Reference, the index entry under "views" in the Oracle8 Server Application Developer's Guide, and the index entry on "updatable join views" in Oracle8 Server Concepts.


ORA-01777

ORA-01777WITH GRANT OPTION not allowed in this system

Cause:This version of ORACLE does not support the WITH GRANT OPTION.

Action:Remove the WITH GRANT option.


ORA-01778

ORA-01778maximum subquery nesting level exceeded

Cause:An attempt was made to use more than 255 levels of nested subqueries.

Action:Merge some of the subqueries into their containing queries until there are less than 255 levels of nesting.


ORA-01779

ORA-01779cannot modify a column which maps to a non-key-preserved table

Cause:An attempt was made to insert or update columns of a join view which map to a non-key-preserved table.

Action:Modify the underlying base tables directly.

For more information about join views, see the index entries under "views" in Oracle8 Server SQL Reference, the index entry under "views" in the Oracle8 Server Application Developer's Guide, and the index entry on "updatable join views" in Oracle8 Server Concepts.


ORA-01780

ORA-01780string literal required

Cause:In a COMMENT statement, the comment following the keyword IS must be a quoted string literal.

Action:Make sure the comment is a string literal.


ORA-01781

ORA-01781UNRECOVERABLE cannot be specified without AS SELECT

Cause:UNRECOVERABLE was specified in a CREATE TABLE statement without also specifying a populating subquery with an AS clause.

Action:Do not specify UNRECOVERABLE.


ORA-01782

ORA-01782UNRECOVERABLE cannot be specified for a cluster or clustered table

Cause:A CREATE CLUSTER or clustered CREATE TABLE statementspecified UNRECOVERABLE.

Action:Do not specify UNRECOVERABLE.


ORA-01783

ORA-01783only one RECOVERABLE or UNRECOVERABLE clause may be specified

Cause:RECOVERABLE was specified more than once, UNRECOVERABLE was specified more than once, or both RECOVERABLE and UNRECOVERABLE were specified in a CREATE TABLE or CREATE INDEX statement.

Action:Remove all but one of the RECOVERABLE or UNRECOVERABLE clauses and reissue the statement.


ORA-01784

ORA-01784RECOVERABLE cannot be specified with database media recovery disabled

Cause:A CREATE TABLE or CREATE INDEX statement specified RECOVERABLE when the database was running in NOARCHIVELOG mode. Since logs are not being archived, they will be overwritten and the object being created cannot be recovered from a backup taken before the object was created.

Action:Do not specify RECOVERABLE, or restart the database with media recovery enabled.


ORA-01785

ORA-01785ORDER BY item must be the number of a SELECT-list expression

Cause:Either an ORDER BY item for a set expression is not a column number, or the ORDER BY item is not the number of a SELECT list column.

Action:The ORDER BY item must be a number between 1 and the number of columns in the SELECT list. Check the column number, then re-execute the statement.


ORA-01786

ORA-01786FOR UPDATE of this query expression is not allowed

Cause:An attempt was made to use a FOR UPDATE clause on the result of a set expression involving GROUP BY, DISTINCT, UNION, INTERSECT, or MINUS.

Action:Check the syntax and remove the FOR UPDATE clause, then re-execute the statement.


ORA-01788

ORA-01788CONNECT BY clause required in this query block

Cause:A START WITH clause was specified without a CONNECT BY clause.

Action:Check the syntax and specify a CONNECT BY clause, and then re-execute the statement.


ORA-01788

ORA-01788CONNECT BY clause required in this query block

Cause:A START WITH clause was specified without a CONNECT BY clause.

Action:Check the syntax, specify a CONNECT BY clause, and retry the statement.


ORA-01789

ORA-01789query block has incorrect number of result columns

Cause:All of the queries participating in a set expression do not contain the same number of SELECT list columns.

Action:Make sure all the queries in the set expression have the same number of SELECT list columns.


ORA-01790

ORA-01790expression must have same datatype as corresponding expression

Cause:A SELECT list item corresponds to a SELECT list item with a different datatype in another query of the same set expression.

Action:Make sure all corresponding SELECT list items have the same datatypes. The functions TO_NUMBER, TO_CHAR, and TO_DATE can be used to do explicit data conversions.


ORA-01791

ORA-01791not a SELECTed expression

Cause:There is an incorrect ORDER BY item. The query is a SELECT DISTINCT query with an ORDER BY clause. In this context, all ORDER BY items must be either constants, SELECT list expressions, or expressions whose operands are constants or SELECT list expressions.

Action:Remove the inappropriate ORDER BY item from the SELECT list, then re-execute the statement.


ORA-01792

ORA-01792maximum number of columns in a table or view is 254

Cause:While creating a table or view, more than 254 columns were specified.

Action:Remove some columns from the table or view definition. If all the information is required, split the columns into two tables or views and join the columns when querying.


ORA-01793

ORA-01793maximum number of index columns is 16

Cause:While creating an index, more than 16 columns were specified.

Action:Remove some columns from the index definition. If all the columns indexed are required, split them into two indexes.


ORA-01794

ORA-01794maximum number of cluster columns is 16

Cause:More than sixteen columns were specified in the cluster key.

Action:Remove some of the columns from the cluster key definition. Consider concatenating multiple character strings into a single column.


ORA-01795

ORA-01795maximum number of expressions in a list is 254

Cause:More than 254 columns or expressions were specified in a list.

Action:Remove some of the expressions from the list.


ORA-01796

ORA-01796this operator cannot be used with lists

Cause:A relational operator is not allowed in this context. When comparing lists, only use an operator that tests for equivalence (such as =, !=, or IN).

Action:Rephrase the query so that it only compares lists for equivalence. For example, the following clause is invalid:

WHERE (A,B) > ((C,D), (E,F))

It may be necessary to compare individual columns separately. For example, to see if A and B are respectively greater than C and D, use WHERE A>B AND C>D instead of WHERE (A,B)>(C,D).


ORA-01797

ORA-01797this operator must be followed by ANY or ALL

Cause:The keyword ANY or ALL was missing.

Action:Check the statement syntax and adding ANY or ALL where appropriate.


ORA-01798

ORA-01798missing EXCEPTION keyword

Cause:The EXCEPTION keyword is missing from the ENABLE clause.

Action:Refer to the ORACLE7 Server SQL Language Reference Manual for the appropriate syntax of the ENABLE clause.


ORA-01799

ORA-01799a column may not be outer-joined to a subquery

Cause:An expression is not permitted to be joined to a subquery.

Action:Either remove the join or make a view out of the subquery.

________________________________________


ORA-01800

ORA-01800a literal in the date format was too large to process

Cause:A literal specified in a date format was too large. If a literal is entered as a date, it must be less than 220 characters long.

Action:Use only literals less than 220 characters long in the date format.


ORA-01801

ORA-01801date format is too long for internal buffer

Cause:The date format string was too long to process. This should only occur if several long literals are specified as part of a date.

Action:Remove long literals from the date format string.


ORA-01802

ORA-01802Julian date is out of range

Cause:An invalid Julian date was entered. Valid Julian dates run from 1 to 3,442,447.

Action:Enter a valid Julian date between 1 and 3,442,447.


ORA-01803

ORA-01803failure in getting date/time

Cause:This is an internal error message that is not likely to occur. It is usually caused by a failure in the system clock.

Action:Investigate the system clock and the process that requested the date or time. If necessary, contact Worldwide Customer Support.


ORA-01810

ORA-01810format code appears twice

Cause:A format code was listed twice in a date specification. Each format code may only be specified once in the function TO_DATE.

Action:Remove the duplicate format code from the date specification, then retry the operation.


ORA-01811

ORA-01811Julian date precludes use of day of year

Cause:Both a Julian date and a day of the year were specified in the TO_DATE function. If a Julian date is specified, the day of the year (DDD) may not be specified, as it is contained in the Julian date.

Action:Remove the day of the year or the Julian date from the specification, then retry the operation.


ORA-01812

ORA-01812year may only be specified once

Cause:More than one year format code was listed in a date specification. Only one of the following year format codes may be specified in a date: YYYY, YYY, YY, Y.

Action:Remove all but one year format from the date specification.


ORA-01813

ORA-01813hour may only be specified once

Cause:More than one hour format code was listed in a date specification. Only one of the following hour format codes may be specified in a date: HH, HH12, HH24.

Action:Remove all but one hour format from the date specification.


ORA-01814

ORA-01814AM/PM conflicts with use of A.M./P.M.

Cause:Both types of meridian indicator were listed in a date specification. If one of the meridian indicator format masks (such as AM or A.M.) is specified in the date, the other may not be specified.

Action:Remove one type of meridian indicator from the date.


ORA-01815

ORA-01815BC/AD conflicts with use of B.C./A.D.

Cause:Both types of BC/AD indicator were listed in a date specification. If one of the BC/AD indicator format masks (such as BC or B.C.) is specified in the date the other may not be specified.

Action:Remove one type of BC/AD indicator from the date specification.


ORA-01816

ORA-01816month may only be specified once

Cause:More than one month format code was listed in a date specification. Only one of the following month format codes may be specified in a date: MM, MON, MONTH.

Action:Remove all but one month format from the date specification.


ORA-01817

ORA-01817day of week may only be specified once

Cause:More than one day of the week format code was listed in a date specification. Only one of the following day of the week format codes may be specified in a date: D, DY, DAY.

Action:Remove all but one day of the week format from the date specification.


ORA-01818

ORA-01818'HH24' precludes use of meridian indicator

Cause:A date specification contained both a 24-hour time format code and a meridian indicator code. If hours are specified using the 24-hour time format (HH24), a meridian indicator (AM/PM) may not be specified.

Action:Remove the meridian indicator format code (AM/PM or A.M./P.M.) or the 24-hour time format code (HH24) from the date specification.


ORA-01819

ORA-01819signed year precludes use of BC/AD

Cause:A date specification contained both a signed year and a B.C./A.D. indicator. If the year is specified with a sign (such as SYYYY), then B.C. or A.D. is implicit in the date and must not be entered.

Action:Remove the B.C./A.D. indicator from the date specification.


ORA-01820

ORA-01820format code cannot appear in date input format

Cause:A date specification contained an invalid format code. Only the following may be specified when entering a date: year, month, day, hours, minutes, seconds, Julian day, A.M./P.M. and B.C./A.D.

Action:Remove the invalid format code from the date specification.


ORA-01821

ORA-01821date format not recognized

Cause:A date specification contained an invalid format code.

Action:Ensure only valid date format codes are specified.


ORA-01822

ORA-01822era format code is not valid with this calendar

Cause:An era format code, E or EE, was specified with a calendar which does not use era information.

Action:Retry the operation using a date format mask which does not contain era format codes.


ORA-01830

ORA-01830date format picture ends before converting entire input string

Cause:A valid date format picture included extra data. The first part of the format picture was converted into a valid date, but the remaining data was not required.

Action:Check the specifications for date format pictures and correct the statement.


ORA-01831

ORA-01831year conflicts with Julian date

Cause:The wrong year was specified with a Julian day. If a year is specified with a Julian date, it must be the year in which the Julian date occurs.

Action:Remove the year value from the date specification, or enter correct year for the Julian date.


ORA-01832

ORA-01832day of year conflicts with Julian date

Cause:A Julian date was specified with the day of the year but the day did not correspond to the Julian date. If the day of the year is specified with a Julian date, it must be the same day as the Julian date.

Action:Remove the day of the year value from the date specification, or enter the correct day for the Julian date.


ORA-01833

ORA-01833month conflicts with Julian date

Cause:The wrong month was specified with a Julian date. If a month is specified with a Julian date, it must be the month in which the Julian date occurs.

Action:Remove the month value from the date specification, or enter correct month for the Julian date.


ORA-01834

ORA-01834day of month conflicts with Julian date

Cause:A Julian date was specified with the day of the month but the month day did not correspond to the Julian date. If the day of the month is specified with a Julian date, it must be the same day of the month as the Julian date.

Action:Remove the day of the month value from the date specification, or enter the correct day of the month for the Julian date.


ORA-01835

ORA-01835day of week conflicts with Julian date

Cause:A Julian date was specified with the day of the week but the weekday did not correspond to the Julian date. If the day of the week is specified with a Julian date, it must be the same day of the week as the Julian date.

Action:Remove the day of the week value from the date specification, or enter the correct day of the week for the Julian date.


ORA-01836

ORA-01836hour conflicts with seconds in day

Cause:The wrong hour was specified with seconds in the day. If an hour is specified with seconds past midnight (SSSSS), it must be the hour in which the seconds value falls.

Action:Remove the hour value from the date specification, or specify the correct hour for the seconds past midnight.


ORA-01837

ORA-01837minutes of hour conflicts with seconds in day

Cause:A date specification contained both minutes of the hour and seconds in the day but the values did not correspond. If both minutes in the hour (MI) and seconds past midnight (SSSSS) are specified, the minutes value must be the minute in which the seconds value will occur.

Action:Remove the minutes value from the date specification, or enter the correct minute value for the specified seconds value.


ORA-01838

ORA-01838seconds of minute conflicts with seconds in day

Cause:A date specification contained both seconds of the minute and seconds in the day but the values did not correspond. If both types of seconds are specified, the seconds of the minute value (SS) must be the second in which the seconds past midnight value (SSSSS) will fall.

Action:Remove the seconds of the minute value from the date specification, or enter a value that corresponds to the given seconds in the day.


ORA-01839

ORA-01839date not valid for month specified

Cause:The day of the month specified in the date is invalid for the given month. The day of the month (DD) must be between 1 and the number of days in the month.

Action:Enter a valid day of the month for the specified month.


ORA-01840

ORA-01840input value not long enough for date format

Cause:The data to be converted to date format was incomplete; the date format picture was longer than the input data.

Action:Either add more input or shorten the date picture format, then retry the operation.


ORA-01841

ORA-01841(full) year must be between -4713 and +4713

Cause:A date specified a year that is not in the valid date range. A valid date is any date between January 1, 4712 B.C. and December 31, 4712 A.D.

Action:Enter a valid date value between 4712 B.C. and 4712 A.D.


ORA-01842

ORA-01842quarter must be between 1 and 4

Cause:An invalid value was specified for the quarter of the year in a date. The quarter (Q) must be between 1 and 4.

Action:Enter a value for quarter between 1 and 4.


ORA-01843

ORA-01843not a valid month

Cause:A date specified an invalid month. Valid months are: January-December (for format code MONTH), Jan-Dec (for format code MON).

Action:Enter a valid month value in the correct format.


ORA-01844

ORA-01844week of year must be between 1 and 52

Cause:An invalid value was specified for week of the year in a date. Week of the year (WW) must be between 1 and 52.

Action:Enter a week of the year value between 1 and 52.


ORA-01845

ORA-01845week of month must be between 1 and 5

Cause:An invalid value was specified for week of the month in a date. Week of the month (W) must be between 1 and 5.

Action:Enter a week of the month value between 1 and 5.


ORA-01846

ORA-01846not a valid day of the week

Cause:A date specified an invalid day of the week. Valid days are: Monday-Sunday (for format code DAY); Mon-Sun (for format code DY); and 1-7 (for format code D).

Action:Enter a valid day of the week value in the correct format.


ORA-01847

ORA-01847day of month must be between 1 and last day of month

Cause:The day of the month listed in a date is invalid for the specified month. The day of the month (DD) must be between 1 and the number of days in that month.

Action:Enter a valid day value for the specified month.


ORA-01849

ORA-01849hour must be between 1 and 12

Cause:An invalid hour was specified for a date using the 12-hour time format. If a 12-hour format code (HH or HH12) is used, the specified hour must be between 1 and 12.

Action:Enter an hour value between 1 and 12.


ORA-01850

ORA-01850hour must be between 0 and 23

Cause:An invalid hour was specified for a date using the 24-hour time format. If the 24-hour format code (HH24) is listed, the specified hour must be between 0 and 23.

Action:Enter an hour value between 0 and 23.


ORA-01851

ORA-01851minutes must be between 0 and 59

Cause:An invalid minute value was specified in a date. Minutes must be between 0 and 59.

Action:Enter a minute value between 0 and 59.


ORA-01852

ORA-01852seconds must be between 0 and 59

Cause:An invalid seconds value was specified in a date. Seconds must be between 0 and 59, if the seconds format code (SS) is used.

Action:Enter a seconds value between 0 and 59.


ORA-01853

ORA-01853seconds in day must be between 0 and 86399

Cause:An invalid value for seconds in the day was specified in a date. Seconds must be between 0 and 86399 if the seconds past midnight format code (SSSSS) is used.

Action:Specify a seconds value between 0 and 86399.


ORA-01854

ORA-01854Julian date must be between 1 and 3442447

Cause:An invalid Julian date was entered.

Action:Correct and retry.


ORA-01855

ORA-01855AM/A.M. or PM/P.M. required

Cause:A date specification contained a meridian indicator format code but a valid meridian indicator was not specified. If a meridian indicator code (A.M./P.M. or AM/PM) is included in a date format, the date must include a valid meridian indicator.

Action:Specify the meridian indicator in the correct format (A.M./AM or P.M./PM).


ORA-01856

ORA-01856BC/B.C. or AD/A.D. required

Cause:A date specification contained a BC/AD format code but a valid BC/AD indicator was not specified. If one of the BC/AD format codes (BC/AD or B.C./A.D.) is specified in a date format, the date must include BC/B.C. or AD/A.D.

Action:Specify the BC/AD indicator in the date using the correct format.


ORA-01857

ORA-01857not a valid time zone

Cause:An incorrect time zone code was specified for the NEW_TIME function.

Action:Correct the invalid time zone code, then retry the operation.


ORA-01858

ORA-01858a non-numeric character found where a digit was expected

Cause:The input data to be converted using a date format model was incorrect; the format model expected a number but found a non-numeric character.

Action:Check the input data and the date format model to make sure the elements match in number and type, then retry the operation.


ORA-01859

ORA-01859a non-alphabetic character was found where a letter was expected

Cause:The input data to be converted using a date format model was incorrect; the format model expected a letter but found a non-alphabetic character.

Action:Check the input data and the date format model to make sure the elements match in number and type, then retry the operation.


ORA-01860

ORA-01860week of year must be between 1 and 53

Cause:A week number outside the range 1 to 53 was specified.

Action:Use only a value within the valid range for the week number.


ORA-01861

ORA-01861literal does not match format string

Cause:Literals in the input string must be the same length as the literals in the format string (with the exception of the leading white space characters). If the "FX" modifier is specified, the literal must match exactly (including the leading white space).

Action:Correct the format string to match the string literal.


ORA-01862

ORA-01862wrong number of digits for this format item

Cause:The number of digits used for this format item is not equal to the number required for the format. This error usually occurs when the "FX" modifier (format exact) has been specified.

Action:Resubmit the command using the required amount of numbers for the format mask.


ORA-01863

ORA-01863The year is not supported for the current calendar

Cause:The year is not supported for the current calendar.

Action:Please check the documentation to find out what years are supported for the current calendar.


ORA-01864

ORA-01864the date is out of range for the current calendar

Cause:Your calendar does not extend to the specified date.

Action:Specify a date which is legal for this calendar.


ORA-01898

ORA-01898too many precision specifiers

Cause:While trying to truncate or round dates, extra data was found in the date format picture.

Action:Check the syntax of the date format picture and retry.


ORA-01899

ORA-01899bad precision specifier

Cause:An invalid precision code was specified in a date.

Action:Enter a valid precision code in the date format. Valid precision types are: century, year, month, day, Julian date, hours, minutes, and seconds.

________________________________________


ORA-01900

ORA-01900LOGFILE keyword expected

Cause:The keyword LOGFILE is required in this context.

Action:Check the syntax, insert the keyword LOGFILE where required, then re-execute the statement.


ORA-01901

ORA-01901ROLLBACK keyword expected

Cause:The keyword ROLLBACK is required in this context.

Action:Check the syntax, insert the keyword ROLLBACK where required, then re-execute the statement.


ORA-01902

ORA-01902SEGMENT keyword expected

Cause:The keyword SEGMENT is required in this context.

Action:Check the syntax, insert the keyword SEGMENT where required, then re-execute the statement.


ORA-01903

ORA-01903EVENTS keyword expected

Cause:The keyword EVENTS is required in this context.

Action:Check the syntax, insert the keyword EVENTS where required, then re-execute the statement.


ORA-01904

ORA-01904DATAFILE keyword expected

Cause:The keyword DATAFILE is required in this context.

Action:Check the syntax, insert the keyword DATAFILE where required, then re-execute the statement.


ORA-01905

ORA-01905STORAGE keyword expected

Cause:The keyword STORAGE is required in this context.

Action:Check the syntax, insert the keyword STORAGE where required, then re-execute the statement.


ORA-01906

ORA-01906BACKUP keyword expected

Cause:The keyword BACKUP is required in this context.

Action:Check the syntax, insert the keyword BACKUP where required, then re-execute the statement.


ORA-01907

ORA-01907TABLESPACE keyword expected

Cause:The keyword TABLESPACE is required in this context.

Action:Check the syntax, insert the keyword TABLESPACE where required; then re-execute the statement.


ORA-01908

ORA-01908EXISTS keyword expected

Cause:The keyword EXISTS is required in this context.

Action:Check the syntax, insert the keyword EXISTS where required, then re-execute the statement.


ORA-01909

ORA-01909REUSE keyword expected

Cause:The keyword REUSE is required in this context.

Action:Check the syntax, insert the keyword REUSE where required, then re-execute the statement.


ORA-01910

ORA-01910TABLES keyword expected

Cause:The keyword TABLES is required in this context.

Action:Check the syntax, insert the keyword TABLES where required, then re-execute the statement.


ORA-01911

ORA-01911CONTENTS keyword expected

Cause:The keyword CONTENTS is required in this context.

Action:Check the syntax, insert the keyword CONTENTS where required, then re-execute the statement.


ORA-01912

ORA-01912ROW keyword expected

Cause:The keyword ROW is required in this context.

Action:Check the syntax, insert the keyword ROW where required, then re-execute the statement.


ORA-01913

ORA-01913EXCLUSIVE keyword expected

Cause:The keyword EXCLUSIVE is required in this context.

Action:Check the syntax, insert the keyword EXCLUSIVE where required, then re-execute the statement.


ORA-01914

ORA-01914invalid auditing option for sequence numbers

Cause:AUDIT or NOAUDIT on a sequence number specifies an auditing option that is legal for tables but not for sequence numbers.

Action:The following options may not be used for sequence numbers and should be removed from the statement: COMMENT, DELETE, INDEX, INSERT, LOCK, RENAME, UPDATE, REFERENCES, and EXECUTE.


ORA-01915

ORA-01915invalid auditing option for views

Cause:AUDIT or NOAUDIT on a view specifies an auditing option that is legal for tables but not for views.

Action:The following options may not be used for views and should be removed from the statement: ALTER, INDEX, REFERENCES, and EXECUTE.


ORA-01916

ORA-01916ONLINE keyword or OFFLINE keyword expected

Cause:The keyword ONLINE or OFFLINE is required in this context.

Action:Check the syntax, insert the keyword ONLINE or OFFLINE where required; then re-execute the statement.


ORA-01917

ORA-01917user or role 'name' does not exist

Cause:An invalid user or role name was specified.

Action:Ensure a valid user or role name is used.


ORA-01918

ORA-01918user name does not exist

Cause:The user name specified cannot be found in the system.

Action:Ensure a valid user or role name is used.


ORA-01919

ORA-01919role 'name' does not exist

Cause:An invalid role name was specified.

Action:Ensure a valid role name is specified.


ORA-01920

ORA-01920user name 'name' conflicts with another user or role name

Cause:A user or role by that name already exists.

Action:Choose a different user name.


ORA-01921

ORA-01921role name 'name' conflicts with another user or role name

Cause:A user or role by that name already exists.

Action:Choose a different role name.


ORA-01922

ORA-01922CASCADE must be specified to drop 'name'

Cause:The user owns objects that need to be dropped along with the user.

Action:Use the CASCADE command.


ORA-01923

ORA-01923CASCADE aborted, objects locked by another user

Cause:A CASCADE operation was aborted because the user specified owns objects that are locked and thus cannot be dropped.

Action:Use the lock monitor to determine who locked the objects. The objects must be unlocked before the specified user can be dropped.


ORA-01924

ORA-01924role 'name' not granted or does not exist

Cause:The grantor attempted to use a SET ROLE command to enable a role not granted to the grantor, or enable a subrole; or the grantor did not have the SET ROLE system privilege.

Action:To use the SET ROLE command, ensure the grantor has the SET ROLE system privilege and is granted the role desired to be passed on.


ORA-01925

ORA-01925maximum of num enabled roles exceeded

Cause:The specified number of enabled roles exceeds the value specified in the initialization parameter MAX_ENABLED_ROLES.

Action:Increase MAX_ENABLED_ROLES and restart the instance.


ORA-01926

ORA-01926cannot grant WITH GRANT OPTION to a role

Cause:Privileges with GRANT OPTION cannot be granted to a role.

Action:Perform the grant without the GRANT OPTION.


ORA-01927

ORA-01927original grantor must REVOKE privileges

Cause:Only the original grantor of privileges can REVOKE those privileges.

Action:Ask the database administrator for the grantor of the privileges and ask that person to revoke the privileges.


ORA-01928

ORA-01928GRANT option not granted for all privileges

Cause:The grantor does not have the GRANT OPTION for some or all of the privileges specified. These privileges are not granted.

Action:Ensure grantor has the GRANT OPTION for privileges to be granted to a user or role.


ORA-01929

ORA-01929no privileges to GRANT

Cause:The grantor attempted to grant privileges using the object privilege ALL, but was not granted privileges to do so via the GRANT OPTION.

Action:Ensure the grantor has the necessary privileges via the GRANT OPTION and try again.


ORA-01930

ORA-01930no privileges to REVOKE

Cause:Grantor attempted to revoke privileges using the object privilege ALL, but does not have the necessary privileges.

Action:Ensure grantor has the necessary privileges via the GRANT OPTION and try again.


ORA-01931

ORA-01931cannot grant UNLIMITED TABLESPACE , REFERENCES, or INDEX to a role

Cause:The UNLIMITED TABLESPACE, REFERENCES, or INDEX privileges cannot be granted to a role.

Action:Grant these privileges directly to the user.


ORA-01932

ORA-01932WITH ADMIN option not granted for role 'name'

Cause: Grantor attempted an operation on a role, but does not have the necessary privileges via the ADMIN OPTION.

Action:Obtain the necessary privileges via the ADMIN OPTION and try again.


ORA-01933

ORA-01933cannot create a stored object using privileges from a role

Cause:An attempt was made to create a stored object using privileges from a role. Stored objects cannot use privileges from roles.

Action:Grant the required privileges to the user directly.


ORA-01934

ORA-01934circular role grant detected

Cause:A role (the primary role) cannot be granted to itself or another role that is granted via one or more roles to the primary role. This would cause a circular definition. See the ORACLE7 Server SQL Language Reference Manual for more detail.

Action:Analyze the role and user structure to be used and ensure no attempt is made to grant roles circularly.


ORA-01935

ORA-01935missing user or role name

Cause:The entered statement required a user or role name and it was not specified.

Action:Specify a user or role name in the statement.


ORA-01936

ORA-01936cannot specify owner when creating users or roles

Cause:An attempt was made to specify an owner while creating a user or a role. Users and roles do not have owners.

Action:Do not specify an owner when creating a user or a role.


ORA-01937

ORA-01937invalid role name

Cause:An invalid role name was specified.

Action:Choose a different role name.


ORA-01938

ORA-01938IDENTIFIED BY must be specified for CREATE USER

Cause:An attempt was made to create a user without using the IDENTIFIED EXTERNALLY clause or the IDENTIFIED BY password clause.

Action:In the CREATE USER statement, either assign the user a password using the IDENTIFIED BY password clause or use the IDENTIFIED EXTERNALLY clause, which allows the operating system to perform user authentication.


ORA-01939

ORA-01939only the ADMIN OPTION can be specified

Cause:An attempt was made to grant a system privilege or a role to a user by using a GRANT statement with the GRANT OPTION (GRANT Form I). System privileges and roles must be granted using the WITH ADMIN OPTION (GRANT Form II).

Action:Use the WITH ADMIN OPTION rather than the WITH GRANT OPTION in the GRANT statement.


ORA-01940

ORA-01940cannot DROP a user that is currently logged in

Cause:An attempt was made to drop a user that was currently logged in.

Action:Make sure the user is logged off; then re-execute the command.


ORA-01941

ORA-01941SEQUENCE keyword expected

Cause:The keyword SEQUENCE is required in this context.

Action:Check syntax, insert keyword SEQUENCE as required, and try again.


ORA-01942

ORA-01942IDENTIFIED BY and EXTERNALLY cannot both be specified

Cause:A user was specified with an ORACLE password and as identified externally.

Action:Specify only one of these options. For details and syntax, see the ORACLE7 Server SQL Language Reference Manual.


ORA-01943

ORA-01943IDENTIFIED BY already specified

Cause:The IDENTIFIED BY 'password' clause was specified more than once in a statement.

Action:Use the clause IDENTIFIED BY only once in the statement. If desired, change the user's password later with an ALTER USER command.


ORA-01944

ORA-01944IDENTIFIED EXTERNALLY already specified

Cause:The keyword IDENTIFIED EXTERNALLY was specified more than once in a statement.

Action:Use the keyword IDENTIFIED EXTERNALLY only once in the statement.


ORA-01945

ORA-01945DEFAULT ROLE[S] already specified

Cause:The keyword DEFAULT ROLE was used more than once in a CREATE USER or ALTER USER statement.

Action:Use the keyword DEFAULT ROLE only once in the statement. If desired, change the user's role later with an ALTER USER statement.


ORA-01946

ORA-01946DEFAULT TABLESPACE already specified

Cause:The keyword DEFAULT TABLESPACE was specified more than once in a CREATE USER or ALTER USER statement.

Action:Use the keyword DEFAULT TABLESPACE only once in the statement. If desire, change the user's tablespace later with an ALTER USER statement.


ORA-01947

ORA-01947TEMPORARY TABLESPACE already specified

Cause:The keyword TEMPORARY TABLESPACE was specified more than once in a CREATE USER or ALTER USER statement.

Action:Use the keyword TEMPORARY TABLESPACE only once in the statement. If desire, change the user's tablespace later with an ALTER USER statement.


ORA-01948

ORA-01948invalid DEFAULT ROLE specification

Cause:An invalid role name was specified.

Action:Make sure that the role name is correct.


ORA-01949

ORA-01949ROLE keyword expected

Cause:The context of the command or argument requires the use of the ROLE keyword; for example, DROP [ROLE], DEFAULT [ROLE], etc.

Action:Check syntax and try again. For syntax rules, see the ORACLE7 Server SQL Language Reference Manual.


ORA-01950

ORA-01950no privileges on tablespace 'name'

Cause:The attempt to give the user a tablespace quota failed because the user does not have the necessary system privileges.

Action:Either grant the user the system privileges needed to create objects in the specified tablespace, or grant the user a specific space resource in the tablespace.


ORA-01951

ORA-01951role not granted for ROLE: name, user: name

Cause:An attempt was made to revoke a role not granted to the user.

Action:Ensure the user has the role.


ORA-01952

ORA-01952system privileges not granted to 'name'

Cause:An attempt was made to revoke a system privilege not granted to the user.

Action:Ensure the user has the system privilege.


ORA-01953

ORA-01953command no longer valid, see ALTER USER

Cause:The syntax for assigning quotas on tablespaces has changed. The ALTER USER command is now used to grant quotas on tablespaces.

Action:Use the ALTER USER command.


ORA-01954

ORA-01954DEFAULT ROLE clause not valid for CREATE USER

Cause:An attempt was made to grant a default role to a user in a CREATE USER statement. A DEFAULT ROLE clause cannot be used in a CREATE USER statement.

Action:Use a GRANT ROLE statement to grant an initial role to the user; then use the ALTER USER command to assign any desired default roles.


ORA-01955

ORA-01955user not granted DEFAULT ROLE 'name'

Cause:An attempt was made to set the default role of a user to a role the user was not granted.

Note: Subroles cannot be specified in a DEFAULT ROLE clause.

Action:Ensure the user is granted the role before specifying it as the default.


ORA-01956

ORA-01956invalid command when OS_ROLES are being used

Cause:An attempt to grant a role to a user failed because ORACLE database roles are disabled and operating system roles are enabled. This occurred because the OS_ROLES parameter in the initialization parameter file is set to TRUE.

Action:Ask the database administrator or security administrator how to set roles via the operating system. Refer to the operating system documentation for more information.


ORA-01957

ORA-01957keyword MIN or MAX expected, not found

Cause:The keyword MIN or MAX was expected as an argument.

Action:Enter the keyword MIN or MAX and retry the operation.


ORA-01958

ORA-01958must supply an integer for the LAYER option

Cause:An item other than an integer was entered for the LAYER option.

Action:Enter an integer for the LAYER option and retry the operation.


ORA-01959

ORA-01959must supply an integer for the OPCODE option

Cause:An item other than an integer was entered for the OPCODE option. The value in ALTER SYSTEM DUMP ... OPCODE value must be an integer.

Action:Enter an integer for the OPCODE option and retry the operation.

For more information on the OPCODE option, see the Oracle8 Server SQL Reference.


ORA-01960

ORA-01960invalid DUMP LOGFILE option

Cause:An invalid option was entered for the ALTER SYSTEM DUMP LOGFILE option command.

Action:For a list of valid options for DUMP LOGFILE, see the Oracle8 Server SQL Reference.


ORA-01961

ORA-01961invalid DUMP option

Cause:An invalid option was entered for the ALTER SYSTEM DUMP command.

Action:Enter a valid option for ALTER SYSTEM DUMP. Examples of valid options are LOGFILE and UNDO. For more information on the DUMP option, see the Oracle8 Server SQL Reference.


ORA-01962

ORA-01957must specify a file number or log sequence number

Cause:An invalid file number or log sequence number was specified.

Action:Enter a valid file number or log sequence number and retry the operation. For more information on valid file and log sequence numbers, see the Oracle8 Server SQL Reference.


ORA-01963

ORA-01963must specify a block number

Cause:An invalid block number was specified.

Action:Enter a valid block number and retry the operation. For more information on valid block numbers, see the Oracle8 Server SQL Reference.


ORA-01964

ORA-01964must specify a time for the TIME option

Cause:A value was entered for the TIME option that could not be interpreted as a date.

Action:Enter a valid date. For more information on the TIME option, see the Oracle8 Server SQL Reference.


ORA-01965

ORA-01965must specify a period

Cause:A period is missing between the file number and the block number.

Action:Enter a period between the file number and the block number, then retry the operation. For more information on file numbers and block numbers, see the Oracle8 Server SQL Reference.


ORA-01966

ORA-01966must have OS DBA privilege to CREATE CONTROLFILE

Cause:The user issuing the CREATE CONTROLFILE statement does not have the appropriate operating system privilege.

Action:This command can only be issued by a user with the appropriate operating system privilege.


ORA-01967

ORA-01967invalid option for CREATE CONTROLFILE

Cause:An invalid CREATE CONTROLFILE option is present.

Action:Specify only valid CREATE CONTROLFILE options.


ORA-01968

ORA-01968only specify RESETLOGS or NORESETLOGS once

Cause:The keyword RESETLOGS or NORESETLOGS has appeared more than once in the CREATE CONTROLFILE statement.

Action:Be sure to specify RESETLOGS or NORESETLOGS exactly once.


ORA-01969

ORA-01969must specify RESETLOGS or NORESETLOGS

Cause:The RESETLOGS or NORESETLOGS option is missing from the CREATE CONTROL FILE statement.

Action:Be sure to specify RESETLOGS or NORESETLOGS on the command line.


ORA-01970

ORA-01970must specify a database name for CREATE CONTROLFILE

Cause:The CREATE CONTROLFILE statement issued is missing a database name.

Action:Issue the CREATE CONTROLFILE statement again with the appropriate database name for the DATABASE keyword.


ORA-01971

ORA-01971Illegal ALTER TRACING option

Cause:An invalid ALTER TRACING option is present.

Action:Specify only valid ALTER TRACING options. Examples of valid options are ENABLE and DISABLE. For more information, see the Oracle8 Server SQL Reference.


ORA-01972

ORA-01972must specify a string for ALTER TRACING ENABLE or DISABLE

Cause:Something other than a valid identifier was specified for ALTER TRACING ENABLE or DISABLE.

Action:Specify a valid identifier for ALTER TRACING ENABLE or DISABLE and retry the operation. For more information on valid identifiers, see the Oracle8 Server SQL Reference.


ORA-01973

ORA-01973Missing change number

Cause:The keyword CHANGE was specified on the command line, but the change number was not specified.

Action:Check the syntax of the command and resubmit it.


ORA-01974

ORA-01974Illegal archive option

Cause:An invalid option to the ALTER SYSTEM ARCHIVE command was specified.

Action:Check the syntax of the command and resubmit it.


ORA-01975

ORA-01975Illegal character in change number num

Cause:An invalid change number was supplied.

Action:Resubmit the command with a valid change number.


ORA-01976

ORA-01976Missing change number

Cause:A change number was required, but not supplied.

Action:Check the syntax of the command, supply a change number where needed; then resubmit the command.


ORA-01977

ORA-01977Missing thread number

Cause:The keyword THREAD was specified, but a thread number was not specified.

Action:Check the syntax of the command and resubmit it.


ORA-01978

ORA-01978Missing sequence number

Cause:The keyword SEQUENCE was specified, but a sequence number was not specified.

Action:Check the syntax of the command and resubmit it.


ORA-01979

ORA-01979missing or invalid password for role 'name'

Cause:An attempt was made to enable a role without giving the proper password.

Action:Use the IDENTIFIED BY clause in the SET ROLE command to specify the correct password.


ORA-01980

ORA-01980error during OS ROLE initialization

Cause:An operating system error occurred while loading a user's operating system roles.

Action:Check the operating system error and correct it.


ORA-01982

ORA-01982invalid auditing option for tables

Cause:The AUDIT or NOAUDIT command specified either REFERENCES or EXECUTE as an option. Those options are not legal for tables.

Action:Do not specify those auditing options on tables.


ORA-01983

ORA-01983invalid auditing option for DEFAULT

Cause:An illegal option was specified with DEFAULT.

Action:Do not specify the REFERENCES option with DEFAULT.


ORA-01984

ORA-01984invalid auditing option for procedures/packages/functions

Cause:An illegal option was specified with DEFAULT for a procedure, package, or function.

Action:The only legal auditing option with default for procedures, packages, and functions is EXECUTE. Do not specify any option other than EXECUTE.


ORA-01985

ORA-01985cannot create user as LICENSE_MAX_USERS parameter exceeded

Cause: The maximum number of database users allowed by the database license has been created.

Action:Either drop existing users or contact Oracle Corporation to upgrade your site license.


ORA-01986

ORA-01986invalid option for OPTIMIZER_GOAL

Cause:An invalid OPTIMIZER_GOAL option is present.

Action:Check the syntax for OPTIMIZER_GOAL, specify a valid option and re-execute the statement.


ORA-01987

ORA-01987client O/S user name is too long

Cause:A client's O/S user name is too long for the O/S logon to succeed.

Action:Use a shorter O/S user name.


ORA-01988

ORA-01988remote O/S logon is not allowed

Cause:Remote O/S login attempted when not allowed.

Action:Use a local client, or use the REMOTE_OS_AUTHENT initialization parameter to turn on remote O/S logon.


ORA-01989

ORA-01989role name not authorized by operating system

Cause:The specified operating system role does not exist, is not granted to you, or you did not provide the correct password.

Action:Retry the SET ROLE using a valid operating system role and password. See your DBA if you are not granted sufficient privileges.


ORA-01990

ORA-01990error opening password file name

Cause:An attempt to open the specified password file failed because of one of the following errors:

·_An operating system error occurred.

·_ORAPWD is already running, so the password file is locked.

·_The environment variables ORA_sid_PWFILE and ORA_PWFILE are not set.

Action:Check for the above causes and correct as necessary.


ORA-01991

ORA-01991invalid password file name

Cause:The specified password file name is invalid.

Action:Specify a correct password file name.


ORA-01992

ORA-01992error closing password file name

Cause:The password file could not be closed because of an operating system error or because an authentication action failed.

Action:Check for the above causes and correct as necessary.


ORA-01993

ORA-01993error writing password file name

Cause:The password file could not be written to because of an operating system error or because an authentication action failed.

Action:Check for the above causes and correct as necessary.


ORA-01994

ORA-01994GRANT failed: cannot add users to public password file

Cause:A grant failed because a user could not be added to the password file. This is because the value of the REMOTE_LOGIN_PASSWORDFILE initialization parameter is set to PUBLIC.

Action:To add a user to the password file, shutdown the database, change the REMOTE_LOGIN_PASSWORDFILE initialization parameter to PRIVATE, and restart the database.


ORA-01995

ORA-01995error reading password file name

Cause:An operating system error occurred when trying to read the password file.

Action:Fix the operating system error.


ORA-01996

ORA-01996GRANT failed: password file name is full

Cause:The grant failed when a user could not be added to the password file, because all available slots in it were used already.

Action:Either recreate a larger password file or free up slots in the password file by revoking the SYSOPER and SYSDBA privileges from some of the remote users. You can determine which remote users are valid and their privileges by issuing the following query in SQL*DBA:

SELECT * FROM V$REMOTE_USERS;


ORA-01997

ORA-01997GRANT failed: user name is identified externally

Cause:You cannot grant the SYSOPER or SYSDBA privilege to a user created with the IDENTIFIED EXTERNALLY clause.

Action:If you wish to grant the user the SYSOPER or SYSDBA privileges, drop and recreate the user without the IDENTIFIED EXTERNALLY clause.


ORA-01998

ORA-01998REVOKE failed: user SYS always SYSOPER and SYSDBA

Cause:You attempted to revoke one of the necessary privileges, SYSOPER or SYSDBA, from user SYS. These privileges cannot be revoked.

Action:Do not attempt this operation.


ORA-01999

ORA-01999password file mode has changed from mode to mode

Cause:Another instance has started with the FORCE_PASSWORD_FILEMODE initialization parameter, which is incompatible with the startup mode of your instance.

Action:Shut down your instance and start up later when the password file changes are completed for the other instance.


ORA-02000

ORA-02000missing keyword 'name'

Cause:The statement entered requires the missing keyword.

Action:Use the specified keyword.


ORA-02001

ORA-02001user SYS is not permitted to create indexes with freelist groups

Cause:An attempt was made to create an index while running with SYS authorization.

Action:Indexes cannot be created with SYS authorization. Either do not create the index or switch to USER authorization.


ORA-02002

ORA-02002error while writing to audit trail

Cause:The auditing facility is unable to write to the AUDIT_TRAIL table. If this error occurs, SQL statements that are currently being audited may also fail. This error will occur if the SYSTEM tablespace runs out of disk space.

Action:Add space to the SYSTEM tablespace or delete rows from the AUDIT_TRAIL table. If these operations fail or do not eliminate the problem, shut down and restart ORACLE with auditing disabled. This is done by setting the initialization parameter AUDIT_TRAIL to FALSE.


ORA-02003

ORA-02003invalid USERENV parameter

Cause:An invalid parameter was specified for the USERENV function.

Action:Specify one of the allowable parameters TERMINAL, SESSIONID, ENTRYID, or NLS_LANG.


ORA-02004

ORA-02004security violation

Cause:A user is attempting to perform an operation without the proper permission, and this fact is being recorded in the AUDIT_TRAIL table. (This message only appears in the AUDIT_TRAIL table's return code column.)

Action:For auditing information only; no user action is required.


ORA-02005

ORA-02005implicit (-1) length not valid for this bind or define datatype

Cause:A negative length for the define variable was passed to a define function.

Action:An explicit, non-negative, length parameter must be passed.


ORA-02006

ORA-02006invalid packed decimal format string

Cause:A packed decimal datatype was passed to a bind or define function, and the format string parameter was either not present or invalid.

Action:A valid format string parameter must be passed for a packed decimal variable. Check the programming manual for the definition of a packed decimal format string.


ORA-02007

ORA-02007can't use ALLOCATE or DEALLOCATE options with REBUILD

Cause:Allocate or deallocate storage and rebuild index are not compatible.

Action:Choose one or the other.

For more information about ALTER INDEX in changing future storage allocation and the STORAGE clause, see the index entries on "ALTER INDEX" and on "STORAGE clause" in Oracle8 Server SQL Reference.


ORA-02008

ORA-02008non-zero scale specified for non-numeric column

Cause:A scale factor was specified for a bind or define of a non-numeric variable.

Action:Set the scale factor to 0; then retry the operation.


ORA-02009

ORA-02009the file size specified for a file must not be zero

Cause: A file specification included a SIZE clause with a zero value.

Action:If allowed, leave out the size clause, or specify a valid value.


ORA-02010

ORA-02010missing host connect string

Cause:A quoted character string does not follow the keyword USING in the USING clause of a CREATE DATABASE LINK statement.

Action:Specify the host connect string; then retry the operation.


ORA-02011

ORA-02011duplicate database link name

Cause:The database link name specified in a CREATE DATABASE LINK statement already exists.

Action:Either specify a new name or drop the existing link.


ORA-02012

ORA-02012missing USING keyword

Cause:The keyword USING does not follow the CONNECT TO clause in a CREATE DATABASE LINK statement.

Action:Specify the USING clause after the CONNECT TO clause.


ORA-02013

ORA-02013missing CONNECT keyword

Cause:The keyword CONNECT does not follow the database link name in a CREATE DATABASE LINK statement.

Action:Specify the CONNECT clause after the database link name.


ORA-02014

ORA-02014cannot select FOR UPDATE from view with DISTINCT, GROUP BY, etc.

Cause:An attempt was made to SELECT ... FOR UPDATE from a view whose defining SELECT statement uses at least one of the following constructs in its outer block: outer join, GROUP BY clause, aggregate functions, SELECT DISTINCT, CONNECT BY clause, or set operation (UNION, INTERSECT, or MINUS).

Action:Do not use SELECT ... FOR UPDATE on this view.


ORA-02015

ORA-02015cannot select FOR UPDATE from remote table

Cause:An attempt was made to SELECT ... FOR UPDATE from a table in a remote database.

Action:It is not currently possible to SELECT ... FOR UPDATE from a table in a remote database; instead, log on or connect directly to the remote database before entering a SELECT ... FOR UPDATE on its tables.


ORA-02016

ORA-02016cannot use a subquery in a START WITH on a remote database

Cause:An attempt was made to use a subquery in a START WITH clause. Such a subquery is not currently permitted if the table in the FROM clause of the tree query is in a remote database.

Action:It is necessary to connect directly to the remote database before a subquery in the START WITH clause can be used.


ORA-02017

ORA-02017integer value required

Cause:The specified value must be an integer.

Action:Specify an appropriate integer value; then retry the operation


ORA-02018

ORA-02018database link of same name has an open connection

Cause:The user is currently connected to a PUBLIC database link with the same name as the database link name specified in a CREATE or DROP DATABASE LINK statement.

Action:Close the cursors that use the PUBLIC database link.


ORA-02019

ORA-02019connection description for remote database not found

Cause:The user attempted to connect or log on to a remote database using a connection description that could not be found.

Action:Specify an existing database link. Query the data dictionary to see all existing database links. Check your operating system specific SQL*Net documentation for valid connection descriptors.


ORA-02020

ORA-02020too many database links in use

Cause:The maximum number of active connections to remote databases per user logon has been reached.

Action:If the user has no open cursors, the current SQL statement accesses more than the maximum allowed remote databases. Otherwise, the user may free remote database connections by closing all cursors that access the databases.

If this occurs often, consider increasing a the value of the initialization parameter OPEN_LINKS, which controls the maximum number of concurrent open connections to remote databases per user process.


ORA-02021

ORA-02021DDL operations are not allowed on a remote database

Cause:An attempt was made to use a DDL operation on a remote database. For example, "CREATE TABLE tablename@remotedbname ...".

Action:To alter the remote database structure, you must connect to the remote database with the appropriate privileges.


ORA-02022

ORA-02022remote statement has unoptimized view with remote object

Cause:The local view is unoptimized and contains references to objects at the remote database and the statement must be executed at the remote database.

Action:Create a similar view on the remote database and modify the violating view in the SQL statement with the new view@remote.


ORA-02023

ORA-02023START WITH or CONNECT BY predicate cannot be evaluated by remote database

Cause:The statement contains a tree query on a remote database and the tree query's START WITH or CONNECT BY predicate contains a term that cannot be evaluated at the remote database. Such terms include calls to user functions, calls to USERENV, and references to ROWID.

Action:Remove the disallowed term, directly connect, or log on to the remote database.


ORA-02024

ORA-02024database link not found

Cause:Database link to be dropped is not found in dictionary.

Action:Correct the database link name.


ORA-02026

ORA-02026missing LINK keyword

Cause:The keyword LINK is required in this context.

Action:Check syntax, insert keyword LINK as required, and try again.


ORA-02027

ORA-02027multi-row UPDATE of LONG column is not supported

Cause:A bind variable with length greater than 2000 bytes is being used to update a column, and the UPDATE statement affects more than one row.

Action:Ensure such a bind variable only updates a single row.


ORA-02028

ORA-02028fetching an exact number of rows is not supported by the server

Cause:The server does not support UPIALL, so the fetch of an exact number of rows cannot be emulated on the user side.

Action:Connect to a valid server or do not use an exact fetch.


ORA-02029

ORA-02029missing FILE keyword

Cause:The keyword FILE is required in this context.

Action:Check syntax, insert keyword FILE as required, and try again.


ORA-02030

ORA-02030can only select from fixed tables/views

Cause:An operation other than SELECT on a fixed table (dynamic performance table) or view was attempted. It is only possible to select from fixed tables or views.

Action:Remove the fixed table or view name from the SELECT statement.


ORA-02031

ORA-02031no ROWID for fixed tables

Cause:An attempt was made to select the ROWID from a fixed table.

Action:Do not select ROWID from a fixed table.


ORA-02032

ORA-02032clustered tables cannot be used before the cluster index is built

Cause:An attempt was made to perform a DML operation on a clustered table for which no cluster index has yet been created.

Action:Create a cluster index before referencing clustered tables in a SQL statement.


ORA-02033

ORA-02033a cluster index for this cluster already exists

Cause:A cluster index already exists for the cluster.

Action:No user action is required.


ORA-02034

ORA-02034speed bind not permitted

Cause:Speed bind not allowed with supplied bind variables.

Action:None.


ORA-02035

ORA-02035illegal bundled operation combination

Cause:UPI bundled execution call was requested on an illegal combination of operations.

Action:Use a legal combination of operations and retry.


ORA-02036

ORA-02036too many variables to describe with automatic cursor open

Cause:UPI bundled execution call requested to perform automatic cursor open and close on a describe operation. There were too many SELECT list items or bind variables to do this.

Action:Open and close cursor explicitly.


ORA-02037

ORA-02037uninitialized speed bind storage

Cause:A user attempted to perform a speed-execution call on a SQL statement containing host variables without first performing a speed-bind call.

Action:Perform a speed-bind call before performing a speed-execution call.


ORA-02038

ORA-02038define is not allowed for array type

Cause:A user attempted to define a select list variable of type "array". Arrays may only serve as host bind variables.


ORA-02039

ORA-02039bind by value is not allowed for array type

Cause:User attempted to bind an array host variable by value. Arrays may only be bound by reference.

________________________________________


ORA-02040

ORA-02040remote database 'name' does not support two-phase commit

Cause:A distributed update of more than one database was attempted, but the named database does not support the prepare phase of the two-phase commit (as determined by its logon transaction traits). The transaction was rolled back.

Action:Do not attempt to update the named database unless it is the only database updated in the transaction. Distributed updates of more than one database in a single transaction can only be performed if all databases support the two-phase commit mechanism.


ORA-02041

ORA-02041client database did not begin a transaction

Cause:This is an internal error that is not normally encountered.

Action:Contact Worldwide Customer Support.


ORA-02042

ORA-02042too many distributed transactions

Cause:The distributed transaction table is full, because too many distributed transactions are active.

Action:Increase the DISTRIBUTED_TRANSACTIONS parameter in the initialization parameter file, or run fewer transactions. If it is certain there are not too many concurrent distributed transactions, this may be an internal error; in this case, contact Worldwide Customer Support. Shutting down and restarting the instance could be a work-around.


ORA-02043

ORA-02043must end current transaction before executing command

Cause: A transaction is in progress and one of the following commands is issued: COMMIT FORCE, ROLLBACK FORCE, or ALTER SYSTEM ENABLE DISTRIBUTED RECOVERY in single process mode.

Action:COMMIT or ROLLBACK the current transaction and resubmit command.


ORA-02044

ORA-02044transaction manager login denied: transaction in progress

Cause:A remote transaction manager tried to log in while a distributed transaction is in progress. A protocol error occurred in the remote transaction manager.

Action:End the current transaction.


ORA-02045

ORA-02045too many local sessions participating in global transactions

Cause:There are too many sessions at this site to accommodate this transaction.

Action:Use an existing database link so that another session need not be created at the remote site.


ORA-02046

ORA-02046distributed transaction already begun

Cause:This is an internal error not normally encountered. A server session received a BEGIN_TRAN remote procedure call before finishing with a previous distributed transaction.

Action:Contact Worldwide Customer Support.


ORA-02047

ORA-02047cannot join the distributed transaction in progress

Cause: Either:

·A transaction is in progress against a remote database that does not support two-phase commit.

·Updates are pending and an attempt was made to update a different database that does not support two-phase commit.

Action:Complete the current transaction before attempting the action that caused the error.


ORA-02048

ORA-02048attempt to begin distributed transaction without logging on

Cause:The client program did not issue a distributed transaction login.

Action:This is an internal error, contact Worldwide Customer Support.


ORA-02049

ORA-02049time-out: distributed transaction waiting for lock

Cause:The time to wait on a lock in a distributed transaction has been exceeded. This time is specified in the initialization parameter DISTRIBUTED_LOCK_TIMEOUT.

Action:This situation is treated as a deadlock and the statement was rolled back. To set the time-out interval to a longer interval adjust the initialization parameter DISTRIBUTED_LOCK_TIMEOUT; then shut down and restart the instance.


ORA-02050

ORA-02050transaction num rolled back, some remote DBs may be in-doubt

Cause:There was a network failure or a remote failure during the two-phase commit.

Action:Notify the database administrator. The remote databases will automatically resynchronize when the failure is repaired.


ORA-02051

ORA-02051another session in same transaction failed

Cause:A session at the same site with same global transaction identification failed.

Action:No action is necessary; the transaction will automatically recover.


ORA-02052

ORA-02052remote transaction failure at name

Cause:There was some error in a remote transaction at the named database link.

Action:More descriptive messages will follow. Correct the problem specified in the following messages and retry the operation.


ORA-02053

ORA-02053transaction num committed, some remote DBs may be in-doubt

Cause:There was a network failure or a remote failure during the two-phase commit.

Action:Notify the database administrator. The remote databases will automatically resynchronize when the failure is repaired.


ORA-02054

ORA-02054transaction num in-doubt

Cause:There was a network failure or a remote failure in the two-phase commit.

Action:Notify the database administrator; remote DBs will automatically resynchronize when the failure is repaired. Monitor the DBA_2PC_INDOUBT and DBA_2PC_INCONSISTENT tables for the final outcome and resubmit the transaction, if necessary.


ORA-02055

ORA-02055distributed update operation failed; rollback required

Cause:A failure during a distributed update operation may not have rolled back all effects of the operation. Since some sites may be inconsistent with others, the transaction must roll back to a savepoint or roll back entirely.

Action:Roll back to a savepoint or roll back the entire transaction, and resubmit the statements that have been rolled back.


ORA-02056

ORA-02056 str: bad two-phase command number num from name

Cause:There was a two-phase commit protocol error.

Action:The transaction may automatically recover. Monitor the DBA_2PC_INDOUBT and DBA_2PC_INCONSISTENT tables to determine the resolution. Enter the transaction again, if necessary. Contact Worldwide Customer Support, if necessary.


ORA-02057

ORA-02057 str: bad two-phase recovery state number num from name

Cause:An internal error in the two-phase recovery protocol occurred.

Action:Contact Worldwide Customer Support.


ORA-02058

ORA-02058no prepared transaction found with ID num

Cause:A COMMIT FORCE was attempted on a transaction, but the transaction with LOCAL_TRAN_ID or GLOBAL_TRAN_ID was not found in the DBA_2PC_INDOUBT table in prepared state.

Action:Check the DBA_2PC_INDOUBT table to ensure the proper transaction ID is used and attempt the commit again.


ORA-02059

ORA-02059ORA-CRASH-TEST-n in commit comment

Cause:This is a special comment used to test the two-phase commit.

Action:Do not use this special comment unless working with Worldwide Customer Support.


ORA-02060

ORA-02060SELECT FOR UPDATE specified a join of non-colocated tables

Cause:An attempt was made to join tables in different remote databases in a SELECT ... FOR UPDATE statement.

Action:Joined tables in a SELECT statement with the FOR UPDATE clause must reside at the same database. Simplify the SELECT ... FOR UPDATE statement so that it only joins tables in the same database.


ORA-02061

ORA-02061lock table specified list of non-colocated tables

Cause:An attempt was made to lock more than one table in different remote databases in a LOCK TABLE statement. Tables in a LOCK TABLE statement must reside at the same database.

Action:Issue multiple LOCK TABLE commands.


ORA-02062

ORA-02062distributed recovery received DBID num, expected num

Cause:A database link at the coordinator point no longer points to the expected database. The database link may have been redefined, or a different database may have been mounted.

Action:Check the database link at the coordinator point to see if it was redefined. If so, contact the database administrator for the remote database to check whether the link still references a valid database. If the link changed, re-create it so it references a valid database at the remote site.


ORA-02063

ORA-02063preceding str from name

Cause:An ORACLE error message was received from a remote database link.

Action:Refer to the preceding messages. Correct the problem mentioned in the preceding messages and try the operation again.


ORA-02064

ORA-02064iterated or long remote update with subquery not supported

Cause:One of two cases occurred. An attempt was made to perform an array execute of a remote update with subquery to different database. Or, an attempt was made to perform an update of a long column using a bind variable and an update of a second column with a subquery to a different database, and the subquery has a bind variable.

Action:Simplify the remote update statement.


ORA-02065

ORA-02065illegal option for ALTER SYSTEM

Cause:The option specified for ALTER SYSTEM is not supported.

Action:Refer to the ORACLE7 Server SQL Language Reference Manual for the proper syntax of the ALTER SYSTEM command.


ORA-02066

ORA-02066missing or invalid MTS_DISPATCHERS text

Cause:A character string literal was expected but not found in the ALTER SYSTEM SET MTS_DISPATCHERS command.

Action:Place the string literal containing the dispatcher's specification in the ALTER SYSTEM SET MTS_DISPATCHERS command.


ORA-02067

ORA-02067transaction or savepoint rollback required

Cause:A failure occurred, typically in a trigger or stored procedure with multiple remote updates. Some sites in the transaction may be inconsistent, so the previous Oracle call cannot be executed, and the transaction cannot be committed.

Action:Roll back to a previous savepoint or to the beginning of the transaction; then resubmit the rolled back statements.


ORA-02068

ORA-02068following severe error from name

Cause:A severe error (a disconnect or fatal ORACLE error) was received from the given database link. See the accompanying messages for a more detailed description of the problem.

Action:Contact the remote system administrator to determine the cause of the remote problem and the estimated time of the problem's resolution.


ORA-02069

ORA-02069remote sequences are not co-located

Cause:The remote sequences referenced are not all in the same location.

Action:All remote sequences referenced must be at the same location. Correct the problem and issue the statement again.


ORA-02070

ORA-02070database name does not support str in this context

Cause:The remote database does not support the named capability in the context in which it was used.

Action:Simplify the SQL statement.


ORA-02071

ORA-02071message initializing capabilities for remote database name

Cause:ORACLE could not load the capability table from the named remote database.

Action:Contact Worldwide Customer Support concerning the remote SQL*Connect product.


ORA-02072

ORA-02072distributed database network protocol mismatch

Cause:This error should never occur between different PRODUCTION releases of ORACLE, but may happen between alpha and beta releases, for example.

Action:Upgrade the older release.


ORA-02073

ORA-02073sequence numbers not supported in remote updates

Cause:Sequence numbers may not be used in INSERTS, UPDATES, or DELETES on remote tables.

Action:Perform the operation without specifying a sequence number.


ORA-02074

ORA-02074cannot COMMIT or ROLLBACK in a distributed transaction

Cause:A COMMIT or ROLLBACK was attempted from a session other than the parent of a distributed transaction.

Action:Only the parent session can issue a COMMIT or ROLLBACK.


ORA-02075

ORA-02075remote sequence not co-located with any table

Cause:All of the referenced sequences must be located on the same node as at least one table or view.

Action:Correct the problem and then re-issue the statement.


ORA-02076

ORA-02076sequence not co-located with updated or long column

Cause:All referenced sequences must be located on the same node as the updated table or the long column.

Action:Correct the problem and then re-issue the statement.


ORA-02077

ORA-02077selects of long columns must be from co-located tables

Cause:All tables returning values of long columns in a SELECT statement must be located at the same node.

Action:Correct the problem; then re-issue the statement.


ORA-02078

ORA-02078invalid setting for ALTER SYSTEM FIXED_DATE

Cause:An invalid value was used.

Action:Use a correct value.


ORA-02079

ORA-02079no new sessions may join a committing distributed transaction

Cause:A call to UPI2BG was issued in a session for a transaction that has begun to commit in a different branch; that is, a call to UPI2EN was issued for a branch of the same transaction in another session. This can only happen when using an external transaction manager.

Action:Contact Worldwide Customer Support.


ORA-02080

ORA-02080database link is in use

Cause:A transaction is active or a cursor is open on the database link given in the ALTER SESSION CLOSE DATABASE LINK statement.

Action:Commit or roll back the transaction, or close the open cursors.


ORA-02081

ORA-02081database link is not open

Cause:An attempt was made to use a database link that is not currently open.

Action:Resolve network problems, or contact the remote database administrator to determine if the remote database's problem has been fixed. Contact the local database administrator to determine if network problems have been resolved. Wait until the link is open and try the operation again.


ORA-02082

ORA-02082a loop-back database link must have a connection qualifier

Cause:An attempt was made to create a database link with the same name as the current database.

Action:This database link needs a trailing qualifier to make the name unique. These qualifiers are operating system specific. Refer to the installation or user's guide for more information about creating database links.


ORA-02083

ORA-02083database name has illegal character 'str'

Cause:The database name supplied contains an invalid character. There can be no periods, semicolons, blanks, or non-printable characters in the database name.

Action:Supply a different database name, and do not use any invalid characters.


ORA-02084

ORA-02084database name is missing a component

Cause:The complete database name was not given

Action:Specify the full database name.


ORA-02085

ORA-02085database link name connects to name

Cause:The database link attempted to connect to a database with a different name. The name of the database link must be the same name as the name of the database.

Action:Create a database link with the same name as the database to which it connects.


ORA-02086

ORA-02086database (link) name is too long

Cause:The name of the database or database link is too long. Database and database link names can be no longer than 128 characters.

Action:Specify the correct database or database link name, or specify a name with fewer characters.


ORA-02088

ORA-02088distributed database option not installed

Cause:The distributed database option is not installed at this site. The requested operation is therefore not possible.

Action:Contact Oracle Corporation about obtaining the distributed database option.


ORA-02088

ORA-02088distributed database option not installed

Cause:The distributed database option is not installed at this site, so the requested operation is not possible.

Action:Contact Oracle Corporation about obtaining the distributed database option.


ORA-02089

ORA-02089COMMIT is not allowed in a subordinate session

Cause:COMMIT was issued in a session that is not the two-phase commit global coordinator.

Action:Issue commits only at the global coordinator.


ORA-02090

ORA-02089network error: attempted callback+passthru

Cause:This is an internal error.

Action:Contact Oracle Worldwide Support.


ORA-02091

ORA-02091transaction rolled back

Cause:The distributed transaction is assigned to the system rollback segment and is trying to get into the prepared state, but the required number of non-PREPARED slots are not available, hence the transaction is rolled back.

If the transaction aborted at a remote site, only ORA-02091 will be seen. If the transaction aborted at the host site then both ORA-02091 and ORA-02092 will be seen.

Action:Complete the current transaction and then do the operation required.


ORA-02092

ORA-02092out of transaction table slots for distributed transaction

Cause:The distributed transaction is assigned to the system rollback segment and is trying to get into the prepared state, but the required number of non-PREPARED slots are not available, hence the transaction is rolled back.

If the transaction aborted at a remote site, only ORA-02091 will be seen. If the transaction aborted at the host site then both ORA-2091 and ORA-2092 will be seen.

Cause:Add a rollback segment and do the operation again.


ORA-02093

ORA-02093TRANSACTIONS_PER_ROLLBACK_SEGMENT(name) more than maximum possible.

Cause:The value of the initialization parameter specified is greater than allowed on this port.

Action:Use the default value or reduce it to less than the maximum.


ORA-02094

ORA-02094replication option not installed

Cause:The replication option was not installed at this site. Updatable snapshots, deferred remote procedure calls, and other replication features were, therefore, unavailable.

Action:Install the replication option. The replication option is not part of the Oracle7 Server product and must be purchased separately. Contact an Oracle sales representative if the replication option needs to be purchased.


ORA-02095

ORA-02095specified initialization parameter cannot be modified

Cause:Specified initialization parameter is not modifiable with this option.

Action:Check the DBA guide for information about under what scope the parameter may be modified.

For more information about modifying an initialization parameter, see the index entry on "initialization parameters, altering" in Oracle8 Server SQL Reference.


ORA-02096

ORA-02096specified initialization parameter is not modifiable with this option

Cause:Though the initialization parameter is modifiable, it cannot be modified using the specified command.

Action:Check the DBA guide for information about under what scope the parameter may be modified.

For more information about modifying an initialization parameter, see the index entry on "initialization parameters, altering" in Oracle8 Server SQL Reference.


ORA-02097

ORA-02097Parameter cannot be modified because specified value is invalid

Cause:Though the initialization parameter is modifiable, the modified value is not acceptable to the parameter.

Action:Check the DBA guide for range of acceptable values for this parameter.


ORA-02098

ORA-02098error parsing index-table reference (:I)

Cause:An incorrect index-table (:I) syntax was encountered.

Action:This syntax is for Oracle internal use only.


ORA-02140

ORA-02140invalid tablespace name

Cause:A valid tablespace name does not follow ALTER TABLESPACE.

Action:Specify a valid tablespace name following ALTER TABLESPACE.


ORA-02141

ORA-02141invalid OFFLINE option

Cause:An option other than NORMAL or IMMEDIATE follows OFFLINE in an ALTER TABLESPACE statement.

Action:The user must either specify no option following OFFLINE or one of these options: NORMAL or IMMEDIATE.


ORA-02142

ORA-02142missing or invalid ALTER TABLESPACE option

Cause:An invalid option was specified after ALTER TABLESPACE.

Action:Use one of the valid options such as ADD DATAFILE, RENAME DATAFILE, DEFAULT STORAGE, ONLINE, OFFLINE, BEGIN BACKUP, or END BACKUP.


ORA-02143

ORA-02143invalid STORAGE option

Cause:An option other than INITIAL, NEXT, MINEXTENTS, MAXEXTENTS, FREELISTS, FREELIST GROUPS, or PCTINCREASE was specified in the STORAGE clause of a CREATE statement.

Action:Check syntax, specify only valid options, and try again.


ORA-02144

ORA-02144no option specified for ALTER CLUSTER

Cause:No valid ALTER CLUSTER options were specified.

Action:Specify one or more valid options such as PCTFREE, PCTUSED, SIZE, INITRANS, MAXTRANS, or STORAGE.


ORA-02145

ORA-02145missing STORAGE option

Cause:No STORAGE options were specified following the keyword STORAGE.

Action:Check syntax, specify one or more valid STORAGE options, and try again.


ORA-02146

ORA-02146SHARED specified multiple times

Cause:The SHARED option was specified more than once in a CREATE DATABASE statement.

Action:Only specify the SHARED option once.


ORA-02147

ORA-02147conflicting SHARED/EXCLUSIVE options

Cause:Both the SHARED and EXCLUSIVE options were specified in a CREATE DATABASE statement.

Action:Specify SHARED or EXCLUSIVE, but not both.


ORA-02148

ORA-02148EXCLUSIVE specified multiple times

Cause:The EXCLUSIVE option was specified in a CREATE DATABASE statement more than once.

Action:Only specify the EXCLUSIVE option once.


ORA-02149

ORA-02149specified partition does not exist

Cause:Partition not found the base object.

Action:Enter the correct partition specification and retry the operation.


ORA-02153

ORA-02153invalid VALUES password string

Cause:An encoded password string does not follow the VALUES clause.

Action:Place a proper encoded password string after the VALUES clause.


ORA-02155

ORA-02155invalid DEFAULT tablespace identifier

Cause:A valid tablespace name does not follow DEFAULT TABLESPACE.

Action:Place a valid tablespace name after DEFAULT TABLESPACE, and try again.


ORA-02156

ORA-02156invalid TEMPORARY tablespace identifier

Cause:A valid tablespace name does not follow TEMPORARY TABLESPACE.

Action:Place a valid tablespace name after TEMPORARY TABLESPACE, and try again.


ORA-02157

ORA-02157no options specified for ALTER USER

Cause:No options were specified.

Action:Specify at least one ALTER USER option, and try again.


ORA-02158

ORA-02158invalid CREATE INDEX option

Cause:An option other than PCTFREE, INITRANS, MAXTRANS, NOSORT, STORAGE, or TABLESPACE was specified.

Action:Specify one of the valid CREATE INDEX options, and try again.


ORA-02159

ORA-02159installed DLM does not support releasable locking mode

Cause:The parameter file specified GC_*PARAMETERS that allow locks to be released by the LCK process when not in use. This mode required additional support in DLM that was not available.

Action:Specify configuration parameters that do not require the additional function.

For more information about the distributed lock manager(DLM), see the index entry on "LCK" in Oracle8 Server Concepts and the index entries on "distributed lock manager" and on "distributed lock manager, LCKn process" in Oracle8 Parallel Server Concepts & Administration.


ORA-02160

ORA-02160index only table cannot contain columns of type LONG

Cause:An attempt was made to define a column of type LONG for an index only table.

Action:Do not use columns of type LONG in index only tables.


ORA-02161

ORA-02161invalid value for MAXLOGFILES

Cause:A number does not follow MAXLOGFILES.

Action:Specify a number after MAXLOGFILES, and try again.


ORA-02162

ORA-02162invalid value for MAXDATAFILES

Cause:A number does not follow MAXDATAFILES.

Action:Specify a number after MAXDATAFILES, and try again.


ORA-02163

ORA-02163invalid value for FREELIST GROUPS

Cause:A number does not follow FREELIST GROUPS.

Action:Specify a number after FREELIST GROUPS, and try again.


ORA-02164

ORA-02164DATAFILE clause specified more than once

Cause:The CREATE DATABASE statement contains more than one DATAFILE clause.

Action:Specify at most one DATAFILE clause, and try again.


ORA-02165

ORA-02165invalid option for CREATE DATABASE

Cause:An invalid CREATE DATABASE option is present.

Action:Specify only valid CREATE DATABASE options, and try again.


ORA-02166

ORA-02166ARCHIVELOG and NOARCHIVELOG specified

Cause:Both ARCHIVELOG and NOARCHIVELOG are specified in a CREATE DATABASE statement.

Action:Specify either of these two options, but not both, and try again.


ORA-02167

ORA-02167LOGFILE clause specified more than once

Cause:The CREATE DATABASE statement contains more than one LOGFILE clause.

Action:Specify at most one LOGFILE clause, and try again.


ORA-02168

ORA-02168invalid value for FREELISTS

Cause:A number does not follow the FREELISTS storage option of the CREATE TABLE or CREATE INDEX statement.

Action:Specify a number after FREELISTS, and try again.


ORA-02169

ORA-02169FREELISTS storage option not allowed

Cause:An attempt was made to specify the FREELISTS storage option when performing an operation other than CREATE TABLE or CREATE INDEX.

Action:Check the syntax of the statement, remove this option, then re-execute the statement.


ORA-02170

ORA-02170FREELIST GROUPS storage option not allowed

Cause:An attempt was made to specify the FREELIST GROUPS storage option. This option may only be specified when using the CREATE TABLE command and when the ALLOW_FREELIST_GROUPS parameter is specified in the initialization parameter file.

Action:Retry the statement without the FREELIST GROUPS storage option or set the ALLOW_FREELIST_GROUPS parameter in the initialization parameter file.


ORA-02171

ORA-02171invalid value for MAXLOGHISTORY

Cause:A number does not follow MAXLOGHISTORY.

Action:Specify a number after MAXLOGHISTORY.


ORA-02172

ORA-02172The PUBLIC keyword is not appropriate for a disable thread

Cause:The PUBLIC keyword was specified when disabling a thread.

Action:Check the syntax of the command and resubmit.


ORA-02173

ORA-02173invalid option for DROP TABLESPACE

Cause:Something other than INCLUDING was found following the tablespace name, or text was found following INCLUDING CONTENTS.

Action:Place nothing or only INCLUDING CONTENTS after the tablespace name, and try again.


ORA-02174

ORA-02174Missing required thread number

Cause:A thread number must be specified after THREAD keyword.

Action:Check the syntax of the command, specify a number after THREAD, then resubmit it.


ORA-02175

ORA-02175invalid rollback segment name

Cause:In the CREATE or DROP ROLLBACK SEGMENT statements, a valid rollback segment name does not follow ROLLBACK SEGMENT.

Action:Place a valid rollback segment name after ROLLBACK SEGMENT, and try again.


ORA-02176

ORA-02176invalid option for CREATE ROLLBACK SEGMENT

Cause:An invalid option was specified in a CREATE ROLLBACK SEGMENT statement.

Action:Specify one of the valid options (TABLESPACE or STORAGE), and try again.


ORA-02177

ORA-02177Missing required group number

Cause:A group number must be specified after GROUP keyword.

Action:Check the syntax of the command, specify a group number after GROUP; then resubmit it.


ORA-02178

ORA-02178correct syntax is: SET TRANSACTION READ { ONLY | WRITE }

Cause:There is a syntax message in the user's statement.

Action:Correct the syntax as indicated, and try again.


ORA-02179

ORA-02179valid options: ISOLATION LEVEL {SERIALIZABLE | READ COMMITTED}

Cause:There was a syntax error in the user's statement.

Action:Correct the syntax as indicated.


ORA-02180

ORA-02180invalid option for CREATE TABLESPACE

Cause:An invalid option follows CREATE TABLESPACE.

Action:Specify one of the valid options: DATAFILE, DEFAULT STORAGE, ONLINE, or OFFLINE, and try again.


ORA-02181

ORA-02181invalid option to ROLLBACK WORK

Cause:A word other than TO follows ROLLBACK [WORK].

Action:Place nothing or TO SAVEPOINT after ROLLBACK [WORK], and try again.


ORA-02184

ORA-02184resource quotas are not allowed in REVOKE

Cause:In a revoke statement, a resource quota was specified.

Action:Specify the resource privilege without the quota, and try again.


ORA-02183

ORA-02183valid options: ISOLATION_LEVEL {SERIALIZABLE | READ COMMITTED}

Cause:There was a syntax error in the user's statement.

Action:Correct the syntax as indicated.


ORA-02184

ORA-02184resource quotas are not allowed in REVOKE

Cause:In a revoke statement, a resource quota was specified.

Action:Specify the resource privilege without the quota and try again.


ORA-02185

ORA-02185a token other than WORK follows COMMIT

Cause:A token other than WORK follows COMMIT.

Action:Place either nothing or WORK after COMMIT, and try again.


ORA-02186

ORA-02186tablespace resource privilege may not appear with other privileges

Cause:An attempt was made to grant or revoke a resource quota in the same statement in which other privileges are granted or revoked.

Action:Use a separate GRANT or REVOKE statement for the resource quota privilege, and try again.


ORA-02187

ORA-02187invalid quota specification

Cause:In a GRANT or REVOKE statement, an attempt was made to grant a tablespace quota above the upper limit.

Action:Grant a smaller tablespace quota and try again.


ORA-02189

ORA-02189required clause: ON <tablespace>

Cause:The GRANT or REVOKE statement specifying a tablespace quota requires the ON tablespace clause.

Action:Correct the syntax and try again.


ORA-02190

ORA-02190keyword TABLES expected

Cause:The keyword TABLES is expected following DROP CLUSTER cluster name INCLUDING.

Action:Place the keyword TABLES after INCLUDING, and try again.


ORA-02191

ORA-02191correct syntax is: SET TRANSACTION USE ROLLBACK SEGMENT name

Cause:There is a syntax message in the SET TRANSACTION statement.

Action:Correct the syntax message and resubmit the statement.


ORA-02192

ORA-02192PCTINCREASE not allowed for rollback segment storage clauses

Cause:The storage parameter PCTINCREASE was specified in a CREATE or ALTER ROLLBACK SEGMENT command.

Action:Resubmit the command without the PCTINCREASE clause.


ORA-02194

ORA-02194event specification syntax message num (minor message num) near 'name'

Cause:There is a syntax message in an event specification.

Action:Check syntax and spelling, and try again.


ORA-02195

ORA-02195attempt to create name object in a name tablespace

Cause:The object type was inconsistent with tablespace contents.

Action:Create the object in a different tablespace, or change the user defaults.

For more information about auditing schema objects, see the index entry on "AUDIT command" in Oracle8 Server SQL Reference.


ORA-02196

ORA-02196PERMANENT/TEMPORARY option already specified

Cause:In CREATE TABLESPACE, the PERMANENT and/or TEMPORARY options were specified more than once.

Action:Specify at least one of REBUILD, INITRANS, MAXTRANS, or STORAGE.

For more information about the parameters of CREATE TABLESPACE, see the index entry on "CREATE TABLESPACE" in Oracle8 Server SQL Reference.


ORA-02197

ORA-02197file list already specified

Cause:In a CREATE TABLESPACE statement, more than one DATAFILE clause was specified.

Action:Merge the DATAFILE clauses into a single clause specifying multiple files, and try again.


ORA-02198

ORA-02198ONLINE/OFFLINE option already specified

Cause:In a CREATE TABLESPACE statement, the ONLINE and/or OFFLINE options were specified more than once.

Action:Specify either ONLINE or OFFLINE, but not both, and try again.


ORA-02199

ORA-02199missing DATAFILE clause

Cause:A CREATE TABLESPACE statement has no DATAFILE clause.

Action:Specify the missing DATAFILE clause, and try again.


ORA-02200

ORA-02200WITH GRANT OPTION not allowed for PUBLIC

Cause:An attempt was made to GRANT to PUBLIC WITH GRANT OPTION.

Action:Remove either the PUBLIC or the WITH GRANT OPTION clause, and try again.


ORA-02201

ORA-02201sequence not allowed here

Cause:An attempt was made to reference a sequence in a FROM list. This is not permitted. A sequence can only be referenced in a SELECT list.

Action:Check the statement syntax, correct the reference, and try again.


ORA-02202

ORA-02202no more tables permitted in this cluster

Cause:An attempt was made to create a table in a cluster that already contains 32 tables. No more than 32 tables may be stored in a cluster.

Action:Do not try to cluster more than 32 tables.


ORA-02203

ORA-02203INITIAL storage options not allowed

Cause:The user attempted to alter the INITIAL storage option of a table, cluster, index, or rollback segment. This option may only be specified when the object is created.

Action:Remove the INITIAL option, and try again.


ORA-02204

ORA-02204ALTER, INDEX, REFERENCE and EXECUTE not allowed for views

Cause:An attempt was made to grant or revoke an invalid privilege on a view.

Action:Do not attempt to grant or revoke the privileges ALTER, INDEX, or REFERENCES on views.


ORA-02205

ORA-02205only SELECT and ALTER privilege is valid for sequences

Cause:An attempt was made to grant or revoke an invalid privilege on a sequence.

Action:Do not attempt to grant or revoke the privileges DELETE, INDEX, INSERT, UPDATE, REFERENCES, or EXECUTE on sequences.


ORA-02206

ORA-02206duplicate INITRANS option specification

Cause:INITRANS is specified more than once.

Action:Specify INITRANS only once, and try again.


ORA-02207

ORA-02207invalid INITRANS option value

Cause:The INITRANS value is not an integer between 2 and 255, and less than or equal to the MAXTRANS value.

Action:Specify a valid INITRANS value, and try again.


ORA-02208

ORA-02208duplicate MAXTRANS option specification

Cause:MAXTRANS is specified more than once.

Action:Specify MAXTRANS only once, and try again.


ORA-02209

ORA-02209invalid MAXTRANS option value

Cause:The MAXTRANS value is not an integer between 1 and 255 and greater than or equal to the INITRANS value.

Action:Specify a valid MAXTRANS value, and try again.


ORA-02210

ORA-02210no options specified for ALTER TABLE

Cause:No ALTER TABLE option was specified.

Action:Specify at least one ALTER TABLE option, and try again.


ORA-02211

ORA-02211invalid value for PCTFREE or PCTUSED

Cause:The specified value for PCTFREE or PCTUSED is not an integer between 0 and 100.

Action:Specify an appropriate value for the option, and try again.


ORA-02212

ORA-02212duplicate PCTFREE option specification

Cause:The PCTFREE option was specified more than once.

Action:Specify PCTFREE only once, and try again.


ORA-02213

ORA-02213duplicate PCTUSED option specification

Cause:The PCTUSED option was specified more than once.

Action:Specify PCTUSED only once, and try again.


ORA-02214

ORA-02214duplicate BACKUP option specification

Cause:The BACKUP option to ALTER TABLE was specified more than once.

Action:Specify the BACKUP option only once, and try again.


ORA-02215

ORA-02215duplicate tablespace name clause

Cause:There is more than one TABLESPACE clause in one of the following statements: GRANT/REVOKE RESOURCE, CREATE TABLE, CREATE INDEX, CREATE/DROP TABLESPACE, CREATE CLUSTER, and CREATE ROLLBACK SEGMENT.

Action:Check the statement syntax, specify only one TABLESPACE clause, and try again.


ORA-02216

ORA-02216tablespace name expected

Cause:A valid tablespace name is not present where required in one of the following statements: CREATE TABLE, CREATE INDEX, CREATE/DROP TABLESPACE, CREATE CLUSTER, and CREATE ROLLBACK SEGMENT.

Action:Check the statement syntax, specify a valid tablespace name where required, and try again.


ORA-02217

ORA-02217duplicate storage option specification

Cause:A storage option (such as INITIAL, NEXT, MINEXTENTS, MAXEXTENTS, or PCTINCREASE) was specified more than once.

Action:Specify storage options only once, and try again.


ORA-02218

ORA-02218invalid INITIAL storage option value

Cause:The specified value must be an integer.

Action:Specify an appropriate integer value, and try again.


ORA-02219

ORA-02219invalid NEXT storage option value

Cause:The specified value must be an integer.

Action:Specify an appropriate integer value, and try again.


ORA-02220

ORA-02220invalid MINEXTENTS storage option value

Cause:The specified value must be a positive integer less than or equal to MAXEXTENTS.

Action:Specify an appropriate integer value, and try again.


ORA-02221

ORA-02221invalid MAXEXTENTS storage option value

Cause:The specified value must be a positive integer greater than or equal to MINEXTENTS.

Action:Specify an appropriate integer value, and try again.


ORA-02222

ORA-02222invalid PCTINCREASE storage option value

Cause:The specified value must be a positive integer.

Action:Specify an appropriate integer value, and try again.


ORA-02223

ORA-02223invalid OPTIMAL storage option value

Cause:The specified value must be an integer.

Action:Chose an appropriate integer value for the OPTIMAL storage option.


ORA-02224

ORA-02224EXECUTE privilege not allowed for tables

Cause:An attempt was made to GRANT or REVOKE an invalid privilege on a table.

Action:Do not attempt to GRANT or REVOKE the EXECUTE privilege on tables.


ORA-02225

ORA-02225only EXECUTE privilege is valid for procedures

Cause:An attempt was made to GRANT or REVOKE an invalid privilege on a procedure, function, or package.

Action:Do not attempt to GRANT or REVOKE any privilege other than EXECUTE on procedures, functions, or packages.


ORA-02226

ORA-02226invalid MAXEXTENTS value (max allowed: num)

Cause:The value specified for MAXEXTENTS is too large for the database block.

Action:Specify a value for MAXEXTENTS that is smaller than the number given in the message.


ORA-02227

ORA-02227invalid cluster name

Cause:A cluster name was not properly formed.

Action:Check the rules for forming object names, and enter an appropriate cluster name.


ORA-02228

ORA-02228duplicate SIZE specification

Cause:The SIZE option is specified more than once.

Action:Specify the SIZE option only once, and try again.


ORA-02229

ORA-02229invalid SIZE option value

Cause:The specified value must be an integer number of bytes.

Action:Specify an appropriate integer value, and try again.


ORA-02230

ORA-02230invalid ALTER CLUSTER option

Cause:An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, or SIZE was specified in an ALTER CLUSTER statement.

Action:Specify only valid options in the ALTER CLUSTER statement, and try again.


ORA-02231

ORA-02231missing or invalid option to ALTER DATABASE

Cause:An invalid option was specified in the statement.

Action:Check the syntax of the ALTER DATABASE command. Specify only valid options in the ALTER DATABASE statement, and try again.


ORA-02232

rORA-02232invalid MOUNT mode

Cause:A mode other than SHARED or EXCLUSIVE follows the keyword MOUNT in an ALTER DATABASE statement.

Action:Specify either SHARED, EXCLUSIVE, or nothing following the keyword MOUNT in the ALTER DATABASE statement, and try again.


ORA-02233

ORA-02233invalid CLOSE mode

Cause:A mode other than NORMAL or IMMEDIATE follows the keyword CLOSE in an ALTER DATABASE statement.

Action:Specify either NORMAL, IMMEDIATE, or nothing following the keyword CLOSE in the ALTER DATABASE statement, and try again.


ORA-02234

ORA-02234changes to this table are already logged

Cause:The log table to be added is a duplicate of another.

Action:Do not add this change log to the system; check that the product used to make copies is consistent.


ORA-02235

ORA-02235this table logs changes to another table already

Cause:The table to be altered is already a change log for another table.

Action:Do not log changes to the specified base table to this table; check that the product used to make copies is consistent.


ORA-02236

ORA-02236invalid file name

Cause:In a LOGFILE, DATAFILE, or RENAME clause, a character string literal was expected, but not found, in a file name list.

Action:Specify file names using character string literals, and try again.


ORA-02237

ORA-02237invalid file size

Cause:An integer file size does not follow SIZE in a LOGFILE or DATAFILE file list.

Action:Specify an appropriate file size following the keyword SIZE, and try again.


ORA-02238

ORA-02238file name lists have different numbers of files

Cause:In a RENAME clause in ALTER DATABASE or TABLESPACE, the number of existing file names does not equal the number of new file names.

Action:Make sure a new file name corresponds to each existing file name, and try again.


ORA-02239

ORA-02239there are objects which reference this sequence

Cause:The sequence to be dropped is still referenced by other objects.

Action:Make sure the sequence name is correct, or drop the constraint or object that references the sequence.


ORA-02240

ORA-02240invalid value for OBJNO or TABNO

Cause:A number does not follow OBJNO or TABNO.

Action:Specify a number after OBJNO or TABNO.


ORA-02241

ORA-02241must be of form EXTENTS (FILE num BLOCK num SIZE num, ...)

Cause:There was an error in the extent storage clause.

Action:Re-specify the storage clause using the correct syntax and resubmit the command.


ORA-02242

ORA-02242no options specified for ALTER INDEX

Cause:No options were specified after ALTER INDEX.

Action:Specify the INITRANS, MAXTRANS, or STORAGE option in the ALTER INDEX statement, and try again.


ORA-02243

ORA-02243invalid ALTER INDEX option

Cause:An option other than INITRANS, MAXTRANS, or STORAGE was specified in an ALTER INDEX statement.

Action:Specify only valid options, and try again.


ORA-02244

ORA-02244invalid ALTER ROLLBACK SEGMENT option

Cause:An option other than STORAGE was found.

Action:Specify the STORAGE option, and try again.


ORA-02245

rORA-02245invalid ROLLBACK SEGMENT name

Cause:A rollback segment name was expected, but not found, following ALTER [PUBLIC] ROLLBACK SEGMENT.

Action:Place a rollback segment name after SEGMENT, and try again.


ORA-02246

ORA-02246missing EVENTS text

Cause:A character string literal was expected, but not found, following the ALTER SESSION SET EVENTS command.

Action:Place the string literal containing the EVENTS text after the keyword EVENTS, and try again.


ORA-02247

ORA-02247no option specified for ALTER SESSION

Cause:The option SET EVENTS was expected, but not found, following the ALTER SESSION command.

Action:Place the SET EVENTS option after the ALTER SESSION command, and try again.


ORA-02248

ORA-02248invalid option for ALTER SESSION

Cause:An option other than SET EVENTS was found following the ALTER SESSION command.

Action:Specify the SET EVENTS option after the ALTER SESSION command, and try again.


ORA-02249

ORA-02249invalid value for MAXLOGMEMBERS

Cause:A number does not follow MAXLOGMEMBERS.

Action:Specify a number after MAXLOGMEMBERS.


ORA-02250

ORA-02250missing or invalid constraint name

Cause:The constraint name is missing or invalid.

Action:Specify a valid constraint name, and try again.


ORA-02251

ORA-02251subquery not allowed here

Cause:A subquery is not allowed at this point in the statement.

Action:Remove or relocate the subquery, and try again.


ORA-02252

ORA-02252check constraint condition not properly ended

Cause:The specified search condition for the check constraint is not properly ended.

Action:Check and correct the search condition's syntax; then retry the operation.


ORA-02253

ORA-02253constraint specification not allowed here

Cause:A constraint specification is not allowed at this point in the statement.

Action:Remove or relocate the constraint specification, and try again.


ORA-02254

ORA-02254DEFAULT <expression> not allowed here

Cause:A default-value expression is not allowed for the column at this point in the statement.

Action:Remove or relocate the default-value expression, and try again.


ORA-02255

ORA-02255NOT NULL not allowed after DEFAULT NULL

Cause:A NOT NULL specification conflicts with the NULL default value.

Action:Remove either the NOT NULL or the DEFAULT NULL specification, and try again.


ORA-02256

ORA-02256number of referencing columns must be equal to number of referenced columns

Cause:The number of columns in the foreign-key referencing list is not equal to the number of columns in the referenced list.

Action:Make sure there are no missing columns, and try again.


ORA-02257

ORA-02257maximum number of columns exceeded

Cause:The number of columns in the key list exceeds the maximum number.

Action:Reduce the number of columns in the list.


ORA-02258

ORA-02258duplicate or conflicting NULL and/or NOT NULL specifications

Cause:A duplicate or conflicting NULL and/or NOTNULL was specified.

Action:Remove one of the conflicting specifications, and try again.


ORA-02259

ORA-02259duplicate UNIQUE/PRIMARY KEY specifications

Cause:A duplicate unique or primary key was specified.

Action:Remove the duplicate specification, and try again.


ORA-02260

ORA-02260table can have only one primary key

Cause:Two or more primary keys were specified for the same table.

Action:Remove the extra primary keys, and try again.


ORA-02261

ORA-02261such unique or primary key already exists in the table

Cause:A unique or primary key was specified that already exists for the table.

Action:Remove the extra key, and try again.


ORA-02262

ORA-02262ORA-num occurs while type-checking column default value expression

Cause:An attempt to alter a column's datatype caused a type-checking error because the new datatype conflicted with the existing column's default value expression.

Action:Remove the default value expression or do not alter the column's datatype, and try again.


ORA-02263

ORA-02263need to specify the datatype for this column

Cause:The required datatype for the column is missing.

Action:Specify the required datatype, and try again.


ORA-02264

ORA-02264 name already used by an existing constraint

Cause:The specified constraint name is not unique.

Action:Specify a unique constraint name for the constraint, and try again.


ORA-02265

ORA-02265cannot derive the datatype of the referencing column

Cause:The datatype of the referenced column is not defined as yet.

Action:Make sure that the datatype of the referenced column is defined before referencing it.


ORA-02266

ORA-02266table has some unique/primary keys that are referenced by some foreign keys

Cause:An attempt was made to drop a table while the table still has some unique or primary keys that are referenced by foreign keys.

Action:Remove all references by foreign keys to unique or primary keys in a table before attempting to drop the table.


ORA-02267

ORA-02267column type incompatible with referenced column type

Cause:An attempt was made to perform an operation on a pair of columns with incompatible datatypes.

Action:Specify a compatible datatype for the referencing column.


ORA-02268

ORA-02268referenced table does not have a primary key

Cause:The referenced table does not have a primary key.

Action:Do not attempt to reference the table using a unique key, or create a unique key for the table.


ORA-02269

ORA-02269key column cannot be of LONG datatype

Cause:An attempt was made to define a key column of datatype LONG. This is not allowed.

Action:Change the datatype of the column, or remove the LONG column from the key, and try again.


ORA-02270

ORA-02270no matching unique or primary key for this column-list

Cause:An attempt was made to reference a unique or primary key in a table with a CREATE or ALTER TABLE statement when no such key exists in the referenced table.

Action:Add the unique or primary key to the table, or find the correct names of the columns with the primary or unique key, and try again.


ORA-02271

ORA-02271table does not have such a constraint

Cause:An attempt was made to reference a table using a constraint that does not exist.

Action:Check the spelling of the constraint name, or add the constraint to the table, and try again.


ORA-02272

ORA-02272constrained column cannot be of LONG datatype

Cause:A constrained column cannot be defined as datatype LONG. This is not allowed.

Action:Change the datatype of the column, or remove the constraint on the column, and try again.


ORA-02273

ORA-02273this unique/primary key is referenced by some foreign keys

Cause:A unique or primary key referenced by foreign keys cannot be dropped.

Action:Remove all references to the key before dropping it.


ORA-02274

ORA-02274duplicate referential constraint specifications

Cause:A referential constraint was specified more than once. This is not allowed.

Action:Remove the duplicate specification.


ORA-02275

ORA-02275such a referential constraint already exists in the table

Cause:An attempt was made to specify a referential constraint that already exists. This would result in duplicate specifications and so is not allowed.

Action:Be sure to specify a constraint only once.


ORA-02276

ORA-02276default value type incompatible with column type

Cause:The type of the evaluated default expression is incompatible with the datatype of the column.

Action:Modify the default expression, or change the column's datatype, and try again.


ORA-02277

ORA-02277invalid sequence name

Cause:An invalid sequence name was specified.

Action:Check syntax and spelling, specify a valid sequence name, and try again.


ORA-02278

ORA-02278duplicate or conflicting MAXVALUE/NOMAXVALUE specifications

Cause:Duplicate or conflicting MAXVALUE and/or NOMAXVALUE specifications.

Action:Remove one of the conflicting specifications, and try again.


ORA-02279

rORA-02279duplicate or conflicting MINVALUE/NOMINVALUE specifications

Cause:Duplicate or conflicting MINVALUE and/or NOMINVALUE clauses were specified.

Action:Remove one of the conflicting specifications, and try again.


ORA-02280

ORA-02280duplicate or conflicting CYCLE/NOCYCLE specifications

Cause:Duplicate or conflicting CYCLE and/or NOCYCLE clauses were specified.

Action:Remove one of the conflicting specifications, and try again.


ORA-02281

ORA-02281duplicate or conflicting CACHE/NOCACHE specifications

Cause:Duplicate or conflicting CACHE and/or NOCACHE clauses were specified.

Action:Remove one of the conflicting specifications, and try again.


ORA-02282

ORA-02282duplicate or conflicting ORDER/NOORDER specifications

Cause:Duplicate or conflicting ORDER and/or NOORDER clauses were specified.

Action:Remove one of the conflicting specifications, and try again.


ORA-02283

ORA-02283cannot alter starting sequence number

Cause:An attempt was made to alter a starting sequence number. This is not allowed.

Action:Do not try to alter a starting sequence number.


ORA-02284

ORA-02284duplicate INCREMENT BY specifications

Cause:A duplicate INCREMENT BY clause was specified.

Action:Remove the duplicate specification, and try again.


ORA-02285

ORA-02285duplicate START WITH specifications

Cause:A duplicate START WITH clause was specified.

Action:Remove the duplicate specification, and try again.


ORA-02286

ORA-02286no options specified for ALTER SEQUENCE

Cause:No ALTER SEQUENCE option was specified.

Action:Check the syntax; then specify at least one ALTER SEQUENCE option.


ORA-02287

ORA-02287sequence number not allowed here

Cause:The specified sequence number reference (CURRVAL or NEXTVAL) is inappropriate at this point in the statement.

Action:Check the syntax; then remove or relocate the sequence number.


ORA-02288

ORA-02288invalid OPEN mode

Cause:A mode other than RESETLOGS was specified in an ALTER DATABASE OPEN statement. RESETLOGS is the only valid OPEN mode.

Action:Remove the invalid mode from the statement, or replace it with the keyword RESETLOGS, and try again.


ORA-02289

ORA-02289sequence does not exist

Cause:The specified sequence does not exist, or access privilege is required for this operation. Also, this error can occur if attempting to access a remote sequence through an invalid or non-existent database link.

Action:Check spelling of the sequence name, or obtain the required access privilege. If necessary, create the sequence. All remote sequences accessed in a distributed transaction must be on the same node.


ORA-02290

ORA-02290check constraint (str.name) violated

Cause:The value or values attempted to be entered into a field or fields violate a defined check constraint.

Action:Enter values that satisfy the constraint.


ORA-02291

ORA-02291integrity constraint (str.name) violated -parent key not found

Cause:An attempt was made to INSERT or UPDATE a foreign key value; the result was a value that is not in the parent key.

Action:UPDATE to or INSERT a value that is in the parent key.


ORA-02292

ORA-02292integrity constraint (str.name) violated -child record found

Cause:An attempt was made to delete a row that is referenced by a foreign key.

Action:It is necessary to DELETE or UPDATE the foreign key before changing this row.


ORA-02293

ORA-02293cannot add check constraint - found non-complying values

Cause:An attempt was made via an ALTERTABLE statement to add a check constraint to a populated table that had no complying values.

Action:Reissue the ALTER TABLE statement specifying a check constraint on a table containing complying values.


ORA-02295

ORA-02295found more than one enable/disable clause for constraint

Cause:An attempt was made via a CREATE or ALTER TABLE statement, to specify more than one ENABLE and/or DISABLE clause for a given constraint.

Action:Only one ENABLE or DISABLE clause may be specified for a given constraint.


ORA-02295

ORA-02295found more than one enable/disable clause for constraint

Cause:An attempt was made via a CREATE or ALTER TABLE statement to specify more than one ENABLE and/or DISABLE clause for a given constraint.

Action:Only one ENABLE or DISABLE clause may be specified for a given constraint.


ORA-02296

ORA-02296cannot enable constraint (str.name) - found non-complying values

Cause:An ALTER TABLE command with an ENABLE CONSTRAINT clause failed because the table contains values that do not satisfy the constraint.

Action:Make sure that all values in the table satisfy the constraint before issuing an ALTER TABLE command with an ENABLE CONSTRAINT clause.


ORA-02297

ORA-02297cannot disable constraint (name.name) - dependencies exist

Cause:An alter table disable constraint failed because the table has foreign keys that are dependent on the constraint.

Action:Either disable the foreign key constraints or use a DISABLE CASCADE command.


ORA-02298

ORA-02298cannot enable constraint (name.name) -parent keys not found

Cause:An ALTER TABLE ENABLE CONSTRAINT command failed because the table has orphaned child records.

Action:Make sure that the table has no orphaned child records before issuing an ALTER TABLE ENABLE CONSTRAINT command.


ORA-02299

ORA-02299cannot enable constraint (name.name) -duplicate keys found

Cause:An ALTER TABLE ENABLE CONSTRAINT command failed because the table has duplicate key values.

Action:Make sure that the table has no duplicate key values before issuing an ALTER TABLE ENABLE CONSTRAINT command.

________________________________________


ORA-02301

ORA-02301 maximum number of OIDGENERATORS is 255

Cause: A number greater than 255 was specified for the value of OIDGENERATORS.

Action: Make sure the number specified for OIDGENERATORS does not exceed 255.


ORA-02302

ORA-02302 invalid or missing type name

Cause: An invalid or missing type name was entered in a statement.

Action: Enter a valid type name in the statement and retry the operation.


ORA-02303

ORA-02303 cannot drop or replace a type with type or table dependent(s)

Cause: An attempt was made to drop or replace a type that has dependents.

Action: Drop all type(s) and table(s) depending on the type, then retry the operation or use the FORCE option.


ORA-02304

ORA-02304 invalid object identifier literal

Cause: An attempt was made to enter an object identifier literal for CREATE TYPE that is either:

not a string of 32 hexadecimal characters

an object identifier that already identifies an existing object

an object identifier different from the original object identifier already assigned to the type

Action:Do not specify the object identifier clause or specify a 32 hexadecimal-character object identifier literal that is unique or identical to the originally assigned object identifier. Then retry the operation.


ORA-02305

ORA-02305only EXECUTE privilege is valid for types

Cause: An attempt was made to GRANT or REVOKE an invalid privilege (not EXECUTE) on a type.

Action: GRANT or REVOKE only the EXECUTE privilege on types.


ORA-02306

ORA-02306cannot create a type that already has valid dependent(s)

Cause: An attempt was made to create a type that already has some valid dependent(s) (these dependents depend on the fact that the type does not exist).

Action: Drop the dependents first before creating the type, or do not create the type.


ORA-02307

ORA-02307 cannot ALTER with REPLACE option a type that is not valid

Cause: An attempt was made to ALTER with REPLACE option a type that is not valid.

Action: Use the CREATE OR REPLACE TYPE command to modify the type.


ORA-02308

ORA-02308invalid option name for object type column

Cause: An attempt was made to specify an invalid option, such as PACKED or UNPACKED, for the object type column.

Action: Remove the invalid option from column specification and retry the operation.


ORA-02309

ORA-02309atomic NULL violation

Cause: An attempt was made to access the attributes of a NULL object instance.

Action: Ensure that the object instance is non-NULL before accessing.


ORA-02310

ORA-02310exceeded maximum number of allowable columns in table

Cause: The attributes in the object type column exceeded the maximum number of columns allowed in a table.

Action: Specify fewer attributes for the object type and retry the operation.


ORA-02311

ORA-02311 cannot alter with COMPILE option a valid type with type or table dependents"

Cause: An attempt was made to ALTER with COMPILE option a type that is valid and has type or table dependents.

Action: No need to perform this operation.


ORA-02312

ORA-02312cannot create extent table for VALUE ADT

Cause: An attempt was made to create extent table for VALUE Object Type.

Action: Specify object type when creating extent table.


ORA-02313

ORA-02313 object type contains non-queryable type name attribute

Cause: The specified object type contains a nested attribute whose type is non-queryable.

Action: Use an object type with queryable attribute types.


ORA-02315

ORA-02315incorrect number of arguments for default constructor

Cause: The number of arguments specified for the default constructor does not match the number of attributes of the object type.

Action:Specify the correct number of arguments for the default constructor and retry the operation.


ORA-02320

ORA-02320failure in creating storage table for nested table column name

Cause: An error occurred while creating the storage table for the specified nested table column.

Action: See the messages that follow for more details. If the situation they describe can be corrected, do so; otherwise contact Oracle Support.


ORA-02322

ORA-02322failure in accessing storage table of the nested table column

Cause: An error occurred while performing DML on the storage table of the nested table column.

Action: If the situation described in the following messages can be corrected, do so; otherwise contact Oracle Support.


ORA-02324

ORA-02324more than one column in the SELECT list of the THE subquery

Cause: More than one column was selected in the THE subquery.

Action: Specify only one column in the SELECT list of the THE subquery and retry the operation.


ORA-02327

ORA-02327 cannot create index on column with datatype name

Cause: An attempt was made to create an index on a non-indexable column.

Action: Change the column datatype or do not create the index on a column whose datatype is one of VARRAY, nested table, object, LOB, or REF.


ORA-02329

ORA-02329 column of datatype name cannot be unique or a primary key

Cause: An attempt was made to place a UNIQUE or a PRIMARY KEY constraint on a column of datatype VARRAY, nested table, object, LOB, FILE or REF.

Action: Change the column datatype or remove the constraint. Then retry the operation.


ORA-02330

ORA-02330datatype specification not allowed

Cause: An attempt was made to specify the data type in the column constraint specification of an object table.

Action: Remove data type specification and retry the operation.


ORA-02331

ORA-02331 cannot create constraint on column of datatype name

Cause: An attempt was made to create a constraint on a column possessing a non-constrainable datatype -- VARRAY, nested table, object, LOB, FILE, or REF.

Action: Change the column datatype, or remove the constraint.


ORA-02332

ORA-02332cannot create index on attributes of this column

Cause: An attempt was made to create an index on an attributes of an object type column.

Action: Do not specify the index on the attribute.


ORA-02333

ORA-02333cannot create constraints on attributes of this column

Cause: An attempt was made to create a constraint on an attribute of an object type column.

Action: Remove the constraint or change the object type.


ORA-02334

ORA-02334cannot infer type for column

Cause: A datatype was not declared for this column (in the CREATE TABLE) and an attempt was made to create a constraint on an attribute of this column.

Action: Declare a datatype for the column.


ORA-02335

ORA-02335invalid datatype for CLUSTER column

Cause: An attempt was made to declare a CLUSTER column of datatype object, REF, nested table, VARRAY, LOB, or FILE.

Action: Remove the CLUSTER column or change the datatype of the column.


ORA-02336

ORA-02336 column attribute cannot be accessed

Cause: An attempt was made to extract an attribute of an object type column.

Action: Change the object type for the column and retry the operation.


ORA-02337

ORA-02337not an object type column

Cause: An attempt was made to use dotted notation on a non-object type column; that is, "a.b.c" where "a" is not an object type.

Action: Either change the column type to an object type or do not perform this operation.


ORA-02338

ORA-02338missing or invalid column constraint specification

Cause: A column constraint was not specified.

Action: Remove the column specification or specify a column constraint. Then retry the operation.


ORA-02339

ORA-02339invalid column specification

Cause: An attempt was made to specify the PACKED or UNPACKED keyword for a non-object type column.

Action: Remove the PACKED or UNPACKED keyword in the column specification and retry the operation.


ORA-02340

ORA-02340invalid column specification

Cause: An attempt was made to specify an UNPACKED column within a packed table.

Action: Remove the UNPACKED keyword in the column specification.


ORA-02341

ORA-02341 cannot refer to non-queryable type name in SQL

Cause: Attempt to refer to an object type attribute that is of a non-queryable type in SQL.

Action: Change attribute type to a SQL-queryable type, or reference the attribute through a 3GL.


ORA-02342

ORA-02342replacement type causes compilation error

Cause: The use of the ALTER...REPLACE statement on a valid type caused a compilation error.

Action: Use the ALTER...REPLACE statement to replace the type with a valid type which does not cause compilation errors.


ORA-02343

ORA-02343 CASCADE aborted, type(s) have dependent(s) in other schemas

Cause: An attempt was made to cascade drop a user whose type(s) have dependent(s) in other schemas.

Action: The dependent(s) in the other schema must first be dropped before the user can be dropped.


ORA-02344

ORA-02344 cannot revoke execute on a type with table dependents

Cause: An attempt was made to revoke execute on a type that has dependents.

Action: Drop all table(s) depending on the type, then retry the operation, or use the FORCE option.


ORA-02345

ORA-02345cannot create a view with column based on CURSOR operator

Cause: A CURSOR operator was used as one of the SELECT elements in the subquery of a CREATE VIEW or CREATE TABLE ... AS SELECT statement.

Action: Remove the CURSOR operator and replace it with the CAST operator.


ORA-02347

ORA-02347cannot grant privileges on columns of an object table

Cause: An attempt was made to grant privileges on the columns of an object table.

Action: Choose another table. Privileges cannot be granted on columns of an object table.


ORA-02349

ORA-02349 invalid user-defined type - type is incomplete

Cause: An attempt was made to use an incomplete type definition as a column or table datatype.

Action: Complete the type definition and retry the operation.


ORA-02351

ORA-02351record num: Rejected - Error on table name, column name

Cause:The record indicated caused an error on insert.

Action:Determine the error and correct the record.


ORA-02352

ORA-02352direct path connection must be homogeneous

Cause:The user-side to kernel-side connection is heterogeneous.

Action:Check that the connection is between identical hardware and operating systems.


ORA-02353

ORA-02353multibyte character error

Cause:The text specified by POSITION or terminated by new lines is invalid.

Action:Edit the control file or the data file to fix the alignment of the column.


ORA-02354

ORA-02354conversion initialization error occurred on field name

Cause:An error occurred during conversion initialization for a field.

Action:This is an internal error. Contact Worldwide Customer Support.


ORA-02355

ORA-02355conversion error occurred on CONSTANT field str

Cause:A CONSTANT field caused an error; all rows will be rejected.

Action:Determine the ORACLE error and correct the record.


ORA-02356

ORA-02356the database is out of space. The load cannot continue

Cause:The load was discontinued due to space exhaustion in the database.

Action:Add space for the specified table.


ORA-02357

ORA-02357packed decimal conversion error

Cause:The column could not be converted from packed decimal to character.

Action:Check the column and make it conform to packed decimal format.


ORA-02358

ORA-02358zoned decimal conversion error

Cause:The column could not be converted from packed decimal to character.

Action:Check the column and make it conform to packed decimal format.


ORA-02359

ORA-02359field in data file exceeded maximum specified length

Cause:The field is too long for the specified column.

Action:Shorten the field so that the length of the field equals, or is less than, the column length.


ORA-02360

ORA-02360column not found before end of logical record (use TRAILING NULLCOLS)

Cause:A column started after the end of the logical record had been reached.

Action:Use the TRAILING NULLCOLS option or supply data for the column.


ORA-02361

ORA-02361initial enclosing character not found

Cause:The initial enclosing character of an enclosed field was not found.

Action:Supply the character before the start of the field.


ORA-02362

ORA-02362logical record ended - second enclosing character not present

Cause:The second enclosing character of an enclosed field was not found.

Action:Supply the character after the end of the field.


ORA-02363

ORA-02363no terminator found after TERMINATED and ENCLOSED field

Cause:No terminator was found after a terminated and enclosed field.

Action:Supply the terminator after the end of the field.


ORA-02364

ORA-02364record num: Discarded - failed all WHEN clauses

Cause:The record was not loaded because it failed the WHEN clauses of the table.

Action:No user action is required.


ORA-02365

ORA-02365index name was left in Direct Load State due to

Cause:The index was not loaded. The cause of the error is stated after the message.

Action:Correct the cause of the error; then drop and re-create the index.


ORA-02366

ORA-02366the following indexes on table name were processed:

Cause:The indexes listed for the named table were loaded.

Action:No user action required.


ORA-02367

ORA-02367index name was loaded.

Cause:The index specified in the message was loaded.

Action:No user action required.


ORA-02368

ORA-02368record num: Discarded - all columns null.

Cause:The record was not loaded because all of the columns in the table were null for that record.

Action:No user action required.


ORA-02369

ORA-02369warning: Variable length field was truncated

Cause:A variable length field was truncated by the end of the logical record.

Action:Although this is a warning, a variable length field has the length embedded in the data for each row, so check the data.


ORA-02370

ORA-02370record num - Warning on table name, column num

Cause:The record indicated caused a warning.

Action:Determine the warning and correct the record if necessary.


ORA-02371

ORA-02371loader must be at least version num for direct path

Cause:The version of SQL*Loader being used is incompatible with this version of ORACLE.

Action:Upgrade the version of SQL*Loader to at least the specified version or use the conventional path.


ORA-02372

ORA-02372relative start position > absolute field end position

Cause:The relative start of a field specified as POSITION(*+n:y) occurred after the absolute position y.

Action:Check that the values of n and y are correct and that the statement was entered correctly. Also check that all opening delimiters have matching closing delimiters.


ORA-02373

ORA-02373Error parsing insert statement for table name.

Cause:A parsing error occurred.

Action:Check the message following this parsing error message.


ORA-02374

ORA-02374No more slots for read buffer queue

Cause:There are no free read buffers.

Action:Use the READBUFFERS keyword in the loader to increase the number of read buffers.

________________________________________


ORA-02375

ORA-02375record num: Rejected - Error on table name

CauseThe record indicated caused an ORACLE error on insert.

ActionDetermine the ORACLE error and correct the record. The offending column(s) are not known.


ORA-02376

ORA-02376invalid or redundant resource

Cause:A resource that is not defined or specified twice appears in the CREATE or ALTER PROFILE statement.

Action:Define the resource before issuing a CREATE or ALTER PROFILE command. Also check the statement to see that each resource is listed only once.


ORA-02377

ORA-02377invalid resource limit

Cause:An invalid resource limit of 0 was specified.

Action:Specify a resource limit greater than 0.


ORA-02378

ORA-02378duplicate resource name name

Cause:The same resource was specified twice in a CREATE or ALTER PROFILE statement.

Action:Issue the statement again carefully checking that each resource is used only once.


ORA-02379

ORA-02379profile name already exists

Cause:An attempt was made to create a profile that already exists.

Action:Create the profile with a name not already used by another profile.


ORA-02380

ORA-02380profile name does not exist

Cause:An attempt was made to assign a user to a non-existent profile.

Action:Assign the user to an existing profile.


ORA-02381

ORA-02381cannot drop PUBLIC_DEFAULT profile

Cause:An attempt was made to drop PUBLIC_DEFAULT profile.

Action:The PUBLIC_DEFAULT profile cannot be dropped.


ORA-02382

ORA-02382profile name has users assigned, cannot drop without CASCADE

Cause:An attempt was made to drop a profile that has users assigned to it without using the CASCADE option of the DROP PROFILE statement. A profile that has users assigned to it cannot be dropped unless the CASCADE option is specified. CASCADE reassigns users to the PUBLIC_DEFAULT profile before dropping the profile.

Action:To reassign all users to the PUBLIC_DEFAULT profile, issue the DROP PROFILE statement with the CASCADE option.


ORA-02383

ORA-02383illegal cost factor

Cause:A negative value or UNLIMITED cost was specified for this resource in the ALTER RESOURCE COST statement.

Action:Only positive integer values can be specified for resources in the ALTER RESOURCE COST statement. Issue the statement again using a positive integer value for each resource specified.


ORA-02390

ORA-02390exceeded COMPOSITE_LIMIT, logoff in progress

Cause:The COMPOSITE_LIMIT for the profile is exceeded. That is, the weighted sum of the connection time, logical reads per session, CPU usage per session, and private SGA space used during the session exceeded the limit set by the COMPOSITE_LIMIT clause set in the user profile.

Action:If this happens often, ask the database administrator to raise the COMPOSITE_LIMIT of the user profile, or determine which resource is used the most and raise the limit on that resource.


ORA-02391

ORA-02391exceeded simultaneous SESSIONS_PER_USER limit, maximum num

Cause:An attempt was made to exceed the maximum number of concurrent sessions allowed by the SESSIONS_PER_USER clause of the user profile.

Action:End one or more concurrent sessions, or ask the database administrator to increase the SESSIONS_PER_USER limit of the user profile.


ORA-02392

ORA-02392exceeded session limit on CPU usage, logging off

Cause:An attempt was made to exceed the maximum CPU usage allowed by the CPU_PER_SESSION clause of the user profile.

Action:If this happens often, ask the database administrator to increase the CPU_PER_SESSION limit of the user profile.


ORA-02393

ORA-02393exceeded call limit on CPU usage

Cause:An attempt was made to exceed the maximum CPU time for a call (a parse, execute, or fetch) allowed by the CPU_PER_CALL clause of the user profile.

Action:If this happens often, ask the database administrator to increase the CPU_PER_CALL limit of the user profile.


ORA-02394

ORA-02394exceeded session limit on I/O usage, logging off

Cause:An attempt was made to exceed the maximum I/O allowed by the LOGICAL_READS_PER_SESSION clause of the user profile.

Action:If this happens often, ask the database administrator to increase the LOGICAL_READS_PER_SESSION limit of the user profile.


ORA-02395

ORA-02395exceeded call limit on I/O usage

Cause:An attempt was made to exceed the maximum I/O for a call (a parse, execute, or fetch) allowed by the LOGICAL_READS_PER_CALL clause of the user profile.

Action:If this happens often, ask the database administrator to increase the LOGICAL_READS_PER_CALL limit of the user profile.


ORA-02396

ORA-02396exceeded max Idle Time, please connect again

Cause:A user has exceeded the maximum time allowed to remain idle.

Action:The user must reconnect to the database.


ORA-02397

ORA-02397exceeded PRIVATE_SGA Limit, logging off

Cause:This error occurs only when using a multi-threaded server.

Action:Contact the database administrator to expand the PRIVATE_SGA limit.


ORA-02398

ORA-02398exceeded procedure space usage

Cause:Stored procedures used up too much space in the SYSTEM tablespace.

Action:Use fewer stored procedures.


02400-02419: EXPLAIN PLAN Command

This sections lists messages generated when using the SQL EXPLAIN PLAN command.


ORA-02401

ORA-02401cannot EXPLAIN view owned by another user

Cause:The view specified in the user's SQL statement belongs to another user and cannot be explained.

Action:Create a view that has the same definition but belongs to the current user.


ORA-02402

ORA-02402PLAN_TABLE not found

Cause:The PLAN_TABLE used by EXPLAIN to describe the SQL statement does not exist in the current schema.

Action:Create a PLAN_TABLE in the current schema or use the INTO clause to store the EXPLAIN results in a plan table with a different name.


ORA-02403

ORA-02403plan table does not have correct format

Cause:The plan table does not have the appropriate columns.

Action:Redefine the plan table with the appropriate columns.


ORA-02404

ORA-02404specified plan table not found

Cause:The specified plan table cannot be found.

Action:Create the specified plan table or use an existing one.

________________________________________


ORA-02420

ORA-02420missing schema authorization clause

Cause:The schema AUTHORIZATION clause is missing in a CREATE SCHEMA statement.

Action:Check the syntax of the statement, provide a valid schema AUTHORIZATION clause, and re-execute the statement.


ORA-02421

ORA-02421missing or invalid schema authorization identifier

Cause:Either:

·The schema authorization identifier is not recognized.

·An attempt was made to use a schema authorization identifier for a user while not connected as that user.

Action:If the cause is:

·an unrecognized identifier; then use an existing identifier.

·connected with a different user name; then disconnect and connect with the correct user name.


ORA-02422

ORA-02422missing or invalid schema element

Cause:A statement other than a CREATE TABLE, CREATE VIEW, or GRANT appears in a CREATE SCHEMA statement.

Action:See the ORACLE7 Server SQL Language Reference Manual for the valid elements of the CREATE SCHEMA statement.


ORA-02423

ORA-02423schema name does not match schema authorization identifier

Cause:A table definition with a schema name prepended to the table name does not match the schema name provided in the AUTHORIZATION clause of a CREATE SCHEMA STATEMENT.

Action:Make sure the schema names match the one given in the CREATE SCHEMA statement.


ORA-02424

ORA-02424potential circular view references or unknown referenced tables

Cause:The CREATE SCHEMA statement contains a view that depends on other views contained in the CREATE SCHEMA statement or they contain references to non-existing tables.

Action:Create the dependent views in a separate CREATE SCHEMA statement and make sure all referenced tables are either defined in the CREATE SCHEMA statement or exist outside the statement.


ORA-02425

ORA-02425create table failed

Cause:A CREATE TABLE statement failed in the CREATE SCHEMA statement.

Action:The cause for failure will be presented below this message. Follow the appropriate actions as suggested by the subsequent messages.


ORA-02426

ORA-02426privilege grant failed

Cause:A GRANT statement failed in the CREATE SCHEMA statement.

Action:The cause for failure will be presented below this message. Follow appropriate actions as suggested by the subsequent messages.


ORA-02427

ORA-02427create view failed

Cause:A CREATE VIEW statement failed in the CREATE SCHEMA statement.

Action:The cause for failure will be presented below this message. Follow appropriate actions as suggested by the subsequent messages.


ORA-02428

ORA-02428could not add foreign key reference

Cause:ORACLE could not add a foreign key reference because of an error in the declaration. Either the referenced table does not exist or the table does not have a unique key.

Action:Make sure the referenced table exists and/or has a unique key.


ORA-02429

ORA-02429cannot drop index used for enforcement of unique/primary key

Cause:An attempt was made to drop an index that is being used as the enforcement mechanism for a unique or primary key.

Action:Drop the integrity constraint instead of dropping the index.

________________________________________


ORA-02430

ORA-02430cannot enable constraint (name) - no such constraint

Cause:The named constraint does not exist for this table.

Action:Make sure that a constraint exists before trying to enable it.


ORA-02431

ORA-02431cannot disable constraint (name) - no such constraint

Cause:The named constraint does not exist for this table.

Action:Make sure that a constraint exists before trying to disable it.


ORA-02432

ORA-02432cannot enable primary key - primary key not defined for table

Cause:An attempt was made to enable a primary key that is not defined for the table.

Action:Add a primary key definition for the table.


ORA-02433

ORA-02433cannot disable primary key - primary key not defined for table

Cause:An attempt was made to disable a primary key that is not defined for the table.

Action:Make sure that a primary key exists before trying to disable it.


ORA-02434

ORA-02434cannot enable unique(str) - unique key not defined for table

Cause:An attempt was made to enable a unique key that is not defined for the table.

Action:Make sure that a unique key exists before trying to enable it.


ORA-02435

ORA-02435cannot disable unique(str) - unique key not defined for table

Cause:An attempt was made to disable a unique key that is not defined for the table.

Action:Make sure that a unique key exists before trying to disable it.


ORA-02436

ORA-02436date or system variable wrongly specified in CHECK constraint

Cause:An attempt was made to use a date constant or system variable, such as USER, in a check constraint that was not completely specified in a CREATE TABLE or ALTER TABLE statement. For example, a date was specified without the century.

Action:Completely specify the date constant or system variable.


ORA-02437

ORA-02437cannot enable primary key - found duplicates or null values

Cause:An attempt was made to enable a primary key constraint on a column that contains either duplicate values or null.

Action:Remove the duplicate values or null before enabling the primary key constraint.


ORA-02438

ORA-02438column check constraint cannot reference other columns

Cause:An attempt was made to define a column check constraint that references another column.

Action:This is not permitted for column check constraints. Create this constraint as a table check constraint.


ORA-02439

ORA-02439non-unique index exists on unique/primary key constraint

Cause:An attempt was made to enable a primary key or unique constraint on a column that has an existing non-unique index.

Action:Drop the non-unique index on the column, or do not attempt to enable this constraint.


ORA-02440

ORA-02440create as select with referential constraints not allowed

Cause:Integrity constraints on table cannot be created when creating the table using the CREATE TABLE ... AS SELECT ... form.

Action:First, create the table, and then alter the table to add the desired integrity constraints.


ORA-02441

ORA-02441cannot drop nonexistent primary key

Cause:An attempt was made to drop the primary key constraint on a table, but there is no primary key constraint on this table.

Action:Ensure the correct table name is entered in the statement. Otherwise, no user action is required.


ORA-02442

ORA-02442cannot drop nonexistent unique key

Cause:An attempt was made to drop a unique key constraint for a column that does not have a unique key constraint.

Action:Make certain the correct column name was entered. Otherwise, no user action is required.


ORA-02443

ORA-02443cannot drop constraint - nonexistent constraint

Cause:An attempt was made to drop a constraint that does not exist.

Action:Make certain the constraint and table name are correct and attempt the procedure again.


ORA-02444

ORA-02444cannot resolve referenced object in referential constraints

Cause:An attempt was made to define a foreign key with a reference to a schema object that cannot be resolved to a base table reference.

Action:Only define referential constraints with schema objects resolving to a base table.


ORA-02445

ORA-02445Exceptions table not found

Cause:The explicitly or implicitly declared exceptions table does not exist.

Action:If the correct exceptions table name was used; then create the table and issue the enable command again.

________________________________________


ORA-02446

ORA-02446CREATE TABLE ... AS SELECT failed - check constraint violated

Cause:An attempt was made to use a CREATE TABLE... AS SELECT statement when some rows violated one or more CHECK constraints.

Action:Do not select rows that violate constraints.


ORA-02447

ORA-02447cannot defer a constraint that is not deferrable

Cause: An attempt was made to defer a nondeferrable constraint.

Action: Drop the constraint and create a new one that is deferrable.


ORA-02448

ORA-02448constraint does not exist

Cause: The named constraint does not exist.

Action: Stop trying to use a nonexistent constraint.


ORA-02449

ORA-02449 unique/primary keys in table referenced by foreign keys

Cause:An attempt was made to drop a table with unique or primary keys referenced by foreign keys in another table.

Action:Before performing the above operations on the table, drop the foreign key constraints in other tables. You can see what constraints are referencing a table by issuing the following command: SELECT * FROM USER_CONSTRAINTS WHERE TABLE_NAME = "tabnam";


ORA-02450

ORA-02450invalid hash option - missing keyword IS

Cause:The IS keyword is missing from the CREATE CLUSTER command.

Action:Check the syntax of the command and resubmit the statement.


ORA-02451

ORA-02451duplicate HASHKEYS specification

Cause:The HASHKEYS option of the CREATE CLUSTER command is specified more than once.

Action:Check the syntax of the command, make certain to specify the HASHKEYS option only once; then resubmit the command.


ORA-02452

ORA-02452invalid HASHKEYS option value

Cause:The value specified for HASHKEYS must be an integer.

Action:Check the syntax of the command, make certain to specify an integer for the HASHKEYS option; then resubmit the command.


ORA-02453

ORA-02453duplicate HASH IS specification

Cause:The HASH IS option is specified more than once.

Action:Check the syntax of the command, make certain to specify the HASH IS option only once; then resubmit the command.


ORA-02454

ORA-02454number of hash keys per block (num) exceeds maximum of num

Cause:The SIZE option specified for this hashed cluster is to small.

Action:Resubmit the statement using a larger value for the SIZE option.


ORA-02455

ORA-02455the number of cluster key column must be 1

Cause:An attempt was made to create a cluster using the HASH IS option with a number of key columns other than 1. Specify one key column only when using the HASH IS option.

Action:Check the syntax of the command. Either specify only one key column, or do not specify the HASH IS option; then resubmit the command.


ORA-02456

ORA-02456the HASH IS column specification must be NUMBER(*,0)

Cause:The column specification in the command must specify an integer.

Action:Check the syntax of the command, make certain to specify an integer for the column specification; then resubmit the command.


ORA-02457

ORA-02457the HASH IS option must specify a valid column

Cause:An attempt was made to create a cluster with the HASH IS option without specifying a valid column name.

Action:Check the syntax of the command. Specify a valid column name in the statement; then resubmit the statement.


ORA-02458

ORA-02458HASHKEYS must be specified for a HASH CLUSTER

Cause:An attempt was made to create a hash cluster without specifying the HASHKEYS option in the statement.

Action:Check the syntax of the command, specify the HASHKEYS option, and resubmit the command.


ORA-02459

ORA-02459hashkey value must be a positive integer

Cause:The value specified for HASHKEYS was not a positive integer.

Action:Check the syntax of the command, specify only positive integers for the HASHKEYS option; then resubmit the command.


ORA-02460

ORA-02460inappropriate index operation on a hash cluster

Cause:An attempt was made to create a cluster index on a hash cluster.

Action:Creation of cluster indexes on hash clusters is not allowed. Do not attempt to create this index.


ORA-02463

ORA-02463duplicate HASH IS option specified

Cause:The HASH IS option is specified more than once.

Action:Check the syntax of the command, correct the problem, then resubmit the statement.


ORA-02462

ORA-02462duplicate INDEX option specified

Cause:The INDEX option is specified more than once.

Action:Check the syntax of the command, correct the problem, then retry the statement.


ORA-02463

ORA-02463duplicate HASH IS option specified

Cause:The HASH IS option is specified more than once.

Action:Check the syntax of the command, correct the problem, then retry the statement.


ORA-02464

ORA-02464cluster definition cannot be both HASH and INDEX

Cause:Both the HASH IS and INDEX option were specified. Clusters can be either hash or indexed, but not both.

Action:Decide on which type of cluster is to be created, check the syntax of the command; then resubmit the statement.


ORA-02465

ORA-02465inappropriate use of the HASH IS option

Cause:The HASH IS option is only valid for clusters.

Action:Check the syntax of the command, use the HASH IS option only for clusters; then resubmit the command.


ORA-02466

ORA-02466the SIZE option is not allowed to be altered for HASH CLUSTERS

Cause:An attempt was made to change the SIZE option of a hash cluster after the cluster was created.

Action:The SIZE option can be specified only when creating the hash cluster. Do not attempt to alter the SIZE of the cluster.

________________________________________


ORA-02467

ORA-02467column referenced in hash expression not present in cluster

Cause:A column referenced in a hash expression is not present in the cluster definition.

Action:Recreate the cluster and correct the error in the hash expression.


ORA-02468

ORA-02468constant or system variable wrongly specified in expression

Cause:A constant or system variable is specified in the hash expression.

Action:Recreate the cluster and correct the error in the hash expression.


ORA-02469

ORA-02469hash expression does not return an Oracle Number

Cause:The result of evaluating a hash expression is not an Oracle Number.

Action:Recreate the cluster and correct the error in the hash expression.


ORA-02470

ORA-02470TO_DATE, USERENV, or SYSDATE incorrectly used in hash expression

Cause:TO_DATE, USERENV, and SYSDATE are not allowed in hash expressions.

Action:Recreate the cluster and correct the error in the hash expression.


ORA-02471

ORA-02471SYSDATE, UID, USER, ROWNUM, OR LEVEL incorrectly used in hash expression

Cause:SYSDATE, UID, USER, ROWNUM, OR LEVEL are not allowed in hash expression(s).

Action:Recreate the cluster and correct the error in the hash expression.


ORA-02472

ORA-02472PL/SQL functions not allowed in hash expressions

Cause:A PL/SQL function is used in a hash expression.

Action:Recreate the cluster and remove the PL/SQL function.


ORA-02473

ORA-02473error while evaluating the cluster's hash expressions

Cause:An error occurred while evaluating the cluster's hash expression.

Action:Correct the query and retry.


ORA-02474

ORA-02474fixed hash area extents used num exceeds maximum allowed num

Cause:The number of extents required for creating the fixed hash area exceeded the maximum number allowed.

Action:Reduce the number of extents required by increasing the extent allocation sizes within the STORAGE clause.

For more information about hashing and the STORAGE clause, see the index entries on "hash cluster" and on "hashing" in Oracle8 Server Concepts and on "STORAGE clause, of ALTER CLUSTER" in Oracle8 Server SQL Reference.


ORA-02477

ORA-02477cannot perform parallel direct load on object "name"

Cause:A parallel direct load is not possible because an index is being created on the table.

Action:Retry the load after the index creation is complete.


ORA-02478

ORA-02478merge into base segment would overflow MAXEXTENTS limit

Cause:Merge of temporary segment into base segment failed because MAXEXTENTS was larger than the total in the temporary and base segments.

Action:Use a larger value for MAXEXTENTS on the base segment or make the extents in the temporary segments larger.


ORA-02479

ORA-02479error while translating file name for parallel load

Cause:The specified name of the database file to load with data was invalid.

Action:Specify a valid database filename.


ORA-02480

ORA-02480too many event classes specified for events

Cause:Illegal trace enable string.

Action:Enter a legal trace enable control string.


ORA-02481

ORA-02481too many id ranges specified for events

Cause:Illegal trace enable string.

Action:Enter a legal trace enable control string.


ORA-02482

ORA-02482specified an event class but gave no events

Cause:Illegal trace enable string.

Action:Enter a legal trace enable control string.


ORA-02483

ORA-02483illegal ID value specified for events

Cause:Illegal trace enable string.

Action:Enter a legal trace enable control string.


ORA-02485

ORA-02485low ID value is greater than high ID value

Cause:Bad file name given in TRACE_DEST INIT.ORA parameter.

Action:Specify a valid name in the TRACE_DEST INIT.ORA parameter.


ORA-02486

ORA-02486error in file name. Check trace_dest init.ora parm

Cause:Bad file name given in TRACE_DEST INIT.ORA parameter.

Action:Specify a valid name in the TRACE_DEST INIT.ORA parameter.


ORA-02487

ORA-02487error in writing file name name. Check trace_dest init.ora parm

Cause:Bad file name given in TRACE_DEST INIT.ORA parameter.

Action:Specify a valid name in the TRACE_DEST INIT.ORA parameter.


ORA-02489

ORA-02489trace_block_size (num) must be divisible by num

Cause:The INIT.ORA parameter TRACE_BLOCK_SIZE was incorrectly set.

Action:Change the init.ora parameter and restart.


ORA-02490

ORA-02490missing required file size in RESIZE clause

Cause:No value was specified for the RESIZE clause.

Action:Use correct syntax.


ORA-02491

ORA-02491missing required keyword ON or OFF in AUTOEXTEND clause

Cause:The keyword ON or OFF was not specified for the AUTOEXTEND clause.

Action:Use correct syntax.


ORA-02492

ORA-02492missing required file block increment size in NEXT clause

Cause:No value was specified for the NEXT clause.

Action:Use correct syntax.


ORA-02493

ORA-02493invalid file increment size in NEXT clause

Cause:A non-integer value was used for the NEXT clause of the DATAFILE list.

Action:Use correct syntax.


ORA-02494

ORA-02494invalid or missing maximum file size in MAXSIZE clause

Cause:UNLIMITED was not specified, or an invalid integer value was specified, for the MAXSIZE clause in the DATAFILE file list. The MAXSIZE value cannot be smaller than the SIZE value.

Action:Use correct syntax.


ORA-02495

ORA-02495cannot resize file name, tablespace name is read only

Cause:An attempt was made to resize a datafile in a tablespace that was read only.

Action:Change the tablespace to read/write and retry the resize operation.


ORA-03001

ORA-03001unimplemented feature

Cause:An attempt was made to use a feature that is not currently implemented.

Action:Do not attempt to use the feature at this time.


ORA-03002

ORA-03002operator not implemented

Cause:An attempt was made to use an operator that is not currently implemented.

Action:Do not attempt to use the operator at this time.


ORA-03007

ORA-03007obsolete feature

Cause:An attempt was made to use a feature that is no longer supported.

Action:No user action is required.

________________________________________


ORA-03008

ORA-03008parameter COMPATIBLE >= val needed for feature_name

Cause:An attempt was made to use a feature for a later Oracle version than the setting of the initialization parameter, COMPATIBLE.

Action:Set COMPATIBLE to the value in the message, or higher, and retry the command, but be aware that this will limit your downgrade options.


ORA-03100

ORA-03100communication area cannot be allocated; insufficient memory

Cause:An attempt to allocate stack space for communication purposes failed. This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03106

ORA-03106fatal two-task communication protocol error

Cause:The communication path between ORACLE and the user task has stopped. This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03107

ORA-03107oranet buffer underflow

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03108

ORA-03108oranet: ORACLE does not support this interface version

Cause:The version of ORACLE connected to via SQL*Net does not support this version of the SQL*Net protocol.

Action:Upgrade the older version of ORACLE, and try again.


ORA-03109

ORA-03109oranet buffer overflow

Cause:Data being transferred between the user program and ORACLE overflowed the buffer space available. This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03110

ORA-03110oranet: ORACLE does not support this SQL version

Cause:The version of ORACLE connected to via SQL*Net does not support the version of the SQL*Net protocol.

Action:Upgrade the older version of ORACLE, and try again.


ORA-03111

ORA-03111break received on communication channel

Cause:A break was processed on the communications channel; but was not properly handled by SQL*Net software. This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03112

ORA-03112host string syntax error

Cause:In a single-task operation, the internally-generated host string was invalid. This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03113

ORA-03113end-of-file on communication channel

Cause:An unexpected end-of-file was processed on the communication channel; bug could not be handled by the SQL*Net (two task) software. This message could occur if the shadow two-task process associated with a SQL*Net connect has terminated abnormally or there is a physical failure of the interprocess communication vehicle (that is, the network or server machine went down).

Action:If this message occurs during a connection attempt, check the setup files for the appropriate SQL*Net driver and confirm SQL*Net software is correctly installed on the server. If the message occurs after a connection is well established and the error is not due to a physical failure, check if a trace file was generated on the server at failure time. Existence of a trace file may suggest an ORACLE internal error that requires the assistance of Worldwide Customer Support.


ORA-03114

ORA-03114not connected to ORACLE

Cause:A call to ORACLE was attempted when no connection was established. Usually this happens because a user-written program has not logged on. It may also happen if communication trouble causes a disconnection.

Action:Try again. If the message recurs and the program is user-written, check the program.


ORA-03115

ORA-03115unsupported network datatype or representation

Cause:A user bind or define, or an ORACLE function is not supported by this heterogeneous SQL*Net connection.

Action:Upgrade the older version of ORACLE, and try again.


ORA-03116

ORA-03116ttcxxx: invalid buffer length

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03117

ORA-03117ttc save area overflow

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03118

ORA-03118ttc coroutine has invalid state

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03120

ORA-03120ttci2u: integer overflow

Cause:An integer value in an internal ORACLE structure overflowed when being sent or received over a heterogeneous connection. This can happen when an invalid buffer length or too great a row count is specified. It usually indicates a bug in the user application.

Action:Check parameters to ORACLE calls. If the problem recurs, reduce all integer parameters (column values not included) to less than 32767.


ORA-03121

ORA-03121no interface driver connected - function not performed

Cause:This message occurs usually because the SQL*Net driver is not loaded into memory or there is a mismatch of the version of the driver. A user program linked with an obsolete library may also cause this message. Only programs provided by Oracle Corporation should use this interface.

Action:If the message occurred during use of a program provided by Oracle Corporation, contact Worldwide Customer Support. If a user program caused the message, relink the program with current versions of the ORACLE libraries.


ORA-03122

ORA-03122attempt to close ORACLE-side window on user side

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-03123

ORA-03123network read would block

Cause:This is an internal error message not normally issued. The error indicates that no data is ready for a network read operation that was designated as non-blocking. The read operation will be retried later.

Action:No action is necessary. The operation will automatically be retried later.


ORA-03124

ORA-03124async operation interrupted

Cause:A non-blocking network operation was in progress, and a new network operation was attempted before the non-blocking operation was completed.

Action:The network connection must be reset, which will be done automatically; the user should retry the failed operation.


ORA-03125

ORA-03125client-server protocol violation

Cause:The application received a bad escape sequence from the server which may indicate a problem with the client application user code.

Action:Contact your customer support representative.


ORA-03126

ORA-03126network drive does not support non-blocking operations

Cause:A non-block operation was attempted and the network driver does not support non-block operations.

Action:Use the default blocking operations or use a driver supporting non-blocking operations.


ORA-03127

ORA-03127no new operations allowed until active non-blocking operation ends

Cause:An attempt was made to execute a new operation before the active non-blocking operation completed.

Action:Execute the new operation after the non-blocking operation completes.


ORA-03128

ORA-03128connection is in blocking mode

Cause:The OCI test for non-blocking mode on a connection indicates that the connection is in blocking mode.

Action:If non-blocking mode is required, use appropriate OCI calls to change the mode.


ORA-03129

ORA-03129the next piece to be inserted is required

Cause:The application performed a piecewise bind on a column.

Action:Provide the next piece of this bind variable.

For more information about binding variables, see the index entries on "bind operation" and on "input variables, binding address" in the Programmer's Guide to the Oracle Call Interface.


ORA-03130

ORA-03130the buffer for the next piece to be fetched is required

Cause:The application performed a piecewise define on the column.

Action:Provide the next buffer for the next piece to be retrieved.

For more information about define and fetching operations, see the index entries on "define operation" and on "rows, fetching" in the Programmer's Guide to the Oracle Call Interface.


ORA-03131

ORA-03131an invalid buffer was provided for the next piece

Cause:The application either provided the length of the buffer for the next piece to be zero or provided a null pointer.

Action:Verify if the buffer pointer for the next piece is null or if the length is zero.

For more information about fetching operations, see the index entries on "rows, fetching" in the Programmer's Guide to the Oracle Call Interface.


ORA-03201

ORA-03201the group number specification is invalid

Cause:The freelist group number is either negative or larger than the number of freelist groups in the segment.

Action:Use a correct group number.


ORA-03202

ORA-03202the scan limit specification is invalid

Cause:The scan limit does not have a positive integer value greater than the number of freelist groups in the segment.

Action:Use a correct scan limit.


ORA-03203

ORA-03203concurrent update activity makes space analysis impossible

Cause:High volume of user updates interfere with the space analysis.

Action:Retry the command or lock the underlying objects.


ORA-03204

ORA-03204the segment type specification should indicate partitioning

Cause:A partition name was specified for the space analysis, but the object type does not indicate partitioning.

Action:Specify PARTITION in the segment type if the object is partitioned, Otherwise, omit the partition name.


ORA-03205

ORA-03205 partition name is required when partitioned type is specified

Cause: A partition name was not specified for the space analysis, but the object type indicates partitioning.

Action: Specify a partition name if the object is partitioned. Otherwise, specify a non-partitioned type.


ORA-03230

ORA-03230segment only contains num blocks of unused space above high water mark

Cause:An attempt was made to preserve too many blocks.

Action:Reduce the KEEP amount.


ORA-03231

ORA-03231the INITIAL extent may not be deallocated

Cause:An attempt was made to deallocate space in segment which was truncated prior to the 7.3 release.

Action:Increase the KEEP amount, or truncate the segment, and reissue the command.

For more information about the TRUNCATE command, see the index entry on "TRUNCATE command" in Oracle8 Server SQL Reference


ORA-03274

ORA-03274both ALLOCATE EXTENT and DEALLOCATE UNUSED options are specified

Cause:The DEALLOCATE option and the ALLOCATE option were specified in the same command.

Action:Choose one of the options or issue two separate commands.

For more information about the ALLOCATE option, see the index entries on "ALLOCATE EXTENT clause, of ALTER CLUSTER command" and on "ALLOCATE EXTENT clause, of ALTER TABLE command" in Oracle8 Server SQL Reference.


ORA-03275

ORA-03275duplicate DEALLOCATE option specification

Cause:The DEALLOCATE UNUSED option to ALTER TABLE or ALTER INDEX was specified more than once.

Action:Specify the option at most once.

For more information about the DEALLOCATE UNUSED option, see the index entries on "ALTER TABLE" and on "ALTER INDEX" in Oracle8 Server SQL Reference.


ORA-03276

ORA-03276duplicate ALLOCATE EXTENT option specification

Cause:The ALLOCATE EXTENT option to ALTER TABLE is specified more than once.

Action:Specify the option at most once.


ORA-03277

ORA-03277invalid SIZE specified

Cause:The value specified for the SIZE option of the ALTER TABLE ... ALLOCATE EXTENT statement must be a positive integer.

Action:Choose an appropriate integer value.


ORA-03278

ORA-03278duplicate option specified for ALLOCATE EXTENT

Cause:An option (DATA FILE, SIZE, or INSTANCE) was specified more than once in the ALTER TABLE ... ALLOCATE EXTENT statement.

Action:Specify each option at most once.


ORA-03279

ORA-03279invalid INSTANCE specified

Cause:The value specified for the INSTANCE option of the ALTER TABLE ... ALLOCATE EXTENT statement is not valid.

Action:Choose an appropriate INSTANCE specification.


ORA-03280

ORA-03280invalid DATA FILE file name specified

Cause:A character-string literal is expected but not found for the DATA FILE option of the ALTER TABLE ... ALLOCATE EXTENT statement.

Action:Specify the file name using a character-string literal enclosed in single quotes. Query the data dictionary view DBA_DATA_FILES to find the correct names of the data files.


ORA-03281

ORA-03281invalid ALLOCATE EXTENT option

Cause:An option other than DATAFILE, SIZE, or INSTANCE was specified in the ALTER TABLE ... ALLOCATE EXTENT statement.

Action:Remove the invalid option and retry the command.


ORA-03282

ORA-03282missing ALLOCATE EXTENT option

Cause:No ALLOCATE EXTENT options were specified inside the parentheses of the ALTER TABLE ... ALLOCATE EXTENT statement.

Action:If no options are required, do not use parentheses. Otherwise, within parentheses, specify one or more of the following options: DATA FILE, SIZE, or INSTANCE.


ORA-03283

ORA-03283specified data file name does not exist

Cause:The data file specified for the DATA FILE option in the ALTER TABLE ... ALLOCATE EXTENT statement does not exist.

Action:Retry the option with the correct file name for the database file. Query the data dictionary view DBA_DATA_FILES to find the correct names of the data files.


ORA-03284

ORA-03284specified data file name is not a member of tablespace name

Cause:The data file specified in the ALTER TABLE ... ALLOCATE EXTENT statement does not belong to the tablespace in which the table resides.

Action:Retry the option with the correct data file or the correct table. Query the data dictionary view DBA_DATA_FILES to find the correct names of the data files in that tablespace, or query DBA_TABLES to find the correct table name.


ORA-03286

ORA-03286ALLOCATE EXTENT not valid for HASH CLUSTERS

Cause:The cluster is a hash cluster, and cannot use the allocate extent option.

Action:Do not use this command on a hash cluster.


ORA-03287

ORA-03287invalid FREELIST GROUP specified

Cause:The specified FREELIST GROUP number is invalid.

Action:Choose a number between 1 and the number of freelist groups for this object.


ORA-03288

ORA-03288both FREELIST GROUP and INSTANCE parameters may not be specified

Cause:Both FREELIST GROUP and INSTANCE were specified in clause.

Action:Remove one of the two parameters.

________________________________________


ORA-03290

ORA-03290invalid truncate command - missing CLUSTER or TABLE keyword

Cause:An invalid object specification was given for the TRUNCATE command.

Action:Check the syntax of the command and retry the operation specifying either TRUNCATE CLUSTER or TRUNCATE TABLE.


ORA-03291

ORA-03291invalid truncate option - missing STORAGE keyword

Cause:The STORAGE keyword was not specified with the DROP or REUSE options of the TRUNCATE command.

Action:Check the syntax of the command and retry the operation.


ORA-03292

ORA-03292table to be truncated is a member of a cluster

Cause:An attempt was made to truncate a table that is a member of a cluster.

Action:Either truncate the entire cluster, or drop and re-create the individual table.


ORA-03293

ORA-03293cluster to be truncated is a HASH CLUSTER

Cause:An attempt was made to truncate a hash cluster. This is not permitted; only index clusters can be truncated.

Action:Drop and re-create the cluster instead of using the TRUNCATE command.

________________________________________


ORA-03297

ORA-03297file contains num blocks of data beyond requested RESIZE value

Cause:Some portion of the file in the region to be trimmed is currently in use by a database segment.

Action:Drop or move segments containing extents in this region prior to resizing the file, or choose a resize value such that only free space is in the trimmed region.


ORA-03298

ORA-03298cannot shrink datafile - file name is under hot backup

Cause:An attempt was made to shrink a datafile while it was under hot backup. This is not allowed.

Action:Retry shrinking the file after the hot backup completes.

For more information about resizing datafiles, see the index entry "datafiles, automatic extension" in the Oracle8 Server Administrator's Guide and the index entry "resizeable datafiles" in Oracle8 Server Migration.


ORA-03299

ORA-03299cannot create dictionary table name

Cause:A dictionary table is created upon the first execution of the command ALTER DATABASE AUTOEXTEND ON for a database. This operation did not succeed. The most probable cause for this is insufficient space in the system tablespace.

Action:See the accompanying messages and take appropriate action.


ORA-04000

ORA-04000the sum of PCTUSED and PCTFREE cannot exceed 100

Cause:The sum of PCTUSED and PCTFREE specified for a cluster or table exceeds 100.

Action:Create the table or cluster specifying values for PCTUSED and PCTFREE whose sum does not exceed 100.


ORA-04001

ORA-04001 str must be an integer

Cause:The specified sequence parameter was not an integer.

Action:Create the sequence, giving the specified parameter an integer value.


ORA-04002

ORA-04002INCREMENT must be a non-zero integer

Cause:A sequence increment was specified as zero.

Action:Specify the increment as a non-zero value.


ORA-04003

ORA-04003 num exceeds the maximum size allowed (num digits) for sequences

Cause:The specified sequence parameter has too many digits.

Action:Specify the parameter with the allowed number of digits, and try again.


ORA-04004

ORA-04004MINVALUE must be less than MAXVALUE

Cause:MINVALUE was specified to be greater than or equal to MAXVALUE.

Action:Specify a MINVALUE that is less than MAXVALUE, and try again.


ORA-04005

ORA-04005INCREMENT must be less than MAXVALUE minus MINVALUE

Cause:INCREMENT was specified as equal to or greater than MAXVALUE minus MINVALUE. This is not permitted.

Action:Specify INCREMENT as less than MAXVALUE minus MINVALUE, and try again.


ORA-04006

ORA-04006START WITH cannot be less than MINVALUE

Cause:The given starting value is less than MINVALUE.

Action:Make sure the starting value is not less than MINVALUE, and try again.


ORA-04007

ORA-04007MINVALUE cannot be made to exceed the current value

Cause:The given MINVALUE is greater than the current value.

Action:Make sure MINVALUE is not greater than the current value, and try again.


ORA-04008

ORA-04008START WITH cannot be more than MAXVALUE

Cause:The starting value is larger than MAXVALUE.

Action:Make sure the starting value is less than MAXVALUE, and try again.


ORA-04009

ORA-04009MAXVALUE cannot be made to be less than the current value

Cause:The current value exceeds the given MAXVALUE.

Action:Make sure the new MAXVALUE is larger than the current value, and try again.


ORA-04010

ORA-04010the number of values to CACHE must be greater than 1

Cause:The value specified in the CACHE clause of a CREATE SEQUENCE statement is 1. (The default value is 20.)

Action:Specify NOCACHE, or a value greater than 1, and try again.


ORA-04011

ORA-04011sequence name must range between num and num

Cause:The value specified for one of the sequence parameters exceeds limits.

Action:Specify a parameter within these limits.


ORA-04012

ORA-04012object is not a sequence

Cause:The object specified cannot have sequence operations performed on it.

Action:Re-enter the statement, making sure to spell the sequence name correctly.


ORA-04013

ORA-04013number to CACHE must be less than one cycle

Cause:The number to CACHE specified in a CREATE SEQUENCE statement exceeds the number of values in a cycle.

Action:Enlarge the cycle, or cache fewer values, and try again.


ORA-04014

ORA-04014[de][a]scending sequences that CYCLE must specify [NO][MIN][MAX] VALUE

Cause:A value was not specified in the CREATE SEQUENCE statement. Sequences that cycle must specify a value at which to begin again.

Action:Re-create the sequence, specifying the value at which it is to begin.

________________________________________


ORA-04015

ORA-04015ascending sequences that CYCLE must specify MAX VALUE

Cause:A value was not specified in the CREATE SEQUENCE statement. Sequences that cycle must specify a value at which to begin again.

Action:Recreate the sequence, specifying the value at which it is to begin.


ORA-04016

ORA-04016sequence name no longer exists

Cause:Sequence was dropped while processing its next value.

Action:Recreate the sequence


ORA-04017

ORA-04017 invalid value num (length = num) for parameter MAX_DUMP_FILE_SIZE

Cause: Neither did the string supplied for MAX_DUMP_FILE_SIZE parameter match the UNLIMITED string value nor did it represent a base 10 integer.

Action: Assign a valid value to this parameter.


ORA-04021

ORA-04021time-out occurred while waiting to lock object name

Cause:While trying to lock a library object, a time-out occurred.

Action:Retry the operation later.


ORA-04022

ORA-04022no wait requested, but had to wait to lock dictionary object

Cause: Had to wait to lock a library object during a no wait request.

Action: Retry the operation later.


ORA-04028

ORA-04028cannot generate diana for object name

Cause:A lock conflict prevented the generation of diana for an object.

Action:Check the syntax. If no syntax errors are found, report this error to Oracle World Wide Support.

For more information about locks, see the index entry on "lock" in Oracle8 Server SQL Reference.


ORA-04029

ORA-04029error ORA-num occurred when querying 'string'

Cause:The table or view being queried might be missing. Look up the ORA-num indicated in the message.

Action:Fix the error.

________________________________________


ORA-04030

ORA-04030out of process memory when trying to allocate num bytes (str)

Cause:Operating system process private memory has been exhausted.

Action:See the database administrator or operating system administrator to increase process memory quota. There may be a bug in the application that causes excessive allocations of process memory space.


ORA-04031

ORA-04031out of shared memory when trying to allocate num bytes (str)

Cause:More shared memory is needed than was allocated in the SGA.

Action:Reduce use of shared memory, or increase the amount of available shared memory by increasing the value of the initialization parameter SHARED_POOL_SIZE.

________________________________________


ORA-04040

ORA-04040new time-stamp is not greater than existing one

Cause:The given time-stamp is not greater than the current time-stamp of the existing object.

Action:Specify a later time-stamp.


ORA-04041

ORA-04041package specification must be created first before creating package body

Cause:An attempt was made to create a package body before creating its package specification.

Action:Create the package specification before trying to create the package body.


ORA-04042

ORA-04042procedure, function, package, or package body does not exist

Cause:An attempt was made to access a procedure, function, package, or package body that does not exist.

Action:Ensure the name specified is correct.


ORA-04043

ORA-04043object name does not exist

Cause:An attempt was made to access a table, view, sequence, procedure, function, package, or package body that does not exist.

Action:Ensure the name of the object is correct.


ORA-04044

ORA-04044procedure, function, or package is not allowed here

Cause:An attempt was made to specify a procedure, function, or package in an inappropriate place in a statement.

Action:Refer to the ORACLE7 Server SQL Language Reference Manual for the correct placement of procedures, functions, and packages in statements.


ORA-04045

ORA-04045errors during recompilation/revalidation of name.name

Cause:Errors occurred during the implicit recompilation/revalidation of the object named in the message.

When Trusted ORACLE7 is configured in OS MAC mode, you may get this error if you attempt to select from a view that needs to be recompiled. In particular, if the view is on a lower database and a higher database selects from this view this error can occur.

Action:More descriptive messages follow this one. Check the causes mentioned in the messages that follow and take the appropriate actions.

For Trusted ORACLE7 users, if the cause is that the view needs to be recompiled, ensure that it is recompiled before it is selected.


ORA-04046

ORA-04046results of compilation are too large to support

Cause:An attempt to compile and store a large stored procedure resulted in compilation data that is too large for the system to support or store.

Action:Reduce the size of the store procedure by splitting it into smallerstored procedures.


ORA-04050

ORA-04050invalid or missing procedure, function, or package name

Cause:The required procedure, function, or package name is invalid or missing.

Action:Specify a valid name.


ORA-04051

ORA-04051user name cannot use database link name

Cause:An attempt was made to access a non-existent database link, or a link not owned by the user logging in or PUBLIC, while attempting to access a remote object.

Action:Change the database link structure so all indirect remote access requests are done from the same user originating the request (or PUBLIC).


ORA-04052

ORA-04052error occurred when looking up remote object name

Cause:An error occurred looking up a remote object.

Action:Fix the error. Make sure the remote database system has run the script to create necessary views used for querying/looking up objects stored in the database. See the ORACLE7 Server Administrator's Guide.


ORA-04053

ORA-04053error occurred when validating remote object name

Cause:An error occurred trying to validate a remote object.

Action:Fix the error. Make sure the remote database system has run the script to create necessary views used for querying/looking up objects stored in the database. See the ORACLE7 Server Administrator's Guide.


ORA-04054

ORA-04054database link name does not exist

Cause:During compilation of a PL/SQL block, an attempt was made to use a non-existent database link.

Action:Either use a different database link or create the database link.


ORA-04055

ORA-04055package STANDARD@name is incompatible to local package STANDARD

Cause:An attempt was made to compile a remote procedure call but the remote procedure was compiled using a package STANDARD that has a different time-stamp from the one of the local package STANDARD; therefore, those package STANDARDs are incompatible with each other, and PL/SQL packages, procedures, and functions compiled against the remote package STANDARD are also incompatible with those compiled against the local package STANDARD.

Action:Upgrade either the local database or the remote database (whichever is older) to the same version.


ORA-04060

ORA-04060insufficient privileges to execute name

Cause:An attempt was made to execute a stored procedure without sufficient privileges.

Action:Obtain the necessary privileges through direct grants of the privileges (not through roles).


ORA-04061

ORA-04061existing state of name has been invalidated

Cause:An attempt was made to resume the execution of a stored procedure using the existing state which has become invalid or inconsistent because the stored procedure has been altered or dropped.

Action:Attempt the action again. This action should cause the existing state of all packages to be reinitialized.


ORA-04062

ORA-04062time-stamp of name has been changed

Cause:An attempt was made to execute a stored procedure to service a remote procedure call stub which specifies a time-stamp that is different from the current time-stamp of the procedure.

Action:Recompile the caller to obtain the new time-stamp.


ORA-04063

ORA-04063 name has errors

Cause:An attempt was made to execute a stored procedure that has errors. For stored procedures, the problem could be syntax or references to other, non-existent procedures. For views, the problem could be a reference in the view's defining query to a non-existent table.

Action:Fix the errors and create referenced objects as necessary.


ORA-04064

ORA-04064not executed, invalidated name

Cause:An attempt was made to execute a stored procedure that has been invalidated.

Action:Recompile the procedure and its dependents.


ORA-04065

ORA-04065not executed, altered or dropped name

Cause:An attempt was made to execute a stored procedure that has been altered or dropped.

Action:Recompile the procedure's dependents.


ORA-04066

ORA-04066non-executable object, name

Cause:An attempt was made to execute an object that is not a package, procedure, or function.

Action:Ensure that a correct name is used.


ORA-04067

ORA-04067not executed, name does not exist

Cause:An attempt was made to execute a package, procedure, or function that does not exist.

Action:Check the name in the command.


ORA-04068

ORA-04068existing state of packages has been discarded

Cause:An error occurred when attempting to execute a stored procedure.

Action:Refer to the accompanying messages and fix the error mentioned. Try the procedure again after proper re-initialization of any application's state.

________________________________________


ORA-04070

ORA-04070invalid trigger name

Cause:An invalid trigger name was specified.

Action:Check to see that the trigger name is not a reserved keyword.


ORA-04071

ORA-04071missing BEFORE or AFTER keyword

Cause:The trigger statement is missing the BEFORE/AFTER clause.

Action:Specify either BEFORE or AFTER.


ORA-04072

ORA-04072invalid trigger type

Cause:An invalid trigger type was given.

Action:Specify either INSERT, UPDATE, or DELETE as the trigger type.


ORA-04073

ORA-04073column list not valid for this trigger type

Cause:A column list was specified for a trigger type other than UPDATE.

Action:Remove the column list from the trigger.


ORA-04074

ORA-04074invalid REFERENCING name

Cause:An invalid name was given in the REFERENCING clause.

Action:Verify that the REFERENCING name is not a reserved word.


ORA-04075

ORA-04075invalid trigger action

Cause:A statement was given for the trigger action.

Action:Specify another trigger action that is not a statement.


ORA-04076

ORA-04076invalid NEW or OLD specification

Cause:An invalid NEW or OLD specification was given for a column.

Action:Specify the column again using a correct NEW or OLD specification.


ORA-04077

ORA-04077WHEN clause cannot be used with table level triggers

Cause:The WHEN clause can only be specified for row-level triggers.

Action:Remove the WHEN clause, or specify it for each row.


ORA-04078

ORA-04078OLD and NEW values cannot be identical

Cause:The REFERENCING clause specifies identical values for NEW and OLD.

Action:Specify the REFERENCING clause again with a different value for either NEW or OLD.


ORA-04079

ORA-04079invalid trigger specification

Cause:The CREATE TRIGGER statement is invalid.

Action:Refer to the ORACLE7 Server SQL Language Reference Manual for the correct syntax of the CREATE TRIGGER statement.


ORA-04080

ORA-04080trigger name does not exist

Cause:The trigger name specified is invalid or the trigger does not exist.

Action:Check the trigger name.


ORA-04081

ORA-04081trigger name already exists

Cause:The trigger name or type already exists.

Action:Use a different trigger name or drop the trigger that is of the same type.


ORA-04082

ORA-04082NEW or OLD references not allowed in table level triggers

Cause:The trigger is accessing NEW or OLD values in a table trigger.

Action:Remove any new or old references.


ORA-04083

ORA-04083invalid trigger variable 'name'

Cause:The variable referenced in the trigger body is invalid.

Action:See the ORACLE7 Server SQL Language Reference Manual for valid trigger variable types.


ORA-04084

ORA-04084cannot change trigger NEW values in after row triggers

Cause:New trigger variables can only be changed in before-row triggers.

Action:Change trigger type or remove the variable reference.


ORA-04085

ORA-04085cannot change the value of an OLD reference variable

Cause:OLD values can only be read and not changed.

Action:Do not attempt to change an OLD variable.


ORA-04086

ORA-04086trigger description too long, move comments into triggering code

Cause:The trigger description is limited to 2000 characters, for dictionary storage reasons. The description does not include the text of the "when" clause or the text of the PL/SQL code executed for the trigger.

Action:If the trigger description contains a large comment, move that comment into the PL/SQL code for the trigger.


ORA-04087

ORA-04087cannot change the value of ROWID reference variable

Cause:ROWIDs can only be read and not changed.

Action:Do not attempt to change a ROWID value.


ORA-04088

ORA-04088error during execution of trigger 'str.name'

Cause:A runtime error occurred during execution of a trigger.

Action:Check the triggers that were involved in the operation.


ORA-04089

ORA-04089cannot create triggers on objects owned by SYS

Cause:An attempt was made to create a trigger on an object owned by SYS.

Action:Do not create triggers on objects owned by SYS.


ORA-04090

ORA-04090'name' specifies same table, event and trigger time as 'name'

Cause:The named trigger has a duplicate event and trigger time as another trigger.

Action:Combine both triggers into one trigger.


ORA-04091

ORA-04091 name is mutating, trigger may not read or modify it

Cause:A trigger attempted to look at (or modify) a table that was in the middle of being modified by the statement that fired it.

Action:Rewrite the trigger so that it does not call that table.


ORA-04092

ORA-04092cannot COMMIT or ROLLBACK in a trigger

Cause:A trigger attempted to COMMIT or ROLLBACK. This is not permitted.

Action:Rewrite the trigger so that COMMIT or ROLLBACK statements are not used.


ORA-04093

ORA-04093references to columns of type LONG are not allowed in triggers

Cause:A trigger attempted to reference a LONG column in the triggering table.

Action:Do not reference the LONG column.


ORA-04094

ORA-04094 name is constraining, trigger may not modify it

Cause:A trigger attempted to modify a table that was constraining for some referential constraint of a parent SQL statement.

Action:Rewrite the trigger so that it does not modify that table.


ORA-04095

ORA-04095trigger "name" already exists on another table, cannot replace

Cause:An attempt was made to replace a trigger that exists on another table.

Action:Re-create the trigger on the other table using the CREATE OR REPLACE TRIGGER statement.

________________________________________


ORA-04096

ORA-04096trigger name has a WHEN clause that is larger than 2K

Cause:A trigger's WHEN clause is limited to 2K for dictionary storage reasons.

Action:Use a smaller WHEN clause. Note, the trigger body could perform the same limiting action as the WHEN clause.


ORA-04097

ORA-04097error while trying to keep trigger name

Cause:An error occurred while trying to keep a trigger pinned in the shared pool.

Action:Check the trigger for possible syntax errors.


ORA-04098

ORA-04098trigger name is invalid and failed re-validation

Cause:A trigger was attempted to be retrieved for execution and was found to be invalid. This also means that compilation/authorization failed for the trigger.

Action:The options are to resolve the compilation/authorization errors, disable the trigger, or drop the trigger.

For more information about enabling and disabling triggers, see the index entries on "enabling, triggers," "disabling, triggers," and "DROP TRIGGER command" in Oracle8 Server SQL Reference.


ORA-04099

ORA-04099trigger name is valid but not stored in compiled form

Cause:A trigger was attempted to be retrieved for execution and was found to be valid, but not stored. This may mean the an upgrade was done improperly from a non-stored trigger release.

Action:Execute the ALTER <triggername> COMPILE command to compile the trigger. The trigger will then be in stored form. Also, you may want to review that a proper upgrade was done.

For more information about ALTER TRIGGER, see the index entry on "ALTER TRIGGER" in Oracle8 Server SQL Reference.


ORA-06102

ORA-06102:NETTCP: cannot allocate context area

Cause:The dynamic memory available for the connection context area is insufficient.

Action:Contact your Oracle Customer Support representative.


ORA-06105

ORA-06105:NETTCP: remote host is unknown

Cause:The host name specified in the login (connect) string is unknown.

Action:Verify the spelling of the host name. Make sure the name exists in the TCP/IP HOST file, and try again.


ORA-06106

ORA-06106:NETTCP: socket creation failure

Cause:The process open file quota was probably exceeded.

Action:Contact your Oracle Customer Support representative.


ORA-06107

ORA-06107:NETTCP: ORACLE network server not found

Cause:The entry for ORACLE server in the SERVICES file is missing.

Action:Add "orasrv" to the TCP/IP SERVICES file.


ORA-06108

ORA-06108:NETTCP: connect to host failed

Cause:The attempt to connect to a remote host has failed. The SQL*Net TCP/IP server on the remote host is not up, or the host itself is not up. Check the latter possibility by targeting it with Telnet.

Action:Start the SQL*Net TCP/IP server process on the remote host.


ORA-06109

ORA-06109:NETTCP: message receive failure

Cause:An I/O error occurred while attempting a network read operation.

Action:Contact your Oracle Customer Support representative.


ORA-06110

ORA-06110:NETTCP: message send failure

Cause:An I/O error occurred while attempting a network write operation.

Action:Contact your Oracle Customer Support representative.


ORA-06111

ORA-06111:NETTCP: disconnect failure

Cause:An error occurred while attempting to close a socket.

Action:Contact your Oracle Customer Support representative.


ORA-06112

ORA-06112:NETTCP: invalid buffer size

Cause:The buffer size specified in the login string exceeds 4096.

Action:Specify the correct buffer size (4096 or less in length).


ORA-06113

ORA-06113:NETTCP: Too many connections

Cause:The number of concurrently open connections has exceeded the maximum.

Action:Close a connection by exiting an application with an open connection that is no longer needed.


ORA-06114

ORA-06114:NETTCP: SID lookup failure

Cause:The database SID specified in the login (connect) string was not recognized (from the remote host's SQL*Net TCP/IP server).

Action:Add the appropriate SID entry to the parameter file on the remote host, then restart the SQL*Net TCP/IP server.


ORA-06115

ORA-06115:NETTCP: unable to create ORACLE logicals

Cause:The host's SQL*Net TCP/IP server was unable to create the necessary logicals required by the ORACLE server process.

Action:See the SQL*Net TCP/IP server log file for more information. Contact your system administrator.


ORA-06116

ORA-06116:NETTCP: unable to create ORASRV process

Cause:The host's SQL*Net TCP/IP server was unable to create the ORACLE server process.

Action:See the SQL*Net TCP/IP server log file for more information. Contact your system administrator.


ORA-06117

ORA-06117:NETTCP: unable to create ORASRV: quota exceeded

Cause:The host's SQL*Net TCP/IP server was unable to create the ORACLE server process because of quota depletion.

Action:Increase the quota allocations to the SQL*Net TCP/IP server process.


ORA-06118

ORA-06118:NETTCP: unable to complete handshake with ORASRV

Cause:The ORACLE server process was started but failed to complete its initialization.

Action:Contact your Oracle Customer Support representative.


ORA-06119

ORA-06119:NETTCP: spurious client request

Cause:The host's SQL*Net TCP/IP server was unable to recognize the connection request.

Action:See the SQL*Net TCP/IP server log file for more information. Contact your Oracle Customer Support representative.


ORA-06120

ORA-06120:NETTCP: network driver not loaded

Cause:The TCP/IP network driver is not loaded.

Action:Verify that the TCP/IP driver loads correctly.


ORA-06121

ORA-06121:NETTCP: access failure

Cause:The host's SQL*Net TCP/IP server was unable to test the accessibility of the SID mapping file (specified in the configuration file) associated with this connection request.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06122

ORA-06122:NETTCP: setup failure

Cause:The host's SQL*Net TCP/IP server was unable to set up the appropriate environment to service this connection request.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06123

ORA-06123:NETTCP: cannot set KEEPALIVE

Cause:The host's SQL*Net TCP/IP server was unable to set the socket KEEPLIVE option.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06124

ORA-06124:NETTCP: timeout waiting for ORASRV

Cause:The ORACLE server process was started but failed to respond after a period of time (n seconds).

Action:This failure can occur on heavily-loaded systems. Increase the value of n (the default is 30) by adding the following entry in the initialization parameter file:

SQLNET ORASRV_WAIT = number


ORA-06125

ORA-06125:NETTCP: ORASRV exited unexpectedly

Cause:The ORACLE server process was started but exited unexpectedly.

Two possible causes:

1. There were insufficient quotas to run ORASRV on the ORACLE server.

2. ORACLE is not installed.

Action:See the ORASRV output file for more information. The ORASRV output file resides in the ORA_SQLNET directory and has a name in the following form:

ORA_SRVTnn_[SID].OUT

If the ORASRV output file does not indicate the appropriate action, contact your Oracle Customer Support representative.


ORA-06126

ORA-06126:NETTCP: ORASRV unable to open network connection

Cause:The ORACLE server process was started but was unable to open the socket that TCPSRV passed to it.

Action:Contact your Oracle Customer Support representative.


ORA-06127

ORA-06127:NETTCP: unable to change username

Cause:The host's SQL*Net TCP/IP server could not establish a Proxy login connection because the client username is unknown to the host operating system.

Action:Create new user account on the host and retry the connection.


ORA-06128

ORA-06128:NETTCP: unable to create mailbox

Cause:The host's SQL*Net TCP/IP server was unable to create a mailbox needed for IPC communication with the ORACLE server process.

Action:See the SQL*Net TCP/IP server log file for more information. Contact your Oracle Customer Support representative.


ORA-06129

ORA-06129:NETTCP: unable to transfer socket ownership to ORASRV

Cause:The host's SQL*Net TCP/IP server was unable to transfer the network communication handle to the ORACLE server process.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06130

ORA-06130:NETTCP: host access denied

Cause:The host's SQL*Net TCP/IP server rejected this connection request because the client node does not have sufficient access privileges.

Action:To grant access, add the appropriate entry to the host's VNT.


ORA-06131

ORA-06131:NETTCP: user access denied

Cause:The host's SQL*Net TCP/IP server rejected this connection request because the client username does not have sufficient access privileges. Privileges are determined by the contents of the Username Mapping Table (UMT), a subset of the host's configuration parameters.

Action:To grant access, add the appropriate entry to the host's UMT.


ORA-06132

ORA-06132:NETTCP: access denied, wrong password

Cause:The host SQL*Net TCP/IP server rejected this connection request because the client password did not match the host password.

Action:To grant access, make sure the passwords are the same.


ORA-06133

ORA-06133:NETTCP: file not found

Cause:The host's SQL*Net TCP/IP server could not find the SID mapping file associated with this connection request.

Action:Verify the spelling and existence of the SID mapping file.


ORA-06134

ORA-06134:NETTCP: file access privilege violation

Cause:The host's SQL*Net TCP/IP server did not have READ/EXECUTE permissions for the SID mapping file associated with this connection request.

Action:Change the protection on the SID mapping file.


ORA-06135

ORA-06135:NETTCP: connection rejected; server is stopping

Cause:The host's SQL*Net TCP/IP server rejected this connection request because the server is in the process of stopping.

Action:Restart SQL*Net TCP/IP server.


ORA-06136

ORA-06136:NETTCP: error during connection handshake

Cause:A network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06137

ORA-06137:NETTCP: error during connection handshake

Cause:A network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06138

ORA-06138:NETTCP: error during connection handshake

Cause:A network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06140

ORA-06140:NETTCP: no such user

Cause:A Proxy login connect attempt failed because the client username is not defined on the host.

Action:Contact your network administrator.


ORA-06141

ORA-06141:NETTCP: no privilege for user

Cause:A proxy login connect attempt failed because the SQL*Net TCP/IP server had insufficient privileges to access the proxy account.

Action:Change the account protection, change the server privileges, or both.


ORA-06142

ORA-06142:NETTCP: error getting user information

Cause:A proxy login connect attempt failed because the SQL*Net TCP/IP server was unable to access the proxy account.

Action:Check the log file for the operating system-specific error code. Contact your Oracle Customer Support representative.


ORA-06143

ORA-06143:NETTCP: maximum connections exceeded

Cause:The connect failed because the number of concurrent connections has exceeded the maximum supported by the host's SQL*Net TCP/IP server.

Action:Wait for a short period and retry the operation.


ORA-06144

ORA-06144:NETTCP: SID (database) is unavailable

Cause:The database administrator on the host has taken the database to which you are requesting access offline.

Action:Wait for it to be brought back online.


ORA-06145

ORA-06145:NETTCP: unable to start ORASRV: images not installed

Cause:The host's SQL*Net TCP/IP server was unable to start the ORACLE server process because the ORACLE protected images were not installed.

Action:Install the images.


ORA-06165

ORA-06165 datafile name is too old to recover, restore a more recent copy

Cause: The archived logs and/or incremental backup sets required to recover the datafile do not exist, but a more recent backup of the datafile exists which can be recovered.

Action: Issue a RESTORE for the datafile, then reissue the RECOVER command.


ORA-06166

ORA-06166 datafile name cannot be recovered

Cause: Incremental backups or archived redo logs needed to recover the datafile cannot be found, and no recoverable full backup or datafile copy exists.

Action: Use the LIST command to see if there is a backup set or datafile copy that can be made AVAILABLE. If not, then the datafile is unrecoverable. If a full or datafile copy exists, then a point-in-time recovery may be possible.


ORA-06167

ORA-06167 already connected

Cause: A CONNECT command was issued, but RMAN is already connected to the specified database.

Action: RMAN has no DISCONNECT command, so to connect to a different instance, exit RMAN and start it again.


ORA-06168

ORA-06168 no backup pieces with this tag found: name

Cause:A tag was used to specify a list of backup pieces, but no backup pieces with this tag could be found.

Action: Make sure the tag is specified correctly.


ORA-06169

ORA-06169 could not read file header for datafile %s error reason %s

Cause: The specified datafile could not be accessed. The reason codes are:

1 - filename is MISSINGxx in the controlfile

2 - file is offline

3 - file is not verified

4 - DBWR could not find the file

5 - unable to open file

6 - I/O error during read

7 - file header is corrupt

8 - file is not a datafile

9 - file does not belong to this database

10 - file number is incorrect

12 - wrong file version

15 - controlfile is not current

Action: If the error can be corrected, do so and retry the operation. The SKIP option can be used to ignore this error during a backup.


ORA-06170

ORA-06170 no controlfile copy found with offline range recid num stamp name datafile name

Cause: This offline range is needed for recovering the specified datafile, but the offline range record has aged out of the current controlfile and no controlfile copy with the record could be accessed. At least 1 controlfile copy containing the offline range was found in the recovery catalog and was in AVAILABLE status.

Action: Query the RC_CONTROLFILE_COPY view for the names of all controlfile copies, then issue a CHANGE CONTROLFILECOPY ... VALIDATE; command for them. Then reissue the RECOVER command.


ORA-06171

ORA-06171not connected to target database

Cause: A command was issued but no connection to the target database has been established.

Action: Issue a CONNECT TARGET command to connect to the target database.


ORA-06172

ORA-06172 not connected to recovery catalog database

Cause: A command was issued but no connection to the recovery catalog database has been established.

Action: Issue a CONNECT RCVCAT command to connect to the recovery catalog database. If you are not have a recovery catalog, then you must use the NOCATALOG option when starting RMAN.


ORA-06173

ORA-06173: no set newname command has been issued for datafile name when restore clone

Cause: Clone type was specified for the controlfile, but no SET NEWNAME command has been previously issued for a datafile.

Action:Issue SET NEWNAME command for every datafile in the recovery set.


ORA-06220

ORA-06220:NETNMP: Server not specified in command line

Cause:A server name is not specified in the DOS command-line after "p:".

Action:Specify the server name after the network prefix and retry, or set the LOCAL or REMOTE parameter in your configuration parameter file.


ORA-06221

ORA-06221:NETNMP: Named pipe busy

Cause:All available Named Pipes instances are in use.

Action:Close any unused connections and retry the operation.


ORA-06222

ORA-06222:NETNMP: Error allocating memory

Cause:The system is unable to allocate memory block.

Action:Resubmit the entry. If the error persists, contact your DBA.


ORA-06223

ORA-06223:NETNMP: Error receiving data from pipe

Cause:Oracle encountered an error when receiving data from the pipe.

Action:Check all LAN connections and cables. If any connections are loose, secure them and retry. Otherwise, reboot your machine and reload the SQL*Net Named Pipes driver. If the error persists, contact your DBA.


ORA-06224

ORA-06224:NETNMP: Error sending data to pipe

Cause:The system encountered an error sending data to the pipe.

Action:Check all LAN connections and cables. If any connections are loose, secure them and retry. Otherwise, reboot the machine and reload the SQL*Net Named Pipes driver. If the error persists, contact your DBA.


ORA-06225

ORA-06225:NETNMP: Invalid packet type

Cause:The system received erroneous data.

Action:Check all LAN connections and cables. If any connections are loose, secure them and retry. Otherwise, reboot the machine and reload the SQL*Net Named Pipes driver. If the error persists, contact your DBA.


ORA-06226

ORA-06226:NETNMP: Send byte count error

Cause:An error was encountered in sending data.

Action:Check all LAN connections and cables. If any connections are loose, secure them and retry. Otherwise, reboot the machine and reload the SQL*Net Named Pipes driver. If the error persists, contact your DBA.


ORA-06227

ORA-06227:NETNMP: Error resetting connection

Cause:The system encountered an error when resetting the connection.

Action:Check all LAN connections and cables. If any connections are loose, secure them and retry. Otherwise, reboot the machine and reload the SQL*Net Named Pipes driver. If the error persists, contact your DBA.


ORA-06228

ORA-06228:NETNMP: Unable to open named pipe

Cause:Either your workstation is not logged on to a valid account, or you are using the wrong version of LAN Manager software or the SQL*Net Named Pipes driver.

Action:Log onto a valid account (do not use the default guest account). If the problem reappears, contact your DBA.


ORA-06229

ORA-06229:NETNMP: Windows NT failed to create or access shared memory

Cause:Unable to open shared memory segment containing the connection status of Oracle Server.

Action:Ensure that Oracle Server has been started properly so that the shared memory segment is available.


ORA-06230

ORA-06230:NETNMP: SQL*Net handshake error

Cause:An error occurred during the SQL*Net handshake between the client and Oracle Server.

Action:Ensure pipe has been created successfully. Check SQL*Net versions on server and client machines and reinstall same versions if different.


06401-06429:SQL*Net NETCMN

This section lists messages that might arise from using SQL*Net. Each message code has the format ORA- nnnnn, where nnnnn is an integer. Each message description lists possible causes for the message and suggests correctve action.

The messages listed here are not duplicated in the Oracle7 Server Messages and Codes Manual.

________________________________________


ORA-06232

ORA-06232Named Pipes Driver: Error return from 'Make Named Pipe'.

Cause:The server process 'nmpsrv' was not able to create the required Named Pipe(s).

Action:Check for root privileges on the 'nmpsrv' executable and check if LAN Manager is operational.


ORA-06233

ORA-06233Named Pipes Driver: The server process 'nmpsrv' is not running.

Cause:The Named Pipes server process was not started.

Action:Start the server with the 'nmpctl start' command.


ORA-06401

ORA-06401:NETCMN: invalid driver designator

Cause:The specified driver is unknown.

Action:Check the last entry and resubmit the connect string using the designated name for the SQL*Net driver.


ORA-06402

ORA-06402:NETCMN: error receiving break message

Cause:The SQL*Net driver detected that its server has unexpectedly exited.

Action:Check the network operating system and resubmit the connect string.


ORA-06403

ORA-06403:NETCMN: cannot allocate context area

Cause:The SQL*Net driver could not allocate heap space for the context area.

Action:Re-submit the connect string. Contact your DBA.


ORA-06404

ORA-06404:NETCMN: invalid login string

Cause:The SQL*Net driver detected a syntax error in the database ID portion of the user's login string.

Action:Check the login string and then correct the syntax error.


ORA-06405

ORA-06405:NETCMN: reset protocol error

Cause:The SQL*Net driver detected an error while trying to reset the connection from a break state.

Action:Re-submit the connect string.


ORA-06406

ORA-06406:NETCMN: error sending break message

Cause:The SQL*Net driver could not correctly handle an incoming out-of-band message.

Action:Re-submit the connect string.


ORA-06407

ORA-06407:NETCMN: unable to set up break handling environment

Cause:The SQL*Net driver could not set up out-of-band break handler.

Action:Re-submit the connect string.


ORA-06408

ORA-06408:NETCMN: incorrect message format

Cause:A message from a partner contains a bad header.

Action:Contact your Oracle Customer Support representative.


ORA-06409

ORA-06409:NETCMN: message send failure

Cause:SQL*Net driver failed to send a message across the communication channel.

Action:Re-submit the connect string.


ORA-06410

ORA-06410:NETCMN: message receive failure

Cause:SQL*Net driver failed to receive a message across the communication channel.

Action:Re-submit the connect string. Contact the DBA if the error message persists.


ORA-06411

ORA-06411:NETCMN: message send failure

Cause:The SQL*Net driver failed to send a complete message across the communication channel.

Action:Re-submit the connect string. Contact the DBA if the error message persists.


ORA-06412

ORA-06412:NETCMN: message receive failure

Cause:The SQL*Net driver failed to receive a complete message from the communication channel.

Action:Re-submit the connect string. Contact the DBA if the error message persists.


ORA-06413

ORA-06413:NETCMN: connection not open

Cause:The SQL*Net driver was unable to open a connection with a remote node.

Action:Check node or wait for available connection to open, then resubmit the connect string.


ORA-06414

ORA-06414:NETCMN: disconnect failure

Cause:The SQL*Net driver was unable to close a connection.

Action:Check the node or wait for an available connection to close and then resubmit the connect string.


ORA-06415

ORA-06415:NETCMN: incompatible versions

Cause:The version of SQL*Net driver loaded on client workstation differs from SQL*Net listener process opened on the server.

Action:Check the installation of SQL*Net on both the server and the client PCs. Upgrade the software to the same version on both sides of the network.


ORA-06416

ORA-06416:NETCMN: error on test

Cause:An error occurred while testing the I/O status of the network connection.

Action:Contact your Oracle Customer Support representative.


ORA-06419

ORA-06419:NETCMN: server cannot start oracle

Cause:The remote server was unable to start an Oracle process on behalf of the client.

Action:Make sure permissions on the remote Oracle program are correctly set. Contact your system administrator.


ORA-06420

ORA-06420:NETCMN: SID lookup failure

Cause:From the remote host's server: the database SID, specified in the login (connect) string, was not recognized.

Action:Add the appropriate SID entry to the parameter file or oratab file on the remote host. Restart the remote server, if necessary.


ORA-06421

ORA-06421:NETCMN: error detected in the read-in data

Cause:An error occurred in the recomputation of checksum or CRC. There is a possible hardware failure in the communication nodes.

Action:Contact your system administrator.


ORA-06422

ORA-06422:NETCMN: error in sending data

Cause:SQL*Net was unable to transmit data to a remote host.

Action:Attempt to reconnect to the remote host. Contact your system administrator.


ORA-06423

ORA-06423:NETCMN: error in receiving data

Cause:SQL*Net was unable to receive data from a remote host.

Action:Attempt to reconnect to the remote host. Contact your system administrator.


ORA-06431

ORA-06431:NETBIOS: Error while listening

Cause:The local session table is full or the server name is invalid.

Action:Reboot the server machine or specify the legal server name.


ORA-06432

ORA-06432: NETBIOS: Cannot terminate current session

Cause:The session ended abnormally or there was an adapter malfunction.

Action:Contact your DBA.


ORA-06433

ORA-06433: NETBIOS: Error encountered while sending data

Cause:An error was encountered in attempting to send data. The possible reasons include: the command timed out, the message was incomplete, the session ended abnormally, the maximum number of connections was reached, or an adapter malfunctioned.

Action:First, check the server machine for any warning messages. Next, try rebooting the machine. If the problem persists, contact your DBA.


ORA-06434

ORA-06434:NETBIOS: Error encountered while receiving data

Cause:An error was encountered in receiving data. The possible reasons include: the command timed out, the message was incomplete, the session ended abnormally, or the adapter malfunctioned.

Action:Reboot the machine. If the problem persists, contact your DBA.


ORA-06435

ORA-06435: NETBIOS: Unable to add local name to name table

Cause:A duplicate locator is running, the last NetBIOS session was terminated abnormally, or the NetBIOS emulator was not loaded.

Action:Turn off any duplicate locators running on network, then reboot the client machine. Make sure your client machine is properly configured for the correct network to support NetBIOS calls. Check that the NetBIOS emulator has been loaded and is running.


ORA-06436

ORA-06436: NETBIOS: Locator not responding

Cause:The network operating system locator is not responding.

Action:Check the network connection between your client and the server. Make sure that there is one and only one locator service running on the network. Make sure that the machine running the locator service is up and is properly connected to the network. Contact your DBA for assistance.


ORA-06437

ORA-06437: NETBIOS: Unusual network condition

Cause:An internal command was issued that it is not valid to cancel.

Action:This is an unusual network condition; contact your DBA.


ORA-06438

ORA-06438: NETBIOS: Error invoking ORACLE shadow process

Cause:The server is unable to start a shadow process after receiving the connection request.

Action:If you are running against a Version 5.1 server, make sure that the CONFIG.ORA parameter ORACLE_EXECUTABLE is set to ORACLE5; the default is ORACLE6. Otherwise, contact your DBA.


ORA-06441

ORA-06441: NETBIOS: OS/2 failed to create or access shared memory

Cause:Unable to open shared memory segment containing the connection status of ORACLE Server.

Action:Ensure that ORACLE Server has been started properly so that the shared memory segment is available.


ORA-06450

ORA-06450:NETSPX: IPX not loaded

Cause:The DOS network shell is not loaded.

Action:Run IPX.EXE and NET3.EXE. If your MS-DOS version is 4.x, use NET4.EXE; for MS-DOS version 5.x, use NETX.EXE.


ORA-06451

ORA-06451:NETSPX: SPX socket open error

Cause:The SPX socket is unavailable. It is possible that there are too many opened sockets.

Action:Increase the number of SPX sockets and IPX sockets in NET.CFG (OS/2) or SHELL.CFG (DOS). If this error occurs, contact your DBA for assistance.


ORA-06452

ORA-06452:NETSPX: SPX connection failure

Cause:The system is unable to connect to the requested server. It is possible that server is not allowing any more connections.

Action:Retry when connection is available. Increase the SPX_MAX_CLIENTS parameter in the CONFIG.ORA file and restart server.


ORA-06453

ORA-06453:NETSPX: Send length error

Cause:The system encountered an error when sending data.

Action:Check all LAN connections and cables. If any connections are loose, secure them and reconnect to the server. Otherwise, reboot the server, reload the SQL*Net driver, and then reconnect to the server.


ORA-06454

ORA-06454:NETSPX: SPX connection broken/All database links used

Cause:The connection has been broken or a database link cannot be performed.

Action:Check all LAN connections and cables. If any connections are loose, secure them and reconnect to the server. Otherwise, reboot the server, reload the SQL*Net driver, and then reconnect to the server.


ORA-06455

ORA-06455:NETSPX: SPX Event Control Block error

Cause:Either no ECBs are available or there is an ECB parameter error.

Action:Reboot the server, reload the SQL*Net driver, and restart ORACLE.


ORA-06456

ORA-06456:NETSPX: SPX packet error

Cause:The system received an erroneous packet.

Action:Check all LAN connections and cables. If any connections are loose, secure them and reconnect to the server. Otherwise, reboot the server, reload the SQL*Net driver, and then reconnect to the server.


ORA-06457

ORA-06457:NETSPX: SPX Event Control Block error

Cause:Error initializing ECBs. SPX is not functioning properly.

Action:Reboot the server, reload the SQL*Net driver, and restart ORACLE. If error recurs, contact your DBA.


ORA-06458

ORA-06458:NETSPX: Connection reset error

Cause:An error occurred when resetting the connection.

Action:Check all LAN connections and cables. If any connections are loose, secure them and reconnect to the server. Otherwise, reboot the server, reload the SQL*Net driver, and then reconnect to the server. If error recurs, contact your DBA.


ORA-06459

ORA-06459:NETSPX: Server name not specified in command line

Cause:A server name is not specified in the command line after "x:".

Action:Specify server name after the network prefix and retry, or set the LOCAL or REMOTE parameter in your CONFIG.ORA file.


ORA-06460

ORA-06460:NETSPX: Unknown server

Cause:The server name that was specified is not running.

Action:Ensure that the specified server is running on the network.


ORA-06461

ORA-06461:NETSPX: Unable to allocate memory

Cause:Not enough system memory or too many memory-resident programs are installed.

Action:Remove unnecessary memory-resident programs and retry the operation.


ORA-06462

ORA-06462:NETSPX: Unable to allocate/access memory

Cause:Not enough system memory, too many memory resident programs are installed, or server is no longer running.

Action:Remove unnecessary memory resident programs and restart the server.


ORA-06463

ORA-06463:NETSPX: Memory deallocation error/SQL*Net handshake error

Cause:Possibly incompatibility between SQL*Net versions on server and clients.

Action:Check SQL*Net versions on server and client machines and reinstall same versions if different.


ORA-06464

ORA-06464:NETSPX: SPX error

Cause:Network data corruption.

Action:Check all LAN connections and cables. If any connections are loose, secure them and reconnect to the server. Otherwise, reboot the server, reload the SQL*Net driver, and then reconnect to the server. If error recurs, contact your DBA.


ORA-06465

ORA-06465:NETSPX: Error listening for SPX packets

Cause:Failed to receive packet from SPX. It is possible that the client or server PC is no longer running, is detached from the Novell file server, or a network cable is broken.

Action:Check all LAN connections and cables. If any connections are loose, secure them and reconnect to the server. Otherwise, reboot the server, reload the SQL*Net driver, and then reconnect to the server. If error recurs, contact your DBA.


ORA-06466

ORA-06466:NETSPX: Error sending SPX packets

Cause:Failed to send packet to SPX. It is possible that the client or server PC is no longer running, is detached from the Novell file server, or a network cable is broken.

Action:Check all LAN connections and cables. If any connections are loose, secure them and reconnect to the server. Otherwise, reboot the server, reload the SQL*Net driver, and then reconnect to the server. If error recurs, contact your DBA.


ORA-06467

ORA-06467:NETSPX: Not attached to Novell server

Cause:Workstation is not attached to Novell file server.

Action:If the workstation is running DOS, run IPX.COM and NETX.EXE (where x=3 for MS-DOS 3.x, x=4 for MS-DOS 4.x, and x=X for MS-DOS 5.x). If the workstation is running OS/2, check CONFIG.SYS for the presence of the following two lines:

device = c:\netware\nwreq.sys

run = c:\netware\nwdaemon.exe

If the lines are not there, add them and then reboot the workstation.


ORA-06468

ORA-06468:NETSPX: SPX get local target error

Cause:SPX cannot locate the destination on the network.

Action:Reboot the server, reload the SQL*Net driver, and retry the operation. If error recurs, contact your DBA.


ORA-06469

ORA-06469:NETSPX: Out of resource

Cause:Novell SPX is out of resources, e.g., SPX socket table full, connection table full, etc.

Action:Terminate some connections to free up the resources requested.


ORA-06470

ORA-06470:NETSPX: Partner died

Cause:Client or server PC is no longer running, e.g., powered down, rebooted, or a network connection is broken.

Action:Ensure that the client or server PC is working properly and is successfully communicating with the network.


ORA-06500

ORA-06500PL/SQL: storage error

Cause:A rare internal error message; memory has been exhausted or corrupted.

Action:Contact Worldwide Customer Support.


ORA-06501

ORA-06501PL/SQL: internal error num, arguments [num], [num], [num], [num], [num], [num]

Cause:Internal error message; an error has been detected in a PL/SQL program.

Action:Contact Worldwide Customer Support.


ORA-06502

ORA-06502PL/SQL: numeric or value error

Cause:An arithmetic, numeric, string, conversion, or constraint error occurred. For example, this error occurs if an attempt is made to assign the value NULL to a variable declared NOT NULL, or if an attempt is made to assign an integer larger than 99 to a variable declared NUMBER(2).

Action:Change the data, how it is manipulated, or how it is declared so that values do not violate constraints.


ORA-06503

ORA-06503PL/SQL: Function returned without value

Cause:A call to PL/SQL function completed, but no RETURN statement was executed.

Action:Rewrite PL/SQL function, making sure that it always returns a value of a proper type.


ORA-06504

ORA-06504PL/SQL: Return types of Result Set variables or query do not match

Cause:Number and/or types of columns in a query do not match the declared return type of a Result Set variable, or the declared types of two Result Set variables do not match.

Action:Change the program statement or declaration. Identify the query to which the variable, during execution, actually refers.


ORA-06505

ORA-06505PL/SQL: variable requires more than 32767 bytes of contiguous memory

Cause: A PL/SQL variable was declared with a constraint which required more than 32767 bytes of memory. PL/SQL does not currently support allocations of contiguous memory greater than 32767 bytes.

Action: Consider reducing the constraint in the variable declaration. If that is not possible, try changing the database or national character set to such, that requires less memory for the same constraint. Note: changing the character set will impact execution of all PL/SQL code.


ORA-06509

ORA-06508

ORA-06508 PL/SQL: could not find program unit being called

Cause:
An attempt was made to call a stored program that could not be found. The program may have been dropped or incompatibly modified, or have compiled with errors.

Action:
Check that all referenced programs, including their package bodies, exist and are compatible.


ORA-06509

ORA-06509PL/SQL: ICD vector missing for this package

Cause:This indicates a version clash between some package distributed with an Oracle product and the product executable.

Action:Contact customer support.


ORA-06510

ORA-06510PL/SQL: unhandled user-defined exception str

Cause:A user-defined exception was raised by PL/SQL code, but not handled.

Action:Fix the problem causing the exception or write an exception handler for this condition. It may be necessary to contact the application or database administrator.


ORA-06511

ORA-06511PL/SQL: cursor already open

Cause:An attempt was made to open a cursor that was already open.

Action:Close the cursor before attempting to reopen it.


ORA-06512

ORA-06512at str line num

Cause:This is usually the last of a message stack and indicates where in the PL/SQL code that a problem occurred.

Action:Fix the problem causing the exception or write an exception handler for this condition. It may be necessary to contact the application or database administrator.


ORA-06513

ORA-06513PL/SQL: index for PL/SQL table out of range for host language array

Cause:An attempt was made to copy a PL/SQL table to a host language array. But an index in the table is either less than one or greater than the maximum size of the host language array. When copying PL/SQL tables to host language arrays, the table entry at index 1 is placed in the first element of the array, the entry at index 2 is placed in the second element of the array, and so on. If a table entry was not assigned then the corresponding element in the host language array is set to null.

Action:Increase the size of the host language arrays, or decrease the size of PL/SQL table. Also make sure that you do not use index values less than 1.


ORA-06514

ORA-06514PL/SQL: The remote call cannot be handled by the server

Cause:The remote call had parameters that were cursor variables. This cannot be handled by stored procedures on your server.

Action:Avoid using cursor variables as parameters for stored procedures on this server or upgrade your server to a version that supports this.

For more information about using cursor variables, see the index entry on "cursor variable" in the PL/SQL User's Guide and Reference.


ORA-06515

ORA-06515PL/SQL: unhandled exception error

Cause:An exception was raised by PL/SQL code, but not handled. The exception number is outside the legal range of Oracle errors.

Action:Fix the problem causing the exception or write an exception handler for this condition. Or you may need to contact your application administrator or DBA.


ORA-06516

ORA-06516PL/SQL: the Probe packages do not exist or are invalid

Cause:A Probe operation, probably an attempt to initialize the ORACLE server to debug PL/SQL, could not be completed because the Probe packages were not loaded or have become invalid.

Action:DBA should load the Probe packages. This can be done by running the pbload.sql script supplied with the RDBMS.


ORA-06517

ORA-06517PL/SQL: Probe error - error

Cause:An error occurred while passing a Probe operation to the server for execution.

Action:Refer to the entry for the embedded error message.


ORA-06518

ORA-06518PL/SQL: Probe version num incompatible with version num

Cause:The current version of Probe is incompatible with the version on the Oracle server.

Action:Refer to the documentation to ensure that this degree of compatibility is supported.


ORA-06520

ORA-06520 PL/SQL: Error loading external library

Cause: An error was detected by PL/SQL trying to load the external library dynamically.

Action: Check the following messages (if any) for more details.


ORA-06521

ORA-06521PL/SQL: Error mapping function

Cause: An error was detected by PL/SQL trying to map the specified function dynamically.

Action: Check the following messages (if any) for more details about the error.


ORA-06523

ORA-06523Maximum number of arguments exceeded

Cause: There is an upper limit on the number of arguments that one can pass to the external function.

Action: Check the port specific documentation on how to calculate the upper limit.


ORA-06524

ORA-06524unsupported option: name

Cause: The option specified is an unsupported feature for external procedures.

Action:Correct the syntax in the external specification.


ORA-06525

ORA-06525 length mismatch for CHAR or RAW data

Cause: The length specified in the length variable has an illegal value. This can happen if you have requested a PL/SQL INOUT, OUT or RETURN raw variable to be passed as a RAW with no corresponding length variable. This error can also happen if there is a mismatch in the length value set in the length variable and the length in the orlvstr or orlraw.

Action: Correct the external procedure code and set the length variable correctly.


ORA-06526

ORA-06526 unable to load PL/SQL library

Cause: PL/SQL was unable to instantiate the library referenced by this referenced in the EXTERNAL syntax. This is a serious error and should normally not happen.

Action: Report this problem to customer support.


ORA-06530

ORA-06530reference to uninitialized composite

Cause: An object, LOB, or other composite was referenced as a left hand side without having been initialized.

Action: Initialize the composite with an appropriate constructor or whole-object assignment.


ORA-06531

ORA-06531reference to uninitialized collection

Cause: An element or member function of a nested table or VARRAY was referenced (where an initialized collection is needed) without the collection having been initialized.

Action: Initialize the collection with an appropriate constructor or whole-object assignment.


ORA-06532

ORA-06532: subscript outside of limit

Cause: A subscript was greater than the limit of a VARRAY or non-positive for a varray or nested table.

Action: Check the program logic and increase the varray limit if necessary.


ORA-06533

ORA-06533 subscript beyond count

Cause: An in-limit subscript was greater than the count of a varray or too large for a nested table.

Action: Check the program logic and explicitly extend if necessary.


ORA-06534

ORA-06534cannot access Serially Reusable package name in the context of a trigger

Cause: The program attempted to access a Serially Reusable package in the context of a trigger. Such an access is currently unsupported.

Action: Check the program logic and remove any references to Serially Reusable packages (procedure, function or variable references) which might happen n the context of a trigger.


ORA-06540

ORA-06540PL/SQL compilation error

Cause:A PL/SQL compilation error occurred. However, the user generally will not see this error message. Instead, there will be accompanying PLS-nnnnn error messages.

Action:See accompanying PLS-nnnnn error messages.


ORA-06541

ORA-06541PL/SQL: compilation error - compilation aborted

Cause:A PL/SQL compilation error occurred and the compilation was aborted. However, the user generally will not see this error message. Instead, there will be accompanying PLS-nnnnn error messages.

Action:See accompanying PLS-nnnnn error messages.


ORA-06544

ORA-06544PL/SQL: internal error, arguments:arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8

Cause:A PL/SQL internal error occurred.

Action:Report this as a bug; the first argument is the internal error number.


ORA-06545

ORA-06545 PL/SQL: compilation error - compilation aborted

Cause: A PL/SQL compilation error occurred and the compilation was aborted completely without the compilation unit being written out to the backing store. Unlike ORA-06541, the user will always see this error along with the accompanying PLS-nnnnn error messages.

Action: See accompanying PLS-nnnnn error messages.


ORA-06550

ORA-06550Line num, column num:

str

Cause:A PL/SQL compilation error has occurred. The numbers given for line and column are the location in the PL/SQL block where the error occurred.

Action:Refer to the following PL/SQL messages for more information about the error.


ORA-06554

ORA-06554Package DBMS_STANDARD must be created before using PL/SQL

Cause:The data dictionary script required by PL/SQL has not yet been run.

Action:See the ORACLE7 Server Administrator's Guide and your installation and user's guide for more information.


ORA-06555

ORA-06555this name is currently reserved for use by use SYS

Cause:An attempt was made to create a user-owned package named STANDARD, DBMS_STANDARD or DBMS_OUTPUT. This is not allowed.

Action:Choose another name for the package.


ORA-06556

ORA-06556the pipe is empty, cannot fulfill the UNPACK_MESSAGE request

Cause:There are no more items in the pipe.

Action:Check that the sender and receiver agree on the number and types of items placed on the pipe.


ORA-06557

ORA-06557null values are not allowed for any parameters to pipe ICD's

Cause:Internal error from the DBMS_PIPE package.

Action:Call Worldwide Customer Support.


ORA-06558

ORA-06558buffer in DBMS_PIPE package is full. No more items allowed

Cause:The pipe buffer size has been exceeded.


ORA-06559

ORA-06559wrong datatype requested, type, actual datatype is type

Cause:The sender put a different datatype on the pipe than that being requested (package DBMS_PIPE). The recognized datatypes and the corresponding numbers are: 6 - number, 9 - char, 12 - date.

Action:Check that the sender and receiver agree on the number and types of items placed on the pipe.


ORA-06560

ORA-06560pos, num, is negative or larger than the buffer size, num

Cause:Internal error from the DBMS_PIPE package.

Action:Call Worldwide Customer Support.

________________________________________


ORA-06561

ORA-06561 given statement is not supported by package DBMS_SQL

Cause: Attempting to parse an unsupported statement using procedure PARSE provided by package DBMS_SQL.

Action: Only statements which begin with SELECT, DELETE, INSERT, UPDATE, LOCK, BEGIN, DECLARE or <= (PL/SQL label delimiter) are supported.


ORA-06562

ORA-06562type of OUT argument must match type of column or bind variable

Cause:An attempt was made to get the value of a column or a bind variable by calling procedure COLUMN_VALUE or VARIABLE_VALUE of package DBMS_SQL. However, the type of the given out argument was different from the type of the column or bind variable that was previously defined by calling procedure DEFINE_COLUMN, for defining a column, or BIND_VARIABLE, for binding a bind variable, of package DBMS_SQL.

Action:Pass in an OUT argument of the correct type when calling procedure COLUMN_VALUE or VARIABLE_VALUE. The right type is the type that was provided when defining the column or binding the bind variable.


ORA-06563

ORA-06563top level procedure or function specified, cannot have subparts

Cause:The name to be resolved was specified with three parts, a.b.c, but the a.b part resolves to a top level procedure or function that does not have nested procedures. This can also happen with a two-part name, a.b, where a is a synonym for a top level package or procedure.

Action:Specify a procedure or function within a package or a top level procedure or function.


ORA-06564

ORA-06564object name does not exist

Cause:The named object could not be found. Either it does not exist or you do not have permission to access it.

Action:Create the object or get permission to access it.


ORA-06565

ORA-06565cannot execute name from within stored procedure

Cause:The named procedure cannot be executed from within a stored procedure, function, or package. This function can only be used from PL/SQL anonymous blocks.

Action:Remove the procedure from the calling stored procedure.


ORA-06566

ORA-06566invalid number of rows specified

Cause:An invalid number of rows was specified in a call to the procedures DEFINE_COLUMN in the package DBMS_SQL. For a given parsed statement in a given cursor, all columns must be defined to have the same number of rows, so all the calls to DEFINE_COLUMN must specify the same numberof rows.

Action:Specify a number that matches the number for previously defined columns.


ORA-06567

ORA-06567invalid number of values specified

Cause:An invalid number of values to be bound was specified in a call to the procedure BIND_VARIABLE in the package DBMS_SQL. For a given parsed statement in a given cursor, the same number of values must be bound for all bind variables, so all the calls to BIND_VARIABLE must specify the same number of values.

Action:Make sure that the same number of values are given for each of the bind variables.


ORA-06568

ORA-06568obsolete ICD procedure called

Cause:An obsolete ICD procedure was called by a PL/SQL program. The PL/SQL program was probably written for an earlier release of Oracle.

Action:Ensure that all PL/SQL packages are upgraded to the latest release of Oracle by following the upgrade instructions noted in the README document or by running the CATPROC.SQL script.


ORA-06569

ORA-06569 collection bound by bind_array contains no elements

Cause: A collection with zero elements was bound to a bind variable in a call to procedure BIND_ARRAY in the package DBMS_SQL. In order to execute a bind of a collection, the collection must contain at least one element. If no elements are present then at execute time there will be no value for this bind and the statement is meaningless.

Action: Fill the collection with the elements you want to bind and try the bind call again.


ORA-06570

ORA-06570shared pool object does not exist, cannot be pinned

Cause:The specified shared pool shared cursor could not be found. Therefore, it cannot be pinned.

Action:Make sure that a correct shared cursor name is given. Names are a string of the form 'HHHHHHHH,SDDDDDDDDDD' where the Hs are an 8-digit hex number from the 'address' column of V$SQLAREA, and the Ds are a 1- to 10-digit decimal number with an optional leading sign from the'hash_value' column.


ORA-06571

ORA-06571function name does not guarantee not to update database

Cause:There are two possible causes for this message:

A SQL statement references a packaged PL/SQL function that does not contain a pragma that prevents the database from being updated.

A SQL statement references a stand-alone, PL/SQL function that contains an instruction to update the database.

Action:If the referenced function is a packaged PL/SQL function: Recreate the PL/SQL function with the required pragma; be certain to include the 'Write No Database State' (WNDS) argument in the argument list of the pragma.

If the referenced function is a stand-alone PL/SQL function: Do not use the function.


ORA-06572

ORA-06572function name has out arguments

Cause:A SQL statement references either a packaged or a stand-alone PL/SQL function that contains an OUT parameter in its argument list. PL/SQL functions referenced by SQL statements must not contain the OUT parameter.

Action:Recreate the PL/SQL function without the OUT parameter in the argument list.


ORA-06573

ORA-06573function name modifies package state, cannot be used here

Cause:There are two possible causes for this message:

A SQL statement references a packaged PL/SQL function that does not contain a pragma containing the 'Write no PackageState' (WNPS).

A SQL statement references a stand-alone PL/SQL function that modifies a package state. A stand-alone PL/SQL function referenced by a SQL statement cannot modify a package state.

Action:If the function is a packaged PL/SQL function: recreate the function and include a pragma containing the 'Write no Package State' (WNPS).

If the function is a stand-alone PL/SQL function: delete the function from the SQL statement.


ORA-06574

ORA-06574function name references package state, cannot execute remotely

Cause:There are two possible causes for this message:

A remote packaged function or a remote-mapped, local packaged function that does not contain a pragma with the 'Write no Package State' (WNPS) and 'Read no Package State' (RNPS) arguments references a package state.

A remote stand-alone function or a remote-mapped, local stand-alone function contains a reference to a package state that reads or writes a package variable.

Only local functions that are referenced in a SELECT list, VALUES clause of an INSERT statement, or SET clause of an UPDATE statement can modify a package state.

Action:If the function is a packaged function: Recreate the function and include a pragma containing the 'Write no Package State' (WNPS) and 'Read no Package State' (RNPS) arguments.

If the function is a stand-alone function: Do not call the function.


ORA-06575

ORA-06575function name is in an invalid state

Cause:A SQL statement references a PL/SQL function that is in an invalid state. Oracle attempted to compile the function, but detected errors.

Action:Check the SQL statement and the PL/SQL function for syntax errors or incorrectly assigned, or missing, privileges for a referenced object.


ORA-06580

ORA-06580Hash Join ran out of memory while keeping large rows in memory

Cause:Hash Join reserved 3 slots (each slot size = DB_BLOCK_SIZE * HASH_JOIN_MULTIBLOCK_IO_COUNT) for a row. If a row is larger than that, this error will be raised.

Action:Increase HASH_JOIN_MULTIBLOCK_IO_COUNT so that each joined row fits in a slot. HASH_AREA_SIZE may also need to be increased.

For more information about hashing and managing hash clusters, see the index entries on "hash clusters" in the Oracle8 Server Application Developer's Guide and on "hashing, how to use" in Oracle8 Server Tuning.


ORA-07436

ORA-07436Instance recovery can not resilver data file %s

Cause:Init.ora parameter _disable_oracle_resilvering is set to true while some datafiles are resilvered by Oracle.

Action:Shutdown all instances. Either stop using the Oracle resilvering feature or do not set _disable_oracle_resilvering to true. Start up the database again.


ORA-08000

ORA-08000maximum number of session sequence lists exceeded

Cause:This is an internal error message not normally issued.

Action:Contact Worldwide Customer Support.


ORA-08001

ORA-08001maximum number of sequences per session exceeded

Cause:An operation requested a resource that was unavailable. The maximum number of user sequences per session is specified by the initialization parameter DC_SEQUENCES. When this maximum is reached, no more requests are processed.

Action:Try the operation again in a few minutes. If this error occurs often, shut down ORACLE, increase the DC_SEQUENCES parameter in the initialization parameter file, and restart ORACLE.


ORA-08002

ORA-08002 name.CURRVAL is not yet defined in this session

Cause:Sequence CURRVAL was selected before sequence NEXTVAL was referenced.

Action:Select NEXTVAL from the sequence before selecting CURRVAL.


ORA-08003

ORA-08003sequence name.NEXTVAL exceeds internal limits

Cause:The sequence was created with unsafe values for some of the parameters. The calculation of NEXTVAL cannot be made because it exceeds the legal representation size.

Action:Alter or recreate the sequence number with legal limits.


ORA-08004

ORA-08004 name.NEXTVAL str [MIN][MAX]VALUE and cannot be instantiated

Cause:The requested value of NEXTVAL is greater than MAXVALUE, or less than MINVALUE.

Action:Alter the sequence so that a new value can be requested, and try again.


ORA-08005

ORA-08005specified row does not exist

Cause:A row with the given ROWID does not exist in any of the specified tables.

Action:Check the query for a misspelled ROWID or table name, and try again.


ORA-08006

ORA-08006specified row no longer exists

Cause:The row has been deleted by another user since the operation began.

Action:No user action is required.


ORA-08008

ORA-08008another instance is mounted with USE_ROW_ENQUEUES = num

Cause:The shared instance being started does not have the same value for the USE_ROW_ENQUEUES initialization parameter as already-running instances.

Action:Make sure all instances' initialization parameter files specify the same value for the USE_ROW_ENQUEUES parameter, and try again.


ORA-08100

ORA-08100index is not valid - see trace file for diagnostics

Cause:There is an error in the index validated by VALIDATE INDEX.

Action:Check the relevant trace file. If the problem is not resolvable, contact Worldwide Customer Support.


ORA-08101

ORA-08101index key does not exist root dba num, dba num (num)

Cause:The system detected a possible inconsistency in an index. This is an internal error message that is not normally issued.

Action:Send the trace file to Worldwide Customer Support, along with a description of the circumstances that produced the error. Customer Support will need the numbers given in the message.


ORA-08102

ORA-08102index key not found, obj# num, dba num (num)

Cause:The system detected a possible inconsistency in an index. This is an internal error message that is not normally issued.

Action:Send the trace file to Worldwide Customer Support, along with a description of the circumstances that produced the error. Customer Support will need the numbers given in the message.


ORA-08103

ORA-08103object no longer exists

Cause:The object has been deleted by another user since the operation began.

Action:Remove references to the object.

________________________________________


ORA-08175

ORA-08175discrete transaction restriction violated (name)

Cause:An attempt was made to perform an action that is not currently supported in a discrete transaction.

Action:Rollback the transaction, and retry it as a normal transaction.


ORA-08176

ORA-08176cannot continue consistent read for the table/index - no undo records

Cause:ORACLE encountered an operation that does not generate undo records; for example, the operation might be create index performing a direct load or executing discrete mode transactions.

Action:Retry the operation with a different snapshot time; if using an index retry the operation without using the index.


ORA-08177

ORA-08177cannot serialize access for this transaction

Cause:Oracle encountered data changed by an operation that occurred after the start of this serializable transaction.

Action:In read/write transactions, retry the intended operation or transaction.


ORA-08178

ORA-08178 illegal SERIALIZABLE clause specified for user INTERNAL

Cause: An attempt was made to specify the SERIALIZABLE mode for user INTERNAL. Serializable mode is not supported for user INTERNAL.

Action: Reconnect as another user and retry the SET TRANSACTION command.


ORA-08401

ORA-08401invalid compiler name: name

Cause:An invalid compiler name was passed to a UTL_RAW conversion routine.

Action:Correct the compiler name parameter in the PL/SQL code that called the conversion routine.


ORA-08402

ORA-08402invalid compiler name in MAKE_RAW_TO_NUMBER_FORMAT

Cause:An invalid compiler name was passed to the MAKE_RAW_TO_NUMBER_FORMAT routine.

Action:Correct the compiler name parameter in the PL/SQL code that calledthe routine.


ORA-08403

ORA-08403invalid compiler name in MAKE_NUMBER_TO_RAW_FORMAT

Cause:An invalid compiler name was passed to the MAKE_NUMBER_TO_RAW_FORMAT routine.

Action:Correct the compiler name parameter in the PL/SQL code that called the routine.


ORA-08404

ORA-08404invalid compiler name in RAW_TO_NUMBER_FORMAT

Cause:An invalid compiler name was passed to theRAW_TO_NUMBER_FORMAT routine.

Action:Correct the compiler name parameter in the PL/SQL code that called the routine.


ORA-08405

ORA-08405invalid compiler name in NUMBER_TO_RAW_FORMAT

Cause:An invalid compiler name was passed to theNUMBER_TO_RAW_FORMAT routine.

Action:Correct the compiler name parameter in the PL/SQL code that called the routine.


ORA-08406

ORA-08406error encountered in MAKE_RAW_TO_NUMBER_FORMAT

Cause:The MAKE_RAW_TO_NUMBER_FORMAT routine returned an error.

Action:This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.


ORA-08407

ORA-08407error encountered in MAKE_NUMBER_TO_RAW_FORMAT

Cause:The MAKE_NUMBER_TO_RAW_FORMAT routine returned an error.

Action:This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.


ORA-08408

ORA-08408error encountered in RAW_TO_NUMBER

Cause:The RAW_TO_NUMBER routine returned an error.

Action:This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.


ORA-08409

ORA-08409error encountered in NUMBER_TO_RAW

Cause:The NUMBER_TO_RAW routine returned an error.

Action:This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.


ORA-08410

ORA-08410error encountered in RAW_TO_NUMBER_FORMAT

Cause:The RAW_TO_NUMBER_FORMAT routine returned an error.

Action:This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.


ORA-08411

ORA-08411error encountered in NUMBER_TO_RAW_FORMAT

Cause:The NUMBER_TO_RAW_FORMAT routine returned an error.

Action:This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.


ORA-08412

ORA-08412error encountered in WMSGBSIZ, size for WMSGBLK is not big enough for warning message

Cause:The WMSGBSIZ is the maximum size for warning message block, it is recommended to be 1024 bytes to 8 kbytes.

Action:Defined WMSGBLK of size between 1k to 8k bytes and update the WMSGBSIZ to the size of WMSGBLK.


ORA-08413

ORA-08413invalid compiler type in FORMAT parameter at name

Cause:An invalid compiler type was defined in the format control block. The format control block is invalid.

Action:Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT and that it was not accidentally overwritten or modified by the PL/SQL procedure.


ORA-08414

ORA-08414error encountered in name

Cause:The function <routine> returned an error. Where <routine> may be:RAW_TO_NUMBERNUMBER_TO_RAWRAW_TO_NUMBER_FORMATNUMBER_TO_RAW_FORMATMAKE_NUMBER_TO_RAW_FORMATMAKE_RAW_TO_NUMBER_FORMAT

Action:This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.


ORA-08421

ORA-08421mask option USAGE IS POINTER is not supported

Cause:The USAGE IS POINTER clause was included in the mask options passed to a UTL_RAW conversion routine.

Action:Remove the USAGE IS POINTER clause from the mask options parameter in the PL/SQL code that called the conversion routine. The POINTER data type is not allowed.


ORA-08422

ORA-08422mask option USAGE IS INDEX is not supported

Cause:The USAGE IS INDEX clause was included in the mask options passed to a UTL_RAW conversion routine.

Action:Remove the USAGE IS INDEX clause from the mask options parameter inthe PL/SQL code that called the conversion routine. The INDEX data type is not allowed.


ORA-08423

ORA-08423mask option USAGE IS COMP-1 is not supported

Cause:The USAGE IS COMP-1 clause was included in the mask options passed to a UTL_RAW conversion routine.

Action:Remove the USAGE IS COMP-1 clause from the mask options parameter inthe PL/SQL code that called the conversion routine. The COMP-1 data type is not allowed.


ORA-08424

ORA-08424mask option USAGE IS COMP-2 is not supported

Cause:The USAGE IS COMP-2 clause was included in the mask options passed to a UTL_RAW conversion routine.

Action:Remove the USAGE IS COMP-2 clause from the mask options parameter inthe PL/SQL code that called the conversion routine. The COMP-2 data type is not allowed.


ORA-08425

ORA-08425raw buffer is too short for 8 bytes binary

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine was less than 8 bytes long, but the picture mask parameter specified that 8 bytes of input data were to be converted.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08426

ORA-08426raw buffer is too short for 4 bytes binary

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine was less than 4 bytes long, but the picture mask parameter specified that 4 bytes of input data were to be converted.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08427

ORA-08427raw buffer is too short for 2 bytes binary

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine was less than 2 bytes long, but the picture mask parameter specified that 2 bytes of input data were to be converted.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08428

ORA-08428raw buffer is too short for display data

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine was too short to contain sufficient data for the specified picturemask parameter.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08429

ORA-08429raw data has invalid digit in display type data

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine contained invalid data. The picture mask parameter specified a digit, but the corresponding input from the raw data did not contain a valid digit.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08430

ORA-08430raw data missing leading sign

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine had no leading sign, but the mask options parameter specified a leading sign.

Action:Correct the input raw data or the mask options so that they match.


ORA-08431

ORA-08431raw data missing zero as defined in picture

Cause:The picture mask parameter passed to a UTL_RAW RAW_TO_NUMBER conversion routine contained a zero, but the corresponding input from the raw data was not a zero.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08432

ORA-08432raw data has invalid floating point data

Cause:The input raw data passed to a UTL_RAW RAW_TO_NUMBER conversion routine contained invalid floating point data.

Action:Correct the input raw data.


ORA-08433

ORA-08433invalid picture type in convert raw to number

Cause:The picture mask parameter passed to a UTL_RAW RAW_TO_NUMBER conversion routine contained non-numeric characters, but the conversion was to a numeric data type.

Action:Correct the picture mask parameter.


ORA-08434

ORA-08434raw data has invalid trailing sign

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine had no trailing sign, but the mask options parameter specified atrailing sign.

Action:Correct the input raw data or the mask options so that they match.


ORA-08435

ORA-08435raw data missing the leading sign

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine had no leading sign, but the mask options parameter specified aleading sign.

Action:Correct the input raw data or the mask options so that they match.


ORA-08436

ORA-08436raw data has invalid sign digit

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine had an invalid sign digit in the position where the picture mask specified a sign.

Action:Correct the input raw data or the picture mask so that they match.


ORA-08437

ORA-08437invalid picture type in picture mask

Cause:The picture mask parameter passed to a UTL_RAW NUMBER_TO_RAW conversion routine contained non-numeric characters, but the conversion was to a numeric data type.

Action:Correct the picture mask parameter.


ORA-08438

ORA-08438error converting Oracle number to character data

Cause:An error occurred when converting an Oracle number to a character variable. The Oracle number was not in the correct format.

Action:Correct the call to the conversion routine. The input must be a valid Oracle number variable.


ORA-08439

ORA-08439error converting Oracle number to COBOL COMP-3

Cause:An error occurred when converting an Oracle number to a COBOL COMP-3 variable. The Oracle number was not in the correct format.

Action:Correct the call to the conversion routine. The input must be a valid Oracle number variable.


ORA-08440

ORA-08440raw buffer is too short to hold converted data

Cause:The output raw buffer passed to a UTL_RAW NUMBER_TO_RAW conversion routine was not large enough to contain the results of the conversion based on the picture mask.

Action:Increase the raw buffer size to the size necessary to hold the entire result of the conversion.


ORA-08441

ORA-08441closed parenthesis missing in picture mask

Cause:A closed parenthesis was missing from the picture mask passed to a UTL_RAW conversion routine.

Action:Correct the picture mask.


ORA-08442

ORA-08442error converting Oracle number to COBOL DISPLAY

Cause:An error occurred when converting an Oracle number to a COBOL DISPLAY variable. The Oracle number was not in the correct format.

Action:Correct the call to the conversion routine. The input must be a valid Oracle number variable.


ORA-08443

ORA-08443syntax error in BLANK WHEN ZERO clause in mask options

Cause:A syntax error was found in the BLANK WHEN ZERO clause in the mask options parameter passed to a UTL_RAW conversion routine. Valid specifications are: BLANK ZERO, BLANK ZEROS, BLANK ZEROES, BLANK WHEN ZERO, BLANK WHEN ZEROS, and BLANK WHEN ZEROES.

Action:Correct the mask options parameter.


ORA-08444

ORA-08444syntax error in JUSTIFIED clause in mask options

Cause:A syntax error was found in the JUSTIFIED clause in the mask options parameter passed to a UTL_RAW conversion routine. Valid specifications are: JUST, JUST RIGHT, JUSTIFIED, and JUSTIFIED RIGHT.

Action:Correct the mask options parameter.


ORA-08445

ORA-08445syntax error in SIGN clause in mask options

Cause:A syntax error was found in the SIGN clause in the mask options parameter passed to a UTL_RAW conversion routine. Valid specifications are: SIGN, LEADING SIGN, LEADING SEPARATE SIGN, LEADING SEPARATE CHARACTER SIGN, TRAILING SIGN, TRAILING SEPARATE SIGN, TRAILING SEPARATE CHARACTER SIGN IS LEADING, SIGN IS LEADING, SEPARATE SIGN IS LEADING, SEPARATE CHARACTER SIGN IS TRAILING, SIGN IS TRAILING, SEPARATE SIGN IS TRAILING, and SEPARATE CHARACTER.

Action:Correct the mask options parameter.


ORA-08446

ORA-08446syntax error in SYNCHRONIZED clause in mask options

Cause:A syntax error was found in the SYNCHRONIZED clause in the mask options parameter passed to a UTL_RAW conversion routine. Valid specifications are: SYNC, SYNC LEFT, SYNC RIGHT, SYNCHRONIZED, SYNCHRONIZED LEFT, and SYNCHRONIZED RIGHT.

Action:Correct the mask options parameter.


ORA-08447

ORA-08447syntax error in USAGE clause in mask options

Cause:A syntax error was found in the USAGE clause in the mask options parameter passed to a UTL_RAW conversion routine. Valid specifications are: USAGE, DISPLAY USAGE, COMP USAGE, COMP-3 USAGE, COMP-4 USAGE, COMPUTATIONAL USAGE, COMPUTATIONAL-3 USAGE, COMPUTATIONAL-4 USAGE IS, DISPLAY USAGE IS, COMP USAGE IS, COMP-3 USAGE IS, COMP-4 USAGE IS, COMPUTATIONAL USAGE IS, COMPUTATIONAL-3 USAGE IS, and COMPUTATIONAL-4.

Action:Correct the mask options parameter.


ORA-08448

ORA-08448syntax error in DECIMAL-POINT environment clause

Cause:A syntax error was found in the DECIMAL-POINT environment clause parameter passed to a UTL_RAW conversion routine. Valid specifications are: DECIMAL-POINT IS COMMA.

Action:Correct the environment clause parameter.


ORA-08449

ORA-08449invalid numeric symbol found in picture mask

Cause:An invalid numeric symbol was found in the picture mask parameter passed to a UTL_RAW conversion routine.

Action:Correct the picture mask parameter.


ORA-08450

ORA-08450invalid specification of CR in picture mask

Cause:The CR suffix was incorrectly specified in the picture mask parameter passed to a UTL_RAW conversion routine. The CR suffix can only appear at the end of a picture mask.

Action:Correct the picture mask parameter.


ORA-08451

ORA-08451invalid specification of DB in picture mask

Cause:The DB suffix was incorrectly specified in the picture mask parameter passed to a UTL_RAW conversion routine. The DB suffix can only appear at the end of a picture mask.

Action:Correct the picture mask parameter.


ORA-08452

ORA-08452specification of E in picture mask is unsupported

Cause:The floating point exponent symbol "E" was specified in the picture mask parameter passed to a UTL_RAW conversion routine. The floating point data type is currently not supported by the UTL_RAW conversion routines.

Action:Correct the picture mask parameter, and the data, if necessary.


ORA-08453

ORA-08453more than one V symbol specified in picture mask

Cause:The picture mask passed to a UTL_RAW conversion routine contained more than one decimal point indicator "V". Only one decimal point indicator is allowed in the picture mask.

Action:Correct the picture mask parameter.


ORA-08454

ORA-08454more than one S symbol specified in picture mask

Cause:The picture mask passed to a UTL_RAW conversion routine contained more than one operational sign indicator "S". Only one operational sign indicator is allowed in the picture mask.

Action:Correct the picture mask parameter.


ORA-08455

ORA-08455syntax error in CURRENCY SIGN environment clause

Cause:A syntax error was found in the CURRENCY SIGN environment clause parameter passed to a UTL_RAW conversion routine. Valid specifications are: CURRENCY SIGN IS x, where x is a valid currency sign.

Action:Correct the environment clause parameter.


ORA-08456

ORA-08456no sign in picture mask but SIGN clause in mask options

Cause:The picture mask parameter passed to a UTL_RAW conversion routine contained no sign symbol, "S", "+", or "-", but the mask options parameter contained a SIGN clause. A sign symbol is required in the picture mask parameter when the mask options parameter contains a SIGN clause.

Action:Correct the picture mask parameter or the mask options parameter.


ORA-08457

ORA-08457syntax error in SEPARATE CHARACTER option of SIGN clause

Cause:A syntax error was found in the SEPARATE CHARACTER option of the SIGN clause in the mask options parameter passed to a UTL_RAW conversion routine. Valid specifications are: SEPARATE and SEPARATE CHARACTER.

Action:Correct the mask options parameter.


ORA-08458

ORA-08458invalid format parameter

Cause:The format parameter passed to a UTL_RAW conversion routine was invalid. The format parameter should have been built by a prior call to either MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT.

Action:Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT and that it was not accidentally overwritten or modified by the PL/SQL procedure.


ORA-08459

ORA-08459invalid format parameter length

Cause:The format parameter passed to a UTL_RAW conversion routine was not the correct length. Format parameters must be 2048 bytes in length.

Action:Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT and that it was not accidentally overwritten or modified by the PL/SQL procedure.


ORA-08460

ORA-08460invalid environment clause in environment parameter

Cause:The environment parameter passed to a UTL_RAW conversion routine contained an unsupported or invalid environment clause. Only the CURRENCY SIGN and the DECIMAL-POINT IS COMMA environment clauses are supported.

Action:Correct the environment parameter.


ORA-08461

ORA-08461raw buffer is too short for decimal data

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine was too short to contain sufficient data to satisfy the specified picture mask parameter.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08462

ORA-08462raw buffer contains invalid decimal data

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine contains invalid decimal data.

Action:Correct the input data.


ORA-08463

ORA-08463overflow converting decimal number to Oracle number

Cause:The output variable passed to a UTL_RAW RAW_TO_NUMBER was not large enough to hold the Oracle number resulting from the input decimal number.

Action:Be sure that the input decimal number is valid, and be sure that the output variable is large enough to hold the Oracle number value.


ORA-08464

ORA-08464input raw decimal data contains more than 42 digits

Cause:The input raw buffer passed to a UTL_RAW RAW_TO_NUMBER conversion routine contained more than 42 digits. This exceeds the maximum size of an Oracle number.

Action:Correct the raw input buffer.


ORA-08465

ORA-08465input mask contains more than 32 characters

Cause:The input mask passed to UTL_PG numeric conversionroutine contained more the 32 characters.

Action:Correct the mask input buffer.


ORA-08466

ORA-08466raw buffer length num is too short for name

Cause:The input raw buffer passed to a UTL_PG RAW_TO_NUMBERconversion routine was less than num bytes long, but thepicture mask parameter specified that num bytes of input data were to be converted.

Action:Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.


ORA-08467

ORA-08467error converting Oracle number to num

Cause:An error occurred when converting an Oracle number to aCOBOL <type> of:DISPLAYCOMP-3or character variable.The Oracle number was not in the correct format.

Action:Correct the call to the conversion routine. The input must be a valid Oracle number variable.


ORA-08468

ORA-08468mask option name is not supported

Cause:The mask option <clause> was passed to a UTL_PGconversion routine, but is not supported by UTL_PG.The <clause> can be:USAGE IS POINTERUSAGE IS INDEXUSAGE IS COMP-1USAGE IS COMP-2POINTER

Action:Remove the <clause> from the mask options parameter in the PL/SQL call to UTL_PG.


ORA-08498

ORA-08498Warning: picture mask name overrides picture mask option USAGE IS name to USAGE IS DISPLAY

Cause:Picture mask option is overridden by Picture mask.

Action:No action need, just for information.


ORA-08499

ORA-08499Warning: picture mask options name ignored by UTL_RAW

Cause:Picture mask options such as OCCUR, SYNC and others are not processedby the UTL_RAW numeric conversion routines and will put in above warning message.

Action:No action need, just for information.


ORA-09100

ORA-09100target system returned following message:

Cause:A target system being accessed by an Oracle gateway returned an error that could not be handled by the gateway server. This message is followed by a second message generated by the target system or the gateway.

Action:See the documentation for the target system for an explanation of the second message.


ORA-09101

ORA-09101target system communication error

Cause:The gateway encountered an error when communicating with the target system. This message will generally be followed by a second message generated either by the target system or the gateway.

Action:See the documentation for the target system for an explanation of the second message.


ORA-09102

ORA-09102gateway internal communication error

Cause:The Oracle gateway encountered an internal error during communication with a module that is part of the gateway.

Action:Contact customer support.


ORA-09103

ORA-09103gateway internal protocol error

Cause:The Oracle gateway encountered an internal error during communication with an internal module.

Action:Contact customer support.


ORA-09104

ORA-09104gateway internal cross-communication error

Cause:The Oracle gateway encountered an internal error during communication with a module that is part of the gateway but located in a different process.

Action:Contact customer support.


ORA-09105

ORA-09105failed to acquire storage space in target system

Cause:For an Oracle gateway, the amount of storage available within the target system was reached. This message is followed by a second message generated by the target system.

Action:See the documentation for the target system for an explanation of the second message.


ORA-09106

ORA-09106target system could not obtain IO resource

Cause:The target system was unable to open a file, dataset, or other resource needed to perform the I/O. This message is followed by a second message generated by the target system.

Action:See the documentation for the target system for an explanation of the second message.


ORA-09107

ORA-09107definition of a target system object may have changed

Cause:In an Oracle transparent gateway, an attempt was made to execute a SQL statement whose definition in the GDDL source may be out of date. The timestamp in the gateway data dictionary is different from the timestamp in the target system.

Action:Use the Transparent Gateway Administrator utility to replace the table using the revised GDDL source.


ORA-09108

ORA-09108invalid record in target system

Cause:The Oracle gateway or the target system noticed that the record is not valid according to its definition. This message is followed by a second message generated by the gateway or the target system depending on the error.

Action:See the gateway documentation or the documentation for the target system for an explanation of the second error message.


ORA-09109

ORA-09109view "view_name" cannot be used in a subquery

Cause:The view definition contains a set operator, which makes it impossible to use that view definition in a subquery. This message can occur only in SQL-based gateways.

Action:Do not use the view in a subquery.


ORA-09110

ORA-09110view "view_name" defines operation not supported on the target system

Cause:In a user-developed gateway, the implementor defined a view that defines an Oracle table in terms of other data source tables, and this definition contains SQL elements not supported by that system.

Action:Contact the implementor to correct the view definition error.


ORA-09111

ORA-09111data manipulation operation not legal on this object

Cause:In an Oracle transparent gateway, the target system rejected an insert, delete, or update operation. This message is followed by a second message generated by the target system.

Action:See the documentation for the target system for an explanation of the second message.


ORA-09112

ORA-09112target system check constraint violated

Cause:The values being inserted or updated do not satisfy the check constraint in the transparent gateway. This message is followed by a second message generated by the target system or the gateway.

Action:See the documentation for the target system or your Oracle7 operating system-specific documentation for an explanation of the second message.


ORA-09113

ORA-09113target system integrity constraint violated

Cause:The values being inserted, updated, or deleted do not satisfy the integrity constraints defined in the target system in a transparent gateway. This message is followed by a second message generated by the target system or the gateway.

Action:See the documentation for the target system or your Oracle7 operating system-specific documentation for an explanation of the second message.


ORA-09115

ORA-09115target system has timed out

Cause:A target system being accessed by an Oracle gateway timed out. This error occurs when system resource usage is too high for the request to be served in a reasonable time or when a deadlock, or some other wait condition, occurred in the target system. This message is followed by a second message generated by the target system or the gateway.

Action:See the documentation for the target system or your Oracle7 operating system-specific documentation for an explanation of the second message.


ORA-09115

ORA-09115target system has timed out

Cause:A target system being accessed by an Oracle gateway timed out. This error occurs when system resource usage is too high for the request to be served in a reasonable time or when a deadlock, or some other wait condition, occurred in the target system. This message is followed by a second message generated by the target system or the gateway.

Action:See the documentation for the target system or your Oracle operating system-specific documentation for an explanation of the second message.


ORA-09116

ORA-09116definition of target system data object is inconsistent

Cause:In an Oracle transparent gateway, The target system was unable to perform the initial operations necessary to access the mapped table. The GDDL source specifies certain fields or options that are not supported for this gateway configuration.

Action:Correct the GDDL source and issue the Transparent Gateway Administrator command to CREATE OR REPLACE or DROP the table.


ORA-09117

ORA-09117bind-value cannot be translated into SQL text

Cause:For the SQL-based transparent gateway, the target system does not support binds, or binds are disabled using the RESOLVE_BINDS gateway initialization parameter.

Action:Enable binds or do not bind using datatypes not supported in SQL text.


ORA-09118

ORA-09118maximum number of savepoints exceeded

Cause:For the SQL-based transparent gateway, the target system was unable to set the savepoint because the maximum number of active savepoints was reached.

Action:Re-organize the transaction so that this limit is not reached or increase the maximum in the target system if that is possible.


ORA-09119

ORA-09119initialization file contains error

Cause:An Oracle gateway server encountered an error in the gateway server initialization file. This message is followed by a second message. If the second message did not follow, it can be found in the gateway log file.

Action:Refer to the second message to fix the initialization file.


ORA-09120

ORA-09120gateway has timed out access to target system

Cause:The Oracle Gateway request was not serviced within the specified time by the target system.

Action:See your Oracle7 operating system-specific documentation for an explanation of when this error can occur.


ORA-09121

ORA-09121fetch exceeds maximum number of records defined for table

Cause:The transparent gateway detected that a query will retrieve more rows than the maximum defined in the GDDL for mapped table.

Action:See your Oracle7 operating system-specific documentation for an explanation of when this error can occur.


ORA-09122

ORA-09122access to object "name" denied

Cause:An Oracle transparent gateway denied access to the specified object.

Action:Log in as a user with access to the object or change the access permission of the object.


ORA-09123

ORA-09123ROWID not found in gateway rowid cache

Cause:For the transparent gateway, the ROWID cache holds no entry that corresponds to the specified ROWID. Possibly, the ROWID entry was overwritten in the gateway ROWID cache.

Cause:Increase the size of the gateway ROWID cache by setting the value of the ROWID_CACHE_SIZE gateway initialization parameter to a higher value and restart the gateway server.


ORA-09124

ORA-09124in name argument name: Index out of range

Cause:The transparent gateway server detected that the index for a mapped table is bigger than allowed by the definition in the GDDL source.

Action:Modify the query or the GDDL source so that the index is in range.


ORA-09201

ORA-09200

ORA-09200sfccf: error creating file

Cause:Disk space is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09201

ORA-09201sfcopy: error copying file

Cause:Block sizes do not match.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09202

ORA-09202sfifi: error identifying file

Cause:The DB_BLOCK_SIZE specified in the initialization parameter file is incorrect.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09203

ORA-09203sfofi: error opening file

Cause:File attributes have changed.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09204

ORA-09204sfotf: error opening temporary file

Cause:An incorrect file path has been specified.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09205

ORA-09205sfqio: error reading or writing to disk

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09206

ORA-09206sfrfb: error reading from file

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09207

ORA-09207sfsrd: error reading from file

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09208

ORA-09208sftcls: error closing file

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09209

ORA-09209sftget: error reading from file

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09210

ORA-09210sftopn: error opening file

Cause:An incorrect file path has been specified.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09211

ORA-09211sfwfb: error writing to file

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09212

ORA-09212sfwfbmt: error writing to file

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09213

ORA-09213slgfn: error fabricating file name

Cause:The file is too long.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09214

ORA-09214sfdone: I/O error detected

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09215

ORA-09215sfqio: error detected in I/O completion routine

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09240

ORA-09240smpalo: error allocating PGA memory

Cause:The amount of available memory is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09241

ORA-09241smsalo: error allocating SGA memory

Cause:The amount of available memory is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09242

ORA-09242smscre: error creating SGA

Cause:This is a OS/2 error.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09243

ORA-09243smsget: error attaching to SGA

Cause:The database is not started; consequently, the SGA has not been created.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09244

ORA-09244smprset: error setting memory protections

Cause:This is a OS/2 error.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09245

ORA-09245smcstk: error switching stacks

Cause:This is a OS/2 error.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09246

ORA-09246sfsmap: unable to map SGA

Cause:This is a OS/2 error.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09247

ORA-09247smsdes: error destroying the SGA

Cause:This is a OS/2 error.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09260

ORA-09260sigpidu: error obtaining process id

Cause:The amount of available resources is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09261

ORA-09261spdcr: error creating detached (background) process

Cause:The amount of available resources is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09262

ORA-09262spdde: error terminating detached (background) process

Cause:The amount of available resources is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09263

ORA-09263spini: error initializing process

Cause:The amount of available resources is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09264

ORA-09264sptpa: error flagging process

Cause:The amount of available resources is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09265

ORA-09265spwat: error temporarily suspending process

Cause:The amount of available memory is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09266

ORA-09266spawn: error starting an oracle process

Cause:The amount of available memory is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09270

ORA-09270szalloc: error allocating memory for security

Cause:The amount of available memory is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09271

ORA-09271szlon: error verifying user name

Cause:The user name is too long.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09272

ORA-09272remote OS login is not allowed

Cause:Remote login to the operating system is not allowed.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09273

ORA-09273szrfc: error verifying role name

Cause:An OS error was returned when verifying the role name.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09274

ORA-09274szrfc: insufficient role name buffer space

Cause:An OS role name is too long.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09280

ORA-09280sllfcf: error closing file

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation. Action:


ORA-09281

ORA-09281sllfop: error opening file

Cause:The specified file path is incorrect.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09282

ORA-09282sllfrb: error reading records

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09283

ORA-09283sllfsk: error skipping records

Cause:The file has been truncated or corrupted.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09290

ORA-09290sksaalo: error allocating memory for archival

Cause:The amount of available memory is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09291

ORA-09291sksachk: invalid device specification for LOG_ARCHIVE_DEST

Cause:The directory is not accessible.

Action:Specify a valid device in the ARCHIVE control string.


ORA-09300

ORA-09300osncon: unable to connect, DPMI not available

Cause:The presence of DPMI is not detected.

Action:Restart Windows and retry.


ORA-09301

ORA-09301osncon: local kernel only supported in standard mode

Cause:An attempt was made to connect to S: while in enhanced mode

Action:Restart Windows in standard mode.


ORA-09310

ORA-09310sclgt: error freeing latch

Cause:This is an internal error, not normally expected to occur.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09311

ORA-09311slsleep: error temporarily suspending process

Cause:The amount of available resources is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09312

ORA-09312slspool: error spooling file to printer

Cause:The amount of available memory is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09313

ORA-09313slsprom: error prompting user

Cause:The amount of available resources is insufficient.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09314

ORA-09314sltln: error translating logical name

Cause:The internal buffer has overflowed.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09315

ORA-09315sql2tt: two-task error translating ORACLE_EXECUTABLE

Cause:This is an internal error, not normally expected to occur.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09316

ORA-09316szrpc: unable to verify password for role

Cause:OS roles are not supported for this platform.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09317

ORA-09317szprv: insufficient privileges

Cause:An invalid password has been specified.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09318

ORA-09318slkhst: error hosting out to operating system

Cause:There is insufficient memory to execute the command or hosting out is not supported on this platform

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09319

ORA-09319slgtd: unable to obtain the current date and time

Cause:The system time is set incorrectly.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09320

ORA-09320szrfc: unable to obtain the list of valid OS roles

Cause:OS roles are not supported on this platform.

Action:Check the operating system error code and consult the OS/2 documentation.


ORA-09330

ORA-09330session terminated internally by Oracle or by an Oracle DBA

Cause:A client workstation is abnormally disconnected or a shutdown abort has been performed.

Action:Properly reconnect the client workstation.


ORA-09340

ORA-09340specified ORACLE_SID is either invalid or too long

Cause:ORACLE_SID is invalid or too long.

Action:Correctly specify the ORACLE_SID parameter variable.


ORA-09350

ORA-09350Windows NT two-task driver unable to allocate context area

Cause:This is a Windows NT error.

Action:Check the operating system error code and consult the Windows NT documentation.


ORA-09351

ORA-09351Windows NT two-task driver unable to allocate shared memory

Cause:This is a Windows NT error.

Action:Check the operating system error code and consult the Windows NT documentation.


ORA-09352

ORA-09352Windows NT two-task driver unable to spawn new ORACLE task

Cause:This is a Windows NT error.

Action:Check the operating system error code and consult the Windows NT documentation.


ORA-09353

ORA-09353Windows NT two-task driver unable to open event semaphore

Cause:This is a Windows NT error.

Action:Check the operating system error code and consult the Windows NT documentation.


ORA-09354

ORA-09354Windows NT two-task driver: ORACLE task unexpectedly died

Cause:This is a Windows NT error.

Action:Check the operating system error code and consult the Windows NT documentation.


ORA-09991

ORA-09991scumnt: translation error while expanding ?/dbs/lk

Cause:Failure of sltln in scumnt

Action:Check additional return error for more information.


ORA-09992

ORA-09992scumnt: unable to create or open file

Cause:Open system call returned an error

Action:Check errno


ORA-09993

ORA-09993scumnt: unable to lock file

Cause:Lock file operating system call returned an error

Action:Check errno


ORA-10901

ORA-10901Disable extent trimming during segment merges

Cause:

Action:Set this event only under the supervision of Oracle development

Comment:Setting this event disables extent trimming during segment merges, which happen on operations such as pctas, parallel create index, and parallel direct load. Instead, blocks in the half-used extent will be formatted and put on the free list.


ORA-12000

ORA-12000a snapshot log already exists on table name

Cause:An attempt was made to create a snapshot log on a table that already has a snapshot log. Each master table can have only one snapshot log.

Action:All snapshots on a table can use the same snapshot log for that table. To make changes to the existing log, use the ALTER SNAPSHOT LOG command, or drop the snapshot log and create it again.


ORA-12001

ORA-12001cannot create log: table name already has a trigger

Cause:An attempt was made to create a snapshot log on a table when the table already had an AFTER ROW trigger. Snapshot logs are filled by an AFTER ROW trigger on the master table, thus the trigger cannot be created.

Action:If it is necessary to create a snapshot log, drop the current trigger on the master table.


ORA-12002

ORA-12002there is no snapshot log on table name

Cause:An attempt was made to drop a snapshot that doesn't exist.

Action:Check spelling, syntax, and use an existing snapshot name.


ORA-12003

ORA-12003snapshot name does not exist

Cause:An attempt was made to reference a snapshot that does not exist.

Action:Check the name of the snapshot in the statement for typing errors. Issue the statement again with an existing snapshot name.


ORA-12004

ORA-12004REFRESH FAST cannot be used

Cause:An attempt to fast refresh a snapshot was made when the master table for the snapshot has no snapshot log, or the snapshot log cannot be used.

Action:To REFRESH FAST, first create a snapshot log on the master table. Otherwise, use the REFRESH COMPLETE option of the ALTER SNAPSHOT command. If these options are omitted, ORACLE decides the appropriate method for refreshing.


ORA-12005

ORA-12005may not schedule automatic refresh for times in the past

Cause:An attempt was made to schedule an automated snapshot refresh for a time in the past.

Action:Choose a time in the future for the automated snapshot refresh.


ORA-12006

ORA-12006a snapshot with the same user.name already exists

Cause:An attempt was made to create a snapshot with name of an already existing snapshot.

Action:Create the snapshot using a different name, or drop the existing snapshot.


ORA-12007

ORA-12007snapshot reuse parameters are inconsistent

Cause:During IMPORT or EXPORT, the CREATE SNAPSHOT or CREATE SNAPSHOT LOG .. REUSE command was given inconsistent parameters immediately after the REUSE.

Action:Other messages will accompany this message. Examine the other messages for a more complete description of the problem.


ORA-12008

ORA-12008error in snapshot refresh path

Cause:Some problem is preventing the snapshot from reading the view on the master table. A number of events could cause this problem, such as the master table no longer exists or a column was added to the master table and the view was not altered.

Action:Other messages will accompany this message. Examine the other messages for a more complete description of the problem. The most likely solution to the problem will be to re-create the snapshot.


ORA-12009

ORA-12009snapshots may not contain long columns

Cause:An attempt was made to create a snapshot with a long column.

Action:Do not attempt to create snapshot logs with long columns.


ORA-12010

ORA-12010cannot create snapshot log on table owned by SYS

Cause:CREATE SNAPSHOT LOG attempts to create a trigger on the table, but triggers can not be created on SYS tables.

Action:Do not create snapshot logs on SYS tables.

________________________________________


ORA-12011

ORA-12011execution of num jobs failed

Cause:Some kind of error was caught in DBMS_IJOB.RUN. One or more jobs that were due to be run produced errors that they could not handle.

Action:Look at the alert log for details on which jobs failed and why.


ORA-12012

ORA-12012error on auto execute of job num

Cause:Some kind of error was caught while doing an automatic execute of a job.

Action:Look at the accompanying errors for details on why the execute failed.


ORA-12013

ORA-12013updatable snapshots must be simple enough to do fast refresh

Cause:The updatable snapshot query statement is specified with a join, subquery, union, CONNECT BY, ORDER BY, or GROUP BY.

Cause:Specify a simpler snapshot statement. If a join is needed, create multiple simple snapshots, and then create a view on top of the multiple snapshots.


ORA-12014

ORA-12014table name does not contain a primary key constraint

CauseThe CREATE SNAPSHOT LOG command was issued with the WITH PRIMARY KEY option and the master table does not contain a primary key constraint or the constraint is disabled.

ActionReissue the command using only the WITH ROWID option, create a primary key constraint on the master table, or enable an existing primary key constraint.


ORA-12015

ORA-12015 cannot create a fast refresh snapshot from a complex query

CauseNeither ROWIDs and nor primary key constraints are supported for complex queries.

ActionReissue the command with the REFRESH FORCE or REFRESH COMPLETE option or create a simple snapshot.


ORA-12017

ORA-12017cannot alter primary key snapshot name to a ROWID snapshot

Cause: Conversion of a primary key snapshot to a ROWID snapshot is not supported.

Action: Create a new snapshot or drop and recreate the snapshot.


ORA-12018

ORA-12018following error encountered during code generation for name.name

Cause:The refresh operations for the indicated snapshot could not be regenerated due to errors. See following error text.

Action:Correct the indicated problem and repeat the operation.


ORA-12019

ORA-12019 master table is a synonym to a remote object

Cause:Snapshot of remote synonyms or snapshot logs on remote synonym are not supported.

Action:Do not create the snapshot or snapshot log on a remote synonym.


ORA-12020

ORA-12020snapshot name is not registered

Cause: Attempt to unregister a snapshot that is not registered.

Action: Nothing needs to be done.


ORA-12021

ORA-12021 snapshot name.name is corrupt

CauseThe snapshot indicated is no longer valid.

ActionContact your customer support representative.


ORA-12022

ORA-12022snapshot log on name.name already has ROWID

Cause: Snapshot log on the indicated table already has ROWID information.

Action: No action required.


ORA-12023

ORA-12023 missing index on snapshot name.name\

Cause: The specified ROWID snapshot does not have the required index on the ROWID column of its underlying table.

Action: The snapshot is corrupted. Drop and recreate the snapshot.


ORA-12024

ORA-12024 snapshot log on name.name does not have primary key columns

Cause: Snapshot log on the indicated table does not have primary key information.

Action: Add primary keys to snapshot log using the ALTER SNAPSHOT command.


ORA-12025

ORA-12025 snapshot log on name.name already has primary keys

Cause: Snapshot log on the indicated table already has primary key columns.

Action: No action required.


ORA-12026

ORA-12026 invalid filter column detected

Cause: One or more of the specified filter columns does not exist or is a primary key column.

Action: Ensure that all specified filter columns exist in the master table and ensure that primary key columns are not included in the list of filter columns.


ORA-12027

ORA-12027 duplicate filter column

Cause: One or more of the specified filter columns is already recorded in the snapshot log.

Action: Describe the snapshot log table and reissue the SQL command specifying the filter columns that are already recorded in the snapshot log.


ORA-12028

ORA-12028:snapshot type is not support by master site name.

Cause: Pre-Oracle8 master sites are not able to support primary key or subquery snapshots that are able to perform a fast refresh.

Action: Create a ROWID snapshot or use a master table from an Oracle8 site.


ORA-12030

ORA-12030: cannot create a fast refresh snapshot

Cause:The snapshot log does not exist or does not log the information needed by the snapshot to perform a fast refresh.

Action: Ensure that the snapshot log exists and logs the necessary information. For ROWID snapshots, the master table's ROWID must be logged. For primary key, snapshots the master table's primary key columns must be logged. For subquery snapshots filter, primary key, and ROWID values must all be logged.


ORA-12031

ORA-12031cannot use primary key columns from snapshot log on name.name

Cause:The snapshot log either does not have primary columns logged, or the timestamp associated with the primary key columns is more recent than the last refresh time.

Action:A complete refresh is required before the next fast refresh.


ORA-12032

ORA-12032 cannot use ROWID column from snapshot log on name.name

Cause: The snapshot log either does not have primary columns logged, or the timestamp associated with the primary key columns is more recent than the last refresh time.

Action: A complete refresh is required before the next fast refresh.


ORA-12033

ORA-12033 cannot use filter columns from snapshot log on name.name

Cause: The snapshot log either does not have primary columns logged, or the timestamp associated with the primary key columns is more recent than the last refresh time.

Action: A complete refresh is required before the next fast refresh.


ORA-12034

ORA-12034snapshot log on name.name more recent than last refresh

Cause: The snapshot log is more recent than the last refresh and cannot be used for fast refresh. The snapshot log is more recent than the last refresh.

Action: Perform a complete refresh of the snapshot before attempting another fast refresh.


ORA-12035

ORA-12035 could not use snapshot log on name.name

Cause: The snapshot log does not exist or cannot be used for fast refresh.

Action: Perform a complete refresh of the snapshot before attempting another fast refresh. If a snapshot log does exist and the snapshot is capable of fast refresh, then the snapshot will be fast refreshable once the complete refresh is performed.


ORA-12036

ORA-12036updatable snapshot log is not empty, refresh snapshot

Cause: The updatable snapshot log must be empty before an updatable ROWID snapshot can be altered to a primary key snapshot.

Action: Ensure that updatable snapshot log is empty by refreshing the snapshot before converting the updatable ROWID snapshot to a primary key snapshot.


ORA-12037

ORA-12037 unknown export format

Cause: An attempt was made to import a snapshot exported by an unknown export version (e.g., from a newer release than the importing site).

Action: Re-export the file using a version of export known by the importing site.


ORA-12038

ORA-12038string literal has unexpected length

Cause: Corrupt or invalid information was detected during import of a snapshot.

Action: Ensure that the export log file has not been corrupted and that no errors were raised during export. Contact customer support if the problem persists.


ORA-12039

ORA-12039unable to use local rollback segment name

Cause: A local rollback segment was specified in the CREATE SNAPSHOT command, but automatic refresh parameters were not specified. Therefore, a refresh group was not created to automatically refresh the snapshot and the local rollback segment cannot be registered for future use.

Action: Either supply the automatic refresh parameters so that a refresh group will be created or do not specify a local rollback segment.


ORA-12040

ORA-12040 master rollback segment option not support by master site name

Cause: The master site of the current snapshot does not allow users to specify a rollback segment to be used for snapshot operations. This feature is only supported by Oracle8 or later master sites.

Action: Do not specify a master rollback segment in the current operation or choose a new master site.


ORA-12150

ORA-12150TNS:Unable to send data

Cause:Unable to send data. Connection probably disconnected.

Action:Re-establish connection. If the error is persistent, turn on tracing and re-execute the operation.


ORA-12151

ORA-12151TNS:Received bad packet type from network layer

Cause:Internal error.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12152

ORA-12152TNS:Unable to send break message

Cause:Unable to send break message. Connection probably disconnected.

Action:Re-establish connection. If the error is persistent, turn on tracing and re-execute the operation.


ORA-12153

ORA-12153TNS:Not connected

Cause:Not currently connected to a remote host.

Action:Re-establish connection.


ORA-12154

ORA-12154TNS:Could not resolve service name

Cause:The service name specified is not defined correctly in the TNSNAMES.ORA file.

Action:Make the following checks and correct the error:

Verify that a TNSNAMES.ORA file exists and is in the proper place and accessible. See the operating system specific manual for details on the required name and location.

Check to see that the service name exists in one of the TNSNAMES.ORA files and add it if necessary.

Make sure there are no syntax errors anywhere in the file. Particularly look for unmatched parentheses or stray characters. Any error in a TNSNAMES.ORA file makes it unusable. See Chapter 4 in the SQL*Net Administrator's Guide. If possible regenerate the configuration files using the Oracle Network Manager.


ORA-12155

ORA-12155TNS:Received bad datatype in NSWMARKER packet

Cause:Internal error during break handling.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12156

ORA-12156TNS:Tried to reset line from incorrect state

Cause:Internal error during break handling.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12157

ORA-12157TNS:Internal network communication error

Cause:Internal error during network communication.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12158

ORA-12158TNS:Could not initialize parameter subsystem

Cause:Unable to locate parameter file.

Action:Verify that a valid parameter file exists, and is readable.


ORA-12159

ORA-12159TNS:trace file not writeable

Cause:The trace file to be generated is not writeable by this user.

Action:If the user does not have write permissions in the directory to which the trace file will be written, contact the DBA to get the proper permissions or use TRACE_DIRECTORY_CLIENT in SQLNET.ORA to specify a directory the user can write to.


ORA-12160

ORA-12160TNS:Internal error: Bad error number

Cause:Corrupt error reporting subsystem.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12161

ORA-12161TNS:Internal error: partial data received

Cause:The connection may be terminated.

Action:Reconnect and try again. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12162

ORA-12162TNS:service name is incorrectly specified

Cause:The connect descriptor corresponding to the service name in TNSNAMES.ORA is incorrectly specified.

Action:Make sure there are no syntax errors in the connect descriptor. Particularly look for unmatched parentheses or stray characters. Any error in the TNSNAMES.ORA file makes it unusable.


ORA-12163

ORA-12163TNS:Connect descriptor is too long.

Cause:The connect descriptor corresponding to the service name in TNSNAMES.ORA is too long.

Action:The maximum length for a connect descriptor is 512 bytes and this limit has been exceeded. Use a smaller connect descriptor. If this is not possible, contact Worldwide Customer Support.


ORA-12164

ORA-12164TNS:sqlnet.fdf file not present

Cause:The sqlnet.fdf file doesn't exist in $ORACLE_HOME/network/admin.

Action:The sqlnet.fdf file is required for Oracle Tracing to occur. Either install the sqlnet.fdf file in $ORACLE_HOME/network/admin or turn off tracing in your ORA file.


ORA-12165

ORA-12165TNS:Trying to write trace file into swap space

Cause:Oracle Trace doesn't allow writing trace information into your swap space.

Action:Oracle Trace cannot write trace information into swap space so either disable tracing or redirect trace files to be written to another area of your disk.


ORA-12166

ORA-12166TNS:client cannot connect to HO agent

Cause:NVstring contained DESCRIPTION/HO.

Action:Call HO agent from integrating server.


ORA-12196

ORA-12196TNS:received an error from TNS

Cause:The navigation layer received an error from TNS.

Action:See the error log file for the specific TNS error.


ORA-12197

ORA-12197TNS:keyword-value resolution error

Cause:The navigation layer received an error while trying to look up a value for a keyword.

Action:Check the syntax of the connect descriptor.


ORA-12200

ORA-12200TNS:Could not allocate memory

Cause:Out of memory on machine.

Action:Reconfigure machine to have more storage or run fewer applications while the Interchange is running.


ORA-12201

ORA-12201TNS:Encountered too small a connection buffer

Cause:TNS connection buffer supplied by the application was too small to retrieve the data sent back.

Action:Supply a larger connection buffer. If problem persists, call Worldwide Customer Support.


ORA-12202

ORA-12202TNS:Internal navigation error

Cause:Internal navigation error.

Action:Not normally visible to the user. For further details contact Worldwide Customer Support.


ORA-12203

ORA-12203TNS:Unable to connect to destination

Cause:Invalid TNS address supplied or destination is not listening. This error can also occur because of underlying network transport problems.

Action:Verify that the service name you entered on the command line was correct. Ensure that the listener is running at the remote node and that the ADDRESS parameters specified in TNSNAMES.ORA are correct. Finally, check that all Interchanges needed to make the connection are up and running.


ORA-12204

ORA-12204TNS:Received data refused from an application

Cause:The application using the Interchange refused the connection at the listener.

Action:Make sure that the listener at the destination is functioning correctly. If it is and the problem persists, contact Worldwide Customer Support.


ORA-12205

ORA-12205TNS:Could not get failed addresses

Cause:Internal navigation error.

Action:Not normally visible to the user. For further details contact Worldwide Customer Support.


ORA-12206

ORA-12206TNS:Received a TNS error during navigation

Cause:Internal navigation error occurred because of an unexpected TNS error.

Action:Look at the log file to find the TNS error. If necessary, turn on tracing and repeat the operation.


ORA-12207

ORA-12207TNS:Unable to perform navigation

Cause:Improperly configured navigation file TNSNAV.ORA.

Action:Check the syntax of the TNSNAV.ORA file on the application's machine, and verify that it lists the correct communities.


ORA-12208

ORA-12208TNS:could not find the TNSNAV.ORA file

Cause:Either the ORACLE environment is not set up correctly, or the TNSNAV.ORA file is not present.

Action:Ensure that the ORACLE environment is set up appropriately on your platform and that a TNSNAV.ORA file is present.


ORA-12209

ORA-12209TNS:encountered uninitialized global

Cause:Application calling navigation routine has not properly configured the global variables. There are no TNSNAV.ORA files available, or they are defective.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12210

ORA-12210TNS:error in finding Navigator data

Cause:Application calling navigation routine has not properly configured the TNSNAV.ORA file.

Action:Check the syntax of the TNSNAV.ORA.


ORA-12211

ORA-12211TNS:needs PREFERRED_CMANAGERS entry in TNSNAV.ORA

Cause:TNSNAV.ORA does not have a PREFERRED_CMANAGERS defined.

Action:Add a PREFERRED_CMANAGERS entry to the TNSNAV.ORA file.


ORA-12212

ORA-12212TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA

Cause:The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have a CMANAGER_NAME specified.

Action:Define the CMANAGER_NAME as part of the PREFERRED_CMANAGERS binding. Use of the Oracle Network Manager should eliminate this error.


ORA-12213

ORA-12213TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA

Cause:The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have an ADDRESS specified.

Action:Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.


ORA-12214

ORA-12214TNS:missing LOCAL_COMMUNITIES entry in TNSNAV.ORA

Cause:There is no LOCAL_COMMUNITIES entry in TNSNAV.ORA.

Action:Define the LOCAL_COMMUNITIES for this node in the TNSNAV.ORA file.


ORA-12215

ORA-12215TNS:poorly formed PREFERRED_NAVIGATORS Addresses in TNSNAV.ORA

Cause:Address binding for PREFERRED_NAVIGATORS entry is improperly entered. entry.

Action:Check your PREFERRED_NAVIGATORS entry and fix it in TNSNAV.ORA.


ORA-12216

ORA-12216TNS:poorly formed PREFERRED_CMANAGERS Addresses in TNSNAV.ORA

Cause:Address binding for the PREFERRED_CMANAGERS entry in the client's TNSNAV.ORA file is improperly entered.

Action:Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.


ORA-12217

ORA-12217TNS:could not contact PREFERRED_CMANAGERS in TNSNAV.ORA

Cause:There is a syntax error in the PREFERRED_CMANAGERS entry, or addresses specified are wrong, or the intended Connection Managers are unavailable

Action:Check the PREFERRED_CMANAGERS entries in the client's TNSNAV.ORA file and correct them or talk with your network administrator to determine if the specified Connection Managers are available. Verify that the Interchanges are active by using the INTCTL STATUS command.


ORA-12218

ORA-12218TNS:unacceptable network configuration data

Cause:Poorly formed network configuration data. For example, a PREFERRED_CMANAGERS entry may have an incorrect CMANAGER_NAME in the client's TNSNAV.ORA file. Or an Interchange downtime parameter (TIMEOUT_INTERVAL) on the Navigator may be set to zero in INTCHG.ORA

Action:Check the entries in TNSNAV.ORA and the Interchange configuration files and correct them. If necessary, talk to your network administrator to determine if the specified Interchanges (Connection Managers) are available and properly configured. Use the Oracle Network Manager to generate the configuration files if necessary.


ORA-12219

ORA-12219TNS:missing community name from address in ADDRESS_LIST

Cause:This error occurs when an ADDRESS_LIST has some ADDRESSes in it that have no COMMUNITY component and others that do have a COMMUNITY component.

Action:Check that in the connect descriptors you are using either all the ADDRESSes have a COMMUNITY component or all do not.


ORA-12221

ORA-12221TNS:illegal ADDRESS parameters

Cause:An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport.

Action:Verify that the destination can be reached using the specified protocol. Check the parameters within the ADDRESS section of TNSNAMES.ORA. Legal ADDRESS parameter formats may be found in the Oracle operating system specific documentation for your platform. Protocols that resolve names at the transport layer (such as DECnet object names) are vulnerable to this error if not properly configured or names are misspelled.


ORA-12222

ORA-12222TNS:no such protocol adapter

Cause:The protocol adapter requested (by way of the "(PROTOCOL=..)" keyword-value pair in a TNS address) is unknown. If the supplied address is typographically correct then the protocol adapter is not installed.

Action:Install the protocol adapter or correct typographically error, as appropriate. Note: if the supplied address was derived from resolving the service name, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA or TNSNET.ORA).


ORA-12223

ORA-12223TNS:internal limit restriction exceeded

Cause:Too many TNS connections open simultaneously.

Action:Wait for connections to close and re-try.


ORA-12224

ORA-12224TNS:no listener

Cause:The connection request could not be completed because the listener is not running.

Action:Ensure that the supplied destination address matches one of the addresses used by the listener - compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.


ORA-12225

ORA-12225TNS:destination host unreachable

Cause:Contact can not be made with remote party.

Action:Make sure the network driver is functioning and the network is up.


ORA-12226

ORA-12226TNS:operating system resource quota exceeded

Cause:The current user has exceeded the allotted resource assigned in the operating system.

Action:Acquire more operating system resource, or perform a different function.


ORA-12227

ORA-12227TNS:syntax error

Cause:The supplied connect descriptor contains illegal syntax.

Action:Check the syntax of the connect descriptor in TNSNAMES.ORA.


ORA-12228

ORA-12228TNS:protocol adapter not loadable

Cause:On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing then this error is returned.

Action:For further details, turn on tracing and re-execute the operation The trace file will include the name of the shared library (or DLL) that could not be loaded.


ORA-12229

ORA-12229TNS:Interchange has no more free connections

Cause:One or more Interchanges along the path to the destination desired has no more free connections available to be used for this call.

Action:Try again later when the Interchanges are less busy, or contact your network administrator to have him determine which interchange it is, and increase the number of connections available on that interchange.


ORA-12230

ORA-12230TNS:Severe Network error occurred in making this connection

Cause:This error is reported by an interchange which fails to make contact with the destination due to a physical network error while calling a destination.

Action:Try again later when the network service may have been fixed or report the problem to your Network Administrator.


ORA-12231

ORA-12231TNS:No connection possible to destination

Cause:This error is reported by an interchange which fails to find a possible connection along the path to the destination

Action:Report the problem to your Network Administrator.


ORA-12232

ORA-12232TNS:No path available to destination

Cause:This error is reported by an interchange which fails to find a possible path to the destination.

Action:Report the problem to your Network Administrator.


ORA-12233

ORA-12233TNS:Failure to accept a connection

Cause:This error is reported by an interchange which fails to accept a connection due to a redirect failure.

Action:Report the problem to your Network Administrator that they might isolate the interchange problem.


ORA-12234

ORA-12234TNS:Redirect to destination

Cause:This error is reported by an interchange which determines that this interchange is not the right gateway and needs to redirect the connection to another gateway along the path to the destination.

Action:None.


ORA-12235

ORA-12235TNS:Failure to redirect to destination

Cause:This error is reported by an interchange which fails to redirect a connection to another interchange along the path to the destination.

Action:Report the problem to your Network Administrator.


ORA-12236

ORA-12236TNS:protocol adapter not loaded

Cause:On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.

Action:For further details, turn on tracing and re-execute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.


ORA-12315

ORA-12315database link type is invalid for the ALTER DATABASE statement

Cause:The database link name specified on the ALTER DATABASE statement is not an ROM: link. Specify an ROM: link when using the ALTER DATABASE statement to mount or open a secondary database.

Action:Re-issue the ALTER DATABASE statement using a valid ROM: link to the database to be mounted or opened. If a valid ROM: link does not exist, create one using the CREATE DATABASE LINK command. See the Trusted ORACLE7 Server Administrator's Guide for more information about creating database links using the ROM: link type.


ORA-12316

ORA-12316syntax error in database link's connect string

Cause:The connect string in the CREATE DATABASE LINK statement has a syntactical error.

Action:Drop the database link and re-create it using valid syntax. See the ORACLE7 Server SQL Language Reference Manual for more information about the connect string portion of the CREATE DATABASE LINK statement.


ORA-12317

ORA-12317logon to database (link name name) denied

Cause:Any of the following:

·Either the user name or password was misspelled.

·The user does not exist in the secondary database.

·The user in the secondary database was not granted the CREATE SESSION system privilege.

·The username/password in the database link definition is invalid for any of the above reasons.

·If database verification of login information is active, then the username and password do not match in the primary and secondary databases.

·If operating system verification of login information is active; then the username, do not match in the primary and secondary databases.

Action:Enter the correct information.

·Ask the database administrator for the secondary database to create the user.

·Ask the database administrator for the secondary database to grant the CREATE SESSION system privilege to the user.

·Correct the database link definition.

·Ensure that username and password match in the primary and secondary databases.

·Ensure that the username matches in the primary and secondary databases.

NOTE: Always use operating system authentication in Trusted ORACLE (see the Trusted ORACLE7 Server Administrator's Guide for more information about the advantages of O/S authentication).


ORA-12318

ORA-12318database (link name name) is already mounted

Cause:An attempt was made to mount a secondary database already mounted by the instance.

Action:No additional action is required to mount the database. To establish access, use the ALTER DATABASE command to open the database.


ORA-12319

ORA-12319database (link name name) is already open

Cause:An attempt was made to open a secondary database that is already open.

Action:No additional action is required to establish access.


ORA-12321

ORA-12321database (link name name) is not open and AUTO_MOUNTING=FALSE

Cause:The instance attempted to mount the secondary database but it is not open and it is not enabled for automatic mounting.

Action:Manually mount and open the secondary database using the ALTER DATABASE command with the OPEN and MOUNT options. To allow the instance to automatically mount and open secondary databases, set the AUTO_MOUNTING parameter in the initialization parameter file to TRUE.


ORA-12322

ORA-12322unable to mount database (link name name)

Cause:This message should be accompanied by additional messages that indicate the cause of the problem.

Action:Follow the steps outlined in the accompanying messages to resolve the problem.


ORA-12323

ORA-12323unable to open database (link name name)

Cause:This message should be accompanied by additional messages that indicate the cause of the problem.

Action:Follow the steps outlined in the accompanying messages to resolve the problem.


ORA-12324

ORA-12324cannot use the ROM: link type on a private database link

Cause:It is only possible to specify the ROM: link type on a public, not a private, database link.

Action:If there is an existing public database link to the secondary database, use that link. If not, and public access to the secondary database is desired, create a public database link to the secondary database using the CREATE DATABASE LINK command.


ORA-12326

ORA-12326database name is closing immediately; no operations are permitted

Cause:The operation attempted was terminated because the database is closing.

Action:Wait until the database reopens, or contact the database administrator.


ORA-12329

ORA-12329database name is closed; no operations are permitted

Cause:The operation attempted was terminated because the database is closing.

Action:Wait until the database is reopened, or contact the database administrator.


ORA-12333

ORA-12333database (link name name) is not mounted

Cause:An attempt was made to open a database that is not mounted.

Action:Mount the database with the ALTER DATABASE command; then re-attempt to open the database.


ORA-12334

ORA-12334database (link name name) is still open

Cause:An attempt was made to dismount a database that is still open.

Action:Close the database with the ALTER DATABASE command; then re-attempt to dismount the database.


ORA-12335

ORA-12335database (link name name) is not open

Cause:An attempt was made to close a database that is not open.

Action:The database is closed; proceed with dismounting it.


ORA-12341

ORA-12341maximum number of open mounts exceeded

Cause:The number specified on the OPEN_MOUNTS parameter in the initialization parameter file exceeds the maximum allowed (255).

Action:Change the value of this initialization parameter so that it reflects the actual number of possible open mounts to secondary databases. This must be less than 255.


ORA-12342

ORA-12342open mounts exceeds limit set on the OPEN_MOUNTS parameter

Cause:The number of currently open mounts exceeds the value specified in the OPEN_MOUNTS initialization parameter.

Action:Increase the value of the OPEN_MOUNTS parameter so that it accommodates the maximum possible number of open mounts to secondary databases.


ORA-12345

ORA-12345user name lacks CREATE SESSION privilege in database (link name %s)

Cause:You tried to connect to a username in the secondary database which exists, but has not been granted the CREATE SESSION privilege.

Action:Grant the CREATE SESSION privilege to the user in the secondary database.


ORA-12350

ORA-12350database link being dropped is still mounted

Cause:An attempt was made to drop a ROM: database link that was still mounted and/or opened.

Action:Close and dismount the database and then re-issue the drop statement.


ORA-12351

ORA-12351cannot create view using a remote object which has a remote object reference

Cause:You tried to create a view which references a remote object which, in turn, references an object on another database. Since the view that you tried to create references a remote object, that object cannot reference an object on another database.

Action:Choose a different object to reference in your view or change the remote object so that it does not reference another database.


ORA-12352

ORA-12352object name is invalid

Cause:An attempt was made to reference, or compile against, an object in a secondary database. However, the object is invalid because it is in a secondary database. Therefore, the system cannot validate or recompile it.

Action:Recompile the invalid object in the secondary database.


ORA-12353

ORA-12353secondary stored object cannot reference remote object

Cause:You tried to either select from a remote view or execute a remote procedure which references an object on another database. Since the remote view or procedure is on a secondary database, an additional reference to another database cannot be done.

Action:Choose a different object to reference or change the remote view or procedure so that it does not reference another database.


ORA-12354

ORA-12354secondary object being dropped

Cause:You tried to access an object, for example, a table or view, on a secondary database that was being dropped.

Action:Repeat the operation. If you receive the message again, try to access the object from the secondary database. If you receive an internal error or a trace file, contact customer support.


ORA-12400

ORA-12400DBLOW is not a valid operating system label

Cause:The operating system label corresponding to DBLOW has become invalid due to a change in operating system label definitions.

Action:Use the operating system facilities to restore the definition of this label, or change the value of DBLOW to a valid label. To change the value of DBLOW, you must mount the database and switch to OSMAC mode.


ORA-12401

ORA-12401DBHIGH is not a valid operating system label

Cause:The operating system label corresponding to DBHIGH has become invalid due to a change in operating system label definitions.

Action:Use the operating system facilities to restore the definition of this label, or change the value of DBHIGH to a valid label. To change the value of DBHIGH, you must mount the database and switch to OSMAC mode.


ORA-12402

ORA-12402file: str

Cause:Reporting file name for detail of another message.

Action:Examine the message stack for additional detail.


ORA-12403

ORA-12403file label (name) must be equal to DBHIGH (name)

Cause:A data file was found to have a label not equal to DBHIGH. This may be caused if DBHIGH is changed, or if a file is re-labeled.

Action:Either re-label the file to match DBHIGH, or change DBHIGH to match the file.


ORA-12404

ORA-12404device low (name) must be dominated by DBLOW (name)

Cause:A data file was found on a device with an authorized range insufficient to handle the lowest labeled data in the file.

Action:Lower the authorized minimum device label or move the file to a different device.


ORA-12405

ORA-12405device high (name) must dominate DBHIGH (name)

Cause:A data file was found on a device with an authorized range insufficient to handle the highest labeled data in the file.

Action:Raise the authorized maximum device label or move the file to a different device.


ORA-12406

ORA-12406must be at DBHIGH (name) in O/S to add files to a tablespace

Cause:A file was added to a new or existing tablespace by a user whose operating system label was not equal to DBHIGH.

Action:Login to the O/S at DBHIGH to add the file. If creating a new tablespace, set the session label to the label at the desired tablespace definition. If adding a file to an existing tablespace, either set the session label to match the tablespace or user WRITE-DOWN privilege to alter the tablespace.


ORA-12407

ORA-12407cannot insert or update the ROWLABEL column of a view

Cause:You tried to insert into or update the ROWLABEL column of a view. Trusted ORACLE does not allow you to modify the ROWLABEL column of a view.

Action:While you cannot modify the ROWLABEL column of a view, you can modify the ROWLABEL column in the base table(s) of the view. Use the INSERT or UPDATE commands to modify the base tables(s); consequently, this modifies the view.


ORA-12408

ORA-12408tablespace previously existed at another label (name)

Cause:A tablespace by this name was previously created and dropped at another label. Part of the dictionary entry for the old tablespace remains, and the new tablespace is attempting to reuse the old entry.

Action:Either re-create the tablespace at the original label or choose a new name for this tablespace.


ORA-12409

ORA-12409DBLOW cannot be null in DBMS MAC mode

Cause:The database was started in DBMS MAC mode before resetting DBLOW.

Action: Restart the database in OS MAC mode and supply valid values for both DBHIGH and DBLOW before starting up in DBMS MAC mode.


ORA-12410

ORA-12410DBHIGH cannot be null in DBMS MAC mode

Cause:The database was started in DBMS MAC mode before resetting DBHIGH.

Action:Restart the database in OS MAC mode and supply valid values for both DBHIGH and DBLOW before starting up in DBMS MAC mode.


ORA-12411

ORA-12411DBHIGH must dominate DBLOW

Cause:DBHIGH does not dominate DBLOW.

Action:Restart the database in OS MAC mode and supply valid values for DBHIGH and DBLOW before starting up in DBMS MAC mode.


ORA-12412

ORA-12412DBLOW must be dominated by name

Cause:An attempt was made to set DBLOW higher than the greatest lower bound of existing data.

Action: Set DBLOW to the given label or lower.


ORA-12413

ORA-12413DBHIGH must dominate name

Cause:An attempt was made to set DBHIGH lower than the least upper bound of existing data.

Action:Set DBHIGH to the given label or higher.


ORA-12414

ORA-12414must be DBHIGH (var) to startup database

Cause:You tried to open a database while at an O/S label not equal to DBHIGH.

Action:Login at DBHIGH to start the database.


ORA-12415

ORA-12415label of role grant must dominate role name

Cause:An attempt was made to grant a privilege to a role below the label where the role was created.

Action:Check the label of the role and perform the grant at the label of the role or higher.


ORA-12416

ORA-12416label of audit must dominate user

Cause:An attempt was made to set statement audit options on a user below the label where the user was created.

Action:Check the label of the user and set the audit options at the user label or higher.


ORA-12418

ORA-12418label of index must equal table

Cause:An attempt was made to create an index on a table at a label different than where the table was created. It is necessary to be at the identical label, and specifically at DBHIGH or DBLOW if the table was created at DBHIGH or DBLOW.

Action:Check the label of the table and create the index at the correct label.


ORA-12419

ORA-12419label of column must equal table

Cause:An attempt was made to add a column to a table at a different label than where the table was created.

Action:Check the label of the table and add the column at the correct label.


ORA-12420

ORA-12420label of stored object must dominate referenced object name

Cause:An attempt was made to create a stored object (view, procedure, function trigger) which references some object not dominated by the current label. While the referenced object may be visible due to enable MAC privileges, MAC privileges cannot be used for creating the stored object.

Action:Check the label of the indicated object and create the new object at a label which dominates all referenced objects.


ORA-12421

ORA-12421label of grant must dominate object

Cause:An attempt was made to grant privileges on an object at a label lower than where the object was created.

Action:Check the label of the object and perform the grant at the object label or higher.


ORA-12422

ORA-12422label of grant must dominate grantee name

Cause:An attempt was made to grant privileges to a user at a label lower than where the user was created.

Action:Check the label of the grantee and perform the grant at that label or higher.


ORA-12423

ORA-12423label of constraint must equal table

Cause:An attempt was made to add a constraint to a table at a label different than the label of the table.

Action:Check the label of the table and add the constraint at the label of the table.


ORA-12424

ORA-12424label of object must dominate tablespace

Cause:An attempt was made to create an object in a tablespace created at a label higher than the object.

Action:Check the label of the tablespace and create the object at that label or higher.


ORA-12425

ORA-12425label of table must dominate cluster

Cause:An attempt was made to crate a table in a cluster created higher than the label of the table.

Action:Check the label of the cluster and create the table at that label or higher.


ORA-12426

ORA-12426label of user must dominate default or temporary tablespace

Cause:An attempt was made to give a user a default or temporary tablespace at a higher label.

Action:Check the label of the default and temporary tablespaces and create the user at that label or higher.


ORA-12427

ORA-12427label of object must dominate schema

Cause:An attempt was made to create an object in a schema defined at a label higher than the object.

Action:Check the label of the schema and create the object at that label or higher.


ORA-12428

ORA-12428insufficient MAC privileges

Cause:There are sufficient privileges to read the object, but no MAC write access to the object.

Action:Either retry the operation at the label of the object, or see the system administrator for the needed MAC privilege.


ORA-12430

ORA-12430label of trigger must equal table

Cause:An attempt was made to create a trigger at a label different than where the table was created.

Action:Check the label of the table and create the trigger at that label.


ORA-12430

ORA-12430label of trigger must equal table

Cause:An attempt was made to create a trigger at a label different from where the table was created. Your DBMS label must match the table's creation label to create the trigger on the table. While the table may be visible due to enabled MAC privileges, MAC privileges cannot be used to create a trigger.

Action:Check the creation label of the table and create the trigger while at a label that matches the creation label of the table.


ORA-12431

ORA-12431label of user must dominate default profile

Cause:An attempt was made to give a user a default profile created at a label lower than the user.

Action:Check the label of the profile and create the user at that label or higher.


ORA-12432

ORA-12432label of default role name must dominate user

Cause:An attempt was made to assign a user a default role list at a label higher than the user.

Action:Check the label of the user and assign the default roles at that label.


ORA-12433

ORA-12433label of default role name must dominate user

Cause:An attempt was made to assign a user a default role created at a label below where the user was created.

Action:Check the labels of the user and role and assign only roles higher than the user.


ORA-12434

ORA-12434label of child record must dominate parent

Cause:An attempt was made to insert a child record at a label lower than the corresponding parent record.

Action:Check the label of the parent key value and insert the child record at that label or higher.


ORA-12435

ORA-12435label of package body must equal package

Cause:An attempt was made to create a package body at a label different than the corresponding package.

Action:Check the label of the package and create the package body at that label.


ORA-12436

ORA-12436package body must exist to grant MAC privileges

Cause:An attempt was made to grant MAC privileges to a package when the package body does not exist.

Action:Create the package body for the package and then re-attempt the grant.


ORA-12437

ORA-12437cannot to write down to a database at a lower label

Cause:An attempt was made to perform a write operation in a secondary database. Write operations are only possible in the primary database.

Action:Connect directly to the database to perform the operation.


ORA-12438

ORA-12438insufficient privileges to validate constraint on all rows

Cause:It is necessary to have access to all rows in a table in order to attempt to enable a constraint.

Action:To read all rows in the table either enable MAC privileges or downgrade all rows in the table.


ORA-12439

ORA-12439cannot modify ROWLABEL column

Cause:An attempt was made to modify the ROWLABEL column.

Action:None. It is not possible to modify the ROWLABEL column.


ORA-12440

ORA-12440database has not been mounted in read-compatible mode

Cause:The requested secondary database was not last started in read-compatible mode.

Action:Set the DB_MOUNT_MODE initialization parameter to READ_COMPATIBLE in the secondary database and startup the secondary database.


ORA-12441

ORA-12441grant already exists at a different label

Cause:One of the privileges granted was previously granted at a different label.

Action:Check USER_SYS_GRANTS or USER_OBJ_GRANTS to locate the label at which the privilege was previously granted. Revoke the old grant and re-grant it at the new label.


ORA-12442

ORA-12442must be at same label as user to modify default roles

Cause:An attempt was made to modify a user's default roles at a different label than where the user was created.

Action:Check the ALL_USERS view to see the label at which the user was created and alter the user at that label.


ORA-12443

ORA-12443audit option already exists at a different label

Cause:You tried to audit an event that was previously audited at a different label.

Action:Check the DBA_STMT_AUDIT_OPTS or DBA_PRIV_AUDIT_OPTS dictionary views to identify the label of the previous audit statement. If you want to audit the event at the new label, stop the old audit (using the NOAUDIT statement) and re-audit the event while at the new label.


ORA-12444

ORA-12444file label is lower than instance label

Cause:You tried to reuse a file with a label different from the database instance label.

Action:Examine the message stack for the filename. Remove the file or relabel it to match the database instance label.


ORA-12445

ORA-12445index/row label mismatch - see trace file

Cause:A label in an index has been found not to match the row to which that label points. This may indicate that index labels have been directly changed, which is inappropriate.

Action:To solve the immediate problem, you can drop and recreate the index. If you are unsure of the problem's cause, contact customer support and send them the trace file.


ORA-12446

ORA-12446file label is higher than instance label

Cause:You tried to reuse a file with a label different than the database instance label. You can only reuse files labeled at or below the instance label.

Action:Examine the message stack for the file name. Remove the file or re-label it to match the database instance label.


ORA-12447

ORA-12447non-secure protocol used; connection denied

Cause:You tried to connect to Trusted ORACLE7 with a networking protocol that was not secure. You must use a secure networking protocol to connect via a remote location.

Action:Either connect to the database with a secure networking protocol or log in directly to the database.


ORA-12449

ORA-12449least upper bound resulted in an invalid operating system label

Cause:You tried to do an operation that generated a least upper bound (LUB) label which is not a valid label on your operating system.

Action:Examine the message stack for a more specific messages. See your installation or user's guide for information on invalid label generation. See the Trusted ORACLE7 Server Administrator's Guide for information on least upper bound (LUB) functions.


ORA-12450

ORA-12450label string could not be translated into binary label

Cause:The operating system could not translate given label string

Action:Ensure the string specified is a valid label and retry the operation.


ORA-12451

ORA-12451binary OS label could not be translated into string label

Cause:The operating system could not translate the specified binary label.

Action:Ensure the string specified is a valid label, and retry the operation.


ORA-12452

ORA-12452label format string could not be parsed; check format codes

Cause:An invalid format string on a label function was specified.

Action:Ensure a valid format string is specified and retry the operation. See the Trusted ORACLE7 Server Administrator's Guide for a complete list of valid format strings.


ORA-12453

ORA-12453missing quote in literal string

Cause:A literal string was specified with an incorrect number of quotes.

Action:Ensure the string has matching quotes and retry the operation.


ORA-12454

ORA-12454punctuation supplied does not match specified input format

Cause:The punctuation supplied in the label string is inconsistent with the format specified.

Action:Change the punctuation in the label string or the format, whichever is appropriate, and reissue the statement.


ORA-12455

ORA-12455OS format not allowed in this context

Cause:The label format string supplied has an O/S format which is not allowed with the TO_LABEL function.

Action:Change the label format string to not use the OS format type.


ORA-12456

ORA-12456literal string supplied does not match specified input format

Cause:The literal string supplied is inconsistent with the format string specified.

Action:Change the literal in the label string or format, whichever is appropriate, and reissue the statement.


ORA-12457

ORA-12457invalid length for MLSLABEL bind variable

Cause:A bind variable of type MLSLABEL is too long.

Action:Consult your documentation for proper datatype lengths.


ORA-12458

ORA-12458the input string could not be translated into a binary label

Cause:The input string you specified is not a valid binary label on your operating system.

Action:Check the input string, change any components so that they form a valid label, and retry the operation.


ORA-12459

ORA-12459maximum number of columns in a Trusted Oracle table is 253

Cause:A CREATE or ALTER TABLE statement tried to add more than 253 columns (not counting ROWLABEL) to a table.

Action:Specify no more than 253 columns in your CREATE or ALTER TABLE command.


ORA-12460

ORA-12460the value var for the MLS_LABEL_FORMAT parameter is not valid

Cause:The value for the MLS_LABEL_FORMAT initialization parameter you specified does not contain a valid format mask. You must have a valid MLS_LABEL_FORMAT parameter for the database to start up.

Action:Change this parameter setting in your initialization parameter file to a correct value.


ORA-12461

ORA-12461invalid binary label

Cause:You provided a binary label in an OCI program's bind statement that was not a valid operating system label.

Action:Replace the invalid binary label with one that is valid.


ORA-12470

ORA-12470process label could not be found

Cause:An message was encountered in translating the operating system process label into a label number.

Action:Examine the message stack for a more specific message.


ORA-12475

ORA-12475cannot login below DBLOW (name)

Cause:An attempt was made to login at a label dominated by DBLOW.

Action:Either login at a higher label, or lower DBLOW.


ORA-12476

ORA-12476cannot login above DBHIGH (name)

Cause:The user attempted to login at a label dominating DBHIGH.

Action:Either login at a lower label, or raise DBHIGH.


ORA-12478

ORA-12478cannot insert label above DBHIGH (var)

Cause:You tried to explicitly insert a value above DBHIGH into the ROWLABEL column, or tried to specify a value higher of datatype MLSLABEL. Any label you insert into a Trusted ORACLE table must fall between DBLOW and DBHIGH, inclusive.

Action:Either raise the value of DBHIGH, or specify a lower label on the INSERT or UPDATE statement.


ORA-12480

ORA-12480secondary database changing between OS MAC and DBMS MAC modes

Cause:An attempt was made to access a secondary database while the secondary database is in the process of changing between OS MAC and DBMS MAC modes.

Action:Retry the operation after the change is complete.


ORA-12485

ORA-12485cannot find file label for name

Cause:An message was encountered while reading the label of the specified file.

Action: Examine the message stack for an operating system message.


ORA-12487

ORA-12487insufficient privileges to set label to DBHIGH or DBLOW

Cause:It is only possible to set a label to DBHIGH or DBLOW when connected INTERNAL to Trusted ORACLE.

Action:Connect INTERNAL to Trusted ORACLE; then set the label DBHIGH or DBLOW. If this is not possible due to insufficient privileges, contact the database administrator.


ORA-12488

ORA-12488session label must be equal to name

Cause:An attempt was made to login to an OS MAC database at other than the database label.

Action:Login from an OS process at the specified label.


ORA-12489

ORA-12489insufficient MAC privilege to alter session.

Cause:User does not have sufficient MAC privileges to alter session.

Action:Either change the OS label so ALTER SESSION is not needed, or obtain MAC privileges.


ORA-12490

ORA-12490cannot connect at session label below user definition (name)

Cause:An attempt was made to alter a session label below the label at which the user was created.

Action:Either do not alter the session label below the specified label, or re-create the user at a lower label.


ORA-12491

ORA-12491cannot change MAC mode when mounted in READ_COMPATIBLE mode

Cause:You tried to change between OS and DB MAC mode while the database was mounted in READ_COMPATIBLE mode.

Action:Set the DB_MOUNT_MODE initialization parameter to NORMAL and restart the database.


ORA-12494

ORA-12494cannot mount secondary database labeled above DBLOW

Cause:The secondary database requested was labeled above the DBLOW of the primary database.

Action:Make sure that DBHIGH on the secondary database is below DBLOW of the primary database.

________________________________________


ORA-12495

ORA-12495multi-threaded server cannot be used with Trusted Oracle

Cause:The MTS_DISPATCHERS parameter is set in the initialization file, which initiated the configuration of the multi-threaded server.

Action:Remove the MTS_DISPATCHERS parameter from the initialization file and restart the instance.


ORA-12500

ORA-12500TNS:listener failed to start a dedicated server process

Cause:The process of starting up a dedicated server process failed. The executable could not be found or the environment may be set up incorrectly.

Action:Turn on tracing at the ADMIN level and re-execute the operation. Verify that the ORACLE Server executable is present and has execute permissions enabled. Ensure that the ORACLE environment is specified correctly in LISTENER.ORA. If error persists, contact Worldwide Customer Support.


ORA-12502

ORA-12502TNS:listener received no CONNECT_DATA from client

Cause:No CONNECT_DATA was passed to the listener.

Action:Check that the service name resolved from TNSNAMES.ORA has the CONNECT_DATA component of the connect descriptor.


ORA-12504

ORA-12504TNS:listener was not given the SID in CONNECT_DATA

Cause:The SID was missing from the CONNECT_DATA.

Action:Check that the connect descriptor corresponding to the service name in TNSNAMES.ORA has an SID component in the CONNECT_DATA.


ORA-12505

ORA-12505TNS:Listener could not resolve SID given in connect descriptor

Cause:The SID in the CONNECT_DATA was not found in the listener's tables.

Action:Check to make sure that the SID specified is correct. The SIDs that are currently registered with the listener can be obtained by typing supported can be obtained by typing "LSNRCTL SERVICES listener_name". These SIDs correspond to SID_NAMEs in TNSNAMES.ORA or db_names in INIT.ORA. Comment: This error will be returned if the database instance has not registered with the listener; the instance may need to be started.


ORA-12509

ORA-12509TNS:listener failed to redirect client to service handler

Cause:The dispatcher terminated unexpectedly.

Action:Attempt to connect again and if the same error occurs, contact the DBA to check the state of the dispatchers for this SID. If the problem persists, turn on tracing in the listener to determine the TNS error caused by the redirect.


ORA-12510

ORA-12510TNS:database lacks resources to handle the request for this SID

Cause:The dispatchers are busy handling other requests.

Action:Contact the DBA to increase the number of dispatchers servicing this SID.


ORA-12511

ORA-12511TNS:service handler found but it is not accepting connections

Cause:The dispatchers are busy handling other requests and they notified the listener that they were temporarily busy.

Action:Attempt the connection again. If the error persists, ask the DBA to increase the number of dispatchers.


ORA-12512

ORA-12512TNS:service handler found but it has not registered a redirect address

Cause:The dispatcher just came up and has not had time yet to register the address that a client should be redirected to.

Action:Attempt the connection again. If the error persists, ask the DBA to increase the number of dispatchers.


ORA-12513

ORA-12513TNS:service handler found but it has registered on a different protocol

Cause:The dispatchers registered for this service are connected to the listener by way of a different network protocol than that of the client.

Action:Contact the DBA to register a dispatcher on your protocol.


ORA-12531

ORA-12531TNS:cannot allocate memory

Cause:Sufficient memory could not be allocated to perform the desired activity.

Action:Either free some resource for TNS, or add more memory to the machine. For further details, turn on tracing and re-execute the operation.


ORA-12532

ORA-12532TNS:invalid argument

Cause:An internal function received an invalid parameter.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12533

ORA-12533TNS:illegal ADDRESS parameters

Cause:An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport. Check the protocol parameters and verify that the destination can be reached using the specified protocol.

Action:Check the parameters within the ADDRESS section of TNSNAMES.ORA Legal ADDRESS parameter formats may be found in the Oracle operating system specific documentation for your platform. Protocols that resolve names at the transport layer (such as DECnet object names) are vulnerable to this error if not properly configured or names are misspelled.


ORA-12534

ORA-12534TNS:operation not supported

Cause:An internal function received a request to perform an operation that is not supported (on this machine).

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12535

ORA-12535TNS:operation timed out

Cause:The requested operation could not be completed within the timeout period specified by the CONNECT_TIMEOUT parameter in LISTENER.ORA. This error arises from the tnslsnr.

Action:Either reconfigure CONNECT_TIMEOUT to be 0, which means wait indefinitely, or reconfigure CONNECT_TIMEOUT to be some higher value. Or, if the timeout is unacceptably long, turn on tracing for further information.


ORA-12536

ORA-12536TNS:operation would block

Cause:An internal operation did not commence because to do so would block the current process and the user has requested that operations be non-blocking.

Action:None needed; this is an information message.


ORA-12537

ORA-12537TNS:connection closed

Cause:Normal end of file condition has been reached; partner has disconnected.

Action:None needed; this is an information message.


ORA-12538

ORA-12538TNS:no such protocol adapter

Cause:The protocol adapter requested (by way of the (PROTOCOL=) keyword-value pair in a TNS address is unknown. If the supplied address is typographically correct then the protocol adapter is not installed.

Action:Install the protocol adapter or correct the typographical error, as appropriate. Note: if the supplied address was derived from resolving the service name resolution, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA, or TNSNET.ORA).


ORA-12539

ORA-12539TNS:buffer over- or under- flow

Cause:Buffer too small for incoming data or too large for outgoing data.

Action:This restriction (which is associated with CONNECT DATA) is not normally visible to the user. For further details, turn on tracing and re-execute the operation; contact Worldwide Customer Support.


ORA-12540

ORA-12540TNS:internal limit restriction exceeded

Cause:Too many TNS connections open simultaneously.

Action:Wait for connections to close and re-try.


ORA-12541

ORA-12541TNS:no listener

Cause:The connection request could not be completed because the listener is not running.

Action:Ensure that the supplied destination address matches one of the addresses used by the listener -- compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.


ORA-12542

ORA-12542TNS:address already in use

Cause:Specified listener address is already being used.

Action:Start your listener with a unique address.


ORA-12543

ORA-12543TNS:destination host unreachable

Cause:Contact cannot be made with remote party.

Action:Make sure the network driver is functioning and the network is up.


ORA-12544

ORA-12544TNS:contexts have different wait/test functions

Cause:Two protocol adapters have conflicting waittest functions.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12545

ORA-12545Connect failed because target host or object does not exist

Cause:The address specified is not valid, or the program being connected to does not exist.

Action:Ensure the ADDRESS parameters have been entered correctly; the most likely incorrect parameter is the node name. Ensure that the executable for the server exists (perhaps "oracle" is missing.) If the protocol is TCP/IP, edit the TNSNAMES.ORA file to change the host name to a numeric IP address and try again.


ORA-12546

ORA-12546TNS:permission denied

Cause:User has insufficient privileges to perform the requested operation.

Action:Acquire necessary privileges and try again.


ORA-12547

ORA-12547TNS:lost contact

Cause:Partner has unexpectedly gone away, usually during process startup.

Action:Investigate partner application for abnormal termination. On an Interchange, this can happen if the machine is overloaded.


ORA-12548

ORA-12548TNS:incomplete read or write

Cause:A data send or receive failed.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12549

ORA-12549TNS:operating system resource quota exceeded

Cause:The current user has exceeded the allotted resource assigned in the operating system.

Action:Acquire more operating system resource, or perform a different function.


ORA-12550

ORA-12550TNS:syntax error

Cause:The supplied connect descriptor contains illegal syntax.

Action:Check the syntax of the connect descriptor in TNSNAMES.ORA.


ORA-12551

ORA-12551TNS:missing keyword

Cause:The supplied connect descriptor is missing one or more TNS keywords.

Action:Check the syntax, and ensure all required keywords are present.


ORA-12552

ORA-12552TNS:operation was interrupted

Cause:An internal operation was interrupted and could not complete.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12554

ORA-12554TNS:current operation still in progress

Cause:An internal operation is still in progress.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support


ORA-12555

ORA-12555TNS:permission denied

Cause:User has insufficient privileges to perform the requested operation.

Action:Acquire necessary privileges and try again.


ORA-12556

ORA-12556TNS:no caller

Cause:TNS detected an incoming connect request but there was no caller.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support


ORA-12557

ORA-12557TNS:protocol adapter not loadable

Cause:On some platforms (such as OS2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing then this error is returned.

Action:For further details, turn on tracing and re-execute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.


ORA-12558

ORA-12558TNS:protocol adapter not loaded

Cause:On some platforms (such as OS2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.

Action:For further details, turn on tracing and re-execute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.


ORA-12560

ORA-12560TNS:protocol adapter error

Cause:A generic protocol adapter error occurred.

Action:Check addresses used for proper protocol specification. Before reporting this error, look at the error stack and check for lower level transport errors. For further details, turn on tracing and re-execute the operation. Turn off tracing when the operation is complete.


ORA-12561

ORA-12561TNS:unknown error

Cause:A generic protocol error occurred.

Action:For further details, turn on tracing and re-execute the operation.


ORA-12562

ORA-12562TNS:bad global handle

Cause:Internal error-bad gbh argument passed to TNS from caller. System may have been linked with old libraries.

Action:Not normally visible to user. Contact Worldwide Customer Support.


ORA-12564

ORA-12564TNS:connection refused

Cause:The connect request was denied by the remote user (or TNS software).

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation.


ORA-12566

ORA-12566TNS:protocol error

Cause:An unexpected TNS protocol error has occurred.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12569

ORA-12569TNS:packet checksum failure

Cause:The data received is not the same as the data sent.

Action:Attempt the transaction again. If the error is persistent, turn on tracing and re-execute the operation.


ORA-12570

ORA-12570TNS:packet reader failure

Cause:An error occurred during a data receive.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12571

ORA-12571TNS:packet writer failure

Cause:An error occurred during a data send.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12574

ORA-12574TNS:redirection denied

Cause:The connect request failed because it would have required redirection and the caller has requested no redirections.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12582

ORA-12582TNS:invalid operation

Cause:An internal function received an invalid request.

Action:Not normally visible to the user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12585

ORA-12585TNS:data truncation

Cause:A receive operation has completed with insufficient data to satisfy the user's request.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12589

ORA-12589TNS:connection not bequeathable

Cause:An attempt to hand-off a connection from one process to another has failed because the protocol provider does not support it.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12590

ORA-12590TNS:no IO buffer

Cause:An attempt to perform an IO operation failed because no buffer was available.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support


ORA-12591

ORA-12591TNS:event signal failure

Cause:The TNS software is unable to signal an event occurrence.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12592

ORA-12592TNS:bad packet

Cause:An ill-formed packet has been detected by the TNS software.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12593

ORA-12593TNS:no registered connection

Cause:An attempt to solicit network event activity has failed because no connections are registered for event notification.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12595

ORA-12595TNS:no confirmation

Cause:TNS is unable to get requested confirmation acknowledgment from remote partner.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12596

ORA-12596TNS:internal inconsistency

Cause:TNS has detected an internal inconsistency

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12597

ORA-12597TNS:connect descriptor already in use

Cause:Internal error - illegal use of connect descriptor.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support


ORA-12598

ORA-12598TNS:banner registration failed

Cause:The registration of the product banner with the Oracle server failed.

Action:This is an error which is not normally visible externally. Enable tracing and attempt to repeat the error. If it occurs again, contact Worldwide Customer Support.


ORA-12599

ORA-12599TNS:cryptographic checksum mismatch

Cause:The data received is not the same as the data sent.

Action:Attempt the transaction again. If error persists, check (and correct) the integrity of your physical connection.


ORA-12600

ORA-12600TNS:string open failed

Cause:The creation of the string in ORACLE NLS format failed.

Action:This is an internal error. Enable tracing and attempt to repeat the error. If it occurs again, contact Worldwide Customer Support.


ORA-12601

ORA-12601TNS:information flags check failed

Cause:The TNS information flags set by the process prior to connection negotiation were not present after the negotiation was finished.

Action:This is an internal error. Enable tracing and attempt to repeat the error. If it occurs again, contact Worldwide Customer Support.


ORA-12611

ORA-12611TNS:operation is not portable

Cause:Attempted operation is not portable.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12612

ORA-12612TNS:connection is busy

Cause:Attempted operation failed because it conflicts with an on-going action or status of the connection.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12615

ORA-12615TNS:preempt error

Cause:A request to service an event failed because no event notification has yet been posted.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12616

ORA-12616TNS:no event signals

Cause:The TNS software is unable to enable event signals.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12617

ORA-12617TNS:bad 'what' type

Cause:The operation failed because the type of data specified is unknown.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12618

ORA-12618TNS:versions are incompatible

Cause:The two machines are running incompatible versions of TNS.

Action:Check the version numbers, and upgrade the machine with the smaller one.


ORA-12619

ORA-12619TNS:unable to grant requested service

Cause:The connect request failed because requested service could not be provided by the local TNS software.

Action:If appropriate, re-execute with reduced service requirements.


ORA-12620

ORA-12620TNS:requested characteristic not available

Cause:The connect request failed because a requested transport characteristic could not be supported by the remote TNS software.

Action:If appropriate, re-execute with reduced requirements.


ORA-12622

ORA-12622TNS:event notifications are not homogeneous

Cause:An attempt to register a connection for event notification failed because the event notification type conflicts with existing registrations.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation and contact Worldwide Customer Support


ORA-12623

ORA-12623TNS:operation is illegal in this state

Cause:Connection is half-duplex and a full-duplex operation was attempted.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation. If error persists, contact Worldwide Customer Support.


ORA-12624

ORA-12624TNS:connection is already registered

Cause:An attempt to register a connection for event notification failed because the connection is already registered.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation and contact Worldwide Customer Support.


ORA-12625

ORA-12625TNS:missing argument

Cause:An operation failed because an argument was missing.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation and contact Worldwide Customer Support.


ORA-12626

ORA-12626TNS:bad event type

Cause:An attempt to register a connection for event notification failed because the event type is unknown.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation and contact Worldwide Customer Support.


ORA-12628

ORA-12628TNS:no event callbacks

Cause:An attempt to register a connection for event modification failed because asynchronous callbacks are not available.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation and contact Worldwide Customer Support


ORA-12629

ORA-12629TNS:no event test

Cause:An attempt to register a connection for event notification failed because the ability to test for events is not available.

Action:Not normally visible to user. For further details, turn on tracing and re-execute the operation and contact Worldwide Customer Support.


ORA-12630

ORA-12630Native service operation not supported

Cause:An operation requested by a user is not supported by the native services component.

Action:This may be an internal error if the operation should have been supported.


ORA-12631

ORA-12631Username retrieval failed

Cause:The authentication service failed to retrieve the name of a user.

Action:Enable tracing to determine which routine is failing.


ORA-12632

ORA-12632Role fetch failed

Cause:The authentication service failed to retrieve one of the user's roles.

Action:Enable tracing to determine which routine is failing.


ORA-12633

ORA-12633No shared authentication services

Cause:The list of authentication services specified by the user does not match those supported by the process.

Action:Either specify another list or relink the executable with the desired services.


ORA-12634

ORA-12634Memory allocation failed

Cause:Process was unable to allocate memory.

Action:Terminate other processes in order to reclaim needed memory.


ORA-12635

ORA-12635No authentication adapters available

Cause:The executable was not linked with any authentication service adapters but the sqlnet.ora parameter that determines whether or not authentication is required was set to true.

Action:Either disable the parameter or relink the executable with service adapters.


ORA-12636

ORA-12636Packet send failed

Cause:A process was unable to send a packet to another process. Possible causes are:

1. The other process was terminated.

2. The machine on which the other process is running went down.

3. Some other communications error occurred.

Action:If the cause is not obvious, contact Worldwide Customer Support.


ORA-12637

ORA-12637Packet receive failed

Cause:A process was unable to receive a packet from another process. Possible causes are:

1. The other process was terminated.

2. The machine on which the other process is running went down.

3. Some other communications error occurred.

Action:If the cause is not obvious, contact Worldwide Customer Support


ORA-12638

ORA-12638Credential retrieval failed

Cause:The authentication service failed to retrieve the credentials of a user.

Action:Enable tracing to determine the exact error.


ORA-12639

ORA-12639Authentication service negotiation failed

Cause:No match was found between the types of authentication services that the client supports and those that the server is using.

Action:Possible solutions:

1. Change the entry in sqlnet.ora that determines which services are to be used.

2. Relink the client with at least one of the authentication service adapters that the server supports.

3. Relink the server with at least one of the authentication service adapters that the client supports.

4. Disable authentication on both the client and server.


ORA-12640

ORA-12640Authentication service initialization failed

Cause:The function specified in the authentication table entry for the service failed.

Action:Enable tracing to determine the exact error.


ORA-12641

ORA-12641Authentication service failed to initialize

Cause:The authentication service failed during initialization.

Action:Enable tracing to determine the exact error.


ORA-12642

ORA-12642No session key

Cause:A process has no session key associated with it because the authentication service being used does not use one.

Action:If a session key is required, use another authentication service.


ORA-12643

ORA-12643Client received internal error from server

Cause:The client process received an error from the server that indicated that an internal SQL*Net native services error had occurred.

Action:Enable tracing on both processes and attempt to recreate the problem. If successful in recreating the problem, contact Worldwide Customer Support.


ORA-12644

ORA-12644Authentication service initialization failed

Cause:The routine called to initialize the authentication adapter failed.

Action:Enable tracing to determine the exact error. A likely cause is that memory is exhausted.


ORA-12645

ORA-12645Parameter does not exist

Cause:A sqlnet.ora parameter from which a value was needed does not exist.

Action:Set the parameter in the parameter file.


ORA-12646

ORA-12646Invalid value specified for boolean parameter

Cause:The value specified for a parameter was set to a value other than true/false or on/off.

Action:Correct the value of the parameter.


ORA-12647

ORA-12647Authentication required

Cause:The parameter that controls whether authentication is required was set to TRUE, but the executable does not have an authentication service linked in.

Action:Either re-link the executable with an authentication service adapter or disable the parameter.


ORA-12648

ORA-12648Encryption or data integrity algorithm list empty

Cause:A SQL*Net list-of-algorithms parameter was empty, e.g. ( ).

Action:Change the list to contain the name of at least one installed algorithm, or remove the list entirely if every installed algorithm is acceptable.


ORA-12649

ORA-12649Unknown encryption or data integrity algorithm

Cause:A SQL*Net list-of-algorithms parameter included an algorithm name that was not recognized.

Action:Either remove that algorithm name, correct it if it was misspelled, or install the driver for the missing algorithm.


ORA-12650

ORA-12650No common encryption or data integrity algorithm

Cause:The client and server have no algorithm in common for either encryption or data integrity or both.

Action:Choose sets of algorithms that overlap. In other words, add one of the client's algorithm choices to the server's list or vice versa.


ORA-12651

ORA-12651Encryption or data integrity algorithm unacceptable

Cause:The algorithm the server chose to use for encryption or data integrity was not one of the choices acceptable to the client. This is either the result of an internal error, of a network data transmission error, or of deliberate tampering with the transmitted data.

Action:For further details, turn on tracing, re-execute the operation, and contact Worldwide Customer Support.


ORA-12652

ORA-12652String truncated

Cause:Not enough memory was allocated for a string so it had to be truncated.

Action:If it is OK that the string is truncated, then it is not an error. Otherwise, call the routine that reported the error again with a larger string buffer.


ORA-12653

ORA-12653Authentication control function failed

Cause:The control function utilized by the authentication service driver failed.

Action:Enable tracing to determine the exact error.


ORA-12654

ORA-12654Authentication conversion failed

Cause:The authentication service was unable to convert the credentials of a user from the format specified to the ORACLE format.

Action:Enable tracing to determine the exact error.


ORA-12655

ORA-12655Password check failed

Cause:The authentication service being used was unable to verify the provided password.

Action:Enable tracing to determine the exact error.


ORA-12656

ORA-12656Cryptographic checksum mismatch

Cause:The cryptographic checksum received with a packet of incoming data didn't match the checksum computed by the receiving end. This indicates that the packet was tampered with or otherwise corrupted in transit.

Action:Look for sources of data corruption, perhaps including deliberate tampering.


ORA-12657

ORA-12657No algorithms installed

Cause:The near side of the connection required the use of a service (either encryption or checksumming) when no algorithms for that service were installed.

Action:Remove the ON requirement for that service.


ORA-12658

ORA-12658Native service required but TNS version is incompatible

Cause:A process that is running an earlier version of TNS attempted to connect but the connection failed because the server process required that a native service (authentication, encryption, etc.) be used.

Action:Relink the calling executable and retry the connection or eliminate the requirement that the service be used on the server side.


ORA-12659

ORA-12659Error received from other process

Cause:An error was received by one or more services from the process on the other side of the connection.

Action:Enable tracing to determine the exact error(s). The error(s) is (are) not returned directly because an error generated by a server may not make sense on the client side and vice-versa.


ORA-12660

ORA-12660Encryption or crypto-checksumming parameters incompatible

Cause:One side of the connection specified REQUIRED for encryption or crypto-checksumming, while the other side specified REJECTED.

Action:Change the REQUIRED side to REQUESTED if you want encryption or crypto-checksumming to be optional, or change the REJECTED side to ACCEPTED if you do not want the service to be optional.


ORA-12661

ORA-12661Protocol authentication to be used

Cause:The SQL*Net authentication service has determined that the SQL*Net transport protocol in use is to be utilized to authenticate a user's identity.

Action:This error is used solely to communicate information between the authentication service and the SQL*Net session layer and should not be visible to the user. If the error is seen, contact Worldwide Customer Support.


ORA-12662

ORA-12662proxy ticket retrieval failed

Cause:The authentication adapter used by SQL*Net failed to retrieve the credentials needed to authenticate a database link.

Action:Enable tracing to determine the exact error.


ORA-12663

ORA-12663Services required by client not available on the server

Cause:Service(s) that was (were) required by the client process were not available on the server process.

Action:Configure the server with the services required by the client (best solution) or delete the requirement from the configuration file of the client (least secure).


ORA-12664

ORA-12664Services required by server not available on the client

Cause:Service(s) that was (were) required by the server process were not available on the client process.

Action:Configure the client with the services required by the server (best solution) or delete the requirement from the configuration file of the server (least secure).


ORA-12666

ORA-12666Dedicated server: outbound transport protocol different from inbound

Cause:The protocol specified for an externally-identified outbound connection from a dedicated server (database link) was not the same as that used for the inbound connection. It is not possible for SQL*Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the dedicated server.

Action:Specify the same protocol in the SQL*Net connect string or alias for the outbound connection as that used for the inbound connection.


ORA-12667

ORA-12667Shared server: outbound transport protocol different from inbound

Cause:The protocol specified for an externally-identified outbound connection from a shared server (database link) was not the same as that used for the inbound connection. It is not possible for SQL*Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the shared server.

Action:Specify the same protocol in the SQL*Net connect string or alias for the outbound connection as that used for the inbound connection.


ORA-12668

ORA-12668Dedicated server: outbound protocol does not support proxies

Cause:The protocol specified to perform an externally-identified proxy connection (database link) from a dedicated server does not support proxy connections.

Action:Specify a protocol in the SQL*Net connect string or alias used for the connection that does support externally-authenticated proxy connections.

Note: Because of a limitation in SQL*Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.


ORA-12669

ORA-12669Shared server: outbound protocol does not support proxies

Cause:The protocol specified to perform an externally-identified proxy connection (database link) from a shared server does not support proxy connections.

Action:Specify a protocol in the SQL*Net connect string or alias used for the connection that does support externally-authenticated proxy connections.

Note: Because of a limitation in SQL*Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.


ORA-12670

ORA-12670Incorrect role password

Cause:A password supplied for a role could not be validated by the authentication service.

Action:Supply the correct password.


ORA-12671

ORA-12671Shared server: adapter failed to save context

Cause:The adapter for the authentication service failed when it tried to save the data needed for proxy connections (database links) through the multi-threaded server.

Action:Enable tracing to determine the exact error. Contact Worldwide Customer Support if the reason is not obvious.


ORA-12672

ORA-12672Database logon failure

Cause:The authentication service adapter in use encountered an error it attempted to validate the logon attempt of a user.

Action:Enable tracing to determine the exact error encountered by the adapter


ORA-12673

ORA-12673Dedicated server: context not saved

Cause:A connection was marked as being a proxy connection (database link) from a dedicated server but no inbound context was present.

Action:Before calling nsnainit(), call the routine that saves the context.


ORA-12674

ORA-12674Shared server: proxy context not saved

Cause:A connection was marked as being a proxy connection (database link) from a shared server but no inbound context was present.

Action:Before calling nsnainit(), call the routine that saves the context.


ORA-12675

ORA-12675External user name not available yet

Cause:The authentication service in use was not able to return the external name of a user of the ORACLE server because it is not available to the service yet.

Action:This is just an information message and should not normally be visible to the user. If the error does appear, contact Worldwide Customer Support.


ORA-12676

ORA-12676Server received internal error from client

Cause:The server process received an error from the client which indicated that an internal SQL*Net native services error had occurred.

Action:Enable tracing on both processes and attempt to recreate the problem. If the problem recurs, contact Worldwide Customer Support.


ORA-12677

ORA-12677Authentication service not supported by database link

Cause:The authentication service used by the proxy process (database link) was unable to find the adapter being used by the client in its list of authentication mechanisms.

Action:Specify an authentication adapter that is shared by the client and the server being used for the database link.


ORA-12678

ORA-12678Authentication disabled but required

Cause:The configuration parameters that control whether SQL*Net authentication is disabled or required were both set to TRUE.

Action:Set one or both of the parameters to FALSE.


ORA-12679

ORA-12679Native services disabled by other process but required

Cause:The remote process has disabled native services but the local process requires them.

Action:Enable native services on the remote process or disable them locally.


ORA-12680

ORA-12680Native services disabled but required

Cause:The process has disabled native services but at least one service is required.

Action:Enable native services or change the configuration file so that none of the available services are required.


ORA-12681

ORA-12681Login failed: the SecurID card does not have a pincode yet

Cause:The SecurID card that is used to logon to Oracle, does not have a pincode assigned to it.

Action:Use one of the programs supplied by Security Dynamics to assign a pincode to the card.


ORA-12682

ORA-12682Login failed: the SecurID card is in next PRN mode

Cause:The SecurID card and the SecurID server are out of sync and the server requires the next cardcode to resynchronize the card.

Action:Use one of the programs supplied by Security Dynamics to resynchronize the SecurID card.


ORA-12683

ORA-12683Encryption/crypto-checksumming: no Diffie-Hellman seed

Cause:The sqlnet.crypto_seed parameter is missing from the SQLNET.ORA parameters file for SQL*Net.

Action:Add this line to SQLNET.ORA, perhaps by using Network Manager: sqlnet.crypto_seed = rand omly-chosen text.


ORA-12684

ORA-12684Encryption/crypto-checksumming: Diffie-Hellman seed too small

Cause:The sqlnet.crypto_seed parameter in the SQLNET.ORA parameter file for SQL*Net is too small.

Action:Add more randomly-chosen text to it, perhaps using Network Manager.


ORA-12685

ORA-12685Native service required remotely but disabled locally

Cause:A native service is required by the remote process but native services have been disabled locally.

Action:Enable native services locally or change the configuration parameters on the remote host so that no native services are required.


ORA-12686

ORA-12686Invalid command specified for a service

Cause:An operation which does not exist was specified for a native service.

Action:This is a programming error and should not normally be visible to the user. If the error does appear, contact Worldwide Customer Support.


ORA-12687

ORA-12687Database link failed: credentials expired

Cause:The credentials that are used to authenticate the user for the requested database link have expired.

Action:Renew your credentials. Refer to the documentation specific for your Network Authentication Adapter on how to do this.


ORA-12688

ORA-12688Login failed: the SecurID server rejected the new pincode

Cause:There are a number of reasons why the SecurID server would refuse a pincode:
-The user might not have permission to make up his own pincode.
-The pin code was either too short or too long. Valid pincodes consist of
minimal four, but no more than eight characters.
-The pincode contains any non alpha-numeric characters.

Action:Re-execute the operation and make sure to use a pincode that satisfies the above requirements. If the problem persists, turn on tracing at the Oracle Server side of the connection and examine the trace file for the exact error.


ORA-12689

ORA-12689Server Authentication required, but not supported

Cause:Server Authentication is required for this connection, but not supported by both sides of the connection.

Action:Make sure both sides of the connection have the correct version of Secure Network Services, and that the Authentication Adapter supports Server Authentication.


ORA-12699

ORA-12699Native service internal error

Cause:An internal error occurred in the native services component.

Action:Enable tracing to determine the exact error. Contact Worldwide Customer Support.


ORA-12700

ORA-12700Invalid NLS parameter value (var)

Cause:An invalid NLS initialization parameter was specified.

Action:Check the syntax and spelling of the parameter. Enter the correct parameter into the initialization parameter file.


ORA-12701

ORA-12701CREATE DATABASE character set is not known

Cause:The character set specified in the CREATE DATABASE command does not exist on the system.

Action:Refer to the installation or user's guide for more information about character sets on the system. Use a valid character set in the CREATE DATABASE command.


ORA-12702

ORA-12702invalid NLS parameter string used in SQL function

Cause:An invalid parameter or value was entered in the NLS parameter string in a SQL function.

Action:Check the syntax of the function and the parameters. Enter the command again using the correct syntax and valid values.


ORA-12703

ORA-12703This character set conversion is not supported

Cause:An attempt was made to use the CONVERT function to convert between two character sets, and the requested conversion is not possible due to unavailability of one or both character sets.

Action:Use character sets available on the system in the CONVERT function.


ORA-12704

ORA-12704character set mismatch

Cause:One of the following:

The string operands(other than an nlsparams argument) to an operator or built-in function do not have the same character set.

An nlsparams operand is not in the database character set.

String data with character set other than the database character set is passed to a built-in function not expecting it.

The second argument to CHR() or CSCONVERT() is not CHAR_CS or NCHAR_CS.

A string expression in the VALUES clause of an INSERT statement. or the SET clause of an UPDATE statement, does not have the same character set as the column into which the value would be inserted.

A value provided in a DEFAULT clause when creating a table does not have the same character set as declared for the column.

An argument to a PL/SQL function does not conform to the character set requirements of the corresponding parameter.

Action:Strings declared with NCHAR or NCHAR VARYING do not interoperate with strings declared with CHAR or VARCHAR2. Use TRANSLATE() function to explicitly convert one to the other.


ORA-12705

ORA-12705Invalid or unknown NLS parameter value specified

Cause:An attempt was made to issue an ALTER SESSION statement with an invalid NLS parameter or value.

Action:Check the syntax of the ALTER SESSION command and the NLS_PARAMETER. Correct the syntax and re-issue the statement.


ORA-12706

ORA-12706This CREATE DATABASE character set is not allowed

Cause:An attempt was made to create a database on an ASCII-based machine using an EBCDIC-based character set, or vice versa. This is not permitted.

Action:Create the database using either ASCII- or EBCDIC-based character sets depending on what is supported by the hardware. Refer to the installation or user's guide for more information about the type of character set supported.

________________________________________


ORA-12800

ORA-12800system appears too busy for parallel query execution

Cause:The load on the system is too high to perform parallel queries.

Action:Re-enter the statements serially or wait until the system load is reduced.


ORA-12801

ORA-12801error signaled in parallel query server name

Cause:A parallel query server encountered an exception as described in the accompanying message(s).

Action:Correct the error described in the accompanying message.


ORA-12802

ORA-12802parallel query server lost contact with coordinator

Cause:A parallel query server was unable to communicate with the server coordinating the parallel query.

Action:Check for operating system or network errors and retry the statement. If this problem persists, contact customer support.


ORA-12803

ORA-12803parallel query server lost contact with another server

Cause:A parallel query server was unable to communicate with another server involved in the parallel query.

Action:Check for operating system or network errors and retry the statement. If this problem persists, contact customer support.


ORA-12804

ORA-12804parallel query server appears to have died

Cause:Process information for a parallel query server thread cannot be found.

Action:Check for operating system errors and retry the statement. If this problem persists, contact customer support.


ORA-12805

ORA-12805parallel query server died unexpectedly

Cause:The PMON process is cleaning up the process because a parallel query server terminated unexpectedly.

Action:Check for operating system errors and retry the statement. If this problem persists, contact customer support.


ORA-12806

ORA-12806could not get background process to hold enqueue

Cause:This is an internal error that is not usually issued.

Action:Contact customer support.


ORA-12807

ORA-12807process queue could not receive parallel query message

Cause:This is an internal error that is not usually issued.

Action:Contact customer support.


ORA-12808

ORA-12808cannot set [CACHE | SCAN]_INSTANCES greater than number of instances num

Cause:An attempt was made, using the ALTER SYSTEM command, to set CACHE_INSTANCES or SCAN_INSTANCES to a value greater than the number of available instances.

Action:See the accompanying message for the allowable maximum value or set SCAN_INSTANCES or CACHE_INSTANCES to ALL.


ORA-12809

ORA-12809cannot set [CACHE | SCAN]_INSTANCES when mounted inexclusive mode

Cause:An attempt was made to set CACHE_INSTANCES or SCAN_INSTANCES using the ALTER SYSTEM command while the database was mounted in exclusive mode.

Action:Only set CACHE_INSTANCES or SCAN_INSTANCES when the database is mounted in PARALLEL or SHARED mode.


ORA-12810

ORA-12810PARALLEL_MAX_SERVERS must be less than or equal to num

Cause:An attempt was made to set the PARALLEL_MAX_SERVERS initialization parameter to a value higher than the maximum allowed by the system.

Action:See the accompanying message for the allowable maximum value.


ORA-12811

ORA-12811PARALLEL_MIN_SERVERS must be less than or equal to PARALLEL_MAX_SERVERS, num

Cause:An attempt was made to set the PARALLEL_WIN_SERVERS initialization parameter to a value higher than PARALLEL_MAX_SERVERS.

Action:See the accompanying message for the allowable maximum value.


ORA-12812

ORA-12812only one PARALLEL or NOPARALLEL clause may be specified

Cause:PARALLEL was specified more than once, NOPARALLEL was specified more than once, or both PARALLEL and NOPARALLEL were specified in a CREATE TABLE, CREATE CLUSTER, CREATE INDEX, ALTER TABLE, ALTER CLUSTER statement, or a RECOVER command.

Action:Specify PARALLEL or NOPARALLEL only once.


ORA-12813

ORA-12813value for PARALLEL or DEGREE must be greater than 0

Cause:PARALLEL 0 or DEGREE 0 was specified in a CREATE TABLE, CREATE CLUSTER, CREATE INDEX, ALTER TABLE, ALTER CLUSTER statement, or a RECOVER command.

Action:Specify a value greater than 0 or specify default parallelism using PARALLEL with no degree or using DEGREE DEFAULT within a PARALLEL clause.


ORA-12814

ORA-12814only one CACHE or NOCACHE clause may be specified

Cause:CACHE was specified more than once, NOCACHE was specified more than once, or CACHE and NOCACHE, were specified in a CREATE TABLE, CREATE CLUSTER, CREATE INDEX, ALTER TABLE, ALTER CLUSTER, or a RECOVER command.

Action:Specify CACHE or NOCACHE only once.


ORA-12815

ORA-12815value for INSTANCES must be greater than 0

Cause:PARALLEL parameter specifying number of instances must be a positive integer or DEFAULT.

Action:Specify a positive integer or DEFAULT for INSTANCES if parallelism across instances is desired.


ORA-12817

ORA-12817parallel query option must be enabled

Cause:You tried to attempt an operation that requires the parallel query option.

Action:Enable the parallel query option.


ORA-12818

ORA-12818invalid option in PARALLEL clause

Cause:An unrecognized option was specified with a PARALLEL clause.

Action:Specify any combination of DEGREE {<n> | DEFAULT } and INSTANCE { <n> | DEFAULT } within the PARALLEL clause.


ORA-12819

ORA-12819missing options in PARALLEL clause

Cause:The PARALLEL clause was specified without an option.

Action:Specify any combination of DEGREE { <n> | DEFAULT } and INSTANCE { <n> | DEFAULT } within the PARALLEL clause.


ORA-12820

ORA-12820invalid value for DEGREE

Cause:An invalid value for DEGREE was specified within a PARALLEL clause.

Action:Specify a positive integer or DEFAULT.


ORA-12821

ORA-12821invalid value for INSTANCES

Cause:An invalid value for INSTANCES was specified within a PARALLEL clause.

Action:Specify a positive integer or DEFAULT.


ORA-12822

ORA-12822duplicate option in PARALLEL clause

Cause:DEGREE or INSTANCE was specified more than once within a PARALLEL clause.

Action:Specify the option only once.


ORA-12823

ORA-12823default degree of parallelism may not be specified here

Cause:Either an ALTER DATABASE RECOVER command was specified with the DEGREE DEFAULT option in a PARALLEL clause or another command was specified with no option in the PARALLEL clause.

Action:Specify an explicit degree of parallelism.


ORA-12824

ORA-12824INSTANCES DEFAULT may not be specified here

Cause:An ALTER DATABASE RECOVER command was specified with the INSTANCES DEFAULT option.

Action:Specify an explicit value for INSTANCES or omit the INSTANCES option if single instance recovery is desired.


ORA-12825

ORA-12825explicit degree of parallelism must be specified here

Cause:An ALTER DATABASE RECOVER command was specified without the DEGREE option.

Action:Specify an explicit degree of parallelism.


ORA-12826

ORA-12826hung parallel query server was killed

Cause:Parallel query server was hung and subsequently killed.

Action:Re-execute query and report suspicious events noted in the trace file to customer support if error persists.


ORA-12827

ORA-12827parallel query option must be enabled

Cause:A parallel query option feature has been invoked, but this option has not been enabled.

Action:Enable the parallel query option.


ORA-12828

ORA-12828can't start parallel transaction - distributed transaction in progress

Cause:PDML transaction cannot be started because a distributed transaction is in progress.

Action:Change the DML statement to exclude updates to remote tables and re-execute the statement.


ORA-12829

ORA-12829deadlock - itls occupied by siblings at block name of file name

Cause:Parallel statement failed because all itls in the current block are occupied by siblings of the same transaction.

Action:Increase MAXTRANS of the block or reduce the degree of parallelism for the statement. Re-execute the statement. Report suspicious events in trace file to Oracle support representative if error persists.


ORA-12830

ORA-12830must COMMIT or ROLLBACK after executing parallel INSERT/UPDATE/DELETE

Cause:After executing a parallel INSERT/UPDATE/DELETE statement, a command other than COMMIT or ROLLBACK was issued.

Action:Execute COMMIT or ROLLBACK before issuing another SQL command.


ORA-12831

ORA-12831must COMMIT or ROLLBACK after executing INSERT with APPEND hint

Cause:After executing an INSERT statement with an APPEND hint, a command other than COMMIT or ROLLBACK was issued.

Action:Execute COMMIT or ROLLBACK before issuing another SQL command.


ORA-12833

ORA-12833coordinator's instance not a member of PARALLEL_INSTANCE_GROUP

Cause:The coordinator's instance must be a member of the PARALLEL_INSTANCE_GROUP in which this operation will be run.

Action:Either add the coordinator's instance to the current PARALLEL_INSTANCE_GROUP or change PARALLEL_INSTANCE_GROUP.


ORA-12834

ORA-12834instance group name, name, too long, must be less than num characters

Cause:The instance group name is too long.

Action:Either shorten the name or get rid of the instance group.


ORA-12835

ORA-12835No instances are active in the OPS_ADMIN_GROUP

Cause:There must be at least one instance in the OPS_ADMIN_GROUP in order to execute a query on global views.

Action:Change the value of OPS_ADMIN_GROUP.


ORA-12838

ORA-12838cannot read/modify an object after a parallel modification on it in the same transaction

Cause:Multi Statement Parallel DML restriction violated.

Action:Once a table has been modified in parallel, no more read or modification statements are allowed on that table, within the same transaction. Rewrite the transaction, or brake it up into two transactions.


ORA-12839

ORA-12839cannot modify an object in parallel after modifying it in the transaction

Cause:Multi Statement Parallel DML restriction violated.

Action:Once a table has been modified, no parallel modification operations are allowed on that table, within the same transaction. Rewrite the transaction or break it up into two transactions.


ORA-12840

ORA-12840 cannot access remote table in a parallel transaction

Cause:Multi Statement Parallel DML restriction violated

Action:Distributed accesses may not be performed after a PDML statement has been issued in a transaction. Commit/rollback the PDML transaction first, and then perform the distributed access, or do it before the first PDML statement in the transaction.


ORA-13000

ORA-13000dimension number is out of range

Cause:The specified dimension is either smaller than 1 or greater than the number of dimensions encoded in the HHCODE.

Action:Make sure that the dimension number is between 1 and the maximum number of dimensions encoded in the HHCODE.


ORA-13001

ORA-13001dimensions mismatch error

Cause:The number of dimensions in two HHCODEs involved in a binary HHCODE operation do not match.

Action:Make sure that the number of dimensions in the HHCODEs match.


ORA-13002

ORA-13002specified level is out of range

Cause:The specified level is either smaller than 1 or greater than the maximum level encoded in an HHCODE.

Action:Verify that all levels are between 1 and the maximum number of levels encoded in the HHCODE.


ORA-13003

ORA-13003the specified range for a dimension is invalid

Cause:The specified range for a dimension is invalid.

Action:Make sure that the lower bound (lb) is less than the upper bound (ub).


ORA-13004

ORA-13004the specified buffer size is invalid

Cause:The buffer size for a function is not valid.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-13005

ORA-13005recursive HHCODE function error

Cause:An error occurred in a recursively called HHCODE function.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-13006

ORA-13006the specified cell number is invalid

Cause:The cell identifier is either less than 0 or greater that (2^ndim - 1).

Action:Make sure that the cell identifier is between 0 and (2^ndim - 1).


ORA-13007

ORA-13007 an invalid HEX character was detected

Cause:A character that is not in the range [0-9] or [A-Fa-f] was detected.

Action:Verify that all characters in a string are in [0-9] or [A-Fa-f].


ORA-13008

ORA-13008the specified date format has an invalid component

Cause:Part of specified date format is invalid.

Action:Verify that the date format is valid.


ORA-13009

ORA-13009the specified date string is invalid

Cause:The specified date string has a bad component or does not match the specified format string.

Action:Make sure that the components of the date string are valid and that the date and format strings match.


ORA-13010

ORA-13010an invalid number of arguments has been specified

Cause:An invalid number of arguments was specified for an HHCODE function.

Action:Verify the syntax of the function call.


ORA-13011

ORA-13011value is out of range

Cause:A specifed dimension value is outside the range defined for that dimension.

Action:Make sure that all values to be encoded are within the defined dimension range.


ORA-13012

ORA-13012an invalid window type was specifed

Cause:An invalid window type was specifed.

Action:Valid window types are RANGE, PROXIMITY, POLYGON.


ORA-13013

ORA-13013 the specified topology was not INTERIOR or BOUNDARY

Cause:A topology was specified that was not INTERIOR or BOUNDARY.

Action:Make sure that INTERIOR or BOUNDARY is used to describe an HHCODE's topology.


ORA-13014

ORA-13014a topology identifier outside the range of 1 to 8 was specified

Cause:A topology identifier outside the range of 1 to 8 was specified

Action:Specify a topology in the range of 1 to 8.


ORA-13015

ORA-13015the window definition is not valid

Cause:The number of values used to define the window does not correspond to the window type.

Action:Verify that the number of values used to defined the window is correct for the window type and number of dimensions.


ORA-13016

ORA-13016bad partition definition

Cause:The partition common code was not correctly decoded.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-13017

ORA-13017unrecognized line partition shape

Cause:The shape of a 2-D line partition could not be determined.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-13018

ORA-13018bad distance type

Cause:The specified distance type is invalid.

Action:The only supported distance functions are EUCLID and MANHATTAN.


ORA-13020

ORA-13020coordinate is NULL

Cause:A vertex coordinate has a NULL value

Action:Re-define vertex coordinate to have a non-NULL value


ORA-13021

ORA-13021element not continuous

Cause:The coordinates defining a geometric element are not connected

Action:Re-define coordinates for the geometric element


ORA-13022

ORA-13022polygon crosses itself

Cause:The coordinates defining a polygonal geometric element represent crossing segments

Action:Re-define coordinates for the polygon


ORA-13023

ORA-13023interior element interacts with exterior element

Cause:An interior element of a geometric object interacts with the exterior element of that object

Action:Re-define coordinates for the geometric elements


ORA-13024

ORA-13024polygon has less than three segments

Cause:The coordinates defining a polygonal geometric element represent less than three segments

Action:Re-define the coordinates for the polygon


ORA-13025

ORA-13025polygon does not close

Cause:The coordinates defining a polygonal geometric element represent an open polygon

Action:Redefine the coordinates of the polygon


ORA-13026

ORA-13026unsupported geometric type

Cause:The <layer>_SDOINFO table contains an invalid geometric element type

Action:Redefine the geometric element type in the <layer>_SDOINFO table


ORA-13027

ORA-13027GID not in layer

Cause:The <layer>_SDOINFO table does not contain the specified GID

Action:Verify that the correct layer name and GID were specified


ORA-13039

ORA-13039no geometry elements defined

Cause:The Spatial Data Option INFO table contains a geometric object (GID) that has no elements defined in the Spatial Data Option GEOMETRY table.

Action:Add elements for the geometric object to the Spatial Data Option GEOMETRY table.


ORA-13040

ORA-13040no geometry info defined

Cause:The Spatial Data Option GEOMETRY table contains a geometric object (GID) that has no geometry information defined in the Spatial Data Option INFO table.

Action:Add geometry information for the geometric object to the Spatial Data Option INFO table or drop and re-create the geometric object.


ORA-13041

ORA-13041failed to check title

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13042

ORA-13042an SDO error has been encountered

Cause:This is an undocumented error.

Action:Please refer to the user documentation for an explanation of this error.


ORA-13043

ORA-13043an SDO error has been encountered

Cause:This is an undocumented error.

Action:Please refer to the user documentation for an explanation of this error.


ORA-13044

ORA-13044an SDO error has been encountered

Cause:This is an undocumented error.

Action:Please refer to the user documentation for an explanation of this error.


ORA-13045

ORA-13045an SDO error has been encountered

Cause:This is an undocumented error.

Action:Please refer to the user documentation for an explanation of this error.


ORA-13108

ORA-13108spatial table name not found

Cause:The specified spatial table does not exist.

Action:Check the Spatial Data option data dictionary to make sure that the table is registered.


ORA-13109

ORA-13109spatial table name exists

Cause:The specified spatial table is registered in the Spatial Data data dictionary.

Action:Remove the existing table from the Spatial Data option data dictionary or use a different name.


ORA-13110

ORA-13110spatial table name is not partitioned

Cause:The specified spatial table is not partitioned.

Action:Check the Spatial Data option data dictionary and make sure that a high water mark is set.


ORA-13111

ORA-13111spatial table name has no partition key defined

Cause:The specified spatial table does not have a partition key defined.

Action:Check the Spatial Data option data dictionary and make sure that the table is partitioned.


ORA-13112

ORA-13112invalid count mode name

Cause:The specified count mode is not valid.

Action:Alter the count mode. Valid count modes are ESTIMATE or EXACT.


ORA-13113

ORA-13113Oracle table name does not exist

Cause:The specified Oracle table does not exist.

Action:Check the Oracle7 data dictionary and make sure that the table exists.


ORA-13114

ORA-13114tablespace name not found

Cause:The specified tablespace does not exist.

Action:Check the Oracle7 data dictionary and make sure that the specified tablespace exists and that there is a space quota defined on it.


ORA-13115

ORA-13115tablespace name is already allocated

Cause:The specified tablespace is already allocated to the spatial table.

Action:Allocate another tablespace name to the table.


ORA-13116

ORA-13116tablespace name is already allocated

Cause:The specified tablespace is not allocated to the specified spatial table.

Action:Allocate the tablespace to the spatial table.


ORA-13117

ORA-13117partition name not found

Cause:The specified partition does not exist.

Action:Verify the name of the partition by checking the Spatial Data option data dictionary.


ORA-13119

ORA-13119source and target tablespaces are identical

Cause:Identical source and target tablespaces were specified when trying to move partition.

Action:Specify different source and target tablespaces if you wish to move a partition.


ORA-13121

ORA-13121failed to create child partition

Cause:The creation of a child partition failed.

Action:Check for other errors that accompany this error and correct them first.


ORA-13122

ORA-13122child partition name not found

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13123

ORA-13123column name is already defined

Cause:The specified column is already defined for the spatial table.

Action:Use a different column name.


ORA-13124

ORA-13124unable to determine column id for column name

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13125

ORA-13125partition key is already set

Cause:A partition key is already set for the spatial table.

Action:Only one partition key can be specified per spatial table.


ORA-13126

ORA-13126unable to determine class for spatial table name

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13127

ORA-13127failed to generate target partition

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13129

ORA-13129HHCODE column name not found

Cause:The specified spatial column does not exist.

Action:Verify that the specified column is a spatial column by checking the Spatial Data option data dictionary.


ORA-13135

ORA-13135failed to alter spatial table

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13136

ORA-13136null common code generated

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13137

ORA-13137failed to generate tablespace sequence number

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13138

ORA-13138could not determine name of object name

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13139

ORA-13139could not obtain column definition for name

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13140

ORA-13140invalid target type

Cause:The specified target type is not valid.

Action:Substitute a valid target type. Valid target types are TABLE or VIEW.


ORA-13141

ORA-13141invalid RANGE window definition

Cause:The RANGE window specified is not correctly defined.

Action:A RANGE window is defined by specifying the lower and upper boundary of each dimension as a pair of values (e.g.: lower_bound1,upper_bound1,lower_bound2,upper_bound2,...). There should be an even number of values.


ORA-13142

ORA-13142invalid PROXIMITY window definition

Cause:The PROXIMITY window specified is not correctly defined.

Action:A PROXIMITY window is defined by specifying a center point and a radius. The center point is defined by ND values. There should be ND+1 values.


ORA-13143

ORA-13143invalid POLYGON window definition

Cause:The POLYGON window specified is not correctly defined.

Action:A POLYGON window is defined by specifying N pairs of values that represent the vertices of the polygon. There should be an even number of values.


ORA-13144

ORA-13144target table name not found

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13145

ORA-13145failed to generate range list

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13146

ORA-13146could not find table substitution variable name

Cause:The partition name substitution variable name was not found in the SQL filter.

Action:The substitution variable name must be in the SQL filter to indicate where that partition name should be placed.


ORA-13147

ORA-13147failed to generate MBR

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13148

ORA-13148failed to generate SQL filter

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13149

ORA-13149failed to generate next sequence number for spatial table name

Cause:This is an internal error.

Action:Document messages and contact Oracle Worldwide Support.


ORA-13150

ORA-13150failed to insert exception record

Cause:Operation failed to insert a record into the exception table

Action:Fix any other errors reported.


ORA-13151

ORA-13151failed to remove exception record

Cause:Operation failed to insert a record into the exception table.

Action:Fix any other errors reported.


ORA-13152

ORA-13152invalid HHCODE type

Cause:Specified HHCODE type is not valid.

Action:Substitute a valid HHCODE type. Valid HHCODE types are POINT and LINE.


ORA-13153

ORA-13153invalid high water mark specified

Cause:The high water mark must be greater than or equal to zero.

Action:Make sure that the high water mark is an integer greater than or equal to zero.


ORA-13154

ORA-13154invalid precision specified

Cause:The precision specified is out of range.

Action:The precision must be an integer greater than or equal to zero.


ORA-13155

ORA-13155invalid number of dimensions specified

Cause:The number of dimensions specified is out of range.

Action:The number of dimension must be between 1 and 32.


ORA-13156

ORA-13156table to be registered %s.%s is not empty

Cause:The specified table has rows in it.

Action:Make sure that the table to be registered is empty.


ORA-13157

ORA-13157Oracle error ORA-nnnn encountered while name

Cause:Specified Oracle error was encountered.

Action:Correct the Oracle error.


ORA-13158

ORA-13158Oracle object %s does not exist

Cause:The specified object does not exist.

Action:Verify that the specified object exists.


ORA-13159

ORA-13159Oracle table %s already exists

Cause:The specified table already exists.

Action:Drop the specified table.


ORA-13181

ORA-13181failed to parse recursive SQL statement

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13182

ORA-13182failed to read geometry type for geometry %s.%s

Cause:SDO was unable to determine the geometry type for the specified geometry.

Action:Verify that the information in the <layer>_SDOINFO table exists and is valid.


ORA-13183

ORA-13183unsupported geometric type for geometry %s.%s

Cause:The geometry type in the <layer>_SDOINFO table is unsupported.

Action:Modify the geometry type to be one of the supported types.


ORA-13184

ORA-13184failed to parse recursive SQL statement

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13185

ORA-13185failed to read a vertex for geometry %s.%s

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13186

ORA-13186failed to read a vertex for geometry %s.%s

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13187

ORA-13187failed to read a vertex for geometry %s.%s

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13188

ORA-13188failed to read a vertex for geometry %s.%s

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13189

ORA-13189failed to parse recursive SQL statement

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13190

ORA-13190unsupported geometric type for geometry %s.%s

Cause:The geometry type in the <layer>_SDOINFO table is unsupported.

Action:Modify the geometry type to be one of the supported types.


ORA-13191

ORA-13191failed to parse recursive SQL statement

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13192

ORA-13192failed to determine the supercell for geometry %s.%s

Cause:SDO was unable to compute a supercell for the specified geometry.

Action:Verify the geometry. Note any additional messages and report the problem to World Wide Support.


ORA-13193

ORA-13193failed to decode supercell

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13194

ORA-13194failed to decode supercell

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13195

ORA-13195failed to decode supercell

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13196

ORA-13196failed to decode supercell

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-13197

ORA-13197failed to parse recursive SQL statement

Cause:This is an internal error.

Action:Contact World Wide Support.


ORA-14001

ORA-14001LOCAL clause contradicts previously specified GLOBAL clause

Cause:CREATE INDEX statement contained a GLOBAL clause and a LOCAL clause.

Action:Specify either a LOCAL or a GLOBAL clause. Do not specify both clauses. Retry the operation.


ORA-14002

ORA-14002only one GLOBAL clause may be specified

Cause:A CREATE INDEX statement contained more than one GLOBAL clause.

Action:Specify the GLOBAL option no more than one time. Then retry the operation.


ORA-14003

ORA-14003GLOBAL clause contradicts previously specified LOCAL clause

Cause:A CREATE INDEX statement contained a LOCAL clause and a GLOBAL clause.

Action:Specify a GLOBAL or a LOCAL clause. Do not specify both clauses. Then retry the operation.


ORA-14004

ORA-14004missing PARTITION keyword

Cause:A statement was issued which was missing the keyword PARTITION.

Action:Supply the missing keyword, and retry the operation.


ORA-14005

ORA-14005missing RANGE keyword

Cause:A statement was issued which was missing the keyword RANGE.

Action:Supply the missing keyword, and retry the operation.


ORA-14006

ORA-14006invalid partition name

Cause:A partition name of the form name is expected, but it is not present.

Action:Enter an appropriate partition name. Then retry the operation.


ORA-14007

ORA-14007missing LESS keyword

Cause:A statement was issued which was missing the keyword LESS.

Action: Supply the missing keyword. Then retry the operation.


ORA-14008

ORA-14008missing THAN keyword

Cause:A statement was issued which was missing the keyword THAN.

Action:Supply the missing keyword. Then retry the operation.


ORA-14010

ORA-14010this physical attribute may not be specified for an index partition

Cause:An unexpected option was encountered while parsing physical attributes of an index partition; valid options are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE. This message could also have resulted from omission of a terminating (right) parenthesis following the list of partition descriptions.

Action:Remove invalid option(s) from the list of physical attributes of an index partition.


ORA-14011

ORA-14011names assigned to resulting partitions must be distinct

Cause:The names given to partitions resulting from the splitting of an existing table or index partition were not distinct.

Action:Rename resulting partition(s) to ensure that their names are distinct and different from those of any other partition of the table or index.


ORA-14012

ORA-14012resulting partition name conflicts with that of an existing partition

Cause:Name of a partition resulting from splitting of an existing table or index partition was given a name identical to that of some other existing partition of that table or index.

Action: Rename resulting partition(s) to ensure that their names are distinct and different from those of any other partition of the table or index.


ORA-14013

ORA-14013duplicate partition name

Cause:Name given to a partition of a table or index being created was not unique.

Action: Rename partition(s) to ensure that their names are unique among partitions of the table or index being created.


ORA-14014

ORA-14014maximum number of partitioning columns is 16

Cause:The number of columns in a partitioning column list exceeded the legal limit of 16.

Action: Modify the partitioning column list so that it consists of 16 columns or less.


ORA-14015

ORA-14015too many partition descriptions

Cause:CREATE TABLE or CREATE INDEX contained too many partition descriptions; maximum number of partitions is 2**32-1 (65535).

Action: Reduce the number of partitions so that they do not exceed 2**32-1 (65535).


ORA-14016

ORA-14016underlying table of a LOCAL partitioned index must be partitioned

Cause:An attempt was made to create a LOCAL partitioned index on a non-partitioned table. Only GLOBAL indices (partitioned or otherwise) can be created on a non-partitioned table.

Action: Correct the statement, and retry the operation.


ORA-14017

ORA-14017partition bound list contains too many elements

Cause:A partition bound list contained more elements than there are partitioning columns.

Action: Ensure that the number of elements in the partition bound list is equal to the number of partitioning columns of the table or index. Then retry the operation.


ORA-14018

ORA-14018partition bound list contains too few elements

Cause:Partition bound list contained fewer elements than partitioning columns.

Action: Ensure that the number of elements in the partition bound list is equal to the number of partitioning columns of the table or index.


ORA-14019

ORA-14019partition bound element must be either string literal, number, or MAXVALUE

Cause:Partition bound list contained an element of invalid type (that is, not a number, non-empty string literal, or MAXVALUE).

Action: Ensure that all elements of partition bound list are of valid type.


ORA-14020

ORA-14020this physical attribute may not be specified for a table partition

Cause:An unexpected option was encountered while parsing physical attributes of a table partition; valid options are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE, and PCTUSED. This error also could have resulted from the omission of a terminating (right) parenthesis following the list of partition descriptions.

Action: Remove invalid option(s) from the list of physical attributes of a table partition.


ORA-14021

ORA-14021MAXVALUE must be specified for all columns

Cause:In the VALUES LESS THAN clause for the highest (last) partition of a GLOBAL index, MAXVALUE was not specified for all columns.

Action: Ensure that the VALUES LESS THAN clause for the last partition of a GLOBAL index has MAXVALUE specified for all columns.


ORA-14022

ORA-14022creation of LOCAL partitioned cluster indices is not supported

Cause:An attempt was made to create a LOCAL partitioned cluster index, which is currently illegal.

Action: Remove LOCAL along with partition descriptions, if any, from the CREATE INDEX statement.


ORA-14023

ORA-14023creation of GLOBAL partitioned cluster indices is not supported

Cause:An attempt was made to create a GLOBAL partitioned cluster index, which is currently illegal.

Action: Remove PARTITION BY RANGE clause along with partition descriptions from the CREATE INDEX statement.


ORA-14024

ORA-14024number of partitions of LOCAL index must equal that of the underlying table

Cause:An attempt was made to create a LOCAL partitioned index with a number of partitions which is different from that of the underlying table.

Action: Correct the CREATE INDEX statement to specify a correct number of partitions, and retry the operation.


ORA-14025

ORA-14025PARTITION may not be specified for a snapshot or a snapshot log

Cause:PARTITION option was encountered while parsing a definition of a snapshot or a snapshot log.

Action: Ensure that the definition of a SNAPSHOT does not include invalid options, and retry the operation.


ORA-14026

ORA-14026PARTITION and CLUSTER clauses are mutually exclusive

Cause:The definition of a table contained both PARTITION and CLUSTER clauses. A table definition can only contain one of these clauses.

Action: Remove one of the conflicting clauses, and retry the operation.


ORA-14027

ORA-14027only one PARTITION clause may be specified

Cause:A CREATE TABLE statement contained more than one PARTITION clause.

Action: Specify the PARTITION option no more than one time, and retry the operation.


ORA-14028

ORA-14028missing AT keyword

Cause:A statement was issued that was missing the keyword AT.

Action:Supply the missing keyword, and retry the operation.


ORA-14029

ORA-14029GLOBAL partitioned index must be prefixed

Cause:The partitioning columns of a global partitioned index did not contain a prefix of the key columns of the index.

Action:Ensure that the GLOBAL partitioned index being created is prefixed, and retry the operation.


ORA-14030

ORA-14030non-existent partitioning column in CREATE TABLE statement

Cause:The partitioning column specified in the CREATE TABLE statement is not one of columns of the table being created.

Action: Ensure that all columns in the partitioning column list are columns of the table being created. Then retry the operation.


ORA-14031

ORA-14031partitioning column may not be of type LONG or LONG RAW

Cause:The partitioning column specified was of type LONG or LONG RAW, which is illegal.

Action: Ensure that no partitioning column is of type LONG or LONG RAW. Then retry the operation.


ORA-14032

ORA-14032partition bounds of partition number num are too high

Cause:High bound of the partition whose number (partitions are numbered starting with 1) is displayed in this message did not collate lower than that of the following partition, which is illegal.

Action: Ensure that high bound of every partition (except for the last one) collates lower than that of a following partition. Then retry the operation.


ORA-14036

ORA-14036partition bound value too large for column

Cause:Length of partition bound value is longer than that of the corresponding partitioning column.

Action:Ensure that lengths of the high bound values do not exceed those of corresponding partitioning columns. Then retry the operation.


ORA-14037

ORA-14037partition bounds of partition name are too high

Cause:High bound of the partition whose name (explicitly specified by the user) is displayed in this message did not collate lower than that of the following partition, which is illegal.

Action:Ensure that the high bound of every partition (except for the last one) collates lower than that of a following partition.


ORA-14038

ORA-14038GLOBAL partitioned index must be prefixed

Cause:An attempt was made to create a GLOBAL non-prefixed partitioned index which is illegal.

Action: If a non-prefixed index is desired, it must be created as LOCAL; otherwise, correct the list of key and/or partitioning columns to ensure that the index is prefixed. Then retry the operation.


ORA-14039

ORA-14039partitioning columns must form a subset of key columns of a UNIQUE index

Cause:An attempt was made to create a UNIQUE partitioned index whose partitioning columns do not form a subset of its key columns.

Action:If an index whose partitioning columns do not form a subset of its key columns is indeed desired, it must be created as non-UNIQUE; otherwise, correct the list of key and/or partitioning columns to ensure that the partitioning columns of the index form a subset of the key columns of the index. Then retry the operation.


ORA-14041

ORA-14041partition bound may not be specified for resulting partitions

Cause:While parsing an ALTER {TABLE|INDEX} SPLIT PARTITION statement, a resulting partition was found to contain a VALUES LESS THAN clause which is illegal.

Action:Remove the VALUES LESS THAN clause from the description(s) of partitions which result from splitting an existing table or index partition. Then retry the operation.


ORA-14042

ORA-14042partition bound may not be specified for a partition being moved, modified, or rebuilt

Cause:While parsing an ALTER {TABLE|INDEX} MODIFY PARTITION, ALTER TABLE MOVE PARTITION, or ALTER INDEX REBUILD PARTITION statement, the description of new physical attributes of the partition being moved, modified, or rebuilt was found to contain a VALUES LESS THAN clause, which is illegal.

Action: Remove the VALUES LESS THAN clause from the description of new attributes of the partition being moved, modified, or rebuilt. Then retry the operation.


ORA-14043

ORA-14043only one partition may be added

Cause:The ALTER TABLE ADD PARTITION statement contained descriptions of more than one partition to be added.

Action: Ensure that the statement contains exactly one partition definition and that it does not contain any commas. Then retry the operation.


ORA-14044

ORA-14044only one partition may be moved

Cause:The ALTER TABLE MOVE PARTITION statement contained descriptions of more than one partition to be moved.

Action: Ensure that the statement describes exactly one partition to be moved and that it does not contain any commas. Then retry the operation.


ORA-14045

ORA-14045only one partition may be modified

Cause:The ALTER TABLE|INDEX MODIFY PARTITION statement contained descriptions of more than one partition to be modified.

Action:Ensure that the statement describes exactly one partition to be modified and that it does not contain any commas.


ORA-14046

ORA-14046a partition may be split into exactly two new partitions

Cause:The ALTER TABLE|INDEX SPLIT PARTITION did not contain descriptions of exactly two new partitions into which an existing table or index partition was to be split.

Action:Ensure that the statement describes exactly two partitions into which an existing partition is to be split. Then retry the operation.


ORA-14047

ORA-14047ALTER TABLE|INDEX RENAME may not be combined with other operations

Cause:The ALTER TABLE or ALTER INDEX statement attempted to combine a RENAME operation with some other operation, which is illegal.

Action: Ensure that RENAME operation is the sole operation specified in ALTER TABLE or ALTER INDEX statement. Then retry the operation.


ORA-14048

ORA-14048a partition maintenance operation may not be combined with other operations

Cause:The ALTER TABLE or ALTER INDEX statement attempted to combine a partition maintenance operation (for example, MOVE PARTITION) with some other operation (for example, ADD PARTITION or PCTFREE), which is illegal.

Action:Ensure that a partition maintenance operation is the sole operation specified in an ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices, or specifying that a table be renamed (ALTER TABLE RENAME) can be combined.


ORA-14049

ORA-14049invalid ALTER TABLE MODIFY PARTITION option

Cause:An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, BACKUP, ALLOCATE EXTENT, or DEALLOCATE UNUSED was specified in an ALTER TABLE MODIFY PARTITION statement.

Action: Specify only legal options, and then retry the operation.


ORA-14050

ORA-14050invalid ALTER INDEX MODIFY PARTITION option

Cause:An option other than INITRANS, MAXTRANS, STORAGE, or DEALLOCATE UNUSED was specified in an ALTER INDEX MODIFY PARTITION statement.

Action: Specify only legal options, and then retry the operation.


ORA-14051

ORA-14051invalid ALTER SNAPSHOT option

Cause:An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, or BACKUP was specified in an ALTER SNAPSHOT statement.

Action: Specify only legal options, then retry the operation.


ORA-14052

ORA-14052partition-extended table name syntax is not allowed in this context

Cause:An attempt was made to use partition-extended table name syntax in illegal context (that is, not in a FROM-clause or INSERT, DELETE, or UPDATE statement).

Action: Avoid use of partition-extended table name syntax in contexts other than those mentioned above.


ORA-14053

ORA-14053illegal attempt to modify name in name statement

Cause:An attempt was made to modify an attribute (for example, a table) with the ALTER statement at creation time.

Action:Ensure that ALTER statement specifies new values only for attributes which can be changed after an object has been created.


ORA-14054

ORA-14054invalid ALTER TABLE TRUNCATE PARTITION option

Cause:An attempt was made to specify an invalid option following the partition name in the ALTER TABLE TRUNCATE PARTITION statement. The name of the partition to be truncated can be followed only by DROP STORAGE or REUSE STORAGE options.

Action:Ensure that no options besides DROP STORAGE or REUSE STORAGE are specified with ALTER TABLE TRUNCATE PARTITION.


ORA-14055

ORA-14055keyword REBUILD in ALTER INDEX REBUILD must immediately follow name

Cause:The ALTER INDEX statement contained the REBUILD keyword following an index attribute (for example, INITRANS).

Action:Ensure that the keyword REBUILD immediately follows the name of the index being altered.


ORA-14056

ORA-14056partition number num: sum of PCTUSED and PCTFREE may not exceed 100

Cause:The sum of PCTUSED and PCTFREE for a partition whose number (partitions are numbered starting with 1) is displayed in this message exceeds 100.

Note that if PCTUSED and/or PCTFREE values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If default PCTUSED and/or PCTFREE values for the partitioned table or index were not specified, system defaults would be used.

Action:Ensure that a sum of PCTUSED and PCTFREE for the partition does not exceed 100. Then retry the operation.


ORA-14057

ORA-14057partition name: sum of PCTUSED and PCTFREE may not exceed 100

Cause:The sum of PCTUSED and PCTFREE for a partition whose name is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If default PCTUSED and/or PCTFREE values for the partitioned table or index were not specified, system defaults would be used.

Action:Ensure that a sum of PCTUSED and PCTFREE for the partition does not exceed 100. Then retry the operation.


ORA-14058

ORA-14058partition number num: INITRANS value must be less than MAXTRANS value

Cause:The value of INITRANS was found to be greater than that of MAXTRANS for a partition whose number (partitions are numbered starting with 1) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If default INITRANS and/or MAXTRANS values for the partitioned table or index were not specified, system defaults would be used.

Action: Ensure that value of INITRANS (whether specified explicitly or derived from the default value for the partitioned table or index) is no greater than that of MAXTRANS. Then retry the operation.


ORA-14059

ORA-14059partition name: INITRANS value must be less than MAXTRANS value

Cause:The value of INITRANS was found to be greater than that of MAXTRANS for a partition whose name is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If default INITRANS and/or MAXTRANS values for the partitioned table or index were not specified, system defaults would be used.

Action: Ensure that value of INITRANS (whether specified explicitly or derived from the default value for the partitioned table or index) is no greater than that of MAXTRANS.


ORA-14060

ORA-14060data type or length of a table partitioning column may not be changed

Cause:An attempt was made to use the ALTER TABLE statement to modify data type and/or length of a column used to partition the table named in the ALTER TABLE statement.

Action: Avoid modifying data type and/or length of table partitioning column(s).


ORA-14061

ORA-14061data type or length of an index partitioning column may not be changed

Cause:An attempt was made to use the ALTER TABLE statement to modify data type and/or length of a column used to partition some index defined on the table named in the ALTER TABLE statement.

Action: Avoid modifying the data type and/or length of index partitioning column(s).


ORA-14062

ORA-14062one or more of the partitions of the table reside in a read-only tablespace

Cause:An attempt was made to use the ALTER TABLE statement to modify an existing VARCHAR2 (or VARCHAR) column to be of type CHAR (or CHARACTER), increase length of an existing CHAR (or CHARACTER) column, or add a column with user-specified default for a table that has one or more partitions residing in read-only tablespaces.

Action: Avoid performing these operations on a partitioned table that has one or more partitions residing in read-only tablespaces.


ORA-14063

ORA-14063unusable index exists on unique/primary constraint key

Cause:An attempt was made to add or enable a primary key/unique constraint on column(s) of a table that has an index marked Index Unusable.

Action: Drop the existing index, or rebuild it using ALTER INDEX REBUILD.


ORA-14064

ORA-14064index with Unusable partition exists on unique/primary constraint key

Cause:An attempt was made to add or enable a primary key/unique constraint on column(s) of a table on which there exists an index that has one or more partitions marked Index Unusable.

Action:Drop the existing index, or rebuild unusable partitions of it using ALTER INDEX REBUILD PARTITION.


ORA-14065

ORA-14065ALLOCATE STORAGE may not be specified for a partitioned table

Cause:An attempt was made to specify an ALLOCATE STORAGE clause in an ALTER TABLE statement issued against a partitioned table.

Action:Remove the ALLOCATE STORAGE option. The ALLOCATE STORAGE clause may be specified with ALTER TABLE MODIFY PARTITION statement, if additional storage to individual partitions is desired.


ORA-14066

ORA-14066Illegal option for a non-partitioned table

Cause:An attempt was made to issue an ALTER TABLE statement containing an option (such as TABLESPACE and INITIAL, FREELISTS, and FREELIST GROUPS inside STORAGE clauses) for a non-partitioned table. These options are permitted only for partitioned tables.

Action: Remove the illegal option(s), and retry the operation.


ORA-14067

ORA-14067duplicate TABLESPACE_NUMBER specification

Cause:A TABLESPACE_NUMBER clause was specified more than once for an index or an index partition.

Action: Correct the code generating text of the CREATE INDEX statement sent to the slaves, then retry the operation.


ORA-14068

ORA-14068TABLESPACE and TABLESPACE_NUMBER may not be both specified

Cause:An attempt was made to specify both TABLESPACE and TABLESPACE_NUMBER clauses for an index or an index partition.

Action:Correct the code generating text of the CREATE INDEX statement sent to the slaves, then retry the operation.


ORA-14069

ORA-14069invalid TABLESPACE_NUMBER value

Cause:An attempt was made to specify a TABLESPACE_NUMBER value which is not an integer between 0 and 0x7FFFFFFF.

Action: Correct the code generating text of the CREATE INDEX statement sent to the slaves, then retry the operation.


ORA-14070

ORA-14070option may be specified only for partitioned indices or with REBUILD

Cause:An attempt was made to issue an ALTER INDEX statement containing an option (such as PCTFREE, TABLESPACE, [NO]PARALLEL and INITIAL, FREELISTS, and FREELIST GROUPS inside STORAGE clause) which are permitted only for partitioned indices or in conjunction with REBUILD.

Action: Remove illegal option(s), and retry the operation.


ORA-14071

ORA-14071invalid option for an index used to enforce a constraint

Cause:An option other than COMPRESS, NOCOMPRESS, PCTFREE, INITRANS, MAXTRANS, STORAGE, TABLESPACE, PARALLEL, NOPARALLEL, RECOVERABLE, UNRECOVERABLE, LOGGING, NOLOGGING, LOCAL, or GLOBAL was specified for an index used to enforce a constraint.

Action: Choose one of the valid index options, and retry the operation.


ORA-14072

ORA-14072fixed table may not be truncated

Cause:An attempt was made to truncate a fixed table. Fixed tables cannot be truncated.

Action:Ensure that the table being truncated is not a fixed table.


ORA-14073

ORA-14073bootstrap table or cluster may not be truncated

Cause:An attempt was made to truncate a bootstrap table or cluster. Bootstrap tables or clusters cannot be truncated.

Action:Ensure that the table (or cluster) being truncated is not a bootstrap table (or cluster).


ORA-14074

ORA-14074partition bound for partition maintenance operation are too low

Cause:Partition bound for SPLIT or ADD partition operation did not collate higher than the partition bound of previous partition.

Action:Ensure that the partition bound of every partition (except the first one) collates higher than that of the previous partition.


ORA-14075

ORA-14075partition maintenance operations may only be performed on partitioned indices

Cause:The index named in the ALTER INDEX partition maintenance operation is not partitioned, making a partition maintenance operation meaningless.

Action: Ensure that the index named in the ALTER INDEX statement specifying a partition maintenance operation is partitioned.


ORA-14076

ORA-14076DROP/SPLIT PARTITION may not be applied to a LOCAL index partition

Cause:An attempt was made to drop or split a partition of a LOCAL index.

Action: Ensure that the index named in the DROP/SPLIT PARTITION statement is a GLOBAL partitioned index.


ORA-14077

ORA-14077specified partition does not exist

Cause:An attempt was made to perform a partition maintenance operation involving a non-existent partition.

Action: Ensure that the partitioned object (table or index) named in the ALTER TABLE/INDEX statement contains a specified partition.


ORA-14078

ORA-14078you may not drop the highest partition of a GLOBAL index

Cause:An attempt was made to drop highest partition of a GLOBAL index.

Action: Ensure that the partition specified in ALTER INDEX DROP PARTITION statement is not the highest partition of the index.


ORA-14079

ORA-14079illegal option for a partition marked Index Unusable

Cause:The ALTER INDEX MODIFY PARTITION statement issued against an index partition marked Index Unusable contained STORAGE and/or DEALLOCATE SPACE clauses.

Action:Ensure that only valid options are specified, then retry the operation.


ORA-14080

ORA-14080partition cannot be split along the specified high bound

Cause:An attempt was made to split a partition along a bound which either collates higher than that of the partition to be split or lower than that of a partition immediately preceding the one to be split.

Action:Ensure that the bound along which a partition is to be split collates lower than that of the partition to be split and higher than that of a partition immediately preceding the one to be split.


ORA-14081

ORA-14081new partition name must differ from the old partition name

Cause:An attempt was made to enter a ALTER TABLE/INDEX RENAME PARTITION statement specifying a partition name identical to the name of the partition being renamed.

Action: Ensure that the new partition name is different from the name of any (including the one being renamed) existing partition of a given table or index.


ORA-14082

ORA-14082new partition name must differ from that of any other partition of the object

Cause:An attempt was made to enter a ALTER TABLE/INDEX RENAME PARTITION statement specifying a partition name identical to the name of some existing partition of the object.

Action: Ensure that the new partition name is different from the name of any (including the one being renamed) existing partition of a given table or index.


ORA-14083

ORA-14083cannot drop the only partition of a partitioned table

Cause:A drop partition command was executed when there is only one partition in the table.

Action: Ensure that there is more than one partition. Drop the table to remove all partitions.


ORA-14084

ORA-14084you may specify TABLESPACE DEFAULT only for a LOCAL index

Cause:An attempt was made to specify TABLESPACE DEFAULT for an object other than a LOCAL index.

Action: Reenter the statement without the TABLESPACE DEFAULT clause.


ORA-14085

ORA-14085partitioned table cannot have column with LONG datatype

Cause:An attempt was made either to create a partitioned table with a LONG datatype or to add a LONG datatype column to a partitioned table.

Action: LONG data types are not supported with partitioned tables. Create a table without the LONG column or change the table to not-partitioned. If adding a column, do not use the LONG datatype. If modifying attributes of a column to change data type to LONG, it has to be a non-partitioned table.


ORA-14086

ORA-14086a partitioned index may not be rebuilt as a whole

Cause:An attempt was made to rebuild a partitioned index using the ALTER INDEX REBUILD statement.

Action: Rebuild the index one partition at a time (using ALTER INDEX REBUILD PARTITION) or drop and recreate the entire index.


ORA-14094

ORA-14094invalid ALTER TABLE EXCHANGE PARTITION option

Cause:Name of the table to be EXCHANGED was not followed by the [{INCLUDING|EXCLUDING} INDEX][{WITH|WITHOUT} VALIDATION] statement.

Action: Ensure that no options besides INCLUDING INDEX or EXCLUDING INDEX are specified with ALTER TABLE EXCHANGE PARTITION.


ORA-14095

ORA-14095ALTER TABLE EXCHANGE requires a non-partitioned, non-clustered table

Cause:An attempt was made to perform the EXCHANGE operation on a clustered or partitioned table.

Action: Ensure that the table being exchanged with the partition is not partitioned or clustered.


ORA-14096

ORA-14096tables in ALTER TABLE EXCHANGE PARTITION must have the same number of columns

Cause:The two tables specified in the EXCHANGE statement have a different number of columns.

Action: Ensure that the two tables have the same number of columns with the same type and size.


ORA-14098

ORA-14098index mismatch for tables in ALTER TABLE EXCHANGE PARTITION

Cause:The two tables specified in the EXCHANGE statement have indexes which are not equivalent.

Action: Ensure that the indexes for the two tables have indexes which follow this rule for every non-partitioned index for the non-partitioned table, there has to be an identical LOCAL index on the partitioned table and vice versa. By identical, the column position, type and size have to be the same.


ORA-14099

ORA-14099all rows in table do not qualify for specified partition

Cause:It was detected that at least one row in the non-partitioned table does not qualify for the partition specified in the ALTER TABLE EXCHANGE PARTITION.

Action: Ensure that all the rows in the segment qualify for the partition. Perform the ALTER TABLE operation with the NO CHECKING option. Run ANALYZE table VALIDATE on that partition to find out the invalid rows and delete them.


ORA-14100

ORA-14100partition extended table name cannot refer to a remote object

Cause:An attempt was made to use partition-extended table name syntax in conjunction with a remote object name.

Action: Correct the statement and retry the operation.


ORA-14101

ORA-14101partition extended table name cannot refer to a synonym

Cause:An attempt was made to use partition-extended table name syntax in conjunction with a synonym name.

Action: Correct the statement and retry the operation.


ORA-14102

ORA-14102only one LOGGING or NOLOGGING clause may be specified

Cause:LOGGING was specified more than once, NOLOGGING was specified more than once, or both LOGGING and NOLOGGING were specified.

Action: Remove all but one of the LOGGING or NOLOGGING clauses and reissue the statement.


ORA-14103

ORA-14103LOGGING/NOLOGGING may not be combined with RECOVERABLE/UNRECOVERABLE

Cause:A statement contained both [NO]LOGGING and [UN]RECOVERABLE clauses which is not allowed.

Action: Remove one of the offending clauses. [UN]RECOVERABLE is being deprecated in V8. To duplicate the semantics of the UNRECOVERABLE clause, create an object with the NOLOGGING option and then ALTER it specifying LOGGING. To duplicate semantics of RECOVERABLE clause, create an object with the LOGGING option.


ORA-14104

ORA-14104RECOVERABLE/UNRECOVERABLE may not be specified for partitioned tables/indices

Cause:The CREATE TABLE/INDEX statement used to create a partitioned table/index contained a RECOVERABLE or UNRECOVERABLE clause.

Action: Remove the offending clause. [UN]RECOVERABLE is being deprecated in V8. To duplicate the semantics of the UNRECOVERABLE clause, create an object with the NOLOGGING option and then ALTER it specifying LOGGING. To duplicate the semantics of the RECOVERABLE clause, create an object with the LOGGING option.


ORA-14105

ORA-14105RECOVERABLE/UNRECOVERABLE may not be specified in this context

Cause:RECOVERABLE/UNRECOVERABLE clause is not allowed in this context.

Action: Remove the offending clause. RECOVERABLE/UNRECOVERABLE may only be specified in CREATE TABLE/INDEX statement describing a non-partitioned table or index and ALTER INDEX REBUILD statement. [UN]RECOVERABLE is being deprecated in V8. To duplicate the semantics of the UNRECOVERABLE clause, create an object with the NOLOGGING option and then ALTER it specifying LOGGING. To duplicate the semantics of the RECOVERABLE clause, create an object with the LOGGING option.


ORA-14106

ORA-14106LOGGING/NOLOGGING may not be specified for a clustered table

Cause:An attempt was made to specify a LOGGING or NOLOGGING clause in a CREATE TABLE or ALTER TABLE statement involving a clustered table.

Action: Remove offending clause and retry the operation.


ORA-14107

ORA-14107partition specification is required for a partitioned object

Cause:A parameter which supplies the partition name was not entered. This parameter is optional for non-partitioned objects, but is required for partitioned objects.

Action: Supply the missing parameter and retry the operation.


ORA-14108

ORA-14108illegal partition-extended table name syntax

Cause:An attempt was made to use a partition number or a bind variable. A partition to be accessed can only be specified using its name.

Action: Modify the statement so that the partition is referred to by its name.


ORA-14109

ORA-14109partition-extended object names may only be used with tables

Cause:An attempt was made to use a partition-extended object name with an object which is not a table.

Action: Avoid using partition-extended name syntax with objects which are not tables.


ORA-14110

ORA-14110partitioning column may not be of type ROWID

Cause:The specified partitioning column was of type ROWID.

Action: Ensure that no partitioning column is of type ROWID, then retry the operation.


ORA-14111

ORA-14111creation of GLOBAL partitioned indices on clustered tables is not supported

Cause:An attempt was made to create a GLOBAL partitioned index on a clustered table which is currently illegal.

Action:Remove PARTITION BY RANGE() clause along with the partition-list to create a GLOBAL non-partitioned index on a clustered table.


ORA-14112

ORA-14112RECOVERABLE/UNRECOVERABLE may not be specified for a partition

Cause:Description of a partition found in CREATE TABLE/INDEX statement contained a RECOVERABLE or UNRECOVERABLE clause.

Action:Remove the offending clause. Use LOGGING or NOLOGGING instead and retry the operation.


ORA-14113

ORA-14113partitioned table cannot have column with LOB datatype

Cause:An attempt was made either to create a partitioned table with a LOB datatype or to add a LOB datatype column to a partitioned table.

Action:LOB data types are not supported with partitioned tables. Create table without the LOB column or change the table to non-partitioned. If adding a column, do not use LOB datatype. If modifying attributes of a column to change data type to LOB, it has to be a non-partitioned table.


ORA-14114

ORA-14114partitioned table cannot have column with ADT, REF, nested table, array datatype

Cause:An attempt was made either to create a partitioned table with an OBJECT datatype (ADT, REF, nested table, array) or to add an OBJECT datatype column to a partitioned table.

Action:Object data types are not supported with partitioned tables. Create the table without the Object column or change the table to non-partitioned. If adding a column, do not use OBJECT datatypes. If modifying attributes of a column to change data type to OBJECT, it has to be a non-partitioned table.


ORA-14115

ORA-14115partition bound of partition number num is too long

Cause:Length of linear key representation of a high bound of the partition whose number (partitions are numbered starting with 1) is displayed in this message exceeded the legal limit (4K).

Action:Change representation of a partition high bound to bring its length within legal limit.


ORA-14116

ORA-14116partition bound of partition num is too long

Cause:Length of linear key representation of a high bound of the partition whose name (explicitly specified by the user) is displayed in this message exceeded the legal limit (4K).

Action:Change representation of a partition high bound to bring its length within legal limit.


ORA-14117

ORA-14117partition resides in offlined tablespace

Cause:User attempted an operation requiring that we access data in a partition which resides in a tablespace which was taken offline. Such operations include trying to drop a tablespace of a table which has indices defined on it or is referenced by a constraint.

Action:Bring tablespace online before attempting the operation.


ORA-14118

ORA-14118CHECK constraint mismatch in ALTER TABLE EXCHANGE PARTITION

Cause:The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE PARTITION have different CHECK constraint.

Action:Ensure that the two tables do not have CHECK constraint defined on any column.


ORA-14119

ORA-14119specified partition bound is too long

Cause:Length of a linear key representation of a high bound of a table partition being added or along which an existing table or index partition is being split exceeded the legal limit (4K).

Action:Change representation of a partition high bound to bring its length within legal limit.


ORA-14120

ORA-14120incompletely specified partition bound for a DATE column

Cause:An attempt was made to use a date expression whose format does not fully (i.e. day, month, and year (including century)) specify a date as a partition bound for a DATE column. The format may have been specified explicitly (using TO_DATE() function) or implicitly (NLS_DATE_FORMAT).

Action: Ensure that date format used in a partition bound for a DATE column supports complete specification of a date (i.e. day, month, and year (including century)). If NLS_DATE_FORMAT does not support complete (i.e. including the century) specification of the year, use TO_DATE() (e.g. TO_DATE('01-01-1999', 'MM-DD-YYYY') to fully express the desired date.


ORA-14121

ORA-14121MODIFY DEFAULT ATTRIBUTES may not be combined with other operations

Cause:ALTER TABLE or ALTER INDEX statement attempted to combine MODIFY DEFAULT ATTRIBUTES with some other operation (for example, ADD PARTITION or PCTFREE) which is illegal.

Action: Ensure that MODIFY DEFAULT ATTRIBUTES is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices, or specifying that a table be renamed (ALTER TABLE RENAME) may be combined.


ORA-14122

ORA-14122only one REVERSE or NOREVERSE clause may be specified

Cause:Both REVERSE and NOREVERSE were specified in CREATE INDEX statement..

Action: Remove all but one of the REVERSE or NOREVERSE clauses and reissue the statement.


ORA-14123

ORA-14123duplicate NOREVERSE clause

Cause:NOREVERSE was specified more than once in ALTER INDEX statement.

Action: Remove all but one of the NOREVERSE clauses and reissue the statement.


ORA-14124

ORA-14124duplicate REVERSE clause

Cause:REVERSE was specified more than once in ALTER INDEX or CREATE INDEX statements.

Action:Remove all but one of the REVERSE clauses and reissue the statement.


ORA-14125

ORA-14125REVERSE/NOREVERSE may not be specified in this context

Cause:REVERSE/NOREVERSE clause is not allowed in this context.

Action:Remove offending clause. REVERSE may be specified as an attribute of an index (not of an individual partition, if creating a partitioned index) in CREATE INDEX statement and ALTER INDEX REBUILD statement. NOREVERSE may be specified only in ALTER INDEX REBUILD statement.


ORA-14400

ORA-14400inserted partition key is beyond highest legal partition key

Cause:The concatenated partition key of an inserted record was found to be beyond the concatenated partition bound list of the last partition.

Action:Either do not insert the key or add a partition capable of accepting the key.


ORA-14401

ORA-14401inserted partition key is outside specified partition

Cause:The concatenated partition key of an inserted record was found to be outside the ranges of the two concatenated partition bound lists that delimit the partition named in the INSERT statement.

Action:Either do not insert the key or else insert it in another partition.


ORA-14402

ORA-14402attempt to change the value of a partition key column

Cause:An UPDATE statement attempted to change the value of a partition key column.

Action:Either do not attempt to update a partition key column or else make sure that the new column value is equal to the old column value.


ORA-14403

ORA-14403cursor invalidation detected after getting DML partition lock

Cause:Cursor invalidation was detected after acquiring a partition lock during an INSERT, UPDATE, DELETE statement. This error is never returned to user, because is caught in opiexe() and the DML statement is retried.

Action:Nothing need be done, error should never be returned to user.


ORA-14404

ORA-14404partitioned table contains partitions in a different tablespace

Cause:An attempt was made to drop a tablespace which contains tables whose partitions are not completely contained in this tablespace.

Action:Find tables with partitions which span the tablespace being dropped and some other tablespace(s). Drop these tables or move partitions to a different tablespace.


ORA-14405

ORA-14405partitioned index contains partitions in a different tablespace

Cause:An attempt was made to drop a tablespace which contains indexes whose partitions are not completely contained in this tablespace, and which are defined on the tables which are completely contained in this tablespace.

Action:Find indexes with partitions which span the tablespace being dropped and some other tablespace(s). Drop these indexes, or move the index partitions to a different tablespace, or find the tables on which the indexes are defined, and drop (or move) them.


ORA-14500

ORA-14500LOCAL option not valid without partition name

Cause:Incorrect syntax was specified for the LOCAL option.

Action:Enter a partition name for the LOCAL option and retry the command.


ORA-14501

ORA-14501object is not partitioned

Cause:The table or index was not partitioned. Invalid syntax.

Action:Retry the command with correct syntax.


ORA-14502

ORA-14502partition does not exist

Cause:An attempt was made to specify a partition which does not exist for the object.

Action:Specify a valid partition name and retry the operation.


ORA-14503

ORA-14503only one partition name can be specified

Cause:More than one partition name has been specified for the ANALYZE option.

Action:Specify one partition name and retry the operation.


ORA-14504

ORA-14504syntax not supported for ANALYZE

Cause:A partition number or bind variable has been used for the ANALYZE option.

Action:Specify a valid partition name.


ORA-14505

ORA-14505LOCAL option valid only for partitioned indexes

Cause:Incorrect syntax was specified for the LOCAL option.

Action:Correct the syntax by specifying a partitioned index and retry the command.


ORA-14506

ORA-14506LOCAL option required for partitioned indexes

Cause:Incorrect syntax was specified for the partitioned index.

Action:Correct the syntax by specifying the LOCAL option and retry the command.


ORA-14507

ORA-14507partition corrupt. all rows do not fall within partition bounds

Cause:The partition contained rows which should be in some other partition. This was possibly due to an exchange partition without validation.

Action:Delete rows in partition which fall outside the partition bounds.


ORA-14508

ORA-14508specified VALIDATE INTO table not found

Cause:The specified table either does not exist or the user does not have the proper privileges.

Action:Specify the correct table to use or obtain the proper privileges.


ORA-14509

ORA-14509specified VALIDATE INTO table form incorrect

Cause:The specified table does not have the proper field definitions.

Action:Specify the correct table to use and retry the operation.


ORA-14510

ORA-14510can specify VALIDATE INTO clause only for partitioned tables

Cause:The VALIDATE INTO has been specified for a non-partitioned table, cluster or index.

Action:Use the VALIDATE INTO clause only for a partitioned table and retry the operation.


ORA-16000

ORA-16000database open for read-only access

Cause:The database has been opened for read-only access. Attempts to modify the database using inappropriate DML or DDL statements generate this error.

Action:In order to modify the database, it must first be shut down and re-opened for read-write access.


ORA-16001

ORA-16001database already open for read-only access by another instance

Cause:The database has been opened for read-only access by another instance, and cannot be opened for read-write access by this instance.

Action:This instance must be opened for read-write access, or all other instances must first be shut down and re-opened for read-only access.


ORA-16002

ORA-16002database already open for read-write access by another instance

Cause:The database has been opened for read-write access by another instance, and cannot be opened for read-only access by this instance.

Action:This instance must be opened for read-only access, or all other instances must first be shut down and re-opened for read-write access.


ORA-19500

ORA-19500device block size num is invalid

Cause:The device block size returned by sequential I/O OSD is invalid.

Action:Correct the block size and retry the operation.


ORA-19501

ORA-19501read error on file name, blockno name (blocksize=num)

Cause:A read error was detected on the input file.

Action:Check that the file is not corrupt and retry the operation.


ORA-19502

ORA-19502write error on file name, blockno name (blocksize=num)

Cause:A write error was detected on the output file.

Action:Check that the file is not corrupt and retry the operation.


ORA-19503

ORA-19503cannot obtain information on device, name=name, type=name, parms=name

Cause:A call to get device information returned an error. Most likely one or more of the following was entered incorrectlydevice name, type, parameters.

Action:Check that the device name, type, and parameters are correct and retry the operation.


ORA-19504

ORA-19504failed to create file name

Cause:A call to create file returned an error.

Action:Check additional messages and access permissions, make the necessary corrections, then retry the operation.


ORA-19505

ORA-19505failed to identify file name

Cause:A call to identify the file returned an error. Most likely the filename was entered incorrectly or the file does not exist.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Check if the file exists, then retry the operation.


ORA-19507

ORA-19507failed to retrieve sequential file, handle=name, parms=name

Cause:A call to retrieve the sequential file returned an error. Most likely the filename was entered incorrectly or the file does not exist.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Check if the filename was entered correctly and that the file exists. Then retry the operation.


ORA-19508

ORA-19508failed to delete file name

Cause:A call to delete the file returned an error. Most likely the filename was entered incorrectly or the file does not exist.

Action:One or more other messages should be displayed to help pinpoint the cause of the error.


ORA-19509

ORA-19509failed to delete sequential file, handle=name, parms=name

Cause:A call to delete the sequential file returned an error.

Action:One or more other messages should be displayed to help pinpoint the cause of the error.


ORA-19510

ORA-19510failed to set size of num blocks for file name (blocksize=num)

Cause:A call to resize the file returned an error.

Action:One or more other messages should be displayed to help pinpoint the cause of the error.


ORA-19550

ORA-19550cannot use BACKUP/RESTORE functions while using dispatcher

Cause:Attempted to use BACKUP/RESTORE functions while connected to the dispatcher in a multi-threaded server. This is not allowed because the device that is used for backup and restore must remain allocated to a single process.

Action:Connect directly to the instance then re-execute the BACKUP or RESTORE function.


ORA-19551

ORA-19551device is busy, device type: name, device name: name

Cause:The indicated device could not be allocated because it is allocated to another session, or no device was named, or all devices of the requested type are busy.

Action:Either attempt to allocate another device or wait until the required device is no longer busy.


ORA-19552

ORA-19552device type name is invalid

Cause:The device type indicated is invalid.

Action:Supply a correct device type and retry the allocation.


ORA-19553

ORA-19553device name name is invalid

Cause:The device name indicated is invalid.

Action:Supply a correct device name and retry the allocation.


ORA-19554

ORA-19554error allocating device, device type: name, device name: name

Cause:The specified device could not be allocated.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.


ORA-19555

ORA-19555invalid LOG_ARCHIVE_MIN_SUCCEED_DEST INIT.ORA parameter

Cause:The initialization parameter LOG_ARCHIVE_MIN_SUCCEED_DEST is not within the valid range.

Action:Specify a correct value. If the database is in ARCHIVELOG mode with automatic archiving enabled, LOG_ARCHIVE_MIN_SUCCEED_DEST should be either 1 or 2.


ORA-19556

ORA-19556one of the two must-succeed archive destinations is disabled

Cause:LOG_ARCHIVE_DUPLEX_DEST has been disabled possibly due to failure to archive to that destination.

Action:Either

(1) change the number of must-succeed destinations or

(2) re-specify LOG_ARCHIVE_DUPLEX_DEST.


ORA-19557

ORA-19557device error, device type: name, device name: name

Cause:An error occurred in the platform-specific device code.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.


ORA-19558

ORA-19558error de-allocating device

Cause:The specified device could not be de-allocated.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.


ORA-19559

ORA-19559error sending device command: name

Cause:An error occurred while sending the indicated command to the session device.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.


ORA-19560

ORA-19560name is not a valid device limit

Cause:An invalid type of device limit was specified in a call to X$DBMS_BACKUP_RESTORE.SETLIMIT.

Action:Use one of the documented limitsKBYTES, READRATE, or PARALLEL.


ORA-19561

ORA-19561name requires null session device

Cause:The attempted datafile, archivelog, or controlfile copy requires that a null device be allocated to the session, but a non-null device was found.

Action:De-allocate the current device and allocate a null device to the session, then retry the copy.


ORA-19562

ORA-19562file name is empty

Cause:The indicated file, which is an archivelog, controlfile, or datafile was found to be empty during a copy, scan, or backup operation.

Action:Ensure that the correct files are being specified for the copy or backup operation.


ORA-19563

ORA-19563name header validation failed for file name

Cause:When opening the file to be placed in a copy or backup set, or to be inspected, the header was not recognized as a valid file header for a file of the indicated type (datafile, archivelog, or controlfile), belonging to the current database, or perhaps the file does belong to the current database but has been changed since it was specified for inclusion in the backup set.

Action:Ensure that the correct files are being specified for the copy or backup operation.


ORA-19564

ORA-19564error occurred writing num bytes at block number num

Cause:An error occurred while writing to a file.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error if possible, then retry the copy, backup, or restore operation.


ORA-19566

ORA-19566exceeded limit of num corrupt blocks for file name

Cause:The user-specified limit of allowable corrupt blocks was exceeded while reading the specified datafile for a datafile copy or backup.

Action:None. The copy or backup operation fails. The session trace file contains detailed information about which blocks were corrupt.


ORA-19567

ORA-19567cannot shrink file name because it is being backed up or copied

Cause:An ALTER statement attempted to reduce the size of the indicated file while the same file is being backed up or copied.

Action:Retry the resize after the backup or copy is complete.


ORA-19568

ORA-19568a device is already allocated to this session

Cause:An attempt was made to allocate a device to a session while another device is already allocated.

Action:De-allocate the current device and retry the operation.


ORA-19569

ORA-19569no device is allocated to this session

Cause:An operation was attempted which requires a device to be allocated to the current session, and there is no device allocated.

Action:Allocate a device then retry the operation.


ORA-19570

ORA-19570file number num is outside valid range of 1 through num

Cause:A file number used in a COPY, BACKUP, or RESTORE operation is not valid for the current database.

Action:Specify a valid file number and retry the operation.


ORA-19571

ORA-19571num recid num stamp name not found in controlfile

Cause:The input file specified for a COPY or BACKUP operation could not be opened because the record describing the file is not found in the controlfile.

Action:Specify a correct recid/stamp and retry the copy or backup.


ORA-19572

ORA-19572cannot process file name, file is being resized

Cause:The input file specified for a COPY or BACKUP operation could not be opened because the file is being resized.

Action:Wait for the resize to complete then retry the copy or backup.


ORA-19573

ORA-19573cannot obtain name enqueue for datafile num

Cause:The file access enqueue could not be obtained for a file specified in a COPY or BACKUP operation. If the enqueue type shown is "shared", then the file is the input file for a backup or copy. If the type is "exclusive", then the file is the output file for a datafile copy or restore which is attempting to overwrite the currently active version of that file. In this case, the file must be offline or the database must be closed.

Action:Wait until the conflicting operation is complete, then retry the COPY or BACKUP.


ORA-19574

ORA-19574output filename must be specified

Cause:This type of COPY or RESTORE requires an output file name.

Action:Specify an output filename and retry the operation.


ORA-19575

ORA-19575expected num blocks in file name, found num

Cause:During a BACKUP, RESTORE, COPY or SCAN operation, the indicated file did not contain as many blocks as were indicated in the file header.

Action:The input copy or backup piece is probably corrupt. If another backup or copy of the file that is being restored exists, then the corrupt file can be deleted from the recovery catalog and the operation can be restarted.


ORA-19576

ORA-19576datafile num not defined in control file

Cause:The specified file number was not found in the control file.

Action:Specify a correct file number and retry the operation.


ORA-19577

ORA-19577file name is MISSING

Cause:A copyDataFileCopy or restoreDataFileTo function specified a file number but no output file name, indicating that the output filename should be taken from the controlfile. However, the controlfile entry for this file indicates that it was created for a file that was present in the data dictionary but not named during the last CREATE CONTROLFILE statement, so the name in the controlfile cannot be used for restoration.

Action:Either specify an output filename or issue a SQL RENAME command to enter a valid name for this file in the controlfile.


ORA-19580

ORA-19580name conversation not active

Cause:A BACKUP or RESTORE operation was attempted before a conversation was started.

Action:Start a conversation then retry the operation.


ORA-19581

ORA-19581no files have been named

Cause:An attempt was made to proceed from the file naming phase to the piece processing phase of a BACKUP or RESTORE conversation before any files have been specified for BACKUP or RESTORE.

Action:Specify some files then retry the operation.


ORA-19583

ORA-19583conversation terminated due to error

Cause:An error occurred which forced the termination of the current BACKUP or RESTORE conversation.

Action:There should be other error messages to help identify the cause of the problem. Correct the error and begin another conversation.


ORA-19584

ORA-19584file name already in use

Cause:The indicated file, which was specified as the target for a COPY or RESTORE operation is already in use by the database.

Action:Specify a different name and retry the COPY or RESTORE operation.


ORA-19585

ORA-19585premature end of volume on piece name

Cause:While creating the indicated backup piece, an end-of-volume condition was encountered before all of the backup set control data was written to the backup piece. This is most likely a media error, because the amount of backup set control data is very small in relation to the total amount of data in a backup set.

Action:Retry the piece with a larger piece of output media.


ORA-19586

ORA-19586num k-byte limit is too small to hold piece directory

Cause:The user-specified limit of k-bytes per backup piece is not enough to hold the backup set control data.

Action:Use the SETLIMIT procedure to increase the k-byte limit and retry the operation.


ORA-19587

ORA-19587error occurred reading num bytes at block number num

Cause:An error occurred while reading from a file.

Action:One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error then retry the COPY, BACKUP, or RESTORE operation.


ORA-19588

ORA-19588num recid num stamp name is no longer valid

Cause:The indicated record has been marked as deleted. This indicates that the corresponding file has either been overwritten by another copy or restore, or that the copy was "consumed" by a switchToCopy operation.

Action:If you know the name of the file you want to copy, then inspect it and then retry the copy specifying the new recid.


ORA-19589

ORA-19589name is not a snapshot or backup controlfile

Cause:The controlfile that is the source for a backup or copy operation is not a SNAPSHOT or BACKUP controlfile.

Action:Specify the name of a SNAPSHOT or BACKUP controlfile.


ORA-19590

ORA-19590conversation already active

Cause:You tried to begin a BACKUP or RESTORE conversation, but another conversation is already active in this session.

Action:Either continue the current conversation, or call backupCancel or restoreCancel to end the current conversation before starting a new one.


ORA-19592

ORA-19592wrong name conversation type

Cause:An attempt was made to specify a type of file to be backed-up or restored, but the current conversation cannot process this type of file. For example, an attempt was made to specify an archived log to be included in a datafile backup set. The specified file will not be included in the BACKUP or RESTORE operation.

Action:No action required - the conversation is still active, and more files can be specified.


ORA-19593

ORA-19593datafile number num already included as name

Cause:This datafile is already specified for inclusion in this BACKUP or RESTORE conversation. A BACKUP or RESTORE conversation may process only a single instance of a datafile.

Action:No action required - the conversation is still active, and more files can be specified.


ORA-19594

ORA-19594controlfile already included as name

Cause:The controlfile is already specified for inclusion in this BACKUP or RESTORE conversation. A BACKUP or RESTORE conversation may process only a single instance of the controlfile.

Action:No action required - the conversation is still active, and more files can be specified.


ORA-19595

ORA-19595archivelog thread name sequence name already included as name

Cause:The indicated archivelog has already been specified for inclusion in this backup conversation. A backup conversation may process only one copy of any archivelog.

Action:No action required - the conversation is still active, and more files can be specified.


ORA-19596

ORA-19596snapshot controlfile has not been created

Cause:An attempt was made to request that the snapshot controlfile be included in the backup set, but no snapshot controlfile has been created for this instance.

Action:Specify a different controlfile name, or call cfileMakeAndUseSnapshot to create the snapshot controlfile.


ORA-19597

ORA-19597file name blocksize num does not match set blocksize of num

Cause:A file was specified for inclusion in a backup set but it has a logical block size different from the rest of the files in the backup set. All files in a backup set must have the same logical block size.

Action:Specify a file that has the same block size as the rest of the files in the backup set. The conversation is still active and more files can be specified.


ORA-19598

ORA-19598starting SCN must be specified for incremental backup

Cause:No starting SCN was specified to backupDataFile or backupDataFileCopy, but the current backup conversation is for an incremental backup, which requires that a non-zero SCN be specified for all datafiles.

Action:The conversation is still active. Re-specify the datafile with a non-zero SCN.


ORA-19599

ORA-19599block number num is corrupt in name

Cause:A corrupt block was found in a controlfile, archivelog, or backup piece that is being read for a backup or copy. Corruption is not allowed in controlfiles, archivelogs, or backup pieces.

Action:None. The COPY or BACKUP operation fails. Note that in the case of a backup set, the conversation is still active and the piece may be retried.


ORA-19600

ORA-19600input file is name num

Cause:This message identifies the input file for a failed copy operation. Both the file number and name (if the name has been determined) are shown.

For a datafile, the file number refers to the datafile's absolute file number as shown in the DBA_DATA_FILES view.

For a datafile-copy, the file number refers to the copy's controlfile record number as shown in the V$DATAFILE_COPY view.

For a datafile-copy, the file number refers to the copy's controlfile record number as shown in the RECID column of the V$DATAFILE_COPY view.

For an archived log, the file number refers to the log's controlfile record number as shown in the RECID column of the V$ARCHIVED_LOG view.

Action:Other messages should display to help pinpoint the cause and the solution.


ORA-19999

ORA-19999SKIP_ROW procedure was called

Cause:This message is raised when the SKIP_ROW procedure is called.

Action:This procedure should be called only within a trigger or a procedure called by a trigger.


ORA-20000

ORA-20000 str

Cause:The stored procedure RAISE_APPLICATION_ERROR was called which causes this message to be generated.

Action:Correct the problem as described in the message, or contact the application administrator or database administrator for more information.


ORA-21000

ORA-21000message number argument to RAISE_APPLICATION_ERROR of name is out of range, must be between -20000 and -20999, inclusive

Cause:An attempt was made to specify a message number not in the range of -20000 to -20999.

Action:The valid range for user-specified error numbers is -20000 to -20999 inclusively. Do not specify numbers outside of this range.


ORA-21001

ORA-21001error number argument to raise_system_error of num is out of range

Cause:An attempt was made to specify a number not in the range of -23300 to -24299, or -29300 to -29399, inclusive.

Action:Use an error number in the range of -23300 to -24299, or -29300 to -29399, inclusive.


ORA-21300

ORA-21300objects option not installed

Cause:The objects option was not installed at this site. Object types and other object features were, therefore, unavailable.

Action:Install the objects option. The objects option is not part of the Oracle Server product and must be purchased separately. Contact an Oracle sales representative if the objects option needs to be purchased.


ORA-21301

ORA-21301not initialized in object mode

Cause:This function requires the OCI process to be initialized in object mode.

Action:Specify OCI_OBJECT mode when calling OCIInitialize().


ORA-21500

ORA-21500internal error code, arguments: [num], [num], [num], [num], [num], [num], [num], [num]

Cause:This is the generic error number for the user-side Oracle Runtime Environment for Objects (OREO) internal errors. This indicates that the runtime environment has encountered an exceptional condition.

Action:Report as a bug to Oracle Support - the first argument is the internal error number.


ORA-21503

ORA-21503program terminated by fatal error

Cause:A program is in an unrecoverable state.

Action:Report as a bug to Oracle Support.


ORA-21520

ORA-21520driver does not exist

Cause:An attempted was made to connect to a persistent store driver that is not linked in.

Action:Check the server name supplied in origrgc(). Check if the driver corresponding to this server name has been linked in and entered in the server table.


ORA-21521

ORA-21521exceeded maximum number of connection

Cause:An attempted was made to exceed the maximum number of connections allowed (255) per OMS instance.

Action:Close some of the existing connections using origurg() before requesting more connections.


ORA-21522

ORA-21522invalid connection number

Cause:There is no connection entry corresponding to this connection number.

Action:Check the connection number and ensure that the connection exists.


ORA-21524

ORA-21524object type mismatch

Cause:The type of the object is different from what was specified.

Action:Check the type of the object and correct it.


ORA-21525

ORA-21525attribute number or (collection element at index) num violated its constraints

Cause:Attribute value or collection element value violated its constraint.

Action:Change the value of the attribute or collection element such that it meets its constraints. The constraints are specified as part of the attribute or collection element's schema information.


ORA-21560

ORA-21560argument name should not be null

Cause:The argument is expecting a non-NULL, valid value but the argument value passed in is NULL, invalid, or out of range. Examples include when the LOB/FILE positional or size argument has a value outside the range 1 through (4GB - 1), or when an invalid open mode is used to open a file, etc.

Action:Check your program and correct the caller of the routine to not pass a NULL, invalid, or out-of-range argument value.


ORA-21600

ORA-21600path expression too long

Cause:The path expression that was entered is too long. The path expression specifies the position of an attribute in an object. When the ORI* function retrieves the attribute using the path expression, it encounters an attribute of primitive type before finishing to consume the all the elements in the expression.

Action:Pass in the correct path expression to locate the attribute.


ORA-21601

ORA-21601attribute is not an instance of user-defined type

Cause:An attempt was made to perform an operation (that is valid only for an object type) to an attribute of primitive type. The operation includes dynamically setting a null structure to an attribute of primitive type.

Action:Avoid performing this operation on an attribute of primitive type.


ORA-21602

ORA-21602the operation does not support the specified typecode

Cause:The user attempts to perform an operation that does not support the specified typecode.

Action:User should use the range of valid typecodes that are supported by this function.


ORA-21700

ORA-21700object does not exist or has been deleted

Cause:An attempt was made to perform an inappropriate operation to a deleted or non-existent object that is referenced by a dangling reference. Operations that cannot be applied to a non-existent or deleted object include deleting, updating and allocating memory.

Action:Re-initialize the reference in order to reference an existent object before performing the operation.


ORA-21701

ORA-21701object has been purged

Cause:An attempt was made to perform an inappropriate operation to an object that is marked purged. The actual object could have been modified in the database. Operations that cannot be applied to a purged object includes updating, deleting and flushing.

Action:Pin the object again to get the new data.


ORA-21702

ORA-21702object is not instantiated in the cache

Cause:An attempt was made to perform an inappropriate operation to a transient object that is not instantiated in the object cache. Operations that cannot be

applied to a not-instantiated transient object include deleting or pinning such an object.

Action:Check the code to see if operations are being performed without instantiating the object first, or operations are being performed after the allocation duration of the object has expired.


ORA-21703

ORA-21703cannot flush an object that is not modified

Cause:The object could not be flushed because it has not been modified.

Action:The object should not be flushed.


ORA-21704

ORA-21704terminate cache or connection without flushing

Cause:See the error message.

Action:The transaction should be aborted or committed before terminating the cache or connection.


ORA-21705

ORA-21705service context is invalid

Cause:An attempt was made to supply a service context that is not valid.

Action:Establish the service context and retry the operation.


ORA-21706

ORA-21706duration does not exist

Cause:An attempt was made to supply a duration number that is not valid.

Action:Establish the duration or use a correct predefined duration.


ORA-21707

ORA-21707the pin duration is longer than the allocation duration

Cause:An attempt was made to supply a pin duration that is longer than the allocation duration. This affects operations such as pinning and setting default parameters.

Action:Use a shorter pin duration or use the null duration.


ORA-21708

ORA-21708operations cannot be performed on a transient object

Cause:An attempt was made to perform an inappropriate operation on a transient object. Operations that cannot be applied to a transient object include flushing and locking.

Action:Avoid performing operations such as flushing and locking on a transient object.


ORA-21709

ORA-21709operations can only be performed on a current object

Cause:An attempt was made to perform an inappropriate operation on a not-current object. Operations that cannot be applied to a not-current object include locking, updating, deleting and flushing.

Action:Avoid performing locking, updating, deleting or flushing operations on a not-current object.


ORA-21710

ORA-21710 magic number mismatch

Cause:An attempt was made to supply an invalid object. A bad pointer might have been passed to the object or else a value might have been passed to a function that is expecting an object.

Action:Ensure that a valid pointer or a valid value is passed to the function.


ORA-21779

ORA-21779duration not active

Cause:An attempt was made to use a duration that has been terminated.

Action:Do not use terminated durations in operations.


ORA-22000

ORA-22000variable-length string size of num bytes is outside valid range num to num bytes

Cause:An attempt was made to pass a variable-length string which is outside the valid range.

Action:Specify a string size which is within the valid range and retry the operation.


ORA-22053

ORA-22053overflow error

Cause:The number is too large to be represented by Oracle number.

Action:The operation is beyond the range of Oracle number.


ORA-22054

ORA-22054underflow error

Cause:Number is too small to be represented by Oracle number.

Action:The operation is beyond the range of Oracle number.


ORA-22055

ORA-22055unknown sign flag value [name]

Cause:The signed flag that was used is not ORLTSB or ORLTUB as defined in ORL.H.

Action:Use either ORLTSB or ORLTUB as the sign flag.


ORA-22056

ORA-22056value [num] is divided by zero

Cause:A divide by zero operation has occurred.

Action:Modify the invalid operation and reissue the command.


ORA-22057

ORA-22057bad integer length [num]

Cause:An attempt was made to convert an integer of invalid length (that is, number of bytes) to or from an Oracle number.

Action:Use an integer length of 1, 2, 4 or 8 bytes only.


ORA-22059

ORA-22059 buffer size [num] is too small - [num] is needed

Cause:The buffer to hold the text string which wa to be converted from an Oracle number is too small.

Action:Use a buffer size at least that suggested in the error message and retry the operation.


ORA-22060

ORA-22060argument [num] is an invalid or uninitialized number

Cause:An invalid or uninitialized number was passed to a function.

Action:Call kolnini() to initialize a number before using it.


ORA-22061

ORA-22061invalid format text [num]

Cause:An invalid numeric format string was used to convert characters to or from an Oracle number.

Action:See format specification in the description of the TO_NUMBER conversion function in the PL/SQL User's Guide and Reference.


ORA-22062

ORA-22062invalid input string [name]

Cause:An invalid text string was used for converting to numbers.

Action:Use a valid input string and retry the operation.


ORA-22063

ORA-22063reading negative value [num] as unsigned

Cause:An attempt was made to convert a negative number to an unsigned integer.

Action:Use the sign flag ORLTSB to convert a signed number.


ORA-22064

ORA-22064invalid NLS parameter string [name]

Cause:An invalid parameter string was used to convert characters to or from an Oracle number.

Action:See format specification under the TO_NUMBER conversion function in the PL/SQL User's Guide and Reference.


ORA-22065

ORA-22065number to text translation for the given format causes overflow

Cause:Rounding done due to the given string format causes overflow.

Action:Change the string format such that overflow does not occur.


ORA-22130

ORA-22130given buffer size num is less than the required size of num

Cause:An attempt was made to write a hexadecimal REF string into a buffer which is too small.

Action:Provide a buffer of the required size and retry the operation.


ORA-22131

ORA-22131given hexadecimal string length num is not valid

Cause:An attempt was made to give a hexadecimal string a length of zero or less.

Action:Specify a hexadecimal string length greater than zero.


ORA-22132

ORA-22132given hexadecimal string does not correspond to a valid REF

Cause:The given hexadecimal string is invalid.

Action:Use the orlr2h() function for the value to obtain a valid hexadecimal string. Then retry the operation.


ORA-22140

ORA-22140given size num must be in the range of 0 to num

Cause:The given resize size is invalid.

Action:Ensure that the given size is in the required range.


ORA-22150

ORA-22150variable-length array has not been initialized

Cause:An attempt was made to operate on an un-initialized variable-length array.

Action:Use the kolaini() function to initialize the variable-length array before performing an operation on it.


ORA-22151

ORA-22151cannot resize non-zero variable-length array to zero elements

Cause:An attempt was made to resize a non-zero variable-length array to 0 elements.

Action:Do not perform this operation on a non-zero variable-length array.


ORA-22152

ORA-22152destination variable-length array is not initialized

Cause:An attempt was made to use a non-initialized variable-length array on the right-hand-side of an assignment (kolasg()) or as the destination array of an append.

Action:Use the kolaini() function to initialize the variable-length array, then retry the operation.


ORA-22153

ORA-22153source variable-length array is not initialized

Cause:An attempt was made to use a non-initialized variable-length array on the left-hand-side of an assignment (kolasg()) or the as the source array of an append (kolapp()).

Action:Use the kolaini() function to initialize the variable-length array, then retry the operation.


ORA-22161

ORA-22161type code name is not valid

Cause:An invalid type code was used.

Action:Consult the ORO.H file for valid type codes.


ORA-22162

ORA-22162element at index name has been previously deleted

Cause:An attempt was made to access a collection element which does not exist at the given index.

Action:Check for the existence of the element prior to calling the function. Then retry the function.


ORA-22163

ORA-22163left hand and right hand side collections are not of same type

Cause:An attempt was made to use left hand and right hand side collections that are not of the same type.

Action:Ensure that the same collection type is passed for both left hand and right hand side of the operation (for example, ASSIGNMENT).


ORA-22164

ORA-22164DELETE ELEMENT operation is not allowed for VARRAYs

Cause:An attempt was made to delete an element of a VARRAY.

Action:Do not perform the DELETE ELEMENT operation on collections of type VARRAY. Ensure that the collection is not of type VARRAY prior to calling this function. Then retry the function.


ORA-22165

ORA-22165given index name must be in the range of 0 to num

Cause:An attempt was made to use an index not in the required range.

Action:Change the index so that it is in the required range, then retry the operation.


ORA-22166

ORA-22166collection is empty

Cause:An attempt was made to use an empty collection.

Action:Test to see if the collection is empty prior to invoking this function.


ORA-22167

ORA-22167given trim size num must be less than or equal to num

Cause:An attempt was made to use a trim size which is greater than the current collection size.

Action:Assign a trim size less than or equal to the collection size, then retry this function.


ORA-22275

ORA-22275invalid LOB locator specified

Cause:There are several causes: (1) the LOB locator was never initialized; (2) the locator is for a BFILE and the routine expects a BLOB/CLOB/NCLOB locator; (3) the locator is for a BLOB/CLOB/NCLOB and the routine expects a BFILE locator; (4) trying to update the LOB in a trigger body -- LOBs in trigger bodies are read only.

Action:For (1), initialize the LOB locator by selecting into the locator variable or by setting the LOB locator to empty. For (2) and (3), pass the correct type of locator into the routine. For (4), remove the trigger body code that updates the LOB value.


ORA-22276

ORA-22276invalid locator for LOB buffering

Cause:There are several causes: (1) the locator was never enabled for buffering (2) it is not an updated locator but is being used for a write/flush operation.

Action:For (1) enable the locator for buffering; (2) ensure that only an updated locator is used for a LOB update operation


ORA-22277

ORA-22277cannot use two different locators to modify the same LOB

Cause:LOB buffering is enabled and an attempt was made to modify the same LOB using two different LOB locators.

Action:When using LOB buffering, modify the LOB through one LOB locator only.


ORA-22278

ORA-22278must update the LOB only through the LOB buffers

Cause:LOB buffering is enabled for this LOB and there are buffers for this LOB in the buffer pool. Thus, updating the LOB through means other than the LOB buffers is not allowed.

Action:Update the LOB through the LOB buffers using the locator that has LOB buffering enabled. If this operation is required, buffers associated with this LOB should either be flushed as necessary or buffering should be disabled. Once this is done, reissue the command.


ORA-22279

ORA-22279cannot perform operation with LOB buffering enabled

Cause:The operation attempted is not allowed when LOB buffering is enabled.

Action:If the operation is required, LOB buffering should not be used. In this case, flush buffers associated with the input LOB locator as necessary, disable buffering on the input LOB locator and reissue the command.


ORA-22280

ORA-22280no more buffers available for operation - current LOB usage num

Cause:There are two causes:

Case 1: All buffers in the buffer pool have been used up by previous operations

Case 2: Attempt to flush a LOB without any previous buffered update operations.

Action:For Case 1: Flush the LOB(s) through the locator that is being used to update the LOB. The current LOB usage indicates the number of buffers being held for the LOB relevant to the current operation.

For Case 2: First write to the LOB through a locator enabled for buffering before attempting to flush buffers.


ORA-22281

ORA-22281cannot perform operation with an updated locator

Cause:The input locator has buffering enabled and was used to update the LOB value through the LOB buffering subsystem. The modified buffer has not been flushed since the write that was performed by the input locator; thus the input locator is considered an updated locator. Updated locators cannot be the source of a copy operation. Only one locator per LOB can be used to modify the LOB value through the LOB buffering subsystem.

Action:Depending on whether the modifications made through the input locator to the LOB buffering subsystem should be written to the server, either flush the buffer to write the modifications, or, disable buffering on the locator to discard the modifications. Then, reissue the command.


ORA-22282

ORA-22282: non-contiguous append to a buffering enabled LOB not allowed

Cause:The buffered write operation has an input offset value more than one byte or character past the end of the LOB.

Action:Specify an input offset value which is exactly one character or byte greater than the length of the LOB that you are attempting to update through a buffered write operation.


ORA-22285

ORA-22285non-existent directory or file for name operation

Cause:Attempted to access a directory that does not exist, or attempted to access a file in a directory that does not exist.

Action:Ensure that a system object corresponding to the specified directory exists in the database dictionary, or make sure the name is correct.


ORA-22286

ORA-22286insufficient privileges on file or directory to perform name operation

Cause:The user does not have the necessary access privileges on the directory alias and/or the file for the operation.

Action:Ask the database/system administrator to grant the required privileges on the directory alias and/or the file.


ORA-22287

ORA-22287invalid or modified directory occurred during name operation

Cause:The directory alias used for the current operation is not valid if being accessed for the first time, or has been modified by the DBA since the last access.

Action:If you are accessing this directory for the first time, provide a valid directory name. If you have been already successful in opening a file under this directory before this error occurred, then close the file and retry the operation with a valid directory alias as modified by your DBA. Oracle recommends that directories should be modified only during quiescent periods.


ORA-22288

ORA-22288file operation name failed

Cause:The operation attempted on the file failed.

Action:Verify that the file exists and that the necessary privileges are set for the specified operation. If the error still persists, report the error to the DBA.


ORA-22289

ORA-22289cannot perform name operation on an unopened file

Cause:The file is not open for the required operation to be performed.

Action:Check that the current operation is preceded by a successful file open operation.


ORA-22290

ORA-22290operation would exceed the maximum number of opened files

Cause:The number of open files has reached the maximum limit.

Action:Close some of the opened files and retry the operation.


ORA-22303

ORA-22303TYPE name.name not found

Cause:An attempt was made to obtain information for a type that cannot be found.

Action:Make sure that the type has been committed successfully, and the schema information has been supplied correctly. Then retry the operation.


ORA-22305

ORA-22305input name of name is invalid

Cause:An attempt was made to use an invalid input name. The name does not exist in the type.

Action:Modify the program to have the caller of the routine pass a name that is valid for the function being called.


ORA-22306

ORA-22306input schema name name type name name already exists

Cause:An attempt was made to create a schema name, type name pair that matches a schema name, type name pair that already exists.

Action:Modify the program to have the caller of the routine pass a schema name, type name pair that does not already exist.


ORA-22307

ORA-22307type to alter is not a user-defined type

Cause:An attempt was made to use an input type which is not a user-defined type. User-defined types can only be altered.

Action:Modify the program to have the caller of the routine pass a user-defined type as input.


ORA-22309

ORA-22309input name name already exists in the type

Cause:An input name was used that is not a unique name in the type.

Action:Modify the program to have the caller of the routine pass a name that does not already exist in the type.


ORA-22311

ORA-22311type for attribute name does not exist

Cause:A type which does not exist was used for the attribute.

Action:No types were created/modified for this DDL transaction. Redo the DDL transaction and add the creation of the attribute's type in the DDL transaction.


ORA-22313

ORA-22313cannot use two versions of the same type name

Cause:The version of this type conflicts with the version of this type used by another library that was linked in with the application. An application may only use one version of a type.

Action:Check that the libraries being linked with this application use the same versions of the type.


ORA-22314

ORA-22314method information mismatch in ALTER TYPE

Cause:The number of methods or the method signature does not match that of the original type declaration. This is not supported.

Action:Make sure the method signatures stay identical for the previously declared method. Do not drop existing methods.


ORA-22315

ORA-22315the input type name does not contain a map or order function

Cause:The input type cannot be returned because it does not contain a map or order function.

Action:Add a map or order function to the type and retry the operation.


ORA-22316

ORA-22316input type is not a named primitive type

Cause:An attempt was made to obtain NPT-specific information on a non-named primitive type.

Action:Use a named primitive type for the function then retry the operation.


ORA-22317

ORA-22317typecode name is not legal as a number type

Cause:An attempt was made to use a number typecode that is not valid.

Action:Use only these number typecodes OROTCSML, OROTCINT, OROTCSHO,OROTCUSH, OROTCLON, OROTCULO, OROTCREA, OROTCDOU, OROTCFLO, OROTCNUM, or OROTCDEC.


ORA-22318

ORA-22318input type is not an array type

Cause:An attempt was made to obtain the number of elements for a non-array type.

Action:Pass in only a named collection type which is an array.


ORA-22319

ORA-22319type attribute information altered in ALTER TYPE

Cause:The type attribute information that was entered does not match that of the original type declaration when altering type.

Action:You cannot alter any type information other than to add new methods when altering a type.


ORA-22321

ORA-22321method does not return any results

Cause:The ortgrbp() function was called on a method that does not return any results.

Action:Check that you are passing in the correct method descriptor, or that your method creation was done correctly.


ORA-22600

ORA-22600encountered 8.0.2 (Beta) VARRAY data that cannot be processed

Cause:Production Oracle8 (8.0.3 and beyond) encountered some VARRAY data which was created and stored by Oracle8 8.0.2 (Beta 2). Production Oracle8 cannot understand or process such VARRAY data.

Action:Delete the VARRAY data from the table by dropping the table, deleting the rows, or nulling out the VARRAY columns, and then re-insert the VARRAY data. There is no provided script or tool to help automate this conversion.


ORA-22800

ORA-22800invalid user-defined type

Cause:An attempt was made to use an incomplete type as a constructor.

Action:Complete the type definition before using it in a query.


ORA-22801

ORA-22801invalid object row variable

Cause:The specified object row variable is not available in the scope of name resolution.

Action:Verify the specified row object variable is correct, or use a valid row object variable visible in scope.


ORA-22803

ORA-22803object type contains zero attributes

Cause:An attempt was made to create or specify a column or constructor of an object type that has no attributes. Only object types that have at least one attribute are allowed in this context.

Action:Specify a valid object type and retry the operation.


ORA-22804

ORA-22804remote operations not permitted on object tables or user-defined type columns

Cause:An attempt was made to perform queries or DML operations on remote object tables or on remote table columns whose type is one of object, REF, nested table or VARRAY.

Action:Remove the reference to remote tables in the statement.


ORA-22805

ORA-22805cannot insert NULL object into object tables or nested tables

Cause:An attempt was made to insert a NULL object into an object table or a Nested Table.

Action:Ensure that a non-NULL object is inserted into the table or insert an object with attributes whose values are NULL.


ORA-22806

ORA-22806not an object or REF

Cause:An attempt was made to extract an attribute from an item that is neither an object nor a REF.

Action:Use an object type or REF type item and retry the operation.


ORA-22807

ORA-22807cannot resolve to a scalar or a collection type

Cause:Invalid use of a non-scalar (for example, object type) item.

Action:Change the item's data type and retry the operation.


ORA-22808

ORA-22808REF dereferencing not allowed

Cause:An attempt was made to access a type's attributes by dereferencing a REF item.

Action:Make the item an object type instead of a REF to an object type.


ORA-22809

ORA-22809nonexistent attribute

Cause:An attempt was made to access a non-existent attribute of an object type.

Action:Check the attribute reference to see if it is valid. Then retry the operation.


ORA-22810

ORA-22810cannot modify object attributes with REF dereferencing

Cause:An attempt was made to modify attributes of an object by dereferencing a REF column in an UPDATE statement.

Action:Update the table containing the object that the REF points to, or change the REF column to an object type column.


ORA-22813

ORA-22813operand value exceeds system limits

Cause:Object or Collection value was too large. The size of the value might have exceeded 30k in a SORT context, or the size may be too big for available memory.

Action:Choose another value and retry the operation.


ORA-22814

ORA-22814attribute or element value is larger than declared in type

Cause:Value provided for the object type attribute or collection element exceeded the size specified in the type declaration.

Action:Choose another value and retry the operation.


ORA-22816

ORA-22816unsupported feature with RETURNING clause

Cause:RETURNING clause is currently not supported for object type columns, LONG columns, remote tables and INSERT with subquery.

Action:Use separate SELECT statement to get the values.


ORA-22850

ORA-22850duplicate LOB storage option specified

Cause:A LOB store option (CHUNK, PCTVERSION, CACHE, NOCACHE, TABLESPACE, STORAGE, INDEX) was specified more than once.

Action:Specify all LOB store options only once.


ORA-22851

ORA-22851invalid CHUNK LOB storage option value

Cause:The specified CHUNK LOB storage option value must be an integer.

Action:Choose an appropriate integer value and retry the operation.


ORA-22852

ORA-22852invalid PCTVERSION LOB storage option value

Cause:The specified PCTVERSION LOB store option value must be an integer.

Action:Choose an appropriate integer value and retry the operation.


ORA-22853

ORA-22853invalid LOB storage option specification

Cause:A LOB storage option was not specified.

Action:Specify one of (CHUNK, PCTVERSION, CACHE, NOCACHE, TABLESPACE, STORAGE, INDEX) as part of the LOB storage clause.


ORA-22854

ORA-22854invalid option for LOB storage index

Cause:A valid LOB store index option was not specified.

Action:Specify one of (INITTRANS, MAXTRANS, TABLESPACE, STORAGE) as part of the LOB storage index.


ORA-22855

ORA-22855optional name for LOB storage segment incorrectly specified

Cause:The optional name for LOB storage segment was specified with multiple columns in the column list.

Action:Specify each column LOB storage only with optional name(s).


ORA-22856

ORA-22856cannot add columns to object tables

Cause:An attempt was made to add columns to an object table. Object tables cannot be altered to add columns since its definition is based on an object type.

Action:Create a new type with additional attributes, and use the new type to create a object table. The new object table will have the desired columns.


ORA-22857

ORA-22857cannot modify columns of object tables

Cause:An attempt was made to alter the object table by modifying existing columns. An object table cannot be altered to modify existing columns since it is based

on an object type. The table definition must be in sync with the corresponding type.

Action:Create a new type with additional attributes, and use the new type to create an object table. The new object table will have the desired columns.


ORA-22858

ORA-22858invalid alteration of datatype

Cause:An attempt was made to modify the column type to object, REF, nested table, VARRAY or LOB type.

Action:Create a new column of the desired type and copy the current column data to the new type using the appropriate type constructor.


ORA-22859

ORA-22859invalid modification of columns

Cause:An attempt was made to modify an object, REF, VARRAY, nested table, or LOB column type.

Action:Create a new column of the desired type and copy the current column data to the new type using the appropriate type constructor.


ORA-22860

ORA-22860object type expected

Cause:An attempt was made to create an object table using a non-object type, or to create a column that is a REF to a non-object type.

Action:Use a valid object type in the table or column definition.


ORA-22861

ORA-22861invalid user-defined type

Cause:An attempt was made to create a column or object table of a non-existent type

Action:Specify a valid type in table or column definition.


ORA-22862

ORA-22862specified object identifier doesn't match existing object identifier

Cause:An attempt was made to specify an object identifier for the type that does not match the existing identifier of the incomplete type of the same name.

Action:Specify the correct object identifier or leave it out of the statement.


ORA-22863

ORA-22863synonym for datatype name.name not allowed

Cause:An attempt was made to use a synonym specification for a datatype.

Action:Do not use the synonym specification for the data type.


ORA-22864

ORA-22864cannot ALTER or DROP lob indexes

Cause:An attempt was made to ALTER or DROP a LOB index.

Action:Do not operate directly on the system-defined lob index. Perform operations on the corresponding LOB column.


ORA-22865

ORA-22865more than one column specified

Cause:An attempt was made to specify multiple columns where only one is allowed.

Action:Specify a single column and retry the operation.


ORA-22866

ORA-22866default character set is of varying width

Cause:A character LOB was defined but the default character set is not fixed width.

Action:Ensure that the character set is of fixed width before defining character LOBs.


ORA-22868

ORA-22868table with LOBs contains segments in different tablespace

Cause:An attempt was made to drop a tablespace which contains the segment(s) for the LOB columns of a table but does not contain the table segment.

Action:Find table(s) with LOB columns which have non-table segments in this tablespace. Drop these tables and reissue drop tablespace.


ORA-22869

ORA-22869depth of type dependency hierarchy exceeds maximum limit

Cause:The type dependency hierarchy was structured to have depth greater than 1024.

Action:Re-structure the type dependency hierarchy to a shorter depth.


ORA-22870

ORA-22870ALTER TYPE with REPLACE option a non-object type

Cause:An attempt was made to perform ALTER TYPE with REPLACE option a non-object type.

Action:First drop the non-object type, then re-create it as an object type.


ORA-22880

ORA-22880invalid REF

Cause:An invalid REF was accessed.

Action:Modify the REF and retry the operation.


ORA-22881

ORA-22881dangling REF

Cause:The object corresponding to the REF that was accessed does not exist.

Action:Ensure that the REF value is pointing to an existing object.


ORA-22882

ORA-22882object creation failed

Cause:The object cannot be inserted in the database.

Action:Check to see if the object table exists and that the object size is not too big. Then retry the operation.


ORA-22883

ORA-22883object deletion failed

Cause:The object could not be deleted from the database.

Action:Check to see if the table exists. Then retry the operation.


ORA-22884

ORA-22884object modification failed

Cause:The object could not be modified in the database.

Action:Check to see if the object table exists and the object size is not too big. Then retry the operation.


ORA-22885

ORA-22885: cannot get REF to a non-persistent object

Cause:An attempt was made to get a REF for something other than an object in an object table. REFs can only be taken for objects in object tables.

Action:Rewrite the query to obtain REF values from object tables.


ORA-22886

ORA-22886scoped table name in schema name is not an object table

Cause:The scoped table specified for a REF column is not an object table.

Action:Ensure that the scope table is an object table. Then retry the operation.


ORA-22887

ORA-22887type of REF column is not the same as that of its scoped table

Cause:The type specified for the REF column and the type specified for the scoped table are different.

Action:Ensure that the types of a REF column and its scoped table are the same.


ORA-22888

ORA-22888duplicate SCOPE clauses for a REF column

Cause:Multiple SCOPE clauses were specified for a single REF column.

Action:Remove the duplicate scope clauses and retry the operation.


ORA-22889

ORA-22889: REF value does not point to scoped table

Cause:An attempt was made to insert a REF value that does not point to the scoped table.

Action:Ensure that the REF values point to the scoped table.


ORA-22890

ORA-22890cannot specify name for REF column constraint

Cause:An attempt was made to specify a constraint name for a constraint on a REF column.

Action:Remove the constraint name and retry the operation.


ORA-22891

ORA-22891cannot have multiple columns in REF constraint

Cause:An attempt was made to specify multiple columns in a single REF constraint.

Action:Specify separate constraints for each column and retry the operation.


ORA-22892

ORA-22892scoped table name does not exist in schema name

Cause:The scope table specified for a REF column does not exist.

Action:Ensure that the scope table exists and retry the operation.


ORA-22893

ORA-22893constraint can be specified only for REF columns

Cause:The constraint specified does not apply to non-REF columns.

Action:Remove the constraint.


ORA-22894

ORA-22894cannot add constraint on existing REF columns of non-empty tables

Cause:An attempt was made to add a constraint to existing REF columns of a table which contains one or more rows.

Action:Remove the constraint specification or add the constraint after emptying the table.


ORA-22900

ORA-22900select item of subquery within THE operator is not a collection

Cause:The subquery within THE operator must select a collection item.

Action:Change the subquery to select a collection item, then retry the operation.


ORA-22901

ORA-22901cannot compare nested table or VARRAY or LOB attributes of an object type

Cause:An attempt was made to compare nested table, VARRAY, or LOB attributes of an object type in the absence of a MAP or ORDER method.

Action:Define a MAP or ORDER method for the type of the object type then retry the operation.


ORA-22902

ORA-22902CURSOR expression not allowed

Cause:CURSOR on a subquery is allowed only in the top-level SELECT list of a query.

Action:Remove the CURSOR expression and retry the operation.


ORA-22903

ORA-22903MULTISET expression not allowed

Cause:An attempt was made to use the MULTISET expression outside of a CAST to a nested table or VARRAY type.

Action:Put the MULTISET(subquery) expression inside a CAST to a nested table or VARRAY type.


ORA-22904

ORA-22904invalid reference to a nested table column

Cause:An invalid reference was made to a nested table column.

Action:Remove invalid reference to the nested table column and retry the operation.


ORA-22905

ORA-22905cannot access rows from a non nested table item

Cause:An attempt was made to access rows of an item whose type is not known at parse time or that is not of a nested table type.

Action:Use the CAST operator to cast the item to a nested table type.


ORA-22906

ORA-22906cannot perform DML on expression or on nested table view column

Cause:An attempt was made to perform a DML on a nested table view column where a nested table column of a base table is expected.

Action:Remove the DML statements on nested table view columns and retry the operation.


ORA-22907

ORA-22907invalid CAST to a type that is not a nested table or VARRAY

Cause:The CAST to a type was performed on something other than a nested table or VARRAY type.

Action:CAST only to a nested table or VARRAY type then retry the operation.


ORA-22908

ORA-22908reference to NULL table value

Cause:The evaluation of the THE subquery resulted in a NULL value implying a NULL table instance. The THE subquery must result in a single non-NULL table

instance.

Action:Ensure that the evaluation of the THE subquery results in a single non-null table instance. If the error occurs in the context of an insert statement where the THE subquery was the target of an insert, then ensure that an empty nested table instance is created by updating the nested table column of the parent table's row specifying an empty nested table constructor.


ORA-22909

ORA-22909exceeded maximum VARRAY limit

Cause:The total number of elements used in VARRAY construction exceeds the specified VARRAY limit.

Action:Don't use the more than the specified limit of elements for VARRAY construction.


ORA-22910

ORA-22910cannot specify schema name for nested tables

Cause:Table name was qualified with schema name in the nested table storage clause.

Action:Respecify the nested table storage clause without the schema name qualification. By default, the store table for the nested table is created in the same schema as the containing table.


ORA-22911

ORA-22911duplicate storage specification for the nested table item

Cause:The storage clause is specified more than once for the nested table column.

Action:Remove the duplicate storage specification.


ORA-22912

ORA-22912specified column or attribute is not a nested table type

Cause:The storage clause is specified for a column or attribute that is not a nested table column or attribute.

Action:Specify a valid nested table column or attribute.


ORA-22913

ORA-22913must specify table name for nested table column or attribute

Cause:The storage clause is not specified for a column or attribute that is a nested table column or attribute.

Action:Specify a table name using the Nested Table storage clause.


ORA-22914

ORA-22914DROP of nested tables not supported

Cause:Attempt was made to DROP a nested table.

Action:Nested tables cannot be explicitly dropped. Nested tables can only be dropped by dropping their containing parent table.


ORA-22915

ORA-22915cannot ALTER nested tables to ADD/MODIFY columns

Cause:Attempt was made to ADD or MODIFY columns of a nested table.

Action:Columns cannot be added or modified for a nested table. You must ALTER the parent table's nested table column to cause any such change.


ORA-22920

ORA-22920row containing the LOB data to update is not locked

Cause:The row containing the LOB was not locked before the lob was updated.

Action:Lock the row containing the LOB before updating the LOB data.


ORA-22921

ORA-22921length of input buffer is smaller than amount requested

Cause:The buffer length was not big enough to hold the amount of data requested.

Action:Verify that the number of bytes/characters specified in the input amount parameter is not bigger than the number of bytes specified in the input buffer length parameter. Allocate more space for the input buffer if necessary.


ORA-22922

ORA-22922LOB does not exist

Cause:The lob associated with the input locator does not exist. The information in the locator does not refer to an existing LOB.

Action:Repopulate the locator by issuing a SELECT statement and retry the operation.


ORA-22923

ORA-22923amount of data specified in streaming lob write is 0

Cause:An attempt was made to write LOB data by the streaming mechanism (that is, unlimited write) but the input amount of data to stream was specified as 0. This means that an attempt is being made to write 0 bytes to the LOB data.

Action:Write more than 0 bytes to the LOB data.


ORA-22924

ORA-22924snapshot too old

Cause:The version of the LOB data needed for the consistent read was already overwritten by another writer.

Action:Use a larger version pool then retry the operation.


ORA-22925

ORA-22925operation would exceed maximum size allowed for a LOB

Cause:An attempt was made to write too much data to the LOB. LOB size is limited to 4 gigabytes.

Action:Either start writing at a smaller LOB offset or write less data to the LOB.


ORA-22926

ORA-22926input trim length is greater than current LOB length

Cause:The input trim length to which the LOB data will be trimmed was specified to be greater than the current length of the LOB data.

Action:Might not need to trim the LOB data because it is already smaller than the trim length specified. Or, if trimming the LOB data really is required, use a smaller trim length.


ORA-22927

ORA-22927invalid input LOB locator

Cause:An invalid input LOB locator was used; it was never initialized.

Action:Initialize the input LOB locator and pass the initialized LOB locator to the function.


ORA-22928

ORA-22928invalid privilege on directories

Cause:An attempt was made to grant or revoke an invalid privilege on a directory.

Action:Only CREATE, DELETE, READ and WRITE privileges can be granted or revoked on directories. Do not grant or revoke other privileges.


ORA-22929

ORA-22929invalid or missing directory name

Cause:The required directory name is invalid or missing.

Action:Specify a valid name.


ORA-22930

ORA-22930directory does not exist

Cause:Attempt to access a directory that does not exist.

Action:Make sure the name is correct.


ORA-22950

ORA-22950cannot order objects with without map or order method

Cause:Object types must have map or order methods defined for all comparisons other than equality and inequality comparisons.

Action:Define a map or order method for the object type.


ORA-22951

ORA-22951NULL returned by ORDER method

Cause:Order method used to compare two object values returned NULL.

Action:Redefine the order method to not return a NULL.


ORA-22970

ORA-22970object view is required here

Cause:Either the expression that was entered is not a view name or the name specified does not correspond to an object view.

Action:Replace the expression with the name of an object view and retry the operation.


ORA-22971

ORA-22971invalid datatype for primary key-based OID

Cause:When creating a typed view, the datatype of an expression in the WITH OID clause was not allowed for primary key-based OID.

Action:Replace the expression with one of appropriate scalar datatype and retry the operation.


ORA-22972

ORA-22972NULL value not allowed in primary key-based OID

Cause:A value constituting the primary key-based OID evaluated to NULL.

Action:Ensure the expressions in MAKE_REF system function or WITH OID clause of CREATE VIEW do not evaluate to NULL.


ORA-22973

ORA-22973size of primary key-based OID exceeds maximum column size

Cause:The size of the primary key-based OID of a typed view was too large.

Action:Specify fewer or smaller primary key columns in the WITH OID clause when creating the typed view.


ORA-22974

ORA-22974WITH OID clause required but not specified

Cause:WITH OID clause was not specified when creating a typed view.

Action:Specify the WITH OID clause, or create an untyped view instead, or create a typed view on a single typed table or view.


ORA-22975

ORA-22975cannot create a primary key-based REF to this object view

Cause:The object view specified in the MAKE_REF function did not have a primary key-based OID. A primary key-based REF cannot be created for such a view.

Action:Specify an object view that has a primary key-based OID in the MAKE_REF function.


ORA-22976

ORA-22976incorrect number of arguments to MAKE_REF

Cause:Number of arguments for MAKE_REF was different from the number of primary key attributes of the object view.

Action:Specify all the necessary arguments for MAKE_REF.


ORA-22977

ORA-22977missing or invalid attribute

Cause:Either the attribute name is missing in the WITH OBJECT OID clause or it is invalid.

Action:Specify a valid attribute of the object type of the object view.


ORA-22978

ORA-22978only simple attribute name is allowed in the WITH OBJECT OID clause

Cause:Attempted to specify a Nested attribute in the WITH OBJECT OID clause.

Action:Specify a top-level attribute of the object type of the object view.


ORA-22979

ORA-22979cannot INSERT a REF from an object view into a table

Cause:Attempt to insert a REF selected from an object view into the REF column of a table. Currently, such a REF cannot be stored in the database.

Action:Make sure the REF to be inserted into a REF column is selected from a table.


ORA-22990

ORA-22990LOB locators cannot span transactions

Cause:A LOB locator selected in one transaction cannot be used in a different transaction.

Action:Re-select the LOB locator and retry the operation.


ORA-22991

ORA-22991insufficient space allocated for argument name

Cause:The data to be returned in the argument is greater than the amount of space allocated for the argument.

Action:Allocate more space for the argument.


ORA-22992

ORA-22992cannot use LOB locators selected from remote tables

Cause:A remote LOB column cannot be referenced.

Action:Remove references to LOBs in remote tables.


ORA-22993

ORA-22993specified input amount is greater than actual source amount

Cause:Case 1: For LOB write, the amount of data received is different from the amount that was indicated would be sent.

Case 2: For LOB copy and loadfromfile, the end of the source LOB/FILE value was reached before the specified input amount was copied/loaded.

Action:For Case 1: This will happen when using OCI's piecewise mechanism with polling or with a callback function. Modify the code either to send the amount specified or to pass 0 as the input amount so that any amount of data can be sent.

For Case 2: This will happen if the specified input amount is too large for the source LOB/FILE given the starting source offset. Either decrease the starting source offset, or decrease the amount to copy/load.


ORA-23300

ORA-23300application_specific_message

Cause:The stored procedure RAISE_SYSTEM_ERROR was called to generate this message.

Action:Correct the problem described in the message or contact the application programmer or database administrator for more information.


ORA-23301

ORA-23301mixed use of deferred RPC destination modes

Cause:Replication catalog determined deferred remote procedure call destinations were mixed with destination determined by other mechanisms in the same transaction.

Action:Do not mix destination types in the same transaction.


ORA-23302

ORA-23302application raised communication failure during deferred RPC

Cause:An application declared a communication failure during a deferred remote procedure call.

Action:Retry the application when communication is restored.


ORA-23303

ORA-23303application raised generic exception during deferred RPC

Cause:An application declared a generic failure during a deferred remote procedure call.

Action:Dependent on application.


ORA-23304

ORA-23304malformed deferred RPC at arg name of name in call name, in tid name

Cause:A deferred remote procedure call was issued without the correct number of arguments as determined by the count parameter DBMS_DEFER.CALL.

Action:Ensure the number of arguments matches the count.


ORA-23305

ORA-23305internal deferred RPC error: str

Cause:An internal error occurred in the deferred remote procedure call.

Action:Contact customer support.


ORA-23306

ORA-23306schema "name" does not exist

Cause:The schema name was null or misspelled, or the schema does not exist locally.

Action:Specify the schema correctly, or create it with CREATE USER.


ORA-23307

ORA-23307replicated schema "name" already exists

Cause:The given database already replicates the given schema.

Action:Choose a different schema or a different database.


ORA-23308

ORA-23308object "name" does not exist or is invalid

Cause:The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object, or the object does not exist as a replicated object with the appropriate status.

Action:Ensure the object is valid in the database, is visible to the user, and, if appropriate, is a valid object in ALL_REPOBJECT.


ORA-23309

ORA-23309object "name" of type name exists

Cause:An object in the same namespace exists, perhaps with a different type or shape.

Action:Drop the offending object or reinvoke the request using TRUE for a boolean parameter such as RETRY or USE_EXISTING_OBJECT.


ORA-23310

ORA-23310replicated schema "name" is not quiesced

Cause:The requested operation requires the replicated schema to be suspended.

Action:Invoke SUSPEND_MASTER_ACTIVITY at the repschema's masterdef, wait until the status has changed to quiesced, and then retry the original request.


ORA-23311

ORA-23311replicated schema "name" is quiesced

Cause:SUSPEND_MASTER_ACTIVITY has been called before the replicated schema has resumed normal operation.

Action:If a RESUME_MASTER_ACTIVITY request is pending, wait until it completes, and then re-invoke SUSPEND_MASTER_ACTIVITY.


ORA-23312

ORA-23312not the masterdef according to name

Cause:The schema name is null, the schema name is misspelled, the invocation or given database is not the masterdef, or one of the masters does not believe the invocation database is the masterdef.

Action:If the given schema name and masterdef were both correct, connect to the masterdef and retry the request, or relocate the masterdef at the errant databases using RELOCATE_masterdef.


ORA-23313

ORA-23313schema "name" is not mastered at name

Cause:The schema name is null, the schema name is misspelled, the invocation database is not a master, or the invocation database does not believe the given database is a master.

Action:If the given schema name was correct, connect to a current master and retry the request, make the invocation database a master with ADD_MASTER_DATABASE, or use SWITCH_SNAPSHOT_MASTER if the invocation database is a snapshot site.


ORA-23314

ORA-23314database is not a snapshot site for name

Cause:The invocation database is not a snapshot database for the given replicated schema.

Action:Connect to the desired snapshot database and retry the request, or make the invocation database a snapshot site with CREATE_SNAPSHOT_REPSCHEMA.


ORA-23315

ORA-23315repcatlog version or request name is not supported by version name

Cause:Either incompatible repcat versions are used, or a REPCATLOG record has been corrupted.

Action:Convert the master to a compatible version of repcat or retry the request.


ORA-23316

ORA-23316the masterdef is name

Cause:One of the masters to be removed is the masterdef.

Action:Relocate the masterdef to a master that will not be removed, and then reinvoke the REMOVE_MASTER_DATABASES request at the new masterdef.


ORA-23317

ORA-23317a communication failure has occurred

Cause:The remote database is inaccessible.

Action:Ensure the remote database is running, the communications network is functioning, and the appropriate database links are present.


ORA-23318

ORA-23318a DDL failure has occurred

Cause:User-supplied or system-generated DDL did not execute successfully.

Action:Examine DDL, database state, REPCATLOG, and ALL_ERRORS to determine why the failure occurred.


ORA-23319

ORA-23319parameter value name is not appropriate

Cause:The given value of a parameter is either null, misspelled, or not supported.

Action:Refer to the documentation and use parameter values that are appropriate for the given situation.


ORA-23320

ORA-23320the request failed because of values name and name

Cause:A missing DDL record for a REPCATLOG record, or inconsistency in REPCAT views.

Action:Retry the request, or make the views consistent.


ORA-23323

ORA-23323parameter length exceeds deferred remote procedure call limits

Cause:A deferred remote procedure call parameter was longer than the deferred remote procedure call limit of 2000 bytes for CHAR/VARCHAR2 parameters and 255 bytes for raw parameters.

Action:Use smaller parameters.


ORA-23324

ORA-23324error num, while creating DEFERROR entry at name with error num

Cause:The given error was encountered while attempting to create a DEFEROR entry for the given error code and the given database.

Action:Correct the cause of the given error.


ORA-23325

ORA-23325parameter type is not type

Cause:A function in DBMS_DEFER_SYS_QUERY was called to retrieve a deferred remote procedure call parameter from the deferred remote procedure call queue, but the type of the parameter does not match the return type ofthe function.

Action:Use the function corresponding to the parameter type.


ORA-23326

ORA-23326the system is being quiesced

Cause:A deferred remote procedure call operation was attempted while the database was quiesced.

Action:Resume database activity with the DBMS_REPCAT.RESUME_MASTER_ACTIVITY call.


ORA-23327

ORA-23327imported deferred remote procedure call data does not match id of importing db

Cause:Deferred remote procedure call queues were imported from a database with a different global name or operating system than the importing database.

Action:Deferred remote procedure call data should only be imported into a database with the same global name and hardware and operating system.


ORA-23328

ORA-23328snapshot name name.name must be same as replicated master table

Cause:When creating a snapshot through repcat, the snapshot name did not match a replicated table name at the master.

Action:Change the snapshot DDL to use the same name as the replicated table name at the master.


ORA-23329

ORA-23329successful user-provided DDL but no snapshot name.name.

Cause:The DDL provided by the user to create a snapshot was executed without error, but snapshot does not exist.

Action:Manually back-out the DDL, and re-register with matching ddl and snapshot.

For more information about naming a snapshot base table, see the index entries on "snapshots, naming" and on "snapshots, base table" in Oracle8 Server Distributed Systems.


ORA-23330

ORA-23330column group name already exists

Cause:The column group was already registered in the replicated schema.

Action:Use a column group name not yet registered in the replicated schema.


ORA-23331

ORA-23331column group name does not exist

Cause:The given column group is either null, misspelled or not registered.

Action:Use a registered column group.


ORA-23332

ORA-23332group name is in use; cannot drop

Cause:The given column group or priority group is being used to resolve conflicts.

Action:Call DBMS_REPCAT procedures DROP_UPDATE_RESOLUTION, DROP_DELETE_RESOLUTION, DROP_UNIQUE_RESOLUTION so that the column group or priority group is no longer in use before dropping.


ORA-23333

ORA-23333column name is already part of a column group

Cause:Attempted to add a column to a column group when the column was already a member of a column group.

Action:Drop the column from its existing column group before trying to add itto another.


ORA-23334

ORA-23334column name does nor exist in table or column group

Cause:The given column is either null, misspelled or is not part of the given table or column group.

Action:Use a column that is a member of the table or column group.


ORA-23335

ORA-23335priority group name already exists

Cause:The priority group was already registered in the replicated schema.

Action:Use a column group name not yet registered in the replicated schema.


ORA-23336

ORA-23336priority group name does not exist

Cause:The priority group was already registered in the replicated schema.

Action:Use a priority group name not yet registered in the replicated schema.


ORA-23337

ORA-23337priority or value not in priority group name

Cause:The specified value or priority has not been registered as part of the priority group.

Action:Either specify a different value or priority that is already part of the priority group, or add the value to the priority group.


ORA-23338

ORA-23338priority or value already in priority group name

Cause:The specified value or priority has already been registered as part of the priority group.

Action:Either specify a different value or priority that is not already part of the priority group, or drop the value from the priority group.


ORA-23339

ORA-23339duplicate conflict resolution information

Cause:The specified combination of column group, sequence, conflict type and/or parameter table name, parameter column name, and parameter sequence number has already been registered.

Action:Verify that additional conflict resolution information needs to be added and provide a new sequence number. If modifying existing information, the existing information must be dropped first.


ORA-23340

ORA-23340incorrect resolution method name

Cause:User function is specified when conflict resolution method was not "USER FUNCTION" or specified resolution method is not one of the predefined methods.

Action:If user function is specified when conflict resolution method was not "USER FUNCTION", either reregister function with method as "USER FUNCTION" or specify a NULL user function. Otherwise, specify one of the documented supported conflict resolution methods.


ORA-23341

ORA-23341user function required

Cause:A NULL user function was specified for the "USER FUNCTION" method.

Action:Provide user function name, e.g., "schema"."package"."function", that conforms to the documented user function specifications or specify one of the documented supported conflict resolution methods.


ORA-23342

ORA-23342invalid parameter column name

Cause:The parameter column name is null or misspelled, the invocation databaseis not a master, or is of the wrong type for the specified conflict resolution method.

Action:Specify a parameter column from the specified column group that has a correct type for the conflict resolution method.


ORA-23343

ORA-23343no match for specified conflict resolution information

Cause:The specified combination of column group, sequence, conflict type has not been registered, for example, for adding a comment.

Action:Specify a combination of column group, sequence, conflict type that has been registered.


ORA-23344

ORA-23344constraint name.name does not exist

Cause:A null, misspelled or nonexistent constraint was specified when registering a uniqueness conflict.

Action:Register a named constraint for the specified table.


ORA-23345

ORA-23345table name.name not registered to collect statistics

Cause:A procedure that deals with conflict resolution statistics-gathering was called for a table that was not registered to collect statistics.

Action:Call DBMS_REPCAT.REGISTER_STATISTICS to register the table.


ORA-23346

ORA-23346primary key is undefined for table name

Cause:Trying to generate replication support for a table without a primary key as defined by a constraint or DBMS_REPCAT_COLUMNS.

Action:Add a primary key constraint to the table or define a primary key using DBMS_REPCAT_COLUMNS.


ORA-23347

ORA-23347datatype name for column name table name not supported

Cause:The table has a column whose datatype is not supported by repcat.

Action:Remove the column from the table, or alter the column to have one of the supported datatypes.


ORA-23348

ORA-23348cannot replicate procedure name; only IN parameters supported

Cause:Trying to generate replication support for a package that has a procedure with OUT or IN OUT parameters.

Action:Remove the procedure from the package, or remove the OUT or IN OUT parameters from the procedure.


ORA-23349

ORA-23349cannot generate replication support for functions

Cause:Trying to generate replication support for a package that has a public function, or for a stand-alone function.

Action:Remove the public function from the package, or alter the function to be a procedure.


ORA-23350

ORA-23350maximum number of recursive calls exceeded

Cause:This usually occurs when trying to resolve conflicts in a table while concurrent updates to the same row create more conflicts.

Action:Re-execute the deferred transaction from DEFERROR using DBMS_DEFER_SYS.EXECUTE_ERROR.


ORA-23351

ORA-23351parameter datatype name for procedure name not supported

Cause:The procedure has a parameter whose datatype is not supported by repcat.

Action:Remove the parameter from the procedure, or alter the parameter to have one of the supported datatypes.


ORA-23352

ORA-23352duplicate destination for deferred transaction

Cause:A duplicate destination was specified for a deferred transaction either in a DBMS_DEFER.CALL call or an earlier DBMS_DEFER.TRANSACTION call or a DBMS_DEFER_SYS.ADD_DEFAULT_DEST call.

Action:Remove the duplicate entry.


ORA-23353

ORA-23353deferred RPC queue has entries for replicated schema name

Cause:The requested action cannot be performed until the queue is empty for the given replicated schema.

Action:Use DBMS_DEFER_SYS.EXECUTE or DBMS_DEFER_SYS.DELETE_TRAN to empty the queue.


ORA-23354

ORA-23354deferred RPC execution disabled for name

Cause:The execution of a deferred remote procedure call at the destination failed because its propagation was disabled.

Action:Enable deferred remote procedure call execution with the DBMS_DEFER_SYS.ENABLE call.


ORA-23355

ORA-23355object name.name does not exist or is invalid at master site

Cause:The given name was null or misspelled; the given type was wrong; the object does not exist as a valid database object at the master site; or the object does not exist as a replicated object with the appropriat e status.

Action:Ensure the object is valid in the master database and is visible to the user; and if appropriate, ensure the object is a valid object in all_repobject.

For more information about valid objects at the master site, see the index entry on "snapshot sites, objects allowed" in Oracle8 Server Distributed Systems.


ORA-23356

ORA-23356masterdef recognizes a master which does not recognize the masterdef

Cause:Possibly drop_master_repgroup was run at a master site but remove_master_databases was not run at master definition site for that master.

Action:Run remove_master_databases from master definition site to remove the appropriate master (see associated error messages).


ORA-23357

ORA-23357the propagator does not exist

Cause:The propagator does not exist.

Action:Register a new propagator.


ORA-23358

ORA-23358invalid remote user

Cause:The local user does not match the remote user connected via a database link.

Action:Drop and recreate the identified database link with the connect-to user identical to the owner of the database link.


ORA-23359

ORA-23359error on creating a DDL record for a repcatlog record

Cause:The userid in the repcatlog record does not match the userid of the connected user.

Action:Retry the operation with a different user.


ORA-23360

ORA-23360only one snapshot for master table name can be created

Cause:An attempt to create more than one snapshot on a given master table in the same rep group.

Action:Create these other snapshots in a different rep group at another site.

For more information about creating a snapshot, see the index entries on "snapshot sites, creating" and on "snapshot logs, master table, creating" in Oracle8 Server Distributed Systems.


ORA-23361

ORA-23361snapshot name does not exist at master site

Cause:The snapshot does not exist at the master site for offline instantiation of the snapshot.

Action:The correct procedure is to create the snapshot in a different schema at the master site, and then follow the instructions for offline instantiation of snapshots.

For more information about creating a snapshot, see the index entries on "snapshot sites, creating" and on "snapshot logs, master table, creating" in Oracle8 Server Distributed Systems.


ORA-23362

ORA-23362invalid user

Cause:The given user does not exist.

Action:Enter the name of a valid user and retry the operation.


ORA-23363

ORA-23363mismatch of snap base table name at master and snap site

Cause:The name of the base table of the snapshot at the master site is different from the base table at the snapshot site. This error may arise during offline instantiation of snapshots.

Action:Retry offline instantiation with a snapshot name less than 24 bytes.

For more information about naming a snapshot, see the index entry on "snapshots, base table" in Oracle8 Server Distributed Systems.


ORA-23364

ORA-23364replication option not installed

Cause:The replication option was not installed at this site. Updatable snapshots, deferred remote procedure calls, and other replication features were, therefore, unavailable.

Action:Install the replication option. The replication option is not part of the Oracle7 Server product and must be purchased separately. Contact an Oracle Sales representative if the replication option needs to be purchased.


ORA-23365

ORA-23365site name does not exist

Cause:The site specified in argument REFERENCE_SITE or argument COMPARISON_SITE in call to DIFFERENCES() routine or RECTIFY() routine did not name an existing site.

Action:Make sure that database sites specified really do exist, and re-run the routine.

For more information about the arguments to the DIFFERENCES() routine and the RECTIFY() routine, see the Oracle8 Server Distributed Systems.


ORA-23366

ORA-23366integer value num is less than 1

Cause:The value of argument MAX_MISSING to routine DIFFERENCES() cannot be less than 1. Value of argument COMMIT_ROWS to routines DIFFERENCES() and RECTIFY() cannot be less than 1.

Action:Choose an integer value for those arguments to be 1 or greater.

For more information about the arguments to the DIFFERENCES() routine and the RECTIFY() routine, see the Oracle8 Server Distributed Systems.


ORA-23367

ORA-23367table name is missing the primary key

Cause:The table specified in argument ONAME1 or ONAME2 in call to DIFFERENCES() routine did not contain either a primary key or a virtual primary key (defined through DBMS_REPCAT package under symmetric replication).

Action:Make sure the tables specified have a primary key defined.

For more information about the arguments to the DIFFERENCES() routine, see the Oracle8 Server Distributed Systems.


ORA-23368

ORA-23368name name cannot be null or the empty string

Cause:Argument SNAME1, SNAME2, ONAME1, ONAME2, MISSING_ROWS_SNAME, MISSING_ROWS_ONAME1, MISSING_ROWS_ONAME2 to DIFFERENCES() or RECTIFY() cannot be NULL or (EMPTY STRING).

Action:Change the argument to a non-null or a non-empty string.

For more information about the arguments to the DIFFERENCES() routine and the RECTIFY() routine, see the Oracle8 Server Distributed Systems.


ORA-23369

ORA-23369value of "name" argument cannot be null

Cause:Argument MAX_MISSING to DIFFERENCES() routine cannot be NULL.

Action:Legal values for MAX_MISSING are integers 1 or greater.

For more information about the arguments to the DIFFERENCES() routine, see the Oracle8 Server Distributed Systems.


ORA-23370

ORA-23370table name and table name are not shape equivalent name

Cause:The tables specified were not shape equivalent, which means intuitively that the number of columns, the names, their datatypes and lengths were not the same. Specifically, the problem was in the parentheses and was one of the following: the number of columns were not equal, datatypes of columns with same name in different tables were different, lengths of VARCHAR2 and CHAR columns were not equal, precision and scale of number datatypes were not equal.

Action:Make sure the two tables being compared have the same number of columns, same column names, and same datatypes.

For more information about using column groups, see the index entry on "column groups, using" in Oracle8 Server Distributed Systems.


ORA-23371

ORA-23371column name unknown in table name

Cause:Some column in ARRAY_COLUMNS argument (or COLUMN_LIST argument) to DIFFERENCES()routine did not correspond to a column in the specified table.

Action:Make sure that all the columns in either ARRAY_COLUMNS or COLUMN_LIST are present in the specified table.

For more information about the arguments to the DIFFERENCES() routine, see the Oracle8 Server Distributed Systems.


ORA-23372

ORA-23372type name in table name is unsupported

Cause:Certain types in the table comparison utility were not supported.

Action:Make sure that the types of columns in the tables to be compared are the ones supported by symmetric replication.

For more information about column groups, see the index entry on "column groups, understanding" in Oracle8 Server Distributed Systems.


ORA-23373

ORA-23373object group name does not exist

Cause:The group name was null or misspelled, or the group did not exist locally.

Action:Specify the group correctly, or create it with DBMS_REPCAT.CREATE_MASTER_REGROUP().

For more information about creating a replicated group, see the index entries on "replicated groups, creating" and on "DBMS_REPCAT.CREATE_MASTER_REGROUP" in Oracle8 Server Distributed Systems.


ORA-23374

ORA-23374object group name already exists

Cause:The given database already replicated the given object group.

Action:Choose a different group or a different database.


ORA-23375

ORA-23375feature is incompatible with database version at num

Cause:A feature not compatible with the specified database was used.

Action:Set or raise the value of the COMPATIBLE parameter in the INIT.ORA file to match the necessary compatibility level.

For more information about parameter files and their initialization parameters, see the index entry on "parameter files" in Oracle8 Server Concepts.


ORA-23376

ORA-23376node name is not compatible with replication version "name"

Cause:A feature that was not compatible with the remote database was used.

Action:Upgrade the remote database and retry the operation.

For more information about replication compatibility, see Oracle8 Server Distributed Systems.


ORA-23377

ORA-23377bad name name for missing_rows_oname1 argument

Cause:An attempt was made to use the name of the reference site table as the name of the MISSING_ROWS_ONAME1 argument.

Action:Provide a separately created table with a different name for MISSING_ROWS_ONAME1 argument. The separately created table will contain the differences between the tables being compared.

For more information about the MISSING_ROWS_ONAME1 argument, see Oracle8 Server Distributed Systems.


ORA-23378

ORA-23378connection qualifier name is not valid for object group name

Cause:The connection qualifier used in the database link for the specified object group does match the qualifier specified for the group in create_master_repgroup.

Action:Use or create a database link which contains the correct connection qualifier.

For more information about connection qualifiers, see Oracle8 Server Distributed Systems.


ORA-23379

ORA-23379connection qualifier name is too long

Cause:The maximum length of a database link, including the connection qualifier, is 128 bytes.

Action:Use a shorter connection qualifier, or shorten the name of the database link.

For more information about connection qualifiers, see Oracle8 Server Distributed Systems.


ORA-23380

ORA-23380propagation mode name is not valid

Cause:The specified propagation is misspelled, or is not supported.

Action:Refer to the manual on replicated data for valid propagation modes.

For more information about propagation, see the index entry "propagating changes" in Oracle8 Server Distributed Systems.


ORA-23381

ORA-23381generated object for base object name.name@name does not exist

Cause:The system generated object(s) for the specified base object do not exist at the specified site. The current operation requires the base object to have generated replication support.

Action:Ensure that the generated replication object(s) for the base object exist and are valid at the specified site. If the generated object(s) do not exist, then the procedure dbms_repcat.generate_replication_support() needs to be called from the master definition site for the base object.

For more information about generating replication support, see the index entry "generating, replication support" in Oracle8 Server Distributed Systems.


ORA-23382

ORA-23382snapshot REPGROUP name is not registered at site name

Cause:The snapshot REPGROUP is not currently registered at the master and so cannot be unregistered.

Action:No action required.


ORA-23383

ORA-23383registration for snapshot REPGROUP name failed at site name

Cause:Insertion into local REPSCHEMA table failed.

Action:No action required.


ORA-23384

ORA-23384replication parallel push name argument out of range

Cause:Specified numeric argument to DBMS_DEFER_SYS.PUSH is invalid.

Action:Fix the argument value and try again.


ORA-23385

ORA-23385replication parallel push name argument not valid

Cause:Specified string argument to DBMS_DEFER_SYS.PUSH is invalid.

Action:Fix the argument value and try again.


ORA-23386

ORA-23386replication parallel push cannot create slave processes

Cause:An error occurred while creating slave processes for parallel push.

Action:If the PARALLEL_MAX_SERVERS initialization parameter is zero, reconfigure the parameter to be greater than zero. Otherwise, contact your customer support representative.


ORA-23387

ORA-23387replication parallel push dequeue error

Cause:An attempt to dequeue a deferred transaction failed while trying to assign a new queue batch number.

Action:Contact your customer support representative.


ORA-23388

ORA-23388replication parallel push watermark error

Cause:An error occurred during parallel push while trying to update the high-water-mark information in system.def$_destination.

Action:Contact your customer support representative.


ORA-23389

ORA-23389obsolete procedure; drop objects and recreate using new master

Cause:DBMS_REPCAT.SWITCH_SNAPSHOT_MASTER is no longer supported.

Action:Drop the objects in the object group and recreate them using the new master.


ORA-23392

ORA-23392could not find snapshot to be associated with name.name

Cause:Could not find snapshot associated with a trigger or index that is being pulled from the master site.

Action:Ensure that snapshot, master, and master index or trigger is registered as replicated objects.


ORA-23393

ORA-23393the user is already the propagator

Cause:The given user is already the current propagator.

Action:No action required.


ORA-23394

ORA-23394duplicate propagator

Cause:More than one valid propagator exist.

Action:Unregister any duplicate propagator.


ORA-23395

ORA-23395object name.name of type name does not exist or is invalid

Cause:The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object, or the object does not exist as a replicated object with the appropriate status.

Action:Ensure the object is valid in the database, is visible to the user, and, if appropriate, is a valid object in ALL_REPOBJECT.


ORA-23396

ORA-23396database link name does not exist or has not been scheduled

Cause:The database link does not exist in the schema of the replication propagator or has not been scheduled.

Action:Ensure that the database link exists in the database, is accessible and is scheduled for execution.


ORA-23397

ORA-23397global name name does not match database link name name

Cause:The database link name at the local node does not match the global name of the database that the link accesses.

Action:Ensure that global names is set to true and the link name matches the global name.


ORA-23398

ORA-23398user name name at database link name does not match local user name name

Cause:The user name of the replication administration user at the local node and the user name at the node corresponding to the database link are not the same. Symmetric replication expects the two users to be the same.

Action:Ensure that the user ID of the replication administration user at the local node and the user ID at the node corresponding to the database link are the same.


ORA-23399

ORA-23399object name has not been completely generated

Cause:The object has not been generated at other master sites or is still being generated.

Action:Ensure that the object is generated by calling GENERATE_REPLICATION_SUPPORT and DO_DEFERRED_REPCAT_ADMIN for the object at the MASTERDEF site.


ORA-23400

ORA-23400invalid snapshot name "name"

Cause:A null, misspelled, or badly formed snapshot name was given to DBMS_SNAPSHOT.REFRESH.

Action:Provide a valid snapshot name to DBMS_SNAPSHOT.REFRESH.


ORA-23401

ORA-23401snapshot "name.name" does not exist

Cause:A snapshot name was given to DBMS_SNAPSHOT.REFRESH that is notin SYS.SNAP$ or its associated views.

Action:Provide a snapshot name that is in SYS.SNAP$, ALL_SNAPSHOTS, or USER_SNAPSHOTS.


ORA-23402

ORA-23402refresh was aborted because of conflicts caused by deferred transactions

Cause:There are outstanding conflicts logged in the DEFERROR tableat the snapshot's master.

Action:Resolve the conflicts in the master DEFERROR table and refresh again after the table is empty. Alternatively, refresh with REFRESH_AFTER_ERRORS set to TRUE, which will proceed with the refresh, even if there are conflicts in the master's DEFERROR table. Proceeding despite conflicts can result with an updatable snapshot's changes appearing to be temporarily lost, until a refresh succeeds after theconflicts are resolved.


ORA-23403

ORA-23403refresh group "name.name" already exists. Refresh group not a stored object?

Cause:Making a new refresh group when there is already a group ofthe same name in SYS.RGROUP$.

Action:Choose a different refresh group name.


ORA-23404

ORA-23404refresh group "name.name" does not exist

Cause:A refresh group name was given that is not in SYS.RGROUP$.

Action:Provide a refresh group name that is in SYS.RGROUP$ or DBS_RGROUP.


ORA-23405

ORA-23405refresh group number name does not exist

Cause:A refresh group number was given that is not in SYS.RGROUP$.

Action:Provide a refresh group number that is in SYS.RGROUP$ or DBS_RGROUP.


ORA-23406

ORA-23406insufficient privileges on user "name"

Cause:The caller is not the owner of the snapshot and does not haveALTER ANY SNAPSHOT privileges.

Action:Perform the operation as the owner of the snapshot or as auser with ALTER ANY SNAPSHOT privileges.


ORA-23407

ORA-23407object name name must be shaped like "SCHEMA.OBJECT" or "OBJECT"

Cause:The object name, for example, the rollback segment, the snapshot name, or the refresh group, was incorrectly specified.

Action:Retry the operation with the object name properly specified, like "SCHEMA.OBJECT" or "OBJECT".


ORA-23408

ORA-23408this replication operation is not supported in a mixed configuration

Cause:The operation is not supported if the object group is replicated at a pre-Oracle Version 8 node.

Action:Ensure that all nodes of the replicated object group are Oracle Version 8.


ORA-23409

ORA-23409could not find an unused refresh group number

Cause:1000 consecutive refresh group numbers, as defined by theRGROUPSEQ number, were already used by rows in SYS.RGROUP$.

Action:Alter the sequence number to be within a legal unused rangeand destroy unneeded refresh groups.


ORA-23410

ORA-23410snapshot "name.name" is already in a refresh group

Cause:A snapshot of the same name is already in a refresh group.

Action:Subtract the snapshot its the current refresh group and add itto its new refresh group, or combine the two refresh groups into a single refresh group.


ORA-23411

ORA-23411snapshot "name.name" is not in refresh group "name.name"

Cause:The specified snapshot is not in the specified refresh group.

Action:Try again with the proper snapshot and refresh group names.


ORA-23412

ORA-23412master table's primary key columns have changed

Cause:The master table's primary key constraint was modified after the primary key snapshot was created.

Action:Drop and recreate the primary key snapshot.


ORA-23413

ORA-23413table name.name does not have a snapshot log

Cause:The fast refresh cannot be performed because the master table did not contain a snapshot log.

Action:Use the CREATE SNAPSHOT LOG command to create a snapshot log on the master table.


ORA-23414

ORA-23414snapshot log for name.name does not record rowid values

Cause:A ROWID snapshot is being fast refreshed, but the snapshot log does not record ROWID information.

Action:Use the CREATE SNAPSHOT LOG...ADD ROWID command to begin recording ROWID information in the snapshot log.


ORA-23415

ORA-23415snapshot log for name.name does not record the primary key

Cause:A primary key snapshot is being fast refreshed, but the snapshot log does not record primary key information.

Action:Use the CREATE SNAPSHOT LOG...ADD PRIMARY KEY command to begin recording primary key information in the snapshot log.


ORA-23416

ORA-23416table name.name does not contain a primary key constraint

Cause:The master table did not constrain a primary key constraint or the primary key constraint was disabled.

Action:Create a primary key constraint on the master table or enable the existing constraint.


ORA-23417

ORA-23417unknown snapshot type: name

Cause:A fast refresh was performed on a snapshot of an unknown or unsupported type.

Action:Check ALL_SNAPSHOTS and ensure that the snapshot being refreshed is a valid snapshot.


ORA-23418

ORA-23418cannot unregister the propagator who is currently in use

Cause:The propagator is currently used in propagating replication RPCs.

Action:Try again later when there is no transaction active in propagating replication RPCs.


ORA-23419

ORA-23419regenerate replication support before resuming master activity

Cause:There are tables in the object group that require regeneration of replication support.

Action:Check the GENERATION_STATUS column in the ALL_REPOBJECTS view. Regenerate replication support for any table in the object group with a 'NEEDSGEN' status. Resume master activity.


ORA-23420

ORA-23420interval must evaluate to a time in the future

Cause:The parameter INTERVAL evaluates to a time earlier than SYSDATE.

Action:Choose an expression that evaluates to a time later than SYSDATE.


ORA-23421

ORA-23421job number num is not a job in the job queue

Cause:There is no job visible to the caller with the given job number.

Action:Choose the number of a job visible to the caller.


ORA-23422

ORA-23422Oracle Server could not generate an unused job number

Cause:Oracle Server could not generate a job number that was not used to identify another job.

Action:Retry the operation.


ORA-23423

ORA-23423job number num is not positive

Cause:The given job number is less than 1.

Action:Choose a positive integer.


ORA-23424

ORA-23424snapshot basename.extension at name not registered

Cause:The specified snapshot has not be successfully registered at this site.

Action:Register the snapshot manually at either the master site or the snapshot site.


ORA-23425

ORA-23425invalid snapshot identifier name

Cause:The argument provided to DBMS_SNAPSHOT.PURGE_SNAPSHOT_FROM_LOG is an invalid snapshot identifer or it does not identify an Oracle 8 fast refreshable snapshot or the snapshot has been already purged.

Action:If the snapshot is an Oracle 8 fast refreshable snapshot then provide PURGE_SNAPSHOT_FROM_LOG with its valid snapshot identifier.


ORA-23426

ORA-23426deferred RPC queue has entries for name

Cause:The requested action cannot be performed until the queue is empty for the given site/dblink

Action:Use DBMS_DEFER_SYS.PUSH, DBMS_DEFER_SYS.PURGE_QUEUE or DBMS_DEFER_SYS.DELETE_TRAN to empty the queue.


ORA-23427

ORA-23427deferred purge queue argument name out of range

Cause:Specified numeric argument to DBMS_DEFER_SYS.PURGE_QUEUE is invalid.

Action:Fix the argument value and try again.


ORA-23430

ORA-23430the replicated schema "name" does not exist

Cause:The caller has provided the name of a replicated schema that is not known at the master site as an argument to a routine in offline instantiation of a schema.

Action:Check that the replicated schema exists at the master site where the user is executing the procedure, and retry the call.


ORA-23431

ORA-23431site name is not the master definition site

Cause:The master site where the routine was executing is not the master definition site.

Action:Find out the master definition site for the replicated schema in question, and re-run the routine.


ORA-23432

ORA-23432wrong state: name

Cause:Routine is executing against a replicated schema whose state is in the wrong state.

Action:Make sure that the replicated schema is in the state given in the error message.


ORA-23433

ORA-23433master site name already exists

Cause:Trying to instantiate a replicated schema at a master site that is already a part of the schema.

Action:If you were trying to add this site, do nothing because it already exists; otherwise, pick the name of another site, and re-run the routine.


ORA-23434

ORA-23434executing against wrong master site name

Cause:Caller provides an argument indicating the site against which the routine should be executing; trying to execute the routine at a site that is different from that argument.

Action:Execute against the correct master site.


ORA-23435

ORA-23435malformed master site name name

Cause:Site name as argument to routine is not formed correctly.

Action:Please consult the Oracle manuals on how to construct site names.


ORA-23436

ORA-23436site name is not master site

Cause:The new site given as an argument to a routine is not a master site for the given replicated schema.

Action:Execute DBMS_OFFLINE_SCHEMA.BEGIN_INSTANTIATION() routine to add a new site to the replicated schema.


ORA-23437

ORA-23437master site name not known for replicated schema

Cause:The site name given as an argument to a routine is not already known to the replicated schema.

Action:Execute DBMS_OFFLINE_SCHEMA.BEGIN_INSTANTIATION() routine to add a new site to the replicated schema.


ORA-24000

ORA-24000invalid value name, name should be of the form [SCHEMA.]NAME

Cause:An invalid value was specified for the parameter.

Action:Specify a string of the form [SCHEMA.]NAME .


ORA-24001

ORA-24001cannot create QUEUE_TABLE, name already exists

Cause:The queue table already exists in the queueing system.

Action:Drop the table first using the DROP_QUEUE_TABLE() command or specify another table.


ORA-24002

ORA-24002QUEUE_TABLE name does not exist

Cause:QUEUE_TABLE does not exist.

Action:Query on the user view USER_QUEUE_TABLES to find out existing queue tables.


ORA-24003

ORA-24003queue table index name inconsistent with queue table name

Cause:The queue table index has not yet been successfully imported.

Action:Import the queue table index before attempting to use any queue in the queue table. If the import failed, correct the problem and try to import the queue table index again.


ORA-24004

ORA-24004invalid column name name in SORT_LIST, should be ENQ_TIME or PRIORITY

Cause:Invalid column name was specified in the SORT_LIST.

Action:The valid column names are ENQ_TIME and PRIORITY.


ORA-24006

ORA-24006cannot create QUEUE, name already exists

Cause:The queue requested to be created already exists.

Action:Specify another queue name. Query USER_QUEUES for all the exisiting queues in the users's schema.


ORA-24007

ORA-24007invalid value num, MAX_RETRIES should be non-negative integer

Cause:An invalid value was specified for MAX_RETRIES.

Action:Specify a non-negative integer.


ORA-24009

ORA-24009invalid value num, QUEUE_TYPE should be NORMAL_QUEUE or EXCEPTION_QUEUE

Cause:Invalid queue type parameter

Action:Valid values are NORMAL_QUEUE for normal queue and EXCEPTION_QUEUE for exception queue.


ORA-24010

ORA-24010QUEUE name does not exist

Cause:The specified queue does not exist.

Action:Specify a valid queue. Query USER_QUEUES for all the valid queues.


ORA-24011

ORA-24011cannot drop QUEUE, name should be stopped first

Cause:The queue has not been stopped, i.e., either ENQUEUE or DEQUEUE is still enabled.

Action:Stop the queue first using the STOP_QUEUE command and disable it from both enqueueing and dequeueing.


ORA-24012

ORA-24012cannot drop QUEUE_TABLE, some queues in name have not been dropped

Cause:A queue exists in the queue table which has not been dropped. All queues need to be dropped first.

Action:Drop all queues belonging to this queue table using the drop_queue() command. Be sure to stop the queues appropriately before dropping them. Alternately, use the FORCE option in DROP_QUEUETABLE.


ORA-24013

ORA-24013invalid value num, RETRY_DELAY should be non-negative

Cause:A negative value was specified for RETRY_DELAY.

Action:Specify a non-negative value for RETRY_DELAY.


ORA-24014

ORA-24014invalid value name, RETENTION_TIME should be FOREVER or non-negative

Cause:Queue retention was specified, but the retention time was specified to be less than zero.

Action:Specify the retention time to be non-negative or FOREVER. Alternately don't specify retention.


ORA-24015

ORA-24015cannot create QUEUE_TABLE, QUEUE_PAYLOAD_TYPE name.name does not exist

Cause:An invalid QUEUE_PAYLOAD_TYPE specified during CREATE_QUEUE_TABLE.

Action:The QUEUE_PAYLOAD_TYPE should be RAW or an object type that already exists in the database.


ORA-24016

ORA-24016cannot create QUEUE_TABLE, do not have execute priviliges on QUEUE_PAYLOAD_TYPE name.name

Cause:An invalid object type specified for QUEUE_PAYLOAD_TYPE during CREATE_QUEUE_TABLE.

Action:The user should have execute priviliges on the object type specified for the queue.


ORA-24017

ORA-24017cannot enable enqueue on QUEUE, name is an exception queue

Cause:An attempt was made to enable enqueueing to an exception queue.

Action:None.


ORA-24018

ORA-24018STOP_QUEUE on name failed, outstanding transactions found

Cause:There were outstanding transactions on the queue, and WAIT was set to false, so STOP_QUEUE was unsucessful in stopping the queue.

Action:Set WAIT to TRUE and try STOP_QUEUE again. It will hang until all outstanding transactions are completed.


ORA-24019

ORA-24019identifier for name too long, should not be greater than 24 characters

Cause:The queue name specified is too long.

Action:Specify an identifier which is no more than 24 bytes long. Try again with a shorter name.


ORA-24020

ORA-24020internal error in DBMS_AQ_IMPORT_INTERNAL, name

Cause:Internal Error occured in the package DBMS_AQ_IMPORT_INTERNAL.

Action:Internal error, call Oracle Support.


ORA-24021

ORA-24021queue table definition not imported for name.name

Cause:The queue definition is not updated because the queue table was not imported properly.

Action:Import the queue table again.


ORA-24022

ORA-24022the specified parameters has no effect on the queue

Cause:The parameter combination will not cause the queue to be started or stoped.

Action:None. This is just a warning.


ORA-24025

ORA-24025invalid value name, QUEUE_PAYLOAD_TYPE should be RAW or an object type

Cause:Parameter QUEUE_PAYLOAD_TYPE has invalid value.

Action:Specify a valid object type or RAW.


ORA-24031

ORA-24031invalid value, name should be non-NULL

Cause:Parameter is NULL.

Action:Specify a non NULL value for the parameter.


ORA-24032

ORA-24032object name exists, index could not be created for queue table name

Cause:Oracle advanced queueing tried to create an index with the name specified in the error message. The index could not be created for the specified queue table because a object exists with the same name.

Action:Drop the object specified in the error message and retry the command. You can also choose a different name for the queue table.


ORA-24034

ORA-24034application name is already a subscriber for queue name

Cause:An application name that was already a subscriber for the queue was specified in the DBMS_AQ.SUBSCRIBE call.

Action:Choose another application name and retry the call.


ORA-24035

ORA-24035application name is not a subscriber for queue name

Cause:An application name that was not a subscriber for the queue was specified in the DBMS_AQ.UNSUBSCRIBE call.

Action:Check the name of the application and retry the call.


ORA-24036

ORA-24036invalid SORT_ORDER column name specified for queue table

Cause:The create queue table command was issued with MESSAGE_GROUPING set to TRANSACTIONAL and a sort order column other than priority. Only the priority column can be specified in the sort order for queue tables with transactional grouping.

Action:Change the sort order list in the create queue table command and retry the call.


ORA-24037

ORA-24037schema name in QUEUE_NAME is not same as schema name in QUEUE_TABLE

Cause:The schema specified in the QUEUE_NAME parameter of CREATE_QUEUE is not the same as the schema specified in the QUEUE_TABLE parameter.

Action:Use the same schema name for both the QUEUE_NAME and QUEUE_TABLE parameters and retry the command.


ORA-24038

ORA-24038RETRY_DELAY cannot be specified for a multiple consumer queue

Cause:The CREATE_QUEUE or ALTER_QUEUE command was issued with a non-zero RETRY_DELAY and a QUEUE_TABLE that was created for multiple consumers.

Action:Either set the RETRY_DELAY to zero or create the queue in a queue table that is not created for multiple consumers.


ORA-24039

ORA-24039queue name not created in queue table for multiple consumers

Cause:An ADD_SUBSCRIBER, REMOVE_SUBSCRIBER or an ENQUEUE with a non-empty recipient list was issued on a queue that has not been created for mutiple consumers.

Action:Create the queue in a queue table that has been created for multiple consumers and retry the call.


ORA-24270

ORA-24270a row already exists in the name table for these parameters

Cause:A call was made to create a new row in the specified table. A row already exists in the table with the specified values.

Action:Delete the existing row using the appropriate API or check the parameters used to create the row.


ORA-24271

ORA-24271translation type must be either T, S or M

Cause:The translation type parameter is not a T, S or an M. A value other than T, S or M was specified.

Action:Correct the translation type and re-execute the API call.


ORA-24272

ORA-24272initialization value must be either F or T

Cause:The initialization value must be either F or T. A value other than F or T was specified.

Action:Correct the initialization value and re-execute the API call.


ORA-24273

ORA-24273translation text is required if translation type is T or S

Cause:If a translation type of T or S is specified, translation text must be supplied.

Action:Provide translation text and re-execute the API call.


ORA-24274

ORA-24274no row exists in the name table for these parameters

Cause:A call was made to update a row that does not exist or a foreign key value supplied to create a table does not exist.

Action:Create the row using the appropriate API or check the parameters used to create the new row to ensure that all specified values exist.


ORA-24275

ORA-24275function name parameter name missing or invalid

Cause:The function <pkgname.funcname> was called with a parameter <parname> that was null, 0 length, or had an invalid value.

Action:Correct the parameter to supply values that comply with its datatype and limits as specified in the documentation.


ORA-24276

ORA-24276function name output name maximum value exceeded

Cause:The function <pkgname.funcname> computed a value for the output <parname> that exceeded the maximum allowed. This can occur when multiple input parameters, each valid separately, combine to specify an invalid result. For example, when a length parameter multiplied by a copies parameter yields a total length exceeding the maximum for the output datatype.

Action:Correct the input values to produce a result that will comply with the limits as specified in the documentation.


ORA-24277

ORA-24277insufficient privileges to execute name

Cause:The access to this procedure is limited to users with certain privileges, which the invoker doesn't have.

Action:Check your documentation to verify the privileges needed to execute the named procedure.


ORA-24278

ORA-24278privilege type mismatch

Cause:Privileges can be granted to a user on an object like execute rights or just to a user like create library rights. Those are different types of privileges. One cannot insert an object privilege into the user privileges table and vice versa.

Action:Make sure the Privilege type is correct.


ORA-24279

ORA-24279insufficient privileges to create library

Cause:An attempt was made to create a remote library without having the remote create library privilege.

Action:A local DBA must grant the remote user the create library privilege by invoking DBMS_HS_EXTPROC.GRANT_CREATE_LIBRARY().


ORA-24280

ORA-24280invalid input value for parameter name

Cause:The parameter has been provided a negative, out of range, or NULL input value.

Action:Correct the input value such that it is valid, and is within the range as specified in the documentation.


ORA-24281

ORA-24281invalid access past the maximum size of LOB parameter name

Cause:The value of positional or size parameters exceeds the maximum allowed LOB size of 4 Gigabytes.

Action:Correct the input values for amount and offset such that their sum is less than or equal to 4 Gigabytes. If error occurs in a read or write loop, check the looping conditions and/or offset increments.


(Untitled)

PL/SQL and FIPS Messages

This chapter lists messages issued by PL/SQL. For each PL/SQL message, the probable cause and corrective action are given.

To help you find and fix errors, PL/SQL inserts object names, numbers, and character strings into some error messages. These message inserts are represented by name, num, and str, respectively. For example, the error message listed as

PLS-00388: undefined column name in subquery

might be issued as

PLS-00388: undefined column AMPNO in subquery

This chapter also lists the warnings that can be generated when the FIPS flagger is set in an Oracle product, and an Oracle extension to the SQL92 standard is used or a SQL92 feature is used in a non-conforming manner. FIPS warnings messages are listed for completeness. The cause and actions are described in the ANSI document ANSI X3.135-1992.


ORA-24301

ORA-24301null host specified in thread-safe logon

Cause:An HDA was not specified in the logon call while running in a thread safe environment.

Action:Make sure that HDA is not NULL when calling the logon routine.

For more information about host data areas(HDA) and defining the OCI data structures, see the index entries on "host data area" and on "data structures, defining" in the Programmer's Guide to the Oracle Call Interface, Volume II: OCI Reference.


ORA-24302

ORA-24302host connection in use by another thread

Cause:An attempt was made to use the host connection while it was in use by another thread.

Action:Wait for another thread to finish before using this connection.

For more information about connecting to the Oracle Server, see the index entry on "connections, multiple" in the Programmer's Guide to the Oracle Call Interface, Volume II: OCI Reference.


ORA-24303

ORA-24303call not supported in non-deferred linkage

Cause:One of the calls that was supported in deferred mode linkage exclusively was invoked when the client was linked non-deferred.

Action:Use this call in deferred mode of linkage.

For more information about deferred mode linking, see the index entry on "deferred, mode linking" in the Programmer's Guide to the Oracle Call Interface, Volume II: OCI Reference.


ORA-24304

ORA-24304datatype not allowed for this call

Cause:Data of this datatype cannot be sent or fetched in pieces.

Action:Use other bind or define calls for this datatype.

For more information about bind and define calls, see the index entry on "developing an OCI program" in the Programmer's Guide to the Oracle Call Interface, Volume II: OCI Reference.


ORA-24305

ORA-24305bad bind or define context

Cause:The call was executed on a cursor for which this was invalid.

Action:Verify that this call is valid for this cursor. For example, GET PIECE INFORMATION and SET PIECE INFORMATION are valid on a cursor if appropriate binds and defines have been done on this cursor.

For more information about bind and define calls, see the index entries on "bind operation" and on "define operation" in the Programmer's Guide to the Oracle Call Interface, Volume II: OCI Reference.


ORA-24306

ORA-24306bad buffer for piece

Cause:A zero length buffer or a null buffer pointer was provided.

Action:Verify that the buffer pointing to this piece or its length is non-zero. The buffer pointer for the next piece or its length can be zero if it is the last piece to be inserted and there are no more data for the column.

For more information about fetching operations, see the index entry on "rows, fetching" in the Programmer's Guide to the Oracle Call Interface, Volume II: OCI Reference.


ORA-24307

ORA-24307invalid length for piece

Cause:The length of the piece exceeds the maximum possible size of the data.

Action:Verify that the length of this piece and the cumulative length of all the previous pieces are not more than the PROGVL parameter specified in the obindps call.

For more information about fetching operations, see the index entry on "rows, fetching" in the Programmer's Guide to the Oracle Call Interface, Volume II: OCI Reference.


ORA-24308

ORA-24308illegal named data type variable

Cause:A named data type define was issued for a non-existent variable.

Action:Verify that a define call is already issued for this variable.


ORA-24309

ORA-24309already connected to this server

Cause:The specified server handle is already attached to a server.

Action:Disconnect from the server and then retry the ociatch() call.


ORA-24310

ORA-24310length specified for null connect string

Cause:The connect string is NULL, but a length was specified for it.

Action:Set length to zero if connect string is NULL.


ORA-24311

ORA-24311memory initialization failed

Cause:Cannot initialize user memory.

Action:Contact customer support.


ORA-24312

ORA-24312illegal parameters specified for allocating user memory

Cause:An illegal size or NULL pointer was specified for user memory.

Action:Specify a legal size and a valid pointer for user memory.


ORA-24313

ORA-24313user is already authenticated

Cause:A user has already been authenticated on this service handle.

Action:Terminate the service context before using it for another user.


ORA-24314

ORA-24314need explicit attach before initialize service context

Cause:An ociatch() was not done before an ociisc() call.

Action:Issue ociatch() before calling ociatch().


ORA-24315

ORA-24315illegal attribute type

Cause:An illegal attribute type was specified for the handle.

Action:Consult user manual to specify an attribute valid for this handle.


ORA-24316

ORA-24316illegal handle type

Cause:An illegal handle type was specified.

Action:Consult user manual to specify a valid handle type.


ORA-24317

ORA-24317re-defining different position

Cause:A define was done again with a different position.

Action:Specify the same position as before on a re-define.


ORA-24318

ORA-24318named data type calls not allowed for scalar data types

Cause:A named data type bind or define call was issued for a scalar type.

Action:Verify that the data-type for this variable is a named data type.


ORA-24319

ORA-24319unable to allocate memory for Diagnostic Record

Cause:Process was unable to allocate memory.

Action:Terminate other processes in order to reclaim needed memory.


ORA-24320

ORA-24320unable to initialize a mutex

Cause:An attempt to initialize a mutex failed.

Action:Contact customer support.


ORA-24321

ORA-24321inconsistent parameters passed to ocipi

Cause:One of the three memory function pointers is null or non-null.

Action:Verify that either all the memory functions are null or non-null.


ORA-24322

ORA-24322unable to delete an initialized mutex

Cause:An attempt to delete an initialized mutex failed.

Action:Contact customer support.


ORA-24323

ORA-24323value not allowed

Cause:A null value or a bogus value was passed in for a mandatory parameter.

Action:Verify that all mandatory parameters are properly initialized.


ORA-24324

ORA-24324service handle not initialized

Cause:An attempt was made to use an improper service context handle.

Action:Verify that the service context handle has all the parameters initialized and set for this call.


ORA-24325

ORA-24325this OCI operation is not currently allowed

Cause:An attempt was made to use an improper context handle.

Action:Verify that the context handle is not a part of a service context that has been converted to a logon data area for other OCI calls. The logon data area must be converted back to a service context before its components can be used.


ORA-24326

ORA-24326handle passed in is already initialized

Cause:An attempt was made to pass an initialized handle.

Action:Verify that the parameter passed in to retrieve a handle does not already point to a handle.


ORA-24327

ORA-24327need explicit attach before authenticating a user

Cause:A server context must be initialized before creating a session.

Action:Create and initialize a server handle.


ORA-24328

ORA-24328illegal attribute value

Cause:The attribute value passed in is illegal.

Action:Consult the users manual and specify a legal attribute value for the handle.


ORA-24329

ORA-24329invalid character set identifier

Cause:The character set identifier specified is invalid.

Action:Specify a valid character set identifier in the OCI call.


ORA-24330

ORA-24330internal OCI error

Cause:An internal OCI error has occurred.

Action:Please contact Oracle customer support.


ORA-24331

ORA-24331user buffer too small

Cause:The user buffer to contain the output data is too small.

Action:Specify a larger buffer.


ORA-24332

ORA-24332invalid object type

Cause:An invalid object type is requested for the describe call.

Action:Specify a valid object type to the describe call.


ORA-24333

ORA-24333zero iteration count

Cause:An iteration count of zero was specified for a non-select statement.

Action:Specify the number of times this statement must be executed.


ORA-24334

ORA-24334no descriptor for this position

Cause:The application is trying to get a descriptor from a handle for an illegal position.

Action:Check the position number.


ORA-24335

ORA-24335cannot support more than 1000 columns

Cause:The number of columns exceeds the maximum number supported.

Action:Specify a number of columns less than 1000.


ORA-24336

ORA-24336invalid result set descriptor

Cause:The result set descriptor should have valid data fetched into it before it can be converted to a statement handle

Action:Fetch valid data into the descriptor before attempting to convert it into a statement handle.


ORA-24337

ORA-24337statement handle not prepared

Cause:A statement cannot be executed before making preparing a request.

Action:Prepare a statement before attempting to execute it.


ORA-24338

ORA-24338statement handle not executed

Cause:A fetch was attempted before executing a statement handle.

Action:Execute a statement and then fetch the data.


ORA-24340

ORA-24340cannot support more than 255 columns

Cause:The number of columns exceeds maximum supported by the server.

Action:Limit your operation to 255 columns.


ORA-24341

ORA-24341bad mode specified

Cause:OCI_ENV_NO_MUTEX mode was specified for a non-threaded client.

Action:OCI_ENV_NO_MUTEX may be specified when OCI_THREADED had been specified at process initialization.


ORA-24342

ORA-24342unable to destroy a mutex

Cause:An attempt to destroy a mutex failed.

Action:Contact Oracle Worldwide Support.


ORA-24343

ORA-24343user defined callback error

Cause:The only valid return value for a user defined callback function is OCI_CONTINUE. Any other value will cause this error.

Action:Please insure that OCI_CONTINUE is returned from the user defined callback function.


ORA-24344

ORA-24344success with compilation error

Cause:A SQL/PLSQL compilation error occurred.

Action:Return OCI_SUCCESS_WITH_INFO along with the error code.


ORA-24345

ORA-24345a truncation or NULL fetch error occurred

Cause:A truncation or a null fetch error occurred.

Action:Please ensure that the buffer size is long enough to store the returned data. Then retry the operation.


ORA-24346

ORA-24346cannot execute without binding variables

Cause:None of the bind variables in the SQL statement are bound.

Action:Please bind all the variables before the execute is done.


ORA-24350

ORA-24350this OCI call is not allowed

Cause:This OCI callback is not permitted from trusted 3GL callouts.

Action:Do not use this call.


ORA-24351

ORA-24351invalid date passed into OCI call

Cause:An invalid date was passed into one of the OCI calls.

Action:Check your date bind values and correct them.


ORA-24352

ORA-24352invalid COBOL display type passed into OCI call

Cause:An invalid COBOL display type was passed into one of the OCI calls.

Action:Check your COBOL display type bind values and correct them.


ORA-24353

ORA-24353user buffer too small to accommodate COBOL display type

Cause:User supplied buffer for a COBOL display type was too small to accommodate fetched number.

Action:Increase the allocation for COBOL display type buffer.


ORA-24354

ORA-24354number fetched too large to fit in COBOL display type buffer.

Cause:The number fetched was beyond the range that can be displayed.

Action:Please check the number in the database.


ORA-24355

ORA-24355attempt to store a negative number in an Unsigned Display type.

Cause:An attempt was made to convert a negative number into an unsigned display type.

Action:Please check the number in the database or change the defined datatype.


ORA-24356

ORA-24356internal error while converting from to COBOL display type.

Cause:An internal error was encountered during conversion to COBOL display type.

Action:Contact customer support.


ORA-24357

ORA-24357internal error while converting from to OCIDate.

Cause:An internal error was encountered during conversion to OCIDate type.

Action:Contact customer support.


ORA-24358

ORA-24358OCIBindObject not invoked for a Object type or Reference

Cause:OCIBindObject was not invoked resulting in an incomplete bind specification for a Object Type or Reference.

Action:Please invoke the OCIBindObject call for all Object Types and References.


ORA-24359

ORA-24359OCIDefineObject not invoked for a Object type or Reference

Cause:OCIDefineObject was not invoked resulting in an incomplete bind specification for a Object Type or Reference.

Action:Please invoke the OCIDefineObject call for all Object Types and References.


ORA-24360

ORA-24360Type Descriptor Object not specified for Object Bind/Define

Cause:Type Descriptor Object is a mandatory parameter for Object Types Binds and Defines.

Action:Please invoke the OCIBindObject() or OCIDefineObject() call with a valid Type Descriptor Object.


ORA-24361

ORA-24361basic bind call not invoked before invoking advanced bind call

Cause:One of the basic bind calls was not invoked on this bind handle before performing an advanced bind call.

Action:Please invoke the advanced bind call on this bind handle only after performing a basic bind call.


ORA-24362

ORA-24362improper use of the character count flag

Cause:When the character count flag is set, then the maximum size of the buffer in the server should be specified as a non-zero value.

Action:Please use a non-zero value for the maximum size of the buffer in the server.


ORA-24363

ORA-24363measurements in characters illegal here

Cause:Measurements in characters instead of bytes are illegal if either the server's or client's character set is varying width.

Action:If either the client's or server's character set is varying width then do not use the OCI_ATTR_CHAR_COUNT attribute for the bind handle. Use OCI_ATTR_MAXDATA_SIZE instead.


ORA-24364

ORA-24364internal error while padding blanks

Cause:An internal error has occurred while attempting to blank pad string data. This error should not occur normally.

Action:Contact customer support.


ORA-24365

ORA-24365error in character conversion

Cause:This usually occurs during conversion of a multibyte character data when the source data is abnormally terminated in the middle of a multibyte character.

Action:Make sure that all multibyte character data is properly terminated.


ORA-24366

ORA-24366migratable user handle is set in service handle

Cause:This occurs during user authentication: a migratable user handle has been set in the service handle.

Action:Service handle must not be set with migratable user handle when it is used to authenticate another user.


ORA-24367

ORA-24367user handle has not been set in service handle

Cause:This occurs during authentication of a migratable user. the service handle has not been set with non-migratable user handle.

Action:Service handle must be set with non-migratable user handle when it is used to authenticate a migratable user.


ORA-24368

ORA-24368OCI mutex counter non-zero when freeing a handle

Cause:This is an internal OCI error.

Action:Contact customer support.


ORA-24369

ORA-24369required callbacks not registered for one or more bind handles"

Cause:No callbacks have been registered for one or more of the bind handles which are part of the RETURNING clause.

Action:The bind handles which are to receive data in a DML statement with a RETURNING clause must have their mode set as DATA_AT_EXEC and callback functions must be registered for these bind handles using OCIBindDynamic.


ORA-24370

ORA-24370illegal piecewise operation attempted

Cause:Data of a certain datatype that does not support piecewise operation is being sent or fetched in pieces.

Action:Always set the piece value to OCI_ONE_PIECE for datatypes that does not support piecewise operation.


ORA-24371

ORA-24371data would not fit in current prefetch buffer

Cause:An internal OCI error has occurred.

Action:Please contact Oracle customer support.


ORA-24372

ORA-24372invalid object for describe

Cause:The object to be described is not valid. It either has compilation or authorization errors.

Action:The object to be described must be valid.


ORA-24750

ORA-24750incorrect size of attribute

Cause:Transaction ID attribute size is incorrect.

Action:Verify that the size parameter is correct.


ORA-24752

ORA-24752OCI_TRANS_NEW flag must be specified for local transactions

Cause:Application attempted to start a local transaction without using OCI_TRANS_NEW.

Action:Use OCI_TRANS_NEW when starting local transactions.


ORA-24753

ORA-24753local transactions cannot be detached

Cause:An attempt to detach a local transaction was made.

Action:Local transactions may only be committed or rolled back.


ORA-24754

ORA-24754cannot start new transaction with an active transaction

Cause:An attempt to start a new transaction was made when there was an active transaction.

Action:Commit, rollback or detach the existing transaction before starting a new transaction.


ORA-24755

ORA-24755OCI_TRANS_NOMIGRATE, OCI_TRANS_JOIN options are not supported

Cause:These flags are currently not supported.

Action:No action required.


ORA-24756

ORA-24756transaction does not exist

Cause:An invalid transaction identifier or context was used or the transaction has completed.

Action:Supply a valid identifier if the transaction has not completed and retry the call.


ORA-24757

ORA-24757duplicate transaction identifier

Cause:An attempt was made to start a new transaction with an identifier already in use by an existing transaction.

Action:Verify that the identifier is not in use.


ORA-24758

ORA-24758not attached to the requested transaction

Cause:An attempt was made to detach or complete a transaction that is not the current transaction.

Action:Verify that the transaction context refers to the current transaction.


ORA-24759

ORA-24759invalid transaction start flags

Cause:An invalid transaction start flag was passed.

Action:Verify that one of the following values - OCI_TRANS_NEW, OCI_TRANS_JOIN, OCI_TRANS_RESUME was specified.


ORA-24760

ORA-24760invalid isolation level flags

Cause:An invalid isolation level flag was passed.

Action:Verify that only one of following values - OCI_TRANS_READONLY, OCI_TRANS_READWRITE, OCI_TRANS_SERIALIZABLE is used.


ORA-24761

ORA-24761transaction rolled back

Cause:The application tried to commit a transaction and the server rolled it back.

Action:No action required.


ORA-24762

ORA-24762server failed due to unspecified error

Cause:An internal error has occurred in the server commit protocol.

Action:Contact customer support.


ORA-24763

ORA-24763transaction operation cannot be completed now

Cause:The commit or rollback cannot be performed now because the session cannot switch to the specified transaction.

Action:Retry the operation later.


ORA-24764

ORA-24764transaction branch has been heuristically committed

Cause:This is an information message.

Action:No action required.


ORA-24765

ORA-24765transaction branch has been heuristically rolled back

Cause:This is an information message.

Action:No action required.


ORA-24766

ORA-24766transaction branch has been partly committed and aborted

Cause:This is an information message.

Action:No action required.


ORA-24767

ORA-24767transaction was read-only and has been committed

Cause:This is an information message.

Action:No action required.


ORA-24768

ORA-24768commit protocol error occurred in the server

Cause:This is an internal error.

Action:Contact customer support


ORA-24769

ORA-24769cannot forget an active transaction

Cause:Transaction identifier refers to an active transaction.

Action:Verify that the identifier of an active transaction was not passed as an argument.


ORA-24770

ORA-24770cannot forget a prepared transaction

Cause:Transaction identifier refers to a prepared transaction.

Action:Verify that the identifier of a prepared transaction was not passed as an argument.


ORA-24771

ORA-24771cannot detach, prepare or forget a local transaction

Cause:Service handle contains a local transaction context.

Action:Verify that the transaction context does not refer to a local transaction.


ORA-24772

ORA-24772Cannot mix tightly-coupled and loosely-coupled branches

Cause:Application attempted to start a transaction with a global transaction identifier and a wrong option.

Action:Verify that all branches of a global transaction are started with either OCI_TRANS_TIGHT or OCI_TRANS_LOOSE option. If the application is correct and uses distributed updates, contact customer support.


ORA-24773

ORA-24773invalid transaction type flags

Cause:OCI_TRANS_TIGHT or OCI_TRANS_LOOSE mode was not specified.

Action:Verify that the right parameters are being used.


ORA-24774

ORA-24774cannot switch to specified transaction

Cause:The transaction specified in the call refers to a transaction created by a different user.

Action:Create transactions with the same authentication so that they can be switched.


ORA-24775

ORA-24775cannot prepare or commit transaction with non-zero lock value

Cause:An attempt was made to detach the transaction with a non-zero lock value.

Action:Detach the transaction with lock value set to zero and then try to prepare or commit the transaction.


ORA-24776

ORA-24776cannot start a new transaction

Cause:An attempt was made to start a new transaction when session was already attached to an existing transaction.

Action:End the current transaction before creating a new transaction.


ORA-24777

ORA-24777cannot create migratable transaction

Cause:The transaction tried to access a remote database from a non-multi threaded server instance.

Action:Perform the work in the local database or open a connection to the remote database from the client. If multi threaded server option is installed connect to the Oracle instance through the dispatcher.


ORA-24778

ORA-24778cannot open connections

Cause:The migratable transaction tried to access a remote database when the session itself had opened connections to remote database(s).

Action:Close the connection(s) in the session and then try to access the remote database from the migratable transaction. If the error still occurs, contact Oracle customer support.


ORA-24801

ORA-24801illegal parameter value in OCI lob function

Cause:One of the parameter values in the OCI lob function is illegal.

Action:Check every parameter in the OCI Lob function call to make sure they are correct. Offsets should be greater than or equal to one.


ORA-24802

ORA-24802user defined lob read callback error

Cause:The only valid return value for a user defined lob read callback function is OCI_CONTINUE. Any other value will cause this error.

Action:Verify that OCI_CONTINUE is returned from the user defined lob read callback function.


ORA-24803

ORA-24803illegal parameter value in lob read function

Cause:This is an internal error.

Action:This error should not normally occur. If it persists, please contact your customer service representative.


ORA-24804

ORA-24804illegal parameter value in lob write function

Cause:Internal error.

Action:This error should not normally occur. If it persists, please contact your customer service representative.


ORA-24805

ORA-24805LOB type mismatch

Cause:When copying or appending LOB locators, both source and destination LOB locators should be of the same type.

Action:Pass the same type of LOB locators for copying or appending.


ORA-24806

ORA-24806LOB form mismatch

Cause:When reading from or writing into LOBs, the character set form of the user buffer should be same as that of the LOB.

Action:Make sure that the buffer you are using to read or write has the same form as that of the LOB.


ORA-24807

ORA-24807LOB form mismatch

Cause:When copying or appending LOBs, both source and destination LOB locators should have the same character set form.

Action:Pass locators of the same character set form for copying or appending LOBs.


ORA-24808

ORA-24808streaming of LOB data is not allowed when using LOB buffering

Cause:Attempted to stream LOB data via the polling mode or a callback when LOB buffering was enabled for the input lob locator.

Action:LOB buffering is useful when reading/writing small amounts of LOB data so streaming should not be necessary. Rewrite the OCILobRead/OCILobWrite call so that it does not use streaming. If streaming of data is required, LOB buffering should not be used. In this case, flush buffers associated with the input LOB locator as necessary, disable buffering on the input LOB locator and reissue the CILobRead/OCILobWrite call.


ORA-24809

ORA-24809amount specified will not fit in the LOB buffers

Cause:LOB buffering is enabled for the input lob locator so buffering will be used. However, the amount of lob data to read or write is larger than what the lob buffers can hold.

Action:Either disable buffering on the input lob locator and reissue the command or pass a smaller amount.


ORA-25001

ORA-25001cannot create this trigger type on views

Cause:Only INSTEAD OF triggers can be created on a view.

Action:Change the trigger type to INSTEAD OF.


ORA-25002

ORA-25002cannot create INSTEAD OF triggers on tables

Cause:Only BEFORE or AFTER triggers can be created on a table.

Action:Change the trigger type to BEFORE or AFTER.


ORA-25003

ORA-25003cannot change NEW values for this column type in trigger

Cause:Attempt to change NEW trigger variables of datatype object, REF, nested table, VARRAY or LOB datatype which is not supported.

Action:Do not change the NEW trigger variables in the trigger body.


ORA-25004

ORA-25004WHEN clause is not allowed in INSTEAD OF triggers

Cause:WHEN clause is specified in an INSTEAD OF trigger.

Action:Remove the WHEN clause when creating an INSTEAD OF trigger.


ORA-25005

ORA-25005cannot create INSTEAD OF trigger on a read-only view

Cause:An attempt was made to create an INSTEAD OF trigger on a view which was created with the read-only option. The view cannot be updated using INSTEAD OF triggers.

Action:Do not create the trigger.


ORA-25006

ORA-25006cannot specify this column in UPDATE OF clause

Cause:Attempt to create a trigger on update of a column whose datatype is disallowed in the clause, such as LOB and nested table.

Action:Remove the UPDATE OF clause.


ORA-25007

ORA-25007functions or methods not allowed in WHEN clause

Cause:PLSQL function call or method invocation is not allowed in the WHEN clause when creating a trigger.

Action:Remove the function call or method invocation from the WHEN clause.


ORA-25008

ORA-25008no implicit conversion to LOB datatype in instead-of trigger

Cause:When inserting or updating a view using instead-of trigger, the new value for a LOB view column is of a different datatype.

Action:Specified a LOB value as the new value for the LOB view column.


ORA-25100

ORA-25100TABLESPACE option can only be used with ALTER INDEX REBUILD

Cause:The TABLESPACE option to ALTER INDEX was used without the REBUILD option.

Action:Use ALTER INDEX REBUILD TABLESPACE <tablespace name>.

For more information about ALTER INDEX and other options in CREATE INDEX, see the index entries on "ALTER INDEX" and on "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25101

ORA-25101duplicate REBUILD option specification

Cause:The REBUILD option to ALTER INDEX was specified more than once.

Action:Specify the option at most once.

For more information about ALTER INDEX and other options in CREATE INDEX, see the index entries on "ALTER INDEX" and on "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25102

ORA-25102PARALLEL option can only be used with ALTER INDEX REBUILD

Cause:The PARALLEL option to ALTER INDEX was used without the REBUILD option.

Action:Use ALTER INDEX REBUILD.

For more information about ALTER INDEX and other options in CREATE INDEX, see the index entries on "ALTER INDEX" and on "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25103

ORA-25103NOPARALLEL option can only be used with ALTER INDEX REBUILD

Cause:The NOPARALLEL option to ALTER INDEX was used without the REBUILD option.

Action:Use ALTER INDEX REBUILD.

For more information about ALTER INDEX and other options in CREATE INDEX, see the index entries on "ALTER INDEX" and on "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25104

ORA-25104UNRECOVERABLE option can only be used with ALTER INDEX REBUILD

Cause:The UNRECOVERABLE option to ALTER INDEX was used without the REBUILD option.

Action:Use ALTER INDEX REBUILD.

For more information about ALTER INDEX and other options in CREATE INDEX, see the index entries on "ALTER INDEX, " "UNRECOVERABLE, " and "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25105

ORA-25105RECOVERABLE option can only be used with ALTER INDEX REBUILD

Cause:The RECOVERABLE option to ALTER INDEX was used without the REBUILD option.

Action:Use ALTER INDEX REBUILD.

For more information about ALTER INDEX and other options in CREATE INDEX, see the index entries on "ALTER INDEX" and on "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25106

ORA-25106only one of PARALLEL or NOPARALLEL clause may be specified

Cause:PARALLEL was specified more than once, NOPARALLEL was specified more than once, or both PARALLEL and NOPARALLEL were specified in an ALTER INDEX REBUILD statement.

Action:Remove all but one of the PARALLEL or NOPARALLEL clauses.

For more information about ALTER INDEX and other options in CREATE INDEX, see the index entries on "ALTER INDEX" and on "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25107

ORA-25107duplicate TABLESPACE option specification

Cause:The TABLESPACE was specified more than once in an ALTER INDEX REBUILD statement.

Action:Remove all but one of the TABLESPACE clauses.

For more information about ALTER INDEX and the TABLESPACE option in CREATE INDEX, see the index entries on "ALTER INDEX" and on "CREATE INDEX" in Oracle8 Server SQL Reference.


ORA-25108

ORA-25108standby lock name space exceeds size limit of num characters

Cause:The lock name space for the standby database exceeded the maximum string length.

Action:Change initialization parameter STANDBY_LOCK_NAME_SPACE to a character string of less than the specified characters.

For more information about standby databases, see the index entries on "standby database" in the Oracle8 Server Administrator's Guide.


ORA-25109

ORA-25109standby lock name space has illegal character char

Cause:An invalid lock name space was specified for the standby database. The lock name space for the standby database can only contain A-Z, 0-9, '_', '#', '$', and '@' characters.

Action:Change initialization parameter STANDBY_LOCK_NAME_SPACE to a valid character string.

For more information about standby databases, see the index entries on "standby database" in the Oracle8 Server Administrator's Guide.


ORA-25110

ORA-25110NOSORT may not be used with a bitmap index

Cause:An attempt was made to create a bitmap index using the NOSORT option.

Action:Remove NOSORT from the CREATE BITMAP INDEX statement.

For more information about the NOSORT option, see the index entry on "NOSORT option, of CREATE INDEX command" in Oracle8 Server SQL Reference.


ORA-25111

ORA-25111BITMAP may not be used with a cluster index

Cause:An attempt was made to create a cluster index with the BITMAP attribute.

Action:Remove BITMAP from the CREATE INDEX statement.

For more information about the CREATE INDEX command, see the index entry on "CREATE INDEX command" in Oracle8 Server SQL Reference.


ORA-25112

ORA-25112a bitmap index may index only one column

Cause:An attempt was made to create a bitmap index on more than one column.

Action:Remove all columns in the CREATE INDEX statement except one.

For more information about the CREATE INDEX command, see the index entry on "CREATE INDEX command" in Oracle8 Server SQL Reference.


ORA-25113

ORA-25113DML operations for BITMAP indexes not implemented

Cause:A DML operation such as INSERT, UPDATE, DELETE was performed on a table that has at least one BITMAP index defined.

Action:Remove all BITMAP indexes defined on the table.

For more information about the CREATE INDEX command, see the index entry on "CREATE INDEX command" in Oracle8 Server SQL Reference


ORA-25114

ORA-25114invalid file number specified in the DUMP DATAFILE command

Cause:A file number used in dumping a data file is invalid.

Action:Specify a valid file number.


ORA-25115

ORA-25115duplicate BLOCK option specification

Cause:BLOCK (MIN/MAX) is specified more than once in DUMP DATAFILE command.

Action:Choose one BLOCK option and specify it.


ORA-25116

ORA-25116invalid block number specified in the DUMP DATAFILE command

Cause:A block number used in dumping a data file is invalid.

Action:Specify a valid block number.


ORA-25117

ORA-25117MIN/MAX/Block Number expected

Cause:MIN/MAX, or block number is expected in the DUMP DATAFILE command.

Action:Correct the syntax and retry.


ORA-25118

ORA-25118invalid DUMP DATAFILE option

Cause:Invalid option specified for DUMP DATAFILE command.

Action:Correct the syntax and retry.


ORA-25119

ORA-25119LOGGING/NOLOGGING option already specified

Cause:In CREATE TABLESPACE, the LOGGING and/or NOLOGGING options were specified more than once.

Action:Remove all but one of the logging specifications.


ORA-25120

ORA-25120MINIMUM EXTENT option already specified

Cause:In CREATE TABLESPACE, the MINIMUM EXTENT option is specified more than once.

Action:Remove all but one of the MINIMUM EXTENT specifications.


ORA-25121

ORA-25121MINIMUM EXTENT value greater than maximum extent size

Cause:In CREATE/ALTER TABLESPACE, value specified for MINIMUM EXTENT option is greater than the maximum extent size.

Action:Decrease the value specified for MINIMUM EXTENT option.


ORA-25122

ORA-25122only LOCAL bitmap indexes are permitted on partitioned tables

Cause:An attempt was made to create a global bitmap index on a partitioned table.

Action:Create a local bitmap index instead. Then retry the operation.


ORA-25123

ORA-25123too many components specified in the name

Cause:Specifying more components to a name than allowed.

Action:Check the name specified for the operation.


ORA-25124

ORA-25124database link name not allowed

Cause:Specifying a database link name when it is not permitted.

Action:Check the name specified for the operation.


ORA-25125

ORA-25125BUFFER_POOL storage option not allowed

Cause:An attempt was made to specify the BUFFER_POOL storage option. This option may only be specified during CREATE/ALTER TABLE/CLUSTER/INDEX.

Action:Remove this option and retry the statement.


ORA-25126

ORA-25126invalid name specified for BUFFER_POOL

Cause:The name of the buffer pool specified by the user is invalid. The only valid names are KEEP, RECYCLE and DEFAULT.

Action:Use a valid name or remove the BUFFER_POOL clause.


ORA-25175

ORA-25175no PRIMARY KEY constraint found

Cause:A PRIMARY KEY constraint must be defined for a table with this organization.

Action:Define a PRIMARY KEY and retry the operation.


ORA-25176

ORA-25176storage specification not permitted for primary key

Cause:Storage parameters cannot be defined for a PRIMARY KEY constraint for a table with this organization.

Action:Remove storage specification for primary key.


ORA-25177

ORA-25177UNRECOVERABLE option not permitted

Cause:The UNRECOVERABLE option might not be specified for a primary key for a table with this organization.

Action:Remove UNRECOVERABLE option for primary key.


ORA-25178

ORA-25178duplicate PCTTHRESHOLD storage option specification

Cause:The storage option PCTTHRESHOLD is specified more than once.

Action:Specify storage options at most once.


ORA-25179

ORA-25179invalid PCTTHRESHOLD storage option value

Cause:The specified value must be a positive integer.

Action:Specify an appropriate value.


ORA-25180

ORA-25180PCTTHRESHOLD only valid for certain table organizations

Cause:PCTTHRESHOLD can only be specified for tables with certain organizations.

Action:Remove the PCTTHRESHOLD option.


ORA-25181

ORA-25181missing ON keyword for NESTED INDEX

Cause:ON keyword required to specify nested index column nest.

Action:Add ON keyword and retry the operation


ORA-25182

ORA-25182feature not currently available for index-organized tables

Cause:An attempt was made to use one or more of the following feature(s) not currently supported for index-organized tables:

CREATE TABLE with LOB/BFILE/VARRAY columns

partitioning/PARALLEL/CREATE TABLE AS SELECT options

ALTER TABLE with ADD/MODIFY column options, CREATE INDEX

Action:Do not use the disallowed feature(s) in this release.


ORA-25183

ORA-25183index only table top index segment is in a different tablespace

Cause:An attempt was made to drop a tablespace which contains an index only table's overflow segment but not the top index segment.

Action:Find the index only tables which span the tablespace being dropped and some other tablespace(s). Drop these tables.


ORA-25184

ORA-25184column name expected

Cause:A column name is not present where required by the CREATE TABLE for specifying last column to be included in the index segment of the index-organized table.

Action:Specify a column name where required by the syntax.


ORA-25185

ORA-25185index column other than last can not be specified for INCLUDE clause

Cause:While creating index-only tables, an index column name, instead of a non-index column name, was used for the INCLUDING clause of a CREATE TABLE statement used for creating index-organized tables.

Action:Specify a column name which is not part of index-organized table top index for the INCLUDING clause.


ORA-25186

ORA-25186INCLUDING clause specified without an OVERFLOW clause

Cause:The INCLUDING clause of a CREATE TABLE is a valid option only for index-organized tables with OVERFLOW clause.

Action:Specify an OVERFLOW clause for the index-organized table.


ORA-25187

ORA-25187specified exceptions table form incorrect

Cause:The specified table does not have the proper field definitions.

Action:Specify the correct table to use.


ORA-25188

ORA-25188cannot DROP/DISABLE/DEFER the primary key constraint for Index-organized tables

Cause:An attempt was made to DROP, DISABLE, or DEFER the primary key constraint for an index-only table. This is not allowed.

Action:This is an informational message. Do not DROP, DISABLE, or DEFER the primary key constraint for an index-only table.


ORA-25189

ORA-25189illegal ALTER TABLE option for an index-organized table

Cause:During ALTER of a index-organized table, the user attempted to enter one or more of the following options: TABLESPACE, ALLOCATE/DEALLOCATE EXTENT, PCTFREE/PCTUSED for IOT top index segment.

Action:Remove the illegal option(s).


ORA-25190

ORA-25190an index-organized table maintenance operation may not be combined with other operations

Cause:ALTER TABLE statement attempted to combine an index-organized table maintenance operation (e.g. changing physical attributes) with some other operation (e.g. ADD constraint) which is illegal.

Action:Ensure that a index-organized table maintenance operation is the sole operation specified in ALTER TABLE statement.


ORA-25191

ORA-25191cannot reference overflow table of an index-organized table

Cause:An attempt was made to directly access the overflow table of an index-organized table.

Action:Issue the statement against the parent index-organized table containing the specified overflow table.


ORA-25200

ORA-25200: invalid value name.name QUEUE_NAME should be [SCHEMA.]NAME

Cause:A NULL parameter was specified for the queue name.

Action:Specify a NON-NULL queue name.


ORA-25201

ORA-25201: invalid value, VISIBILITY should be ON_COMMIT or IMMEDIATE

Cause: An invalid value specified for parameter VISIBILITY.

Action:Specify either ON_COMMIT or IMMEDIATE.


ORA-25202

ORA-25202: invalid value NULL, name should be non-NULL

Cause:A NULL value was specified for the parameter.

Action:Specify a non-NULL value.


ORA-25203

ORA-25203: invalid value num, DELAY should be non-negative

Cause:A negative value or NULL was specified for DELAY.

Action:Specify a non negative integer for DELAY.


ORA-25204

ORA-25204: invalid value, SEQUENCE_DEVIATION should be BEFORE or TOP

Cause:An invalid SEQUENCE_DEVIATION was specified.

Action:Specify either the option BEFORE or TOP.


ORA-25205

ORA-25205: the QUEUE name.name does not exist

Cause:The specified queue does not exist.

Action:Create the queue first before specifying it for enqueue or dequeue.


ORA-25206

ORA-25206: enqueue failed, enqueue to exception queue name.name not permitted

Cause:An attempt was made to enqueue to an exception queue.

Action:Try enqueueing to another queue.


ORA-25207

ORA-25207: enqueue failed, queue name.name is disabled from enqueueing

Cause:The queue has been stopped to prevent any further enqueueing.

Action:Enable the queue first by using an administrative operation.


ORA-25208

ORA-25208: RELATIVE_MSGID must be specified if SEQUENCE_DEVIATION is BEFORE

Cause:A relative message identifier should be specified if sequence deviation is specified as BEFORE.

Action:Specify a non-null parameter for sequence deviation. valid values are either A, B, or T.


ORA-25209

ORA-25209: invalid value num, EXPIRATION should non-negative or NEVER

Cause:The expiration is less than zero or NULL.

Action:Specify a valid value for expire_after which should be greater than or equal to zero or NEVER.


ORA-25210

ORA-25210: invalid value for RELATIVE_MSGID, no message in queue with that msgid

Cause:No message inm the queue with the msgid equal to the specified RELATIVE_MSGID.

Action:Try again with a valid RELATIVE_MSGID.


ORA-25211

ORA-25211: invalid DELAY specified when using sequence deviation

Cause:The DELAY specified in the enqueue is greater than the delay of the message with the given relative message id.

Action:Set the DELAY to be less than or equal to the delay of the message with the given relative message id. If the TOP option is used the delay must be less than or equal to the delay of all the messages in the queue.


ORA-25212

ORA-25212: invalid PRIORITY specified when using sequence deviation

Cause:The PRIORITY specified in the enqueue is less than the priority of the message with the given relative message id.

Action:Set the PRIORITY to be less than the delay of the message with the given relative message id. If the TOP option is used the priority must be greater than or equal to the priority of all the messages in the queue.


ORA-25213

ORA-25213: message with specified RELATIVE_MSGID has been dequeued

Cause:The message specified by the RELATIVE_MSGID field in the sequence deviation BEFORE option has been dequeued.

Action:No action required. This is an informational message only.


ORA-25215

ORA-25215: user_data type and queue type do not match

Cause:An attempt was made to enqueue an object to a queue that was created for objects of different type.

Action:Try enqueue again with an object of the right type.


ORA-25225

ORA-25225: invalid value name, DEQUEUE_MODE should be REMOVE or BROWSE or LOCKED

Cause:An invalid parameter has been specified for DEQUEUE_MODE.

Action:Specify either REMOVE, BROWSE or LOCKED.


ORA-25226

ORA-25226: dequeue failed, queue name.name is not enabled for dequeue

Cause:The queue has not been enabled for dequeue.

Action:Enable the queue using START_QUEUE.


ORA-25228

ORA-25228: timeout in dequeue from name.name while waiting for a message

Cause:User-specified dequeue wait time has passed but no message has been retrieved.

Action:Try dequeue again with the appropriate WAIT_TIME.


ORA-25230

ORA-25230: invalid value name, WAIT should be non-negative

Cause:A negative value was specified for WAIT.

Action:Specify a non negative value or FOREVER.


ORA-25231

ORA-25231: SUBSCRIBER not specified

Cause:An attempt was made to dequeue from a queue that has been created for subscription but a subscriber has not been specified.

Action:Try dequeue again after specifying the name of the subscriber.


ORA-25232

ORA-25232: duplicate recipients specified for message

Cause:An enqueue was performed with duplicate queue agents in the recipient's parameter.

Action:Remove the duplicate queue agent and retry the call.


ORA-25233

ORA-25233: invalid parameter specified for NAVIGATION

Cause:An invalid parameter has been specified for NAVIGATION.

Action:Choose one of FIRST_MESSAGE, NEXT_MESSAGE, or NEXT_TRANSACTION. Use FIRST_MESSAGE for dequeuing first message that satisfies the criterion, NEXT_MESSAGE for dequeuing next message that satisfies the criterion and NEXT_TRANSACTION for moving to a set of messages enqueued by another transaction.


ORA-25234

ORA-25234: NEXT_TRANSACTION navigation option invalid for queue table basename.extension

Cause:The NEXT_TRANSACTION navigation flag was used in a dequeue from a queue in a queue table that was not created for transactional grouping.

Action:Specify either FIRST_MESSAGE or NEXT_MESSAGE as the navigation option. If you want to dequeue messages using transactional grouping create the queue in a queue table that has transactional grouping enabled.


ORA-25235

ORA-25235: fetched all messages in current transaction

Cause:The NEXT_TRANSACTION navigation option was used in a dequeue where there were no messages that belong to the same transaction.

Action:Use the NEXT_TRANSACTION navigation option to move to the next group of messages that belong to the same transaction. You can also use the FIRST_MESSAGE option to start from the head of the queue again.


ORA-25236

ORA-25236: buffer too small for user data

Cause:The variable or buffer used for the out parameter payload is too small for the user data dequeued.

Action:Increased the size of the buffer or the size of the variable. Maximum size allowed is 32K.


ORA-25237

ORA-25237: navigation option used out of sequence

Cause:The NEXT_MESSAGE or NEXT_TRANSACTION option was specified after dequeuing all the messages.

Action:Reset the dequeuing position using the FIRST_MESSAGE navigation option and then specify the NEXT_MESSAGE or NEXT_TRANSACTION option.


ORA-25238

ORA-25238: too many recipients specified for message

Cause:An enqueue was performed with more than 32 recipients.

Action:Reduce the number of recipients to 32 and retry the call.


ORA-25350

ORA-25350: maximum number of concurrent transaction branches exceeded

Cause:The limit on the number of concurrent transaction branches has been hit.

Action:Shutdown the system, increase the value of the INIT.ORA parameter TRANSACTIONS, and then restart the system.


ORA-25351

ORA-25351: transaction attached to some other session

Cause:The user transaction is currently used by others.

Action:Do not switch to a transaction attached to some other session.


ORA-25352

ORA-25352: no current transaction

Cause:The user session is not attached to any transaction.

Action:Do not attempt to detach when there is no current transaction.


ORA-25353

ORA-25353: branch marked for deletion

Cause:The branch specified cannot be killed immediately because another session is using the branch, but it has been marked for kill. This means it will be killed as soon as possible after the current operation, which cannot be interrupted, is done.

Action:No action is required for the branch to be deleted.


ORA-25400

ORA-25400: must replay FETCH

Cause:A failure occurred since the last fetch on this cursor. Failover was able to bring the cursor to its original state to allow continued fetches.

Action:This is an internally used error message and should not be seen by the user.


ORA-25401

ORA-25401: cannot fetch on cursor

Cause:A failure occurred since the last fetch on this cursor. Failover was unable to bring the cursor to its original state to allow continued fetches.

Action:Re-execute the statement and start fetching from the beginning.


ORA-25402

ORA-25402: transaction must roll back

Cause:A failure occurred while a transaction was active on this connection.

Action:The client must roll back.


ORA-25403

ORA-25403: could not reconnect

Cause:The connection to the database has been lost, and attempts to reconnect have failed.

Action:Manually reconnect.


ORA-25404

ORA-25404: lost instance

Cause:The primary instance has died.

Action:This is an internally used error message and should not be seen by the user.


ORA-25405

ORA-25405: transaction status unknown

Cause:A failure occurred while a transaction was attempting to commit. Failover could not automatically determine instance status.

Action:Determine the transaction's status manually.


ORA-25406

ORA-25406: could not generate a backup connect string

Cause:Failover was unable to generate a connect string for a backup instance.

Action:Report this error to Oracle support.


ORA-25407

ORA-25407: died in fetch

Cause:The connection was lost while doing a fetch.

Action:This is an internally used error message and should not be seen by the user.


ORA-25408

ORA-25408: cannot safely replay call

Cause:The connection was lost while doing this call. It may not be safe to replay it after failover.

Action:Check to see if the results of the call have taken place, and then replay it if desired.


ORA-25425

ORA-25425: connection lost during rollback

Cause:The connection was lost while issuing a rollback.

Action:If the transaction is not externally coordinated, then Oracle implicitly rolled back, so no action is required. Otherwise examine PENDING_TRANS$ to determine if ROLLBACK FORCE is required.


ORA-25426

ORA-25426: remote instance does not support shared dblinks

Cause:A shared DBLINK is being used to connect to a remote instance that does not support this feature because it is an older version.

Action:Use a normal DBLINK if you need to connect to this instance.


ORA-26000

ORA-26000: partition load specified but table name is not partitioned

Cause:The Loader control file contains a PARTITION clause but the table being loaded is not partitioned.

Action:Remove the partition specification from the SQL*Loader control file and retry the load.


ORA-26001

ORA-26001: index name specified in SORTED INDEXES does not exist on table %s

Cause:A nonexistent index was specified in the SORTED INDEXES clause.

Action:Specify an existing index as a SORTED INDEX and retry the operation.


ORA-26002

ORA-26002: table name has index defined upon it.

Cause:Parallel load was specified into a table which has an index defined on it.

Action:Do one of the following:

drop index(es) defined on the table

do not use parallel load

use SKIP_INDEX_MAINTENANCE option


ORA-26003

ORA-26003: error fetching results of SELECT statement (rpi): [name]

Cause:See Action statement.

Action:Check the accompanying ORACLE error message for more information.


ORA-26004

ORA-26004: tables loaded through the direct path may not be clustered

Cause:An attempt was made to load a clustered table using the direct path.

Action:Retry the operation using the conventional path.


ORA-26005

ORA-26005: table name does not exist

Cause:The specified table does not exist.

Action:Make sure the table exists and that you have privileges on it.


ORA-26007

ORA-26007: for INSERT option, table must be empty. Error on table name

Cause:An attempt was made to use the INSERT option on a non-empty table.

Action:Empty the table from SQL*Plus, or use the REPLACE option.


ORA-26008

ORA-26008: NOT NULL column name has a NULLIF clause

Cause:A column which is NOT NULL in the database has a SQL*Loader NULLIF clause on it.

Action:Remove the NULLIF clause in the SQL*Loader control file.


ORA-26009

ORA-26009: NOT NULL column name has a DEFAULTIF clause which may evaluate to NULL

Cause:A column which is NOT NULL in the database has a SQL*Loader DEFAULTIF clause which may evaluate to NULL.

Action:Remove the DEFAULTIF clause in the SQL*Loader control file.


ORA-26010

ORA-26010: column name in table name is NOT NULL and is not being loaded

Cause:A column which is NOT NULL in the database is not being loaded and will cause every row to be rejected.

Action:Load the column by specifying the NOT NULL column in the INTO TABLE clause in the SQL*Loader control file.


ORA-26011

ORA-26011: tables loaded through the direct path may not be object tables

Cause:An attempt was made to load an object table using the direct path.

Action:Retry the operation using the conventional path.


ORA-26012

ORA-26012: tables loaded through the direct path may not have object columns

Cause:User attempted to load a table with an object column using the direct path.

Action:Retry the operation using the conventional path.


ORA-26013

ORA-26013: tables loaded through the direct path may not be nested

Cause:An attempt was made to load a nested table using the direct path.

Action:Retry the operation using the conventional path.


ORA-26014

ORA-26014: tables loaded through the direct path may not have REF columns

Cause:An attempt was made to load a table with a REF column using the direct path.

Action:Retry the operation using the conventional path.


ORA-26015

ORA-26015: tables loaded through the direct path may not have array columns

Cause:An attempt was made to load a table with an array column using the direct path.

Action:Retry the operation using the conventional path.


ORA-26016

ORA-26016: record name: rejected - error on table name, partition name

Cause:The record indicated caused an ORACLE error on insert.

Action:Determine the ORACLE error and correct the record. The offending column(s) are not known.


ORA-26017

ORA-26017: global indexes not allowed on direct path partition load, table name

Cause:Global indexes are defined on a table when direct path loading a single partition of the table.

Action:Remove the global index from the named table and retry the operation.


ORA-26018

ORA-26018: column name in table name does not exist

Cause:The column specified in the loader control file does not exist.

Action:Ensure that the column exists and that you have privileges on it. Correct the loader control file if it is incorrect.


ORA-26019

ORA-26019: column name in table name of type name not supported by direct path

Cause:The specified column of SQL column type name is not supported by the direct path loader.

Action:If the column is NULLable, remove it from the control file description. Then it will be loaded as a NULL.


ORA-26020

ORA-26020: index name.name loaded successfully with name keys

Cause:Non-partitioned index information was successfully added to the log file.

Action:No action required. This is an informational message only.


ORA-26021

ORA-26021: index name.name partition name loaded successfully with name keys

Cause:Partitioned index information was successfully added to the loader log file.

Action:No action required. This is an informational message only.


ORA-26022

ORA-26022: index name.name was made unusable due to:

Cause:A non-partitioned index was made index unusable due to the error displayed in the accompanying error message.

Action:Depending on the error, either rebuild the index, or drop and re-create it.


ORA-26023

ORA-26023: index name.name partition name was made unusable due to:

Cause:A partition of a partitioned index was made index unusable due to error displayed in the accompanying error message.

Action:Depending on the error, either rebuild the index partition, or drop and re-create the entire index.


ORA-26024

ORA-26024: SKIP_UNUSABLE_INDEXES requested and index segment was initially unusable

Cause:The SKIP_UNUSABLE_INDEXES option was specified and the index segment was in an unusable state prior to the beginning of the load.

Action:This is an informational message only. You will need to do one of the following: rebuild the index or index partition re-create the index


ORA-26025

ORA-26025: SKIP_INDEX_MAINTENANCE option requested

Cause:A request was made that index maintenance be skipped on a direct path load.

Action:The listed index was put into Index Unusable state due to a request that index maintenance be skipped. You will need to do one of the following:

rebuild the index or index partition

re-create the index


ORA-26026

ORA-26026: unique index name.name initially in unusable state

Cause:A unique index is in IU state (a unique index cannot have index maintenance skipped by using the SKIP_UNUSABLE_INDEXES option).

Action:Either rebuild the index or index partition, or use SKIP_INDEX_MAINTENANCE if the client is SQL*Loader.


ORA-26027

ORA-26027: unique index name.name partition name initially in unusable state

Cause:A partition of a unique index is in IU state (a unique index cannot have index maintenance skipped by using the SKIP_UNUSABLE_INDEXES option).

Action:Either rebuild the index or index partition, or use SKIP_INDEX_MAINTENANCE if the client is SQL*Loader.


ORA-26028

ORA-26028: index name.name initially in unusable state

Cause:An index is in IU state prior to the beginning of a direct path load, it cannot be maintained by the loader.

Action:Either rebuild the index, re-create the index, or use either SKIP_UNUSABLE_INDEXES or SKIP_INDEX_MAINTENANCE (Sql*Loader only).


ORA-26029

ORA-26029: index .name partition name initially in unusable state

Cause:A partition of an index is in IU state prior to the beginning of a direct path load; it cannot be maintained by the loader.

Action:Either rebuild the index partition, re-create the index, or use either SKIP_UNUSABLE_INDEXES or SKIP_INDEX_MAINTENANCE (Sql*Loader only).


ORA-26030

ORA-26030: index name.name had name partitions made unusable due to:

Cause:A logical index error occurred on a partitioned index which affected one or more index partitions, which are listed in an accompanying error message.

Action:The affected index partitions will have to be re-built, or, the entire index dropped and re-created.


ORA-26031

ORA-26031: index maintenance error, the load cannot continue

Cause:A index error occurred during the index maintenance phase of a direct path load. The load cannot continue. See the accompanying error message.

Action:See the accompanying error message for more information.


ORA-26032

ORA-26032: index name.name loading aborted after name keys

Cause:An index error occurred during direct-load of an index-organized table. Loading had to be aborted. No rows were loaded.

Action:Check the key just following the number of keys mentioned above. This key caused the index problem mentioned in an earlier message.


ORA-26100

ORA-26100: unused error

Cause:This error is not used.

Action:No action required.


ORA-26101

ORA-26101: tablespace # in file header is %s rather than %s for file %s

Cause:The tablespace number in the file header is inconsistent with the tablespace number in the control file.

Action:Check if the control file has been migrated correctly. Retry with the correct control file and data file.


ORA-26102

ORA-26102: relative file # in file header is %s rather than %s for file %s

Cause:The relative file number in the file header is inconsistent with the relative file number in the control file.

Action:Check if the control file has been migrated correctly. Retry with the correct control file and data file.


ORA-26103

ORA-26103V6 or V7 data file used to create control file

Cause:The file header of the referenced file is in V6 or V7 format.

Action:Either remove the file from the CREATE CONTROL FILE command, or somehow migrate the file header to V8 format.


ORA-26500

ORA-26500 error on caching name.name

Cause: Attempt to cache the replication information which is unavailable in the catalog for the object.

Action: Use DBMS_REPUTIL.SYNC_UP_REP to validate the replication catalog.


ORA-26501

ORA-26501RepAPI operation failure

Cause: An external RepAPI operation failed.

Action: Consult detail error message.


ORA-26502

ORA-26502 error resignal

Cause: An internal service failed and signalled an error.

Action: Consult the detailed error message which accompanies this one.


ORA-26503

ORA-26503 internal RepAPI operation failure on object name.name

Cause: An unexpected internal RepAPI failure was detected.

Action: Contact Oracle Worldwide Support.


ORA-26504

ORA-26504:operation not implemented

Cause: The caller requested a RepAPI operation that was not implemented.

Action: Do not issue this call.


ORA-26505

ORA-26505 unexpected internal NULL

Cause: An internal buffer control structure was NULL.

Action: Verify that sufficient memory resources are available to RepAPI.


ORA-26506

ORA-26506NULL global context

Cause: An internal buffer control structure was NULL.

Action: Verify that sufficient memory resources are available to RepAPI.


ORA-26507

ORA-26507NULL master connection

Cause: The master connection handle was or became invalid.

Action: Verify that the master connection is valid. Then retry the operation.


ORA-26508

ORA-26508 NULL snapshot connection

Cause: The client connection handle was or became invalid.

Action: Verify that the client connection is valid.


ORA-26509

ORA-26509NULL snapshot control structure

Cause: An internal snapshot control structure could not be obtained.

Action: Check that the owner and users provided are correct.


ORA-26510

ORA-26510snapshot name: name is greater than max. allowed length of num bytes

Cause: The specified snapshot name was too long.

Action: Shorten the snapshot name.


ORA-26511

ORA-26511master table name.name not found

Cause: A RepAPI operation was attempted against a non-existent or invalid master table.

Action: Verify that the master table object exists.


ORA-26512

ORA-26512error pushing transaction to DEF$ERROR

Cause: An unexpected error occurred while sending an DEF$ERROR RPC to the master site.

Action: Verify that the DBMS_DEFER package is valid and executable by the RepAPI client. Contact the local ormaster site administrator, if necessary.


ORA-26513

ORA-26513push error: master proc. name$RP.name failed for trans:name seq:name

Cause: A conflict/error occurred at the master site while executing a $RP.rep_insert(), rep_update(), or rep_delete() function which was not handled by conflict resolution logic at the master.

Action: Notify master site system administrator or DBA.


ORA-26514

ORA-26514object name.name not found

Cause: The specified object was expected but not found.

Action: Verify that the specified object exists and is valid.


ORA-26515

ORA-26515no master log available for name.name

Cause: The specified master log was not found or available for the named table.

Action: Create the master log at the master site or correct any problems that may exist with the log.


ORA-26516

ORA-26516 no push transaction acknowledgment

Cause: RepAPI was unable to confirm that the last pushed transaction was successfully committed by the master site.

Action: Verify that the communications link between the local site and the master site is still valid. If the transaction has not been committed at the master, repush the transaction.


ORA-26517

ORA-26517snapshot control entry for name.name was not found

Cause: The specified snapshot catalog control record was not found.

Action: Verify that the local snapshot catalog is valid and that the local snapshot is properly defined.


ORA-26518

ORA-26518push queue synchronization error detected

Cause:Client tried to repush a transaction has already been committed at the master site. A common cause of this problem is an error at the local site in initializing or updating the local site transaction sequence mechanism.

Action: Verify that transaction data that RepAPI was attempting to repush to the master site exists at the master table and is valid and consistent with the local site. If this error occurs, redundantly identified transactions are ignored and then purged from the local updatable snapshot logs. Check that the local site is correctly assigning new transaction IDs and is not accidentally generating non-unique values.


ORA-26519

ORA-26519no memory available to allocate

Cause:There was no memory left for the RepAPI process. This error may occur when RepAPI is trying to allocate a new table buffer area.

Action:Shutdown one or more local applications to attempt to free heap memory and retry the RepAPI operation.


ORA-26520

ORA-26520internal memory failure

Cause: An internal memory error was detected.

Action: Check if other errors have occurred or determine if any local application may have corrupted the memory subsystem.


ORA-26521

ORA-26521RPC initialization error

Cause: An error occurred during the initialization of a PL/SQL RPC.

Action: Verify that the procedure to be invoked exists and is valid at the master site and is executable by the RepAPI user.


ORA-26522

ORA-26522RPC execution error

Cause: An error occurred during the execution of a PL/SQL RPC.

Action: Check the error messages from the remote procedure and fix any remote site problems that may be preventing the execution of the invoked RPC.


ORA-26523

ORA-26523RPC termination error

Cause: An error occurred during the termination of a PL/SQL RPC. This is usually caused by master site being unable to close an opened cursor or if RepAPI cannot deallocate internal memory.

Action: Fix any server side problems first, determine if the RepAPI memory subsystem has been corrupted.


ORA-26524

ORA-26524NLS subsystem initialization failure for product=name, facility=name

Cause:The NLS product/facility error message file could not be located or properly initialized.

Action: Check that the error message directory and file(s) have been properly installed.


ORA-26525

ORA-26525: session connection attempt failed for name (@name)

Cause: A connection could not be established to the specified database using the provided connection string.

Action: Check that the user, password, connect string, names services, network, and any remote site listener process are properly installed and working.


ORA-26526

ORA-26526snapshot SQL DDL parse/expansion failed for name.name

Cause: The client SQL snapshot definition query could not be properly parsed by the master Oracle site.

Action: Check that snapshot DDL SQL is compatible with the currently connected version of Oracle and does not violate any of the RepAPI SQL limitations or restrictions.


ORA-26527

ORA-26527local store callback init phase failed for name.name

Cause: The client callback failed during its INIT phase for the named object.

Action: Verify that the objects referenced by the client callback exist and are valid. Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error states and notify Oracle Worldwide Support.


ORA-26528

ORA-26528local store callback proc phase failed for name.name

Cause: The client callback failed during its PROC phase for the named object.

Action: Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error state and notify Oracle Worldwide Support.


ORA-26529

ORA-26529local store callback term phase failed for name.name

Cause: The client callback failed during its TERM phase for the named object.

Action: Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error state and notify Oracle Worldwide Support.


ORA-26530

ORA-26530unable to build snapshot refresh control list

Cause: The snapshot control list could not be constructed. This is generally the result of an error while accessing the local snapshot catalog.

Action: Verify that the named snapshot(s) are properly defined and valid. Then retry the operation


ORA-26531

ORA-26531replication parallel push failure recovery test event

Cause: N/A.

Action: Event used to simulate site failure for parallel push testing.


ORA-26532

ORA-26532replication parallel push simulated site failure

Cause: A parallel push executed with the event ORA-26531 enabled raises this error to simulation failure of network or destination site.

Action: Do not enable the event for normal operation.


ORA-26534

ORA-26534collision: tranID num ignored and purged

Cause: A transaction that was pushed had a transaction ID that collided with a transaction that was previously pushed and committed at the master site.

Action: See the Action section for E_QUEUESYNC (ORA-26518).


ORA-26535

ORA-26535num byte row cache insufficient for table with rowsize=num

Cause:A transaction that was pushed had a transaction ID that collided with a transaction that was previously pushed and committed at the master site.

Action: Increase the RepAPI row buffer size or reduce the width of the replicated tables.


ORA-26536

ORA-26536refresh was aborted because of conflicts caused by deferred transactions

Cause: There are outstanding conflicts logged in the DEFERROR table at the snapshot's master site.

Action: Do one of the following:

Resolve the conflicts in the master DEFERROR table and refresh again after the table is empty.

Refresh with REFRESH_AFTER_ERRORS, even if there are conflicts in the master site's DEFERROR table. If you proceed even with existing conflicts, an updatable snapshot's changes could appear to be temporarily lost. A refresh that succeeds after the conflicts are resolved should restore the changes.


ORA-26563

ORA-26563 renaming this table is not allowed

Cause: An attempt was made to rename a replicated table, an updatable snapshot table, or the master table of a snapshot for which a snapshot log has been created.

Action:If desired, unregister the replicated table with DBMS_REPCAT.DROP_MASTER_REPOBJECT, or use the recommended procedure to rename the master table of a snapshot.


ORA-26564

ORA-26564 %s argument is not of specified type

Cause: The passed type of the given argument number does not match the type of the argument in the stored arguments.

Action: Invoke the correct type procedure (that is, GET_XXX_ARG).


ORA-26565

ORA-26565 call to <type>_ARG made before calling DBMS_DEFER.CALL

Cause: An attempt was made to invoke the <type>_ARG procedure before starting a deferred call.

Action: Invoke the needed procedures in the correct order.


ORA-26566

ORA-26566could not open connect to name

Cause: Failed to open connection using given DBLINK.

Action: Make sure that the DBLINK is valid and remote m/c is up.


ORA-27501

ORA-27501IPC error creating a port

Cause:OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27502

ORA-27502IPC error setting up signal handler

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27504

ORA-27504IPC error querying network address of a port

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27506

ORA-27506IPC error connecting to a port

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27507

ORA-27507IPC error disconnecting from a port

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27508

ORA-27508 IPC error sending a message

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27509

ORA-27509IPC error receiving a message

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27510

ORA-27510IPC error waiting for a request to complete

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27512

ORA-27512IPC error posting a process

Cause: OS system call error.

Action: Check errno and contact Oracle Worldwide Support.


ORA-27528

ORA-27528 cannot allocate communication buffers of zero size

Cause: Client tried to allocate a zero length message.

Action: Refer to kgxp.h for information on the usage of kgxpvalo().


ORA-27529

ORA-27529cannot allocate zero sized communication buffers

Cause: Client tried to allocate a zero length message.

Action: Refer to kgxp.h for information on the usage of kgxpvalo().


ORA-27530

ORA-27530cannot deallocate pointer to NULL memory

Cause: Client passed in a NULL pointer for deallocation.

Action: Refer to kgxp.h for information on the usage of kgxpvfre().


ORA-27531

ORA-27532

ORA-27532IPC global name service is not supported

Cause:The global name service used by KGXP is not supported.

Action:Either use a different name service, of abort the current process/thread.


ORA-27532

ORA-27531

ORA-27531cannot destroy invalid port

Cause: The specified port is invalid.

Action: Recreate the port.


ORA-27533

ORA-27533 trying to destroy invalid connection identifier

Cause: The connection identifier passed in is invalid.

Action: Check the connection identifier, or abort the process/thread.


ORA-27534

ORA-27534 cannot send unaligned message

Cause: The message that was sent is not aligned on the required boundaries.

Action: Use the KGXPALSZ() macro to get the alignment size of messages, and align all messages on this boundary.


ORA-27535

ORA-27535exceeded the maximum vectored message size

Cause: An attempt was made to send a vectored message that exceeds the maximum vector size.

Action: Use a smaller vector size.


ORA-27536

ORA-27536multicast message is not aligned on the correct boundary

Cause: The message to multi-cast was not aligned on the proper boundary.

Action: Align the message appropriately.


ORA-27537

ORA-27537 cannot receive messages into unaligned buffers

Cause: The message that was posted for receive is not aligned on the required boundary.

Action: Use the KGXPALSZ() macro to get the alignment size of messages, and align all messages on this boundary.


ORA-27538

ORA-27538 failed to added accept handle to the free pool

Cause: Could not add an accept handle to the free pool.

Action: Exit the process.


ORA-27539

ORA-27539accept handle free pool is empty. Cannot accept new connections

Cause: The free pool of accept handles is empty.

Action: Add accept handles to the free pool.


ORA-27540

ORA-27540 no more communication channels can be created for process/thread. Already at maximum

Cause: The maximum communication channels that were specified are already in use for this process/thread.

Action: Destroy connections which are not needed.


ORA-27541

ORA-27541 fatal error trying to connect to remote port

Cause: Either the remote address was not valid, or the process was faulty.

Action: Destroy all connections, and try to re-establish them.


ORA-27542

ORA-27542 failed trying to queue up accept handles

Cause: The OSD would not allow KGXP to queue up the storage necessary to accept new incoming connections.

Action: Check the parameters, if they are OK, then abort the process.


ORA-27543

ORA-27543 cannot cancel an outstanding request

Cause: The OSD could not cancel an outstanding request immediately.

Action: Shutdown all connections and abort the process.


ORA-27544

ORA-27544memory mapped communication is not supported

Cause: The platform does not support memory communication.

Action: Use the default send/receive.


ORA-28000

ORA-28000the account is locked

Cause: Either the wrong password was entered the maximum number of times specified by the profile parameter FAILED_LOGIN_ATTEMPTS, or else the DBA has locked the account.

Action: Wait for PASSWORD_LOCK_TIME or contact the DBA.


ORA-28001

ORA-28001 the account has expired

Cause: The account has expired and the password needs to be changed.

Action: Change the password or contact the DBA.


ORA-28002

ORA-28002the account will expire within num days

Cause: The account is about to about to expire and the password needs to be changed.

Action: Change the password or contact the DBA.


ORA-28003

ORA-28003 password verification for the specified password failed

Cause: The new password did not meet the necessary complexity specifications and the PASSWORD_VERIFY_FUNCTION failed.

Action: Enter a different password. Contact the DBA to find out the rules for choosing the new password.


ORA-28004

ORA-28004 invalid argument for function specified in PASSWORD_VERIFY_FUNCTION name

Cause: The password verification function did not have the required number and type of input/output arguments and/or the return argument.

Action: Check the Server Reference manual to find out the format of the password verification function.


ORA-28005

ORA-28005 invalid logon flags

Cause: The logon flags were not properly set or else conflicting flags were set in making calls.

Action: Call the function with appropriate flags set.


ORA-28006

ORA-28006 conflicting values for parameters name and name

Cause:The parameters PASSWORD_REUSE_TIME and PASSWORD_REUSE_MAX were both set. One parameter should be unlimited while other is set.

Action: Set the value of one parameter to UNLIMITED explicitly.


ORA-28007

ORA-28007 the password cannot be reused

Cause:An attempt was made to reuse password after the specified number of days or after the specified number of password changes.

Action:Try the password that has not been used for the specified number of days or the specified number of password changes. Refer to the password parameters in the CREATE PROFILE statement.


ORA-28008

ORA-28008 cannot authenticate user; password cannot be changed

Cause:The old password that was supplied is wrong. Authentication cannot proceed using the old password.

Action:Supply the correct old password for authentication and retry the operation.


ORA-28009

ORA-28009connection to SYS should be as SYSDBA or SYSOPER

Cause:CONNECT SYS/<password> ORA-is no longer a valid syntax.

Action:Try CONNECT SYS/<password> ORA-AS SYSDBA or CONNECT SYS/<password>ORA-AS SYSOPER.


ORA-28010

ORA-28010 cannot expire external or global accounts

Cause:If a user account is created as IDENTIFIED EXTERNALLY, or IDENTIFIED GLOBALLY, this account cannot be expired.

Action: Try to expire the password of the user that has database password.


ORA-28020

ORA-28020 IDENTIFIED GLOBALLY already specified

Cause: The IDENTIFIED GLOBALLY clause was specified twice.

Action: Use only one IDENTIFIED GLOBALLY clause.


ORA-28021

ORA-28021 cannot grant global roles

Cause: A role granted was IDENTIFIED GLOBALLY. Global roles can only be granted via a central authority for the domain.

Action: Use ALTER ROLE to change the type of role (from IDENTIFIED GLOBALLY to other, such as IDENTIFIED BY password), or allocate it to a global user via the central authority.


ORA-28022

ORA-28022 cannot grant external roles to global user or role

Cause: A role granted was IDENTIFIED EXTERNALLY. External roles cannot be granted to global users or global roles.

Action: Use ALTER ROLE to change the type of the role being granted (from IDENTIFIED EXTERNALLY to other, such as IDENTIFIED BY password), or use ALTER ROLE or ALTER USER to change the type of the user or role that is the grantee.


ORA-28023

ORA-28023 must revoke grants of this role to other user(s) first

Cause: The role altered to IDENTIFIED GLOBALLY was granted to one or more other users and/or roles. Global roles cannot be granted to any user or role.

Action: Use REVOKE to revoke the role from other users or roles first.


ORA-28024

ORA-28024 must revoke grants of external roles to this role/user

Cause: The user or role altered to IDENTIFIED GLOBALLY has external roles directly granted - these must be revoked, since external roles cannot be granted to global users or roles.

Action: Use REVOKE to revoke the external roles from the user or role to be ALTERed.


ORA-28025

ORA-28025 missing or null external name

Cause: The IDENTIFIED EXTERNALLY AS or IDENTIFIED GLOBALLY AS clause was specified with a valid external name.

Action: Provide a valid external name.


ORA-28027

ORA-28027 privileged database links may be used by global users

Cause: Only users IDENTIFIED GLOBALLY may use a privileged database link.

Action: Either change the user to a global user or try to use a different database link.


ORA-28028

ORA-28028 could not authenticate remote server

Cause: During the course of opening a privileged database link, the remote server was not securely identified using the network security service. Additional errors should follow.

Action: Consult the network security service documentation on how to properly configure the remote server.


ORA-28029

ORA-28029 could not authorize remote server for user name

Cause: During the course of opening a privileged database link, the remote server was found to lack the necessary authorizations to connect as the current global user. This may be because the server was not authorized by the network security service. Or it may be because the local server is restricting access by the remote server using the DBMS_SECURITY_DOMAINS_ADMIN package.

Action: Grant the remote server the proper authorization to connect as the given global user, and check that the local server is not restricting access.


ORA-28501

ORA-28501 communication error on heterogeneous database link

Cause: An unexpected communication failure occurred on a heterogeneous database link to a non-Oracle system. The message above will be followed by a second message generated by the connected non-Oracle system.

Action: See the documentation for the non-Oracle system for an explanation of the second error message.


ORA-28502

ORA-28502 internal communication error on heterogeneous database link

Cause: A communication error internal to ORACLE's heterogeneous services has occurred. This should normally not occur.

Action: Contact Oracle Worldwide Support.


ORA-28503

ORA-28503 bind value cannot be translated into SQL text for non-Oracle system

Cause: There are two possible causes. Either:

the non-Oracle system connected on a heterogeneous database link does not support binds

binds have been disabled with the RESOLVE_BINDS initialization parameter.

Action:Enable binds by setting the RESOLVE_BINDS initialization parameter to TRUE, or try to transform your SQL statement so that it does not use bind variables.


ORA-28504

ORA-28504 ROWID not found in rowid cache for heterogeneous database link

Cause: The rowid cache for Heterogeneous Services holds no entry that corresponds to the specified ROWID. Possibly the ROWID entry was overwritten in the rowid cache.

Action: Enlarge the Heterogeneous Services ROWID cache size by increasing the value of the initialization parameter ROWID_CACHE_SIZE.


ORA-28505

ORA-28505 unable to get non-Oracle system capabilities from name

Cause: ORACLE was unable to retrieve capability information for the non-Oracle system connected through a heterogeneous database link. This capability information should be stored in data dictionary tables viewable with the HS_CLASS_CAPS data dictionary view.

Action: Verify that AGENT_ID and FDS_ID are set correctly in the Net8 service name definition used by the heterogeneous database link. The Net8 service name is defined in the TNSNAMES.ORA configuration file or in the Oracle Names Server. If these are correct, verify correct installation of Heterogeneous Services data dictionary information stored in dictionary tables viewable with the HS_CLASS_CAPS view.


ORA-28506

ORA-28506 parse error in data dictionary translation for name stored in name

Cause: A reference to an ORACLE Data Dictionary table or view name on a heterogeneous database link to a non-Oracle system cannot be translated. The ORACLE Data Dictionary tables viewable with view HS_CLASS_DD contains invalid SQL for the data dictionary translation.

Action: Contact customer support of the agent vendor.


ORA-28507

ORA-28507 error in DD table name, when processing Heterogeneous Services initialization parameters

Cause: Initialization parameter table for the Heterogeneous Services does not exist, or its structure (number of columns or column types) is incorrect.

Action: Verify correct installation of Heterogeneous Services' initialization parameter views, HS_CLASS_INIT and HS_INST_INIT. If these are not available, make sure you ran the script CATHO.SQL in the $ORACLE_HOME/rdbms/admin directory.


ORA-28508

ORA-28508 invalid value name for Heterogeneous Services initialization parameter name

Cause: The value of the named Heterogeneous Services initialization parameter, as stored in the Oracle data dictionary, is not valid.

Action: Check Heterogeneous Services documentation to determine acceptable values and update that parameter in HS_INST_INIT using the procedures in the DBMS_HS package.


ORA-28509

ORA-28509unable to establish a connection to non-Oracle system

Cause:Initialization of a database link to a non-Oracle system failed to connect to the Heterogeneous Services agent process for this non-Oracle system.

Action:Check the Net8 service name definition in the following places:

in the USING clause of the CREATE DATABASE LINK statement

in the TNSNAMES.ORA file

in the Oracle Names Server

Possible reasons for name mismatches are:

The USING clause in the CREATE DATABASE LINK statement has to match the service name defined in TNSNAMES.ORA or in the Oracle Names Server

The service name definition to connect to a non-Oracle system, requires additional Heterogeneous Services information. This information is agent specific. Please see the agent's Installation and User's Guide for more information.

The protocol-specific information in the service name definition must match the protocol-specific definition of the listener.

bmc bullet.bmp} The SID=<name> in the service name definition (TNSNAMES.ORA file or in Oracle Names Server) must match the value in the LISTENER.ORA file for the responding listener.


ORA-28510

ORA-28510 heterogeneous database link initialization failed

Cause: Initialization of a heterogeneous database link to a non-Oracle system failed due to an error identified by the agent for this non-Oracle system.

Action: Make sure the non-Oracle system is up and running and that all of the environment and initialization values for the agent are set correctly.


ORA-28511

ORA-28511 lost RPC connection to heterogeneous remote agent using SID=num

Cause:A fatal error occurred in one of the following:

the connection between the ORACLE server and the agent

the heterogeneous services remote agent itself

the connection to the non-Oracle system.

This error occurred after communication had been established successfully.

Action:Check first for network problems and remote host crashes. Most likely this is problem in the agent software. Contact a customer support representative of the agent vendor


ORA-28512

ORA-28512 error while retrieving heterogeneous DD translation information from name

Cause: Either the data dictionary transparency table does not exist, or its structure (number of columns or column types) is incorrect.

Action: Verify that AGENT_ID and FDS_ID, referenced by the database link definition, are set correctly in the Net8 service name definition. If these are correct, verify that the Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHO.SQL script in the $ORACLE_HOME/rdbms/admin directory.


ORA-28513

ORA-28513 internal error in heterogeneous remote agent

Cause: An internal error has occurred in the Oracle remote agent supporting a heterogeneous database link.

Action: Make a note of how the error was produced and contact the customer support representative of the agent vendor.


ORA-28514

ORA-28514 heterogeneous database link initialization could not convert system date

Cause: The system date is not currently retrievable.

Action: Verify the system date.


ORA-28515

ORA-28515 unable to get heterogeneous definitions from name

Cause: ORACLE was unable to retrieve definitions of distributed external procedures or remote libraries registered for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is malformed.

Action: Verify that AGENT_ID and FDS_ID are set correctly in the database link's connect parameters, or in the TNSNAMES.ORA entry referenced by the link definition. If these are correct, verify that the Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHO.SQL script in the $ORACLE_HOME/rdbms/admin directory.


ORA-28518

ORA-28518 data dictionary translation has illegal translation type

Cause: This error can occur when running a script from the agent vendor to install the data dictionary information. A data dictionary translation specifies an illegal translation type code. Legal values are 'T' or 't' for 'translate', 'M' or 'm' for 'mimic'. Information on the exact data dictionary translation causing the error is written to a trace (.TRC) file for the ORACLE instance and to the ORACLE instance's alert log.

Action: Contact the customer support of the agent vendor.


ORA-28519

ORA-28519 no heterogeneous data dictionary translations available

Cause: The ORACLE Server's data dictionary does not define data dictionary translations for the connected non-Oracle system. The connected agent does not enable self-registration (automatic data dictionary upload).

Action: Make sure you ran the script to load the heterogeneous service data dictionary with information specific for the non-Oracle system. This script is provided by the agent vendor. If the script is run and the error persists, contact the customer support representative of the agent vendor.


ORA-28520

ORA-28520 error initializing data dictionary translations

Cause:ORACLE was unable to retrieve data dictionary translations for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is malformed.

Action:Verify that AGENT_ID and FDS_ID are set correctly in the Net8 service name definition, which is used in the database link definition. If these are correct, verify the following:

The Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, run the CATHO.SQL script in the $ORACLE_HOME/rdbms/admin directory.

You executed the script to load the Heterogeneous Service data dictionary with information specific for the non-Oracle system. This script is provided by the agent vendor.

If both scripts are executed and the error persists, contact the customer support representative of the agent vendor.


ORA-28521

ORA-28521 no heterogeneous capability information available

Cause: The ORACLE kernel's data dictionary does not contain capabilities for the connected non-Oracle system. The connected agent does not enable self-registration.

Action: Make sure the script to load the Heterogeneous Service data dictionary with information specific for the non-Oracle system was executed. This script is provided by the agent vendor. If the script is executed and the error persists, contact the customer support representative of the agent vendor.


ORA-28522

ORA-28522 error initializing heterogeneous capabilities

Cause: An attempt to read capability definitions for a non-Oracle system from the ORACLE instance's data dictionary failed.

Action: Verify that AGENT_ID and FDS_ID are set correctly in the Net8 service name definition, which is used in the database link definition. If these are correct, verify

The correct installation of Heterogeneous Services data dictionary. If the Heterogeneous Services data dictionary is not installed, execute the CATHO.SQL script in the $ORACLE_HOME/rdbms/admin directory.

You executed the script to load the Heterogeneous Service data dictionary with information specific for the non-Oracle system. This script is provided by the agent vendor.

If the both scripts are run and the error persists, contact the customer support representative of the agent vendor.


ORA-28523

ORA-28523 ORACLE and heterogeneous agent are incompatible versions

Cause:An operation on a database link attempted to connect to a non-Oracle system. The ORACLE instance and the remote agent process for the non-Oracle system are incompatible.

Action:Ask your DBA to confirm configuration of both the ORACLE instance and the agent. Additional information on the version incompatibility is logged in trace (.TRC) files, the ORACLE instance and the agent, and in the ORACLE instance's alert log. Check the Installation and User's Guide of your agent to find out what releases of the Oracle Server are supported.


ORA-28524

ORA-28524 invalid max length specified for heterogeneous table column

Cause:Heterogeneous Services sets the maximum length of long columns to what the client defines. If the Heterogeneous Services receives a length that is not in the range of values it can handle, then this error will be signaled. This error normally should not be raised.

Action:Contact Oracle Worldwide Support.


ORA-28525

ORA-28525: unable to create Heterogeneous Services error message text

Cause:Incorrect arguments were passed into the error message creation routine. This error normally should not be raised.

Action:Contact Oracle Worldwide Support.


ORA-28526

ORA-28526 invalid describe information returned to Heterogeneous Services

Cause: The Heterogeneous Services received invalid describe information for a select list, bind list, or stored procedure from the Heterogeneous Services agent. This indicates a problem with the Heterogeneous Services' non-Oracle system agent.

Action: Contact customer support of the agent vendor.


ORA-28527

ORA-28527 Heterogeneous Services datatype mapping error

Cause: Mappings between Oracle datatypes and non-Oracle system datatypes are stored in the capability table in the data dictionary. This error could be raised for one of these reasons:

the Oracle datatype cannot be mapped onto an non-Oracle datatype system

a non-Oracle system datatype cannot be mapped onto an Oracle datatype.

Action:Make sure that the script to load the heterogeneous service data dictionary was executed with information specific for the non-Oracle system. This script contains datatype capability information. This script is provided by the agent vendor. If the script is executed and the error persists, contact the customer support representative of the agent vendor.


ORA-28528

ORA-28528 Heterogeneous Services datatype conversion error

Cause: The Heterogeneous Services was not able to convert a value from Oracle datatype to a value from the non-Oracle system datatype, or was not able to convert a value from the non-Oracle system datatype to an Oracle datatype. This could be due to one of the following reasons:

overflow problems (in the case of numbers)

length limitations (in the case of character strings)

invalid values passed into the conversion routines

Action:Contact customer support of the agent vendor. If the problem is due to size discrepancies between Oracle and the non-Oracle system, it might not be possible to convert the value.


ORA-28529

ORA-28529 invalid or missing parameter in Net8 service name definition

Cause:There was an invalid or missing Heterogeneous Services parameter in the Net8 service name definition stored in either the TNSNAMES.ORA file or in the Oracle Names server.

Action:Contact your DBA and make sure the information is correct and complete. The correct information that should be included in the Net8 service definition can be found in the agent's Installation and User's Guide.


ORA-28530

ORA-28530 Heterogeneous Services initialization error

Cause:An error occurred when initializing the Heterogeneous Services. This should not normally happen.

Action:Contact Oracle Worldwide Support.


ORA-28531

ORA-28531 HS 2PC mode must be set only by init parameter

Cause:On a Heterogeneous Services database link a setting for the two-phase commit capability (1029) is present for the connected FDS class name and/or instance name. This is supplied in either HS DD content (view HS_CLASS_CAPS or HS_INSTANCE_CAPS), or in equivalent information uploaded from the HS agent for this FDS. This mode can be set ONLY through the 2PC initialization parameter.

Action:If necessary to change the two-phase commit mode for this heterogeneous connection specify the mode ONLY in HS_CLASS_INIT or HS_INST_INIT, using INIT_VALUE_NAME = `2PC' and INIT_VALUE = `SS', `CC', `2P', `PREP', `2PCC', or `RO'.


ORA-28550

ORA-28550 passthrough SQL: cursor not found

Cause:The cursor passed by the function or procedure call is invalid.

Action:Use a cursor number returned by the API OPEN_CURSOR call.


ORA-28551

ORA-28551 passthrough SQL: SQL parse error

Cause:An attempt was made to pass illegal SQL to the non-Oracle system.

Action:Ensure that the SQL supplied to the API parse call is accepted by the non-Oracle system.


ORA-28552

ORA-28552 passthrough SQL: call flow error

Cause:An attempt was made to call a passthrough SQL function in an invalid order.

Action:Correct program flow by changing the order of API calls to match the flow described in the manual.


ORA-28553

ORA-28553 passthrough SQL: API parameter error

Cause:Passthrough parse SQL API: invalid position. A parameter notating the position is out of range.

Action:Verify the parameter is in range with the number of bind variables or select list items.


ORA-28554

ORA-28554 passthrough SQL: out of cursors

Cause:The allowed number of open cursors has been exceeded.

Action:Close open cursors by using Passthrough SQL API close call.


ORA-28555

ORA-28555 passthrough SQL: required parameter missing or null

Cause:An attempt was made to pass a null value to a non-null parameter.

Action:Use a non-null value for the parameter.


ORA-28556

ORA-28556 authorization insufficient to access table

Cause:A query attempted to access a table in the non-Oracle system that is either privileged or has privileged columns.

Action:Contact your DBA. The DBA can grant permission to access the privileged table or columns.


ORA-28557

ORA-28557 name unknown for database link to non-Oracle system

Cause:When attempting to connect to a non-Oracle system through a Heterogeneous Services database link, the agent supporting this non-Oracle system failed to return FDS_CLASS_NAME and/or FDS_INST_NAME. ORACLE requires these names to configure the heterogeneous database link.

Action:Contact your DBA to check setup of the connection and the Heterogeneous Services agent.


ORA-28558

ORA-28558 FDS_CONNECT_STRING undefined for non-Oracle system

Cause:A database link to a non-Oracle system had no FDS_CONNECT_STRING initialization parameter in the ORACLE data dictionary for Heterogeneous Services. Without this parameter the connection could not be completed.

Action:Contact your DBA to verify correct setup of an FDS_CONNECT_STRING entry in the ORACLE Heterogeneous Services data dictionary (see HS_ALL_INITS view in the Oracle8 Server Reference Manual). It might be necessary to use PL/SQL procedures in the SYS.DBMS_HS package to create or replace an entry for the connection's FDS_CLASS_NAME and FDS_INST_NAME.


ORA-28559

ORA-28559 FDS_CLASS_NAME is name, FDS_INST_NAME is name

Cause:This message supplies supplementary information to assist diagnosis of an error reported in another message. FDS_CLASS_NAME and FDS_INST_NAME are used to access information in tables and views of the ORACLE data dictionary which direct operation of Heterogeneous Services on a database link to a non-Oracle Data Store.

Action:Use the FDS_CLASS_NAME and FDS_INST_NAME values to check ORACLE data dictionary contents when necessary to diagnose the cause of the associated error.


ORA-28576

ORA-28576lost RPC connection to external procedure agent

Cause:A fatal error occurred in either an RPC network connection, the extproc agent, or the invoked 3GL after communication had been established successfully.

Action:First check the 3GL code you are invoking, and make sure there are no network problems. Most likely, the invoked "C" routine is terminating abnormally. If all components appear to be normal but the problem persists, this could be an internal logic error in the transfer code. Contact your customer support representative.


ORA-28577

ORA-28577argument name of external procedure name has unsupported datatype name

Cause:While transferring the external procedure arguments to the agent, an unsupported datatype was detected.

Action:Check your documentation for the supported datatypes of external procedure arguments.


ORA-28578

ORA-28578protocol error during callback from an external procedure

Cause:An internal protocol error occurred while trying to execute a callback to the Oracle Server from the user's 3GL routine.

Action:Contact Oracle Worldwide Support.


ORA-28579

ORA-28579network error during callback from external procedure agent

Cause:An internal network error occurred while trying to execute a callback to the Oracle Server from the user's 3GL routine.

Action:Contact Oracle Worldwide Support.


ORA-28580

ORA-28580recursive external procedures are not supported

Cause:A callback from within a user's 3GL routine resulted in the invocation of another external procedure.

Action:Make sure that the SQL executed in a callback does not directly call another external procedure, or indirectly results in another external procedure, for example, triggers calling external procedures, PL/SQL procedures calling external procedures, and so on.


ORA-28581

ORA-28581protocol error while executing recursive external procedure

Cause:An internal protocol error occurred while trying to execute an external procedure resulting from a callback in another external procedure.

Action:Contact Oracle Worldwide Support.


ORA-28582

ORA-28582a direct connection to this agent is not allowed

Cause:A user or a tool tried to establish a direct connection to either an external procedure agent or a Heterogeneous Services agent, for example:

SVRMGR> CONNECT SCOTT/TIGER@NETWORK_ALIAS

This is not allowed.

Action:When executing the CONNECT statement make sure your database link or network alias is not pointing to a Heterogeneous Services agent or an external procedure agent.


ORA-28751

ORA-28751memory allocation failed

Cause:The allocation of memory failed due to exhaustion of system memory.

Action:Terminate other processes to free up memory or add memory to the system.


ORA-28752

ORA-28752failed to initialize data source

Cause:The initialization of a data source failed.

Action:Enable Net8 tracing to determine the exact cause of the error. Frequently, this error is caused by the exhaustion of system resources.


ORA-28753

ORA-28753failed to terminate use of data source

Cause:The termination of the use of a data source failed.

Action:Enabled Net8 tracing to determine the exact cause of the error. The error may be caused by the corruption of memory or disk, among other things.


ORA-28755

ORA-28755object retrieval failed

Cause:There was a failure to retrieve subject information from a file or database.

Action:Check if the data source exists or check for the correct subject information.


ORA-28756

ORA-28756callback failed to allocate memory

Cause:A function supplied by the caller failed to allocate memory.

Action:This error could be due to system memory exhaustion.


ORA-28757

ORA-28757attempted to allocate 0 bytes of memory

Cause:Memory has been exhausted.

Action:This error could be due to system memory exhaustion.


ORA-28758

ORA-28758memory release failed

Cause:The release of memory fragment failed. This may be caused by corruption of memory either within the application or the Oracle Security Server library.

Action:Enable Net8 tracing to determine the reason why the operation failed.


ORA-28759

ORA-28759failed to open file

Cause:The opening of the specified file failed.

Action:Enable Net8 tracing to determine the name of the file that could not be opened and the reason.


ORA-28763

ORA-28763invalid parameter type

Cause:Possible error in parameter in SQLNET.ORA.

Action:Check the SQLNET.ORA file for this parameter value.


ORA-28764

ORA-28764configuration parameter retrieval failed

Cause:The retrieval of a configuration parameter failed.

Action:Supply the needed configuration parameter.


ORA-28766

ORA-28766failed to terminate use of data source

Cause:An error occurred when attempting to end use of a data source. This could be due to a system error.

Action:Enable tracing to see what the exact error is.


ORA-28767

ORA-28767invalid version number

Cause:Version number of the file is incorrect.

Action:Enter the correct version number and retry the operation.


ORA-28768

ORA-28768bad magic number

Cause:An invalid magic number was specified in a data file.

Action:This could be due to disk corruption or some other process overwriting the file. Enable tracing to determine what the exact error is.


ORA-28769

ORA-28769specified method does not exist

Cause:The data access method specified in the configuration file is not supported.

Action:Specify a supported method. Consult the Oracle Security Server documentation to determine the supported types.


ORA-28770

ORA-28770data source already initialized

Cause:The caller attempted to initialize a data source which was already initialized.

Action:This is a programming error. An application should not attempt to initialize a data source more than once.


ORA-28771

ORA-28771data source not yet initialized

Cause:The caller attempted to use a data source which had not been initialized yet.

Action:This is a programming error. The application must always initialize the data source.


ORA-28773

ORA-28773write of magic and version numbers failed

Cause:The write of both the magic and version numbers failed.

Action:This error usually occurs because disk space has been exhausted.


ORA-28774

ORA-28774write of file to disk failed

Cause:The output of a file failed.

Action:This error usually occurs because disk space has been exhausted.


ORA-28775

ORA-28775close of file failed

Cause:The close of a file used by a data access method failed.

Action:This error usually indicates an error such as memory corruption or a system error. Enable tracing and examine the trace file to see what the exact error.


ORA-28776

ORA-28776output buffer supplied is too small

Cause:The data to be returned by a function is too large for the supplied buffer.

Action:Call the routine again with a larger buffer.


ORA-28778

ORA-28778parameter not specified in proper format

Cause:The configuration parameter was not specified in the proper format.

Action:Consult the Oracle Security Server documentation for a description of the proper format for this parameter.


ORA-28779

ORA-28779no data access method specified in parameter

Cause: No method for data access was specified in the parameter value.

Action: Specify a parameter method. Consult the Oracle Security Server documentation for the supported data access methods for this data type.


ORA-28780

ORA-28780invalid method specified by parameter

Cause: The data access method specified by the parameter value is not supported.

Action: Specify a data access method. Consult the Oracle Security Server documentation for the supported data access methods for this data type.


ORA-28781

ORA-28781no method data specified in parameter

Cause:No data was specified in the parameter for use with the specified access method.

Action:Consult the Oracle Security Server documentation for the data that must be specified for the access method.


ORA-28782

ORA-28782data source not allocated

Cause:No memory was allocated for a data source.

Action:The application should call in the data source initialization function.


ORA-28783

ORA-28783invalid parameter

Cause:No match for parameter name in the configuration file.

Action:Check your SQLNET.ORA file for the parameter.


ORA-28784

ORA-28784file name translation failed

Cause:The translation of a file name from Oracle format to native format failed.

Action:Specify a correct name. Consult your ORACLE documentation for the correct file name format.


ORA-28785

ORA-28785parameter does not exist

Cause:A configuration parameter does not exist in a parameter file.

Action:Supply the required parameter.


ORA-28786

ORA-28786unknown cryptographic algorithm

Cause:Use of incorrect password for decryption.

Action:Type in the correct password.


ORA-28787

ORA-28787failed to allocate more memory

Cause:The allocation of memory to grow a buffer failed due to exhaustion of system memory.

Action:Terminate other processes to free up memory or add memory to the system.


ORA-28788

ORA-28788invalid key size

Cause:Incorrect input by the user in response to a prompt or an unknown error.

Action:Provide the correct input or enable tracing and check the trace file for errors.


ORA-28790

ORA-28790NLS string open failed

Cause:The opening of a string for use by the NLS subsystem failed.

Action:Enable Net8 tracing to determine the exact error.


ORA-28791

ORA-28791certificate verification failed

Cause:Verification of the certificate supplied by the user failed.

Action:Enable Net8 tracing to determine the exact error.


ORA-28792

ORA-28792PL/SQL operation failed

Cause:A PL/SQL operation attempted by the Oracle Security Service failed.

Action:This is an internal error. Enable Net8 and try the operation again. Contact Oracle Worldwide Support for assistance.


ORA-28794

ORA-28794attribute initialization data type failed

Cause:The initialization of the attribute data type failed.

Action:Enable tracing to determine the exact error. This error may be caused by the exhaustion of system resources.


ORA-28795

ORA-28795attribute data type termination failed

Cause:The termination of the use of the attribute data type subsystem failed.

Action:Enable Net8 tracing to determine the exact error.


ORA-28796

ORA-28796unsupported access method

Cause:The method specified to access data is not supported.

Action:Use a supported access method.


ORA-28797

ORA-28797invalid data type

Cause:The data type specified for a key is not supported.

Action:Correct the key type and retry the operation.


ORA-28798

ORA-28798number of sub-keys to bind does not match that in key

Cause:The number of keys passed by the application to bind does not match the number used to create the key.

Action:This is an internal programming exception. Contact your Oracle Worldwide Support representative.


ORA-28799

ORA-28799failed to allocate shared memory

Cause:The allocation of shared memory for use in operations involving the shared server failed.

Action:Enable Net8 tracing to determine the exact error. This error is probably caused by the exhaustion of the memory heap supplied by the Oracle server.


ORA-28800

ORA-28800open failed

Cause:Failed to open the data source (file or database).

Action:Enable Net8 tracing to determine the exact error.


ORA-28802

ORA-28802invalid mode specified

Cause:Mode or data source specified in configuration file is incorrect.

Action:Check the SQLNET.ORA file for method parameter. Else enable Net8 tracing to determine the exact error.


ORA-28803

ORA-28803input/output operation failed

Cause:Failed to access a data source(file or database).

Action:Enable Net8 tracing to determine the exact error.


ORA-28804

ORA-28804close failed

Cause:Failed to close the data source(file or database).

Action:Enable Net8 tracing to determine the exact error.


ORA-28805

ORA-28805retrieve failed

Cause:Failed to retrieve information from the data source (file or database).

Action:Enable Net8 tracing to determine the exact error.


ORA-28806

ORA-28806store failed

Cause:Failed to write to the data source(file or database).

Action:Enable Net8 tracing to determine the exact error.


ORA-28807

ORA-28807update failed

Cause:Failed to update a data source(file or database).

Action:Enable Net8 tracing to determine the exact error.


ORA-28808

ORA-28808retrieval of method information failed

Cause:Failed to retrieve method (file/database) information.

Action:Check the SQLNET.ORA file for method configuration parameters. Else enable Net8 tracing to determine the exact error.


ORA-28809

ORA-28809deletion failed

Cause:Failed to delete information from data source.

Action:Enable Net8 tracing to determine the exact error.


ORA-28810

ORA-28810creation failed

Cause:Failed to create a key descriptor.

Action:Enable Net8 tracing to determine the exact error.


ORA-28814

ORA-28814conversion of number in Oracle format to native failed

Cause:The conversion of a number which was specified in Oracle format to n

Action:This is an internal programming exception. Enable Net8 tracing and attempt to reproduce the problem. Contact your customer support representative and supply the trace file.


ORA-28815

ORA-28815Conversion of native number to Oracle format failed

Cause:The conversion of a number which was specified in native format to Oracle portable format failed.

Action:This is an internal programming exception. Enable Net8 tracing and attempt to reproduce the problem. Contact your customer support representative and supply the trace file.


ORA-28816

ORA-28816no password provided

Cause:A required password was not passed to a PL/SQL function.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28817

ORA-28817PL/SQL function returned an error

Cause:A PL/SQL function returned an error unexpectedly.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28818

ORA-28818no package context provided

Cause:The context that holds the state of the security package was not passed to a function or procedure that was expecting it.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28819

ORA-28819no distinguished name provided

Cause:The user's distinguished name was not provided to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28820

ORA-28820state not provided

Cause:The state of either a signature or decryption/encryption was not passed to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28821

ORA-28821no input buffer provided

Cause:A PL/SQL function or procedure was not passed an expected buffer.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28822

ORA-28822no seed

Cause:No seed was specified to the PL/SQL seed initialization function.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28823

ORA-28823number of bytes not specified

Cause:The number of random bytes to generate was not specified to the PL/SQL random number generator.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28824

ORA-28824invalid encryption/decryption/signature state

Cause:An invalid state was passed to a PL/SQL encryption, decryption or signature procedure or function.

Action:Specify a correct state value and retry the operation.


ORA-28825

ORA-28825no cryptographic engine function

Cause:No function was specified for the cryptographic engine.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28826

ORA-28826invalid cryptographic engine function

Cause:An incorrect cryptographic engine function was passed to a PL/SQL function or procedure.

Action:Specify a correct engine function and retry the operation.


ORA-28827

ORA-28827invalid cipher type

Cause:An incorrect cipher type was passed to a PL/SQL function or procedure.

Action:Specify a correct cipher type and retry the operation.


ORA-28828

ORA-28828invalid identity type

Cause:An incorrect identity type was passed to a PL/SQL function or procedure.

Action:Specify a correct identity type and retry the operation.


ORA-28829

ORA-28829no cipher type specified

Cause:No cipher type was passed to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28830

ORA-28830no identity type specified

Cause:No identity type was passed to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28831

ORA-28831no data unit format

Cause:No data unit format was passed to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28832

ORA-28832invalid data unit format

Cause:An incorrect data unit format was passed to a PL/SQL function or procedure.

Action:Specify a data unit format and retry the operation.


ORA-28833

ORA-28833not enough info provided

Cause:Not enough info (usually parameters) provided to a PL/SQL function

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28834

ORA-28834buffer too small

Cause:Buffer provided by PL/SQL to a Oracle Security Server toolkit function is too small for the data to be returned

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28835

ORA-28835identity descriptor not present or too small

Cause:An identity descriptor passed to a PL/SQL function or descriptor was not provided or does not have the correct size.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28836

ORA-28836wallet not open

Cause:The wallet to be used has not been opened yet.

Action:Call the function that opens the wallet and retry the operation.


ORA-28837

ORA-28837no wallet descriptor

Cause:No wallet descriptor was specified to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28838

ORA-28838no identity descriptor

Cause:No identity descriptor was specified to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28839

ORA-28839no persona descriptor

Cause:No persona descriptor was specified to a PL/SQL function or procedure.

Action:This is an internal error. Contact Oracle Worldwide Support.


ORA-28840

ORA-28840wallet already open

Cause:An attempt was made to open a wallet that had already been opened.

Action:This is a programming error. A wallet should only be opened once.


ORA-28841

ORA-28841operation not supported

Cause:An attempt was made to perform an operation that is not supported.

Action:This is a programming error.


ORA-29228

ORA-29228the number of bytes for output could not be calculated

Cause:The cryptographic engine is confused about the algorithm.

Action:Check the parameters being used with the cryptographic functions.


ORA-29229

ORA-29229the magic number found in the header does not match expected

Cause:The input TDU has either been corrupted or it is not being used correctly.

Action:Check that the TDU is being used from the beginning. If possible, compare the size of the TDU upon generation to the size trying to be used.


ORA-29230

ORA-29230the header length is not sufficient for message header

Cause:The input TDU has either been corrupted or it is not being used correctly.

Action:Check that the TDU is being used from the beginning. If possible, compare the size of the TDU upon generation to the size trying to be used.


ORA-29231

ORA-29231the cryptographic engine failed to initialize

Cause:During initialization of the cryptographic engine, some failure occurred. This includes running out of memory and trying to seed the random number generator.

Action:Make sure the executable has been linked with compatible library versions, and that you are not running out of swap space.


ORA-29232

ORA-29232the cryptographic engine key initialization failed

Cause:During initialization of a key for cryptography, some failure occurred. This includes running out of memory and passing illegal arguments.

Action:Make sure the executable has been linked with compatible library versions, and that the correct parameters are being used for the cryptographic functions.


ORA-29233

ORA-29233the key object could not be encoded

Cause:The key object may be corrupted or may be an unsupported type.

Action:Check the key object being passed to the encoding routine.


ORA-29234

ORA-29234a key object was not extracted from encoding

Cause:The encoding may be corrupted or may not be a key object at all.

Action:Check the encoding and parameters passed to decoding routine.


ORA-29235

ORA-29235the key information could not be retrieved

Cause:The key may be corrupted or may be an unsupported type.

Action:Check the parameters being used with the cryptographic functions.


ORA-29236

ORA-29236the random number generator will not accept seed

Cause:The cryptographic engine may have run out of memory.

Action:Make sure the executable has been linked with compatible library versions.


ORA-29237

ORA-29237the cryptographic engine could not finish the algorithm

Cause:The cryptographic engine does not have enough information to correctly finish applying the algorithm.

Action:Check the parameters being used with the cryptographic functions.


ORA-29238

ORA-29238the cryptographic engine could not apply the algorithm

Cause:The cryptographic engine does not have enough information to correctly apply the algorithm.

Action:Check the parameters being used with the cryptographic functions.


ORA-29239

ORA-29239the cryptographic engine could not initialize the algorithm

Cause:The cryptographic engine does not have enough information to correctly initialize the algorithm.

Action:Check the parameters being used with the cryptographic functions.


ORA-29240

ORA-29240the cryptographic engine does not recognize the algorithm

Cause:The application probably passed the wrong parameters.

Action:Check the parameters being used with the cryptographic functions.


ORA-29241

ORA-29241a buffer block needs to more space but its length is fixed

Cause:The application has preallocated an output buffer that is too short for the operation and has specified that the buffer should not grow as needed.

Action:Either preallocate a larger buffer or allow the toolkit to grow the output buffer as needed.


ORA-29242

ORA-29242the asymmetric key is too short to be used with the data.

Cause:An asymmetric key must be at least 11 bytes longer than the data it is being used to encrypt.

Action:Use an asymmetric key with more bits or break the data into smaller pieces.


ORA-29243

ORA-29243the toolkit does not recognize the type of key being used

Cause:The application probably passed the wrong parameters.

Action:Check the parameters being used with the toolkit functions.


ORA-29245

ORA-29245the toolkit does not recognize the function being used

Cause:The application probably passed the wrong parameters.

Action:Check the parameters being used with the toolkit functions.


ORA-29246

ORA-29246the toolkit could not parse the TDU

Cause:The TDU could be corrupted.

Action:Check the parameters being used with the toolkit functions.


ORA-29247

ORA-29247an unopen toolkit object was used before it was opened

Cause:Some toolkit objects must be opened before they can be used.

Action:Check the parameters being used with the toolkit functions.


ORA-29248

ORA-29248an unrecognized WRL was used to open a wallet

Cause:WRL's have a specific set of types and must be formatted correctly.

Action:Check the parameters being used with the toolkit functions.


ORA-29249

ORA-29249an unrecognized state was passed to a cryptographic function

Cause:The application probably passed the wrong parameters.

Action:Check the parameters being used with the toolkit functions.


ORA-29251

ORA-29251index1 is greater than index2 in call to dbms_sql.bind_array

Cause:The value of index1 was greater than the value for index2 in the call to bind_array. This is illegal since the elements of the table that will be bound are those with indexes greater than or equal to index1 and less than or equal to index2.

Action:Correct the value of the two indexes and try the call to again BIND_ARRAY.


ORA-29252

ORA-29252collection does not contain elements at index locations in call to DBMS_SQL.BIND_ARRAY

Cause:The bound table does not contain elements at both index locations in call to BIND_ARRAY of DBMS_SQL. This is illegal. Both index locations must contain elements. In other words tab.exists(index1) and tab.exists(index2) must both return true.

Action:Either modify the two indexes or the contents of the table and try the call again.


ORA-29253

ORA-29253invalid count argument passed to procedure DBMS_SQL.DEFINE_ARRAY

Cause:The count argument specified in the call to procedure DEFINE_ARRAY of package DBMS_SQL had an invalid value. Invalid values are negative numbers and nulls. The argument must be a positive integer.

Action:Correct your PL/SQL program so that only valid arguments are passed to DEFINE_ARRAY and try again.


ORA-29254

ORA-29254invalid lower_bound argument passed to procedure DBMS_SQL.DEFINE_ARRAY

Cause:The LOWER_BOUND argument specified in the call to procedure DEFINE_ARRAY had an invalid value. Legal values are all integers (both positive and negative) including zero. The NULL value is illegal.

Action:Correct your PL/SQL program so that only valid arguments are passed to DEFINE_ARRAY and try again.


ORA-29255

ORA-29255cursor contains both bind and define arrays which is not permissible

Cause:Both DEFINE_ARRAY and BIND_ARRAY have been called on this cursor. This is illegal. It is not possible for a cursor to both contain array binds and array defines. Array defines are used to move data from select queries into PL/SQL tables and array binds to bind PL/SQL tables to non-select queries.

Action:Modify your PL/SQL program to only perform calls to one of the two functions depending on the kind of cursor at hand.


ORA-29256

ORA-29256cursor contains both regular and array defines which is illegal

Cause:Both DEFINE_ARRAY and DEFINE_COLUMN have been called on this cursor. This is illegal. It is not possible for a cursor to both contain regular and array defines. Array defines are used to move data from select queries into PL/SQL tables and regular defines to move data from select queries into PL/SQL variables.

Action:Modify your PL/SQL program to only perform calls to one of the two functions depending on the situation at hand.


ORA-29300

ORA-29300ORACLE error, tablespace point-in-time recovery

Cause:An ORACLE error occurred in the DBMS_PITR package.

Action:See the text of the Oracle error message for a description of the error.


ORA-29301

ORA-29301wrong DBMS_PITR package function/procedure order

Cause:The DBMS_PITR package function/procedure was called in an incorrect order.

Action:Restart tablespace point-in-time recovery with a correct procedure.


ORA-29302

ORA-29302database is not open clone

Cause:Database was not opened as a clone database.

Action:Mount the database clone and open the database.


ORA-29303

ORA-29303user does not login as SYS

Cause:User did not log in as SYS to perform tablespace point-in-time recovery in a clone database.

Action:Log in as SYS and restart tablespace point-in-time recovery.


ORA-29304

ORA-29304tablespace 'name' does not exist

Cause:The selected tablespace does not exist in the database.

Action:Check the list of tablespaces in V$TABLESPACE and select a valid tablespace.


ORA-29305

ORA-29305cannot point-in-time recover tablespace 'name'

Cause:An attempt was made to ALTER the tablespace to be read only.

Action:Check if the tablespace is SYSTEM or with online rollback segment.


ORA-29306

ORA-29306datafile name is not online

Cause:The selected datafile was not online.

Action:Bring the datafile online and rename it if necessary.


ORA-29307

ORA-29307datafile name error, name

Cause:The datafile is not ready for tablespace point-in-time recovery.

Action:Check the correct tablespace point-in-time recovery procedure.


ORA-29309

ORA-29309export dump file was generated by different version of DBMS_PITR package

Cause:The version of DBMS_PITR is different from the version of the cloned database.

Action:Load the version of DBMS_PITR which matches the version of the cloned database.


ORA-29310

ORA-29310database is not open, or opened as a clone

Cause:Either the database was not open, or an attempt was made to open it as a cloned database.

Action:Open the production database instead.


ORA-29311

ORA-29311export dump file was not generated by this database, name not match

Cause:The production database is not the same as the clone database.

Action:Open the correct production database and try the import again.


ORA-29312

ORA-29312database not compatible, name name

Cause:A point-in-time tablespace was chosen to perform the recovery, but the current database is not compatible with the database that was used to create the point-in-time tablespace.

Action:Choose a different point-in-time and retry the operation.


ORA-29313

ORA-29313tablespace 'name' cannot be imported twice

Cause:This is an internal error.

Action:Contact your database administrator.


ORA-29314

ORA-29314tablespace 'name' is not OFFLINE FOR RECOVERY nor READ ONLY

Cause:Tablespace clean SCN (system commit number) is either 0 or invalid.

Action:ALTER the tablespace OFFLINE FOR RECOVER.


ORA-29315

ORA-29315tablespace 'name' has been recreated

Cause:An attempt was made to recover a tablespace to a point-in-time before it was recreated.

For example, you CREATE TABLESPACE FINANCIAL on 1/1 and DROP it on 1/10. On 1/12, you CREATE a new tablespace also called FINANCIAL. ORACLE allows you to do this. Note that the two FINANCIAL tablespaces are different. To continue the example, on 1/14, you try to recover tablespace FINANCIAL to 1/5. ORACLE returns the above error because although ORACLE finds the FINANCIAL tablespace on 1/5, it is not the FINANCIAL tablespace that exists on 1/14. This is because FINANCIAL was recreated.

Action:Choose a different point in time for recovery.


ORA-29316

ORA-29316datafile name been imported twice

Cause:This is an internal error.

Action:Contact your database administrator.


ORA-29317

ORA-29317datafile name does not exist

Cause:The specified datafile could not be found in the production database.

Action:Copy the datafile from the clone database


ORA-29318

ORA-29318datafile name is online

Cause:The datafile is online.

Action:Take the datafile offline.


ORA-29319

ORA-29319datafile name is not correct

Cause:An incorrect datafile was copied to the production database. The datafile information in the export dump file differs with the information in the datafile in the production database.

Action:Copy the datafile from the clone database to the production database.


ORA-29320

ORA-29320datafile header error

Cause:An error occurred while reading the datafile header.

Action:Copy the correct datafile from the clone database to the production database, then retry the operation.


ORA-29321

ORA-29321too many datafiles added since the point-in-time

Cause:Too many datafiles were added to the recovery set since the point-in-time. It is assumed that no more than 100 datafiles were added since the point-in-time.

Action:Divide the recovery set into smaller subsets and contact Oracle.


ORA-29322

ORA-29322SCN string size too long -- maximum size 58 bytes/characters

Cause:Too many characters in specifying the SCN string

Action:Remove all unnecessary characters. Only 15 characters are required for both the hex and decimal representation of the 48-bit SCN.


ORA-29323

ORA-29323SET COMPATIBILITY command cannot be used for releases before 8.0.0

Cause:The rolling release feature was first implemented in 8.0.3

Action:Try 8.0.3 as the value for SET COMPATIBILITY.


ORA-29324

ORA-29324SET COMPATIBILITY release string format is wrong

Cause:The SET COMPATIBILITY release string was not specified in the form 8.x.x.

Action:Enter a release string in the form 8.x.x. For example, 8.0.3.


ORA-29325

ORA-29325SET COMPATIBILITY release number mismatches compatibility release number

Cause:In 8.0.3, release number should be the same as compatibility release number.

Action:Specify the release number to be the same as the COMPATIBLE initialization parameter. Note that this cannot be a release number less than 8.0.0


ORA-29326

ORA-29326specified SET COMPATIBILITY release number reduced to release_number

Cause:One or more instances had a lower release number.

Action:To roll the release to the specified number, all instances will need to migrate to the same release number or higher.


ORA-29701

ORA-29701unable to connect to Group Membership Service (GMS)

Cause:Connect to GMS failed or timed out

Action:Verify that the GMS was started. If it the GMS was not started, start it and then retry the database startup. If the GMS died or is not responding, check the Oracle and GMS trace files for errors.


ORA-29702

ORA-29702error occurred in Group Membership Service operation

Cause:An unexpected error occurred while performing a GMS operation.

Action:Verify that the Group Membership Service is still active. Also, check the Oracle and GMS trace files for errors.


OSD-01000

OSD-01000Logical block size mismatch

Cause:File created with logical block size different from that requested

Action:Use matching logical block sizes


OSD-01001

OSD-01001Invalid logical block size

Cause:Logical block size is not a multiple of 512 bytes, or is too big

Action:Change requested logical block size


OSD-01002

OSD-01002Unable to open file

Cause:Invalid path or filename specified, device full, insufficient file handles

Action:Make sure file exists and/or device is not full, verify OS is functioning correctly


OSD-01003

OSD-01003Unable to read file header block

Cause:Damaged media

Action:Recover file if necessary, verify OS is functioning correctly


OSD-01005

OSD-01005Lseek() failure, unable to read from file

Cause:Unexpected return from lseek() call

Action:Check OS error code, verify file is not damaged


OSD-01006

OSD-01006Read() or ReadFile() failure, unable to read from file

Cause:Unexpected return from call to read from file

Action:Check OS error code, verify file is not damaged


OSD-01007

OSD-01007Truncated read

Cause:Unexpected end of file, damaged media

Action:Verify file is not damaged


OSD-01008

OSD-01008Writefile() failure, unable to write to file

Cause:Unexpected return from Windows system service WriteFile()

Action:Check OS error code and consult Windows documentation


OSD-01009

OSD-01009Truncated write

Cause:Unable to write to device, device full, damaged media

Action:Verify device is not full, file is not damaged


OSD-01010

OSD-01010<Create> option specified, file already exists

Cause:Asked to create already existing file

Action:Delete file or use <reuse> option


OSD-01011

OSD-01011GetFileSize() failure, unable to obtain file size

Cause:Unexpected return from GetFileSize()

Action:Check OS error code


OSD-01012

OSD-01012File size mismatch

Cause:File to be reused is too large or too small

Action:Specify new file size


OSD-01013

OSD-01013Unable to read line from file

Cause:Check OS error code

Action:Remedy OS error


OSD-01014

OSD-01014Unable to close file

Cause:Damaged media

Action:Recover file if necessary, verify OS is functioning correctly


OSD-01015

OSD-01015Unable to delete file

Cause:File is write protected

Action:Remove protections from file, verify OS is functioning correctly


OSD-01016

OSD-01016DosQueryPathInfo() failure, unable to obtain path info

Cause:Unexpected return from DosQueryPathInfo()

Action:Check OS error code


OSD-01017

OSD-01017The path specified for archive destination is not a directory

Cause:A filename was specified as the archive destination

Action:Specify a valid directory as the archive destination


OSD-01018

OSD-01018Out of space on specified device

Cause:Not enough space on the device to write to or create the file

Action:Free up space for the file or specify another device


OSD-01019

OSD-01019SetFilePtr() failure, unable to read from file

Cause:Unexpected return from SetFilePtr() call

Action:Check OS error code, verify file is not damaged


OSD-01100

OSD-01100Malloc() failure, unable to allocate memory

Cause:Out of memory

Action:Free up memory, terminate processes, install more memory in machine


OSD-01102

OSD-01102Free() failure, unable to free allocated memory

Cause:Unexpected return from Windows system service free()

Action:Check OS error code and consult Windows documentation


OSD-01103

OSD-01103Unable to allocate memory

Cause:Out of memory

Action:Free up memory, terminate processes, install more memory in machine


OSD-01104

OSD-01104Unable to attach to SGA: SGA does not exist

Cause:No SGA exists to connect to

Action:Startup ORACLE instance


OSD-01105

OSD-01105Invalid SGA: SGA not initialized

Cause:The SGA has been allocated but not yet initialized

Action:Try again later


OSD-01106

OSD-01106Unable to attach to variable part of SGA

Cause:Shared memory containing variable part of SGA not available

Action:Verify that SGA has been created w/o error


OSD-01107

OSD-01107Unable to attach to database buffers area of SGA

Cause:Shared memory containing database buffers not available

Action:Verify that SGA has been created w/o error


OSD-01108

OSD-01108Unable to attach to redo buffer area of SGA

Cause:Shared memory containing redo buffers not available

Action:Verify that SGA has been created w/o error


OSD-01109

OSD-01109Invalid memory protection mode specified

Cause:A mode other than read-only and read-write was specified for memory protection

Action:Contact your Oracle Customer Support Representative


OSD-01110

OSD-01110VirtualProtect() failure, unable to set memory protections

Cause:Unable to set the memory protections for a database block in the SGA

Action:Check OS error code and consult Windows documentation


OSD-01204

OSD-01204Invalid pid

Cause:Process ID not recognized by system, process previously terminated

Action:Verify that process ID is correct and that process is active


OSD-01205

OSD-01205Unable to spawn process

Cause:Scheduler could not start background process

Action:Check OS error code


OSD-01300

OSD-01300Unable to read complete record from data file

Cause:With fixed length records, the data file ended in the middle of a record

Action:Verify that the data file is of the correct length and contains complete records


OSD-01301

OSD-01301Record size too large

Cause:The record size specified is too large to load

Action:Reduce record size and retry the data load


OSD-01302

OSD-01302Invalid record type and/or load options

Cause:The OS-dependent file processing specifications string contains an invalid option or keyword

Action:Set the OS-dependent string to an acceptable value


OSD-01303

OSD-01303Unable to open Btrieve file

Cause:The Btrieve file specification was incorrect, or Btrieve is not functional

Action:Verify the Btrieve file name, and verify that Btrieve is operational


OSD-01304

OSD-01304Unable to read Btrieve file

Cause:The Btrieve file was corrupted or truncated

Action:Verify that the Btrieve is valid and complete


OSD-01305

OSD-01305Variable length Btrieve files not supported

Cause:The Btrieve file contains variable length records

Action:Convert the file to fixed length records and reload


OSD-01500

OSD-01500Illegal option specified

Cause:Internal error

Action:Contact your Oracle Customer Support Representative


OSD-01501

OSD-01501Internal buffer overflow

Cause:Internal error

Action:Contact your Oracle Customer Support Representative


OSD-01502

OSD-01502Translations nested too deep

Cause:A CONFIG variable translation caused too many intermediate translations

Action:Simplify CONFIG variables


OSD-01503

OSD-01503Text contains no translatable elements

Cause:No recognized variables are contained in the text to be translated

Action:This message is mostly informational


OSD-01505

OSD-01505Stdin not responding

Cause:Unable to receive input from the standard input stream

Action:Verify that process has access to an input device


OSD-01506

OSD-01506Unable to spawn process via system()

Cause:Out of resource or invalid executable name

Action:Free up memory, terminate processes, install more memory in machine, verify executable name


OSD-01507

OSD-01507Password for 'internal' is incorrect

Cause:An attempt was made to connect as 'internal' with an invalid password

Action:Verify that the password is correct and try again


OSD-01509

OSD-01509No password found

Cause:Oracle was unable to locate and retrieve the password for 'internal'

Action:Verify that Oracle is installed and configured correctly


OSD-01510

OSD-01510Operating system roles are not supported

Cause:An attempt was made to use an OS Role

Action:Only use roles that were created 'IDENTIFIED BY password' as opposed to 'IDENTIFIED EXTERNALLY'


OSD-01511

OSD-01511Unable to get date and time from the operating system

Cause:Unexpected return from localtime() call

Action:Verify that the system time is correct on the computer


OSD-01512

OSD-01512Unable to translate the 'USERNAME' configuration variable

Cause:In order for os logins to work, the 'USERNAME' configuration variable must be set on the database machine

Action:Verify that the 'USERNAME' variable is set


OSD-01513

OSD-01513'Remote_os_authent' init.ora variable not set to true

Cause:In order for os logins to work, 'REMOTE_OS_AUTHENT' must be set to 'TRUE' in INIT.ORA.

Action:Shutdown and startup the instance with 'REMOTE_OS_AUTHENT = TRUE' in INIT.ORA


OSD-04000

OSD-04000logical block size mismatch

Cause:The database block size specified in the initialization parameter file does not match the block size of the actual database files.

Action:Use matching logical block sizes.


OSD-04001

OSD-04001invalid logical block size

Cause:The logical block size is not a multiple of 512 bytes, or it is too large.

Action:Change the value of DB_BLOCK_SIZE in the initialization parameter file.


OSD-04002

OSD-04002unable to open file

Cause:The specified path or filename is invalid, or the destination device is full. This error can also be caused by insufficient Windows NT file handles.

Action:Make sure that the path and file exist, and that the device has free space. If this fails, increase the number of Windows NT file handles.


OSD-04003

OSD-04003unable to read file header block

Cause:The media has been damaged.

Action:Recover the file if necessary, and verify that Windows NT is functioning correctly.


OSD-04004

OSD-04004invalid file header

Cause:The file is corrupted.

Action:Recover the file.


OSD-04005

OSD-04005SetFilePointer() failure, unable to read from file

Cause:There was an unexpected return from the Windows NT system service, SetFilePointer().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04006

OSD-04006ReadFile() failure, unable to read from file

Cause:There was an unexpected return from the Windows NT system service, ReadFile().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04007

OSD-04007truncated read

Cause:The system encountered an unexpected end-of-file, which is due to damaged media.

Action:Verify that the file is not damaged.


OSD-04008

OSD-04008WriteFile() failure, unable to write to file

Cause:There was an unexpected return from the Windows NT system service, WriteFile().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04009

OSD-04009truncated write

Cause:The destination device is full or the media is damaged.

Action:Verify that the device has free space and the file is not damaged.


OSD-04010

OSD-04010option specified, file already exists

Cause:The file that you attempted to create already exists.

Action:Delete the existing file or use the REUSE option in the SQL statement.


OSD-04011

OSD-04011GetFileInformationByHandle() failure, unable to obtain file info

Cause:There was an unexpected return from the Windows NT system service, GetFileInformationByHandle().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04012

OSD-04012file size mismatch

Cause:The file to be reused is either too large or too small

Action:Specify the correct file size or delete the existing file.


OSD-04013

OSD-04013unable to read line from file

Cause:This error is caused by an operating system error or by damaged media.

Action:Check the operating system error code (if available) and consult the Windows NT documentation. If no operating system error code is presented, verify that the media is not damaged.


OSD-04014

OSD-04014unable to close file

Cause:The media has been damaged.

Action:Recover the file, if necessary, and verify that Windows NT is functioning correctly.


OSD-04015

OSD-04015asynchronous I/O request returned an error

Cause:There was an unexpected return from the Windows NT system service.

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04016

OSD-04016error queuing an asynchronous I/O request

Cause:There was an unexpected return from the Windows NT system service.

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04017

OSD-04017unable to open the specified RAW device

Cause:An invalid path or filename was specified or the device is full.

Action:Make sure the file exists and/or device is not full; verify that the operating system is functioning correctly.


OSD-04018

OSD-04018unable to access the specified directory or device

Cause:An invalid path name was specified.

Action:Make sure the directory or device exists and is accessible.


OSD-04019

OSD-04019unable to set file pointer

Cause:This error is caused by an operating system error or by damaged media.

Action:Check the operating system error code (if available) and consult the Windows NT documentation. If no operating system error code is presented, verify that the media is not damaged.


OSD-04020

OSD-04020unable to set eof file marker

Cause:This error is caused by an operating system error or by damaged media.

Action:Check the operating system error code (if available) and consult the Windows NT documentation. If no operating system error code is presented, verify that the media is not damaged.


OSD-04021

OSD-04021unable to read file

Cause:This error is caused by an operating system error or by damaged media.

Action:Check the operating system error code (if available) and consult the Windows NT documentation. If no operating system error code is presented, verify that the media is not damaged.


OSD-04022

OSD-04022unable to write file

Cause:This error is caused by an operating system error or by damaged media.

Action:Check the operating system error code (if available) and consult the Windows NT documentation. If no operating system error code is presented, verify that the media is not damaged.


OSD-04023

OSD-04023SleepEx() failure, unable to Sleep

Cause:There was an unexpected return from the Windows NT system service.

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04024

OSD-04024Unable to delete file

Cause:This error is caused by an operating system error or by damaged media.

Action:This error is caused by an operating system error or by damaged media.


OSD-04025

OSD-04025Invalid question asked

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Worldwide Customer Support.


OSD-04026

OSD-04026Invalid parameter passed

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Worldwide Customer Support.


OSD-04100

OSD-04100malloc() failure, unable to allocate memory

Cause:The program is out of memory.

Action:Shutdown all unnecessary processes or install more memory in the machine.


OSD-04101

OSD-04101invalid SGA: SGA not initialized

Cause:The System Global Area (SGA) has been allocated but not initialized.

Action:Wait until the STARTUP has completed before attempting to connect.


OSD-04102

OSD-04102unable to open/create file for shared memory object

Cause:There was an unexpected return from the Windows NT system service, CreateFile().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04103

OSD-04103unable to attach to SGA: SGA does not exist

Cause:The System Global Area (SGA) does not exist.

Action:Start up an Oracle instance.


OSD-04104

OSD-04104unable to map shared memory (SGA) into the address space

Cause:There was an unexpected return from the Windows NT system service, MapViewOfFileEx().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04105

OSD-04105shared memory (SGA) mapped to wrong address

Cause:There was an unexpected return from the Windows NT system service, MapViewOfFileEx().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04106

OSD-04106unable to allocate memory with VirtualAlloc

Cause:The program is out of memory.

Action:Shutdown all unnecessary processes; install more memory in the machine.


OSD-04107

OSD-04107unable to deallocate memory with VirtualFree

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04108

OSD-04108Unable to protect memory with VirtualProtect

Cause:There was an unexpected return from the Windows NT system service, VirtualProtect().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04200

OSD-04200unable to begin another thread

Cause:The program has run out of system resources.

Action:Shutdown all unnecessary processes; install more memory in the machine.


OSD-04201

OSD-04201no pid structure supplied to spdcr()

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04203

OSD-04203DosKillProcess() failure, unable to kill process

Cause:There was an unexpected return from the Windows NT system service, DosKillProcess().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04204

OSD-04204invalid pid

Cause:Process id not recognized by system, process previously terminated.

Action:Verify that process ID is correct and that process is active.


OSD-04205

OSD-04205CreateProcess() failure, unable to spawn process

Cause:There was an unexpected return from the Windows NT system service, CreateProcess().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04207

OSD-04207invalid priority specified in CONFIG parameter ORACLE_PRIORITY

Cause:The priority specified is invalid or out of range.

Action:Specify a valid setting for ORACLE_PRIORITY.


OSD-04208

OSD-04208OpenProcess() failure, unable to open process handle

Cause:There was an unexpected return from the Windows NT system service, OpenProcess().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04209

OSD-04209Incorrect or unknown background image name given to spdcr()

Cause:There was an unexpected background name given to spdcr().

Action:Contact Oracle Customer Support.


OSD-04210

OSD-04210Timeout waiting for thread semaphore

Cause:An Oracle7 thread died holding the semaphore.

Action:Restart Oracle7 instance.


OSD-04211

OSD-04211Thread information not found

Cause:An Oracle7 thread died without deleting its information.

Action:Restart Oracle7 instance.


OSD-04212

OSD-04212Maximum number of Oracle threads reached

Cause:The maximum number of Oracle7 threads for the instance is reached.

Action:Wait until some connections exit before trying again.


OSD-04213

OSD-04213Oracle thread unable to DuplicateHandle()

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04214

OSD-04214Oracle thread unable to CreateEvent()

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04215

OSD-04215Bad function code supplied to ssthreadop

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04216

OSD-04216Unable to find file handle for that thread

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04217

OSD-04217Unable to retrieve system username for current user

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Worldwide Customer Support.


OSD-04218

OSD-04218Cannot post thread

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Worldwide Customer Support.


OSD-04219

OSD-04219Bad thread list semaphore

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Worldwide Customer Support.


OSD-04300

OSD-04300unable to read complete record from data file

Cause:The data file ended in the middle of a record. This error occurs when loading files with a fixed record length.

Action:Verify that the data file is of the correct length and contains complete records.


OSD-04301

OSD-04301record size too large

Cause:The specified record size is too large to load.

Action:Reduce record size and reload the data.


OSD-04302

OSD-04302invalid record type and/or load options

Cause:The control file's Windows NT file processing options string contains an invalid option or keyword.

Action:Set the Windows NT file processing options string to an acceptable value.


OSD-04400

OSD-04400unable to acquire internal semaphore for process

Cause:Oracle7 Workgroup Server for Windows NT has exceeded the maximum number of connections.

Action:Delete any unused connections and try again.


OSD-04401

OSD-04401WaitForSingleObject() failure, unable to obtain semaphore

Cause:There was an unexpected return from the Windows NT system service, WaitForSingleObject().

Action:Check the operating system error code and consult the Windows NT documentation.


OSD-04500

OSD-04500illegal option specified

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04501

OSD-04501internal buffer overflow

Cause:This is an internal error, not normally expected to occur.

Action:Contact Oracle Customer Support.


OSD-04502

OSD-04502translations nested too deep

Cause:The program encountered too many intermediate translations while attempting to translate a configuration variable.

Action:Simplify the values of configuration parameters to include fewer intermediate translations.


OSD-04503

OSD-04503text contains no translatable elements

Cause:The program cannot recognize variables in the text to be translated.

Action:Check and, if necessary, correct the text to be translated.


OSD-04505

OSD-04505stdin not responding

Cause:The system is unable to receive input from the standard input stream.

Action:Verify that the process has access to an input device.


OSD-04506

OSD-04506unable to spawn process via system()

Cause:The system is out of memory or the executable is invalid.

Action:Shutdown unnecessary processes; install more memory in machine. Verify the name of the executable.


OSD-04507

OSD-04507password for 'internal' is incorrect

Cause:An attempt was made to connect as 'internal' with an invalid password.

Action:Verify that the password is correct and try again.


OSD-04508

OSD-04508no password given

Cause:An attempt was made to connect as 'internal' without a password.

Action:Enter a valid password when connecting as internal.


OSD-04509

OSD-04509no password found

Cause:Oracle was unable to locate and retrieve the password for 'internal'.

Action:Verify that Oracle is installed and configured correctly.


OSD-04510

OSD-04510operating system roles are not supported

Cause:An attempt was made to use an operating system role.

Action:Only use roles that were created 'IDENTIFIED BY password' as opposed to 'IDENTIFIED EXTERNALLY'.


OSD-04511

OSD-04511unable to get date and time from the operating system

Cause:There was an unexpected return from GetLocalTime() call.

Action:Verify that the system time is correct on the computer.


OSD-04512

OSD-04512unable to translate the 'USERNAME' configuration variable on server

Cause:The 'USERNAME' configuration parameter variable on the host is not properly set.

Action:Verify the 'USERNAME' variable is set.


OSD-04513

OSD-04513'REMOTE_OS_AUTHENT' variable not set to TRUE

Cause:For remote operating system logins to function, the 'REMOTE_OS_AUTHENT' parameter must be set to TRUE.

Action:Shut down and start up the instance with 'REMOTE_OS_AUTHENT = TRUE' in the initialization parameter file.


OSD-04514

OSD-04514The Windows NT Group name is too long for internal buffer

Cause:The Windows NT Group name is too long.

Action:Use a shorter Windows NT group name.


PCC-00002

PCC-00002Invalid syntax at column name in line num of file name

Cause:There is a syntax error in an EXEC statement or the statement is notproperly terminated.

Action:Correct the syntax of the EXEC statement. If the error occurred at the end of the input file, check that the last EXEC statement is properly terminated.


PCC-00003

PCC-00003Invalid SQL Identifier at column name in line num of file name

Cause:The symbol in a conditional precompilation statement (such as EXEC ORACLE IFDEF) is invalid, or the name of a SQL descriptor, statement, or cursor is invalid or was not properly declared.

Action:Check the statement syntax and spelling of the identifier and check that a reserved word was not accidentally used. If necessary, define the identifier in a variable declaration or DECLARE statement ahead of the line in error.


PCC-00004

PCC-00004Mismatched IF/ELSE/ENDIF block at line num in file name

Cause:There is an EXEC ORACLE ELSE or EXEC ORACLE ENDIF statement without a matching EXEC ORACLE IFDEF statement.

Action:Add the missing EXEC ORACLE IFDEF statement or delete or move the EXEC ORACLE ELSE or EXEC ORACLE ENDIF statement.


PCC-00005

PCC-00005Unsupported datatype in line num of file name

Cause:A host variable defined in the Declare Section has an unsupported datatype or has a scale or precision outside the supported range.

Action:Redefine the host variable using a supported datatype. Check that the scale and precision of a numeric variable are in the accepted range.


PCC-00007

PCC-00007Invalid WHENEVER condition at column name in line num of file name

Cause:A condition other than SQLERROR, SQLWARNING, or NOT FOUND was specified in an EXEC SQL WHENEVER statement, or one of these was used but spelled incorrectly.

Action:Correct the spelling of the WHENEVER condition or use a host-language IF statement to test the special condition.


PCC-00008

PCC-00008Invalid WHENEVER action at column name in line num of file name

Cause:At least one of the following:

An action other than CONTINUE, GOTO, or STOP was specified in an EXEC SQL WHENEVER statement.

One of the specified actions was spelled incorrectly.

The host language does not allow the action (STOP is illegal in Pro*Pascal programs).

A GOTO label is invalid.

Action:Check that the host language allows the specified WHENEVER action. If necessary, correct the spelling of the WHENEVER action or correct theGOTO label.


PCC-00009

PCC-00009Invalid host variable at column name in line num of file name

Cause:A host variable used in an EXEC SQL statement was not declared in the Declare Section or has an unsupported datatype.

Action:Declare the host variable in the Declare Section, making sure it has one of the supported datatypes.


PCC-00010

PCC-00010Statement out of place at line num in file name

Cause:An EXEC statement was not placed properly in the host program. For example, there might be a data manipulation statement in the Declare Section. In a Pro*COBOL program, the Declare Section might be outside the WORKING-STORAGE SECTION.

Action:Remove or relocate the statement.


PCC-00011

PCC-00011Already in a Declare Section at line num in file name

Cause:A BEGIN DECLARE SECTION statement was found inside a Declare Section.

Action:Remove the extra BEGIN DECLARE SECTION statement.


PCC-00012

PCC-00012Not in a Declare Section at line num in file name

Cause:An END DECLARE SECTION statement without a matching BEGIN DECLARE SECTION statement was found. Either the BEGIN DECLARE SECTION statement is missing or misspelled or the END DECLARE SECTION statement is an extra.

Action:Add or correct the BEGIN DECLARE SECTION statement or remove the extra END DECLARE SECTION statement.


PCC-00013

PCC-00013Unable to open INCLUDE file name at line num in file name

Cause:The precompiler was unable to open the input file specified in the INCLUDE statement. Some possible causes follow:

The filename is misspelled.

The file does not exist.

The search path to the file is incorrect.

File access privileges are insufficient.

Another user has locked the file.

There is not enough disk space.

There are too many open files.

Action:Check that the file exists, that the search path to the file is correct, that sufficient privileges to access the file have been granted, and that it is not locked by another user. Also, check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).


PCC-00014

PCC-00014Undeclared SQL identifier ident at line num in file name

Cause:The name of a descriptor, statement, or cursor was not declared oris misspelled.

Action:Add or correct the descriptor, statement, or cursor declaration.


PCC-00015

PCC-00015Unrecognized host language syntax ignored at line num in file name

Cause:The host language syntax used to define a host variable in the Declare Sectionis incorrect.

Action:Check the syntax and the spelling, then correct the declaration.


PCC-00016

PCC-00016Unable to open a cursor at line num in file name

Cause:The syntax in a SQL statement is faulty. The precompiler was expecting a host variable but found something else.

Action:Check the syntax and the spelling, then correct the SQL statement.


PCC-00017

PCC-00017Unable to parse statement at line num in file name

Cause:There is a syntax error in an array declaration. The precompiler was expecting a right bracket (]) but found something else.

Action:Check the syntax, then correct the array declaration.


PCC-00018

PCC-00018Expected token, but found token at line num in file name

Cause:The syntax in a SQL statement is faulty. The precompiler found an unexpected or illegal token.

Action:Check the syntax and the spelling, then correct the SQL statement.


PCC-00019

PCC-00019Unable to obtain bind variables at line num in file name

Cause:The precompiler was unable to find information about an input host variable (bind variable) used in a SQL statement.

Action:Check that the input host variable is declared in the Declare Section and used properly in the SQL statement.


PCC-00020

PCC-00020Unable to obtain define variables at line num in file name

Cause:The precompiler was unable to find information about an output host variable (define variable) used in a SQL statement.

Action:Check that the output host variable is declared in the Declare Section and used properly in the SQL statement.


PCC-00021

PCC-00021Oracle Error: ORA-nnnnn

Cause:An Oracle error occurred.

Action:Refer to the indicated message in Chapter 2msgchpt2 of this manual.


PCC-00022

PCC-00022Out of space - unable to allocate num bytes

Cause:The precompiler process ran out of memory.

Action:Allocate more memory to the process, then retry.


PCC-00023

PCC-00023Unable to log off Oracle

Cause:An Oracle connection error occurred while the precompiler was trying to log off, probably because Oracle has been shut down.

Action:Check that Oracle is available, then retry.


PCC-00024

PCC-00024Indicator variable var has wrong type or length at line num in file name

Cause:An indicator variable was not declared in the Declare Section as a 2-byte integer. Indicator variables must be defined as 2-byte integers.

Action:Redefine the indicator variable as a 2-byte integer.


PCC-00025

PCC-00025Undeclared indicator variable var at line num in file name

Cause:An indicator variable used in a SQL statement was not declared in the Declare Section or its name is misspelled.

Action:Add or correct the indicator variable declaration.


PCC-00026

PCC-00026Invalid host variable vat at line num in file name

Cause:A host variable used in a SQL statement was not declared properly. Some possible causes follow:

It was not declared in the Declare Section.

Its datatype is not supported.

Its name is misspelled.

It is a COBOL group item; in Pro*COBOL, only elementary items are allowed in a SQL statement.

Action:Add or correct the host variable declaration.


PCC-00027

PCC-00027Redeclared SQL identifier ident at line num in file name

Cause:The name of a SQL descriptor, statement, or cursor was re-declared (that is, declared twice).

Action:Check the spelling of the identifier, then, if necessary, remove theextra declaration.


PCC-00028

PCC-00028Option optnam not legal as EXEC ORACLE OPTION

Cause:A precompiler option was specified inline in an EXEC ORACLE statement, instead of on the command line. Some options can be specified only on the command line. For example, INAME cannot be specified inline.

Action:Respecify the precompiler option on the command line, instead of in an EXEC ORACLE statement. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt.


PCC-00029

PCC-00029Ambiguous option optnam

Cause:The name of a precompiler option was abbreviated ambiguously. For example, MAX= might refer to MAXLITERAL or MAXOPENCURSORS.

Action:Respecify the full option name or an unambiguous abbreviation. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt.


PCC-00031

PCC-00031Invalid value given for option optnam

Cause:The value specified for a precompiler option is invalid, probably because the value is misspelled (as in LTYPE=HORT) or out of range (as in PAGELEN=-55).

Action:Check the value, making sure it is spelled correctly and within the legal range.


PCC-00032

PCC-00032Invalid option optnam

Cause:The precompiler found an invalid precompiler option name. Some possible causes follow:

The option name is misspelled.

The specified option does not exist.

The equal sign (=) between the option name and value is missing or has space around it.

Action:Check that the option exists and that its name is spelled correctly. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt. Also check that there is an equal sign between the option name and value.


PCC-00033

PCC-00033Missing operand for option optnam

Cause:No value was specified for a precompiler option. Either the value is missing or there is space around the equal sign (as in LTYPE=SHORT).

Action:Check that a value for each option has been specified and that there is no space around the equal sign.


PCC-00036

PCC-00036No input file name specified

Cause:The input file was not specified on the command line.

Action:Use the INAME command-line option to specify the input file.


PCC-00037

PCC-00037Unable to log on to Oracle with username. Oracle error number: ora-nnnnn

Cause:The precompiler was unable to log on to Oracle with the specified username and password. An Oracle error with given number occurred when the logon was attempted.

Action:Refer to the indicated message in Chapter 2msgchpt2. of this manual.


PCC-00038

PCC-00038Unable to open a cursor

Cause:This is an internal error message not usually issued.

Action:Call customer support for assistance. If the application does not require syntactic or semantic checking of SQL statements and does not use PL/SQL, specify SQLCHECK=NONE on the command line.


PCC-00040

PCC-00040Unable to open listing file name

Cause:The precompiler was unable to open the listing file specified by the LNAME precompiler option. Some possible causes follow:

The filename is misspelled.

The file does not exist.

The search path to the file is incorrect.

File access privileges are insufficient.

Another user has locked the file.

There is not enough disk space.

There are too many open files.

Action:Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager). If a listing file is not needed, specify LTYPE=NONE on the command line.


PCC-00041

PCC-00041Unable to open output file name

Cause:The precompiler was unable to open the output file specified by the ONAME precompiler option. Some possible causes follow:

The filename is misspelled.

The file does not exist.

The search path to the file is incorrect.

File access privileges are insufficient.

Another user has locked the file.

There is not enough disk space.

There are too many open files.

Action:Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).


PCC-00042

PCC-00042Must include SQLCA file when MODE=ANSI and WHENEVER SQLWARNING used

Cause:When MODE={ANSI|ANSI14}, an attempt was made to use the WHENEVER SQLWARNING statement without declaring the SQLCA. When MODE={ANSI |ANSI14}, declaring the SQLCA is optional, but to use the WHENEVER SQLWARNING statement, the SQLCA must be declared.

Action:Remove all WHENEVER SQLWARNING statements from the program or declare the SQLCA by hardcoding it or copying it into the program with the INCLUDE statement.


PCC-00044

PCC-00044Array size mismatch in INTO/USING. Minimum is: min (num:num)

Cause:The size of an array variable in an INTO/USING clause is too small for the number of rows processed.

Action:Declare all array variables in the INTO/USING clause to have at least the minimum dimension given.


PCC-00045

PCC-00045clause_name clause inappropriate at line num in file name. Ignored

Cause:There is a misplaced clause at the end of an EXEC SQL statement (an AT clause at the end of a SELECT statement, for example), or the action specified in a FOR clause is invalid (for example, FOR:loop INTO...).

Action:Check the statement syntax, then relocate or correct the misplaced orinvalid clause.


PCC-00047

PCC-00047Unterminated comment/string constant beginning near line num in file name

Cause:A string constant is missing an ending quotation mark, or a comment is missing an ending delimiter.

Action:Check that all comments are delimited and all string constants are enclosed by quotation marks.


PCC-00050

PCC-00050Unable to generate descriptor in program unit ending line num in file name

Cause:The precompiler was unable to generate a descriptor for the compilation unit. This can occur from either of the following:

a non-existent or improperly implemented Declare Section

undetected syntax errors near the beginning of the source file or just before the END DECLARE SECTION statement

Action:Verify that the Declare Section is properly implemented. Then check for syntax errors at the beginning of the compilation unit and before any END DECLARE SECTION statement, and correct as appropriate.


PCC-00051

PCC-00051Size of VARCHAR hostvar at num is larger than 65533 at line num infile name

Cause:The declared size of a VARCHAR host variable exceeds the precompiler limit of 65533 bytes.

Action:Check the Declare Section, making sure the size of each VARCHAR variable does not exceed 65533 bytes.


PCC-00053

PCC-00053FOR variable var is invalid type at line num in file name

Cause:The count variable in a FOR clause has the wrong datatype. The datatype must be NUMBER or LONG (or be compatible with NUMBER or LONG).

Action:Check the declaration and check that the count variable has a datatype of NUMBER or LONG (or a compatible Oracle or host-language datatype).


PCC-00054

PCC-00054Expected end-of-statement at column name in line num of file name

Cause:The precompiler expected to find a statement terminator at the end of an EXEC statement but found something else. This can happen if tabs were embedded in the source code (because the precompiler has no way of knowing how many spaces a tab represents).

Action:If tabs are embedded in the source code, replace them with spaces. Check the statement syntax and check that each EXEC statement has a terminator. For embedded CREATE {FUNCTION|PROCEDURE|PACKAGE} statements and for embedded PL/SQL blocks, check that the statement terminator is END-EXEC.

Action:Correct or remove the erroneous CREATE statement.


PCC-00055

PCC-00055Array name not allowed as bind variable at line num in file name

Cause:A host array was used as a bind (input) variable in the WHERE clause of a SELECT statement. This is not allowed.

Action:Remove the host array or replace it with a simple host variable.


PCC-00056

PCC-00056FOR clause not allowed in SELECT statement at line num in file name

Cause:FOR clause was used with a SELECT statement. This is not allowed, as data returned from the last loop in the execution of the SELECT overwrites data returned in a previous loop.

Action:Remove the FOR clause from the SELECT statement and use a host-language construct to iteratively execute the SELECT statement.


PCC-00060

PCC-00060Both CURSOR and STATEMENT have AT clauses at line num of file name

Cause:Two AT clauses, one in a DECLARE STATEMENT statement, the other in a DECLARE CURSOR statement, pertain to the same SQL statement. The AT clause may be specified with either DECLARE STATEMENT or DECLARE CURSOR but not with both.

Action:Remove the AT clause from one of the statements.


PCC-00061

PCC-00061Error at line num, column name. PLS-nnnnn

Cause:The precompiler found an error in an embedded SQL statement orPL/SQL block.

Action:Refer to the indicated PL/SQL error message and correct the SQL statement or embedded PL/SQL block. See Chapter 3msgchpt3 "PL/SQL Message"..


PCC-00062

PCC-00062Must use option SQLCHECK=SEMANTICS when there isembedded PL/SQL

Cause:The precompiler tried to parse an embedded PL/SQL block when SQLCHECK={SYNTAX|NONE}. PL/SQL blocks can be parsed only when SQLCHECK=SEMANTICS is specified.

Action:Remove the PL/SQL block or specify SQLCHECK=SEMANTICS.


PCC-00063

PCC-00063Reached end of file name before end-of-statement at line num

Action:The precompiler encountered an end-of-file while parsing a PL/SQL block.

Action:Add the appropriate statement terminator (;) or end-of-block statement (END;) to the PL/SQL block.


PCC-00064

PCC-00064All uses of a given host variable must use identical indicator variables

Cause:Two or more occurrences of a host variable in an EXEC SQL statement were associated with different indicator variables. This is not allowed.

Action:Rename the indicator variables so that each occurrence of the host variable is associated with the same indicator variable.


PCC-00065

PCC-00065USERID required, but not specified

Cause:The SQLCHECK=SEMANTICS option was specified, but the USERID option on the command line was not specified.

Action:Specify USERID=username/password or enter a username and password when prompted or specify SQLCHECK={SYNTAX|NONE}.


PCC-00066

PCC-00066USERID only used when SQLCHECK=SEMANTICS, USERID ignored

Cause:The USERID option was specified when SQLCHECK={SYNTAX|NONE}. This is unnecessary.

Action:Specify the USERID option only when SQLCHECK=SEMANTICS.


PCC-00067

PCC-00067IRECLEN exceeded. Line num in file name truncated

Cause:While reading the input file, the precompiler found a line longerthan IRECLEN.

Action:Either shorten the input line or specify a larger IRECLEN value on the command line.


PCC-00068

PCC-00068Host and indicator variables may not have the same name

Cause:In an EXEC SQL statement, an indicator variable had the same name as a host variable. The names of a host variable and its associated indicator variable must be different. Also, an indicator variable cannot be used as a host variable.

Action:Rename the host or indicator variable.


PCC-00069

PCC-00069Host variable var has unsupported datatype at line num in file name

Cause:A host variable had an unsupported datatype. For a list of supported datatypes, see the language-specific supplement to the Programmer's Guide to the Oracle Precompilersorg@LGPG7.hlp.

Action:Redefine the host variable in the Declare Section, giving it asupported datatype.


PCC-00070

PCC-00070Illegal syntax. Exponential value in SQL statement: text

Cause:The precompiler found a syntax error while parsing a number coded in scientific notation. The precompiler expected to find a signed integer following the exponentiation indicator (E), but found something else.

Action:Reformat the number correctly.


PCC-00071

PCC-00071unable to open message file

Cause:The precompiler was unable to open the message file containing the messages that can be issued by the precompiler. This can happen if there are too many open files or if there were problems with installation of the precompiler.

Action:Check that the limit for open files is high enough (check with the system manager). Otherwise, contact customer support.


PCC-00072

PCC-00072Input file name length exceeds 14 characters

Cause:The filename specified exceeded the maximum length. On some operating systems, the maximum length of a filename is 14 characters.

Action:Use a filename of 14 or fewer characters.


PCC-00073

PCC-00073Cursor is declared but never OPENed at line num in file name

Cause:A cursor was DECLAREd but was not referenced in an OPEN statement. This is only an informational message.

Action:Remove the cursor declaration or code an OPEN statement for the cursor.


PCC-00074

PCC-00074FIPS warning: Multiply defined host variable in line num of file name

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the name of a global host variable was used to declare a local host variable. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not reuse the names of global host variables to declare local host variables.


PCC-00075

PCC-00075":" expected before indicator variable

Cause:An indicator variable was not prefixed with a colon, as required.

Action:Prefix a colon to the indicator variable in question.


PCC-00076

PCC-00076DISPLAY type must be SIGN LEADING SEPARATE

Cause:This message is issued only by Pro*COBOL. DISPLAY SIGN LEADING SEPARATE is the only DISPLAY type supported by Pro*COBOL.

Action:Check the spelling of the variable declaration. If necessary, remove the reference to the unsupported DISPLAY type.


PCC-00077

PCC-00077Colon usage with numeric label in WHENEVER statement is not ANSI

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a numeric WHENEVER... GOTO label was prefixed with a colon. For example, the code might have looked like:

EXEC SQL WHENEVER SQLERROR GOTO :99;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, prefix alphanumeric (but not numeric) WHENEVER... GOTO labels with a colon.


PCC-00078

PCC-00078FIPS warning: Invalid ANSI SQL identifier

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the name given to a host variable:

is longer than 18 characters,

does not begin with a letter, or

contains consecutive or trailing underscores

In the following Pro*C example, the host variable name is 19 characters long and therefore non-compliant:

EXEC SQL BEGIN DECLARE SECTION;

int department_location; -- not ANSI/ISO-compliant

...

EXEC SQL END DECLARE SECTION;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, change the host variable name so that it is <=18 characters long, begins with a letter, and does not contain consecutive or trailing underscores.


PCC-00079

PCC-00079ANSI requires colon on label in WHENEVER statement

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an alphanumeric WHENEVER... GOTO label was not prefixed with a colon. For example, the offending code might look like:

EXEC SQL WHENEVER NOT FOUND GOTO no_more;

This message is only a warning issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, prefix alphanumeric (but not numeric) WHENEVER... GOTO labels with a colon.


PCC-00080

PCC-00080TYPE identifier already TYPEd

Cause:The identifier being TYPEd in an EXEC SQL TYPE statement appeared in a previous EXEC SQL TYPE statement. A given identifier can appear in only one EXEC SQL TYPE statement.

Action:Check the spelling of the identifiers. Use different identifiers in the EXEC SQL TYPE statements, or remove one of the EXEC SQL TYPE statements.


PCC-00081

PCC-00081Scale specification not allowed for given datatype

Cause:The Oracle external datatype referenced in an EXEC SQL VAR or EXEC SQL TYPE statement does not allow a scale specification.

Action:Check the precision specification and remove the scale specification.


PCC-00082

PCC-00082Length and scale specifications must be an integer

Cause:A floating point number or a non-number to specify a length or scale was used. Only integers can be used.

Action:Correct or remove the length and/or scale specification.


PCC-00083

PCC-00083Bind and define variables not allowed in CREATE statement

Cause:Host variables cannot appear in a CREATE statement. If the makeup of a CREATE statement cannot be known until run time, a dynamic SQL statement must be used to execute it. That is, the program must accept or build the CREATE statement at run time, store it in a host string, then EXECUTE it.

Action:Correct or remove the erroneous CREATE statement.


PCC-00085

PCC-00085Error writing to file name

Cause:The precompiler was unable to write to the named output file. Some possible causes follow:

Sufficient file access privileges were not defined.

Another user has locked the file.

There is not enough disk space.

There are too many open files.

Action:Check that sufficient privileges exist to access the file and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).


PCC-00086

PCC-00086Source file name has zero length

Cause:The source file specified on the command line contains no code. Consequently, there is nothing for the precompiler to process.

Action:Specify a valid source file containing embedded SQL statements.


PCC-00087

PCC-00087EXEC SQL TYPE statement not allowed for this host language

Cause:An EXEC SQL TYPE statement was used with a host language that does not support user-defined datatype equivalencing. This feature is available only in Pro*C and Pro*Pascal.

Action:Remove the offending EXEC SQL TYPE statement.


PCC-00088

PCC-00088User-defined type identifier expected

Cause:The user-defined datatype name in an EXEC SQL TYPE statement is missing or misspelled, is a reserved word, is not a legal identifier in the host language or conflicts with a base datatype in that language.

Action:Check the spelling of the user-defined datatype name. If necessary, declare a valid user-defined datatype. User-defined datatype equivalencing is available only in Pro*C and Pro*Pascal.


PCC-00089

PCC-00089Invalid Oracle TYPE specification

Cause:The Oracle external datatype name in an EXEC SQL TYPE or EXEC SQL VAR statement is missing or misspelled.

Action:Check the spelling of the external datatype name. If necessary, supply the missing datatype name.


PCC-00090

PCC-00090Precision/scale specification must be given for DECIMAL datatype

Cause:A precision and/or scale specification for the Oracle external datatype DECIMAL in an EXEC SQL TYPE or EXEC SQL VAR statement was omitted.

Action:Add the precision and/or scale specification to the EXEC SQL TYPE or EXEC SQL VAR statement.


PCC-00091

PCC-00091TYPE statement requires format specification for this Oracle datatype

Cause:A length, precision, and/or scale specification for an Oracle external datatype in an EXEC SQL TYPE or EXEC SQL VAR statement was omitted.

Action:Add the length, precision, and/or scale specification for the external datatype to the EXEC SQL TYPE or EXEC SQL VAR statement.


PCC-00092

PCC-00092Length and/or scale incompatible with specified Oracle datatype

Cause:An invalid length or scale for an Oracle external datatype in an EXEC SQL TYPE or EXEC SQL VAR statement was specified.

Action:Check that a length large enough to accommodate the external datatype is specified. If a scale is specified, check that it lies in the range -84 .. 99.


PCC-00093

PCC-00093Invalid or obsolete option, ignored

Cause:The precompiler found an option available in a prior version or different host language but not in the current version or host language.

Action:Remove the option specification.


PCC-00094

PCC-00094Array length for char[n] datatype must be => 2

Cause:When MODE={ANSI|ANSI14}, a length of less than 2 characters for a char[n] host variable was specified or a simple CHAR variable was specified. When MODE={ANSI|ANSI14}, the length must be at least 2 characters. This message is issued only by the Pro*C Precompiler.

Action:Correct the declaration so that it specifies a length of at least 2 characters.


PCC-00095

PCC-00095Missing PROGRAM, SUBROUTINE, FUNCTION, or BLOCKDATA statement

Cause:FORTRAN source files are expected to have at least one PROGRAM, SUBROUTINE, FUNCTION, or BLOCK DATA statement, which the precompiler uses to detect the beginning of a routine or compilation unit.

Action:Add one of these statements to the source file.


PCC-00096

PCC-00096Array FETCH not allowed for MODE=ANSI14

Cause:When MODE=ANSI14, an array SELECT or FETCH was attempted. However, array operations are not allowed when MODE=ANSI14.

Action:If MODE=ANSI14 must be specified, place the SELECT or FETCH statement in a host-language loop, instead of using the array interface.


PCC-00097

PCC-00097Use of DECIMAL and DISPLAY types allowed only for COBOL and PLI

Cause:The DECIMAL or DISPLAY external datatype was used in an EXEC SQL VAR statement with an Oracle Precompiler other than Pro*COBOL or Pro*PL/I. These external datatypes are available only in Pro*COBOL and Pro*PL/I.

Action:Remove the reference to the DECIMAL or DISPLAY external datatype from the EXEC SQL VAR statement.


PCC-00098

PCC-00098Scale specification cannot be used in this context

Cause:In a Pro*C, Pro*FORTRAN, or Pro*Pascal program, scale in an EXEC SQL TYPE or EXEC SQL VAR statement in the current context cannot be specified.

Action:Remove the scale specification from the EXEC SQL TYPE or EXEC SQLVAR statement.


PCC-00099

PCC-00099Length cannot be given for types ROWID, DATE, or MLSLABEL

Cause:A length for the ROWID, DATE, or MLSLABEL external datatype was specified in an EXEC SQL TYPE or EXEC SQL VAR statement. This is unnecessary because those are fixed-length types.

Action:Remove the length specification from the EXEC SQL TYPE or EXECSQL VAR statement.


PCC-00100

PCC-00100Non integer label is not ANSI

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a non-integer WHENEVER... GOTO label was in a Pro*Pascal program. For example, the offending code might look like:

EXEC SQL WHENEVER NOT FOUND GOTO 5.0;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, use only integer WHENEVER... GOTO labels in a Pro*Pascal program.


PCC-00101

PCC-00101Lower case 'e' in floating point number is not ANSI

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a lowercase "e" was used in scientific notation. For example, the offending code might look like:

maxnum = 10e38;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, use an uppercase 'E' in scientific notation.


PCC-00102

PCC-00102FOR UPDATE is an Oracle extension

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR UPDATE OF clause was used in a cursor declaration. For example, the offending code might look like:

EXEC SQL DECLARE emp_cursor CURSOR FOR

SELECT ENAME, SAL FROM EMP WHERE DEPTNO = :dept_number

FOR UPDATE OF SAL;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use the FOR UPDATE OF clause.


PCC-00103

PCC-00103AT clause is an Oracle extension

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the AT db_name clause was used in a SQL statement. For example, the offending code might look like:

EXEC SQL AT oracle3 COMMIT RELEASE;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use the AT db_name clause.


PCC-00104

PCC-00104FOR clause is an Oracle extension

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR clause was used in an array-processing SQL statement. For example, the offending code might look like:

EXEC SQL FOR :limit INSERT INTO EMP (EMPNO, JOB, DEPTNO)

VALUES (:emp_number, :job_title, :dept_number);

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use theFOR clause.


PCC-00105

PCC-00105Keyword WORK required here by ANSI

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the keyword WORK was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like:

EXEC SQL COMMIT WORK RELEASE;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use the keyword WORK.


PCC-00106

PCC-00106RELEASE is an Oracle extension to the COMMIT and ROLLBACK statements

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the parameter RELEASE was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like:

EXEC SQL ROLLBACK RELEASE;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use the parameter RELEASE.


PCC-00107

PCC-00107The CONNECT statement is Oracle implementation dependent

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the CONNECT statement was used to log on to Oracle. For example, the offending code might look like:

EXEC SQL CONNECT :username IDENTIFIED BY :password;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, specify the AUTO_CONNECT command-line option instead of using aCONNECT statement.


PCC-00108

PCC-00108This statement is not supported by ANSI

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming SQL statement such as PREPARE was used. For example, the offending code might look like:

EXEC SQL PREPARE sql_statement FROM :sql_string;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use the nonconforming SQL statement.


PCC-00110

PCC-00110Oracle extension to the WHENEVER statement

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming keyword such as NOTFOUND, STOP, RAISE, or DO was used in the WHENEVER statement. (Note that NOT FOUND is ANSI-compliant.) For example, the offending code might look like:

EXEC SQL WHENEVER SQLERROR STOP;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use the nonconforming keyword.


PCC-00111

PCC-00111SQLCHECK value in EXEC ORACLE statement exceeds command line value

Cause:The SQLCHECK option was entered inline and specified a level of checking higher than the level specified (or accepted by default) on the command line. This is not allowed. For example, if SQLCHECK={SYNTAX|LIMITED} is specified on the command line, SQLCHECK={SEMANTICS|FULL} cannot be specified inline.

This message is only a warning; the precompiler ignores the inline value and continues processing.

Action:Revise the EXEC ORACLE statement or specify a lower level of checking on the command line.


PCC-00112

PCC-00112Datatype not supported by ANSI

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a pointer or nonconforming datatype such as VARCHAR was used. For example, the offending code might look like:

EXEC SQL BEGIN DECLARE SECTION;

VARCHAR username[20];

...

EXEC SQL END DECLARE SECTION;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use pointers or nonconforming datatypes.


PCC-00113

PCC-00113Value of DBMS option invalid with given value of MODE option

Cause:When MODE={ANSI14|ANSI13}, DBMS=V7 was specified, or when MODE=ANSI, DBMS=V6 was specified. These option settings are incompatible. Note that the DBMS option was not available before release 1.5 of the Oracle Precompilers.

Action:With DBMS=V7, instead of MODE={ANSI14|ANSI13}, specify MODE={ANSI|ORACLE}. With DBMS=V6, instead of MODE=ANSI, specify MODE={ANSI14|ANSI13|ORACLE} but MODE=ORACLE is recommended.


PCC-00114

PCC-00114Length spec required in EXEC SQL VAR statements for VARxxx types

Cause:In a EXEC SQL VAR statement, a VARCHAR or VARRAW external datatype was specified without a length. Unlike other types, the maximum length of the data field must be specified for VARCHAR and VARRAW.

Action:Add a length specification to the EXEC SQL VAR statement.


PCC-00115

PCC-00115Array required here

Cause:In an ARRAYLEN statement, the name of a previously declared host array was not specified. The first host variable in an ARRAYLEN statement must be an array. The second host variable, which specifies an array dimension, must be a 4-byte integer. The correct syntax follows:

EXEC SQL ARRAYLEN host_array (dimension);

The ARRAYLEN statement must appear in the Declare Section along with, but somewhere after, the declarations of host_array and dimension.

Action:Check the spelling of both identifiers in the ARRAYLEN statement. If necessary, supply the missing host array name.


PCC-00116

PCC-00116This array already given in an ARRAYLEN statement

Cause:The same host array was specified in two different ARRAYLEN statements. A given host array cannot be specified in more than one ARRAYLEN statement.

Action:Check the spelling of the host array names in both ARRAYLEN statements. Change one of the names so that they refer to different host arrays or remove one of the ARRAYLEN statements.


PCC-00117

PCC-00117Invalid ARRAYLEN length variable type

Cause:A valid array dimension was not specified in an ARRAYLEN statement. The array dimension must be specified using a previously declared 4-byte integer host variable, not a literal or expression. For example, the offending code might look like:

EXEC SQL ARRAYLEN ename_array (25); -- illegal dimension

Action:Supply a valid array dimension. If necessary, declare a 4-byte integer host variable for use in the ARRAYLEN statement.


PCC-00118

PCC-00118Use of host variable initialization not supported by ANSI SQL

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was initialized in its declaration, as shown in the following Pro*C example:

EXEC SQL BEGIN DECLARE SECTION;

int dept_number = 20; -- not ANSI/ISO-compliant

...

EXEC SQL END DECLARE SECTION;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not initialize host variables in their declarations.


PCC-00119

PCC-00119Value of const variable in INTO clause will be modified

Cause:A variable declared with the type specifier const was used in an INTO clause. Such variables should not be modified and should not be used in an INTO clause.

Action:Check the spelling of all identifiers in the INTO clause. If necessary, remove const from the host variable declaration or use a different host variable.


PCC-00120

PCC-00120File I/O error during code generation

Cause:A file I/O error occurred during code generation. This may be caused by insufficient disk space.

Action:Check that there is enough disk space.


PCC-00121

PCC-00121Arrays of VARCHAR pointers are not supported

Cause:An array of pointers was declared, which is not allowed. However, pointers to scalar types are allowed. With Pro*C, declare pointers to char[n] and VARCHAR[n] variables as pointers to CHAR or VARCHAR (with no length specification).

Action:Correct or remove the declaration.


PCC-00122

PCC-00122Input file name and output file name are identical

Cause:On the command line, the same pathname for INAME and ONAME was specified, which designates the precompiler input and output files, respectively.

Action:Change one of the path/filenames.


PCC-00123

PCC-00123Entire VARCHAR declaration must be on same line

Cause:In a Pro*C program, a VARCHAR declaration spans more than one line, which is not allowed.

Action:Revise the declaration so that it uses only one line.


PCC-00124

PCC-00124COMMON_NAME option must be before PROGRAM or subroutine beginning

Cause:In a FORTRAN program, subroutine, or function, the precompiler option COMMON_NAME was mistakenly specified after the PROGRAM, SUBROUTINE, or FUNCTION statement. If COMMON_NAME is specified inline, its EXEC ORACLE OPTION statement must precede the PROGRAM, SUBROUTINE, or FUNCTION statement.

Action:Relocate the EXEC ORACLE OPTION statement or specify COMMON_NAME on the command line.


PCC-00126

PCC-00126Could not find or open system configuration file

Cause:The precompiler was unable to find or open the system configuration file (a text file containing preset command-line options, which the precompiler uses by default). Some possible causes follow:

The file does not exist.

The search path to the file is incorrect.

File access privileges are insufficient.

There are too many open files.

However, this message is just a warning. Processing continues even if the system configuration file does not exist.

Action:Check that the file exists, that the search path to the file is correct, and that sufficient privileges exist to access the file. Also check that the limit for open files is set high enough (check with the system manager).


PCC-00127

PCC-00127text

Cause:This is a generic error message from the command-line processor.

Action:Correct the indicated error.


PCC-00128

PCC-00128Command line processor severe error

Cause:The command line processor encountered a severe error.

Action:After making sure that all the command-line options are specified correctly,call customer support with a full account of all the options and configuration files used.


PCC-00129

PCC-00129option optnam must be given

Cause:A required command-line option is missing. For example, the INAME option, which specifies the name of the input file, might be missing.

Action:Supply the missing command-line option.


PCC-00130

PCC-00130Invalid value val for option optnam

Cause:The precompiler found an invalid option value. For example, the value might have been misspelled (as in DBMS=6V) or illegal (as in DBMS=V5).

Action:Check the value, making sure that it is legal and correctly spelled.


PCC-00132

PCC-00132Indicator array size must not be less than its host variable

Cause:An host variable array was used with an indicator array declared with a smaller dimension. For example:

EXEC SQL BEGIN DECLARE SECTION;

int dept_no[20];

short dept_no_ind[10];

EXEC SQL END DECLARE SECTION;

...

SELECT ... INTO dept_no:dept_no_ind ...

Action:Increase the size of the indicator array.


PCC-00133

PCC-00133Command line option MODE=ANSI required with option NLS_LOCAL=YES

Cause:The precompiler option NLS_LOCAL=YES was used without also specifying MODE=ANSI. The precompiler option MODE=ANSI must be specified if NLS_LOCAL=YES.

Action:Set the precompiler option MODE=ANSI in addition to NLS_LOCAL=YES or do not set NLS_LOCAL=YES.


PCC-00135

PCC-00135Result Set Cursor usage is not standard SQL

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an Oracle Result Set Cursor was used. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action required. However, for ANSI/ISO compliance, do not use Result Set Cursors.


PCC-00136

PCC-00136Invalid SQL_CURSOR declaration

Cause:An array of SQL_CURSOR host variables was declared or, if Pro*COBOL, a PICTURE clause was specified in the SQL_CURSOR declaration. In Pro*FORTRAN, a length specification (i.e., "*n") on the SQL_CURSOR declaration may have been specified. These usages are not supported.

Action:Check that the SQL_CURSOR variable is not declared as an array or, if Pro*COBOL, that no PICTURE clause is specified for the SQL_CURSOR. In Pro*FORTRAN, check that there is no length specification (i.e., "*n") for the SQL_CURSOR.


PCC-00137

PCC-00137Invalid use of SQL_CURSOR host variable

Cause:A SQL_CURSOR variable was used in an INTO or WHERE clause. SQL_CURSOR variables can be used only where ordinary cursor identifiers or, in a PL/SQL block, a cursor would normally be used.

Action:Remove the SQL_CURSOR variable reference from the INTO or WHERE clause, or use a host variable of another type in the INTO or WHERE clause.


PCC-00138

PCC-00138Result Set Cursors are not implemented in this precompiler

Cause:There was an attempt to reference a host variable as a cursor reference. Cursor variables are not implemented in Pro*Pascal or Pro*PL/I.

Action:Rewrite your host-language code to use standard SQL cursors.


PCC-00139

PCC-00139cannot change MAXLITERAL after an EXEC SQL statement

Cause:The MAXLITERAL option has been used in an inline EXEC ORACLE OPTION statement after and EXEC SQL, EXEC TOOLS, or EXEC IAF statement. This is not allowed.

Action:Use the MAXLITERAL option only on the command line or in an EXEC ORACLE OPTION statement placed at the beginning of the input source file.


PCC-00140

PCC-00140CREATE FUNCTION/PROCEDURE/PACKAGE/TRIGGER are Oracle extensions

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, one of the following statements was used:

CREATE FUNCTION

CREATE PROCEDURE

CREATE PACKAGE

CREATE TRIGGER

These statements are Oracle extensions to the ANSI/ISO SQL standards. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action:No action is required. However, for ANSI/ISO compliance, do not use any of these statements.


PCC-00141

PCC-00141Thread Safety is not implemented in this precompiler

Cause:There has been an attempt to use CONTEXT sql statements. The thread safety feature is not implemented in PRO*Pascal, Pro*PL/I, or Pro*C 1.x.

Action:Rewrite your host-language code without using runtime contexts.


PCC-00142

PCC-00142no EXEC SQL CONTEXT USE statement encountered

Cause:No EXEC SQL CONTEXT USE statement was encountered and the option THREADS=YES was requested.

Action:Ensure that the necessary context variable (of type sql_context) has been declared, ALLOCATEd, and USEd prior to any executable SQL statements.


PCC-00143

PCC-00143runtime context variable not of correct type

Cause:The runtime context variable referenced in an EXEC SQL CONTEXT USE statement is not of type sql_context.

Action:Declare your runtime context variable of type sql_context.


PCC-00144

PCC-00144UNSAFE_NULL=YES must be used with DBMS=V7 and MODE=ORACLE

Cause:The option UNSAFE_NULL=YES has been used with DBMS=V6 or DBMS=NATIVE (the default) or has been used with MODE=ANSI/ANSI14/ANSI13.

Action:Either specify MODE=ORACLE and DBMS=V7 when using UNSAFE_NULL=YES or do not use UNSAFE_NULL=YES.


PCC-00145

PCC-00145this statement can only be used with THREADS=YES

Cause:An EXEC SQL ENABLE THREADS or EXEC SQL CONTEXT statement was used with THREADS=NO specified when precompiling.

Action:Specify THREADS=YES when running the precompiler, or remove the EXEC ENABLE THREADS or EXEC SQL CONTEXT statement from the source code.


PCC-00146

PCC-00146illegal value for host option, ignored

Cause:An invalid host language was specified using the command-line host option. The host option valid values are pro* language specific. For example, for Pro*FORTRAN, the only valid value is FORTRAN. For Pro*COBOL, the only valid values are COBOL and COB74.

Action:Specify a valid host language with the host option.


PCC-01000

PCC-01000You are not authorized to run Pro*COBOL

Cause:The authorization or license to run the Pro*COBOL Precompiler has expired.

Action:Call customer support for assistance.


PCC-01001

PCC-01001Your Pro*COBOL authorization is about to expire

Cause:The authorization or license to run the Pro*COBOL Precompiler is aboutto expire.

Action:Call customer support for assistance.


PCC-01002

PCC-01002Invalid character char in indicator area at line num in file name

Cause:In a Pro*COBOL Precompiler program, only a blank, hyphen (-), asterisk (*), slash (/), or letter "D" is allowed in the indicator area, but the precompiler found another character.

Action:Remove or replace the invalid character. If the FORMAT=ANSI option is specified, check for an end-of-line in column 7.


PCC-01003

PCC-01003Invalid continuation at line num in file name

Cause:In a Pro*COBOL program, a continuation line was completely blank, except for the continuation character.

Action:Remove or replace the empty continuation line.


PCC-01004

PCC-01004In an EXEC statement at end-of-file

Cause:In a Pro*COBOL input file, the last EXEC statement was notterminated properly.

Action:Terminate the last EXEC statement with an END-EXEC.


PCC-01005

PCC-01005PROCEDURE DIVISION not found

Cause:The precompiler could not find the PROCEDURE DIVISION header in a Pro*COBOL program. Some possible causes follow:

A keyword in the header is missing or misspelled.

There is an apostrophe in the REMARKS section (the precompiler mistook the apostrophe for the beginning of a string literal).

There is an unterminated literal in the WORKING-STORAGE SECTION.

The wrong value for the FORMAT option was specified.

Action:Check that the PROCEDURE DIVISION header is in place and spelled correctly, that there is no apostrophe in the REMARKS section, that all literals in the WORKING-STORAGE SECTION are terminated, and that the right value for the FORMAT option is specified.


PCC-01006

PCC-01006EXEC statement cannot begin in Area A at line num in file name

Cause:In a Pro*COBOL program, EXEC statements must begin in Area B, but the precompiler found a statement beginning in Area A.

Action:Move the statement rightward so that it begins in Area B.


PCC-01007

PCC-01007WORKING-STORAGE SECTION not found

Cause:The precompiler could not find the WORKING-STORAGE SECTION header in a Pro*COBOL program, probably because a keyword is missing or misspelled, or the wrong value for the FORMAT option might have been specified.

Action:Check that the WORKING-STORAGE SECTION header is in place and spelled correctly and that the right value for the FORMAT option is specified.


PCC-01008

PCC-01008Multiple element records not allowed in Declare Section

Cause:A few COBOL compilers do not allow group items to be passed as parameters in a CALL statement. (Check the COBOL compiler user's guide.) If the compiler is one of these, group items within the Declare Section can contain only one elementary item.

Action:Assign each host variable its own group item.


PCC-01009

PCC-01009For HOST=COB74, a SQL statement must be followed by ELSE or "."

Cause:In a Pro*COBOL program, an EXEC SQL statement is followed by another statement in the same sentence. An EXEC SQL statement must be the last statement in a COBOL-74 sentence and so must be terminated by the keyword ELSE or a period.

Action:Change the program logic, making the EXEC SQL statement the last statement in the sentence.


PCC-01010

PCC-01010Invalid use of NULL character in character literal

Cause:A null character (binary zero) was found in a string literal. This is not allowed by Pro*COBOL.

Action:Remove the null character from the string literal.


PCC-01011

PCC-01011USAGE IS BINARY clause must be terminated by "." on same line

Cause:The period terminating the USAGE IS BINARY clause must be on the same line as the USAGE clause. This message only occurs on operating systems that support the COMP5=YES command line option of Pro*COBOL, where COMP-5 is substituted for BINARY.

Action:Check that the period terminating the USAGE IS BINARY clause is on the same line as the USAGE clause.


PCC-01012

PCC-01012DATA DIVISION not found

Cause:The Pro*COBOL precompiler did not find a DATA DIVISION in the input source file. Pro*COBOL applications are required to have a DATA DIVISION.

Action:Add a DATA DIVISION to the input source file.


PCC-01013

PCC-01013Invalid use of PIC N array variable "variable_name" at line line_number in file name

Cause:A PIC N variable was declared using an OCCURS clause. Tables of PIC N variables are not supported by the Pro*COBOL precompiler.

Action:Declare the PIC N variable without an OCCURS clause or, if the PIC N variable is not used in any SQL statements, declare it outside the Declare Section.


PCC-01014

PCC-01014"VARYING" not supported with PIC N PICTURE clause

Cause:The keyword VARYING was used in a PIC N variable declaration.

Action:Remove the keyword VARYING from the variable declaration. If you want to declare a PIC N VARCHAR variable, specify the precompiler option VARCHAR=YES and declare the variable as an implicit VARCHAR group item as illustrated by the following example:

EXEC SQL BEGIN DECLARE SECTION END-EXEC.

...

01 ENAME.

05 ENAME-LEN PIC S9(4) COMP.

05 ENAME-ARR PIC N(20).

...

EXEC SQL END DECLARE SECTION END-EXEC.


PCC-01015

PCC-01015Cannot equivalence PIC N variable name

Cause:A PIC N variable or an implicit VARCHAR group item (with a PIC N variable as an elementary item) was used in an EXEC SQL VAR statement. This is not allowed.

Action:Do not use a PIC N variable in an EXEC SQL VAR statement. If you want an equivalence to an Oracle type using an EXEC SQL VAR statement, use a PIC X variable instead of a PIC N variable.


PCC-01016

PCC-01016"N" character literals not supported in embedded PL/SQL

Cause:An "N" character literal was used within a PL/SQL block.

Action:Remove the "N" character literal from the PL/SQL block.


PCC-01017

PCC-01017the SQLCA and a SQLCODE variable cannot both be used

Cause:An "N" character literal was used within a PL/SQL block.

Action:Remove the "N" character literal from the PL/SQL block.


PCC-01018

PCC-01018conversion buffer size can only be specified for character types

Cause:A CONVBUFSZ clause has been used in an EXEC SQL VAR statement where the variable is not of a character datatype.

Action:Remove the CONVBUFSZ clause from the EXEC SQL VAR statement.


PCC-01019

PCC-01019Invalid conversion buffer size

Cause:The size specified in a CONVBUFSZ clause must be an integer in the range 1-32765. Either the size given is not an integer or is outside the required range.

Action:Specify an integer in the range 1-32765.


PCC-01100

PCC-01100You are not authorized to run Pro*FORTRAN

Cause:The authorization or license to run the Pro*FORTRAN Precompiler has expired.

Action:Call customer support for assistance.


PCC-01101

PCC-01101Your Pro*FORTRAN authorization is about to expire

Cause:The authorization or license to run the Pro*FORTRAN Precompiler is aboutto expire.

Action:Call customer support for assistance.


PCC-01102

PCC-01102Invalid label at line num in file name

Cause:The Pro*FORTRAN Precompiler found an invalid FORTRAN statement label in columns 1 through 6.

Action:Correct or remove the statement label.


PCC-01200

PCC-01200You are not authorized to run Pro*C

Cause:The authorization or license to run the Pro*C Precompiler has expired.

Action:Call customer support for assistance.


PCC-01201

PCC-01201Your Pro*C authorization is about to expire

Cause:The authorization or license to run the Pro*C Precompiler is about to expire.

Action:Call customer support for assistance.


PCC-01202

PCC-01202Identifier ident truncated to 31 characters

Cause:A host identifier (the name of a host variable, for example) was truncated to the maximum length (31 characters) allowed by the precompiler.

Action:No action required. This message is just informational.


PCC-01300

PCC-01300You are not authorized to run Pro*PL/I

Cause:The authorization or license to run the Pro*PL/I Precompiler has expired.

Action:Call customer support for assistance.


PCC-01301

PCC-01301Your Pro*PL/I authorization is about to expire

Cause:The authorization or license to run the Pro*PL/I Precompiler is about to expire.

Action:Call customer support for assistance.


PCC-01400

PCC-01400You are not authorized to run Pro*Pascal

Cause:The authorization or license to run the Pro*Pascal Precompiler has expired.

Action:Call customer support for assistance.


PCC-01500

PCC-01500You are not authorized to run Pro*Ada

Cause:The authorization or license to run the Pro*Ada Precompiler has expired.

Action:Call Oracle Customer Support for assistance.


PCC-01501

PCC-01501Your Pro*Ada authorization is about to expire

Cause:The authorization or license to run the Pro*Ada Precompiler is about to expire.

Action:Call Oracle Customer Support for assistance.


PCC-01510

PCC-01510No package, procedure, or function statement seen in name

Cause:Every Ada source file must have a package, procedure, or function statement. The precompiler did not find one.

Action:Add the appropriate statement(s) to the source file and rerun Pro*Ada.


PCC-01511

PCC-01511Identifier on line num in file name was too long for code generated infile name

Cause:An identifier used in the host program is of a length that causes precompiler-generated code to exceed the length limitation on source lines.

Action:Use a shorter identifier or use the ORECLEN option to increase the allowed line length.


PCC-01512

PCC-01512Invalid EXEC SQL INCLUDE of file name found at line num in file name

Cause:The EXEC SQL INCLUDE statement is not allowed in Pro*Ada.

Action:Embed required source text directly in the Pro*Ada file. Use the "with" context clause to include required packages.


PCC-01513

PCC-01513FIPS warning: Unsupported datatype in line num of file name

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was declared with a non-ANSI/ISO standard type.

Action:No action required. However, for ANSI/ISO compliance, use only ANSI/ISO standard types.


PCC-01515

PCC-01515FIPS warning: Undeclared host variable hostvar at line num in file name

Cause:An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was declared outside of a Declare Section.

Action:No action required. However, for ANSI/ISO compliance, declare the host variable within a Declare Section.


PCC-02011

PCC-02011Found identifier greater than 128 characters (truncated)

Cause:The precompiler found an identifier that was too long.

Action:Shorten the identifier. SQL identifiers should be limited to 18 characters.


PCC-02012

PCC-02012Did not find a matching quote for CHAR constant

Cause:A character constant with a single quotation mark was not terminated.

Action:Terminate the character constant.


PCC-02013

PCC-02013Unknown escape sequence

Cause:The precompiler found an escape sequence that it could not process inside a string literal. This error can arise when multibyte character strings that can contain shift-in or shift-out escape sequences are used.

Action:Correct the string representation.


PCC-02014

PCC-02014Syntax error at line num, column colnam, file name

Cause:The precompiler detected an error in C or embedded SQL syntax. This message is followed by a more specific error message.

Action:Correct the syntax error.


PCC-02015

PCC-02015Unable to open include file

Cause:The precompiler could not open a header file that was specified using the #include preprocessor directive or the EXEC SQL INCLUDE statement. This can happen if the file specification is inaccurate or if read permission or read access rights on the file or on one or more of the directories in the path werenot granted.

Action:Recheck that the file specification is correct, that the file exists, and that read permission have been granted so that the file can be read.


PCC-02016

PCC-02016Include file pathname is too long

Cause:The pathname for include files exceeded the maximum length of 80 characters.

Action:Move the include file, or create an environment variable or logical to shorten the pathname.


PCC-02017

PCC-02017Unable to open output file

Cause:The precompiler could not open an output file. This could be a generated code output file (.c file) or a listing file. This message can result from many causes. For example:

A pathname for a specified output file contains a non-existent directory.

An operating-system error occurred because the file system or diskis full.

Write permission on the specified directory or directories in the path do not exist.

Action:Track down the cause of the error, as suggested above, and correct it.


PCC-02018

PCC-02018Found end-of-file while scanning comment

Cause:A C comment, either in C code or in an embedded SQL statement, was not terminated.

Action:Find the unterminated comment and terminate it with */.


PCC-02019

PCC-02019Preprocessor warning at line num, column colnam, file name

Cause:This message indicates that a warning condition occurred as the precompiler was doing the preprocessor pass. A more specific warning message will follow this message.

Action:Correct the condition according to the action specified for the messagethat follows.


PCC-02020

PCC-02020Preprocessor error at line num, column colnam, file name

Cause:This message indicates that an error condition occurred as the precompilerwas in the preprocessing phase. A more specific error message will followthis message.

Action:Correct the error according to the action specified for the message that follows.


PCC-02021

PCC-02021Found newline while scanning string literal

Cause:A string constant contains a newline character. For example,

char x[] = "Hello
world";

Action:Remove the newline character.


PCC-02022

PCC-02022Found end of file while scanning a SQL statement

Cause:The precompiler encountered an end of file while parsing an exec sql statement.

Action:Add the statement terminator(;) or complete the exec sql statement.


PCC-02023

PCC-02023Found end of file while scanning a PL/SQL statement

Cause:The precompiler encountered an end of file while parsing a PL/SQL statement (EXEC SQL EXECUTE ...).

Action:Complete the PL/SQL statement.


PCC-02024

PCC-02024NCHAR literals are not permitted inside PL/SQL blocks

Cause:The precompiler found a multi-byte character string in an embedded PL/SQL statement. For example, the offending code might look like

EXEC SQL execute
declare
name char(10) := N'Matsuda';
BEGIN
....
END;
END-EXEC;

Action:Remove multi-byte character string from the PL/SQL block or rewrite the declaration without using NLS_CHAR.


PCC-02025

PCC-02025NLS_LOCAL should be TRUE when using NCHAR literals

Cause:The precompiler detected a multi-byte character host variable(NCHAR literal) when the option NLS_LOCAL was not set to TRUE on the command line. When NLS_LOCAL=TRUE, the runtime library (SQLLIB) performs blank-padding and blank-stripping for host variables that are of multi-byte types.

Action:Specify NLS_LOCAL=TRUE on the command line.


PCC-02035

PCC-02035CMD-LINE: CONFIG= option is invalid in a config file

Cause:A user configuration file inside a user configuration file cannot be specified. That is, nested configuration files cannot be nested.

Action:If there are nested configuration files, move the options from the nested files to the top-level file.


PCC-02040

PCC-02040CMD-LINE: Option selected, but no value provided

Cause:An option on the command line was specified, but a value for it was not included. For example, the offending code might look like:

proc ina=sample1 oname=

could trigger this error message.

Action:Provide a value for the option.


PCC-02041

PCC-02041CMD-LINE: Option does not exist:

Cause:A non-existent option on the command line was specified.

Action:See the Programmer's Guide to the Oracle Precompilers for a list of the valid command-line options and their possible values.


PCC-02043

PCC-02043CMD-LINE: Option syntax is incorrect

Cause:A value for a command-line option was incorrectly specified.

Action:See the Programmer's Guide to the Oracle Precompilers for the correct syntax for specifying command-line option values.


PCC-02044

PCC-02044CMD-LINE: Illegal or out of range value for option: option string

Cause:A value specified for a command-line option was not within the accepted range. For example, the range for the MAXOPENCURSORS option is 5 to 256. If a value outside this range is specified, this message is triggered.

Action:See the Programmer's Guide to the Oracle Precompilers for the ranges that option values can take.


PCC-02045

PCC-02045CMD-LINE: Option is not unique: option name

Cause:An option name was partially specified on the command line that made it non unique. For example, in the command line

proc in=t.pc

the "in" option can imply either the INAME or INCLUDE option.

Action:Provide sufficient characters on the command line to make the optionname unique.


PCC-02046

PCC-02046CMD-LINE: Unable to open config file: filename

Cause:A non-existent user configuration file was specified on the command line with the config option.

Action:Provide a valid filename for the configuration file.


PCC-02047

PCC-02047CMD-LINE: Option is not allowed inline: option string

Cause:An option was entered inline that can only be entered on the command line or in a configuration file. For example, the offending code might look like

EXEC ORACLE OPTION (NLS_CHAR=<name>);

The NLS_CHAR option can only be entered on the command line or in a configuration file.

Action:Remove the option from the source file, and specify it on the command line.


PCC-02066

PCC-02066CMD-LINE: Could not find or could not open system config file

Cause:The system configuration file has a standard name (pmscfg.h) and a location that is operating-system dependent. On UNIX systems, it is located in the $ORACLE_HOME/proc directory. If a file named pmscfg.h is not found in the standard location, this warning message is issued.

Action:Create a system configuration file in the standard location. The file can be empty. See also the operating system-specific Oracle documentation.


PCC-02100

PCC-02100Unable to initialize PL/SQL

Cause:The precompiler connected to Oracle but could not invoke the PL/SQL engine. This error can result if an earlier release of Oracle7 is used without the Procedural Option

Action:To use PL/SQL, upgrade to a more recent release of Oracle7.


PCC-02101

PCC-02101Unable to open input file

Cause:The precompiler could not open the input file. This is the .pc file specified in the INAME= option. This means that the file does not exist, that a directory was incorrectly specified in the pathname, or that the person running the precompiler does not have read permission for the file.

This message could also result from operating-system errors. For example, an unmounted file system or disk I/O errors, could trigger this error.

Action:Check that permission to read the file exists and that the full pathname has been specified correctly. Check for operating system-specific problems. See also the operating system-specific Oracle documentation.


PCC-02102

PCC-02102Fatal error while doing C preprocessing

Cause:The precompiler issues this message after a more specific message.

Action:Correct the problem specified in the previous message or messages.


PCC-02103

PCC-02103Please enter your password:

Cause:The username was specified on the command line without a password.For example:

proc sqlcheck=full iname=sample1.pc userid=scott/

Action:Re-enter the command line, and include the password.


PCC-02104

PCC-02104Unable to connect to Oracle

Cause:The precompiler could not connect to Oracle with the username, password, and, if applicable, database link that was supplied. Note that this is a precompiler message, not a run time message. This means that the USERID option value, either on the command line or in a configuration file,was incorrect.

Action:Check that the username and password are current and correct. Run SQL*DBA or SQL*Plus and verify that connection can be made using that usernameand password.


PCC-02105

PCC-02105Unable to open list file

Cause:The precompiler could not open the listing file. This message can result from many causes. For example:

A pathname for a specified listing file contains a non-existent directory.

An operating-system error occurred because the file system or diskis full.

Write permission on the specified directory has not been granted.

Action:Track down the cause of the error, as suggested above, and correct it.


PCC-02106

PCC-02106Userid only used when SQLCHECK=FULL, userid ignored

Cause:The USERID option was specified on the command line, but SQLCHECK was not equal to FULL or SEMANTICS. The USERID has no effect, unless SQLCHECK=FULL or SQLCHECK=SEMANTICS.

Action:This is a warning message only.


PCC-02107

PCC-02107You may not specify PARSE = FULL when CODE = CPP

Cause:The PARSE=FULL and CODE=CPP options were both specified on the command line. The PARSE=FULL option invokes the C parser, which doesnot understand any C++ constructs generated by the precompiler with CODE=CPP option.

Action:Set the PARSE option to either NONE or PARTIAL if the CODE=CPP optionis specified.


PCC-02129

PCC-02129CMD-LINE: Client supplied static options table is invalid

Cause:This is an internal error message not usually issued.

Action:Call Oracle customer support.


PCC-02132

PCC-02132CMD-LINE: Could not allocate memory

Cause:This is an internal error message not usually issued.

Action:Call Oracle customer support.


PCC-02133

PCC-02133CMD-LINE: Error processing string function

Cause:This is an internal error message not usually issued. It indicates that a C string function, such as strcpy or strlen, returned an error.

Action:Call Oracle customer support.


PCC-02134

PCC-02134CMD-LINE: Null option supplied

Cause:A zero length option was specified on the command line.

Action:Re-enter the command line with a valid option.


PCC-02135

PCC-02135CMD-LINE: User asked for help

Cause:This is a final message that the precompiler issues when information about the command-line options has been requested. For example, if the command

proc ?

is issued to get a list of the current default values for the command-line options, this message appears at the end of the list.

Action:No action required.


PCC-02200

PCC-02200Found unrecognized punctuation sequence

Cause:This error indicates that the precompiler parser encountered a badly-formed identifier or keyword

Action:Correct the syntax.


PCC-02201

PCC-02201Found syntax error

Cause:This general message precedes one or more specific messages that detail the nature of the error.

Action:No action required. Correct the errors diagnosed in the following message(s).


PCC-02202

PCC-02202No TYPEDEF name was given

Cause:The precompiler parser encountered a TYPEDEF statement that had no name after the type specification. For example

typedef int;

Action:Correct the syntax.


PCC-02203

PCC-02203Found end of file when not expected

Cause:The parser can emit this message when a general syntax error occurs, for example, an unmatched `{' or `('.

Action:Correct the syntax.


PCC-02204

PCC-02204EXEC SQL INCLUDE not permitted from within an included file

Cause:EXEC SQL INCLUDE statements cannot be nested. Also, an EXEC SQL INCLUDE statement cannot be put inside a file that is included using the #include preprocessor command.

Action:Recode the program so that the nested include statement is not required.


PCC-02205

PCC-02205Parser error at line num, column colnam, file name

Cause:The precompiler parser encountered a syntax error, either in C code or in SQL code. A more specific message should follow.

Action:No action required for this message. Take the appropriate action for any following messages.


PCC-02206

PCC-02206Host variables are not permitted within a DDL statement

Cause:A Data Definition Language statement cannot use host variables. For example, the statement

CREATE TABLE :table_name (c1 char(10));

is illegal, because the name of the table in a CREATE TABLE statement cannot be represented using a host variable.

Action:Use dynamic SQL to create the names of database objects (tables, views, columns, etc.) at runtime. See the Programmer's Guide to the Oracle Precompilers for information about dynamic SQL.


PCC-02207

PCC-02207Invalid macro name

Cause:The precompiler parser encountered a #DEFINE directive that had no macro name associated with it. For example,

#define

Action:Correct the syntax.


PCC-02208

PCC-02208No filename specified in #include statement

Cause:The precompiler parser encountered a #INCLUDE directive that had no filename associated with it. For example,

#include

Action:Specify appropriate filename with the #INCLUDE directive, or correctthe syntax.


PCC-02209

PCC-02209Macro invocation has incorrect number of arguments

Cause:A macro invocation in the source does not have the same number of arguments as the macro definition in the #DEFINE line.

Action:Correct the macro reference or the macro definition.


PCC-02210

PCC-02210A C++ punctuation sequence was found

Cause:C++ punctuation sequences are not supported by the Pro*C/C++ precompiler.

Action:Rewrite your C++ code without using punctuation sequences and precompileit again.


PCC-02301

PCC-02301Cannot open input file for reading

Cause:The semantic analysis phase of the precompiler could not re-open the input file to generate output code.

Action:Check that the input file and its directory's protections and privileges do not change during precompilation.


PCC-02302

PCC-02302Cannot open code generation output file

Cause:The precompiler was not able to open one or both of the temporary files that are required for code generation. The user executing the precompiler must have write permission (and/or the appropriate privileges) on the current directory.

Action:Check that permission exists to create files in the current directory.


PCC-02303

PCC-02303Cannot open include file

Cause:The precompiler was not able to open a header file specified using the#INCLUDE preprocessor directive or the EXEC SQL INCLUDE statement. This can happen if the file specification is inaccurate or if read permission or read-access rights on the file or on one or more of the directories in the path have not been granted.

Action:Recheck that the file specification is correct, that the file exists, and that read permission has been granted so that the file can be read.


PCC-02304

PCC-02304Invalid declaration of C function

Cause:A C function using invalid syntax was declared.

Action:Consult a C programming manual and correct the declaration.


PCC-02305

PCC-02305Illegal mixing of new and old style C function declarations

Cause:All C functions using either the traditional style (K&R style) function declarations or the new (ANSI) style must be declared; the two styles cannotbe mixed.

Action:Adopt a consist declaration style for functions.


PCC-02306

PCC-02306Illegal name of C function

Cause:A C function was declared with a name that is not a legal C identifier.

Action:Use legal C identifiers for all function names.


PCC-02307

PCC-02307Void can only be used when single parameter

Cause:A function can be declared or defined using the following syntax:

int func1(void)

to indicate that the function has no parameters. void can be used only once in this case.

Action:Remove the extra voids in the function definition or declaration.


PCC-02309

PCC-02309Illegal formal parameter declaration

Cause:A formal parameter in a function declaration was specified without givingits type.

Action:Include the types of all parameters in function declarations.


PCC-02309

PCC-02309Illegal formal parameter declaration

Cause:A formal parameter in a function declaration was specified without giving its type.

Action:Include the types of all parameters in function declarations.


PCC-02310

PCC-02310Formal parameter VARCHARs must be declared as pointers

Cause:Many C compilers allow structures to be passed to and returned from functions. Although a VARCHAR is implemented as a C struct, VARCHARs must be passed to a function as pointers.

Action:Take the address of a VARCHAR when it is passed to a function. See the example in the section "Referencing VARCHAR Variables" in the Programmer's Guide to the Oracle Precompilers.


PCC-02311

PCC-02311Cannot have VARCHAR bit fields

Cause:Host variables cannot contain bit fields.

Action:Recode the application to remove the bit fields.


PCC-02312

PCC-02312Arrays of VARCHAR greater than two dimensions not allowed

Cause:A VARCHAR array with more than two dimensions was declared. Multidimensional arrays are not supported as host variables.

Action:Recode the application to remove multidimensional array usage.


PCC-02313

PCC-02313Malformed VARCHAR declaration - missing length

Cause:When a VARCHAR is declared, a length specification is mandatory. For example, the following VARCHAR declaration is meaningless, hence illegal:

VARCHAR v1[];

Action:Specify the length for each declared VARCHAR.


PCC-02314

PCC-02314Cannot evaluate constant SIZEOF expression

Cause:A SIZEOF operator was used where a precompiler expression was expected.

Action:Eliminate the SIZEOF operator.


PCC-02315

PCC-02315Cannot evaluate expression as a constant.

Cause:The specified expression does not evaluate to a constant. Such expressions are required, for example, as the length of a VARCHAR.

Action:Replace the expression with one that does evaluate to a constant integer


PCC-02316

PCC-02316Illegal operator in constant expression

Cause:A non-arithmetic operator was present in the expression.

Action:Rewrite the expression to eliminate the non-arithmetic operator.


PCC-02317

PCC-02317Illegal cast type expression

Cause:A illegal cast is present in the expression.

Action:Remove the illegal cast.


PCC-02318

PCC-02318Missing type expression

Cause:The specified expression is missing the declaration of a type.

Action:Specify a type for the expression.


PCC-02319

PCC-02319Expression type does not match usage

Cause:The type of a variable does not match its usage. For example, in dynamic SQL, a host variable containing the text of a SQL statement must be declared as a C character type or be equivalenced to the SQL type STRING.

Action:Remove the declaration.


PCC-02320

PCC-02320Arithmetic expression does not have correct operand types

Cause:The arithmetic expression must be specified with integral types.

Action:Rewrite the expression using integral types.


PCC-02321

PCC-02321Only subtraction between two pointers is permitted

Cause:Pointer values cannot be added, multiplied, or divided.

Action:Recode to avoid this error message.


PCC-02322

PCC-02322Found undefined identifier

Cause:An identifier used in a SQL statement was not defined. For example, a cursor name was referenced that had not been declared, or in a DECLARE CURSOR statement, a statement name was used that had not been PREPAREd.

Action:Check that all SQL identifiers, such as cursor names and statement names, have been defined before use.


PCC-02326

PCC-02326Illegal structure reference operation

Cause:A structure component using invalid syntax was referenced. For example, a -> operator was used instead of a required `.' operator.

Action:Correct the invalid reference.


PCC-02327

PCC-02327Struct or struct pointer required

Cause:A scalar host variable was used in a context where a structure (or its pointer)is required.

Action:Make the host variable a structure or add more scalar host variables to satisfy the SQL syntax requirements.


PCC-02328

PCC-02328Undefined struct member

Cause:A structure component was referenced that was not declared as part ofthe structure.

Action:Redefine the structure.


PCC-02330

PCC-02330Expecting an expression of integer type

Cause:The expression does not evaluate to an integer. For example, a SQL FOR expression must evaluate to an integral type.

Action:Rewrite the expression.


PCC-02331

PCC-02331Undefined SQL identifier

Cause:All SQL identifiers must be defined before they are used. This message can result when a CURSOR or STATEMENT is not declared (defined) beforebeing referenced.

Action:Define the identifier.


PCC-02332

PCC-02332Attempted to redefine SQL identifier

Cause:A SQL identifier (such as a cursor name) can be defined only once.

Action:Do not redefine the identifier. Use a different name.


PCC-02333

PCC-02333SQL identifier was not declared as a statement

Cause:A SQL statement identifier was referenced in a DECLARE... CURSOR statement that was not PREPAREd.

Action:Check that all SQL statement names have been declared. Remember that SQL statement names are identifiers, not variables, and that they are local to the precompilation unit.


PCC-02334

PCC-02334SQL identifier was not declared as a cursor

Cause:A cursor name was used in an OPEN, FETCH, or CLOSE statement that had not been DECLAREd.

Action:Check that all SQL cursor names have been declared. Remember that cursors are identifiers, not variables, and that they are local to the precompilation unit.


PCC-02335

PCC-02335Body of cursor must name statement identifier

Cause:In a Dynamic SQL Method 4 application, the DECLARE... CURSOR statement must name a statement identifier that has been PREPAREd in a preceding statement. The PREPARE statement must physically (not logically) precede the DECLARE command.

Action:This error message is followed by another message that gives the line and column of the reference to the statement. Recode the application.


PCC-02336

PCC-02336Host variable expression has invalid type

Cause:The host variable was declared using a C type that is not permitted as a host variable. See the Programmer's Guide to the Oracle Precompilers for a list of the permissible C types for host variables.

Action:Use a permissible host variable type


PCC-02337

PCC-02337Cannot declare multi-dimensioned array for this type

Cause:Host variable arrays of scalars with more than 1 dimension cannot be declared.

Action:Recode the application because this kind of host variable usage is not possible with database operations.


PCC-02338

PCC-02338Structure contains a nested struct or union

Cause:A host structure was used that contained a struct or union. This usage is not legal for Pro*C Release 2.0.

Action:This error message is followed by another message that gives the line and column of the reference to the illegal struct. Redefine the structure.


PCC-02339

PCC-02339Host variables cannot be of union types

Cause:A C union as a host variable cannot be used.

Action:This error message is followed by another message that gives the line and column of the reference to the illegal union. Recode, using a struct or individual scalar host variables.


PCC-02340

PCC-02340Structure contains a bit field

Cause:Bit fields are not allowed in host variables because they are meaningless for database DML operations.

Action:This error message is followed by another message that gives the line and column of the reference to the offending host variable. Recode the application.


PCC-02341

PCC-02341Host variable has illegal type

Cause:A host variable cannot be declared using the void type.

Action:Rewrite the declaration, using a permissible host variable type.


PCC-02342

PCC-02342Using WHERE CURRENT OF on cursor defined without FORUPDATE clause

Cause:When MODE=Oracle, a cursor defined with a WHERE CURRENT OF clause must also have a FOR UPDATE clause.

Action:Rewrite the cursor definition.


PCC-02343

PCC-02343Body of cursor must be a query expression

Cause:A cursor definition must be a SELECT statement.

Action:Rewrite the cursor definition.


PCC-02344

PCC-02344Host variable arrays must all be of equal size

Cause:This is a warning message. If host arrays are not of equal size, the size of the smallest array is used.

Action:No action required.


PCC-02345

PCC-02345SQLCHECK=SEMANTICS must be given when embedded PL/SQL blocks are used

Cause:When a Pro*C program contains embedded PL/SQL blocks, the program must be precompiled using the SQLCHECK=SEMANTICS option, specified either on the command line or in a configuration file.

Action:Use the SQLCHECK=SEMANTICS option. This also requires that the USERID connect option be given.


PCC-02346

PCC-02346PL/SQL found semantic errors

Cause:A database entity, such as a table or column name, was referenced, that does not exist. This is a compile time error, not a runtime error.

Action:Check that all referenced objects in PL/SQL statements actually exist and that the necessary access permission on them have been granted.


PCC-02347

PCC-02347PL/SQL found syntax errors

Cause:A PL/SQL statement was used illegally.

Action:Check the PL/SQL User's Guide and Reference for the correct syntax.


PCC-02348

PCC-02348Indicators are not allowed in EXEC IAF statements

Cause:Indicator variables associated with host variables cannot be used in EXEC IAF statements such as GET and PUT in a user exit.

Action:Eliminate the indicator variables. If feasible (for example with Forms V4), use EXEC TOOLS statements, which do allow indicator variables. See the Programmer's Guide to the Oracle Precompilers for more information of EXEC IAF and EXEC TOOLS statements.


PCC-02349

PCC-02349Precision must be specified for this type

Cause:In a VAR or TYPE statement, certain Oracle types require that the precision be specified. For example, VARCHAR2 or CHAR.

Action:Indicate the precision.


PCC-02350

PCC-02350Cannot equivalence this SQL type

Cause:Datatype or variable equivalencing to the datatypes NUMBER or DECIMAL cannot be used. See the "Datatype Equivalencing" section in the Programmer's Guide to the Oracle Precompilers for more information.

Action:Use the appropriate datatype for the application.


PCC-02351

PCC-02351Illegal datatype equivalencing operation

Cause:The datatype specified could not be equivalenced, or the syntax was incorrect in the VAR or TYPE statement.

Action:See the Programmer's Guide to the Oracle Precompilers for a list of the datatypes that can be equivalenced and the correct syntax of the VAR or TYPE statement.


PCC-02352

PCC-02352Out of bounds bind position from PL/SQL

Cause:This is an internal error.

Action:Call Oracle customer support for assistance.


PCC-02353

PCC-02353Semantic error at line num, column colnam, file name

Cause:This error message precedes a more specific error message.

Action:No action required. Correct the error(s) reported in the following message(s).


PCC-02354

PCC-02354A file included with #INCLUDE cannot contain SQL statements

Cause:The Pro*C Precompiler reads header files referenced in #INCLUDE directives and uses the values defined in them. But the precompiler never generates code using statements in header files, so use of SQL statements in these filesis illegal.

Action:Move the SQL statement(s) into the main body of the application or use EXEC SQL INCLUDE to check that the included file is precompiled.


PCC-02355

PCC-02355Invalid or obsolete option, ignored

Cause:A command-line option that is not used in Pro*C Release 2.0 was specified. For example, the option AREASIZE is no longer valid with precompilers used with the Oracle7 Server.

Action:No action required. This is an informational message.


PCC-02356

PCC-02356Warning at line num, column colnam, file name

Cause:This is a generic warning message. It precedes a more specific warning.

Action:No action required. Correct the error(s) indicated in the following messages.


PCC-02357

PCC-02357Function calls may not be used as host variable expressions

Cause:Only objects that are lvalues (that resolve to an address) can be host variables. Because a function call is not an lvalue, one cannot be used in place of ahost variable.

Action:Recode the application.


PCC-02358

PCC-02358Identifier following ARRAYLEN must be the name of an array

Cause:A declared array must be specified as the argument for an ARRAYLEN statement. Declare the array textually before the ARRAYLEN statement. Seethe Programmer's Guide to the Oracle Precompilers for the syntax of the ARRAYLEN statement.

Action:Correct the statement, specifying a host array as the argument.


PCC-02359

PCC-02359Identifier specifying ARRAYLEN dimension must be an integer

Cause:The expression that specifies the ARRAYLEN dimension must evaluate to an integer. For example, the statement

EXEC SQL ARRAYLEN my_array(1.3)

cannot be parsed.

Action:Correct the statement, using an integral dimension.


PCC-02360

PCC-02360This array type is invalid for use with ARRAYLEN statement

Cause:Arrays of some host variables types are not allowed and hence also cannot be used in ARRAYLEN statements. VARCHAR is an example.

Action:Specify an array with a datatype that can be used in host arrays.


PCC-02361

PCC-02361Use of ARRAYLEN with SQL host arrays is ignored

Cause:ARRAYLEN is only valid with arrays that can be bound in PL/SQL blocks.

Action:Use an appropriate array type.


PCC-02362

PCC-02362Host variable not declared within SQL Declare Section

Cause:When MODE=ANSI is specified at precompile time, all host variables must be declared inside Declare Sections. Remember that MODE=ANSI refers to ANSI SQL, not ANSI C.

Action:Add the EXEC SQL BEGIN DECLARE SECTION... EXEC SQL END DECLARE SECTION statements around all host variable declarations.


PCC-02363

PCC-02363Indicator variable must be a structure

Cause:If the host variable is a structure, the associated indicator variable must also be a structure.

Action:Recode the application.


PCC-02364

PCC-02364Host structure and its indicator must have the same number of fields

Cause:When a structure containing indicator variables is declared and associated with a host structure, the indicator structure must contain the same number of fields as the host structure. This is so even when some of the indicators will not be used or even when it would not make sense to do so (for fields constrained as NON NULL, for example).

Action:Redeclare the indicator structure.


PCC-02365

PCC-02365Host and its indicator variable must have the same array dimensions

Cause:When associating an array of indicators with a host array, it is good practiceto make the indicator array the same length as the host array. It should neverbe shorter.

Action:This is a warning message. The smallest array size will determine the number of items fetched, inserted, or updated.


PCC-02366

PCC-02366Command line argument MODE=ANSI may not be used with DBMS=V6

Cause:The semantics of certain operations (such as character comparison) in Oracle Version 6 are not 100% compliant with the ANSI/ISO SQL standards. When V6 semantics are requested, using the DBMS=V6 or DBMS=V6_CHAR option, precompilation with MODE=ANSI is not permitted.

Action:Do not use ANSI mode with the V6 options.


PCC-02367

PCC-02367Indicator variables must be declared as type short

Cause:The only C type allowed for indicator variables is short. An array of indicator variables must be an array of shorts.

Action:Redeclare the indicator variables and/or indicator arrays.


PCC-02368

PCC-02368An EXEC TOOLS host variable context name is not type char

Cause:If a host variable is used to define a context name in an EXEC TOOLS GET CONTEXT or EXEC TOOLS SET CONTEXT statement, the host variable must be a character type.

Action:Redeclare the context name host variable.


PCC-02369

PCC-02369An EXEC TOOLS host pointer variable is not a pointer

Cause:The host variable specifying an EXEC TOOLS context must be a pointer type

Action:Redeclare the variable, making sure that it is a pointer.


PCC-02370

PCC-02370An EXEC TOOLS message host variable is not type char

Cause:If a host variable is used to define a context name in an EXEC TOOLS GET CONTEXT or EXEC TOOLS SET CONTEXT statement, the host variable must be a character type.

Action:Redeclare the context name host variable.


PCC-02371

PCC-02371Illegal FOR clause

Cause:The argument of a FOR clause must be specified as an integer or as an identifier containing an integer.

Action:Rewrite the FOR clause.


PCC-02372

PCC-02372FOR clause not allowed in a SELECT statement

Cause:A SQL statement containing a SELECT command cannot contain a FOR clause. The meaning of such a statement would be unclear.

Action:Rephrase the SELECT statement, removing the FOR clause.


PCC-02373

PCC-02373Invalid declaration in EXEC SQL DECLARE section

Cause:An improper declaration was placed in a Declare Section. This message is usually caused by including an EXEC SQL TYPE or EXEC SQL VAR declaration in a Declare Section.

Action:Move the declaration outside the Declare Section.


PCC-02374

PCC-02374SQLCHECK value exceeds command line value

Cause:The value assigned to the SQLCHECK option in an EXEC Oracle statement in a program was greater than the value given either on the command line or greater than the default value if no SQLCHECK option was given on the command line.

The order of the option values is SEMANTICS > SYNTAX > NONE.

When this warning message is issued, the original value of SQLCHECK (the default or the command-line value) stays in effect.

Action:Remove or recode the EXEC Oracle option(s) in the .pc source file to avoid this warning message.


PCC-02375

PCC-02375SQL statement found outside the body of a function

Cause:A SQL statement other than a declarative, datatype equivalence or WHENEVER statement was found outside the body of a function when PARSE=FULL.

Action:Move the SQL statement inside the body of a function.


PCC-02376

PCC-02376You may not declare SQLCODE when DEF_SQLCODE = TRUE

Cause:The DEF_SQLCODE option may not be specified if a SQLCODE declaration already explicitly appears in the program.

Action:Remove the SQLCODE declaration from the program or specify DEF_SQLCODE=NO (the default).


PCC-02377

PCC-02377Arrays of implicit VARCHARs are not permitted

Cause:An array of implicit VARCHARs was declared when HOST_VARCHAR=TRUE.

Action:Rewrite the implicit VARCHAR declaration without using arrays.


PCC-02378

PCC-02378Invalid type for National Language character variable

Cause:A variable declared as a National Language character using the NLS_CHAR option was not declared as a char or implicit VARCHAR.

Action:Declare the variable as a char or implicit VARCHAR or do not specify using the NLS_CHAR option.


PCC-02379

PCC-02379Cannot equivalence National Language character variables

Cause:A National Language character variable (specified using the NLS_CHAR option) has undergone datatype equivalencing using either the EXEC SQL VAR or TYPE statements.

Action:Do not equivalence National Language character variables.


PCC-02380

PCC-02380NLS_LOCAL should be TRUE when using NLS_CHAR

Cause:NLS_CHAR was used to specify National Language character variables without specifying NLS_LOCAL=TRUE.

Action:Specify NLS_LOCAL=TRUE. Note that in future releases, this will nolonger apply.


PCC-02381

PCC-02381Cannot use National Language character variables inside PL/SQL

Cause:A variable or fixed length National Language character variable was used in an embedded PL/SQL block.

Action:Remove the variable from the block or use another one having a legalbind type.


PCC-02382

PCC-02382You must specify MODE = ANSI when using NLS_CHAR

Cause:NLS_CHAR was used to specify NLS multi-byte character variables without specifying MODE=ANSI.

Action:Specify MODE=ANSI on the command line.


PCC-02383

PCC-02383Arrays of National Language variables are not permitted

Cause:A variable used as a bind or define variable declared using NLS_CHAR was declared as an array of National Language character strings.

Action:Rewrite the declaration without using arrays or choose not to specify using NLS_CHAR.


PCC-02384

PCC-02384Missing array length specifier

Cause:An array declaration was given without an array length specifier.

Action:Provide the length for the array declaration.


PCC-02385

PCC-02385You may not specify DBMS = V6_CHAR when using NLS_CHAR

Cause:The DBMS=V6_CHAR option was specified on the command line while indicating which host variables are to be treated by the precompiler as NLS multi-byte character variables. A multi-byte character string must be null-terminated, but if the DBMS=V6_CHAR option is specified, the precompiler pads the character arrays with blanks up to the length of the array without the null-terminator.

Action:Remove the DBMS=V6_CHAR option from the command line.


PCC-02386

PCC-02386Use of the AT clause is not permitted here

Cause:An explicit AT clause was used with an ALLOCATE statement or a FETCH/CLOSE statement also using a SQL_CURSOR declaration.

Action:Remove the AT clause.


PCC-02387

PCC-02387Expecting an expression of type SQL_CURSOR

Cause:A host bind variable was used in an ALLOCATE, FETCH or CLOSE statement that was not declared as a result set SQL_CURSOR.

Action:Declare the variable to be of type SQL_CURSOR.


SQL-02101

SQL-02101Inconsistent cursor cache. Unit cursor/global cursor mismatch

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02102

SQL-02102Inconsistent cursor cache. No global cursor entry

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02103

SQL-02103Inconsistent cursor cache. Out of range cursor cache reference

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02104

SQL-02104Inconsistent host cache. No cursor cache available

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02105

SQL-02105Inconsistent cursor cache. Global cursor not found

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02106

SQL-02106Inconsistent cursor cache. Invalid Oracle cursor number

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02107

SQL-02107Program too old for runtime library; please re-precompile it

Cause:The program was precompiled by an older version of the Oracle Precompilers, which is incompatible with this release of SQLLIB.

Action:Precompile the program with a newer version of the Oracle Precompilers.


SQL-02108

SQL-02108Invalid descriptor passed to run-time library

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02109

SQL-02109Inconsistent host cache. Host reference is out of range

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02110

SQL-02110Inconsistent host cache. Invalid host cache entry type

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02111

SQL-02111Heap consistency error

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02112

SQL-02112SELECT ... INTO returns too many rows

Cause:A SELECT ... INTO statement returned more rows than can be stored in the host variable provided.

Action:There are three possible solutions:

Use the precompiler option SELECT_ERROR=NO.

Declare a host variable with a larger array dimension.

Declare a cursor or cursor variable for the select statement.


SQL-02113

SQL-02113Unable to open message file

Cause:SQLLIB was unable to find or open the file, ora_sqllib:sqlli*.msb.

Action:Check that ora_sqllib is properly defined, and that a sqlli*.msb file exists andis readable.


SQL-02114

SQL-02114Invalid SQL Cursor usage: trying to CLOSE a CLOSEd cursor

Cause:An attempt was made to CLOSE a cursor that was already CLOSEd with MODE={ANSI|ANSI14}. A CLOSEd cursor can be re-CLOSEd only when MODE={ORACLE|ANSI13}.

Action:When MODE={ANSI|ANSI14}, verify that a cursor is not already CLOSEd before trying to CLOSE it. Specify MODE={ORACLE|ANSI13} if a CLOSEd cursor is to be re-CLOSEd.


SQL-02115

SQL-02115Code interpretation problem -- check COMMON_NAME usage

Cause:With Pro*FORTRAN, this error occurs if the precompiler option COMMON_NAME is specified incorrectly. With other Oracle Precompilers, this error occurs when the precompiler cannot generate a segment of code.

Action:With Pro*FORTRAN, when using COMMON_NAME to precompile two or more source modules, make sure to specify a different common name for each module. With other Oracle Precompilers, if the error persists, call customer support for assistance.


SQL-02116

SQL-02116FATAL ERROR: Reentrant code generator gave invalid context

Cause:This internal error typically indicates a memory-related error.

Action:Check the program for memory-related errors, such as invalid pointers or array-bounds violations.


SQL-02117

SQL-02117Invalid SQL Cursor usage: trying to OPEN an OPENed cursor

Cause:An attempt was made to OPEN an cursor that was already OPENed with MODE={ANSI|ANSI14|ANSI13}. An open cursor can be re-OPENed only when MODE=ORACLE.

Action:When MODE={ANSI|ANSI14|ANSI13}, verify that a cursor is not already OPEN before trying to OPEN it. Specify MODE=ORACLE if an OPENed cursor is to be re-OPENed to avoid reparsing.


SQL-02118

SQL-02118Invalid row for a WHERE CURRENT OF operation

Cause:An attempt was made to reference a nonexistent row using the CURRENT OF clause in an UPDATE or DELETE statement. This happens when no FETCH has been executed or when FETCH returns a "no data found" error that the program fails to trap.

Action:Check that the last cursor operation succeeded and that the current row of the cursor is valid. The outcome of a cursor operation can be checked in two ways: implicit checking with the WHENEVER statement or explicit checking of SQLCODE in the SQLCA.


SQL-02119

SQL-02119Invalid HSTDEF argument

Cause:A non-null pointer was given for an HSTDEF as the second argument to a SQLRCN call when the first argument was also used. Either the first or the second argument to SQLRCN must be null.

Action:Pass a null pointer in either the first or second argument to SQLRCN.


SQL-02120

SQL-02120First and second arguments to SQLRCN both null

Cause:Both the first and second arguments to SQLRCN were null. An HSTDEF must be passed into SQLRCN in the form of either an OCI LDA (first argument) or as an HSTDEF pointer itself (second argument).

Action:Pass either an OCI LDA or a HSTDEF, but not both.


SQL-02121

SQL-02121Invalid host name

Cause:The host name passed into a SQLFCN call was not used in a previous callto SQLRCN.

Action:Use the same identifier used in the corresponding SQLRCN call.


SQL-02122

SQL-02122Invalid OPEN or PREPARE for this database connection

Cause:An attempt was made to execute an OPEN or PREPARE statement using a cursor that is currently open for another database connection and, therefore, cannot be used for this connection.

Action:Close the cursor to make it available for this connection or use a different cursor for this connection.


SQL-02123

SQL-02123Context referenced in EXEC TOOLS GET CONTEXT statement not found

Cause:The context name given in the EXEC TOOLS GET CONTEXT statement was never stored with an EXEC TOOLS SET CONTEXT statement.

Action:Use the EXEC TOOLS SET CONTEXT statement to save any contexts to be retrieved later.


SQL-02124

SQL-02124NULL value returned by EXEC TOOLS statement

Cause:An EXEC TOOLS statement returned a null to a host variable that lacks an indicator variable. This error occurs only when MODE=ANSI. When MODE=ORACLE, although the value of the host variable is indeterminate, no error is generated.

Action:Associate an indicator variable with each host variable to which nulls mightbe returned.


SQL-02125

SQL-02125Connect error, can't get error text

Cause:No connection (not even to the default host) was available, so SQLLIB could not get the message text for the Oracle error that occurred. However, SQLLIB returns the Oracle error number, which can be used to look up the message.

Action:Lookup up the appropriate message in Oracle7 Server Messages and follow the Cause and Action information provided.


SQL-02126

SQL-02126Number of array elements cannot be negative (i.e. < 0)

Cause:The precompiler found a negative number of array elements in the N or F variable of the SQLDA (SQL Descriptor Area, which is used with dynamic SQL Method 4). Before executing the DESCRIBE statement, N must be set to the dimension of the descriptor arrays. After executing the DESCRIBE statement, N must be reset to the actual number of variables DESCRIBEd, which is stored in the F variable.

Action:Check that the N and F variables are set to non-negative values.


SQL-02127

SQL-02127Precompiler/SQLLIB version mismatch

Cause:The program was linked to an older version of SQLLIB, which is incompatible with this release of the Oracle Precompilers.

Action:Relink the program with the appropriate version of SQLLIB.


SQL-02128

SQL-02128Sessions still exist, not logged off

Cause:A host was not removed ("logged off") from SQLLIB because XA still has sessions associated with that host.

Action:Before calling SQLXDH to drop a host, XA must either drop all sessions for that host or set the doit_anyway flag.


SQL-02129

SQL-02129FETCHed number of bytes is odd

Cause:The program tried to FETCH an invalid column value into a multi-byte NLS host variable. Specifically, the column did not contain valid double-byte data.

Action:Make sure the column contains only double-byte data. To verify this, use SQL*Plus or Server Manager.


SQL-02130

SQL-02130EXEC TOOLS interface is not available

Cause:An attempt was made to link with a version of an Oracle tool that does not support the EXEC TOOLS interface.

Action:Either upgrade the Oracle tool, or use the EXEC IAF interface.


PCF-00252

PCF-00252use of the C preprocessor within SQL


PCF-00253

PCF-00253use of the AT clause


PCF-00254

PCF-00254use of the FOR clause


PCF-00255

PCF-00255use of the CONNECT statement


PCF-00256

PCF-00256SQLCODE returns non-standard values


PCF-00257

PCF-00257keyword WORK required after COMMIT


PCF-00258

PCF-00258keyword WORK required after ROLLBACK


PCF-00259

PCF-00259use of RELEASE clause


PCF-00260

PCF-00260use of dynamic SQL


PCF-00261

PCF-00261use of PL/SQL


PCF-00262

PCF-00262use of SQLWARN within WHENEVER clause


PCF-00263

PCF-00263use of NOTFOUND within WHENEVER clause


PCF-00264

PCF-00264use of NOT FOUND within WHENEVER clause


PCF-00265

PCF-00265use of STOP within WHENEVER clause


PCF-00266

PCF-00266use of RAISE within WHENEVER clause


PCF-00267

PCF-00267use of DO within WHENEVER clause


PCF-00268

PCF-00268use of DECLARE TABLE statement


PCF-00269

PCF-00269use of DECLARE DATABASE statement


PCF-00270

PCF-00270use of EXEC SQL INCLUDE


PCF-00271

PCF-00271use of EXEC SQL TYPE


PCF-00272

PCF-00272use of SQL FORMS statement


PCF-00273

PCF-00273use of EXEC ORACLE statement


PCF-00274

PCF-00274invalid datatype


PCF-00275

PCF-00275use of DROP TABLE statement


PCF-00276

PCF-00276use of non-ANSI function


PCF-00277

PCF-00277use of non-ANSI function


PCF-00278

PCF-00278use of the ALLOCATE statement


PLS-00101

PLS-00101reserved for future use

Not in Release 2.2.


PLS-00102

PLS-00102parser stack overflow because nesting is too deep

Cause:The parser, which checks the syntax of PL/SQL statements, uses a data structure called a stack; the number of levels of nesting in your PL/SQL block exceeded the stack capacity.

Action:Reorganize your block structure to avoid nesting at too deep a level. For example, move the lowest-level sub-block to a higher level.


PLS-00103

PLS-00103found 'str' but expected one of the following: 'str'

Cause:This message is from the parser. It found a token (language element) that is inappropriate in this context.

Action:Check previous tokens as well as the one given in the message. The line and column numbers given in the following message refer to the end of the faulty language construct.


PLS-00108

PLS-00108declarative units must be a single variable declaration

Cause:While checking a declarative unit (a top-level declare block without the BEGIN...END), PL/SQL found that there was more than one item declared or that the item was not a variable declaration. A table is a common variable declaration at the unit level. To define a TABLE you can compile a DECLARE compilation unit, but only one at a time is allowed.

Action:Declare variables in separate declarative units.


PLS-00105

PLS-00105at most one forward declaration of type name is permitted

Not in Release 2.2.


PLS-00108

PLS-00108declarative units must be a single variable declaration

Cause:While checking a declarative unit (a top-level declare block without the BEGIN...END), PL/SQL found that there was more than one item declared or that the item was not a variable declaration. A table is a common variable declaration at the unit level. To define a TABLE, compile a DECLARE compilation unit, but only one at a time is allowed.

Action:Declare variables in separate declarative units.


PLS-00109

PLS-00109unknown exception name 'name' in PRAGMA EXCEPTION_INIT

Cause:No declaration for the exception name was found within its scope.

Action:Make sure the pragma follows the exception declaration and is within the same scope.


PLS-00110

PLS-00110bind variable 'name' not allowed in this context

Cause:A bind variable, that is, an identifier prefixed with a colon, was found in an inappropriate context.

Action:Remove the colon or replace the bind variable with the appropriate object.


PLS-00111

PLS-00111end-of-file in comment

Cause:A comment had a comment initiator (/*), but before the comment terminator (*/) was found, an end-of-file marker was encountered.

Action:Remove the comment initiator or add a comment terminator. The line and column numbers given in the following message refer to the beginning of the last legal token before the comment initiator.


PLS-00112

PLS-00112end-of-line in quoted identifier

Cause:A quoted identifier had a beginning quote ("), but before the ending quote (") was found, an end-of-line marker was encountered.

Action:Remove the beginning quote or add the ending quote. The line and column numbers given in the message refer to the beginning of the quoted identifier.


PLS-00116

PLS-00116duplicate WHERE clause in table expression

Cause:Two or more WHERE clauses were found in a DELETE, SELECT, or UPDATE statement. The WHERE clause specifies a condition under which rows in a table are processed. The condition can contain several logical expressions connected by AND or OR, but a statement can contain only one WHERE clause.

Action:Remove one of the WHERE clauses and, if necessary, connect logical expressions by AND or OR.


PLS-00114

PLS-00114identifier name too long

Cause:The name of a PL/SQL variable is longer than 30 characters. Legal identifiers (including quoted identifiers) have a maximum length of 30 characters. A string literal might have been mistakenly enclosed in double quotes instead of single quotes, in which case PL/SQL considers it a quoted identifier.

Action:Shorten the name to 30 characters or less. If a string literal is being used, replace the double quotes with single quotes.


PLS-00115

PLS-00115this PRAGMA must follow the declaration of name

Cause:The pragma refers to a PL/SQL object that was not declared or is not within the scope of the reference. Identifiers must be declared before they are used in a pragma; forward references are not allowed.

Action:Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00116

PLS-00116duplicate WHERE clause in DELETE, SELECT, or UPDATE statement

Cause:Two or more WHERE clauses were found in a DELETE, SELECT, orUPDATE statement. The WHERE clause specifies a condition under which rows in a table are processed. The condition can contain several logical expressions connected by AND or OR, but a statement can contain only one WHERE clause.

Action:Remove one of the WHERE clauses and, if necessary, connect logical expressions by AND or OR.


PLS-00117

PLS-00117duplicate CONNECT BY clause in table expression

Cause:Two or more CONNECT BY clauses were found in a SELECT statement. The CONNECT BY clause defines a relationship used to return rows in a hierarchical order. The relationship can contain two expressions separated by a relational operator (such as = or !=), but a statement can contain only one CONNECT BY clause.

Action:Remove one of the CONNECT BY clauses and, if necessary, separate expressions by a relational operator.


PLS-00118

PLS-00118duplicate GROUP BY clause in table expression

Cause:Two or more GROUP BY clauses were found in a SELECT statement. The GROUP BY clause lists column expressions used to form a summary row for each group of selected rows. The list can contain several column expressions separated by commas, but a statement can contain only one GROUP BY clause.

Action:Remove one of the GROUP BY clauses and, if necessary, separate column expressions by commas.


PLS-00119

PLS-00119duplicate HAVING clause in table expression

Cause:Two or more HAVING clauses were found in a SELECT statement. The HAVING clause specifies a condition under which groups of rows (formed by the GROUP BY clause) are included in the result. The condition can include several logical expressions connected by AND or OR, but a statement can contain only one HAVING clause.

Action:Remove one of the HAVING clauses and, if necessary, connect logical expressions by AND or OR.


PLS-00120

PLS-00120inappropriate argument in OPEN statement

Cause:The cursor_name parameter in an OPEN statement is misspelled or does not refer to a legally declared cursor.

Action:Check your spelling of the cursor_name parameter. Make sure the cursor was declared properly.


PLS-00121

PLS-00121only the set function COUNT may take * as an argument

Cause:The asterisk (*) option was used in the argument list of a SQL group function other than COUNT. For example, the code might look like

SELECT SUM(*) INTO emp_count FROM emp; -- should be COUNT(*)

Only COUNT permits the use of the asterisk option, which returns the number of rows in a table.

Action:Remove the asterisk option from the argument list and replace it with an expression that refers to one or more database columns.


PLS-00123

PLS-00123program too large

Cause:PL/SQL was designed primarily for robust transaction processing. One consequence of the special-purpose design is that the PL/SQL compiler imposes a limit on block size. The limit depends on the mix of statements in your PL/SQL block. Blocks that exceed the limit cause generate this message.

Action:The best solution is to modularize your program by defining subprograms, which can be stored in an ORACLE database. Another solution is to break your program into two sub-blocks. Have the first block INSERT any data the second block needs into a temporary database table. Then, have the second block SELECT the data from the table.


PLS-00124

PLS-00124name of exception expected for first argument in EXCEPTION_INIT pragma

Cause:The first argument passed to the EXCEPTION_INIT pragma was something other than an exception name. The first argument must be the name of a legally declared exception.

Action:Replace the first argument with the name of a legally declared exception.


PLS-00125

PLS-00125type name expected

Cause:When a constant or variable was declared, its datatype was not specified. For example, the code might look like

pi CONSTANT := 3.14159; -- should be CONSTANT REAL := 3.14159

Every constant and variable must have a datatype, which specifies a storage format, constraints, and valid range of values.

Action:Supply the missing datatype specifier.


PLS-00126

PLS-00126selector ALL is not allowed

Cause:The ALL shortcut for specifying system privileges or statement options was used in a SQL statement. PL/SQL does not support the ALL shortcut.

Action:Remove the ALL shortcut from the SQL statement.


PLS-00127

PLS-00127pragma name is not a supported pragma

Cause:The named pragma (compiler directive) is not among those supported by PL/SQL. The pragma name might be misspelled, or the pragma syntax might be faulty.

Action:Check the spelling of the pragma name, and make sure the proper syntax was used.


PLS-00128

PLS-00128illegal number of arguments for pragma name

Cause:The number of arguments (actual parameters) passed to the named pragma (compiler directive) is incorrect. A required argument was omitted from the argument list, or the pragma syntax is faulty (for example, a comma might be missing between two parameters).

Action:Supply the missing argument, or correct the faulty syntax.


PLS-00129

PLS-00129pragma INTERFACE only supports C as its first argument

Cause:The first parameter passed to pragma INTERFACE specified a host language other than C. Currently, C is the only host language supported. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the spelling of the first parameter, which should be C, and make sure the proper syntax was used.


PLS-00130

PLS-00130pragma name expects 1st argument to be a procedure/function/package/ cursor

Cause:The first argument (actual parameter) passed to the named pragma (compiler directive) was not the name of a subprogram, package, or cursor, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the spelling of the first parameter, and make sure the proper syntax was used.


PLS-00131

PLS-00131pragma name expects 2nd argument to be a procedure

Cause:The second argument (actual parameter) passed to the named pragma (compiler directive) was not the name of a procedure, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the spelling of the second parameter, and make sure the proper syntax was used.


PLS-00132

PLS-00132 pragma RESTRICT_REFERENCES does not support str

Cause:One of the parameters passed to pragma RESTRICT_REFERENCES was not among the following, as required: WNDS, WNPS, RNDS, RNPS. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the spelling of all the parameters, and make sure the proper syntax was used.


PLS-00133

PLS-00133pragma name expects 1st argument to be an identifier or string literal

Cause:The first argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or string literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the spelling of the first parameter, and make sure the proper syntax was used.


PLS-00134

PLS-00134pragma name expects 2nd argument to be an identifier

Cause:The second argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the spelling of the second parameter, and make sure the proper syntax was used.


PLS-00135

PLS-00135pragma name expects 3rd argument to be an identifier or string literal

Cause:The third argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or string literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the spelling of the third parameter, and make sure the proper syntax was used.


PLS-00136

PLS-00136pragma name expects 3rd argument to be an empty string

Cause:The third argument (actual parameter) passed to the named pragma (compiler directive) was not an empty string, as required. The parameter might be coded incorrectly, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the coding of the third parameter, and make sure the proper syntax was used.


PLS-00137

PLS-00137pragma name expects 4th argument to be a numeric-literal

Cause:The fourth argument (actual parameter) passed to the named pragma (compiler directive) was not a numeric literal, as required. The parameter might be coded incorrectly, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action:Check the coding of the fourth parameter, and make sure the proper syntax was used.


PLS-00138

PLS-00138precision for a binary type must be one of 8, 16, or 32

Cause:Invalid precision was specified for a signed or unsigned binary type.

Action:Specify precision as one of 8, 16, or 32.


PLS-00139

PLS-00139duplicate external NAME specification in subprogram expression

Cause:The subprogram was found to have two external NAME specifications.

Action:Remove one of the external NAME specifications.


PLS-00140

PLS-00140duplicate external LIBRARY specification in subprogram expression

Cause:The subprogram was found to have two external LIBRARY specifications.

Action:Remove one of the external LIBRARY specifications.


PLS-00141

PLS-00141duplicate external PARAMETER STYLE specification in subprogram expression

Cause:The subprogram was found to have two external PARAMETER STYLE specifications.

Action:Remove one of the external PARAMETER STYLE specifications.


PLS-00142

PLS-00142duplicate external PARAMETER list specification in subprogram expression

Cause:The subprogram was found to have two external PARAMETER STYLE specifications.

Action:Remove one of the external PARAMETER STYLE specifications.


PLS-00143

PLS-00143duplicate external LANGUAGE specification in subprogram expression

Cause:The subprogram was found to have two external LANGUAGE specifications.

Action:Remove one of the external LANGUAGE specifications.


PLS-00144

PLS-00144duplicate external CALLING STANDARD specification in subprogram expression

Cause:The subprogram was found to have two external CALLING STANDARD specifications.

Action:Remove one of the external CALLING STANDARD specifications.


PLS-00145

PLS-00145duplicate external WITH CONTEXT specification in subprogram expression

Cause:The subprogram was found to have two external WITH CONTEXT specifications.

Action:Remove one of the external WITH CONTEXT specifications.


PLS-00146

PLS-00146duplicate external TRUSTED/UNTRUSTED specification in subprogram expression

Cause:The subprogram was found to have two external TRUSTED/UNTRUSTED specifications.

Action:Remove one of the external TRUSTED/UNTRUSTED specifications.


PLS-00147

PLS-00147LIBRARY file specification string is empty

Cause:A zero-length string was found for the LIBRARY file specification.

Action:Specify a non-zero length string for the LIBRARY file specification.


PLS-00148

PLS-00148 only 1 pragma of this type is allowed per subprogram

Cause:The subprogram was found to have two PRAGMA RESTRICT_REFERENCES.

Action:Remove one of the PRAGMA RESTRICT_REFERENCES.


PLS-00150

PLS-00150found: name but expected: INTEGER

Cause:This error happens in the creation of a PL/SQL external type: [SIGNED | UNSIGNED] BINARY INTEGER (<precision>). It can be referenced only in a CREATE TYPE statement. Such types are non-queryable. Something other than 'INTEGER' was supplied.

Action:Use a different type and retry the operation.


PLS-00151

PLS-00151expression or variable is an illegal type to PL/SQL: name

Cause:A type was used which does not belong PL/SQL. This type can only be referenced in CREATE TYPE statements, and is a non-queryable data type.

Action:Use a different type and retry the operation.


PLS-00152

PLS-00152POINTER type may only reference an object type

Cause:A POINTER type which does not belong to PL/SQL can only refer to an object type. This type can only be referenced in CREATE TYPE statements, and is a non-queryable data type.

Action:Use a different type and retry the operation.


PLS-00153

PLS-00153a name type may only be used as an object type attribute

Cause:A POINTER or [SIGNED/UNSIGNED] BINARY INTEGER can only be used as attributes of object types. These types can only be referenced in CREATE TYPE statements, and are non-queryable data types. One of these external PL/SQL types outside of an object type.

Action:Use a different type and retry the operation.


PLS-00154

PLS-00154an object type may have only 1 MAP or 1 ORDER method

Cause:More than one map or order function was declared. An object type can have only one map function or one order function, but not both.

Action:Delete all but one of the MAP or ORDER functions on the type.


PLS-00155

PLS-00155only a function may be a MAP or ORDER method

Cause:A member procedure was declared as either a map or order method. Only member functions can be map or order methods.

Action:Change the procedure to a function.


PLS-00202

PLS-00202type 'name' must be declared

Cause:You tried to reference an undefined type. Either you failed to declare the type identifier or it is not within the scope of the reference.

Action:Check your spelling and declaration of the type identifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00202

PLS-00202type name must be declared

Cause:An attempt was made to reference an undefined type. Either the type specifier was not declared or it is not within the scope of the reference.

Action:Check the spelling and declaration of the type specifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00203

PLS-00203function DECODE must be called with at least 3 non-Boolean arguments

Cause:Less than three arguments were passed to the built-in function DECODE. Though DECODE takes a variable number of (non-Boolean) arguments, you must pass it at least three.

Action:Call DECODE with three or more arguments.


PLS-00204

PLS-00204function or pseudo-column 'name' may be used inside a SQL statement only

Cause:A pseudo-column or proscribed function was used in a procedural statement. The SQL pseudo-columns (CURRVAL, LEVEL, NEXTVAL, ROWID, ROWNUM) can be used only in SQL statements. Likewise, certain functions such as DECODE and the SQL group functions (AVG, MIN, MAX, COUNT, SUM, STDDEV, VARIANCE) can be used only in SQL statements.

Action:Remove the pseudo-column reference or function call from the procedural statement. Or, replace the procedural statement with a SELECT INTO statement; for example, replace

bonus := DECODE(rating,1,5000,2,2500,...);

with the following statement:

SELECT DECODE(rating,1,5000,2,2500,...)INTO bonus FROM dual;


PLS-00205

PLS-00205aggregate not allowed here

Cause:An aggregate, that is, a parenthesized list of values such as (7788, 'SCOTT', 20), was found in an inappropriate context.

Action:Remove or relocate the aggregate.


PLS-00206

PLS-00206%TYPE must be applied to a variable or column, not 'name'

Cause:The program object declared using the %TYPE datatype attribute is not of the appropriate class. It must be a variable, column, record component, subprogram formal parameter, or other object to which values can be assigned.

Action:Declare an object of the appropriate class or define the datatype in another way (for example, use %ROWTYPE).


PLS-00207

PLS-00207identifier 'name', applied to implicit cursor SQL, is not a legal cursor attribute

Cause:An identifier that is not a cursor attribute was applied to the identifier SQL. For example, this error occurs if the cursor attribute is misspelled.

Action:Check your spelling of the cursor attribute name. Make sure the attribute is one of these: %NOTFOUND, %FOUND, %ROWCOUNT, %ISOPEN.


PLS-00208

PLS-00208identifier 'name' is not a legal cursor attribute

Cause:An identifier not declared as a cursor attribute was applied to an identifier declared as a cursor. For example, this error occurs if the cursor attribute is misspelled.

Action:Check your spelling of the cursor attribute name. Make sure the attribute is one of these: %NOTFOUND, %FOUND, %ROWCOUNT, %ISOPEN.


PLS-00209

PLS-00209table 'name' is not in FROM clause

Cause:In a query, a table referenced by the select list is not named in the FROM clause.

Action:Check your spelling of the table names, make sure each column in the select list refers to a table in the FROM clause, then retry the query.


PLS-00210

PLS-00210an OTHERS clause is required in this CASE statement

Cause:Not in Release 2.0.


PLS-00211

PLS-00211CASE labels or ranges must not be duplicated in different WHEN clauses

Cause:Not in Release 2.0.


PLS-00212

PLS-00212could not obtain enough memory to compile CASE statement

Cause:Not in Release 2.0.


PLS-00213

PLS-00213package STANDARD not accessible

Cause:The PL/SQL compiler could not find library unit STANDARD in the current ORACLE database and so could not access package STANDARD, which is stored in library unit STANDARD. To compile a program, PL/SQL needs package STANDARD.

Action:Make sure that library unit STANDARD is available in the current ORACLE database, then retry the operation.


PLS-00214

PLS-00214BEGIN...END block nesting is too deep

Cause:The number of levels of nesting in your PL/SQL block is too large. You can nest blocks up to 255 levels deep, depending on the availability of system resources such as memory.

Action:Reorganize your block structure to avoid nesting at too deep a level. For example, move the lowest-level sub-block to a higher level.


PLS-00215

PLS-00215string length constraints must be in range (1 .. 32767)

Cause:When declaring a character variable, you specified a length that is outside the legal range. For example, the following declarations are illegal:

flag CHAR(0); -- illegal; zero length

name VARCHAR2(-10); -- illegal; negative length

Action:Change the length constraint, making sure that it lies in the range 1 .. 32767.


PLS-00216

PLS-00216NUMBER precision constraint must be in range (1 .. 38)

Cause:You declared a NUMBER variable with a precision that is outside the legal range. Declarations such as N NUMBER(800) or N NUMBER(123,10) are not supported.

Action:Change the illegal NUMBER precision constraint, making sure that it lies in the range 1 .. 38.


PLS-00217

PLS-00217NUMBER scale constraint must be in range (-84 .. 127)

Cause:You declared a NUMBER variable with a scale that is outside the legal range. Declarations such as N NUMBER(10,345) or N NUMBER(10,-100) are not supported.

Action:Change the illegal NUMBER scale constraint, making sure that it lies in the range -84 .. 127.


PLS-00218

PLS-00218a variable declared NOT NULL must have an initialization assignment

Cause:In general, variables that have no initialization clause in their declaration are automatically initialized to NULL. This is illogical for NOT NULL variables, and therefore an initialization clause is required.

Action:Add an initialization clause to the variable declaration.


PLS-00219

PLS-00219label 'name' reference is out of scope

Cause:A block or loop label was used to qualify a variable (as in outer_block.date) that was not declared or is not within the scope of the label. The variable name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action:Check your spelling and declaration of the variable name. Also confirm that the declaration is placed correctly in the block structure.


PLS-00220

PLS-00220simple name required in this context

Cause:A qualified name such as A.B or A.B.C is not permitted here.

Action:Use a simple name such as A instead.


PLS-00221

PLS-00221'name' is not a procedure or is undefined

Cause:The named identifier is being referenced as a procedure, but the identifier was not declared or actually represents another object (for example, it might have been declared as a function).

Action:Check your spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00222

PLS-00222no function with name 'name' exists in this scope

Cause:The named identifier is being referenced as a function, but the identifier was not declared or actually represents another object (for example, it might have been declared as a procedure).

Action:Check your spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00223

PLS-00223parameterless procedure 'name' used as function

Cause:The named identifier is being referenced as a parameterless function, but the identifier actually represents a procedure.

Action:Check your spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure. If necessary, change the declaration of the identifier or change the reference so that it does not require a return value.


PLS-00224

PLS-00224object 'name' must be of type function or array to be used this way

Cause:The named identifier is being referenced as a function or an array, but the identifier actually represents an object (a number or date, for example) that cannot be referenced in this way.

Action:Check your spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00225

PLS-00225subprogram or cursor 'name' reference is out of scope

Cause:A subprogram or cursor references a variable that was not declared or is not within the scope of the subprogram or cursor. The variable name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action:Check your spelling and declaration of the variable name. Also confirm that the declaration is placed correctly in the block structure.


PLS-00226

PLS-00226package 'name' used as variable reference

Cause:A package was referenced in an expression as if it were a variable or function. Either the name of the variable or function is misspelled or the reference is not fully qualified. For example, to call the function my_function, which is stored in package my_package, you must use dot notation as follows:

... my_package.my_function ...

Action:Correct your spelling of the variable or function name or use dot notation to reference the packaged variable or function.


PLS-00227

PLS-00227subprogram IN formal 'name' is not yet denotable

Cause:When declaring the formal parameters of a subprogram, you used one parameter to initialize another, as in

PROCEDURE my_proc (j NUMBER, k NUMBER := j) IS ...

The first parameter has no value until run time, so it cannot be used to initialize another parameter.

Action:Remove the illegal formal parameter reference.


PLS-00228

PLS-00228illegal declaration of variable of type LONG

Cause:An attempt was made to declare a variables to be of type LONG. Only columns can be of type LONG.

Action:Remove the illegal variable definition.


PLS-00229

PLS-00229attribute expression within SQL expression

Cause:You used an attribute expression such as SQL%NOTFOUND in a SQL statement, but attribute expressions are allowed only in procedural statements.

Action:To work around this limitation, assign the value of the attribute expression to a variable, then use the variable in the SQL statement. For example, replace the statement

INSERT INTO audits VALUES (c1%ROWCOUNT, ...);

with the following statements:

row_count := c1%ROWCOUNT;

INSERT INTO audits VALUES (row_count, ...);


PLS-00230

PLS-00230OUT and IN OUT formal parameters may not have default expressions

Cause:When declaring the formal parameters of a procedure, you initialized an OUT or IN OUT parameter to a default value, as in

PROCEDURE calc_bonus (bonus OUT REAL := 0, ...) IS ...

However, only IN parameters can be initialized to default values.

Action:Remove the illegal default expression.


PLS-00231

PLS-00231function 'name' may not be used in SQL

Cause:You used a proscribed function in a SQL statement. Certain functions such as SQLCODE and SQLERRM can be used only in procedural statements.

Action:Remove the function call from the SQL statement. Or, replace the function call with a local variable. For example, the following statement is illegal:

INSERT INTO errors VALUES (SQLCODE, SQLERRM);

However, you can assign the values of SQLCODE and SQLERRM to local variables, then use the variables in the SQL statement, as follows:

err_num := SQLCODE;

err_msg := SQLERRM;

INSERT INTO errors VALUES (err_num, err_msg);


PLS-00232

PLS-00232nested packages not permitted

Cause:You declared a package inside another package, but package declarations are allowed only at the top level. In other words, you cannot nest packages.

Action:Move the package declaration outside the enclosing package.


PLS-00233

PLS-00233function name used as an exception name in WHEN clause

Cause:The WHEN clause in an exception handler contains a function call instead of an exception name. A valid exception handler consists of a WHEN clause, which must specify an exception, followed by a sequence of statements to be executed when that exception is raised.

Action:Check your spelling of the identifier in the WHEN clause, then replace the function call with an exception name.


PLS-00234

PLS-00234PARAMETER STYLE SQL may not be specified with a PARAMETERS list

Cause:A subprogram cannot specify both PARAMETER STYLE SQL and an explicit PARAMETERS list. Use PARAMETER STYLE GENERAL to supply default PARAMETERS list types.

Action:Change the subprogram specification.


PLS-00235

PLS-00235the external type is not appropriate for the parameter

Cause:An unsuccessful attempt was made to convert a parameter to the specified external parameter type.

Action:Specify a different external type or parameter type.


PLS-00236

PLS-00236:invalid external type specification for name

Cause:The external type specified is not valid for one of the following: INDICATOR, LENGTH, MAXLEN, TDO, DURATION, CHARSETID, or CHARSETFORM.

Action:Check the manual and specify an appropriate external type.


PLS-00237

PLS-00237:invalid BY VALUE indicator or length specification

Cause:BY VALUE was specified with an indicator or length parameter that is being passed in OUT or IN OUT mode. Only IN mode parameters can be passed by value.

Action:Remove the BY VALUE specification or change it to IN mode.


PLS-00238

PLS-00238:external parameter name not found in formal parameter list

Cause:An external parameter name was specified that does not match one in the formal parameter list.

Action:Correct the external parameter name.


PLS-00239

PLS-00239:invalid external type specification for SQLCODE

Cause:An inappropriate external parameter type was specified for the SQLCODE parameter.

Action:Correct the SQLCODE parameter specification.


PLS-00240

PLS-00240invalid type specification for RETURN indicator, LENGTH, TDO, or DURATION

Cause:An inappropriate external parameter type was specified for the RETURN indicator, LENGTH, TDO, or DURATION.

Action:Correct the RETURN parameter specification.


PLS-00241

PLS-00241invalid external type specification for SQLSTATE

Cause:An inappropriate external parameter type was specified for the SQLSTATE parameter.

Action:Correct the SQLSTATE parameter specification.


PLS-00242

PLS-00242invalid external type specification for CONTEXT

Cause:An inappropriate external parameter type was specified for the CONTEXT parameter.

Action:Correct the CONTEXT parameter specification.


PLS-00243

PLS-00243invalid external type specification for SQLNAME

Cause:An inappropriate external parameter type was specified for the SQLNAME parameter.

Action:Correct the SQLNAME parameter specification.


PLS-00244

PLS-00244multiple declarations in foreign function formal parameter list

Cause:There are multiple declarations of at least one the following: FORMAL, INDICATOR, LENGTH, MAXLENGTH, or CONTEXT. PL/SQL allows only one declaration of the above for each formal parameter in the PARAMETERS clause.

Action:Correct the PARAMETERS clause.


PLS-00245

PLS-00245formals used in the 'parameters' clause must appear exactly once

Cause:There are multiple declarations of the formal parameter in the PARAMETERS clause. PL/SQL allows only one declaration of the formal parameter in the PARAMETERS clause.

Action:Correct the PARAMETERS clause.


PLS-00246

PLS-00246PARAMETER STYLE is unsupported

Cause:A PARAMETER STYLE clause was placed in the external subprogram body.

Action:Remove the PARAMETER STYLE clause.


PLS-00247

PLS-00247LIBRARY name must be specified

Cause:The LIBRARY name was not specified in the external subprogram body.

Action:Add a valid LIBRARY name.


PLS-00248

PLS-00248invalid LIBRARY syntax

Cause:The LIBRARY syntax was entered incorrectly.

Action:Correct the LIBRARY syntax and recompile.


PLS-00249

PLS-00249invalid WITH CONTEXT Syntax

Cause:CONTEXT was used in a WITH CONTEXT or a PARAMETERS clause. This is invalid.

Action:Check if WITH CONTEXT is used without specifying CONTEXT in the PARAMETERS clause or vice versa. The PARAMETERS clause must be complete. Thus if WITH CONTEXT is specified, then CONTEXT must be referenced in the PARAMETERS clause (if there is one).


PLS-00250

PLS-00250incorrect usage of name in parameters clause

Cause:Keywords such as MAXLEN, LENGTH were used in the PARAMETERS clause. This is invalid.

Action:This error occurs if keywords like MAXLEN, LENGTH, TDO, DURATION, CHARSETID, or CHARSETFORM cannot be used with PL/SQL formal parameters or the mode of the formal parameter. For example, MAXLEN can only be declared for a CHAR or VARCHAR2 PL/SQL variable and its use is allowed only for OUT or INOUT PL/SQL variables.


PLS-00251

PLS-00251RETURN, for actual function return, must be last in the parameters clause

Cause:RETURN specification for the actual function return, used within the parameters clause must hold the very last position.

Example : The following will give this error since the RETURN specification for the actual function return in the PARAMETERS clause is not the last

FUNCTION myexternalfunc (var1 BINARY_INTEGER,

var2 BINARY_INTEGER)

RETURN BINARY_INTEGER IS EXTERNAL

NAME "myexternalfunc"

LIBRARY somelib

PARAMETERS (var1 LONG, var2 SHORT,

RETURN INT, RETURN INDICATOR SHORT);

The correct syntax is the following. Note that RETURN for actual function return is the last specification in the PARAMETERS clause.

FUNCTION myexternalfunc (var1 BINARY_INTEGER,

var2 BINARY_INTEGER)

RETURN BINARY_INTEGER IS EXTERNAL

NAME "myexternalfunc"

LIBRARY somelib

PARAMETERS (var1 LONG, var2 SHORT,

RETURN INDICATOR SHORT, RETURN INT);

Action:Correct the syntax of the RETURN specification in the PARAMETERS clause.


PLS-00252

PLS-00252reference to the wrong copy of package STANDARD

Cause:A reference is made to the fixed package version of STANDARD when the database is open, or to the on-disk version when the database is closed. Explicit use of a SYS.X$ package name can lead to this. One might also see this from a compilation that begins while the db is closed but has the bad luck to have another session open the db before name-res is complete.

Action:Make use of on-disk versions of packages when the database is open and fixed (preloaded) versions when the database is closed. Do not attempt to use the wrong set. It should be quite hard to reference the wrong set, except by using SYS.X$ names explicitly.


PLS-00302

PLS-00302component 'name' must be declared

Cause:In a reference to a component (for example, in the name A.B, B is a component of A), the component was not declared. The component might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action:Check your spelling and declaration of the component. Also confirm that the declaration is placed correctly in the block structure.


PLS-00303

PLS-00303qualifier 'name' must be declared

Cause:In a name such as A.B, A is a qualifier, and B is a component of the qualifier. This error occurs when no declaration for the qualifier is found. The qualifier might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action:Check your spelling and declaration of the qualifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00304

PLS-00304cannot compile body of 'name' without its specification

Cause:The compiled package specification needed to compile a package body could not be found. Some possible causes follow:

·the package name is misspelled

·the package specification was never compiled

·the compiled package specification is not accessible

You must compile the package specification before compiling the package body, and the compiler must have access to the compiled specification.

Action:Check your spelling of the package name. Compile the package specification before compiling the package body. And, make sure the compiler has access to the compiled specification.


PLS-00305

PLS-00305previous use of 'name' conflicts with this use

Cause:While looking for prior declarations of a cursor, procedure, function, or package, the compiler found another object with the same name in the same scope.

Action:Check your spelling of the cursor, procedure, function, or package name. Also check the names of all constants, variables, parameters, and exceptions declared in the same scope. Then, remove or rename the object with the duplicate name.


PLS-00306

PLS-00306wrong number or types of arguments in call to 'name'

Cause:This error occurs when the named subprogram call cannot be matched to any declaration for that subprogram name. The subprogram name might be misspelled, a parameter might be of the wrong datatype, the declaration might be faulty, or the declaration might be placed incorrectly in the block structure. For example, this error occurs if you call the built-in square root function SQRT with a misspelled name or with a parameter of the wrong datatype.

Action:Check your spelling and declaration of the subprogram name. Also confirm that its call is correct, its parameters are of the right datatype, and, if it is not a built-in function, that its declaration is placed correctly in the block structure.


PLS-00307

PLS-00307too many declarations of 'name' match this call

Cause:The declaration of a subprogram name is ambiguous because there was no exact match between the declaration and the call and more than one declaration matched the call when implicit conversions of the parameter datatypes were used. The subprogram name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action:Check your spelling and declaration of the subprogram name. Also confirm that its call is correct, its parameters are of the right datatype, and, if it is not a built-in function, that its declaration is placed correctly in the block structure.


PLS-00308

PLS-00308this construct is not allowed as the origin of an assignment

Cause:The construct or expression does not designate a value that can be assigned to a variable. For example, the datatype name NUMBER cannot appear on the right hand side of an assignment statement as in X := NUMBER.

Action:Correct the illegal assignment statement.


PLS-00309

PLS-00309with %LAST attribute, 'name' must be a variable of an enumerated type

Cause:Not in Release 2.0.


PLS-00310

PLS-00310with %ROWTYPE attribute, 'name' must name a cursor or table

Cause:The %ROWTYPE attribute must be applied to an identifier declared as a cursor or table. This error occurs when %ROWTYPE follows some identifier that has not been so declared.

Action:Change the declaration or do not apply the %ROWTYPE attribute to the identifier.


PLS-00311

PLS-00311the declaration of the type of 'name' is incomplete or malformed

Cause:This occurrence of the identifier cannot be compiled because its datatype has not been properly defined.

Action:Correct the faulty datatype declaration.


PLS-00312

PLS-00312a positional parameter association may not follow a named association

Cause:When passing a list of parameters to a subprogram or cursor, if you use both positional and named associations, you must place all positional associations in their declared order and before all named associations, which can be in any order.

Action:Reorder the parameter list to meet the requirements or use named association only.


PLS-00313

PLS-00313'name' not declared in this scope

Cause:There is no declaration for the given identifier within the scope of reference. The identifier might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action:Check your spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00314

PLS-00314TABLE declarations are not allowed as PL/SQL local variables

Cause:In a precompiled program, you mistakenly used the DECLARE TABLE statement inside an embedded PL/SQL block. If an embedded PL/SQL block refers to a database table that does not yet exist, you can use the DECLARE TABLE statement to tell the precompiler what the table will look like. But, DECLARE TABLE statements are allowed only in the host program.

Action:Move the DECLARE TABLE statement outside the embedded PL/SQL block. If you want a variable that can store an entire row of data selected from a database table or fetched by a cursor, use the %ROWTYPE attribute.


PLS-00315

PLS-00315PL/SQL TABLE declarations must currently use BINARY_INTEGER indexes

Cause:In the INDEX BY clause of a PL/SQL table declaration, you specified a datatype other than BINARY_INTEGER. PL/SQL tables can have one column and a primary key. The column can belong to any scalar type, but the primary key must belong to type BINARY_INTEGER.

Action:Change the datatype specifier to BINARY_INTEGER.


PLS-00316

PLS-00316PL/SQL TABLE declarations must currently use a single index

Cause:In the INDEX BY clause of a PL/SQL table declaration, you specified a composite primary key. PL/SQL tables must have a simple, unnamed primary key of type BINARY_INTEGER.

Action:Change the faulty clause to INDEX BY BINARY_INTEGER.


PLS-00317

PLS-00317incomplete type name was not completed in its declarative region

Cause:An incomplete type declaration was not completed in the declarative region where it was declared.

Action: Complete the type appropriately.


PLS-00318

PLS-00318type name is malformed because it is a non-REF mutually recursive type

Cause: A type-declaration such as:

-- non-REF recursive type

type t is record (a t);

or

-- non-REF mutually dependent types

type t1;

type t2 is record (a t1);

type t1 is record (a t2);

was entered.

Action: Use another type to remove the recursion.


PLS-00319

PLS-00319subquery in an IN or NOT IN clause must contain exactly one column

Cause:You used an invalid expression such as:

a IN (SELECT x, y, z FROM ... )

When a [NOT]IN clause is used with a subquery, it does not test for set membership. The number of expressions in the [NOT]IN clause and the subquery select list must match. So, in the example above, the subquery must specify at most one column.

Action:Change the subquery to select only one column.


PLS-00320

PLS-00320the declaration of the type of this expression is incomplete or malformed

Cause:In a declaration, the name of a variable or cursor is misspelled or the declaration makes a forward reference. Forward references are not allowed in PL/SQL. You must declare a variable or cursor before referencing it in other statements, including other declarative statements. For example, the following declaration of DEPT_REC raises this exception because it refers to a cursor not yet declared:

DECLARE

dept_rec dept_cur%ROWTYPE;

CURSOR dept_cur IS SELECT ...

...

Action:Check your spelling of all identifiers in the declaration. If necessary, move the declaration so that it makes no forward references.


PLS-00321

PLS-00321expression 'str' is inappropriate as the left hand side of an assignment statement

Cause:The expression does not designate a variable that can have a value assigned to it. For example, the function SYSDATE cannot appear on the left hand side of an assignment statement such as:

SYSDATE := '01-JAN-1990';

Action:Correct the illegal assignment statement.


PLS-00322

PLS-00322declaration of a constant 'name' must contain an initialization assignment

Cause:A constant declaration is lacking the assignment of the constant value. For example, in the following declaration ":= 3.14159" is the initialization assignment:

pi CONSTANT NUMBER := 3.14159;

Action:Correct the constant declaration by supplying the missing initialization assignment.


PLS-00323

PLS-00323subprogram 'name' is declared in a package specification and must be defined in the package body

Cause:You placed a subprogram specification in a package specification, but neglected to place the corresponding subprogram body in the package body. The package body implements the package specification. So, the package body must contain the definition of every subprogram declared in the package specification.

Action:Check your spelling of the subprogram name. If necessary, add the missing subprogram body to the package body.


PLS-00324

PLS-00324cursor attribute may not be applied to non-cursor 'name'

Cause:This error occurs when a cursor attribute (%FOUND, %NOTFOUND, %ROWCOUNT, or %ISOPEN) appears following an identifier not declared as a cursor. It occurs, for example, if the variable name my_cur in my_cur%FOUND was not properly declared as a cursor or if the variable declaration was placed incorrectly in the block structure.

Action:Check your spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.


PLS-00325

PLS-00325non-integral numeric literal num is inappropriate in this context

Cause:A non-integral numeric literal was used in a context that requires an integer (a number with no fractional part).

Action:Replace the inappropriate literal with an integral literal.


PLS-00326

PLS-00326IN clause must contain same number of expressions as subquery

Cause:The number of expressions in an IN clause did not equal the number of expressions in a corresponding subquery select list. For example, the following statement is invalid because the IN clause contains two expressions, but the subquery select list contains just one:

... WHERE (ename, sal) IN (SELECT sal FROM emp);

Action:Check the number of expressions in each set, then revise the statement to make the numbers equal.


PLS-00327

PLS-00327'name' is not in SQL scope here

Cause: In a SQL statement, a reference was made to an out-of-scope database object. The referenced object might be misspelled, or the reference might be mixed, as in the following example:

CURSOR c1 IS SELECT dept.dname FROM emp;

Action: Check the spelling of all database objects in the SQL statement, and make sure all references are to objects within the current scope.


PLS-00328

PLS-00328a subprogram body must be defined for the forward declaration of 'name'

Cause:You declared a subprogram specification, but failed to define the corresponding subprogram body. You can write the subprogram specification and body as a unit. Or, you can separate the specification from its body, which is necessary when you want to define mutually recursive subprograms or group subprograms in a package.

Action:Check your spelling of the subprogram name. If necessary, supply the missing subprogram body.


PLS-00329

PLS-00329schema-level type has illegal reference to name

Cause: An attempt was made to make a reference from a schema-level type to something other than a schema-level type.

Action: Replace the illegal reference with a schema type.


PLS-00330

PLS-00330invalid use of type name or subtype name

Cause:A datatype or subtype specifier was mistakenly used in place of a constant, variable, or expression. For example, the code might look like

IF emp_count > number THEN ... -- illegal; NUMBER is a datatype specifier

Action:Replace the datatype or subtype specifier with a valid constant, variable,or expression.


PLS-00331

PLS-00331illegal reference to name

Cause:An illegal reference was made to some object in user SYS. This could have happened only if:

You had privileges to see those system objects in the first place and were trying to use one of them in an illegal way.

An illegal reference was made to some object in user SYS.

Action:Remove the reference.


PLS-00332

PLS-00332name is not a valid prefix for a qualified name

Cause: You have a malformed qualified name because the prefix is not valid.

Action: Remove or change the reference.


PLS-00333

PLS-00333 name must match an object-table alias in this context

Cause: The name, appearing in the context of a REF or VALUE, did not resolve to an object-table alias.

Action: 1)If there is no object table in the scope, then remove the REF or VALUE; or provide the missing object table reference.

Action: 2)If there is an object table in the scope, but you are not referring to it, add the reference.


PLS-00334

PLS-00334name matches table or view without an alias

Cause:You have a reference to a table or view name without an alias.

Action:Replace the reference with a reference to an object-table alias.


PLS-00335

PLS-00335a package name conflicts with an existing object

Cause:In a CREATE PACKAGE statement, a package (which is a database object that groups logically related PL/SQL types, objects, and subprograms) was given the same name as an existing database object.

Action:Give the package a unique name.


PLS-00336

PLS-00336non-object-table name illegal in this context

Cause: You have a REF or VALUE modifier for a non-object-table

Action: Replace the reference with a reference to an object-table alias.


PLS-00337

PLS-00337name matches too many object table aliases

Cause: You have an ambiguous reference to an object-table alias; there are at least two object-table aliases in the same scope.

Action: Remove all but one of the references or change the alias names of the remaining.


PLS-00338

PLS-00338 unable to resolve name as a column or row expression

Cause: You have a reference to a name that could not be resolved as a column or row expression. This occurred in an update or insert statement involving an object-table.

Action: If this is an update statement and you intended to code this as a column reference, fix it as such. If you intended to code this as a row expression, change this to refer to an alias of an object-table.


PLS-00339

PLS-00339name matches object-table without a REF or VALUE modifier"

Cause:You have an object-table name appearing without a REF or VALUE modifier.

Action: If you intended to code this with a REF or VALUE modifier, add the modifier; if you intended to code this as a column reference, change the reference appropriately; otherwise, remove the reference.


PLS-00341

PLS-00341declaration of cursor 'name' is incomplete or malformed

Cause:A cursor declaration is improper or an identifier referenced in the cursor declaration was not properly declared. You might have specified a return type (%ROWTYPE) that does not refer to an existing database table or previously declared cursor. For example, the following cursor declaration is illegal because c1 is not yet fully defined:

CURSOR c1 RETURN c1%ROWTYPE IS SELECT ... -- illegal

In this case, you need not specify a return type because it is implicit.

Action:Check your spelling and declaration of the cursor name and any identifiers referenced in the cursor declaration. Also confirm that the declaration is placed correctly in the block structure. If you specified a return type, make sure that it refers to an existing database table or previously declared cursor.


PLS-00351

PLS-00351not logged on to database 'name'

Cause:You tried to access an ORACLE database without being logged on. Probably, an invalid username or password was entered.

Action:Log on to ORACLE with a correctly spelled username and password before trying to access the database.


PLS-00352

PLS-00352unable to access another database 'name'

Cause:You tried to reference an object in a database other than the current local or remote ORACLE database.

Action:Correct your reference and make sure the object is in the current ORACLE database.


PLS-00353

PLS-00353'name' must name a user in the database

Cause:This error occurs when the username was misspelled or when the user does not exist in the database.

Action:Check your spelling of the username and make sure the user exists.


PLS-00354

PLS-00354username must be a simple identifier

Cause:A qualified username such as SCOTT.ACCTS is not permitted in this context.

Action:Specify a simple username such as SCOTT instead.


PLS-00355

PLS-00355use of PL/SQL table not allowed in this context

Cause:A PL/SQL table was referenced in the wrong context (for example, with a remote link).

Action:Remove the PL/SQL table reference or change the context.


PLS-00356

PLS-00356'name' must name a table to which the user has access

Cause:The named table is not accessible to the user. This error occurs when the table name or username was misspelled, the table and/or user does not exist in the database, or the user was not granted the necessary privileges.

Action:Check your spelling of the table name and username. Also confirm that the table and user exist and that the user has the necessary privileges.


PLS-00357

PLS-00357table, view or sequence reference 'name' not allowed in this context

Cause:A reference to database table, view, or sequence was found in an inappropriate context. Such references can appear only in SQL statements or (excluding sequences) in %TYPE and %ROWTYPE declarations. Some valid examples follow:

SELECT ename, emp.deptno, dname INTO my_ename, my_deptno, my_dept

FROM emp, dept WHERE emp.deptno = dept.deptno;

DECLARE

last_name emp.ename%TYPE;

dept_rec dept%ROWTYPE;

Action:Remove or relocate the illegal reference.


PLS-00358

PLS-00358column 'name' exists in more than one table; use qualifier

Cause:Your statement is ambiguous because it specifies two or more tables having the same column name. For example, the following statement is ambiguous because DEPTNO is a column in both tables:

SELECT deptno, loc INTO my_deptno, my_loc FROM emp, dept;

Action:Precede the column name with the table name (as in EMP.DEPTNO) so that the column reference is unambiguous.


PLS-00359

PLS-00359assignment target in 'str' must have components

Cause:An assignment target was not declared to have the required components. For example, this error occurs if you try to assign a row of column values to a variable instead of a record, as follows:

DECLARE

dept_rec dept%ROWTYPE;

my_deptno dept.deptno%TYPE;

...

BEGIN

SELECT deptno, dname, loc INTO my_deptno -- invalid

FROM dept WHERE ...

...

Action:Check your spelling of the names of the assignment target and all its components. Make sure the assignment target is declared with the required components and that the declaration is placed correctly in the block structure.


PLS-00360

PLS-00360:cursor declaration without body needs return type

Cause:A cursor declaration lacks either a body (SELECT statement) or a return type (%ROWTYPE). If you want to separate a cursor specification from its body, you must supply a return type, as in

CURSOR c1 RETURN emp%ROWTYPE;

Action:Add a SELECT statement or return type to the cursor declaration.


PLS-00361

PLS-00361a cursor variable must be IN OUT to modify its state

Cause:A cursor variable was declared as the IN or OUT formal parameter of a subprogram that, when called, will change the state of the cursor variable. In such cases, the cursor variable must be declared as an IN OUT parameter.

Action:Change the parameter mode from IN or OUT to IN OUT.


PLS-00362

PLS-00362:invalid cursor return type; 'name' must be a record type

Cause: In a cursor specification or REF CURSOR type definition, a non-record type such as NUMBER or TABLE was specified as the return type. This is not allowed. Only the following return types are allowed:

<record_type_name>

<record_name>%TYPE

<table_name>%ROWTYPE

<cursor_name>%ROWTYPE

<cursor_variable_name>%ROWTYTPE

Action: Revise the cursor specification or REF CURSOR type definition so that it specifies one of the above return types.


PLS-00363

PLS-00363expression 'str' cannot be used as an assignment target

Cause:You mistakenly used a literal, constant, IN parameter, loop counter, or function call as the target of an assignment. For example, the following statement is illegal because the assignment target, 30, is a literal:

SELECT deptno INTO 30 FROM dept WHERE ... -- illegal

Action:Correct the statement by using a valid assignment target.


PLS-00364

PLS-00364loop index variable 'name' use is invalid

Cause:A reference to a loop counter was found in an inappropriate context. For example, the following statement is illegal because the loop counter is used as the terminal value in its own range expression:

FOR j IN 1 .. j LOOP ... -- illegal

Action:Change the loop range expression so that it does not reference the loop counter. If you want to refer in the range expression to another variable with the same name as the loop counter, change either name or qualify the variable name with a label.


PLS-00365

PLS-00365'name' is an OUT parameter and cannot be read

Cause:You tried to assign the value of an OUT parameter to another parameter or variable. Inside a procedure, an OUT parameter acts like an uninitialized variable; therefore, its value cannot be read. For example, the following assignments are illegal:

PROCEDURE calc_wages (bonus OUT REAL, ...) IS

rating REAL;

wages REAL;

BEGIN

...

IF rating > 90 THEN

bonus := bonus * 2; -- illegal

END IF;

SELECT sal + bonus INTO wages FROM emp ... -- illegal

...

END calc_bonus;

Action:Use an IN OUT parameter instead of the OUT parameter. Inside a procedure, an IN OUT parameter acts like an initialized variable; therefore, its value can be read.


PLS-00366

PLS-00366subtype of a NOT NULL type must also be NOT NULL

Cause:Not in Release 2.0.


PLS-00368

PLS-00368in RAISE statement, 'name' must be an exception name

Cause:The identifier in a RAISE statement is not a valid exception name.

Action:Make sure the identifier in the RAISE statement was declared as an exception and is correctly placed in the block structure. If you are using one of the PL/SQL predefined exception names, check its spelling.


PLS-00368

PLS-00368in RAISE statement, name must be an exception name

Cause:The identifier in a RAISE statement is not a valid exception name.

Action:Make sure the identifier in the RAISE statement was declared as an exception and is correctly placed in the block structure. If you are using the name of a PL/SQL predefined exception, check its spelling.


PLS-00369

PLS-00369no choices may appear with choice OTHERS in an exception handler

Cause:A construct of the form

WHEN excep1 OR OTHERS =>

was encountered in the definition of an exception handler. OTHERS must appear by itself as the last exception handler in a block.

Action:Remove the identifier that appears with OTHERS or write a separate exception handler for that identifier.


PLS-00370

PLS-00370OTHERS handler must be last among the exception handlers of a block

Cause:One or more exception handlers appear after an OTHERS handler. However, the OTHERS handler must be the last handler in a block or subprogram because it acts as the handler for all exceptions not named specifically.

Action:Move the OTHERS handler so that it follows all specific exception handlers.


PLS-00371

PLS-00371at most one declaration for 'name' is permitted in the declaration section

Cause:A reference to an identifier is ambiguous because there are conflicting declarations for it in the declaration section of a block, procedure, or function. At most one declaration of the identifier is permitted in a declaration section.

Action:Check your spelling of the identifier. If necessary, remove all but one declaration of the identifier.


PLS-00372

PLS-00372in a procedure, RETURN statement cannot contain an expression

Cause:In a procedure, a RETURN statement contains an expression, which is not allowed. In functions, a RETURN statement must contain an expression because its value is assigned to the function identifier. However, in procedures, a RETURN statement simply lets you exit before the normal end of the procedure is reached.

Action:Remove the expression from the RETURN statement, or redefine the procedure as a function.


PLS-00373

PLS-00373EXIT label 'name' must label a LOOP statement

Cause:The statement with the named label is not a loop. An EXIT statement does not require a label operand, but if you specify one (as in EXIT my_label), it must be the label of a loop statement.

Action:Make sure the label name is spelled correctly and that it refers to a loop statement.


PLS-00374

PLS-00374illegal EXIT statement; it must appear inside the loop labeled 'name'

Cause:An EXIT statement does not require a label operand, but if you specify one (as in EXIT my_label), the EXIT statement must be inside the loop designated by that label.

Action:Make sure the label name is spelled correctly, placed properly, and refers to the appropriate EXIT statement.


PLS-00375

PLS-00375illegal GOTO statement; this GOTO cannot branch to label 'name'

Cause:The line and column numbers accompanying the error message refer to a GOTO that branches from outside a construct (a loop or exception handler, for example) containing a sequence of statements to a label inside that sequence of statements. Such a branch is not allowed.

Action:Either move the GOTO statement inside the sequence of statements or move the labeled statement outside the sequence of statements.


PLS-00376

PLS-00376illegal EXIT statement; it must appear inside a loop

Cause:An EXIT statement was found outside of a loop construct. The EXIT statement is used to exit prematurely from a loop and so must always appear within a loop.

Action:Either remove the EXIT statement or place it inside a loop.


PLS-00377

PLS-00377internal type PLS_INTEGER is not included in this release of PL/SQL

Cause:In a declaration, you mistakenly specified the datatype PLS_INTEGER. PLS_INTEGER is a PL/SQL internal datatype used within package STANDARD.

Action:Specify the datatype BINARY_INTEGER instead of PLS_INTEGER.


PLS-00378

PLS-00378invalid compilation unit for this release of PL/SQL

Cause:A compilation unit is a file containing PL/SQL source code that is passed to the compiler. Only compilation units containing blocks, declarations, statements, and subprograms are allowed. This error occurs when some other language construct is passed to the compiler.

Action:Make sure the compilation unit contains only blocks, declarations, statements, and subprograms.


PLS-00379

PLS-00379CASE statements are not included in this release of PL/SQL

Cause:The unit being compiled contains a CASE statement. However, the current release of PL/SQL does not support CASE statements.

Action:Remove the CASE statement from the compilation unit.


PLS-00381

PLS-00381type mismatch found at 'name' between column and variable in subquery or INSERT

Cause:The datatypes of a column and a variable do not match. The variable was encountered in a subquery or INSERT statement.

Action:Change the variable datatype to match that of the column.


PLS-00382

PLS-00382expression is of wrong type

Cause:The given expression variable is of the wrong datatype for the context in which it was found.

Action:Change the datatype of the expression. You might want to use datatype conversion functions.


PLS-00383

PLS-00383type mismatch found at 'name' inside an IN or NOT IN clause

Cause:In a test for set membership such as X NOT IN (SELECT Y ... ), the expressions X and Y do not match in datatype, and it is unclear which implicit conversion is needed to correct the mismatch.

Action:Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the select list.


PLS-00384

PLS-00384type mismatch found at 'name' in UPDATE's SET clause

Cause:The column to the left of the equal sign in the SET clause of an UPDATE statement does not match in datatype with the column, expression, or subquery to the right of the equal sign, and it is unclear which implicit conversion is needed to correct the mismatch.

Action:Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the SET clause.


PLS-00385

PLS-00385type mismatch found at 'name' in SELECT...INTO statement

Cause:The expressions to the left and right of the INTO clause in a SELECT...INTO statement do not match in datatype, and it is unclear which implicit conversion is needed to correct the mismatch.

Action:Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the select list.


PLS-00386

PLS-00386type mismatch found at 'name' between FETCH cursor and INTO variables

Cause:An assignment target in the INTO list of a FETCH statement does not match in datatype with the corresponding column in the select list of the cursor declaration, and it is unclear which implicit conversion is needed to correct the mismatch.

Action:Change the cursor declaration or change the datatype of the assignment target. You might want to use datatype conversion functions in the select list of the query associated with the cursor.


PLS-00387

PLS-00387INTO variable cannot be a database object

Cause:An item in the INTO list of a FETCH or SELECT statement was found to be a database object. INTO introduces a list of user-defined variables to which output values are assigned. Therefore, database objects cannot appear in the INTO list.

Action:Check your spelling of the INTO list item. If necessary, remove the item from the INTO list or replace it with a user-defined output variable.


PLS-00388

PLS-00388undefined column 'name' in subquery

Cause:A subquery contains a column name that was not defined for the specified table.

Action:Change the expression to specify a column that was defined.


PLS-00389

PLS-00389undefined column 'name' in left-hand-side expression

Cause:A left-hand-side expression in a SQL statement refers to an undefined column.

Action:Check your spelling of the column name, then change the expression so that it refers only to defined columns.


PLS-00390

PLS-00390undefined column 'name' in INSERT statement

Cause:An INSERT statement refers to a column not defined for the table or view into which data is being INSERTed.

Action:Check your spelling of the column name, then revise the statement so that it refers only to defined columns.


PLS-00391

PLS-00391undefined column 'name' in UPDATE statement

Cause:An UPDATE statement refers to a column not defined for the table or view being UPDATEd.

Action:Check your spelling of the column name, then revise the statement so that it refers only to defined columns.


PLS-00392

PLS-00392type mismatch in arguments to BETWEEN

Cause:In a comparison such as X BETWEEN Y AND Z, the expressions X, Y, and Z do not match in datatype, and it is unclear which implicit conversion is needed to correct the mismatch.

Action:Change the expressions so that their datatypes match. You might want to use datatype conversion functions.


PLS-00393

PLS-00393wrong number of columns in SELECT...INTO statement

Cause:The number of columns selected by a SELECT...INTO statement does not match the number of variables in the INTO clause.

Action:Change the number of columns in the select list or the number of variables in the INTO clause so that the numbers match.


PLS-00394

PLS-00394wrong number of values in the INTO list of a FETCH statement

Cause:The number of variables in the INTO clause of a FETCH statement does not match the number of columns in the cursor declaration.

Action:Change the number of variables in the INTO clause or the number of columns in the cursor declaration so that the numbers match.


PLS-00395

PLS-00395wrong number of values in VALUES clause of INSERT statement

Cause:The number of columns in an INSERT statement does not match the number of values in the VALUES clause. For example, the following statement is faulty because no column is specified for the value 20:

INSERT INTO emp (empno, ename) VALUES (7788, 'SCOTT', 20);

Action:Change the number of items in the column list or the number of items in the VALUES list so that the numbers match.


PLS-00396

PLS-00396INSERT statement's subquery yields wrong number of columns

Cause:The number of columns in an INSERT statement does not match the number of columns in a subquery select list. For example, the following statement is faulty because no corresponding column is specified for col3:

INSERT INTO emp (ename, empno) SELECT col1, col2, col3 FROM ...

Action:Change the number of items in the column list of the INSERT statement or the number of items the select list so that the numbers match.


PLS-00397

PLS-00397type mismatch in arguments to IN

Cause:In a test for set membership such as X IN (Y, Z), the expressions X, Y, and Z do not match in datatype, and it is unclear which implicit conversion is needed to correct the mismatch.

Action:Change the expressions so that their datatypes match. You might want to use datatype conversion functions.


PLS-00398

PLS-00398wrong number of columns in UNION, INTERSECT, or MINUS expression

Cause:The SELECT clauses to the left and right of a UNION, INTERSECT, or MINUS expression do not select the same number of columns. For example, the following statement is faulty because the select lists do not contain the same number of items:

CURSOR my_cur IS SELECT ename FROM emp

INTERSECT SELECT ename, empno FROM emp;

Action:Change the select lists so that they contain the same number of items.


PLS-00399

PLS-00399different types of columns in UNION, INTERSECT, or MINUS expression

Cause:The select lists to the left and right of a UNION, INTERSECT, or MINUS expression select at least one column that is mismatched in datatype. For example, the following statement is faulty because the constant 3 is of datatype NUMBER, whereas SYSDATE is of datatype DATE:

CURSOR my_cur IS SELECT 3 FROM emp

INTERSECT SELECT SYSDATE FROM emp;

Action:Change the select lists so that they match in datatype. You might want to use datatype conversion functions in the select list of one or more queries.


PLS-00400

PLS-00400:different number of columns between cursor SELECT statement and return value

Cause:In a cursor declaration, you specified a return type (such as RETURN emp%ROWTYPE), but the number of returned column values does not match the number of select-list items.

Action:Change the cursor return type or the select list so that the number of returned column values matches the number of select-list items.


PLS-00401

PLS-00401:different column types between cursor SELECT statement and return value found at 'name'

Cause:In a cursor declaration, you specified a return type (such as RETURN emp%ROWTYPE), but a returned column value and its corresponding select-list item belong to different datatypes.

Action:Change the cursor return type or the select list so that each returned column value and its corresponding select-list item belong to the same datatype.


PLS-00402

PLS-00402alias required in SELECT list of cursor to avoid duplicate column names

Cause:A cursor was declared with a SELECT statement that contains duplicate column names. Such references are ambiguous.

Action:Replace the duplicate column name in the select list with an alias.


PLS-00403

PLS-00403INTO list of FETCH statement contains illegal assignment target

Cause:A FETCH statement was unable to assign a value to an assignment target in its INTO list because the target is not a legally formed and declared variable. For example, the following assignment is illegal because 'Jones' is a character string, not a variable:

FETCH my_cur INTO 'Jones';

Action:Check your spelling and declaration of the assignment target. Make sure you followed the rules for forming variable names.


PLS-00404

PLS-00404cursor 'name' must be declared with FOR UPDATE to use with CURRENT OF

Cause:The use of the CURRENT OF name clause is legal only if name was declared with a FOR UPDATE clause.

Action:Add a FOR UPDATE clause to the definition of the cursor or do not use the CURRENT OF 'name' clause.


PLS-00405

PLS-00405subquery not allowed in this context

Cause:A subquery was used in an inappropriate context, such as:

if (SELECT deptno FROM emp WHERE ... ) = 20 then ...

Subqueries are allowed only in SQL statements.

Action:You can get the same result by using a temporary variable, as in:

SELECT deptno INTO temp_var FROM emp WHERE ...;

IF temp_var = 20 THEN ...


PLS-00406

PLS-00406length of SELECT list in subquery must match number of assignment targets

Cause:A query select list is not the same length as the list of targets that will receive the returned values. For example, the following statement is faulty because the subquery returns two values for one target:

UPDATE emp SET ename =

(SELECT ename, empno FROM emp WHERE ename = 'SMITH') ...

Action:Change one of the lists so that they contain the same number of items.


PLS-00407

PLS-00407'*' not allowed here; a list of columns is required

Cause:An asterisk (*) was used as an abbreviation for a list of column names. However, in this context the column names must be written out explicitly.

Action:Replace the asterisk with a list of column names.


PLS-00408

PLS-00408duplicate column 'name' not permitted in INSERT or UPDATE

Cause:An UPDATE or INSERT statement has a column list that contains duplicate column names.

Action:Check your spelling of the column names, then eliminate the duplication.


PLS-00409

PLS-00409duplicate variable 'name' in INTO list is not permitted

Cause:The same variable appears twice in the INTO list of a SELECT or FETCH statement.

Action:Remove one of the variables from the INTO clause.


PLS-00410

PLS-00410duplicate fields in record or table are not allowed

Cause:When declaring a user-defined record, you gave the same name to two fields. Like column names in a database table, field names in a user-defined record must be unique.

Action:Check your spelling of the field names, then remove the duplicate.


PLS-00411

PLS-00411number of values in aggregate and in subquery don't match

Cause:In a statement of the form aggregate = subquery, the numbers of values in the aggregate and subquery are unequal. For example, the code might look like

... WHERE (10,20,30) = (SELECT empno,deptno FROM emp WHERE...);

Action:Revise the aggregate or subquery so that the numbers of values match.


PLS-00412

PLS-00412list of values not allowed as argument to this function or procedure

Cause:A parenthesized list of values separated by commas (that is, an aggregate) was used in the wrong context. For example, the following usage is invalid:

WHERE (col1, col2) > (SELECT col3, col4 FROM my_table ...)

However, an equal sign can take a list of values and a subquery as left- and right-hand-side arguments respectively, so the following usage is valid:

WHERE (col1, col2) = (SELECT col3, col4 FROM my_table ...)

Action:Rewrite the expression. For example, the clause

WHERE (col1, col2) > (SELECT col3, col4 FROM my_table ...)

can be rewritten as

WHERE col1 > (SELECT col3 FROM my_table ...) AND

col2 > (SELECT col4 FROM my_table ...)


PLS-00413

PLS-00413identifier in CURRENT OF clause is not a cursor name

Cause:The identifier in a CURRENT OF clause names an object other than a cursor.

Action:Check your spelling of the identifier. Make sure that it names the cursor in the DELETE or UPDATE statement and that it names the cursor itself, not a FOR-loop variable.


PLS-00414

PLS-00414no column 'name' in table

Cause:A table name or alias was used to qualify a column reference, but the column was not found in that table. Either the column was never defined or the column name is misspelled.

Action:Confirm that the column was defined and check your spelling of the column name.


PLS-00415

PLS-00415'name' is an OUT parameter and cannot appear in a function

Cause:When declaring the formal arguments of a function, you specified the OUT or IN OUT parameter mode. Procedures can take IN, OUT, and IN OUT parameters, but functions can take only IN arguments.

Action:Remove the OUT or IN OUT argument from the formal argument list, or redefine the function as a procedure.


PLS-00417

PLS-00417table or view or column does not exist

Cause:A database table, view, or column was specified in a SQL statement that does not exist, or the privileges required to access the table or view were not granted.

Action:Check the spelling of the table (or view) and column names; make sure the table and columns exist. If necessary, ask the DBA to grant the privileges required to access the table.


PLS-00418

PLS-00418array bind type must match PL/SQL table row type

Cause:A host array was passed (by an Oracle Precompiler program, for example) to a PL/SQL subprogram for binding to a PL/SQL table parameter. However, the datatypes of the array elements and PL/SQL table rows are incompatible. So, the binding failed.

Action:Change the datatype of the array elements or PL/SQL table rows to make the datatypes compatible.

Cause:An attempt was made to reference a remote cursor attribute, which is not allowed. For example, the code might look like

IF SQL%NOTFOUND@newyork THEN ...

Action:Do not try to reference a remote cursor attribute.


PLS-00419

PLS-00419reference to remote attribute not permitted

Cause:An attempt was made to reference a remote cursor attribute, which is not allowed. For example, the code might look like

IF SQL%NOTFOUND@newyork THEN ...

Action:Do not try to reference a remote cursor attribute.


PLS-00420

PLS-00420cannot call built-in routines remotely

Cause:An attempt was made to call a built-in PL/SQL function remotely, which is not allowed. For example, the code might look like

my_sqlerrm := SQLERRM@newyork;

or

INSERT INTO emp VALUES (my_empno, STANDARD.RTRIM@newyork(my_ename), ...);

Action:Always call built-in functions locally; never specify a database link.


PLS-00421

PLS-00421synonym definitions nested too deeply; possible loop in synonyms

Cause:Directly or indirectly, a synonym was defined in terms of itself, creating a circular definition. Or, a chain of synonyms, too long for the PL/SQL compiler to handle, was defined.

Action:Redefine the synonyms to eliminate the circular definition. If necessary, shorten the chain of synonyms.


PLS-00422

PLS-00422no PL/SQL translation for the bind type given for this bind variable

Cause:A host variable was passed (by an Oracle Precompiler program, for example) to PL/SQL for binding. However, its datatype is not compatible with any PL/SQL datatype. So, the binding failed.

Action:Change the datatype of the host variable to make it compatible with aPL/SQL datatype.


PLS-00423

PLS-00423ORDER BY item must be the number of a SELECT-list expression

Cause: A column alias was used in the ORDER BY clause of a SELECT statement that uses a UNION, INTERSECT, or MINUS set operator. This is not allowed. In such cases, expressions in the ORDER BY clause must be unsigned integers that designate the ordinal positions of select-list items.

Action: Change the alias in the ORDER BY clause to an unsigned integer that designates the ordinal position of the select item in question.


PLS-00424

PLS-00424all arguments must be provided in remote procedure call; no defaults

Cause:An attempt was made to call a remote subprogram using defaulted parameters, which is not allowed. When calling remote subprograms, the actual parameters must be passed explicitly, even if the corresponding formal parametershave defaults.

Action:Call the remote subprogram by passing each actual parameter explicitly.


PLS-00425

PLS-00425in SQL statement, argument to function must have SQL type

Cause:When a stored function was called from a SQL statement, parameters of the wrong type were passed. To be callable from SQL statements, a stored function must meet several requirements, one of which is that its arguments have SQL datatypes such as CHAR, DATE, or NUMBER. None of the arguments can have non-SQL types such as BOOLEAN, TABLE, or RECORD.

Action:Make sure all the arguments in the function call have SQL datatypes.


PLS-00426

PLS-00426:cursor variable OUT parameter 'name' cannot be FETCH'ed or CLOSE'd

Cause: When a cursor variable was declared as the formal parameter of a subprogram that will FETCH from and/or CLOSE the cursor variable, the OUT parameter mode was specified. This is not allowed. In such cases, the IN or IN OUT mode must be specified.

Action: Change the parameter mode from OUT to IN or IN OUT.


PLS-00428

PLS-00428an INTO clause is expected in this SELECT statement

Cause:The INTO clause of a SELECT INTO statement was omitted. For example, the code might look like

SELECT deptno, dname, loc FROM dept WHERE ...

instead of

SELECT deptno, dname, loc INTO dept_rec FROM dept WHERE ...

In PL/SQL, only a subquery is written without an INTO clause.

Action:Add the required INTO clause.


PLS-00450

PLS-00450a variable of this private type cannot be declared here

Cause:Not in Release 2.0.


PLS-00451

PLS-00451remote types not allowed

Cause:When a constant or variable was declared, a datatype that is defined in a remote library unit was specified. This is not allowed.

Action:Do not specify the datatype unless it is defined locally.


PLS-00452

PLS-00452subprogram name violates its associated pragma

Cause:A packaged function cannot be called from SQL statements unless its purity level is asserted by coding a RESTRICT_REFERENCES pragma in the package specification. The pragma, which is used to control side effects, tells the PL/SQL compiler to deny the packaged function read/write access to database tables, public packaged variables, or both. A SQL statement that violates the pragma will cause a compilation error.

Action:Raise the purity level of the function, or relax the pragma restrictions.


PLS-00483

PLS-00483exception 'name' may appear in at most one exception handler in this block

Cause:The same exception appears in two different exception handlers within the same EXCEPTION section. That is not allowed.

Action:Remove one of the duplicate exception handlers.


PLS-00484

PLS-00484exceptions 'name' and 'name' have same ORACLE error number and must appear in same exception handler

Cause:Using PRAGMA EXCEPTION_INIT, you initialized different exceptions to the same ORACLE error number, then referred to them in different exception handlers within the same EXCEPTION section. Such references conflict.

Action:Remove one of the exceptions or initialize it to a different ORACLE error number.


PLS-00485

PLS-00485in exception handler, 'name' must be an exception name

Cause:An identifier not declared as an exception appears in an exception handler WHEN clause. Only the name of an exception is valid in a WHEN clause.

Action:Check your spelling of the exception name and make sure the exception was declared properly.


PLS-00486

PLS-00486SELECT list cannot be enclosed in parentheses

Cause:In a SELECT statement, the select list was enclosed in parentheses, as in:

SELECT (deptno, dname, loc) FROM dept INTO ...

This breaks the rules of SQL syntax. Parentheses are not needed because the keywords SELECT and FROM delimit the select list.

Action:Remove the parentheses enclosing the select list.


PLS-00487

PLS-00487invalid reference to variable 'name'

Cause:A variable was referenced in a way that is inconsistent with its datatype. For example, you might have mistakenly referenced a scalar variable as a record, as follows:

DECLARE

CURSOR emp_cur IS SELECT empno, ename, sal FROM emp;

emp_rec emp_cur%ROWTYPE;

my_sal NUMBER(7,2);

BEGIN

...

total_sal := total_sal + my_sal.sal; -- invalid

...

Action:Check your spelling of the variable name. Make sure the variable was declared properly and that the declaration and reference are consistent with regard to datatype.


PLS-00488

PLS-00488invalid variable declaration: object 'name' must be a type or subtype

Cause:The datatype specifier in a variable declaration does not designate a legal type. For example, you might have neglected to add the %TYPE attribute to a declaration, as in

DECLARE

my_sal emp.sal%TYPE;

my_ename emp.ename; -- missing %TYPE

...

When declaring a constant or variable, to provide the datatype of a column automatically, you must use the %TYPE attribute. Likewise, when declaring a record, to provide the datatypes of a row automatically, you must use the %ROWTYPE attribute.

Action:Make sure the datatype specifier designates a legal type. Remember to use the %TYPE and %ROWTYPE attributes when necessary.


PLS-00489

PLS-00489invalid table reference: 'name' must be a column in this expression

Cause:In a query, a select-list item refers to a table in the FROM clause but not to a database column.

Action:Check your spelling of the column names, make sure each column in the select list refers to a table in the FROM clause, then retry the query.


PLS-00490

PLS-00490illegal statement

Cause:A constant, variable, function call, or incomplete statement was used where a statement was expected. For example, instead of calling a function from an expression, it might have been called as a statement (as if it were a procedure).

Action:Check the statement, making sure that its commands, identifiers, operators, delimiters, and terminator form a complete and valid PL/SQL statement.


PLS-00491

PLS-00491numeric literal required

Cause:A constant or variable was used where a numeric literal is required. For example, the code might look like

my_ename VARCHAR2(max_len);

instead of

my_ename VARCHAR2(15);

When specifying the maximum length of a VARCHAR2 variable, an integer literal must be used.

Action:Replace the identifier with a numeric literal.


PLS-00492

PLS-00492variable or constant initialization may not refer to functions declared in the same package

Cause:If a package spec p declares a function f, that function may not be used in any variable declarations in that same package spec. This is because of a circular instantiation problem: in order to fully instantiate the package spec, the variable must be initialized. To initialize the variable, the function body code in the package body must be executed. That requires that the package body be instantiated. However, the package body cannot be instantiated until the package spec is fully instantiated.

Action: Remove the reference to the function from the variable initialization. A technique which often works is to move the variable initialization from the variable declaration (in the package spec) to the package body initialization block.


PLS-00493

PLS-00493invalid reference to a server-side object in a local context

Cause: A reference to a server-side object (such as a column) was found in a context where only PL/SQL objects may be present (such as within the parameter list of a local function or as the index of a (local) PL/SQL table.)

Action: Rewrite the offending statement; or (if a local function call is the problem context), make the function non-local (either packaged or top-level.)


PLS-00494

PLS-00494coercion into multiple record targets not supported

Cause: The INTO list of a SELECT or FETCH specified more than a single record-type target and the column types required coercion into a record to match the INTO list. This is type checked as correct, but not yet supported.

Action: Create a new record type to hold all of the column types or code the SELECT with an INTO target for every source column.


PLS-00495

PLS-00495too many columns in SELECT...INTO statement after bursting record targets

Cause: Type checking indicated the columns in a SELECT or FETCH were being collected into a record in the INTO list. The record was burst into its fields. There were not enough fields in the record for each of the columns.

Action: Change the number of columns or the record variable(s) in the INTO clause so that they match.


PLS-00496

PLS-00496too few columns in SELECT...INTO statement after bursting record targets

Cause: Type checking indicated the columns in a SELECT or FETCH were being collected into a record in the INTO list. The record was burst into its fields. There were not enough columns to fill all of the fields in the record.

Action: Change the number of columns or the record variable(s) in the INTO clause so that they match.


PLS-00497

PLS-00497cannot mix single row and multi-row (bulk) SELECT

Cause:A SELECT or FETCH had an INTO list for which some variables were of the same type as the corresponding column and other variables were of a type that was a collection of the type of the corresponding column. This is ambiguous for whether the intention was to fetch one row or bulk fetch multiple rows.

Action: Change the INTO list so that all variables are of the same (convertible) type as the columns or so that all INTO variables are collections of the same type as the corresponding columns.


PLS-00498

PLS-00498illegal use of a type before its declaration

Cause: A variable or constant was declared to be of a type whose declaration appears later in the compilation unit; or, a type or subtype was declared in terms of another type whose declaration appears later in the compilation unit.

Action: Ensure that the type declaration precedes its use in the variable/ constant/type declaration.


PLS-00499

PLS-00499coercion into collection of records not supported

Cause: A SELECT or FETCH may specify a column list to be coerced into a variable which is a collection of records. This is type checked as correct, but not yet supported because of the implicit layout change required.

Action: Express the SELECT with an object constructor around the columns and use a collection of objects as an INTO variable.

Or, build the collection one row at a time coercing each row into a record which happens to be an element.

Or, use a record of collections.


PLS-00503

PLS-00503RETURN <value> statement required for this return from function

Cause:In a function body, you used a RETURN statement that contains no expression. In procedures, a RETURN statement contains no expression because the statement simply returns control to the caller. However, in functions, a RETURN statement must contain an expression because its value is assigned to the function identifier.

Action:Add an expression to the RETURN statement.


PLS-00504

PLS-00504type 'name'_BASE may not be used outside of package STANDARD

Cause:In a declaration, you mistakenly specified (for example) the datatype NUMBER_BASE. CHAR_BASE, DATE_BASE, MLSLABEL_BASE, and NUMBER_BASE are PL/SQL internal datatypes used within package STANDARD.

Action:Specify (for example) the datatype NUMBER instead of NUMBER_BASE.


PLS-00505

PLS-00505user-defined types may only be defined as PL/SQL tables or records

Cause:You tried to define a datatype derived from some base type other than RECORD or TABLE. User-defined types must be derived from the RECORD or TABLE type.

Action:Remove the faulty type definition, or define a RECORD or TABLE type.


PLS-00506

PLS-00506user-defined constrained subtypes are disallowed

Cause:You tried to define a subtype (a subtype associates a base type with a constraint and so defines a subset of values). User-defined subtypes are not allowed in this release of PL/SQL. For example, the following type definition is illegal:

SUBTYPE Acronym IS VARCHAR2(5); -- illegal

However, future versions of PL/SQL will allow you to define subtypes.

Action:Remove the illegal type definition.


PLS-00507

PLS-00507PL/SQL tables may not be defined in terms of records or other tables

Cause:In a TABLE type definition, you mistakenly specified a composite datatype (RECORD or TABLE) for the column. The single, unnamed column must belong to a scalar datatype such as CHAR, DATE, or NUMBER.

Action:Remove the TABLE type definition, or replace the composite datatype specifier with a scalar datatype specifier.


PLS-00508

PLS-00508the expression in a RETURN statement cannot be a type

Cause:A datatype specifier was used instead of an expression in the RETURN statement of a user-defined function, as shown in the example below. Do not confuse the RETURN statement, which sets the function identifier to the result value, with the RETURN clause, which specifies the datatype of theresult value.

FUNCTION credit-rating (acct_no NUMBER) RETURN BOOLEAN IS
BEGIN
...
RETURN NUMBER; -- should be an expression
END;

Action:Replace the datatype specifier in the RETURN statement with an appropriate expression.


PLS-00509

PLS-00509implementation restriction: pass a returned record to a temporary identifier before selecting a field

Cause:Illegal syntax was used to call a parameter-less function that returns a record or a PL/SQL table of records. When calling a function that takes parameters and returns a record, you use the following syntax to reference fields in the record:

function_name(parameters).field_name

However, you cannot use the syntax above to call a parameter-less function because PL/SQL does not allow empty parameter lists. That is, the following syntax is illegal:

function_name().field_name -- illegal; empty parameter list

You cannot just drop the empty parameter list because the following syntax is also illegal:

function_name.field_name

-- illegal; no parameter list.

Action:Declare a local record or PL/SQL table of records to which you can assign the function result, then reference its fields directly.


PLS-00510

PLS-00510FLOAT cannot have scale

Cause:When declaring a FLOAT variable, its precision and scale were specified, as shown in the following example:

DECLARE
Salary FLOAT(7,2);

However, a scale for FLOAT variables cannot be specified; only a precision can be specified, as in

salary FLOAT(7);

Action:Remove the scale specifier from the declaration, or declare a NUMBERvariable instead.


PLS-00511

PLS-00511a record may not contain a PL/SQL table of records

Cause:In a RECORD definition, one of the fields was declared as a PL/SQL table of records. This is not allowed. A record can be the component of another record (that is, records can be nested), but a PL/SQL table of records cannot be the component of a record.

Action:Remove the field declaration, or revise it to specify a simple record type.


PLS-00512

PLS-00512implementation restriction: 'name' cannot directly access remote package variable or cursor

Cause:An attempt was made to reference a remote packaged variable or cursor. This is not allowed. Instead, add to the remote package a function that returns the value of the variable or cursor.

Action:Remove the illegal reference.


PLS-00513

PLS-00513PL/SQL function called from SQL must return value of legal SQL type

Cause:In a SQL statement, do not call a PL/SQL function having a return type that can not be handled by SQL. For example, type BOOLEAN, records and indexed-tables are not supported by SQL and functions returning such values cannot be called from SQL.

Action:Change the returned type and retry the operation.


PLS-00514

PLS-00514INSERT statement with REF INTO clause requires a typed table

Cause:INSERT statement with REF INTO clause is illegal if the table specified in the INTO clause is not an object table.

Action:Remove REF INTO clause and retry the operation.


PLS-00515

PLS-00515the type of the REF INTO variable 'name' must be REF to the table's type

Cause:In INSERT statement with REF INTO clause, the type of the variable or column used onto the REF INTO clause must be a REF <T>, where <T> is the type of the table from the INTO clause.

Action:Use variable or column of appropriate type.


PLS-00516

PLS-00516type mismatch between object table and value 'name' in INSERT statement

Cause:In the INSERT statement operating on typed tables (tables of objects), the type of a non-aggregate value did not match the object type of the table.

Action:Provide a value of appropriate type.


PLS-00517

PLS-00517type mismatch between a select list element 'name' and corresponding table column in INSERT statement with a subquery

Cause:In an INSERT statement with subquery, at lease one of the elements of the select list was not type-compatible with the corresponding column of the table in the INTO clause. This error indicates that the subquery should be rewritten to match the structure of the target table.

Action:Provide a select list element of compatible type.


PLS-00518

PLS-00518this INSERT statement requires VALUES clause containing a parenthesized list of values

Cause:A VALUES clause was entered without a list of SQL data items in parentheses. In all INSERT statements with an explicit column list, the VALUES clause must contain a list of SQL data items in parentheses. For example:

INSERT INTO my_tab (a,b,c) VALUES (1,2,my_variable);

Action:Rewrite the statement to include a list of SQL data items in parentheses.


PLS-00519

PLS-00519this INSERT statement requires a VALUES clause containing an object type expression, not a list of values

Cause:In an INSERT statement with typed tables, an aggregate was used when an object type item was expected.

Action:Replace the aggregate with an object constructor or other object type expression.


PLS-00520

PLS-00520MAP methods must be declared without any parameters other than (optional) SELF

Cause:A MAP member function was declared with a parameter. MAP member functions can have only one parameter: the default SELF parameter. MAP methods must be declared without any parameters. The compiler adds the SELF parameter.

Action:Remove the parameter from the MAP member function.


PLS-00521

PLS-00521ORDER methods must be declared with 1 (one) parameter in addition to (optional) SELF

Cause:An ORDER member function was declared without the user-specified parameter. ORDER member functions have two parameters, one is the default SELF parameter which is added by the compiler. the second parameter is added by the user and must declare an order method which must be the same type as the containing object type.

Action:Check and correct the way the parameter is specified.


PLS-00522

PLS-00522 MAP methods must return a scalar type

Cause:The MAP member function was written such that it returns something other than a scalar type.

Action:Rewrite the MAP function such that it returns a scalar type.


PLS-00523

PLS-00523ORDER methods must return an INTEGER

Cause:An ORDER member function was written such that it returns something other than an integer type.

Action:Rewrite the ORDER method such that it returns an integer type.


PLS-00524

PLS-00524The parameter type in an ORDER method must be the containing object type

Cause:An ORDER member function was declared without the user-specified parameter. ORDER member functions have two parameters, one is the default SELF parameter which is added by the compiler. the second parameter is added by the user and must declare an ORDER method which must be the same type as the containing object type.

Action:Check and correct the way the parameter is specified.


PLS-00525

PLS-00525within SQL statements, only equality comparisons of objects are allowed without a map or order function

Cause:A MAP or ORDER function was not provided for a relational comparison. Only equality comparisons may be used when a map or order function is not supplied.

Action:Supply either a MAP or ORDER function for the object. Otherwise change the program to use only equality comparisons.


PLS-00526

PLS-00526a MAP or ORDER function is required for comparing objects in PL/SQL

Cause:Within stand alone PL/SQL, an attempt was made to compare objects without a MAP or ORDER function.

Action:Provide a MAP or ORDER function and retry the operation.


PLS-00527

PLS-00527MAP or ORDER functions require a PRAGMA RESTRICT_REFERENCES specifying:WNDS, WNPS, RNPS, RNDS

Cause:Either a PRAGMA RESTRICT_REFERENCES was not specified or it was specified without one of the following: WNDS, WNPS, RNPS, or RNDS.

Action:Add or correct the PRAGMA and retry the operation.


PLS-00528

PLS-00528the parameters to an ORDER function must have IN mode

Cause:You declared parameter to an ORDER function to have OUT or IN OUT mode.

Action:Correct the parameter to use IN mode only.


PLS-00529

PLS-00529bad column name name in INSERT statement (must be an identifier)

Cause:In an INSERT statement, an attempt was made to use a column name that is not an identifier. In any INSERT statement with explicit column list a column name must be a simple identifier.

Action:Rewrite the INSERT statement, using a simple identifier for the column name.


PLS-00530

PLS-00530illegal type used for object type attribute: name

Cause:An attempt was made to use an invalid type for an object type attribute.

Action:Use only supported types for the object type attribute.


PLS-00531

PLS-00531unsupported type in a VARRAY or TABLE type: name

Cause:An attempt was made to use an unsupported type in a VARRAY or TABLE type.

Action:Use only supported types in a VARRAY or TABLE type.


PLS-00532

PLS-00532target of REF must be a complete or incomplete object type

Cause:An attempt was made to specify a REF target that was neither a complete nor an incomplete object type. A potential REF target can be one of the following:

a complete object type. For example:

CREATE TYPE type_with_no_errors (a number);

CREATE TYPE t2 (a REF type_with_no_errors);

a pure incomplete type. For example:

CREATE TYPE pure_incomplete_type;

CREATE TYPE t2 (a REF pure_incomplete_type);

an impure incomplete object type. For example:

CREATE TYPE type_with_semantic_errors (an undeclared_type);

CREATE TYPE t2 (a REF type_with_semantic_errors);

Action:If a REF must be used, rewrite it such that its target is either a complete or an incomplete object type. Otherwise, remove the REF.


PLS-00533

PLS-00533tables of non_queryable types are not supported

Cause:An attempt was made to create a table of a type which cannot be queried. Tables of such types are not supported.

Action:Create an object type containing the non-queryable type. Then create a table of the object type.


PLS-00534

PLS-00534a Table type may not contain a nested table type or VARRAY

Cause:An attempt was made to do one of the following: define a table type which contained nested collection types. Or define an object table that has (perhaps nested) another table type or VARRAY type.

Action:Check the table definitions to be sure that they do not contain nested tables or VARRAYs.


PLS-00535

PLS-00535a VARRAY type may not contain a NESTED TABLE, VARRAY or LOB

Cause:An attempt was made to do one of the following: define a VARRAY type containing a nested collection type or LOB or define a VARRAY type of an object type that has a nested attribute which is one of NESTED TABLE, VARRAY or LOB type.

Action:Check the VARRAY definitions to be sure that they do not contain nested collection types, LOBs or nested attributes.


PLS-00536

PLS-00536navigation through REF variables is not supported in PL/SQL

Cause:The expression of the form refvar.field was entered. This is not supported in this version of PL/SQL.

Action:This navigation is only supported for database objects. The REF variable can be used to insert into a database column of the same type, or select from it. However, you will not be able to navigate through it. You will have to remove the navigation.


PLS-00537

PLS-00537a VARRAY must have a positive limit

Cause:A VARRAY type was declared with a non-positive limit, for example VARRAY(0).

Action:Declare the VARRAY with a positive limit and retry the operation.


PLS-00538

PLS-00538subprogram or cursor name is declared in an object type specification and must be defined in the object type body

Cause:The specified subprogram is declared in an object type's specification, but is not defined in the object type body.

Action:Define the subprogram in the object type body, or remove the declaration from the specification.


PLS-00539

PLS-00539subprogram name is declared in an object type body and must be defined in the object type specification

Cause:The specified subprogram is declared in an object type's body, but is not defined in the object type's specification. Notice cursor bodies can exist without a specification.

Action:Define the subprogram in the object type's specification, or remove the declaration from the body.


PLS-00540

PLS-00540object not supported in this context

Cause:An object was declared inside a local scope (Function, Procedure, or anonymous block), or in a package scope which is not supported.

Action:Declare the type in a global or data base scope.


PLS-00541

PLS-00541size or length specified is too large

Cause:A length or size that is too large was specified for a data item.

Action:Specify a smaller value and retry the operation.


PLS-00542

PLS-00542CLOB and NCLOB cannot use varying-width character sets in the server

Cause:A server type is being created with an embedded CLOB or NCLOB attribute which uses a varying-width character set.

Action:Use VARCHAR2 instead of CLOB, or use a fixed-width character set.


PLS-00543

PLS-00543a PLSQL Table may not contain a nested table type or VARRAY

Cause:You defined a PLSQL table that contains a (possibly deeply) nested table type or VARRAY. Nested collection types are not supported.

Action:Remove the nested table type or VARRAY and retry the operation.


PLS-00546

PLS-00546SELF may not be declared as a REF parameter

Cause:SELF was declared as a REF parameter to a member function or procedure. SELF is not supported as a REF.

Action:Re-declare SELF as a value parameter.


PLS-00550

PLS-00550character set specification is not allowed for this type

Cause:A character set specification was made on a type that does not require one.

Action:Remove the character set specification, or change the type.


PLS-00551

PLS-00551character set ANY_CS is only allowed on a subprogram parameter

Cause:The character set ANY_CS was specified when it is not allowed.

Action:Change or remove the character set specification.


PLS-00552

PLS-00552flexible character set is not allowed on component element

Cause:ANY_CS or %CHARSET was used to reference an ANY_CS parameter which is not a CHAR, VARCHAR2, or CLOB type. ANY_CS or %CHARSET is not allowed for fields of a record, object, elements of a collection, etc.

Action:Change or remove the character set specification.


PLS-00553

PLS-00553character set name is not recognized

Cause:An unrecognized name appears in a character set specification.

Action:Change or remove the character set specification.


PLS-00554

PLS-00554character set has already been determined

Cause:A redundant or conflicting character set was specified.

Action:Remove the CHARACTER SET specification, or change the character set specified.


PLS-00560

PLS-00560character set mismatch

Cause:An expression was used that has the wrong character set.

Action:Change the expression using TRANSLATE(... USING ...) or change the character set.


PLS-00561

PLS-00561character set mismatch on value for parameter name

Cause:An expression was used that has the wrong character set.

Action:Change the expression using TRANSLATE(... USING ...) or change the character set.


PLS-00562

PLS-00562a function must return a type

Cause:The current function was defined to return something other than a data type.

Action:Make sure the function is returning a data_type.


PLS-00563

PLS-00563illegal use of CAST expression

Cause:CAST (in PLSQL) was used outside of a DML scope.

Action:Do not use CAST outside DML statements.


PLS-00564

PLS-00564LOB arguments are not permitted in remote calls

Cause:Use of LOB argument in remote call is not allowed. Note this also includes composite types including LOBs.

Action:Remove LOB argument from the remote call.


PLS-00565

PLS-00565name must be completed as a potential REF target (object type)

Cause:Incomplete library units that are potential targets of REF dependencies must be completed so that they continue to remain potential targets of REF dependencies (since there might be library units with REF dependencies on this library unit. Potential REF targets include complete and incomplete object types. This error occurred because an attempt was made to complete a potential REF target as something other than a potential REF target.

Action:Use another name for this library unit, or drop the original incomplete library unit


PLS-00700

PLS-00700PRAGMA EXCEPTION_INIT of 'name' must follow declaration of its exception in same block

Cause:A PRAGMA EXCEPTION_INIT was not declared in the same block as its exception. They must be declared in the proper order in the same block, with the PRAGMA EXCEPTION_INIT declaration following the exception declaration.

Action:Place the PRAGMA EXCEPTION_INIT declaration directly after the declaration of the exception referenced by the pragma.


PLS-00701

PLS-00701illegal ORACLE error number num for PRAGMA EXCEPTION_INIT

Cause:The error number passed to a PRAGMA EXCEPTION_INIT was out of range. The error number must be in the range -9999 .. -1 (excluding -100) for ORACLE errors or in the range -20000 .. -20999 for user-defined errors.

Action:Use a valid error number.


PLS-00702

PLS-00702second argument to PRAGMA EXCEPTION_INIT must be a numeric literal

Cause:The second argument passed to a PRAGMA EXCEPTION_INIT was something other than a numeric literal (a variable, for example). The second argument must be a numeric literal in the range -9999 .. -1 (excluding -100) for ORACLE errors or in the range -20000 .. -20999 for user-defined errors.

Action:Replace the second argument with a valid error number.


PLS-00703

PLS-00703multiple instances of named argument in list

Cause:Two or more actual parameters in a subprogram call refer to the same formal parameter.

Action:Remove the duplicate actual parameter.


PLS-00704

PLS-00704'name' must be declared as an exception

Cause:The exception_name parameter passed to PRAGMA EXCEPTION_INIT is misspelled or does not refer to a legally declared exception. Or, the pragma is misplaced; it must appear in the same declarative section, somewhere after the exception declaration.

Action:Check your spelling of the exception_name parameter. Then, check the exception declaration, making sure the exception name and the keyword EXCEPTION are spelled correctly. Also make sure the pragma appears in the same declarative section somewhere after the exception declaration.


PLS-00705

PLS-00705exceptions not allowed in an expression

Cause:You mistakenly referred to an exception within an expression. Exceptions have names but not values and therefore cannot contribute values to an expression. For example, the following RETURN statement is illegal:

FUNCTION credit_limit (cust_no INTEGER) RETURN NUMBER IS

limit NUMBER;

over_limit EXCEPTION;

...

BEGIN

...

RETURN over_limit; -- illegal

END;

Action:Check your spelling of the identifiers in the expression, then rewrite the expression so that it does not refer to an exception.


PLS-00706

PLS-00706exception name cannot be used as prefix of a selected component

Cause:An exception name was mistakenly used to qualify a reference to a component. For example, when dot notation was used to specify fields within a record, an exception name might have been coded instead of the record name.

Action:Rewrite the component reference using a valid prefix (for example, the name of a package, record, or schema).


PLS-00707

PLS-00707unsupported construct or internal error [num]

Cause: At run time, this is an internal error. At compile time, it indicates one of the following problems:

A call was made to a remote subprogram that has a parameter type or default expression not supported at the calling site.

An incomplete upgrade or downgrade was done to a database that has stored procedures. Perhaps incorrect versions of system packages such as STANDARD.SQL were installed.

A compiler bug was encountered. In such cases, legal PL/SQL syntax will fail to compile.

Action: Either report the internal error to your Customer Support representative or, depending on the problem, take one of the following actions:

Revise the logic of the application to use parameter types and default expressions that are supported at both the local and remote sites.

Complete the upgrade or downgrade properly, making sure to install correct versions of all system packages.

Report the legal-syntax error to your Customer Support representative. If there are line and column numbers displayed with the error message, they might help you find a workaround. For example, try recoding the offending line to avoid the bug.


PLS-00708

PLS-00708pragma name must be declared in a package specification

Cause: The named pragma was not declared in a package specification, as required. For example, the pragma RESTRICT_REFERENCES must be declared in a package specification.

Action: Remove or relocate the misplaced pragma.


PLS-00709

PLS-00709pragma name must be declared in package specification and body

Cause: The named pragma was declared in a package specification but not in the corresponding package body or vice-versa, as well as the package body.

Action: Add the pragma to that part of the package declaration that does not have the pragma.


PLS-00801

PLS-00801internal error [num]

Cause: This is a generic internal error that might occur during compilation or execution. The first parameter is the internal error number.

Action:Report this error as a bug to your Customer Support representative.


PLS-00900

PLS-00900can't find body of unit 'name'

Cause:At run time, the body of a program unit could not be found. This happens, for example, if you reference a procedure for which a specification but no body exists. (No compile-time errors were generated because the specification exists.)

Action:Define a body for the program unit.


PLS-00901

PLS-00901the datatype of column 'name' of table 'name' is not supported

Cause:A column in a database table belongs to a datatype that is not supported by the current release of PL/SQL.

Action:Remove the offending column from the table or copy the desired columns to another table.


PLS-00904

PLS-00904insufficient privilege to access object 'name'

Cause:You tried to operate on a database object without the required privilege. This error occurs, for example, if you try to UPDATE a table for which you have only SELECT privileges.

Action:Ask your DBA to perform the operation or to grant you the required privilege.


PLS-00904

PLS-00904insufficient privilege to access object name

Cause:An attempt was made to operate on a database object without the required privilege. This error occurs, for example, if an attempt was made to UPDATE a table for which only SELECT privileges were granted.

Action:Ask the DBA to perform the operation or to grant you the required privilege.


PLS-00905

PLS-00905object 'name' is invalid

Cause:You referenced an invalid package specification or stored subprogram. A package specification or stored subprogram is invalid if its source code or any database object it references has been DROPped, REPLACEd, or ALTERed since it was last compiled.

Action:Find out what invalidated the package specification or stored subprogram, then make sure that ORACLE can recompile it without errors.


PLS-00906

PLS-00906compilation is not possible

Cause:The PL/SQL compiler cannot run properly because its operating environment is corrupted. For example, its error message file might be inaccessible.

Action:Check the PL/SQL operating environment, making sure that all files required by the compiler are accessible.


PLS-00907

PLS-00907unable to find library unit name

Cause: PL/SQL was unable to find and load a library unit which had previously been available. Typically this can happen when loading a library unit from backing storage, but other library units on which that unit depends are not in the backing store.

Action: Provide the needed library unit.


PLS-00908

PLS-00908 the stored format of name is not supported by this release

Cause: PL/SQL cannot understand the stored format of a library unit. It has been compiled or shrink-wrapped with a version of PL/SQL incompatible with this version.

Action: Recompile the library unit for this version of PL/SQL.


PLS-00990

PLS-00990PL/SQL tables of cursor variables are not allowed

Cause:An attempt was made to use a REF CURSOR type to define a TABLE type, which is not allowed. The rows in a PL/SQL table cannot store the values of cursor variables.

Action:Redefine the TABLE type using one of the PL/SQL scalar datatypes (such as CHAR, DATE, or NUMBER) to specify its column type.


PLS-00992

PLS-00992cursor variables cannot be FETCHed from

Cause:An attempt was made to FETCH from a cursor variable inside a PL/SQL block or subprogram, which is not allowed. Although a cursor variable is OPENed on the server side by passing it to an anonymous PL/SQL block, it must be fetched from on the client side (that is, in the host environment).

Action:Move the FETCH statement from the PL/SQL block or subprogram to thehost environment.


PLS-00993

PLS-00993cursor variables cannot be passed as RPC arguments or results

Cause:An attempt was made to pass a cursor variable to or from a remote subprogram, which is not allowed. For example, a remote procedure cannot be used to open a cursor variable because remote subprograms cannot return the values of cursor variables.

Action:Change the subprogram call to reference a local database.


PLS-00994

PLS-00994cursor variables cannot be declared as part of a package

Cause:An attempt was made to declare a cursor variable in a package specification, which is not allowed. Although REF CURSOR types can be defined in a PL/SQL block, subprogram, or package, cursor variables can be declared only in a block or subprogram.

Action:Move the cursor variable declaration into a PL/SQL block or subprogram.


PLS-00995

PLS-00995unhandled exception # 'num'

Cause:An exception was raised for which no handler was found. If it cannot find a handler for a raised exception, PL/SQL returns an unhandled exception to the host environment. The number in the message refers to the ORA-num listed in Chapter2 of this Manual.

Action:Look up ORA-num in Chapter2 of this Manual. Fix the condition that raised the exception, write an appropriate exception handler, or use the OTHERS handler. If there is an appropriate handler in the current block, the exception was raised in a declaration or exception handler. (An exception raised in a declaration or exception handler propagates immediately to the enclosing block.) You can avoid unhandled exceptions by coding an OTHERS handler at the topmost level of every PL/SQL block and subprogram.


PLS-00996

PLS-00996out of memory

Cause:A request from PL/SQL for more memory failed.

Action:Make sure that you are not referencing the wrong row in a PL/SQL table and that your program is not recursing too deeply.


PLS-01401

PLS-01401identifier over 18 characters long


PLS-01402

PLS-01402use of quoted identifier


PLS-01403

PLS-01403Comment delimiters /* */


PLS-01404

PLS-01404ANSI Identifiers can only consist of letters, digits, and the underscore character


PLS-01405

PLS-01405under ANSI's grammar, numeric data represented in exponent notation must use an uppercase E


PLS-01406

PLS-01406an identifier has been found that is considered a keyword in ANSI's grammar but not in PL/SQL's


PLS-01407

PLS-01407one of the identifiers CHAR, CHARACTER, or INTEGER has been redefined by the programmer


PLS-01408

PLS-01408use of & token


PLS-01409

PLS-01409use of PRIOR_ token


PLS-01410

PLS-01410use of MOD token


PLS-01411

PLS-01411use of REM token


PLS-01412

PLS-01412use of EXP token


PLS-01413

PLS-01413use of NULL an expression


PLS-01414

PLS-01414use of qualified expression here


PLS-01415

PLS-01415use of aggregate value here


PLS-01416

PLS-01416use of <id> (<value>...) here


PLS-01417

PLS-01417use of %attribute


PLS-01418

PLS-01418subquery cannot include set operators in ANSI's grammar


PLS-01419

PLS-01419subquery must have either *' or exactly one column in its select list


PLS-01420

PLS-01420INTERSECT and MINUS set operators are not ANSI


PLS-01421

PLS-01421FOR UPDATE clause


PLS-01422

PLS-01422aliases


PLS-01423

PLS-01423subquery on right-hand-side in set clause


PLS-01424

PLS-01424non-ANSI order of clauses


PLS-01425

PLS-01425connect-by clause


PLS-01450

PLS-01450this <value expression> contains a nonconforming datatype


PLS-01451

PLS-01451the datatypes of these <value expressions> must be comparable


PLS-01452

PLS-01452this function is not part of the ANSI standard


PLS-01453

PLS-01453this procedure is not part of the ANSI standard


PLS-01454

PLS-01454no operator may be used with values of datatype CHAR


PLS-01455

PLS-01455the predicates IS NULL and IS NOT NULL are defined only forcolumn specifications


PLS-01456

PLS-01456name length cannot exceed 3.


PLS-01458

PLS-01458the set clause in an UPDATE statement requires a column name of length 1


PLS-01460

PLS-01460cannot access object on a remote host


PLS-01463

PLS-01463STDDEV is not a standard set function


PLS-01464

PLS-01464VARIANCE is not a standard set function


PLS-01466

PLS-01466null strings are not allowed


PLS-01468

PLS-01468the first argument of the like-predicate must be a column of typecharacter string


PLS-01469

PLS-01469ANSI standard does not permit records


PLS-01470

PLS-01470the escape character in the like-predicate must be a literal or a variable of type CHAR


PLS-01471

PLS-01471the keyword DISTINCT must be present in a COUNT(DISTINCT sim_expr)


PLS-01472

PLS-01472in a set_function_specification, if DISTINCT is present, the expression must be a column_specification


PLS-01473

PLS-01473use <> instead of != or ~=


PLS-01474

PLS-01474use of ANY is non_ANSI


PLS-01500

PLS-01500unions are not allowed in the definition of a view


PLS-01501

PLS-01501options in CREATE TABLE statement is non-ANSI.


PLS-01502

PLS-01502constraint name and constraint status are non-ANSI.


PLS-01503

PLS-01503the expression in a SET clause must not include a set function


PLS-01504

PLS-01504use of AS phase in CREATE TABLE statement is non_ANSI


PLS-01505

PLS-01505ALTER is non-ANSI


PLS-01506

PLS-01506CREATE INDEX is non-ANSI


PLS-01507

PLS-01507DROP is non-ANSI


PLS-01701

PLS-01701illegal syntax in ROLLBACK WORK statement


PLS-01702

PLS-01702illegal syntax in COMMIT WORK statement


PLS-01703

PLS-01703cursor name in CLOSE statement must be of length 1


PLS-01704

PLS-01704the expressions in a sort clause must be column specs or unsigned integers, with optional ASC or DESC


PLS-01705

PLS-01705table specified by a cursor not updatable if cursor specification has a UNION or ORDER_BY


PLS-01707

PLS-01707in positioned DELETE or UPDATE statement, table must be identified in specification of cursor


PLS-01708

PLS-01708in searched DELETE, UPDATE or INSERT, table must not appear in FROM clause of subqueries in search condition


PLS-01709

PLS-01709value list of INSERT statement, if specified with value list rather than subquery, must be value specification


PLS-01710

PLS-01710in a positioned DELETE or UPDATE statement, the cursor name must be of length 1


PLS-01711

PLS-01711a SELECT statement may not contain ORDER_BY, HAVING, or GROUP_BY clause


PLS-01712

PLS-01712ANSI does not allow bind variables as INDICATORS


PLS-01713

PLS-01713the constraints on these types do not match


PLS-01714

PLS-01714ANSI expects a column name not a literal value here


PLS-01715

PLS-01715ANSI does not accept SAVEPOINTs


ATT-05002

ATT-05002 Circular dependency in the specialization/generalization hierarchy

Cause:

The type is specialized from a type that has this type in its specialization hierarchy. You cannot specialize a type from itself.

Action:

Break the circular dependency by removing one of the specializations.


ATT-05005

ATT-05005 Type marked 'Final' cannot have any subtypes

Cause:

The type's 'Final' property is set to Yes, indicating it is not to be specialized. However, it has been specialized into one or more subtypes.

Action:

Either remove the subtypes, or set the type's 'Final' property to No.


ATT-05006

ATT-05006 Type marked 'Final' must be Instantiable

Cause:

The type's 'Final' property is set to Yes, indicating it is not to be specialized. However, it also has been marked as not Instantiable and non-instantiable types must be specialized into one or more subtypes.

Action:

Either set the Instantiable property to Yes, or set the Final property to No.


ATT-05007

ATT-05007 Interface Type cannot specialize a non-Interface Type

Cause:

The type is defined as an Interface Type, but it specializes another type that is not an Interface Type. Interface Types can only specialize other Interface Types.

Action:

Either remove the specialization, or set the 'Interface' property for this type to No.


ATT-05008

ATT-05008 Object Type has no members

Cause:

The Object Type has no Attributes, Operations or Association Roles (collectively referred to as Type Members). Each Type must have at least one Type Member.

Action:

Add one or more Type Members to the Object Type.


ATT-05009

ATT-05009 Valid value not in supertype's Value Set

Cause:

The Value Type that this valid value is defined against has been specialized from another Value Type that also has a Value Set defined against it, and this Valid Value is outside of that set. If a supertype (or one of its ancestors) has a Value Set defined against it, then the Value Set on this Value Type must be a subset of the supertype's Value Set.

Action:

Extend the supertype's Value Set to incorporate this value, or remove the valid value from this Value Type.


ATT-05010

ATT-05010 Interface Types cannot be marked 'Persistent'

Cause:

The Object Type is defined as an Interface Type, but it has also been marked as Persistent. Persistency of Interface Types is not supported.

Action:

Either set the 'Persistent' property to 'No', or the 'Interface' property to 'No'.


ATT-05011

ATT-05011 Type Member cannot be Persistent unless Type is Persistent

Cause:

The Type Member (Attribute, Operation or Role) has the 'Persistent' property set to Yes, but is part of an Object Type whose 'Persistent' property is set to No. A Type Member can only be made persistent if it forms part of a persistent type.

Action:

Either set the 'Persistent' property of the Type Member to No, or set the 'Persistent' property of the Object Type to Yes.


ATT-05012

ATT-05012 DataType of Attribute not specified

Cause:

The DataType of this Attribute has been left blank. Before the Attribute can be used in any implementation, its DataType property must be set to a valid Value Type.

Action:

Set the DataType property to a valid Value Type.


ATT-05013

ATT-05013 Array Size must be specified if Attribute's Array property is set

Cause:

The 'Array' property of this attribute is set to Yes, but the 'Array Size' property is undefined. The Array Size property must be specified.

Action:

Either set the 'Array' property to No, or specify a value for the 'Array Size' property.


ATT-05015

ATT-05015 Member with 'Type/Class' scope cannot be made persistent

Cause:

The Type Member (Attribute, Operation or Association Role) has its 'Scope' property set to 'Type/Class', and also has its 'Persistent' property set to Yes. Persistent Type Members must be Instance scope.

Action:

Either set the 'Scope' property to Instance, or set the 'Persistent' property to No.


ATT-05016

ATT-05016 Operation that must be overridden cannot be private

Cause:

The 'Overridable' property on the operation is set to 'Must be overridden', but the 'Visibility' property is set to Private. The visibility of an operation cannot be private if it is to be overridden.

Action:

Either change the 'Visibility' so that the operation is not Private, or change the 'Overridable' property accordingly.


ATT-05017

ATT-05017 Constructor cannot be persistent

Cause:

The operation's 'Operation Type' property is set to Constructor and the 'Persistent' property is set to Yes. Persistency of Constructors is not supported.

Action:

Set the Persistent property of the operation to No.


ATT-05018

ATT-05018 Constructor must be Instance scope

Cause:

The operation's 'Operation Type' property is set to Constructor, and the 'Scope' property is set to Type/Class. Constructors must be of Instance scope.

Action:

Set the 'Scope' property to Instance.


ATT-05019

ATT-05019 Operation that must be overridden part of Object Type marked 'Final'

Cause:

The 'Overridable' property on the operation is set to 'Must be overridden', but the operation forms part of a Type marked as 'Final', indicating that the type cannot be specialized.

Action:

Change either the 'Overridable' property on the operation, or the 'Final' property on the Object Type accordingly.


ATT-05021

ATT-05021 Type can only specialize one non-Interface type

Cause:

The Object Type specializes more than one other non-Interface types. A type can specialize multiple Interface types, but only a single non-Interface type.

Action:

Change the inheritance accordingly.


ATT-05022

ATT-05022 Value Type can only specialize one other Value Type

Cause:

A Value Type is specialized from more than one other Value Type. Only single inheritance of Value Types is allowed.

Action:

Change the inheritance accordingly.


ATT-05023

ATT-05023 Other association role must also be persistent

Cause:

The 'Persistent' property is set to Yes on this Association Role, but is set to No on the Association Role at the other end of the association. If this role is to be persistent, the other role (and its owning Object Type) must also be marked as Persistent.

Action:

Change the setting of the Persistent property on either this role, or the role at the other end of the association.


ATT-05027

ATT-05027 Cannot compose an Object Type into itself

Cause:

The 'Aggregation' property of this Association Role is set to 'Strong', and the Association Role at the other end of the association is attached either to the same Object Type, or to a type that itself is aggregated into this type (either directly or indirectly). A type cannot be composed of itself.

Action:

Change the 'Aggregation' property setting to either 'Weak' or 'None'.


ATT-05028

ATT-05028 Parameter Type not specified

Cause:

The 'Type' property of this parameter has been left blank. The Type should be specified before generation.

Action:

Set the Type property of the operation parameter to a valid Value Type or Object Type.


ATT-05029

ATT-05029 Operation Return Type not specified

Cause:

The operation's 'Return Value' property is set to Yes (indicating that the operation returns a value), but the type of the return value (i.e. the 'Return Type' property) is not defined.

Action:

Either specify a value for the operation Return Type, or set the 'Return Value' property to No.


ATT-05030

ATT-05030 Uniqueness constraint must contain at least one type member

Cause:

There are no type members (attributes, operations, associations) for this uniqueness constraint. Therefore it will be ignored.

Action:

Either delete the type constraint or add one or more type members (attributes, operations, associations).


ATT-05031

ATT-05031 Uniqueness constraint cannot contain large type attributes

Cause:

A component of the uniqueness constraint has a Datatype based on a large Value Type.

Action:

Either remove the type component from the uniqueness constraint, or change the 'Datatype' to a Value Type that does not have the 'Large Object' property set to Yes.


ATT-05032

ATT-05032 Large object Value Types must be specialized from String or Binary

Cause:

The 'Large Object' property of this Value Type is set to Yes but it is specialized from a Value Type that is not based on String or Binary.

Action:

Either set the 'Large Object' property to No, or set the 'Datatype' to a Value Type specialized from String or Binary. Alternatively, remove the specialization.


ATT-05300

ATT-05300 Preference '%s' not loaded

Cause:

This is an internal message that is not normally issued.

Action:

Contact your customer support representative.


ATT-05301

ATT-05301 %s Failure: Please send the following information to your support person

Cause:

This is an internal message that is not normally issued.

Action:

Contact your customer support representative


ATT-05302

ATT-05302 Call failed in:

Cause:

Action:


ATT-05303

ATT-05303 Assertion Failure at:

Cause:

Action:


ATT-05304

ATT-05304 Failed to update Repository element

Cause:

The most likely reason for this error is that another user is updating the Repository element that the generation/design capture process needs to update. Another cause could be that you do not have the required access privileges to the application system.

Action:

Check if another user is updating the same data, then try again when they have completed. Check your access rights to the application system.


ATT-05400

ATT-05400 API Failed to create Oracle Object Type

Cause:

An API call has been made to create an Oracle Object type and any dependent elements. This call has failed either because of validation checks, possibly access rights or a corrupt Repository.

Action:


ATT-05502

ATT-05502 Unable to define select for SQL cursor '%s'

Cause:

A error occurred while creating a SQL statement.

Action:

Contact Customer Support.


ATT-05503

ATT-05503 Unknown generation state

Cause:

An unknown generation state has been detected.

Action:

Contact Customer Support.


ATT-05504

ATT-05504 Unable to execute SQL cursor

Cause:

An error occurred while executing an SQL cursor.

Action:

Contact Customer Support.


ATT-05506

ATT-05506 Unable to get registry key for '%s'

Cause:

A registry variable could not be found.

Action:

The product is not installed correctly. Re-install as necessary.


ATT-05507

ATT-05507 Invalid file path '%s'

Cause:

Internal error while expanding and validating a file path.

Action:

Contact Customer Support.


ATT-05508

ATT-05508 No base value type defined, cannot be made persistent

Cause:

A member for this attribute will be generated in mapped/support code but not persistent mapping will be generated in the run time context class.

Action:

If the attribute is required to be made persistent then set the datatype to one that is derived from a base value type.


ATT-05509

ATT-05509 Unable to create unique name

Cause:

A filename and other existing filenames are such that it is impossible to make the filename unique.

Action:

Contact Customer Support.


ATT-05510

ATT-05510 Failed to find language for '%s'

Cause:

A registry value could not be found.

Action:

Ensure this product has been installed correctly.


ATT-05511

ATT-05511 The following error occurred during token expansion, '%s'

Cause:

Code generation failed.

Action:

Contact Customer Support.


ATT-05513

ATT-05513 Invalid token group encountered during token expansion, '%s'

Cause:

Code generation failed.

Action:

Contact Customer Support.


ATT-05514

ATT-05514 The Class Set was not passed to the Generator

Cause:

The Generator could not determine the Class Set.

Action:

Contact Customer Support.


ATT-05515

ATT-05515 The generation target was not passed to the Generator

Cause:

The Generator could not determine the generation target.

Action:

Contact Customer Support.


ATT-05516

ATT-05516 The Object Types were not passed to the Generator

Cause:

The Generator could not determine the object types to be generated.

Action:

Contact Customer Support.


ATT-05517

ATT-05517 The commit list was not passed to the Generator

Cause:

The Generator was unable obtain the change list.

Action:

Contact Customer Support.


ATT-05518

ATT-05518 Source file not found

Cause:

An assign was performed on a file before an add.

Action:

Contact Customer Support.


ATT-05519

ATT-05519 Unable to find linkage to unassign

Cause:

An assign has been performed for a linkage that does not exist.

Action:

Contact Customer Support.


ATT-05520

ATT-05520 Unable to open file '%s'

Cause:

The file could not be opened

Action:

Ensure that the file and/or directory exists and is not read-only. Ensure that another application is not using the file. The code structure may be out of date with respect to the Repository in which case you must re-scan files or remove file mappings.


ATT-05521

ATT-05521 Unable to find linkage to generate

Cause:

Generation has occurred for a linkage that does not exist.

Action:

Contact Customer Support.


ATT-05522

ATT-05522 Unable to generate to read-only file '%s'

Cause:

The file to generate to is read-only.

Action:

Change the file permission to be read/write.


ATT-05523

ATT-05523 Unable to read from file '%s'

Cause:

The file could not be read from.

Action:

Contact Customer Support.


ATT-05524

ATT-05524 Unable to write to file '%s'

Cause:

The file could not be written to.

Action:

Contact Customer Support.


ATT-05525

ATT-05525 Unable to copy temporary file to code file

Cause:

A temporary file created during generation, could not be copied to a new file location.

Action:

Ensure that the generation file directory and existing files are not read-only. Ensure that files are not being used by another application.


ATT-05526

ATT-05526 Greater than one set member item to drop

Cause:

There is ambiguity as to which set member item to delete.

Action:

Contact Customer Support.


ATT-05527

ATT-05527 Generalization outside the class set : %s

Cause:

You have generalized to a type that is not in the current class set. Hence, meta data would not be created for the super-type.

Action:

Add the super-type to the class set.


ATT-05528

ATT-05528 Unable to determine file mapping for '%s'

Cause:

The file mappings as entered in the C++ Generator Options dialog were not found in the registry.

Action:

Contact Customer Support.


ATT-05529

ATT-05529 Mapping must be ONE, SEPARATE or SAME, value is '%s'

Cause:

An invalid file mapping type has been detected. File mappings are entered via the C++ Generator Options dialog.

Action:

Contact Customer Support.


ATT-05530

ATT-05530 Object Type %s which is not defined in the current class set

Cause:

An object type within this Class Set has a strong aggregation (composition) association to an object type outside of the current Class Set.

Action:

Either add the aggregated object type to the Class Set, or change the 'Aggregation' property to Weak.


ATT-05531

ATT-05531 Code not generated for '%s'

Cause:

There is already more than one file for all types in this Class Set.

Action:

Disable 'One file for all types' in the C++ Generator Options dialog.


ATT-05532

ATT-05532 Super Types of Base Exception Types must also be Base Exceptions.

Cause:

This Object Type is marked as being a Base Exception. However it is derived from an Object Type that is not a Base Exception.

Action:

Set 'Base Exception' on the super types of this object type to 'Yes', or Set 'Base Exception' on this object type to 'Inherit', or modify the inheritance of this object type accordingly.


ATT-05533

ATT-05533 Interface type can only have static Attributes

Cause:

The type is defined as an Interface Type, but the attribute is defined as static i.e. the 'Scope' property is set to Type/Class. Interface Types may only contain static attributes.

Action:

Set the 'Scope' property for the Interface Type attributes to Instance.


ATT-05534

ATT-05534 Interface type can only have abstract operations

Cause:

The type has been defined as an Interface Type, but the operation is not defined as 'Must be Overridden'. Operations on Interface Types must be overridden on types that implement the Interface.

Action:

Set the 'Overridable' property for interface operations to be 'Must be Overridden'.


ATT-05535

ATT-05535 Association cannot have 'Type/Class' scope.

Cause:

The 'Scope' of the association is defined as Type/Class. Only Instance scoped associations are supported by C++ Generator.

Action:

Set the 'Scope' property of the association role to Instance.


ATT-05536

ATT-05536 Constant attribute must have initial value

Cause:

The attribute is defined as 'Constant', but no initial value has been defined against the attribute. Constant attributes must be given an initial value.

Action:

Add an initial value to the attribute definition.


ATT-05537

ATT-05537 Previous parameter has default value; this parameter must also have default.

Cause:

The operation parameter sequenced before this one has a default value, but this operation parameter has no default value. If a default value is specified against a parameter, then all subsequent parameters on the same operation must also be given default values.

Action:

Either assign default values to all parameters, or resequence the parameters so that all trailing parameters have defaults.


ATT-05538

ATT-05538 Non Public visibility is not supported; defaulted to public

Cause:

A type has been specialized from another type, and the 'Visibility' of the generalization is set to something other than Public. Only Public inheritance is supported by C++ Generator.

Action:

Set the 'Visibility' of the generalization association to Public.


ATT-05539

ATT-05539 Operation must have dynamic binding if it must be overridden.

Cause:

The operation is defined as ' Must be overridden', but the Dynamic Binding property is set to 'No'. For C++ generation, the Dynamic Binding must be set to 'Yes' if the operation must be overridden.

Action:

Set the 'Dynamic Binding' property for the operation to Yes.


ATT-05540

ATT-05540 Visibility not specified, this will be defaulted to 'Private'

Cause:

The visibility has not specified on this attribute, operation, or association role. The visibility of the generated class member will be defaulted to 'Private'.

Action:

Set the 'Visibility' property to 'Public', 'Protected', or 'Private'


ATT-05541

ATT-05541 Attributes of datatype derived from Boolean should have an initial value

Cause:

The 'DataType' of the attribute is Boolean, or a datatype derived from Boolean but the attribute has no initial value.

Action:

Specify an initial value for the attribute.


ATT-05543

ATT-05543 File '%s' does not exist, creating new file

Cause:

Code was previously generated to this file and the code location saved, but the file no longer exists.

Action:

None.


ATT-05544

ATT-05544 The Generation Mode was not passed to the Generator

Cause:

The Generator could not determine the mode.

Action:

Contact Customer Support.


ATT-05545

ATT-05545 The re-scan files were not passed to the Generator

Cause:

The files for re-scanning were not passed to the Generator.

Action:

Contact Customer Support.


ATT-05546

ATT-05546 The success flag was not passed to the Generator

Cause:

The Success indicator was not passed to the C++ Generator.

Action:

Contact Customer Support.


ATT-05547

ATT-05547 Object Type not found %s

Cause:

While re-scanning source files, the specified object type was not found.

Action:

Change the name of the object type and/or the source file name so the names are the same.


ATT-05550

ATT-05550 Class members must be generated for both roles of an association

Cause:

The 'Generate Class Member' property is set to Yes on this association role, but is set to No on the association role at the other end of the association. If this class member is to be created for this role, there must also be a class member generated for the other role within its respective class.

Action:

Change the setting of the 'Generate Class Member' property on either this role, or the role at the other end of the association.


ATT-05551

ATT-05551 Unable to find Mapped Section Type

Cause:

'Same file as mapped' specified but the mapped section type could not be found in the Repository.

Action:

Contact your Customer Support representative.


ATT-05552

ATT-05552 Unable to find linkage for Mapped Section Type

Cause:

'Same file as mapped' has been specified but the mapped linkage could not be found.

Action:

Contact your Customer Support representative.


ATT-05553

ATT-05553 Unable to reuse %s

Cause:

C++ Generator has detected a previously generated file with this path and has attempted to reuse it. An error has occurred because this file was previously part of different C++ Class Set.

Action:

Change the file path. It is recommended that you generate different Class Sets to different directories. Use the C++ Generator Options dialog (choose Options->Generator Options->C++) to change the destination directory.


ATT-05554

ATT-05554 Operation with 'Type/Class' scope cannot be overridable

Cause:

The operation has scope 'Type/Class' but is defined as 'Must be overridden' or 'May be overridden'. Static virtual functions are not allowed in C++.

Action:

Change the Overridable property of the operation to 'Cannot be overridden', or change the Scope of the operation to 'Instance'


ATT-05555

ATT-05555 Cannot generate mapped and support classes for shared object type

Cause:

You have attempted to generate mapped and support classes for an object type not owned by this application system.

Action:

Change to application system which owns the object type and then generate the mapped and support classes from there.


ATT-05556

ATT-05556 Duplicate code section found %s

Cause:

The code section is implemented more than once in the specified source files.

Action:

Examine the source files and remove the duplicate code section. Re-run the Re-Scan utility to check that the code no longer contains duplicate sections.


ATT-05557

ATT-05557 '%s' for object type '%s' in file '%s' at line %s

Cause:

No further information available

Action:


ATT-05558

ATT-05558 '%s' in file '%s' at line %s

Cause:

No further information available

Action:


ATT-05750

ATT-05750 Collection Type created as REFs, as Object Type contains LOB attributes

Cause:

A collection type has been generated to implement a 1:M composition but the 'Collections As REFs' preference is set to No. In this case, the object type cannot be embedded as it contains a type attribute which represents a 'large object'. Therefore the Collection As REF? property for this collection type is set to Yes.

Action:

To avoid this warning on subsequent generations Either change the 'Collections As REFs preference setting to 'Yes' or change the datatype of the large attribute.


ATT-05751

ATT-05751 Collection type created as REFs, as Object Type contains embedded scalars

Cause:

A collection type has been generated to implement a 1:M composition but the 'Collections As REFs' preference is set to No. In this case the object type cannot be embedded as it contains a type attribute which implements an array, or a table of embedded scalars. Therefore, the 'Collections As REFs' property of the collection type is set to Yes.

Action:

To avoid this warning on subsequent generations Either change the 'Collections As REFs' preference to Yes, or change the Array? property of the type attribute.


ATT-05752

ATT-05752 Maximum length defaulted to %s

Cause:

The Maximum Length specified for the Type Attribute or the Value Type exceeds that which is allowed for the created column. Therefore the maximum length has been defaulted to the maximum length allowed for the datatype. For VARCHAR2, the maximum column length is 4000 characters. For RAW, the maximum column length is 2000 characters.

Action:

Either change the Maximum Length used by the Type Attribute or the Value Type to less than or equal to the allowed length, or change the Datatype.


ATT-05753

ATT-05753 A valid maximum length must be specified for this format type

Cause:

Some datatypes such as String require a Maximum Length to be specified. Since no Maximum Length was specified a default value will be used instead.

Action:

Either specify a Maximum Length for the attribute, or change the datatype used by the attribute.


ATT-05754

ATT-05754 Relational table '%s' already implements this Object Type

Cause:

A Relational Table implementing this Object Type (in your type model) already exists and therefore, an Oracle Object Type cannot be created. It is possible that this Object Type has already been implemented as a Relational Table.

Action:

Remove the Relational Table that implements this Object Type. Select the Object Type and then choose 'Remove Server Model Mapping' from the Utilities menu.


ATT-05755

ATT-05755 Visibility will be ignored, Oracle8 only supports 'Public' operations.

Cause:

The visibility of the operation is set to something other than 'Public'. Oracle8 only supports public operations.

Action:

Set the Visibility of the operation to 'Public'.


ATT-05756

ATT-05756 Composition not supported in relational mode

Cause:

Composition (or 'Strong' aggregation) is not supported by the C++ Generator, or processed during relational database generation in this release.

Action:

The composition should be removed and any mapped/support classes using the generated table should be re-generated. Change the Aggregation property on the role to 'Weak' or 'None'.


ATT-05758

ATT-05758 No base Datatype defined for attribute's Value Type

Cause:

The attribute is based on a Value Type that has not been specialized from one of the built-in Value Types such as String, Integer, etc.

Action:

Check a Datatype is defined for the Type Attribute and that the Datatype inherits from one of the built-in Value Types.


ATT-05759

ATT-05759 Primary object being used as an implementing object type must be persistent

Cause:

The object is being used as an implementing object type because none of its sub-types were marked as such. Implementing object types need to be persistent.

Action:

Change the property of the primary object type to make it persistent.


ATT-05760

ATT-05760 There can only be one implementing object in each inheritance branch

Cause:

This object, and one of its super or sub types have both been marked as implementing object types. Only one is permitted.

Action:

Remove the implementing object preference from either of the two objects. Alternatively remove both and make a super type of both objects the implementing object.


ATT-05761

ATT-05761 Value Type not specialized from any other Value Type

Cause:

The Value Type is not specialized from another Value Type. Value Types must be specialized from another Value Type for a Domain to be created. A Value Type should at least be specialized from one of the following: Binary, Boolean, Date, DateTime, Integer, LargeBinary, Large String, String, Integer, Real.

Action:

Specialize the Value Type from another Value Type. The Value Type can be specialized from one of the following: Binary, Boolean, Date, DateTime, Integer, LargeBinary, Large String, String, Integer, Real.


ATT-05762

ATT-05762 ATT-5762 Error: An unexpected operation has occurred

Cause:

The Transformer has encountered an exception, and cannot continue.

Action:

Contact Customer Support.


ATT-05763

ATT-05763 Object type '%s' at end of association not implemented by Oracle Object Type

Cause:

There is no Oracle Object Type to implement the Object Type at the other end of the association. Therefore, no Oracle Object Type Attribute/Column can be created for the association.

Action:

Ensure that an Oracle Object Type exists for the Object Type at the other end of the association. An Oracle Object Type may not have been generated if: 1) The name for the Oracle Object Type was invalid, or was being used by another Oracle Object Type. 2) The Object Type was a persistent interface type.


ATT-05764

ATT-05764 Embedded column will not be accessible via other associations

Cause:

The Target Object Type which is being strongly aggregated into the Source Object Types is at the '1' end of any other associations. Thus instances of the Target Object embedded in the source Object Type will not be accessible via other associations to the Target Object Type.

Action:

Change the 'Aggregation' property for the association role from Strong, to Weak.


ATT-05765

ATT-05765 Oracle Object Type/Object Table already implements this Object Type

Cause:

An Oracle Object Type/Object Table already implements this Object Type and therefore a Relational Table cannot be generated for it.

Action:

Remove the Oracle Object Type/Object Table previously generated for the Object Type. Select the Object Type and then choose 'Remove Server Model Mapping' from the Utilities menu.


ATT-05766

ATT-05766 Implementing object types must be persistent

Cause:

For an implementing object type to be valid it must be marked as persistent. This object type is not persistent, but has been marked as an implementing object type.

Action:

Set the persistent property of the implementing object, or make a super type of the object which is persistent the implementing object instead.


ATT-05767

ATT-05767 Inheritance branch does not contain an implementing object type

Cause:

Neither the object, or its sub-types are marked as implementing object types.

Action:

Set the implementing object type preference of the object to indicate that it should be an implementing object.


ATT-05768

ATT-05768 Super types of an implementing object type should not be instantiable

Cause:

One or more of the implementing object type's super types are marked as instantiable.

Action:

Make the super type of the implementing object non-instantiable, or make the super type itself the implementing object rather than the current object.


ATT-05769

ATT-05769 NOTM Preference must be defined against an Implementing Object Type

Cause:

The preference 'Generate Number of Times Modified Column' has been set on this Object Type but this is not an Implementing Object Type.

Action:

Unset the 'Generate Number of Times Modified Column' preference on this Object Type and set it on the Implementing Object Type(s).


ATT-05770

ATT-05770 Duplicate Uniqueness Constraint not generated

Cause:

This uniqueness constraint has the same components as another uniqueness constraint.

Action:

Remove or edit the uniqueness constraint to ensure that it is different. Also check to see if some components were invalid, making the remaining components the same as those in another constraint.


ATT-05772

ATT-05772 Composition of supertype '%s' not supported

Cause:

This target Object Type is strongly aggregated (i.e. a composition) to the source Object Type and it is also a supertype. As this is not supported, the Object Type Inclusion has been set to 'Reference'. If this is a 1:M relationship, the generated Collection Type will be a 'Collection of REFs'

Action:

Change the 'Aggregation' property of the association role from Strong, to Weak.


ATT-05773

ATT-05773 Object Table exists for Object Type at other end of association

Cause:

The Object Type at the other end of this association is mapped to an Object Table definition, so no Foreign Key Constraint can be created.

Action:

Remove the Object Table definition for the Object Type at the other end of this association. Select the Object Type and then choose 'Remove Server Model Mapping'.


ATT-05774

ATT-05774 Array type attributes cannot have a large datatype

Cause:

The 'Array' property for the type attribute is set to Yes but the attribute's Datatype is based on a Value Type that is a large object.

Action:

Either set the 'Array' property for the type attribute to No or change the Datatype to a value that is not based on a large object.


ATT-05777

ATT-05777 Multiple inheritance of Value Types not supported

Cause:

This Value Type, or one of its parents, inherits from more than one other Value Type. Multiple Inheritance is not supported.

Action:

Change the Value Type hierarchy, so that a Value Type inherits from only one other Value Type, i.e. remove multiple inheritance.


ATT-05778

ATT-05778 No Object Type created for the other end of the association

Cause:

The other end of this Association does not have an Object Type, so no Column could be created for the Association.

Action:

Either remove the Association, or ensure that the Association has an Object Type at the other end.


ATT-05779

ATT-05779 Precision cannot be specified for this Datatype

Cause:

The specified Datatype can have no precision.

Action:

Ensure that the 'Decimal Places' property for this Type Attribute or the Value Type being used is empty.


ATT-05780

ATT-05780 Cannot map the type of the parameter to an Oracle Object Type or Datatype

Cause:

The operation parameter type does not map to a base Datatype, a generated Domain or a generated Oracle Object Type.

Action:

Change the 'Type' property of the operation parameter to be a base Value Type, a Value Type that has a domain created for it, or an Object Type that has an Oracle Object Type generated for it.


ATT-05781

ATT-05781 Cannot map Return Type to an Oracle Object Type or a Datatype

Cause:

The Return Type of the operation does not map to a base Datatype, Domain or Oracle Object Type.

Action:

Change the 'Return Type' property of the operation to be a base Value Type, a Value Type that has a domain created for it, or an Oracle Type that has an Oracle Object Type generated for it.


ATT-05782

ATT-05782 Already mapped to Foreign Key %s; No Intersection Table can be generated

Cause:

This Association Role is already mapped to a Foreign Key Constraint in a Table, so no Intersection Table, or Foreign Key Constraints, can be generated for the Association Role.

Action:

Remove the Foreign Key Constraint that this Association Role is mapped to. Select the Association Role and choose 'Remove Server Model Mapping' from the Utilities menu.


ATT-05784

ATT-05784 Multiplicity upper limit must be 1 for composition associations

Cause:

The 'Aggregation' property of this association role is set to 'Strong' (i.e. a composition) but the Multiplicity upper limit is set to a value greater than one. Strong aggregation associations (compositions) can only be to a single object.

Action:

Either set the 'Aggregation' property to None or Weak, or set the 'Multiplicity Upper Bound' property to 1.


ATT-05785

ATT-05785 Could not generate complete Primary Key Constraint

Cause:

One or more Primary Key Components could not be created for this Primary Key. One reason for this may be because elements (e.g. Columns, Foreign Keys) were not generated for Type Constraint Components in the Uniqueness Constraint, from which this Primary Key Constraint was generated.

Action:

Examine the causes of why some constraint members were not generated and correct the data.


ATT-05786

ATT-05786 Could not generate complete Unique Key Constraint

Cause:

One or more Unique Key Components could not be created for this Unique Key. One reason for this may be because elements (e.g. Columns, Foreign Keys) were not generated for Type Constraint Components in the Uniqueness Constraint, from which this Unique Key Constraint was generated.

Action:

Try to create the Unique Key Components for the Unique Key Constraint manually.


ATT-05787

ATT-05787 Cannot create Foreign Key Columns due to missing/incomplete Primary Key

Cause:

Foreign Key Columns and Key Components could not be created because the corresponding Primary Key Constraint is missing or incomplete.

Action:

Try to make the Primary Key Constraint, that this Foreign Key Constraint references, complete.


ATT-05788

ATT-05788 There is an inconsistent mapping; the element will be ignored

Cause:

You have attempted to re-generate a server model (from a type model) but changes you have made to the type model, or preferences have caused an inconsistency with the existing server model.

Action:

Do one of the following: - Delete the relevant parts of the generated server model, by selecting the type model elements that have changed and then choosing 'Remove Server Model Mapping' from the Utilities menu. - Change the type model and/or preferences, back to their original settings.


ATT-05790

ATT-05790 Datatype %s is invalid

Cause:

The Datatype specified for this attribute is invalid so the attribute/column has not been created. The problem with the datatype will have been displayed in a previous message.

Action:

Either fix the problem with the Datatype, or use a different Datatype for the attribute.


ATT-05791

ATT-05791 The preference specifies 'VARRAY' but the association is unbounded

Cause:

This association is being implemented as an Oracle Collection Type and the database generation preference 'Collect Type Implementation' is set to 'VARRAY'. However, the maximum multiplicity of the matching association role is unbounded. This is used for the VARRAY limit and it must be set to a positive value.

Action:

Set the 'Collection Type Implementation' preference to 'NESTED TABLE' or define a maximum multiplicity for the matching association role.


ATT-06002

ATT-06002 Cannot find a mapping for key component '%s', component ignored

Cause:

The design capture process is attempting to create a constraint component from a column in the table's primary or unique key. It has failed because this column was not successfully mapped to a type attribute or an association role.

Action:

Check any previous messages relating to the column to see why the mapping was unsuccessful and then correct the problem.


CDA-00001

CDA-00001 Repository has not been initialized -- execute 'cdapi.initialize(<App Sys name>,<App Sys version>)'

Cause:

Before opening an activity and making operation calls, the API must be initialized within the database connection.

Action:

Execute 'cdapi.initialize[(application system name[,application system version])]' to initialize the API and establish a context application system.


CDA-00003

CDA-00003 API internal error in ciilok.get_new_range: Unable to allocate reference value range from CI_REFERENCE_RANGES

Cause:

All reference ranges are currently in use.

Action:

Issue a call to 'cdapi.initialize()' from another database connection to allocate more API reference ranges. This call causes an implicit commit and so, if the current API database connection is engaged in an activity, the call must be made from a database connection other than the current one. To avoid this in the future, increase the number of available ranges, or increase the range size.


CDA-00004

CDA-00004 API internal error in %0!s: Duplicate data found in SDD_ELEMENTS/SDD_STRUCTURE_ELEMENTS

Cause:

The Repository instance appears to have become corrupt. Duplicate elements have been detected.

Action:

Run a corruption detection utility on your Repository instance to determine which elements are in violation of uniqueness constraints.


CDA-00005

CDA-00005 API initialization error: SYS.DUAL table has multiple rows and should have only one

Cause:

More than one row was detected in the SYS.DUAL table.

Action:

Reset the SYS.DUAL table to have a single row, with value 'X' in its only column.


CDA-00006

CDA-00006 API initialization error: The API has already been initialized

Cause:

An attempt was made to run 'cdapi.initialize()' twice in a database connection.

Action:

'cdapi.initialize()' must be called only once in a database connection.


CDA-00007

CDA-00007 API message instantiation error: no message text found for %0!s-%1!s

Cause:

No message was found in the table 'RM$NLS_MESSAGES' for the given Facility and Code.

Action:

Make sure that this table was populated with data during API installation.


CDA-00008

CDA-00008 Lock failed. Record has been locked by another user.

Cause:

An exclusive database lock has been taken out on this record by another user or session.

Action:

Save outstanding work in other sessions and try again.


CDA-00009

CDA-00009 Could not lock the utility in exclusive mode

Cause:

A request was made to lock this utility in single user mode. The request has timed out because someone else is running this utility. Some of the utilities have to be run in exclusive single mode.

Action:

Try again later or see Enterprise Manager for who is running the utility. Restarting the database will remove all locks.


CDA-00010

CDA-00010 System error locking the utility in exclusive mode

Cause:

Lock failed.

Action:

This is an internal program error and should not normally be issued. Note any further information/messages etc. and refer to system/computer administrator before retrying. Restarting the database might help. If problem persists then refer to Oracle support.


CDA-00011

CDA-00011 Failed to lock Application System %0!s Version %1!s in exclusive mode.

Cause:

Lock failed.

Action:

This is an internal program error and should not normally be issued. Note any further information/messages etc. and refer to system/ computer administrator before retrying. Restarting the database may help. If the problem persists then refer to Oracle Support.


CDA-00012

CDA-00012 Unable to lock Application System %0!s Version %1!s in exclusive mode.

Cause:

A request was made to take an exclusive lock on this Application System. The request has timed out because another user is accessing the Application System or another session is already holding an exclusive lock on this Application System.

Action:

Try again later. If the problem persists use Enterprise Manager or ask your DBA to determine who is preventing you from obtaining an exclusive lock on this Application System. Ending the session holding the lock will remove the lock. Alternatively restarting the database will remove all locks.


CDA-00013

CDA-00013 System error releasing user defined lock. Lock ID %0!s

Cause:

The utility was unable to remove an exclusive lock on an Application System.

Action:

End your session to remove any outstanding Application Locks you may be holding. If the problem persists refer to your database administrator.


CDA-00102

CDA-00102 %0!s: Cannot delete -- %1!s of this %2!s exist

Cause:

The specified element cannot be deleted because it is referenced by elements that cannot be cascade deleted.

Action:

Drop the referenced elements, or dissociate them, before reissuing the specified operation.


CDA-00103

CDA-00103 %0!s: This synonym is defined against %1!s and cannot be updated

Cause:

Synonyms defined against entities cannot be updated or deleted directly.

Action:

Update the entity to change its Name, Plural or Short Name.


CDA-00104

CDA-00104 %0!s: This synonym is defined against %1!s and cannot be deleted

Cause:

Synonyms defined against entities cannot be updated or deleted directly.

Action:

Update the entity to change its Name, Plural or Short Name.


CDA-00105

CDA-00105 %0!s '%1!s': An attempt was made to provide a value for an ineligible property of this Copy function

Cause:

Copy functions are limited to holding basic information only, relying on the Master function to hold the detailed information about the function. Valid properties in a Copy function are its Short Definition, Sequence In Parent, Parent Reference, Common Function Reference and Function Label.

Action:

Resubmit the operation, but withhold values for all but the restricted list of properties.


CDA-00500

CDA-00500 %0!s: Invalid format type <%1!s>

Cause:

The specified format type is not valid.

Action:

Refer to the format type rules in the Oracle Designer Meta-model and API documentation.


CDA-00501

CDA-00501 %0!s: Unusual format type <%1!s>

Cause:

The specified format type is considered unusual, though it is valid.

Action:

No action need be taken. This is an informational message only.


CDA-00502

CDA-00502 %0!s: Maximum Length must be provided for this format type <%1!s>

Cause:

The specified format type requires a Maximum Length.

Action:

Update the specified element, providing a Maximum Length value.


CDA-00503

CDA-00503 %0!s: Length is invalid for this format type <%1!s> -- it has been reset to null

Cause:

The specified format type cannot be length constrained.

Action:

The system automatically nullified the length constraint. No action need be taken by the user.


CDA-00504

CDA-00504 %0!s: Maximum Length is not meaningful for this format type <%1!s>

Cause:

The specified format type cannot be length constrained.

Action:

Refer to the format type rules in the Oracle Designer Meta-model and API documentation.


CDA-00505

CDA-00505 %0!s: Maximum Length <%1!s> is larger than the allowed limit for this format type <%2!s>

Cause:

The supplied Maximum Length exceeds the limit for this format type.

Action:

Refer to the format type rules in the Oracle Designer Meta-model and API documentation.


CDA-00506

CDA-00506 %0!s: Maximum Length must be at least 1 for this format type <%1!s>

Cause:

The Maximum Length for this format type must have a positive integer value.

Action:

Refer to the format type rules in the Oracle Designer Meta-model and API documentation.


CDA-00507

CDA-00507 %0!s: Precision is mandatory for this format type <%1!s>

Cause:

The specified format type must be constrained by a Precision.

Action:

Update the specified element, providing a Precision value with this format type.


CDA-00508

CDA-00508 %0!s: Precision cannot be specified for this format type <%1!s> -- it has been reset to null

Cause:

The specified format type can have no Precision.

Action:

The system automatically nullified the Precision property value. No action need be taken by the user.


CDA-00510

CDA-00510 %0!s: Precision is out of range for this format <%1!s>

Cause:

The Precision value must be within the range specified by the Oracle SQL language documentation.

Action:

Refer to the format type rules in the Oracle SQL language documentation.


CDA-00511

CDA-00511 %0!s: %1!s must not contain whitespace characters

Cause:

Use of blank spaces is not allowed in this property.

Action:

Use underscores instead of spaces in the property.


CDA-00512

CDA-00512 %0!s: Datatype, Maximum Length and Scale are inconsistent with the specified Denormalized Summary Function

Cause:

When the Denormalized Summary Function is 'COUNT', Datatype must be numeric, Maximum Length must be greater than or equal to 5, and Scale must be 0.

Action:

Make the element values consistent.


CDA-00513

CDA-00513 %0!s: The Datatype of this column (%1!s) is not consistent with the Datatype of its denormalized column (%2!s)

Cause:

Datatype values of denormalized columns must be consistent according to the specified Denormalized Summary Function.

Action:

Refer to the format type rules in the Oracle Designer Meta-model and API documentation.


CDA-00514

CDA-00514 %0!s: Maximum Length must not be specified when the Datatype is 'DATE'

Cause:

When an item is specified as being of the Datatype 'DATE' the MAXIMUM_ LENGTH property must be null.

Action:

If Datatype is 'DATE' ensure that the MAXIMUM_LENGTH property is not given a value.


CDA-00700

CDA-00700 %0!s: Too many references provided

Cause:

Too many reference values were provided in an arc relationship.

Action:

Provide a reference for only one relationship in the arc.


CDA-00701

CDA-00701 %0!s: Event is maintained internally and cannot be updated

Cause:

An attempt was made to update an Event that is maintained internally by the system.

Action:

This operation was automatically rolled back. No action need be taken by the user. This is an informational message only.


CDA-00702

CDA-00702 %0!s: Mismatch between %1!s referenced by the two ends of this relationship or association

Cause:

The specified relationship end or association role does not match the one at the other end. Either the two ends do not reference the same entities or object types consistently, or they do not reference each other.

Action:

Delete both relationship ends or association roles and re-create them.


CDA-00703

CDA-00703 Cannot delete application systems through CDAPI; use the Repository Object Navigator

Cause:

An attempt was made to delete an application system version through the API. This operation must be performed through the Repository Object Navigator.

Action:

Use the Repository Object Navigator to drop a version of an application system.


CDA-00704

CDA-00704 %0!s: Maximum Sequence In Parent number (999) reached during auto-generation -- using a non-maximum value

Cause:

When generating a value for Sequence In Parent, the maximum value (999) was reached. A non-maximum value was used instead.

Action:

No action need be taken. This is an informational message only.


CDA-00705

CDA-00705 %0!s: Maximum number of root functions (999) has been exceeded -- cannot create

Cause:

The limit on the number of root functions has been exceeded in the context application system.

Action:

Either delete a root function in the context application system, or make one subordinate to another function.


CDA-00810

CDA-00810 Invalid Text Type '%0!s'

Cause:

An invalid Text Type was typed.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-00811

CDA-00811 Text Type '%0!s' already exists

Cause:

This text type already exists - it cannot be assigned to a new Text Type.

Action:

Choose another value for Text Type.


CDA-00812

CDA-00812 Unknown Text Type '%0!s'

Cause:

An unknown Text Type was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-00813

CDA-00813 Operation denied: Text Type '%0!s' is not a user-extended text type

Cause:

The Text Type value supplied was not a user-extended text type.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-00814

CDA-00814 Operation denied: Text Type '%0!s' is published

Cause:

The Text Type value supplied is a published text type.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-00815

CDA-00815 Operation denied: Text Type '%0!s' is not published

Cause:

The Text Type value supplied is an unpublished text type.

Action:

None - text type is already unpublished.


CDA-00816

CDA-00816 Usages exists for Text Type %0!s - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended text type with no text usages.

Action:

Ensure that this text type is not used by any element types before unpublishing.


CDA-00820

CDA-00820 Text Type '%0!s' for the text usage does not exist

Cause:

The Text Type specified for the text usage does not exist.

Action:

Refer to the list of valid values specified for the property in the documentation.


CDA-00821

CDA-00821 The Element Type ID %0!s specified for the text usage does not exist

Cause:

The Element Type ID specified for the text usage does not exist.

Action:

Refer to the list of valid values specified for the property in the documentation.


CDA-00822

CDA-00822 Text usage already exists: Text Type = '%0!s', Element Type ID = '%1!s'

Cause:

The text usage identified by the specified Text Type and Element Type ID already exists.

Action:

Specify a combination of values to identify a new text usage.


CDA-00823

CDA-00823 Unknown text type usage: Text Type = '%0!s', Element Type ID = %1!s

Cause:

The specified Text Type and Element Type ID do not identify a known text usage.

Action:

Specify a combination of values to identify a known text usage.


CDA-00824

CDA-00824 Operation denied: Not an extended Text Type usage

Cause:

The specified usage is not an extended Text Type usage.

Action:

Specify an extended Text Type usage.


CDA-00825

CDA-00825 Operation denied: Text Type usage is published

Cause:

The operation was called with the ID of a user-defined element type which is published, and this operation requires that the element type is not published.

Action:

Specify the ID of an unpublished user-defined element type or unpublish this element type.


CDA-00826

CDA-00826 Text Type '%0!s' is not published

Cause:

The operation was called with the ID of a user-defined element type which is not published, and this operation requires that the element type is published.

Action:

Specify the ID of a published user-defined element type or publish this element type.


CDA-00827

CDA-00827 Operation denied: Text Type usage is not published - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a published user extended text usage.

Action:

None - this text type usage is already unpublished.


CDA-00828

CDA-00828 Instances of Text Usage '%0!s' currently exist - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended text usage with no instances.

Action:

Delete the instances of this text usage before unpublishing.


CDA-00830

CDA-00830 Invalid Extended Element Short Name '%0!s' (should be E1 through E499)

Cause:

SHORT_NAME is mandatory and must begin with E and be followed by a number between 1 an 499.

Action:

Pick a SHORT_NAME that follows the above rule.


CDA-00831

CDA-00831 Short Name must be specified for an Extended Element Type

Cause:

SHORT_NAME is mandatory and has not been specified.

Action:

Specify SHORT_NAME.


CDA-00832

CDA-00832 An Element Type with Short Name '%0!s' already exists

Cause:

SHORT_NAME must be unique across the Repository.

Action:

Specify a unique SHORT_NAME.


CDA-00833

CDA-00833 Name must be specified for an Extended Element Type

Cause:

NAME is mandatory and has not been specified.

Action:

Specify NAME.


CDA-00834

CDA-00834 An Element Type with Name '%0!s' already exists

Cause:

NAME must be unique across the Repository.

Action:

Specify a unique NAME.


CDA-00835

CDA-00835 Plural Name must be specified for an Extended Element Type

Cause:

PLURAL_NAME is mandatory and has not been specified.

Action:

Specify PLURAL_NAME.


CDA-00838

CDA-00838 Element Type '%0!s' is not a user-extendible type

Cause:

The operation was called with the ID of an element type which is not user-defined.

Action:

Specify the ID of a user-defined element type (eg E64).


CDA-00839

CDA-00839 Element Type '%0!s' is published

Cause:

The operation was called with the ID of a user-defined element type which is published, and this operation requires that the element type is not published.

Action:

Specify the ID of an unpublished user-defined element type or unpublish this element type.


CDA-00840

CDA-00840 Invalid Extended Association Short Name '%0!s' (should be A1 through A499)

Cause:

SHORT_NAME is mandatory and must begin with A and be followed by a number between 1 an 499.

Action:

Pick a SHORT_NAME that follows the above rule.


CDA-00841

CDA-00841 Short Name must be specified for an Extended Association Type

Cause:

SHORT_NAME is mandatory and has not been specified.

Action:

Specify SHORT_NAME.


CDA-00842

CDA-00842 An Association Type with Short Name '%0!s' already exists

Cause:

SHORT_NAME must be unique across the Repository.

Action:

Specify a unique SHORT_NAME.


CDA-00843

CDA-00843 Name must be specified for an Extended Association Type

Cause:

NAME is mandatory and has not been specified.

Action:

Specify NAME.


CDA-00844

CDA-00844 An Association Type with Name '%0!s' already exists

Cause:

NAME must be unique across the Repository.

Action:

Specify a unique NAME.


CDA-00845

CDA-00845 Plural Name must be specified for an Extended Association Type

Cause:

PLURAL_NAME is mandatory and has not been specified.

Action:

Specify PLURAL_NAME.


CDA-00846

CDA-00846 An Association Type with Plural Name '%0!s' already exists

Cause:

PLURAL_NAME must be unique across the Repository.

Action:

Specify a unique PLURAL_NAME.


CDA-00847

CDA-00847 Association Type %0!s does not exist

Cause:

The operation was called with the ID of an unknown (or non-existent) association type.

Action:

Specify the ID of a user-defined association type (not instance).


CDA-00848

CDA-00848 Association Type '%0!s' is not a user-extendible type

Cause:

The operation was called with the ID of an association type which is not user-defined.

Action:

Specify the ID of a user-defined association type (eg A64).


CDA-00849

CDA-00849 Association Type '%0!s' is published

Cause:

The operation was called with the ID of a user-defined association type which is published, and this operation requires that the association type is not published.

Action:

Specify the ID of an unpublished user-defined association type or unpublish this association type.


CDA-00850

CDA-00850 Invalid Part Of reference %0!s

Cause:

PART_OF_REFERENCE must refer to a Primary Access Control element type or one of a limited number of Secondary Access Control element types.

Action:

Refer to the Repository Administration Utility 'Maintain User Extensions' section for the full list of valid PART_OF element types.


CDA-00851

CDA-00851 Invalid Part Of Degree '%0!s' (should be NULL, '1' or 'M')

Cause:

PART_OF_DEGREE has valid values NULL, '1' or 'M'.

Action:

Set one of the valid values.


CDA-00852

CDA-00852 Invalid Use Of reference %0!s

Cause:

USE_OF_REFERENCE must refer to a Primary Access Control element type or one of a limited number of Secondary Access Control element types.

Action:

Refer to the Repository Administration Utility 'Maintain User Extensions' section for the full list of valid USE_OF element types.


CDA-00853

CDA-00853 Invalid Use Of Degree '%0!s' (should be NULL, '1', or 'M')

Cause:

USE_OF_DEGREE has valid values NULL, '1' or 'M'.

Action:

Set one of the valid values.


CDA-00854

CDA-00854 Data exists for Association Type %0!s - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended association type with no instance data.

Action:

Delete all instance data of this association type before unpublishing.


CDA-00855

CDA-00855 Text Type %0!s refers to Association Type %1!s - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended association type with no text usages.

Action:

Delete (or unpublish?) all text usages of this element type unpublishing.


CDA-00856

CDA-00856 Association Type '%0!s' is not published - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a published user extended association type.

Action:

None - this element type is already unpublished.


CDA-00857

CDA-00857 Association Type '%0!s' is not a User Type - Cannot remap

Cause:

Can only carry out a remap operation on a User Defined Association Type, not a System Association Type.

Action:

Remap another Association Type.


CDA-00860

CDA-00860 Specified property '%0!s' does not exist

Cause:

The operation was called with the ID of an unknown (or non-existent) property.

Action:

Specify the ID of a user-defined property.


CDA-00861

CDA-00861 Property '%0!s' is not a user-extendible property

Cause:

The operation was called with the ID of a property which is not user-defined.

Action:

Specify the ID of a user-defined property (eg USER_DEFINED_PROPERTY_1).


CDA-00862

CDA-00862 Property '%0!s' is published

Cause:

The operation was called with the ID of a user-defined property which is published, and this operation requires that the property is not published.

Action:

Specify the ID of an unpublished user-defined property or unpublish this property.


CDA-00863

CDA-00863 Property Displayed Name must be specified

Cause:

DISPLAY_NAME is mandatory and has not been specified.

Action:

Specify DISPLAY_NAME.


CDA-00864

CDA-00864 Unknown Datatype '%1!s' for property '%0!s'

Cause:

DISPLAY_DATATYPE must be either 'CHAR','NUMBER' or 'DATE'

Action:

Set a valid value for DISPLAY_DATATYPE.


CDA-00865

CDA-00865 Invalid Length '%2!s' specified for property '%0!s' Datatype '%1!s'

Cause:

DISPLAY_LENGTH must be set and be between 0 and 240 inclusive.

Action:

Set a valid value for DISPLAY_LENGTH.


CDA-00866

CDA-00866 Invalid Precision '%2!s' specified for property '%0!s' Datatype '%1!s'

Cause:

DISPLAY_PRECISION must not be set for CHAR and DATE datatypes and for NUMBER datatypes may be null or between 1 and 38.

Action:

Set a valid value for DISPLAY_PRECISION.


CDA-00867

CDA-00867 Invalid Scale '%2!s' specified for property '%0!s' Datatype '%1!s'

Cause:

DISPLAY_SCALE must not be set for CHAR and DATE datatypes and for NUMBER datatypes may be null or between 0 and DISPLAY_PRECISION.

Action:

Set a valid value for DISPLAY_SCALE.


CDA-00868

CDA-00868 Invalid Mandatory flag '%0!s'; expected 'Y' or 'N'

Cause:

IS_MANDATORY must be 'Y' or 'N'.

Action:

Set a valid value for IS_MANDATORY.


CDA-00869

CDA-00869 Data exists for Property %0!s - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended property, when all the instance data is null.

Action:

Nullify all instance data of this Property before unpublishing.


CDA-00870

CDA-00870 Data exists for Element Type %0!s - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended element type with no instance data.

Action:

Delete all instance data of this element type before unpublishing.


CDA-00871

CDA-00871 Association Type %0!s refers to Element Type %1!s - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended element type with no associations.

Action:

Delete (or unpublish?) this association before unpublishing.


CDA-00872

CDA-00872 Text Type %0!s refers to Element Type %1!s - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a user extended element type with no text usages.

Action:

Delete (or unpublish?) all text usages of this element type before unpublishing.


CDA-00873

CDA-00873 Element Type '%0!s' is not published - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a published user extended element type.

Action:

None - this element type is already unpublished.


CDA-00874

CDA-00874 Property '%0!s' is not published - Cannot unpublish

Cause:

Can only carry out an unpublish operation on a published user extended property.

Action:

None - this property is already unpublished.


CDA-00875

CDA-00875 Element Type '%0!s' is not a User Type - Cannot remap

Cause:

Can only carry out a remap operation on a User Defined Element Type, not a System Element Type.

Action:

Remap another Element Type.


CDA-00876

CDA-00876 Property '%0!s' is not extended - Cannot be source of a remap

Cause:

Can only carry out a remap operation from a user extended Property.

Action:

Remap from another Property.


CDA-00902

CDA-00902 Unknown association type ID %0!s

Cause:

The operation was called with the ID of an unknown (or non-existent) association type.

Action:

Specify the ID of a user-defined association type (not instance).


CDA-00903

CDA-00903 Internal error: Association type %0!s missing from CIUE_ASSOCIATION_TYPES

Cause:

Internal error - should not occur

Action:

Contact Oracle support


CDA-00904

CDA-00904 PART OF end of association wrong: Expected type '%0!s', found type '%1!s'

Cause:

The element type at the end of the PART_OF_REFERENCE property is of the wrong element type.

Action:

Set PART_OF_REFERENCE to refer to an element of the expected element type.


CDA-00905

CDA-00905 PART OF end of association wrong: Element %0!s does not exist

Cause:

No element exists with the ID specified in PART_OF_REFERENCE.

Action:

Set PART_OF_REFERENCE to refer to an element of the expected element type.


CDA-00906

CDA-00906 USE OF end of association wrong: Expected type '%0!s', found type '%1!s'

Cause:

The element type at the end of the USE_OF_REFERENCE property is of the wrong element type.

Action:

Set USE_OF_REFERENCE to refer to an element of the expected element type.


CDA-00907

CDA-00907 USE OF end of association wrong: Element %0!s does not exist

Cause:

No element exists with the ID specified in USE_OF_REFERENCE.

Action:

Set USE_OF_REFERENCE to refer to an element of the expected element type.


CDA-00908

CDA-00908 Equivalent association between specified %0!s and %1!s already exists

Cause:

An association of this type already exists between these two elements.

Action:

Change PART_OF_REFERENCE, USE_OF_REFERENCE or the association type.


CDA-00909

CDA-00909 An PART OF association already exists to the specified '%0!s'

Cause:

The PART OF end of this association is defined as being 'one and only one' (ie. it has PART_OF_DEGREE = 1), and an association of this type already exists to the element referred to in PART_OF_REFERENCE.

Action:

Change the PART_OF_REFERENCE to refer to another element of the same type or modify the definition of this user-defined association.


CDA-00910

CDA-00910 A USE OF association already exists to the specified '%0!s'

Cause:

The USE OF end of this association is defined as being 'one and only one' (ie. it has USE_OF_DEGREE = 1), and an association of this type already exists to the element referred to in USE_OF_REFERENCE.

Action:

Change the USE_OF_REFERENCE to refer to another element of the same type or modify the definition of this user-defined association.


CDA-00921

CDA-00921 Property '%0!s' cannot be set because it is not published

Cause:

The user-defined property specified has not been published so may not be updated or inserted.

Action:

Publish the property in the Repository Administration Utility.


CDA-00922

CDA-00922 Property '%0!s' is not updateable

Cause:

The user-defined property specified has been defined as 'not updateable'.

Action:

Alter the property definition in the Repository Administration Utility.


CDA-00924

CDA-00924 Property '%0!s' length %1!s is longer than maximum allowed (%2!s)

Cause:

The user-defined property specified has a maximum length specified that is smaller than the data value being set.

Action:

Set a shorter value for this property or alter the property definition in the Repository Administration Utility.


CDA-00925

CDA-00925 Invalid date value '%1!s' specified for property '%0!s'

Cause:

The internal DATE format is 'YYYYMMDDHHMISS', and the value does not confirm to this.

Action:

Set a DATE value that confirms to this rule.


CDA-00926

CDA-00926 Invalid number '%1!s' specified for property '%0!s'

Cause:

The value specified is not a valid number.

Action:

Set a valid number.


CDA-00927

CDA-00927 Number '%1!s' value for property '%0!s' is too big (-%2!s < value < %2!s)

Cause:

The value specified is too large for the precision and scale defined for this property.

Action:

Set a smaller value for this property or alter the property definition in the Repository Administration Utility.


CDA-01000

CDA-01000 %0!s: Average Length (%1!s) is greater than Maximum Length (%2!s)

Cause:

The Average Length must be less than or equal to the Maximum Length.

Action:

Update the element and provide consistent Average Length and Maximum Length values.


CDA-01001

CDA-01001 %0!s: The Start Value (%1!s) must be between Minimum Value (%2!s) and Maximum Value (%3!s)

Cause:

The Start Value is outside the range implied by the Minimum Value and Maximum Value.

Action:

Specify a Start Value that is consistent with the Minimum Value and Maximum Value.


CDA-01002

CDA-01002 %0!s: Initial Transaction (%1!s) exceeds Maximum Transaction (%2!s)

Cause:

The Initial Transaction must be less than or equal to the Maximum Transaction.

Action:

Update the element and provide consistent Initial Transaction and Maximum Transaction values.


CDA-01003

CDA-01003 %0s : Name %1s is not a valid ORACLE object name.

Cause:

The rules for naming are as follows: 1) Object name must begin with an alphabetical character (A-Z). 2) Object name can only contain characters: A-Z, 0-9, $, # and _. 3) Enclose name in double quotes to include other characters. 4) Object Name cannot be that of an ORACLE reserved word except in the case of Database Roles where the following reserved words are allowed; CONNECT, DBA, RESOURCE and PUBLIC.

Action:

Ensure ORACLE object name does not include any illegal characters or formatting.


CDA-01004

CDA-01004 %0!s: Average Attribute Length (%1!s) is greater than Maximum Attribute Length (%2!s)

Cause:

The Average Attribute Length must be less than or equal to the Maximum Attribute Length.

Action:

Update the element and provide consistent Average Attribute Length and Maximum Attribute Length values.


CDA-01005

CDA-01005 %0!s: Average Column Length (%1!s) is greater than Maximum Column Length (%2!s)

Cause:

The Average Column Length must be less than or equal to the Maximum Column Length.

Action:

Update the element and provide consistent Average Column Length and Maximum Column Length values.


CDA-01006

CDA-01006 %0!s: Super-type %1!s is itself a sub-type of a domain

Cause:

An invalid loop was found in a domain hierarchy. A domain cannot be an ancestor of one of its descendants.

Action:

Reset one of the super-type references to remove the inconsistency.


CDA-01007

CDA-01007 %0!s: Initial Volume (%1!s) exceeds Maximum Volume (%2!s)

Cause:

The Initial Volume must be less than or equal to the Maximum Volume.

Action:

Update the element and provide consistent Initial Volume and Maximum Volume values.


CDA-01008

CDA-01008 %0!s: Average Volume (%1!s) exceeds Maximum Volume (%2!s)

Cause:

The Average Volume must be less than or equal to the Maximum Volume.

Action:

Update the element and provide consistent Average Volume and Maximum Volume values.


CDA-01009

CDA-01009 Attribute Value for %0!s: Low Value (%1!s) exceeds High Value (%2!s)

Cause:

The Low Value must be less than or equal to the High Value.

Action:

Update the element and provide consistent Low Value and High Value values.


CDA-01010

CDA-01010 %0!s: Specified super-type %1!s must be owned by the context application system

Cause:

In order to specify a super-type for an element, both the element and its super-type must be owned by the context application system.

Action:

Change the context application system or connect the specified element to the current context application system.


CDA-01011

CDA-01011 %0!s: Referenced %1!s is not part of %2!s

Cause:

An attempt was made to include an Attribute in a Unique Identifier Entry that is not part of the Entity against which the Unique Identifier is specified.

Action:

Include only those Attributes and Relationships that are specified against the Entity that is constrained by the Unique Identifier Entry.


CDA-01012

CDA-01012 %0!s: Referenced %1!s is not connected to %2!s

Cause:

An attempt was made to include a Relationship End in a Unique Identifier Entry that is not part of the Entity against which the Unique Identifier is specified.

Action:

Include only those Attributes and Relationships that are specified against the Entity that is constrained by the Unique Identifier Entry.


CDA-01013

CDA-01013 %0!s: %1!s is not of 'ONE AND ONLY ONE' Degree

Cause:

Relationships in a Unique Identifier should generally be of Degree ONE AND ONLY ONE. This message is simply to alert the user of a possible modeling error.

Action:

It is recommended that the Relationship be updated to be of Degree ONE AND ONLY ONE, though violation of this rule will not prevent an activity from being closed successfully.


CDA-01014

CDA-01014 %0!s: Cannot change the From Relationship End Reference when the relationship end is part of a UID

Cause:

A Relationship End that is part of a Unique Identifier Entry for an Entity cannot be transferred to another Entity.

Action:

Remove the Relationship End from the Unique Identifier of the entity.


CDA-01015

CDA-01015 %0!s: Cannot change the From Relationship End Reference when the relationship end is in an arc

Cause:

A relationship end that is part of an arc cannot be transferred to another entity without removing it from the arc.

Action:

Nullify the Arc Number property on the relationship end when transferring the relationship.


CDA-01016

CDA-01016 %0!s: Minimum Value (%1!s) exceeds Maximum Value (%2!s)

Cause:

The Minimum Value must be less than or equal to the Maximum Value.

Action:

Update the specified element and provide consistent Minimum Value and Maximum Value values.


CDA-01017

CDA-01017 %0!s: Minimum Volume (%1!s) exceeds Maximum Volume (%2!s)

Cause:

The Minimum Volume must be less than or equal to the Maximum Volume.

Action:

Update the specified element and provide consistent Minimum Volume and Maximum Volume values.


CDA-01018

CDA-01018 %0!s: Average Volume (%1!s) exceeds Maximum Volume (%2!s)

Cause:

The Average Volume must be less than or equal to the Maximum Volume.

Action:

Update the specified element and provide consistent Average Volume and Maximum Volume values.


CDA-01019

CDA-01019 Function Attribute Usage: mismatch in usage flags between %0!s and %1!s for %2!s

Cause:

A mismatch has been detected between the usage flags in a Function Attribute Usage element and the corresponding Function Entity Usage element.

Action:

Refer to the documentation for rules regarding usage flags.


CDA-01020

CDA-01020 %0!s: An Entity Reference must be supplied for CHANGE events

Cause:

When CHANGE events are performed, they must be performed on entities.

Action:

Provide an Entity Reference when specifying an event of type CHANGE.


CDA-01021

CDA-01021 Event trigger for %0!s and %1!s: Either an Event triggers a Function or a Function triggers an Event

Cause:

If the triggering reference is a function, the triggered reference must be an event. If the triggering reference is an event, the triggered reference must be a function.

Action:

Provide an Event Reference and a Function Reference.


CDA-01022

CDA-01022 %0!s: A domain cannot be its own super-type

Cause:

A Supertype Reference specified against a domain appears already to be a sub-type of that domain; this violates the hierarchy.

Action:

Reset the Supertype Reference property either of the super-type or of the sub-type, to avoid the violation.


CDA-01023

CDA-01023 %0!s: Minimum Extents (%1!s) exceeds Maximum Extents (%2!s)

Cause:

The Minimum Extents must be less than or equal to the Maximum Extents for storage parameter definitions.

Action:

Enter consistent values for Minimum Extents and Maximum Extents.


CDA-01024

CDA-01024 %0!s: %1!s is already a child of %2!s. It may only be in one TYPE BODY

Cause:

A PLSQL Module that is a child of a TYPE BODY PLSQL Module is specific to that Type Body and it is not be possible to reuse it elsewhere (ie via a Module Network, as a child of another Type Body or of a Procedure etc).

Action:

Do not associate this PLSQL Module with this TYPE BODY PLSQL Module.


CDA-01025

CDA-01025 %0!s: %1!s already exists for %2!s. Only one TYPE BODY is permitted

Cause:

Only one TYPE BODY PL/SQL Module is permitted for an Oracle Object Type, and one exists for this Oracle Object Type already.

Action:

Delete the other TYPE BODY PL/SQL Module, or choose a different value for PLSQL_MODULE_TYPE.


CDA-01026

CDA-01026 %0!s: Maximum length of Journal table names is 27 characters

Cause:

The name of a journal table, for logging the activities on a table, must not exceed 27 characters in length.

Action:

Shorten the table name to 27 characters.


CDA-01027

CDA-01027 %0!s: Sum of Percent Free and Percent Used exceeds 100

Cause:

The parameters PCTFREE and PCTUSED sum to over 100.

Action:

Enter consistent values for the PCTFREE and PCTUSED parameters.


CDA-01028

CDA-01028 %0!s: Referenced %1!s is not connected to the context application system

Cause:

The element referred must be connected to the context application system.

Action:

Either share the referenced element into the context application system or specify a reference to another element. element.


CDA-01030

CDA-01030 An implementation for this database object already exists in the schema

Cause:

Each schema may contain only one implementation for each database object. The schema you are attempting to copy to already contains an implementation for the database object implemented by the item you are copying.

Action:

Either delete the database object implementation that is already present in the schema, or use a different schema for the implementation you are attempting to copy.


CDA-01032

CDA-01032 %0!s: Table has more than 12 triggers with create status = 'Y'

Cause:

For Versions 7.0.X of the Oracle database, there can be only one database trigger of a particular execute time, event and trigger level per table. The maximum possible number of triggers is therefore 2x3x2 = 12. Versions 7.1.X have no such constraint.

Action:

Warning only: No action must be taken


CDA-01033

CDA-01033 %0!s: Trigger of this event, level and execute time already exists

Cause:

Versions 7.0.X of the Oracle database cannot implement more than one database trigger of a particular execution time, event and trigger level per table; e.g. only one PRE-INSERT ROW level trigger per table. Versions 7.1.X can cope with more than one, but the order in which the database triggers are fired is indeterminate.

Action:

Warning only: No action must be taken


CDA-01035

CDA-01035 %0!s: Invalid Trigger EXECUTION_TIME (%1!s)

Cause:

An invalid EXECUTION_TIME has been chosen for this trigger.

Action:

For details of valid values for EXECUTION_TIMEs and contexts see the Oracle Designer Model, which you can access from the Designer Start Here icon.


CDA-01036

CDA-01036 %0!s: Invalid Trigger TRIGGER_LEVEL (%1!s)

Cause:

An invalid TRIGGER_LEVEL has been chosen for this trigger.

Action:

For details of valid TIGGER_LEVELs and their contexts, see the Oracle Designer Model, which you can access from the Designer Start Here icon.


CDA-01038

CDA-01038 %0s : %1s cannot not be inserted, base table usage already exists.

Cause:

A table usage already exists for this module component with the usage type of Base.

Action:

If this is a table usage of another usage type other than Base, ensure the correct type is selected in the properties palette.


CDA-01040

CDA-01040 %0!s: PL/SQL Module defined as Trigger from %1!s must have type of Trg-Logic

Cause:

The PL/SQL Module was defined as a Trigger from a Table and must have type of Trg-Logic.

Action:

Keep the type value as Trg-Logic.


CDA-01042

CDA-01042 %0!s: PL/SQL definition referenced from Trigger. Cannot change type.

Cause:

This definition is referenced by a trigger and therefore the type of module can only be of Trg-Logic.

Action:

Ensure type is kept as Trg-Logic.


CDA-01043

CDA-01043 %0!s: Sum of PERCENT_FREE and PERCENT_USED exceeds 100

Cause:

The algorithm used is: (nvl(PERCENT_FREE,10) + nvl(PERCENT_USED,40)) <= 100

Action:

Set PERCENT_FREE and PERCENT_USED so that the above rule is fulfilled.


CDA-01049

CDA-01049 %0!s: Invalid Function Return type (%1!s)

Cause:

The DATATYPE of the return value has been set to one which is not valid.

Action:

For details on valid DATATYPES, see the Oracle Designer Model, which you can access from the Designer Start Here icon.


CDA-01051

CDA-01051 %0!s: Generators may truncate this title to 15 characters

Cause:

The SHORT_NAME property value exceeds 15 characters and this may be truncated to 15 characters when generated.

Action:

Warning only: no action need be taken.


CDA-01056

CDA-01056 %0!s: Only Tables, Views and Snapshots can have constraints

Cause:

Attempting to attach a primary, unique or foreign key or check constraint to a Record. Only Tables, Views and Snapshots can have such constraints.

Action:

Ensure that the Record does not have any constraints attached.


CDA-01057

CDA-01057 %0!s: Specified Exception Table does not exist

Cause:

The Exception Table specified does not exist within the context of this application.

Action:

This is a Warning Message so no action is needed.


CDA-01058

CDA-01058 %0!s: Trigger can only reference PL/SQL definition of type Trg-Logic.

Cause:

A trigger can only reference a PL/SQL definition that as been created with type value of Trg-Logic.

Action:

Either choose to reference a PL/SQL definition of type Trg-Logic or leave PL/SQL definition field blank and a new one will be created automatically.


CDA-01059

CDA-01059 %0!s: A primary key constraint already exists for this table

Cause:

A table can have only one primary key constraint.

Action:

Delete or update the existing primary key constraint, or add a unique key constraint.


CDA-01061

CDA-01061 %0!s: Arc cannot be mandatory if an arc number is not specified

Cause:

It is not meaningful to specify that the constraint is in a mandatory arc, if the arc number is not set.

Action:

Specify the ARC_NUMBER or set the ARC_MANDATORY property to 'N'.


CDA-01062

CDA-01062 %0!s: Constraints implemented on the server cannot perform this deletion

Cause:

Constraints implemented on the server can either cascade on delete or restrict delete.

Action:

Specify either that the constraint is implemented on the client only, or that deletes are either cascaded or restricted.


CDA-01063

CDA-01063 %0!s: Constraints implemented on the server cannot perform this update

Cause:

Constraints implemented on the server prohibit the update of the source column. Any other action can be performed by client-side code only.

Action:

Specify either that the constraint is implemented on the client only, or that updates are restricted.


CDA-01064

CDA-01064 %0!s: Only Tables, Views and Snapshots can be referenced

Cause:

Only Tables, Views and Snapshots can be referenced by the Foreign Table reference.

Action:

Ensure that any Foreign Key references are not made to objects other than Tables, Views or Snapshots.


CDA-01068

CDA-01068 %0!s: A primary key and a unique key have been defined the same

Cause:

No unique constraint can have the same key components as the primary key.

Action:

Change the key components of one of the keys.


CDA-01071

CDA-01071 %0!s: Column must be in the same table as the constraint

Cause:

The specified Column does not exist in the same Table as the constraint.

Action:

Ensure that a Column usage is within the same Table as the constraint usage.


CDA-01072

CDA-01072 %0!s: Null Columns in a mandatory Key

Cause:

Only mandatory (NOT NULL) Columns should appear in Unique Constraints or Foreign Key Constraints, when MANDATORY_FLAG = 'Y'.

Action:

Make this Column mandatory or do not make it part of the Primary Key for this Table.


CDA-01073

CDA-01073 %0!s: Join column (FOREIGN_COLUMN_REFERENCE) does not exist in the join table

Cause:

FOREIGN_COLUMN_REFERENCE must refer to a Column in the same Table that the Constraint joins to.

Action:

Choose a Column that is in the same Table that the Constraint joins to.


CDA-01074

CDA-01074 %0!s: Join column is not part of the primary key

Cause:

The join column should be part of the primary key for its table.

Action:

Modify the key for the join table, or choose another column.


CDA-01075

CDA-01075 %0!s: Column is defined as NOT NULL but appears in an arc

Cause:

Columns that appear in arcs should allow NULLs.

Action:

Ensure the Mandatory property for this column is not checked i.e. that it can contain a NULL value.


CDA-01076

CDA-01076 %0!s: Column is defined as NOT NULL but cascade rule nullifies

Cause:

The cascade delete or update rule for this constraint is to nullify the foreign key, but this key contains a NOT NULL column.

Action:

Change the key components or change the cascade delete or cascade update rule.


CDA-01077

CDA-01077 %0!s: Column and join column do not have identical descriptions

Cause:

The Datatype, Average Length and Maximum Length of both the parent column and the join column should be identical.

Action:

Modify one or other of the column definitions, or document the reason for the difference.


CDA-01078

CDA-01078 %0!s: A foreign column can be referred to only once per constraint

Cause:

Columns must be unique within a constraint.

Action:

Remove the duplicate reference to the column.


CDA-01079

CDA-01079 Term exists as a synonym or entity, possibly in another application

Cause:

Terms must be unique. They must not duplicate any entity names or synonyms that are visible from the context application system.

Action:

Ensure that the term does not exist as a name or synonym for another term or entity within the current or connected application systems.


CDA-01080

CDA-01080 Reference already exists for this module

Cause:

A change history is uniquely identified by its module and change reference number.

Action:

Enter a different reference, or rename the existing change history to have the same change reference.


CDA-01081

CDA-01081 Previous change not transferred back to production directory

Cause:

A new change history cannot be entered until all previous change histories are transferred back for use, e.g. Live or System Test.

Action:

Ensure that all existing change history entries for this module have 'date transferred' set.


CDA-01082

CDA-01082 %0!s: Module is not yet complete or passed testing

Cause:

A module should not be subject to change history until it is complete.

Action:

Set the 'module complete' flag.


CDA-01083

CDA-01083 %0!s: Super-module is used in another application

Cause:

The calling module is shared into another application system.

Action:

This is a warning message and no action is required.


CDA-01085

CDA-01085 %0!s: Column usage is updatable but table usage is not insertable/updatable

Cause:

A Column of this Table has been set so that it can be updated but the Table has not been set to allow updates and insertions.

Action:

If the module can change the value of a column, update the module table usage update flag or insert flag as appropriate.


CDA-01086

CDA-01086 %0!s: Column usage is nullable but table usage is not insertable/updatable

Cause:

The Column usage for a module has been set so that values can be set to NULL but the Table usage that the Column is attached to has not had its UPDATE_FLAG set to Yes.

Action:

Either set the Column usage UPDATE_FLAG to N if you wish no updating to be allowed or change the Table usage UPDATE_FLAG to Y if you wish the column to be updated to a NULL value.


CDA-01087

CDA-01087 %0!s: Column usage is selectable but table usage is not selectable

Cause:

A Column usage has been set so that values can be queried but the Table usage to which it is attached has not been set for queries.

Action:

Either set the Table Usage to allow queries on the Column or set the Column Usage to not allow queries (SELECT_FLAG = 'N')


CDA-01089

CDA-01089 %0!s: Update flag conflicts with one or more foreign key constraints

Cause:

UPDATE_FLAG is 'Y' but the Column is in a non-transferable Foreign Key Constraint.

Action:

Set UPDATE_FLAG to 'N' or update the Foreign Key Constraint this Column is in so that FK_TRANSFERABLE = 'Y'.


CDA-01090

CDA-01090 %0!s: Update flag conflicts with one or more primary key constraints

Cause:

The UPDATE_FLAG has been set for a primary key constraint; Primary Keys must be NOT NULL and cannot be updated.

Action:

Ensure the UPDATE_FLAG for columns that are Primary Keys is set to No for updates allowed.


CDA-01091

CDA-01091 %0!s: Update flag conflicts with one or more unique key constraints

Cause:

The UPDATE_FLAG has been set to yes for one or more Unique Key constraints; Unique Keys must be NOT NULL and unique and are generally system generated. They cannot be updated.

Action:

Ensure that the UPDATE_FLAG for columns that are Unique Keys is set to No for updates allowed.


CDA-01099

CDA-01099 %0!s : Multiple inheritance of value types not permitted.

Cause:

More than one generalisation association has been made for this value type. Value types can only inherit from a single other value type.

Action:

Ensure that this value type has only one generalisation association to another value type.


CDA-01101

CDA-01101 A relationship with End Names %0!s and %1!s already exists between %2!s and %3!s

Cause:

A relationship with the same names between the same respective entities has been detected.

Action:

Rename one of the relationship ends to avoid the uniqueness conflict.


CDA-01102

CDA-01102 %0!s: Entities %1!s and %2!s must both be connected to the context application system

Cause:

Each entity must either be shared or owned directly by the context application system.

Action:

Connect the entity in violation by sharing it with the context application system.


CDA-01103

CDA-01103 Relation selection for %0!s: Cannot associate a view/snapshot with itself

Cause:

An association has been attempted between this view/snapshot and itself. A view or snapshot cannot be based on itself.

Action:

Ensure the View or Snapshot is based on another Table, View or Snapshot.


CDA-01104

CDA-01104 %0!s: MTI_REFERENCE (Link To) must be defined for a non BASE Detailed Table Usage

Cause:

If USAGE_TYPE is neither 'BASE' nor null, then MTI_REFERENCE (Link To) must be set.

Action:

Set the MTI_REFERENCE (Link To) to the required Detailed Table Usage, or set USAGE_TYPE to 'BASE' or null.


CDA-01105

CDA-01105 Unique identifier entry %0!s: Attribute Or Relation property must be either A[ttribute] or R[elationship End]

Cause:

The Attribute Or Relation property must be provided in order to create a unique identifier entry.

Action:

Provide a value of A or R.


CDA-01106

CDA-01106 Unique identifier entry: %0!s %1!s already exists in UID for entity %2!s

Cause:

A uniqueness constraint violation was detected that caused processing of this unique identifier entry to halt. Continuation would have led to a SQL unique index constraint violation.

Action:

Since the element is already part of the unique identifier entry, no action need be taken.


CDA-01107

CDA-01107 %0!s: No SHARE access privileges on application system that owns Common Function %1!s

Cause:

The specified common function is not owned by the context application system, and the user does not have SHARE privileges on the remote application system in order to share the common function.

Action:

Obtain SHARE privileges on the remote application system.


CDA-01108

CDA-01108 %0!s: Parent Function %1!s must be owned by context application system

Cause:

A function hierarchy must be contained within an application system.

Action:

Specify a reference to a function that is owned by the context application system.


CDA-01109

CDA-01109 %0!s: Cannot be both a Master function and a Copy function

Cause:

The specified function is both a Copy function (i.e. it refers to a Common Function) and a Master function (i.e. other functions refer to this function as a Common Function).

Action:

Update the Copy functions to reference a different Master function, or ensure that this function does not refer to a Common Function.


CDA-01110

CDA-01110 %0!s: A function cannot refer to the same function as both Master and Parent

Cause:

A Common Function that is a Child Function refers to its own Parent as its Master Function.

Action:

Update the function with references to a different Common Function and/or a different Parent Function.


CDA-01111

CDA-01111 %0!s: A Function cannot be its own Parent

Cause:

A violation in the function hierarchy was detected.

Action:

Update the function to refer to a different Parent.


CDA-01112

CDA-01112 %0!s: A function cannot be its own Common function

Cause:

A violation in the function hierarchy was detected.

Action:

Update the function to refer to a different Common Function.


CDA-01113

CDA-01113 %0!s: Cannot be both a Parent Function and a Copy Function

Cause:

An attempt has been made either to make an existing Copy Function a Parent Function, or to make an existing Parent Function a Copy Function.

Action:

Ensure consistent cross-referencing to avoid these violations to the hierarchy. A Master Function can be a Parent Function.


CDA-01114

CDA-01114 %0!s: Master %1!s cannot be an ancestor of this function

Cause:

A violation in the function hierarchy was detected.

Action:

Update the function to refer to a different Common Function.


CDA-01115

CDA-01115 %0!s: Parent %1!s is a descendant of this Function

Cause:

A violation in the function hierarchy was detected.

Action:

Update the function to refer to a different Parent Function.


CDA-01124

CDA-01124 %0!s: Foreign Constraint and linked Table Usage must be to the same table

Cause:

If both MTI_REFERENCE and CONSTRAINT_REFERENCE are set then EITHER: TABLE_REFERENCE must equal CONSTRAINT_REFERENCE.TABLE_REFERENCE and MTI_REFERENCE.TABLE_REFERENCE must equal CONSTRAINT_REFERENCE.FOREIGN_TABLE_REFERENCE OR TABLE_REFERENCE must equal CONSTRAINT_REFERENCE.FOREIGN_TABLE_REFERENCE and MTI_REFERENCE.TABLE_REFERENCE must equal CONSTRAINT_REFERENCE.TABLE_REFERENCE

Action:

Set CONSTRAINT_REFERENCE and MTI_REFERENCE so that the above rules are fulfilled, or leave one of them null.


CDA-01126

CDA-01126 %0!s: The Foreign Constraint join is the wrong way round for a LOOKUP usage

Cause:

If USAGE_TYPE = LOOKUP and both MTI_REFERENCE and CONSTRAINT_REFERENCE are set then EITHER: TABLE_REFERENCE must equal CONSTRAINT_REFERENCE.FOREIGN_TABLE_REFERENCE and MTI_REFERENCE.TABLE_REFERENCE must equal CONSTRAINT_REFERENCE.TABLE_REFERENCE OR TABLE_REFERENCE must not equal CONSTRAINT_REFERENCE.TABLE_REFERENCE OR MTI_REFERENCE.TABLE_REFERENCE must not equal CONSTRAINT_REFERENCE.FOREIGN_TABLE_REFERENCE

Action:

Set CONSTRAINT_REFERENCE and MTI_REFERENCE so that the above rules are fulfilled, or leave one of them null, or do not set USAGE_TYPE to LOOKUP.


CDA-01129

CDA-01129 %0!s: Cannot have an Outer Join on a SUBQRY foreign key link

Cause:

OUTER_JOIN_FLAG = 'Y' is not allowed if USAGE_TYPE is 'SUBQUERY'.

Action:

Set USAGE_TYPE or OUTER_JOIN_FLAG to one of their other values. See the API documentation for Module Detail Table Usages for the effects of different values of USAGE_TYPE.


CDA-01134

CDA-01134 %0!s: Case-independent Name is not unique in module

Cause:

Program Data Name is not case-sensitive. Although it can be expressed in mixed case, its uniqueness cannot depend on case-sensitivity.

Action:

Change the Name of the Program Data, or define it for a different module.


CDA-01135

CDA-01135 %0!s: If Value Datatype is null, Length, Scale and Default must all be null

Cause:

If Value Datatype is not being set to describe the program datum, then it is not valid to set Value Length, Value Scale or Value Default.

Action:

Either set Value Length, Value Scale and Value Default to null, or specify Value Datatype (and set references to Domain and Datastructure to null).


CDA-01136

CDA-01136 %0!s: Type = 'EXCEPTION': VALUE_DATATYPE, DATASTRUCTURE_REFERENCE, DOMAIN_REFERENCE, ORACLE_TYPE_REFERENC must be null

Cause:

If the DATA_CONSTRUCT_TYPE is 'EXCEPTION', it is not valid to set VALUE_DATATYPE or to refer to a Domain or to a Datastructure or to an Oracle Type.

Action:

Set DATA_CONSTRUCT_TYPE to another value, or set VALUE_DATATYPE and references to Domain, Datastructure and Oracle Type all to null.


CDA-01137

CDA-01137 %0!s: Type not = 'EXCEPTION': Set either Datatype or a reference to Domain, Datastructure, Column, Table or Oracle Type

Cause:

If DATA_CONSTRUCT_TYPE is not 'EXCEPTION', you must set either a VALUE_DATATYPE or a reference to either a Domain or a Datastructure or an Oracle Type or a Column or a Table.

Action:

Supply one and only one of these values.


CDA-01138

CDA-01138 %0!s: No Datatype named %1!s exists

Cause:

This is a warning to draw your attention to the fact that the Datatype specified is not one of the standard ones.

Action:

Warning, so action need not be taken.


CDA-01139

CDA-01139 %0!s: Scope can only be public for PL/SQL modules of Type PACKAGE

Cause:

It is not valid to create a Program Datum with Scope = 'PUBLIC' when the context Module is not Module Type = 'PACKAGE', but it is written in the Language 'PL/SQL'.

Action:

Ensure that the Scope and Module Type values are consistent.


CDA-01151

CDA-01151 %0!s: Cannot set UPDATE_FLAG - the Column is in a non-updateable Constraint

Cause:

This column appears in a Constraint (Primary, Unique or Foreign) that is either not updateable or not transferable, but this module is attempting to update this column.

Action:

Ensure the UPDATE_FLAG is not set for this Column usage or it is not in a non-updateable Constraint.


CDA-01158

CDA-01158 %0!s: If Datatype is null, Length, Scale and Default Value must all be null

Cause:

If Datatype is not being set to describe the program datum, then it is not valid to set Length, Scale or Default Value.

Action:

Either set Length, Scale and Default Value to null or specify a Datatype (and set references to Domain and Datastructure to null).


CDA-01159

CDA-01159 %0!s: Set either Datatype or a reference to Domain, Datastructure, Column, Table or Oracle Type

Cause:

Either a Datatype must be set, or a reference to Domain or to Datastructure or to Column or to Table or to Oracle Type.

Action:

Ensure that Datatype is set as a reference to Domain or to Datastructure or to Column or to Table or to Oracle Type.


CDA-01160

CDA-01160 %0!s: Must link to a Usage that is within the same Module Component

Cause:

MTI_REFERENCE (Link To) must refer to a Module Detailed Table Usage (MTI) that is within the same Module Component as the current one.

Action:

Leave MTI_REFERENCE (Link To) as null, or set it to a Module Detail Table Usage which is within the same Module Component as this one.


CDA-01163

CDA-01163 %0!s: Invalid Datastructure type (%1!s)

Cause:

An invalid type for this Datastructure has been chosen.

Action:

For details of valid types for Datastructures see the Oracle Designer Model, which you can access from the Designer Start Here icon.


CDA-01164

CDA-01164 %0!s: Specified module is the wrong type

Cause:

This Datastructure has been defined against a module of the wrong type. Datastructures can be used with modules of type PROCEDURE, PACKAGE or FUNCTION only.

Action:

Ensure that the Datastructure is assigned to the right PL/SQL module. If it is, ensure that the TYPE property of the PL/SQL module is valid.


CDA-01165

CDA-01165 %0!s: PL/SQL Tables can contain only one item

Cause:

A Datastructure Item already exists for this Datastructure. As this Datastructure is of TYPE 'PL/SQL Table' further Datastructure Items cannot be added.

Action:

Ensure that the Datastructure that this Item is attached to is set to the right TYPE. If this is PL/SQL Table then ensure only one Datastructure Item exists.


CDA-01173

CDA-01173 %0!s: PLSQL_MODULE_REFERENCE must refer to either a PACKAGE or a PROCEDURE

Cause:

If PLSQL_MODULE_REFERENCE is set it must refer to a PL/SQL Module which has PLSQL_MODULE_TYPE = 'PACKAGE' or 'PROCEDURE'.

Action:

Refer to a different PL/SQL Module, a different element or change the PL/SQL Module to be a Package or Procedure.


CDA-01174

CDA-01174 %0!s: CURSOR_REFERENCE must refer to a PL/SQL Module of type CURSOR

Cause:

If CURSOR_REFERENCE is set it must refer to a PL/SQL Module which has PLSQL_MODULE_TYPE = 'CURSOR'.

Action:

Refer to a different PL/SQL Module, a different element or change the PL/SQL Module to be a Cursor.


CDA-01175

CDA-01175 %0!s: One and only one source of a datatype should be set

Cause:

The datatype is evaluated from one of many sources. One of the following must be set: Datatype or references to Cursor, Domain, Column, Datastructure2, Program Datum, Table Definition or Oracle Type.

Action:

Ensure that the Datatype has only one source.


CDA-01176

CDA-01176 %0!s: PL/SQL tables can contain only one item

Cause:

PL/SQL tables may have only one column. This datastructure is of type 'TABLE' and has more than one datastructure item.

Action:

Either do not attempt to place this Item on this Datastructure, or delete the other Item first.


CDA-01178

CDA-01178 %0!s: Both Package and Cursor must be set to define a cursor

Cause:

In the Repository, a cursor can be defined in more than one package or procedure via the module network. The pair need to be referenced to resolve the cursor to be used.

Action:

Ensure that both Package and Procedure are referenced.


CDA-01180

CDA-01180 %0!s: Datatype must be set if either LENGTH or DEFAULT_VALUE is set

Cause:

One or more of the properties LENGTH or DEFAULT_VALUE or DECIMAL_PLACES has been set without a Datatype being referenced.

Action:

If either LENGTH or DEFAULT_VALUE or DECIMAL_PLACES properties are populated then DATATYPE property must be set.


CDA-01184

CDA-01184 %0!s: A business unit cannot be its own parent

Cause:

A violation in the business unit hierarchy was detected.

Action:

Update the business unit to refer to a different Parent.


CDA-01185

CDA-01185 %0!s: Only set one of ITEM_REFERENCE, MODULE_ARGUMENT_REFERENCE, VALUE

Cause:

One and only one of the following properties must be set: ITEM_REFERENCE, MODULE_ARGUMENT_REFERENCE, VALUE

Action:

Set only one of these properties.


CDA-01186

CDA-01186 %0!s: CALLED_ARGUMENT_REFERENCE.MODULE_REFERENCE must equal MODULE_NETWORK_REFERENCE.CHILD_MODULE_REFERENCE

Cause:

The CALLED_ARGUMENT_REFERENCE must refer to a Module Argument belonging to the called Module of the Module Network (as identified by MODULE_NETWORK_REFERENCE.

Action:

Either set CALLED_ARGUMENT_REFERENCE to refer to a different Module Argument, or set MODULE_NETWORK_REFERENCE to refer to a different Module Network, so that the values conform to the above rule.


CDA-01187

CDA-01187 %0!s: The DATATYPE of the called Module Argument must match what is passed in

Cause:

The DATATYPE of the CALLED_ARGUMENT_REFERENCE must match the DATATYPE of the ITEM_REFERENCE.DATATYPE or the MODULE_ARGUMENT_REFERENCE.DATATYPE or the VALUE. Note API cannot verify the datatype of VALUE.

Action:

Alter the DATATYPE.


CDA-01188

CDA-01188 %0!s: Cannot be for a PL/SQL Module

Cause:

The Passed Value must be passed via a Module Network such that its CHILD_MODULE_REFERENCE and PARENT_MODULE_REFERENCE refer to General Modules.

Action:

Set the MODULE_NETWOK_REFERENCE to a Module Network with its CHILD_MODULE_REFERENCE and PARENT_MODULE_REFERENCE set to General Modules.


CDA-01189

CDA-01189 %0!s: Cannot be the value for an Item in the context of a Sql Query Set

Cause:

If ITEM_REFERENCE is set then ITEM_REFERENCE.ITEM_FOR must equal 'MCO'.

Action:

Set ITEM_REFERENCE to an Item within a Module Component.


CDA-01190

CDA-01190 %0!s: Item must belong to a Module Component that is included in the calling Module

Cause:

If ITEM_REFERENCE is set then the Item must belong to a Module Component that is included in the calling Module in the Module Network. (MODULE_NETWORK_REFERENCE.PARENT_MODULE_REFERENCE)

Action:

Make the Passed Value refer to a different MODULE_NETWORK_REFERENCE or a different ITEM_REFERENCE, MODULE_ARGUMENT_REFERENCE or VALUE.


CDA-01191

CDA-01191 %0!s: Cannot delete this Module Component Inclusion as %1!s depends on it

Cause:

This Module Component Inclusion cannot be deleted as it links a Module Component which is the context of an Item with the value passed via a Passed Value, and a Module that calls that Passed Value.

Action:

Delete the Passed Value by hand.


CDA-01192

CDA-01192 %0!s: The Module Argument must belong to the calling Module in the Module Network

Cause:

When the Passed Value is the value of a Module Argument it must be within the calling Module, that is the parent Module of the Module Network.

Action:

Make the Passed Value refer to a different MODULE_NETWORK_REFERENCE or a different ITEM_REFERENCE, MODULE_ARGUMENT_REFERENCE or VALUE.


CDA-01193

CDA-01193 %0!s: Parent reference cannot be same as child.

Cause:

This object's parent value is referencing itself.

Action:

Ensure that the parent field references another of this object type or leave blank.


CDA-01194

CDA-01194 %0s : Definition cannot be switched from object to relational and vice versa

Cause:

TABLE and VIEWS can be either object or relational. An object TABLE or VIEW references an Oracle Object Type and this is set in the Object Type property field or left blank when the TABLE or view is relational. This is set on insertion of a new VIEW or TABLE and cannot be updated.

Action:

The reference to an Oracle Object Type cannot be updated. If this has to be changed the TABLE or VIEW must be deleted and recreated in the correct state.


CDA-01195

CDA-01195 %0s : Object View Definitions cannot have columns.

Cause:

A column cannot be attached to a View Definition that references an Oracle Object Type.

Action:

Ensure that the Object View does not have any Columns.


CDA-01196

CDA-01196 %0s : When Unlimited flag is set Maximum extents must be null.

Cause:

Caused when a value is attached to the max extents property when unlimited? property is set to Yes.

Action:

Leave max extents as null or change unlimited? to No.


CDA-01201

CDA-01201 %0!s: A Maximum Value must exist if the value for Cycle is 'Y' and the Increment Value positive

Cause:

If the CYCLE property in a Sequence Implementation is set to Y and the INCREMENT value is positive then the MAXIMUM value must also be set.

Action:

Ensure that the MAXIMUM value is set.


CDA-01202

CDA-01202 %0!s: Increment Value cannot be zero

Cause:

INCREMENT property as been set to zero for this Sequence Implementation.

Action:

Set the INCREMENT property to a positive or negative number.


CDA-01203

CDA-01203 %0!s: Increment Value (%1!s) must not be greater than the sequence range

Cause:

The INCREMENT value exceeds the MAXIMUM value.

Action:

Ensure that the INCREMENT value is a sensible level with regard to the MAXIMUM set.


CDA-01204

CDA-01204 %0!s: When Cycle is 'Y', the Cache Value must not be more than one cycle

Cause:

If caching and cycling are used, CACHE must be less than (CIEL(MAXVALUE - MINVALUE)) / ABS(INCREMENT). See Oracle Server SQL Reference.

Action:

Change the values of CACHE, CYCLE, MAXVALUE, MINVALUE or INCREMENT so that the rule outlined in the CAUSE is obeyed.


CDA-01205

CDA-01205 %0!s: DEGREE (%1!s) must be null when PARALLEL is null

Cause:

If PARALLEL is not set, then DEGREE must not be set either.

Action:

Set PARALLEL to a value or set DEGREE to null.


CDA-01206

CDA-01206 %0!s: Specified %1!s does not exist <%2!s>

Cause:

The reference property to the specified Type has been populated with either the ID of an object of a different Type, or a non-existent ID.

Action:

Populate the specified reference property with an ID of an element of the correct Type, or if it is an optional property, set it to null.


CDA-01208

CDA-01208 %0!s: Reference to foreign table does not match reference to joined key table

Cause:

This foreign key constraint refers to a unique key or to a primary key. The foreign table referred to in the foreign key constraint must be the same as the table referred to in the unique or primary key constraint.

Action:

Ensure that the foreign table referred to in the foreign key constraint is the same as the table referred to in the unique or primary key constraint.


CDA-01209

CDA-01209 %0!s: Foreign key constraints in an arc must be optional

Cause:

The MANDATORY property for a foreign key that is part of an arc has been set to Y. Foreign keys in Arcs must be optional because they may reference another TABLE or another foreign key in the arc may reference another TABLE.

Action:

Ensure all foreign keys in an arc have MANDATORY set to N.


CDA-01210

CDA-01210 %0!s: BASE_COLUMN_REFERENCE must be null for a Table or Record Column

Cause:

BASE_COLUMN_REFERENCE has been set for a Table or Record. Only Views and Snapshots can refer to a base column.

Action:

Ensure that BASE_COLUMN_REFERENCE is null.


CDA-01211

CDA-01211 %0!s: PREFERENCE_NAME %1!s does not exist for PRODUCT_FLAVOR %2!s

Cause:

The combination of PREFERENCE_NAME and PRODUCT_FLAVOR must be valid. The combination must be found in the system table CDI_DFLT_USER_PREF_USAGES; columns DUP_SNAME and P_SNAME respectively.

Action:

Change the value of PREFERENCE_NAME or PRODUCT_FLAVOR.


CDA-01212

CDA-01212 %0!s Mininum Cardinality (%1!s) exceeds Maximum Cardinality (%2!s)

Cause:

The Minimum Cardinality exceeds the Maximum Cardinality.

Action:

Change either the Maximum Cardinality or the Maximum Cardinality of the Relationship end. A null value for Maximum Cardinality means infinity.


CDA-01213

CDA-01213 %0!s: The properties All Databases and Database cant both be set

Cause:

A specific database has been defined as well as all databases. This is not allowed.

Action:

Specify either All Databases or a Database or neither.


CDA-01301

CDA-01301 %0!s: Property %1!s must not be NULL

Cause:

A violation of a property optionality constraint was detected.

Action:

Provide a value for this property.


CDA-01302

CDA-01302 %0!s: Invalid value for property %1!s

Cause:

An invalid value was supplied for the specified property.

Action:

Refer to the list of valid values for this property in the documentation.


CDA-01304

CDA-01304 %0!s: Arc %1!s violation

Cause:

This element contains an arc on a set of relationships to other elements. A value can be provided for only one of the relationships in this arc, and values for multiple relationships in the arc were detected.

Action:

Refer to the documentation to determine which relationships for this element are part of the arc.


CDA-01305

CDA-01305 %0!s: UID %1!s uniqueness violation

Cause:

A uniqueness constraint violation was detected for this element.

Action:

Refer to the documentation for the uniqueness constraint rules for this element. The number after 'UID' refers to which uniqueness constraint is violated if there are more than one.


CDA-01306

CDA-01306 %0!s: Mandatory Flag disallows a nullify action on update or delete

Cause:

Making a Foreign Key Constraint mandatory means that when the 'source' row is deleted or any of the columns' values are updated, then the only valid cascade actions are to Cascade, Restrict or Default.

Action:

Make the Foreign Key Constraint optional or make both the Cascade Delete and Cascade Update flags either 'C', 'R' or 'D'.


CDA-01307

CDA-01307 %0!s: Language name must be the same as the associated source file

Cause:

Class Code Locations and Class Set Code Locations are located in Source Files. If the Source File has an associated Language it must be the same as the LANGUAGE_NAME property of the Class Code Location and Class Set Code Location.

Action:

Either change the associated Source File so that it has no Language or make the Source File's Language the same as the LANGUAGE_NAME in the associated Class Code Locations and Class Set Code Locations.


CDA-01308

CDA-01308 %0!s: HASHKEYS must be an integer >= 2

Cause:

The property HASHKEYS must be an integer and its minimum value is 2.

Action:

Alter the value of HASHKEYS.


CDA-01309

CDA-01309 %0!s: Language_Name <%1!s> and Code_Section_Type <%2!s> not found in table cdi_code_section_types

Cause:

Each Class Code Location must refer to one and only one row in the table cdi_code_section_types.

Action:

The combination of properties Language_Name and Code_Section_Type for this Class Code Location must match a combination of the columns Language_Name and Type_Name in cdi_code_section_types.


CDA-01310

CDA-01310 %0!s: Language_Name <%1!s> and Class_Set_Code_Type <%2!s> not found in table cdi_class_set_code_types

Cause:

Each Class Set Code Location must refer to one and only one row in the table cdi_class_set_code_types.

Action:

The combination of properties Language_Name and Class_Set_Code_Type for this Class Set Code Location must match a combination of the columns Language_Name and Type_Name in cdi_class_set_code_types.


CDA-01311

CDA-01311 %0!s: Full Pathname <%1!s> clashes with <%2!s> in <%3!s>

Cause:

The FULL_PATHNAME of a file must be unique across all types of file (Database, Record and Source), which are shared into the context application system.

Action:

Set the FULL_PATHNAME to a unique value or to null.


CDA-01312

CDA-01312 %0!s: Class Code Location must mirror an existing Set Member Item

Cause:

The values of the properties SOURCE_FILE_REFERENCE and GENERATOR_CLASS_SET_REFERENCE should be the same as an instance of a Set Member Item's ELEMENT_REFERENCE and USER_DEFINED_SET_REFERENCE.

Action:

Either insert a Set Member Item with the appropriate values or select different values for the Class Code Location.


CDA-01313

CDA-01313 %0!s: Class Set Code Location must mirror an existing Set Member Item

Cause:

The values of the properties SOURCE_FILE_REFERENCE and GENERATOR_CLASS_SET_REFERENCE should be the same as an instance of a Set Member Item's ELEMENT_REFERENCE and USER_DEFINED_SET_REFERENCE.

Action:

Either insert a Set Member Item with the appropriate values or select different values for the Class Set Code Location.


CDA-01314

CDA-01314 %0!s: Cannot associate %1!s with more than one Generator Class Set

Cause:

A Source File may only be associated with one and only one Generator Class Set.

Action:

Remove the association between this Source File and Generator Class Set before creating the new association.


CDA-01315

CDA-01315 %0!s: Module of PLSQL_MODULE_TYPE %1!s cannot have a return type.

Cause:

Only modules of type FUNCTION and CURSOR can have a return type.

Action:

Set return type to null for this plsql_module_type.


CDA-01317

CDA-01317 %0!s: Default value must be entered if null values are not permitted

Cause:

Default value must be entered if Optional? is set to False.

Action:

Enter default value


CDA-01318

CDA-01318 %0!s: ALIAS %1!s already exists.

Cause:

The ALIAS already exists for a Table, View or Snapshot in the current application system.

Action:

Choose another value for ALIAS


CDA-01319

CDA-01319 %0!s: Cannot grant Reference privilege on table to a Role.

Cause:

REFERENCE_FLAG may only be 'Y' for a Table when the grant is made to a User, not a Role.

Action:

Set REFERENCE_FLAG to 'N' or grant to a User, or grant to another Object Implementation eg a View.


CDA-01320

CDA-01320 %0!s: Select at least one privilege.

Cause:

At least one privilege must be selected for the object.

Action:

Set at least one privilege to 'Y'.


CDA-01321

CDA-01321 %0!s: Function Entity Usages cannot be created for a copy function.

Cause:

Copy (Slave) Functions may not be modified so Function Entity Usages cannot be created.

Action:

Add the Function Entity Usages to the Master Function.


CDA-01322

CDA-01322 %0!s: A PUBLIC Role cannot be a %1!s.

Cause:

A PUBLIC Role cannot be specified for a Child or Parent Role reference.

Action:

Specify another Role as Child or Parent Role.


CDA-01323

CDA-01323 %0!s: %1!s already exists for %1!s database.

Cause:

Roles and User NAMEs must be unique within the Database.

Action:

Choose another NAME for this Role or Group.


CDA-01324

CDA-01324 %0!s: Cannot update or delete a PUBLIC Role.

Cause:

A PUBLIC Role cannot be updated or deleted.

Action:

Delete the database to delete PUBLIC Role.


CDA-01325

CDA-01325 %0!s: A generatable language %1!s cannot be deleted.

Cause:

Languages with GENERATABLE_FLAG = 'Y' may not be deleted.

Action:

Do not attempt to delete this Language.


CDA-01326

CDA-01326 %0!s: The associated Module Detail Table Usage does not exist for the Column %1!s

Cause:

A Detail Table Usage does not exist for the Table to which the Column belongs.

Action:

Create a Detail Table Usage for the Table to which the Column belongs.


CDA-01327

CDA-01327 %0!s: Module of PLSQL_MODULE_TYPE %1!s must have a return type

Cause:

FUNCTIONs must have a return type

Action:

Set a valid return type


CDA-01328

CDA-01328 %0!s: The NAME or LANGUAGE_TYPE for generatable languages cannot be changed

Cause:

NAME or LANGUAGE_TYPE of a Language that can be generated from Oracle Designer cannot be updated.

Action:

Do not attempt to update the NAME or LANGUAGE_TYPE of this Language.


CDA-01329

CDA-01329 %0!s: Primary Key Constraint cannot be defined on an optional Column %1!s.

Cause:

Only mandatory (NOT NULL) Columns are valid in a Primary Key.

Action:

Make this Column mandatory or do not make it part of the Primary Key for this Table.


CDA-01330

CDA-01330 %0!s: Cannot define an Index for a Hash Cluster.

Cause:

Hash Clusters (CLUSTER_TYPE = 'HCL') may not have Cluster Indexes.

Action:

Change the Cluster's CLUSTER_TYPE or do not attempt to associate a Cluster Index with this Cluster.


CDA-01331

CDA-01331 %0!s: Property HASHKEYS and HASH_IS cannot be defined for index cluster.

Cause:

Property HASHKEYS and HASH_IS should be null for index cluster.

Action:

Set HASHKEYS and HASH_IS to null.


CDA-01332

CDA-01332 %0!s: Table Partitions are only valid for Oracle8 databases

Cause:

Table Partitions may only be associated with Table Implementations which are in the schema of a Database User on an Oracle Database with DB_VERSION = 8.

Action:

Set the owning Database to version 8.


CDA-01333

CDA-01333 %0!s: A Break Group may not have a Parent Group

Cause:

An Item Group with BREAK_GROUP_FLAG = 'Y' may not have ITEM_GROUP_REFERENCE set.

Action:

Don't make this Item Group a Break Group, or do not give it a parent Item Group.


CDA-01334

CDA-01334 %0!s: A Chart Group may not have a Parent Group

Cause:

An Item Group with CHART_CATEGORY set may not have ITEM_GROUP_REFERENCE set.

Action:

Don't make this Item Group a Chart Group, or do not give it a parent Item Group.


CDA-01335

CDA-01335 %0!s: Local Index Partitions must be for LOCAL Index Storage

Cause:

The Local Index Partition must be a partition of an Index Storage element with INDEX_STORAGE_TYPE = 'LOCAL'

Action:

Set the INDEX_STORAGE_TYPE to 'LOCAL' or associate a Global Index Partition to the Index Storage element.


CDA-01336

CDA-01336 %0!s: Global Index Partitions must be for GLOBAL Index Storage

Cause:

The Global Index Partition must be a partition of an Index Storage element with INDEX_STORAGE_TYPE = 'GLOBAL'

Action:

Set the INDEX_STORAGE_TYPE to 'GLOBAL' or associate a Local Index Partition to the Index Storage element.


CDA-01337

CDA-01337 %0!s: Partition Key Entries must be for GLOBAL Index Storage

Cause:

The Partition Key Entry must be in the partition key of an Index Storage element with INDEX_STORAGE_TYPE = 'GLOBAL'

Action:

Set the INDEX_STORAGE_TYPE to 'GLOBAL'


CDA-01338

CDA-01338 %0!s: RELATION_SELECTION_REFERENCE must be null for a Table or Record

Cause:

Only Columns for Views and Snapshots can refer to a Relation Selection.

Action:

Leave the property null. Choose a Column of a View or Snapshot.


CDA-01339

CDA-01339 %0!s: DATATYPE, MAXIMUM_LENGTH and DECIMAL_PLACES must match the Cluster Column's

Cause:

If CLUSTER_COLUMN_REFERENCE is set, then the Column's DATATYPE, PRECISION and SCALE must match the Cluster Column's. MAXIMUM_LENGTH and DECIMAL_PLACES must match the Cluster Column's DATATYPE, LENGTH and SCALE.

Action:

Alter the Column's DATATYPE, MAXIMUM_LENGTH or DECIMAL_PLACES or set CLUSTER_COLUMN_REFERENCE to null.


CDA-01340

CDA-01340 %0!s: Module Component FLAGs should not be set when the BASE Usage FLAGs are not set

Cause:

If this Data Bound Item is for a BASE Module Detail Table Usage then the SELECT_FLAG or the UPDATE_FLAG should not be set to 'Y' if the associated Module Component's SELECT_FLAG or UPDATE_FLAG are set to 'N'.

Action:

Update the SELECT_FLAG or UPDATE_FLAG or the associated Module Component's SELECT_FLAG or UPDATE_FLAG. This is only a identical. Warning so action need not be taken.


CDA-01341

CDA-01341 %0!s: Module Component must not be MODULE_LEVEL

Cause:

The associated Module Component must have its MODULE_LEVEL_FLAG set to 'N'.

Action:

Associate this Data Bound Item with another Module Component or set the MODULE_LEVEL_FLAG to 'N'.


CDA-01342

CDA-01342 %0!s: The Database User and the Role must be in the same Database

Cause:

In order for a Role to be granted to a User, they both must be in the same Database.

Action:

Associate the User with a different Role which is in the same Database as the User.


CDA-01343

CDA-01343 %0!s: Cannot grant the PUBLIC role to a User

Cause:

The PUBLIC Role is not a real Role and cannot be granted to a User.

Action:

Grant a different Role to this User.


CDA-01344

CDA-01344 %0!s: %1!s is in %2!s but the Object is in %3!s

Cause:

The User or Role which is being granted privileges is in a different database than the User which owns the Database Object.

Action:

Grant privileges to a User or Role in the Database which contains the User which owns the Database Object (or in the case of Directory, grant privileges to a User or Role in the Database which owns the Directory).


CDA-01345

CDA-01345 %0!s: Cannot delete -- Module Program Data exist which refer to Program Data owned by this Module

Cause:

The specified element could not be deleted because it owns Program Data which is referenced by another Module. ie a Module Program Datum links Program Data owned by this Module to another Module.

Action:

Ensure that all Program Data owned by this Module is not referenced by any other Module.


CDA-01346

CDA-01346 %0!s: A General Module may not have language PL/SQL

Cause:

There are two types of Module: PL/SQL Module, which has an implied Language of PL/SQL, and has all the associations and properties particular to PL/SQL Modules; and General Modules for all other Languages.

Action:

Give the General Module a different Language or create a PL/SQL Module.


CDA-01347

CDA-01347 %0!s: May not grant to or from PUBLIC

Cause:

When creating a Role Grant, neither GRANTOR_ROLE_REFERENCE nor GRANTEE_ROLE_REFERENCE may refer to the Role with NAME = 'PUBLIC'.

Action:

Refer to a different Role.


CDA-01348

CDA-01348 %0!s: Uniqueness conflict with %1!s

Cause:

See the documentation for the Uniqueness Constraint of this element type. There are a number of element types which share this namespace.

Action:

Choose another NAME for this object.


CDA-01349

CDA-01349 %0!s: Uniqueness conflict with %1!s

Cause:

See the documentation for the Uniqueness Constraint of this element type. There are a number of element types which share this namespace.

Action:

Choose a different associated element.


CDA-01350

CDA-01350 %0!s: Module Component Inclusion references must be different

Cause:

MCN_REFERENCE_FROM must not equal MCN_REFERENCE_TO.

Action:

Refer to different Module Component Inclusions.


CDA-01351

CDA-01351 %0!s: Associated Module Detail Table Usages must not be within SQL Query Sets

Cause:

The Module Detail Table Usages referenced by TABLE_USAGE_REFERENCE_TO and TABLE_USAGE_REFERENCE_FROM must both be directly within Module Components, not SQL Query Sets.

Action:

Associate the Key Based Link with Module Detail Table Usages which are within Module Components.


CDA-01352

CDA-01352 %0!s: The Module Component for the 'From' Detail Table Usage must match the one for the 'From' Module Component Inclusion

Cause:

TABLE_USAGE_REFERENCE_FROM.MODULE_COMPONENT_REFERENCE must equal MCN_REFERENCE_FROM.MODULE_COMPONENT_REFERENCE.

Action:

Make sure the 'from' Module Detail Table Usage and the 'from' Module Component Inclusion are for the same Module Component.


CDA-01353

CDA-01353 %0!s: The Module Component for the 'To' Detail Table Usage must match the one for the 'To' Module Component Inclusion

Cause:

TABLE_USAGE_REFERENCE_TO.MODULE_COMPONENT_REFERENCE must equal MCN_REFERENCE_TO.MODULE_COMPONENT_REFERENCE.

Action:

Make sure the 'to' Module Detail Table Usage and the 'to' Module Component Inclusion are for the same Module Component.


CDA-01354

CDA-01354 %0!s: Foreign Key Constraint must be based on the same Table as the 'From' or 'To' Module Detail Table Usage

Cause:

If the Key Based Link is based on a Foreign Key Constraint, then FOREIGN_KEY_REFERENCE.TABLE_REFERENCE must equal TABLE_USAGE_REFERENCE_FROM.TABLE_REFERENCE or TABLE_USAGE_REFERENCE_TO.TABLE_REFERENCE.

Action:

Associate the Key Based Link with a different Foreign Key Constraint or a different Module Detail Table Usage.


CDA-01355

CDA-01355 %0!s: Foreign Key Constraint must refer to the same Table as the 'From' or 'To' Module Detail Table Usage

Cause:

If the Key Based Link is based on a Foreign Key Constraint, then FOREIGN_KEY_REFERENCE.FOREIGN_TABLE_REFERENCE must equal TABLE_USAGE_REFERENCE_TO.TABLE_REFERENCE or TABLE_USAGE_REFERENCE_FROM.TABLE_REFERENCE.

Action:

Associate the Key Based Link with a different Foreign Key Constraint or a different Module Detail Table Usage.


CDA-01356

CDA-01356 %0!s: Primary Key Constraint must be for the same Table as the 'From' and 'To' Module Detail Table Usage

Cause:

If the Key Based Link is based on a Primary Key Constraint, then PRIMARY_KEY_REFERENCE.TABLE_REFERENCE must equal TABLE_USAGE_REFERENCE_FROM.TABLE_REFERENCE and TABLE_USAGE_REFERENCE_TO.TABLE_REFERENCE.

Action:

Associate the Key Based Link with a different Primary Key Constraint or a different Module Detail Table Usage.


CDA-01357

CDA-01357 %0!s: Unable to create unique Name for Type %1!s. Base Name = %2!s

Cause:

The simple algorithm used to create unique Names has failed. It acts by adding a number to the end of the Name until it is unique or grows to be longer than the property maximum length.

Action:

Choose a shorter or maybe completely different Name.


CDA-01358

CDA-01358 %0!s: For SPECIFIC Module Components, no other Module Component Inclusion may have the same MODULE_COMPONENT_REFERENCE

Cause:

If MODULE_COMPONENT_REFERENCE.MODULE_COMPONENT_TYPE = 'SPECIFIC' then no more other Module Component may have the same MODULE_COMPONENT_REFERENCE.

Action:

Refer to another Module Component.


CDA-01359

CDA-01359 %0!s: Cannot delete if Module Component is MODULE_LEVEL

Cause:

A Module Component or Module Component Inclusion cannot be deleted if MODULE_LEVEL_FLAG = 'Y'. GENERAL_MODULE_REFERENCE.LANGUAGE_REFERENCE <has property> 'SupportsModuleLevelComponent'.

Action:

Delete the General Module directly.


CDA-01360

CDA-01360 %0!s: Shared COMMON Module Components cannot become SPECIFIC

Cause:

This Module Component is shared into another Application System.

Action:

Unshare this Module Component before making it SPECIFIC.


CDA-01361

CDA-01361 %0!s: REUSABLE Module Components must be included in only one Module before becoming SPECIFIC

Cause:

Before changing a Module Component from REUSABLE to SPECIFIC it must be included in at most one General Module via a Module Component Inclusion.

Action:

Delete Module Component Inclusions that associate this REUSABLE Module Component with General Modules.


CDA-01362

CDA-01362 %0!s: MODULE_LEVEL Module Components must be in a valid Language

Cause:

If MODULE_LEVEL_FLAG = 'Y' then LANGUAGE_REFERENCE must refer to a Language with the property 'SupportsModuleLevelComponent'.

Action:

Refer to another Language or set MODULE_LEVEL_FLAG to 'N'


CDA-01363

CDA-01363 %0!s: This MODULE_LEVEL Module Component is in the same Module as %1!s

Cause:

If MODULE_LEVEL_FLAG = 'Y' GENERAL_MODULE_REFERENCE must be unique There is a maximum of one MODULE_LEVEL Module Component per General Module. Another Module Component with MODULE_LEVEL_FLAG = 'Y' already exists.

Action:

Set the MODULE_LEVEL_FLAG to 'N', associate this Component with another Module, or modify the existing Module Level Component for this Module.


CDA-01364

CDA-01364 %0!s: Only SPECIFIC Module Components may be MODULE_LEVEL

Cause:

If MODULE_LEVEL_FLAG = 'Y' then MODULE_COMPONENT_TYPE must be 'SPECIFIC'.

Action:

Set MODULE_LEVEL_FLAG to 'N' or MODULE_COMPONENT_TYPE to 'REUSABLE'.


CDA-01365

CDA-01365 %0!s: REUSABLE Module Components must not set GENERAL_MODULE_REFERENCE

Cause:

If MODULE_COMPONENT_TYPE = 'REUSABLE' then GENERAL_MODULE_REFERENCE must be null.

Action:

Set GENERAL_MODULE_REFERENCE to null or set MODULE_COMPONENT_TYPE to 'SPECIFIC', but not both.


CDA-01366

CDA-01366 %0!s: SPECIFIC Module Components must set GENERAL_MODULE_REFERENCE

Cause:

If MODULE_COMPONENT_TYPE = 'SPECIFIC' then GENERAL_MODULE_REFERENCE must not be null.

Action:

Set MODULE_COMPONENT_TYPE to 'REUSABLE' or set GENERAL_MODULE_REFERENCE but not both.


CDA-01367

CDA-01367 %0!s: Language must not be 'PL/SQL'

Cause:

Module Components are only included in General Modules, not PL/SQL Modules.

Action:

Put the Module Component in another Language.


CDA-01368

CDA-01368 %0!s: Cannot be included in a Module without a Language

Cause:

Module Components can only be associated to Modules with a specified Language. ie GENERAL_MODULE_REFERENCE.LANGUAGE_REFERENCE must not be null.

Action:

Associate this Module Component with a General Module which has a specified Language.


CDA-01369

CDA-01369 %0!s: MTI_REFERENCE (Link To) must not be defined for a BASE Detailed Table Usage

Cause:

If USAGE_TYPE is either 'BASE' or null, then MTI_REFERENCE (Link To) must be null.

Action:

Set the MTI_REFERENCE (Link To) to null or set USAGE_TYPE to another value.


CDA-01370

CDA-01370 %0!s: Upper limit Column (FOREIGN_COLUMN_REFERENCE2) does not exist in the join Table

Cause:

FOREIGN_COLUMN_REFERENCE2 must refer to a Column in the same Table that the Constraint joins to.

Action:

Choose a Column that is in the same Table that the Constraint joins to.


CDA-01371

CDA-01371 %0!s: Module Component Inclusion or Window must belong to the General Module

Cause:

If GENERAL_MODULE_REFERENCE is set then MCN_REFERENCE.GENERAL_MODULE_REFERENCE or WINDOW_REFERENCE.GENERAL_MODULE_REFERENCE must equal GENERAL_MODULE_REFERENCE.

Action:

Assign the Navigation Action Item to a different General Module or a different Window or Module Component Inclusion.


CDA-01372

CDA-01372 %0!s: A Plsql Mod Implementation is only valid in an Oracle Database above version 6

Cause:

A PL/SQL Mod Implementation must be in the schema of a Database User on an Oracle Database and the DB_VERSION > 6. ie DATABASE_USER_REFERENCE.DATABASE_REFERENCE.DATABASE_TYPE = 'ORC' and DATABASE_USER_REFERENCE.DATABASE_REFERENCE.DB_VERSION > 6.

Action:

Associate this PL/SQL Mod Implementation with another Database User or associate the Database User with an Oracle Database V7 or above.


CDA-01373

CDA-01373 %0!s: %1!s already refers to %2!s

Cause:

Each Foreign Key Constraint may have one and only one Relation Index. That is there may be no other Relation Indexes with the same FOREIGN_KEY_REFERENCE.

Action:

Set FOREIGN_KEY_REFERENCE to null or refer to another Foreign Key Constraint.


CDA-01374

CDA-01374 %0!s: Snapshot Refresh Group is in %1!s but Snapshot is in %2!s

Cause:

If the Snapshot Implementation is a member in a Snapshot Refresh Group, then the Database User which is the schema for the Snapshot Implementation must be in the same Database as the Snapshot Refresh Group. ie SNAPSHOT_GROUP_REFERENCE.DATABASE_REFERENCE must equal DATABASE_USER_REFERENCE.DATABASE_REFERENCE.

Action:

Don't put the Snapshot Implementation in a Snapshot Refresh Group, put it in another Snapshot Refresh Group, or put it in a different Database User.


CDA-01375

CDA-01375 %0!s: Snapshot is Simple and %1!s is based on more than one Table

Cause:

FAST Snapshots may only be based on one Table. It is not permitted to set a Snapshot Implementation's REFRESH_TYPE to 'FAST' if it is based on a Snapshot Definition that is derived from more than one Table. Similarly it is not permitted to make a Snapshot Definition to be derived from more than one Table if even one of its Implementations has REFRESH_TYPE = 'FAST'. FAST or Updateable Snapshots must be Simple; that is they may be based on only one Table. It is not permitted to set a Snapshot Implementation's REFRESH_TYPE to 'FAST' or a Snapshot Definition's UPDATABLE_FLAG to 'Y' if the Snapshot Definition is derived from more than one Table. Similarly it is not permitted to derive a Snapshot Definition from more than one Table if it has UPDATABLE_FLAG = 'Y' or even one of its Implementations has REFRESH_TYPE = 'FAST'.

Action:

Set the Snapshot Implementation's REFRESH_TYPE to a value other than 'FAST', or set the Snapshot Definition's UPDATABLE_FLAG to 'N'.


CDA-01376

CDA-01376 %0!s: Snapshot is Simple and %1!s is not based on a Table.

Cause:

FAST Snapshots may only be based on one Table (not Views or other Snapshots). It is not permitted to set a Snapshot Implementation's REFRESH_TYPE to 'FAST' if it is based on a Snapshot Definition that is derived from a View, Snapshot or Record. Similarly it is not permitted to make a Snapshot Definition to be derived from a View, Snapshot or Record if even one of its Implementations has REFRESH_TYPE = 'FAST'. FAST or Updateable Snapshots must be Simple; that is they may only be based on one Table (not Views or other Snapshots). It is not permitted to set a Snapshot Implementation's REFRESH_TYPE to 'FAST' or a Snapshot Definition's UPDATABLE_FLAG to 'Y' if the Snapshot Definition is derived from a View, Snapshot or Record. Similarly it is not permitted to derive a Snapshot Definition from a View, Snapshot or Record if it has UPDATABLE_FLAG = 'Y' or even one of its Implementations has REFRESH_TYPE = 'FAST'.

Action:

Set the Snapshot Implementation's REFRESH_TYPE to a value other than 'FAST', or set the Snapshot Definition's UPDATABLE_FLAG to 'N'.


CDA-01377

CDA-01377 %0!s: Only Views and Snapshots can be derived from Relation Selections

Cause:

Record and Table Definitions may not be derived from Relation Selections. Only View and Snapshot Definitions may be derived. ie VIEW_REFERENCE.TABLE_TYPE must be in ('SNP','VW').

Action:

Refer VIEW_REFERENCE to a Snapshot or View.


CDA-01378

CDA-01378 %0!s: Cannot be based on a MODULE_LEVEL Module Component

Cause:

A SQL Query Set must not be in a set operation with a Module Component that has MODULE_LEVEL_FLAG = 'Y'.

Action:

Associate the SQL Query Set with another Module Component.


CDA-01379

CDA-01379 %0!s: Cannot be based on a Module Component with DATASOURCE_TYPE = 'TABLE'

Cause:

A SQL Query Set must not be in a set operation with a Module Component that has DATASOURCE_TYPE = 'TABLE'.

Action:

Associate the SQL Query Set with another Module Component or set the DATASOURCE_TYPE to another value.


CDA-01381

CDA-01381 %0!s: Column must be within referenced Table

Cause:

If COLUMN_REFERENCE is set then COLUMN_REFERENCE.TABLE_REFERENCE must equal TABLE_REFERENCE.

Action:

Choose a Column in the referenced Table


CDA-01382

CDA-01382 %0!s: Replication Group is in a different Database to the Database User

Cause:

If the View or Table Implementation is in a Replication Group then it must be in the same Database as the Database User ie REPLICATION_GROUP_REFERENCE.DATABASE_REFERENCE must equal DATABASE_USER_REFERENCE.DATABASE_REFERENCE.

Action:

Either leave the REPLICATION_GROUP_REFERENCE null, or refer to a different Replication Group or Database User.


CDA-01383

CDA-01383 %0!s: Tablespace is in a different Database to the Database User

Cause:

The Tablespace must be part of the same Database that owns the Database User. ie DATABASE_USER_REFERENCE.DATABASE_REFERENCE must equal TABLESPACE_REFERENCE.DATABASE_REFERENCE.

Action:

Choose a different Database User or Tablespace.


CDA-01384

CDA-01384 %0!s: MODULE_LEVEL Module Components may not be of TYPE 'SQL EXPRESSION' or 'SQL AGGREGATE'

Cause:

If MODULE_COMPONENT_REFERENCE.MODULE_LEVEL_FLAG = 'Y' then UNBOUND_TYPE must not be in ('SQL EXPRESSION','SQL AGGREGATE').

Action:

Set UNBOUND_TYPE to a different value or put the Unbound Item in a non-MODULE_LEVEL Module Component.


CDA-01385

CDA-01385 %0!s: Insert and Update not permitted for non-CUSTOM Unbound Items

Cause:

If UNBOUND_TYPE != 'CUSTOM' then INSERT_FLAG must be 'N' and UPDATE_FLAG must be 'N'.

Action:

Set UNBOUND_TYPE to another value or set INSERT_FLAG and UPDATE_FLAG to 'Y'.


CDA-01386

CDA-01386 %0!s: Can only set RELATION_SELECTION_REFERENCE if BASE_COLUMN_REFERENCE is set

Cause:

BASE_COLUMN_REFERENCE must be set before RELATION_SELECTION_REFERENCE may be set. RELATION_SELECTION_REFERENCE need only be set if the View or Snapshot is based on one table twice)

Action:

Either leave RELATION_SELECTION_REFERENCE as null or set BASE_COLUMN_REFERENCENCE.


CDA-01389

CDA-01389 %0!s: Window must be in same General Module as Module Component Inclusion

Cause:

If WINDOW_REFERENCE is set then WINDOW_REFERENCE.GENERAL_MODULE_REFERENCE must equal GENERAL_MODULE_REFERENCE.

Action:

Either do not set WINDOW_REFERENCE, or set it to the ID of a Window in the same General Module as this Module Component Inclusion.


CDA-01390

CDA-01390 %0!s: Module Network must be both from and to a General Module

Cause:

If a Navigation Action Item is for navigation to a Module Network, then both the PARENT_MODULE_REFERENCE and the CHILD_MODULE_REFERENCE must refer to General Modules, not PL/SQL Modules.

Action:

Either refer to a different Module Network, or update this Module Network so that conforms to the above rule.


CDA-01391

CDA-01391 %0!s: A Primary Unique Identifier already exists for this Entity

Cause:

Only one Unique Identifier for each Entity may have PRIMARY_UID_FLAG set to 'Y'.

Action:

Set PRIMARY_UID_FLAG to 'N' for this or all other Unique Identifiers for this Entity.


CDA-01392

CDA-01392 %0!s: The Role or User must be in the same Database as the Database Object

Cause:

(ROLE_REFERENCE or DATABASE_USER_REFERENCE).DATABASE_REFERENCE must equal (PLSQL_MODULE_REFERENCE, SEQUENCE_REFERENCE, SNAPSHOT_REFERENCE, TABLE_REFERENCE or VIEW_REFERENCE).DATABASE_USER_REFERENCE.DATABASE_REFERENCE

Action:

Select another Role or User, or another Database Object.


CDA-01393

CDA-01393 %0!s: Cannot update or delete built in Value Types

Cause:

A number of Value Types are classed as 'built in' (property DATATYPE is set) and these may not be updated or deleted.

Action:

Do not update or delete built in Value Types.


CDA-01394

CDA-01394 %0!s: It is not possible to recursively generalise or specialise

Cause:

Generalisation Associations may not set the SUPERTYPE_REFERENCE to the same Type as the SUBTYPE_REFERENCE.

Action:

Set the SUPERTYPE_REFERNCE and the SUBTYPE_REFERENCE to different values.


CDA-01395

CDA-01395 %0!s: May not generalise or specialise different Types

Cause:

The two Abstract Types involved in a Generalisation Association must either both be Value Types or both be Object Types, but not a mixture of the two.

Action:

Set different values for SUPERTYPE_REFERENCE and SUBTYPE_REFERENCE.


CDA-01396

CDA-01396 %0!s: '%1!s..%2!s' is not a valid permutation

Cause:

The full list of valid permutations of MINIMUM_CARDINALITY and MAXIMUM_CARDINALITY is: 0..1, 0..n, 0..*, 1..1, 1..n, 1..*, n..n, n..*

Action:

Set MINIMUM_CARDINALITY and MAXIMUM_CARDINALITY so that the above rule holds.


CDA-01397

CDA-01397 %0!s: Only one role in a pair can have AGGREGATION != \"NONE\"

Cause:

At least one of the ends of the Association Role pair must have AGGREGATION = 'NONE'.

Action:

Set AGGREGATION = 'NONE' for one of the ends of the Association.


CDA-01398

CDA-01398 %0!s: %1!s and %2!s : A Type Operation may not be part of an Arc Constraint

Cause:

Only Type Attributes and Association Roles may be part of an Arc Constraint.

Action:

Either refer to a Uniqueness Constraint or an Other Constraint, alternatively refer to a Type Attribute or an Association Role.


CDA-01399

CDA-01399 %0!s: VERB_NAME cannot be set at both ends of a pair of Association Roles

Cause:

VERB_NAME may only be set on one end of an Association Role pair.

Action:

Set VERB_NAME to null on one Association Role.


CDA-01400

CDA-01400 %0!s: If ORDERED_SET_FLAG is 'Y', then MAXIMUM_CARDINALITY must be > 1

Cause:

ORDERED_SET_FLAG may only be set at the 'many' end of an Association Role.

Action:

Set ORDERED_SET_FLAG to 'N', or MAXIMUM_CARDINALITY to a value greater than 1, or '*'(null).


CDA-01401

CDA-01401 %0!s: If ABSTRACT_TYPE_REFERENCE ('return_type') is set, then RETURN_VALUE_FLAG must = 'Y'

Cause:

While RETURN_VALUE_FLAG may be set if ABSTRACT_TYPE_REFERENCE is not set (indicating that this Operation will return a value that is unspecified as yet), once a return_type is specified RETURN_VALUE_FLAG must be set to 'Y'.

Action:

Set RETURN_VALUE_FLAG to 'Y', or set ABSTRACT_TYPE_REFERENCE to null.


CDA-01402

CDA-01402 %0!s: Either VALUE or IDENTIFIER (or both) must be set

Cause:

Both VALUE or IDENTIFIER may be set, but one MUST be set.

Action:

Set either VALUE or IDENTIFIER or both.


CDA-01404

CDA-01404 %0!s: SOURCE_LEVEL and TARGET_LEVEL must be different

Cause:

The Transformation must be between different levels.

Action:

Set SOURCE_LEVEL and TARGET_LEVEL to different values.


CDA-01405

CDA-01405 %0!s: If DEFAULT_VALUE is set then OVERRIDE_DEFAULT_FLAG must be set to 'Y'

Cause:

Setting DEFAULT_VALUE overrides any inherited value, so must be set

Action:

Set OVERRIDE_DEFAULT_FLAG to 'Y'.


CDA-01406

CDA-01406 %0!s: SCOPE_TABLE_REFERENCE may only be set if DATATYPE = 'REF'

Cause:

A Column can only be scoped by a Table if it has a REF datatype.

Action:

Leave SCOPE_TABLE_REFERENCE as null, or set DATATYPE to 'REF'.


CDA-01407

CDA-01407 %0!s: Object Columns must have OBJECT_TYPE_INCLUSION set

Cause:

OBJECT_TYPE_INCLUSION must be set for Object Columns. Object Columns have ORACLE_TYPE_REFERENCE set.

Action:

Set OBJECT_TYPE_INCLUSION, or leave ORACLE_TYPE_REFERENCE null.


CDA-01408

CDA-01408 %0!s: Object Columns may not have DATATYPE, MAXIMUM_LENGTH or DECIMAL_PLACES set

Cause:

This Column has ORACLE_TYPE_REFERENCE set and therefore must not set DATATYPE, MAXIMUM_LENGTH and DECIMAL_PLACES.

Action:

Set DATATYPE, MAXIMUM_LENGTH and DECIMAL_PLACES all to null.


CDA-01409

CDA-01409 %0!s: Object Columns must not be in Records

Cause:

This Column has ORACLE_TYPE_REFERENCE set and therefore may not be a component in a Record.

Action:

Set ORACLE_TYPE_REFERENCE to null, or place it in a Table, Snapshot or View.


CDA-01412

CDA-01412 %0!s: Scalar Columns must not have OBJECT_TYPE_INCLUSION set

Cause:

This Column has COLUMN_OR_ATTRIBUTE_TYPE = 'SCALAR' and therefore must not have OBJECT_TYPE_INCLUSION set.

Action:

Set OBJECT_TYPE_INCLUSION to null.


CDA-01414

CDA-01414 %0!s: CACHE_FLAG and LOGGING_FLAG may not both be set to 'Y'

Cause:

Either CACHE_FLAG or LOGGING_FLAG or neither may be set, but not both.

Action:

Set either CACHE_FLAG or LOGGING_FLAG or make them both null.


CDA-01415

CDA-01415 %0!s: Column must be SCALAR

Cause:

The discriminator Column must have ORACLE_TYPE_REFERENCE set to null.

Action:

Remove this Column as a discriminator Column.


CDA-01416

CDA-01416 %0!s: CLUSTER_REFERENCE may not be set for Implicit Index Storages

Cause:

Implicit Index Storage may not be set for a Cluster Implementation.

Action:

Use this Implicit Index Storage for a Snapshot or a Table.


CDA-01417

CDA-01417 %0!s: RETURN_TYPE and ORACLE_TYPE_REFERENCE may not both be set

Cause:

Only one of these two properties may be set.

Action:

Set either RETURN_TYPE or ORACLE_TYPE_REFERENCE (or neither).


CDA-01418

CDA-01418 %0!s: SCALAR... and OBJECT... properties are mutually exclusive

Cause:

If COLLECTION_OF = 'SCALAR' then SCALAR_DATATYPE must be set (plus SCALAR_MAXIMUM_LENGTH and SCALAR_DECIMAL_PLACES if appropriate) while ORACLE_OBJECT_TYPE_REFERENCE must not be set. If COLLECTION_OF = 'OBJECT' then SCALAR_DATATYPE must be null while ORACLE_OBJECT_TYPE_REFERENCE must be set.

Action:

Set the properties so the rules outlined in the Cause are met.


CDA-01419

CDA-01419 %0!s: VARRAY COLLECTION_TYPES only must set VARRAY_LIMIT

Cause:

VARRAY_LIMIT must be set if COLLECTION_TYPE = 'VARRAY'. VARRAY_LIMIT must not be set if COLLECTION_TYPE = 'NESTED TABLE'.

Action:

Either leave VARRAY_LIMIT null and set COLLECTION_TYPE = 'NESTED TABLE' or set VARRAY_LIMIT and set COLLECTION_TYPE = 'VARRAY'.


CDA-01420

CDA-01420 %0!s: TYPE BODY Modules must have ORACLE_OBJECT_TYPE_REFERENCE set, and no other PL/SQL Modules may

Cause:

ORACLE_OBJECT_TYPE_REFERENCE must be set if PLSQL_MODULE_TYPE is 'TYPE BODY'. ORACLE_OBJECT_TYPE_REFERENCE must not be set if PLSQL_MODULE_TYPE is not 'TYPE BODY'.

Action:

Either set PLSQL_MODULE_TYPE to 'TYPE BODY' and set ORACLE_OBJECT_TYPE_REFERENCE; or set PLSQL_MODULE_TYPE to another value, and leave ORACLE_OBJECT_TYPE_REFERENCE null.


CDA-01421

CDA-01421 %0!s: May not make a Valid Value for a System Value Type

Cause:

Some of the basic Value Types are created automatically and may not have any Valid Values set for them. They all have SYSTEM_ELEMENT_FLAG set to 'Y'.

Action:

Do not associate a Valid Value with this Value Type.


CDA-01422

CDA-01422 %0!s: An Item Group may not refer to itself

Cause:

ITEM_GROUP_REFERENCE may not refer to itself.

Action:

Set ITEM_GROUP_REFERENCE to null or to refer to another Item Group.


CDA-01423

CDA-01423 %0!s: A Module Detail Table Usage may not refer to itself

Cause:

MTI_REFERENCE may not refer to itself.

Action:

Set MTI_REFERENCE to null or to another Module Detail Table Usage.


CDA-02000

CDA-02000 %0!s: Uniqueness conflict in %1!s with %2!s

Cause:

A uniqueness violation was detected. An element already exists in the specified application system with the same identifying properties.

Action:

Rename the element in violation, or otherwise change its identifying properties so that it avoids the uniqueness conflict.


CDA-02001

CDA-02001 %0!s: %1!s conflicts with another synonym in %2!s

Cause:

A synonym by this name already exists in the specified application system.

Action:

Change the property of the entity for which the synonym is being created (i.e., Name, Short Name or Plural) to avoid the uniqueness conflict.


CDA-02002

CDA-02002 %0!s: Invalid value <%1!s> for property %2!s

Cause:

An invalid value was supplied for the specified property.

Action:

Refer to the documentation for a list of valid values for this property.


CDA-02003

CDA-02003 %0!s: Property %1!s (%2!s) may not be negative

Cause:

An attempt was made to enter a negative value into this property.

Action:

Enter a non-negative value.


CDA-02004

CDA-02004 %0!s: Invalid Datatype value (%1!s)

Cause:

An invalid Datatype was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02005

CDA-02005 %0!s: Value for property %1!s (%2!s) is not in the recommended list

Cause:

The recommended list contains the frequently used values for this property.

Action:

Warning only. No action need be taken. The recommended list can be found in the documentation.


CDA-02006

CDA-02006 %0!s: Invalid Unit Of Frequency value (%1!s)

Cause:

An invalid Unit Of Frequency was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02007

CDA-02007 %0!s: Invalid Frequency Unit value (%1!s)

Cause:

An invalid Frequency Unit was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02009

CDA-02009 %0!s: Invalid Response Needed value (%1!s)

Cause:

An invalid Response Needed value was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02010

CDA-02010 %0!s: Invalid Response Required value (%1!s)

Cause:

An invalid Response Required was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02012

CDA-02012 %0!s: Invalid Time value (%1!s)

Cause:

An invalid Time was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02013

CDA-02013 %0!s: Invalid Attribute Precision value (%1!s)

Cause:

An invalid Attribute Precision was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02014

CDA-02014 %0!s: Invalid Datastore Type (%1!s)

Cause:

An invalid Datastore Type was supplied.

Action:

Refer to the list of valid values specified for this property in the documentation.


CDA-02020

CDA-02020 %0!s: Uniqueness conflict with %1!s in %2!s

Cause:

See the Uniqueness Constraint for this element in the user documentation.

Action:

Rename the new element or modify the new associations such that the documented uniqueness constraint is not violated.


CDA-02022

CDA-02022 %0!s: Either source or destination must be a function

Cause:

A dataflow must connect a function to another element.

Action:

Provide a reference to a function for either the source or the destination.


CDA-02023

CDA-02023 %0!s: The source object must not be the same as the destination object

Cause:

The elements at each end of a dataflow must be different.

Action:

Update the dataflow, specifying distinct source and destination elements.


CDA-02024

CDA-02024 %0!s: Source Function %1!s and destination Function %2!s do not share the same parent

Cause:

If both the source and the destination of the dataflow are functions, then they must both be either root functions or children the same parent.

Action:

Update the dataflow to refer to source and destination functions that are both either root functions or sibling functions.


CDA-02025

CDA-02025 %0!s: Multiple indexes map to %1!s within context %2!s"

Cause:

Each Cluster may have only one Index and this Cluster already has one.

Action:

Do not attempt to add extra Indexes to this Cluster.


CDA-02028

CDA-02028 %0!s: Source function %1!s must not be a Copy function

Cause:

Functions contained in dataflows must not be Copy functions (i.e. they must not refer to a Common function).

Action:

Either update the specified source function to remove the reference to the Common function, or update the dataflow to refer to a different source function.


CDA-02029

CDA-02029 %0!s: Destination function %1!s must not be a Copy function

Cause:

Functions contained in dataflows must not be copy functions (i.e. they must not refer to a Common function).

Action:

Either update the specified destination function to remove the reference to a Common function, or update the dataflow to refer to a different destination function.


CDA-02030

CDA-02030 %0!s: Source %1!s must be connected to the context application system

Cause:

Both the source and the destination elements of a dataflow must be connected to the context application system.

Action:

Connect the specified source element to the context application system.


CDA-02031

CDA-02031 %0!s: Destination %1!s must be connected to the context application system

Cause:

Both the source and the destination elements of a dataflow must be connected to the context application system.

Action:

Connect the specified destination element to the context application system.


CDA-02033

CDA-02033 %0!s: ORACLE6 databases may not have snapshots, PL/SQL Modules or Cursors

Cause:

Version 6 ORACLE databases may not have associated Snapshots or PL/SQL Modules of type Package, Procedure, or Cursor.

Action:

Change the DB_VERSION of the Oracle Database.


CDA-02035

CDA-02035 %0!s: Uniqueness conflict with %1!s in %2!s

Cause:

See the Uniqueness Constraint for this element in the user documentation.

Action:

Rename the new element or modify the new associations such that the documented uniqueness constraint is not violated.


CDA-02042

CDA-02042 %0!s: Sequences cannot have Insert, Update, Delete, Index or Reference privileges

Cause:

Only Select, Grant and Alter (and All) privileges can be granted for Sequences.

Action:

Do not set any other FLAGs to 'Y'.


CDA-02049

CDA-02049 Unable to unlock the Set; it is locked by another user

Cause:

An attempt was made to unlock a user defined set which was locked by a different user.

Action:

Check that the correct user defined set was specified. It is not possible to unlock a set locked by another user. The other user must release the lock before this operation can be performed.


CDA-02050

CDA-02050 Set is not locked

Cause:

An attempt was made to unlock a user defined set which is not locked. This may have happened during a check in operation.

Action:

Check that the correct user defined set has been specified. If this is the result of a check in operation ensure that the target is a locked checked out source set. If necessary, relock the source set and then repeat the operation.


CDA-02051

CDA-02051 Set members are locked by another set

Cause:

An attempt was made to lock a user defined set containing elements already locked in a different set. An object may exist in many user defined sets but it can only be locked in one of these sets.

Action:

Check that the set members are not already contained in another locked user defined set. It will be necessary to unlock these sets before this operation can be completed successfully. It is not advisable to manually unlock a user defined set marked as checked out. The set should be checked back in which will automatically release the lock.


CDA-02052

CDA-02052 Unable to delete a locked Set; unlock the Set before deletion

Cause:

A locked set may not be deleted.

Action:

Unlock the set before attempting to delete it.


CDA-02054

CDA-02054 Created from Database Trigger - %0!s

Cause:

Information Only

Action:

Information Only


CDA-02055

CDA-02055 %0!s: The application system referred to is not the context application system

Cause:

For PUBLIC system privileges, there must be a reference to the context application system.

Action:

Transfer the system privilege to another application system or change the context application system to the one that owns this system privilege.


CDA-02057

CDA-02057 %0!s: Index and foreign key constraint must be for the same Relation Definition

Cause:

The table referred to by this Index is not the same as the table referred to on the foreign key constraint that is referred to as the foreign key for the Index.

Action:

Update the reference to the foreign key. (The other properties are not updateable.)


CDA-02058

CDA-02058 %0!s: Database Type is 'ORACLE', but it is defined in an ANSI Database

Cause:

The Table or View has a Database Type of 'ORACLE', but it is associated with an ANSI Database.

Action:

Either change the Database Type to 'ANSI' or 'ANY', or set the reference to null or the ID of an Oracle Database.


CDA-02060

CDA-02060 %0!s: These cannot be defined against a version 6 ORACLE Database

Cause:

Version 6 of the ORACLE database does not support Datastructure Items. This Datastructure Item is for a Table Definition which is in turn implemented on a version 6 oracle database.

Action:

Associate this Datastructure Item with another Table (or none at all), or change the Database that the Table is implemented upon.


CDA-02063

CDA-02063 %0!s: Parent %1!s is a descendent of this %0!s

Cause:

The parent is also a descendent of this element. This is not allowed in this hierarchy.

Action:

Change the parent so that it is not a sibling of the current element.


CDA-02065

CDA-02065 A %0!s may only be modified via the diagrammers

Cause:

Update, Insert and Delete operations on Diagrams, Diagram Segments, and Diagram Element Usages may only be performed by diagrammers and not via the API.

Action:

Do not attempt this action using the API - use one of the diagrammers.


CDA-02066

CDA-02066 %0!s: %1!s cannot be a parent Application System as it is not empty

Cause:

Application Systems may become parents only when they do not own or share any Elements (except Languages).

Action:

Either choose another Application System to be the parent, or delete any owned Elements and disconnect any shared Elements.


CDA-02067

CDA-02067 %0!s: %1!s cannot be a parent Application System as it has a parent itself

Cause:

Only one level of Application System hierarchy is permitted.

Action:

Either choose another empty Application System to be the parent, or nullify the Parent Reference of the intended parent Application System.


CDA-02068

CDA-02068 %0!s: Cannot have a parent Application System as it is a parent itself

Cause:

Only one level of Application System hierarchy is permitted.

Action:

Nullify the Parent Reference of the child Application Systems


CDA-02069

CDA-02069 %0!s: %1!s is in %2!s, but %3!s is in %4!s

Cause:

When a Column appears in an Index, it must be defined against the same Table as the Index.

Action:

Choose another Column or another Index.


CDA-02070

CDA-02070 %0!s: Uniqueness conflict with %1!s

Cause:

NAME (case sensitive) must be unique across all Type Attributes and Type Operations in the same Object Type.

Action:

Give the Type Attribute a NAME which does not clash.


CDI-23241

CDI-23241: This name is already used by another index. Please enter a unique name.

Cause:

No further information is available.

Action:


CDA-03002

CDA-03002 %0!s: Specified super-type %1!s is currently a sub-type of %0!s

Cause:

A violation in the entity hierarchy was detected.

Action:

Update the entity to refer to a different super-type.


CDA-03004

CDA-03004 %0!s: The referenced %1!s does not exist

Cause:

The element for which the synonym is created does not exist.

Action:

Update the synonym to refer to a valid element.


CDA-03005

CDA-03005 %0!s: A Short Definition must be provided

Cause:

A Short Definition must be provided when there is no reference to a Common function.

Action:

Update the function, either to provide a valid Short Definition or to nullify the reference to a Common function.


CDA-03500

CDA-03500 %0!s: Invalid %1!s reference <%2!s>

Cause:

An invalid reference property was detected.

Action:

Update the specified element, providing a valid reference value for the indicated property.


CDA-03502

CDA-03502 %0!s <%1!s>: An association already exists between triggering %2!s and triggered %3!s

Cause:

A uniqueness constraint violation was detected when associating two elements that are already associated.

Action:

The association already exists, and so no action need be taken.


CDA-03504

CDA-03504 %0!s<%1!s>: Does not exist

Cause:

The ID specified either does not exist or is for an element of the wrong type.

Action:

Either specify the ID of an element of the correct element type, or call the correct function for this ID.


CDA-04000

CDA-04000 %0!s: %1!s is not mandatory

Cause:

It is recommended that only mandatory Attributes be included in Unique Identifier Entries.

Action:

This is a modeling suggestion only. To avoid this warning, make all Attributes mandatory (non-optional) when they are included in a Unique Identifier Entry.


CDA-04001

CDA-04001 %0!s: %1!s is in an arc

Cause:

The specified Relationship is included in an arc. It is recommended that such Relationships be excluded from Unique Identifier Entries, or that all Relationships in the arc be included in the Unique Identifier Entry.

Action:

This message is intended only to alert the user to a possible modeling error.


CDA-04002

CDA-04002 %0!s: The generated plural was too long; defaulting to entity name

Cause:

When generating the plural for an entity name, the standard algorithm produced a plural that exceeded 40 characters, so the plural name defaulted to the entity name.

Action:

No action need be taken. This is an informational message only.


CDA-04003

CDA-04003 %0!s: Name has been truncated to 12 characters

Cause:

Application system names must be 12 characters or less, because the final two characters are used for system purposes. The name was truncated to 12 characters.

Action:

No action need be taken. This is an informational message only.


CDA-04004

CDA-04004 %0!s: Changes in format characteristics have caused this attribute to be dissociated from %1!s

Cause:

An attribute associated with a domain was updated, and new format characteristics were supplied that conflict with those of the domain. As a result, the attribute was dissociated from the domain (i.e. the reference to the domain was reset to NULL).

Action:

No action need be taken. This is an informational message only.


CDA-06000

CDA-06000 Access control violation: %1!s not found or no rights on this application system

Cause:

Either the Application System specified does not exist, or the current user has not been granted access to it.

Action:

Check the Application System, and if correct contact the Repository owner to grant access to your user.


CDA-06002

CDA-06002 Access control violation: %0!s with reference %1!s not found in any application system

Cause:

During access control checks, it was detected that a reference property supplied for an element does not correspond to an element in the Repository instance.

Action:

Ensure that all reference properties provided in the property list are references to valid elements.


CDA-06003

CDA-06003 Access control violation: Element %0!s with reference %1!s is of an unexpected element type (expecting %2!s, found %3!s)

Cause:

Access control checks detected that a supplied reference property corresponded to an element of a type different from that expected.

Action:

Ensure that all reference properties provided in the property list are references to valid elements.


CDA-06004

CDA-06004 Access control violation: %0!s is not owned by context %1!s

Cause:

An access control violation was detected. Operations cannot be performed on elements that are not owned by the context application system.

Action:

Reset the context application system to be the application system that owns the element in question, and then reissue the operation request.


CDA-06005

CDA-06005 Access control violation: %0!s operations are not allowed in the context application system %1!s

Cause:

An access control violation was detected. The user does not have privileges to perform the indicated operation in the context application system.

Action:

Obtain privileges to perform the indicated operation and reissue the operation request.


CDA-06006

CDA-06006 Access control violation: Application system %0!s version %1!s not found or no access rights on this application system

Cause:

Either the specified version of this application system does not exist in this Repository instance, or the user has no privileges to perform operations in it.

Action:

Obtain the necessary privileges on this application system, or correct the application system name and/or version, if these are invalid.


CDA-06007

CDA-06007 Access control violation: Application system %0!s not found or no access rights on this application system

Cause:

Either the specified application system does not exist in this Repository instance, or the user has no privileges to perform operations in it.

Action:

Obtain the necessary privileges on this application system, or correct the application system name, if it is invalid.


CDA-06008

CDA-06008 Access control violation: %0!s is a parent Application and cannot be modified

Cause:

Operations cannot be performed on elements in parent application systems at this time.

Action:

Establish the context application system to be a childless application system.


CDA-06009

CDA-06009 Access control violation: Primary access control element not provided on %0!s of %1!s

Cause:

An operation that was performed on an element required that access privileges be checked for its parent. The reference for the parent of the element was not provided in the property list, and so no access checks could be performed.

Action:

Check that all reference properties provided in the property list are references to valid elements.


CDA-06010

CDA-06010 Access control violation: User has no read access for this application

Cause:

Operations could not be performed on this application system because the user has no read privileges on it.

Action:

Obtain the necessary privileges on this context application system through the Repository Administrator or establish a different application system to be the context application system.


CDA-06011

CDA-06011 Access control violation: Changes cannot be made to a frozen application

Cause:

Changes are not allowed to frozen application systems.

Action:

Unfreeze the application system before attempting to perform operations on its elements.


CDA-06012

CDA-06012 Access control violation: %0!s: Neither entity %1!s nor %2!s is owned by the context application system

Cause:

At least one of the entities that are connected by a relationship must be owned by the context application system.

Action:

Reset the context application system to be the owner of at least one of the entities and reissue the operation request.


CDA-06013

CDA-06013 Access control violation: This operation requires ADMIN privileges on the application system

Cause:

The current user does not have the ADMIN privilege to this Application System, which is required for this operation.

Action:

Obtain ADMIN privilege for this Application System from the Repository owner.


CDA-06014

CDA-06014 Access control violation: Renaming an application system requires ADMIN privileges on all versions

Cause:

To rename a versioned Application System, the user must have ADMIN privilege on all versions of the Application System. The current user does not have this privilege for at least one version.

Action:

Obtain ADMIN privilege for all versions of this Application System from the Repository owner.


CDA-06015

CDA-06015 Access control violation: Application system name %0!s already exists

Cause:

An attempt was made to rename an application system to a name that is already used by an existing application system. This application system may be owned by another user.

Action:

Application system names must be unique within the repository instance.


CDA-06016

CDA-06016 Access control violation: %0!s not a valid Repository user

Cause:

An attempt was made to transfer ownership of a application system to a user that has not been registered as a valid repository user.

Action:

This error will only occur if a user has access 'canceled' while the operation was performed. Reselect a valid user and retry.


CDA-06017

CDA-06017 Access control violation: Only the application system owner can transfer ownership

Cause:

Only the owner of an application system may transfer ownership

Action:

Retry operation as the application system owner


CDA-06018

CDA-06018 copy: Uniqueness checks failed on new element

Cause:

An attempt was made to copy a element that would result in a name clash within the application system.

Action:

Specify a new name or short name in the copy dialogue.


CDA-06019

CDA-06019 Element has been deleted by another user

Cause:

An element being processed has been deleted before the operation could complete.

Action:

Re-query elements and retry the operation


CDA-06021

CDA-06021 copy: A new `Short Name` must be specified for this element-type

Cause:

When the source and destination application systems of copy are the same , a new element short name must be specified.

Action:

Enter a new Short Name for the element in the copy dialogue


CDA-06022

CDA-06022 %0!s: The Name is not unique within application system

Cause:

The specified name was not unique

Action:

Specify a unique name and repeat the operation.


CDA-06023

CDA-06023 %0!s: The Short Name is not unique within application system

Cause:

The specified name was not unique

Action:

Specify a unique name and repeat the operation.


CDA-06024

CDA-06024 %0!s: Another database object exists with this name

Cause:

Database object must be unique in an application system

Action:

Repeat the operation specifying a unique name for the database object.


CDA-06025

CDA-06025 Unable to share %0!s type %1!s; share failed

Cause:

The share operation failed for the this element

Action:

The share operation usually fails because of name uniqueness constraints. The name conflicts have to be resolved before the operation is repeated.


CDA-06026

CDA-06026 Unable to share %0!s type %1!s (non-shareable element); share failed

Cause:

An attempt was made to share a non-shareable element

Action:

This error should not normally occur


CDA-06028

CDA-06028 Cannot unshare - Element is referenced from %0!s - %1!s

Cause:

An attempt to unshare a element has failed because references to that element within the application system exist.

Action:

Remove references before unsharing


CDA-06029

CDA-06029 Unshare failed for %0!s - %1!s

Cause:

Unshare failed. Causes are listed separately

Action:

See individual Actions.


CDA-06030

CDA-06030 Unshare operation failed

Cause:

Unshare of a set of elements has failed.

Action:

The entire operation is rollback, so remedy the cause and retry operation


CDA-06031

CDA-06031 Unable to transfer %0!s type %1!s (non-transferable element); transfer failed

Cause:

An attempt has been made to transfer a non-transferable element

Action:

Elements of this type can not be transferred


CDA-06032

CDA-06032 Function is used (%0!s - %1!s)

Cause:

Transferring a function with usages

Action:

A function cannot be transferred to another application system if the function or any of its children has usages with entities, business units, modules or dataflows.


CDA-06033

CDA-06033 Receiving application system contains function/child (%0!s)

Cause:

The application system that is to receive the function or function hierarchy already contains a function with the same label as one of the functions that you are trying to transfer.

Action:

Resolve the duplicate name and retry.


CDA-06034

CDA-06034 Source or destination of Dataflow (%0!s)

Cause:

The specified dataflow exists between the function being transferred and either an external or datastore object. As functions are not shareable it is not possible to maintain this relationship across application systems.

Action:

Either delete the dataflow before transferring the function or transfer the related external or datastore at the same time. In the latter case, there could be further references which would also need to be resolved.


CDA-06035

CDA-06035 Entity/sub-types not shared by the application system

Cause:

This message is not used in the current release.

Action:


CDA-06036

CDA-06036 Must specify a new name for an element that is already shared into the application system

Cause:

An attempt was made to copy or share an element into an application system where the name is already in use.

Action:

Specify a new name for the element and repeat the operation.


CDA-06037

CDA-06037 Cannot copy elements of type %0!s

Cause:

An attempt was made to copy and element which is not allowed to be copied.

Action:

Refer to the on-line help to determine which elements can be copied. Repeat the operation specifying a valid element to copy.


CDA-06038

CDA-06038 A valid application system must be specified

Cause:

An attempt was made to share, copy or transfer an element without specifying the target application system.

Action:

Repeat the operation specifying a valid target application system to which the user has the appropriate access rights. If necessary, refer to the on-line help for further details on the access rights required to perform the operation.


CDA-06042

CDA-06042 Access right values that are mandatory have not been set

Cause:

The following access right values are mandatory and must be set :- Select, Update, Insert, Delete, Share and Admin privileges Target application system User being granted the privilege, user granting the privilege.

Action:

Ensure all mandatory properties are being set and repeat the operation.


CDA-06043

CDA-06043 Access right values have been set incorrectly

Cause:

This message is no longer used.

Action:


CDA-06044

CDA-06044 Insufficient privileges to remove the application system

Cause:

Delete privilege is required to delete an application system.

Action:

Ask the application owner to grant the delete privilege to the user attempting to perform the Application Delete operation. Then, repeat the operation.


CDA-06045

CDA-06045 Not all the application systems within the hierarchy have been specified

Cause:

All application systems in an application system hierarchy must be deleted together.

Action:

Repeat the operation selecting the entire application hierarchy.


CDA-06046

CDA-06046 Elements have been shared by application systems that are not being removed

Cause:

It is not possible to delete an application system which owns elements shared to other application systems not also marked for delete.

Action:

Either unshare the elements or copy the elements in to the application systems not being deleted.


CDA-06049

CDA-06049 Elements within application systems being removed are currently checked out

Cause:

The application system to be deleted contains elements which are checked out to a working application system.

Action:

This is a warning message. Pressing the OK button will delete the application system and it will not be possible to check in the elements from the working application system.


CDA-06051

CDA-06051 A Repository user already exists for this Oracle user

Cause:

No further information available

Action:

No further information available


CDA-06052

CDA-06052 The Repository username is not unique

Cause:

No further information available

Action:

No further information available


CDA-06053

CDA-06053 Application name specified exceeds the maximum length allowed.

Cause:

An application name has been specified which is longer than 14 characters.

Action:

Repeat the operation specifying a new application name which is 14 characters or less.


CDA-06054

CDA-06054 The Oracle user does not exist

Cause:

No further information available

Action:

No further information available


CDA-06055

CDA-06055 The application system does not exist

Cause:

No further information available

Action:

No further information available


CDA-06056

CDA-06056 The user type is invalid

Cause:

No further information available

Action:

No further information available


CDA-06057

CDA-06057 The access privilege is invalid

Cause:

No further information available

Action:

No further information available


CDA-06058

CDA-06058 The database type is invalid

Cause:

No further information available

Action:

No further information available


CDA-06059

CDA-06059 Access to the application system has not been given

Cause:

No further information available

Action:

No further information available


CDA-06060

CDA-06060 Cannot remove the Repository user that owns the Repository tables

Cause:

No further information available

Action:

No further information available


CDA-06061

CDA-06061 The restore process had to create a unique name for application system %0!s

Cause:

After a successful restore of an application system the restore process found duplicate application system names had been created. This could have occurred if another user was running restore simultaneously and chose the same application system name. The restore process has had to rename the application system to remove the duplicate.

Action:

This is a warning message. No errors have occurred but you may want to rename the restored application.


CDA-06062

CDA-06062 Access control violation: Changes cannot be made. Application is invalid.

Cause:

Application is not complete or has become corrupt.

Action:

Application is no longer valid and should be deleted.


CDA-06064

CDA-06064 No Manager access privileges: Cannot create or modify application systems

Cause:

In order to Create, Update, Delete or Select from an Application System the user must have Manager privilege.

Action:

Obtain Manager privilege for this user from the Repository owner.


CDA-06065

CDA-06065 User %0!s does not have access privileges to the repository

Cause:

You either typed in the wrong database user or you have not been given access to the repository.

Action:

Contact your repository manager and get them to give you access to the repository.


CDA-06066

CDA-06066 Unable to share %0!s type %1!s. Elements may not be shared between different versions of the same application system

Cause:

Sharing an element between different versions of the same application system

Action:

Elements can only be copied between different versions of the same application system


CDA-06067

CDA-06067 Unable to assertain access rights on this element (%0!s) %1!s

Cause:

Force delete could not verify access on this element

Action:

Use the normal 'delete' operation. This element may not be force deleted.


CDA-06068

CDA-06068 Access control violation: %0!s is not shared into %1!s

Cause:

An access control violation was detected. Operations cannot be performed or references made to elements that are not owned or shared into the context application system.

Action:

Share the element into the current application system and then reissue the operation request.


CDA-06069

CDA-06069 User Defined Set %0!s is already checked-out to a Working Application. Repeat operation to confirm

Cause:

An attempt was made to check-out a 'Source Set' from a User Defined Set that has already been checked-out or is a Working Set. The check-out process would overwrite the existing version flags if the operation was to continue.

Action:

Repeat operation to confirm.


CDA-06070

CDA-06070 Error %0!s

Cause:

It was not possible to create all the tables and indexes necessary for the Archive and Restore processes.

Action:

Examine the error stack for further details of the Oracle error which has occurred and consult your Database Administrator.


CDA-06071

CDA-06071 Failed to execute %0!s

Cause:

It was not possible to truncate one or more tables necessary for the Archive and Restore processes.

Action:

Examine the error stack for further details of the Oracle error which has occurred and consult your Database Administrator.


CDA-06072

CDA-06072 Failed to execute %0!s

Cause:

It was not possible to drop all the tables and indexes necessary for the Archive and Restore processes.

Action:

Examine the error stack for further details of the Oracle error which has occurred and consult your Database Administrator.


CDA-06073

CDA-06073 No applications exist for this transaction.

Cause:

No applications were selected for the Archive/Restore process being requested.

Action:

Repeat the operation selecting the applications you wish to Archive/ Restore.


CDA-06075

CDA-06075 Not all members of the Archive Group have been selected. Application: %0!s Group: %1!s has not been selected.

Cause:

When attempting to Restore an application group all members of the application group must be selected.

Action:

Repeat the operation selecting all members of the Application group for restore.


CDA-06076

CDA-06076 Application %0!s was archived from Repository Version %1!s. The current Repository Version is %2!s.

Cause:

It is not possible to Restore an application which was archived in an earlier release of Oracle Designer without first performing an upgrade of the tables used by the Restore process.

Action:

Upgrade the tables used by the Restore process and repeat the operation.


CDA-06077

CDA-06077 One or more applications failed to Restore.

Cause:

It was not possible to restore all the applications selected for restore.

Action:

Examine the error stack for further details of the applications which failed to restore. Correct the errors and repeat the operation.


CDA-06078

CDA-06078 The new name %0!s given for Application %1!s already exists in the repository.

Cause:

An application has been given a new name which already exists in the repository.

Action:

Repeat the operation specifying a new name for the application which does not already exist in the repository.


CDA-06079

CDA-06079 %0!s: This element is locked, shared or read only and cannot be altered.

Cause:

This element or its parent has its LOCKED_FLAG set to 'L', 'R' or 'S' indicating that it is Locked, Read-Only or Shared. This element cannot be deleted or updated while it is locked.

Action:

Unlock or Check-in the locked set, or Unshare it.


CDA-06080

CDA-06080 Application System %0!s has got a %1!s User Defined Set %2!s.

Cause:

There is a locked User Defined Set in the Application System which is checked out.

Action:

Continuing will override the locked status of the User Defined Set. Otherwise this operation will halt.


CDA-06082

CDA-06082 Elements have been shared from application systems that are not being copied

Cause:

One or more application systems have shared elements from applications systems that are not being copied.

Action:

To copy application system between repository with shared elements you have to select the owning application system as well. Select applications systems and try again.


CDA-06083

CDA-06083 Access control violation: Changes cannot be made to a locked application

Cause:

Changes are not allowed to locked application systems.

Action:

Unlock the application system before attempting to perform operations on its elements.


CDA-06084

CDA-06084 Unable to transer entity %0!s. Entity is a subtype of another entity.

Cause:

The entity could not be transferred to a different application because it is a subtype of another entity.

Action:

Either transfer the supertype of this entity, (all its subtypes will also be transferred), or nullify the supertype property of this entity, and repeat the transfer operation.


CDA-06085

CDA-06085 Cannot copy: invalid reference to %! : %!. Please change copy rules.

Cause:

Could not copy element as the action would result in an invalid reference to another repository object.

Action:

Amend the copy rules to include the element pointed to by the invalid reference.


CDA-06086

CDA-06086 Unable to identify type body for Oracle Object Type %0!s

Cause:

An attempt was made to transfer an Oracle Object Type but the transfer utility could not identify the type body applicable to the Oracle Object Type.

Action:

Use the RON to examine the Oracle Object Type and ensure it has a valid type body. Repeat the transfer operation.


CDA-06097

CDA-06097 Invalid Version number

Cause:

The new VERSION number must be an integer between 2 and 999, and must be greater than the latest VERSION number.

Action:

Enter a valid VERSION number.


CDA-06098

CDA-06098 Unable to determine the Repository Owner

Cause:

The utility which takes out Application Exclusive locks needs to determine the owner of your repository. The utility was unable to do so.

Action:

Repeat the operation. If the problems persists contact your Repository Administrator.


CDA-07000

CDA-07000 %0!s is a checked out set. Repeat operation to unlock set.

Cause:

An attempt was made to unlock a set which is currently checked out to a working application system. Unlocking this set will reset the status of the set and all its members from 'CHECKED OUT' and 'LOCKED' to 'UNLOCKED'. It will not then be possible to run the checkin operation on this set to accept the changes from the working application system.

Action:

Repeat the operation to override this warning message and successfully UNLOCK the set.


CDA-07003

CDA-07003 Unable to CheckIn User Defined Set %0s! The members of this User Defined Set are not checked out.

Cause:

Attempting to CheckIn to a user defined set which contains set members which have not been checked out.

Action:

Checkout the set from the Source Application before proceeding with the CheckIn operation.


(Untitled)

CDI-10001 Failed to execute Notepad on smadw.txt.

Cause:

The application notepad.exe. could not be invoked to display the report.

Action:

Make sure that notepad.exe is available in the path.


CDI-10002

CDI-10002 Data schema error: cannot match Language.

Cause:

The default language for Forms, Reports or PLSQL could not be found in the list of languages in this application system.

Action:

Make sure that this application system has the default set of languages defined.


CDI-10003

CDI-10003 Data schema error: cannot match Function.

Cause:

The Function passed as a parameter to the transformer could not be found in the list of Functions queried by the dialog in the 'Start Function' combo box.

Action:

Make sure that the Function has not been deleted before calling the transformer.


CDI-10004

CDI-10004 Not connected to Oracle.

Cause:

The database has become unavailable to the application.

Action:

Restart the database or ensure that a sqlnet listener is running and reconnect.


CDI-10005

CDI-10005 There are no Functions in this application system.
You must define some Functions before running the Application Design Transformer.

Cause:

There are no Functions in this application system.

Action:

You must define some Functions before running the Application Design Transformer.


CDI-10020

CDI-10020 Generated Module name/shortname already exists

Cause:

A Module exists in the application system with either the same name or shortname as the Module which the Application Design Transformer is trying to create.

Action:

Rename or delete the existing Module with the same name/shortname. The offending Module is listed in the transformer report, available by pressing the 'Show Results' button on the transformer dialog.


CDI-10021

CDI-10021 The broadcast service failed to start up.

Other tools will not be notified of any changes you make.

Cause:

No further information available.

Action:


CDI-10030

CDI-10030 No Modules selected for generation of data usages

Cause:

There are no Modules in this application system.

Action:

You must define some Modules before running the Create Default Module Data Usages utility.


CDI-10051

CDI-10051 Not connected to Oracle.

Cause:

The database has become unavailable to the application.

Action:

Restart the database or ensure that a sqlnet listener is running and reconnect.


CDI-10052

CDI-10052 Failed to open activity.

Cause:

No further information available.

Action:


CDI-10053

CDI-10053 There are no tables to reverse engineer.

Cause:

There are no Tables in this application system.

Action:

You must define some Tables before running the Table to Entity refrofit utility.


CDI-10054

CDI-10054 The Entity Name column of row <number> is mandatory and requires a value.

Cause:

The Entity name specified for the Table in the specified row is not defined but is required before running the utility.

Action:

Define an Entity name for the Table in the specified row.


CDI-10055

CDI-10055 Failed to connect.

Please check your database.

Cause:

The database has become unavailable to the application.

Action:

Restart the database or ensure that a sqlnet listener is running and reconnect.


CDI-10056

CDI-10056 The steering domain TABENT_DATATYPE does not include all the possible datatypes for columns.

Cause:

The datatype of a Column is not defined in the mapping table which the utility uses to map a Column's datatype to an Attribute's format.

Action:

Please contact customer support.


CDI-10057

CDI-10057 The Cancel button has been pressed. Are you sure you want to do this?

Cause:

The user pressed the cancel button while the utility was running.

Action:

Press 'Yes' to stop the utility or 'No' to proceed.


CDI-10058

CDI-10058 Unable to register notification service for Table to Entity Retrofit. Other tools will not be notified of any successful retrofit.

Cause:

No further information available.

Action:


CDI-10059

CDI-10059 There are no more tables to retrofit.

Cause:

There are no more Tables defined in the application system which are not already mapped to Entities or already selected in the dialog.

Action:

None.


CDI-11001

CDI-11001 (SQL exececution eror) Could not open input file %1

Cause:

Could not open the specified DDL file for execution

Action:

Check that the specified DDL file exists and is readable


CDI-11010

CDI-11010 (Template expansion error) %1

Cause:

Internal error during template file expansion

Action:

Contact CASE support


CDI-11011

CDI-11011 Could not open output file %1

Cause:

Could not open the specified file for writing

Action:

Check that the specified file can be created and written


CDI-11012

CDI-11012 Could not create journal table for '%1' - no primary key

Cause:

Journalling has been enabled for a table that has no primary key

Action:

Create a primary key for the specified table


CDI-11013

CDI-11013 Cannot modify %1 '%2' in database as it has %3 dependent(s) (%4)

Cause:

Cannot drop or replace an object with dependencies, as dependencies would become invalid. This message is typically issued where an Oracle8 object type has been modified, but cannot be altered in the database without first dropping dependent objects (e.g. object tables based on the modified object type).

Action:

The user must first drop the dependent objects before the specified modification can be performed.


CDI-11014

CDI-11014 %1 '%2' property %3 ('%4') cannot be modified

Cause:

This specified property cannot be altered.

Action:

The object must be dropped and re-generated.


CDI-11015

CDI-11015 %1 '%2' contains too many %3 objects

Cause:

The specified object has too many relationships of a particular kind e.g. a table contains more than one primary key

Action:

Reduce the number of specified relationships


CDI-11016

CDI-11016 of / for type %4

Cause:

Qualifying message appended to other messages as required

Action:

No action


CDI-11017

CDI-11017 %1 '%2' referencing %3 '%4' can only be validated in client

Cause:

A foreign key referencing a view can only be validated in the client.

Action:

Change the Validation property of the foreign key to Client the repository.


CDI-11301

CDI-11301 %1 '%2' is inconsistent with %3 '%4'

Cause:

The related object defintions are inconsistent (e.g. a foreign key column datatype differs from that of the referenced table column)

Action:

Re-generate both objects


CDI-11302

CDI-11302 %1 '%2' contains no %3 objects

Cause:

The specified object has no relationships of a particular kind e.g. a table contains no columns

Action:

Add the specified object relationships


CDI-11304

CDI-11304 %1 '%2' will not be dropped

Cause:

The specified database object is not defined in the repository, however, because of potential data loss, it will not be dropped

Action:

The specified object should either be dropped manually, or the repository should be updated using the design capture utility.


CDI-11305

CDI-11305 %1 '%2' property %3 exceeds maximum length (%4) - Truncated

Cause:

The specified property value is too long and has been truncated

Action:

No action required


CDI-11306

CDI-11306 %1 '%2' not processed because dependent %3 '%4' not processed or does not exist in target database

Cause:

Object processing depends on another object

Action:

Re-capture / re-generate both objects. For generation, if generation of foreign keys is required without generating the target table, then set Server Generator User Preference FK Generation needs to 'one end'.


CDI-11308

CDI-11308 Dependent %1 '%2' (for %3 '%4') is invalid in the database and must be re-generated

Cause:

An object dependency has been changed in the repository. The object that was originally dependent on the object being re-generated is now invalid in the database and will need to be re-generated.

Action:

Re-generate dependent object.


CDI-11309

CDI-11309 Dependent %1 '%2' (for %3 '%4') is being re-generated

Cause:

The object being generated has a dependent object which will also be generated.

Action:

No action required.


CDI-11310

CDI-11310 %1 '%2' has relationships with more than one %3 %4

Cause:

The object has multiple relationships / references of the same type, this is unexpected.

Action:

Verify object relationships


CDI-11311

CDI-11311 %1 '%2' has no relationship with %3 '%4'

Cause:

The two objects have no (foreign key) relationship, this is unexpected.

Action:

Verify object relationships


CDI-11312

CDI-11312 %1 '%2' property %3 is '%4'

Cause:

The object property has an unexpected value

Action:

Verify object property value


CDI-11313

CDI-11313 %1 '%2' property %3 has been set to '%4'

Cause:

The object property has an unexpected value, and has been modified

Action:

No action required


CDI-11314

CDI-11314 %1 '%2' property %3 has not been set

Cause:

The object property is null / missing

Action:

Set the specified property's value


CDI-11315

CDI-11315 in Datawarehouse Application

Cause:

(appended warning) - the error / warning is associated with a Datawarehouse application object

Action:


CDI-11316

CDI-11316 not supported by database

Cause:

(appended warning) - not supported for database type / version

Action:


CDI-11317

CDI-11317 A unique index has been added to enforce the key constraint on table '%1'

Cause:

A primary or unique key must have a unique index defined on same columns as the key. (DB2/MVS) only

Action:

No action required


CDI-15002

CDI-15002 Could not process %1 '%2'

Cause:

The specified object breaks internal Server Generator rules and cannot be processed

Action:

Contact CASE support


CDI-15005

CDI-15005 Datatype %1 not found

Cause:

The specified column datatype, detected during design capture was not recognised

Action:


CDI-15007

CDI-15007 (Oracle error) %1 %2

Cause:

A database error message was issued

Action:

Check DDL file syntax, if this is not possible contact CASE support


CDI-15008

CDI-15008 Could not find ODBC column type %1

Cause:

The specified column datatype, detected during design capture, was not recognised

Action:


CDI-15009

CDI-15009 (ODBC Error) %1 %2

Cause:

An ODBC connection error message was issued

Action:

Contact CASE support


CDI-15012

CDI-15012 unexpected parent (%1) for %2

Cause:

Internal error - invalid parent relationship detected

Action:

Contact CASE support


CDI-15014

CDI-15014 invalid %1 reference ('%2') in %3 '%4'

Cause:

The specified object has an unexpected object relationship

Action:

Check specified object relationship


CDI-15016

CDI-15016 Could not find user '%1' identifier in database

Cause:

Internal error when attempting to read database user id

Action:

Contact CASE support


CDI-15303

CDI-15303 unsupported SQL found in view %1

Cause:

The specified view definition contains unrecognised SQL

Action:


CDI-15304

CDI-15304 ODBC API call failed

Cause:

The ODBC driver does not support necessary functionality

Action:

If possible try using a more up-to-date ODBC driver, else contact CASE support


CDI-15306

CDI-15306 Cannot read ODBC database information

Cause:

The ODBC driver does not support functionality necessary to read database information

Action:

If possible try using a more up-to-date ODBC driver, else contact CASE support


CDI-15312

CDI-15312 Error when fetching %1 '%2' (SQL code %3)

Cause:

Internal error on fetching SQL query results

Action:

Contact CASE support


CDI-15313

CDI-15313 Error when attempting to execute SQL to retrieve %1 '%2'

Cause:

Internal error on executing SQL statement

Action:

Contact CASE support


CDI-15314

CDI-15314 Error when attempting to execute SQL to retrieve %1 list

Cause:

Internal error on executing SQL statement

Action:

Contact CASE support


CDI-15315

CDI-15315 Error when fetching list of %1

Cause:

Internal error on fetching SQL query results

Action:

Contact CASE support


CDI-15316

CDI-15316 invalid %1 reference in %2 '%3' - ignored

Cause:

The specified object has an unexpected object relationship

Action:

No action required


CDI-15317

CDI-15317 invalid %1 reference ('%2') in %3 '%4' - ignored

Cause:

The specified object has an unexpected object relationship

Action:

No action required


CDI-15322

CDI-15322 %1 '%2' - datatype is undefined / not recognised, and has been defaulted

Cause:

The object's datatype property is not recognised. This message is typically issued where the base table or column for a view or snapshot column is invalid or does not exist.

Action:

No action required


CDI-15323

CDI-15323 %1 '%2' already exists in the repository. The tables will be merged if differences are found.

Cause:

A table with same name as specified already exists in the repository. Any columns that exist in the recovered table but not in the repository will be added to the version in the repository.

Action:

No action required


CDI-16002

CDI-16002 Semantic check failure for Check Constraint '%2.%1'

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16003

CDI-16003 Semantic check failure for Column '%2.%1'

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16004

CDI-16004 Semantic check failure for Domain '%1'

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16008

CDI-16008 Semantic check failure for Primary Key %1 in table %2

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16009

CDI-16009 Semantic check failure for Primary Key Component %1 in table %2

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16010

CDI-16010 Semantic check failure for Sequence %1

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16011

CDI-16011 Semantic check failure for Synonym %1

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16012

CDI-16012 Semantic check failure for Table %1

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16013

CDI-16013 Semantic check failure for Trigger %1

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16014

CDI-16014 Semantic check failure for Unique Key %1 in table %2

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16015

CDI-16015 Semantic check failure for Unique Key Component %1 in table %2

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16016

CDI-16016 Semantic check failure for View %1

Cause:

The specified object breaks internal Server Generator rules as defined and cannot be processed

Action:

Check SQL file semantics (including the objects mandatory relationships)


CDI-16018

CDI-16018 COMPUTED BY clause in Column '%1' is not supported

Cause:

The Rdb clause COMPUTED BY is not supported

Action:


CDI-16019

CDI-16019 File not found

Cause:

The file was not found, or is locked for write by another application

Action:

Check file exists and is readable


CDI-16020

CDI-16020 File not readable

Cause:

The file does not contain valid SQL

Action:

Check file is a valid SQL file


CDI-16021

CDI-16021 Syntax Error %1: %2 Expecting keyword %3 to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16022

CDI-16022 Syntax Error %1: %2 Expecting one of the following keywords: %3 to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16023

CDI-16023 Syntax Error %1: %2 Expecting a %3 to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16024

CDI-16024 Syntax Error %1: %2 Expecting an %3 to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16025

CDI-16025 Syntax Error %1: %2 Expecting one of the following: %3 to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16026

CDI-16026 Syntax Error %1: %2 Invalid syntax

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16027

CDI-16027 Syntax Error %1: %2 Unknown datatype

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16028

CDI-16028 Syntax Error %1: %2 Expecting identifier - found comma instead

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16029

CDI-16029 Syntax Error %1: %2 Invalid truth value

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16030

CDI-16030 Syntax Error %1: %2 Invalid general literal

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16031

CDI-16031 Syntax Error %1: %2 Invalid table expression

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16032

CDI-16032 Syntax Error %1: %2 Invalid drop behaviour

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16033

CDI-16033 Syntax Error %1: %2 COMPUTED BY clause not handled to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16034

CDI-16034 Syntax Error %1: %2 Where clause exceeds maximum length

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16035

CDI-16035 Syntax Error %1: %2 PL/SQL block exceeds maximum length

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16036

CDI-16036 Syntax Error %1: %2 Invalid identifier to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16037

CDI-16037 Syntax Error %1: %2 Invalid number

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16038

CDI-16038 Syntax Error %1: %2 Expecting one of the Index with-clause keywords to follow %4

Cause:

Syntax error

Action:

Correct SQL file syntax


CDI-16304

CDI-16304 %1 - statement ignored

Cause:

Specified SQL syntax is not supported

Action:


CDI-16305

CDI-16305 AS SELECT clause not supported

Cause:

The "AS SELECT" clause is not supported

Action:

If possible, try re-defining the View / Snapshot so as to remove the AS SELECT clause


CDI-16306

CDI-16306 Temporary tables not supported

Cause:

SQL Server temporary tables are not supported

Action:


CDI-16307

CDI-16307 Error formatting error message

Cause:

Internal error when formatting error message

Action:

Contact CASE support


CDI-16308

CDI-16308 Invalid Constraint base column '%1.%2'

Cause:

The specified constraint base column is invalid

Action:

Correct SQL file


CDI-16311

CDI-16311 Invalid Index Column '%1.%2'

Cause:

The specified index column is invalid

Action:

Correct SQL file


CDI-16312

CDI-16312 Index '%1' has no valid components

Cause:

The specified index is invalid as it contains no index columns

Action:

Correct SQL file


CDI-16313

CDI-16313 Column '%1' has invalid parent table '%2'

Cause:

The specified column is invalid as it does not have a valid parent table

Action:

Correct SQL file


CDI-16314

CDI-16314 Table '%1' has no valid components

Cause:

The specified table is invalid as it contains no columns

Action:

Correct SQL file


CDI-16315

CDI-16315 Index '%1' has invalid parent table '%2'

Cause:

The specified index is invalid as it does not have a valid parent table

Action:

Correct SQL file


CDI-16316

CDI-16316 Synonym '%1'has invalid parent object '%2'

Cause:

The specified synonym is invalid as it does not have a valid parent object

Action:

Correct SQL file


CDI-16319

CDI-16319 Foreign Key '%1' has invalid reference table '%2'

Cause:

The specified foreign key is invalid as it does not have a valid reference table

Action:

Correct SQL file


CDI-16320

CDI-16320 Foreign Key '%1' reference table '%2' has no Primary Key

Cause:

The specified foreign key is invalid as the reference table has no primary key

Action:

Correct SQL file


CDI-16321

CDI-16321 LIKE clause not supported

Cause:

DB2 "CREATE TABLE LIKE" clause is not supported

Action:


CDI-16322

CDI-16322 Function or Procedure %1 External Library clause not supported

Cause:

(Oracle8) "EXTERNAL LIBRARY" clause is not supported

Action:


CDI-16323

CDI-16323 Database Link %1 not supported

Cause:

Database Link syntax is not supported

Action:


CDI-18004

CDI-18004 Duplicate %1 name '%2'. Table %3 conflicts with table %4

Cause:

Duplicate object name found

Action:

Rename one of the duplicate objects


CDI-18006

CDI-18006 Tablespace '%1' contains no Datafile objects

Cause:

The specified object has no relationships of a particular kind

Action:

Add the specified object relationships


CDI-18007

CDI-18007 Server Generator Internal Error

Cause:

Internal error

Action:

Contact CASE Support


CDI-18306

CDI-18306 Could not process Tablespace 'SYSTEM'

Cause:

The specified object breaks internal Server Generator rules and cannot be processed

Action:

Contact CASE support


CDI-19001

CDI-19001 Re-create Objects

Cause:

Re-create Objects dialog title

Action:


CDI-19002

CDI-19002 The following objects need to be dropped and re-created:

Cause:

Re-create Objects dialog text

Action:


CDI-19003

Cause:

Action:


CDI-19004

CDI-19004 Do you want to:

Cause:

Re-create Objects dialog text

Action:

No action


CDI-19005

CDI-19005 &Execute all DDL statements

Cause:

Re-create Objects dialog radio button text

Action:

No action


CDI-19006

CDI-19006 (including statements which drop the objects listed above)

Cause:

Re-create Objects dialog radio button text

Action:

No action


CDI-19007

CDI-19007 &Do not execute drop statements

Cause:

Re-create Objects dialog radio button text

Action:

No action


CDI-19008

CDI-19008 &Cancel generation operation

Cause:

Re-create Objects dialog radio button text

Action:

No action


CDI-19009

CDI-19009 OK

Cause:

Re-create Objects dialog button text

Action:

No action


CDI-19010

CDI-19010 &Help

Cause:

Re-create Objects dialog button text

Action:

No action


CDI-19011

CDI-19011 DDL Generation Complete

Cause:

Generation Complete dialog title

Action:

No action


CDI-19012

CDI-19012 DDL generation is complete.

Cause:

Generation Complete dialog text

Action:

No action


CDI-19013

CDI-19013 Do you want to view the generated DDL, view the reconcile report or execute the DDL?

Cause:

Generation Complete dialog text

Action:

No action


CDI-19014

CDI-19014 View DDL

Cause:

Generation Complete dialog button text

Action:

No action


CDI-19015

CDI-19015 View Report

Cause:

Generation Complete dialog button text

Action:

No action


CDI-19016

CDI-19016 Execute DDL

Cause:

Generation Complete dialog button text

Action:

No action


CDI-19017

CDI-19017 Cancel

Cause:

Generation Complete dialog button text

Action:

No action


CDI-20000

CDI-20000 You are not connected to Oracle

Cause:

Cannot maintain connection to database. Database or listener has been shutdown.

Action:

Contact Database Administrator.


CDI-20001

CDI-20001 Failed to connect to Oracle

Cause:

Connection details wrong, Database or listener has been shutdown.

Action:

Re-enter details or contact Database Administrator.


CDI-20002

CDI-20002 The selected application system or version is invalid.

Cause:

The most likely cause is insufficient system privileges for the Repository owner while installing or upgrading a Repository.

Action:

Run the following SQL statements:

·grant execute on sys.dbms_pipe to <repos_owner>

·grant execute on sys.dbms_lock to <repos_owner>

From the Repository Administration Utility, recompile invalid objects, then reconcile the grants for the Repository owner and all subordinate users.

If this fails to resolve the problem, contact Oracle Customer Support.


CDI-20003

CDI-20003 Diagram name is invalid.

Cause:

Invalid diagram name used.

Action:


CDI-20004

CDI-20004 There are no diagrams of this type in this application system.

Cause:

This message is for information only.

Action:


CDI-20005

CDI-20005 The diagram is locked by another user. Do you want to open a copy?

Cause:

Another user has locked this diagram.

Action:

Open a copy and save as a new diagram or wait until diagram is unlocked.


CDI-20006

CDI-20006 You do not have the application access rights to create a new diagram in this application system.

Cause:

Insufficient access rights.

Action:

Contact Database Administrator.


CDI-20007

CDI-20007 You do not have the application access rights to modify a diagram and will be unable to save any changes that you might make. Do you still want to open a diagram?

Cause:

Insufficient access rights.

Action:

Contact Database Administrator.


CDI-20008

CDI-20008 You do not have the application access rights to open a diagram in this application system.

Cause:

Insufficient access rights.

Action:

Contact Database Administrator.


CDI-20009

CDI-20009 You do not have the application access rights to save a diagram in this application system.

Cause:

Insufficient access rights.

Action:

Contact Database Administrator.


CDI-20010

CDI-20010 The diagram is locked by another user.

Cause:

Another user has locked this diagram.

Action:

Wait until diagram is unlocked.


CDI-20011

CDI-20011 You do not have the application access rights to delete a diagram from this application system.

Cause:

Insufficient access rights.

Action:

Contact Database Administrator.


CDI-20012

CDI-20012 The diagram is locked by another user.

Cause:

Another user has locked this diagram.

Action:

Wait until diagram is unlocked.


CDI-20013

CDI-20013 Failed to open diagram

Cause:

This message is for information only.

Action:


CDI-20014

CDI-20014 Failed to save diagram

Cause:

This message is for information only.

Action:


CDI-20015

CDI-20015 The Diagram already exists. Do you want to overwrite it?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-20016

CDI-20016 Do you want to delete diagram ""%1""?

Cause:

This message asks the user to confirm that a diagram is to be deleted.

Action:


CDI-20017

CDI-20017 Close the diagram with the same name, or choose a different name before attempting the save as operation.

Cause:

This message gives the user information on how to proceed.

Action:


CDI-20018

CDI-20018 The diagram is checked out or locked. You cannot delete it.

Cause:

Diagram has been checked out or locked using the Repository Object Navigator.

Action:

Investigate why it is Checked out or Locked.


CDI-20019

CDI-20019 The diagram is checked out or locked. You will only be able to save as. Open diagram?

Cause:

Diagram has been checked out or locked using the Repository Object Navigator.

Action:

Investigate why it is Checked out or Locked.


CDI-20020

CDI-20020 The diagram is checked out or locked. Do you want to open a copy?

Cause:

Diagram has been checked out or locked using the Repository Object Navigator.

Action:

Investigate why it is Checked out or Locked.


CDI-20022

CDI-20022 Application System %s is frozen. Do you still want to open it?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-20023

CDI-20023 Application System Frozen. Cannot delete diagrams.

Cause:

This message is for information only.

Action:


CDI-20024

CDI-20024 Application system is frozen. You will be unable to save any changes that you might make. Do you still want to open the diagram?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-20025

CDI-20025 Application System Frozen. Cannot create diagrams.

Cause:

This message is for information only.

Action:


CDI-20026

CDI-20026 Application System Frozen. Cannot save diagrams.

Cause:

This message is for information only.

Action:


CDI-20027

CDI-20027 Application System Frozen. Cannot make changes.

Cause:

This message is for information only.

Action:


CDI-20028

CDI-20028 You do not have the application access rights to modify Multiline text in this application system.

Cause:

Insufficient access rights.

Action:

Contact Database Administrator.


CDI-20029

CDI-20029 Application System %s is locked by a utility. Try again when utility has finished.

Cause:

Utility is been run on application system.

Action:

Wait until utility has finished and try again.


CDI-20030

CDI-20030 Application System %s has status invalid. Please run the analyser from the Repository Administrator Utility. Do you still want to open it?

Cause:

This message is for information, and instructs the user how to proceed.

Action:


CDI-20031

CDI-20031 Application System Locked by a utility. Cannot make changes. Please wait until utility has finished.

Cause:

Utility is been run on application system.

Action:

Wait until utility has finished and try again.


CDI-20032

CDI-20032 Application System has status Invalid . Please run the analyser from the Repository Administrator Utility. Cannot make changes.

Cause:

This message is for information, and instructs the user how to proceed.

Action:


CDI-20033

CDI-20033 Application System locked by a utility. Wait until utility finishes. Cannot open diagrams.

Cause:

Utility is been run on application system.

Action:

Wait until utility has finished and try again.


CDI-20034

CDI-20034 Application System locked by a utility. Wait until utility finishes. Cannot create diagrams.

Cause:

Utility is been run on application system.

Action:

Wait until utility has finished and try again.


CDI-20035

CDI-20035 Application System locked by a utility. Wait until utility finishes. Cannot save diagrams.

Cause:

Utility is been run on application system.

Action:

Wait until utility has finished and try again.


CDI-20036

CDI-20036 Application System locked by a utility. Wait until utility finishes. Cannot delete diagrams.

Cause:

Utility is been run on application system.

Action:

Wait until utility has finished and try again.


CDI-20037

CDI-20037 Failed to open diagnostic trace file.

Cause:

This message is for information only.

Action:


CDI-20038

CDI-20038 An application system with this name already exists.

Cause:

Application System uniqueness violation.

Action:

Change to a different name.


CDI-20039

CDI-20039 This user does not have an installed Repository.

Cause:

Connected not a user that does not have an installed repository.

Action:

Change to a user with a Designer repository installed.


CDI-20101

CDI-20101 No entities to requery.

Cause:

No entities on diagram.

Action:


CDI-20102

CDI-20102 No relationships to requery.

Cause:

No relationships on diagram.

Action:


CDI-20103

CDI-20103 The super-type of entity %1 has changed. Include this entity again.

Cause:

Entity's supertype has changed.

Action:

Requery.


CDI-20104

CDI-20104 The source or destination entity of relationship %1 is not on the diagram. Include the missing entity.

Cause:

Both ends of relationship are not on diagram.

Action:

Include missing entity.


CDI-20105

CDI-20105 Area not big enough for AutoLayout. Select larger area.

Cause:

Insufficient room to layout items.

Action:

Select larger area and retry.


CDI-20113

CDI-20113 Opening an old BETA-1 diagram, will convert to new format.

Cause:

Diagram was saved by Beta V1 diagrammer.

Action:


CDI-20117

CDI-20117 Record has been locked by another user. Try again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20119

CDI-20119 AutoLayout failed to initialize.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20120

CDI-20120 Too many entities selected for AutoLayout. Select fewer entities and try again.

Cause:

Too many items to layout.

Action:

Select fewer items and retry.


CDI-20123

CDI-20123 Delete the current row?

Cause:

This message asks the user to confirm that the current row is to be deleted.

Action:


CDI-20124

CDI-20124 Entity overlaps with one or more other entities on the diagram.

Cause:

Layout rules violated.

Action:

Manually or automatically position entities so they do not overlap.


CDI-20125

CDI-20125 Entity is outside of allowed diagram boundary.

Cause:

Entity position outside diagram dimensions.

Action:

Try again.


CDI-20126

CDI-20126 Recursive relationship can only be created on same side or on two adjoining sides of an entity. Using default points.

Cause:

This message informs the user of the rules concerning recursive relationships, and explains what action will be taken.

Action:


CDI-20127

CDI-20127 Not enough free space to create relationship.

Cause:

Not enough space between entities to create relationship.

Action:

Move entities further apart and retry.


CDI-20128

CDI-20128 Area not big enough for AutoLayout. Select larger area.

Cause:

Insufficient room to layout items.

Action:

Select larger area and retry.


CDI-20129

CDI-20129 No more entities to include on the diagram.

Cause:

All entities in application system are on diagram.

Action:


CDI-20130

CDI-20130 No more relationships to include on the diagram

Cause:

All relationships in application system are on diagram.

Action:


CDI-20131

CDI-20131 Entity %1 has been deleted from the Repository.

Cause:

Entity has been deleted by another user.

Action:

Requery.


CDI-20132

CDI-20132 Relationship must be moved to an entity.

Cause:

Selected white space rather than an entity to move relationship end to.

Action:

Select entity.


CDI-20133

CDI-20133 Entity %1 has become a sub-type of entity %2.

Cause:

Entity has been subtyped.

Action:


CDI-20134

CDI-20134 Entity %1 is no longer a sub-type.

Cause:

Entity has been moved outside supertype entity.

Action:


CDI-20135

CDI-20135 Area is outside of allowed diagram boundary.

Cause:

Trying to access area outside diagram boundary.

Action:

Try again and stay inside diagram extent.


CDI-20139

CDI-20139 Overlapping has occurred during AutoLayout.

Cause:

Layout rules have been violated.

Action:

Manually or automatically layout items that overlap.


CDI-20140

CDI-20140 The entity has been deleted in the Repository. Remove entity from the diagram?

Cause:

Entity has been deleted by another user.

Action:

Requery.


CDI-20141

CDI-20141 The entity has been changed by another user. Requery the entity?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-20142

CDI-20142 Cutting the entity from diagram, its parent entity has changed. Include the entity again.

Cause:

This message is for information, explaining what action is being taken, and explains to the user how to proceed.

Action:


CDI-20143

CDI-20143 Record has been deleted in the repository. Requery the diagram.

Cause:

Entity has been deleted by another user.

Action:

Requery.


CDI-20144

CDI-20144 Record has been changed in the repository. Requery the diagram.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20145

CDI-20145 Enter a valid sequence number.

Cause:

Sequence number is not valid.

Action:

Re-enter.


CDI-20146

CDI-20146 The relationship has been deleted from the Repository. Remove relationship from the diagram?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-20147

CDI-20147 The relationship has been changed by another user. Requery the relationship?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-20148

CDI-20148 Cannot create a relationship here because the entity has been deleted from the Repository. Requery the diagram to remove this entity from the diagram.

Cause:

Entity has been deleted by another user.

Action:

Requery.


CDI-20150

CDI-20150 Failed to load the diagram.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20158

CDI-20158 Entity %1 has been locked in the repository by another user.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20159

CDI-20159 Warning This element is not owned by the current application system thus any changes will be lost if you press OK to this dialog. Pressing Cancel will return you to the dialog and give you the

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20160

CDI-20160 You are no longer connected to Oracle. All unsaved changes will be lost.

Cause:

Cannot maintain connection to database. Database or listener has been shutdown.

Action:

Contact Database Administrator.


CDI-20161

CDI-20161 Some entity positions are invalid. AutoLayout will reposition these entities.

Cause:

This message is for information only, explaining to the user what the effects of AutoLayout will be.

Action:


CDI-20166

CDI-20166 Entity %1 has been deleted from the Repository. Requery and try operation again.

Cause:

Entity has been deleted by another user.

Action:

Requery.


CDI-20167

CDI-20167 Entity %1 has been changed in the repository. Requery and try operation again.

Cause:

Element is not up to date.

Action:

Requery


CDI-20168

CDI-20168 Could not re-layout transferred relationship. Use Edit->Include->Relationships to insert back onto diagram.

Cause:

Layout failed.

Action:

Include relationship.


CDI-20169

CDI-20169 Could not re-layout relationships. Use Edit->Include->Relationships to insert back onto diagram.

Layout failed.

Action:

Include relationship.


CDI-20170

CDI-20170 Could not layout relationships. These will be given default positions.

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-20171

CDI-20171 Layout of included elements failed. These will be given default positions.

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-20172

CDI-20172 Supertypes and/or subtypes are already on the diagram. These may be moved or resized.

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-20173

CDI-20173 Warning - Continuing this edit will sever the link with the domain. Do you want to carry on?

Cause:

This is a warning message that asks the user to decide what action to take.

Action:


CDI-20174

CDI-20174 The property has been changed by another user. Requery the property?

Cause:

Property is not up to date.

Action:

Requery.


CDI-20175

CDI-20175 Please enter a value or press Esc to cancel edit.

Cause:

This message explains to the user what action to take.

Action:


CDI-20176

CDI-20176 Could not autolayout the relationships. These will be given default positions.

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-20177

CDI-20177 No more related entities to include on the diagram

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-20178

CDI-20178 relationship source/destination entities changed. Please requery.

Cause:

Relationship ends have changed.

Action:

Requery.


CDI-20179

CDI-20179 The Name field is mandatory and requires a value

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20195

CDI-20195 Delete the current row?

Cause:

This message asks the user to confirm that the current row is to be deleted.

Action:


CDI-20196

CDI-20196 You have outstanding changes, would you like to save them?

Cause:

You have modified elements.

Action:

Save your changes or cancel them.


CDI-20201

CDI-20201 OLE 2.0 initialization failed. Make sure that the OLE libraries are the correct version.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20202

CDI-20202 Failed to create object. Make sure the object is entered in the system registry.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20203

CDI-20203 Unexpected error while building functions list.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20205

CDI-20205 Function is locked by another user. Try again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20206

CDI-20206 Failed to Query back NUMBER_OF_TIMES_MODIFIED.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20208

CDI-20208 Invalid master function.

Cause:

This message is for information only.

Action:


CDI-20209

CDI-20209 The new object overlaps an existing object on the diagram.

Cause:

Layout rules violated.

Action:

Manually or automatically position elements so they do not overlap.


CDI-20210

CDI-20210 The dataflow must be connected to\na function, datastore or external.

Cause:

Selected white space rather than an node to attach dataflow to.

Action:

Select Node.


CDI-20211

CDI-20211 Invalid list selection.

Cause:

This message is for information only.

Action:


CDI-20212

CDI-20212 Area not big enough for AutoLayout.

Cause:

Insufficient room to layout items.

Action:

Select larger area and retry.


CDI-20213

CDI-20213 The frame size is too small to contain included functions.\n Increase the frame size.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20214

CDI-20214 Failed to open Entity Relationship Diagrammer.

Cause:

Installation incorrect.

Action:

Check that Entity Relationship Diagrammer is installed.


CDI-20215

CDI-20215 Failed to open Function Hierarchy Diagrammer.

Cause:

Installation incorrect.

Action:

Check that Function Hierarchy Diagrammer is installed.


CDI-20216

CDI-20216 Failed to open Matrix Diagrammer.

Cause:

Installation incorrect.

Action:

Check that Matrix Diagrammer is installed.


CDI-20217

CDI-20217 Failed to open Tutorial.

Cause:

Installation incorrect.

Action:

Check that Tutorial is installed.


CDI-20218

CDI-20218 Cannot create a local function outside of the frame function.

Cause:

Functions can only be create in the context of the frame.

Action:

Create function by clicking mouse inside frame function.


CDI-20219

CDI-20219 One end of a dataflow must be connected to a function.

Cause:

Dataflow modeling requires at least 1 end to be connected to a function. E.g. you cannot connect a datastore to another datastore via a dataflow.

Action:


CDI-20220

CDI-20220 One of the fields on the dialog box is empty.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20221

CDI-20221 Element is locked by another user. Try again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20222

CDI-20222 Element is locked by another user. Try again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20223

CDI-20223 Cannot create an external inside the frame function.

Cause:

Externals must be outside frame function.

Action:

Create external by clicking mouse outside frame function.


CDI-20224

CDI-20224 Cannot move an external inside the frame function.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20225

CDI-20225 Failed to populate Element Type List.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20226

CDI-20226 Failed to open Module Network Diagrammer.

Cause:

Installation incorrect.

Action:

Check that Function Network Diagrammer is installed.


CDI-20227

CDI-20227 Failed to open Repository Object Navigator.

Cause:

Installation incorrect.

Action:

Check that Repository Object Navigator is installed.


CDI-20228

CDI-20228 Failed to find a boundary for the frame function in the converted diagram.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20229

CDI-20229 Resizing the frame function will overlap other elements.

Cause:

Layout rules violated.

Action:

Resize frame so it does not overlap or move nodes to make room.


CDI-20230

CDI-20230 Cannot Open Down on function %1.\nThe function has been deleted from the Repository.

Cause:

This message is for information only.

Action:


CDI-20231

CDI-20231 Failed to open Reports.

Cause:

Installation incorrect.

Action:

Check that Reports are installed.


CDI-20232

CDI-20232 Cannot paste function. It exists as a frame function.

Cause:

This message is for information only.

Action:


CDI-20233

CDI-20233 Cannot paste flow. It already exists on diagram.

Cause:

This message is for information only.

Action:


CDI-20234

CDI-20234 Cannot paste flow. Source/Destination nodes not found.

Cause:

This message is for information only.

Action:


CDI-20235

CDI-20235 Do you wish to reparent this function?

Cause:

This message asks the user to decide what action to take.

Action:


CDI-20236

CDI-20236 This element has been deleted by another user.\nRequery the diagram.

Cause:

Element has been deleted by another user.

Action:

Requery


CDI-20237

CDI-20237 This element has been updated by another user.\nRequery the diagram?

Cause:

Element is not up to date.

Action:

Requery


CDI-20238

CDI-20238 This element is locked by another user. Try again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20239

CDI-20239 Failed to lock the element.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20242

CDI-20242 Cannot find object extent for %1, assuming default.

Cause:

This message is for information.

Action:


CDI-20243

CDI-20243 The frame function has been deleted from the Repository by another user.\nDelete the diagram.

Cause:

Element has been deleted by another user.

Action:


CDI-20246

CDI-20246 No more functions to include.

Cause:

All functions are already on diagram.

Action:


CDI-20247

CDI-20247 No more datastores to include.

Cause:

All datastores are already on diagram.

Action:


CDI-20248

CDI-20248 No more global functions to include.

Cause:

All global functions are already on diagram.

Action:


CDI-20249

CDI-20249 No more externals to include.

Cause:

All externals are already on diagram.

Action:


CDI-20250

CDI-20250 No more resolved flows to include.

Cause:

All resolved flows are already on diagram.

Action:


CDI-20251

CDI-20251 No more dataflows to include.

Cause:

All dataflows are already on diagram.

Action:


CDI-20252

CDI-20252 The field has been updated. The updated value will be displayed now.

Cause:

Field is not up to date.

Action:


CDI-20253

CDI-20253 Function ""%1"" is locked by another user.\nTry again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20254

CDI-20254 Datastore ""%1"" is locked by another user.\nTry again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20255

CDI-20255 External ""%1"" is locked by another user.\nTry again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20256

CDI-20256 Dataflow ""%1"" is locked by another user.\nTry again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20257

CDI-20257 Initial Layout failed.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20264

CDI-20264 Opening an old Beta-1 diagram, will convert to new format.

Cause:

Diagram was saved by Beta V1 diagrammer.

Action:


CDI-20265

CDI-20265 Opening an old Pre-Production diagram, will convert to new format.

Cause:

Diagram was saved by pre-production V1 diagrammer.

Action:


CDI-20266

CDI-20266 Warning: This element is not owned by the current application system thus any changes will be lost if you press OK to this dialog. Pressing Cancel will return you to the dialog and give you the

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20267

CDI-20267 You are no longer connected to Oracle.\nAll unsaved changes will be lost while recovery takes place.

Cause:

Cannot maintain connection to database. Database or listener has been shutdown.

Action:

Contact Database Administrator.


CDI-20268

CDI-20268 Failed to load the diagram.

Cause:

Diagram corruption.

Action:

Contact Customer support.


CDI-20269

CDI-20269 Dataflow ""%1"" source/destination ends are not on the diagram.\nThe dataflow will be removed.

Cause:

Dataflow ends are not on diagram.

Action:

Include dataflow ends.


CDI-20270

CDI-20270 No more global flows to include.

Cause:

This message is for information only.

Action:


CDI-20271

CDI-20271 No Functions to requery.

Cause:

This message is for information only.

Action:


CDI-20272

CDI-20272 No Dataflows to requery.

Cause:

This message is for information only.

Action:


CDI-20273

CDI-20273 No Datastores to requery.

Cause:

This message is for information only.

Action:


CDI-20274

CDI-20274 No Externals to requery.

Cause:

This message is for information only.

Action:


CDI-20275

CDI-20275 No Global Functions to requery.

Cause:

This message is for information only.

Action:


CDI-20276

CDI-20276 No Resolved Flows to requery.

Cause:

This message is for information only.

Action:


CDI-20277

CDI-20277 Cannot create a flow to or from a frame function.

Cause:

Selected frame as to/from end of flow.

Action:


CDI-20300

CDI-20300 One of the functions has been deleted by another user. Please requery the diagram.

Cause:

Element has been deleted by another user,

Action:

Requery.


CDI-20301

CDI-20301 One of the functions has been updated by another user. Please requery the diagram.

Cause:

Element is not up to date.

Action:

Requery


CDI-20302

CDI-20302 One of the functions has been locked by another user. Please try later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20304

CDI-20304 This function has been deleted by another user. Please requery the diagram.

Cause:

Element has been deleted by another user,

Action:

Requery.


CDI-20305

CDI-20305 This function has been updated by another user. Requery the function?

Cause:

Element is not up to date.

Action:

Requery


CDI-20306

CDI-20306 Function is locked by another user, please re-try later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20307

CDI-20307 Parent function has been deleted by another user. Please requery the diagram.

Cause:

Element has been deleted by another user,

Action:

Requery.


CDI-20308

CDI-20308 Parent function has been updated by another user. Please requery the diagram.

Cause:

Element is not up to date.

Action:

Requery


CDI-20309

CDI-20309 Parent function is locked by another user. Try again later.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20310

CDI-20310 This diagram is out of date. Requery the diagram?

Cause:

Elements on diagram have changed since last saving diagram.

Action:

Requery or cancel to keep diagram for documentation purposes.


CDI-20315

CDI-20315 Root function %1 not included. Please requery the diagram.

Cause:

Function is out of date.

Action:

Requery.


CDI-20318

CDI-20318 Opening an old Beta-1 diagram, will convert to new format.

Cause:

Diagram was saved by Beta V1 diagrammer.

Action:


CDI-20319

CDI-20319 Text file contains too long a line - aborting read.

Cause:

Lines in file too long.

Action:

Change file.


CDI-20320

CDI-20320 Text file contains too many tabs - aborting read.

Cause:

Too many tabs in file.

Action:

Change file.


CDI-20321

CDI-20321 Opening an old Pre-Production diagram, will convert to new format.

Cause:

Diagram was saved by pre-production V1 diagrammer.

Action:


CDI-20322

CDI-20322 Failure while requerying.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20323

CDI-20323 Failed while requerying function.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20324

CDI-20324 Failure while querying database.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20325

CDI-20325 Unexpected error while building Functions List.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20326

CDI-20326 You are not connected to Oracle.

Cause:

Cannot maintain connection to database. Database or listener has been shutdown.

Action:

Contact Database Administrator.


CDI-20327

CDI-20327 Failed to query back NUMBER_OF_TIMES_MODIFIED.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20328

CDI-20328 Usage: awf20 [<username>/<password>[@<database>]] [/a:<appsysname>,<version>]

Cause:

Command line passed to Function Hierarchy contains unrecognized parameters.

Action:

Change parameters and retry.


CDI-20330

CDI-20330 Failed to open Entity Relationship Diagrammer.

Cause:

Installation incorrect.

Action:

Check that Entity Relationship Diagrammer is installed.


CDI-20331

CDI-20331 Failed to open Matrix Diagrammer.

Cause:

Installation incorrect.

Action:

Check that Matrix Diagrammer is installed.


CDI-20332

CDI-20332 Failed to open Repository Object Navigator

Cause:

Installation incorrect.

Action:

Check that Repository Object Navigator is installed.


CDI-20333

CDI-20333 Failed to open Module Structure Diagrammer.

Cause:

Installation incorrect.

Action:

Check that Module Structure Diagrammer is installed.


CDI-20334

CDI-20334 Failed to open Reports.

Cause:

Installation incorrect.

Action:

Check that Reports are installed.


CDI-20336

CDI-20336 OLE 2.0 initialization failed. Make sure that the OLE libraries are the correct version.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20337

CDI-20337 Failed to create object. Make sure the object is entered in the System Registry.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20339

CDI-20339 Cannot layout diagram

Cause:

This message is for information.

Action:


CDI-20340

CDI-20340 Layout error. Node size is too large to layout the diagram. Please decrease the size of the functions or their separation. Reduce the font size if all text not seen in the functions. Do you want to autoscale the node's size?

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20341

CDI-20341 You are no longer connected to Oracle. All unsaved changes will be lost while recovery takes place.

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-20342

CDI-20342 Cannot delete tree %1 as function %2 is a child of a different function. Requery and try again.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20343

CDI-20343 Cannot delete tree %1 as function %2 is in the tree but is not on the diagram. Requery and try again.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20344

CDI-20344 Cannot delete tree %1 as function %2 is not in the tree. Requery and try again.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20345

CDI-20345 Failed to open text file.

Cause:

This message is for information.

Action:


CDI-20346

CDI-20346 Failed to create Function/Attribute Matrix.

Cause:

This message is for information.

Action:


CDI-20347

CDI-20347 Failed while fetching updated NUMBER_OF_TIMES_MODIFIED

Cause:

Application error.

Action:

Contact Customer support.


CDI-20348

CDI-20348 Some of the selected functions are not root functions.

Cause:

This message is for information.

Action:


CDI-20400

CDI-20400 No row property selected.

Cause:

The user has not selected a row property in the settings dialog

Action:

Select the row tab within the settings dialog and select a property


CDI-20401

CDI-20401 Cannot determine which row or column should be 3 dimensional.

Cause:

This message is for information only.

Action:

Or

CDI-20401 No column property selected.

Cause:

The user has not selected a column property in the settings dialog

Action:

Select the column tab within the settings dialog and select a property


CDI-20402

CDI-20402 No intersection axis property selected.

Cause:

The user has not selected an intersection property in the settings dialog

Action:

Select the intersection tab within the settings dialog and select a property


CDI-20403

CDI-20403 Insufficient memory to run application.

Cause:

PC has run out virtual memory

Action:

Increase the amount of virtual memory using the system properties panel


CDI-20404

CDI-20404 Not a valid matrixable combination against this Repository.

Cause:

The user changed the Repository connection and the matrix combination is not valid against the Repository

Action:

Exit the matrix diagrammer and restart the matrix diagrammer against the target Repository


CDI-20405

CDI-20405 Unable to register notification service

Cause:

This message is for information only.

Action:


CDI-20406

CDI-20406 No row object selected.

Cause:

No matrix row object is selected in the new matrix dialog

Action:

Select a row object and then continue


CDI-20410

CDI-20410 Not a valid date; must be of the following format %1.

Cause:

You have supplied a date that is not in a valid format

Action:

Supply a date in the format shown in the error message and then continue


CDI-20411

CDI-20411 Not a valid number.

Cause:

The value supplied is not a valid number

Action:

Check the value and ensure that you supply a valid number, then continue


CDI-20412

CDI-20412 Cannot reset to previous Properties Palette values.

Cause:

This message is for information only.

Action:


CDI-20413

CDI-20413 Window is not large enough to display micro intersection cells.

Cause:

The current matrix window is too small to display the matrix

Action:

Make the window larger or reduce the amount of data held on the matrix diagram


CDI-20414

CDI-20414 Using Network Notification.

Cause:

This message is for information only.

Action:


CDI-20415

CDI-20415 The element in the selected cell has been deleted by another user.

Cause:

This message is for information only.

Action:


CDI-20416

CDI-20416 The element in the selected cell has been locked by another user.

Cause:

This message is for information only.

Action:


CDI-20417

CDI-20417 The element in the selected cell has been changed by another User. The Properties Palette will requery the Repository.

Cause:

This message is for information only.

Action:


CDI-20418

CDI-20418 There are no %1.

Cause:

This message is for information only.

Action:


CDI-20419

CDI-20419 Failed to open the Repository Object Navigator.

Cause:

This message is for information only.

Action:


CDI-20420

CDI-20420 Failed to open the Process Modeller.

Cause:

This message is for information only.

Action:


CDI-20421

CDI-20421 Failed to open the Entity Relationship Diagrammer.

Cause:

This message is for information only.

Action:


CDI-20422

CDI-20422 Failed to open the Function Hierarchy Diagrammer.

Cause:

This message is for information only.

Action:


CDI-20423

CDI-20423 Failed to open the Dataflow Diagrammer.

Cause:

This message is for information only.

Action:


CDI-20430

CDI-20430 Value must be between %1 and %2.

Cause:

The value supplied was not in the required range

Action:

Supply a value in the range shown in the error message and then continue


CDI-20431

CDI-20431 Field must be greater than zero.

Cause:

The value supplied was not in the required range.

Action:

Supply a value that is greater than zero and continue


CDI-20432

CDI-20432 No intersection object selected.

Cause:

No matrix intersection object is selected in the new matrix dialog

Action:

Select an intersection object


CDI-20433

CDI-20433 Need a Repository connection to open the matrix diagram.

Cause:

Not connected to a Repository

Action:

Use the Change connection option to connect to a Repository


CDI-20434

CDI-20434 Matrix diagram contains data changes which have not been saved to the Repository. Save changes?

Cause:

User exiting/closing the matrix diagram without saving changes

Action:

Save changes


CDI-20435

CDI-20435 Are you sure you want to delete the selected element(s) from the matrix and the Repository?

Cause:

This message asks the user for confirmation.

Action:

Respond to the question in the message.


CDI-20436

CDI-20436 Failed to open the Reports.

Cause:

This message is for information only.

Action:


CDI-20437

CDI-20437 Save text changes.

Cause:

About to exit/close/select another multi line text property without saving current multi line text

Action:

Save changes


CDI-20438

CDI-20438 Unable to open diagram from recently opened diagrams list.

Cause:

Not connected to the correct Repository or diagram has been deleted from the Repository

Action:

Use File->Open to open a matrix diagrams


CDI-20441

CDI-20441 Field contains non-numeric characters.

Cause:

Non-numeric characters are given for a field in which only numeric characters are allowed.

Action:

Check the data and correct it, then continue


CDI-20442

CDI-20442 Unshare selected element(s)?

Cause:

This message is for information only.

Action:


CDI-20443

CDI-20443 Do not have delete privileges on application system %1 cannot unshare.

Cause:

This message is for information only.

Action:


CDI-20444

CDI-20444 Application system %1 is frozen, cannot %2

Cause:

This message is for information only.

Action:


CDI-20445

CDI-20445 Do not have insert privileges on application system %1 cannot share.

Cause:

This message is for information only.

Action:


CDI-20446

CDI-20446 Do not have share privileges on application system %1 cannot share.

Cause:

This message is for information only.

Action:


CDI-20447

CDI-20447 %1 is a parent application system, cannot share.

Cause:

This message is for information only.

Action:


CDI-20448

CDI-20448 Can not unshare owner objects.

Cause:

This message is for information only.

Action:


CDI-20449

CDI-20449 Cannot incremental load from the repository.

Cause:

This message is for information only.

Action:


CDI-20501

CDI-20501 Icon file not found.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20502

CDI-20502 Image file not found.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20503

CDI-20503 Sound file not found.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20504

CDI-20504 Video file not found.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20505

CDI-20505 Configuration file (.CFG) not found.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20506

CDI-20506 Initialization file (.INI) not found.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20507

CDI-20507 Diagram file not found.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20520

CDI-20520 Unable to connect to database.

Cause:

Connection details wrong, Database or listener has been shutdown.

Action:

Re-enter details or contact Database Administrator.


CDI-20521

CDI-20521 Non-existent application system.

Cause:

This message is for information.

Action:


CDI-20522

CDI-20522 Unable to lock data.

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-20523

CDI-20523 The mouse must be within the organization area to carry out this operation.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20524

CDI-20524 The mouse must be within the main process area to carry out this operation.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20525

CDI-20525 Path does not exist.

Cause:

Invalid path specified.

Action:

Change path.


CDI-20526

CDI-20526 Cannot connect to the database.

Cause:

Connection details wrong, Database or listener has been shutdown.

Action:

Re-enter details or contact Database Administrator.


CDI-20527

CDI-20527 Cannot place a diagram element on top of another.

Cause:

This message explains the mistake to the user.

Action:


CDI-20528

CDI-20528 Flows must start at a process step or store.

Cause:

This message explains the mistake to the user.

Action:


CDI-20529

CDI-20529 Flows must end at a process step or store

Cause:

This message explains the mistake to the user.

Action:


CDI-20530

CDI-20530 Unable to create diagram element

Cause:

This message is for information.

Action:


CDI-20531

CDI-20531 Invalid filename.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20532

CDI-20532 A trigger or outcome can only be applied to a process step.

Cause:

This message explains the mistake to the user.

Action:


CDI-20533

CDI-20533 Annotations can only be applied to diagram elements.

Cause:

This message explains the mistake to the user.

Action:


CDI-20534

CDI-20534 Unable to create element on database.

Cause:

This message is for information.

Action:


CDI-20535

CDI-20535 Flows cannot be directly created between two stores.

Cause:

This message explains the mistake to the user.

Action:


CDI-20536

CDI-20536 Unable to animate - no system timers available.

Cause:

This message is for information only.

Action:


CDI-20537

CDI-20537 No edit program specified. Use the 'Options', 'Customize', 'Basic' dialog to specify the program.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20538

CDI-20538 No preview program specified. Use the 'Options', 'Customize', 'Basic' dialog to specify the program.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-20539

CDI-20539 Unable to connect to Oracle.

Cause:

Connection details wrong, Database or listener has been shutdown.

Action:

Re-enter details or contact Database Administrator.


CDI-20540

CDI-20540 Unable to open configuration file.

Cause:

File moved or deleted.

Action:

Check file is at location specified.


CDI-20542

CDI-20542 Diagram elements can only be created within the swimlanes.

Cause:

This message explains the mistake to the user.

Action:


CDI-20543

CDI-20543 Unable to load default bitmap.

Cause:

This message is for information.

Action:


CDI-20544

CDI-20544 Unable to create default bitmap.

Cause:

This message is for information.

Action:


CDI-20545

CDI-20545 Unable to delete from database, cutting element:

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-20546

CDI-20546 Illegal to hide or delete 'Unspecified' organization unit.

Cause:

This message explains the mistake to the user.

Action:


CDI-20547

CDI-20547 Illegal to create a child of 'Unspecified' organization unit.

Cause:

This message explains the mistake to the user.

Action:


CDI-20548

CDI-20548 Unable to find element in query list.

Cause:

This message is for information.

Action:


CDI-20549

CDI-20549 Unable to hide/cut organization due to displayed process steps and/or stores.

Cause:

Process steps and/or stores are displayed in this organization

Action:


CDI-20550

CDI-20550 Cannot move diagram element outside diagram area.

Cause:

This message explains the mistake to the user.

Action:


CDI-20551

CDI-20551 Organization unit has children. Unable to hide/cut:

Cause:

This message explains the mistake to the user.

Action:


CDI-20552

CDI-20552 Cannot move organization unit with children displayed.

Cause:

This message explains the mistake to the user.

Action:


CDI-20553

CDI-20553 Organization unit is at the top of its range.

Cause:

This message explains to the user that the organization unit cannot be moved any further upwards on the diagram, because it is already the first unit in its range.

Action:


CDI-20554

CDI-20554 Organization unit is at the bottom of its range.

Cause:

This message explains to the user that the organization unit cannot be moved any further downwards on the diagram, because it is already the last unit in its range.

Action:


CDI-20555

CDI-20555 Organization unit already has minimum height.

Cause:

This message explains the mistake to the user.

Action:


CDI-20556

CDI-20556 Cannot decrease organization unit height - space occupied.

Cause:

This message explains the mistake to the user.

Action:


CDI-20557

CDI-20557 Unable to include flow.

Cause:

This message is for information only.

Action:


CDI-20558

CDI-20558 Illegal to edit the unspecified organization unit.

Cause:

This message explains the mistake to the user.

Action:


CDI-20559

CDI-20559 This is a copy of a global process step. You cannot edit it.

Cause:

This message is for information only.

Action:


CDI-20560

CDI-20560 The organization unit is not owned by this application. It is illegal to create child elements for it.

Cause:

This message explains the mistake to the user.

Action:


CDI-20561

CDI-20561 Unable to load diagram from recently used list.

Cause:

Diagram in recent file list is not in application system.

Action:


CDI-20562

CDI-20562 Failed to run command:

Cause:

Command is invalid.

Action:

Try running command manually.


CDI-20563

CDI-20563 Illegal to move the unclassified organization unit.

Cause:

This message explains the mistake to the user.

Action:


CDI-20564

CDI-20564 Illegal to move organization unit below unclassified.

Cause:

This message explains the mistake to the user, that you cannot move an organization unit below the unit labeled 'Unclassified' on the diagram.

Action:


CDI-20565

CDI-20565 Process name must be entered.

Cause:

Action:

Enter a Process name and then continue.


CDI-20566

CDI-20566 A name must be entered.

Cause:

Action:

Enter a name and then continue.


CDI-20567

CDI-20567 A short name must be entered.

Cause:

Action:

Enter a short name and then continue.


CDI-20568

CDI-20568 Icon file cannot be found. Load without further messages?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-20569

CDI-20569 Illegal to re-parent organization unit to itself.

Cause:

An organization unit may not be its own parent organization unit.

Action:


CDI-20570

CDI-20570 During multiple element move, cannot place a diagram element on top of another.

Cause:

You cannot move an element on the diagram to be on top of another element.

Action:


CDI-20571

CDI-20571 During multiple element move, cannot move diagram element outside diagram area.

Cause:

You cannot move an element on the diagram to be outside the diagram area.

Action:


CDI-20572

CDI-20572 During multiple element move, cannot move diagram element between Organization Units.

Cause:

When you are moving several elements, you cannot move them all to a new organization unit at the same time.

Action:

If you need to move several elements to a new organization unit, move the elements one at a time.


CDI-20573

CDI-20573 Illegal to have the same elements as both the source and destination of a flow.

Cause:

This message is for information.

Action:


CDI-20574

CDI-20574 Flow source and destination must be different.

Cause:

The same element may not be both the source and the destination of a flow.

Action:


CDI-20575

CDI-20575 Failed to set SQL Trace On.

Cause:

This message is for information.

Action:


CDI-20576

CDI-20576 Default name provided is non-unique. Enter new name.

Cause:

This message is for information.

Action:


CDI-20577

CDI-20577 Failed to write to .INI file.

Cause:

This message is for information.

Action:


CDI-20578

CDI-20578 Failed to write to local .INI file.

Cause:

This message is for information.

Action:


CDI-20579

CDI-20579 Maximum number of characters reached.

Cause:

This message is for information.

Action:


CDI-20580

CDI-20580 Number of characters exceeds: %d bytes.

Cause:

This message is for information.

Action:


CDI-20581

CDI-20581 Error: Organization network found.

Cause:

This message is for information.

Action:


CDI-20582

CDI-20582 Illegal organization reparent. Organization network will be created.

Cause:

This message is for information.

Action:


CDI-20583

CDI-20583 Diagram import failed.

Cause:

This message is for information.

Action:


CDI-20584

CDI-20584 Diagram ID Fixup Failed. Please close diagram and call Customer Support.

Cause:

This message is for information.

Action:


CDI-20585

CDI-20585 A label must be entered.

Cause:

Action:

Enter a label and then continue.


CDI-20586

CDI-20586 A short definition must be entered.

Cause:

Action:

Enter a short definition and then continue.


CDI-20587

CDI-20587 An ID must be entered.

Cause:

Action:

Enter an ID and then continue.


CDI-20588

CDI-20588 Assigning element to Unspecified because the diagram does not contain the correct organization unit for this element:

Cause:

Element has no organization unit.

Action:


CDI-20589

CDI-20589 Node size exceeded maximum. Reduce node to maximum size.

Cause:

This message is for information.

Action:


CDI-20590

CDI-20590 Default icon create failed.

Cause:

This message is for information.

Action:


CDI-20591

CDI-20591 Default icon create error 1.

Cause:

This message is for information.

Action:


CDI-20592

CDI-20592 Default icon create error 2 (%lu).

Cause:

This message is for information.

Action:


CDI-20593

CDI-20593 Default icon create error 3.

Cause:

This message is for information.

Action:


CDI-20594

CDI-20594 Default icon create error 4 (%lu).

Cause:

This message is for information.

Action:


CDI-20595

CDI-20595 Default icon create error 5.

Cause:

This message is for information.

Action:


CDI-20596

CDI-20596 Default icon create error 6.

Cause:

This message is for information.

Action:


CDI-20598

CDI-20598 Unrecoverable error.

Cause:

Application error.

Action:

Contact Customer support.


CDI-20901

CDI-20901 Cannot matrix this combination.

Cause:

Matrix combination selected in the open matrix dialog can be matrixed

Action:

Select a different matrix combination


CDI-20902

CDI-20902 No broadcast notification targets found in the registry.

Cause:

Matrix diagrammer cannot find any diagrammer notification targets in the registry

Action:

Reinstall product set or install entries into the registry from the install process


CDI-20903

CDI-20903 No Text Editors specified in the registry.

Cause:

No text editor entries found in the registry for editing multi-line text

Action:

Use Text Editor dialog, (menu Options->Text Edit Options) to set the text editors


CDI-20904

CDI-20904 Date format registry variables %1 %2 are empty.

Cause:

Product not installed correctly

Action:

Re-install or reload the registry


CDI-20905

CDI-20905 Intersection axis contains an empty cell. Select a different intersection axis property.

Cause:

Property value selected for the intersection axis is empty.

Action:

Invoke Settings dialog and select another property for the intersection axis


CDI-20906

CDI-20906 Cannot load matrix combinations from the repository.

Cause:

Loading a matrix combinations which is not valid.

Action:

Recreate the matrix by using the new and settings dialog.


CDI-20907

CDI-20907 Window is to small to display selected row/column properties, will reduce the number of properties.

Cause:

Selected a large number of properties for the row or column which results in properties not being displayed.

Action:

Use the settings dialog to reduce the number of selected properties


CDI-20908

CDI-20908 Failed to start browser with command: %1

Cause:

Cannot find an HTML browser

Action:

Do one or both of the following:

- Make sure an HTML browser is installed

- Set the HTML browser via the Options->text Editor dialog


CDI-20909

CDI-20909 Error occurred during query.

Cause:

Property palette is unable to query the Repository for information on the selected matrix cell

Action:

Reconnect to the Repository, or restart the matrix diagrammer


CDI-20910

CDI-20910 Number must not be greater than %1 digits

Cause:

The number supplied is not valid

Action:

Supply a number as described in the error message.


CDI-20911

CDI-20911 Failed to load detail

Cause:

Unable to get information from the repository on the row, column or intersection meta element

Action:

Restart the matrix diagrammer


CDI-20912

CDI-20912: Diagram of the wrong type.

Cause:

The user has attempted an illegal operation.

Action:


CDI-20913

CDI-20913: Cannot locate the temporary directory.

Cause:

Action:

Check the setup of your temporary directory.


CDI-20914

CDI-20914: Cannot create a name for a temporary file.

Cause:

Action:

Check that you have write access to the temporary directory.


CDI-21072

CDI-21072 Recovery will lose all OLE embedding, diagram preferences and print legend. Do you wish to continue?

Cause:

Diagram is corrupt.

Action:

Open diagram and re-insert OLE items and print legend and reapply diagram preferences.


CDI-21108

CDI-21108: A set with the same name already exists in this Application. Do you want to create this with another name ?

Cause:

No further information is available.

Action:


CDI-21109

CDI-21109: The value must be in the range %1 to %2

Cause:

No further information is available.

Action:


CDI-21110

CDI-21110: The value of the preference cannot be <null>.

Cause:

No further information is available.

Action:


CDI-21200

CDI-21200 Cannot connect to perform repository administration as a subordinate user.

Cause:

The RAU has detected that the user being connected to is a Subordinate user

Action:

Connect as the Repository owner


CDI-21201

CDI-21201 This user does not have rights to execute the SYS.DBMS_SHARED_POOL package.

To create this package run the DBA admin scripts dbmspool.sql followed by prvtpool.plb as the SYS user, and then grant execute on it to the Repository owner.

Cause:

Action:

Follow the instructions in the message.


CDI-21202

CDI-21202 Unknown object or no access right to pin the object

Cause:

An attempt was made to PIN an OBJECT into that SGA, but the OBJECT could not be found.

Action:

Use the View Object Status dialog to verify that the OBJECT exists. If it does not then you may have to recreate it (for example, Recreate->Packages, if a package was missing). You should consult the Administrators Guide before recreating any objects. If the problem persists contact your Designer support representative.


CDI-21203

CDI-21203 Can't Define User Extended Association type.

Maximum number of User Extended Association Types is 500. (A0 - A499).

Cause:

You have tried to define an Association outside the specified range.

Action:

Re-specify within the range


CDI-21204

CDI-21204 Can't Define User Extended Element type.

Maximum number of User Extended Element Type is 500. (E0 - E499).

Cause:

You have tried to define an Element outside the specified range

Action:

Re-specify within the range


CDI-21206

CDI-21206 Your Repository install is in an inconsistent state.

Please do the following:

·Remove all objects.

·Restart the install operation.

Cause:

Something serious has happened during the install process from which the RAU cannot recover.

You may have got this message as a result of replying - NO to CDI-21205

Action:

Either restart the operation and see if you are allowed to continue from the point of previous failure or perform the actions as specified in the message text.


CDI-21207

CDI-21207 Executable File Not Found.

Cause:

The RAU was making an a call to another executable which it was unable to invoke.

Action:

The two main causes are:

1.Check the RAU Parameters screen to see if any of the Registry variables for EXECUTE_<executable_name>.. are UNDEFINED or spelt incorrectly

2.The executable name is not available on the client, try running it manually from the command line


CDI-21208

CDI-21208 Executable Path Invalid.

Cause:

The RAU was making an a call to another executable which it was unable to invoke.

Action:

Check the RAU Parameters screen to see if any of the Registry variables contain an invalid path reference.


CDI-21209

CDI-21209 Not Enough Memory to run program.

Cause:

The RAU was making an a call to another executable which it was unable to invoke because there was not enough memory on the client.

Action:

Shutdown other applications to free up some memory.

If this does not help try rebooting the client machine.


CDI-21210

CDI-21210 Program already loaded.

Cause:

The RAU was making an a call to another executable which it was unable to invoke because an instance of that executable was already running on the client.

Action:

You will have to shutdown the other instance or retry the operation later.


CDI-21211

CDI-21211 WinExec Failed - Return code

Cause:

The RAU was making an a call to another executable which it was unable to invoke and was not for one of the reasons identified in CDI-21208 to CDI-21210.

Action:

Contact your Designer support representative.


CDI-21212

CDI-21212 Failed to Re-Connect to Repository owner

Cause:

The RAU has tried to invoke another server session which has failed.

Action:

Check that the original server connection is still active.

You may have run out of user processes on the server or you may have a limit to the number of connections allowed. Refer to the your ORACLE database administration guide.


CDI-21213

CDI-21213 The current version of the RAU utility is incompatible with the underlying Repository version.

Cause:

You have connect to a Repository that is of a later version to that supported by the RAU.

Action:

Check that you have connected to the correct Repository owner, or install a later version (compatible) of the RAU.


CDI-21214

CDI-21214 An error has occurred. Please examine the following .lis files:

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21215

CDI-21215 Please ensure that all subordinate users have the correct system privileges

(see Chapter 2 Oracle Designer Installation Guide).

Cause:

This message appears after you have reconciled users.

Action:

Do as specified in the message text.


CDI-21216

CDI-21216 Your Repository upgrade is in an inconsistent state.

Please do the following:

·Drop the current instance.

·Reload your backup.

·Restart the upgrade process from the beginning.

Cause:

Something serious has happened during the upgrade process from which the RAU cannot recover.

You may have got this message as a result of replying NO to CDI-21205

Action:

Either restart the operation and see if you are allowed to continue from the point of previous failure or perform the actions as specified in the message text.


CDI-21220

CDI-21220 Do you want to delete the output?

Cause:

The current operation has produced an output log/data file, which can be removed by the RAU.

Action:

If you wish to remove the file select [YES], otherwise [No] will delete it.


CDI-21221

CDI-21221 Cannot find script file : <file-name>

Cause:

The named file could not be located.

Action:

Check that the registry REPADM20 is correctly defined (using the RAU parameter screen).

Also check to see if the file does exist on your client.


CDI-21222

CDI-21222 Detected "UNDEFINED" parameter variable(s). Please check the parameter definition(s) for: <parameter list>

Cause:

The named parameter(s) have not been defined in the Registry

Action:

Define them in your Registry.


CDI-21223

CDI-21223 User defined reporting meta data exists. Do you want Upgrade to automatically restore them?

Cause:

The operation you are about to perform will remove any user defined reporting metadata, but it will be backed up to some Save tables.

Action:

If you want the RAU to restore them immediately after the operation, select [YES], otherwise you can manually restore them from the RAU->Utilities menu.


CDI-21226

CDI-21226 All Repository Objects will be deleted, Continue ?

Cause:

The operation you are about to perform will completely remove your Repository.

Action:

If you are sure this is what you want then select [YES].

You should also consider taking a back up of the Repository first.


CDI-21227

CDI-21227 WARNING: The following privilege(s) have not been granted directly to this user: <Privilege-List>

You should NOT proceed until these privilege(s) have been granted to this user.

To grant these privilege(s), using SQL*Plus connect as a DBA and type:

GRANT <privilege>[,<privilege>] TO <user>;

You can do this now, and then select [Retry Stage] to continue this process.

Alternatively you can select [Abort] and then retry this process later after these privilege(s) have been granted.

Do NOT select [Skip Stage] as this process will fail.

Cause:

The operation you are about to perform has detected that the respective

Privileges have not been DIRECTLY granted to the user.

Action:

Perform the actions as instructed. Do not continue until you have done so.


CDI-21228

CDI-21228 Warning: About to Delete Repository user: <User-Name>

This user has Access Rights defined against them.

These Access Rights will be Deleted or Transferred to the Repository Owner.

Please confirm Delete operation?

Cause:

The respective subordinate user to be deleted, has ownership or sole access to some applications, so that the applications are not left "dangling" their ownership will be transferred to the Repository owner

Action:

You may first want to transfer ownership of the respective application to someone other the Repository owner (this can be done from the RON).

Only confirm the delete if you are sure that the user should be removed.


CDI-21229

CDI-21229 You must select a valid Oracle User.

Cause:

You have not selected a valid Oracle user from the users list box

Action:


CDI-21230

CDI-21230 You must specify a value for Full User Name.

Cause:

You have not entered a value in the Full User Name edit box

Action:


CDI-21231

CDI-21231 ERROR: File too large.

Cause:

The respective file exceeds the a system defined limitation on the client for MAXIMUM INTERGER size.

Action:

None.


CDI-21234

CDI-21234 WARNING: There are UNCOMMITTED changes. Are you sure you want to CANCEL?

Cause:

A CANCEL operation has been invoked which could result in some loss data that has not been written back to the Repository.

Action:

If you wanted to save the data first select [NO] and [SAVE] first, otherwise select [YES].


CDI-21235

CDI-21235 An error has occurred: RETRY/SKIP/ABORT operation

Cause:

The current process has failed. Usually you should also see a corresponding ORA-<error>.

Action:

You have the opportunity to fix the underlying problem on-line without having to restart or exiting from the current process.

Consult your Oracle Error Message guide for the ORA-<error> ACTIONS to see if the problem can be fixed or contact your Designer support representative for help.

If you think the problem has been fixed then select {RETRY "<"], otherwise [ABORT "^"] and seek further help.

Important Note: You should only [SKIP] if you have been advised to do so by Designer support.


CDI-21236

CDI-21236 IMPORTANT: If you have just imported a table-level backup (not a Full User backup), you should now use the Upgrade option to rebuild the Repository API.

Cause:

This is an informative message which is output following the Import operation, from a backup.

Action:

If you have imported a table-level backup you will need to run the [UPGRADE] option to re-build the API.

Note: CDI-21237 will usually be displayed if the backup version is the same as the current RAU. If you have imported a Full Repository backup ignore this message.


CDI-21237

CDI-21237 WARNING: Your Repository is already up to date.

If you continue the Upgrade process, your API will be rebuilt.

Are you sure you wish to continue?

Cause:

The upgrade has detected that the current Repository version is up to date with that expected by the RAU.

Action:

You may still wish to continue to rebuild the API (for restore of a Table-Level backup).

Otherwise do not continue.


CDI-21238

CDI-21238 Your Repository is in an unknown state.

Please start CONVERSION to try again.

Cause:

Conversion may have failed.

Action:

Follow the instruction in the message.


CDI-21239

CDI-21239 Error While Populating CK_INSTALLED_OBJECTS.

Cause:

You should also see a corresponding ORA-<error>.

Action:

Consult your Oracle Error Message guide for the ORA-<error> ACTIONS to see if the problem can be fixed or contact your Designer support representative for help.


CDI-21240

CDI-21240 Cannot connect as <SYS/SYSTEM>.

Cause:

You have tried to connect as the SYS or SYSTEM user

Action:

This is not permitted.


CDI-21241

CDI-21241 Text type name must be prefixed with "UE".

Cause:

An attempt to create a user defined text type that does not begin with "UE

Action:


CDI-21242

CDI-21242 Cannot read NLS directory for list of translation files

Cause:

(NLS versions only) the directory where the NLS translation files exist cannot be located.

Action:

Check that REPADM20 has correctly been defined in the registry.

Also check that the NLS directory exists under the directory <ORACLE_HOME>\REPADM20


CDI-21243

CDI-21243 Warning: This process will truncate all temporary Repository tables and once started cannot be reversed.

Before proceeding please ensure that no one is accessing the Repository.

Are you sure you wish to continue?

Cause:

Action:

Follow the instructions in the message.


CDI-21244

CDI-21244 : This process has been aborted.

Check the log files for errors.

It may be possible to restart this process.

Cause:

The previous process has failed or the user has aborted it.

Action:

Follow the instructions in the message.


CDA-00101

CDA-00101 %0!s: Cannot delete -- %1!s exist that reference this %2!s

Cause:

The specified element could not be deleted because it is referenced by elements that cannot be cascade deleted.

Action:

Drop the connected elements, or disconnect them from the specified element, before reissuing the operation. If you are using a diagramming tool, the connected elements may not be visible and a consolidate operation may be required.


CDI-21300

CDI-21300 Executable File Not Found

Cause:

Check that Oracle Reports Runtime has been installed in your <ORACLE_HOME>

Action:

Do one of the following:

·Install Oracle Reports Runtime.

·If you have already installed Oracle Reports, invoke Windows Explorer and double-click on the file R30RUN32.EXE under <ORACLE_HOME>\BIN to ensure that Oracle Reports Runtime is working stand-alone.


CDI-21305

CDI-21305 Invalid Number - Parameter not accepted

Cause:

A valid positive number is needed for parameters of type number.

Action:

Supply a valid positive number for the parameter.


CDI-21306

CDI-21306 Application not specified

Cause:

The report must be run in the context of an Application System.

Action:

From the list provided, choose the Application System against which the report is to be run.


CDI-21307

CDI-21307 Not all required parameters have been specified

Cause:

Mandatory parameters must have a value otherwise the report cannot be run.

Action:

Enter a value for the mandatory parameters and try running the report again.


CDI-21308

CDI-21308 Program load failure - return code %1

Cause:

Repository Reports has failed a system command to invoke another executable.

Action:

Turn on the diagnostics and set High-Level and Low-Level tracing on. Look for calls to executables and make sure they exist where they are being called from.


CDI-21309

CDI-21309 Unable to delete file %1

Cause:

Repository Reports has failed to delete the temporary file that was created to pass report parameter values to Oracle Reports Runtime.

Action:

Delete the file from your temp directory.


CDI-21310

CDI-21310 No default printer installed, please install a printer

Cause:

Oracle Reports requires a printer driver to be installed on the machine that you are running the report on.

Action:

Associate a default printer with your computer using the Control Panel.


CDI-21311

CDI-21311 %1 variable not set in Registry key %2

Cause:

Repository Reports could not find a required value from the Registry.

Action:

Check that the variable exists in the Registry under the specified key.


CDI-21312

CDI-21312 Invalid Command Line Parameter %1

Cause:

The command line arguments used to invoke Repository Reports are incorrect.

Action:

Check the help for the correct syntax of the command line arguments for Repository Reports.


CDI-21319

CDI-21319 No match found

Cause:

The search string could not be located in the tree.

Action:

Try entering a different search string.


CDI-21320

CDI-21320 At first report

Cause:

The reverse search has not located the search string in the tree, and has reached the first node in the tree.

Action:

Try entering a different search string.


CDI-21321

CDI-21321 At last report

Cause:

The forward search has not located the search string in the tree, and has reached the last node in the tree.

Action:

Try entering a different search string.


CDI-21322

CDI-21322 Cannot locate temporary directory

Cause:

The temporary directory set under the TEMP or TMP variable does not exist and therefore a temporary file containing report parameter values cannot be created.

Action:

Check that the temporary directory exists on the file system.


CDI-21323

CDI-21323 Cannot create temporary file in directory %1 , return code failure %2

Cause:

The temporary file containing report parameter values cannot be created in the specified directory.

Action:

Check that this directory exists and that you have write privileges.


CDI-21326

CDI-21326 Cannot open report output file %1

Cause:

Cannot open the specified file to check if it is of type PDF or HTML.

Action:

Check that the specified file exists in the given location.


CDI-21327

CDI-21327 Cannot open SQL file %1

Cause:

Archive and Restore of User Defined Meta data has failed. The SQL file cannot be opened for read.

Action:

Check that the SQL file exists in the specified location.


CDI-21329

CDI-21329 Cannot overwrite existing report file %1

Cause:

You have tried to copy a report and overwrite an existing report definition file.

Action:

Check that the report file been overwritten has write privileges.


CDI-21330

CDI-21330 Module Name for report already exists, please specify another.

Cause:

You have tried to create a new report with a non-unique Module Name.

Action:

Specify another value for the Module Name and try again.


CDI-21332

CDI-21332 Registry variable %1 is not set in key %2
Cannot run Reports in this session

Cause:

Repository Reports needs to read this variable in order to find the location of the Reports Runtime executable.

Action:

Check that the variable has been set under the specified key.


CDI-21335

CDI-21335 Get File Attributes failure - return code %1

Cause:

Repository Reports is unable to locate the directory.

Action:

Check that the specified directory exists on the fiel system


CDI-21402

CDI-21402 No sound clip available.

Cause:

This message is for information.

Action:


CDI-21403

CDI-21403 No video clip available.

Cause:

This message is for information.

Action:


CDI-21404

CDI-21404 No execution process string specified.

Cause:

This message is for information.

Action:


CDI-21406

CDI-21406 Differentiate using sub-types?

Cause:

This message is for information.

Action:


CDI-21409

CDI-21409 Do you want to animate all selected process steps?

Cause:

This message is for information.

Action:


CDI-21414

CDI-21414 Unknown keyword %s at line %d (%s).

Cause:

This message is for information.

Action:


CDI-21418

CDI-21418 Data import warning.

Cause:

This message is for information.

Action:


CDI-21419

CDI-21419 Are you sure you want to delete the base process?

Cause:

This message is for information

Action:


CDI-21420

CDI-21420 Unable to delete base process, delete all child processes first.

Cause:

You cannot delete a base process that has child processes.

Action:

If you want to delete the base process, delete or move the child processes first.


CDI-21421

CDI-21421 No matching organization unit (Unspecified).

Cause:

This message is for information.

Action:


CDI-21424

CDI-21424 Warning: This will delete elements from the database. Continue?

Cause:

This message warns the user, and asks them to decide what action to take.

Action:


CDI-21425

CDI-21425 For 3D control change to take effect you need to restart Process Modeler.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21427

CDI-21427 Another user has changed this element. Update diagram copy?

Cause:

Element is not up to date.

Action:

Requery


CDI-21428

CDI-21428 Elements within the diagram have changed. Requery now?

Cause:

Elements are not up to date.

Action:

Requery


CDI-21429

CDI-21429 Element is locked by another user

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-21430

CDI-21430 Another user has deleted elements on this diagram. Requery now?

Cause:

This message is for information, and asks them to decide what action to take.

Action:


CDI-21431

CDI-21431 Diagram up to date. No requery is required.

Cause:

This message is for information only.

Action:


CDI-21432

CDI-21432 One or more elements on this diagram have been updated or deleted. Requery now?

Cause:

This message is for information, and asks them to decide what action to take.

Action:


CDI-21433

CDI-21433 Illegal to edit this organization unit as it is not owned by the current application system.

Cause:

This message explains to the user that you cannot edit an organization unit that is not owned by the current application.

Action:


CDI-21434

CDI-21434 Illegal to edit this store as it is not owned by the current application system.

Cause:

This message explains to the user that you cannot edit a store that is not owned by the current application.

Action:


CDI-21435

CDI-21435 No objects to include.

Cause:

This message is for information only.

Action:


CDI-21436

CDI-21436 No objects to select.

Cause:

This message is for information only.

Action:


CDI-21437

CDI-21437 No elements to requery.

Cause:

This message is for information only.

Action:


CDI-21438

CDI-21438 Some elements may need additional text before the export can proceed. Retrieve it now?

Cause:

This message is for information, and asks them to decide what action to take.

Action:


CDI-21439

CDI-21439 In order to move a node to this position, the diagram size needs to be increased. Do you wish to continue?

Cause:

This message is for information, and asks them to decide what action to take.

Action:


CDI-21440

CDI-21440 For the new toolbar position to take effect you need to restart Process Modeler.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21441

CDI-21441 Cannot cut or copy the Unspecified organization unit.

Cause:

This message explains the mistake to the user.

Action:


CDI-21442

CDI-21442 Cannot paste a flow onto a diagram which does not include the source and destination activities.

Cause:

This message explains the mistake to the user.

Action:


CDI-21443

CDI-21443 Cannot paste a flow onto a diagram on which either the source or destination activities are not visible.

Cause:

This message explains the mistake to the user.

Action:


CDI-21444

CDI-21444 Cannot paste a step or store onto a diagram which does not include the Organization Unit by which it is owned.

Cause:

This message explains the mistake to the user.

Action:


CDI-21446

CDI-21446 Cannot paste an organization unit onto a diagram which does not contain its parent.

Cause:

This message explains the mistake to the user.

Action:


CDI-21447

CDI-21447 Cannot paste an organization unit onto a diagram on which its parent is not visible.

Cause:

This message explains the mistake to the user.

Action:


CDI-21448

CDI-21448 Cannot paste an element which already exists on the diagram.

Cause:

This message explains the mistake to the user.

Action:


CDI-21449

CDI-21449 Cannot paste a step or store onto a diagram which does not have the same base process.

Cause:

This message explains the mistake to the user.

Action:


CDI-21450

CDI-21450 Loop detected during critical path analysis.

Cause:

Critical Path Analysis cannot handle loops in process network.

Action:

Remove loop and try again.


CDI-21452

CDI-21452 Inactive flows in process diagram.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21453

CDI-21453 Load with multimedia?

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21454

CDI-21454 Write base process total time to database?

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21455

CDI-21455 Write CPA information to database?

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21456

CDI-21456 Write changes to database?

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21457

CDI-21457 Element requires requerying before update can occur.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21458

CDI-21458 Remove unused organization units?

Cause:

This message is for information.

Action:


CDI-21459

CDI-21459 Element has been assigned to a different organization unit. Please run requery.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21498

CDI-21498 Usage: bpmod10 [<username>/<password>[@<database>]] [/a:<appsysname>,<version>] [/d:<diagname> ]

Cause:

Called Process Modeler will unrecognized command line argument.

Action:

Change command line and try again.


CDI-21499

CDI-21499 The system cannot calculate the total process time using the time units specified. Please select a larger time unit.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21500

CDI-21500 Process Modeler cannot save a diagram which contains organization units which have hidden child units. Click OK to expand all organization units and save the diagram, or Cancel to abort the Save operation and arrange the diagram manually.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21501

CDI-21501 This diagram was created by an older version of Process Modeler, and certain elements have been removed in order to ensure that the diagram is internally coherent. The elements removed from this diagram are listed below.

Cause:

This message is for information only, explaining to the user what action will be taken.

Action:


CDI-21502

CDI-21502 Value out of range.

Cause:

This message is for information only.

Action:


CDI-21503

CDI-21503 Unable to perform an 'Open Down' operation - the selected step has been deleted from the Repository.

Cause:

This message is for information only.

Action:


CDI-21504

CDI-21504 Triggers/outcomes defined against multiple process steps ignored.

Cause:

This message is for information only.

Action:


CDI-21505

CDI-21505 The base process of this diagram has been deleted, and further changes of the diagram are not possible. Do you wish to close this diagram?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-21506

CDI-21506 Diagram switched to 'Read-Only' mode

Cause:

This message is for information only.

Action:


CDI-21507

CDI-21507: The cache may be invalid. If you do any further operations in this session, the Repository may be invalid.

PLEASE QUIT AND RESTART THE DATABASE DESIGN TRANSFORMER WITHOUT COMMITING YOUR CHANGES.

Cause:

During processing the transformer has encountered a serious problem that it cannot resolve.

Action:

Do not commit any changes, this may result in incorrect data being saved. Exit Oracle Designer completely and restart.


CDI-21508

CDI-21508: An object has been deleted from the database in another session.

PLEASE QUIT AND RESTART THE DATABASE DESIGN TRANSFORMER WITHOUT SAVING THE CHANGES YOU HAVE MADE.

Cause:

The Database Design Transformer has detected an inconsistency in the cache, probably caused by another user deleting an object.

Action:

Do not commit any changes, this may result in incorrect data being saved. Exit Oracle Designer completely and restart.


CDI-21509

CDI-21509: Object generation terminated by the user.

Cause:

You have pressed the cancel button. This is to confirm that you do not wish to commit the unsaved changes to the database.

Action:

Press 'Yes' if you really want to 'Abort' and not commit the changes. Press 'No' if you want to continue with the processing.


CDI-21510

CDI-21510: Warning: Preferences were not written to the database because row in table 'CI_USER_PREFERENCES' was locked by another user.

Cause:

This generally indicates that another user is editing the preferences.

Action:

Exit the Database Designer transformer. Ensure that no users users are currently updating the preferences then try again


CDI-21511

CDI-21511: Warning: Multi-line Text properties were not written to the database because a row in table 'RM_TEXT_LINES' was locked by another user.

Cause:

This generally indicates that another user is editing the multi-line text properties.

Action:

Exit the Database Designer transformer. Ensure that no users users are currently updating the preferences then try again


CDI-21512

CDI-21512: An error has occurred while trying to save this file. Make sure that your disk is not full or write protected or the file path is incorrect.

Cause:

The transformer could not write the operating system file.

Action:

Investigate why the file could not be written and take corrective action.


CDI-21513

CDI-21513: Cannot proceed with the run because you haven't set any Create/Modify options. Set Create/Modify options from the Customize/Run Options Page

Cause:

For the transformer to continue it needs the Create/modify options set.

Action:

Set Create/Modify options in the Customize/Run Options Page


CDI-21515

CDI-21515: The entity and supertype must be mapped.

Cause:

In the 'table mapping' tab you have checked the 'Arc' Check box, indicating that you wish the Sub-Type entity to be implemented using an 'arc' approach. To do this both the entity and its supertype entity must already have been mapped to tables in a previous transformation.

Action:

Run the transformer to map bothe entity and its supertype to tables. Only choose to map to tables on this first run. Do not map columns or keys, that should be done on the second run.


CDI-21516

CDI-21516: The entity does not have a supertype.

Cause:

In the 'table mapping' tab you have checked the 'Arc' Check box, indicating that you wish the Sub-Type entity to be implemented using an 'arc' approach. To do this the entity must have a supertype.

Action:

Check your design. If the entity is not a sub-type you cannot implement the transformation as an arc


CDI-21517

CDI-21517: Property: CONSTRAINT_REFERENCE set to NULL for %1 : %2 ( id = %3 ).

IT MUST BE SET TO A VALID ID.

Cause:

This is an internal error; the message is not normally displayed

Action:

Please contact Customer Support.


CDI-21518

CDI-21518: Property: COLUMN_REFERENCE set to NULL for %1 : %2 ( id = %3 ).

IT MUST BE SET TO A VALID ID.

Cause:

This is an internal error; the message is not normally displayed

Action:

Please contact Customer Support.


CDI-21519

CDI-21519: Property: ATTRIBUTE_REFERENCE set to NULL for %1 : %2 ( id = %3 ).

IT MUST BE SET TO A VALID ID.

Cause:

This is an internal error; the message is not normally displayed

Action:

Please contact Customer Support.


CDI-21520

CDI-21520: Property: DOMAIN_REFERENCE set to NULL for %1 : %2 ( id = %3 ).

IT MUST BE SET TO A VALID ID.

Cause:

This is an internal error; the message is not normally displayed

Action:

Please contact Customer Support.


CDI-21521

CDI-21521: Property: ENTITY_REFERENCE set to NULL for %1 : %2 ( id = %3 ).

IT MUST BE SET TO A VALID ID.

Cause:

This is an internal error; the message is not normally displayed

Action:

Please contact Customer Support.


CDI-21523

CDI-21523: The Unique Identifier should have a value between 10 and 30.

Cause:

The value for the Maximum Identifier Length on the 'Keys' page of the 'Run Options' settings has been set to an invalid value

Action:

Enter a value between 10 and 30


CDI-21524

CDI-21524: Would you like to update the changes you have made to the Settings?

Cause:

You have made changes to the settings on the 'Run Options' tab and then pressed Cancel. This message is asking whether you wish to save these changes or not.

Action:

Press 'Yes' if you want to keep your changes and 'No' if you want to discard the changes.


CDI-21525

CDI-21525: The Settings will not be stored unless the changes in Transformer are commited.

Cause:

You have made changes to the settings on the 'Run Options' tab and have the 'Don't Commit' Button pressed. This message is just reminding you that these changes you made will not be committed until you commit the changes made by the transformer.

Action:

No action


CDI-21526

CDI-21526: The Settings will not be stored until the Run button is pressed.

Cause:

You have made changes to the settings in the 'Run Options' tab. This message is informing you that these changes will not be saved unless you run the transformer.

Action:

No action


CDI-21528

CDI-21528: Are you sure that you wish to abort the generation ?

Cause:

You have pressed the cancel button. This is to confirm that you do not wish to commit the unsaved changes to the database.

Action:

Press 'Yes' if you really want to 'Abort' and not commit the changes. Press 'No' if you want to continue with the processing.


CDI-21529

CDI-21529: There are no entities in %1 (%2), for the Database Design Transformer to analyze.

Cause:

You are trying to run the Database Design Transformer, which transforms entities into tables; but there are no entities in the application system.

Action:

Choose an application system which has some entities or create some entities in the current application system.


CDI-21530

CDI-21530: Error: Preferences could not be read from the database because there is a problem with the table 'CDI_DFLT_USER_PREF_USAGES'.

Cause:

This is an internal error which indicates that there is a problem with your installation.

Action:

Please contact Customer Support.


CDI-21532

CDI-21532: There was a problem in initializing the resources. This could be due to an OCX not being registered correctly.

Cause:

The transformer could not start to run, possibily because an OCX was not registered correctly.

Action:

Check the registry entry


CDI-21533

CDI-21533: Failed to determine implementation type.

Cause:

No furthur information

Action:


CDI-21534

CDI-21534: Pre-production freeze message.

Version information required by the Database Design Transformer could not be found.

To fix this, remove from the registry \\\\HKEY_CURRENT_USER\\Software\\Oracle\\Database Design Transformer.

Cause:

Message not used in Production Release

Action:

No Action

Or

CDI-21534: Version information required by the Database Design Transformer could not be found!

Cause:

The version information required by the Database Design transformer was not found in the registry. This could only happen if the product was incorrectly installed.

Action:

Check your installation


CDI-21535

CDI-21535: Pre-production freeze message.

This version of the Database Design Transformer is not compatible with the previous version.

To fix this, remove from the registry \\\\HKEY_CURRENT_USER\\Software\\Oracle\\Database Design Transformer.

Cause:

Message not used in production release

Action:

No action

Or

CDI-21535: This version of the Database Design Transformer is not compatible with the previous version.

Cause:

The version information held in the registry is not compatable with the version of Database Design transformer that you are attempting to run.

Action:

Check your Installation


CDI-21536

CDI-21536: Failed to Write to the registry.

Cause:

The transformer was unable to write information to the registry.

Action:

Check the validty of your reistry


CDI-21537

CDI-21537: Failed to write to the registry. Please check disk space, on the boot disk (e.g. C:\\).

Cause:

The transformer was unable to write information to the registry. The most likely cause is that there was insufficient space.

Action:

Check that you have not run out of disc space.


CDI-21538

CDI-21538: Failed to write to the registry. The registry is corrupt.

Cause:

The transformer was unable to write information to the registry because the registry has been corrupted.

Action:

Investigate the problem with the registry.


CDI-21539

CDI-21539: Failed to write to the registry. An I/O error occurred.

Cause:

The transformer was unable to write information to the registry

Action:

Investigate the problem with the registry.


CDI-21540

CDI-21540: Failed to load Broadcast Support. The Database Design Transformer will not be able to broadcast.

Cause:

No furthur information.

Action:

No action


CDI-21541

CDI-21541: Are you sure that you wish to abort ?

Cause:

You have pressed the cancel button. This is to confirm that you do not wish to commit the unsaved changes to the database.

Action:

Press 'Yes' if you really want to 'Abort' and not commit the changes. Press 'No' if you want to continue with the processing.

Or

CDI-21541: Internal error code, arguments: [%1], [%2]

Cause:

This is an internal error; the message is not normally displayed

Action:

Please contact Customer Support.


CDI-21542

CDI-21542: Key components cannot be generated for the key %1, as the maximum number of key components for this foreign key has been reached.

Cause:

The number of key components has exceeded 999. the transformer cannot process this number.

Action:

Reduce the number of key components in the key


(Untitled)

CDI-21600 Lock failed: Record has been deleted from the Repository. Consolidate the diagram.

Cause:

Element has been deleted.

Action:

Consolidate diagram.

Or

CDI-21600: A running Generator or Utility has failed.

It is possible that the internal cache is now in an inconsistent state.

You are therefore recommended to close and restart the application.

Cause:

Generator or utility fail.

Action:

Close down tool and restart the application.


(Untitled)

CDI-21601 Lock failed: Record has been locked by another user. Please try again later.

Cause:

Another user has element locked.

Action:

Wait until lock is released.

Or

CDI-21601: Unable to register broadcast notification window

Cause:

No further information available.

Action:


(Untitled)

CDI-21602 Lock failed: Record has been changed by another user. Do you want to re-read the row?

Cause:

Element details displayed are out of date with repository.

Action:

Re-read element details or leave to maintain diagram for documentation purposes.

Or

CDI-21602: Broadcast object initialisation failed

Cause:

No further information available.

Action:


(Untitled)

CDI-21603 Failed to lock element for update.

Cause:

Element could not be locked.

Action:

Check another user does not have a lock on the element.

Or

CDI-21603: Unable to register notification service

Cause:

No further information available.

Action:

-


CDI-21604

CDI-21604 Lock failed: Too many elements with the same ID.

Cause:

Element uniqueness violation.

Action:

Contact customer support.


CDI-21605

CDI-21605 NLS_LANG in ORACLE.INI is not set. Client and server character set must match for conversion to work. Continue?

Cause:

Incorrect installation.

Action:


CDI-21606

CDI-21606 NLS_LANG is not set in the Registry. Client and server character set must match for conversion to work. Continue?

Cause:

Incorrect installation.

Action:


CDI-21607

CDI-21607 Character set on client (%1) is different to the server (%2). This may cause conversion to fail Do you want to continue?

Cause:

This message is for information, and asks the user to decide what action to take.

Action:


CDI-21608

CDI-21608 This Repository was not upgraded from CASE*Designer v1.1. There are no diagrams to convert.

Cause:

Repository is not a CASE*Designer upgraded repository.

Action:


CDI-21609

CDI-21609 There are no CASE*Designer 1.1 diagrams to convert.

Cause:

This message is for information only.

Action:


CDI-21610

CDI-21610 This diagram was saved by a more recent diagrammer. Use the newer product version to view this diagram.

Cause:

Diagram is newer than client software.

Action:

Upgrade client software.


CDI-21611

CDI-21611 Failed to save the diagram. Try File->Save As after closing other applications.

Cause:

This message is for information only.

Action:


CDI-21612

CDI-21612 No room to AutoLayout. Do you want to select a larger layout area?

Cause:

Too small an area to layout selected items.

Action:

Select larger area.


CDI-21613

CDI-21613 Overlapping has occurred during AutoLayout. Try running the utility again with fewer items selected.

Cause:

Too small an area to layout selected items.

Action:

Select larger area.


CDI-21617

CDI-21617 There is not enough space left in the listbox to show all of the functions queried. However, these functions are still being held in memory and can be accessed by using the filter facility to reduce the list of functions to be shown.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21618

CDI-21618 There is still not enough space left in the listbox to show all of the functions you have chosen to view. You must use the filter facility to further reduce the list of functions to be shown in order to find the function(s) you require.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21630

CDI-21630 Element locked by another user

Cause:

Another user has locked this element.

Action:

Wait until element is released and try again.


CDI-21631

CDI-21631 Element modified. Do you want to Requery?

Cause:

Element is not up to date.

Action:

Requery


CDI-21632

CDI-21632 The selected element has been deleted from the Repository

Cause:

Element has been deleted by another user,

Action:

Requery.


CDI-21633

CDI-21633 Are you sure you want to delete the selected element(s) from the diagram and the Repository?

Cause:

This message asks the user to confirm that the selected elements are to be deleted both from the diagram and from the Repository.

Action:


CDI-21634

CDI-21634 One of the functions has been deleted by another user. Please Requery the diagram.

Cause:

Functions have been deleted by another user,

Action:

Requery.


CDI-21635

CDI-21635 One of the functions has been updated by another user. Please Requery the diagram.

Cause:

Functions are not up to date.

Action:

Requery.


CDI-21636

CDI-21636 One of the functions has been locked by another user. Please try later.

Cause:

Another user has locked the functions.

Action:

Wait until functions are released and try again.


CDI-21637

CDI-21637 Failure while querying database.

Cause:

Database failure.

Action:

Check database is still active.


CDI-21638

CDI-21638 Unexpected error while building Functions List.

Cause:

Application error.

Action:

Contact customer support.


CDI-21639

CDI-21639 This Function has been deleted by another user. Please Requery the diagram.

Cause:

Function has been deleted by another user,

Action:

Requery.


CDI-21640

CDI-21640 Function is locked by another user, please re-try later.

Cause:

Another user has locked this function

Action:

Wait until function is released and try again.


CDI-21641

CDI-21641 Failed to query Function Label.

Cause:

Application error.

Action:

Contact Customer Support.


CDI-21642

CDI-21642 Failed to query back NUMBER_OF_TIMES_MODIFIED.

Cause:

Application error.

Action:

Contact Customer Support.


CDI-21644

CDI-21644 Invalid master function.

Cause:

Function's master function has been deleted.

Action:

Requery.


CDI-21645

CDI-21645 All attributes have already been selected.

Cause:

All attributes displayed.

Action:


CDI-21646

CDI-21646 All entities have already been selected.

Cause:

All entities displayed

Action:


CDI-21647

CDI-21647 Delete the current row?

Cause:

This message asks the user to confirm that the current row should be deleted.

Action:


CDI-21660

CDI-21660 Recovery will lose all OLE embedding. Do you wish to continue?

Cause:

Corruption in saved diagram.

Action:

Open diagram and reapply OLE items.


CDI-21661

CDI-21661 This diagram is damaged. Do you want to recover it? Choose Yes to recover (preferred). Choose No to abandon load.

Cause:

Corruption in saved diagram.

Action:


CDI-21662

CDI-21662 The broadcast service failed to start up. Other tools will not be notified of any changes you make.

Cause:

This message is for information only.

Action:


CDI-21663

CDI-21663 No valid elements have been selected for addition to the diagram.

Cause:

Set of elements selected are already on diagram or not valid for diagram.

Action:


CDI-21664

CDI-21664 All the valid elements that have been selected are already on diagram.

Cause:

Set of elements selected are already on diagram or not valid for diagram.

Action:


CDI-21665

CDI-21665 Some of the selected elements have been deleted from the Repository.

Cause:

Elements selected have been deleted by another user.

Action:


CDI-21666

CDI-21666 The diagram needs consolidating. Do you wish to bring it up to date?

Cause:

Some elements on the diagram are not up to date.

Action:

Consolidate diagram.


CDI-21667

CDI-21667 Please select something first.

Cause:

Action needs selection to work.

Action:

Select elements and retry action.


CDI-21668

CDI-21668 Deleted diagram item!

Cause:

Item has been deleted.

Action:


CDI-21669

CDI-21669 You are no longer connected to Oracle. All unsaved changes will be lost while recovery takes place.

Cause:

Cannot maintain connection to database. Database or listener has been shutdown.

Action:

Contact Database Administrator.


CDI-21670

CDI-21670 You have only SELECT access for this application system %1. Many operations will be unavailable.

Cause:

This message is for information only.

Action:


CDI-21671

CDI-21671 You do not have full INSERT/DELETE/UPDATE access for this application system %1. Some operations will be unavailable

Cause:

This message is for information only.

Action:


CDI-21672

CDI-21672 You do not have access to perform any operations on this application system %1.

Cause:

Insufficient database user access rights.

Action:

Contact Database Administrator.


CDI-21673

CDI-21673 You must have INSERT access to %1 to create new elements.

Cause:

Insufficient database user access rights.

Action:

Contact Database Administrator.


CDI-21675

CDI-21675 You cannot add details to this shared element.

Cause:

Element shared for this application system.

Action:


CDI-21676

CDI-21676 Do you want to consolidate the diagram?

Cause:

Diagram is out of date.

Action:

Consolidate diagram.


CDI-21677

CDI-21677 Out of memory Cannot insert new object.

Cause:

System resources exhausted.

Action:

Shutdown some applications and retry.


CDI-21678

CDI-21678 Failed to create object. Make sure the object is entered in the System Registry.

Cause:

Environment problem with OLE item.

Action:

Check registry.


CDI-21679

CDI-21679 Cannot invoke summary information dialog. Report no print legend to Customer Support.

Cause:

Application problem.

Action:

Report no print legend to Customer Support.


CDI-21680

CDI-21680 AutoLayout could not eliminate %1 overlaps.

Cause:

Insufficient room to layout items.

Action:

Select larger area and retry.


CDI-21681

CDI-21681 Maximum limits of AutoLayout reached. Try a larger grid setting or reducing the size of the diagram.

Cause:

Area too large for layout.

Action:

Try a larger grid setting or reducing the size of the diagram.


CDI-21682

CDI-21682 Maximum limits of AutoLayout reached. A grid setting larger than %1 may help.

Cause:

This message is for information, and explains to the user how to proceed.

Action:


CDI-21683

CDI-21683 Help file variable %1 is not set in Registry. Help may not be available.

Cause:

Installation incorrect.

Action:


CDI-21684

CDI-21684 There is nothing to consolidate.

Cause:

This message is for information only.

Action:


CDI-21685

CDI-21685 Failed to delete %1.Do you want to continue deleting the other elements?

Cause:

This message is for information only.

Action:


CDI-21686

CDI-21686 Cannot include elements from a different application system or connection.

Cause:

This message is for information only.

Action:


CDI-21687

CDI-21687 Error saving diagram Discard changes without saving?

Cause:

Application Error.

Action:

Contact Customer support.


CDI-21700

CDI-21700 Check that your PATH contains a valid copy of ""%1"".

Cause:

Incorrect environment.

Action:

Check can run executable and it is in your path.


CDI-21701

CDI-21701 Check that your PATH contains a copy of ""%1"". This file should have been installed but could not be found.

Cause:

Incorrect environment.

Action:


CDI-21702

CDI-21702 The variable ""%1"" is not set in the [%2] section of your Registry. This would indicate the name of a file to be loaded.

Cause:

Incorrect environment.

Action:


CDI-21703

CDI-21703 You are running an earlier version of the server software. Do you wish to continue?

Cause:

The repository is a older than the client software but still compatible.

Action:

Upgrade repository using Repository Administrator Utility.


CDI-21704

CDI-21704 Running incompatible versions of client and server software. Server version should be %3. Current version of server is %1, nearest compatible version on server is %2. Upgrade the server using the Repository Administration Utility.

Cause:

The repository is not compatible with the client software.

Action:

Upgrade repository using Repository Administrator Utility.


CDI-21705

CDI-21705 No server information available. Cannot check that client and server versions are compatible. Cannot continue.

Cause:

Invalid installation. Registry entries missing.

Action:

Check installation.


CDI-21706

CDI-21706 Invalid installation. Cannot retrieve server version. Cannot continue.

Cause:

Repository installation incomplete.

Action:

Check repository installation.


CDI-21707

CDI-21707 Unable to open recent diagram

Cause:

Diagram in recent file list is not in application system.

Action:


CDI-21709

CDI-21709 Cannot run a second instance of this tool.

Cause:

Can only invoke one instance of tool at a time.

Action:


CDI-21711

CDI-21711 Error running tool, status = %2. Command=%1.

Cause:

Tool failed with a system error.

Action:

Correct environment so tool can run.


CDI-21712

CDI-21712 Could not invoke tool. Check path contains ""%1"".

Cause:

No further information available.

Action:


CDI-21713

CDI-21713 Printer setup changed. Changing display.

Cause:

The printer settings page size and/or orientation have been changed that the diagram uses for layout.

Action:


CDI-21721

CDI-21721 No text types available for this type of element.

Cause:

This element type has no text types defined for it.

Action:


CDI-21722

CDI-21722 Text is too long.

Cause:

No further information available.

Action:


CDI-21723

CDI-21723 Cannot load print dialog.

Cause:

No further information available.

Action:


CDI-21724

CDI-21724 Diagram must be saved before editing text

Cause:

Diagram does not exist on repository.

Action:

Save diagram.


CDI-21725

CDI-21725 Failed to load text type from file """"%1"""". External editor changes have been lost.

Cause:

Intermediate file has been deleted externally.

Action:


CDI-21726

CDI-21726 Failed to save text type to file. Cannot use external editor.

Cause:

Cannot save file due to disk full or access rights.

Action:

Check file system.


CDI-21727

CDI-21727 Failed to start editor with command: %1

Cause:

Environment problem.

Action:

Check can manually run command.


CDI-21729

CDI-21729 Variable %1 in the Registry specifies %2. No file found.

Cause:

Installation incorrect.

Action:

Check installation.


CDI-21740

CDI-21740 The incoming notification queue filled while this application was busy. Some notification messages may have been lost.

Cause:

No further information available.

Action:


CDI-21741

CDI-21741 The notification server has been shut down. Notifications are now only being sent to the local desktop.

Cause:

No further information available.

Action:


CDI-21742

CDI-21742 No network notification service has been configured for this Repository instance. A desktop-only notification session has been started.

Cause:

No further information available.

Action:


CDI-22050

CDI-22050: Maximum limits of autolayout reached Try a larger grid setting or reducing the size of the diagram

Cause:

No further information is available.

Action:


CDI-22051

CDI-22051: Autolayout could not eliminate %1 overlaps

Cause:

No further information is available.

Action:


CDI-22052

CDI-22052: Not enough room on diagram to autolayout! Do you want to select an area yourself?

Cause:

No further information is available.

Action:


CDI-22053

CDI-22053: Do you want to consolidate the diagram?

Cause:

No further information is available.

Action:


CDI-22054

CDI-22054: Captured data reverted, This diagram will be removed.

Cause:

You have chosen not to save the results of a Design Capture operation. The diagram will be removed because the objects it is showing no longer exist.

Action:

No further action required


CDI-22055

CDI-22055: Some items have been deleted from the repository, and were removed from the diagram.

Cause:

No further information is available.

Action:


CDI-22056

CDI-22056: The diagram needs consolidating. Choose Edit->Requery All to bring it up to date

Cause:

No further information is available.

Action:


CDI-22057

CDI-22057: You are no longer connected to Oracle All unsaved changes will be lost while recovery takes place

Cause:

No further information is available.

Action:


CDI-22058

CDI-22058: Application is about to die Cannot recover from this

Cause:

This is an internal error from which the Server Modeller cannot recover.

Action:

Restart the Server Modeller


CDI-22059

CDI-22059: Out of memory Cannot create foreign key connector

Cause:

No further information is available.

Action:


CDI-22060

CDI-22060: Out of memory Cannot create new node

Cause:

No further information is available.

Action:


CDI-22061

CDI-22061: Out of memory Cannot insert new object

Cause:

There are not enough system resources to insert the OLE object

Action:

Try closing other applications.


CDI-22062

CDI-22062: There are no foreign keys left to be able to continue!

Cause:

All of the foreign keys being added or removed from an arc were locked by other users, or had been deleted. No updates could be performed.

Action:

If the foreign keys were locked, try repeating the operation later.


CDI-22063

CDI-22063: Failed to create object. Make sure the object is entered in the system registry.

Cause:

The Server Modeller was unable to insert an OLE object.

Action:

Ensure that the OLE server for the object is installed correctly.


CDI-22064

CDI-22064: Foreign key %1 has been deleted from repository Ignore and continue?

Cause:

A foreign key being added to or removed from an arc, no longer exists in the Repository, because another user has deleted it.

Action:

Choose 'OK' to skip the operation on the foreign key. Choose 'Cancel' to to revert your changes and abort the operation.


CDI-22065

CDI-22065: Cannot lock foreign key %1 Ignore and continue?

Cause:

A foreign key being added to or removed from an arc, cannot be locked because it is being edited by another user.

Action:

Choose 'OK' to skip the operation on the foreign key. Choose 'Cancel' to to revert your changes and abort the operation.


CDI-22066

CDI-22066: Foreign Key %1 as been deleted from the repository Remove from the diagram ?

Cause:

No further information is available.

Action:


CDI-22067

CDI-22067: Foreign Key %1 has been updated Do you want to requery it?

Cause:

No further information is available.

Action:


CDI-22068

CDI-22068: Foreign key %1 is in a different arc now Continue changing it anyway?

Cause:

A foreign key being added to or removed from an arc has been found to be in a different arc on the Repository.

Action:

Choose 'Yes' to make the change, regardless of the state of the Repository. Chose 'No' to skip this foreign key. Choose 'Cancel' to revert your changes and abort the operation.


CDI-22069

CDI-22069: This would cause items to overlap, try a new position

Cause:

No further information is available.

Action:


CDI-22070

CDI-22070: Out of memory Cannot include %1

Cause:

No further information is available.

Action:


CDI-22071

CDI-22071: Out of memory Cannot include %1

Cause:

No further information is available.

Action:


CDI-22072

CDI-22072: Failed to autolayout Do you want to accept the default routing?

Cause:

AutoLayout could not position the selected connectors.

Action:

Choose 'Yes' to see the default positioning, or 'No' to remove the connectors.


CDI-22073

CDI-22073: Failed to resize diagram! Do you want to select an area yourself?

Cause:

No further information is available.

Action:


CDI-22074

CDI-22074: Not enough room to autolayout! Do you want to try a different area?

Cause:

No further information is available.

Action:


CDI-22075

CDI-22075: This overlaps other items

Cause:

You attempted to create a diagram element which overlapped an existing diagram element. This functionality is not supported.

Action:

Try creating the diagram element in an empty area of the diagram.


CDI-22076

CDI-22076: Cannot invoke summary information dialog. Report no print legend to Customer Support.

Cause:

The diagram you are currently editing does not have a print legend

Action:

This is an internal error which should be reported to Customer Support.


CDI-22077

CDI-22077: Object Type %1 has been deleted from the repository Remove from the diagram ?

Cause:

No further information is available.

Action:


CDI-22078

CDI-22078: Object Type %1 has been updated Do you want to requery it?

Cause:

No further information is available.

Action:


CDI-22079

CDI-22079: This already has a primary key

Cause:

No further information is available.

Action:


CDI-22080

CDI-22080: Deleted diagram item!

Cause:

During the loading of a diagram, or paste from the clipboard, a diagram item was found, whose references to other diagram items could not be resolved. The diagram item will be removed from the diagram.

Action:

No further action is required.


CDI-22081

CDI-22081: Snapshot %1 has been deleted from the repository Remove from the Diagram ?

Cause:

No further information is available.

Action:


CDI-22082

CDI-22082: Snapshot %1 has been updated Do you want to requery it?

Cause:

No further information is available.

Action:


CDI-22083

CDI-22083: Table %1 has been deleted from the repository Remove from the Diagram ?

Cause:

No further information is available.

Action:


CDI-22084

CDI-22084: Table %1 has been updated Do you want to requery it?

Cause:

No further information is available.

Action:


CDI-22085

CDI-22085: You must perform Requery All before using the Track Associations facilty

Cause:

No further information is available.

Action:


CDI-22086

CDI-22086: Try selecting something first!

Cause:

You have attempted an operation which requires a selection.

Action:

Select something on the diagram before attempting the operation.


CDI-22087

CDI-22087: Not all actions were undone.

Cause:

Not all of the operations performed on the diagram could be undone. The diagram may not appear exactly as expected.

Action:

No further action required.


CDI-22088

CDI-22088: View %1 has been deleted from the repository Remove from the Diagram ?

Cause:

No further information is available.

Action:


CDI-22089

CDI-22089: View %1 has been updated Do you want to requery it?

Cause:

No further information is available.

Action:


CDI-22150

CDI-22150: The object upon which this diagram is based has been deleted from the Repository. The diagram will now close.

Cause:

No further information is available.

Action:


CDI-22151

CDI-22151: This diagram is based on module ""%1"" which no longer exists. Would you like to delete the diagram ?

Cause:

No further information is available.

Action:


CDI-22152

CDI-22152: There are no applicable Foreign Key relationships.

Cause:

No further information is available.

Action:


CDI-22153

CDI-22153: The MD / MCE has been passed an object which is not in the cache, and is therefore unable to diagram it.

Cause:

This is an internal error.

Action:

Save any outstanding changes and then restart the Design Editor.


CDI-22154

CDI-22154: There are no Primary or Foreign Keys available to create a link for a Module Component based on %1. The new Component will be placed after all other Components.

Cause:

No further information is available.

Action:


CDI-22155

CDI-22155: You are about to Delete the current diagram. Are you sure ?

Cause:

No further information is available.

Action:


CDI-22156

CDI-22156: Only an immediate Lookup, Sub-query or Single Row SQL Aggregate usage of a Base usage can be used to create a Master-Detail Relationship.

Cause:

It is not possible to create a new Base Table usage from a non-base table usage other than one directly linked to an existing Base Table usage.

Action:


CDI-22157

CDI-22157: The current diagram has been deleted from the repository. The diagram will now close.

Cause:

No further information is available.

Action:


CDI-22158

CDI-22158: Failed to create object. Make sure the object is entered in the system registry.

Cause:

No further information is available.

Action:


CDI-22159

CDI-22159: OLE 2.0 initialization failed. Make sure that the OLE libraries are the correct version.

Cause:

No further information is available.

Action:


CDI-22160

CDI-22160: Generation completed Successfully.

Cause:

No further information is available.

Action:


CDI-22161

CDI-22161: A problem occurred during Generation.

Cause:

No further information is available.

Action:


CDI-22200

CDI-22200: An unspecified error has occurred.

Cause:

This message is used for development purposes only.

Action:


CDI-22201

CDI-22201: Invalid font name.

Cause:

The cause may be one of the following:

1.Failure to initialize a font selected from the preferences dialog for Logic Editor options.

2. Failed to read a font name from the Registry when initalizing the Logic Editor preferences.

Action:

1. Select a font from the drop-down list, or retype the font name.

2. Check the registry for corrupt data.


CDI-22202

CDI-22202: An error occurred trying to store text.

Cause:

The text could not be written to the Repository.

Action:

Check the Repository for corrupt data or network downtime.


CDI-22203

CDI-22203: An error occurred installing language rules ""%1"". Would you like to select an alternative file?

Cause:

The language rules meta-data file has been corrupted or could not be read.

Action:

Check the file system for corrupt data. If the file is not recoverable, reset the language default rules.


CDI-22204

CDI-22204: Unable to create constructs for language ""%1"". The construct tree will be empty.

Cause:

A generic language could not be initialized.

Action:

Check the file system and the repository for corrupt data.


CDI-22205

CDI-22205: An error occurred trying to retrieve text.

Cause:

Text could not be read for the specified module or application logic item.

Action:

Check the network and check the Repository.


CDI-22206

CDI-22206: An unexpected internal failure has occurred. The Logic Editor may be unstable - save data immediately.

Cause:

An I/O error has occurred.

Action:

Save data now and then reboot.


CDI-22207

CDI-22207: Language mismatch: you cannot drag into application logic of another language type.

Cause:

An attempt has been made to drag logic from one language type into the text window of another language type.

Action:

Check that the right language type is being used.


CDI-22208

CDI-22208: Could not find text.

Cause:

A text-search failed to find the specified text.

Action:

None. The specified text does not exist.


CDI-22209

CDI-22209: No current construct is available for insertion.

Cause:

An attempt has been made to Insert Construct when none is selected on the Construct Tree window (or a non-language container-only node is selected, such as the root node).

Action:

Select an appropriate construct tree leaf node before attempting to Insert Construct.


CDI-22210

CDI-22210: Invalid font size.

Cause:

Failure to initialize a font with the specified size from one of the following:

1. Logic Editor Options dialog

2. Registry.

Action:

1. Select a font size from the drop-list.

2. Check the registry entry.


CDI-22211

CDI-22211: Cannot goto mark.

Cause:

An attempt was made to goto bookmark before a bookmark has been set.

Action:

Set a bookmark before attempting to do this.


CDI-22212

CDI-22212: Cannot set mark.

Cause:

An attempt has been made to set-mark when an invalid node is selected or no node has been selected.

Action:

Select a node first and then continue.


CDI-22213

CDI-22213: The file %1 contained no text.

Cause:

An attempt has been made to Import Text with a file that was empty.

Action:

Check which file contains the text you wish to import and try again.


CDI-22214

CDI-22214: The import text is too large for current memory.

Cause:

The file specified for importing was too large to fit in the existing memory.

Action:

Try the following:

1. Shut down some other applications.

2. Break the file into smaller chunks first and then import them separately.


CDI-22215

CDI-22215: Error reading file %1.

Cause:

A file specified for importing text could not be read.

Action:

Check that the file and file system (or network path) are not corrupt.


CDI-22216

CDI-22216: There is no current text to export.

Cause:

An attempt has been made to save an export-text file from an editor that contains no text.

Action:

Find or create the text first, before attempting to save an export-text file.


CDI-22217

CDI-22217: Error writing file %1.

Cause:

An attempt to write export text to an external file failed.

Action:

Check that the pathname is valid, that correct permissions are available and that the network path is working. Check that a valid filename is entered.


CDI-22218

CDI-22218: The %1 has been deleted. The document will close.

Cause:

The associated element (plsq module/application logic) was deleted from the repository.

Action:

None. The logic is now invalid.


CDI-22219

CDI-22219: The %1 has been updated.\r Would you like to re-load the logic?

Cause:

The associated element was changed by another user. This may have altered the displayed logic.

Action:

Press 'Y' to re-query the logic, losing recent changes, or 'N' to retain the logic as displayed.


CDI-22220

CDI-22220: The source pathname "%1" could not be created. Would you like to specify a new pathname?

Cause:

The logic could not be saved to the path and/or filename given, either because the path is invalid or there are inadequate permissions.

Action:

Select 'Yes' to choose a new pathname, or 'No' to continue editing.


CDI-22300

CDI-22300: An internal error in Server Generator occured. Please contact Designer Support.

Cause:

No further information is available.

Action:


CDI-22301

CDI-22301: There are no Database Users in this Application System. Please Create a Database User and try again.

Cause:

No further information is available.

Action:


CDI-22302

CDI-22302: There appears to be a problem with the source of the Design Capture. Please check the source is valid.

Cause:

No further information is available.

Action:


CDI-22303

CDI-22303: You can only select Implementation objects owned by a selected Database User. Please reselect and try again.

Cause:

No further information is available.

Action:


CDI-22304

CDI-22304: Only definition objects can be selected on their own for generation. Please reselect and try again.

Cause:

You have selected an implementation object for generation without selecting a context database user.

Action:

Alter your selection to include a database user


CDI-22305

CDI-22305: When a Diagram is selected for generation, no other objects can be selected. Please reselect and try again.

Cause:

No further information is available.

Action:


CDI-22306

CDI-22306: Only Tablespace, Rollback Segment, User, Role, Database Links, Profile and Replication Group objects can be selected. Please Reselect and try again.

Cause:

No further information is available.

Action:


CDI-22307

CDI-22307: Only a Database object can be passed as context.

Cause:

You have called the Generate database dialog but given an object other than a database for context.

Action:

Select a database or reset the selection before calling this dialog.


CDI-22308

CDI-22308: When a Database User is selected, no other objects can be selected for Module Component API generation. Please reselect and try again.

Cause:

No further information is available.

Action:


CDI-22309

CDI-22309: Can't create directory.

Cause:

You have entered an invalid name for the new directory

Action:

Enter a new name consisting of alphanumeric characters and backslashes "\" as separators


CDI-22310

CDI-22310: Can't update the Server Generator preferences.

Cause:

An internal error occurred while trying to save the Server Generator options

Action:

Close down the dialog and try again


CDI-22311

CDI-22311: A diagram will not be displayed because the element(s) captured are not shown on Server Model diagrams.

Cause:

No further information is available.

Action:


CDI-22312

CDI-22312: You may only select abstract types from a single generator class set

Cause:

No further information is available.

Action:


CDI-22313

CDI-22313: You may only generate from a single generator class set

Cause:

No further information is available.

Action:


CDI-22314

CDI-22314: The directory that you specified does not exist or the file prefix specified is write-protected. Please specify another directory or file prefix.

Cause:

No further information is available.

Action:


CDI-22315

CDI-22315: The directory that you specified does not exist or the database connection is in error. Please specify a different directory or database connection

Cause:

No further information is available.

Action:


CDI-22316

CDI-22316: You must add object types to the class set before generating the run-time context class

Cause:

No further information is available.

Action:


CDI-22317

CDI-22317: You must set the options for mapping types to files before generating your types.

Cause:

No further information is available.

Action:


CDI-22318

CDI-22318: The connection that you specified is not an Oracle8 database

Cause:

No further information is available.

Action:


CDI-22319

CDI-22319: The directory that you specified does not exist. Please specify another directory.

Cause:

No further information is available.

Action:


CDI-22320

CDI-22320: The database connection that you specified is invalid or is not available. Please specify a different database connection.

Cause:

No further information is available.

Action:


CDI-22321

CDI-22321: File prefix not given, cannot proceed with generation.

Cause:

No further information is available.

Action:


CDI-22322

CDI-22322: No DDL can be generated from the given data

Cause:

The Server Generator cannot create any DDL because the Transformer did not create a server model from the type model

Action:

Consult the Messages Window for more information on why the Transformer failed


CDI-22323

CDI-22323: No data was recovered from the database

Cause:

Object Designer could not recover the Object Types because the Server Generator did not recover any data from the database

Action:

Consult the Messages Window for more information on why the Server Generator failed


CDI-22325

CDI-22325: The name you have specified for the Destination module already exists. Do you want to merge the captured module with this existing module?

Cause:

No further information is available.

Action:


CDI-22326

CDI-22326: You cannot merge the captured module with the Destination module because the Destination module you specified does not exist. Do you want to create the captured module as a new Repository module with the name you entered?

Cause:

No further information is available.

Action:


CDI-22327

CDI-22327: Provide a name for the Destination Module

Cause:

No further information is available.

Action:


CDI-22328

CDI-22328: The destination you specified already exists. Do you want to replace the existing module with the captured module?

Cause:

No further information is available.

Action:


CDI-22361

CDI-22361: Please enter a project in the Project field, or select the ""Create new Visual Basic project"" radio button

Cause:

No further information is available.

Action:


CDI-22363

CDI-22363: Please enter a username or leave the Connect String field empty

Cause:

No further information is available.

Action:


CDI-22364

CDI-22364: Please enter a username or leave the Connect String field empty

Cause:

No further information is available.

Action:


CDI-22365

CDI-22365: Please enter a username or leave the Connect String field empty

Cause:

No further information is available.

Action:


CDI-22366

CDI-22366: The DLL could not be loaded or does not exist. Please check that the product has been installed correctly.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-22367

CDI-22367: Please enter a default session

Cause:

No further information is available.

Action:


CDI-22368

CDI-22368: Unable to load library cvvbs20.dll

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-22369

CDI-22369: The Registry does not have the required infromation. Please chack that the product has been installed correctly.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-22370

CDI-22370: You are using an out-of-date DLL, or the Registry is in error. Please check that the product has been installed correctly.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-22371

CDI-22371: A problem occured while trying to load the Generator. Please check with Support.

Cause:

No further information is available.

Action:


CDI-22500

#CDI-22500 Invalid Repository

Cause:

An attempt was made to logon to a repository that did not contain the standard repository tables.

Action:

Check the correct userid and database SID have been specified.

Check the repository has been correctly installed using the Repository Administration Utility

Check that the user has been given access to the repository objects using the Repository Administration Utility


CDI-22501

CDI-22501 Invalid Repository User

Cause:

An attempt was made to logon with a userid either not recognized by Oracle Designer or marked as invalid by the repository.

Action:

·Ensure the userid has been added to the repository using the Repository Administration Utility.

·Reconcile the user using the Repository Administration Utility


CDI-22502

CDI-22502 No Access to Application

Cause:

An attempt was made to access a repository application to which the user had no access.

Action:

Ask the Application owner to grant access using from Application->Grant menu options from the RON.


CDI-22503

CDI-22503 There are unsaved changes - Do you want to Commit ?

Cause:

This message simply asks the user to make a decision.

Action:


CDI-22504

CDI-22504 Cannot update locked object

Cause:

An attempt was made to update or delete a locked repository object.

The repository object is locked as a result of locking or checking out a user defined set containing it.

Action:

Wait until the element has been unlocked or ask the person who checked out or locked the set to check it back in or unlock the set. An application administrator can also perform this task if necessary.


CDI-22505

CDI-22505 Cannot update shared object

Cause:

An attempt was made to update or delete a shared object.

Action:

Open the application system that owns the repository object and perform the update in the context of that application system. Note - a short cut to do this is to select the locate object definition toolbar or menu or press the share icon with the left mouse button.


CDI-22506

CDI-22506 Cannot delete %1 from here

Cause:

The specified element type cannot be deleted from the RON

This is because the element can only be deleted by a specialized tool.

Action:

Invoke the appropriate tool


CDI-22507

CDI-22507 Cannot create %1 from here

Cause:

The specified element type or association cannot be created in this context

This maybe because there is insufficient information in the current context or because a specialized tool is required to create the element or association.

Action:

Navigate to a more appropriate context in the RON's Navigator or Property Palette, for example is it is an association try creating from the other end of the association.

Invoke the appropriate tool or diagrammer for elements that cannot be created in the RON.


CDI-22508

CDI-22508 Shared objects can only be deleted within the context Application

Cause:

Objects can only be deleted from within the context of the owning application.

Action:

Navigate to the owning application and then delete the object. Note the locate object definition toolbar/menu options are short cut way of navigating to the application system.


CDI-22509

CDI-22509 Unable to load language DLL %1: rc = %2

Cause:

The program was unable to load the specified dll library.

This may be because one or more registry setting are incorrect or because the DLL is missing, corrupt or the user has no access rights to execute the library.

Action:

Check the dll exists and the user has execute access rights.

Check the registry setting are correct.

Check the return code specified in %2 for further clues.

Reinstall if necessary.


CDI-22510

CDI-22510 No %1 found

Cause:

This message is for information only.

Action:

None.


CDI-22511

CDI-22511 Cannot Force Delete Applications - Use Application -> Delete

Cause:

Application systems can only be deleted using the Application->Delete option from the RON

Action:

Select this option and continue.


CDI-22513

CDI-22513 Warning - Optional %1 selected for UID

Cause:

An optional relationship or attribute was selected as a unique identifier

Action:

This is just a warning as it is generally recommended that only mandatory attributes or relationships are used for unique identifiers. No action is required.


CDI-22514

CDI-22514 Warning - Join Column is not part of Primary or Unique Key

Cause:

A foreign key join column was selected that was not part of the primary key or included in any Unique Keys

Action:

This is just a warning. No action is required.


CDI-22520

CDI-22520 Unable to register notification service

Cause:

The server database is not responding

The notification service schema has not been correctly installed.

Action:

Check the status of the Oracle server.

Ensure that the notification service has been correctly installed using the RAU


CDI-22530

CDI-22530 No elements found for this query

Cause:

This message is for information only.

Action:


CDI-22531

CDI-22531 There are %1 matches

Cause:

This message is for information only.

Action:


CDI-22533

CDI-22533 Duplicate navigator group name %1 exists

Cause:

The supplied name has already been used.

Action:

Enter another name and continue


CDI-22534

CDI-22534 Navigator view is currently in use

Cause:

Unable to remove a navigator view while it is being used by a navigator window.

Action:

Close all navigator windows that contain the view before attempting to remove the navigator view.


CDI-22535

CDI-22535 Navigator view is included in one or more navigator groups

Cause:

Unable to remove the Navigator view while it is contained in one or more navigator groups.

Action:

Using the Options->Navigator Groups dialog remove the view from the groups that include the navigator view.


CDI-22536

CDI-22536 Navigator group is currently in use

Cause:

Unable to remove a navigator group while it is being used by a navigator window.

Action:

Close all navigator windows that contain the group before attempting to remove the navigator group.


CDI-22540

CDI-22540 No Domains are Selected

Cause:

The user has attempted an invalid activity.

Action:


CDI-22541

CDI-22541 No Functions are Selected

Cause:

The user has attempted an invalid activity.

Action:


CDI-22542

CDI-22542 No Modules are Selected

Cause:

The user has attempted an invalid activity.

Action:


CDI-22550

CDI-22550 Cannot remove select access

Cause:

The user has attempted an invalid activity.

Action:


CDI-22551

CDI-22551 Cannot remove admin access from application owner

Cause:

The user has attempted an invalid activity.

Action:


CDI-22552

CDI-22552 Cannot remove all access from application owner

Cause:

The user has attempted an invalid activity.

Action:


CDI-22553

CDI-22553 No Applications to add

Cause:

The user has attempted an invalid activity.

Action:


CDI-22554

CDI-22554 No Users to add

Cause:

This message is for information only.

Action:


CDI-22560

CDI-22560 the PL/SQL file %1 cannot be found

Cause:

The RON tried to invoke the specified PL/SQL script but was unable to locate it

Action:

Check the registry variable REPADM20 is pointing to the correct path.

Reinstall if necessary.


CDI-22561

CDI-22561 the PL/SQL script %1 exceeds size limits

Cause:

The specified PL/SQL file is too large.

Action:

Check the registry variable REPADM20 is pointing to the correct path.

Call customer support if necessary.


CDI-22562

CDI-22562 Restoring Dictionary 5.1 applications is not supported

Cause:

The XT archive applications that were imported were found to contain data from CASE*Dictionary 5.1 or earlier.

This is not supported by the RON. Only dump files archived by Oracle Designer are supported by the RON's restore operation.

Action:

Use the Repository Administrator Utility to upgrade the entire repository to Oracle Designer.


CDI-22563

CDI-22563 Unrecognised Archive Dictionary Version

Cause:

A dump file has been imported into the XT archive tables but RON is unable to recognize the data or from which version of Oracle Designer it was archived.

Action:

Check that the log file produced by the import to make sure the import worked successfully. ( Press View Log from dialog)

Check that the name of the dump file is correct.

Check that it was an XT application dump and not a full repository dump. The table names inside the dump file can be examined using the Oracle IMP or data manager tools.

Re-archive and the import application again.


CDI-22564

CDI-22564 Warning - User extended definitions of archived applications do not match those of current repository Please consult your repository administrator to resolve differences Continue with restore?

Cause:

An XT archive dump has been imported but the source repository has different user extension definitions to those of the target repository.

Action:

If the user extensions are not used by the applications to be restored, then press continue to restore.

Otherwise get a report of the differences by pressing the UE Report button from the Restore dialog.

The Repository administrator should examine the report and add the missing UE definitions or resolve the differences using the Repository Administration Utility.

Note that the UE definitions apply to the whole repository.


CDI-22565

CDI-22565 Archive tables are empty

Cause:

An attempt was made to export the XT archive tables but there was no data in the tables

Action:

Archive the applications first using the Application->Archive option from the RON.


CDI-22566

CDI-22566 Archive Tables are not empty - Delete existing Data ?

Cause:

The requested operation will cause the user's XT application data to be removed before new data can be written to it.

Action:

Press OK to remove all the applications currently in the archive table and continue the operation.


CDI-22569

CDI-22569 Delete all archived applications from the archive tables ?

Cause:

This message simply asks the user to make a decision.

Action:


CDI-22571

CDI-22571 The XT Archive tables have been successfully upgraded. Select application(s) and press <Restore>

Cause:

This message is for information, and asks the user to select applications to restore.

Action:


CDI-22572

CDI-22572 Cannot create temporary restore import parameter file %1: rc = %2

Cause:

The Import process was unable to create a temporary file on the user's temp directory to contain the parameters for import, probably due to no access rights or no disk space, or invalid path name.

Action:

Ensure that a valid TEMP directory is specified in the operating system configuration which has some disk space (only a small amount required ) and write access for the user.


CDI-22573

CDI-22573 Cannot open archive export parameter file %1: rc = %2

Cause:

The Export process was unable to open the shipped parameter file which contains the basic export parameters

Action:

Check the REPADM20 variable is pointing to the correct path

Check the file exists

Check user has read access to the file

Reinstall if necessary

Or

CDI-22573 Cannot open restore import parameter file %1: rc = %2

Cause:

The Import process was unable to open the shipped parameter file which contains the basic import parameters

Action:

Check the REPADM20 variable is pointing to the correct path

Check the file exists

Check user has read access to the file

Reinstall if necessary


CDI-22575

CDI-22575 Invalid filename %1

Cause:

The specified filename is invalid due to one of the following:

·The file does not exist

·The path name or file name contains invalid characters or has an invalid format

·The user does not have correct access rights to the file

Action:

Correct the filename and continue.


CDI-22576

CDI-22576 Data in the XT archive tables is not up to date ( %1 ). Upgrade or re-archive.

Cause:

The archive tables contain applications archived in a previous version of the repository.

Action:

Upgrade the data using the upgrade button from the Restore Dialog.

Re archive the applications using Application->Archive option.


CDI-22577

CDI-22577 A reconnect application must be specified for all skeleton application if the reconnect share links option is selected

Cause:

When restoring an application the reconnect option was specified for the skeleton application.

But not all skeleton applications have a reconnect application specified in the dialog

Action:

Deselect the reconnect option or ensure or selected skeleton applications (denoted with an empty book icon) have a reconnect application specified.


CDI-22578

CDI-22578 -Warning: Upgraded applications contain invalid references.

These applications may only be restored by checking the force invalid references option.

Cause:

The upgrade process detected that some structure elements had the str_use_of reference pointing to a nonexistent element. At this point it is not possible to determine the cause of the corruption.

Action:

To continue with the restore check the Force Invalid References checkbox otherwise the restore will fail.

If this option is selected and the data is restored, the affected applications will be marked as invalid. The utility trace file on the server can be examined to see the which rows are invalid. Contact customer support for more information on how to use this feature. To remove the invalid data run the Repository Analyzer from the Repository Administration Utility.


CDI-22580

CDI-22580 Do you wish to continue?

Cause:

This message simply asks the user to make a decision.

Action:


CDI-22581

CDI-22581 - Error occurred running the import utility. Check log file %1

Cause:

A serious error during the import process.

Action:

Examine the log file from the import by pressing the View Log button on the dialog. ( The log file is automatically displayed for fatal errors ).

Refer to the Oracle Server messages for more information on import errors.

Correct the error and restart the import.


CDI-22582

CDI-22582 - Error occurred running the export utility. Check log file %1

Cause:

A serious error during the export process.

Action:

Examine the log file from the export by pressing the View Log button on the dialog.

Refer to the Oracle Server messages for more information on import errors.

Correct the error and restart.


CDI-22583

CDI-22583 Error - not all applications of an application set were specified

Cause:

An attempt was made to restore a partial set of applications through the command line interface.

All applications connected via share links must be restored as a set.

Action:

Specify the complete set of application in the parameter file and rerun.


CDI-22584

CDI-22584 Unknown Repository Version

Cause:

The program looks it the XT data version table to detect the version of the archived or imported application.

The version string was not recognized. This may be due to a bad import or some corruption on the archive data.

Action:

Check the version string in XT_APPLICATION.

Check the last import ran successfully by viewing the log file (%TEMP%\ckronimp.log) if it still exists.

Import again, or re-archive the data and rerun


CDI-22585

CDI-22585 - Archived data is from a repository version newer than the current repository, and is not backwards compatible.

Cause:

The XT Applications that have been imported into the repository have been archived from a repository which is a newer version than the target repository and the structure of the data does not match.

Backwards compatibility is not supported.

Action:

Upgrade the target repository to the same or later version than the source repository and rerun the restore.


CDI-22586

CDI-22586 File %1 already exists. Do you want to replace it?

Cause:

The specified export dump file already exists.

Action:

Press OK to overwrite the existing file. Otherwise press CANCEL and specify the file name again.


CDI-22587

CDI-22587 Application version must be numeric and between 1 and 999

Cause:

An invalid version number has been entered for application new version or restore

Action:

Enter a version number between 1 and 999 and continue.


CDI-22590

CDI-22590 Cannot Open Parameter file %1: rc is %2

Cause:

The parameter file passed to the command line interface could not be opened.

Action:

Check the correct filename has been specified and that the file exists and the user has read access.


CDI-22591

CDI-22591 No parameter file specified on the command line

Cause:

An attempt was made to run the command line interface without specifying a parameter file.

Action:

Create a parameter file and run using the syntax ckrob20 user/password@db /P:param.fil


CDI-22592

CDI-22592 Logon string was not specified on the command line

Cause:

An attempt was made to run the command line interface without specifying the logon string.

Action:

Rerun using the syntax ckrob20 user/password@db /P:param.fil


CDI-22593

CDI-22593 Unknown parameter

Cause:

A parameter passed to the command line interface through the parameter file could not be recognized

Action:

Check the spelling and syntax, correct the error and rerun.


CDI-22594

CDI-22594 Invalid parameter value

Cause:

A parameter value passed to the command line interface through the parameter file was invalid.

Action:

Correct the error and rerun


CDI-22595

CDI-22595 Operation was not specified

Cause:

An attempt was made to run the command line interface without specifying the operation to be run in the parameter file

Action:

Refer to the Help documentation on the command line interface for valid operations.

Correct the error and rerun.


CDI-22596

CDI-22596 Application %1 not found in repository

Cause:

The specified application either does not exist or the user does not have any access rights to it.

Action:

Check the application name/version is correct.

Ask the application owner/administrator to grant access.

Rerun.


CDI-22597

CDI-22597 Inappropriate access rights on application for operation

Cause:

An attempt was made to run the command line interface without the user having the appropriate access rights on the specified application for the operation required.

Action:

Ask the application owner/administrator to grant the necessary access rights on the application and rerun.


CDI-22598

CDI-22598 No target objects were specified for operation

Cause:

An attempt was made to run the command line interface without specifying any target objects for the operation.

Action:

Add the objects/application systems to the parameter file and rerun.


CDI-22601

CDI-22601 Can't find meta file %1. Check %2 registry variable

Cause:

The file which contains the tool's meta data is not found./NEWPARA/This is a fatal error and the tool will terminate.

Action:

Check the REPADM20 registry variable.

Check that the Paths set by these variables are correct.

Check that the file exists in the directory pointed to by the REPADM20 variable.

Reinstall the repository administrator product if necessary.


CDI-22602

CDI-22602 Meta file %1 is wrong version. Check path and %2 registry variable

Cause:

The version of the meta file does not match the version of the tool.

This is a fatal error and the tool will terminate.

Action:

Check the path and the REPADM20 registry variable.

Check that the correct version of the tool is being invoked.

Reinstall the repository administrator product if necessary.


CDI-22603

CDI-22603 No Access to meta file %1

Cause:

The user does not have access rights to read the meta file.

Action:

Ask your system administrator to grant read access to this file.


CDI-22604

CDI-22604 Unexpected error opening meta file %1: Error code = %2

Cause:

The program encountered an unexpected error opening the tool's meta file.

Action:

Check that the file has not been compressed or corrupted.

Check that the path is accessible

Reinstall the repository administrator product if necessary.


CDI-22605

CDI-22605 Registry variable %1 not found in registry section %2

Cause:

The specified registry variable has not been set, possibly due to a bad installation.

Action:

Set the specified registry variable.

Reinstall the appropriate product.


CDI-22610

CDI-22610 Unable to load library %1

Cause:

The specified library is missing or corrupt.

Action:

Reinstall the appropriate product.


CDI-22611

CDI-22611 Function %1 not found in library %2

Cause:

The DLL library is the wrong version or is corrupt.

Action:

Reinstall the appropriate product.


CDI-22612

CDI-22612 Executable file %1 not found

Cause:

The program attempted to invoke an .exe program but it was not found.

Action:

Reinstall the appropriate product.


CDI-22613

CDI-22613 Invalid executable path %1

Cause:

The tool attempted to invoke an .exe program but the directory or the file name was found to be invalid.

Action:

Respecify the path or file name of the executable.

Reinstall the tool if necessary.


CDI-22614

CDI-22614 Not enough memory to run program

Cause:

The tool attempted to invoke an .exe program but there was not enough virtual memory available to run it.

Action:

Close down any unneeded processes running on the PC.

Reboot the PC if necessary.

Install more RAM on the PC.


CDI-22615

CDI-22615 Program already loaded - cannot run two copies

Cause:

The tool attempted to invoke an .exe program that was already running and that does not allow more than one copy to be run concurrently.

Action:

Use the process already running or shut it down and reinvoke it from the tool.


CDI-22616

CDI-22616 Unable to load %1: Error code = %2

Cause:

An unexpected error was encountered attempting to invoke an .exe program.

Action:

Examine the error code and if possible look it up in the operating system error codes manual or help system and take appropriate action.

Call customer support if unable to find error.


CDI-22617

CDI-22617 Unable to load %1 or one of its components

Cause:

The tool attempted to load an .exe program but the program or one of its components or DLLs could not be loaded.

Action:

Attempt to run the specified .exe program from the command line to see if it can be run.

If it does run, the path may need to be modified to ensure the program and all its components can be located.

If it doesn't run, look for further details of the components that may be missing.

Reinstall the appropriate product if necessary.


CDI-22701

CDI-22701 Unable to Initialize Server Process - Continue in ReadOnly Mode?

Cause:

Unable to initialize the repository server API process.

This message should have been preceded by a message from the server showing the cause of the problem.

Action:

Press OK to continue in a ReadOnly session.

Press Cancel to abort the session. Correct the API problem and restart the tool or use the File->Change Connection option.


CDI-22702

CDI-22702 - Unable to Set Application System in server process

Cause:

On attempting to update the repository the program was unable to set the context application system in the server.

This message should have been preceded by a message from the serve showing the cause of the problem.

Action:

Correct the server problem and continue.

Restart the tool or the session using File->Change Connection option.


CDI-22703

CDI-22703 %1 %2 is locked by another User

Cause:

An attempt was made to update an element currently being updated by another user.

Action:

Try again later.


CDI-22704

CDI-22704 - %1 %2 has been Deleted

Cause:

The specified element has been deleted. This may be by another user or a result of some secondary or cascade processing in the current session.

Action:

No action required. The tool will remove the element from the current window.


CDI-22706

CDI-22706 %1 %2 has been changed by another User - Requery ?

Cause:

The specified element has been updated by another user.

Action:

Press YES to discard any changes and query on the changed element.

Press NO to keep any properties currently in memory.


CDI-22710

CDI-22710 - Invalid number - property value cannot be set

Cause:

An attempt was made to enter a nonnumeric value into a numeric property.

Action:

Reenter a numeric value.


CDI-22711

CDI-22711 - Invalid date - property value cannot be set

Cause:

An attempt was made to enter an invalid date or time into a date/time property

Action:

Ensure the correct date format is being used, using the Options->Property Palette dialog.

Reenter the date/time value.


CDI-22712

CDI-22712 - Sequence numbers must be positive

Cause:

An attempt was made to enter a negative value into a sequence property.

Action:

Reenter a positive value.


CDI-22715

CDI-22715 - There are unsaved changes - Do you want to Commit ?

Cause:

An attempt was made to close a pinned property palette window which has outstanding changes.

Action:

Press YES to save the changes

Press NO to undo the changes.


CDI-22720

CDI-22720 Unable to allocate memory

Cause:

General error produced when not enough virtual memory is available on the client machine to perform the current task.

Action:

Close any unwanted processes on the client machine.

Reboot if the machine if necessary.

Install more memory in client machine if problem persists.


CDI-22721

CDI-22721 - Unable to open temporary text file

Cause:

An attempt to populate a multi line text property from a temporary or external file failed.

An attempt to open a text file to write the contents of a multi line text property field failed.

Action:

Check access rights on the directory or file.

Retry the operation.

If the problem persists contact customer support.


CDI-22722

CDI-22722 - Insufficient memory in Edit Control to perform operation

Cause:

An attempt to update a multi line text property using TextPad has failed due to reaching a windows edit control limit.

This may happen on Windows 95 on text approaching 64K bytes or greater.

Note that the edit control limits are lower on Windows 95 than those of Windows NT.

Action:

Check a suitable external editor such as Write/WordPad has been specified using the Options->Text Editors dialog.

Select the ascii editor menu or toolbar option to edit the text.


CDI-22723

CDI-22723 - Text is too large to display in TextPad

Cause:

The amount of text exceeds the Windows edit control maximum size.

This may happen on Windows 95 on text approaching 64K bytes or greater.

Note that the edit control limits are lower on Windows 95 than those of Windows NT.

Action:

Check a suitable external editor such as Write/WordPad has been specified using the Options->Text Editors dialog.

Select the ascii editor menu or toolbar option to edit the text.


CDI-22730

CDI-22730 %1 %2 have been loaded - continue?

Cause:

A repository query was returning an unusually large number of elements.

This message is issued to let the user know the progress of the query and allow them to cancel or stop the query if required.

Action:

Press YES to continue with query, Press NO to stop the query at this point, Press CANCEL to cancel the operation altogether.


CDI-22731

CDI-22731 - No %1 found in Repository for referencing to this property

Cause:

A list of values was invoked for a reference property in the property palette. No suitable objects were found in the Repository.

Action:

Create some suitable elements and then make the reference. Note that the palette may be pinned until the create operation is complete.


CDI-22732

CDI-22732 - Query returned no objects

Cause:

This message is for information only.

Action:


CDI-22740

CDI-22740 - Not all reference properties on the clipboard reference objects owned by or shared into the current context application. These properties were not copied.

Cause:

The property clipboard was used to copy reference properties across application systems. Where the reference property is not visible (i.e. owned by or shared into ) the context application system, these reference properties have not been copied.

Action:

Share the referenced elements first then use the clipboard to copy them.


CDI-22800

CDI-22800 - There are mandatory references to objects outside the copy set which are not owned by or shared by the target application. Specify Share or Copy or remove the referencing object from the set

Cause:

An attempt was made to copy an element from one application system to another, while the element contains a mandatory reference to another element which is not visible in(i.e. not owned by or shared by ) the target application system.

Action:

Go to the external references tab on the dialog. The mandatory references are shown in red.

To share the referenced element , click the share checkbox

To copy the referenced element , click the copy checkbox

To remove the reference altogether, determine which element(s) reference the object by pressing the Referenced By button and then remove them from the copy set by going to the expanded copy list tab and unchecking the elements.


CDI-22801

CDI-22801 - Insufficient Access Rights on Application

Cause:

An attempt was made to perform a repository operation for which the user did not have the appropiate access rights.

Action:

Ask the application owner/administrator to grant the appropiate access rights


CDI-22802

CDI-22802 - Application System is Frozen

Cause:

An attempt was made to perform an update operation on a frozen application.

Action:

Unfreeze the application if necessary.


CDI-22803

CDI-22803 - Files with "".rci"" (CheckIn) suffix must be checked back into the original source application

Cause:

An attempt was made to load a checkin file into into a non source application.

Action:

Check the correct file name was selected.

Check the correct dialog was invoked.

Go to the specify source application page of the dialog and ensure the source application is specified.


CDI-22804

CDI-22804 - Files with "".rco"" (CheckOut) suffix must be checked into a working application where the data may then be modified

Cause:

An attempt was made to load a checkout file into another source application rather then a working application.

Action:

Check the correct file name was selected.

Check the correct dialog was invoked.

Go to the specify working application page of the dialog and select or create a working application.


CDI-22805

CDI-22805 - Cannot CheckOut a Locked Set

Cause:

An attempt as made to checkout a set which has already been locked or checked out

Action:

Try again later

Ask the person who locked/checked out the set to checkin/unlock the set. This operation can also be done by an application administrator if necessary.


CDI-22806

CDI-22806 - Only one set can be specified for CheckIn/CheckOut

Cause:

The attempt was made to checkOut or checkIn multiple user defined sets.

Action:

Select a single set at a time and continue.


CDI-22807

CDI-22807 - Unknown Element Type %1

Cause:

In navigating the repository or loading the operation rules, an unrecognized element type was encountered.

Action:

Ensure the correct version of the client and server software is installed.

Contact customer support if problem persists.


CDI-22809

CDI-22809 - Internal Error ( Element ID = %1)

Cause:

The program has failed to locate a parent object for a child object.

Action:

Contact customer support.

Or

CDI-22809 - CheckOut file suffix must be ".rco

Cause:

An attempt was made to checkout a set using an intermediary file with a suffix other than "rco";

Action:

Change the filename suffix to "rco" and continue;


CDI-22810

CDI-22810 - CheckIn file suffix must be "".rci"

Cause:

An attempt was made to checkin a set using an intermediary file with a suffix other than "rci";

Action:

Change the filename suffix to "rci" and continue;


CDI-22811

CDI-22811 - Warning - not all objects were marked for share as some in the list are not shareable. These objects should be copied or dereferenced.

Cause:

The Share All button was pressed but not all objects in the list were of a type that could be shared.

Action:

Review these objects and for each either click the copy checkbox or remove the elements referencing them from the copy set and then continue.


CDI-22820

CDI-22820 Warning %1 %2 is locked

Cause:

An attempt was made to update/delete/transfer a locked element.

The element will have been discarded from the set.

Action:

Perform the operation again when the element has been unlocked.


CDI-22821

CDI-22821 Warning %1 %2 is not owned by context application

Cause:

An attempt was made to update/delete/transfer/share a shared element.

The element will have been discarded from the set.

Action:

Perform the operation from the owning application.


CDI-22822

CDI-22822 Warning %1 %2 is not shareable

Cause:

At attempt was made share an object that was not shareable.

The element will have been discarded from the set.

Action:


CDI-22823

CDI-22823 Warning %1 %2 is not transferable

Cause:

At attempt was made share an object that was not transferable.

The element will be discarded from the set.

Action:


CDI-22900

CDI-22900 File not found.

Cause:

The current process is unable to locate the specified file.

This may be because of access rights, or an invalid path name.

Action:

Specify a correct file name that can be opened.


CDI-22901

CDI-22901 Illegal path name.

Cause:

The current process is unable to locate the specified file.

This is either because of an invalid path name or the filename is empty.

Action:

Specify a correct path name and filename that can be accessed.


CDI-22902

CDI-22902 Too many open files.

Cause:

The current process is unable to open the specified file.

This is because there are too many open files on the system.

Action:

Close some of the open files and retry the operation.


CDI-22903

CDI-22903 File access denied.

Cause:

The current process is unable to access the specified file.

This is because it has no access rights on the specified file.

Action:

Specify a correct file name that can be accessed.


CDI-22904

CDI-22904 Invalid file.

Cause:

The input file specified is not of the correct format.

This may be caused by attempting to load a file unloaded or checked out from an earlier release of Oracle Designer.

Action:

Check that the file you are trying to load has been created from a compatible version of Oracle Designer. Then repeat the operation specifying a valid input file.


CDI-22905

CDI-22905 File sharing violation.

Cause:

The current process is unable to access the specified file.

This is because another process is attempting to access the file simultaneously.

Action:

Check that another process is not trying to access the file at the same time. Then repeat the operation.


CDI-22906

CDI-22906 Unexpected end of file.

Cause:

The load or check in utility reached the end of the input file without finding all the expected commands.

Action:

Check that a valid input file has been specified and that it contains all the expected data. Then repeat the operation.


CDI-22907

CDI-22907 Disk is full.

Cause:

The utility is attempting to write to a file but there is no room left on the disk.

Action:

Remove any unwanted files from the disk and then repeat the operation.


CDI-22908

CDI-22908 File error.

Cause:

The utility is attempting to read from or write to a file but it encountered an unexpected error.

Action:

Check that the input and output files are valid. Then repeat the operation.


CDI-22909

CDI-22909 Invalid association type :-

Cause:

The given association type is not legal between the two specified element types.

Action:

Refer to the help on command syntax and specify the correct association type, then repeat the operation.


CDI-22910

CDI-22910 Association not found :-

Cause:

The specified block in the input data file does not define a mandatory association for an element. This is a fault in the input data file.

Action:

Refer to the help on command syntax and define the missing association in the input data file and then repeat the operation.


CDI-22911

CDI-22911 Incorrect number of arguments :-

Cause:

The specified command in the input data file does not contain the correct number of arguments.

Action:

Refer to the help on command syntax and correct the command syntax. Then repeat the operation.


CDI-22912

CDI-22912 Substituting 'J for E' on Secondary Update element type.

Cause:

The load process recognized a secondary update and amended the command syntax from an insert command to a query command.

Action:

This message is for information purposes only.

There is no need to take any action.


CDI-22913

CDI-22913 Substituting 'J for E' in update mode.

Cause:

The load process recognized that the process was running in update mode and amended the command syntax from an insert command to a query command.

Action:

This message is for information purposes only.

There is no need to take any action.


CDI-22914

CDI-22914 Object not found Reverting to E' in update mode.

Cause:

The load process could not find the unnamed element to update so it returned the command syntax back to an insert command.

Action:

This message is for information purposes only.

There is no need to take any action.


CDI-22915

CDI-22915 Not a named Element Type :-

Cause:

The given element type is not a named element type so it cannot be inserted using the I command.

Action:

Refer to the help on command syntax and specify the correct command to insert an unnamed element type. Then repeat the operation.


CDI-22918

CDI-22918 Object not found Reverting to I' in update mode.

Cause:

The load process could not find the named element to update so it returned the command syntax back to an insert command.

Action:

This message is for information purposes only.

There is no need to take any action.


CDI-22919

CDI-22919 Invalid FK column :-

Cause:

The given foreign key column is not valid for the specified element type.

Action:

If this is prefixed as a WARNING message and the block was committed successfully then there is no need to take any action.

Otherwise, if the block failed to commit, refer to the help on command syntax and specify the correct foreign key column or remove it altogether.

Then repeat the operation.


CDI-22920

CDI-22920 Invalid property Name :-

Cause:

The given property name is not valid for the specified element type.

Action:

If this is prefixed as a WARNING message and the block was committed successfully then there is no need to take any action.

Otherwise, if the block failed to commit, refer to the help on command syntax and specify the correct property name or remove it altogether. Then repeat the operation.


CDI-22921

CDI-22921 Property not found :-

Cause:

The given property is a mandatory property and it was not specified for the given element type.

Action:

Refer to the help on command syntax and include the mandatory property in the input file. Then repeat the operation.


CDI-22922

CDI-22922 Invalid column for relationship end :-

Cause:

An attempt was made to link two relationship ends but one of the elements given is not a relationship end.

Action:

Refer to the help on command syntax and specify the correct details for each relationship end. Then repeat the operation.


CDI-22923

CDI-22923 Invalid text type :-

Cause:

The given text type is not valid for the specified element type.

Action:

If this is prefixed as a WARNING message and the block was committed successfully then there is no need to take any action.

Otherwise, if the block failed to commit, refer to the help on command syntax and specify the correct text type or remove it altogether. Then repeat the operation.


CDI-22924

CDI-22924 Element cannot be found :-

Cause:

At attempt was made to query the repository for the given element but it did not exist in the repository. This usually occurs if the insert command for the element has failed during earlier processing.

Action:

Correct any earlier errors in the input file and repeat the operation.


CDI-22925

CDI-22925 Element name missing quote :-

Cause:

The name of the given element type has not be delimited with a quotation mark.

Action:

Refer to the help on command syntax and specify the correct delimiter for the element name. Then repeat the operation.


CDI-22926

CDI-22926 Handle missing ampersand :-

Cause:

The handle of the given element type has not been prefixed with an ampersand.

Action:

Refer to the help on command syntax and specify an ampersand before the element handle. Then repeat the operation.


CDI-22927

CDI-22927 Null handle :-

Cause:

The handle of the given element type has not been specified.

Action:

Refer to the help on command syntax and specify a valid handle for the given element. Then repeat the operation.


CDI-22928

CDI-22928 Handle missing asterisk :-

Cause:

The handle of the given element type has not been prefixed with an asterisk.

Action:

Refer to the help on command syntax and specify an asterisk before the element handle. Then repeat the operation.


CDI-22929

CDI-22929 Invalid handle value :-

Cause:

The handle of the given element type is not valid.

Action:

Refer to the help on command syntax and specify a valid handle for the given element. Then repeat the operation.


CDI-22930

CDI-22930 Invalid 'G' Option :-

Cause:

The specified 'G' command in the input data file is not syntactically correct.

Action:

Refer to the help on command syntax and correct the command syntax.

Then repeat the operation.


CDI-22931

CDI-22931 Value missing quote :-

Cause:

The value of a property for the given element type has not be delimited with a quotation mark.

Action:

Refer to the help on command syntax and specify the correct delimiter for the value of the property. Then repeat the operation.


CDI-22932

CDI-22932 Break command not yet supported.

Cause:

The specified Break command in the input data file is not currently supported.

Action:

Refer to the help on command syntax for valid commands. Remove the Break command from the input file. Then repeat the operation.


CDI-22933

CDI-22933 Unrecognized command line :-

Cause:

The specified command line in the input data file is not syntactically correct.

Action:

Refer to the help on command syntax and correct the command syntax.

Then repeat the operation.


CDI-22934

CDI-22934 Failed to execute Error File viewer.

Cause:

This error message is not currently displayed.

Action:


CDI-22935

CDI-22935 Invalid element type specified :-

Cause:

The given element type is not a valid element type in the repository.

Action:

Refer to the help on command syntax and specify a valid type for the given element.

Then repeat the operation.


CDI-22936

CDI-22936 Element references an element which is not in SET. (element, element, property) :-

Cause:

The unload process found a reference to an element not marked for unload. The element reference has been nullified by the unloader.

Action:

If the element reference nullified is for a mandatory property then this is a fatal error and must be reported to Oracle Support. This would be apparent during the load process.

Otherwise, this is a warning message and there is no need to take any action.


CDI-22937

CDI-22937 Substituting 'G for I' on Secondary Update element type.

Cause:

The load process recognized a secondary update and amended the command syntax from an insert command to a query command.

Action:

This message is for information purposes only.

There is no need to take any action.


CDI-22938

CDI-22938 Too many candidate elements for relationship :-

Cause:

The unload process could not resolve a reference to an element. There is more than one element that meets the known properties for the element being referenced.

Action:

Refer to the subsequent errors and determine which element cannot be resolved.

Refer to the help on command syntax and specify further commands in the load file to uniquely identify the element.

Then repeat the operation.

This error should be reported to Oracle Support.


CDI-22939

CDI-22939 The number of elements yanked does not match number in file :-

Cause:

The check in process has validated the check in file and found there to be the wrong number of elements in the file.

Action:

If the check in file has been manually edited make sure the number of 'Y' commands contained in the file matches the checksum specified.

Correct the error then repeat the operation.

If the check in file has not been manually edited this error should be reported to Oracle Support.


CDI-22940

CDI-22940 Failed to Unlock User Defined Set : -

Cause:

The check in process was not able to unlock the user defined set in the source application.

Action:

Make sure that the user defined set is a checked out source set. It may already have been checked back in by another user.

Check out the source set if it is not already checked out and then repeat the operation.


CDI-22941

CDI-22941 Server raised error

Cause:

An error has been raised by the API.

Action:

API errors are normally caused by invalid data in the file being loaded.

Refer to the help on command syntax and to resolve the cause of the API error.

Then repeat the operation.


CDI-22942

CDI-22942 This PAC element already exists and Loader is in Insert Mode. The element was NOT loaded.

Cause:

The loader attempted to create an element in the repository which already existed.

Action:

Set the loader mode to UPDATE and then repeat the operation.


CDI-22943

CDI-22943 This PAC element does not exist and Loader is in Update Mode. The element was NOT created.

Cause:

The loader attempted to update an element in the repository which did not already exist.

Action:

Set the loader mode to INSERT and then repeat the operation.


CDI-22944

CDI-22944 ""Failed to delete an element from the source set."

Cause:

The check in process attempted to delete elements in the source user defined set which were not checked out from the working application.

The usual reason for the delete to fail is because the element is not owned by the source application.

Action:

Report this error to Oracle Support.


CDI-22945

CDI-22945 The input filename is invalid.

Cause:

The input file specified has an invalid filename.

Action:

Repeat the operation specifying a valid input filename.


CDI-22946

CDI-22946 Unable to load definition for element type :-

Cause:

The current process was not able to find the given element type in the system tables.

This may be caused by attempting to load a file unloaded or checked out from an earlier release of Oracle Designer.

Action:

Check that the file you are trying to load has been created from a compatible version of Oracle Designer. Then repeat the operation specifying a valid input file.


CDI-22947

CDI-22947 Invalid syntax. Expected handle was not set.

Cause:

The specified command in the input data file does not contain a valid handle.

Action:

Refer to the help on command syntax and correct the command syntax. Then repeat the operation.


CDI-22948

CDI-22948 One or more arguments for this command are incorrect :-

Cause:

The specified command in the input data file does not contain the correct arguments.

Action:

Refer to the help on command syntax and correct the command syntax. Then repeat the operation.


CDI-22949

CDI-22949 The 'A' command is obsolete in this version of the loader.

Cause:

The specified 'A' command in the input data file is not compatible with the version of the loader being run.

Action:

Refer to the help on command syntax and replace the 'A' command with the correct command syntax for the version of the loader being run.

Then repeat the operation.


CDI-22950

CDI-22950 The 'B' command is obsolete in this version of the loader.

Cause:

The specified 'B' command in the input data file is not compatible with the version of the loader being run.

Action:

Refer to the help on command syntax and replace the 'B' command with the correct command syntax for the version of the loader being run.

Then repeat the operation.


CDI-22951

CDI-22951 The application system is Frozen.

Cause:

The load process cannot load elements into a frozen application system.

Action:

Specify a valid, unfrozen application system. Then repeat the operation.


CDI-22952

CDI-22952 The Application system in not in the expected freeze state

Cause:

The load process cannot load elements into a frozen application system.

Action:

Specify a valid, unfrozen application system. Then repeat the operation.


CDI-23000

CDI-23000: Enter a unique name for the check constraint.

Cause:

No further information is available.

Action:


CDI-23001

CDI-23001: This name is already used by another constraint. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23002

CDI-23002: The lower bound for the minimum cardinality cannot be lower than 0, nor higher than the upper bound value.

Cause:

No further information is available.

Action:


CDI-23003

CDI-23003: The upper bound for the minimum cardinality cannot be lower than 0.

Cause:

No further information is available.

Action:


CDI-23004

CDI-23004: Invalid Maximum Length value!

Cause:

No further information is available.

Action:


CDI-23005

CDI-23005: Invalid Decimal Places value!

Cause:

No further information is available.

Action:


CDI-23006

CDI-23006: Invalid name value!

Cause:

No further information is available.

Action:


CDI-23007

CDI-23007: Attribute name is not unique!

Cause:

No further information is available.

Action:


CDI-23009

CDI-23009: Invalid Sort Sequence Value!

Cause:

No further information is available.

Action:


CDI-23010

CDI-23010: You must enter a Value in the row

Cause:

No further information is available.

Action:


CDI-23011

CDI-23011: Value name is not unique!

Cause:

No further information is available.

Action:


CDI-23012

CDI-23012: Cannot be overridden

Cause:

No further information is available.

Action:


CDI-23013

CDI-23013: Invalid name value!

Cause:

No further information is available.

Action:


CDI-23014

CDI-23014: The type operation name is not unique within type member!

Cause:

No further information is available.

Action:


CDI-23015

CDI-23015: Incorrect sort sequence value!

Cause:

No further information is available.

Action:


CDI-23016

CDI-23016: Duplicate Name!

Cause:

No further information is available.

Action:


CDI-23017

CDI-23017: Please enter a unique name for this attribute or delete the row.

Cause:

No further information is available.

Action:


CDI-23018

CDI-23018: The name %1 is being used by more than one attribute, please use unique names.

Cause:

No further information is available.

Action:


CDI-23019

CDI-23019: Please enter a unique name for this object type.

Cause:

No further information is available.

Action:


CDI-23020

CDI-23020: This name is being used by another abstract type. Please enter a different name

Cause:

No further information is available.

Action:


CDI-23021

CDI-23021: Please enter a unique name for this operation or delete the row.

Cause:

No further information is available.

Action:


CDI-23022

CDI-23022: Please enter a unique name for this operation or delete the row.

Cause:

No further information is available.

Action:


CDI-23023

CDI-23023: Please enter a unique name for this attribute or delete the row.

Cause:

No further information is available.

Action:


CDI-23024

CDI-23024: The name %1 is being used by more than one attribute, please use unique names.

Cause:

No further information is available.

Action:


CDI-23025

CDI-23025: Please enter a unique name for this object type.

Cause:

No further information is available.

Action:


CDI-23026

CDI-23026: This name is being used by another abstract type. Please enter a different name

Cause:

No further information is available.

Action:


CDI-23027

CDI-23027: This is a mandatory property. Please enter a value.

Cause:

No further information is available.

Action:


CDI-23028

CDI-23028: The value you have specified for this property is out of range. Please enter a different value.

Cause:

No further information is available.

Action:


CDI-23029

CDI-23029: Please enter a unique name for this value type.

Cause:

No further information is available.

Action:


CDI-23030

CDI-23030: Enter a positive integer for the file size.

Cause:

No further information is available.

Action:


CDI-23031

CDI-23031: This name is being used by another abstract type. Please enter a different name.

Cause:

No further information is available.

Action:


CDI-23032

CDI-23032: You must enter a value in either the Identifier or the Value column

Cause:

No further information is available.

Action:


CDI-23033

CDI-23033: Please enter a valid number in the Maximum Length field

Cause:

No further information is available.

Action:


CDI-23034

CDI-23034: Please enter a valid number in the Decimal Places field

Cause:

No further information is available.

Action:


CDI-23035

CDI-23035:The current row is empty. Please enter a module name for this row or remove the row from the grid.

Cause:

No further information is available.

Action:


CDI-23036

CDI-23036: The name %1 is being used by another module. Please enter a different name or remove the row.

Cause:

No further information is available.

Action:


CDI-23037

CDI-23037: Name is not entered

Cause:

No further information is available.

Action:


CDI-23038

CDI-23038: The name %1 is being used by another module. Please enter a different name.

Cause:

No further information is available.

Action:


CDI-23039

CDI-23039: Enter a non-zero Context ID prefix

Cause:

No further information is available.

Action:


CDI-23049

CDI-23049 Unable to lock %1 %2.

Cause:

No further information is available.

Action:


CDI-23060

CDI-23060: Enter a unique name for the foreign key constraint.

Cause:

No further information is available.

Action:


CDI-23061

CDI-23061: Table name is blank

Cause:

You have not selected a join table for this foreign key

Action:

Select a table from the join table droplist


CDI-23064

CDI-23064: No columns have been defined for the unique key. Do you still wish to use the unique key?

Cause:

No further information is available.

Action:


CDI-23066

CDI-23066: Warning - the selected table has no columns.

Cause:

No further information is available.

Action:


CDI-23067

CDI-23067: Enter a unique name for the column.

Cause:

No further information is available.

Action:


CDI-23068

CDI-23068: There are no columns in table %1 of type %2.

Cause:

No further information is available.

Action:


CDI-23069

CDI-23069: Only the foreign key constraint element will be created, since all details have not yet been entered. Do you wish to add the remaining details?

Cause:

No further information is available.

Action:


CDI-23070

CDI-23070: You must select a column.

Cause:

No further information is available.

Action:


CDI-23071

CDI-23071: Warning - You are about to define a foreign key between two FACT tables.

Cause:

It is unusual to put FACT tables in relation to each other.

Action:

If it is your intention to put a relation between these FACT tables,be aware that they could handicap functionality (eg. moving from one time instance to another)


CDI-23089

CDI-23089: You must enter a filename if you choose to source the library code from a file.

Cause:

No further information is available.

Action:


CDI-23090

CDI-23090: Enter a unique short name for the module.

Cause:

No further information is available.

Action:


CDI-23091

CDI-23091: Select a language for the module.

Cause:

No further information is available.

Action:


CDI-23092

CDI-23092: Enter a purpose for the module.

Cause:

No further information is available.

Action:


CDI-23093

CDI-23093: This short name is already used by another module. Please enter a unique short name.

Cause:

No further information is available.

Action:


CDI-23094

CDI-23094: Enter a positive integer for the maximum length of the argument.

Cause:

No further information is available.

Action:


CDI-23095

CDI-23095: Please enter a unique name for this argument

Cause:

No further information is available.

Action:


CDI-23096

CDI-23096: Please select a domain or a datatype for this argument.

Cause:

No further information is available.

Action:


CDI-23098

CDI-23098: This name is already used by another argument. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23099

CDI-23099: One or more arguments in this module are not defined by a domain or datatype. These arguments will not appear in the argument list.

Cause:

It is unusual to define arguments of a general module against a datastructre, table, column or Oracle object type. This is usually done for arguments of a PL/SQL module.

Action:

Either set the arguments to be defined by a domain or a datatype, or ignore this warning.


CDI-23150

CDI-23150: Enter a unique name for the node.

Cause:

No further information is available.

Action:


CDI-23151

CDI-23151: Select the type of node from the dropdown list or enter a new type.

Cause:

No further information is available.

Action:


CDI-23152

CDI-23152: This name is already used by another node. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23180

CDI-23180: Enter a positive integer for the number of decimal places.

Cause:

No further information is available.

Action:


CDI-23181

CDI-23181: Enter a unique name for the PL/SQL table.

Cause:

No further information is available.

Action:


CDI-23182

CDI-23182: Enter a positive integer for the maximum length.

Cause:

No further information is available.

Action:


CDI-23186

CDI-23186: Enter a unique name for the record.

Cause:

No further information is available.

Action:


CDI-23188

CDI-23188: Enter a unique name for the field.

Cause:

No further information is available.

Action:


CDI-23189

CDI-23189: This will delete all datastructure items you have already defined. Do you wish to continue?

Cause:

No further information is available.

Action:


CDI-23210

CDI-23210: All the columns are already used by another key constraint.

Cause:

No further information is available.

Action:


CDI-23242

CDI-23242: Warning - you have set the index type to BITMAP where the context table is of type DIMENSION

Cause:

BITMAP Index access could slow down access and therfore should not be used to access DIMENSION-tables.

Action:

Don't BITMAP them or be aware of possible performance problem


CDI-23243

CDI-23243: Warning - One or more index entries are to the primary key of the context FACT table, but the index type is not BITMAP

Cause:

Columns of FACT-tables which represent relation to DIMENSION table should be BITMAP for increase of performance

Action:

BITMAP them or be aware of possible performance problem


CDI-23270

CDI-23270: This name is already used by another rollback segment. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23271

CDI-23271: Enter a unique name for this rollback segment.

Cause:

No further information is available.

Action:


CDI-23272

CDI-23272: Enter a positive integer for the optimal size.

Cause:

No further information is available.

Action:


CDI-23273

CDI-23273: This name is already used by another tablespace. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23274

CDI-23274: You must select an existing tablespace or enter the name of a new tablespace.

Cause:

No further information is available.

Action:


CDI-23300

CDI-23300: This name is already used by another storage definition. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23301

CDI-23301: Enter a unique name for this storage definition

Cause:

No further information is available.

Action:


CDI-23302

CDI-23302: The minimum number of extents must not exceed the maximum number of extents.

Cause:

No further information is available.

Action:


CDI-23304

CDI-23304: Enter a positive integer for the number of freelists in each group.

Cause:

No further information is available.

Action:


CDI-23305

CDI-23305: Enter a positive integer for the size of the first extent that will be allocated when the object is created.

Cause:

No further information is available.

Action:


CDI-23306

CDI-23306: Enter a positive integer for the size of every extent to be allocated, after the initial extent.

Cause:

No further information is available.

Action:


CDI-23307

CDI-23307: Enter a positive integer for the percentage increase by which each following extent will grow over the last extent allocated.

Cause:

No further information is available.

Action:


CDI-23308

CDI-23308: Enter a positive integer for the initial number of extents to be allocated.

Cause:

No further information is available.

Action:


CDI-23309

CDI-23309: Enter a positive integer for the maximum number of extents that can ever be allocated.

Cause:

No further information is available.

Action:


CDI-23330

CDI-23330: This name is already used by another snapshot refresh group. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23331

CDI-23331: Enter a unique name for this snapshot refresh group.

Cause:

No further information is available.

Action:


CDI-23360

CDI-23360: Enter a unique name for this sequence.

Cause:

No further information is available.

Action:


CDI-23361

CDI-23361: This name is already used by another sequence. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23390

CDI-23390: Enter a purpose for this trigger.

Cause:

No further information is available.

Action:


CDI-23391

CDI-23391: Enter a unique name for this trigger.

Cause:

No further information is available.

Action:


CDI-23392

CDI-23392: This name is already used by another database trigger. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23420

CDI-23420: This name is already used by another tablespace. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23421

CDI-23421: Enter a unique name for this tablespace.

Cause:

No further information is available.

Action:


CDI-23422

CDI-23422: Enter a positive integer for the quota size.

Cause:

No further information is available.

Action:


CDI-23450

CDI-23450: Enter a unique name for this window.

Cause:

No further information is available.

Action:


CDI-23451

CDI-23451: This name is already used by another window. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23452

CDI-23452: Enter a positive integer for the X-position of the generated window.

Cause:

No further information is available.

Action:


CDI-23453

CDI-23453: Enter a positive integer for the Y-position of the generated window.

Cause:

No further information is available.

Action:


CDI-23454

CDI-23454: Enter a positive integer for the default width of the generated window.

Cause:

No further information is available.

Action:


CDI-23455

CDI-23455: Enter a positive integer for the default height of the generated window.

Cause:

No further information is available.

Action:


CDI-23500

CDI-23500: The ATD has been passed an object which is not in the cache, and is therefore unable to diagram it.

Cause:

This is an internal error.

Action:

Save any outstanding changes and then restart Object Designer.


CDI-23501

CDI-23501: You are about to Delete the current diagram. Are you sure ?

Cause:

No further information is available.

Action:


CDI-23503

CDI-23503: Value types may only be specialized from one other value type.

Cause:

No further information is available.

Action:


CDI-23504

CDI-23504: Failed to create object. Make sure the object is entered in the system registry.

Cause:

No further information is available.

Action:


CDI-23506

CDI-23506: Generation completed Successfully.

Cause:

No further information is available.

Action:


CDI-23507

CDI-23507: A problem occurred during Generation.

Cause:

No further information is available.

Action:


CDI-23509

CDI-23509: The elements are already represented on the diagram. No new representations added.

Cause:

You have attempted to add (via the clipboard or by dragging and droping), an Object Type or Value Type which is already shown on the diagram. This functionality is not supported.

Action:

No further action required.


CDI-23551

CDI-23551: The %1 %2 is out of date. Do you want to requery ?

Cause:

This may be caused by another user modifying this element or the design editor may not have consolidated all the elements it should have after making some change.

Action:

Requery the database so that the most up to date information is being presented in the Design Editor.


CDI-23552

CDI-23552: The %1 %2 has been deleted by another user. Do you want to requery ?

Cause:

No further information is available.

Action:


CDI-23553

CDI-23553: Unable to initialise the Properties Window

Cause:

The Properties Window could not be loaded.

Action:

Check that the palette has been installed correctly and that has been installed in a directory in your PATH


CDI-23554

CDI-23554: Unable to load %1. Check that this DLL is installed correctly.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-23555

CDI-23555: Diagrams can only be deleted from within the diagrammer.

Cause:

No further information is available.

Action:


CDI-23556

CDI-23556: A column must be entered for the foreign key.

Cause:

No further information is available.

Action:


CDI-23557

CDI-23557: The tables are not joined by a foreign key. To create a lookup a foreign key constraint must exist between the tables

Cause:

No further information is available.

Action:


CDI-23558

CDI-23558: Fatal Error - Unable to initialise the application system.

Cause:

The Repository data for the selected Application System is incorrect.

Action:

Check that you have installed compatible versions of client and server software


CDI-23559

CDI-23559: Check that your PATH contains a valid copy of ""%1"".

Cause:

The component could not be loaded.

Action:

Check that this component has been installed correctly and that has been installed in a directory in your PATH


CDI-23560

CDI-23560: Developer/2000 not installed or missing dll. Please check that the product has been installed correctly.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-23562

CDI-23562: The variable ""%1"" is not set correctly in the [%2] section f your Registry. This would indicate the name of a file to be loaded.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-23563

CDI-23563: A problem occured while trying to load the Generator. Please check with Support.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-23564

CDI-23564: "" %1"" could not be loaded or does not exist. Please check that the product has been installed correctly.

Cause:

A component has failed to load for some reason. This could be due to the fact that it is not correctly defined in the system registry.

Action:

Check the registry settings for the location of the required component. If necessary, try reinstalling.


CDI-23565

CDI-23565: A Key Based Link cannot be created because there are no applicable Key Constraints, or the link is already used.

Cause:

No further information is available.

Action:


CDI-23570

CDI-23570: Unable to determine the base table usage as there is no foreign key between the tables.

Cause:

No further information is available.

Action:


CDI-23572

CDI-23572: The connection to the database has been lost. Any outstanding changes will be lost.

Cause:

No further information is available.

Action:


CDI-23573

CDI-23573: Error in displaying items and groups. The item groups are recursively nested.

Cause:

The parent of one of the item groups is the same as one of its nested item groups.

Action:

Change the Parent Item Group.


CDI-23574

CDI-23574: Unable to set the Parent Item Group as this is recursively nested.

Cause:

The Parent Item Group is the same as a nested item group

Action:

Change the Parent Item Group.


CDI-23630

CDI-23630: Enter a positive integer for the button width.

Cause:

No further information is available.

Action:


CDI-23631

CDI-23631: Enter a unique name for the action item.

Cause:

No further information is available.

Action:


CDI-23632

CDI-23632: Enter a positive integer for the button height.

Cause:

No further information is available.

Action:


CDI-23633

CDI-23633: This name is already used by another action item. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23634

CDI-23634: Select a module to navigate to.

Cause:

No further information is available.

Action:


CDI-23690

CDI-23690: Enter a unique name for the module component.

Cause:

No further information is available.

Action:


CDI-23691

CDI-23691: This name is already used by another module component. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23692

CDI-23692: Select a language for this module component.

Cause:

No further information is available.

Action:


CDI-23693

CDI-23693: Enter a positive integer for the number of rows displayed.

Cause:

No further information is available.

Action:


CDI-23694

CDI-23694: Enter a positive integer for the x position.

Cause:

No further information is available.

Action:


CDI-23695

CDI-23695: Please enter a positive integer for the y position.

Cause:

No further information is available.

Action:


CDI-23696

CDI-23696: Please enter a positive integer for the canvas width.

Cause:

No further information is available.

Action:


CDI-23697

CDI-23697: Please enter a positive integer for the canvas height.

Cause:

No further information is available.

Action:


CDI-23698

CDI-23698: Please enter a positive integer for the view width.

Cause:

No further information is available.

Action:


CDI-23699

CDI-23699: Please enter a positive integer for the view height.

Cause:

No further information is available.

Action:


CDI-23700

CDI-23700: Please enter a positive integer for the chart width.

Cause:

No further information is available.

Action:


CDI-23701

CDI-23701: Please enter a positive integer for the chart height.

Cause:

No further information is available.

Action:


CDI-23702

CDI-23702: Please enter a positive integer for the context ID prefix.

Cause:

No further information is available.

Action:


CDI-23720

CDI-23720: Enter a unique name for the module component.

Cause:

No further information is available.

Action:


CDI-23721

CDI-23721: This name is already used by another module component. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23751

CDI-23751: This name is already used by another item group. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23752

CDI-23752: Item group %1 has no items in it.

Cause:

No further information is available.

Action:


CDI-23753

CDI-23753: Enter a positive integer for the number of rows displayed.

Cause:

No further information is available.

Action:


CDI-23754

CDI-23754:Enter a positive integer for the x position.

Cause:

No further information is available.

Action:


CDI-23755

CDI-23755: Enter a positive integer for the y position.

Cause:

No further information is available.

Action:


CDI-23811

CDI-23811: Enter a scale for this datatype.

Cause:

No further information is available.

Action:


CDI-23812

CDI-23812: Enter a length if you specify a scale for this datatype.

Cause:

No further information is available.

Action:


CDI-23813

CDI-23813: Enter a positive integer for the number of decimal places.

Cause:

No further information is available.

Action:


CDI-23814

CDI-23814: Enter a positive integer for the maximum length.

Cause:

No further information is available.

Action:


CDI-23815

CDI-23815: This name is already used by another argument. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23816

CDI-23816: This name is already used by another datum. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23817

CDI-23817: Enter a unique name for the exception.

Cause:

No further information is available.

Action:


CDI-23818

CDI-23818: This name is already used by another exception. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23819

CDI-23819: This name is already used by another module. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23820

CDI-23820: Enter the name of a file containing the source.

Cause:

No further information is available.

Action:


CDI-23821

CDI-23821: Enter a unique name for the module.

Cause:

No further information is available.

Action:


CDI-23827

CDI-23827: Enter a default value for this constant.

Cause:

No further information is available.

Action:


CDI-23828

CDI-23828: This program datum has been included in the PL/SQL definition more than once, please select a different program datum.

Cause:

No further information is available.

Action:


CDI-23829

CDI-23829: Select a return type for this PL/SQL function.

Cause:

PL/SQL modules of type FUNCTION must have a Return Type value set.

Action:

Either select a Return Type or change the type of this PL/SQL module to something other than FUNCTION.


CDI-23840

CDI-23840: Enter a positive integer for the number of sequence values cached.

Cause:

No further information is available.

Action:


CDI-23841

CDI-23841: A sequence can not have an increment of zero. Please enter a new value.

Cause:

No further information is available.

Action:


CDI-23844

CDI-23844: Enter a positive or negative integer for the first sequencenumber to be generated.

Cause:

No further information is available.

Action:


CDI-23845

CDI-23845: Enter a non-zero integer by which sequence is incremented.

Cause:

No further information is available.

Action:


CDI-23870

CDI-23870: Enter a unique name for the role.

Cause:

No further information is available.

Action:


CDI-23871

CDI-23871: This name is already used by another role. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23872

CDI-23872: You have already assigned the role '%1' via the role '%2'.

Cause:

No further information is available.

Action:


CDI-23900

CDI-23900: Enter a unique name for the user.

Cause:

No further information is available.

Action:


CDI-23901

CDI-23901: This name is already used by another user. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23902

CDI-23902: Enter an initial password for the user.

Cause:

No further information is available.

Action:


CDI-23903

CDI-23903: Enter a positive integer for the quota size.

Cause:

No further information is available.

Action:


CDI-23904

CDI-23904: Warning - system privileges granted through other roles will not be removed.

Cause:

No further information is available.

Action:


CDI-23905

CDI-23905: Enter a unique object Table name.

Cause:

No further information is available.

Action:


CDI-23907

CDI-23907: Select an object for the table.

Cause:

No further information is available.

Action:


CDI-23908

CDI-23908: Enter a unique collection name.

Cause:

No further information is available.

Action:


CDI-23909

CDI-23909: The collection type cannot be null

Cause:

No further information is available.

Action:


CDI-23910

CDI-23910: The scalar data type must not be null.

Cause:

No further information is available.

Action:


CDI-23911

CDI-23911: A collection of type Object must contain an object type.

Cause:

No further information is available.

Action:


CDI-23912

CDI-23912: Enter a varray limit

Cause:

No further information is available.

Action:


CDI-23960

CDI-23960: Enter a unique name for the snapshot.

Cause:

No further information is available.

Action:


CDI-23961

CDI-23961: The SQL statement could not be parsed.

Cause:

No further information is available.

Action:


CDI-23962

CDI-23962: Enter a unqiue name for this column.

Cause:

No further information is available.

Action:


CDI-23963

CDI-23963: This name is used by another column. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23964

CDI-23964: This name is already used by another table, view or snapshot. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23967

CDI-23967: Please enter a positive integer for the display height.

Cause:

No further information is available.

Action:


CDI-23990

CDI-23990: Select a table, view or snapshot.

Cause:

No further information is available.

Action:


CDI-23991

CDI-23991: Select a table, view or snapshot.

Cause:

No further information is available.

Action:


CDI-23992

CDI-23992: This alias is already used by another table usage. Please enter a unique alias.

Cause:

No further information is available.

Action:


CDI-23993

CDI-23993: Enter a unique alias for this table usage.

Cause:

No further information is available.

Action:


CDI-23994

CDI-23994: Enter a unique name for this item.

Cause:

No further information is available.

Action:


CDI-23995

CDI-23995: This name is already used by another item. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-23996

CDI-23996: Enter a positive integer for the display width.

Cause:

No further information is available.

Action:


CDI-23997

CDI-23997: Enter a positive integer for the display height.

Cause:

No further information is available.

Action:


CDI-24050

CDI-24050: Enter a unique name for the view.

Cause:

No further information is available.

Action:


CDI-24052

CDI-24052: Enter a unqiue name for this column.

Cause:

No further information is available.

Action:


CDI-24054

CDI-24054: This name is already used by another table, view or snapshot. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24055

CDI-24055: This alias is already used by another table, view or snapshot. Please enter a unique alias.

Cause:

No further information is available.

Action:


CDI-24056

CDI-24056: Enter a positive integer for the display width.

Cause:

No further information is available.

Action:


CDI-24057

CDI-24057: Enter a positive integer for the display height.

Cause:

No further information is available.

Action:


CDI-24058

CDI-24058: Please select an Oracle object type for this object view

Cause:

No further information is available.

Action:


CDI-24059

CDI-24059: Warning - At least one DIMENSION table in the selection list does not relate to the FACT table in the selection list.

Cause:

No further information is available.

Action:


CDI-24060

CDI-24060: Warning You are attempting to create a view based on more than one FACT tables

Cause:

No further information is available.

Action:


CDI-24080

CDI-24080: Select the table to implement.

Cause:

No further information is available.

Action:


CDI-24081

CDI-24081: Enter a unique name for this table partition.

Cause:

No further information is available.

Action:


CDI-24082

CDI-24082: Enter an expression for this table partition.

Cause:

No further information is available.

Action:


CDI-24083

CDI-24083: This name is already used by another table partition. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24084

CDI-24084: The maximum number of columns in the key is sixteen.

Cause:

No further information is available.

Action:


CDI-24110

CDI-24110: The maximum number of columns in the key is sixteen.

Cause:

No further information is available.

Action:


CDI-24111

CDI-24111: Enter a unique name for this index partition.

Cause:

No further information is available.

Action:


CDI-24112

CDI-24112: Enter an expression for this index partition.

Cause:

No further information is available.

Action:


CDI-24113

CDI-24113: This name is already used by another index partition. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24114

CDI-24114: Local partitions exist for this index storage. Delete these local partitions before the index storage type can be changed.

Cause:

No further information is available.

Action:


CDI-24115

CDI-24115: Global partitions exist for this index storage. Delete these global partitions before the index storage type can be changed.

Cause:

No further information is available.

Action:


CDI-24116

CDI-24116: Partition keys exist for this index storage.Delete these partition keys before the index storage type can be changed.

Cause:

No further information is available.

Action:


CDI-24117

CDI-24117: This name is already used by another local index partition. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24140

CDI-24140: Enter a unique name for the database.

Cause:

No further information is available.

Action:


CDI-24141

CDI-24141: This name is already used by another database. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24142

CDI-24142: Enter the name for the local database.

Cause:

No further information is available.

Action:


CDI-24143

CDI-24143: Enter a unique name for the user.

Cause:

No further information is available.

Action:


CDI-24144

CDI-24144: Enter an integer between 1 and 255 for the maximum number of instances.

Cause:

No further information is available.

Action:


CDI-24145

CDI-24145: Enter a positive integer for the maximum number of datafiles.

Cause:

No further information is available.

Action:


CDI-24146

CDI-24146: Enter a positive integer for the maximum number of redo log files.

Cause:

No further information is available.

Action:


CDI-24147

CDI-24147:Enterthe maximum number of members in the redo log file group.

Cause:

No further information is available.

Action:


CDI-24150

CDI-24150: Temporary file for Serialized Data could not be created.

Cause:

There is no space left on the disk in the path specified by TEMP environment variable

Action:

Delete unused temporary files in the path specified by TEMP environment variable to create space.


CDI-24151

CDI-24151: Could not get the path for temporary files!

Cause:

The TEMP environment variable is not set, or points to a non-existent path.

Action:

Give the TEMP environment variable value for a valid path in the filesystem.


CDI-24152

CDI-24152: Must Specify a Database!

Cause:

User tried to navigate out of the page leaving the database field blank.

Action:

Enter a name for the Database.


CDI-24153

CDI-24153: Must Specify a Database User!

Cause:

User tried to navigate out of the page leaving the database user field blank.

Action:

Enter a name for the Database User.


CDI-24154

CDI-24154: Commit to repository failed! Could not create new objects.

Cause:

The new database or database user could not be created in the repository

Action:


CDI-24155

CDI-24155: Must specify a filename!

Cause:

User tried to navigate out of the page without specifying a filename after checking the specify filename checkbox

Action:

Uncheck the specify filename checkbox or specify the filename.


CDI-24156

CDI-24156: Problems with initialising common component!

Cause:

No further information is available.

Action:


CDI-24170

CDI-24170: Enter a unique name for this cluster.

Cause:

No further information is available.

Action:


CDI-24171

CDI-24171: Enter a positive integer for the number of hash values

Cause:

No further information is available.

Action:


CDI-24173

CDI-24173: This name is already used by an index cluster.. Please enter another name

Cause:

No further information is available.

Action:


CDI-24174

CDI-24174: Enter a name for the cluster column, or delete this row

Cause:

No further information is available.

Action:


CDI-24175

CDI-24175: This column is already in the cluster

Cause:

No further information is available.

Action:


CDI-24176

CDI-24176: Enter columns with the same datatype and length to be mapped to the same cluster column

Cause:

No further information is available.

Action:


CDI-24177

CDI-24177: This name is already used by another cluster. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24178

CDI-24178: This name is already used by another cluster column. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24200

CDI-24200: Enter a unique name for this table.

Cause:

No further information is available.

Action:


CDI-24201

CDI-24201: This name is already used by another table, view or snapshot. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24202

CDI-24202: This alias is already used by another table, view or snapshot. Please enter a unique alias.

Cause:

No further information is available.

Action:


CDI-24203

CDI-24203: Enter a unique name for this column.

Cause:

No further information is available.

Action:


CDI-24204

CDI-24204: Enter the maximum length of data that can be stored in this column.

Cause:

No further information is available.

Action:


CDI-24205

CDI-24205:Enter a positive integer for the length.

Cause:

No further information is available.

Action:


CDI-24206

CDI-24206: Enter the number of decimal places allowed for this column.

Cause:

No further information is available.

Action:


CDI-24207

CDI-24207: Enter a positive integer for the number of decimal places.

Cause:

No further information is available.

Action:


CDI-24208

CDI-24208: This name is already used by another column. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24209

CDI-24209: Enter a valid value for this allowable value.

Cause:

No further information is available.

Action:


CDI-24210

CDI-24210: This combination of value and meaning is already used. Please enter a unique combination to describe this allowable value.

Cause:

No further information is available.

Action:


CDI-24211

CDI-24211: Enter a unique name for this foreign key.

Cause:

No further information is available.

Action:


CDI-24212

CDI-24212: This name is already used by another constraint. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24213

CDI-24213: Enter a unique name for this primary key.

Cause:

No further information is available.

Action:


CDI-24214

CDI-24214: This name is already used by another constraint. Please enter a unique name.

Cause:

No further information is available.

Action:


CDI-24215

CDI-24215: Warning - this column is in the primary key and will be removed.

Cause:

No further information is available.

Action:


CDI-24216

CDI-24216: Enter a positive integer for the display width.

Cause:

No further information is available.

Action:


CDI-24217

CDI-24217: Enter a positive integer for the display height.

Cause:

No further information is available.

Action:


CDI-24218

CDI-24218: Warning - you are creating a foreign key between two FACT tables

Cause:

No further information is available.

Action:


CDI-24230

CDI-24230: Enter an integer between 0 and 100 for the minimum level of of space usage that Oracle maintains for each block.

Cause:

No further information is available.

Action:


CDI-24231

CDI-24231: Enter an integer between 0 and 100 for the amount of free space in each block that is allocated to a table for future updates.

Cause:

No further information is available.

Action:


CDI-24232

CDI-24232: Enter a positive integer for the maximum number of transactions that can update a block concurrently.

Cause:

No further information is available.

Action:


CDI-24233

CDI-24233: Enter a positive integer for the initial number of transactions that are allocated within each block in the table.

Cause:

No further information is available.

Action:


CDI-24234

CDI-24234: The sum of percent free and percent used must be less than 100.

Cause:

No further information is available.

Action:


CDI-24235

CDI-24235: Select a schema before leaving this page.

Cause:

No further information is available.

Action:


CDI-24236

CDI-24236: Select at least one privilege for the 'create synonym' option

Cause:

No further information is available.

Action:


CDI-24238

CDI-24238: Select an object to implement.

Cause:

No further information is available.

Action:


CGEN-00002

CGEN-00002 Cannot allocate %u bytes of memory

Cause:

memory has been exhausted. Form Generator is unable to allocate any more memory.

Action:

Check the memory available and the memory consumption of other programs that may be running. If the problem persists contact your Customer Support representative.


CGEN-00008

CGEN-00008 Unable to find SDD_ELEMENT; EL_ID = %s

Cause:

Form Generator cannot find the Repository element indicated. The most likely cause is that another user has deleted the element during this Form Generator session.

Action:

Rerun the Form Generator. If the problem persists then the Repository may be corrupted; contact your Customer support representative.


CGEN-00009

CGEN-00009 Valid values are %s or %s to quit

Cause:

You have supplied an invalid response to a question requiring a "Yes" or "No" response.

Action:

Enter one of the options in the list given.


CGEN-00010

CGEN-00010 cgfree: memory unallocated or previously freed

Cause:

This is an internal error message and should not normally be issued.

Action:

Contact your Customer Support representative.


CGEN-00011

CGEN-00011 %d bytes allocated and not freed

Cause:

This is an internal error message and should not normally be issued.

Action:

Contact your Customer Support representative.


CGEN-00012

CGEN-00012 Location %s - invalid argument

Cause:

This is an internal error message and should not normally be issued.

Action:

Contact your Customer Support representative.


CGEN-00013

CGEN-00013 Valid values are integers in the range %d to %d or %s to quit

Cause:

You have entered a number which is not an integer or which is outside the range of allowable values.

Action:

Enter an integer in the range indicated.


CGEN-00014

CGEN-00014 Valid values are integers greater than %d or %s to quit

Cause:

You have entered a number which is not an integer or which is less than the minimum allowed.

Action:

Enter an integer which is greater than or equal to the minimum indicated.


CGEN-00015

CGEN-00015 Valid values are integers less than %d or %s to quit

Cause:

You have entered a number which is not an integer or which is greater than the maximum allowed.

Action:

Enter an integer which is less than or equal to the maximum indicated.


CGEN-00016

CGEN-00016 Unable to open file %s

Cause:

The file shown does not exist, or is not readable.

Action:

Make sure the file exists and is readable. If the file does not exist this may be due to lack of write permission in the current directory.


CGEN-00018

CGEN-00018 Invalid parameter to %s (%d)

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-00019

CGEN-00019 Code group id %d not found. Function = %s

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-00020

CGEN-00020 %s has failed, please send the following information to your support person

Cause:

An unexpected internal failure has occurred.

Action:

Please send the trace back information which was output after this message to your support representative.


CGEN-00023

CGEN-00023 Unable to initialize source control api for the following reason %s

Cause:

The Source control has not been initialized.

Action:

Refer to Source control system documentation regarding the error message issued.


CGEN-00024

CGEN-00024 Source control action failed for the following reason %s

Cause:

The Source control action has failed.

Action:

Refer to Source control system documentation regarding the error message issued.


CGEN-00025

CGEN-00025 Creation of forms text file failed.

Cause:

Creation of the forms text file has failed prior to it being put in source control.

Action:

Check that you have sufficient privileges and space to create files in the working directory. Also check to see if the generated binary file can be loaded into the Form Builder Designer without error.


CGEN-00026

CGEN-00026 Creation of binary file failed .

Cause:

Creation of the forms binary file has failed after the file has been taken out of source control.

Action:

Check that you have sufficient privileges and space to create files in the working directory. Also make sure that the archive file is stored in text format.


CGEN-00027

CGEN-00027 Checking in file %s.

Cause:

File is being checked into source control.

Action:

None.


CGEN-00028

CGEN-00028 Checking out the file %s to %s.

Cause:

File is being checked out of source control.

Action:

None.


CGEN-00029

CGEN-00029 An error occurred whilst writing the log file:- %s

Cause:

The Generator was unable to write the log file.

Action:

Check that the path and filename you entered are valid.


CGEN-00031

CGEN-00031 Unable to create log file

Cause:

Not issued in this release.

Action:

Not issued in this release.


CGEN-00033

CGEN-00033 Unable to read configuration file %s for the following reason: %s

Cause:

The generator was unable to read the configuration file specified.

Action:

Refer to Source control system documentation regarding the error message issued.


CGEN-00034

CGEN-00034 Duplicate program unit name %s

Cause:

The user has defined two named routines which have the same name. This is illegal.

Action:

Change one of the routine names so that they are no longer the same.


CGEN-00035

CGEN-00035 Invalid name (%s) for user named routine

Cause:

The name you have specified for a named routine is invalid for one or both the following reasons:

· the specified name is greater than 30 characters

·the specified name conflicts with names reserved for generated routines (i.e. the name starts with the characters CG, followed by two characters, followed by a $ sign)

Action:

Change the name of the named routine either by reducing the length of the name or by changing the first five characters.


CGEN-00036

CGEN-00036 User modified logic ignored, generatable code not generated

Cause:

The user has modified a generatable piece of event code which would not have been generated this run. The user modified code has been ignored.

Action:

Select help on the generatable event segment in the Design Editor to tell you how this piece of logic is generated.


CGEN-00037

CGEN-00037 The scrollable window %s does not allow vertical scrollbars

Cause:

The window is defined as scrollable, (either by the window's Repository definition, or by the preference WINSCR), and the property 'Show Vertical Scrollbar' in the object library is set to 'No'. Consequently, parts of a canvas may be inaccessible.

Action:

Set the 'Show Vertical Scrollbar' property to 'Yes' in the object library for the window, or set the window to be non-scrollable (either in the Repository or using the preference WINSCR).


CGEN-00038

CGEN-00038 The scrollable window %s does not allow horizontal scrollbars

Cause:

The window is defined as scrollable, (either by the window's Repository definition, or by the preference WINSCR), and the property 'Show Horizontal Scrollbar' in the object library is set to 'No'. Consequently, parts of a canvas may be inaccessible.

Action:

Set the 'Show Horizontal Scrollbar' property to 'Yes' in the object library for the window, or set the window to be non-scrollable (either in the Repository or using the preference WINSCR).


CGEN-00039

CGEN-00039 Unsupported item display datatype '%s'

Cause:

The item display datatype that is specified is not supported by the Form Generator. A text item will be generated instead.

Action:

Set the display datatype for the item to one recognized by the Form Generator.


CGEN-00040

CGEN-00040 Many-to-one relationships are not supported by this Generator

Cause:

Two module components in the module are related by a many-to-one relationship. This is an inverted master detail relationship. This Generator does not support inverted master detail relationships.

Action:

Re-structure the module to exclude many-to-one inverted master detail relationships.


CGEN-00041

CGEN-00041 %s has no module components and/or table usages

Cause:

The Repository definition of the module contains no module components.

Action:

Add at least one module component to the module in the Design Editor/RON.


CGEN-00042

CGEN-00042 Same table relationships are not supported by this Generator

Cause:

Two module components in this module are related by a link between two usages of the same table, based on a primary key constraint. This is a same table relationship. This Generator does not support same table relationships.

Action:

Re-structure the module to exclude same table relationships.


CGEN-00043

CGEN-00043 Constraint %s must have the column references defined

Cause:

The correct column references for this table constraint have not been defined properly. For example, a foreign key must have both the 'column' and 'join column' properties set to valid table columns.

Action:

Ensure that the table's constraint definitions have the table reference properties set to valid tables and the appropriate column properties set to valid table columns.


CGEN-00044

CGEN-00044 Shared Data Links are not supported by this generator

Cause:

The Repository definition of a module includes a module component with a shared data link defined.

Action:

Remove the Shared Data Link from the Module Component.


CGEN-00045

CGEN-00045 Unrecognized comment tag for event segment in '%s' template trigger

Cause:

Form Generator is looking for one of the following comment tags:

·/*CGAP$TES_SEQUENCE_BEFORE*/

·/*CGAP$TES_SEQUENCE_AFTER*/

These tags indicate where to place template code groups in relation to other code for the same trigger in the generated form. Form Generator has found a tag beginning with CGAP$TES. However, the characters that follow do not match either of the recognized tags.

Action:

Change the spelling of the comment tag above the event segment in the template trigger code to one of the following:

·/*CGAP$TES_SEQUENCE_BEFORE*/

·/*CGAP$TES_SEQUENCE_AFTER*/


CGEN-00046

CGEN-00046 '%s' Action Item set to non-displayed because width is not greater than zero

Cause:

The action item width in the Repository is set to zero/unset or the AIBBWD preference is set to none and the action item has not prompt.

Action:

Set the action item width to greater than zero in the Repository or change the value of the preference AIBBWD.


CGEN-00047

CGEN-00047 '%s' Action Item set to non-displayed because height isn't greater than zero

Cause:

The action item height in the Repository is set to zero/unset or the sub-classed action item from the object library has a height set to zero..

Action:

Set the action item width to greater than zero in the Repository or set the height of the sub- classed action item in the object library to a value of greater than zero.


CGEN-00048

CGEN-00048 Unable to capture the Form Module: '%s' to preserve layout.

Cause:

One of the following:

·the form (fmb) cannot be retrieved because the user specified form name and location are incorrect

·the form (fmb) is corrupt

·the form module bears no relation to the module being generated.

Action:

Ensure that the specified form name and file location are correct and the form relates to the same module as the module currently being generated.


CGEN-00049

CGEN-00049 Transfer Canvas '%s' contains item(s), so it can not be removed.

Cause:

The source FMB file, used in the comparison process for Generation Preserving Layout, has an Overflow canvas containing items.

Action:

Reposition the items onto a normal canvas in the source FMB file, using Form Builder. Overflow Canvases are only used as temporary storage for new items when Generating in Preserve Layout mode.


CGEN-00050

CGEN-00050 Failed to compile library, errors detailed in '%s'

Cause:

The command to compile the .pll file into a .plx file has failed. A possible cause is a problem in the .pll file that has resulted in a compilation error. Alternatively, there might be a problem with your environment (e.g. you might have the wrong version of Form Builder installed).

Action:

If compilation errors occurred during generation, the Generator creates a log file detailing the problem. For more information about the compilation error, view the log file from the Build Action dialog box.


CGEN-00051

CGEN-00051 '%s' Action Item name exceeds %d characters in length

Cause:

Name of action item exceeds allowable length.

Action:

Set the name property of the action item to a smaller length name.


CGEN-00052

CGEN-00052 Expanding width of window: %s to fit canvases.

Cause:

The window contains at least one canvas with a width greater than the window's width, and the window is set to non-scrollable.

Action:

Set the window to be scrollable or decrease the sizes of all the canvases belonging to the window.


CGEN-00053

CGEN-00053 Expanding height of window: %s to fit canvases.

Cause:

The window contains at least one canvas with a height greater than the window's height, and the window is set to non-scrollable.

Action:

Set the window to be scrollable or decrease the sizes of all the canvases belonging to the window.


CGEN-00054

CGEN-00054 Cannot access registry key '%s'

Cause:

The application tried to access the specified registry key but an error occurred during the operation. The registry key may not exist.

Action:

Check the key exists in the registry.


CGEN-00055

CGEN-00055 Using Form default Length for %s module argument length

Cause:

The module argument's length property is unset in the Repository definition or has been set to zero.

Action:

Set the module argument length property to a value greater than zero in the Repository.


CGEN-00056

CGEN-00056 Number of rows displayed for '%s' module component is not specified.

Cause:

Form Generator has detected that you did not specify a value for the Rows Displayed property of the module component, or you set the property to zero.

Action:

Set the value of the Rows Displayed property to a value greater than zero unless you want Form Generator to determine the number of rows to be displayed. Form Generator will assume the block to be multi-row.


CGEN-00057

CGEN-00057 Module Generated In Preserve Layout Mode

Cause:

The Preserve Layout Option has been chosen in the Generate Form Dialog Box.

Action:

To Generate the module normally, ensure Preserve Layout checkbox is 'unchecked' in the Generate Form Dialog Box.


CGEN-00058

CGEN-00058 Unable to find Forms compiler

Cause:

Library generator uses the Oracle Developer Forms compiler to convert Forms or common library files between text and binary formats. Library generator was unable to locate the Forms compiler executable.

Action:

Make sure the EXECUTE_FORMS_GENTIME registry variable holds the path of the forms compiler executable, and reinstall if necessary.


CGEN-00059

CGEN-00059 Unable to find Reports compiler

Cause:

Library generator uses the Oracle Developer Reports compiler to convert Reports library files between text and binary formats. Library generator was unable to locate the Reports compiler executable.

Action:

Make sure the EXECUTE_REPORTS_GENTIME registry variable holds the path of the reports compiler executable, and reinstall if necessary.


CGEN-00060

CGEN-00060 Bad or missing Form Builder installation

Cause:

To read and write Oracle Developer Form Builder binary files, Form Generator accesses the Form Builder component. However, Form Generator was unable to locate the Form Builder component. One possible cause might be the length of the FORMS60_PATH Registry variable.

Action:

Try reducing the length of the FORMS60_PATH Registry variable. Alternatively, reinstall the Oracle Developer Form Builder component.


CGEN-00061

CGEN-00061 Named routine '%s' with unrecognized generator comment ignored

Cause:

The generator has encountered a named routine which is marked with a generator comment, but the comment is badly formatted.

Action:

If this is a user named routine then you will have to change the comment at the start of the code to something which doesn't conflict with generated code. See the help system for details on the rules for naming user named routines. If this is a generated routine which you have modified, you need to check the comment in the named routine code is properly formatted. It should be exactly the same as the named routine name but with some extra characters appended. For example, you might add _MODIFIED to the named routine name as follows:

·/* CGLY$CANVAS_MANAGEMENT_MODIFIED */


CGEN-00062

CGEN-00062 Ignoring unrecognized code group '/* %s */'

Cause:

The generator has found a code group that it does not recognize. There may be several reasons for this:

·You are recovering a form generated by a previous version of the generator and the code group is no long valid.

·This is a user event segment which has been given a name which is reserved by the generator.

·This is a user modified code group but the comment has been improperly modified.

Action:

If you are recovering an old form then ignore this warning. If this is a user event segment then make sure you do not have a comment in your code which has a generator reserved name. i.e CGXX$... If this is a user modified event segment then check you have only appended text to the comment and have not altered the name of the code group.


CGEN-00063

CGEN-00063 Cannot find end line for procedure '%s'

Cause:

The recovery tool cannot find the end line for the named procedure. This is most probably due to a syntax error in the procedure text.

Action:

Check the procedure code for syntax errors.


CGEN-00064

CGEN-00064 Cannot find end line for function '%s'

Cause:

The recovery tool cannot find the end line for the named function. This is most probably due to a syntax error in the function text.

Action:

Check the function code for syntax errors.


CGEN-00065

CGEN-00065 Cannot find end line for package spec '%s'

Cause:

The recovery tool cannot find the end line for the named package spec. This is most probably due to a syntax error in the package spec text.

Action:

Check the package spec code for syntax errors.


CGEN-00066

CGEN-00066 Cannot find end line for package body '%s'

Cause:

The recovery tool cannot find the end line for the named package body. This is most probably due to a syntax error in the package body text.

Action:

Check the package body code for syntax errors.


CGEN-00067

CGEN-00067 Cannot capture trigger '%s.%s', error parsing trigger code

Cause:

The recovery tool encountered an error whilst parsing the trigger text. This is most likely to be a syntax error in the trigger text.

Action:

Check the syntax of the trigger text by compiling it in Form Builder.


CGEN-00068

CGEN-00068 Failed to create binary library file '%s'

Cause:

The attempt to create the binary library file failed.

Action:

Check your Form Builder installation is working correctly. If the problem still persists then contact your support representative.


CGEN-00069

CGEN-00069 Bad or missing Reports installation

Cause:

To read and write Oracle Developer Report Builder binary files, the Generator accesses the Report Builder component. However, the Generator was unable to locate the Report Builder component.

Action:

Reinstall the Oracle Developer Report Builder component.


CGEN-00070

CGEN-00070 Unable to create text file '%s' from binary library file '%s'

Cause:

To capture a library, Library Generator must first convert the binary library file into a text file. However, Library Generator is unable to convert the current library into a text file. The library might have attached libraries that Library Generator cannot locate, or Library Generator might be unable to write the text file to the filesystem, or the library file might be corrupt.

Action:

If the library has attached libraries, check that the locations of the attached libraries are included in the appropriate path environment variables in the Registry. To check the library binary file is not corrupt, open it in Oracle Developer. Make sure that Library Generator can save the text file to the filesystem by removing any write-protected files that have the same name as the file Library Generator will create, or by making more space available. If the problem persists, contact your support representative.


CGEN-00071

CGEN-00071 Failed to create Forms API context

Cause:

To read and write Oracle Developer Form Builder binary files, the Generator accesses the Form Builder component. However, an error occurred when the Generator attempted to initialize the Form Builder API.

Action:

Reinstall the Oracle Developer Form Builder component.


CGEN-00074

CGEN-00074 Form Calling Menu Not Permitted

Cause:

An inter-module action item has been created in the form with a navigate to property set to a module of type Menu.

Action:

Remove Action Item or change Action Item's Navigate To property to reference a valid module type.


CGEN-00075

CGEN-00075 Illegal value entered for preference AIBBWD for action item '%s'

Cause:

The preference AIBBWD value for this action item contains an illegal series of characters.

Action:

This preference value must be either a number of greater value than zero, or one of the valid string values defined in the on-line help for this preference.


CGEN-00076

CGEN-00076 Module Argument %s has an illegal item usage

Cause:

A module arguments has an item usage to a lookup item or an item which is not in the first navigable block.

Action:

Delete the item usage or reset the item usage to a base table item in the first navigable block.


CGEN-00077

CGEN-00077 Increasing length of bound module argument %s to match item %s.

Cause:

One of the following:

·The argument has a length specified in the Repository which is less than the length of one of the items which uses this argument.

·An item using the argument is of type date and consequently the argument length needs to be increased to accommodate a 'full date' format.

Action:

Increase the length of the module argument in the Repository to the length of the parameter in the generated form.


CGEN-00078

CGEN-00078 Badly formed named routine '%s'

Cause:

The Repository definition of the specified named routine does not have a recognizable beginning and end.

Action:

Make sure that the code follows the correct syntax for a package specification, package body, function or procedure. In particular, make sure that each code block after a BEGIN keyword is terminated properly with "END;" or "END <block name> ;".


CGEN-00079

CGEN-00079 Module component %s contains table usages but its Datasource property = NONE

Cause:

The named module component contains table usages. However, its Datasource Type property has been set to NONE. This setting is only appropriate for generating non-database control blocks from module components that contain no table usages.

Action:

If the module component is to be generated as a non-database control block, remove the table usage(s). If the module component is to be generated as a database block, set the Datasource Type property to a value other than NONE (refer to the help system to find out which datasource to use).


CGEN-00080

CGEN-00080 Query property of module component %s is set, but its Datasource = NONE

Cause:

The Query property of the named module component has been set to Yes. However, the module component's Datasource Type property has been set to NONE, indicating that it is to be generated as a non-database control block. It is not possible to query non-database control blocks, so the setting of the Query property is inappropriate.

Action:

If the module component is to be generated as a non-database control block, set the module component's Query property to No. If the module component is to be generated as a queryable database block, select a value other than NONE for the module component's Datasource Type property (refer to the help system to find out which datasource to use).


CGEN-00081

CGEN-00081 Module component %s contains table usages but its Datatarget property = NONE

Cause:

The named module component contains table usages. However, its Datatarget Type property has been set to NONE. This setting is only appropriate for generating non-database control blocks from module components that contain no table usages.

Action:

If the module component is to be generated as a non-database control block, remove the table usage(s). If the module component is to be generated as a database block, set the Datatarget Type property to a value other than NONE (refer to the help system to find out which datatarget to use).


CGEN-00082

CGEN-00082 Ins/Upd/Del properties of module component %s set, but its Datatarget = NONE

Cause:

One or more of the Insert, Update, or Delete properties of the named module component has been set to Yes. However, the module component's Datatarget Type property has been set to NONE, indicating that it is to be generated as a non-database control block. It is not possible to perform DML operations on non-database control blocks, so the setting of the Insert/Update/Delete property is inappropriate.

Action:

If the module component is to be generated as a non-database control block, set the module component's Insert, Update and Delete properties to No. If the module component is to be generated as a database block on which DML operations can be performed, select a value other than NONE for the module component's Datatarget Type property (refer to the help system to find out which datatarget to use).


CGEN-00100

CGEN-00100 ERROR

Cause:

Text used in building up error messages.

Action:

None.


CGEN-00101

CGEN-00101 WARNING

Cause:

Text used in building up warning messages.

Action:

None.


CGEN-00102

CGEN-00102 ERROR: SYSTEM

Cause:

Text used in building up system error messages.

Action:

None.


CGEN-00104

CGEN-00104 Error reading input file.

Cause:

The operating system detected an error while reading a file.

Action:

Check disk for physical errors.


CGEN-00105

CGEN-00105 Error rewinding input file.

Cause:

The operating system detected an error while trying to reposition the file pointer to the beginning of the file.

Action:

Check the disk for physical errors since the file was opened.


CGEN-00113

CGEN-00113 Buffer overflow in %s

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-00117

CGEN-00117 Location %s, invalid code %d

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-00158

CGEN-00158 Log file %s is empty

Cause:

The log file, which should contain any errors or warnings issued during generation, does not contain any non-space characters.

Action:

Ensure that there is enough disk space available to write the file.


CGEN-00160

CGEN-00160 Assertion failed in %s, at %s:%d

Cause:

This is an internal error message not normally issued.

Action:

Please make a note of the full error stack following this error message and contact your Customer Support representative.


CGEN-00162

CGEN-00162 Call failed in %s, at %s:%d

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-01001

CGEN-01001 No PL/SQL block text for button item %s.%s; Button has no functionality.

Cause:

an item has been defined having a display datatype of 'BUTTON', but no PL/SQL has been defined that will determine the generated buttons functionality.

Action:

Define PL/SQL block text for button item.


CGEN-01002

CGEN-01002 Too many alternate regions

Cause:

The Oracle Form Generator can only support one alternate region per block

Action:

Stack all the item groups into one alternate region


CGEN-01003

CGEN-01003 Placement property changed to New Tab Canvas Page

Cause:

The specified module component's Placement property was set to Same Tab Canvas Page. This implies that a preceding module component exists with its Placement property set to New Tab Canvas Page. However, Form Generator has been unable to locate that preceding module component.

Action:

No action required. Form Generator will change the specified module component's Placement property to New Tab Canvas Page.


CGEN-01005

CGEN-01005 OCX/ActiveX Control Implementation %s for %s.%s not found

Cause:

The given item has a Display Datatype of OCX but a Custom Item of type OLE Container named as its Implementation cannot be found in the template form.

Action:

Ensure that the Implementation for the Repository Item is the name of a Custom Item in the template form of type OCX Control.


CGEN-01006

CGEN-01006 Descriptive Flex name not defined, DFLEX usage ignored

Cause:

The preference DFNAME has a null value in the context of the given item, but a value is required.

Action:

Specify the name of the required descriptive flex using the preference DFNAME


CGEN-01007

CGEN-01007 No Implementation specified for OCX/ActiveX Control %s.%s

Cause:

The specified Repository item is defined as display datatype OCX but the 'Template/Library Object' property is not set.

Action:

Set the 'Template/Library Object' property of the Repository item to an OCX control in the template form.


CGEN-01008

CGEN-01008 Failed to change directory to %s

Cause:

No further information available.

Action:


CGEN-01009

CGEN-01009 Application short name not defined, DFLEX usage ignored

Cause:

The preference DFAPPL has a null value in the context of the given item, but a value is required

Action:

Specify the application short name using the preference DFAPPL


CGEN-01010

CGEN-01010 Lookup Validation WHERE clause is invalid: %s

Cause:

The Lookup Validation where clause and any column ordering have been built up into a WHERE clause for the block. This has failed to parse.

Action:

Correct the restrictive lookup validation condition held on the detailed table usage in the module definition.


CGEN-01011

CGEN-01011 Block with name %s already exists in form, existing block has been deleted.

Cause:

One of the following:

·The template contains a block with a name that is also specified in the Repository

·The Preserve Layout option has been chosen and a block originally generated for a particular window in the form, has been moved to a different window in the form or the corresponding module component has been moved to a different window in the Repository.

Action:

One of the following:

·Change name of block

·If preserving layout, ensure that the block in the original form and the equivalent module component in the Repository are positioned in the same window.


CGEN-01012

CGEN-01012 Inter-module key based links are not supported by this generator

Cause:

The Repository definition of a module includes a module component with a key based link from a module component belonging to a different module.

Action:

Remove the Key Based Data Link from the module component in the source module. Use the 'called module' with 'passed parameters' functionality to pass data from one module to another.


CGEN-01014

CGEN-01014 'Validate in LOV' for item %s.%s not available. Building trigger code.

Cause:

It has been requested that List of Values be used to perform the validation of the specified item (by setting the preference LOVVAL=Y). However this is not possible because the column on which the item is based is:

·part of a multi-column foreign key, or

·within a domain which includes ranges as well as discrete values Validation will therefore be performed by PL/SQL code built on triggers.

Action:

No action required


CGEN-01017

CGEN-01017 Flag %s ignored on column with range

Cause:

The column specified has been defined to have a range but also has either the 'Suggested List' flag and/or the 'Dynamic List' flag set against the column. It is not considered sensible to have these flags set AND ranges as well, therefore the flags will be ignored and the column will be generated with validation against the range.

Action:

You will need to decide which method of validation is appropriate for the column in question and set the flags accordingly.


CGEN-01018

CGEN-01018 Flags %s and %s ignored on column with ranges

Cause:

The column specified has been defined to have a range but also has either the 'Suggested List' flag and/or the 'Dynamic List' flag set against the column. It is not considered sensible to have these flags set AND ranges as well, therefore the flags will be ignored and the column will be generated with validation against the range.

Action:

You will need to decide which method of validation is appropriate for the column in question and set the flags accordingly.


CGEN-01019

CGEN-01019 An equivalent relationship already exists between blocks '%s' and '%s'

Cause:

During generation the generator has attempted to create a relationship between two blocks which already exists. The existing relationship will be used.

Action:

None.


CGEN-01020

CGEN-01020 Not generating help for module as help table not created

Cause:

The CG_FORM_HELP table does not exist, therefore unable to store help information.

Action:

Create the CG_FORM_HELP table.


CGEN-01022

CGEN-01022 No base canvas in window %s for stacked canvas %s

Cause:

during generation, the Form Generator checks that a popup canvas has a base canvas (named CG$PAGE_...) in the same window. This error is flagged because no base canvas has been found.

Action:

Check that the CG$PAGE... canvases have not been deleted or renamed since the form was generated.


CGEN-01023

CGEN-01023 Value in item Help Context Id Prefix contains a negative value or is unset.

Cause:

The Help Context Id item is only allowed to have a positive number specified. It must contain a value for Help to work. Help information will not be available at this level.

Action:

Make sure it is set to a positive number


CGEN-01024

CGEN-01024 Underlying column with the prefix '%s' may cause problems in generated code

Cause:

This is an integrity check on the Repository. Because Form Generator creates parameters for form level procedures with this prefix there may problems resolving the names of the column and the PL/SQL parameter. This is most likely to be a problem if the column is named P_ROWID or the cascade delete rule is enforced in the form.

Action:

Rename the column.


CGEN-01025

CGEN-01025 Help Generator has not been run or a new help item has been added since

Cause:

The Help Context Id is null in the Repository. Help information will not be available at this level.

Action:

Run the Help Generator


CGEN-01026

CGEN-01026 '%s' is not a valid overflow action for block %s based on table %s

Cause:

In the table layout, a block position of "NEW STACKED CANVAS or "SAME STACKED CANVAS" has been chosen. In addition, an overflow style of "SPREAD TABLE" has been set or defaulted from the default block overflow action preference (BLKOVF). The generator cannot build a spread table on a stacked canvas since if the canvas view size is smaller than the canvas size, the spread table will remain fixed when the popup scrolls. This is because the spread table is implemented as a stacked canvas which is anchored to the underlying content canvas, not the stacked canvas.

Action:

The generator created the block using the "WRAP LINE" overflow style. Set an overflow style of something other than "SPREAD TABLE" to remove this warning.


CGEN-01028

CGEN-01028 No implementation class specified for Bean Area

Cause:

The Display Type of the specified Repository item is set to Bean Area but its Template/Library Object property is not set.

Action:

Set the specified Repository item's Template/Library Object property to the name of a Bean Area item in the object library.


CGEN-01029

CGEN-01029 Visual Attribute %s not found in template form

Cause:

To generate current record indicator items the visual attributes named CG$CURRENT_RECORD and CG$OTHER_RECORD should exist in the template form.

Action:

Create these visual attributes in the template form.


CGEN-01030

CGEN-01030 Parameter prefix %s not allowed; try %s instead

Cause:

The preference PARAMP is used as a prefix for parameters in generated PL/SQL. It must start with a letter and contain only those characters which are legal in PL/SQL variable names; i.e. alpha-numeric, underscore and dollar sign.

Action:

Correct the preference PARAMP.


CGEN-01031

CGEN-01031 Table names %s and %s are not unique within %s characters

Cause:

The table names as entered in the Repository are not unique within the specified number of characters. This may cause problems during generation as they are used for naming and identifying objects in the generated code.

Action:

Rename the tables identified in the Repository.


CGEN-01033

CGEN-01033 Form '%s' may not return the domain meaning.

Cause:

If the DVDSPM (display domain meaning) preference is set to 'Y' and the DVLOVF preference is set to use a form.

Action:

The list of values form specified with the DVLOVF preference must assign the meaning item to the global variable ':GLOBAL.CG$REF_MEANING' after the user has selected a value.


CGEN-01034

CGEN-01034 Column %s.%s is not allowed in an expression

Cause:

A lookup table column that is part of a foreign key has been used in an expression.

Action:

Remove column reference from expression. Use the base table column of the foreign key.


CGEN-01036

CGEN-01036 Block %s has the Current Record Visual Attribute property set

Cause:

The block has the Current Record Visual Attribute Group property set.

Action:

If you wish to achieve the same results as setting this property on generation, set the CURREC preference against the captured module component.


CGEN-01045

CGEN-01045 Overflow style invalid with stacked item groups, set to %s

Cause:

No action required. The generator has changed the block's overflow style to "WRAP LINE".

Action:

In the module component layout, an overflow style of "SPREAD TABLE" has been chosen. In addition, the module component contains items which are in a stacked item group. The generator cannot build a stacked item group on a spread table.


CGEN-01046

CGEN-01046 Drilldown generated as current record indicator

Cause:

You have defined a drilldown indicator in a block that has no detail blocks. Therefore there is nothing to drilldown to and the item will be generated as a normal current record indicator

Action:

Define a detail block for the block containing the drilldown indicator


CGEN-01047

CGEN-01047 Form template %s not on template path

Cause:

The specified form template could not be found on the template path

Action:

Check your template path, form template name and if the form template exists


CGEN-01048

CGEN-01048 Unable to process the following ORDER BY clause: <%s>

Cause:

During the Design Capture operation a block's ORDER BY clause was found to contain expressions that were not simple column names. This type of information is not stored in the Repository, so nothing can be extracted from the clause.

Action:

Column usages resulting from this default ordering specification must be entered manually, if desired.


CGEN-01050

CGEN-01050 Item(s) in block %s have the Current Record Visual Attribute property set

Cause:

One or more items in the block has the Current Record Visual Attribute Group property set.

Action:

If you wish to achieve the same results as setting this property on generation, either set the CURREC preference against the captured module component to an appropriate value, or create an unbound item of type "CURRENT RECORD" in the captured module component.


CGEN-01051

CGEN-01051 Preference PAGEXP ignored since canvas expansion required for %s

Cause:

The current content canvas needs to be expanded to display the number of rows requested. However, the user preference 'PAGEXP' is set to N so this has been ignored.

Action:

Set the user preference 'PAGEXP' to 'Y'


CGEN-01057

CGEN-01057 Unable to do %s of item %s in block %s

Cause:

The formula item the summary item is based on contains references to other formula items. This is not allowed when the DSMOQM preference is set to Y.

Action:


CGEN-01058

CGEN-01058 Object library %s is not on template path

Cause:

The specified object library could not be found on the template path.

Action:

Check your template path, object library name and if the object library exists.


CGEN-01059

CGEN-01059 Failed to load object library %s

Cause:

The generator failed to load the object library

Action:

Try loading the object library into Oracle Developer Form Builder to check the file is not corrupt.


CGEN-01060

CGEN-01060 Failed to load menu template %s

Cause:

The menu failed to load.

Action:

Try loading the menu into Oracle Developer Form Builder to check the file is not corrupt.


CGEN-01061

CGEN-01061 Invalid derivation expression '%s' for this item's type

Cause:

The derivation expression is invalid for an item of this type.

Action:

Amend the derivation expression so that it is valid for the item type.


(Untitled)

CGEN-01062 Required item %s used in derivation expression not found in module

Cause:

An item referenced in a derivation expression recorded against an item or column was not found in the Repository module definition.

Action:

Add the missing item to the module definition or change the derivation expression.


CGEN-01064

CGEN-01064 Action Item %s has illegal Source for CALL METHOD Named Passed Value

Cause:

When using the Named Passed Value CALL METHOD, you should only set it's source to be Value, not Item or Argument. Otherwise the default CALL METHOD is used (OPEN FORM).

Action:

Set the source of the Named Passed Value CALL METHOD to be a Value, not an Item or Parameter.


CGEN-01065

CGEN-01065 Invalid PL/SQL Block text - '%s'

Cause:

Invalid text was entered in the PL/SQL text for this item.

Action:

Correct the text.


CGEN-01066

CGEN-01066 Dynamic list flag ignored for item with range

Cause:

The item specified has been defined to have a range but also has 'Dynamic List' flag set against the domain being used. It is not considered sensible to have this flag set AND ranges as well, therefore the flags will be ignored and the column will be generated with validation against the range.

Action:

You will need to decide which method of validation is appropriate for the item in question and set the flag accordingly.


CGEN-01067

CGEN-01067 %s is unsupported language for called modules from Forms

Cause:

A Navigation Action Item was defined with a target module in an unsupported language.

Action:

Change the target of the Navigation Action Item to be a module of a supported language.


CGEN-01068

CGEN-01068 is not supported

Cause:

The Named Passed Value is not supported and so will be ignored.

Action:

Use one of the supported Named Passed Values or remove this one.


CGEN-01069

CGEN-01069 Object Library/Template %s does not exist in the Forms Path

Cause:

The Forms Path registry variable does not include the object library/template path. With the current registry settings, compilation errors may occur when trying to compile and/or run the generated form.

Action:

Modify the Forms Path registry variable to include the template/object library path.


CGEN-01073

CGEN-01073 Formula item '%s' has an invalid formula

Cause:

This calculated formula item either has an invalid formula or the formula property for the item is empty. This item will be marked as a custom unbound item.

Action:

If you want to capture this item as the correct type you should either change the formula to make it valid or mark the item as non-calculated.


CGEN-01074

CGEN-01074 Summary item '%s' has an empty mandatory property

Cause:

This calculated summary item has an empty mandatory property on the form.

Action:

To capture this item correctly set the empty property on the form to a valid value. The possible empty values are summary function, summarized block name or summarized item name.


CGEN-01075

CGEN-01075 Skipping mirror item '%s' as the mirrored item is unbound

Cause:

An item in the form which is based on a non-database item was found.

Action:

Either change the item the mirror item is based on to be a database item or change the mirror item to a non-mirror item.


CGEN-01076

CGEN-01076 Implementation source object specified (%s), but no Object Library loaded

Cause:

An implementation source object was specified but no object library is currently being used. Generation will continue, but the implementation source object cannot be used.

Action:

Specify an object library that contains the implementation source object, or remove the implementation source object from the definition of the Repository object.


CGEN-01077

CGEN-01077 Implementation source object %s not found in Object Library

Cause:

An implementation source object was specified but it does not exist in the object library that is currently being used. Generation will continue but the object will not be based on the implementation source object.

Action:

Add a definition of the named implementation source object to the object library that is currently being used, or specify an object library that contains a definition of the named object.


CGEN-01078

CGEN-01078 Invalid default value %s

Cause:

The argument CG$STARTUP_MODE or named passed value STARTUP_MODE is used to control the default mode which this module starts in. The value you enter was not a supported startup mode. The generator has defaulted to use startup mode NORMAL.

Action:

Change the default value of argument CG$STARTUP_MODE or named passed value STARTUP_MODE to be one of the supported values.


CGEN-01080

CGEN-01080 Default value for item is greater than %s characters

Cause:

The length of the default value for an item is greater than the Repository limit. The default value will be truncated to be within the limit.

Action:

Either change the default value for the item in the form and run the Design Capture tool again, or amend the default value in the Repository to a correct value.


CGEN-01081

CGEN-01081 Hint text for item is longer than %s characters

Cause:

The length of the hint text for an item is greater than the Repository limit. The hint text will be truncated to be within the limit.

Action:

Either change the hint text for the item in the form and run the Design Capture tool again, or amend the hint text in the Repository.


CGEN-01082

CGEN-01082 Nested stacked groups not supported; stacked flag ignored

Cause:

Tab canvases must be placed on a content canvas. A tab canvas cannot be placed on another tab canvas; there is no implementation of nested tab canvases.

Action:

To remove this warning, unset the item group stacked flag.


CGEN-01083

CGEN-01083 Making item %s the first item in List of Values '%s'

Cause:

The validate using LOV preference 'LOVVAL' is set to 'Y' and the item being validated is currently not the first item in the lookup table usage. This item needs to be the first item in the list so that Forms can do the validation.

Action:

If you want this item to appear elsewhere in the list you must set LOVVAL to 'N' so that validation is carried out using triggers.


CGEN-01084

CGEN-01084 Library module '%s' not found in the Repository

Cause:

An attached library in the form being captured has no corresponding module in the Repository. Therefore no link will be created from the form module.

Action:

If you want to create a link from the form module you should do one of the following:

·Create a library module in the Repository with the same name as the attached library, and then re-run the Forms Design Capture tool.

·Use the Library Design Capture tool to capture the library, and then re-run the Forms Design Capture tool.


CGEN-01085

CGEN-01085 Not extracting template from database, already exists on file system (%s)

Cause:

Template with same name as template being extracted from the database exists in the current directory.

Action:

Remove template on file system.


CGEN-01086

CGEN-01086 Attached library '%s' not found in forms search path. Using full path name.

Cause:

Form Generator could not locate the library to attach to the generated form in any of the paths specified by the appropriate Form Builder Registry variables. However, Form Generator did locate the library in the path specified as the destination for generated library modules. To ensure that the library is located at runtime, Form Generator has hard coded that path into the generated form. However, hard coding the path into the form makes the generated application significantly less portable, and is therefore not recommended.

Action:

Add the path identifying the location of the attached library module to the appropriate Form Builder Registry variable. Consult the Form Builder documentation if you are not sure which Registry variable to use.


CGEN-01087

CGEN-01087 '%s' Lookup list item not generated: other lookup items are also displayed

Cause:

A lookup list item (Poplist or Textlist) has been specified in a lookup table usage where other lookup items are also set as displayed.

Action:

Ensure that the lookup list item is the only lookup table usage item with the 'display' property set to 'yes'.


CGEN-01088

CGEN-01088 '%s' Lookup list item not generated: foreign key item is set to displayed

Cause:

At least one base table usage foreign key item is specified as displayed.

Action:

Ensure that all base table usage foreign key columns have the 'display' property set to 'no'.


CGEN-01089

CGEN-01089 '%s' Lookup list item not generated: source column is not unique

Cause:

The table column which the lookup list item is based upon is not the only member column of a unique key for the table.

Action:

Set the lookup list item to be based upon a table column where the column is the only member column of a unique key defined for the table.


CGEN-01093

CGEN-01093 '%s' Lookup list item not generated: some foreign key items are not present

Cause:

At least one base table foreign key column has not got an item defined for it.

Action:

Ensure that all base table foreign key columns have base table usage items defined for them and that all the items' display' properties are set to 'no'.


CGEN-01094

CGEN-01094 '%s' Lookup Table Usage contains illegal validation clause

Cause:

The Lookup's 'Validation Where Clause Property' contains a reference to a generated item in the current block/module component, which means that the lookup list item will not have its values populated correctly in a running form.

Action:

Remove part of the validation clause which references an item in the current block/module component.


CGEN-01102

CGEN-01102 Impossible prompt layout

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-01105

CGEN-01105 Display length of right justified item %s.%s has been truncated.

Cause:

This occurs when the generator has to truncate the display length of the named item in order to fit it into the necessary width. This may result in the whole or part of the item's value not being visible when records are queried. However, the item will be scrollable so that the whole of the value can eventually be seen.

Action:

No action required. To avoid this warning in future executions of Form Generator, consider altering preference values so that more width is available in order to layout the items of the form.


CGEN-01109

CGEN-01109 No functions found for flavor %d

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-01110

CGEN-01110 Default value of column %s.%s not used because column is auto-generated.

Cause:

A column definition in the Repository has been defined as both having a default value, and as having its value derived from a unique source. In this situation, Form Generator ignores the default value.

Action:

No action required. To avoid this warning in future executions of Form Generator, remove the default value from the column definition in the Repository.


CGEN-01111

CGEN-01111 Unique ID generated column %s.%s is not in any primary or unique keys.

Cause:

A column is defined in the Repository as having its value derived from a unique source, but that column is not included in any of its table's Unique or Primary keys.

Action:

This warning is simply highlighting an area of the design in the Repository that does not seem correct. Generation of the current module is not affected.


CGEN-01119

CGEN-01119 Base table %s of block %s has no primary or unique keys

Cause:

A table that has no Unique or Primary key is being used in this module to create or update records.

Action:

No action is required. This warning is highlighting an area in the database design that does not seem correct. Generation of the current module is not affected.


CGEN-01124

CGEN-01124 Missing columns in key %s in table %s in insert/update block

Cause:

There are missing usages for one or more columns in the given unique or primary key, from a table usage in which Insert is allowed.

Action:

This warning is simply highlighting an area of the design in the Repository that does not seem correct. Generation of the current module is not affected.


CGEN-01126

CGEN-01126 cflufl() called with no candidate items

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-01133

CGEN-01133 Cannot journal table %s; no usages for entire primary key

Cause:

The table specified is defined in the Repository as being journaled, but either the table has no primary key, or not all columns in the primary key are being used in this module. A journaled table must have a non-updateable primary key.

Action:

Define a primary key for your table and/or ensure that the module definition includes items for all columns in the primary key.


CGEN-01139

CGEN-01139 No validation generated on partially specified foreign key %s.%s

Cause:

The foreign key displayed has usages for some but not all of its columns, within the given table usage. Form Generator has not generated any code that will validate against this foreign key.

Action:

This warning is simply highlighting an area of the design in the Repository that does not seem correct. Generation of the current module is not affected. to avoid this warning in future executions of Form Generator, include usages in the module definition for those columns that are missing.


CGEN-01140

CGEN-01140 Column %s.%s used in link to previous block changed to non-display

Cause:

A column usage has been used to link a block back to a previous block in the generated form. As the usage indicated that update is not allowed in this column, there is no need to display the column value; therefore Form Generator has updated the usage to make it non-display.

Action:

This warning is highlighting an area in the module design that does not seem correct. Generation of the current module is not affected. No action is required.


CGEN-01145

CGEN-01145 Template form %s does not exist

Cause:

The generator cannot load the template form whose name is defined in the STFFMB preference.

Action:

Log into Oracle Form Builder, and ensure that the form exists in the Form Builder database. If the owner of the form is not yourself, check that its owner has granted you access to it. Or ensure the template form exists in the file system.


CGEN-01153

CGEN-01153 Cannot derive value for column %s.%s with default value

Cause:

A column is defined in the Repository as both being derived from an expression, and as having a default value.

Action:

This warning is followed by a question asking if the default is not to be used. Form Generator will then either not use the default value, or will not use the derivation expression.


CGEN-01156

CGEN-01156 Table %s has no primary key

Cause:

The table specified is defined in the Repository as being journaled, but the table has no primary key. Journaled tables must be given primary keys.

Action:

Define a primary key for your table in the Repository, and ensure that there exists usages for all columns in the primary key in your module definition.


CGEN-01157

CGEN-01157 Foreign key item(s) in %s not enterable; those in lookup not a unique key %s

Cause:

Form Generator has found the need to validate a foreign key. however, Form Generator has also determined from the lookup table usage's properties that none of the items forming part of the foreign key are to be generated as enterable (regardless of their Insert/Update/Query properties). Instead, validation code is to be generated for those lookup items that form a unique or primary key in the lookup table. If none of the lookup items form such a key, this message is issued and Form Generator generates code to perform validation across all the lookup items.

Action:

No action is necessary. If this is not required behavior, change the properties of the lookup table usage.


CGEN-01170

CGEN-01170 Foreign key from %s (in block %s based on %s) in same arc as link to parent

Cause:

Form Generator has recognized the need for validation against column(s) in a foreign key. However, the foreign key is in an arc with a second foreign key that has already been used to link this block back to a previous block. The item(s) based on the foreign key will therefore always be null, and validation will fail.

Action:

Correct the module definition by removing the item(s) based on one or other of the foreign keys.


CGEN-01171

CGEN-01171 Masters of block %s based on %s are linked via foreign keys in the same arc

Cause:

This block is has two links back to previous blocks via two foreign keys that are in the same arc.

Action:

This warning is highlighting an area in the module design that does not seem correct. Generation of the current module is not affected. No action is required.


CGEN-01173

CGEN-01173 Display datatype of item is inappropriate for column datatype

Cause:

The display datatype recorded against the column usage is inappropriate for the column's actual datatype. For example you will get this warning if you have a HIREDATE column of type DATE, which when used in a module has been given a display datatype of INT.

Action:

Change the display datatype of the Column Usage to be something that corresponds to the actual datatype of the column.


CGEN-01177

CGEN-01177 No list of values form found for table %s

Cause:

The user preference FKLOVT indicates that the list of values processing for foreign keys in the given table is to be supplied via modules defined in the Repository as being called by this module, and being of format 'LOV'. No such modules can be found.

Action:

Define such a module, or change the preference value.


CGEN-01178

CGEN-01178 All table usage flags will be updated to query only

Cause:

The format of the current module is defined as 'LOV' which indicates that it is to be used to provide a list of valid values for a foreign key in another module. One or more of the detailed table usages in the current module have usage flags other than 'Select' set. A List of Values form should be query only.

Action:

You will be asked whether or not you wish to continue. If you choose to do so, Form Generator will update your detailed table usages to make them query only.


CGEN-01182

CGEN-01182 Lookup usages for non-enterable foreign key must be displayed

Cause:

The foreign key is not enterable, and a lookup exists, and none of the lookup's items are displayed.

Action:

Modify the module definition so that the foreign key is enterable, or the lookup items are displayed. If Form Generator has unset the Display properties of lookup items, and you have also set the Display in LOV property of the lookup item based on the primary key column(s) of the lookup table, unset the Display in LOV properties and set them on foreign key items in the base table.


CGEN-01195

CGEN-01195 Failed to create .fmx file for form module %s

Cause:

The command to compile the .fmb file into a .fmx file has failed. A possible cause is a problem in the .fmb file that has resulted in a compilation error. Alternatively, there might be a problem with your environment (e.g. you might have the wrong version of Form Builder installed).

Action:

If compilation errors occurred during generation, Form Generator creates a log file detailing the problem. For more information about the compilation error, view the log file from the Build Action dialog box.


CGEN-01196

CGEN-01196 Column Usage %s.%s has display length %d but format of length %d

Cause:

an item is of type date and has a format mask that is of a different length than the display length specified on the usage.

Action:

This warning is highlighting an area in the module design that does not seem correct. Generation of the current module is not affected. No action is required.


CGEN-01197

CGEN-01197 %s.%s has an invalid date format %s, mask ignored: %s

Cause:

An item is of type date and has a format mask that is invalid.

Action:

No action is required. To avoid this warning during further runs of Form Generator, change the mask on the item.


CGEN-01198

CGEN-01198 Auto-generated item %s.%s should not be enterable

Cause:

A column is defined in the Repository as being auto-generated as 'sequence within parent', but the item indicates that the resulting item should be made enterable.

Action:

This warning is highlighting an area in the module design that does not seem correct. Generation of the current module is not affected. No action is required. To avoid this warning in further runs of Form Generator, update the item in the Repository to unset the Insert and Update allowed flags.


CGEN-01199

CGEN-01199 Block based on table %s will have no queryable item

Cause:

A table usage has the query allowed flag set, but none of its items have the associated flag set.

Action:

Navigate to the table usage and set the query flag on the items you wish to allow the user to query in the form.


CGEN-01203

CGEN-01203 Invalid preference for date format %s

Cause:

The preference for default mask for DATE items contains a value that is not a valid date mask.

Action:

Change the value of the preference to either a valid mask, or null.


CGEN-01204

CGEN-01204 Table %s used as first block in LOV form is not referenced by other tables

Cause:

You have defined a list of values form, based on the given table name, but there are no other tables that have foreign keys that go to this table. It therefore makes no sense to have a list of values form based on this table, as no other tables will require a list based on this table.

Action:

Change the module format from LOV, or define foreign keys that reference this table.


CGEN-01223

CGEN-01223 Message CGF-6815 must contain a '-'

Cause:

The NLS message 6815 / utility CGF has been converted to a string that does not contain a hyphen. This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-01224

CGEN-01224 Column in key %s is optional

Cause:

A column defined in the Repository as being optional is also defined as being in a primary key. Form Generator assumes primary key columns are mandatory when generating SQL code that validates uniqueness, etc.

Action:


CGEN-01231

CGEN-01231 Name of generated parameter %s is too long; reduce length of item name

Cause:

A parameter for a form level procedure has been generated whose name is based on the name of an item in the module. The resulting parameter name is longer than that allowed in PL/SQL.

Action:

Rename the item so that its name is no more than 28 characters long.


CGEN-01232

CGEN-01232 %s.%s has display length %d but defined default length is %d

Cause:

The display length on an item whose display datatype is DATE or DATETIME is different to the default display length for this datatype defined in the TXTDDL or TXTDTL preference value.

Action:

No action is required.


CGEN-01235

CGEN-01235 Item %s.%s maximum length %d, this is different to the column length %d

Cause:

An item in the form being generated has a length that is different from the maximum length of the column in the Repository.

Action:

Modify the column definition so that the column maximum length matches the item length, or modify the item definition in the Oracle Form Builder as appropriate.


CGEN-01236

CGEN-01236 Item %s.%s is %s, this is different to the column which is %s

Cause:

An item in the form being generated is defined differently to the corresponding column definition.

Action:

Modify either the item in the form using Form Builder to match the corresponding column definition or modify column definition to match the item.


CGEN-01239

CGEN-01239 Item %s.%s of type DATE, but pref WHTIME indicates time should be recorded

Cause:

An item has a display datatype of date, but that column is used to record the Record Creation/Update date, and the preference WHTIME indicates that the time should be recorded as well as the date.

Action:

Change the display datatype to DATETIME on the detailed column usage.


CGEN-01241

CGEN-01241 Cascade upd/del rule on fk %s not consistent with column properties

Cause:

The cascade delete or update rule for the foreign key is either NULL or DEFAULT and a column in the key is mandatory.

Action:

Either make the column optional or change the rule.


CGEN-01242

CGEN-01242 %s.%s enabled and navigable to allow scrolling on queried values

Cause:

A column usage in a table usage that does not allow insert has been defined such that the display length is less than the actual length of the column. Form Generator has made the resultant item enabled and navigable to allow the user to scroll the queried value.

Action:

No action required.


CGEN-01246

CGEN-01246 Query property has invalid WHERE clause: %s

Cause:

The query where clause and any column ordering have been built into a WHERE clause for the block. This has failed to parse.

Action:

Correct the restrictive query condition held on the detailed table usage in the module definition.


CGEN-01247

CGEN-01247 Hidden or non-insertable item %s.%s is mandatory

Cause:

The item is not displayed and is mandatory. It is not auto- generated, that is it does not have a copy value, default, sequence, it is not a formula item and it is not auto-generated for journaling.

Action:

Amend the item in the Repository to ensure that the item is made displayed and enterable.


CGEN-01250

CGEN-01250 Default value removed/modified on audit item %s

Cause:

An audit column (i.e. Date Created/User Created/Date modified /User modified) is defined as having a default value. Form Generator will ignore the default value. values for the audit columns will be created during commit processing in the generated form.

Action:

Correct the Repository column definition of the column indicated.


CGEN-01251

CGEN-01251 Column %s.%s not wide enough to hold username; must be CHAR(30).

Cause:

An audit column has been defined with a maximum length that is insufficiently large to allow the storage of the audit data. the Form Generator will continue processing.

Action:

Correct the Repository column definition of the column indicated. The column should have a minimum length of 30 characters.


CGEN-01252

CGEN-01252 Enterable audit item %s.%s updated to be non-enterable

Cause:

An audit column has been defined as updateable in the current module. Form Generator has updated it to be non-enterable. Values for the audit columns will be created during commit processing in the generated form.

Action:

Correct the Repository module column usage definition for the current module's usage of the column indicated.


CGEN-01253

CGEN-01253 Length of audit item %s.%s increased to %d

Cause:

An audit column has been defined with a display length which is less than 30. Form Generator has increased the display length to the maximum length if the audit column.

Action:

Correct the Repository column or module column usage definition for the column indicated.


CGEN-01254

CGEN-01254 Check constraint %s in table %s ignored; no base usages for column(s) %s

Cause:

Form Generator is processing a table usage for a table that has a check constraint defined for it, and there exists items for some but not all of the columns mentioned in the constraint text.

Action:

This warning is simply highlighting an area of the design in the Repository that does not seem correct. Generation of the current module is not affected. You may however wish to add usages for the missing columns.


CGEN-01258

CGEN-01258 Missing mandatory column %s in usage of table

Cause:

The Usage of the given table has the Insert Allowed usage flag set, but there is no detailed usage of the given column, which is defined as being mandatory in the Repository.

Action:

Add a detailed data usage of this column to the module definition in the Repository.


CGEN-01261

CGEN-01261 Module must be generated prior to loading help text

Cause:

The utility to load up module level help text has been run for a module that has yet to be generated.

Action:

Run Form Generator for that module prior to loading its help text.


CGEN-01264

CGEN-01264 Following user-defined expression has an error: (%s)

Cause:

A derivation expression defined in the Repository has a syntax error in it.

Action:

Correct the error in the Repository.


CGEN-01277

CGEN-01277 Inappropriate usage flags cleared on non-base table/column usage(s)

Cause:

One or more of the lookup detailed table and column usages have their Insert, Update or Delete Allowed flags set, or one or more of the items that specify formula items are likewise defined. The allowed operations on foreign key lookups should be defined against the usage of the foreign key columns themselves (regardless of whether or not the foreign key columns are displayed). Usages that specify requirements for formula items need not have any usage flags set, because the corresponding items will not be enterable.

Action:

No action required. Form Generator will update the module definition accordingly.


CGEN-01280

CGEN-01280 display length = %d, item length = %d;

Cause:

The display length on the item is bigger than that which is computed to be used for the item length. Note, the item length is based on the column maximum length. If the underlying column type is numeric, the item length may be increased to allow space for a sign and decimal point.

Action:

No action necessary.


CGEN-01281

CGEN-01281 Form Builder binary file for %s has NOT been created

Cause:

An error occurred during the generation process, and consequently no Form Builder definition has been created for this module.

Action:

No action required.


CGEN-01288

CGEN-01288 Check constraint on column %s.%s contains references to other columns.

Cause:

Check constraints specified against a column should contain only references to that column. Cross-column validation should be specified at the table level.

Action:

The generated form will enforce the constraint. However, to prevent the warning appearing on subsequent generations of the form, specify the constraint at the table level


CGEN-01312

CGEN-01312 Following PL/SQL line %d chars too long %s

Cause:

The length of a line of generated PL/SQL is greater than the value of the MAXPLS preference.

Action:

Either reduce the length of generated PL/SQL lines to less than the value of MAXPLS, or increase the value of MAXPLS to greater than the length of the longest PL/SQL line to be generated.


CGEN-01313

CGEN-01313 Following PL/SQL statement cannot be split to fit onto a line %s

Cause:

Form Generator cannot generate the form, because one of the generated lines of PL/SQL is too long, and it cannot be split sensibly into more than one line. The normal cause for such an error is in the data defined in the Repository or user preferences, such as a very long value for the ONMES preference without any embedded spaces.

Action:

The line of PL/SQL displayed should indicate the data that is causing the problem. This data should be modified appropriately. If the cause is not that as described above, then make a note of the exact text of the error message, and contact your Customer Support representative.


CGEN-01314

CGEN-01314 No linked-in function list for flavor %d.

Cause:

This is an internal error message not normally issued. Form Generator cannot find a linked-in list of functions defining the functionality of the given flavor.

Action:

Contact your Customer Support representative.


CGEN-01316

CGEN-01316 Foreign key constraint %s in %s has no enterable items or lookups

Cause:

Entry of the foreign value is required in this module, but none of the items associated with the foreign key (i.e. the base table items and associated lookup items) are enterable.

Action:

Items should be added for the lookup table, to allow entry of the foreign key value.


CGEN-01318

CGEN-01318 Usage format %s is longer than max length, changing max length to %d

Cause:

The format defined against the item is larger than the item maximum length. To accommodate a number formatted in this way (and possibly a minus sign as well), the item maximum length needs to be increased.

Action:

This warning is highlighting an area in the module design that does not seem correct. Form Generator has ignored the format this run. To avoid the same warning in later runs, either reduce the length of the format defined against the item, or if the format is exactly the same length as the column and the column will only contain positive values, specify this by entering a low value of '0' (and a high value) against the column in the Repository. This will remove the possibility of the item having to display a minus sign, allowing the format to fit.


CGEN-01319

CGEN-01319 Usage format %s is invalid, not applied

Cause:

The format defined against the item cannot be applied as an item format mask because it is invalid.

Action:

This warning is highlighting an area in the module design that does not seem correct. Form Generator has ignored the format this run. To avoid the same warning in later runs, correct the format defined against the item.


CGEN-01322

CGEN-01322 Check constraint on column %s.%s ignored; no base usages for column(s) %s

Cause:

Form Generator is processing an item for a column that has a check constraint defined for it, and there exists items for some but not all of the columns mentioned in the constraint text.

Action:

This warning is simply highlighting an area of the design in the Repository that does not seem correct. Generation of the current module is not affected. You may however wish to add usages for this missing columns. Constraints involving cross_column validation are normally specified at table level rather than column level.


CGEN-01325

CGEN-01325 Form Builder module %s already exists

Cause:

The Form Builder application being generated already exists in the Form Builder Repository.

Action:

You will be asked whether or not you wish to overwrite the existing Form Builder module. If this form has previously been generated and changes have been made via the Oracle Form Builder then these changes will be lost if you choose to overwrite. In this case a generate operation may be more appropriate. To avoid this question being asked on future runs of Form Generator you may set the ANOVRW preference to the answer required.


CGEN-01326

CGEN-01326 User cannot access tablespace: %s

Cause:

The user has requested that one of the utility tables should be created in a tablespace to which the user has no resource privileges.

Action:

Enter a tablespace to which the user has resource privileges or use the default tablespace.


CGEN-01327

CGEN-01327 Existing Form Builder module %s not overwritten

Cause:

The existing Form Builder application has not been overwritten either because you answered 'No' when asked whether you wanted to overwrite it, or because the value of the ANOVRW preference was set to 'N'.

Action:

No action is required.


CGEN-01329

CGEN-01329 Form Generator internal name %s not recognized

Cause:

A PL/SQL comment line has been identified with an unknown Form Generator keyword. The most likely cause is that the text has been amended via the Oracle Form Builder.

Action:

The offending comment line should be removed from the form definition, or restored to its original state.


CGEN-01337

CGEN-01337 Unable to create forms object

Cause:

The two most likely causes are that the memory has been exhausted or that the DE environment has been installed incorrectly.

Action:

Check the memory available and the memory consumption of the other programs that may be running. Also check your environment by invoking Form Builder and verify that you can create and run forms. If the problem persists contact your Customer Support representative


CGEN-01338

CGEN-01338 Failed to load form %s

Cause:

The form module currently being processed does not exist.

Action:

Ensure that the form module that is being processed exist either in the file system or on the specified database.


CGEN-01339

CGEN-01339 Unable to generate check box; ranges exist in the valid values

Cause:

The display datatype of the item is set to CHECK BOX, and the underlying column or its domain does not possess exactly one or two valid values. If the column is mandatory, it must have exactly two allowed values. Ranges are not permitted.

Action:

Ensure that the column that the item is based on (or its domain) has only one or two allowed values. If only one allowed value is specified, ensure that the column is not mandatory, and that the nullify flag is set on the detailed column usage. Note that ranges are not allowed for a domain when used as valid values for a check box.


CGEN-01340

CGEN-01340 Unable to generate radio group; valid values contain ranges.

Cause:

The display datatype of the item is set to RADIO GROUP, and the underlying column usage or its domain one or more ranges.

Action:

Ensure that the column that the item is based on (or its domain) has a set of distinct values (not ranges). If only one allowed value is specified, ensure that the column is not mandatory, and that the nullify flag is set on the detailed column usage. Note that ranges are not allowed for a domain when used as valid values for a radio group.


CGEN-01341

CGEN-01341 Radio group has too many buttons; %d valid values (max is %d)

Cause:

The number of valid values defined for the underlying column for which the radio group is being generated (and therefore the number of generated buttons) is greater than the number specified in the butgrp preference. note that if the item is defined a 'Nulls Allowed', then an extra button will be created to represent a NULL value.

Action:

This warning is highlighting an unusual aspect of the end user interface to the generated form. You may wish to change the display datatype for this item to something other than RADIO GROUP. To remove the warning during future generation either increase (or set to NULL) the value of the preference BUTGRP.


CGEN-01342

CGEN-01342 VGS function call failed in %s, at %s:%d

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-01343

CGEN-01343 Display datatype '%s' for '%s.%s' not appropriate for derived values

Cause:

This item or column is derived from one of the following:

·SQL Expression

·Client Side Function

·Server Side Function

However, the display type for such an item or column is not allowed.

Action:

Change the display type for this item or column to one of the following:

·text item

·check box

·list item -

·radio group.


CGEN-01352

CGEN-01352 Data Block %s : Layout position changed to '%s'

Cause:

Generator has changed the layout position of the given detailed table usage to a value that is valid in the current context.

Action:

No action is necessary.


CGEN-01354

CGEN-01354 Invalid layout requirements found on usage of table

Cause:

Generator has found one or more invalid layout requirements against the given table usage.

Action:

This is an internal message that should not normally be issued. It suggests that corruption of data in the Repository has taken place.


CGEN-01355

CGEN-01355 Positive value for block indentation on content canvas ignored

Cause:

The PAGBIN preference for block indentation on canvases contains a positive value, yet the preference PAGSTB indicates that block stubs should not be generated on canvases. Generator is unable to produce positive block indentation unless block stubs are generated.

Action:

Change the value of the PAGSTB preference so that stubs are generated on canvases.


CGEN-01356

CGEN-01356 Positive value for block indentation on stacked canvas ignored

Cause:

The POPBIN preference for block indentation on stacked canvases contains a positive value, yet the preference POPSTB indicates that block stubs should not be generated on canvases. Generator is unable to produce positive block indentation unless block stubs are generated.

Action:

Change the value of the POPSTB preference so that stubs are generated on stacked canvases.


CGEN-01357

CGEN-01357 Unable to generate check box; mandatory column must have 2 values

Cause:

The display datatype of the item is set to CHECK BOX, and the underlying column or its domain does not possess exactly one or two valid values. If the column is mandatory, it must have exactly two allowed values. Ranges are not permitted.

Action:

Ensure that the column that the item is based on (or its domain) has only one or two allowed values. If only one allowed value is specified, ensure that the column is not mandatory, and that the nullify flag is set on the detailed column usage. Note that ranges are not allowed for a domain when used as valid values for a check box.


CGEN-01358

CGEN-01358 Unable to generate check box; Optional column must have 1 value

Cause:

The display datatype of the item is set to CHECK BOX, and the underlying column or its domain does not possess exactly one or two valid values. If the column is mandatory, it must have exactly two allowed values. Ranges are not permitted.

Action:

Ensure that the column that the item is based on (or its domain) has only one or two allowed values. If only one allowed value is specified, ensure that the column is not mandatory, and that the nullify flag is set on the detailed column usage. Note that ranges are not allowed for a domain when used as valid values for a check box.


CGEN-01359

CGEN-01359 Unable to generate radio group; No valid values

Cause:

The display datatype of the item is set to RADIO GROUP, and the underlying column does not have any valid values defined.

Action:

Ensure that the column that the item is based on (or its domain) has a set of distinct values (not ranges). If only one allowed value is specified, ensure that the column is not mandatory, and that the nullify flag is set on the detailed column usage. Note that ranges are not allowed for a domain when used as valid values for a radio group.


CGEN-01360

CGEN-01360 Unable to generate list; No valid values

Cause:

This column is not appropriate as a list item as neither valid values, nor a domain with valid values have been specified for the column.

Action:

Either change the display type or provide some valid value.


CGEN-01361

CGEN-01361 Unable to generate list; ranges exist in the valid values

Cause:

This column is not appropriate as a list item as the list of valid values contains one or more ranges

Action:

Either change the display type or remove the ranges from the list of valid values


CGEN-01362

CGEN-01362 Popup list has too many values; %d valid values (maximum is %d)

Cause:

Too many valid values have been specified. Note that if the column is optional, NULL counts as a valid value.

Action:

Reduce the number of valid values for the column or Increase the maximum size of a pop up list (preference PLSMAX) or choose a different display data type


CGEN-01363

CGEN-01363 Text list has too many values; %d valid values (maximum is %d)

Cause:

The number of valid values exceeds the maximum number of values allowed in a text list. Note that if the column is optional, NULL counts as a valid value.

Action:

Reduce the number of valid values or increase the maximum number of valid values allowed (preference TLSMAX) or choose a different display data type.


CGEN-01364

CGEN-01364 Available width on %s %d (%d) less than minimum allowable width (%d)

Cause:

The width available to Generator on the given canvas is less than the minimum width in which blocks can be laid out. The available width is dependent on the width of the canvas, the canvas margin, whether boxes are being generated or not, and, if boxes are being generated, the space taken up by boxes.

Action:

Ensure that Generator has sufficient space for the layout of blocks on the given canvas by checking values for width taken from canvases in the template form, from information specified against a table usage in the Repository, or from the preferences PAGWID or POPWID. Also check the values of the PAGMAR or POPMAR preferences and the BOXES and BOXCOL preferences.


CGEN-01367

CGEN-01367 Insert flag ignored for %s.%s

Cause:

The item flags allow insert into this image. however, there is no mechanism for entering the image.

Action:

Either remove the insert flag, or specify an image control item (Preference IMCTR1 = Y)


CGEN-01368

CGEN-01368 Insert flag ignored for file based image in %s.%s

Cause:

The underlying column for the image is of type CHAR. Therefore the database holds the filename of a file containing the image. The Repository column usage indicates that INSERT is allowed. However, the form does not have an item into which we can insert the filename, only the image is displayed

Action:

Either remove the INSERT flag from the usage or display the image control item (preference IMCTR1 = YES)


CGEN-01369

CGEN-01369 Update flag ignored for file based image in %s.%s

Cause:

The underlying column for the image is of type CHAR. Therefor the database holds the filename of a file containing the image. The Repository column usage indicates that UPDATE is allowed. However, the form does not have an item into which we can UPDATE the filename, only the image is displayed

Action:

Either remove the UPDATE flag from the usage or display the image control item (preference IMCTR1 = YES)


CGEN-01370

CGEN-01370 Delete flag ignored for file based image in %s.%s

Cause:

The underlying column for the image is of type CHAR. Therefor the database holds the filename of a file containing the image. The Repository column usage indicates that DELETE is allowed. However, the form does not have an item where we can DELETE the filename, only the image is displayed.

Action:

Either remove the DELETE flag from the usage or display the image control item (preference IMCTR1 = YES)


CGEN-01371

CGEN-01371 An IMAGE must be based on either a LONG RAW or VARCHAR2 column type - %s.%s

Cause:

The underlying column for an IMAGE display type is neither a LONG RAW nor a VARCHAR2 If the underlying column type is LONG RAW, the image is held on the database. If the underlying column type is VARCHAR2 the name of a file holding the image is held on the database. The generator cannot handle any other underlying column type.

Action:

Reconsider displaying this column as an image.


CGEN-01373

CGEN-01373 Unable to attach library %s

Cause:

Form Generator could not find one or more PLL files to attach to the generated form/menu. If the PLL file corresponds to a Repository library module attached to the form/menu by a module network link, Form Generator searched the following in turn:

·the path specified by the appropriate Form Builder Registry variable (e.g. FORMS60_PATH)

·if the attached library module is repository-based, the path specified by the current Library Generator PLL file location option

·if the attached library module is file-based, the path specified by the library module's Source Pathname property

If the PLL file does not correspond to a Repository library module attached to the form/menu by a module network link (i.e. the PLL file is one of the libraries shipped with Form Generator, or is specified by the MODLIB preference, or is attached to a template), Form Generator searched the following locations in turn:

·the Form Generator PLL file location option (if set)

· the path specified by the appropriate Form Builder Registry variable (only searched if the Form Generator PLL file location option is not set)

Action:

We recommend you include the location of the library file in the appropriate Form Builder Registry variable (e.g. FORMS60_PATH). Alternatively, you can hard code the location into the generated form/menu by specifying the location in one of the following:

·the Library Generator PLL file location option for attached Repository-based library modules

·the Source Path Name property of attached file-based library modules

·the Form Generator PLL file location option for library files supplied with Form Generator

Note that a hard coded library location makes a generated application significantly less portable than if the location is specified using Registry variables.


CGEN-01376

CGEN-01376 Cannot delete form application %s

Cause:

An ORACLE error occurred when attempting to delete a form from the database. The ORACLE error message is displayed immediately after this message.

Action:

Refer to the "ORACLE Error and Codes Messages Manual" for a full description of the ORACLE error, its cause, and the action you should take.


CGEN-01377

CGEN-01377 Failed to write form %s

Cause:

An ORACLE or Forms error occurred when attempting to write the form. The text of the message is displayed immediately after this message.

Action:

Refer to either the "ORACLE Error and Codes Messages Manual" or "Form Builder Reference Manual" for a full description of the error, its cause, and the action you should take.


CGEN-01378

CGEN-01378 Data Block %s: Invalid layout position '%s'

Cause:

The table usage on which the block is based has a layout position which is invalid in the current context.

Action:

If there is more than one valid alternative layout position then you will be asked to select from a list of more appropriate ones. Otherwise, the layout position will be changed to the one valid alternative available.


CGEN-01379

CGEN-01379 Block %s : Cannot fit a complete row on any canvases

Cause:

One of the following:

·There is no room on any canvas for Generator to fit a complete row of the given block. This could be due to a combination of factors including canvas sizes being too small, canvas expansion being prevented, requirements for large headers/footers as specified in preferences or in the template form, or various layout preferences either decreasing the space available to Generator, or increasing the amount of space required by generated objects.

·The block does not contain any displayed items.

Action:

If the block does not contain any displayed items, consider if this is really what you want. Otherwise, Increase canvas sizes by modifying preferences and/or increasing canvas sizes specified against table usages and/or reducing the size of header/footer objects by modifying preferences or canvases in the template form.


CGEN-01380

CGEN-01380 '%s' is not a valid layout position

Cause:

The user was prompted with list of valid layout positions for a block. An invalid layout position has been chosen.

Action:

Choose a valid layout.


CGEN-01381

CGEN-01381 Required number of rows %d reduced to %d

Cause:

Generator is unable to display the number of rows specified against the table usage and has therefore reduced the number of rows to the maximum that may be displayed.

Action:

No action is necessary. If a reduced number of rows is not acceptable consider increasing canvas sizes by modifying preferences and/or increasing canvas sizes specified against Table usages and/or reducing the size of header/footer objects in the template form.


CGEN-01382

CGEN-01382 Expanding %s %d to fit %d row(s)

Cause:

Generator will expand the given canvas in order to fit the requested number of rows.

Action:

No action is necessary.


CGEN-01384

CGEN-01384 Block will span multiple canvases (starting on %s %d)

Cause:

Generator has insufficient room on the current canvas to fit a complete row of the block. The block will therefore be spread across one or more canvases (starting on the given canvas).

Action:

No action is necessary. If this situation is undesirable, consider providing more space on the canvas by changing preference values, table usage values and/or dimensions of canvases in the template form. Alternatively, allow Generator to expand canvases by setting the PAGEXP/POPEXP preferences to 'Y'.


CGEN-01385

CGEN-01385 Data Block %s: Can no longer fit a complete row on %s %d

Cause:

As only 1 row of the given block will be displayed and the ITMPAS preference indicates that prompts cannot be displayed over items in a single-row block, Generator has re-laid out the block taking this restriction into account. Now, however, the one row cannot be fitted into the space available.

Action:

Consider increasing the size of the canvas on which you wish the given block to be displayed. Alternatively, allow the canvas to expand by setting the PAGEXP/POPEXP preference to 'Y'.


CGEN-01387

CGEN-01387 Database trigger required on table %s to validate arc number %d

Cause:

All foreign keys in the table and arc number specified are enforced in the server only, however, the server cannot enforce an arc declaratively.

Action:

Write a database trigger on the table to ensure that not more than one of the foreign keys has a value, and if the arc is mandatory that there is always one foreign key with a value.


CGEN-01390

CGEN-01390 Editor %s specified by preference %s is not defined in template form

Cause:

One of the default editor preferences DFTCED or DFTLED contains the name of an editor that cannot be found in the current template form used during generation.

Action:

Ensure that any user defined editor name as specified by one of the default editor preferences DFTCED or DFTLED is defined in the template form used during generation


CGEN-01398

CGEN-01398 Cannot link blocks based on tables %s and %s. FK %s references optional cols

Cause:

The foreign key in the first table does not refer to a unique or primary key in the second, and not all columns in the foreign key map to mandatory columns in the referenced table.

Action:

Modify the module definition such that the tables are linked by a foreign key which maps onto a unique or primary key, or make one of referenced columns mandatory.


CGEN-01399

CGEN-01399 Cannot link blocks based on tables %s and %s. FK %s references opt key %s

Cause:

You are attempting to link two blocks via a foreign key which maps onto an optional unique key.

Action:

Make the unique key mandatory.


CGEN-01400

CGEN-01400 Cannot manage canvases where block %s spread over multiple canvases

Cause:

The specified block is spread over more than one canvas which cannot be managed.

Action:

Modify the canvas attribute of the items in the block so that they all lie on the same canvas.


CGEN-01401

CGEN-01401 Foreign key %s in table %s does not reference a unique or primary key

Cause:

The specified foreign key, which is enforced in the server only, does not map onto a primary or unique key. This message should not normally be given as a foreign key declared in the server must map onto a unique or primary key.

Action:

Contact your Customer Support representative.


CGEN-01402

CGEN-01402 Cannot link blocks based on tables %s and %s. FK %s does not reference UK/PK

Cause:

You are attempting to link two blocks via a foreign key which does not reference a unique or primary key in the master block.

Action:

Modify the module definition so that the foreign key maps onto a unique or primary key.


CGEN-01405

CGEN-01405 Content canvas %s has inappropriate name

Cause:

The canvas name prefix implies that it is a template for a stacked canvas. However is not stacked. Name prefixes which imply a stacked canvas are: "CG$POPUP", "CG$SPREAD_TABLE", "CG$SINGLE_AREA" and "CG$OVERFLOW".

Action:

Rename the canvas.


CGEN-01406

CGEN-01406 Require DB constraint to ensure all columns not null for mandatory key %s

Cause:

There is a constraint which is mandatory and enforced by the Server only, but all its columns are optional.

Action:

One of the following:

·Write a database constraint (i.e. table level check constraint) to ensure that not all columns are null (if null is a valid value)

·Modify the definition of at least one of the columns in the constraint to make it mandatory.


CGEN-01407

CGEN-01407 Item has no valid values, cannot be displayed as a GUI item

Cause:

The item display datatype specifies this as a GUI item (i.e. RADIO GROUP, CHECK BOX, POP-LIST or T-LIST). However, GUI items can be generated only when the column has known valid values. Neither domain nor column validation has been specified.

Action:

Add column validation to the column specification in the CASE the Repository.


CGEN-01408

CGEN-01408 Limit of %s canvas sequence numbers reached

Cause:

This is an internal error message not normally issued. The Generator has run out of internal sequence numbers to allocate to canvases of the given type.

Action:

Contact your Customer Support representative.


CGEN-01409

CGEN-01409 Limit of %s window sequence numbers reached

Cause:

This is an internal error message not normally issued. The Generator has run out of internal sequence numbers to allocate to windows of the given type.

Action:

Contact your Customer Support representative.


CGEN-01410

CGEN-01410 The following function call used in a condition is invalid (%s)

Cause:

The function specified as the validation condition defined in the Repository against either a check constraint or a column is invalid. This may have been caused by a syntax error or one of the columns used as arguments to the function does not exist in the current table.

Action:

Correct the text in the Repository


CGEN-01411

CGEN-01411 Invalid function name

Cause:

The function specified as a derivation or a condition does not have a valid name.

Action:

Check the validation and derivation code held against the detailed table usages, the columns and the tables. Remove or correct the text.


CGEN-01412

CGEN-01412 Derivation expression ignored for LONG RAW column %s.%s

Cause:

A usage of a LONG RAW column cannot be derived from an expression.

Action:

No action required; the derivation is ignored. to avoid this warning in future executions of Form Generator, the derivation should be removed from the column definition in the Repository.


CGEN-01413

CGEN-01413 Display datatype IMAGE for '%s.%s' not appropriate for lookup items

Cause:

A column of type CHAR or VARCHAR2 has a display datatype of IMAGE specified on the item.

Action:

No action required; the column is displayed as a CHAR


CGEN-01414

CGEN-01414 %s is not an appropriate type for lookup item usage

Cause:

A column with a lookup usage is of type LONG. Form Builder record group columns must have a length in the range 1 - 255, a LONG RAW is not appropriate.

Action:

Remove this column from the lookup.


CGEN-01424

CGEN-01424 Column datatype mismatch between tables %s and %s for foreign key %s

Cause:

The data types of at least one pair of corresponding columns in the foreign key and the unique/primary key onto which it maps are different.

Action:

If this is not required, modify the data type of one of the columns.


CGEN-01425

CGEN-01425 The datatype CHAR is not suitable in an Oracle 7 database

Cause:

This is an integrity check on the Repository. The datatype CHAR is not suitable in an Oracle 7 database for most purposes.

Action:

Use the datatype VARCHAR2 instead.


CGEN-01427

CGEN-01427 FK %s considered mandatory in order to link blocks based on tables %s and %s

Cause:

The optional foreign key which is specified to link the two blocks will be considered mandatory in this context. That is, any records entered in the detail block must reference a record in the master. This will not affect the functionality of the module.

Action:

No action required.


CGEN-01429

CGEN-01429 Width of check box incremented by %d to show check box indicator

Cause:

The display datatype of the item is set to CHECK BOX. A display width has been specified against the item but this width is too small too display a check box indicator. The generator assumes that the specified display width on the item excludes the check box indicator. The width is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item


CGEN-01430

CGEN-01430 Height of check box set to %d to show check box indicator

Cause:

The display datatype of the item is set to CHECK BOX. A display height has been specified against the item but this height is too small too display a check box indicator. The generator sets the height large enough to display the check box indicator and updates the item.

Action:

No further action is required however you may care to review the displayed item height in the item.


CGEN-01431

CGEN-01431 Width of radio button incremented by %d to show button indicator

Cause:

The display datatype of the item is set to RADIO BUTTON. A display width has been specified against the item but this width is too small too display a radio button indicator. The generator assumes that the specified display width on the item excludes the radio button indicator. The width is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item.


CGEN-01432

CGEN-01432 Height of radio button set to %d to show radio button indicator

Cause:

The display datatype of the item is set to RADIO BUTTON. A display height has been specified against the item but this height is too small too display a radio button indicator. The height is set to that of a radio button indicator.

Action:

No further action is necessary. However you may care to review the display height in the item


CGEN-01433

CGEN-01433 Width of popup list incremented by %d to show pop list indicator

Cause:

The display datatype of the item is set to POPUP LIST. A display width has been specified against the item but this width is too small too display a popup list indicator. The generator assumes that the specified display width on the item excludes the popup list indicator. The width is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item.


CGEN-01434

CGEN-01434 Width of text list incremented by %d to show vertical scroll bar

Cause:

The display datatype of the item is set to TEXT LIST. A display width has been specified against the item but this width is too small too display a vertical scroll bar. The generator assumes that the specified display width on the item excludes the vertical scroll bar. The width is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item.


CGEN-01435

CGEN-01435 Height of popup list set to %d to show popup list indicator

Cause:

The display datatype of the item is set to POPUP LIST. A display height has been specified against the item but this height is too small too display a popup list indicator. The height is set to the height of a popup list indicator.

Action:

No further action is necessary. However you may care to review the display height in the item.


CGEN-01436

CGEN-01436 Height of text list incremented by %d for horizontal scroll bar

Cause:

The display datatype of the item is set to TEXT LIST. A display height has been specified against the item but this height is too small too display a horizontal scroll bar. The generator assumes that the specified display height on the item excludes the horizontal scroll bar. The height is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display height in the item.


CGEN-01437

CGEN-01437 Width of text item for %s.%s incremented by %d to show vertical scroll bar

Cause:

The display datatype of the item is set to a multi-line text item. A display width has been specified against the item but this width is too small to display a vertical scroll bar. The generator assumes that the specified display width on the item excludes the vertical scroll bar. The width is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item.


CGEN-01438

CGEN-01438 Width of image for %s.%s incremented by %d to show vertical scroll bar

Cause:

The display datatype of the item is set to IMAGE. A display width has been specified against the item but this width is too small too display a vertical scroll bar. The generator assumes that the specified display width on the item excludes the vertical scroll bar. The width is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item.


CGEN-01439

CGEN-01439 Height of image for %s.%s incremented by %d to show horizontal scroll bar

Cause:

The display datatype of the item is set to IMAGE. A display height has been specified against the item but this height is too small too display a horizontal scroll bar. The generator assumes that the specified display height on the item excludes the horizontal scroll bar. The height is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item.


CGEN-01442

CGEN-01442 Cascade upd/del rule is Nullify for mandatory foreign key %s

Cause:

You have specified that the referential integrity rule for either update, delete or both is nullify, but the foreign key is mandatory and therefore must contain a valid value.

Action:

Update the foreign key definition to optional, or specify an alternative referential integrity rule.


CGEN-01445

CGEN-01445 Form has incompatible coordinate system

Cause:

The form has a coordinate system that is incompatible with Oracle Form Generator. the form must use the character coordinate system with default font scaling.

Action:

If the form is being generated, modify the template form so that it uses the character coordinate system with default font scaling. If the form is being generated, then use the Oracle Form Builder to change its coordinate system to character with default font scaling.


CGEN-01446

CGEN-01446 Not enough space to layout an LOV indicator next to %s.%s

Cause:

The available width on the canvas is not enough to layout a list of values indicator button next to the item. This item is laid out without a list of values indicator button. Note, the 'list of values' is available on the item.

Action:

There are several possible courses of action:

·Do nothing, accept that this item does not have a list of values indicator button.

·Make the item display width smaller to allow space for the list of values indicator button.

·Increase the available width by making the canvas wider.


CGEN-01450

CGEN-01450 The following function call used in a derivation is invalid (%s)

Cause:

The function specified as a derivation defined in the Repository against either a column or an item is invalid. This may have been caused by a syntax error or one of the columns used as arguments to the function do not exist in the current table

Action:

Correct the text in the Repository


CGEN-01451

CGEN-01451 Cannot enforce '%s' rule declaratively in server. Require triggers %s

Cause:

The referential integrity rules (for delete and/or update) cannot be enforced declaratively on the server.

Action:

Write data base triggers as detailed in the message to enforce the referential integrity and secondly, maintain the foreign key.


CGEN-01455

CGEN-01455 Client enforced %s constraint %s on table %s %s

Cause:

Due to the delete/update referential integrity rule specified for the foreign key, there is a danger of the specified client- enforced constraint being violated.

Action:

If possible, modify the constraint to be validated on the server.


CGEN-01461

CGEN-01461 Column validation on %s.%s %s

Cause:

Due to the delete/update referential integrity rule specified for the foreign key, there is a danger of the column-level validation being violated.

Action:

If possible, change the column level validation to a server-side table level check constraint.


CGEN-01463

CGEN-01463 '%c' is used for ITMSPM and ITMPPM

Cause:

The same character has been specified (via the preferences) to indicate the item split prompt marker (ITMSPM) and the item post prompt marker (ITMPPM)

Action:

Review why the same character has been chosen for each of these preferences.


CGEN-01467

CGEN-01467 Display datatype is TIME, this cannot take a format mask

Cause:

The display datatype recorded in the item is TIME. It is not appropriate to apply a format mask to this item type. The format mask is removed.

Action:

No further action is necessary.


CGEN-01469

CGEN-01469 Default value %s for %s in %s exceeds item length %ld

Cause:

The default value length exceeds the item length. The default is ignored.

Action:

Either increase the column size or choose a shorter default value.


CGEN-01472

CGEN-01472 Template form %s has incompatible coordinate system

Cause:

The template form has a coordinate system that is incompatible with Form Generator. the template form must use the character coordinate system with default font scaling.

Action:

Modify the template form so that it uses the character coordinate system with default font scaling.


CGEN-01476

CGEN-01476 Width of combo-box incremented by %d to show combo-box indicator

Cause:

The display data type of the item is set to COMBO-BOX. A display width has been specified against the item but this width is too small to display a combo-box indicator. The generator assumes that the specified display width on the item excludes the combo-box indicator. The width is incremented and the item updated.

Action:

No further action is necessary. However you may care to review the display width in the item.


CGEN-01477

CGEN-01477 Height of combo-box set to %d to show combo-box indicator

Cause:

The display datatype of the item is set to COMBO-BOX. A display height has been specified against the item but this height is too small to display a combo-box indicator. The height is set to the height of a combo-box indicator.

Action:


CGEN-01479

CGEN-01479 OLE Container cannot be generated for %s.%s

Cause:

The given item has a display datatype of OLE CONTAINER but the underlying column is not of type LONG RAW.

Action:

OLE containers can only be generated for items based on columns of type LONG RAW since the value of an OLE Object is a byte-stream.


CGEN-01480

CGEN-01480 OLE Container Implementation %s for %s.%s not found

Cause:

The given item has a display datatype of OLE CONTAINER but a Custom Item of type OLE Container named as its Implementation cannot be found in the template form.

Action:

Ensure that the implementation for the item is the name of a Custom Item in the template form of type OLE Container that embodies a class definition for the OLE Container Custom Item. In the absence of such a definition Form Generator has created a 'vanilla' OLE Container Custom Item with default functional properties that will accept OLE Objects of any class.


CGEN-01485

CGEN-01485 Validation is ignored because column is server derived

Cause:

A column is defined in the Repository as both having a list of valid values (or being a domain so defined), and as being derived by the server. In this situation, Form Generator ignores the valid values.

Action:

This warning is simply highlighting an area of the design in the Repository that does not seem correct. Generation of the current module is not affected. to avoid this warning in future executions of Form Generator, modify the definition of the column in the Repository accordingly.


CGEN-01486

CGEN-01486 Column level check constraint ignored on server derived column %s.%s

Cause:

A column is defined in the Repository as both having a column level check constraint and being derived by the server. In this situation, Form Generator ignores the constraint.

Action:

This warning is simply highlighting an area of the design in the Repository that does not seem correct. Generation of the current module is not affected. to avoid this warning in future executions of Form Generator, modify the definition of the column in the Repository accordingly.


CGEN-01487

CGEN-01487 Column %s.%s is served derived: default ignored

Cause:

A column that is defined as server derived also has a default defined. This default may be defined on the column definition or the item. In this situation Form Generator ignores the default.

Action:

This warning is highlighting an area in the database design that does not seem correct. Generation of the current module is not affected. To avoid this warning in future executions of Form Generator the column definition/item in the Repository should be amended accordingly.


CGEN-01493

CGEN-01493 Subclassed procedure found in template %s will not be included

Cause:

Form Generator does not support the subclassing of procedures into the template form.

Action:

Include the procedure in a library (.PLL) attached to the template form.


CGEN-01494

CGEN-01494 'Display in LOV' property for column ignored

Cause:

The specified item is (or forms part of) a foreign key link to a lookup (or chained lookup) table usage. The corresponding column in that lookup usage has the 'Display In LOV' attribute set to No, and this overrides the setting of Yes on this foreign key column usage.

Action:

Adjust the 'Display In LOV' property against the primary/unique key column usage(s) in the lookup table usage, and/or this Foreign key column usage, as appropriate.


CGEN-02000

CGEN-02000 Failed in call to Oracle Reports API '%s'

Cause:

A general fault has occurred between the Generator and the Oracle Reports engine.

Action:

Contact your technical support representative.


CGEN-02004

CGEN-02004 Invalid Link on table : %s

Cause:

The link on this table does not match a valid foreign key constraint.

Action:

Check that the link is correct, and matches a foreign key constraint.


CGEN-02005

CGEN-02005 This module has been captured from a generated report with DOJOIN = 'Y'

Cause:

The captured report has been generated with the DOJOIN preference set to 'Y'. The captured module has the same structure as the original module. However, the DOJOIN preference will be set to the default value.

Action:

To generate from the captured module and get a report exactly like the one captured, manually set the DOJOIN preference to 'Y'.


CGEN-02006

CGEN-02006 The space chars in the routine named %s have been replaced with underscores.

Cause:

In Report Builder, creation of a program unit with space characters in the name is not permitted. Space characters have been found in the name of a named routine in the module. These spaces have been replaced by underscores in order to produce a generatable report.

Action:

Application logic items referencing a named routine whose name has had its spaces replaced by underscores will need updating to call the modified named routine correctly.


CGEN-02007

CGEN-02007 Failed to parse generated SQL statement %s

Cause:

When Report Generator tried to build the query from the SQL statement that was being generated for the module, it failed to parse. This could be for a number of reasons:

·Tables referenced do not exist in the user that you are connected to

·An invalid expression has been added, for example against the Where clause on a table usage

Action:

Since the most likely cause of this error is that the tables referred to in the SQL statement do not exist in the user that you are connecting with, then the best cause of action is to either:

·Create the tables in the user you are connecting with, for example by using the Server Generator.

·If the tables have been created in a different user, you can supply the connect string to this user from the Report Generator Options dialog.

If the error persists, the best course of action is to cut and paste the generated statement into a SQL*Plus session to determine the exact error. You can then correct the module definition and then re-generate the module.


CGEN-02016

CGEN-02016 Cannot convert template report, %s already exists

Cause:

The given RDF template cannot be converted to a TDF template because a template already exists with that name.

Action:

Either update your preferences to use the TDF template, or deleted the existing TDF template.


CGEN-02084

CGEN-02084 Unable to access template report %s or registry variable REPORTS30PATH

Cause:

The generator cannot access the given layout model template report. In order to generate a report the generator must be able to open the layout model template report.

Action:

Ensure that the user generating the report can open the template layout model report specified in the template preferences.


CGEN-02092

CGEN-02092 Unable to save report %s

Cause:

The generated report could not be saved to the filesystem.

Action:

Ensure that the user generating the report has write access to the filesystem.


CGEN-02173

CGEN-02173 Unable to layout report into given area

Cause:

When trying to layout the given module, the Report Generator has failed to fit the requested items into the given area as specified by the layout template (if specified) The report will still be saved, but no layout will be created for it.

Action:

Since the Report Generator will have already tried to reduce the font of the items to fit the layout area, the only options left are one of the following.

·Increase the size of the layout area in the template report.

·Decrease the number of displayed items

·Reduce the width of displayed items.


CGEN-02178

CGEN-02178 Journaling preference JNCOLS has invalid syntax, %s

Cause:

The value for the preference JNCOLS has not been recognized.

Action:

Consult the documentation for this preference and check the syntax is correct


CGEN-02179

CGEN-02179 Journaling preference JNCOLS has invalid width for journal column %s

Cause:

The displayed field specified for the journal column must be greater than zero

Action:

Check the displayed field width for the journal column specified in the value of preference JNCOLS


CGEN-02180

CGEN-02180 Logon to validation user (%s) failed. Using current connection.

Cause:

The generator attempted to connect using the noted connect string but failed to establish a connection.

Action:

Either correct the connect string or examine the system message that will follow.


CGEN-02182

CGEN-02182 %s - View HTML report output

Cause:

The command line used to auto-generate the HTM/PDF files has not executed correctly

Action:

To resolve the problem do one of the following:

·Check Reports Runtime has been installed correctly

·Check Reports Runtime runs on its own by double-clicking the executable from the File Manager or Windows Explorer


CGEN-02184

CGEN-02184 %s has no displayed column usages or navigation action items

Cause:

There must exist a module component that has at least one column usage that is marked as displayed or a navigation action item

Action:

Do either one of the following:

·Make sure that at least one of the column usages is marked as displayed.

·Make sure that there is at least one navigation action item.


CGEN-02185

CGEN-02185 PL/SQL library %s does not exist

Cause:

The PL/SQL library cannot be attached unless it exists at the specified location

Action:

Check that the library exists in the specified location. If a User PL/SQL Library, check the Report-Level Objects preference MODLIB points to the correct location and name


CGEN-02186

CGEN-02186 Unable to generate bookmark item due to invalid field type

Cause:

Unable to generate bookmarks for the following types of fields:

·fields in a matrix group

·fields based on a item with IMAGE, BUTTON or OLE display datatype

·fields that include boilerplate text or other types of column text

Action:

Check that the field is a valid type for generating bookmarks. If not set the Context Flag on the item to 'No'.


CGEN-02187

CGEN-02187 Label style is incompatible with multiple groups

Cause:

Only one group may exist if a label style report is to be generated.

Action:

Delete all but one group.


CGEN-02188

CGEN-02188 Label style is incompatible with multiple module components

Cause:

Only one zone and group may exist for a label style report.

Action:

Delete all but one group.


CGEN-02189

CGEN-02189 Item cannot have a report level-summary function of % of Total

Cause:

A report level-summary cannot have a function of % of Total, otherwise it would always compute to be 100%.

Action:

Change the function of the report level summary or move the computed item out of the module level module component.


CGEN-02190

CGEN-02190 Computed item is based on '%s' which must be in the same window

Cause:

A computed item cannot reference a source item that is not in the same window as the computed item.

Action:

Do one of the following:

·Change the computed item to reference a source item that is in the same window as the computed item.

·Move the module component containing the source item into the window that contains the computed item.


CGEN-02191

CGEN-02191 Parameters preference LOVTYP has invalid syntax, %s

Cause:

The value for the preference LOVTYP has not been recognized.

Action:

Consult the documentation for this preference and check the syntax is correct.


CGEN-02192

CGEN-02192 Parameters preference VALTYP has invalid syntax, %s

Cause:

The value for the preference VALTYP has not been recognized.

Action:

Consult the documentation for this preference and check the syntax is correct


CGEN-02194

CGEN-02194 Computed item '%s' has reset level 'Page'

Cause:

A computed item that has a reset level of Page must be placed in a module-level module component, otherwise its reset level will be defaulted to Module

Action:

Either ignore the warning as the computed item will be created with reset level 'module' or move the computed item into a module level module component.


CGEN-02196

CGEN-02196 Capturing module design and application logic from file '%s'

Cause:

Action:


CGEN-02197

CGEN-02197 The named routine \"%s\" has a name uniqueness conflict within this module.

Cause:

Report Builder does not allow two program units to have the same name, except for the case of a Package with its specification and body. This error has occurred because there is more than one function, procedure, or package with the same name.

Action:

Ensure that the named routines follow the Report Builder restriction stated in the cause text. Make the names of the named routines concerned unique by editing the name of the offending package set/function/procedure in the application logic editor and saving the change. Note: If this named routine is referenced elsewhere within the module, update the reference to call the relevant named routine.


CGEN-02198

CGEN-02198 Computed item with invalid derivation text ignored

Cause:

Either the derivation expression contains an invalid summary function or the source item is referenced out of scope. Valid summary functions for a computed item are :

·Average

·Count

·First

·Last

·Maximum

·Minimum

·% of Total

·Standard Deviation

·Sum

·Variance

Action:

Check the derivation expression on the Computed item contains a valid summary function.


CGEN-02199

CGEN-02199 Only navigation action items are supported; action item ignored

Cause:

This drill down module contains an action item that is not a navigation action item. Report Generator only supports navigation action items in drill down modules.

Action:

If you require an action item in a drill down module, delete the existing action item and create a navigation action item.


CGEN-02201

CGEN-02201 Module layout style of %s is incompatible with structure of report

Cause:

The style of the report has been derived from the structure of the report. This style is different from the module layout style.

Action:

No action is necessary: The module layout style will be defaulted correctly.


CGEN-02202

CGEN-02202 Break group direction for all groups has been defaulted to %s

Cause:

In a Group Left Report, all break group directions must be the same. All break group directions have been defaulted to that of the first break group.

Action:

Change the direction of the first break group to either DOWN or ACROSS. All other break groups directions will be defaulted to that of the first break group.


CGEN-02203

CGEN-02203 Layout style for master group defaulted to FORM in Master Detail Report

Cause:

In a master-detail-detail chain, all but the last group in the chain must have a layout style of FORM.

Action:

The group style will be defaulted to FORM, You may set it to FORM if you wish.


CGEN-02204

CGEN-02204 Module component layout style of ADDRESS is incompatible with report layout

Cause:

The report has more than one breakgroup, or more than one module component, so a module component layout style of ADDRESS is not valid. It will default to NONE.

Action:

No action is necessary. You may reset the module component layout style to NONE.


CGEN-02205

CGEN-02205 Invalid break group design, no displayed item

Cause:

Break group must have at least one item that is displayed and is not of unbound type Computed

Action:

Either add a displayed item to the break group or delete the break group


CGEN-02206

CGEN-02206 Invalid break group design, item %s has invalid datatype

Cause:

Break group cannot contain a single item that is of datatype LONG or LONG RAW.

Action:

Either add a displayed item to the break group or delete the break group.


CGEN-02500

CGEN-02500 Report for design capture failed to load: %s

Cause:

Unable to load the given Report filename

Action:

The Report may have failed to load for various reasons. Check the following and retry:

·The file is not being locked by another program or user.

·The file can be opened in the Report Builder.


CGEN-02502

CGEN-02502 Unable to recover some or all logic from Program Unit %s.

Cause:

An inconsistency has been picked upon by the Application Logic Capture tool, rendering some or all of the code in this Program Unit unrecoverable.. This will generally be a result of incorrectly editing a tag that has been generated into the Program Unit whose logic has been edited.

Action:

See the help section that covers how to use the Application Logic functionality. The most likely reason is that a tag specifying a Generated Code Group has been deleted.


CGEN-02510

CGEN-02510 Unable to Link SRSA table usage '%s'

Cause:

During the analysis of the SQL statement that will form the Module Component, a sub query construct was found in the statement.

Action:

In order for the table usage to be incorporated into the module component design, the following actions need to be taken:

·Set the table usage type to be Sub Query.

·Link the table usage back to its parent Base or Lookup usage.


CGEN-02511

CGEN-02511 Capturing module design from file '%s'

Cause:

A query in the report definition uses a column that is not defined in the table for this application system.

Action:

Add column definition to table definition in application system or specify the correct application system.


CGEN-02513

CGEN-02513 Unable to Link Sub Query table usage '%s'

Cause:

During the analysis of the SQL statement that will form the Module Component, a sub query construct was found in the statement.

Action:

In order for the table usage to be incorporated into the module component design, the following actions need to be taken:

·Set the table usage type to be Sub Query.

·Link the table usage back to its parent Base or Lookup usage.


CGEN-02517

CGEN-02517 No filename given for design capture

Cause:

No filename was given to recover.

Action:

This is an internal problem with the calling mechanism.


CGEN-02518

CGEN-02518 Parse error - the following SQL statement will be ignored {%s}

Cause:

The generator has been unable to parse the displayed SQL statement. No usages will be reverse engineered for the statement and processing will continue.

Action:

Modify the report to ensure that all the SQL statements within the report are syntactically correct.


CGEN-02520

CGEN-02520 No Table Usages captured for Data Source %s

Cause:

During the recovery of a Reports Data Source (i.e. SQL statement), no table usages were found to be recovered.

Action:

Use the Report Building to check the integrity of the application. The actions that can be taken are thus:

·Correct the SQL statement to include the appropriate table usages.

·Ensure the SQL statement has the correct syntax.

·Remove the Data Source object from the Report.

·Ignore this message.

·Create any required tables usages using the Design Editor or the Repository Object Navigator.


CGEN-02521

CGEN-02521 Failed to capture routine %s due to routine being of unknown type.

Cause:

Unable to capture this Program Unit as it's type is not known.

Action:

Open the report in Report Developer and examine the troublesome Program Unit for abnormalities. If anything appears to be out of order correct it, then save the report and re-attempt application logic recovery. If problems persist either delete the program unit from the report or contact your support representative.


CGEN-02522

CGEN-02522 Failed to capture routine %s as no code segment was found

Cause:

The code segment of the Report's Program Unit being captured by application logic recovery is empty, and so there is nothing to recover back to the Repository.

Action:

Open the report whose application logic you are attempting to recover and enter PL/SQL into the Program Unit this program unit that has no code. If this program unit is redundant, as it has no code in it then deleting it would be a good option.


CGEN-03002

CGEN-03002 No command line can be built for module %s. Menu compilation will fail.

Cause:

The module command line or the MNUDFC or MNUDRC preferences are null.

Action:

Set either the module command line or the preferences MNUDFC or MNUDRC.


CGEN-03003

CGEN-03003 Failed to create .mmx file for menu module %s

Cause:

The command to compile the .mmb file into a .mmx file has failed. A possible cause is a problem in the .mmb file that has resulted in a compilation error. Alternatively, there might be a problem with your environment (e.g. you might have the wrong version of Form Builder installed).

Action:

If compilation errors occurred during generation, Form Generator creates a log file detailing the problem. For more information about the compilation error, view the log file from the Build Action dialog box.


CGEN-03008

CGEN-03008 Menu template %s not on template path

Cause:

The specified menu template could not be found on the template path.

Action:

Check your template path, menu template name and if the menu template exists.


CGEN-03009

CGEN-03009 Unable to generate unique substitution string

Cause:

Too many parameters were specified to generate unique names for all of them.

Action:

Try and reduce the number of parameters you require.


CGEN-03010

CGEN-03010 No menu modules to generate

Cause:

No further information available.

Action:


CGEN-03011

CGEN-03011 Too many menus in the generated menu module

Cause:

You have specified more modules of type MENU in the Repository than can be generated.

Action:

Reduce the number of modules of type MENU that will be included in the generated menu module.


CGEN-03014

CGEN-03014 Command line for module %s is too long

Cause:

The command line you have specified in the module definition is too long.

Action:

Specify a shorter command line.


CGEN-03016

CGEN-03016 Invalid role name

Cause:

A group name you have specified is not appropriate for an Form Builder role.

Action:

Change the group name appropriately.


CGEN-03031

CGEN-03031 Cannot delete menu module %s

Cause:

This internal message should not normally be issued. The generator is attempting to delete the existing menu module from the database on which the Repository is also held.

Action:

Contact your Customer Support Representative.


CGEN-03032

CGEN-03032 Failed to write menu module %s

Cause:

The menu generator could not write out the binary file for the menu module that it has just generated.

Action:

Investigate the reason given. Check that you have any write permissions necessary.


CGEN-03036

CGEN-03036 Specified module is not a valid start module, unable to generate menu

Cause:

The module specified from which to start the menu generation is not a valid start module. To be valid, a start module must:

·be of type MENU or type DEFAULT

·be of language Forms

·call other modules in the module network

Note that at least one of the called modules must also be of type MENU or type DEFAULT, and of language Forms.

Action:

Modify the module definition and/or the module network to make the module a valid start module.


CGEN-03250

CGEN-03250 Error during expansion: %s

Cause:

This is an internal error message not normally issued.

Action:

Contact your Customer Support representative.


CGEN-03251

CGEN-03251 Unknown Layout Style: '%s'; using default style

Cause:

The layout style specified against the module component is not in the list of styles supported by the generator.

Action:

A default style will be used instead of the style requested. To prevent the message from being issued in subsequent generations. modify the layout style property on the module component accordingly.


CGEN-03252

CGEN-03252 No valid values defined for checkbox item

Cause:

A checkbox item must have a set of valid values to source its checked/unchecked state values. There are no such valid values defined. Note: For bound items, the valid values must be defined against the underlying column or against the column's domain. For unbound items, the valid values must be defined against the item itself, or against the item's domain.

Action:

Add the appropriate valid values, as described.


CGEN-03253

CGEN-03253 Too many valid values defined for checkbox item

Cause:

A checkbox item that has been defined as optional must have a single valid value defined to source its checked state value. There are however more than one valid values defined. The first allowed value will be used. Note: For bound items, the valid values are defined against the underlying column or against the column's domain. For unbound items, the valid values are defined against the item itself, or against the item's domain.

Action:

Change the valid values, as described.


CGEN-03254

CGEN-03254 Not enough valid values defined for underlying column of checkbox item

Cause:

The underlying column for a mandatory item used to implement a checkbox is defined as NOT NULL but has only a single valid value defined for it.

Action:

Either make the both the column and item optional, or add a second valid value to the underlying column definition or its domain.


CGEN-03255

CGEN-03255 Not enough valid values defined for checkbox item

Cause:

A checkbox item that has been defined as mandatory must have two valid values to source its checked/unchecked state values. There is only one such valid value defined. Note: For bound items, the valid values are defined against the underlying column or against the column's domain. For unbound items, the valid values are defined against the item itself, or against the item's domain.

Action:

Add a second valid value, or make the item optional.


CGEN-03256

CGEN-03256 Too many valid values defined for checkbox item

Cause:

A checkbox item must have up to 2 valid values defined to source its checked/unchecked state values. There are more than 2 valid values defined; only the first two will be used. Note: For bound items, the valid values are defined against the underlying column or against the column's domain. For unbound items, the valid values are defined against the item itself, or against the item's domain.

Action:

Reevaluate the choice of display style for the item given the set of allowed values for the column.


CGEN-03257

CGEN-03257 Low/high range inappropriate for this item

Cause:

The set of allowed values used for the item includes one or more ranges. The high value(s) will be ignored. Note: For bound items, the valid values are defined against the underlying column or against the column's domain. For unbound items, the valid values are defined against the item itself, or against the item's domain.

Action:

No action required.


CGEN-03259

CGEN-03259 List item display type '%s' chosen, but no list of allowed values

Cause:

A PopList or TextList item must have a set of valid values defined for it. There are no such valid values defined. Note: For bound items, the valid values are defined against the underlying column or against the column's domain. For unbound items, the valid values are defined against the item itself, or against the item's domain.

Action:

Add the appropriate valid values, as described.


CGEN-03260

CGEN-03260 Invalid property '%s' in Control/Object definition file

Cause:

The given entry in the Control/Object definition file has not been recognized as a valid entry.

Action:

Check the file for any incorrect spellings.


CGEN-03261

CGEN-03261 Component placed within master must have exactly one master

Cause:

The required placement of 'STACKED' indicates that the component is to be embedded within its master. This component either has zero, or more than one master.

Action:

Use an alternative required position setting.


CGEN-03262

CGEN-03262 Constraint '%s' not validated

Cause:

The constraint is marked as being validated in the application only. No code will be created in the generated application to perform this validation.

Action:

The constraint should be marked as either 'Validate in DBMS' or 'Validate in both application and DBMS'.


CGEN-03263

CGEN-03263 Lookup item that forms part of link cannot be made enterable.

Cause:

The lookup item forms part of the lookup's link to its parent table usage. Such items may not be made enterable; the associated usage on the prior (parent) table usage should be made enterable if required.

Action:

Change the Item to unset its Display flag, and instead make the associated Item visible and enterable.


CGEN-03265

CGEN-03265 Items bound to RAW/LONG RAW columns not supported

Cause:

Use of columns defined as RAW or LONG RAW is not supported in this release.

Action:

Remove the item based on this column from the module definition.


CGEN-03266

CGEN-03266 Ambiguous source foreign key item for enterable lookup

Cause:

If a lookup is made enterable, a search is made for a foreign key column from an earlier table usage for this lookup to be matched against. This search resulted in more than one foreign key column being found. This often results from an unnormalized design.

Action:

Although no action is required, it is likely that manual changes will be required to the generated code. Check that each column in the multi-column foreign key used in the link to this lookup may be mapped to a separate lookup table.


CGEN-03267

CGEN-03267 Control '%s' not suitable for data entry/display

Cause:

The given control is, according to its properties read from the Control/Object Definition File, is unsuitable for representing a value mapped to a database column.

Action:

Either the Control/Object Definition File is incorrect, or the choice of control (e.g. CommandButton) is unsuitable.


CGEN-03268

CGEN-03268 Zones on window '%s' do not fit within template window size

Cause:

The zones placed on the given generated window cannot fit within the maximum window size allowed. The maximum window size is defined by the size of the template window that the generated window is based on. Generation of the module will continue, although some of the generated controls may be positioned below the window height.

Action:

Do one of the following:

·Increase the size of the template window(s).

·If the window contains more than one zone, consider placing each zone on its own window.

·Make use of stacked display groups to reduce the space required by a FORM or LISTFORM style zone.

·Modify the layout manually after generation.


CGEN-03269

CGEN-03269 Zone template is wider than template window

Cause:

The template zone used for this module component is wider than the layout area within the template window.

Action:

Either reduce the size of the zone template, or increase the size of the window template's layout area.


CGEN-03270

CGEN-03270 Template button '%s' not found in template form

Cause:

The given button template cannot be located in the template form. This template button is to be used as the basis of a button to be added to the zone or window's button bar. This button should be added either to the template zone form, or the template controls form.

Action:

Modify the template form and add the required button control.


CGEN-03271

CGEN-03271 Template window for property sheet dialog too narrow

Cause:

The template window used as the basis for creating property sheet dialog windows is not wide enough to fit necessary controls.

Action:

Increase the size of the template window.


CGEN-03272

CGEN-03272 Template window for property sheet dialog is too small

Cause:

The controls placed on the Property Sheet Dialog cannot fit within the maximum window size allowed. The maximum window size is defined by the size of the template window. Generation will continue, although some of the generated controls may be positioned below the window height.

Action:

You can either increase the size of the template window used as the basis for creating property sheet dialogs, or make use of stacked display groups to reduce the amount of space required.


CGEN-03273

CGEN-03273 Template window for query dialog too narrow.

Cause:

The template window used as the basis for creating query dialog windows is not wide enough for the generated controls.

Action:

Increase the size of the template window.


CGEN-03274

CGEN-03274 Template window for query dialog is too small

Cause:

The controls placed on the query dialog cannot fit within the maximum window size defined by the size of the template window that the query dialog is based on. Generation will continue, although some of the generated controls may be positioned below the window height.

Action:

Unset the Query flag on those Items that need not appear in the Query Dialog, or make the template window larger.


CGEN-03275

CGEN-03275 File '%s' does not exist

Cause:

A request was made to open the given file which is not present on the file system.

Action:

Ensure that the file is present and accessible.


CGEN-03277

CGEN-03277 Operating System Error: '%s'

Cause:

The file named in the previous message could not be opened due to an unanticipated O/S specific error.

Action:

Contact your system administrator.


CGEN-03278

CGEN-03278 Table '%s' has no primary key

Cause:

The table has no primary key defined for it. It is good design practice to ensure that each table has an associated primary key defined.

Action:

Add a primary key to the table.


CGEN-03279

CGEN-03279 Component allows Insert, but mandatory item not enterable

Cause:

The module component has the Insert Flag set, but the given item is one of the following:

·based on a NOT NULL column

·not enterable by the user

·not automatically derived

Action:

If the item's value is to be derived automatically, ensure one of the following column properties is set:

·Sequence

·Auto Generation Type

·Server Derived

·Server Defaulted

·Default Value

·Denormalised Alternatively, ensure that you add the required application logic to perform the derivation. Otherwise, set the Display and Insert flags on the Item to make it enterable by the user.


CGEN-03280

CGEN-03280 Item Group '%s' contains no displayed items

Cause:

The item group has neither any displayed items nor any other item groups within it.

Action:

Remove the item group if it is not required.


CGEN-03281

CGEN-03281 Cannot find template control '%s' (defined against the Item)

Cause:

The given template control, defined against the Item, does not exist in the Template Controls form.

Action:

Correct the Template/Library Object Name setting on the Item. Note that this setting can be left empty, to allow a default control to be chosen.


CGEN-03282

CGEN-03282 Cannot find template control '%s' (defined via user preference value)

Cause:

The given template control cannot be found in the Template Controls form (CGTCControls). Either the control has not been created in the Template Controls form, or the value of the corresponding user preference is incorrect.

Action:

Add the missing control to the template form, or modify the value of the user preference.


CGEN-03284

CGEN-03284 Template control '%s' is not appropriate for radio groups.

Cause:

The given control does not contain an embedded option button control and is therefore unsuitable for representing a radio group. A template control for a radio group should be a Frame style control with an embedded option button.

Action:

Modify the template control accordingly, or specify an alternative control.


CGEN-03285

CGEN-03285 Missing template caption to use with control '%s'

Cause:

The Template Controls Form is missing one or more of the template captions:

·DfltCaption (template caption)

·DfltCaptionRO (template caption for read only controls)

·DfltCaptionMand (template caption for mandatory controls) These controls must be present to define the appearance of control prompt/captions created for those control types that do not possess an integrated caption property.

Action:

Add the missing control(s) to the Template Controls form.


CGEN-03286

CGEN-03286 Cannot find template form object '%s'

Cause:

Generation requires that the named object be present in the given template form, and no such object exists.

Action:

Add the required object to the named template form.


CGEN-03287

CGEN-03287 Cannot find template form '%s'

Cause:

Cannot find the given form within the given template project or application.

Action:

A form of the given name must be present in the template project or application. Items within this form will be used as the basis for generated items.


CGEN-03288

CGEN-03288 Use of List style control '%s' for Foreign Key columns is not supported

Cause:

The control chosen for data entry of foreign key values must be a Text control. The use of a ListBox/ComboBox style control for foreign keys is not supported in this release. Use of these controls IS however supported where the underlying column is defined in the Repository as having a set of allowed values, which can be defined as being dynamically loaded at runtime.

Action:

Change the item's display type and/or template/library object setting to use a text based control.


CGEN-03289

CGEN-03289 Missing button in stacking area template

Cause:

The template radio button frame used for a Stacking Area must contain an embedded option button. No such option button can be found.

Action:

Modify the template and add the option button.


CGEN-03290

CGEN-03290 Name of generated file '%s' is too long

Cause:

The name of a generated file that is built up from a Repository property is longer than the maximum file name length allowed. The maximum length is dictated by an option set in the Design Editor.

Action:

Define a filename name that conforms to the maximum allowed length. View the navigation action to know what name needs to be changed.


CGEN-03291

CGEN-03291 Failed to load Control/Object Definition file '%s'

Cause:

The Control/Object Definition file could not be loaded.

Action:

Check that this file can be opened from an editor such as Notepad. Note that the user preference CTLDEF (VB Generator) or OBJDEF (Power Objects Generator) defines the location of this file.


CGEN-03292

CGEN-03292 Control type '%s' unknown

Cause:

There is no definition for the given control in the Control/Object Definition File.

Action:

Modify the Control/Object Definition File to add an entry for this control.


CGEN-03293

CGEN-03293 Control type '%s' is not suitable for entry of optional values

Cause:

The item or its underlying column has been defined as optional but the Control/Object Definition File entry indicates that the chosen control type cannot hold an empty value.

Action:

Either remove the optional flag on the column or item, or change the item's display type or template/library object setting(s) to chose a more suitable template control. Note there is a possibility that the Definition File entry is in error.


CGEN-03294

CGEN-03294 Control type '%s' is not suitable for date values

Cause:

The item is based on a Date column, but the Control/Object Definition file indicates that the chosen control type cannot be used to represent a Date value.

Action:

Change the item's display type or template/library object setting(s) to chose a more suitable template control. Note there is a possibility that the Definition File entry is in error.


CGEN-03295

CGEN-03295 Control type '%s' is not suitable for numeric values

Cause:

The item is based on a Number column, but the Control/Object Definition File entry indicates that the chosen control type cannot be used to represent numeric values.

Action:

Change the item's display type or template/library object setting(s) to chose a more suitable template control. Note there is a possibility that the Definition File entry is in error.


CGEN-03297

CGEN-03297 %s has failed, please send the following information to your support person

Cause:

An unexpected internal error has occurred.

Action:

Please save the information messages written to the generation dialog window by copying them to a file, and contact your customer support representative.


CGEN-03298

CGEN-03298 Control type '%s' is read only and cannot support data entry

Cause:

The item has the Insert or Update allowed flag(s) set indicating that the user should be allowed to enter a value for this item during the Insert or Update of records. The Control/Object Definition File indicates, however, that the chosen control type is read only, i.e. it cannot be set interactively.

Action:

Change the item's display type or template/library object setting(s) to chose a more suitable template control. Note there is a possibility that the Definition File entry is in error.


CGEN-03299

CGEN-03299 Column datatype '%s' unsuitable for use in Query WHERE clause

Cause:

The item is based on a LONG column, and has the Query flag set indicating that the user should be allowed to enter search criteria against the column during queries. This is not supported.

Action:

Unset the query flag on the item.


CGEN-03300

CGEN-03300 Item derivation text '%s' references own item name

Cause:

The item's derivation expression contains a reference to its own item name. This recursive reference is not permitted.

Action:

Correct the derivation text.


CGEN-03301

CGEN-03301 Display height of 1 not appropriate for display type of Text List

Cause:

The item has a display height set to one and a display type of Text List. The height is not adequate to display the item as a Text List

Action:

Either increase the display height to a minimum of three, or make the display type a Pop List.


CGEN-03302

CGEN-03302 Valid values ignored because column is auto generated

Cause:

A column is defined in the Repository as both having a list of valid values (or being a domain so defined), and as being derived either via a Sequence name or an auto generate type. In this situation, the valid values will be ignored.

Action:

The column definition should be modified to eliminate the inconsistency. Ensure the column is not autogenerated OR remove the valid values.


CGEN-03303

CGEN-03303 Failed to allocate windows device context

Cause:

The attempt to allocate a windows device context has failed.

Action:

Close down some other windows applications and try again. Upon repeated failure reboot windows and/or the PC.


CGEN-03304

CGEN-03304 Column defining sort order cannot be referenced by a foreign key

Cause:

The column is defined in the Repository as being auto generated as 'Sequence within Parent', and the column is referenced by a foreign key within another table. This column should not be used to link tables together, as it may be frequently updated during resequence operations.

Action:

Use an alternative column to join the tables together.


CGEN-03305

CGEN-03305 Failed to release windows device context

Cause:

Attempt to release a device context back to the Windows O/S has failed.

Action:

Upon repeated failure reboot windows and/or the PC.


CGEN-03306

CGEN-03306 Missing column usage for parent column '%s'

Cause:

The column is defined in the Repository as being Sequenced Within Parent, and a component of the primary or unique key that it is a part of has not been defined as being used in the module. No code for allocating sequence number within parent will be generated.

Action:

Add usages of the other columns in the same primary/unique key if code to allocate this column's value is required.


CGEN-03307

CGEN-03307 No role defined; Assuming present in both LOV and Form

Cause:

The lookup item has neither of the "In LOV" and "Lookup Item" flags set; at least one of these flags should be set.

Action:

No action required. Both flags will be set implicitly.


CGEN-03308

CGEN-03308 Reference to item '%s' in derivation text is not allowed

Cause:

The derivation text recorded against this SQL expression or Server Function unbound item contains a reference to another unbound item that is one of the following:

·Computed

·Custom

·Client Function

·Target Specific References to these types of item are not permitted.

Action:

Modify the derivation text accordingly.


CGEN-03309

CGEN-03309 Radio group cannot support a suggestion list

Cause:

A radio group has been chosen for a column whose list of allowed values has been defined as a suggestion list. This display type is not suitable for suggestion lists.

Action:

Either clear the 'Suggestion List' property on the column definition, or chose an alternative control type for this item.


CGEN-03310

CGEN-03310 List of allowed values for Radio group should be defined as static

Cause:

A radio group has been chosen for a column whose list of allowed values is defined as dynamic. This display type is not suitable for value lists that are to be loaded dynamically at run time.

Action:

Either the 'Dynamic LOV' flag on the column (or domain) should be unset, or a different display type should be chosen.


CGEN-03311

CGEN-03311 Column '%s' defined as Seq within Parent in single column primary key

Cause:

The column is defined as being auto-generated as Sequence within Parent, but the column is in a single column primary key, implying it should be unique across all rows.

Action:

If the column is required to be unique across all rows, then remove the Auto Generation setting of 'Sequence in Parent' from column definition, and instead assign a Sequence to the column. Otherwise, correct the definition of the primary/unique key.


CGEN-03312

CGEN-03312 Check box cannot support a suggestion list

Cause:

A checkbox has been chosen for a column whose list of allowed values has been defined as a suggestion list. This display type is not suitable for suggestion lists.

Action:

Either unset the 'suggestion list' property on column definition, or chose an alternative control type.


CGEN-03313

CGEN-03313 List of allowed values for Check box should be defined as static

Cause:

A checkbox has been chosen for a column whose list of allowed values has been defined as dynamic. This display type is not suitable for representing a list of allowed values that is to be dynamically loaded at runtime.

Action:

Either unset the 'dynamic lov' flag on the column (or its domain), or chose an alternative display type.


CGEN-03314

CGEN-03314 This control cannot be used for a suggestion list

Cause:

A list style control has been chosen for a column whose list of allowed values has been defined as a suggestion list, but the Control/Object Definition File entry for this control indicates that this control can only support a fixed set of values.

Action:

Either unset the 'suggestion list' property on the column definition, or choose an alternative control type. Note there is a possibility that the Definition File entry is in error.


CGEN-03315

CGEN-03315 File Access Denied

Cause:

The file required is in use by another application, however sole access to this file is required.

Action:

Ensure that no other application is using this file before trying to generate the module again.


CGEN-03316

CGEN-03316 Too many open files

Cause:

In an attempt to open a file, the maximum open files that the operating system allows was exceeded.

Action:

Close any files that are not currently needed or increase the maximum number of files that the operating system allows.


CGEN-03317

CGEN-03317 Column '%s' defined as Seq within Parent is not in a primary key

Cause:

The column is defined in the Repository as being auto-generated as Sequence within Parent, but does not form part of a primary key.

Action:

This warning is highlighting an area in the database design that does not seem correct. It is likely that the column should form part of a primary key.


CGEN-03318

CGEN-03318 Column '%s' defined as Seq within Parent should be numeric

Cause:

The column is defined in the Repository as being auto-generated as Sequence within Parent, but the column is not defined as being of a numeric datatype.

Action:

This warning is highlighting an area in the database design that does not seem correct.


CGEN-03319

CGEN-03319 System Generated column is not in any primary or unique key

Cause:

The item's underlying column is defined as having its value derived from a unique source, but that column is not included in any of its tables Unique or Primary keys.

Action:

No action required, although it is likely that this column should form the primary key of the table.


CGEN-03320

CGEN-03320 Component with Sort Order column does not permit restrictive queries

Cause:

The module component includes an item based on a column that defines the sorting order of the rows within the master component, and one or more of the items have the Query flag set. Restrictive queries are not permitted in this situation.

Action:

The corresponding items should be updated to unset the Query allowed flag.


CGEN-03321

CGEN-03321 Item name '%s' ambiguously defined

Cause:

The given item is referenced in the expression/condition text, and more than one item exists with this name within the module definition. The item from the component which is most closely related to this component will be mapped.

Action:

To remove any possible ambiguities, change the names of your items so that they are unique across the whole module.


CGEN-03322

CGEN-03322 Syntax error in check constraint condition text.

Cause:

There is a syntax error in the check constraint condition text. The accompanying message(s) detail the nature of the error.

Action:

Check the condition text for syntax errors, and correct.


CGEN-03323

CGEN-03323 Column '%s' referenced in check constraint text has no corresponding item

Cause:

The check constraint condition text references a column for which there is no corresponding item defined.

Action:

If you want this constraint to be validated by the generated application, add an item based on the specified column.


CGEN-03324

CGEN-03324 Column reference '%s' ambiguously defined

Cause:

The given column is referenced in the expression/condition text, and more than one column exists with this name within the tables used by this module component.

Action:

To remove any possible ambiguities, qualify the column references by the table usage name. For example, if you have base and lookup table usages both based on EMP with names 'E' and 'MGR' respectively, use 'MGR.ENAME' instead of 'ENAME' to refer to the manager's name.


CGEN-03325

CGEN-03325 Missing change history item '%s' added automatically as non-displayed

Cause:

The given item has been added automatically during generation because it is required to maintain change history information.

Action:

No action required.


CGEN-03326

CGEN-03326 Valid value '%s' larger than column's maximum length

Cause:

The valid value defined on the underlying column (or domain) of this bound item is larger than the column's maximum size permits.

Action:

Increase the size of the column, or modify the allowed value accordingly.


CGEN-03327

CGEN-03327 Assertion failure at %s

Cause:

This is an internal message not normally issued.

Action:

Contact your customer support representative.


CGEN-03328

CGEN-03328 Derived item made non-updateable

Cause:

This item is based on a column that has been defined as having its value derived, but the item has the Update flag set. The item will be made non-updateable. The derivation criteria is defined via the following Column properties:

·AutoGenerate Type

·Sequence

·Server derived

·Denormalised

Action:

This warning is highlighting an area in the module design that does not correspond to information specified in the database design. The Generator has modified the module design accordingly; both in the context of the generation of this module, and also in the Repository.


CGEN-03329

CGEN-03329 Control on which to add repository code could not be found

Cause:

A piece of application logic has been defined against this item with a target location of 'Property Sheet Dialog' or 'Query Dialog', but the component's layout style and the item's usage flags are set such that no control has been created in this location for this item.

Action:

Change the location of the application logic to the main form, or add the required control to the 'Property Sheet Dialog' or 'Query Dialog' as required.


CGEN-03330

CGEN-03330 Display width increased to '%s' to accommodate the display of meaning values

Cause:

The underlying column has a set of allowed values, and the meaning to be displayed at runtime instead of the value itself. However the display width specified on the item is not large enough to accommodate the longest meaning string currently defined. The width has been increased accordingly.

Action:

No action required.


CGEN-03331

CGEN-03331 Reference to column '%s' from SQL expression text not permitted

Cause:

The derivation text for this SQL Expression makes reference to a column from a table that is used in this module component as part of the requirement for one of the following:

·a single row SQL aggregate

·a subquery

As the table usage will not form part of the FROM clause of the component's main query, a reference to any of its columns from any SQL expressions is not permitted. Note: This message will be issued even where one of the component's base or lookup table usages is based on the same table.

Action:

If one of the base/lookup table usages is based on the same column, qualify the column reference within the SQL expression by the table usage name.


CGEN-03332

CGEN-03332 Duplicate usage of column '%s' ignored

Cause:

A module component has been defined with more than one item based on the same column. This design is not supported in this release.

Action:

Remove the duplicate item.


CGEN-03333

CGEN-03333 Missing usage of primary key column '%s'

Cause:

The given column is defined in the table's primary key, and there is no item based on this column in the module definition. The module's base table usages must include items for all of the table's primary key columns.

Action:

Add items for the table's primary key columns.


CGEN-03334

CGEN-03334 Item used to link to master cannot have Query flag set

Cause:

This item forms part of the link back to a master component, and as such may have query criteria specified against it. A query on a detail component must always show records related to the current master record.

Action:

No action required. The query flag will be automatically cleared on the item.


CGEN-03335

CGEN-03335 Usage flags transferred from hidden foreign key item '%s'

Cause:

An item that forms a single column link to a lookup table has either the Insert or Update allowed flags set, and is marked as non-displayed. The flag settings have been transferred to the given lookup item.

Action:

No action required.


CGEN-03336

CGEN-03336 Inappropriate usage flags cleared

Cause:

It is not appropriate to set the Insert, Update and Nullify flags on non-displayed items, nor on unbound items that are displaying a derived value.

Action:

No action required. The flags will be automatically cleared.


CGEN-03337

CGEN-03337 Column '%s' is part of the primary key and cannot be updated

Cause:

The Update flag is set of the item, and the column is part of its table's primary key. Updateable primary keys are not supported.

Action:

If there is a requirement to update primary key columns, consider adding a hidden numeric primary key column derived from a sequence, and create a unique key based on the columns currently in this primary key.


CGEN-03338

CGEN-03338 No derivation text specified

Cause:

The column has an expression type of either SQL expression or client function but no expression has been entered against the column

Action:

Either add an expression or change the expression type to NULL.


CGEN-03339

CGEN-03339 Column defined as Sequence in Parent should be NOT NULL

Cause:

The column is defined in the Repository as being Autogenerated as Sequence in Parent. It is recommended that the column is made mandatory.

Action:

No action required.


CGEN-03340

CGEN-03340 Preference '%s' not loaded

Cause:

The specified preference is missing. It is possible that the Generator has not been installed correctly.

Action:

Contact your Customer Support representative.


CGEN-03341

CGEN-03341 Syntax error in column derivation expression text: '%s'.

Cause:

There is a syntax error in the column derivation expression text. Parsing of the expression resulted in the specified Oracle error.

Action:

If the error is due to a syntax error in the derivation expression text, correct it and generate again. If it is due to database objects not being created in the account (e.g. a table), ensure they are available before the application is run.


CGEN-03342

CGEN-03342 Maximum display width (255) exceeded

Cause:

A display width of greater than 255 characters has been specified against the given item.

Action:

No action required. The width will be reduced automatically.


CGEN-03343

CGEN-03343 Display type of item '%s' not supported. Defaulted to TEXT

Cause:

The display type specified is not supported in this release. The display type will be defaulted to TEXT.

Action:

Change the display type accordingly.


CGEN-03344

CGEN-03344 First descriptor column is optional

Cause:

For each module component, one or more of the items should be marked 'Context', indicating that the values in these columns can be used to identify the row. The first of these columns should be a mandatory column to ensure useful context information. Note: If no items are marked 'Context' Primary Key columns are used instead, together with any columns which are marked as 'descriptors' within the column definition (Descriptor Seq).

Action:

Re-assess which items in the component should be marked as Descriptor/Context, and the order in which they appear.


CGEN-03345

CGEN-03345 Maximum length of control name prefix exceeded for control type '%s'

Cause:

The length of the control name prefix is too long, maximum length is 3 characters.

Action:

Decrease the length of the control name prefix for this control type The control name prefix is specified in the Control/Object Definition File.


CGEN-03346

CGEN-03346 Reset Group '%s' not found in any component within this module

Cause:

This item has a reset level of 'named group' but the reset group defined does not exist in any of the module components that make up this module. The reset group will be defaulted to be the current group.

Action:

Change the property setting to a valid group name.


CGEN-03347

CGEN-03347 Expression type set as none when column %s has derivation text defined

Cause:

Column has derivation text defined to be generated but the derivation text type is set to none.

Action:

Set the derivation text type to either SQL Expression or Function Call


CGEN-03348

CGEN-03348 The client function derivation text references items incorrectly - %s

Cause:

No further information available.

Action:


CGEN-03349

CGEN-03349 Generator action item not required

Cause:

A generator action item has been defined against the module component, but (according to the usage flags on the component) an action item of this type is not required.

Action:

Review the settings of the usage flags on the component, or consider using a custom action item.


CGEN-03350

CGEN-03350 Item used in link to master changed to non-display

Cause:

An item has been used to link a module component back to a previous component. As the usage indicated that update is not allowed in this item, there is no need to display the column value, therefore the item has been changed to make it non-displayed.

Action:

No action is required.


CGEN-03351

CGEN-03351 Cannot navigate to component '%s'

Cause:

The layout requirements of components within the module are such that it will not be possible to navigate to the specified component, or any other component in the same window. This is because there are no action items that navigate to the window.

Action:

Add an action item to navigate to the component from an earlier window.


CGEN-03352

CGEN-03352 Suggestion List and/or Dynamic List flags ignored

Cause:

The column on which this item is based is in a Domain, or has an allowed value defined against it, which defines a range between a low and high limit. This Domain, or Column, has been marked as either Suggestion List or Soft LOV. Both of these flags will be ignored and the control will be generated to allow values in the range currently defined in the Repository.

Action:

No action required.


CGEN-03353

CGEN-03353 Multiple ranges, or combination of ranges and discrete values not supported

Cause:

The list of Allowable Values defined against this item, column, or module argument, contains a number of entries of which one or more is defined as a range. This combination is not supported.

Action:

Redefine the Domain (or list of Allowed Values against the element) as a list of discrete values (with no ranges) or as a single range. If a combination of ranges and discrete values is required then this could be validated using application logic.


CGEN-03354

CGEN-03354 Item based on column '%s' not created: column is not marked 'Complete'

Cause:

An item based on the column was not created as the column's complete flag is set to 'No'. Bound items can only be based on complete columns.

Action:

No action required.


CGEN-03355

CGEN-03355 Lookup item marked for use in LoV has not been used

Cause:

The given item forms part of a lookup table usage, and has the 'Include in LoV' usage flag set, but does not have the 'Lookup Item' flag set. The characteristics of the associated foreign key control are such that no list of values has been generated that uses this item.

Action:

Ensure that the associated foreign key item is defined with the Insert or Update usage flag set, or that one of the lookup items has the 'Lookup Item' flag set.


CGEN-03356

CGEN-03356 No invocation code has been generated for the navigation item '%s'

Cause:

There is an action item for navigating to another module via a module network link, where the calling and called modules are of different languages, and no command line has been specified, in order to invoke the called module

Action:

Do one of the following:

·Manually add the navigation code after generation.

·Make both modules the same language then code will be generated onto the navigation menu item.

·Add the invocation code to the command line of the called module.


CGEN-03357

CGEN-03357 Recursion found traversing foreign keys between tables '%s' and '%s'

Cause:

This error can occur when two foreign keys link the same tables with the same columns e.g. FK1 on table A links to table B using columns A:X and B:Y and FK2 on table B links to table A using the same columns i.e. B:Y and A:X This design is not supported.

Action:

Remove one of the foreign keys, or create the link between different columns


CGEN-03358

CGEN-03358 Ranges not supported by the requested display type

Cause:

An inappropriate display type or template/library object is being used to represent a column which is defined to be in a range.

Action:

Change the Control Type or template/library object to some other control which supports ranges.


CGEN-03359

CGEN-03359 No items within this component have been marked as displayed

Cause:

None of the items defined against this component, have been marked as displayed. A generated module component must contain at least one displayed item.

Action:

Set the Display flag on one or more items.


CGEN-03360

CGEN-03360 Name is a reserved SQL or PL/SQL word

Cause:

The name is a reserved SQL or PL/SQL word which is not allowed.

Action:

Change the name.


CGEN-03361

CGEN-03361 Same column '%s' at both ends of foreign key constraint

Cause:

A foreign key has been defined where the same column is used at both ends of the foreign key. This design is not supported.

Action:

Remove the foreign key.


CGEN-03362

CGEN-03362 No repository element found to map application logic on : '%s'

Cause:

Application logic has been added against an object in the generated application, which does not map to a Repository element. This code will be ignored by the Application Logic Recovery.

Action:

Change the location of the application logic to the main form, or add the required control to the 'Property Sheet Dialog' or 'Query Dialog' as required.


CGEN-03363

CGEN-03363 Datatype mismatch in columns used in foreign key constraint

Cause:

The columns at either end of foreign key have different datatypes. It is good design to use consistent datatypes and maximum sizes across columns used to join tables.

Action:

No action required.


CGEN-03364

CGEN-03364 Read-only GUI items not supported

Cause:

A GUI display type has been specified on the item, and the item's Insert and update flags are unset. The generator does not support read-only GUI items, so a text display type will be used instead.

Action:

No action required.


CGEN-03365

CGEN-03365 No help text defined

Cause:

No Help text is defined for the module element and no substitute text is available. Only a title or heading will appear in the generated help output.

Action:

Enter some Help text for the module element and then generate again. If you have not done so already, try setting the 'No Text Entered for Module Component' (DTUNHP) and 'No Text Entered for Item' (DCUNHP) preferences. These preferences let you make use of other suitable text sources when help text is omitted. If certain items do not have Help text to display, use the 'Display Prompts for Items with No Help Text' preference (DCUCAP), to hide any associated heading and then generate the Help again.


CGEN-03366

CGEN-03366 Module '%s' is already included in the menu hierarchy

Cause:

When building the menu hierarchy from the module network, the same module was found more than once.

Action:

No action required.


CGEN-03368

CGEN-03368 No PSD was created for zone '%s' on which to add application logic

Cause:

A segment of code held in the Repository, has a destination window of type Property Sheet Dialog (PSD), but no PSD has been created for this zone. This indicates that the module definition has been modified after this segment of code was loaded or entered into the Repository. This may have been caused by changing the zone style.

Action:

No action is required; the segment of code will be ignored


CGEN-03369

CGEN-03369 Column '%s' not wide enough to hold username - maximum length is 30

Cause:

The underlying column of this item is defined as being auto derived as the User who Created/Modified the row, but the maximum length of the column is less than 30 characters.

Action:

Increase the size of the column to 30 characters.


CGEN-03370

CGEN-03370 Cannot generate module '%s'; it has no language

Cause:

The given module has no language defined against it. The language of a module must be specified before it can be generated.

Action:

Specify the required language against the module definition.


CGEN-03371

CGEN-03371 Parent break group not found; using current break group

Cause:

The reset level of the item has been set to 'Parent Group', but no parent break group can be found for this item. The reset level will be defaulted to 'Current Group'.

Action:

Review the break groups defined in the module against the reset levels being used, and update the module accordingly.


CGEN-03372

CGEN-03372 Query set only contains unbound items

Cause:

The generator does not support query sets consisting only of unbound items.

Action:

Add a bound item to the query set.


CGEN-03373

CGEN-03373 PL/SQL Block text for item is invalid - %s

Cause:

The unbound item is typed as a 'Custom', but the associated PL/SQL text is not in the expected syntax of 'function_name(parameters)'.

Action:

Modify the PL/SQL text.


CGEN-03374

CGEN-03374 Cannot generate module '%s'; it is of type MENU

Cause:

A MENU Module is not a valid module to choose as a start module.

Action:

Remove the MENU setting from the module type, if this is appropriate. Otherwise create a dummy non-MENU module and add this to the top of the module network structure you wish to generate.


CGEN-03375

CGEN-03375 LOV usages must have matching query and data entry settings

Cause:

The column usages which are used in building a List of Values to populate the given control, do not have consistent data entry (i.e. Insert and/or Update) and query (i.e. Select) usage settings. As the same List of Values form will be used in both cases, the usage flags must be set accordingly.

Action:

Modify the data entry and/or select usage settings on the column usage(s) used to populate the control. These can be set as just data entry, just select, or, if both data entry and select are required, all such usages must have consistent flag settings.


CGEN-03376

CGEN-03376 Master/detail links ignored for Unbound Component

Cause:

This component is an unbound component which means that it cannot be involved in master/detail links. Master/detail links were detected and ignored.

Action:

Remove any master/detail links for this component


CGEN-03377

CGEN-03377 Name is not a valid name; try '%s'

Cause:

The name is not a valid name. A valid name can only include alphanumeric characters, plus underscore. It also must not begin with a digit.

Action:

Amend the name in the Repository.


CGEN-03378

CGEN-03378 Name is too long; maximum of '%s' characters

Cause:

The name is too long.

Action:

Change the name so that it is no longer than the specified size.


CGEN-03379

CGEN-03379 Syntax error in item derivation expression text: '%s'.

Cause:

There is a syntax error in the item derivation expression text. Parsing of the expression resulted in the specified Oracle error. For WebServer Generator, you will see this message when an unbound item references a Named Routine, because the routine is not visible during generation. You do not need to take any action.

Action:

If the error is due to a syntax error in the derivation expression text, correct it and generate again. If it is due to database objects not being created in the account (e.g. a table), ensure they are available before the application is run.


CGEN-03380

CGEN-03380 Unable to resolve all references in the derivation expression '%s'

Cause:

A circular reference has been detected in the derivation expression. This derived item is used in the derivation of an item from which itself is derived.

Action:

Remove the circular reference.


CGEN-03382

CGEN-03382 Unbound item type '%s' is not appropriate for Unbound Component

Cause:

The unbound item type is not appropriate for unbound components. The item will be ignored.

Action:

Remove the item, or change its type to 'Custom' and add the appropriate application logic to maintain its value.


CGEN-03383

CGEN-03383 Usage flags unset for unbound component

Cause:

It is not appropriate to set any of the usage flags on an unbound component.

Action:

No action required. The flags will be automatically cleared.


CGEN-03384

CGEN-03384 User does not have access rights; repository definition will not be updated

Cause:

The current Repository user does not have access rights to update the Repository, so any changes made by the generator will not be saved.

Action:

No action required.


CGEN-03385

CGEN-03385 Language differs from Save Language; repository definition not updated

Cause:

This module has been generated as a language different to the module language and therefore cannot be saved in the generated language.

Action:

Change the language in the module properties to the language you wish to generate and save in.


CGEN-03386

CGEN-03386 Display type of item %s was NULL. Defaulted to TEXT.

Cause:

No display type was defined for the item, so a default display type has been used.

Action:

No action required.


CGEN-03387

CGEN-03387 Missing link items in Master-Detail link

Cause:

Items in the detail module component required to link to the master are missing, and the generator could not create them.

Action:

Add the missing items to the detail module component.


CGEN-03388

CGEN-03388 No caption defined for data entry control

Cause:

An item has been defined with the Insert/Update flags set and without a prompt. In the generated application the prompt of a data entry control may be required in a validation message, to identify the item if a validation condition fails.

Action:

Define an appropriate prompt for the column usage.


CGEN-03390

CGEN-03390 Implementation Name '%s' used by more than one module

Cause:

More than one module in the chosen network shares the same generated file name. Names of generated files are derived from the module's Implementation Name (or the module's Short Name if an Implementation Name is not provided).

Action:

Ensure that all the modules in the module network have a unique Implementation Name. If a module's Implementation Name is not defined, ensure that the Short Name does not clash with the Implementation Name of any other modules in the network.


CGEN-03391

CGEN-03391 Mnemonic character '%s' is also used by a top level template menu item

Cause:

The specified mnemonic access character has been added to the prompt of the given item, and is also used by a top level menu item on the template form. Mnemonic access characters which are used by top level menu items cannot be shared.

Action:

Either remove or change the mnemonic access character on the prompt property of this item.


CGEN-03392

CGEN-03392 Logon to validation user (%s) failed. Using current connection.

Cause:

Logging onto the validation user has failed and so all SQL parsing will be performed using the Repository User connection in use at the time of generation. This may result in parse errors and warnings which are not relevant.

Action:

Correct the specified validation user and generate again.


CGEN-03393

CGEN-03393 Enterable lookups have inconsistent usage flags

Cause:

This item is populated by more than one lookup item. These lookups do not have identical settings for Insert and/or Update.

Action:

Modify the Insert and/or Update settings for the lookup items.


CGEN-03394

CGEN-03394 Dependent items have inconsistent usage flags

Cause:

This item forms part of a foreign key link and there is an inconsistency between the Insert and/or Update flags with one or more of the enterable items which define the other column(s) in that foreign key.

Action:

Modify the Insert and/or Update settings of the dependent controls.


CGEN-03395

CGEN-03395 Syntax error in check constraint condition text: '%s'.

Cause:

There is a syntax error in the check constraint condition text. Parsing of the check constraint condition resulted in the specified Oracle error.

Action:

If the error is due to a syntax error in the check constraint text, correct it and generate again. If it is due to database objects not being created in the account (e.g. a table), ensure they are available before the application is run.


CGEN-03396

CGEN-03396 Cannot have multiple enterable items of base column

Cause:

There are multiple items based on a particular column, more than one of which has Update and/or Insert flags set. This is not supported.

Action:

Ensure only one item (based on the given column) has Insert and Update flags set.


CGEN-03397

CGEN-03397 No source foreign key control for enterable lookup

Cause:

If a lookup is made enterable, a search is made for a foreign key column in an earlier table usage for this lookup to be matched against. This search resulted in no foreign key item being found.

Action:

Add the missing item for the foreign key column.


CGEN-03398

CGEN-03398 List style control not allowed in this context

Cause:

The display type for the specified item is defined as Pop List or Text List. This type of control is not supported for foreign key data entry controls where there is more than one enterable lookup defining a single foreign key column, nor where the list of possible values are dependent on the value of another column.

Action:

Change the Display Type for the item to 'TEXT'.


CGEN-03399

CGEN-03399 Missing mandatory item '%s' added automatically

Cause:

A mandatory item was missing from the module component: the generator has automatically added this item.

Action:

No action required.


CGEN-03400

CGEN-03400 'Closed loop' of mandatory foreign keys found

Cause:

A loop of mandatory foreign keys was found. If this is the case then it is impossible to enter the first record. For example if the EMP table has a mandatory foreign key to itself for the manager id then it will be impossible to enter the first record since no manager exists.

Action:

Change the model so there is no 'closed loop' of mandatory foreign keys.


CGEN-03401

CGEN-03401 Control type '%s' is not suitable for character values

Cause:

The item is based on a Character column, but the display type or template/library object indicates that the chosen control type cannot be used to represent character values.

Action:

Chose an alternative control type for this item. Note there is a possibility that the Control Definition File is in error.


CGEN-03402

CGEN-03402 Generator Action Items at the window level are not supported

Cause:

A generator action item has been added to the specified window. Currently the use of this type of action item at the window level is not supported. This action item has been ignored and will not be generated

Action:

Remove the action item from the window


CGEN-03403

CGEN-03403 General syntax error in check constraint condition text.

Cause:

There is a syntax error in the check constraint condition text. Parsing of the check constraint condition resulted in the Oracle error 'FROM keyword not found when expected'.

Action:

Check the condition text for syntax errors, and correct.


CGEN-03404

CGEN-03404 Display of meaning alongside of code is not supported

Cause:

The display of meanings alongside the code value is not supported in this release. The meaning will be shown instead of the code.

Action:

To avoid this warning on subsequent generations change the value of the 'Show Meaning' property to 'ALONGSIDE'


CGEN-03405

CGEN-03405 No datatype specified for unbound item.

Cause:

There was no datatype defined for the unbound item; a default value will be assumed.

Action:

To avoid this message on future generations enter a datatype for the unbound item.


CGEN-03406

CGEN-03406 Usage Sequence greater than that of Component '%s'

Cause:

The Module Component has a link to another Module Component with a lesser Usage Sequence in the same module. Such linking is not supported.

Action:

Modify the Usage Sequences of one, or both, of the Module Components, such that the link is from the Component with the lesser Usage Sequence to the Component with the higher Usage Sequence.


CGEN-03407

CGEN-03407 No derivation text defined on unbound item

Cause:

This type of unbound item requires derivation text to define how its value is to be derived. No such text has been defined.

Action:

Add the missing derivation text for the item or change the type of the unbound item to 'CUSTOM'


CGEN-03408

CGEN-03408 Syntax error in item derivation text.

Cause:

There is a syntax error in the item derivation text. The accompanying message(s) detail the nature of the error.

Action:

Check the text for syntax errors, and correct.


CGEN-03409

CGEN-03409 General syntax error in the derivation expression text.

Cause:

There is a syntax error in the derivation expression text. Parsing of the expression resulted in the Oracle error 'FROM keyword not found when expected'.

Action:

Check the expression text for syntax errors, and correct.


CGEN-03410

CGEN-03410 Module '%s' not generated; prevent generation flag is set

Cause:

The prevent generation flag is set to YES so the module cannot be generated.

Action:

If you wish to generate the module set the prevent generation flag to NO


CGEN-03411

CGEN-03411 This module is shared; its repository definition will not be updated

Cause:

This module definition is shared from another application system. Consequently the generation process will not make any changes to the module.

Action:

No action required.


CGEN-03412

CGEN-03412 Unbound module components not supported

Cause:

All of the items in this module component are unbound. Generation of module components with no bound items is not supported.

Action:

Add table usages / bound items to the module component.


CGEN-03413

CGEN-03413 Module Component language '%s' differs from module language

Cause:

Mixed language modules are not supported by the generator.

Action:

No action required.


CGEN-03414

CGEN-03414 DataSource type '%s' is not supported

Cause:

The specified datasource type is not supported by the generator.

Action:

No action required.


CGEN-03416

CGEN-03416 The display group '%s' does not belong to a break group

Cause:

The generator requires that all items and display groups are nested within break groups. This display group has not been created within a break group.

Action:

Move the item group so it is part of a break group.


CGEN-03417

CGEN-03417 External links must be to the first module component in the module

Cause:

The module component is the target (detail) of a key based link sourced from another module. Any such links may only be defined on the first component within the module.

Action:

Remove the key based link, or resequence the module component within the module.


CGEN-03418

CGEN-03418 Missing action item to navigate to '%s'

Cause:

There is a key based link defined from this component to another component placed on a different window, but there is no action item defined to enable this navigation.

Action:

No action required.


CGEN-03419

CGEN-03419 Key based link (to '%s') linked from lookup table not supported

Cause:

There is a key based link that links to a lookup table usage at the detail end of the link. This design is not currently supported by the generator.

Action:

Ensure that the detail ends of any key based links are linked to base table usages.


CGEN-03420

CGEN-03420 Component contains one or more un-typed table usages

Cause:

This component contains one or more table usages whose type is unknown.

Action:

Use the module diagrammer to specify the types of table usages, and the links between them, prior to generation.


CGEN-03421

CGEN-03421 Unbound item type 'SQL Expression' not supported

Cause:

The unbound item type is 'SQL Expression', which is not supported by this generator in this release. The item will be ignored.

Action:

Remove the item, or change its type to 'Custom' and add the appropriate application logic to maintain its value.


CGEN-03422

CGEN-03422 Unbound item type 'SQL Aggregate' not supported

Cause:

The unbound item type is 'SQL Aggregate', which is not supported by this generator in this release. The item will be ignored.

Action:

No action required.


CGEN-03423

CGEN-03423 Unbound item type 'Computed' not supported

Cause:

The unbound item type is 'Computed', which is not supported by this generator in this release. The item will be ignored.

Action:

Remove the item, or change its type to 'Custom' and add the appropriate application logic to maintain its value.


CGEN-03424

CGEN-03424 Unbound item type 'Client Function' not supported

Cause:

The unbound item type is 'Client side function', which is not supported by this generator in this release. The item will be ignored.

Action:

Remove the item, or change its type to 'Custom' and add the appropriate application logic to maintain its value.


CGEN-03425

CGEN-03425 Unbound item type 'Server Function' not supported

Cause:

The unbound item type is 'Server side function', which is not supported by this generator in this release. The item will be ignored.

Action:

No action required.


CGEN-03426

CGEN-03426 Unbound item type 'Target Specific' not supported

Cause:

The unbound item type is 'Target specific', which is not supported by this generator. The item will be ignored.

Action:

No action required.


CGEN-03427

CGEN-03427 Unbound item type 'Custom' not supported

Cause:

The unbound item type is 'Custom', which is not supported by this generator. The item will be ignored.

Action:

No action required.


CGEN-03428

CGEN-03428 Unbound item type '%s' not supported

Cause:

The unbound item type is not supported by this generator. The item will be ignored.

Action:

Remove the item, or change its type to one that is supported and add the appropriate application logic to maintain its value. Refer to the help system for more information about supported unbound item types.


CGEN-03429

CGEN-03429 Missing base usage of foreign key column %s

Cause:

No base table usage was defined for base table column, although lookup control used in foreign key.

Action:

Add item to base table usage for the foreign key columns.


CGEN-03430

CGEN-03430 No aggregate function in derivation text '%s'

Cause:

The unbound item is typed as a SQL Aggregate, but the derivation text does not reference any SQL aggregate functions such as MAX, SUM, etc.

Action:

If the item is not required to aggregate the data over multiple rows, use a SQL Expression instead.


CGEN-03431

CGEN-03431 Item reference found in SQL Aggregate derivation text '%s'

Cause:

One of the column references in the derivation text of the SQL Aggregate item has a corresponding bound item within the module component. As bound items will participate in the resulting group by, this derivation text may not be correct.

Action:

No action required.


CGEN-03432

CGEN-03432 Long item in lookup incompatible with Oracle Objects for OLE

Cause:

OO4O v2 does not get the rowid (required when retrieving a long) when a complex SQL expression is used i.e. one involving column aliases, or joins across tables.

Action:

No action required.


CGEN-03433

CGEN-03433 Incorrect syntax for client function derivation text '%s'

Cause:

The unbound item is typed as a 'Client Function', but the associated derivation text is not in the expected syntax of 'function_name(parameters)'.

Action:

No action required.


CGEN-03434

CGEN-03434 Aggregate functions not allowed in SQL Expression

Cause:

An aggregate function has been entered in the SQL Expression.

Action:

Use a function from the drop down list in the Edit Unbound Item dialog


CGEN-03435

CGEN-03435 Incorrect syntax for server function derivation text '%s'

Cause:

The unbound item is typed as a 'Server Function', but the associated derivation text is not in the expected syntax of 'function_name(parameters)'.

Action:

No action required.


CGEN-03436

CGEN-03436 Detailed table usage has no linkage

Cause:

No link from the detailed table usage to the base table.

Action:

Create foreign key link to base table.


CGEN-03437

CGEN-03437 Incorrect syntax for computed item derivation text '%s'

Cause:

The unbound item is typed as 'Computed', but the associated derivation text is not in the expected syntax of 'function_name(item_name)'.

Action:

No action required.


CGEN-03438

CGEN-03438 Module '%s' has been marked as completed

Cause:

The given module has been marked as 'Completed' and should subsequently not be the subject of further generations.

Action:

No action required.


CGEN-03439

CGEN-03439 Failed to update repository element

Cause:

The most likely cause is that the element is already locked by another user.

Action:

No action required.


CGEN-03440

CGEN-03440 Tree walks on non-base table usages not supported

Cause:

Tree walks are only supported on base table usages

Action:

No action required


CGEN-03441

CGEN-03441 Check constraint '%s' has no condition text

Cause:

The given check constraint is defined in the Repository without any condition text.

Action:

Change the constraint definition in the Repository accordingly.


CGEN-03442

CGEN-03442 Constraint '%s' has no key columns

Cause:

The given constraint has no columns defined in it.

Action:

Add key columns to the constraint.


CGEN-03444

CGEN-03444 Inconsistency in mandatory values for foreign keys in arc '%s'

Cause:

A set of foreign keys have been defined as belonging in the same arc, and there is an inconsistency in the setting of the arc mandatory flag across these foreign keys.

Action:

Change the foreign key(s) so that the mandatory setting is the same for all keys in the arc.


CGEN-03445

CGEN-03445 Foreign Key Arc number '%s' contains mandatory foreign key

Cause:

The specified foreign key is defined as being both mandatory and in an arc. These conditions are mutually exclusive.

Action:

Either make the foreign key optional or remove it from the arc.


CGEN-03446

CGEN-03446 Optional constraint '%s' contains mandatory column

Cause:

You have specified that a unique or foreign key constraint is optional (i.e., may contain all null values), but there is a column within it which is mandatory (ie., cannot contain a null value).

Action:

Either, change the unique/foreign key constraint definition to mandatory, or ensure that all columns within the key can contain nulls.


CGEN-03447

CGEN-03447 Constraint '%s' contains a LONG/LONG RAW column

Cause:

A LONG RAW column has been used as part of the constraint. This is not supported.

Action:

Choose an alternative column for the key.


CGEN-03448

CGEN-03448 Name is not a valid Oracle name; try '%s'

Cause:

The name is not a valid Oracle name. An Oracle name can only include alphanumeric characters, plus underscore, dollar and hash (_ $ #). It also must not begin with a digit.

Action:

Amend the name in the Repository.


CGEN-03449

CGEN-03449 No usage flags set; defaulting to allow query/insert%s and delete

Cause:

The module component has no allowed usage flags set. The flags have been defaulted as stated.

Action:

No action required; The Generator will set the flags as indicated in the message text.


CGEN-03450

CGEN-03450 /update

Cause:

This is text used to construct other messages.

Action:


CGEN-03451

CGEN-03451 No usage flags set; defaulting to allow query

Cause:

The module component has no allowed usage flags set. The flags have been defaulted as stated.

Action:

No action required. The Generator will set the query flag.


CGEN-03452

CGEN-03452 All items in updateable Module Component are non-updateable

Cause:

A module component being generated has no updateable items, but the 'Update Allowed' flag is set on the component.

Action:

This warning is highlighting an area in the module design that does not seem correct. The Generator will unset the Update Allowed flag on the detailed table usage.


CGEN-03453

CGEN-03453 Component allows update; changed to also allow query

Cause:

The component has the Update allowed flag set, but not the Query allowed flag.

Action:

No action required. The Generator will set the Query flag.


CGEN-03454

CGEN-03454 Component allows delete; changed to also allow query

Cause:

The component has the Delete allowed flag set, but not the Query allowed flag.

Action:

No action required. The Generator will set the query flag.


CGEN-03455

CGEN-03455 Module component has no items

Cause:

The module component does not have any items.

Action:

Check and amend the module component as required in the Repository.


CGEN-03456

CGEN-03456 Missing change history item '%s'

Cause:

The change history item was missing from the base table usage and the generator could not add it.

Action:

Add the specified item to the base table usage.


CGEN-03457

CGEN-03457 Table '%s' is not of type Oracle

Cause:

The table being used in this module is not of the Oracle database type. This release of the Generator only supports Oracle as the target environment.

Action:

No action is required.


CGEN-03459

CGEN-03459 Missing mandatory item '%s'

Cause:

A mandatory item was missing from the module component; the generator could not add this item.

Action:

Add the mandatory item.


CGEN-03460

CGEN-03460 Validation specified for primary key column ignored

Cause:

The underlying column of this item is defined as both forming part of a Primary Key, and as being validated against a list of known values.

Action:

This warning is highlighting an area in the database design that does not seem correct. Generation of the current module is not affected. No action is required.


CGEN-03461

CGEN-03461 Validation specified for foreign key column; validation ignored

Cause:

The underlying column of this item is defined in the Repository both as being validated against a set of allowed values, and as forming part of a foreign key. In this situation the list of valid values is ignored.

Action:

Modify the column definition in the Repository to remove its allowed values.


CGEN-03462

CGEN-03462 Column datatype '%s' unsuitable for unique id generated column

Cause:

A LONG column datatype has been specified for a unique id generated column. This is not supported.

Action:

Choose a different data type for the unique id generated column.


CGEN-03463

CGEN-03463 Column datatype '%s' unsuitable for auto-generated column

Cause:

A LONG column datatype has been specified for an auto-generated column. This is not supported.

Action:

Choose a different data type for the auto-generated column.


CGEN-03464

CGEN-03464 Column datatype '%s' unsuitable for Order By

Cause:

This item is based on a LONG column datatype and has been specified in an Order By Sequence. This is not supported.

Action:

Choose an alternative column for the Order By Sequence.


CGEN-03466

CGEN-03466 Derived item made non-insertable

Cause:

This item is based on a column that has been defined as having its value derived, but the item has the Insert flag set. The item will be made non-insertable. The derivation criteria is defined via the following Column properties:

·AutoGenerate Type

·Sequence

·Server derived

·Denormalised

Action:

This warning is highlighting an area in the module design that does not correspond to information specified in the database design. The Generator has modified the module design accordingly; both in the context of the generation of this module, and also in the Repository.


CGEN-03467

CGEN-03467 Update flag unset; Column forms part of non-updateable constraint

Cause:

This item is based on a column that forms part of a non- updateable unique or primary key, but the item has the 'Update' flag set. The item will be changed to non-updateable.

Action:

No action required.


CGEN-03468

CGEN-03468 Update flag unset; Column forms part of non-transferable foreign key

Cause:

This item is based on a column that forms part of a non- transferable foreign key, but the item has the 'Update' flag set. The item will be changed to non-updateable.

Action:

No action required.


CGEN-03469

CGEN-03469 No valid values defined against column to display meaning, defaulting to use

Cause:

The column the data bound item is based on has no valid values defined or domain specified against it to allow the meaning to be displayed.

Action:

Specify valid values against the column the item is based on or specify a domain against the column. Or set the Repository property 'Show Meaning' to <Null>.


CGEN-03470

CGEN-03470 Update flag unset; Module component does not allow update

Cause:

The item has the update allowed flag set, but the module component it is within has the update allowed flag UNset.

Action:

No action required. The Generator will unset the Update allowed flag on the item.


CGEN-03471

CGEN-03471 Query flag unset; Module component does not allow query

Cause:

The item has the query allowed flag set, but the module component it is within has the query allowed flag UNset.

Action:

No action required. The Generator will unset the Query allowed flag on the item.


CGEN-03472

CGEN-03472 Insert flag unset; Module component does not allow insert

Cause:

The item has the insert allowed flag set, but the module component it is within has the insert allowed flag UNset.

Action:

No action is required. The Generator will unset the Insert allowed flag on the item.


CGEN-03473

CGEN-03473 Default value '%s' is not one of column's valid values

Cause:

The default value (specified in the item or against the column) is not one of the valid values defined for the column (either in a domain or against the column). The default value is ignored.

Action:

If the default value is valid, add it to the list of valid values. Otherwise, correct it.


CGEN-03474

CGEN-03474 Problem mapping navigation action item

Cause:

The destination of the navigation action item could not be found.

Action:

Check that the navigation action item is specified correctly.


CGEN-03475

CGEN-03475 Unbound item type 'Shared Data' not supported

Cause:

The unbound item type is 'Shared Data', which is not supported by this generator. The item will be ignored.

Action:

No action required.


CGEN-03476

CGEN-03476 Item Prompt is invalid - Split Prompt Marker removed

Cause:

It is not possible to generate with the arrangement of Post Prompt and Split Prompt markers in the item prompt.

Action:

No action required.


CGEN-03477

CGEN-03477 Base table usage required

Cause:

No base table usage was defined for the module component.

Action:

Add a base table usage.


CGEN-03478

CGEN-03478 Module status changed to 'In Progress'

Cause:

A module with status 'Not Started' was generated

Action:

No action required.


CGEN-03479

CGEN-03479 No Start With clause defined against Tree Walk table usage

Cause:

No Start With clause has been defined against Tree Walk table usage. Note that a Start With cause may still have been added to the generated SQL if a module argument item usage with an operator of type 'START WITH' exists.

Action:

Add a Start With clause to the Tree Walk table usage if required.


CGEN-03480

CGEN-03480 Derivation text '%s' for computed item must start with an aggregate function

Cause:

The unbound item is typed as 'Computed', but the associated derivation text is not in the expected syntax of 'function_name(item_name)' where function name is an aggregate function.

Action:

Check that the derivation text has the correct syntax


CGEN-03481

CGEN-03481 Source item in derivation text '%s' for computed item not found

Cause:

The source item for the derivation text must be in the same module component as the computed item or in a detail module component.

Action:

Check that the source item of the derivation text is in the same module component as the computed item or in a detail module component.


CGEN-03483

CGEN-03483 This module has been deleted by another user. Requery

Cause:

No further information available.

Action:


CGEN-03485

CGEN-03485 Inconsistent item datatypes or wrong number of items in query set

Cause:

Either the query set has a different number of items to the module component, or the items are of different types.

Action:

Ensure that the query set has the same number of items as the module component, and that each query set item has the same datatype as its corresponding item in the module component.


CGEN-03486

CGEN-03486 Stacked module component must have parent component in same window

Cause:

A module component has been defined as 'Stacked', but no parent module component could be found in the same window.

Action:

Ensure that both the master and the associated stacked detail zones are placed in the same window, and that a key-based link is defined between them.


CGEN-03488

CGEN-03488 Missing usage of primary key column '%s' added automatically

Cause:

The given column is defined in the table's primary key, and there is no item based on this column in the module definition. The generator has automatically created an item based on this column.

Action:


CGEN-03493

CGEN-03493 Domain or valid values on view column must be subset of those on table.

Cause:

A domain or list of valid values has been defined against a view column that includes valid values not allowed on the underlying table column.

Action:

No action required.


CGEN-03494

CGEN-03494 No join columns in foreign key link to detail

Cause:

The foreign key used for the key-based link to the detail has no join columns defined.

Action:

Specify the join columns for the foreign key


CGEN-03495

CGEN-03495 Library module '%s' not loaded - incompatible language

Cause:

The attached library module was not loaded since its language differs from that of the top level module, and it is not a common library.

Action:

No action required.


CGEN-03496

CGEN-03496 Invalid datatype specified for module argument

Cause:

An invalid datatype was specified for the module argument. The datatype must be numeric, date or character based.

Action:

Modify the module argument datatype.


CGEN-03601

CGEN-03601 File '%s'

Cause:

This message indicates the file and position at which the preceding error occurred.

Action:

Try to load the application into the Visual Basic designer to ensure that the file does not contain any corrupt information.


CGEN-03602

CGEN-03602 Unexpected end of file found when reading Visual Basic Form file.

Cause:

End of File found, but not expected during the load of a Visual Basic Form file.

Action:

The following error message will give the file name and location of the problem. Ensure that the given file can be loaded into the Visual Basic designer before attempting to use it again. If it does load into the Visual Basic designer without any errors being reported, contact your Customer Support Representative.


CGEN-03603

CGEN-03603 Missing OK/Cancel/Close buttons in template Property Sheet Dialog Form '%s'

Cause:

One of the OK/Cancel or Close buttons is missing from the form being used the template for a Property Sheet Dialog.

Action:

Add the missing button(s). Note that these buttons are identified via the Tag property values:

·CG_PSD_OK (OK button)

·CG_PSD_CANCEL (Cancel button)

·CG_PSD_CLOSE (Close button)


CGEN-03604

CGEN-03604 Missing ListBox control in template List style Zone '%s'

Cause:

The template zone for a LIST style zone must include a ListBox for displaying the set of records (tag CG_ZN_LIST). This template control is missing.

Action:

Add the required control to the template zone.


CGEN-03605

CGEN-03605 Missing OK/Cancel buttons in template Query Dialog Form '%s'

Cause:

One of the OK/Cancel buttons is missing from the form being used as the template for a Query Dialog.

Action:

Add the missing buttons. Note that these buttons are identified via the Tag property values:

·CG_QD_OK (OK button)

·CG_QD_CANCEL (Cancel button)


CGEN-03606

CGEN-03606 Missing ListBox/Status control(s) in template Form style Zone '%s'

Cause:

The template zone for a FORM style zone must include a ListBox for displaying multiple records (tag CG_ZN_LIST) and a label for displaying the record status (tag CG_REC_STATUS). One or both of these template controls are missing.

Action:

Add the required controls to the template zone.


CGEN-03608

CGEN-03608 No navigation control created for call to '%s'

Cause:

There is a module network link to the given module, but no control has been created to implement the link. The template form used as the basis of the first window should contain menu items as named by the TFMNMN and TFMNZC preferences. Menu items will then be generated against these menus to implement the module network links.

Action:

Add the appropriate menu items to the template form.


CGEN-03609

CGEN-03609 Failed to load template project '%s'

Cause:

The template project could not be loaded successfully. This message should be accompanied by another message indicating the cause of failure.

Action:

Examine the accompanying message to find out why the load failed.


CGEN-03610

CGEN-03610 Unsupported Tab control in template form '%s'

Cause:

The Tab control in the template project is not supported.

Action:

Use the template tab control that is shipped with the generator.


CGEN-03611

CGEN-03611 Failed to load merge project '%s'

Cause:

The accompanying error message will indicate why the file could not be loaded.

Action:

Resolve the error indicated by the previous message before trying to generate again.


CGEN-03612

CGEN-03612 Didn't generate the first module.

Cause:

The first module failed to generate for the reason(s) previously given. However, since the first module could not be generated, the project file was not created.

Action:

Make the necessary change to the first module to remove the situation that caused the error and then re-generate the module.


CGEN-03613

CGEN-03613 Did not generate the module.

Cause:

The module failed to generate for the reason(s) previously given. Therefore the project file was not created as well.

Action:

Make the necessary change to the first module to remove the situation that caused the error and then re-generate the module.


CGEN-03614

CGEN-03614 The project file '%s' has NOT been created.

Cause:

The project file for the generated application has not been created for the reasons given previously.

Action:

Correct the problems that have caused the errors, and re-run the generator.


CGEN-03615

CGEN-03615 Form '%s' has been saved using an older version of Visual Basic

Cause:

The Generator has tried to load the given form during the generation process. However, it was saved using a version of Visual Basic prior to Version 4.00.

Action:

Take the given form and upgrade it to Visual Basic Version 4.00 or 5.00. This can simply be done by loading it into the Visual Basic designer and re-saving the form.


CGEN-03616

CGEN-03616 File '%s' does not contain a Visual Basic form definition

Cause:

When loading a Visual Basic project, an attempt was made to load the associated Forms for the project. However, when loading the Form, it was found NOT to contain a Form definition. For some the project file has become corrupted.

Action:

The project file needs to be corrected before another attempt to use it is made. Therefore, try to load the Project into Visual Basic since it will perform any necessary actions in order to correct your corrupted project.


CGEN-03617

CGEN-03617 Unexpected data found during load of VB file

Cause:

An unexpected entry was found during the load of a VB file. This may possibly be due to a corrupt file.

Action:

Ensure that the file has been saved from VB in text format and that it can be loaded successfully into Visual Basic.


CGEN-03618

CGEN-03618 Expected '%s'

Cause:

No further information available.

Action:


CGEN-03619

CGEN-03619 Found '%s'

Cause:

No further information available.

Action:


CGEN-03620

CGEN-03620 Failed to find any suitable forms in project '%s'

Cause:

The Recover Application Logic Utility failed to find any suitable forms in the given project. This may be caused by the deletion of the forms generated from the module we are currently trying to recover.

Action:

No action required.


CGEN-03621

CGEN-03621 Failed to load project to capture: '%s'

Cause:

The given project could not be loaded. The accompanying error message will indicate why the file could not be loaded.

Action:

Resolve the error indicated by the previous message before trying to capture the project again.


CGEN-03622

CGEN-03622 Could not find definition for '%s'

Cause:

When recovering the Visual Basic application the control type definition was required to determine how to recovery the control. No entry for this control was found in the control definition file.

Action:

If the default settings are not appropriate, then a definition for the control type will need to be specified in the control definition file.


CGEN-03623

CGEN-03623 Cannot capture project '%s' since it has no Forms

Cause:

The given project did not contain any Visual Basic Forms. Since the design information that is capture into the Repository is derived from the details of a Form definition, the given project is unsuitable for capturing.

Action:

Either select a project which contains Forms that can be captured or supplement the given project with the Forms that are required to be captured.


CGEN-03701

CGEN-03701 Formatting '%s' not incorporated in generated application

Cause:

One or more items within a module component have the Formatting property defined. However, the formatting will not appear within the generated application for the following reasons:

·a View Form has not been generated because the module component is query-only, the Layout Style is List and all the column usages are marked 'Context'. Also, if the module component has any details, hyperlinks to the detail module component have been incorporated within the Record List using the Add Detail Hyperlinks to Record List preference (ZONLDL).

·the Apply HTML Formatting preference (ZONLHF) is set to No, indicating that any HTML formatting defined against items should not be applied in the Record List. Note: Setting the Display Type to 'IMAGE' is equivalent to setting the Formatting property to 'IMAGE'.

Action:

Depending on your requirements, do one of the following:

·To display HTML formatting in the Record List, set the ZONLHF preference to Yes.

·To display column usages with HTML formatting on a View Form, uncheck the 'Context' flag on one or more of the column usage(s).

·To remove unwanted HTML formatting, clear the Formatting property on the column usage(s).


CGEN-03702

CGEN-03702 No List of Values created on Query Form

Cause:

List Of Values are only supported in the Query form if the LOV Style preference is 'WINDOW', or if, in the case of a List/Form style module component, the Query form is not on its own page.

Action:

If you require List of Values in the Query Form, either modify the preference LOVSTL to 'WINDOW', or, if the module component is List/Form style, make sure the Query Form is not on its own page.


CGEN-03703

CGEN-03703 No template frameset file specified

Cause:

The Module Component is of List/Form Style, and the User Preference LFCUST indicates that a custom frameset is being used. However, the template file for the custom frameset has not been defined.

Action:

Specify a valid filename, including directory path, for the frameset template file.


CGEN-03704

CGEN-03704 Combination of Module Implementation Name and DTU Alias too long

Cause:

The module's Implementation Name and table usage Alias are combined (with a separating character $) to name generated packages. The maximum length of a package name is 30 characters and this has been exceeded. The package name is truncated to 30 characters. However, if the truncated name is not unique an error may occur when the generated PL/SQL packages are installed.

Action:

If the truncation causes a clash of package names, reduce the length of the Table Usage name and/or the module Implementation Name such that the generated package name does not exceed 30 characters. Then, generate the module again. Otherwise, no action is required. However, reducing the length of the Table Usage Name will prevent this warning from being issued in the future. Note: Remember, if the module Implementation Name is not defined the Short Name is used instead.


CGEN-03705

CGEN-03705 Null or invalid frame defined in user preference. Assuming %s

Cause:

A valid frame name has not been specified for the given user preference.

Action:

If the given default is not acceptable, enter the required frame name for the given preference via the Preferences Navigator.


CGEN-03707

CGEN-03707 Invalid syntax in User Help Text or Page Text for %s

Cause:

Text defined within User Help Text (Startup Page, About Page) or, Page Text (Query Form, Record List, View Form, Insert Form or Delete Form) may contain a PL/SQL function call with a syntax error. If an error is present, it will prevent successful installation of the generated application.

Action:

Check the syntax of the embedded PL/SQL function call and ensure that all the custom packages defined within the Package List Preference (PKGLST) are installed correctly. Then, generate the module again.


CGEN-03708

CGEN-03708 Invalid color value specified for preference '%s'.

Cause:

The color value specified for the given preference is not a valid value.

Action:

Enter a valid color value for the preference specified and generate the module again. Color values should be defined as XXYYZZ where:

·XX is a hexadecimal value from 00 to FF for the degree of the red color component

·YY for the green component

·ZZ for the blue component. For example, FFC000 (Yellow), 000080 (Dark Blue).


CGEN-03709

CGEN-03709 Unknown token '%s' in preference value ZONLBD

Cause:

The value specified for the Record List Button Display Order preference (ZONLBD) contains a token that is not recognized. Therefore, the custom Record List buttons set you have defined cannot be displayed correctly i.e. unrecognized tokens are ignored.

Action:

Modify the ZONLBD preference, ensuring that the value defined contains valid tokens separated by a full stop. Valid tokens are:

·P = Previous button

·F = First button

·N = Next button

·L = Last button

·R = Requery button

·C = Count button

·/ = newline

For example, P.F./.N.L


CGEN-03710

CGEN-03710 Invalid syntax in preference %s

Cause:

The preference specified was found to contain a PL/SQL function call with a syntax error. This error will prevent successful installation of the generated application.

Action:

Check the syntax of the PL/SQL function call within this preference and ensure that all the custom packages defined within the Package List Preference (PKGLST) are installed correctly. Then, generate the module again.


CGEN-03711

CGEN-03711 Cannot use Form style for this module component.

Cause:

The Layout Style for the module component has been defined as 'Form' but this style is only permitted when the module component is query-only. The module component is generated using the 'List' Layout Style instead.

Action:

If the module component should be query-only, uncheck the 'Insert' or 'Update' flags on all the items and generate the module again. Otherwise, no action is necessary as the 'List' Layout Style is used instead. However, to avoid this message being issued again change the Layout Style to 'List', or 'Frames' if preferred.


CGEN-03712

CGEN-03712 Client-side validation code not generated for Check Constraint '%s

Cause:

The check constraint contains one or more SQL commands that cannot be translated into JavaScript by WebServer Generator. As a result, the check constraint cannot be enforced on the client Browser using JavaScript. If the 'Validate In' property of the constraint is Server or Both, the check constraint will still be enforced on the server using generated Server API code. However, if the 'Validate In' property of the constraint is Client, the check constraint will not be enforced.

Action:

If the 'Validate In' property of the constraint is Both, no action required. However, to avoid this message being issued again change the 'Validate In' property of the check constraint to 'Server'. If the 'Validate In' property of the constraint is Client, change the 'Validate In' property of the check constraint to 'Server' and then run DDL Generator to add the constraint to the table. Then, re-run the Server API Generator to add the error message handling.


CGEN-03713

CGEN-03713 Cannot use this column as a hyperlink from the Record List

Cause:

This column usage is used in the Record List to navigate to a View Form, detail module component, or called module. However, the column usage also has a Formatting property that makes it an active link (e.g. MAILTO or URL).

Action:

If Formatting is not required in the Record List, set the Apply HTML Formatting preference (ZONLHF) to 'NO'. Alternatively, remove the column usage from the Record List by unchecking its 'Context' flag.


CGEN-03714

CGEN-03714 Client-side derivation code not generated %s

Cause:

The Derivation Expression contains one or more SQL commands that cannot be translated into JavaScript by WebServer Generator. As a result, JavaScript code cannot be used to calculate and display the derived value dynamically during data entry i.e. on the client Browser. However the Derivation Expression will be performed on the server each time the record is refreshed, using generated Server API code.

Action:

No action required.


CGEN-03715

CGEN-03715 Client-side derivation code not generated for Item with Formatting property

Cause:

The item has a 'Formatting' property defined, which can only be applied to read-only text. As a result, JavaScript code cannot be used to calculate and display the derived value dynamically i.e. on the client Browser. However, the Derivation Expression will be performed on the server each time the record is refreshed, using generated Server API code.

Action:

No action required.


CGEN-03716

CGEN-03716 Client-side derivation code not generated on the Insert Form

Cause:

One or more of the columns from which this item is derived do not appear as enterable fields on the Insert Form. As a result, JavaScript code cannot be used to calculate and display the derived value dynamically during data entry i.e. on the client Browser. However, the Derivation Expression will be performed on the server when the inserted record is refreshed, using generated Server API code.

Action:

For client-side validation to take place, ensure that items are created for all of the columns referenced within the Derivation Expression and that they all appear on the Insert Form i.e. marked 'Ins'. Then, generate the module again. Otherwise, no action required.


CGEN-03717

CGEN-03717 Client-side derivation code not generated on the View Form

Cause:

One or more of the columns from which this item is derived do not appear as enterable fields on the View Form. As a result, JavaScript code cannot be used to calculate and display the derived value dynamically during data entry i.e. on the client Browser. However, the Derivation Expression will be performed on the server when the record is refreshed, using generated Server API code.

Action:

For client-side validation to take place, ensure that items are created for all of the columns referenced within the Derivation Expression and that they are all modifiable on the View Form i.e. marked 'Upd'. Then, generate the module again. Otherwise, no action required.


CGEN-03718

CGEN-03718 No client-side code generated in the Insert Form for Check Constraint '%s'

Cause:

The check constraint contains one or more columns that do not appear as enterable fields on the Insert Form. As a result the check constraint cannot be enforced on the client Browser, using JavaScript. If the 'Validate In' property of the constraint is Server or Both, then the check constraint will still be enforced on the server, using generated Server API code. If, however, the 'Validate In' property of the constraint is Client, then the check constraint will not be enforced.

Action:

For the check constraint to be enforced on the client, ensure that items are created for all of the columns referenced within the check constraint and that they all appear on the Insert Form i.e. marked 'Ins'. Then, generate the module again. Alternatively, change the 'Validate In' property of the check constraint to 'Server', and then run DDL Generator to add the constraint to the table. Then re-run the Server API Generator to add the error message handling. Otherwise, no action required. However, to avoid this message being issued again change the 'Validate In' property of the check constraint from 'Both' to 'Server'.


CGEN-03719

CGEN-03719 No client-side code generated in the View Form for Check Constraint '%s'

Cause:

The check constraint contains one or more columns that do not appear as enterable field on the View Form. As a result the check constraint cannot be enforced on the client Browser, using JavaScript. If the 'Validate In' property of the constraint is Server or Both, then the check constraint will still be enforced on the server, using generated Server API code. If, however, the 'Validate In' property of the constraint is Client, then the check constraint will not be enforced.

Action:

For the check constraint to be enforced on the client, ensure that items are created for all of the columns referenced within the check constraint and that they all appear on the View Form i.e. marked 'Upd'. Then, generate the module again. Alternatively, change the 'Validate In' property of the check constraint to 'Server', and then run DDL Generator to add the constraint to the table. Then re-run the Server API Generator to add the error message handling. Otherwise, no action required. However, to avoid this message being issued again change the 'Validate In' property of the check constraint from 'Both' to 'Server'.


CGEN-03720

CGEN-03720 Format mask '%s' ignored on data entry control

Cause:

The format mask on this control cannot be used for data entry and so will be ignored. Note that the Roman Numeral format mask (RN) is not supported.

Action:

No action required.


CGEN-03722

CGEN-03722 Password missing from database user

Cause:

A database user has been specified in the Generator Options dialog but no password was supplied. The generator may require this password to log on to the database during generation.

Action:

Add the password to the dialog box after the user name (e.g. scott/tiger).


CGEN-03723

CGEN-03723 Cannot generate Matrix style module

Cause:

The module contains a module component with more than one master. This is not supported by WebServer Generator.

Action:

Redesign the module such that no module component has more than one master.


CGEN-03724

CGEN-03724 Suggestion Lists not supported

Cause:

The specified item has a list of allowed values which are marked as being a 'Suggestion List'. Suggested lists of values are not supported by WebServer Generator. The item is generated as an text box, with no suggested values.

Action:

No action required.


CGEN-03725

CGEN-03725 Invalid syntax in Formatting property: '%s'

Cause:

The Formatting property of the specified item contains an invalid PL/SQL function call.

Action:

Correct the syntax defined within the Formatting property and then generate the module again.


CGEN-03726

CGEN-03726 Implementation name '%s' not allowed

Cause:

The specified Implementation name is not allowed in order to prevent possible name clashes with Server API and Oracle Designer Repository Management packages.

Action:

Change the Implementation name.


CGEN-03727

CGEN-03727 JavaScript routine inappropriate at module level

Cause:

JavaScipt named routines at module level are not supported by the WebServer Generator.

Action:

Write the routine in PL-SQL.


CGEN-03728

CGEN-03728 Client-side Derivation code not generated for date/time columns

Cause:

One or more of the columns from which this item is derived, have a Date or Time Datatype that cannot be translated to JavaScript by WebServer Generator. As a result, the derivation expression cannot be performed using JavaScript on the client Browser. However the derivation expression will still be performed on the server each time the record is refreshed, using generated Server API code.

Action:

No action required.


CGEN-03729

CGEN-03729 No client-side code generated for date/time columns in Check Constraint '%s'

Cause:

One or more of the columns in the check constraint have a Date or Time Datatype that cannot be translated to JavaScript by WebServer Generator. As a result, the check constraint cannot be enforced using JavaScript on the client Browser. If the 'Validate In' property of the constraint is Server or Both, the check constraint will still be enforced on the server using generated Server API code. However, if the 'Validate In' property of the constraint is Client, the check constraint will not be enforced.

Action:

If the 'Validate In' property of the constraint is Both, no action required. However, to avoid this message being issued again change the 'Validate In' property of the check constraint to 'Server'. If the 'Validate In' property of the constraint is Client, change the 'Validate In' property to 'Server' and then run the DDL Generator to add the constraint to the table. Then re-run the Server API Generator to add the error message handling.


CGEN-03730

CGEN-03730 Named Routines are inappropriate at item level

Cause:

The routine can be written in JavaScript or PLSQL at module component level

Action:

The named routine can be written in either PLSQL or JavaScript at Module Component level.


CGEN-03731

CGEN-03731 Formatting '%s' not applied to data entry control(s)

Cause:

The Formatting property has been defined for an item which allows insert and/or update operations. Additional HTML formatting can only be applied to read-only text fields and therefore this property is ignored when the associated form element is generated.

Action:

No action required.


CGEN-03732

CGEN-03732 Server API package for table '%s' not installed

Cause:

This module component requires the specified Server API package in order to perform Database Manipulation on the base table. Installation will fail as it cannot be found.

Action:

First, check the Install User defined on the Options Tab of the Generate WebServer dialog is correct. Then, generate and install the Server API packages for the tables associated with this module component. Finally, re-install the generated WebServer package(s).


CGEN-03733

CGEN-03733 Called module '%s' not installed

Cause:

This module component has a hyperlink to a module and the number of rows returned from that module is being displayed within the hyperlink (controlled by the preference ZONLRL). However, the called module has not been generated or installed yet, hence the installation of the current module will fail.

Action:

Generate and install the called module. Alternatively, generate the current module with the 'Include the Module Network' check box set.


CGEN-03801

CGEN-03801 The keyword '%s' contains a semicolon, so will be treated as two keywords.

Cause:

The keyword specified contains a semicolon, this is an invalid keyword character. The keyword will be split at the point of the semicolon, resulting in two keywords.

Action:

Remove the semicolon from the keyword. Place each new keyword on a separate line. Generate the Help again.


CGEN-03802

CGEN-03802 No prompt defined for group '%s' - name used instead for jump text

Cause:

A 'prompt' property is not defined for this Item Group. This property is normally used to derive the topic title and jump text for the group, if omitted (and required for a jump), the item group's 'name' property is used instead.

Action:

Enter an appropriate 'prompt' for the specified group and then generate the Help again.


CGEN-03803

CGEN-03803 Invalid Context ID Prefix for '%s'.

Cause:

The Context ID Prefix for this element is either missing or an invalid number. Context IDs cannot be generated for this element or saved back to the Repository for inclusion within the generated application.

Action:

To provide context sensitive Help, enter a valid Context ID Prefix for the element and then generate the Help again. This value must be greater than zero and unique within the application system.


CGEN-03804

CGEN-03804 No Help File Name defined for module, temporary name has been assigned: '%s'

Cause:

The module selected for generation has an undefined Help File Name property. A temporary Help file is created with the name: t_<implementation name>.hlp

Action:

If you chose to generate a Help file for testing purposes, no action is required. Review the temporary file, checking for errors and omissions. When you are ready to generate the final Help file ensure you select the 'top-level module' where the Help File Name property is defined. However if the module selected for generation should be a top-level module, enter a valid Help File Name property for the module and then generate again.


CGEN-03805

CGEN-03805 No title defined; name used instead for jump text

Cause:

A title has not been defined for this component This property is normally used to derive any title or jump text for the component; if omitted, the component name is used instead.

Action:

Enter an appropriate title for the component and then generate the Help again.


CGEN-03806

CGEN-03806 No prompt defined for item '%s' - name used instead for jump text

Cause:

A prompt is not defined for the item. This property is normally used to derive the jump text for the item, if omitted, the item's name property is used instead.

Action:

Enter an appropriate prompt for the specified item, where required and then generate the Help again. If the property was omitted intentionally, remove any Help text assigned to this column usage and set the Display Empty item Descriptions preference (DCUCAP) to hide the substitute name property. Generate the Help again.


CGEN-03808

CGEN-03808 Help text defined against item '%s' but its display flag is set to false.

Cause:

The specified item will not be displayed in the generated application because its display flag is set to false. No help will be generated for this item, even though there is help text defined against it.

Action:

Either remove the help text from the item or set its display flag to true.


CGEN-03812

CGEN-03812 Given project name contains invalid characters

Cause:

The specified project name contains illegal characters, such as \ or %.

Action:

Remove these illegal characters and try again.


CGEN-03813

CGEN-03813 Duplicate context id suffixes have been reallocated.

Cause:

Duplicate context id suffixes were found. This is due to previously generated items being copied across modules components. Any duplicate suffix values are reallocated, which means that for the context sensitivity to work, the client application will need to be generated again.

Action:

Generate the Client Application again.


CGEN-03814

CGEN-03814 Help Text with no caption will appear directly under previous topic item

Cause:

A 'prompt' property was not defined for this topic item. The Help text will therefore appear directly under the previous topic item.

Action:

Enter an appropriate 'prompt' for the specified topic item and then generate the Help again.


CGEN-03815

CGEN-03815 Could not allocate ID suffix.

Cause:

Too many help items have been defined.

Action:

Remove some help items.

/

/ 03901 .. 04000 Generic Design Recovery Error/Warnings

/


CGEN-03901

CGEN-03901 Table definition '%s' not found in repository

Cause:

Design capture of applications requires that the definitions of underlying tables, columns and constraints have been entered (or recovered) in the current application system. The table definition indicated is not defined in the Repository.

Action:

Enter definitions of the appropriate tables, columns and constraints.


CGEN-03902

CGEN-03902 Column Definition for '%s' not found in repository

Cause:

Design capture of applications requires that the definitions of underlying tables, columns and constraints have been entered (or captured) in the current application system. The column definition indicated is not defined in the Repository.

Action:

Enter the definition of this column.


CGEN-03903

CGEN-03903 Foreign key constraint to link lookup table '%s' not found in repository

Cause:

Design capture of applications requires that the definitions of underlying tables, columns and foreign key constraints have been entered (or captured) in the current application system. A foreign key, required to link to the given lookup table, has not been defined in the Repository.

Action:

Enter the definition of this foreign key.


CGEN-03904

CGEN-03904 Sequence '%s' not found in repository

Cause:

Design capture of applications requires that the definitions of underlying tables, columns and sequences have been entered (or captured) in the current application system. The sequence definition indicated is not defined in the Repository.

Action:

Enter the definition of this sequence.


CGEN-03905

CGEN-03905 Length of '%s' exceeds the maximum column length

Cause:

The maximum value length allowed for this column by the application being recovered exceeds the maximum column length defined against the column definition in the Repository.

Action:

No action required.


CGEN-03906

CGEN-03906 Column '%s' must be in uppercase

Cause:

The uppercase property held on the column definition, differs from the captured controls uppercase property

Action:

No action required.


CGEN-03907

CGEN-03907 Constraint not found in repository to link table '%s'

Cause:

Design capture of applications requires that the definitions of underlying tables, columns and foreign key constraints have been entered (or captured) in the current application system. A relationship has been found in the application being captured, but no foreign or primary key constraint to represent the relationship can be found in the repository.

Action:

The relationship has been ignored. If you want to capture the application with the correct relationships you should define or capture these into the repository before attempting to capture the application.


CGEN-03908

CGEN-03908 No modules captured from this application

Cause:

No items to capture found in this application. This may be due to incorrect settings in the control/ object definition file

Action:

Review the settings in the control/object definition file and access their applicability to the application in question.


CGEN-03909

CGEN-03909 Captured Table Usage %s is derived from module with Journal Preference set.

Cause:

The Capture tool has captured a table usage generated out by a module with Journaling preferences set. It is presently not possible to set preferences against a module.

Action:

Set the Journal Preferences against this module.


CGEN-03910

CGEN-03910 Creating design objects for application

Cause:

No further information available.

Action:


CGEN-03912

CGEN-03912 Unable to write %s to repository: element is locked by another user

Cause:

An attempt was made to lock the element in order to modify it. The attempt failed because the element was already locked by another user.

Action:

Ensure that no other user has the element locked and retry.


CGEN-03916

CGEN-03916 Allowed value '%s' not in list defined in the repository

Cause:

A list of allowed values against this control being captured has been found in the Repository, but the underlying column does not have the specified value as one of it's allowed values or domain values.

Action:

Check the column definition has the desired values


CGEN-03917

CGEN-03917 No allowed values defined in repository for this column

Cause:

A list of allowed values against this control has been detected during design capture. However, the underlying column does not have any allowed values or domains associated with it.

Action:

No action required.


CGEN-03918

CGEN-03918 Range on control has different values from the range in the repository

Cause:

A range has been detected against the control being captured. The High, Low or both values do not match the values of the range as defined against the underlying column in the Repository

Action:

Check the column definition in the Repository for the controls underlying column


CGEN-04000

CGEN-04000 PLL destination not in search path. PLLs may not load from this destination.

Cause:

The PLL destination specified in the Library Generator Options dialog is not contained in any of the search path registry variables that apply to the language of the library module to generate. This may mean that the appropriate Oracle Developer builder and runtime applications will not be able to locate the generated PLL files if they are attached to any other Oracle Developer modules.

Action:

Consult the help file to determine the names of the search path registry variables that apply to the language of the library module to be generated. Add the PLL destination specified in the Library Generator Options dialog to the path in one of these variables.


CGEN-04001

CGEN-04001 Failed to write library '%s'

Cause:

The generator failed to write the library file to the file system.

Action:

Make sure:

·the specified directory exists

·the current user has access to the directory If the library file already exists, make sure the file is writable.


CGEN-04002

CGEN-04002 Cannot access .PLD destination directory '%s'

Cause:

The directory specified for the destination of .PLD files either does not exist or this user does not have access to it.

Action:

Check the directory exists and this user has access to it.


CGEN-04003

CGEN-04003 Cannot access .PLL destination directory '%s'

Cause:

The directory specified for the destination of .PLL files either does not exist or this user does not have access to it.

Action:

Check the directory exists and this user has access to it.


CGEN-04004

CGEN-04004 Cannot access .PLX destination directory '%s'

Cause:

The directory specified for the destination of .PLX files either does not exist or this user does not have access to it.

Action:

Check the directory exists and this user has access to it.


CGEN-04005

CGEN-04005 Library '%s' is file-based and cannot be generated

Cause:

Because the source path property of this module is set. Library Generator assumes that it is defined by an Oracle Developer library that already exists on the filesystem, so it need not be generated.

Action:

If this module contains named routines and you want to be able to generate an Oracle Developer library from it, make sure the Source Path property is empty.


CGEN-04006

CGEN-04006 Attached library '%s' is file-based and will not be generated

Cause:

Because the source path property of this module is set. Library Generator assumes that it is defined by an Oracle Developer library that already exists on the filesystem, so it need not be generated.

Action:

If this module contains named routines and you want to be able to generate an Oracle Developer library from it, make sure the Source Path property is empty.


CGEN-04007

CGEN-04007 Assuming value \"%s\" for option '%s'

Cause:

The registry key for an option set in the Library Generator Options dialog could not be found. The generator has had to assume a default value for this option.

Action:

Set the options in the Library Generator Options dialog.


CGEN-04100

CGEN-04100 Cannot read source file '%s'

Cause:

The source file given to the recovery tool either does not exist, or you do not have permission to access the file.

Action:

Check the filename given is correct and that you have permission to access it.


CGEN-04101

CGEN-04101 Cannot find library '%s'

Cause:

The source filename given cannot be found on the filesystem.

Action:

Check the location of the file is valid and that you have read access to the file.


CGEN-04102

CGEN-04102 File '%s' is not an Oracle Developer library source file

Cause:

The file is not recognized as an Oracle Developer library source file. The file must have an extension of .pld for a text file or .pll for a binary file.

Action:

Check the filename extension for the correct type.


CGEN-04103

CGEN-04103 Repository short name differs from Oracle Developer library name (%s)

Cause:

The library module short name is different from the name of the library in the source file. When updating library application logic the name of the library in the source file must be the same as the module name you have updated.

Action:

If you intended to capture the library onto a new module, choose the Utilities->Capture Design Of...->Library menu option. If you intended to update the logic of an existing library module, check the name of the library chosen as the source file.


CGEN-04104

CGEN-04104 Cannot find library '%s' in search path '%s'

Cause:

The source file name for the library does not contain a full path so the capture tool is looking for the file in the search path, and has failed to find it.

Action:

Consult the documentation to find out how the search path is built. Then check the values of the registry variables mentioned in the documentation.


CWB-20001

CWB-20001, 00000, "start : start notification listener

Cause:

Control program usage message.

Action:

None.


CWB-20002

CWB-20002, 00000, "stop : stop notification listener

Cause:

Control program usage message.

Action:

None.


CWB-20003

CWB-20003, 00000, "status [<index>/<user_name>/<host_name>/<class_name>] : - get the status of notification listener

Cause:

Control program usage message.

Action:

None.


CWB-20004

CWB-20004, 00000, "kill [*/<index>/<user_name>/<host_name>/<class_name>] : - disconnet all connections or a specific set of connections

Cause:

Control program usage message.

Action:

None.


CWB-20005

CWB-20005, 00000, "kill_failed : terminate all connections which are failing to respond

Cause:

Control program usage message.

Action:

None.


RME-02114

RME-02114 Multiple 'into' variables defined at position %0!s

Cause:

Internal software problem. An attempt was made to define multiple INTO variables, by position, and more than one has the same name.

Action:

Contact Oracle Designer support.


RME-00009

RME-00009 Invalid %0!s reference (%1!s)

Cause:

Internal software error. This generally indicates that one of the following:

·an element ID has been allocated and used before the referenced element has been inserted

·an element was deleted and delete secondary updates didn't properly cascade

Both cases indicate a software problem.

Action:

Contact Oracle Designer support


RME-00010

RME-00010 The element %0!s of type = %1!s is locked by another session

Cause:

Another user has a Repository element locked. This generally indicates that another user is editing an element that needs to be updated indirectly as a result of the current action (i.e. as a 'secondary update'.)

Action:

Cancel and try again. If that fails, try again later.


ATT-05501

ATT-05501 Unable to set RM Connection

Cause:

A connection could not be made to the Repository.

Action:

Contact Customer Support.


RME-00101

RME-00101 Unknown RM data type %0!s

Cause:

Internal software problem. An invalid property or parameter datatype was passed to the CRMParameter or CRMProperty classes.

Action:

Contact Oracle Designer support.


RME-00102

RME-00102 Unknown RM passing direction %0!s

Cause:

Internal software problem. An invalid passing direction was passed to the CRMParameter or CRMProperty classes.

Action:

Contact Oracle Designer support.


RME-00103

RME-00103 Property name too long (%0!s specified, %1!s maximum)

Cause:

Internal software problem. The specified property name is too long.

Action:

Contact Oracle Designer support.


RME-00104

RME-00104 Property name is missing

Cause:

Internal software problem. A property's name was not specified where required.

Action:

Contact Oracle Designer support.


RME-00105

RME-00105 Invalid maximum storage length %0!s for Repository data type %1!s

Cause:

Internal software problem. The specified data storage size is invalid (e.g. varchar2(-20))

Action:

Contact Oracle Designer support.


RME-00106

RME-00106 NULL property list specified

Cause:

Internal software problem. An operation was requested with an empty property list.

Action:

Contact Oracle Designer support.


RME-00107

RME-00107 Property values cannot be property lists

Cause:

Internal software problem. Properties in a property list can only have scalar values (structured value was specified).

Action:

Contact Oracle Designer support.


RME-00108

RME-00108 Property %0!s not found (must be between 1 and %1!s)

Cause:

Internal software problem. An invalid property index within a property list was specified.

Action:

Contact Oracle Designer support.


RME-00109

RME-00109 Property '%0!s' not found in property list

Cause:

Internal software problem. A named property was not found in a property list.

Action:

Contact Oracle Designer support.


RME-00110

RME-00110 Invalid parameter/property conversion requested

Cause:

Internal software problem. The requested parameter/property datatype conversion is not supported.

Action:

Contact Oracle Designer support.


RME-00111

RME-00111 Parameter %0!s not found (must be between 1 and %1!s)

Cause:

Internal software problem. An invalid parameter index within a parameter list was specified.

Action:

Contact Oracle Designer support.


RME-00120

RME-00120 Failed to define parameter

Cause:

Internal software problem. A parameter definition request failed.

Action:

Examine other reported errors for specific details.


RME-00121

RME-00121 Failed to define property

Cause:

Internal software problem. A property definition request failed.

Action:

Examine other reported errors for specific details.


RME-00201

RME-00201 Already connected to a Repository

Cause:

Internal software problem. A connection request was refused because the CRMConnection is already connected.

Action:

Contact Oracle Designer support.


RME-00202

RME-00202 Not connected to a Repository

Cause:

Repository request denied because no Repository connection has yet been established.

Action:

Connect to a Repository and re-issue the request.


RME-00203

RME-00203 Missing product code

Cause:

Internal software problem. An operation was requested without specifying the product code (RM, CI).

Action:

Contact Oracle Designer support.


RME-00204

RME-00204 Missing element type name

Cause:

Internal software problem. An operation was requested without specifying the element type name.

Action:

Contact Oracle Designer support.


RME-00205

RME-00205 Missing operation name

Cause:

Internal software problem. An operation was requested without specifying the operation name.

Action:

Contact Oracle Designer support.


RME-00206

RME-00206 Missing parameter list

Cause:

Internal software problem. An operation was requested without specifying the operation's parameter list.

Action:

Contact Oracle Designer support.


RME-00223

RME-00223 Failed to open new activity

Cause:

Could not open a new activity because of other errors.

Action:

Examine other reported errors for specific details.


RME-00224

RME-00224 Failed to close activity

Cause:

Could not close ('commit') an activity.

Action:

Examine other reported errors for specific details.


RME-00225

RME-00225 Failed to abort activity

Cause:

Could not rollback an open activity

Action:

Examine other reported errors for specific details.


RME-00226

RME-00226 Failed to validate activity

Cause:

Data validation failed.

Action:

Examine other reported errors for specific details.


RME-00227

RME-00227 Failed to abort all open activities (activity %0!s of %1!s)

Cause:

Failed to rollback all open activities.

Action:

Examine other reported errors for specific details.


RME-00301

RME-00301 No text found for element %0!s text type '%1!s'

Cause:

Expected text not found for the given element.

Action:

Examine other reported errors for specific details.


RME-00302

RME-00302 Text size %0!s is too big (%1!s maximum bytes)

Cause:

Multi-line text is too big to read or write. This error should only occur on platforms (such as MS-Windows) where a limit is imposed on the size of contiguous memory allocation (generally 64k)

Action:

Reduce size of multi-line text and try again. If the error occurred when READING the text, contact Oracle Designer support.


RME-00303

RME-00303 Invalid text type '%0!s' specified

Cause:

A multi-line text type was specified that is not supported by the element type. If this occurs it tends to suggest an internal software problem.

Action:

Examine other reported errors for specific details and contact Oracle Designer support if you cannot solve the problem yourself.


RME-00501

RME-00501 Element with ID %0!s not found in cache

Cause:

Internal software problem. One part of the element caching code said that the element was there but another part of the code couldn't find it!

Action:

Contact Oracle Designer support.


RME-00502

RME-00502 '%0!s' named '%1!s' not found in cache

Cause:

Internal software problem. A named element could not be found in the cache.

Action:

Contact Oracle Designer support.


RME-00503

RME-00503 Failed to pre-load element type '%0!s' into the cache

Cause:

Error occurred when trying to load an element type's definition into the client-side cache.

Action:

Contact Oracle Designer support.


RME-00504

RME-00504 Failed to lock '%0!s' with ID '%1!s'

Cause:

Element lock request failed.

Action:

Examine other reported errors for specific details.


RME-00505

RME-00505 Failed to load text types from Repository

Cause:

An error occurred trying to load the Repository text types into the client-side cache.

Action:

Examine other reported errors for specific details.


RME-00506

RME-00506 Failed to find text type '%0!s' in cache

Cause:

Internal software problem. A text type was used that is not defined in the Repository and, hence, was not found in the client-side cache.

Action:

Contact Oracle Designer support.


RME-00507

RME-00507 Failed to load text types for element type '%0!s'

Cause:

An error occurred trying to load the multi-line text types supported by the indicated element type into the client-side cache.

Action:

Examine other reported errors for specific details.


RME-00508

RME-00508 Failed to get text types for element type '%0!s'

Cause:

An error occurred trying to find the multi-line text types supported for an element type.

Action:

Examine other reported errors for specific details.


RME-00511

RME-00511 Operation not implemented for this element type

Cause:

Internal software problem. A request was made to perform an unsupported operation on an element.

Action:

Contact Oracle Designer support.


RME-00512

RME-00512 Cache load by ID %0!s failed

Cause:

An error occurred trying to load an element into the client-side element type cache.

Action:

Examine other reported errors for specific details.


RME-00513

RME-00513 Cache load by NAME '%0!s' failed

Cause:

An error occurred trying to load an element into the client-side element type cache.

Action:

Examine other reported errors for specific details.


RME-00514

RME-00514 Element does not exist

Cause:

Internal software error. An attempt was made to load a non-existent element into the client-side element type cache. This can be caused by improperly installed Repository table data.

Action:

Contact Oracle Designer support.


RME-00521

RME-00521 String property '%0!s' does not exist

Cause:

An attempt to load a property value into the client-side element type cache has failed. This can be caused by improperly installed Repository table data.

Action:

Contact Oracle Designer support.


RME-00522

RME-00522 Reference property '%0!s' does not exist

Cause:

An attempt to load a property value into the client-side element type cache has failed. This can be caused by improperly installed Repository table data.

Action:

Contact Oracle Designer support.


RME-00523

RME-00523 Number property '%0!s' does not exist

Cause:

An attempt to load a property value into the client-side element type cache has failed. This can be caused by improperly installed Repository table data.

Action:

Contact Oracle Designer support.


RME-00531

RME-00531 Lock failed: Element does not exist

Cause:

An attempt was made to lock an element that was deleted by another user.

Action:

Cancel and retry operation.


RME-00532

RME-00532 Lock failed: Another user has locked this element

Cause:

An attempt was made to lock an element that another user has already locked.

Action:

Cancel and retry. If that fails wait until the other user has released the lock.


RME-00533

RME-00533 Lock failed: Another user has modified the element

Cause:

An attempt was made to lock an element that another user has changed. This is generally caused by another user changing the element between the time a dialog was entered and the first modification you requested.

Action:

Cancel and retry. This will reload the changed data.


RME-00534

RME-00534 Lock failed: More than one element with the same ID

Cause:

Internal software problem. More than one element in the Repository has the same ID.

Action:

Contact Oracle Designer support.


RME-00541

RME-00541 Text type '%0!s' is not defined

Cause:

Internal software problem. The requested text type is not supported by the Repository.

Action:

Contact Oracle Designer support.


RME-00542

RME-00542 Failed to lock '%0!s' with ID '%1!s' and Name '%2!s'

Cause:

Element lock request failed.

Action:

Examine other reported errors for specific details.


RME-00803

RME-00803 Open transaction(s) exist

Cause:

An attempt was made to close/abort an activity which has opened sub-activities. This should only occur if the API is being used by third party applications.

Action:

Fix the third party application code (if using third party code). If you are not using Oracle code only, contact Oracle Designer support.


RME-00851

RME-00851 No current activity

Cause:

A request was made to perform an operation without having first established an open activity. This should only occur if the API is being used by third party applications.

Action:

Fix the third party application code (if using third party code.) If you are not using Oracle code only, contact Oracle Designer support.


RME-00852

RME-00852 Activity %0!s is not the current activity (current activity is %1!s)

Cause:

A request was made to close/abort an activity that is not the current activity. This should only occur if the API is being used by third party applications.

Action:

Fix the third party application code (if using third party code). If you are not using Oracle code only, contact Oracle Designer support.


RME-00853

RME-00853 Activity rollback detection failed (operation=%0!s, status=%1!s)

Cause:

The activity rollback/commit detection code in the API has determined that someone, using the same connection, has quite wrongly performed a commit or rollback without using the proper activity abort/close API calls. This should only occur if the API is being used by third party applications.

Action:

Fix the third party application code (if using third party code). If you are not using Oracle code only, contact Oracle Designer support.


RME-00854

RME-00854 Activity package initialisation failed

Cause:

Internal software error. An error occurred while the API activity package was first invoked.

Action:

Contact Oracle Designer support.


RME-01301

RME-01301 Element %0!s property '%1!s' must not be NULL

Cause:

The indicated element property must not be NULL.

Action:

Change the property to contain a non-NULL value.


RME-01302

RME-01302 Invalid value for element %0!s property '%1!s'

Cause:

The indicated element property has been set to an invalid value. This generally occurs as a result of putting a value in a property that is not in the property's list of valid values.

Action:

Put a valid value in the property.


RME-01303

RME-01303 Expression constraint violation for element type '%0!s'

Cause:

A combination of property values does not pass the internal Repository integrity checks.

Action:

Fix the values or contact Oracle Designer support.


RME-01304

RME-01304 Arc %0!s violation for element type '%1!s'

Cause:

More than one foreign key value in an exclusive set of foreign keys has been specified. This should not normally occur.

Action:

If you are using third party software to populate the API data contact the supplier of the software. If you are using exclusively Oracle products contact Oracle Designer support.


RME-01305

RME-01305 UID %1!s violation for element type '%0!s'

Cause:

Uniqueness constraint rules have been violated.

Action:

Change the data you entered so that the constraint is not violated.


RME-01306

RME-01306 Element %0!s references a non-existent element

Cause:

Internal software problem. This indicates that referential integrity rules have been violated. This should only occur if the API is being used by third party applications.

Action:

Fix the third party application code (if using third party code.) If you are not using Oracle code only, contact Oracle Designer support.


RME-01401

RME-01401 Operation request '%0!sO%1!s.%2!s failed: Outstanding constraint violations

Cause:

The requested operation has failed because of another error.

Action:

Examine the reported errors for specific details.


RME-01501

RME-01501 Invalid multiline text handle %0!s was found

Cause:

Internal software problem.

Action:

Contact Oracle Designer support.


RME-01502

RME-01502 Invalid open mode '%0!s' requested for text type '%1!s'

Cause:

Internal software problem.

Action:

Contact Oracle Designer support.


RME-01503

RME-01503 Operation not allowed when text has been opened with mode '%0!s'

Cause:

Internal software problem.

Action:

Contact Oracle Designer support.


RME-01504

RME-01504 Text buffer is too small for the text to be read

Cause:

Internal software problem.

Action:

Contact Oracle Designer support.


RME-01505

RME-01505 Invalid text type '%0!s' specified

Cause:

Internal software problem.

Action:

Contact Oracle Designer support.


RME-02001

RME-02001 Out of memory allocating %0!s bytes

Cause:

Insufficient memory.

Action:

Exit now. Try again. If you have the same problem, you probably need more memory (virtual or physical) in your machine.


RME-02002

RME-02002 Connect string too long (%0!s bytes maximum)

Cause:

The specified database connect string was too long.

Action:

Use a shorter connect string. If you did not enter a connect string directly then contact Oracle Designer support.


RME-02003

RME-02003 User name in connect string is too long (%0!s bytes maximum)

Cause:

The indicated user name is too long (database limitation).

Action:

Specify a shorter (and correct) user name.


RME-02004

RME-02004 Password in connect string is too long (%0!s bytes maximum)

Cause:

The indicated password is too long (database limitation).

Action:

Specify a shorter (and correct) password.


RME-02005

RME-02005 Host name in connect string is too long (%0!s bytes maximum)

Cause:

The indicated host name is too long.

Action:

Try specifying a shorter host name. If you cannot then contact Oracle Designer support.


RME-02008

RME-02008 Missing host name in connect string

Cause:

You did not specify a host to connect to and no default host is available.

Action:

Specify the host. (You need to specify a host to identify 'where' you are connecting.)


RME-02009

RME-02009 Host '%0!s' is version %1!s.%2!s.%3!s (must be 7 or above)

Cause:

The specified database cannot support Designer/2000 because the database is not version compatible.

Action:

Specify a compatible database or, more unlikely, upgrade your database.


RME-02010

RME-02010 Unknown Oracle error (%0!s) received from upi call

Cause:

An unknown and unhandled Oracle error received from low level database connection software. This generally tends to indicate that Oracle is not properly installed or you have a hardware/software problem with your machine.

Action:

Contact Oracle Designer support.


RME-02011

RME-02011 Cannot connect - Already connected!

Cause:

Internal software problem.

Action:

Exit Designer/2000 and try again. If you can reproduce the problem then contact Oracle Designer support.


RME-02012

RME-02012 Not connected to a database

Cause:

You attempted to perform an operation that requires a database connection. If you were connected and didn't request to be disconnected it is possible that the database connection was lost. In this case it is possible that:

·the database was shutdown

·an internal database problem has occurred

·you have a software or hardware configuration problem.

Action:

Connect to a database. If you cannot, contact your systems administrator. If you cannot solve the problem contact Oracle Designer support.


RME-02013

RME-02013 Commit/rollback has been disabled on this database connection

Cause:

You are using a 'read only' connection and attempted to commit or rollback changes to the database.

Action:

Use a 'read/write' connection.


RME-02014

RME-02014 Database connection lost

Cause:

Your established connection to the database was lost. It is possible that one of the following has happened:

·the database was shutdown

·an internal database problem has occurred

·you have a software or hardware configuration problem.

Action:

Contact your systems administrator. If you cannot solve the problem contact Oracle Designer support.


RME-02020

RME-02020 Failed to connect to Oracle database

Cause:

A error occurred while attempting to connect to an Oracle database.

Action:

Examine reported errors for specific details.


RME-02021

RME-02021 Failed to disconnect from Oracle database

Cause:

A error occurred while attempting to connect to an Oracle database.

Action:

Examine reported errors for specific details.


RME-02022

RME-02022 Failed to commit

Cause:

A error occurred attempting to commit data to the database.

Action:

Examine reported errors for specific details.


CDI-18002

CDI-18002 Invalid cluster column datatype: %1.%2 differs from %3.%4

Cause:

Column cannot be added to cluster as there is a datatype mismatch

Action:

Check cluster column definitions


RME-02101

RME-02101 Cursor is not open

Cause:

Internal software problem. An attempt was made to use a cursor that was not open.

Action:

Contact Oracle Designer support.


RME-02102

RME-02102 Not connected to a database

Cause:

Internal software problem. An attempt was made to use a cursor without associating it with a connection.

Action:

Contact Oracle Designer support.


RME-02104

RME-02104 No database connect string specified

Cause:

Internal software problem. An attempt was made to connect a cursor without specifying a connect string.

Action:

Contact Oracle Designer support.


RME-02105

RME-02105 Oracle error occurred...
%0!s

Cause:

An unhandled Oracle error has occurred.

Action:

Examine reported errors for specific details.


RME-02106

RME-02106 Cannot execute because 'select' AND 'into' variables are defined

Cause:

Internal software problem. An attempt was made to execute a cursor with both SELECT and INTO variables specified.

Action:

Contact Oracle Designer support.


RME-02107

RME-02107 Cannot fetch without 'select' variables defined

Cause:

Internal software problem. An attempt was made to fetch from a cursor without any SELECT variable defined.

Action:

Contact Oracle Designer support.


RME-02108

RME-02108 No bind buffer specified

Cause:

Internal software problem. An attempt was made to fetch from a cursor without any bind buffer to fetch the data into.

Action:

Contact Oracle Designer support.


RME-02109

RME-02109 Invalid SQL datatype (ESqlDataType) '%0!s'

Cause:

Internal software problem. An invalid SQL datatype was specified for a SELECT, INTO, or BIND variable.

Action:

Contact Oracle Designer support.


RME-02115

RME-02115 Multiple 'select' variables defined at position %0!s

Cause:

Internal software problem. An attempt was made to define multiple SELECT variables, by position, and more than one has the same name.

Action:

Contact Oracle Designer support.


RME-02116

RME-02116 Bind variable '%0!s' not found

Cause:

Internal software problem. An attempt was made to locate a named bind variable that wasn't defined.

Action:

Contact Oracle Designer support.


RME-02117

RME-02117 Bad arraysize: %0!s (%1!s maximum)

Cause:

Internal software problem. An invalid BIND/SELECT/INTO variable array size was specified (e.g. -10, 128000, etc.)

Action:

Contact Oracle Designer support.


RME-02120

RME-02120 Failed to connect cursor to database

Cause:

An error occurred attempting to connect a cursor to a database.

Action:

Examine reported errors for specific details.


RME-02121

RME-02121 Failed to open cursor

Cause:

An error occurred attempting to open a cursor.

Action:

Examine reported errors for specific details.


RME-02124

RME-02124 Failed to execute SQL statement: %0!s

Cause:

An error occurred while executing a SQL statement.

Action:

Examine reported errors for specific details.


RME-02125

RME-02125 Failed to fetch next row(s)

Cause:

An error occurred while attempting to fetch the next row(s) in an open cursor.

Action:

Examine reported errors for specific details.


RME-02126

RME-02126 Failed to bind cursor variables

Cause:

An error occurred while attempting to bind cursor variables.

Action:

Examine reported errors for specific details.


RME-02127

RME-02127 Failed to define 'bind' variable '%0!s'

Cause:

An error occurred while attempting to define a cursor BIND variable.

Action:

Examine reported errors for specific details.


RME-02128

RME-02128 Failed to define 'into' variable '%0!s'

Cause:

An error occurred while attempting to define a cursor INTO variable.

Action:

Examine reported errors for specific details.


RME-02129

RME-02129 Failed to define 'select' variable '%0!s'

Cause:

An error occurred while attempting to define a cursor SELECT variable.

Action:

Examine reported errors for specific details.


RME-02132

RME-02132 Failed to cancel fetches

Cause:

An error occurred while attempting to cancel outstanding unfetched rows.

Action:

Examine reported errors for specific details.


RME-02201

RME-02201 Variable name '%0!s' is too long (%1!s maximum)

Cause:

Internal software problem. The indicated BIND/SELECT/INTO variable name is too long.

Action:

Contact Oracle Designer support.


RME-02202

RME-02202 Unknown SQL datatype (ESqlDataType) '%0!s'

Cause:

Internal software problem. The indicated SQL datatype is invalid.

Action:

Contact Oracle Designer support.


RME-02203

RME-02203 Invalid bind array size '%0!s'

Cause:

Internal software problem. The indicated BIND/SELECT/INTO variable array size is invalid (e.g. -20, 128000).

Action:

Contact Oracle Designer support.


RME-02204

RME-02204 Out of memory allocating bind variable buffers

Cause:

Failed to allocate enough memory for bind variable buffers.

Action:

Try exiting Designer/2000 and try again. If that still fails then contact Oracle Designer support after you have checked to make sure your machine has the minimum memory required for Designer/2000.


RME-02205

RME-02205 Invalid array subscript '%0!s'"

Cause:

Internal software problem. An invalid subscript was specified for a BIND/SELECT/INTO variable.

Action:

Contact Oracle Designer support.


RME-02206

RME-02206 Invalid buffer length %0!s

Cause:

Internal software problem. An invalid buffer length was specified for a BIND/SELECT/INTO variable.

Action:

Contact Oracle Designer support.


RME-02220

RME-02220 Failed to create new bind variable

Cause:

An error occurred while attempting to create a new BIND/SELECT/INTO variable in an internal cursor.

Action:

Examine reported errors for specific details.


RME-02221

RME-02221 Failed to bind variable '%0!s'

Cause:

An error occurred while attempting to bind a BIND/SELECT/INTO variable into a SQL statement.

Action:

Examine reported errors for specific details.


RME-02303

RME-02303 Invalid month %0!s of year (must be between 1 and 12)

Cause:

An invalid month of year was specified.

Action:

Enter a month between 1 and 12.


RME-02304

RME-02304 Invalid day %0!s of month (must be between 1 and 31)

Cause:

An invalid day of month was specified.

Action:

Enter a day between 1 and 31 (watch out for February 29, etc.)


RME-02305

RME-02305 Invalid hour %0!s (must be between 0 and 23)

Cause:

You entered an invalid hour of the day.

Action:

Enter a valid hour of day.


RME-02306

RME-02306 Invalid minute %0!s (must be between 0 and 59)

Cause:

You entered an invalid minute.

Action:

Enter a valid minute.


RME-02307

RME-02307 Invalid second %0!s (must be between 0 and 59)

Cause:

You entered an invalid second.

Action:

Enter a valid second.


RME-02308

RME-02308 Format string length (%0!s) too long (must be between 0 and %1!s)

Cause:

The date format string was too long.

Action:

Use a shorter date format string.


RME-02309

RME-02309 Invalid date format string '%0!s'

Cause:

The date format string was invalid.

Action:

Use a valid date format string (check documentation.)


RME-02320

RME-02320 Failed to set julian date %0!s

Cause:

An error occurred attempting to set a julian date.

Action:

Examine reported errors for specific details.


RME-02321

RME-02321 Failed to set date's year

Cause:

An error occurred attempting to set a date's year.

Action:

Examine reported errors for specific details.


RME-02322

RME-02322 Failed to set date's month

Cause:

An error occurred attempting to set a date's month.

Action:

Examine reported errors for specific details.


RME-02323

RME-02323 Failed to set date's day

Cause:

An error occurred attempting to set the day of the month in a date.

Action:

Examine reported errors for specific details.


RME-02324

RME-02324 Failed to set date's hour

Cause:

An error occurred attempting to set the hour of the day in a date.

Action:

Examine reported errors for specific details.


RME-02325

RME-02325 Failed to set date's minute

Cause:

An error occurred attempting to set the minute of the hour in a date.

Action:

Examine reported errors for specific details.


RME-02326

RME-02326 Failed to set date's second

Cause:

An error occurred attempting to set the second in the minute of a date.

Action:

Examine reported errors for specific details.


RME-02327

RME-02327 Failed to set date from SYSDATE

Cause:

An error occurred attempting to get the current system date.

Action:

Examine reported errors for specific details.


RME-02328

RME-02328 Failed to convert string to date

Cause:

An error occurred attempting to convert a string to a date.

Action:

Examine reported errors for specific details.


RME-02403

RME-02403 Invalid number format string

Cause:

An invalid number format string was used.

Action:

Contact Oracle Designer support.


RME-02404

RME-02404 to_char buffer size %0!s is too small

Cause:

Internal software error. The number to string conversion buffer is too small.

Action:

Contact Oracle Designer support.


RME-02420

RME-02420 Failed to cast CSqlNumber to (int)

Cause:

An error occurred attempting to convert a number.

Action:

Examine reported errors for specific details.


RME-02421

RME-02421 Failed to cast CSqlNumber to (long)

Cause:

An error occurred attempting to convert a number.

Action:

Examine reported errors for specific details.


RME-02422

RME-02422 Failed to cast CSqlNumber to (size_t)

Cause:

An error occurred attempting to convert a number.

Action:

Examine reported errors for specific details.


RME-02423

RME-02423 Failed to cast CSqlNumber to (ub2)

Cause:

An error occurred attempting to convert a number.

Action:

Examine reported errors for specific details.


RME-02425

RME-02425 Failed to convert string to CSqlNumber

Cause:

An error occurred attempting to convert a string to a number.

Action:

Examine reported errors for specific details.


RME-02426

RME-02426 Failed to convert CSqlNumber to string

Cause:

An error occurred attempting to convert a number to a string.

Action:

Examine reported errors for specific details.


RME-20021

RME-20021 Failed to open diagnostic trace file. Check permissions to create / modify file: ""%1""

Cause:

This message is for information, and instructs the user how to proceed.

Action:


CDA-03501

CDA-03501 %0!s <%1!s>: An association already exists between %2!s and %3!s

Cause:

A uniqueness constraint violation was detected when associating two elements that are already associated.

Action:

The association already exists, and so no action need be taken.


RME-20023

RME-20023 Failed to run trace file viewer with command: %1

Cause:

Viewer executable not found or limited system resources.

Action:

Check that executable runs and/or system resources.


ATT-05000

ATT-05000 Circular inheritance detected in Value Types

Cause:

The value type or one of it's supertypes is derived from itself. Value types must be derived from a base type.

Action:

Modify the generalizations in the value type so that it is derived from a base type i.e. one of String, Integer, Real, Date, DateTime, Boolean, and Binary.